summaryrefslogtreecommitdiff
path: root/src/ui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/ui/CMakeLists.txt')
-rw-r--r--src/ui/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/ui/CMakeLists.txt b/src/ui/CMakeLists.txt
index f522b03..c42c262 100644
--- a/src/ui/CMakeLists.txt
+++ b/src/ui/CMakeLists.txt
@@ -130,7 +130,9 @@ add_dependencies(fqterm_ui
fqterm_utilities
)
-ADD_DEFINITIONS(-D "FQTERM_GIT_REVISION=\\\"${MCGGIT_WC_REVISION}\\\"")
+IF(NOT MCGGIT_WC_REVISION MATCHES "NOTFOUND")
+ ADD_DEFINITIONS(-D "FQTERM_GIT_REVISION=\\\"${MCGGIT_WC_REVISION}\\\"")
+ENDIF(NOT MCGGIT_WC_REVISION MATCHES "NOTFOUND")
if(USE_QT5)
target_link_libraries(fqterm_ui Qt5::Core Qt5::Widgets)