summaryrefslogtreecommitdiff
path: root/core/src/fxcodec/fx_libopenjpeg/libopenjpeg20/CMakeLists.txt
diff options
context:
space:
mode:
authorBo Xu <bo_xu@foxitsoftware.com>2014-09-30 11:12:05 -0700
committerBo Xu <bo_xu@foxitsoftware.com>2014-09-30 11:12:05 -0700
commitd53e6fdb0a86ca1ddb12876a60f7f2d7508b5349 (patch)
tree1d1eebf565936adff5d2d5c68741774e8d86f0eb /core/src/fxcodec/fx_libopenjpeg/libopenjpeg20/CMakeLists.txt
parent1b24b697659b9b933f336238665c835497464a0b (diff)
downloadpdfium-d53e6fdb0a86ca1ddb12876a60f7f2d7508b5349.tar.xz
Update openjpeg
BUG=407964, 414182, 413447 R=tsepez@chromium.org Review URL: https://codereview.chromium.org/589243004
Diffstat (limited to 'core/src/fxcodec/fx_libopenjpeg/libopenjpeg20/CMakeLists.txt')
-rw-r--r--core/src/fxcodec/fx_libopenjpeg/libopenjpeg20/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/core/src/fxcodec/fx_libopenjpeg/libopenjpeg20/CMakeLists.txt b/core/src/fxcodec/fx_libopenjpeg/libopenjpeg20/CMakeLists.txt
index 5c87f29771..fcf60ecf01 100644
--- a/core/src/fxcodec/fx_libopenjpeg/libopenjpeg20/CMakeLists.txt
+++ b/core/src/fxcodec/fx_libopenjpeg/libopenjpeg20/CMakeLists.txt
@@ -68,10 +68,12 @@ install(FILES openjpeg.h opj_stdint.h
DESTINATION ${OPENJPEG_INSTALL_INCLUDE_DIR} COMPONENT Headers
)
+if(BUILD_DOC)
# install man page of the library
install(
FILES ${OPENJPEG_SOURCE_DIR}/doc/man/man3/libopenjp2.3
DESTINATION ${OPENJPEG_INSTALL_MAN_DIR}/man3)
+endif()
# internal utilities to generate t1_luts.h (part of the jp2 lib)
# no need to install: