American Megatrends, Inc.

BlockS3Var

Copyright

Release Notes

© American Megatrends, Inc.


Release Notes - NDA Required

Component Information:
Component Title: BlockS3Var
Component Reference Name: BlockS3Var
Component Type: eModule
Release Date: 2015-06-18
Source Control Label: BlockS3Var_00
Source Control Location: SS:\\Alaska\Source\Modules\BlockS3Var

Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
This module creates an Blocked Variable Name/Guid eLink to block and protect the variable modification in Runtime and SMM.
Filename | Description
BlockS3Var.cif | Component information file for this e-Module.
BlockS3Var.chm | Module chm file.
BlockS3Var.sdl | Module parameters file.
BlockS3Var.c | BlockS3Var source file.
BlockS3Var.mak | Make file for linking this module to Nvram driver.

AMI Build Tools:
Tools Label: 4.5.5_tools_34, Dated: 2010-10-06
Visual eBios: RSS.5.70.0171, Dated: 2010-10-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7.1.0 build 7600.16385.1
New features added in this label:
N0NE
General Bug Fixes:
N0NE
EIP addressed in this label:
N0NE
Files changed for EIP fixes:
N0NE
Known issues and limitations in this label:
N0NE
Remaining Issues:
N0NE
Unit Testing:
N0NE
Validation Testing:
N0NE
Release History:

Label : BlockS3Var_00
Improvement:
Initial check-in.
Bug Fixed:
None.

© American Megatrends Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • BlockS3Var.c
  • BlockS3Var.mak
Built on 15:54:12 06/18/15


BlockS3Var.c

Description:
This file contains code for blocking Variables at runtime.

The following functions are used in the file: BlockS3Var.c.

Function | Description
BdsEvtFunc | This function is called when BDS is ready to connect drivers.
SetVariableS3Hook | This function checks the input Variable whether it needs to be blocked or not.


BdsEvtFunc in the BlockS3Var.c

Function : BdsEvtFunc

File: BlockS3Var.c
Description:
This function is called when BDS is ready to connect drivers.
Input:
Event   - Event of callback
Context - Context of callback.
Output:
None


SetVariableS3Hook in the BlockS3Var.c

Function : SetVariableS3Hook

File: BlockS3Var.c
Description:
This function checks the input Variable whether it needs to
be blocked or not.
Input:
VariableName - Pointer to Variable Name in Unicode
VendorGuid - Pointer to Variable GUID
Attributes - Attributes of the Variable
DataSize - Size of the Variable
Data - Pointer to memory where Variable data is stored
Output:
EFI_STATUS
   EFI_UNSUPPORTED - The Variable isn't found.
   EFI_WRITE_PROTECTED - The Variable is found.


BlockS3Var.mak

Description:
This make file builds Blocked S3 Variable eModule


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

  • B
  • S


Functions in Alphabetical Order

B

Function | Description
BdsEvtFunc | This function is called when BDS is ready to connect drivers.


Functions in Alphabetical Order

S

Function | Description
SetVariableS3Hook | This function checks the input Variable whether it needs to be blocked or not.


General Information