American Megatrends, Inc.

EcPs2Kbd

Copyright

Release Notes

© American Megatrends, Inc.


Project Release Notes

Aptio EcPs2Kbd Module Release Notes

Module Information:

Module location on Sourcesafe: SS: Alaska;$/Alaska/SOURCE/Modules/EcPs2Kbd;
Label: 4.6.3.3_EcPs2Kbd_04
Date: 07/18/2011
Description: This module installs PS2 Keyboard and Mouse Device paths for systems where the KBC is in the Embedded Controller. It also updates SIO_DEV_STATUS to specify that a KB and mouse are present in the system.

Section 1: New features added in this label:

  • None

Section 2: Bug Fixes:

  • None

Section 3: EIP addressed in this label:

  • EIP# 65200: Port EcPs2Kbd to be compliant with PI 1.2, and UEFI 2.3.1 specifications.

Section 4: Files changed for EIP fixes:

  • EIP# 65200: EcPs2Kbd.h

Section 5: Known issues and limitations in this label:

  • None

Section 6: Remaining EIP Issues:

  • None

Testing:

  • Verified that the Chief River project compiles with UEFI 2.3.1 and PI 1.2 enabled.

Release History

  • 4.6.3.3_EcPs2Kbd_03
    • EIP# 39388: SCT Execution test failed-4.6.3.5_VeB_0ABUC_004
  • 4.6.3.3_EcPs2Kbd_02
    • Added CHM
  • 4.6.3.3_EcPs2Kbd_01
    • Added code to install a device path for PS2 Mouse.
    • Added code to create/update the SIO_DEV_STATUS EFI variable. This requires Core 4.6.3.3.
  • 4.6.3.2_EcPs2Kbd_00
    • Initial label. This has been tested on Menlow.

© American Megatrends Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • EcPs2Kbd.c
  • EcPs2Kbd.dxs
  • EcPs2Kbd.h
  • EcPs2Kbd.mak
Built on 18:11:16 07/18/11


EcPs2Kbd.c

Description:
This file contains code necessary to install the EC PS2 devices
for EFI, ACPI and DOS.
Notes:
The following functions are used in the file: EcPs2Kbd.c.

Function | Description
ConnectDevicePath | This function connects the EFI device to its parent device.
EcPs2KbdEntry | This function installs the Device Path for the EC Ps2.


ConnectDevicePath in the EcPs2Kbd.c

Function : ConnectDevicePath

File: EcPs2Kbd.c
Description:
This function connects the EFI device to its parent device.
Input:
pPath - Pointer to an EFI device path.
Output:
VOID


EcPs2KbdEntry in the EcPs2Kbd.c

Function : EcPs2KbdEntry

File: EcPs2Kbd.c
Description:
This function installs the Device Path for the EC Ps2.
Input:
ImageHandle Image handle
SystemTable Pointer to the system table
Output:
EFI_STATUS      Returned from PCI read call


EcPs2Kbd.dxs

Description:
Dependency expression file for EcPs2Kbd DXE driver


EcPs2Kbd.h

Description:
defines needed for EcPs2Kbd.
Notes:


EcPs2Kbd.mak

Description:


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

  • C
  • E


Functions in Alphabetical Order

C

Function | Description
ConnectDevicePath | This function connects the EFI device to its parent device.


Functions in Alphabetical Order

E

Function | Description
EcPs2KbdEntry | This function installs the Device Path for the EC Ps2.


General Information


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2011 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.