American Megatrends, Inc.

Fit

Copyright

Release Notes

© American Megatrends, Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2012-06-27
Source Control Label: 4651_FIT_001
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_03d-RC_056
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
The IntelFit eModule may be added to a BIOS to support Intel Fit , Firmware Interface Table.
The table is a data structure inside BIOS flash, contains different type and entry.
Please see Intel Haswell BIOS Writer's Guide for more details.

Module Name: Intel FIT
Filename | Description
Fit.cif/td> | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
BpmTable.asm | Fit module ASM source file
KmTable.asm | Fit module ASM source file

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_38, Dated: 2011-12-20
Visual eBios: RSS.5.72.0219, Dated: 2011-12-20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
None
EIP addressed in this label:
None
Release History:

Label 4651_FIT_001
[TAG]None
Initial release.

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2012-10-04
Source Control Label: 4.6.5.1_FIT_003
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_03d-RC_056
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
The IntelFit eModule may be added to a BIOS to support Intel Fit , Firmware Interface Table.
The table is a data structure inside BIOS flash, contains different type and entry.
Please see Intel Haswell BIOS Writer's Guide for more details.

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
BpmTable.asm | Fit module ASM source file
KmTable.asm | Fit module ASM source file
AnC_ACM_Rev0_6.bin | Intel Anchor Cove ACM rom file

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_38, Dated: 2011-12-20
Visual eBios: RSS.5.72.0219, Dated: 2011-12-20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
1. Implementation of the Intel Anchor Cove for mobile platforms.
2. Implementation of FIT table using FFS.
3. Updated the FITUtil.exe to support the ACM, KM and BPM for Intel Anchor Cove.
General Bug Fixes:
None
EIP addressed in this label:
None
Release History:
4.6.5.1_FIT_001

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2012-11-09
Source Control Label: 4.6.5.1_FIT_004
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_08a-RC_072
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
If you want to enable the Anchor Cove, you have to do below step.
After you compiled the code, BpmKmGen.exe will show the Key Manifest ID and OEM Public Key Hash.
Key Manifest ID : XX
OEM Public Key Hash : XX
Please update the Key Manifest ID and OEM Public Key Hash to the Secure boot of FITC.

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
AnC_ACM_Rev0_7_1.bin | Intel Anchor Cove ACM rom file
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of Bpm and KM and update to BIOS ROM for Anchor Cove
keygen.exe | Generation of Bpm and KM private keys for Anchor Cove

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_38, Dated: 2011-12-20
Visual eBios: RSS.5.72.0219, Dated: 2011-12-20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
1. Implementation of the Intel Anchor Cove for Shark Bay ULT.
2. Fixed FitUtil didn't work in AptioV Sharkbay.
3. Update the Anchor Cove ACM SDK Release Version 0.7.1.
General Bug Fixes:
None
EIP addressed in this label:
105381, 104159, 105029
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2012-11-12
Source Control Label: 4.6.5.1_FIT_005
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_08a-RC_072
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
If you want to enable the Anchor Cove, you have to do below step.
After you compiled the code, BpmKmGen.exe will show the Key Manifest ID and OEM Public Key Hash.
Key Manifest ID : XX
OEM Public Key Hash : XX
Please update the Key Manifest ID and OEM Public Key Hash to the Secure boot of FITC.

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
AnC_ACM_Rev0_7_1.bin | Intel Anchor Cove ACM rom file
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of Bpm and KM and update to BIOS ROM for Anchor Cove
keygen.exe | Generation of Bpm and KM private keys for Anchor Cove

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_38, Dated: 2011-12-20
Visual eBios: RSS.5.72.0219, Dated: 2011-12-20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
1. Fixed build error when disabled ULT_SUPPORT.
EIP addressed in this label:
None
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2012-11-29
Source Control Label: 4.6.5.1_FIT_006
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_08a-RC_072
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
If you want to enable the Anchor Cove, please following as below.
1. Please make sure your Intel PPT configuration that set to enable in ME settings of Fitc.
a). ME Region->Configuration->ME->Enable Intel Platform Trust Technology => True
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => False
c). PCH Strap 10->Intel® Platform Trust Technology softstrap disable => False
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Anchor Cove Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
AnC_ACM_Rev0_7_1.bin | Intel Anchor Cove ACM rom file
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of Bpm and KM and update to BIOS ROM for Anchor Cove
keygen.exe | Generation of Bpm and KM private keys for Anchor Cove

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_38, Dated: 2011-12-20
Visual eBios: RSS.5.72.0219, Dated: 2011-12-20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
1. Fixed the FIT building error when disabled the LZMA_SUPPORT and MICROCODE_SPLIT_BB_UPDATE=1.
2. Add the debug flag for debugging the Anchor Cove.
EIP addressed in this label:
107897
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2012-12-12
Source Control Label: 4.6.5.1_FIT_007
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_08a-RC_072
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
If you want to enable the Anchor Cove, please following as below.
1. Please make sure your Intel PPT configuration that set to enable in ME settings of Fitc.
a). ME Region->Configuration->ME->Enable Intel Platform Trust Technology => True
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => False
c). PCH Strap 10->Intel® Platform Trust Technology softstrap disable => False
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Anchor Cove Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
AnC_ACM_Rev0_7_1.bin | Intel Anchor Cove ACM rom file
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of Bpm and KM and update to BIOS ROM for Anchor Cove
keygen.exe | Generation of Bpm and KM private keys for Anchor Cove

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_38, Dated: 2011-12-20
Visual eBios: RSS.5.72.0219, Dated: 2011-12-20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] EIP108904
[Category] Improvement
[Description] GenFFS utility is not PI 1.2 compliant. GenFFS utility will populate signature "5A" for FFS with fixed checksum. PI 1.2 requires this signature to be "AA". GenFFS does not support passing PI version.Please check the attachment to change Genffs usage to FWBuild.
[Files] Fit.mak, Fit.sdl
EIP addressed in this label:
108904
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2012-12-21
Source Control Label: 4.6.5.1_FIT_008
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_08a-RC_072
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
If you want to enable the Anchor Cove, please following as below.
1. Please make sure your Intel PPT configuration that set to enable in ME settings of Fitc.
a). ME Region->Configuration->ME->Enable Intel Platform Trust Technology => True
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => False
c). PCH Strap 10->Intel® Platform Trust Technology softstrap disable => False
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Anchor Cove Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
AnC_ACM_Rev0_7_1.bin | Intel Anchor Cove ACM rom file
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of Bpm and KM and update to BIOS ROM for Anchor Cove
keygen.exe | Generation of Bpm and KM private keys for Anchor Cove

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
Other Tools Requirements
The FIT Tools such as BpmKmGen.exe, CutRom.exe and FITUtil.exe require Microsoft Redistribution Package Installed on the Build platform.
The 32 bit version can be found at: Microsoft Redistribution Package 32 Bit
The 64 bit version can be found at: Microsoft Redistribution Package 64 Bit
New features added in this label:
None
General Bug Fixes:
[TAG] EIP110217
[Category] Improvement
[Description] Support Fault Tolerant Boot Block Update for Intel FIT.
[Files] Fit.mak, Fit.sdl, FITUtil.exe
EIP addressed in this label:
108904
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-01-04
Source Control Label: 4.6.5.1_FIT_009
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_11-RC_090
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
If you want to enable the Anchor Cove, please following as below.
1. Please make sure your Intel PPT configuration that set to enable in ME settings of Fitc.
a). ME Region->Configuration->ME->Enable Intel Platform Trust Technology => True
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => False
c). PCH Strap 10->Intel® Platform Trust Technology softstrap disable => False
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Anchor Cove Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
AnC_ACM_Rev0_8.bin | Intel Anchor Cove ACM rom file
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of Bpm and KM and update to BIOS ROM for Anchor Cove
keygen.exe | Generation of Bpm and KM private keys for Anchor Cove

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
Other Tools Requirements
The FIT Tools such as BpmKmGen.exe, CutRom.exe and FITUtil.exe require Microsoft Redistribution Package Installed on the Build platform.
The 32 bit version can be found at: Microsoft Redistribution Package 32 Bit
The 64 bit version can be found at: Microsoft Redistribution Package 64 Bit
New features added in this label:
None
General Bug Fixes:
[TAG] EIP110784
[Category] Improvement
[Description] Anchor Cove ACM SDK Rev0.8 Beta Release for Shark Bay ULT Platforms.
[Files] AnC_ACM_Rev0_8.bin, FitTable.asm, Fit.sdl, FITUtil.exe, BpmKmGen.exe, ReserveBpmTable.bin
EIP addressed in this label:
110784
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-01-14
Source Control Label: 4.6.5.1_FIT_010
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_11-RC_090
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
The correct ACM binary must match the correct CPU
Pre-ES and ES CPU set the token of ANCHOR_COVE_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 0
Pre-QS and QS CPU set the token of ANCHOR_COVE_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 1

If you want to enable the Anchor Cove, please following as below.
1. Please make sure your Intel PPT configuration that set to enable in ME settings of Fitc.
a). ME Region->Configuration->ME->Enable Intel Platform Trust Technology => True
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => False
c). PCH Strap 10->Intel® Platform Trust Technology softstrap disable => False
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Anchor Cove Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
AnC_ACM_Rev0_8_ES.bin | Intel Anchor Cove ACM rom file for Pre-ES and ES CPU
AnC_ACM_Rev0_8_QS.bin | Intel Anchor Cove ACM rom file for Pre-QS and QS CPU
ReserveAnchorCoveFvMainHashKey.bin | Intel Anchor Cove Fv_Main hash key file for Pre-QS and QS CPU for chain of trust
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Anchor Cove
keygen.exe | Generation of BPM and KM private keys for Anchor Cove

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
Other Tools Requirements
The FIT Tools such as BpmKmGen.exe, CutRom.exe and FITUtil.exe require Microsoft Redistribution Package Installed on the Build platform.
The 32 bit version can be found at: Microsoft Redistribution Package 32 Bit
The 64 bit version can be found at: Microsoft Redistribution Package 64 Bit
New features added in this label:
None
General Bug Fixes:
[TAG] EIP110952
[Category] New Feature
[Description] [SBY] Anchor Cove function to continue chain of trust for verification
[Files] AnchorCovePei.cif, AnchorCovePei.c, AnchorCovePei.h, AnchorCovePei.dxs, AnchorCovePei.sdl, AnchorCovePei.mak, PeiCryptLib.lib, OpensslLib.lib, AnchorCoveDxe.c, AnchorCoveDxe.h, AnchorCoveDxe.sdl, AnchorCoveDxe.dxs, AnchorCoveDxe.mak, FITUtil.exe, BpmKmGen.exe, Fit.mak, ReserveAnchorCoveFvMainHashKey.bin
[TAG] EIP112063
[Category] Spec Update
[Description] [SBY] Anchor Cove ACM SDK Rev0.8.1 Beta Release for Shark Bay ULT Platforms
[Files] AnC_ACM_Rev0_8_ES.bin, AnC_ACM_Rev0_8_QS.bin, Fit.sdl
EIP addressed in this label:
110952, 112063
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-01-17
Source Control Label: 4.6.5.1_FIT_011
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_11-RC_090
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
The correct ACM binary must match the correct CPU
Pre-ES and ES CPU set the token of ANCHOR_COVE_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 0
Pre-QS and QS CPU set the token of ANCHOR_COVE_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 1

If you want to enable the Anchor Cove, please following as below.
1. Please make sure your Intel PPT configuration that set to enable in ME settings of Fitc.
a). ME Region->Configuration->ME->Enable Intel Platform Trust Technology => True
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => False
c). PCH Strap 10->Intel® Platform Trust Technology softstrap disable => False
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Anchor Cove Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
AnC_ACM_Rev0_8_ES.bin | Intel Anchor Cove ACM rom file for Pre-ES and ES CPU
AnC_ACM_Rev0_8_QS.bin | Intel Anchor Cove ACM rom file for Pre-QS and QS CPU
ReserveAnchorCoveFvMainHashKey.bin | Intel Anchor Cove Fv_Main hash key file for Pre-QS and QS CPU for chain of trust
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Anchor Cove
keygen.exe | Generation of BPM and KM private keys for Anchor Cove

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] EIP112546
[Category] Bug Fix
[Severity] Normal
[Symptom] [Anchor Cove] if Continuing Chain of Trust failed, the BIOS recovery is fail
[RootCause] We didn't check the Recovery mode.
[Solution] System disables the Chain of Trust when boot mode is BOOT_IN_RECOVERY_MODE
[Files] AnchorCoveDxe.c, AnchorCovePei.c, AnchorCovePei.h

[TAG] EIP112480
[Category] Improvement
[Description] CutRom.exe, BpmKmGen.exe and FITUtil.exe still can work well, even users didn't install the Microsoft Visual C++ 2010 Redistributable Package
[Files] CutRom.exe, BpmKmGen.exe and FITUtil.exe
EIP addressed in this label:
112546, 112480
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009
4.6.5.1_FIT_010

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-02-09
Source Control Label: 4.6.5.1_FIT_012
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_12-RC_110
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
The correct ACM binary must match the correct CPU
Pre-ES and ES CPU set the token of ANCHOR_COVE_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 0
Pre-QS and QS CPU set the token of ANCHOR_COVE_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 1

If you want to enable the Anchor Cove, please following as below.
1. Please make sure your Intel PPT configuration that set to enable in ME settings of Fitc.
a). ME Region->Configuration->ME->Enable Intel Platform Trust Technology => True
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => False
c). PCH Strap 10->Intel® Platform Trust Technology softstrap disable => False
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Anchor Cove Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
AnC_ACM_Rev0_8_ES.bin | Intel Anchor Cove ACM rom file for Pre-ES and ES CPU
AnC_ACM_Rev0_8_QS.bin | Intel Anchor Cove ACM rom file for Pre-QS and QS CPU
ReserveAnchorCoveFvMainHashKey.bin | Intel Anchor Cove Fv_Main hash key file for Pre-QS and QS CPU for chain of trust
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Anchor Cove
keygen.exe | Generation of BPM and KM private keys for Anchor Cove

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] EIP114925
[Category] Spec Update
[Severity] Critical
[Symptom] The FIT will be compiled error when updated to CPU RC 1.10. Anchor Cove has renamed to BootGuard, so we have to modify it for CPU RC 1.10.
[Files] AnchorCovePei.c, AnchorCovePei.h, AnchorCovePei.mak, AnchorCoveDxe.c, AnchorCoveDxe.h, AnchorCoveDxe.mak
EIP addressed in this label:
114925
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009
4.6.5.1_FIT_010
4.6.5.1_FIT_011

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-02-18
Source Control Label: 4.6.5.1_FIT_013
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_12-RC_110
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
The correct ACM binary must match the correct CPU
Pre-ES and ES CPU set the token of ANCHOR_COVE_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 0
Pre-QS and QS CPU set the token of ANCHOR_COVE_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 1

If you want to enable the Anchor Cove, please following as below.
1. Please make sure your Intel PPT configuration that set to enable in ME settings of Fitc.
a). ME Region->Configuration->ME->Enable Intel Platform Trust Technology => True
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => Enable
c). PCH Strap 10->Intel® Platform Trust Technology softstrap disable => False
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Anchor Cove Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
AnC_ACM_Rev0_8_ES.bin | Intel Anchor Cove ACM rom file for Pre-ES and ES CPU
AnC_ACM_Rev0_8_QS.bin | Intel Anchor Cove ACM rom file for Pre-QS and QS CPU
ReserveAnchorCoveFvMainHashKey.bin | Intel Anchor Cove Fv_Main hash key file for Pre-QS and QS CPU for chain of trust
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Anchor Cove
keygen.exe | Generation of BPM and KM private keys for Anchor Cove

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] None
[Category] Bug Fix
[Severity] Critical
[Symptom] Boot Guard can't work on FIT 12.
[RootCause] BOOT_GUARD_SUPPORT_FLAG didn't define in the FIT.sdl
[Solution] Define the BOOT_GUARD_SUPPORT_FLAG in the FIT.sdl
[Files] Fit.sdl
EIP addressed in this label:
None
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009
4.6.5.1_FIT_010
4.6.5.1_FIT_011
4.6.5.1_FIT_012

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-02-25
Source Control Label: 4.6.5.1_FIT_014
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_12-RC_110
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
TWO
Dependent Component Title: Rom Image
Dependent Component Reference Name: Rom Image
Dependent Source Control Label: 4.6.5.3_RomImage_021
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
4.6.5.1_FIT_014 must to use ME 9.5.0.1372 or above,and please use the BootGuardInfo for testing.

MUST use the correct ACM binary for the matching CPUs, else platform will not behave as expected.
Pre-ES and ES CPU set the token of ANCHOR_COVE_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 0
Pre-QS and QS CPU set the token of ANCHOR_COVE_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 1

If you want to enable the Anchor Cove, please following as below.
Please make sure your Intel PPT configuration that set to enable in ME settings of Fitc.
a). ME Region->Configuration->Platform Trust->Intel PTT HW Enable/Disable => Enable
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => Enable
c). PCH Strap 10->Intel® Platform Trust Technology softstrap disable => No
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Anchor Cove Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
Boot_Guard_ACM_Rev0_8_5_ES.bin | a. Boot_Guard_ACM_Rev0_8_5_QS.bin is for Pre-QS and QS or newer CPU samples ONLY!
Boot_Guard_ACM_Rev0_8_5_QS.bin | b. Boot_Guard_ACM_Rev0_8_5_ES.bin is for Pre-ES and ES CPU samples ONLY!
ReserveBootGuardFvMainHashKey.bin | Intel Boot Guard Fv_Main hash key file for chain of trust
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Boot Guard
keygen.exe | Generation of BPM and KM private keys for Boot Guard

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] EIP114386
[Category] Spec Update
[Severity] Important
[Description] [SBY] Ultrabook for Shark Bay Platform - : Boot Guard for 4th Gen Intel Core Processor based on Mobile U-Processor Line - BIOS Writer's Guide - Rev 0.8.1
[Files] Fit\*.*
[TAG] EIP114386
[Category] Spec Update
[Severity] Important
[Description] Updating the Shark Bay Boot Guard Anchor Cove ACM 0.85
[Files] Fit\*.*
[TAG] None
[Category] Improvement
[Severity] Important
[Description] Speed up the post time for Chain of Trust
[Files] Fit\*.*
EIP addressed in this label:
114386
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009
4.6.5.1_FIT_010
4.6.5.1_FIT_011
4.6.5.1_FIT_012
4.6.5.1_FIT_013

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-02-27
Source Control Label: 4.6.5.1_FIT_015
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_12-RC_110
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
TWO
Dependent Component Title: Rom Image
Dependent Component Reference Name: Rom Image
Dependent Source Control Label: 4.6.5.3_RomImage_021
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
4.6.5.1_FIT_015 must to use ME 9.5.0.1372 or above,and please use the BootGuardInfo for testing.

MUST use the correct ACM binary for the matching CPUs, else platform will not behave as expected.
Pre-ES and ES CPU set the token of BOOT_GUARD_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 0
Pre-QS and QS CPU set the token of BOOT_GUARD_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 1

If you want to enable the Anchor Cove, please following as below.
You must to use the Intel PPT or dTpm as following
Case 1: Use the Intel PPT
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). ME Region->Configuration->Platform Trust->Intel PTT HW Enable/Disable => Enable
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => Enable
c). PCH Strap 10->Intel® Platform Trust Technology softstrap disable => No
Case 2: Use the dTpm
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). PCH Strap 10->Intel® Platform Trust Technology softstrap disable => Yes
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Anchor Cove Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
Boot_Guard_ACM_Rev0_8_5_ES.bin | Boot_Guard_ACM_Rev0_8_5_QS.bin is for Pre-QS and QS or newer CPU samples ONLY!
Boot_Guard_ACM_Rev0_8_5_QS.bin | Boot_Guard_ACM_Rev0_8_5_ES.bin is for Pre-ES and ES CPU samples ONLY!
ReserveBootGuardFvMainHashKey.bin | Intel Boot Guard Fv_Main hash key file for chain of trust
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Boot Guard
keygen.exe | Generation of BPM and KM private keys for Boot Guard

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] None
[Category] Improvement
[Severity] Normal
[Description] Removing the FV_BLANK
[Files] Fit\*.*
EIP addressed in this label:
None
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009
4.6.5.1_FIT_010
4.6.5.1_FIT_011
4.6.5.1_FIT_012
4.6.5.1_FIT_013
4.6.5.1_FIT_014

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-03-06
Source Control Label: 4.6.5.1_FIT_016
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_12-RC_110
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
TWO
Dependent Component Title: Rom Image
Dependent Component Reference Name: Rom Image
Dependent Source Control Label: 4.6.5.3_RomImage_021
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
4.6.5.1_FIT_015 or above must to use ME 9.5.0.1372 or above,and please use the BootGuardInfo for testing.

MUST use the correct ACM binary for the matching CPUs, else platform will not behave as expected.
Pre-ES and ES CPU set the token of BOOT_GUARD_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 0
Pre-QS and QS CPU set the token of BOOT_GUARD_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 1

If you want to enable the Anchor Cove, please following as below.
You must to use the Intel PPT or dTpm as following
Case 1: Use the Intel PPT
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). ME Region->Configuration->Platform Trust->Intel PTT HW Enable/Disable => Enable
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => Enable
c). PCH Strap 10->Intel® Platform Trust Technology softstrap disable => No
Case 2: Use the dTpm
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). PCH Strap 10->Intel® Platform Trust Technology softstrap disable => Yes
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Anchor Cove Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
Boot_Guard_ACM_Rev0_8_5_ES.bin | Boot_Guard_ACM_Rev0_8_5_QS.bin is for Pre-QS and QS or newer CPU samples ONLY!
Boot_Guard_ACM_Rev0_8_5_QS.bin | Boot_Guard_ACM_Rev0_8_5_ES.bin is for Pre-ES and ES CPU samples ONLY!
ReserveBootGuardFvMainHashKey.bin | Intel Boot Guard Fv_Main hash key file for chain of trust
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Boot Guard
keygen.exe | Generation of BPM and KM private keys for Boot Guard

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] EIP116907
[Category] Improvement
[Severity] Normal
[Description] BpmKmGen.exe generates KM / BPM tables and BootGuardFvMainHash key separately
[Files] BpmKmGen.exe, Fit.sdl, Fit.mak, BootGuardPei.sdl, BootGuardDxe.sdl
EIP addressed in this label:
116907
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009
4.6.5.1_FIT_010
4.6.5.1_FIT_011
4.6.5.1_FIT_012
4.6.5.1_FIT_013
4.6.5.1_FIT_014
4.6.5.1_FIT_015

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-03-07
Source Control Label: 4.6.5.1_FIT_017
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_12-RC_110
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
TWO
Dependent Component Title: Rom Image
Dependent Component Reference Name: Rom Image
Dependent Source Control Label: 4.6.5.3_RomImage_021
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
4.6.5.1_FIT_015 or above must to use ME 9.5.0.1372 or above,and please use the BootGuardInfo for testing.

MUST use the correct ACM binary for the matching CPUs, else platform will not behave as expected.
Pre-ES and ES CPU set the token of BOOT_GUARD_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 0
Pre-QS and QS CPU set the token of BOOT_GUARD_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 1

If you want to enable the Anchor Cove, please following as below.
You must to use the Intel PPT or dTpm as following
Case 1: Use the Intel PPT
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). ME Region->Configuration->Platform Trust->Intel PTT HW Enable/Disable => Enable
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => Enable
c). PCH Strap 10->Intel® Platform Trust Technology softstrap disable => No
Case 2: Use the dTpm
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). PCH Strap 10->Intel® Platform Trust Technology softstrap disable => Yes
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Anchor Cove Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
Boot_Guard_ACM_Rev0_8_5_ES.bin | Boot_Guard_ACM_Rev0_8_5_QS.bin is for Pre-QS and QS or newer CPU samples ONLY!
Boot_Guard_ACM_Rev0_8_5_QS.bin | Boot_Guard_ACM_Rev0_8_5_ES.bin is for Pre-ES and ES CPU samples ONLY!
ReserveBootGuardFvMainHashKey.bin | Intel Boot Guard Fv_Main hash key file for chain of trust
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Boot Guard
keygen.exe | Generation of BPM and KM private keys for Boot Guard

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] EIP117307
[Category] Improvement
[Severity] Normal
[Description] [Boot Guard] Implementation of speed up the post time for Chain of Trust
[Files] BootGuardDxe.h, BootGuardPei.c, BootGuardPei.h, BpmKmGen.exe, ReserveBootGuardFvMainHashKey.bin
EIP addressed in this label:
117307
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009
4.6.5.1_FIT_010
4.6.5.1_FIT_011
4.6.5.1_FIT_012
4.6.5.1_FIT_013
4.6.5.1_FIT_014
4.6.5.1_FIT_015
4.6.5.1_FIT_016

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-03-15
Source Control Label: 4.6.5.1_FIT_018
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_12-RC_110
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
TWO
Dependent Component Title: Rom Image
Dependent Component Reference Name: Rom Image
Dependent Source Control Label: 4.6.5.3_RomImage_021
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
4.6.5.1_FIT_015 or above must to use ME 9.5.0.1372 or above,and please use the BootGuardInfo for testing.

MUST use the correct ACM binary for the matching CPUs, else platform will not behave as expected.
Pre-ES and ES CPU set the token of BOOT_GUARD_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 0
Pre-QS and QS CPU set the token of BOOT_GUARD_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 1

If you want to enable the Anchor Cove, please following as below.
You must to use the Intel PPT or dTpm as following
Case 1: Use the Intel PPT
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). ME Region->Configuration->Platform Trust->Intel PTT HW Enable/Disable => Enable
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => Enable
c). PCH Strap 10->Intel® Platform Trust Technology softstrap disable => No
Case 2: Use the dTpm
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). PCH Strap 10->Intel® Platform Trust Technology softstrap disable => Yes
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Anchor Cove Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
Boot_Guard_ACM_Rev0_9_ES.bin | Boot_Guard_ACM_Rev0_9_QS.bin is for Pre-QS and QS or newer CPU samples ONLY!
Boot_Guard_ACM_Rev0_9_QS.bin | Boot_Guard_ACM_Rev0_9_ES.bin is for Pre-ES and ES CPU samples ONLY!
ReserveBootGuardFvMainHashKey.bin | Intel Boot Guard Fv_Main hash key file for chain of trust
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Boot Guard
keygen.exe | Generation of BPM and KM private keys for Boot Guard

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] EIP117377
[Category] Spec Update
[Severity] Normal
[Description] [SBY ULY] Boot Guard ACM SDK Rev0.9 PC Release for Shark Bay ULT Platforms
[Files] Boot_Guard_ACM_Rev0_9_ES.bin, Boot_Guard_ACM_Rev0_9_QS.bin, Fit.sdl, Fit.cif
EIP addressed in this label:
117377
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009
4.6.5.1_FIT_010
4.6.5.1_FIT_011
4.6.5.1_FIT_012
4.6.5.1_FIT_013
4.6.5.1_FIT_014
4.6.5.1_FIT_015
4.6.5.1_FIT_016
4.6.5.1_FIT_017

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-03-22
Source Control Label: 4.6.5.1_FIT_019
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_12-RC_110
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
TWO
Dependent Component Title: Rom Image
Dependent Component Reference Name: Rom Image
Dependent Source Control Label: 4.6.5.3_RomImage_021
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
1. The 4.6.5.1_FIT_015 or above must to use ME 9.5.0.1372 or above, and use the BootGuardInfo for testing.

2. MUST use the correct ACM binary for the matching CPUs, else platform will not behave as expected.
Pre-ES and ES CPU set the token of BOOT_GUARD_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 0
Pre-QS and QS CPU set the token of BOOT_GUARD_ACM_FOR_CPU_PRE_QS_AND_QS_SUPPORT to 1

3. If you want to modify the attribution of FV_DATA, please clone the token of FV_DATA_ATTR to your project.

If you want to enable the Boot Guard, please following as below.
You must to use the Intel PPT or dTpm as following
Case 1: Use the Intel PPT
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). ME Region->Configuration->Platform Trust->Intel PTT HW Enable/Disable => Enable
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => Enable
c). PCH Strap 10->Intel Platform Trust Technology softstrap disable => No
Case 2: Use the dTpm
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). PCH Strap 10->Intel Platform Trust Technology softstrap disable => Yes
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Boot Guard Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
Boot_Guard_ACM_Rev0_9_ES.bin | Boot_Guard_ACM_Rev0_9_QS.bin is for Pre-QS and QS or newer CPU samples ONLY!
Boot_Guard_ACM_Rev0_9_QS.bin | Boot_Guard_ACM_Rev0_9_ES.bin is for Pre-ES and ES CPU samples ONLY!
ReserveBootGuardFvMainHashKey.bin | Intel Boot Guard Fv_Main hash key file for chain of trust
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Boot Guard
keygen.exe | Generation of BPM and KM private keys for Boot Guard

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] EIP118400
[Category] Improvement
[Severity] Normal
[Description] Add a token for attribution of FV_DATA
[Files] Fit.mak, Fit.sdl
EIP addressed in this label:
118400
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009
4.6.5.1_FIT_010
4.6.5.1_FIT_011
4.6.5.1_FIT_012
4.6.5.1_FIT_013
4.6.5.1_FIT_014
4.6.5.1_FIT_015
4.6.5.1_FIT_016
4.6.5.1_FIT_017
4.6.5.1_FIT_018

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-03-27
Source Control Label: 4.6.5.1_FIT_020
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_12-RC_110
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
TWO
Dependent Component Title: Rom Image
Dependent Component Reference Name: Rom Image
Dependent Source Control Label: 4.6.5.3_RomImage_024
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
1. The 4.6.5.1_FIT_020 or above must to use PV ME 9.5.0.1428 or above, and use the BootGuardInfo for testing.

2. MUST use the correct ACM binary for the matching CPUs, else platform will not behave as expected.
Pre-ES and ES CPU set the token of BOOT_GUARD_ACM to 0
Pre-QS and QS CPU without PV ME version set the token of BOOT_GUARD_ACM to 1
Pre-QS and QS CPU with PV ME version set the token of BOOT_GUARD_ACM to 2

3. If you want to modify the attribution of FV_DATA, please clone the token of FV_DATA_ATTR to your project.

If you want to enable the Boot Guard, please following as below.
You must to use the Intel PPT or dTpm as following
Case 1: Use the Intel PPT
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). ME Region->Configuration->Platform Trust->Intel PTT HW Enable/Disable => Enable
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => Enable
c). PCH Strap 10->Intel Platform Trust Technology softstrap disable => No
Case 2: Use the dTpm
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). PCH Strap 10->Intel Platform Trust Technology softstrap disable => Yes
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Boot Guard Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
Boot_Guard_ACM_Rev1_0_ES.bin | The ACM is for Pre-ES and ES CPU samples ONLY!
Boot_Guard_ACM_Rev1_0_QS.bin | The ACM is for Pre-QS and QS CPU without PV ME version ONLY!
Boot_Guard_ACM_Rev1_0_PV.bin | The ACM is for Pre-QS and QS CPU with PV ME version ONLY!
ReserveBootGuardFvMainHashKey.bin | Intel Boot Guard Fv_Main hash key file for chain of trust
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Boot Guard
keygen.exe | Generation of BPM and KM private keys for Boot Guard

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] EIP118856
[Category] Spec Update
[Severity] Normal
[Description] [SBY ULT] Boot Guard ACM SDK Rev 1.0 PV Release for Shark Bay ULT Platforms
[Files] Boot_Guard_ACM_Rev1_0_ES.bin, Boot_Guard_ACM_Rev1_0_QS.bin, Boot_Guard_ACM_Rev1_0_PV.bin, BpmKmGen.exe, Fit.cif, Fit.sdl, Fit.mak
EIP addressed in this label:
118856
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009
4.6.5.1_FIT_010
4.6.5.1_FIT_011
4.6.5.1_FIT_012
4.6.5.1_FIT_013
4.6.5.1_FIT_014
4.6.5.1_FIT_015
4.6.5.1_FIT_016
4.6.5.1_FIT_017
4.6.5.1_FIT_018
4.6.5.1_FIT_019

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-05-13
Source Control Label: 4.6.5.1_FIT_021
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_12-RC_110
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
TWO
Dependent Component Title: Rom Image
Dependent Component Reference Name: Rom Image
Dependent Source Control Label: 4.6.5.3_RomImage_024
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
1. The 4.6.5.1_FIT_020 or above must to use PV ME 9.5.0.1428 or above, and use the BootGuardInfo for testing.

2. MUST use the correct ACM binary for the matching CPUs, else platform will not behave as expected.
Pre-ES and ES CPU set the token of BOOT_GUARD_ACM to 0
Pre-QS and QS CPU without PV ME version set the token of BOOT_GUARD_ACM to 1
Pre-QS and QS CPU with PV ME version set the token of BOOT_GUARD_ACM to 2

3. If you want to modify the attribution of FV_DATA, please clone the token of FV_DATA_ATTR to your project.

If you want to enable the Boot Guard, please following as below.
You must to use the Intel PPT or dTpm as following
Case 1: Use the Intel PPT
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). ME Region->Configuration->Platform Trust->Intel PTT HW Enable/Disable => Enable
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => Enable
c). PCH Strap 10->Intel Platform Trust Technology softstrap disable => No
Case 2: Use the dTpm
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). PCH Strap 10->Intel Platform Trust Technology softstrap disable => Yes
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Boot Guard Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
Boot_Guard_ACM_Rev1_0_ES.bin | The ACM is for Pre-ES and ES CPU samples ONLY!
Boot_Guard_ACM_Rev1_0_QS.bin | The ACM is for Pre-QS and QS CPU without PV ME version ONLY!
Boot_Guard_ACM_Rev1_0_PV.bin | The ACM is for Pre-QS and QS CPU with PV ME version ONLY!
ReserveBootGuardFvMainHashKey.bin | Intel Boot Guard Fv_Main hash key file for chain of trust
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Boot Guard
keygen.exe | Generation of BPM and KM private keys for Boot Guard

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] EIP122037
[Category] Improvement
[Severity] Normal
[Description] FV_DATA area is contained in BlocksToUpdate.
[Files] Fit.sdl

[TAG] None
[Category] Improvement
[Severity] Normal
[Description] Update the BpmKmGen.exe to V0.11.
[Files] BpmKmGen.exe, Fit.sdl, Fit.mak
EIP addressed in this label:
122037
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009
4.6.5.1_FIT_010
4.6.5.1_FIT_011
4.6.5.1_FIT_012
4.6.5.1_FIT_013
4.6.5.1_FIT_014
4.6.5.1_FIT_015
4.6.5.1_FIT_016
4.6.5.1_FIT_017
4.6.5.1_FIT_018
4.6.5.1_FIT_019
4.6.5.1_FIT_020

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-05-28
Source Control Label: 4.6.5.1_FIT_022
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_12-RC_110
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
TWO
Dependent Component Title: Rom Image
Dependent Component Reference Name: Rom Image
Dependent Source Control Label: 4.6.5.3_RomImage_024
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
1. The 4.6.5.1_FIT_020 or above must to use PV ME 1.5MB 9.5.0.1428 or above, and use the BootGuardInfo for testing.

2. MUST use the correct ACM binary for the matching CPUs, else platform will not behave as expected.
Pre-ES and ES CPU set the token of BOOT_GUARD_ACM to 0
Pre-QS and QS CPU without PV ME version set the token of BOOT_GUARD_ACM to 1
Pre-QS and QS CPU with PV ME version set the token of BOOT_GUARD_ACM to 2

3. If you want to modify the attribution of FV_DATA, please clone the token of FV_DATA_ATTR to your project.

If you want to enable the Boot Guard, please following as below.
You must to use the Intel PPT or dTpm as following
Case 1: Use the Intel PPT
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). ME Region->Configuration->Platform Trust->Intel PTT HW Enable/Disable => Enable
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => Enable
c). PCH Strap 10->Intel Platform Trust Technology softstrap disable => No
Case 2: Use the dTpm
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). PCH Strap 10->Intel Platform Trust Technology softstrap disable => Yes
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Boot Guard Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
Boot_Guard_ACM_Rev1_0_ES.bin | The ACM is for Pre-ES and ES CPU samples ONLY!
Boot_Guard_ACM_Rev1_0_QS.bin | The ACM is for Pre-QS and QS CPU without PV ME version ONLY!
Boot_Guard_ACM_Rev1_0_PV.bin | The ACM is for Pre-QS and QS CPU with PV ME version ONLY!
ReserveBootGuardFvMainHashKey.bin | Intel Boot Guard Fv_Main hash key file for chain of trust
ReserveBootGuardSigningServer.bin | It's used for commands of tokens of Intel Boot Guard
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Boot Guard
keygen.exe | Generation of BPM and KM private keys for Boot Guard

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] EIP124550
[Category] Improvement
[Severity] Normal
[Description] Implementation of supporting the signing server for Boot Guard.
[Files] Fit.mak, Fit.sdl, ReserveBootGuardSigningServer.bin, BpmKmGen.exe, Fit.cif

EIP addressed in this label:
124550
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009
4.6.5.1_FIT_010
4.6.5.1_FIT_011
4.6.5.1_FIT_012
4.6.5.1_FIT_013
4.6.5.1_FIT_014
4.6.5.1_FIT_015
4.6.5.1_FIT_016
4.6.5.1_FIT_017
4.6.5.1_FIT_018
4.6.5.1_FIT_019
4.6.5.1_FIT_020
4.6.5.1_FIT_021

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-06-04
Source Control Label: 4.6.5.1_FIT_023
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_15-RC_150
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
TWO
Dependent Component Title: Rom Image
Dependent Component Reference Name: Rom Image
Dependent Source Control Label: 4.6.5.3_RomImage_029
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
1. Please use the latest PV ME and the BootGuardInfo for testing.

2. MUST to use the correct ACM binary for the matching CPUs, else platform will not behave as expected.
Pre-ES and ES CPU set the token of BOOT_GUARD_ACM to 0
Pre-QS and QS CPU without PV ME version set the token of BOOT_GUARD_ACM to 1
Pre-QS and QS CPU with PV ME version set the token of BOOT_GUARD_ACM to 2

NOTE: Be extra cautious when using this ACM. If target system previously has used Boot_Guard_ACM_Rev1_0_PV.bin (ACMSVN=2), putting Boot_Guard_ACM_Rev1_1_QS.bin (ACMSVN=0) on the system will trigger Revocation.

3. If you want to modify the attribution of FV_DATA, please clone the token of FV_DATA_ATTR to your project.

If you want to enable the Boot Guard, please following as below.
You must to use the Intel PPT or dTpm as following
Case 1: Use the Intel PPT
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). ME Region->Configuration->Platform Trust->Intel PTT HW Enable/Disable => Enable
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => Enable
c). PCH Strap 10->Intel Platform Trust Technology softstrap disable => No
Case 2: Use the dTpm
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). PCH Strap 10->Intel Platform Trust Technology softstrap disable => Yes
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Boot Guard Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
Boot_Guard_ACM_Rev1_1_PC_ES.bin | Boot_Guard_ACM_Rev1_1_PC_ES.bin will work on both HSW Corporate ES1 and Consumer ES CPU.
Boot_Guard_ACM_Rev1_1_PC_QS.bin | Boot_Guard_ACM_Rev1_1_PC_QS.bin will work on both HSW ULT Corporate ES2/QS CPUs and Consumer QS CPU
Boot_Guard_ACM_Rev1_0_PV.bin | The ACM is for Pre-QS and QS CPU with PV ME version ONLY!
ReserveBootGuardFvMainHashKey.bin | Intel Boot Guard Fv_Main hash key file for chain of trust
ReserveBootGuardSigningServer.bin | It's used for commands of tokens of Intel Boot Guard
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Boot Guard
keygen.exe | Generation of BPM and KM private keys for Boot Guard

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] EIP125148
[Category] Spec update
[Severity] Normal
[Description] [SBY ULT] Boot Guard for 4th Gen Intel Core Processor based on Mobile U-Processor Line - BIOS Writer's Guide - Rev 1.0.
[Files] Board\EM\FIT\Pei\BootGuardTPMPei\*.*, Fit.sdl, Fit.mak, Fit.cif

[TAG] EIP121561
[Category] Spec update
[Severity] Normal
[Description] [SBY ULT] Boot Guard ACM SDK Rev1.1 for ULT Corporate Beta Release.
[Files] Boot_Guard_ACM_Rev1_1_PC_ES.bin, Boot_Guard_ACM_Rev1_1_PC_QS.bin, Fit.sdl, Fit.cif

EIP addressed in this label:
125148, 121561
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009
4.6.5.1_FIT_010
4.6.5.1_FIT_011
4.6.5.1_FIT_012
4.6.5.1_FIT_013
4.6.5.1_FIT_014
4.6.5.1_FIT_015
4.6.5.1_FIT_016
4.6.5.1_FIT_017
4.6.5.1_FIT_018
4.6.5.1_FIT_019
4.6.5.1_FIT_020
4.6.5.1_FIT_021
4.6.5.1_FIT_022

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-07-04
Source Control Label: 4.6.5.1_FIT_024
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_15-RC_150
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
TWO
Dependent Component Title: Rom Image
Dependent Component Reference Name: Rom Image
Dependent Source Control Label: 4.6.5.3_RomImage_030
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
If you use Non-ULT platforms, please don't care below message.
1. If you want to enable the Boot Guard for Intel ULT platform, please use the latest ME 9.5 PV version and the BootGuardInfo for testing.

2. MUST to use the correct ACM binary for the matching CPUs, else platform will not behave as expected.
Pre-ES and ES CPU set the token of BOOT_GUARD_ACM to 0
Pre-QS and QS CPU without PV ME version set the token of BOOT_GUARD_ACM to 1
Pre-QS and QS CPU with PV ME version set the token of BOOT_GUARD_ACM to 2

NOTE: Consumer Platform may upgrade to this 1.1PV. However as ACMSVN=3, therefore downgrade back to ACM1.0PV or any ACM with ACMSVN<3, will trigger ENF

3. If you want to modify the attribution of FV_DATA, please clone the token of FV_DATA_ATTR to your project.

If you want to enable the Boot Guard, please do the following.
You must to use the Intel PPT or dTpm for enabling the measure boot of Boot Guard.
Case 1: Use the Intel PPT
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). ME Region->Configuration->Platform Trust->Intel PTT HW Enable/Disable => Enable
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => Enable
c). PCH Strap 10->Intel Platform Trust Technology softstrap disable => No
Case 2: Use the dTpm
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). PCH Strap 10->Intel Platform Trust Technology softstrap disable => Yes
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Secure Boot->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Secure Boot->Key Manifest ID => in Build.log
c). ME Region->Configuration->Secure Boot->Boot Guard Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
Boot_Guard_ACM_Rev1_1_PC_ES.bin | Boot_Guard_ACM_Rev1_1_PC_ES.bin will work on both HSW Corporate ES1 and Consumer ES CPU.
Boot_Guard_ACM_Rev1_1_PC_QS.bin | Boot_Guard_ACM_Rev1_1_PC_QS.bin will work on both HSW ULT Corporate ES2/QS CPUs and Consumer QS CPU.
Boot_Guard_ACM_Rev1_1_PV_QS.bin | Boot_Guard_ACM_Rev1_1_PV_QS.bin will work on both HSW ULT Corporate ES2/QS CPUs and Consumer QS CPU.
ReserveBootGuardFvMainHashKey.bin | Intel Boot Guard Fv_Main hash key file for chain of trust
ReserveBootGuardSigningServer.bin | It's used for commands of tokens of Intel Boot Guard
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Boot Guard
keygen.exe | Generation of BPM and KM private keys for Boot Guard

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] EIP128151
[Category] Improvement
[Severity] Normal
[Description] Implement an option to flash FV_DATA region uisng AFU flash utility.
[Files] Board\EM\FIT\Smm\*.*, Fit.cif

[TAG] EIP127910
[Category] Spec update
[Severity] Normal
[Description] [SBY ULT] Boot Guard ACM PV SDK Rev 1.1
[Files] Boot_Guard_ACM_Rev1_1_PV_QS.bin, Fit.sdl, Fit.cif

EIP addressed in this label:
128151, 127910
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009
4.6.5.1_FIT_010
4.6.5.1_FIT_011
4.6.5.1_FIT_012
4.6.5.1_FIT_013
4.6.5.1_FIT_014
4.6.5.1_FIT_015
4.6.5.1_FIT_016
4.6.5.1_FIT_017
4.6.5.1_FIT_018
4.6.5.1_FIT_019
4.6.5.1_FIT_020
4.6.5.1_FIT_021
4.6.5.1_FIT_022
4.6.5.1_FIT_023

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-08-20
Source Control Label: 4.6.5.1_FIT_025
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_15-RC_150
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
TWO
Dependent Component Title: Rom Image
Dependent Component Reference Name: Rom Image
Dependent Source Control Label: 4.6.5.3_RomImage_030
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
If you use Non-ULT platforms, please don't care below message.
1. If you want to enable the Boot Guard for Intel ULT platform, please use the latest ME 9.5 PV version and the BootGuardInfo for testing.

2. MUST to use the correct ACM binary for the matching CPUs, else platform will not behave as expected.
Pre-ES and ES CPU set the token of BOOT_GUARD_ACM to 0
Pre-QS and QS CPU without PV ME version set the token of BOOT_GUARD_ACM to 1
Pre-QS and QS CPU with PV ME version set the token of BOOT_GUARD_ACM to 2

NOTE: Consumer Platform may upgrade to this 1.2 PV. However as ACMSVN=3, therefore downgrade back to ACM1.0PV or any ACM with ACMSVN<3, will trigger ENF.

3. If you want to modify the attribution of FV_DATA, please clone the token of FV_DATA_ATTR to your project.

If you want to enable the Boot Guard, please do the following.
You must to use the Intel PPT or dTpm for enabling the measure boot of Boot Guard.
Case 1: Use the Intel PPT
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). ME Region->Configuration->Platform Trust->Intel PTT HW Enable/Disable => Enable
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => Enable
c). PCH Strap 10->Intel Platform Trust Technology softstrap disable => No
Case 2: Use the dTpm
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). PCH Strap 10->Intel Platform Trust Technology softstrap disable => Yes
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Boot Guard->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Boot Guard->Key Manifest ID => in Build.log
c). ME Region->Configuration->Boot Guard->Boot Guard Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
Boot_Guard_ACM_Rev1_1_PC_ES.bin | Boot_Guard_ACM_Rev1_1_PC_ES.bin will work on both HSW Corporate ES1 and Consumer ES CPU.
Boot_Guard_ACM_Rev1_2_PC_QS.bin | Boot_Guard_ACM_Rev1_2_PC_QS.bin will work on both HSW ULT Corporate ES2/QS CPUs and Consumer QS CPU.
Boot_Guard_ACM_Rev1_2_PV_QS.bin | Boot_Guard_ACM_Rev1_2_PV_QS.bin will work on both HSW ULT Corporate ES2/QS CPUs and Consumer QS CPU.
ReserveBootGuardFvMainHashKey.bin | Intel Boot Guard Fv_Main hash key file for chain of trust
ReserveBootGuardSigningServer.bin | It's used for commands of tokens of Intel Boot Guard
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Boot Guard
keygen.exe | Generation of BPM and KM private keys for Boot Guard
ReBuildFIT.bat | If you use MM tool or modify the BIOS ROM, you need to run the RebuildFIT.bat for Boot Guard.

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] EIP132388
[Category] Spec update
[Severity] Normal
[Description] Boot Guard ACM SDK Rev1.2 PV Release for Shark Bay ULT Platforms.
[Files] Boot_Guard_ACM_Rev1_2_PC_QS.bin, Boot_Guard_ACM_Rev1_2_PV_QS.bin, Fit.cif, Fit.sdl

EIP addressed in this label:
132388
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009
4.6.5.1_FIT_010
4.6.5.1_FIT_011
4.6.5.1_FIT_012
4.6.5.1_FIT_013
4.6.5.1_FIT_014
4.6.5.1_FIT_015
4.6.5.1_FIT_016
4.6.5.1_FIT_017
4.6.5.1_FIT_018
4.6.5.1_FIT_019
4.6.5.1_FIT_020
4.6.5.1_FIT_021
4.6.5.1_FIT_022
4.6.5.1_FIT_023
4.6.5.1_FIT_024

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-09-24
Source Control Label: 4.6.5.1_FIT_026
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_15-RC_150
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
TWO
Dependent Component Title: Rom Image
Dependent Component Reference Name: Rom Image
Dependent Source Control Label: 4.6.5.3_RomImage_030
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
If you use Non-ULT platforms, please don't care below message.
1. If you want to enable the Boot Guard for Intel ULT platform, please use the latest ME 9.5 PV version and the BootGuardInfo for testing.

2. MUST to use the correct ACM binary for the matching CPUs, else platform will not behave as expected.
Pre-ES and ES CPU set the token of BOOT_GUARD_ACM to 0
Pre-QS and QS CPU without PV ME version set the token of BOOT_GUARD_ACM to 1
Pre-QS and QS CPU with PV ME version set the token of BOOT_GUARD_ACM to 2

NOTE: Consumer Platform may upgrade to this 1.2 PV. However as ACMSVN=3, therefore downgrade back to ACM1.0PV or any ACM with ACMSVN<3, will trigger ENF.

3. If you want to modify the attribution of FV_DATA, please clone the token of FV_DATA_ATTR to your project.

If you want to enable the Boot Guard, please do the following.
You must to use the Intel PPT or dTpm for enabling the measure boot of Boot Guard.
Case 1: Use the Intel PPT
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). ME Region->Configuration->Platform Trust->Intel PTT HW Enable/Disable => Enable
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => Enable
c). PCH Strap 10->Intel Platform Trust Technology softstrap disable => No
Case 2: Use the dTpm
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). PCH Strap 10->Intel Platform Trust Technology softstrap disable => Yes
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Boot Guard->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Boot Guard->Key Manifest ID => in Build.log
c). ME Region->Configuration->Boot Guard->Boot Guard Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
Boot_Guard_ACM_Rev1_1_PC_ES.bin | Boot_Guard_ACM_Rev1_1_PC_ES.bin will work on both HSW Corporate ES1 and Consumer ES CPU.
Boot_Guard_ACM_Rev1_2_PC_QS.bin | Boot_Guard_ACM_Rev1_2_PC_QS.bin will work on both HSW ULT Corporate ES2/QS CPUs and Consumer QS CPU.
Boot_Guard_ACM_Rev1_2_PV_QS.bin | Boot_Guard_ACM_Rev1_2_PV_QS.bin will work on both HSW ULT Corporate ES2/QS CPUs and Consumer QS CPU.
ReserveBootGuardFvMainHashKey.bin | Intel Boot Guard Fv_Main hash key file for chain of trust
ReserveBootGuardSigningServer.bin | It's used for commands of tokens of Intel Boot Guard
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Boot Guard
keygen.exe | Generation of BPM and KM private keys for Boot Guard
ReBuildFIT.bat | If you use MM tool or modify the BIOS ROM, you need to run the RebuildFIT.bat for Boot Guard.

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] EIP135513
[Category] New Feature
[Severity] Normal
[Description] Boot Guard supports WIN8 CS WHCK on Sharkbay platform.

EIP addressed in this label:
135513
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009
4.6.5.1_FIT_010
4.6.5.1_FIT_011
4.6.5.1_FIT_012
4.6.5.1_FIT_013
4.6.5.1_FIT_014
4.6.5.1_FIT_015
4.6.5.1_FIT_016
4.6.5.1_FIT_017
4.6.5.1_FIT_018
4.6.5.1_FIT_019
4.6.5.1_FIT_020
4.6.5.1_FIT_021
4.6.5.1_FIT_022
4.6.5.1_FIT_023
4.6.5.1_FIT_024
4.6.5.1_FIT_025

© American Megatrends Inc.


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2012 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.


Release Notes - NDA Required

Component Information:
Component Title: Intel FIT
Component Reference Name: FIT
Component Type: eModule
Release Date: 2013-10-29
Source Control Label: 4.6.5.1_FIT_027
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/FIT;

Dependencies
ONE
Dependent Component Title: Intel Haswell
Dependent Component Reference Name: Intel Haswell
Dependent Source Control Label: 4651_Haswell_15-RC_150
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
TWO
Dependent Component Title: Rom Image
Dependent Component Reference Name: Rom Image
Dependent Source Control Label: 4.6.5.3_RomImage_030
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
If you use Non-ULT platforms, please don't care below message.
1. If you want to enable the Boot Guard for Intel ULT platform, please use the latest ME 9.5 PV version and the BootGuardInfo for testing.

2. MUST to use the correct ACM binary for the matching CPUs, else platform will not behave as expected.
Pre-ES and ES CPU set the token of BOOT_GUARD_ACM to 0
Pre-QS and QS CPU without PV ME version set the token of BOOT_GUARD_ACM to 1
Pre-QS and QS CPU with PV ME version set the token of BOOT_GUARD_ACM to 2

NOTE: Consumer Platform may upgrade to this 1.2 PV. However as ACMSVN=3, therefore downgrade back to ACM1.0PV or any ACM with ACMSVN<3, will trigger ENF.

3. If you want to modify the attribution of FV_DATA, please clone the token of FV_DATA_ATTR to your project.

If you want to enable the Boot Guard, please do the following.
You must to use the Intel PPT or dTpm for enabling the measure boot of Boot Guard.
Case 1: Use the Intel PPT
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). ME Region->Configuration->Platform Trust->Intel PTT HW Enable/Disable => Enable
b). ME Region->Configuration->Features Supported->Intel Platform Trust Technology Enable/Disable => Enable
c). PCH Strap 10->Intel Platform Trust Technology softstrap disable => No
Case 2: Use the dTpm
Please make sure your Intel PPT configurations that set to enable in ME settings of Fitc.
a). PCH Strap 10->Intel Platform Trust Technology softstrap disable => Yes
After you compiled the code, please search the “OEM Public Key Hash” and “Key Manifest ID” in build.log and then set to Intel Fitc manually.
a). ME Region->Configuration->Boot Guard->OEM Public Key Hash => in Build.log
b). ME Region->Configuration->Boot Guard->Key Manifest ID => in Build.log
c). ME Region->Configuration->Boot Guard->Boot Guard Profile Configuration => (Please refer to 1.5MB Firmware Bring Up Guide P. 67 for the detail )

Module Name: Intel FIT
Filename | Description
Fit.cif | Fit module CIF file
Fit.chm | Fit module CHM file
Fit.sdl | Fit module SDL file
Fit.mak | Fit module MAK file
FITUtil.exe | Fit module EXE file
FitTable.asm | Fit module ASM source file
ReserveBpmTable.bin | Reserve Bpm Table
ReserveKmTable.bin | Reserve Km Table
Boot_Guard_ACM_Rev1_1_PC_ES.bin | Boot_Guard_ACM_Rev1_1_PC_ES.bin will work on both HSW Corporate ES1 and Consumer ES CPU.
Boot_Guard_ACM_Rev1_2_PC_QS.bin | Boot_Guard_ACM_Rev1_2_PC_QS.bin will work on both HSW ULT Corporate ES2/QS CPUs and Consumer QS CPU.
Boot_Guard_ACM_Rev1_2_PV_QS.bin | Boot_Guard_ACM_Rev1_2_PV_QS.bin will work on both HSW ULT Corporate ES2/QS CPUs and Consumer QS CPU.
ReserveBootGuardFvMainHashKey.bin | Intel Boot Guard Fv_Main hash key file for chain of trust
ReserveBootGuardSigningServer.bin | It's used for commands of tokens of Intel Boot Guard
CryptoCon.exe | For BpmKmGen.exe use
CutRom.exe | For BpmKmGen.exe use
BpmKmGen.exe | Generation of BPM and KM and update to BIOS ROM for Boot Guard
keygen.exe | Generation of BPM and KM private keys for Boot Guard
ReBuildFIT.bat | If you use MM tool or modify the BIOS ROM, you need to run the RebuildFIT.bat for Boot Guard.

AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
None
General Bug Fixes:
[TAG] None
[Category] Bug Fix
[Severity] Important
[Description] Build error when enable the DEBUG mode.

EIP addressed in this label:
None
Release History:
4.6.5.1_FIT_001
4.6.5.1_FIT_003
4.6.5.1_FIT_004
4.6.5.1_FIT_005
4.6.5.1_FIT_006
4.6.5.1_FIT_007
4.6.5.1_FIT_008
4.6.5.1_FIT_009
4.6.5.1_FIT_010
4.6.5.1_FIT_011
4.6.5.1_FIT_012
4.6.5.1_FIT_013
4.6.5.1_FIT_014
4.6.5.1_FIT_015
4.6.5.1_FIT_016
4.6.5.1_FIT_017
4.6.5.1_FIT_018
4.6.5.1_FIT_019
4.6.5.1_FIT_020
4.6.5.1_FIT_021
4.6.5.1_FIT_022
4.6.5.1_FIT_023
4.6.5.1_FIT_024
4.6.5.1_FIT_025
4.6.5.1_FIT_026

© American Megatrends Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • BootGuardDxe.c
  • BootGuardDxe.dxs
  • BootGuardDxe.h
  • BootGuardDxe.mak
  • BootGuardDxe.sdl
  • BootGuardPei.c
  • BootGuardPei.dxs
  • BootGuardPei.h
  • BootGuardPei.mak
  • BootGuardPei.sdl
  • BootGuardTPM2Dxe.c
  • BootGuardTPM2Dxe.h
  • BootGuardTPM2Dxe.mak
  • BootGuardTPM2Dxe.sdl
  • BootGuardTPMPei.c
  • BootGuardTPMPei.h
  • BootGuardTPMPei.mak
  • BootGuardTPMPei.sdl
  • Fit.mak
  • FitHook.c
  • FitHook.mak
  • FitHook.sdl
Built on 17:23:13 10/29/13


BootGuardDxe.c

Description:
Chain of trust for Dxe


BootGuardDxe.dxs

Description:
Dependency expression file for BootGuardDxe Driver.


BootGuardDxe.h

Description:
Header file for BootGuardDxe


BootGuardDxe.mak

Description:
Make file for BootGuardDxe


BootGuardDxe.sdl

Description:
SDL file for BootGuardDxe


BootGuardPei.c

Description:
Chain of trust for Pei

The following functions are used in the file: BootGuardPei.c.

Function | Description
BootGuardVerificationForPeiToDxeHandoffEndOfPei | BootGuardVerificationForPeiToDxeHandoffEndOfPei at end of Pei handler.
LocateBootGuardFvMainHashKey | Loads binary from RAW section of X firwmare volume


BootGuardVerificationForPeiToDxeHandoffEndOfPei in the BootGuardPei.c

Function : BootGuardVerificationForPeiToDxeHandoffEndOfPei

File: BootGuardPei.c
Description:
BootGuardVerificationForPeiToDxeHandoffEndOfPei at end of Pei
  handler.
Output:
PeiServices - Pointer to PEI Services Table.
  NotifyDesc  - Pointer to the descriptor for the Notification
                event that caused this function to execute.
  Ppi         - Pointer to the PPI data associated with
                this function.


LocateBootGuardFvMainHashKey in the BootGuardPei.c

Function : LocateBootGuardFvMainHashKey

File: BootGuardPei.c
Description:
Loads binary from RAW section of X firwmare volume
Output:
Buffer - returns a pointer to allocated memory. Caller
           must free it when done.
  Size   - returns the size of the binary loaded into the
           buffer.


BootGuardPei.dxs

Description:
BootGuardPei dependency file


BootGuardPei.h

Description:
Header file for BootGuardPei


BootGuardPei.mak

Description:
Make file for BootGuardPei


BootGuardPei.sdl

Description:
SDL file for BootGuardPei


BootGuardTPM2Dxe.c

Description:
TPM2 Initialization Flow for Boot Guard


BootGuardTPM2Dxe.h

Description:
TPM2 Initialization Flow for Boot Guard


BootGuardTPM2Dxe.mak

Description:
TPM2 Initialization Flow for Boot Guard


BootGuardTPM2Dxe.sdl

Description:
SDL file for BootGuard TPM2


BootGuardTPMPei.c

Description:
TPM Initialization Flow for Boot Guard


BootGuardTPMPei.h

Description:
TPM Initialization Flow for Boot Guard


BootGuardTPMPei.mak

Description:
TPM Initialization Flow for Boot Guard


BootGuardTPMPei.sdl

Description:
SDL file for BootGuardTPMPei


Fit.mak

Description:
MAK file for Intel FIT module building


FitHook.c

Description:
SW SMI hook.

The following functions are used in the file: FitHook.c.

Function | Description
AppendFvDataToAFU_UpdateBlockTypeId | This function is SW SMI hook that sets Flash Block Description type for AMI AFU utility. (EIP#58139)


AppendFvDataToAFU_UpdateBlockTypeId in the FitHook.c

Function : AppendFvDataToAFU_UpdateBlockTypeId

File: FitHook.c
Description:
This function is SW SMI hook that sets Flash Block Description
type for AMI AFU utility. (EIP#58139)
Input:
SwSmiNum    - SW SMI value number
Buffer      - Flash descriptor address
Output:
VOID


FitHook.mak

Description:
Make file for FitHook eModule.


FitHook.sdl

Description:
SDL file for FitHook


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

  • A
  • B
  • L


Functions in Alphabetical Order

A

Function | Description
AppendFvDataToAFU_UpdateBlockTypeId | This function is SW SMI hook that sets Flash Block Description type for AMI AFU utility. (EIP#58139)


Functions in Alphabetical Order

B

Function | Description
BootGuardVerificationForPeiToDxeHandoffEndOfPei | BootGuardVerificationForPeiToDxeHandoffEndOfPei at end of Pei handler.


Functions in Alphabetical Order

L

Function | Description
LocateBootGuardFvMainHashKey | Loads binary from RAW section of X firwmare volume


General Information