American Megatrends, Inc.

IsctPlatform

Copyright

Release Notes

© American Megatrends, Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2012-09-03
Source Control Label: 4.6.5.3_ISCT40_050_000
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: AcpiAsl
Dependent Component Reference Name: AcpiAsl
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform\AcpiAsl;

Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS 5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Known issue:
1. Changing the ISCT RF Kill Switch Type to Hardware in BIOS setup menu, and ran the iSCTChecker.exe that reported the GABS is fail. iBIOS086 can reproduce the issue, too. It seems the iSCTChecker's bug.
2. Changing the ISCT Timer Selection to RTC in BIOS setup menu,and ran the iSCTChecker.exe that reported both GWLS/SWLS and GWWS/SWWS are fail. iBIOS086 can reproduce the issue, too.
3. After enabled the ISCT in BIOS setup menu and the "Always Updated" in driver's menu, user to do shutdown(WIN8) than auto wake. iBIOS086 can reproduce the issue, too.
Release History:
NONE

© American Megatrends Inc.


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2012-09-26
Source Control Label: 4.6.5.3_ISCT40_050_001
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: AcpiAsl
Dependent Component Reference Name: AcpiAsl
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform\AcpiAsl;

Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS 5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

[TAG] None
[Category] Improvement
[Description] System hung up when ISCT enabled on the debug mode
[Files] IsctAcpi.c, IsctWakeReason.c and IsctWakeReason.c

EIP Addressed
NONE
Known issue:
1. Changing the ISCT RF Kill Switch Type to Hardware in BIOS setup menu, and ran the iSCTChecker.exe that reported the GABS is fail. iBIOS086 can reproduce the issue, too. It seems the iSCTChecker's bug.
2. Changing the ISCT Timer Selection to RTC in BIOS setup menu,and ran the iSCTChecker.exe that reported both GWLS/SWLS and GWWS/SWWS are fail. iBIOS086 can reproduce the issue, too.
3. After enabled the ISCT in BIOS setup menu and the "Always Updated" in driver's menu, user to do shutdown(WIN8) than auto wake. iBIOS086 can reproduce the issue, too.
Release History:
4.6.5.3_ISCT40_050_000

© American Megatrends Inc.


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2012-10-15
Source Control Label: 4.6.5.3_ISCT40_050_002
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: AcpiAsl
Dependent Component Reference Name: AcpiAsl
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform\AcpiAsl;

TWO
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_071_006 or above
Dependent Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;4.6.5.3_iRST-RC_071_006

Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS 5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

[TAG] None
[Category] Improvement
[Description] Rename the IFFS to RapidStart for updating the 4.6.5.3_iRST-RC_071_006
[Files] IsctAcpi.c

EIP Addressed
NONE
Known issue:
1. Changing the ISCT RF Kill Switch Type to Hardware in BIOS setup menu, and ran the iSCTChecker.exe that reported the GABS is fail. iBIOS086 can reproduce the issue, too. It seems the iSCTChecker's bug.
2. Changing the ISCT Timer Selection to RTC in BIOS setup menu,and ran the iSCTChecker.exe that reported both GWLS/SWLS and GWWS/SWWS are fail. iBIOS086 can reproduce the issue, too.
3. After enabled the ISCT in BIOS setup menu and the "Always Updated" in driver's menu, user to do shutdown(WIN8) than auto wake. iBIOS086 can reproduce the issue, too.
Release History:
4.6.5.3_ISCT40_050_000
4.6.5.3_ISCT40_050_001

© American Megatrends Inc.


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2012-10-29
Source Control Label: 4.6.5.3_ISCT40_050_003
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: AcpiAsl
Dependent Component Reference Name: AcpiAsl
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform\AcpiAsl;

Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS 5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

[TAG] None
[Category] Improvement
[Description] ISCT build error when RapidStart_SUPPORT is Disabled in Sharkbay platform
[Files] IsctAcpi.c

EIP Addressed
105047
Known issue:
1. Changing the ISCT RF Kill Switch Type to Hardware in BIOS setup menu, and ran the iSCTChecker.exe that reported the GABS is fail. iBIOS086 can reproduce the issue, too. It seems the iSCTChecker's bug.
2. Changing the ISCT Timer Selection to RTC in BIOS setup menu,and ran the iSCTChecker.exe that reported both GWLS/SWLS and GWWS/SWWS are fail. iBIOS086 can reproduce the issue, too.
3. After enabled the ISCT in BIOS setup menu and the "Always Updated" in driver's menu, user to do shutdown(WIN8) than auto wake. iBIOS086 can reproduce the issue, too.
Release History:
4.6.5.3_ISCT40_050_000
4.6.5.3_ISCT40_050_001
4.6.5.3_ISCT40_050_002

© American Megatrends Inc.


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2012-11-20
Source Control Label: 4.6.5.3_ISCT40_050_004
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: AcpiAsl
Dependent Component Reference Name: AcpiAsl
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform\AcpiAsl;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_080_017 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;4.6.5.3_PF-ACPI_RC_080_017;

Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS 5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

[TAG] None
[Category] None
[Description] None
[Files] None

EIP Addressed
None
Known issue:
1. Changing the ISCT RF Kill Switch Type to Hardware in BIOS setup menu, and ran the iSCTChecker.exe that reported the GABS is fail. iBIOS086 can reproduce the issue, too. It seems the iSCTChecker's bug.
2. Changing the ISCT Timer Selection to RTC in BIOS setup menu,and ran the iSCTChecker.exe that reported both GWLS/SWLS and GWWS/SWWS are fail. iBIOS086 can reproduce the issue, too.
3. After enabled the ISCT in BIOS setup menu and the "Always Updated" in driver's menu, user to do shutdown(WIN8) than auto wake. iBIOS086 can reproduce the issue, too.
Release History:
4.6.5.3_ISCT40_050_000
4.6.5.3_ISCT40_050_001
4.6.5.3_ISCT40_050_002
4.6.5.3_ISCT40_050_003

© American Megatrends Inc.


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2012-12-05
Source Control Label: 4.6.5.3_ISCT40_050_005
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: AcpiAsl
Dependent Component Reference Name: AcpiAsl
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform\AcpiAsl;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_080_017 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;4.6.5.3_PF-ACPI_RC_080_017;

Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS 5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

[TAG] None
[Category] Bug Fixed
[Description] RTC can't wake
[Files] None

EIP Addressed
107708
Known issue:
None
Release History:
4.6.5.3_ISCT40_050_000
4.6.5.3_ISCT40_050_001
4.6.5.3_ISCT40_050_002
4.6.5.3_ISCT40_050_003
4.6.5.3_ISCT40_050_004

© American Megatrends Inc.


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2013-01-11
Source Control Label: 4.6.5.3_ISCT41_070_006
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: AcpiAsl
Dependent Component Reference Name: AcpiAsl
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform\AcpiAsl;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_080_017 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;4.6.5.3_PF-ACPI_RC_080_017;

If you want to enable remote wake function, please set the token of the “HARDWARE_SECURITY_INFO” = 1 that will report the SMBIOS type 24.
Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS 5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

[TAG] EIP112019
[Category] Bug Fix
[Severity] Normal
[Symptom] [ISCT] The wake up reason is incorrect for PME wake
[RootCause] The PME status be cleared before IsctWakeReason.c.
[Solution] Move the IsctGetWakeReason to gAmiPeiCompleteMRCGuid
[Files] IsctWakeReason.c

[TAG] EIP112016
[Category] Bug Fix
[Severity] Normal
[Symptom] ISCT can't use the actual time to wake up the system.
[RootCause] Only support duration time
[Solution] Implementation of the actual time for ISCT
[Files] IsctSmm.c

EIP Addressed
112019, 112016
Known issue:
None
Release History:
4.6.5.3_ISCT40_050_000
4.6.5.3_ISCT40_050_001
4.6.5.3_ISCT40_050_002
4.6.5.3_ISCT40_050_003
4.6.5.3_ISCT40_050_004
4.6.5.3_ISCT40_050_005

© American Megatrends Inc.


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2013-01-14
Source Control Label: 4.6.5.3_ISCT41_070_007
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: AcpiAsl
Dependent Component Reference Name: AcpiAsl
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform\AcpiAsl;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_080_017 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;4.6.5.3_PF-ACPI_RC_080_017;

If you want to enable remote wake function, please set the token of the “HARDWARE_SECURITY_INFO” = 1 that will report the SMBIOS type 24.
Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS 5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

[TAG] EIP112064
[Category] Bug Fix
[Severity] Normal
[Symptom] [ISCT] GWLS,SWLS,GWWS and SWWS are fail while set wake up timer to RTC
[Solution] Implement the GWLS,SWLS,GWWS and SWWS while set wake up timer to RTC
[Files] Isct.asl

EIP Addressed
112064
Known issue:
None
Release History:
4.6.5.3_ISCT40_050_000
4.6.5.3_ISCT40_050_001
4.6.5.3_ISCT40_050_002
4.6.5.3_ISCT40_050_003
4.6.5.3_ISCT40_050_004
4.6.5.3_ISCT40_050_005
4.6.5.3_ISCT41_070_006

© American Megatrends Inc.


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2013-01-18
Source Control Label: 4.6.5.3_ISCT41_070_008
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: AcpiAsl
Dependent Component Reference Name: AcpiAsl
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform\AcpiAsl;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_080_017 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;4.6.5.3_PF-ACPI_RC_080_017;

If you want to enable remote wake function, please set the token of the “HARDWARE_SECURITY_INFO” = 1 that will report the SMBIOS type 24.
Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS 5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

[TAG] EIP112016
[Category] Bug Fix
[Severity] Normal
[Symptom] ISCT can't use the actual time to wake up the system.
[Solution] Only support duration time
[Files] IsctSmm.c

EIP Addressed
112016
Known issue:
None
Release History:
4.6.5.3_ISCT40_050_000
4.6.5.3_ISCT40_050_001
4.6.5.3_ISCT40_050_002
4.6.5.3_ISCT40_050_003
4.6.5.3_ISCT40_050_004
4.6.5.3_ISCT40_050_005
4.6.5.3_ISCT41_070_006
4.6.5.3_ISCT41_070_007

© American Megatrends Inc.


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2013-03-27
Source Control Label: 4.6.5.3_ISCT41_080_009
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_131_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;4.6.5.3_PF-ACPI_RC_131_026;

If you want to enable remote wake function, please set the token of the “HARDWARE_SECURITY_INFO” = 1 that will report the SMBIOS type 24.
Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS 5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

[TAG] EIP118307
[Category] New Feature
[Severity] Normal
[Symptom] Implementation of the ISCT Platform Design Specification 0.8.
[Files] Isct.asl, IsctAcpi.c, IsctAcpi.mak

[TAG] EIP119288
[Category] Bug Fix
[Severity] Normal
[Symptom] When KB or mouse device plugged in P/S2, USB2.0 ports, it showed "PME Wake up event" by tool.
[Solution] Change the USB2.0 wake reason to User pressed power button or HID event [Files] IsctWakeReason.c

EIP Addressed
118307, 119288
Known issue:
None
Release History:
4.6.5.3_ISCT40_050_000
4.6.5.3_ISCT40_050_001
4.6.5.3_ISCT40_050_002
4.6.5.3_ISCT40_050_003
4.6.5.3_ISCT40_050_004
4.6.5.3_ISCT40_050_005
4.6.5.3_ISCT41_070_006
4.6.5.3_ISCT41_070_007
4.6.5.3_ISCT41_070_008

© American Megatrends Inc.


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2013-05-15
Source Control Label: 4.6.5.3_ISCT41_110_010
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_131_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;4.6.5.3_PF-ACPI_RC_131_026;

If you want to enable remote wake function, please set the token of the “HARDWARE_SECURITY_INFO” = 1 that will report the SMBIOS type 24.
Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS 5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

[TAG] EIP123328
[Category] New Feature
[Severity] Normal
[Symptom] Implementation of the ISCT Platform Design Specification 1.1.0.
[Files] Isct.asl, IsctWakeReason.c

EIP Addressed
123328
Known issue:
None
Release History:
4.6.5.3_ISCT40_050_000
4.6.5.3_ISCT40_050_001
4.6.5.3_ISCT40_050_002
4.6.5.3_ISCT40_050_003
4.6.5.3_ISCT40_050_004
4.6.5.3_ISCT40_050_005
4.6.5.3_ISCT41_070_006
4.6.5.3_ISCT41_070_007
4.6.5.3_ISCT41_070_008
4.6.5.3_ISCT41_080_009

© American Megatrends Inc.


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2013-05-28
Source Control Label: 4.6.5.3_ISCT41_110_011
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_131_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;4.6.5.3_PF-ACPI_RC_131_026;

If you want to enable remote wake function, please set the token of the “HARDWARE_SECURITY_INFO” = 1 that will report the SMBIOS type 24.
Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS 5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

[TAG] EIP125007
[Category] Improvement
[Description] [ISCT] Change IASL compiler path
[Files] Isct.mak

EIP Addressed
125007
Known issue:
None
Release History:
4.6.5.3_ISCT40_050_000
4.6.5.3_ISCT40_050_001
4.6.5.3_ISCT40_050_002
4.6.5.3_ISCT40_050_003
4.6.5.3_ISCT40_050_004
4.6.5.3_ISCT40_050_005
4.6.5.3_ISCT41_070_006
4.6.5.3_ISCT41_070_007
4.6.5.3_ISCT41_070_008
4.6.5.3_ISCT41_080_009
4.6.5.3_ISCT41_100_010

© American Megatrends Inc.


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2013-06-03
Source Control Label: 4.6.5.3_ISCT41_110_012
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_131_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;4.6.5.3_PF-ACPI_RC_131_026;

If you want to enable remote wake function, please set the token of the “HARDWARE_SECURITY_INFO” = 1 that will report the SMBIOS type 24.
Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS 5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Files Changed for General Bug Fixes and EIP Addressed in this Label:
Improvement

[TAG] EIP125348
[Category] Improvement
[Description] [SBY] Intel Smart Connect Technology BIOS Sample Code 052413 Update
[Files] IsctAcpi.c,IsctAcpi.h,IsctWakeReason.c,IsctSmm.c

EIP Addressed
125348
Known issue:
None
Release History:
4.6.5.3_ISCT40_050_000
4.6.5.3_ISCT40_050_001
4.6.5.3_ISCT40_050_002
4.6.5.3_ISCT40_050_003
4.6.5.3_ISCT40_050_004
4.6.5.3_ISCT40_050_005
4.6.5.3_ISCT41_070_006
4.6.5.3_ISCT41_070_007
4.6.5.3_ISCT41_070_008
4.6.5.3_ISCT41_080_009
4.6.5.3_ISCT41_100_010
4.6.5.3_ISCT41_110_011

© American Megatrends Inc.


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2013-08-02
Source Control Label: 4.6.5.3_ISCT41_110_013
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_131_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;4.6.5.3_PF-ACPI_RC_131_026;

If you want to enable remote wake function, please set the token of the “HARDWARE_SECURITY_INFO” = 1 that will report the SMBIOS type 24.
Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS 5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Files Changed for General Bug Fixes and EIP Addressed in this Label:
Improvement

[TAG] None
[Category] Improvement
[Description] Hide the item of timer choice on the platforms which don't have EC
Force to RTC wake on Lava Cayon CRB
[Files] Isct.sd, IsctAcpi.c

EIP Addressed
None
Known issue:
None
Release History:
4.6.5.3_ISCT40_050_000
4.6.5.3_ISCT40_050_001
4.6.5.3_ISCT40_050_002
4.6.5.3_ISCT40_050_003
4.6.5.3_ISCT40_050_004
4.6.5.3_ISCT40_050_005
4.6.5.3_ISCT41_070_006
4.6.5.3_ISCT41_070_007
4.6.5.3_ISCT41_070_008
4.6.5.3_ISCT41_080_009
4.6.5.3_ISCT41_100_010
4.6.5.3_ISCT41_110_011
4.6.5.3_ISCT41_110_012

© American Megatrends Inc.


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2013-10-29
Source Control Label: 4.6.5.3_ISCT41_110_014
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_131_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;4.6.5.3_PF-ACPI_RC_131_026;

If you want to enable remote wake function, please set the token of the “HARDWARE_SECURITY_INFO” = 1 that will report the SMBIOS type 24.
Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated: 2013-03-19
Visual eBios: RSS 5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Files Changed for General Bug Fixes and EIP Addressed in this Label:
None

EIP Addressed
138184

[Category] Bug Fix
[Symptom] Panel will light up when entering into S0-iSCT from Rapid-Start-S4(iFFS)
[RootCause] We only judge the boot mode of S3,but it will resume from S4 when enable iRST.
[Solution] Add the judgement of S4 resume
[Files] IsctWakeReason.c

Known issue:
None
Release History:
4.6.5.3_ISCT40_050_000
4.6.5.3_ISCT40_050_001
4.6.5.3_ISCT40_050_002
4.6.5.3_ISCT40_050_003
4.6.5.3_ISCT40_050_004
4.6.5.3_ISCT40_050_005
4.6.5.3_ISCT41_070_006
4.6.5.3_ISCT41_070_007
4.6.5.3_ISCT41_070_008
4.6.5.3_ISCT41_080_009
4.6.5.3_ISCT41_100_010
4.6.5.3_ISCT41_110_011
4.6.5.3_ISCT41_110_012
4.6.5.3_ISCT41_110_013

© American Megatrends Inc.


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2014-05-13
Source Control Label: 4.6.5.3_ISCT41_110_015
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_131_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;4.6.5.3_PF-ACPI_RC_131_026;

If you want to enable remote wake function, please set the token of the “HARDWARE_SECURITY_INFO” = 1 that will report the SMBIOS type 24.
Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated: 2013-03-19
Visual eBios: RSS 5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Files Changed for General Bug Fixes and EIP Addressed in this Label:
None

EIP Addressed
167033

[TAG] EIP167033
[Category] Improvement
[Description] Remove the "ISCT_PERSISTENT_DATA" runtime attribute.
[Files] IsctAcpi.c

Known issue:
None
Release History:
4.6.5.3_ISCT40_050_000
4.6.5.3_ISCT40_050_001
4.6.5.3_ISCT40_050_002
4.6.5.3_ISCT40_050_003
4.6.5.3_ISCT40_050_004
4.6.5.3_ISCT40_050_005
4.6.5.3_ISCT41_070_006
4.6.5.3_ISCT41_070_007
4.6.5.3_ISCT41_070_008
4.6.5.3_ISCT41_080_009
4.6.5.3_ISCT41_100_010
4.6.5.3_ISCT41_110_011
4.6.5.3_ISCT41_110_012
4.6.5.3_ISCT41_110_013
4.6.5.3_ISCT41_110_014

© American Megatrends Inc.


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2014-07-09
Source Control Label: 4.6.5.3_ISCT41_110_016
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_131_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;4.6.5.3_PF-ACPI_RC_131_026;

Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated: 2013-03-19
Visual eBios: RSS 5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel Sightings Report in this label:
None.
Files Changed for General Bug Fixes and EIP Addressed in this Label:
None

EIP Addressed
142924

[TAG] EIP142924
[Category] Improvement
[Description] iSCT 5.0 for Shark Bay Platform.
[Files] Isct.asl\IsctWakeReason.c\IsctWakeReason.mak\IsctAcpi.c\IsctSmm.c

Porting Notes:
1. If you want to enable remote wake function, please set the token of the “HARDWARE_SECURITY_INFO” = 1 that will report the SMBIOS type 24.
2. If you want to use Wake on WLAN or NetDetect, please set the token of the “HOST_WLAN_PP_EN” = 1.
3. If you want to use pnpExerciser, go to Services and stop ISCT Agent.
4. iSCTChecker: Need 5.0.0.1 or above.
Known issue:
None
Release History:
4.6.5.3_ISCT40_050_000
4.6.5.3_ISCT40_050_001
4.6.5.3_ISCT40_050_002
4.6.5.3_ISCT40_050_003
4.6.5.3_ISCT40_050_004
4.6.5.3_ISCT40_050_005
4.6.5.3_ISCT41_070_006
4.6.5.3_ISCT41_070_007
4.6.5.3_ISCT41_070_008
4.6.5.3_ISCT41_080_009
4.6.5.3_ISCT41_100_010
4.6.5.3_ISCT41_110_011
4.6.5.3_ISCT41_110_012
4.6.5.3_ISCT41_110_013
4.6.5.3_ISCT41_110_014
4.6.5.3_ISCT41_110_015

© American Megatrends Inc.


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2012 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2014-07-24
Source Control Label: 4.6.5.3_ISCT41_110_018
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_131_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;4.6.5.3_PF-ACPI_RC_131_026;

Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated: 2013-03-19
Visual eBios: RSS 5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel Sightings Report in this label:
None.
Files Changed for General Bug Fixes and EIP Addressed in this Label:
None
Add complete function with iRST.

EIP Addressed
142924

[TAG] EIP142924
[Category] Improvement
[Description] iSCT 5.0 for Shark Bay Platform.
[Files] Isct.asl\IsctWakeReason.c\IsctWakeReason.mak\IsctAcpi.c\IsctSmm.c

Porting Notes:
1. If you want to enable remote wake function, please set the token of the “HARDWARE_SECURITY_INFO” = 1 that will report the SMBIOS type 24.
2. If you want to use Wake on WLAN or NetDetect, please set the token of the “HOST_WLAN_PP_EN” = 1.
3. If you want to use pnpExerciser, go to Services and stop ISCT Agent.
4. iSCTChecker: Need 5.0.0.1 or above.
Known issue:
None
Release History:
4.6.5.3_ISCT40_050_000
4.6.5.3_ISCT40_050_001
4.6.5.3_ISCT40_050_002
4.6.5.3_ISCT40_050_003
4.6.5.3_ISCT40_050_004
4.6.5.3_ISCT40_050_005
4.6.5.3_ISCT41_070_006
4.6.5.3_ISCT41_070_007
4.6.5.3_ISCT41_070_008
4.6.5.3_ISCT41_080_009
4.6.5.3_ISCT41_100_010
4.6.5.3_ISCT41_110_011
4.6.5.3_ISCT41_110_012
4.6.5.3_ISCT41_110_013
4.6.5.3_ISCT41_110_014
4.6.5.3_ISCT41_110_015
4.6.5.3_ISCT41_110_016
4.6.5.3_ISCT41_110_017

© American Megatrends Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • Isct.mak
  • Isct.sdl
  • IsctAcpi.mak
  • IsctAcpi.sdl
  • IsctGuidLib.mak
  • IsctGuidLib.sdl
  • IsctPlatform.sdl
  • IsctProtocolLib.mak
  • IsctProtocolLib.sdl
  • IsctSmm.mak
  • IsctSmm.sdl
  • IsctWakeReason.mak
  • IsctWakeReason.sdl
Built on 21:42:27 07/11/14


AMIBIOS Function Reference

Isct.mak

Description:
Make file to build Isct ASL components
Built on 21:42:27 07/11/14


AMIBIOS Function Reference

Isct.sdl

Description:
SDL file for Isct
Built on 21:42:27 07/11/14


AMIBIOS Function Reference

IsctAcpi.mak

Description:
Make file to build IsctAcpi components
Built on 21:42:27 07/11/14


AMIBIOS Function Reference

IsctAcpi.sdl

Description:
SDL file for IsctAcpi
Built on 21:42:27 07/11/14


AMIBIOS Function Reference

IsctGuidLib.mak

Description:
Make file to build IsctSmm components.
Built on 21:42:27 07/11/14


AMIBIOS Function Reference

IsctGuidLib.sdl

Description:
SDL file for IsctGuidLib
Built on 21:42:27 07/11/14


AMIBIOS Function Reference

IsctPlatform.sdl

Description:
SDL file for IsctPlatform
Built on 21:42:27 07/11/14


AMIBIOS Function Reference

IsctProtocolLib.mak

Description:
Make file to build IsctProtocolLib components
Built on 21:42:27 07/11/14


AMIBIOS Function Reference

IsctProtocolLib.sdl

Description:
SDL file for IsctProtocolLib
Built on 21:42:27 07/11/14


AMIBIOS Function Reference

IsctSmm.mak

Description:
Make file to build IsctSmm components
Built on 21:42:27 07/11/14


AMIBIOS Function Reference

IsctSmm.sdl

Description:
SDL file for IsctSmm
Built on 21:42:27 07/11/14


AMIBIOS Function Reference

IsctWakeReason.mak

Description:
Make file to build IsctWakeReason components
Built on 21:42:27 07/11/14


AMIBIOS Function Reference

IsctWakeReason.sdl

Description:
SDL file for IsctWakeReason
Built on 21:42:27 07/11/14


Functions in Alphabetical Order

AMIBIOS Function Reference

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

Built on 21:42:27 07/11/14


AMIBIOS Function Reference

General Information

Built on 21:42:27 07/11/14


Component Information:
Component Title: Intel Smart Connect Technology
Component Reference Name: IsctPlatform
Component Type: eModule
Release Date: 2014-07-11
Source Control Label: 4.6.5.3_ISCT41_110_017
Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/ISCT/;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_131_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;4.6.5.3_PF-ACPI_RC_131_026;

Non-Compiled BIN and LIB File(s) within this Component:
NONE
Component Description:
This is an eModule of Intel Smart Connect Technology
Filename | Description
Main Component | Root\Board\EM\Isct
IsctPlatform.cif | Component information file for the eModule.
IsctPlatform.sdl | SDL file for IsctPlatform
IsctAcpiTables
ModulePart 		Root\Board\EM\Isct\AcpiTables - Provide functions to the ACPI methods and setup items for the iSCT agent to use.
Isct.asl | This file provides the ACPI methods for the iSCT agent to use.
Isct.sd | Create the setup item for Isct.
Isct.uni | Define string for Isct
Isct.sdl | SDL file for Isct
Isct.cif | Component information for the Module Part.
Isct.mak | Make file to build the ModulePart.
IsctPeiWakeReason
ModulePart 		Root\Board\EM\Isct\Pei - This ModulePart serves the purpose of finding and saving the wake reason for the Isct agent to see via Acpi Method
IsctWakeReason.c | Provide Wake Reason for ISCT.
IsctWakeReason.dxs | Dependency expression file for IsctWakeReason Driver.
IsctWakeReason.sdl | SDL file for IsctWakeReason.
IsctWakeReason.cif | Component information for the Module Part.
IsctWakeReason.mak | Make file to build IsctWakeReason components.
IsctDxeAcpi
ModulePart 		Root\Board\EM\Isct\Dxe - This ModulePart serves to set up IsctNvs region and set ReadyToBoot event to install Isct AcpiTables
IsctAcpi.c | This Dxe driver will initialize ISCT Persistent Data Variable and also verify ISCT Store valid or not.
IsctAcpi.h | AMI Override for IsctAcpi.
IsctAcpi.dxs | Dependency expression file for IsctAcpi Driver.
IsctAcpi.sdl | SDL file for IsctAcpi.
IsctAcpi.cif | Component information for the Module Part.
IsctAcpi.mak | Make file to build IsctAcpi components.
IsctSmm
ModulePart 		Root\Board\EM\Isct\Smm - This ModulePart serves the purpose of creating a callback upon entry into S3
IsctSmm.c | Main implementation source file for the Isct SMM driver.
IsctSmm.dxs | Dependency expression file for IsctSmm Driver.
IsctSmm.sdl | SDL file for IsctWakeReason.
IsctSmm.cif | Component information for the Module Part.
IsctSmm.mak | Make file to build IsctSmm components.
IsctGuidLib
ModulePart 		Root\Board\EM\Isct\Guid - This ModulePart for define ISCT GUID
IsctAcpiTableStorage.c | The GUID definition for Isct ACPI table storage file name.
IsctAcpiTableStorage.h | GUID definition for the Isct ACPI table storage file name.
IsctPersistentData.c | The GUID definition for Isct Persistent Data.
IsctPersistentData.h | GUID definition for the Isct Persistent Data.
IsctGuidLib.sdl | SDL file for IsctGuidLib.
IsctGuidLib.cif | Component information for the Module Part.
IsctGuidLib.mak | Make file to build IsctSmm components.
IsctProtocolLib
ModulePart 		Root\Board\EM\Isct\Protocol - This ModulePart for define ISCT Protocol
IsctNvsArea.c | Isct NVS Area description protocol implementation.
IsctNvsArea.h | Data structures defined in this protocol are not naturally aligned.
IsctProtocolLib.sdl | SDL file for IsctProtocolLib.
IsctProtocolLib.cif | Component information for the Module Part.
IsctProtocolLib.mak | Make file to build IsctProtocolLib components.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated: 2013-03-19
Visual eBios: RSS 5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel Sightings Report in this label:
None.
Files Changed for General Bug Fixes and EIP Addressed in this Label:
None
Add iRST

EIP Addressed
142924

[TAG] EIP142924
[Category] Improvement
[Description] iSCT 5.0 for Shark Bay Platform.
[Files] Isct.asl\IsctWakeReason.c\IsctWakeReason.mak\IsctAcpi.c\IsctSmm.c

Porting Notes:
1. If you want to enable remote wake function, please set the token of the “HARDWARE_SECURITY_INFO” = 1 that will report the SMBIOS type 24.
2. If you want to use Wake on WLAN or NetDetect, please set the token of the “HOST_WLAN_PP_EN” = 1.
3. If you want to use pnpExerciser, go to Services and stop ISCT Agent.
4. iSCTChecker: Need 5.0.0.1 or above.
5. This label still not support iRST and iSCT complex case.
Known issue:
None
Release History:
4.6.5.3_ISCT40_050_000
4.6.5.3_ISCT40_050_001
4.6.5.3_ISCT40_050_002
4.6.5.3_ISCT40_050_003
4.6.5.3_ISCT40_050_004
4.6.5.3_ISCT40_050_005
4.6.5.3_ISCT41_070_006
4.6.5.3_ISCT41_070_007
4.6.5.3_ISCT41_070_008
4.6.5.3_ISCT41_080_009
4.6.5.3_ISCT41_100_010
4.6.5.3_ISCT41_110_011
4.6.5.3_ISCT41_110_012
4.6.5.3_ISCT41_110_013
4.6.5.3_ISCT41_110_014
4.6.5.3_ISCT41_110_015
4.6.5.3_ISCT41_110_016

© American Megatrends Inc.