American Megatrends, Inc.

ReleaseNotes

Copyright

Release Notes

© American Megatrends, Inc.


Release Notes - NDA Required

Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-04-25
Source Control Label: 4.6.5.3_PF-ACPI_RC_055_004
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_055_004
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;
TWO
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_055_004
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Shark Bay Client ACPI Reference Code Alpha 1 Version 0.5.5.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_055_004

© American Megatrends Inc.


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-05-14
Source Control Label: 4.6.5.3_PF-ACPI_RC_056_005
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_056_006
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;
TWO
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_056_007
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Kit 45204 Shark Bay Client ACPI Reference Code Alpha 2 Version 0.5.6.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
[TAG] None
[Category] Improvement
[Description] Fix Fastboot cause system halt on 0xA2 issue.
[Files] AcpiPlatform.sdl

[TAG] None
[Category] Improvement
[Description] Update Shark Bay Client ACPI Reference Code Alpha 2 Version 0.5.6.
[Files] ReferenceCode\AcpiTables\*.*, GlobalNvsArea.h

[TAG] None
[Category] Improvement
[Description] Fixed UEFI Windows installation will hang on 0xB0 after enable "DEBUG_MODE".
[Files] FvOnFv2Thunk.mak
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-06-13
Source Control Label: 4.6.5.3_PF-ACPI_RC_056_006
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_056_006
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;
TWO
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_056_007
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Kit 45204 Shark Bay Client ACPI Reference Code Alpha 2 Version 0.5.6.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
[TAG] None
[Category] Improvement
[Description] Support Firmware Version Information.
[Files] AcpiPlatform.cif, Board/EM/Platform/FirmwareVerInfo/*.*

[TAG] None
[Description] 01. Implement Intel Rapid Start Technology RC version info.
02. Remove DPTF and TxT RefCode version in setup, because they are not separate components.
[Files] IntelRefVerDisplay.mak, IntelRefVerDisplay.sd, IntelRefVerDisplay.uni, IntelRefVerSetup.c
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_056_005


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-07-03
Source Control Label: 4.6.5.3_PF-ACPI_RC_060_007
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_060_008
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;
TWO
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_060_010
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Kit 46137 Shark Bay Client ACPI Reference Code Alpha 2 Version 0.6.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
[TAG] None
[Category] Improvement
[Description] Update Shark Bay Client ACPI Reference Code Alpha 2 0.6.0.
[Files] ReferenceCode\AcpiTables\*.*, GlobalNvsArea.h, AcpiPlatform.c, PlatformInfo.c, PlatformEC.asl
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_056_006


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-07-11
Source Control Label: 4.6.5.3_PF-ACPI_RC_060_008
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_060_008
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;
TWO
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_060_010
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Kit 46137 Shark Bay Client ACPI Reference Code Alpha 2 Version 0.6.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
[TAG] EIP93982
[Category] Improvement
[Description] Fix system hang at A0 or A2 during bootup.
[Description] FirmwareVerInfo.c

[TAG] None
[Category] Improvement
[Description] Correct Lan PHY Revision in BIOS Setup info.
[Files] PlatformSetupInfo.c, PlatformSetupInfo.h

[TAG] None
[Category] Improvement
[Description] Corrected Setup RefCcode Version info.
[Files] IntelRefVerSetup.cm IntelRefVerDisplay.sd

[TAG] None
[Category] Improvement
[Description] Sync South Bridge module the PM base address configure.
[Files] LPC_DEV.ASL
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_060_007


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-07-27
Source Control Label: 4.6.5.3_PF-ACPI_RC_060_009
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_060_009
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;
TWO
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_060_011
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Kit 46137 Shark Bay Client ACPI Reference Code Alpha 2 Version 0.6.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
[TAG] None
[Category] Improvement
[Description] Support ASLPREPROCESS_FLAG to include Iintel RC flags.
[Files] AcpiPlatform.sdl

[TAG] None
[Category] Improvement
[Description] Create DPTF and CPPC setup item.
[Files] AcpiPlatform.c, AcpiPlatform.sd, AcpiPlatform.uni, PlatformSetup.h
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_060_008


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-08-14
Source Control Label: 4.6.5.3_PF-ACPI_RC_061_010
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_061_010
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;
TWO
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_061_013
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Kit 47211 Shark Bay Client ACPI Reference Code Alpha 2 Version 0.6.1 .
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
[TAG] None
[Category] Improvement
[Description] Update Shark Bay Client ACPI Reference Code Alpha 2 0.6.1.
[Files] ReferenceCode\AcpiTables\*.*, GlobalNvsArea.h

[TAG] None
[Category] Improvement
[Severity] Important
[Description] Update to support Haswell B0 and ULT A0 setup info.
[Files] PlatformSetupInfo.c, PlatformSetupInfo.h

[TAG] None
[Category] Improvement
[Description] Remove useless Dppm policy.
[Files] AcpiPlatform.c
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_060_009


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-08-31
Source Control Label: 4.6.5.3_PF-ACPI_RC_061_011
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_061_012
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;
TWO
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_061_015
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Kit 47211 Shark Bay Client ACPI Reference Code Alpha 2 Version 0.6.1 .
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
[TAG] None
[Category] Improvement
[Severity] Important
[Description] GPIO base address can be updated in ASL source.
[Files] LPC_DEV.ASL

[TAG] None
[Category] Improvement
[Severity] Important
[Description] Add Windows8 identification.
[Files] Platform.asl

[TAG] None
[Category] Improvement
[Severity] Important
[Description] Update Board ID for Haswell platform.
[Files] AcpiPlatform.c, AcpiPlatform.sdl, PlatformInfo.sdl, AcpiAsl.sdl

[TAG] None
[Category] Improvement
[Severity] Important
[Description] Implement Runtime D3.
[Files] AcpiPlatform.c, AcpiPlatform.cif, AcpiPlatform.h, AcpiPlatform.sd, AcpiPlatform.sdl, AcpiPlatform.uni, GlobalNvsArea.h, SsdtRtd3.cif, SsdtRtd3.mak, Ult0Rtd3.asl, SsdtRtd3.sdl
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-09-12
Source Control Label: 4.6.5.3_PF-ACPI_RC_061_012
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_061_013
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;
TWO
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_061_016
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Kit 47211 Shark Bay Client ACPI Reference Code Alpha 2 Version 0.6.1 .
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
[TAG] None
[Category] Improvement
[Severity] Important
[Description] Modified for Switchable Graphics support.
[Files] GlobalNvsArea.h, GloblNvs.asl

[TAG] None
[Category] Improvement
[Severity] Important
[Description] Remove AOAC for Intel Smart Connect Technology module.
[Files] GlobalNvsArea.h, GloblNvs.asl
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-09-26
Source Control Label: 4.6.5.3_PF-ACPI_RC_070_013
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_070_014
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;
TWO
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_070_017
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Kit 48588 Shark Bay Client ACPI Reference Code Beta Version 0.7.0 .
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
[TAG] None
[Category] Improvement
[Severity] Important
[Description] Update Shark Bay Client ACPI Reference Code Beta Version 0.7.0.
[Files] ReferenceCode\AcpiTables\*.*,GlobalNvsArea.h

[TAG] None
[Category] Improvement
[Description] Update for Shark Bay ULT use USB KB wake from S3/S4.
[Files] Gpe.asl
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_070_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-10-16
Source Control Label: 4.6.5.3_PF-ACPI_RC_071_014
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_071_019 or higher
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;
TWO
Dependent Component Title: SwitchableGraphics
Dependent Component Reference Name: SwitchableGraphics
Dependent Source Control Label: 4.6.5.3_SG_002 or higher
Dependent Source Control Location: SS: ALASKA;$/Alaska/SOURCE/Modules/SharkBayRefCodes/SwitchableGraphics/;
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Kit 48999 Shark Bay Client ACPI Reference Code Beta Version 0.7.1(ULT Alpha/Traditional Beta)
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
[TAG] None
[Category] Improvement
[Severity] Important
[Description] Update Shark Bay Client ACPI Reference Code Beta Version 0.7.1
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-10-31
Source Control Label: 4.6.5.3_PF-ACPI_RC_071_015
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_072_020a
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;
TWO
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_071_021a
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: NONE
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] None
[Category] Improvement
[Severity] Normal
[Description] Fine tune Platform Board Information.

[TAG] None
[Category] New Feature
[Severity] Normal
[Description] Support Acpi Debug SSDT.

[TAG] None
[Category] Improvement
[Severity] Normal
[Description] Removed all SaGlobalNvsArea Structure, move to SA module to initial.

General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-11-09
Source Control Label: 4.6.5.3_PF-ACPI_RC_071_016
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_072_020b
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;
TWO
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_071_022
THREE
Dependent Component Title: ME
Dependent Component Reference Name: ME
Dependent Source Control Label: 4.6.4.1_Intel_ME_RC_0.71_018
Dependent Source Control Location: SS:/Alaska/SOURCE/Modules/SharkBayRefCodes/ME;
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: NONE
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] None
[Category] New Feature
[Severity] Important
[Description] ZpOdd SSDT acpi table support

[TAG] None
[Category] Improvement
[Severity] Important
[Description] Shark Bay ULT Platform BSOD with v0.7.2 Reference Code Update

General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-11-20
Source Control Label: 4.6.5.3_PF-ACPI_RC_080_017
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;
TWO
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_080_023
THREE
Dependent Component Title: ME
Dependent Component Reference Name: ME
Dependent Source Control Label: 4.6.4.1_Intel_ME_RC_0.80_019
Dependent Source Control Location: SS:/Alaska/SOURCE/Modules/SharkBayRefCodes/ME;
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: NONE
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] None
[Category] New Feature
[Severity] Important
[Description] SensorHub SSDT acpi table support

[TAG] None
[Category] Improvement
[Severity] Important
[Description] Update Shark Bay Client ACPI Reference Code Beta Version 0.8.0

General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-11-26
Source Control Label: 4.6.5.3_PF-ACPI_RC_080_018
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;
TWO
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_080_023
THREE
Dependent Component Title: ME
Dependent Component Reference Name: ME
Dependent Source Control Label: 4.6.4.1_Intel_ME_RC_0.80_019
Dependent Source Control Location: SS:/Alaska/SOURCE/Modules/SharkBayRefCodes/ME;
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: NONE
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] None
[Category] Improvement
[Severity] Normal
[Description] Fixed that Setup menu shows incorrect CPU informaion for Sharkbay ULT.
[Files] PlatformSetupInfo.c, PlatformSetupInfo.h
[TAG] None
[Category] Improvement
[Severity] Normal
[Description] Include Rtd3FFRD.asl for Haswell - FFRD SKU Board,
BRRtd3.asl for Haswell - Basking Ridge Board.
[Files] SsdtRtd3.cif, SsdtRtd3.sdl, Rtd3FFRD.asl, BRRtd3.asl, Acpiplatform.c
[TAG] None
[Category] Improvement
[Severity] Important
[Description] Fixed the system has blue screen when RTD3 is Enabled for RC 0.8.
[Files] SsdtZpOdd.sdl, Acpiplatform.c
General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-12-19
Source Control Label: 4.6.5.3_PF-ACPI_RC_081_019
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_081_024
omponent Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 0.8.1.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 0.8.1.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] EIP109757
[Category] Important
[Severity] Important
[Description] Update Shark Bay Client ACPI Reference Code Beta Version 0.8.1.
[TAG] None
[Category] Normal
[Severity] Normal
[Description] Add EFICombineImage module part for dGPU OPROM when CSM is Disabled.
[Files] EFICombineImage.c, EFICombineImage.mak, EFICombineImage.sdl, EFICombineImage.cif.
General Bug Fixes and EIP Addressed in this Label:
[TAG] EIP107188
[Category] Important
[Severity] Important
[Description] USB 3.0 port can't work when RTD3 is Enabled in setup menu.
[Files] Acpiplatform.c, Acpiplatform.mak, Acpiplatform.sd, Acpiplatform.uni.
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-01-15
Source Control Label: 4.6.5.3_PF-ACPI_RC_090_020
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_090_025
omponent Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 0.9.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 0.9.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] EIP109757
[Category] Important
[Severity] Important
[Description] Update Shark Bay Client ACPI Reference Code Beta Version 0.9.0.
[TAG] None
[Category] Normal
[Severity] Normal
[Description] Add setup item and setting for DPTF.
[Files] Acpiplatform.c, Acpiplatform.sd, Acpiplatform.uni, PlatformSetup.h.
[TAG] None
[Category] Normal
[Severity] Normal
[Description] Update to support Haswell C0 and ULT C1 setup info.
[Files] PlatformSetupInfo.c, PlatformSetupInfo.h
General Bug Fixes and EIP Addressed in this Label:
NON
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-01-18
Source Control Label: 4.6.5.3_PF-ACPI_RC_090_020a
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_090_025
omponent Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 0.9.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 0.9.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] None
[Category] Normal
[Severity] Normal
[Description] Fixed build error that when update ACPI RC to 090 and "IntelPTT_SUPPORT" = 1.
[Files] Acpiplatform.c.
[TAG] None
[Category] Normal
[Severity] Normal
[Description] Fixed that Setup menu shows incorrect CPU informaion for C0 stepping.
[Files] PlatformSetupInfo.c.
General Bug Fixes and EIP Addressed in this Label:
NON
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-01-29
Source Control Label: 4.6.5.3_PF-ACPI_RC_100_021
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
None
omponent Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.0.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.0.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] EIP113555
[Category] Important
[Severity] Important
[Description] Update Shark Bay Client ACPI Reference Code Beta Version 1.0.0
General Bug Fixes and EIP Addressed in this Label:
NON
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-02-01
Source Control Label: 4.6.5.3_PF-ACPI_RC_100_021a
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
None
omponent Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.0.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.0.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] None
[Category] Important
[Severity] Important
[Description] Fixed that DPPM-06 test item can't be passed.

[Files] Acpiplatform.sd.

General Bug Fixes and EIP Addressed in this Label:
NON
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_090_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-02-15
Source Control Label: 4.6.5.3_PF-ACPI_RC_100_022
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
None
omponent Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.0.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.0.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] None
[Category] Important
[Severity] Important
[Description] Fixed that DPPM-06 test item can't be passed.

[Files] Acpiplatform.sd.

General Bug Fixes and EIP Addressed in this Label:
NON
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-02-21
Source Control Label: 4.6.5.3_PF-ACPI_RC_110_022a
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
None
omponent Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.0.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.0.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] EIP114876
[Category] Normal
[Severity] Normal
[Description] To close Readytoboot event-function : CallbackBootScript
[Files] Acpiplatform.c.

General Bug Fixes and EIP Addressed in this Label:
NON
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-02-25
Source Control Label: 4.6.5.3_PF-ACPI_RC_120_023
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
None
omponent Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.2.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.2.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] EIP115947
[Category] Important
[Severity] Important
[Description] Update Shark Bay Client ACPI Reference Code Beta Version 1.2.0

General Bug Fixes and EIP Addressed in this Label:
NON
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2012-02-26
Source Control Label: 4.6.5.3_PF-ACPI_RC_120_024
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
None
omponent Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.2.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.2.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] None
[Category] Normal
[Severity] Normal
[Description] Fixed build error when CRB EC module is removed.
[Files] PlatformEC.asl.

General Bug Fixes and EIP Addressed in this Label:
NON
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-03-15
Source Control Label: 4.6.5.3_PF-ACPI_RC_130_025
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_130_027
omponent Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.3.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.3.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] EIP118120

[Category] Important

[Severity] Important

[Description] Update Shark Bay Client ACPI Reference Code Beta Version 1.3.0

[TAG] EIP115617

[Category] Normal

[Severity] Normal

[Description] Fixed the system has abnormal event when wake from lan

[Files] Gpe.asl, PchPcie.asl

[TAG] None

[Category] Normal

[Severity] Normal

[Description] Add PCH Lan version information.

[Files] PlatformSetupInfo.c, PlatformSetupInfo.h.

[TAG] None

[Category] Normal

[Severity] Normal

[Description] Add a "Remove_SaSsdt_Data_To_Dsdt" token, it can remove related Sa Ssdt acpi data to Dsdt.

[Files] PlatformExternal.asl, Acpiplatform.c, EC.asl, GloblNvs.asl, Gpe.asl, Video.asl.

General Bug Fixes and EIP Addressed in this Label:
NON
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-03-18
Source Control Label: 4.6.5.3_PF-ACPI_RC_130_025a
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_130_027
omponent Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.3.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.3.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] None

[Category] Important

[Severity] Important

[Description] Fixed CPU C-state is no function.

[Files] CPU.asl

[TAG] None

[Category] Normal

[Severity] Normal

[Description] Fixed build error when CRB EC module is Disabled or Removed.

[Files] Platform.asl, PlatformEC.asl.

General Bug Fixes and EIP Addressed in this Label:
NON
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-03-21
Source Control Label: 4.6.5.3_PF-ACPI_RC_130_025b
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_130_027
omponent Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.3.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.3.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] None

[Category] Important

[Severity] Important

[Description] Fixed build error when Remove_SaSsdt_Data_To_Dsdt = 1.

[Files] Platform.asl

[TAG] None

[Category] Normal

[Severity] Normal

[Description] Added PINI() under PCI0 _INI method for thunderbolt function.

[Files] Platform.asl.

General Bug Fixes and EIP Addressed in this Label:
NON
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-03-26
Source Control Label: 4.6.5.3_PF-ACPI_RC_130_026
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_131_031b
omponent Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.3.1.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.3.1.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] EIP119125
[Category] Important
[Severity] Important
[Description] Update Shark Bay Client ACPI Reference Code Beta Version 1.3.1

General Bug Fixes and EIP Addressed in this Label:
NON
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-04-08
Source Control Label: 4.6.5.3_PF-ACPI_RC_140_027
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_140_032
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_140_028
omponent Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.4.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.4.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] EIP120160
[Category] Important
[Severity] Important
[Description] Update Shark Bay Client ACPI Reference Code Beta Version 1.4.0

General Bug Fixes and EIP Addressed in this Label:
NON
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-04-24
Source Control Label: 4.6.5.3_PF-ACPI_RC_140_027a
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_140_035b
omponent Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.4.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.4.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] EIP121262
[Category] Important
[Severity] Important
[Description] When doing a WOL on Sharkbay systems with any add-on NIC,the system will wake and the BIOS will hand
off to the OS, but windows will BSOD with 0x9F (DRIVER_POWER_FAILURE)pointing to a variety of device drivers.
[Files] Gpe.asl

[TAG] None
[Category] Normal
[Severity] Normal
[Description] Change "Native PCIE Enable" and "Native ASPM" to Enabled as default.
[Files] AcpiPlatform.sd

General Bug Fixes and EIP Addressed in this Label:
NON
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-05-14
Source Control Label: 4.6.5.3_PF-ACPI_RC_150_028
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
omponent Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.5.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.5.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] EIP123497
[Category] Important
[Severity] Important
[Description] Update Shark Bay Client ACPI Reference Code Beta Version 1.5.0

General Bug Fixes and EIP Addressed in this Label:
NON
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-05-16
Source Control Label: 4.6.5.3_PF-ACPI_RC_150_028a
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
omponent Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
PlatformDock.asl | Intel Platform ACPI Sample Driver.
PlatformExternal.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.5.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.5.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] None
[Category] Normal
[Severity] Normal
[Description] Correctly update ACPI RC version to 1.5
[Files] AcpiInfo.h

[TAG] None
[Category] Normal
[Severity] Normal
[Description] Define Token "ACPI_ASL_COMPILER" value = "$(AcpiPlatform_DIR)\iasl.exe"
[Files] AcpiPlatform.sdl
General Bug Fixes and EIP Addressed in this Label:
NON
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-06-04
Source Control Label: 4.6.5.3_PF-ACPI_RC_150_028b
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.5.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.5.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] None
[Category] Improvement
[Severity] Minor
[Description] Change IASL compiler path to $(ACPIPLATFORM_ASL_COMPILER) in SharkBay project.
[Files] SsdtAcpiDebug.mak, SsdtSensorHub.mak, SsdtRtd3.mak, SsdtZpOddULT.mak, SsdtPtid.mak

[TAG] None
[Category] Improvement
[Severity] Normal
[Description] Follow Intel CRB BIOS v126 to Re-modify ZPODD asl for SharkBay ULT CRB.
[Files] SsdtZpOddULT.asl

[TAG] None
[Category] Improvement
[Severity] Normal
[Description] Follow Intel CRB BIOS v126 to set default configuraton setting of RTD3 devices.
[Files] AcpiPlatform.c, AcpiPlatform.sd, AcpiPlatform.uni

[TAG] None
[Category] Bug Fix
[Severity] Normal
[Symptom] UEFI_231C_SCT_Final_Draft_201303 test failed.
[RootCause] The variable use illegal variable guid.
[Solution] Change GUID form EFI_GLOBAL_VARIABLE to AMI_GLOBAL_VARIABLE_GUID.
[Files] PlatformSetupInfo.c
General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
After updating RC to 1.5, it has below issues. And it is related to XHC asl of RTD3.
1. It has yellow bang on USB XHCI device on WIN7 32 OS, and the system hangs up after resume from S4.
2. The system hangs up with black screen after resume from S4 on WIN7 64 OS.
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-06-21
Source Control Label: 4.6.5.3_PF-ACPI_RC_160_029
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_160_039
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] EIP127190
[Category] Important
[Severity] Important
[Description] Update Shark Bay Client ACPI Reference Code Beta Version 1.6.0

General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-06-24
Source Control Label: 4.6.5.3_PF-ACPI_RC_160_029a
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_160_039
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] EIP127217
[Category] Important
[Severity] Important
[Description] Sharkbay ULT GPIO event ASL method doesn't been configured properly.
[Files] Gpe.asl

General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-06-25
Source Control Label: 4.6.5.3_PF-ACPI_RC_160_029b
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_160_039
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] None
[Category] Normal
[Severity] Normal
[Description] Fixed build error when CRB EC is removed.
[Files] PlatformEC.asl
General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_160_029b
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-06-28
Source Control Label: 4.6.5.3_PF-ACPI_RC_160_029c
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_160_039
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.0.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] None
[Category] Important
[Severity] Important
[Description] Fixed that Processors device are disappeared under OS device manager.
[Files] AcpiPlatform.c, AcpiPlatform.h
General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_160_029c
4.6.5.3_PF-ACPI_RC_160_029b
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-07-15
Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_161_040
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.1.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.1.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] EIP129086
[Category] Important
[Severity] Important
[Description] Update Shark Bay Client ACPI Reference Code Beta Version 1.6.1.

General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_161_030
4.6.5.3_PF-ACPI_RC_160_029c
4.6.5.3_PF-ACPI_RC_160_029b
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-07-16
Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030a
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_161_040
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_032a
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.1.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.1.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] EIP125350
[Category] Normal
[Severity] Normal
[Description] System BIOS Support for the Hardware Button for Windows* 8.1 - Rev.0.5
[Files] AcpiPlatform.c, AcpiPlatform.sd, AcpiPlatform.uni

[TAG] EIP127540
[Category] Normal
[Severity] Normal
[Description] Windows* 8.1 Micro-PEP (uPEP) ASL Support Version 0.5
[Files] AcpiPlatform.c, AcpiPlatform.h

General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_161_030a
4.6.5.3_PF-ACPI_RC_161_030
4.6.5.3_PF-ACPI_RC_160_029c
4.6.5.3_PF-ACPI_RC_160_029b
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-08-02
Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030c
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_161_040
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_032a
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.1.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.1.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] None
[Category] Normal
[Severity] Normal
[Description] Reconfigure "PWRB" device asl and PS2 KB/MOUSE definition.
[Files] AmiBoardInfo.mak, AcpiAslWrap.sdl, AcpiAsl.sdl

[TAG] None
[Category] Normal
[Severity] Normal
[Description] Update to support Haswell ULT D0 setup info.
[Files] PlatformSetupInfo.c

General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_161_030c
4.6.5.3_PF-ACPI_RC_161_030a
4.6.5.3_PF-ACPI_RC_161_030
4.6.5.3_PF-ACPI_RC_160_029c
4.6.5.3_PF-ACPI_RC_160_029b
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-08-22
Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030d
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_161_040d
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_032a
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.1.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.1.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
[TAG] None
[Category] Important
[Description] Modify for the delete of SIO in MB platform
[Files] AcpiAsl.sdl

General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_161_030d
4.6.5.3_PF-ACPI_RC_161_030c
4.6.5.3_PF-ACPI_RC_161_030a
4.6.5.3_PF-ACPI_RC_161_030
4.6.5.3_PF-ACPI_RC_160_029c
4.6.5.3_PF-ACPI_RC_160_029b
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-08-23
Source Control Label: 4.6.5.3_PF-ACPI_RC_162_031
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_162_041
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_162_033
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.2.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.2.
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_162_031
4.6.5.3_PF-ACPI_RC_161_030d
4.6.5.3_PF-ACPI_RC_161_030c
4.6.5.3_PF-ACPI_RC_161_030a
4.6.5.3_PF-ACPI_RC_161_030
4.6.5.3_PF-ACPI_RC_160_029c
4.6.5.3_PF-ACPI_RC_160_029b
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-09-18
Source Control Label: 4.6.5.3_PF-ACPI_RC_162_031a
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_162_041
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_162_033
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.2.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.2.
Files changed in the Reference or 3rd Party Code:
AcpiPlatform.c,AcpiPlatform.h
[TAG] EIP136411
[Category] Improvement
[Description] Support MWAIT LPI State Descriptor[1].
New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_162_031a
4.6.5.3_PF-ACPI_RC_162_031
4.6.5.3_PF-ACPI_RC_161_030d
4.6.5.3_PF-ACPI_RC_161_030c
4.6.5.3_PF-ACPI_RC_161_030a
4.6.5.3_PF-ACPI_RC_161_030
4.6.5.3_PF-ACPI_RC_160_029c
4.6.5.3_PF-ACPI_RC_160_029b
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-09-27
Source Control Label: 4.6.5.3_PF-ACPI_RC_162_031b
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_162_041
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_162_033
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
ModulePart Name: lpit
ModulePart Description: lpit.
Filename | Description
lpit.cif | ModulePart lpit of CIF.
lpit.sdl | ModulePart lpit of sdl.
lpit.mak | ModulePart lpit of mak.
lpit.h | ModulePart lpit of h.
lpit.act | ModulePart lpit of act.
LowPowerIdleTable.h | ModulePart LowPowerIdleTable of h.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.2.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.2.
Files changed in the Reference or 3rd Party Code:
AcpiPlatform.c,AcpiPlatform.h
[TAG] EIP137454
[Category] New Feature
[Description] Follow Intel sample code to add LPIT table.
New features added in this label:
Follow Intel sample code to add LPIT table.
FILE:LowPowerIdleTable.h,lpit.act,lpit.h,lpit.mak,lpit.sdl

General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_162_031b
4.6.5.3_PF-ACPI_RC_162_031a
4.6.5.3_PF-ACPI_RC_162_031
4.6.5.3_PF-ACPI_RC_161_030d
4.6.5.3_PF-ACPI_RC_161_030c
4.6.5.3_PF-ACPI_RC_161_030a
4.6.5.3_PF-ACPI_RC_161_030
4.6.5.3_PF-ACPI_RC_160_029c
4.6.5.3_PF-ACPI_RC_160_029b
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-10-22
Source Control Label: 4.6.5.3_PF-ACPI_RC_162_031c
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_162_041
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_162_033
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
ModulePart Name: lpit
ModulePart Description: lpit.
Filename | Description
lpit.cif | ModulePart lpit of CIF.
lpit.sdl | ModulePart lpit of sdl.
lpit.mak | ModulePart lpit of mak.
lpit.h | ModulePart lpit of h.
lpit.act | ModulePart lpit of act.
LowPowerIdleTable.h | ModulePart LowPowerIdleTable of h.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-03
Visual eBios: RSS.5.73.0243, Dated: 2013-03
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.2.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.6.2.
Files changed in the Reference or 3rd Party Code:
Gpe.asl
[TAG] EIP138196
[Category] Improvement
[Description] customized GPE event in Intel RC Gpe.asl should can be enable or disable according OEM requirement.
for example, _L1E event in Gpe.asl is for CRB EC, it may not need for OEM.
CRB always report this GPE event, it might cause unexpected side effect on OEM platform
SsdtZpOdd.mak
[TAG] None
[Category] Improvement
[Description] The token "INTEL_ZPODDULT_ASL_FILE" is no function in makefile, modify to the correct command.
New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_162_031b
4.6.5.3_PF-ACPI_RC_162_031a
4.6.5.3_PF-ACPI_RC_162_031
4.6.5.3_PF-ACPI_RC_161_030d
4.6.5.3_PF-ACPI_RC_161_030c
4.6.5.3_PF-ACPI_RC_161_030a
4.6.5.3_PF-ACPI_RC_161_030
4.6.5.3_PF-ACPI_RC_160_029c
4.6.5.3_PF-ACPI_RC_160_029b
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-11-07
Source Control Label: 4.6.5.3_PF-ACPI_RC_170_032
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_162_041
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_162_033
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
ModulePart Name: lpit
ModulePart Description: lpit.
Filename | Description
lpit.cif | ModulePart lpit of CIF.
lpit.sdl | ModulePart lpit of sdl.
lpit.mak | ModulePart lpit of mak.
lpit.h | ModulePart lpit of h.
lpit.act | ModulePart lpit of act.
LowPowerIdleTable.h | ModulePart LowPowerIdleTable of h.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-03
Visual eBios: RSS.5.73.0243, Dated: 2013-03
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.7.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.7.0.
Files changed in the Reference or 3rd Party Code:
New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_162_031c
4.6.5.3_PF-ACPI_RC_162_031b
4.6.5.3_PF-ACPI_RC_162_031a
4.6.5.3_PF-ACPI_RC_162_031
4.6.5.3_PF-ACPI_RC_161_030d
4.6.5.3_PF-ACPI_RC_161_030c
4.6.5.3_PF-ACPI_RC_161_030a
4.6.5.3_PF-ACPI_RC_161_030
4.6.5.3_PF-ACPI_RC_160_029c
4.6.5.3_PF-ACPI_RC_160_029b
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2013-11-14
Source Control Label: 4.6.5.3_PF-ACPI_RC_170_032a
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_162_041
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_162_033
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
ModulePart Name: lpit
ModulePart Description: lpit.
Filename | Description
lpit.cif | ModulePart lpit of CIF.
lpit.sdl | ModulePart lpit of sdl.
lpit.mak | ModulePart lpit of mak.
lpit.h | ModulePart lpit of h.
lpit.act | ModulePart lpit of act.
LowPowerIdleTable.h | ModulePart LowPowerIdleTable of h.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-03
Visual eBios: RSS.5.73.0243, Dated: 2013-03
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.7.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.7.0.
Files changed in the Reference or 3rd Party Code:
New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] None
[Category] Improvement
[Description] Add judgement for returninig capabilities.
[Files] Platform.asl

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_170_032
4.6.5.3_PF-ACPI_RC_162_031c
4.6.5.3_PF-ACPI_RC_162_031b
4.6.5.3_PF-ACPI_RC_162_031a
4.6.5.3_PF-ACPI_RC_162_031
4.6.5.3_PF-ACPI_RC_161_030d
4.6.5.3_PF-ACPI_RC_161_030c
4.6.5.3_PF-ACPI_RC_161_030a
4.6.5.3_PF-ACPI_RC_161_030
4.6.5.3_PF-ACPI_RC_160_029c
4.6.5.3_PF-ACPI_RC_160_029b
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2014-03-14
Source Control Label: 4.6.5.3_PF-ACPI_RC_180_033
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_180_046
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_180_036
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
ModulePart Name: lpit
ModulePart Description: lpit.
Filename | Description
lpit.cif | ModulePart lpit of CIF.
lpit.sdl | ModulePart lpit of sdl.
lpit.mak | ModulePart lpit of mak.
lpit.h | ModulePart lpit of h.
lpit.act | ModulePart lpit of act.
LowPowerIdleTable.h | ModulePart LowPowerIdleTable of h.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-03
Visual eBios: RSS.5.73.0243, Dated: 2013-03
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.8.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.8.0.
Files changed in the Reference or 3rd Party Code:
New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] 158786
[Category] Spec Update
[Description] [ACPI] Shark Bay-M/DT Reference Code Production Version 1.8.0
[Files] *.*

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_170_032a
4.6.5.3_PF-ACPI_RC_170_032
4.6.5.3_PF-ACPI_RC_162_031c
4.6.5.3_PF-ACPI_RC_162_031b
4.6.5.3_PF-ACPI_RC_162_031a
4.6.5.3_PF-ACPI_RC_162_031
4.6.5.3_PF-ACPI_RC_161_030d
4.6.5.3_PF-ACPI_RC_161_030c
4.6.5.3_PF-ACPI_RC_161_030a
4.6.5.3_PF-ACPI_RC_161_030
4.6.5.3_PF-ACPI_RC_160_029c
4.6.5.3_PF-ACPI_RC_160_029b
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2014-04-23
Source Control Label: 4.6.5.3_PF-ACPI_RC_180_033a
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_180_046
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_180_036
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
ModulePart Name: lpit
ModulePart Description: lpit.
Filename | Description
lpit.cif | ModulePart lpit of CIF.
lpit.sdl | ModulePart lpit of sdl.
lpit.mak | ModulePart lpit of mak.
lpit.h | ModulePart lpit of h.
lpit.act | ModulePart lpit of act.
LowPowerIdleTable.h | ModulePart LowPowerIdleTable of h.
ModulePart Name: SsdtIRMT
ModulePart Description: SsdtIRMT.
Filename | Description
SsdtIRMT.cif | ModulePart SsdtIRMT of CIF.
SsdtIRMT.sdl | ModulePart SsdtIRMT of sdl.
SsdtIRMT.mak | ModulePart SsdtIRMT of mak.
SsdtIRMT.asl | SsdtIRMT SSDT support
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-03
Visual eBios: RSS.5.73.0243, Dated: 2013-03
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.8.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.8.0.
Files changed in the Reference or 3rd Party Code:
New features added in this label:
[TAG] 161825
[Category] New Feature
[Description] Intel Ready Mode (Never Sleep) ASL code implementation
[Files] GlobalNvsArea.h,GloblNvs.asl,AcpiPlatform.c,AcpiPlatform.cif,AcpiPlatform.h,AcpiPlatform.sd,AcpiPlatform.uni,SsdtIRMT/*.*

General Bug Fixes and EIP Addressed in this Label:
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_180_033
4.6.5.3_PF-ACPI_RC_170_032a
4.6.5.3_PF-ACPI_RC_170_032
4.6.5.3_PF-ACPI_RC_162_031c
4.6.5.3_PF-ACPI_RC_162_031b
4.6.5.3_PF-ACPI_RC_162_031a
4.6.5.3_PF-ACPI_RC_162_031
4.6.5.3_PF-ACPI_RC_161_030d
4.6.5.3_PF-ACPI_RC_161_030c
4.6.5.3_PF-ACPI_RC_161_030a
4.6.5.3_PF-ACPI_RC_161_030
4.6.5.3_PF-ACPI_RC_160_029c
4.6.5.3_PF-ACPI_RC_160_029b
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2014-05-20
Source Control Label: 4.6.5.3_PF-ACPI_RC_180_033b
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_180_048
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_180_036
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
ModulePart Name: lpit
ModulePart Description: lpit.
Filename | Description
lpit.cif | ModulePart lpit of CIF.
lpit.sdl | ModulePart lpit of sdl.
lpit.mak | ModulePart lpit of mak.
lpit.h | ModulePart lpit of h.
lpit.act | ModulePart lpit of act.
LowPowerIdleTable.h | ModulePart LowPowerIdleTable of h.
ModulePart Name: SsdtIRMT
ModulePart Description: SsdtIRMT.
Filename | Description
SsdtIRMT.cif | ModulePart SsdtIRMT of CIF.
SsdtIRMT.sdl | ModulePart SsdtIRMT of sdl.
SsdtIRMT.mak | ModulePart SsdtIRMT of mak.
SsdtIRMT.asl | SsdtIRMT SSDT support
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-03
Visual eBios: RSS.5.73.0243, Dated: 2013-03
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.8.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.8.0.
Files changed in the Reference or 3rd Party Code:
New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
[TAG] 152211
[Category] Bug Fix
[Severity] Important
[Symptom] (WHCK) PC Resume Test fail
[RootCause] The definition of _DEP method
[Solution] Remove the _DEP method when CRB_EC_SUPPORT disable.
[TAG] EIP167036
[Category] Improvement
[Description] review the attributes of variable.
[Files] AcpiPlatform.c,AcpiPlatform.h,AcpiPlatform.sd
[TAG] None
[Category] Improvement
[Description] Update for Thunderbolt feature.
[Files] Gpe.asl
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_180_033a
4.6.5.3_PF-ACPI_RC_180_033
4.6.5.3_PF-ACPI_RC_170_032a
4.6.5.3_PF-ACPI_RC_170_032
4.6.5.3_PF-ACPI_RC_162_031c
4.6.5.3_PF-ACPI_RC_162_031b
4.6.5.3_PF-ACPI_RC_162_031a
4.6.5.3_PF-ACPI_RC_162_031
4.6.5.3_PF-ACPI_RC_161_030d
4.6.5.3_PF-ACPI_RC_161_030c
4.6.5.3_PF-ACPI_RC_161_030a
4.6.5.3_PF-ACPI_RC_161_030
4.6.5.3_PF-ACPI_RC_160_029c
4.6.5.3_PF-ACPI_RC_160_029b
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2014-07-11
Source Control Label: 4.6.5.3_PF-ACPI_RC_180_033c
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_180_048
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_180_036
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
ModulePart Name: lpit
ModulePart Description: lpit.
Filename | Description
lpit.cif | ModulePart lpit of CIF.
lpit.sdl | ModulePart lpit of sdl.
lpit.mak | ModulePart lpit of mak.
lpit.h | ModulePart lpit of h.
lpit.act | ModulePart lpit of act.
LowPowerIdleTable.h | ModulePart LowPowerIdleTable of h.
ModulePart Name: SsdtIRMT
ModulePart Description: SsdtIRMT.
Filename | Description
SsdtIRMT.cif | ModulePart SsdtIRMT of CIF.
SsdtIRMT.sdl | ModulePart SsdtIRMT of sdl.
SsdtIRMT.mak | ModulePart SsdtIRMT of mak.
SsdtIRMT.asl | SsdtIRMT SSDT support
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-03
Visual eBios: RSS.5.73.0243, Dated: 2013-03
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.8.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.8.0.
Files changed in the Reference or 3rd Party Code:
New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
[TAG] None
[Category] Improvement
[Description] Support Debug Port Table.
[Files] AcpiPlatform.c,AcpiPlatform.h
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_180_033b
4.6.5.3_PF-ACPI_RC_180_033a
4.6.5.3_PF-ACPI_RC_180_033
4.6.5.3_PF-ACPI_RC_170_032a
4.6.5.3_PF-ACPI_RC_170_032
4.6.5.3_PF-ACPI_RC_162_031c
4.6.5.3_PF-ACPI_RC_162_031b
4.6.5.3_PF-ACPI_RC_162_031a
4.6.5.3_PF-ACPI_RC_162_031
4.6.5.3_PF-ACPI_RC_161_030d
4.6.5.3_PF-ACPI_RC_161_030c
4.6.5.3_PF-ACPI_RC_161_030a
4.6.5.3_PF-ACPI_RC_161_030
4.6.5.3_PF-ACPI_RC_160_029c
4.6.5.3_PF-ACPI_RC_160_029b
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2012 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.


Component Information:
Component Title: Platform
Component Reference Name: Platform
Component Type: eModule
Release Date: 2014-12-02
Source Control Label: 4.6.5.3_PF-ACPI_RC_190_034
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;
Dependencies
Component Dependencies
Dependent Component Title: Intel PCH
Dependent Component Reference Name: Intel PCH
Dependent Source Control Label: 4.6.5.3_Intel_LPT-RC_180_048
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_180_036
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
AcpiPlatform.cif | Intel Platform Acpi of ModulePart.
ReleaseNotes.chm | Intel Platform Acpi eModule of CHM
AcpiPlatformPei.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformPei.dxs | This file is the dependency file for the Platform Acpi Pei driver.
AcpiPlatform.c | Installs EFI_GLOBAL_NVS_AREA_PROTOCOL_GUID.
AcpiPlatformCspLib.c | This file will be build in CSP LIB.
AcpiPlatform.dxs | This file is the dependency file for the Platform Acpi driver.
AcpiPlatformSmi.c | This file contains code for all AcpiPlatform SMI events.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatformSmi.dxs | This file is the dependency file for the Platform Acpi Smi driver.
AcpiPlatform.mak | This make file components and link them to respective binary.
AcpiPlatform.h | AcpiPlatform header file, define all the AcpiPlatform module specific equates and structures in this file.
AcpiPlatform.sd | AcpiPlatform setup form.
AcpiPlatform.uni | AcpiPlatform setup string definitions.
PlatformSetup.h | AcpiPlatform Specific Setup Variables and Structures.
AcpiIntelRC.h | AcpiPlatform header file, Change ASL name.

ModulePart Name: Platform Info
ModulePart Description: Platform Info
Filename | Description
PlatformInfo.cif | ModulePart Platform Info of CIF.
PlatformInfo.sdl | ModulePart Platform Info of SDL.
PlatformInfo.mak | ModulePart Platform Info of MAK.
PlatformInfo.dxs | ModulePart Platform Info of DSX.
PlatformInfo.c | Installs EFI_PLATFORM_INFO_PROTOCOL_GUID.
PlatformInfo.h | Define the Platform Info specific equates and structures in this file.
ModulePart Name: AcpiAsl
ModulePart Description: Acpi Asl.
Filename | Description
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.cif | ModulePart Acpi Asl of CIF.
AcpiAsl.sdl | ModulePart Acpi Asl of sdl.
AcpiAsl.mak | ModulePart Acpi Asl of mak.
*.asl | Intel Platform ACPI RefCode.
ModulePart Name: AcpiAslWrap
ModulePart Description: Acpi Asl Wrap.
Filename | Description
AcpiAslWrap.cif | ModulePart AcpiAslWrap of CIF.
AcpiAslWrap.sdl | ModulePart AcpiAslWrap of sdl.
PlatformPS2Wake.asl | Intel Platform ACPI Sample Driver.
PlatformEC.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: AcpiFvi
ModulePart Description: Acpi Fvi.
Filename | Description
AcpiFvi.cif | ModulePart AcpiFvi of CIF.
AcpiFvi.sdl | ModulePart AcpiFvi of sdl.
AcpiFvi.mak | ModulePart AcpiFvi of mak.
AcpiFvi.c | Intel Platform ACPI Sample Driver.
AcpiFvi.h | Intel Platform ACPI Sample Driver.
AcpiFvi.dxs | Intel Platform ACPI Sample Driver.
AcpiFvi.inf | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtAcpiDebug
ModulePart Description: SsdtAcpiDebug.
Filename | Description
SsdtAcpiDebug.cif | ModulePart SsdtAcpiDebug of CIF.
SsdtAcpiDebug.sdl | ModulePart SsdtAcpiDebug of sdl.
SsdtAcpiDebug.mak | ModulePart SsdtAcpiDebug of mak.
SsdtAcpiDebug.asl | AcpiDebug SSDT support
ModulePart Name: SsdtPtid
ModulePart Description: SsdtPtid.
Filename | Description
SsdtPtid.cif | ModulePart SsdtPtid of CIF.
SsdtPtid.sdl | ModulePart SsdtPtid of sdl.
SsdtPtid.mak | ModulePart SsdtPtid of mak.
Ptid.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtRtd3
ModulePart Description: SsdtRtd3.
Filename | Description
SsdtRtd3.cif | ModulePart SsdtRtd3 of CIF.
SsdtRtd3.sdl | ModulePart SsdtRtd3 of sdl.
SsdtRtd3.mak | ModulePart SsdtRtd3 of mak.
Ult0Rtd3.asl | Intel Platform ACPI Sample Driver.
BRRtd3.asl | Intel Platform ACPI Sample Driver.
Rtd3FFRD.asl | Intel Platform ACPI Sample Driver.
RTD3Common.asl | Intel Platform ACPI Sample Driver.
RTD3Pcie.asl | Intel Platform ACPI Sample Driver.
ModulePart Name: SsdtZpOdd
ModulePart Description: SsdtZpOdd.
Filename | Description
SsdtZpOdd.cif | ModulePart SsdtZpOdd of CIF.
SsdtZpOdd.sdl | ModulePart SsdtZpOdd of sdl.
SsdtZpOdd.mak | ModulePart SsdtZpOdd of mak.
SsdtZpOdd.asl | SsdtZpOdd SSDT support
SsdtZpOddULT.asl | SsdtZpOddULT SSDT support
ModulePart Name: SsdtSensorHub
ModulePart Description: SsdtSensorHub.
Filename | Description
SsdtSensorHub.cif | ModulePart SsdtSensorHub of CIF.
SsdtSensorHub.sdl | ModulePart SsdtSensorHub of sdl.
SsdtSensorHub.mak | ModulePart SsdtSensorHub of mak.
SsdtSensorHub.asl | SsdtSensorHub SSDT support
ModulePart Name: AcpiProtocolLib
ModulePart Description: Acpi Protocol Lib.
Filename | Description
AcpiProtocolLib.cif | ModulePart AcpiProtocolLib of CIF.
AcpiProtocolLib.sdl | ModulePart AcpiProtocolLib of sdl.
AcpiProtocolLib.mak | ModulePart AcpiProtocolLib of mak.
AcpiProtocolLib.inf | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.c | Intel Platform ACPI Peripheral Driver.
AcpiPlatformPolicy\AcpiPlatformPolicy.h | Intel Platform ACPI Peripheral Driver.
AcpiInfo\AcpiInfo.c | Intel Platform ACPI Sample Driver.
AcpiInfo\AcpiInfo.h | Intel Platform ACPI Sample Driver.
ModulePart Name: SMBIOSUpdateData
ModulePart Description: SMBIOS Update Data.
Filename | Description
SMBIOSUpdateData.cif | ModulePart SMBIOSUpdateData of CIF.
SMBIOSUpdateData.sdl | ModulePart SMBIOSUpdateData of sdl.
SMBIOSUpdateData.mak | ModulePart SMBIOSUpdateData of mak.
SMBIOSUpdateData.dxs | ModulePart SMBIOSUpdateData of dxs.
SMBIOSUpdateData.c | SMBIOS update data.
SmbiosUpdateDataProtocol.h | SMBIOS update data protocol.
ModulePart Name: IntelPlatformInclude
ModulePart Description: Intel Platform Include.
Filename | Description
IntelPlatformInclude.cif | ModulePart IntelPlatformInclude of CIF.
IntelPlatformInclude.sdl | ModulePart IntelPlatformInclude of sdl.
ModulePart Name: IntelPlatformPpi
ModulePart Description: Intel Platform ppi.
Filename | Description
IntelPlatformPpi.cif | ModulePart IntelPlatformPpi of CIF.
IntelPlatformPpi.sdl | ModulePart IntelPlatformPpi of sdl.
TcgPeiDone.h | Intel Platform ACPI Sample Driver.
ModulePart Name: IntelPlatformProtocolLib
ModulePart Description: Intel Platform Protocol Lib.
Filename | Description
IntelPlatformProtocolLib.cif | ModulePart IntelPlatformProtocolLib of CIF.
IntelPlatformProtocolLib.sdl | ModulePart IntelPlatformProtocolLib of sdl.
IntelPlatformProtocolLib.mak | ModulePart IntelPlatformProtocolLib of mak.
Protocol\GlobalNvsArea\GlobalNvsArea.c | Intel Platform ACPI RefCode.
Protocol\GlobalNvsArea\GlobalNvsArea.h | Intel Platform ACPI RefCode.
ModulePart Name: DxeKscLib
ModulePart Description: DxeKscLib.
Filename | Description
DxeKscLib.cif | ModulePart DxeKscLib of CIF.
DxeKscLib.sdl | ModulePart DxeKscLib of sdl.
DxeKscLib.mak | ModulePart DxeKscLib of mak.
DxeKscLib.c | Intel Platform Sample Driver.
KscLib.h | Intel Platform Sample Driver.
ModulePart Name: IntelRefVerDisplay
ModulePart Description: IntelRefVerDisplay.
Filename | Description
IntelRefVerDisplay.cif | ModulePart IntelRefVerDisplay of CIF.
IntelRefVerDisplay.sdl | ModulePart IntelRefVerDisplay of sdl.
IntelRefVerDisplay.mak | ModulePart IntelRefVerDisplay of mak.
IntelRefVerDisplay.sd | Setup file for IntelRefVerDisplay driver. It displays the version of Intel RC Driver and its Version String in a form of Advanced tab of setup screen.
IntelRefVerDisplay.uni | String Definitions for Intel RC Version form.Some of the strings are dynamically updated getting the values from IntelRefVerSetup.c.
IntelRefVerSetup.c | Display the verison of Intel RC drivers.
ModulePart Name: PlatformSetupInfo
ModulePart Description: Platform Setup Info.
Filename | Description
PlatformSetupInfo.cif | ModulePart PlatformSetupInfo of CIF.
PlatformSetupInfo.sdl | ModulePart PlatformSetupInfo of sdl.
PlatformSetupInfo.mak | ModulePart PlatformSetupInfo of mak.
PlatformSetupInfo.sd | Setup file for PlatformSetupInfo driver. It displays the platform information and its Version String in a form of Main tab of setup screen.
PlatformSetupInfo.uni | String Definitions for PlatformSetupInfo form.Some of the strings are dynamically updated getting the values from PlatformSetupInfo.c.
PlatformSetupInfo.c | Display platform information.
PlatformSetupInfo.h | Header file for PlatformSetupInfo module.
ModulePart Name: FvOnFv2Thunk
ModulePart Description: This module produces FV on top of FV2.
Filename | Description
FvOnFv2Thunk.cif | ModulePart FvOnFv2Thunk of CIF.
FvOnFv2Thunk.sdl | ModulePart FvOnFv2Thunk of sdl.
FvOnFv2Thunk.mak | ModulePart FvOnFv2Thunk of mak.
FvOnFv2Thunk.dxs | ModulePart FvOnFv2Thunk of dxs.
FvOnFv2Thunk.c | This module produces FV on top of FV2.
ModulePart Name: FirmwareVerInfo
ModulePart Description: Firmware Version Information.
Filename | Description
FirmwareVerInfo.cif | ModulePart FirmwareVerInfo of CIF.
FirmwareVerInfo.sdl | ModulePart FirmwareVerInfo of sdl.
FirmwareVerInfo.mak | ModulePart FirmwareVerInfo of mak.
FirmwareVerInfo.dxs | ModulePart FirmwareVerInfo of dxs.
FirmwareVerInfo.c | Firmware Version Information.
ModulePart Name: EfiCombineImage
ModulePart Description: EfiCombineImage Information.
Filename | Description
EfiCombineImage.cif | ModulePart EfiCombineImage of CIF.
EfiCombineImage.sdl | ModulePart EfiCombineImage of sdl.
EfiCombineImage.mak | ModulePart EfiCombineImage of mak.
EfiCombineImage.c | dGPU OPROM support when CSM is Disabled.
ModulePart Name: lpit
ModulePart Description: lpit.
Filename | Description
lpit.cif | ModulePart lpit of CIF.
lpit.sdl | ModulePart lpit of sdl.
lpit.mak | ModulePart lpit of mak.
lpit.h | ModulePart lpit of h.
lpit.act | ModulePart lpit of act.
LowPowerIdleTable.h | ModulePart LowPowerIdleTable of h.
ModulePart Name: SsdtIRMT
ModulePart Description: SsdtIRMT.
Filename | Description
SsdtIRMT.cif | ModulePart SsdtIRMT of CIF.
SsdtIRMT.sdl | ModulePart SsdtIRMT of sdl.
SsdtIRMT.mak | ModulePart SsdtIRMT of mak.
SsdtIRMT.asl | SsdtIRMT SSDT support
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-03
Visual eBios: RSS.5.73.0243, Dated: 2013-03
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.9.0.
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: Update Shark Bay Client ACPI Reference Code Beta Version 1.9.0.
Files changed in the Reference or 3rd Party Code:
New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
[TAG] 194528
[Category] Spec Update
[Description] [ACPI] Shark Bay-M/DT Reference Code Production Version 1.9.0
[Files] *.*
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Limitation(s) with a Description
NONE
Remaining Issues:
NONE
Release History:
4.6.5.3_PF-ACPI_RC_180_033c
4.6.5.3_PF-ACPI_RC_180_033b
4.6.5.3_PF-ACPI_RC_180_033a
4.6.5.3_PF-ACPI_RC_180_033
4.6.5.3_PF-ACPI_RC_170_032a
4.6.5.3_PF-ACPI_RC_170_032
4.6.5.3_PF-ACPI_RC_162_031c
4.6.5.3_PF-ACPI_RC_162_031b
4.6.5.3_PF-ACPI_RC_162_031a
4.6.5.3_PF-ACPI_RC_162_031
4.6.5.3_PF-ACPI_RC_161_030d
4.6.5.3_PF-ACPI_RC_161_030c
4.6.5.3_PF-ACPI_RC_161_030a
4.6.5.3_PF-ACPI_RC_161_030
4.6.5.3_PF-ACPI_RC_160_029c
4.6.5.3_PF-ACPI_RC_160_029b
4.6.5.3_PF-ACPI_RC_160_029a
4.6.5.3_PF-ACPI_RC_160_029
4.6.5.3_PF-ACPI_RC_150_028b
4.6.5.3_PF-ACPI_RC_150_028a
4.6.5.3_PF-ACPI_RC_150_028
4.6.5.3_PF-ACPI_RC_140_027a
4.6.5.3_PF-ACPI_RC_140_027
4.6.5.3_PF-ACPI_RC_131_026
4.6.5.3_PF-ACPI_RC_130_025b
4.6.5.3_PF-ACPI_RC_130_025a
4.6.5.3_PF-ACPI_RC_130_025
4.6.5.3_PF-ACPI_RC_120_024
4.6.5.3_PF-ACPI_RC_120_023
4.6.5.3_PF-ACPI_RC_110_022a
4.6.5.3_PF-ACPI_RC_110_022
4.6.5.3_PF-ACPI_RC_100_021a
4.6.5.3_PF-ACPI_RC_100_021
4.6.5.3_PF-ACPI_RC_090_020a
4.6.5.3_PF-ACPI_RC_090_020
4.6.5.3_PF-ACPI_RC_081_019
4.6.5.3_PF-ACPI_RC_080_018
4.6.5.3_PF-ACPI_RC_080_017
4.6.5.3_PF-ACPI_RC_071_016
4.6.5.3_PF-ACPI_RC_071_015
4.6.5.3_PF-ACPI_RC_071_014
4.6.5.3_PF-ACPI_RC_070_013
4.6.5.3_PF-ACPI_RC_061_012
4.6.5.3_PF-ACPI_RC_061_011
4.6.5.3_PF-ACPI_RC_061_010


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

Built on 14:18:34 12/02/14


Functions in Alphabetical Order

AMIBIOS Function Reference

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

Built on 14:18:34 12/02/14


AMIBIOS Function Reference

General Information

Built on 14:18:34 12/02/14