American Megatrends, Inc.

ReleaseNotes

Copyright

Release Notes

© American Megatrends, Inc.


Release Notes - NDA Required

Component Information:

Component Title: Intel PCH

Component Reference Name: Intel PCH

Component Type: eChipset

Release Date: 2012-02-10

Source Control Label: 4.6.5.3_Intel_LPT-RC_050_000

Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN

Component Title: Intel Pch SB Chipset

Component Reference Name: Intel Pch SB Chipset

Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom110.BIN

Component Title: Intel Pch SB Chipset

Component Reference Name: Intel Pch SB Chipset

Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom115.BIN

Component Title: Intel Pch SB Chipset

Component Reference Name: Intel Pch SB Chipset

Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

Component Description:

Intel Platform Control Hub - Panther Point initialization.

This is a caption
Filename | Description
sbCSP.cif | Sample Description of CIF
ReleaseNotes.chm | Sample Description of C Code

ModulePart Name: Intel Pch SB Board

ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
SBSetup.cif | SBSetup Component Information.

ModulePart Name: SBSetup

ModulePart Description: South Bridge Setup Settings.

Filename | Description
SBSetup.sdl.CIF | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.

ModulePart Name: Intel Pch SB Chipset

ModulePart Description: Intel Pch SB Chipset Settings.

Filename | Description
SBGeneric.c | This file contains south bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | This file contains code for South Bridge initialization in the PEI stage.
SBDXE.c | This file contains code for South Bridge initialization in the DXE stage.
SBCspLib.h | This file contains South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | This file contains code for general Southbridge runtime protocol.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SATA1.ASL | SATA Controller#1 ASL file.
SATA0.ASL | SATA Controller#0 ASL file.
SB.ASL | The ASL file is for South Bridge specific function.
SataOrom110 | Intel RAID option ROM.

ModulePart Name: SB PPI

ModulePart Description: South Bridge PPI Definition.

Filename | Description
SBPPI.h | This header file contains the PPI definition for the SB.

ModulePart Name: SB Protocols

ModulePart Description: South Bridge Protocol Definition.

Filename | Description
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | The header file for I/O Trap SMM Dispatch Protocol.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures

ModulePart Name: SmmChildDispatcher

ModulePart Description: SMM Child Dispatcher settings.

Filename | Description
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | This file contains the dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | This file contains implementation of generic SMI handler functions.
SmiHandlerPorting.c | This file contains SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | This file contains SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.

ModulePart Name: SmmChildDispatcher2

ModulePart Description: SMM Child Dispatcher2 settings.

Filename | Description
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | This file contains the dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | This file contains implementation of generic SMI handler functions.
SmiHandlerPorting2.c | This file contains SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | This file contains SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.

ModulePart Name: SleepSmi

ModulePart Description: Sleep SMI settings.

Filename | Description
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.

ModulePart Name: SB SMI

ModulePart Description: SB SMI settings.

Filename | Description
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.

ModulePart Name: PchWrap

ModulePart Description: PCH Wrap settings.

Filename | Description
PchWrap.sdl | PCH wrap parameters.

ModulePart Name: PchSpiWrap

ModulePart Description: PCH SPI Wrap settings.

Filename | Description
PchWrap.sdl | PCH wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.

ModulePart Name: WdtAppDxe

ModulePart Description: WDT App Dxe settings.

Filename | Description
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | This file is the dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.

ModulePart Name: WdtAppPei

ModulePart Description: WDT App Pei settings.

Filename | Description
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.dxs | This file is the dependency file for the WDT App PEI.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.

ModulePart Name: WdtAppInclude

ModulePart Description: WDT App Include.

Filename | Description
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.sdl | WDT App Variable parameters.

ModulePart Name: WdtAppProtocolLib

ModulePart Description: WDT App Protocol Library.

Filename | Description
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.

ModulePart Name: PchSataDriver

ModulePart Description: PCH SATA UEFI Driver.

Filename | Description
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
PciHotPlug.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:

N0NE

AMI Build Tools:

Tools Label: 4.5.5_Tools_38, Dated: 2011/12/20

Visual eBios: RSS 5.72.0219, Dated: 2011/12/20

Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:

ITEM_TITLE: Intel Pch SB Refcode

Reference or 3rd Party Code updated in this Release:

ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:

FILEPATH\FILENAME.EXT - CHANGE NOTES

New features added in this label:

NONE

General Bug Fixes and EIP Addressed in this Label:

General Bug Fixes

None

EIP Addressed

None

Files Changed for General Bug Fixes and EIP Addressed in this Label:

General Bug Fixes

None

EIP Addressed

None

Known Limitations and Erratas in this label:

NONE

Remaining Issues:

NONE

Unit Testing:

NONE

Validation Testing:

DOCUMENT ANY BQA TESTING RESULTS

Release History:

LIST PREVIOUS LABEL AND RELEASE DATE AND DESCRIPTION

OR

Link to old Release Notes.htm files

© American Megatrends Inc.


Component Information:

Component Title: Intel PCH

Component Reference Name: Intel PCH

Component Type: eChipset

Release Date: 2012-02-20

Source Control Label: 4.6.5.3_Intel_LPT-RC_051_001

Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

N0NE

Non-Compiled BIN and LIB File(s) within this Component:

N0NE

Component Description:

Intel Platform Control Hub - Panther Point initialization.

This is a caption
Filename | Description
sbCSP.cif | Sample Description of CIF
ReleaseNotes.chm | Sample Description of C Code

ModulePart Name: Intel Pch SB Board

ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
SBSetup.cif | SBSetup Component Information.

ModulePart Name: SBSetup

ModulePart Description: South Bridge Setup Settings.

Filename | Description
SBSetup.sdl.CIF | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.

ModulePart Name: Intel Pch SB Chipset

ModulePart Description: Intel Pch SB Chipset Settings.

Filename | Description
SBGeneric.c | This file contains south bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | This file contains code for South Bridge initialization in the PEI stage.
SBDXE.c | This file contains code for South Bridge initialization in the DXE stage.
SBCspLib.h | This file contains South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | This file contains code for general Southbridge runtime protocol.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SATA1.ASL | SATA Controller#1 ASL file.
SATA0.ASL | SATA Controller#0 ASL file.
SB.ASL | The ASL file is for South Bridge specific function.
SataOrom110 | Intel RAID option ROM.

ModulePart Name: SB PPI

ModulePart Description: South Bridge PPI Definition.

Filename | Description
SBPPI.h | This header file contains the PPI definition for the SB.

ModulePart Name: SB Protocols

ModulePart Description: South Bridge Protocol Definition.

Filename | Description
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | The header file for I/O Trap SMM Dispatch Protocol.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures

ModulePart Name: SmmChildDispatcher

ModulePart Description: SMM Child Dispatcher settings.

Filename | Description
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | This file contains the dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | This file contains implementation of generic SMI handler functions.
SmiHandlerPorting.c | This file contains SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | This file contains SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.

ModulePart Name: SmmChildDispatcher2

ModulePart Description: SMM Child Dispatcher2 settings.

Filename | Description
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | This file contains the dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | This file contains implementation of generic SMI handler functions.
SmiHandlerPorting2.c | This file contains SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | This file contains SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.

ModulePart Name: SleepSmi

ModulePart Description: Sleep SMI settings.

Filename | Description
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.

ModulePart Name: SB SMI

ModulePart Description: SB SMI settings.

Filename | Description
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.

ModulePart Name: PchWrap

ModulePart Description: PCH Wrap settings.

Filename | Description
PchWrap.sdl | PCH wrap parameters.

ModulePart Name: PchSpiWrap

ModulePart Description: PCH SPI Wrap settings.

Filename | Description
PchWrap.sdl | PCH wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.

ModulePart Name: WdtAppDxe

ModulePart Description: WDT App Dxe settings.

Filename | Description
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | This file is the dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.

ModulePart Name: WdtAppPei

ModulePart Description: WDT App Pei settings.

Filename | Description
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.dxs | This file is the dependency file for the WDT App PEI.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.

ModulePart Name: WdtAppInclude

ModulePart Description: WDT App Include.

Filename | Description
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.sdl | WDT App Variable parameters.

ModulePart Name: WdtAppProtocolLib

ModulePart Description: WDT App Protocol Library.

Filename | Description
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.

ModulePart Name: PchSataDriver

ModulePart Description: PCH SATA UEFI Driver.

Filename | Description
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
PciHotPlug.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:

N0NE

AMI Build Tools:

Tools Label: 4.5.5_Tools_38, Dated: 2011/12/20

Visual eBios: RSS 5.72.0219, Dated: 2011/12/20

Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:

ITEM_TITLE: Intel Pch SB Refcode(FrameworkLPT_0_5_1_HSW_Post.zip)

Reference or 3rd Party Code updated in this Release:

ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:

FILEPATH\FILENAME.EXT - CHANGE NOTES

New features added in this label:

NONE

General Bug Fixes and EIP Addressed in this Label:

General Bug Fixes

None

EIP Addressed

None

Files Changed for General Bug Fixes and EIP Addressed in this Label:

General Bug Fixes

[TAG] None

[Category] Improvement

[Description] Fill in a temp value for token "USB_PORTS_LENGTH".

[Files] SB.sdl

[TAG] None

[Category] Improvement

[Description] Update PCH divice IDs by LPT RefCode rev.0.5.1.

[Files] SBSetup.c

EIP Addressed

[TAG] EIP83510

[Category] Spec Update

[Severity] Minor

[Description] Updated Intel LPT RC v0.5.1.

Known Limitations and Erratas in this label:

NONE

Remaining Issues:

NONE

Unit Testing:

NONE

Validation Testing:

DOCUMENT ANY BQA TESTING RESULTS

Release History:

4.6.5.3_Intel_LPT-RC_050_000


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-02-24
Source Control Label: 4.6.5.3_Intel_LPT-RC_051_002
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_050_001 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch7_00 or above
Dependent Source Control Location: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom110.BIN
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom115.BIN
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom110.bin | Intel RAID option ROM.
SataOrom115.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
None
AMI Build Tools:
Tools Label: 4.5.5_Tools_38, Dated: 2011/12/20
Visual eBios: RSS 5.72.0219, Dated: 2011/12/20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl

Support PI 1.2
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.dxs
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_051_001


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-03-22
Source Control Label: 4.6.5.3_Intel_LPT-RC_051_003
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_050_001 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch7_00 or above
Dependent Source Control Location: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN (Dummy file)
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN (Dummy file)
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
None
AMI Build Tools:
Tools Label: 4.5.5_Tools_38, Dated: 2011/12/20
Visual eBios: RSS 5.72.0219, Dated: 2011/12/20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl

Support PI 1.2
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.dxs
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Modified for AMI Debug Rx.
[Files] PchUsbCommon.c

[TAG] None
[Category] Improvement
[Description] Rename SataOpROM. Notice : This SataOrom120.bin file is dummy
[Files] SB.sdl, SataOrom120.bin, sbCSP.CIF

[TAG] None
[Category] Bug Fix
[Severity] Normal
[Symptom] System hang up if enable "DEBUG_MODE"
[Solution] Set "USB_PORTS_LENGTH" to 0x80 as default
[Files] SB.sdl
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_051_002


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-04-03
Source Control Label: 4.6.5.3_Intel_LPT-RC_055_004
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_055_004 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_055_003 or above
Dependent Source Control Location: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN (Dummy file)
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN (Dummy file)
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi (Dummy file)
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
AMI Build Tools:
Tools Label: 4.5.5_Tools_38, Dated: 2011/12/20
Visual eBios: RSS 5.72.0219, Dated: 2011/12/20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl

Support PI 1.2
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.dxs
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_051_003


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-04-25
Source Control Label: 4.6.5.3_Intel_LPT-RC_055_005
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_055_005 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_055_003 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN (Dummy file)
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1476
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1476
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Custom option.
XHCI Pre-Boot Driver item have effect even if it is hidden.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012/04/04
Visual eBios: RSS.5.73.0225, Dated: 2011/03/13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl

Support PI 1.2
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.dxs
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
Correct LynxPoint RC Version info.
..\ReferenceCode\Chipset\LynxPoint\Protocol\PchInfo\PchInfo.h
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Reprogram SMM ChildDispatcher drivers.
[Files] SmiHandlerGeneric.c; SmiHandlerPorting.c; SmiHandlerGeneric2.c; SmmChildDispatch2Main.c; SmmChildDispatcher2.mak; SmmChildDispatcher2.sdl; SmmChildDispatch.h; SmmChildDispatchMain.c; SmmChildDispatchProtocol.c; SmmChildDispatcher.dxs; PchSmiDispatcher.sdl

[TAG] None
[Category] Improvement
[Description] Remove unnecessary dependence.
[Files] AcpiModeEnable.dxs; SBSMI.dxs; SleepSmi.dxs

[TAG] None
[Category] Improvement
[Description] Apply AcpiModeEnable support PI 1.2.
[Files] AcpiModeEnable.c

[TAG] EIP73033
[Category] Improvement
[Description] 'PciDevicePath' used in GetControllerType(), conditionally not set.
[Files] SmiHandlerPorting.c; SmiHandlerPorting2.c

[TAG] None
[Category] Improvement
[Description] Fixed GenericSio use 0x0 ~ 0xfff issue.
[Files] SBDxe.c

[TAG] None
[Category] Improvement
[Description] Relayout PCH USB Setup.
[Files] GetSetupData.c; SB.sd; SB.uni; SbSetupData.h; SBDxe.c

[TAG] None
[Category] Improvement
[Description] Update RAID OROM to 12.0.0.1476.
[Files] SataOrom120.BIN; SataDriver.efi
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_055_004


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-05-03
Source Control Label: 4.6.5.3_Intel_LPT-RC_055_006
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_055_005 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_055_003 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN (Dummy file)
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1476
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1476
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Custom option.
XHCI Pre-Boot Driver item have effect even if it is hidden.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012/04/04
Visual eBios: RSS.5.73.0225, Dated: 2011/03/13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl

Support PI 1.2
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.dxs
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
Correct LynxPoint RC Version info.
..\ReferenceCode\Chipset\LynxPoint\Protocol\PchInfo\PchInfo.h
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Modify to support Thunderbolt.
[Files] SB.sd; SB.uni; SB.sdl; SbSetupData.h; PciHotPlug.c
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_055_005


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-05-14
Source Control Label: 4.6.5.3_Intel_LPT-RC_056_007
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_056_006 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_056_005 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN (Dummy file)
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1476
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1476
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Custom option.
XHCI Pre-Boot Driver item have effect even if it is hidden.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012/04/04
Visual eBios: RSS.5.73.0225, Dated: 2011/03/13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl

Support PI 1.2
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.dxs
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Add PCH Device ID 0x8C40 to support WorkStation C228.
[Files] SBSetup.c
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-06-11
Source Control Label: 4.6.5.3_Intel_LPT-RC_057_008
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_056_007 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_056_005 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN (Dummy file)
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1476
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1476
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Custom option.
XHCI Pre-Boot Driver item have effect even if it is hidden.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012/04/04
Visual eBios: RSS.5.73.0225, Dated: 2011/03/13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl

Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Lynx Point PCH Chipset Framework Reference Code Alpha 2 0.5.7.

[TAG] None
[Category] Improvement
[Description] Revert to the original reference code.
[Files] PchUsbCommon.c

[TAG] None
[Category] Improvement
[Description] Remove dependence of FirmwareVolume2.
[Files] PchS3Support.dxs

[TAG] None
[Category] Improvement
[Description] Implement EFI_PEI_SMBUS2_PPI Support.
[Files] Chipset/SB/SmBus/*.*
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-06-14
Source Control Label: 4.6.5.3_Intel_LPT-RC_057_009
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_056_007 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_056_005 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1476
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1476
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Custom option.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set Setup XHCI Mode to Manual, enable Pre-Boot Driver, and then set XHCI Mode to Enable.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012/04/04
Visual eBios: RSS.5.73.0225, Dated: 2011/03/13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl

Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Implement Warm Boot function for Secure Flash feature.
[Files] SB.H, SB.mak, SB.sdl, SBDxe.c, SBGeneric.c, SBPEI.c, SBSMI.c

[TAG] None
[Category] Improvement
[Description] Program AfterG3 bit depend the setup question in S3/S4/S5.
[Files] SleepSmi.c

[TAG] None
[Category] Improvement
[Description] Update GbE OpROM to v1.3.95.
[Files] GbE_OR.BIN
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-07-02
Source Control Label: 4.6.5.3_Intel_LPT-RC_060_010
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_060_008 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_060_007 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1476
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1476
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Custom option.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set Setup XHCI Mode to Manual, enable Pre-Boot Driver, and then set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012/04/04
Visual eBios: RSS.5.73.0225, Dated: 2011/03/13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl

Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Implement the setup option S3_S4_S5/Battery of DeepSx.
[Files] SB.sd, SB.uni

[TAG] None
[Category] Improvement
[Severity] Normal
[Symptom] System may hang at 0xB1 when boot to UEFI Windows 8.
[Solution] Set Driver type to SMM_DRIVER.
[Files] AcpiModeEnable.mak

[TAG] None
[Category] Improvement
[Description] Set SataDriver_SUPPORT enabled by default.
[Files] SataDriver.sdl

[TAG] None
[Category] Improvement
[Description] SETUP.MassStorageOpRom will instead of SETUP.SataRaidRom to decide the launching policy of RAID UEFI driver/Legacy OpRom if CsmOptOut_SUPPORT enabled.
[Files] SBDex.c, SB.sd

[TAG] None
[Category] Improvement
[Description] Updated and modified for PCH RC 0.6.0.
[Files] SBGeneric.c, SB.sdl, SBCspLib.h, SBDxe.c, SBPEI.c

[TAG] None
[Category] Improvement
[Description] Create new definition for PCH RC Flags.
[Files] Pch.sdl

[TAG] None
[Category] Improvement
[Description] Change default setup of USB 3.0 mode and Pre-Boot Support.
[Files] GetSetupData.c, SB.sd
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
01. Set SATA mode to RAID and select UEFI Driver, CD-ROM device will disappear.
This issue only occur with RAID driver v12.0.0.1476, and v12.0.0.1287 is working fine.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-07-27
Source Control Label: 4.6.5.3_Intel_LPT-RC_060_011
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_060_008 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_060_007 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1573
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1573
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Custom option.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set Setup XHCI Mode to Manual, enable Pre-Boot Driver, and then set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012/04/04
Visual eBios: RSS.5.73.0225, Dated: 2011/03/13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl

Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
Support Server/Workstation PCH ID.
..\ReferenceCode\Chipset\LynxPoint\Include\PchRegs.h
Fixed USB cording.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Support Server/Workstation PCH ID. Please set "PCH_SVR_WS_ID_SUPPORT".
[Files] SBSetup.c, PchRegs.h, Pch.sdl

[TAG] None
[Category] Improvement
[Description] Update setup items and policies.
[Files] GetSetupData.c, SB.sdl, SB.sd, SB.uni, SbSetupData.h, SBPEI.c, SBDXE.c

[TAG] None
[Category] Improvement
[Description] Support ASLPREPROCESS_FLAG to include Iintel RC flags.
[Files] Pch.sdl

[TAG] None
[Category] Improvement
[Description] Update RAID OROM to 12.0.0.1573.
[Files] SataDriver.efi, SataOrom120.bin

[TAG] None
[Category] Improvement
[Description] Adjust PM BASE and GPIO Base length.
[Files] SB.sdl

[TAG] None
[Category] Improvement
[Description] Update to support ULT Platform.
[Files] SB.H, SB.mak, SB.sdl, SB.sd, SBSetup.c, AcpiModeEnable.c, SBDxe.c, SBPEI.c, SBSMI.c, SleepSmi.c, SmiHandlerPorting.c, SmiHandlerPorting2.c, SBPPI.h, Pch.sdl
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-08-14
Source Control Label: 4.6.5.3_Intel_LPT-RC_061_012
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: USB
Dependent Component Reference Name: USB
Dependent Source Control Label: 4.6.3_USB_08.10.22 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1573
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1573
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012/04/04
Visual eBios: RSS.5.73.0225, Dated: 2011/03/13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl

Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
Support Server/Workstation PCH ID.
..\ReferenceCode\Chipset\LynxPoint\Include\PchRegs.h
Fixed USB cording.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] EIP96150
[Category] Bug Fix
[Severity] Normal
[Symptom] USB Device still can be detected even set USB controllers as "Disabled" in BIOS Setup.
[Solution] Set XHCI disable bit of FD Reg.
[Files] SBDxe.c

[TAG] None
[Category] Improvement
[Description] Implement BIOS Lock function.
[Files] SBCspLib.h, SBDxe.c, SBSMI.c, SBSMI.dxs, BSMI.sdl

[TAG] None
[Category] Improvement
[Description] Remove ThimblePeak 1/2/3.
[Files] SB.sdl

[TAG] None
[Category] Improvement
[Description] Create the token "USB30_OVER_CURRENT_MAPPING_SETTINGS" for the policy "Usb30OverCurrentPins".
[Files] SB.sdl, SBDxe.c

[TAG] None
[Category] Improvement
[Description] Changed PM Base Address from 0x400 to 0x1800.
[Files] SB.sdl

[TAG] None
[Category] Improvement
[Description] Improve CheckDisableUsbControllers function.
[Files] SBDxe.c

[TAG] None
[Category] Improvement
[Description] Update correct MMIO BASE for TempMemBaseAddr policy.
[Files] SBPEI.c

[TAG] None
[Category] Improvement
[Description] Remove PCH_A0PWRON_SAFEMODE.
[Files] SBDxe.c, Pch.sdl

[TAG] None
[Category] Improvement
[Description] Remove useless Dppm items.
[Files] GetSetupData.c, SB.sd, SbSetupData.h, SBDxe.c

[TAG] None
[Category] Improvement
[Description] Update PCH Policy.
[Files] SB.sdl, SBDxe.c, SBPEI.c

[TAG] None
[Category] Improvement
[Description] Implement USB Precondition option for policy "UsbPrecondition".
[Files] GetSetupData.c, SB.sd, SB.uni, SbSetupData.h, SBDxe.c, SBPEI.c

[TAG] None
[Category] Improvement
[Description] Update definition in ASL code for building when disabled PCI objects.
[Files] SB.ASL
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-08-15
Source Control Label: 4.6.5.3_Intel_LPT-RC_061_013
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: USB
Dependent Component Reference Name: USB
Dependent Source Control Label: 4.6.3_USB_08.10.22 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1573
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1573
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012/04/04
Visual eBios: RSS.5.73.0225, Dated: 2011/03/13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl

Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
Support Server/Workstation PCH ID.
..\ReferenceCode\Chipset\LynxPoint\Include\PchRegs.h
Fixed USB cording.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed building error when set LPSS_FLAG.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Remove ME_SERVER_SUPPORT.
[Files] SBDxe.c, SBPEI.c

[TAG] None
[Category] Improvement
[Description] Update "SB_TEMP_MMIO_BASE" and "EHCI_MMIO_BASE_ADDRESS".
[Files] SB.sdl, SBDxe.c, SBPEI.c
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-08-24
Source Control Label: 4.6.5.3_Intel_LPT-RC_061_014
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1573
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1573
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012/04/04
Visual eBios: RSS.5.73.0225, Dated: 2011/03/13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl

Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
Support Server/Workstation PCH ID.
..\ReferenceCode\Chipset\LynxPoint\Include\PchRegs.h
Fixed USB cording.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed building error when set LPSS_FLAG.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Remove useless SB_SHADOW_CONTROL.
[Files] SB.sdl, SBCspLib.h, SBGeneric.c

[TAG] None
[Category] Improvement
[Description] Update RC_PORT_x for PCIe.
[Files] SB.sdl, SB.sd, SBDxe.c

[TAG] None
[Category] Improvement
[Description] Report HPET Function Number to zero for VTD.
[Files] SBDxe.c

[TAG] None
[Category] Improvement
[Description] Corrected EHCI_MMIO_BASE_ADDRESS1 to fix system hang at 0x71 when AMI_DEBUGGER_SUPPORT.
[Files] SB.sdl

[TAG] None
[Category] Improvement
[Description] Implement USB Skip MASS Storage function.
[Files] SBDxe.c

[TAG] None
[Category] Improvement
[Description] Sync USB policy for UsbPrecondition function.
[Files] SBPEI.c
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-08-31
Source Control Label: 4.6.5.3_Intel_LPT-RC_061_015
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_061_012 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1573
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1573
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012/04/04
Visual eBios: RSS.5.73.0225, Dated: 2011/03/13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl

Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
Support Server/Workstation PCH ID.
..\ReferenceCode\Chipset\LynxPoint\Include\PchRegs.h
Fixed USB cording.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed building error when set LPSS_FLAG.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Change "GPIO_BASE_ADDRESS" to "0x1C00".
[Files] SB.sdl

[TAG] None
[Category] Improvement
[Description] Update "GPE0_BLK_ADDRESS" and "GPE0_BLK_LENGTH" for RTD3 support.
[Files] SB.sdl

[TAG] None
[Category] Improvement
[Description] Implement EIP#73211 and EIP#79156 for OA 3.0 function.
[Files] SmiHandlerGeneric2.c, SmmChildDispatch2Main.c

[TAG] None
[Category] Improvement
[Description] Fixed building error when disable all PCI slots.
[Files] SB.sdl

[TAG] None
[Category] Improvement
[Description] Fixed building error when disable RC_PORT_0.
[Files] SBDxe.c
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-09-12
Source Control Label: 4.6.5.3_Intel_LPT-RC_061_016
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_061_012 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1573
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1573
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. Provide ELINK "OEM_SPI_VSCC_TABLE" for customer to update the corresponding VSCC value.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012/04/04
Visual eBios: RSS.5.73.0225, Dated: 2011/03/13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl

Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
Support Server/Workstation PCH ID.
..\ReferenceCode\Chipset\LynxPoint\Include\PchRegs.h
Fixed USB cording.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed building error when set LPSS_FLAG.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Fix FPT function failed.
..\ReferenceCode\Chipset\LynxPoint\Include\PchRegs\PchRegsSpi.h
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchInit.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Remove useless HdmiVerbTable.
[Files] SB.sdl, SBCspLib.h, SBDxe.c, SBGeneric.c

[TAG] None
[Category] Improvement
[Description] Change "SB_TEMP_IO_BASE" to "0x1200".
[Files] SB.sdl

[TAG] None
[Category] Improvement
[Description] Support OEM update VSCC table.
[Files] SB.H, SB.mak, SB.sdl, SBDXE.c

[TAG] None
[Category] Improvement
[Description] Fix FPT function failed.
[Files] PchRegsSpi.h, PchInit.c

[TAG] None
[Category] Improvement
[Description] Modify for Thunderbolt support.
[Files] GetSetupData.c, SB.sdl, SB.sd, SB.uni, SbSetupData.h, PciHotPlug.c

[TAG] None
[Category] Improvement
[Description] Force HPET enabled for MRC initialization.
[Files] SB.sd, SBPEI.c

[TAG] None
[Category] Improvement
[Description] Modify for ULT GPIO changed by PCH LPT-LP EDS 1.0.
[Files] SB.H, SB.sdl, AcpiModeEnable.c, AcpiModeEnable.sdl, SBPEI.c
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-09-26
Source Control Label: 4.6.5.3_Intel_LPT-RC_070_017
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_070_014 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_070_013 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1573
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1573
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl

Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
Support Server/Workstation PCH ID.
..\ReferenceCode\Chipset\LynxPoint\Include\PchRegs.h
Fixed USB cording.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed building error when set LPSS_FLAG.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Update for Shark Bay ULT use USB KB wake form S3/S4.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] If SPI Flash module support VSCC updated, skip programming VSCC.
[Files] SB.sdl, SBDxe.c

[TAG] None
[Category] Improvement
[Description] Fixed RTC on iFFS failed.
[Files] AcpiModeEnable.c

[TAG] None
[Category] Improvement
[Description] Update from EIP#95440 to resolve the RAID driver compatibility issue.
[Files] SB.mak, SB.sdl, SBDXE.c

[TAG] None
[Category] Improvement
[Description] Update for Intel PCH LPT RC070.
[Files] SB.sdl, SBDXE.c, SBPEI.c, Pch.sdl, SB.sd, SB.uni

[TAG] None
[Category] Improvement
[Description] Update EIP#101515.
[Files] SBDXE.c

[TAG] None
[Category] Improvement
[Description] Update for PCH LP GPIO compatible.
[Files] SB.sdl, SB.H, AcpiModeEnable.c, AcpiModeEnable.sdl, SBDxe.c, SBGeneric.c, SBPEI.c, SBSMI.c, SleepSmi.c, SmiHandlerPorting.c, SmiHandlerPorting2.c

[TAG] None
[Category] Improvement
[Description] Update for generic Thunderbolt support.
[Files] SB.sd

[TAG] None
[Category] Improvement
[Description] Implement ULT platform LPSS and ADSP setup option.
[Files] GetSetupData.c, SB.sd, SB.uni, SbSetupData.h, SBDxe.c, SB.sdl
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-10-01
Source Control Label: 4.6.5.3_Intel_LPT-RC_070_018
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_070_014 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_070_013 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1573
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1573
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl

Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
Support Server/Workstation PCH ID.
..\ReferenceCode\Chipset\LynxPoint\Include\PchRegs.h
Fixed USB cording.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed building error when set LPSS_FLAG.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Update for Shark Bay ULT use USB KB wake form S3/S4.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Update EIP#102349 "GPE0 setting and SCI routing for ULT platfoem".
[Files] AcpiModeEnable.c, AcpiModeEnable.sdl

[TAG] None
[Category] Improvement
[Description] Update for PFTA support.
[Files] SBGeneric.c

[TAG] None
[Category] Improvement
[Description] Create new token "SOLUTION_FOR_EIP95440" for EIP#95440 changed.
[Files] SB.sdl, SBDXE.c
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-10-16
Source Control Label: 4.6.5.3_Intel_LPT-RC_071_019
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_071_019 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_071_014 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1573
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1573
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
Support Server/Workstation PCH ID.
..\ReferenceCode\Chipset\LynxPoint\Include\PchRegs.h
Fixed USB cording.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed building error when set LPSS_FLAG.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Update for Shark Bay ULT use USB KB wake form S3/S4.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] EIP83353
[Category] Improvement
[Description] Correct IDE Mode SATA2 Ch1 Master timing.
[Files] IDE.asl

[TAG] EIP87695
[Category] Improvement
[Description] System should reboot successfully next time if S3 resume fail
[Files] SB.sdl, SBPei.c

[TAG] None
[Category] Improvement
[Description] Fixed the system hang when Y2K roll over is occur withTCO SMI enabled.
[Files] SBSMI.c
[TAG] EIP76432
[Category] Bug Fix
[Severity] Normal
[[Symptom] It will BSOD ,while system boot to OS at "starting windows" press the KB in succession.
[RootCause] System BSOD is caused by a large number of SMI generated.
[Solution] Disable legacy USB SMI in ACPI enable stage.
[Files] AcpiModeEnable.c; SBDXE.c
[TAG] None
[Category] Improvement
[Description] Clear all SB warm reset flag
[Files] SBDxe.c
[TAG] ULT_SUBID
[Category] Bug Fix
[Severity] Important
[Symptom] Win8 BSOD for ULT A0 CPU
[RootCause] The Sub-device ID not match LPT-LP A0 stepping.
[Solution] Use old Sub-device ID
[Files] SBDxe.c
[TAG] EIP86096
[Category] Improvement
[Description] Fix SATA AHCI port4 & 5 can't loading recovery image.
[Files] SBPei.c
[TAG] None
[Category] Improvement
[Description] One rom for two chip and one chip.
[Files] SPPEIBoard.c, SB.sd, SBDxe.c, SBPEI.c, PCH.asl
[TAG] ULTDsdtTableUpdate
[Category] Improvement
[Description] Update DSDT when ULT.
[Files] SBDxe.c
[TAG] EIP103924
[Category] Improvement
[Description] Update RC 0.7.1
[Files] ReferenceCode\Chipset\LynxPoint\*.*, SBDxe.c, SB.sd, SbSetupData.c, GetSetupDate.c
[TAG] None
[Category] Improvement
[Description] Assign IRQ for device 21
[Files] SBPei.c
[TAG] EIP84720
[Category] Improvement
[Description] Support Hot-Plug in Shark Bay
[Files] PchRootPort.c, PchPcie.asl, PchPciExpressHelpersLib.mak, PchPciExpressHlpersLibrary.c, SB.sdl
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-10-19
Source Control Label: 4.6.5.3_Intel_LPT-RC_071_020
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_071_019 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_071_014 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1573
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1573
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
Support Server/Workstation PCH ID.
..\ReferenceCode\Chipset\LynxPoint\Include\PchRegs.h
Fixed USB cording.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed building error when set LPSS_FLAG.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] EIP101204
[Category] Bug Fix
[Severity] Normal
[[Symptom] Azalia PME bit doesn't been set when Enabled "Azalia PME"
[RootCause] PME bit will be cleared by AMI PCI bus driver
[Solution] Reprogram PME bit in SbInitAfterDeviceInstall().
[Files] SBDXE.c

[TAG] EIP93461
[Category] Bug Fix
[Severity] Normal
[Symptom] System halt when AFUDOS is running with /N /ME command.
[RootCause] An unexpected BIOSWR_STS is set, it causes BIOS stuck at SMM dispatcher.
[Solution] Clear BIOSWR_STS if BIOS Lock Enable is not set.
[Files] SmiHandlerPorting2.c; mmChildDispatch2Main.c; SmmChildDispatcher2.sdl; SmmChildDispatch2.h; SBGeneric.c

[TAG] None
[Category] Improvement
[Description] Update SATA OpRom to 12.0.0.1710
[Files] SataOrom120.bin, SataDriver.efi
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-10-26
Source Control Label: 4.6.5.3_Intel_LPT-RC_071_021
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_072_020 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_071_014 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1710
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1710
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
Support Server/Workstation PCH ID.
..\ReferenceCode\Chipset\LynxPoint\Include\PchRegs.h
Fixed USB cording.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed building error when set LPSS_FLAG.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] EIP84560
[Category] Bug Fix
[Severity] Normal
[[Symptom] Can't enter Win8 after Win8 AHCI driver version:11.5.0.1122 install.
[Solution] fixed in EIP84560
[Files] sb.sdl, sb.mak, sata.asl

[TAG] EIP73607
[Category] Bug Fix
[Severity] Normal
[Symptom] Intruder Detect state is cleaned by BIOS POST.
[Files] SBDXE.c; SBSECInit.asm

[TAG] None
[Category] Improvement
[Description] Add LPSS device and remove device which no use
[Files] SB.sdl, SBPEI.c

[TAG] None
[Category] Improvement
[Description] After S3 resume EC can not use GPI to trigger SMI
[Files] SBDxe.c

[TAG] None
[Category] Improvement
[Description] Create Device Sleep at setup menu
[Files] SB.sd, SB.uni, SBDxe.c, GetSetupData.c, SbSetupData.h

[TAG] None
[Category] Improvement
[Description] Create NFC item at setup
[Files] SB.sd, SB.uni, SbSetupData.h

[TAG] CHECK_BS_VARIABLE
[Category] Improvement
[Description] If project has module NVRamSMI then don't need to check this.
[Files] SBSMI.c

[TAG] EIP100108
[Category] Improvement
[Description] Support Capsule 2.0.
[Files] SBGeneric.c

[TAG] None
[Category] Improvement
[Description] Change all L event, GPRW and pcidock at DSDT for ULT.
[Files] SBDxe.c

[TAG] None
[Category] Bug Fix
[Severity] Normal
[Symptom] After S3 resime R_PCH_SPI_VSCC1 cannot restore.
[RootCause] R_PCH_SPI_VSCC0 set first than R_PCH_SPI_VSCC1 cannot restore.
[Solution] change order for R_PCH_SPI_VSCC1 restore first.
[Files] SBDxe.c
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-10-26
Source Control Label: 4.6.5.3_Intel_LPT-RC_071_021a
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_072_020 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_071_014 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1710
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1710
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
Fixed USB cording.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Update SATA RAID rom to 12.5.0.1710
[Files] SataDriver.efi, SataOrom125.bin, SB.sdl

[TAG] None
[Category] Improvement
[Description] Remove clear SMI state and Y2K roller for PFAT function.
[Files] SBSMI.c, SBGeneric.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-11-08
Source Control Label: 4.6.5.3_Intel_LPT-RC_071_022
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_072_020 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_071_014 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.0.0.1710
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.0.0.1710
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for customization.
..\ReferenceCode\Chipset\LynxPoint\IoTrap\Smm\IoTrap.c
Fixed USB cording.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Remove token "SOLUTION_FOR_EIP95440".
[Files] SBDxe.c, SB.sdl

[TAG] None
[Category] Improvement
[Description] Change memory type for RTC.
[Files] SBDxe.c

[TAG] None
[Category] Improvement
[Description] Reduce function "GetPchSeries()".
[Files] SBPEI.c, SBDxe.c, SmiHandlerPorting.c, SmiHandlerPorting2.c

[TAG] None
[Category] Improvement
[Description] Add device item that connect LPSS.
[Files] GetSetupData.c, SbSetupData.h, SBDxe.c, SB.sd, SB.uni

[TAG] None
[Category] Improvement
[Description] Remove HDMI item.
[Files] SB.sd, SB.uni, GetSetupData.c, SbSetupData.h

[TAG] None
[Category] New Feature
[Description] Add token "PROGRAM_GPIO_TYPE" for select ULT GPIO program function(token or array directly).
[Files] SB.sdl, SBPEIBoard.c

[TAG] None
[Category] Improvement
[Description] Change "SB_TEMP_MMIO_BASE" to "0xDFFF0000"
[Files] SB.sdl

[TAG] Initialize8259
[Category] Improvement
[Description] To prevent the unexpected interrupt asserted in 8259 initialization.
[Files] SBDxe.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-11-20
Source Control Label: 4.6.5.3_Intel_LPT-RC_080_023
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_080_017 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1710
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1710
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Fixed USB cording.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Change APIC ID to 02.
[Files] SB.sdl

[TAG] EIP106353
[Category] Bug Fix
[Severity] Critical
[Symptom] The system has assert error when PFAT is Disabled and Debug Mode is Enabled.
[RootCause] Use build time PFAT flag that make some code not run whrn PFAT disable.
[Solution] Detect PFAT flag useing MSR.
[Files] SBGeneric, SB.mak

[TAG] EIP107014
[Category] Improvement
[Description] Update RC 0.8.0
[Files] ReferenceCode\Chipset\LynxPoint\*.*, SBDxe.c, SBPEI.c, SB.sd, SbSetupData.c, GetSetupDate.c

[TAG] EIP105657
[Category] Improvement
[Description] Follow EDS to clear PME Status.
[Files] PchPcie.asl

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-11-21
Source Control Label: 4.6.5.3_Intel_LPT-RC_080_023a
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_080_017 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1710
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1710
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Fixed USB cording.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Change ASL build path by token.
[Files] SB.sdl, SB.mak

[TAG] None
[Category] Improvement
[Description] Add String at help for USB
[Files] SB.sd, SB.uni

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-11-26
Source Control Label: 4.6.5.3_Intel_LPT-RC_080_023b
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_080_017 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1710
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1710
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Fixed USB cording.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchLpss.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Fixed after S3 resume cannot use FPT
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] EIP105442
[Category] Bug Fix
[Severity] Normal
[Symptom] After S3 resum cannot use FPT win64
[RootCause] The SPI HSFS register "Access Error Log" bit has been set.
[Files] SB.ASL, Pch.asl

[TAG] EIP107376
[Category] Improvement
[Description] dd token "PCH_SPD_WRITE_DISABLE" for SMBus reg 40h bit 4.
[Files] SmBus.sdl, SmBusPei.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-12-18
Source Control Label: 4.6.5.3_Intel_LPT-RC_081_024
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_080_017 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1710
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1710
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Fixed after S3 resume cannot use FPT(EIP105442)
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Use Top down to allocate memory space
..ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
Support WS RAID device ID
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Has no wcam.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\PchXhci.asl
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] EIP105442
[Category] Bug Fix
[Severity] Normal
[Symptom] System stops at CKP 0x9C when system performs a cool boot and AMI debugger is enabled.
[RootCause] Unexpected USB EHCI Legacy Support Extended status is rised, it is out of USB module control.
[Solution] Clear unexpected USB EHCI Legacy Support Extended status.
[Files] SBPEI.c

[TAG] EIP106687
[Category] Improvement
[Description] Add option for delay to detect PCIE card.
[Files] SBPEI.c, SB.sd, SB.uni, GetSetupData.c, SbSetupData.h

[TAG] None
[Category] Improvement
[Description] Add setup menu for LPSS and ECTG.
[Files] GetSetupData.c, SbSetupData.h, SB.sd, SB.uni, SBDxe.c

[TAG] None
[Category] Improvement
[Description] Add module part for memory down.
[Files] ..Chipset\SB\PchWrap\SmBusMemoryDown\*.*

[TAG] EIP101628
[Category] Improvement
[Description] Support PEG use power button wake.
[Files] AcpiModeEnable.c

[TAG] EIP109697
[Category] Improvement
[Description] Update PCH RC 0.8.1
[Files] ReferenceCode\Chipset\LynxPoint\*.*, SBDxe.c, SBPEI.c, SB.sd, SbSetupData.c, GetSetupDate.c

[TAG] None
[Category] Improvement
[Description] Update C0 stepping
[Files] SBSetup.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2012-12-22
Source Control Label: 4.6.5.3_Intel_LPT-RC_081_024a
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_080_017 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1710
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1710
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Fixed after S3 resume cannot use FPT(EIP105442)
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Use Top down to allocate memory space
..ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
Support WS RAID device ID
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Has no wcam.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\PchXhci.asl
Fix disable SDIO will BSOD
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Bug Fix
[Severity] Normal
[Symptom] Disable device SDIO will BSOD at UEFI win8.
[RootCause] When disable SDIO it will free memory that did not allocate.
[Solution] Free memory when SDIO is enable.
[Files] PchSerialIo.c

[TAG] EIP77459
[Category] Improvement
[Description] Update for Intel flash utility "FPT.efi" support.
[Files] SBRun.c

[TAG] None
[Category] Improvement
[Description] Add PCIE "L1 Substates"setup option.
[Files] GetSetupData.c, SbSetupData.h, SB.sd, SB.uni, SBDxe.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-01-04
Source Control Label: 4.6.5.3_Intel_LPT-RC_081_024b
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_080_017 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1710
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1710
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Fixed after S3 resume cannot use FPT(EIP105442)
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Use Top down to allocate memory space
..ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
Support WS RAID device ID
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Has no wcam.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\PchXhci.asl
Fix disable SDIO will BSOD
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
...\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Add GPI_ROUT function.
[Files] PchSmmCore.c

[TAG] None
[Category] Improvement
[Description] Add option for XHCI Idel L1 workaroung.
[Files] GetSetupData.c, SbSetupData.h, SB.sd, SB.uni, SBDxe.c, SBPEI.c

[TAG] None
[Category] Improvement
[Description] Show EHCI option when XHCI is disable.
[Files] SB.sd

[TAG] None
[Category] Improvement
[Description] Correct the wrong word.
[Files] SB.uni

[TAG] None
[Category] Bug Fix
[Severity] Normal
[Symptom] Build error when set IDE mode as default.
[RootCause] The ULT did not support IDE mode that made the value redefine.
[Solution] Separate Sata inter face for 2 Chip and ULT.
[Files] SB.sd, GetSetupData.c, SbSetupData.h

[TAG] None
[Category] Bug Fix
[Severity] Important
[Symptom] GPISMI cannot use.
[RootCause] GPISMI2 will clear status before GPISMI.
[Solution] GPISMI2 do not clear status when GPISMI has register.
[Files] SmmChildDispatcher2.sdl, SmiHandlerGeneric2.c

[TAG] None
[Category] Bug Fix
[Severity] Minor
[Symptom] Azalia option not show at setup menu at 2 chip.
[RootCause] Azalia option will hide when Audio DSP enable at ULT but 2 chip do no need.
[Solution] Hide Azalia only when is ULT platform.
[Files] SB.sd

[TAG] EIP104199
[Category] Improvement
[Description] Register dummy Handler for all Tco Smi
[Files] SBSMI.c;

[TAG] None
[Category] Improvement
[Description] Change USB pre-port disable typo.
[Files] SB.uni

[TAG] None
[Category] Improvement
[Description] ADSP Interrupt Mode should same with LPSS Interrupt Mode
[Files] SBDxe.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-01-11
Source Control Label: 4.6.5.3_Intel_LPT-RC_081_024c
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_080_017 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1758
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1758
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
Support WS RAID device ID
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Has no wcam.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\PchXhci.asl
Fix disable SDIO will BSOD
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
...\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
...\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Support PCIE port swap.
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
OEM Fullreset function support.(EIP81593)
...\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Upsate Sata OpRom to 12.5.0.1758.
[Files] SataOrom125.bin, SataDriver.efi

[TAG] None
[Category] Improvement
[Description] Create DTIO value and DM value option.
[Files] GetSetupData.c, SbSetupData.h, SB.sd, SB.uni, SBDxe.c

[TAG] EIP111666
[Category] New Feature
[Description] Support OEM reset callback function Elink.
[Files] SB.mak, SBCspLib.h, SBGeneric.c, SB.sdl, PchReset.c

[TAG] None
[Category] Improvement
[Description] Create token for SataDriver path.
[Files] SataDriver.sdl, SataDriver.mak

[TAG] EIP81593
[Category] Improvement
[Description] Added new SDL token "COLD_RESET_WITH_POWER_CYCLE".
[Files] SB.sdl, SBGeneric.c, PchResetCommon.c, PchResetCommonLib.sdl

[TAG] EIP88358
[Category] Improvement
[Description] Add FORCE_USER_TO_SETUP_IF_CMOS_BAD token
[Files] SBDex.c, SBPei.c, RTC.h, SB.sdl

[TAG] None
[Category] Improvement
[Description] Add ReadCmos() / WriteCmos() from SB template.
[Files] SBGeneric.c

[TAG] None
[Category] Improvement
[Description] Fixed coding error.
[Files] SBSMI.c;

[TAG] None
[Category] Improvement
[Description] Remove EIP105442 temp solution.
[Files] SB.ASL, Pch.asl

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-01-14
Source Control Label: 4.6.5.3_Intel_LPT-RC_090_025
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_090_020 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1758
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1758
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. SWSMI CRB team used-
Module Name | SWSMI #
ME | SW_SMI_POST_COMPLETE = 0xBB
ThunderBolt | TBT_SWSMI_VALUE = 0xBC
CPU SW_SMI_S3_RESTORE_MSR = 0x59

SW_SMI_ SW_SMI_RESTORE_MSR _INTERNAL = 0x57

SW_SMI_SAVE_MSR = 0x56
SA | NB_SWSMI_IGFX_GET_SETUP = 0xB0
PCH SW_SMI_SB_ACPI_S3 = 0xB8

SW_SMI_SB_EL_S3 = 0xB9
IFFS | SW_SMI_WHOLE_MEMORY_CHECK = 0xB5
SwitchableGraphic SWSMI_NVOEM_CMOS_W = 0xB6

SWSMI_NVOEM_CMOS_R = 0xB7.
CRB | CRB_SWSMI = 0xBF
15.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
Support WS RAID device ID
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Has no wcam.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\PchXhci.asl
Fix disable SDIO will BSOD
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
...\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
...\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Support PCIE port swap.
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
OEM Fullreset function support.(EIP81593)
...\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] EIP112059
[Category] Improvement
[Description] Update PCH RC 0.9.0.
[Files] ReferenceCode\Chipset\LynxPoint\*.*

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-01-28
Source Control Label: 4.6.5.3_Intel_LPT-RC_100_026
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_090_020 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1758
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1758
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
Support WS RAID device ID
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Has no wcam.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\PchXhci.asl
Fix disable SDIO will BSOD
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
...\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
...\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Support PCIE port swap.
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
OEM Fullreset function support.(EIP81593)
...\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] EIP113553
[Category] Improvement
[Description] Update PCH RC 1.0.0.
[Files] ReferenceCode\Chipset\LynxPoint\*.*

[TAG] None
[Category] Improvement
[Description] Use token to set "BIOS Lock", "SMI Lock", BIOS Interface Lock", "GPIO Lock" and "RTC RAM Lock".
[Files] SB.sd, SB.sdl

[TAG] None
[Category] Improvement
[Description] Create GPIO function token for ULT.
[Files] SB.sdl

[TAG] None
[Category] Improvement
[Description] Correct ULT GPIO's help message
[Files] SB.sdl, SBPEIBoard.c

[TAG] None
[Category] Improvement
[Description] Capsule 2.0 crash dump link function.
[Files] SBPEI.c, SBDxe.c, SBRun.c

[TAG] None
[Category] Improvement
[Description] Create PCH Sku fot LPT-LP at setup.
[Files] SBSetup.c

[TAG] EIP108803
[Category] Improvement
[Description] Disable usb port after setup.
[Files] SB.sdl, SBDxe.c, PchUsbCommon.c

[TAG] None
[Category] Bug Fix
[Severity] Important
[Symptom] GPISMI rout not correct
[RootCause] Register GPISMI is use bit number not bit map.
[Solution] Change rout function to bit number.
[Files] PchSmmCore.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-01-30
Source Control Label: 4.6.5.3_Intel_LPT-RC_101_027
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_090_020 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1758
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1758
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
Support WS RAID device ID
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Has no wcam.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\PchXhci.asl
Fix disable SDIO will BSOD
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
...\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
...\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Support PCIE port swap.
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
OEM Fullreset function support.(EIP81593)
...\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] EIP113831
[Category] Improvement
[Description] Update PCH RC 1.0.1.
[Files] ReferenceCode\Chipset\LynxPoint\*.*

[TAG] None
[Category] Improvement
[Description] Fix build error at 4653.
[Files] SBPEI.c

[TAG] None
[Category] Improvement
[Description] Update for 4.6.5.3_TBT_002.
[Files] SB.sd, SB.sdl

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-02-01
Source Control Label: 4.6.5.3_Intel_LPT-RC_101_027a
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_090_020 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1758
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1758
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
Support WS RAID device ID
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Has no wcam.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\PchXhci.asl
Fix disable SDIO will BSOD
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
...\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
...\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Support PCIE port swap.
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
OEM Fullreset function support.(EIP81593)
...\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
...\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed OSBD when interrupt mode is ACPI
....\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Add delay for HDD recovery.
[Files] SBPEI.c

[TAG] None
[Category] Improvement
[Description] Add Serial IO GNVS setup option.
[Files] SBDxe.c, SB.sd, SB.uni, SbSetupData.h, GetSetupData.c

[TAG] None
[Category] Bug Fix
[Severity] Important
[Symptom] BSOD when serial IO interrupt mode is ACPI
[RootCause] The update ASL will override the other code.
[Solution] Correct the override place.
[Files] PchSerialIo.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-02-10
Source Control Label: 4.6.5.3_Intel_LPT-RC_110_028
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_090_020 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1758
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1758
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
Support WS RAID device ID
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
...\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
...\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
...\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
...\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed OSBD when interrupt mode is ACPI
....\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] EIP114922
[Category] Improvement
[Description] Update PCH RC 1.1.0.
[Files] ..\ReferenceCode\Chipset\LynxPoint\*.*, SBDxe.c, SBPEI.c, SB.sd, SB.uni, GetSetupData.c, SbSetupDara.h

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-02-18
Source Control Label: 4.6.5.3_Intel_LPT-RC_110_028a
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_090_020 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1758
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1758
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
Support WS RAID device ID
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
...\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
...\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
...\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
...\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed OSBD when interrupt mode is ACPI
....\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Set PCIE root port function swapping default is disable.
[Files] SB.sd, SB.uni, SB.sdl

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-02-20
Source Control Label: 4.6.5.3_Intel_LPT-RC_110_028b
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_090_020 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1758
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1758
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
Support WS RAID device ID
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
...\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
...\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
...\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
...\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed OSBD when interrupt mode is ACPI
....\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] EIP115460
[Category] Improvement
[Description] PCH RC 1.1.0 Update.
[Files] PchPm.c

[TAG] None
[Category] Improvement
[Description] Correct UsbOverCurrentMapping array size fot LPT-LP
[Files] SBDxe.c

[TAG] None
[Category] Improvement
[Description] Add setup buffer for NFC.
[Files] GetSetupData.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-02-26
Source Control Label: 4.6.5.3_Intel_LPT-RC_120_029
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_090_020 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1758
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1758
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
Support WS RAID device ID
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
...\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
...\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
...\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
...\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
....\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] EIP116154
[Category] Improvement
[Description] Update PCH RC 1.2.0.
[Files] .\ReferenceCode\Chipset\LynxPoint\*.*, SBDxe.c

[TAG] None
[Category] Improvement
[Description] Follow intel BIOS V112 to change IRQ rout.
[Files] SB.sdl, SBPEI.c

[TAG] EIP113678
[Category] Improvement
[Description] Disable BIOS lock when recovery and capsule BIOS flash.
[Files] SBDxe.c

[TAG] None
[Category] Improvement
[Description] Change allocate memory space form bottom up to top down.
[Files] PchPm.c

[TAG] None
[Category] Improvement
[Description] Update right data for DSDT.
[Files] PchSerialIo.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-03-15
Source Control Label: 4.6.5.3_Intel_LPT-RC_130_030
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_080_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_090_020 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1758
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1758
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
Support WS RAID device ID
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
...\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
...\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
...\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
...\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
....\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] EIP118121
[Category] Improvement
[Description] Update PCH RC 1.3.0.
[Files] ..\ReferenceCode\Chipset\LynxPoint\*.*, SBDxe.c, SBPEI.c, SB.sd, SB.uni, GetSetupData.c, SbSetupData.h

[TAG] None
[Category] Improvement
[Description] Support ULT GPISMI.
[Files] SmiHandlerGeneric2.c

[TAG] EIP115528
[Category] Improvement
[Description] USB ports are connected to EHCI not XHCI when recovery.
[Files] SBPEI.c

[TAG] EIP106722
[Category] Improvement
[Description] Clear RTC before capsule function enter S3.
[Files] SBGeneric.c

[TAG] None
[Category] Improvement
[Description] Add Solid State Drive item to port 6.
[Files] GetSetupData.c, SbSetupData.h, SB.sd

[TAG] None
[Category] Improvement
[Description] Update Sata OpRom to 12.5.0.1815.
[Files] SataDriver.efi, SataOrom125.bin

[TAG] None
[Category] Improvement
[Description] Fixed coding error for OEM USB preport disable after setup menu.
[Files] SBDxe.c

[TAG] None
[Category] Improvement
[Description] Correct PCH LP B1 stepping.
[Files] SBSetup.c

[TAG] None
[Category] Improvement
[Description] Add token for PCH policy.
[Files] SBDxe.c, SB.sdl

[TAG] None
[Category] Improvement
[Description] Remove one BIOS lock marco.
[Files] SB.sd

[TAG] None
[Category] Improvement
[Description] Fixed first boot will hang at some platform.
[Files] PchReset.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-03-21
Source Control Label: 4.6.5.3_Intel_LPT-RC_130_030a
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_130_027a or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_130_025a or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
Support WS RAID device ID
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
...\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
...\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
...\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
...\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
....\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] EIP118480
[Category] Improvement
[Description] Use another array for ULT_USB_OVER_CURRENT_MAPPING_SETTINGS.
[Files] SBDxe.c

[TAG] EIP118158
[Category] Improvement
[Description] Correct SBLib_CmosRead () offset.
[Files] SmiHandlerPorting2.c, SBDxe.c, SBGeneric.c, SBSmm.c, SmiHandlerPorting.c

[TAG] None
[Category] Improvement
[Description] Improve alternate access mode enable/disable routine
[Files] SBGeneric.c, SBCspLib.h, SBSMI.c

[TAG] None
[Category] Improvement
[Description] Boot time improvement when PCIE slot has x4 or x8.
[Files] PchInitPeim.c

[TAG] None
[Category] Improvement
[Description] Fixed remove wrong setup item.
[Files] SB.sd

[TAG] EIP83075
[Category] Bug Fix
[Severity] Normal
[Symptom] USB3.0 mouse can not resume form S3 if shot down at POST before.
[Solution] Additional xHCI Controller Configurations Prior to Enter S5.
[Files] SBSMI.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-03-22
Source Control Label: 4.6.5.3_Intel_LPT-RC_131_031
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_130_027a or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_130_025a or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;
Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.
Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
Support WS RAID device ID
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
...\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
...\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
...\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
...\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
....\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] EIP118855
[Category] Improvement
[Description] Update PCH RC 1.3.1.
[Files] ..\ReferenceCode\Chipset\LynxPoint\*.*

[TAG] None
[Category] Improvement
[Description] Disable and clear PM1 Sources except power button for boot or resume.
[Files] AcpiModeEnable.c

[TAG] None
[Category] Improvement
[Description] Wireless LAN PHY use SLP_WLAN# pin
[Files] SB.sdl, SBDxe.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-03-25
Source Control Label: 4.6.5.3_Intel_LPT-RC_131_031a
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_130_027a or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_130_025a or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.
Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
Support WS RAID device ID
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
...\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
...\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
...\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
...\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
....\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Refine GPI SMM2 related routines.
[Files] SmiHandlerGeneric2.c; SmiHandlerPorting2.c; SmmChildDispatch2.h

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-03-26
Source Control Label: 4.6.5.3_Intel_LPT-RC_131_031b
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_130_027a or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_131_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_080_009 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
Support WS RAID device ID
..ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
...\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
...\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
...\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
...\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
....\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed

[TAG] None
[Category] Improvement
[Description] Update the address of operation region "XHCB" for Intel ACPI RC 1.3.1 compatible.
[Files] SBDxe.c

[TAG] None
[Category] Improvement
[Description] To Hide HPET setup option.
[Files] SB.sd

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-04-08
Source Control Label: 4.6.5.3_Intel_LPT-RC_140_032
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_140_027 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_140_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_140_024 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. Added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
# clear this bit.

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
[TAG] EIP116939
[Category] Bug Fix
[Severity] Normal
[Symptom] The available memory size is less than 2GB in Windowss 7 32 bit.
[RootCause] The "SB_TEMP_MMIO_BASE" is too low.
[Solution] Rearrange "SB_TEMP_MMIO_BASE" to 4GB - 16M(ROM) - 64KB (Intel Required).
[Files] SB.SDL; SBDxe.c

[TAG] EIP118045
[Category] Improvement
[Description] Creat tokens to support Power Button Notify for misc events. New token: "SX_NOTIFY_PWRB"
[Files] SB.SDL, SB.ASL

[TAG] EIP118531
[Category] Bug Fix
[Severity] Normal
[Symptom] IRST(IFFS) cannot wake by RTC
[RootCause] The PME and RTC enable bits will be cleared when IRST(iFFS) S3 to S4 transition.
[Solution] Do not clear thoese enable bits.
[Files] AcpiModeEnable.c

[TAG] EIP119703
[Category] Improvement
[Description] Clear RTC before BIOS flash capsule function enter S3.
[Files] SBGeneric.c

[TAG] EIP120159
[Category] Improvement
[Description] Update for Intel PCH LPT RC140. Added new tokens: 1. "PCH_RESET_CYCLE_DURATION"; 2. "LEGACY_DMA_DISABLE"
[Files] SB.SDL, SBDXE.c

[TAG] None
[Category] Improvement
[Description] Follow Intel BIOS 114.4 GPIO setting at ULT platform.
[Files] SB.sdl; SBPEIBoard.c

[TAG] None
[Category] Improvement
[Description] Fix coding error.
[Files] SmBusPei.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-04-18
Source Control Label: 4.6.5.3_Intel_LPT-RC_140_033
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_140_028b or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_140_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_140_024 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] None
[Category] Improvement
[Description] Update GbES02SxWorkaround() and add UsbS02SxWorkaround() for SBPwrBtnHandler().
[Files] SBSMI.c; SBSMI.h

[TAG] None
[Category] Improvement
[Description] Hide HPET device if it is disabled.
[Files] SBDXE.c

[TAG] None
[Category] Improvement
[Description] Change the default of SX_NOTIFY_PWRB to 1.
[Files] SB.SDL

EIP Addressed
[TAG] EIP120480
[Category] Improvement
[Description] Always disabling PCH platform policy "ExternalObffEn".
[Files] SB.SDL, SBDXE.c

[TAG] EIP120623
[Category] Bug Fix
[Severity] Important
[Symptom] LCD doesn't turn on automatically when resume from S3.
[RootCause] PM1_STS (PMBASE+00h) are cleared in EnableAcpiMode().
[Solution] Avoid PM1_STS clearing behavior is occurring in S3 resuming.
*AcpiModeEnable.c Rev#8~11(EIP101628 & EIP118531) are no need be existence.
[Files] SBPEI.c; AcpiModeEnable.c

[TAG] EIP120787
[Category] Bug Fix
[Severity] Normal
[Symptom] System might halts at CKP 0x55 with some specific combinations. (Ex: i7-4770 / 4570 + Hynix 4G / 2G)
[RootCause] All Reference codes are validated with Traditional and ULT build flags enabled. Having one of the flags disable may lead code execution that is not validated by Intel and may cause system instability.
[Solution] Make "TRAD_FLAG" and "ULT_FLAG" are coexist.
[Files] MemoryInit.sdl; SB.h

[TAG] EIP120857
[Category] Bug Fix
[Severity] Normal
[Symptom] TCO S3 Boot Script in wrong order. After S3 resume, TCO_EN bit didn't be restored.
[RootCause] Lockdown TCO bit is set before TCO_EN restore.
[Solution] Relocate PM_BASE+ALTGP_SMI_EN & SMI_EN save/restore to SbExitPmAuthProtocolCallback().
[Files] SBDxe.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-04-19
Source Control Label: 4.6.5.3_Intel_LPT-RC_140_034
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_140_028b or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_140_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_140_024 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx..
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] None
[Category] Improvement
[Description] Update GbES02SxWorkaround() and add UsbS02SxWorkaround() for SBPwrBtnHandler(). (Fix build error.)
[Files] SBSMI.c; SBSMI.h; SBGeneric.c; SBCspLib.h

EIP Addressed
None

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-04-23
Source Control Label: 4.6.5.3_Intel_LPT-RC_140_035
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_140_028b or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_140_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_140_024 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. Add token "ONLY_CLEAR_RTC_EN_IN_PEI" for improve "EIP120623".
a. 1: Only clear RTC_EN in PM1_EN \ 0: Clear all enable bits in PM1_EN.

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] None
[Category] Improvement
[Description] Add token "ONLY_CLEAR_RTC_EN_IN_PEI" for improve "EIP120623".
[Files] AcpiModeEnable.c; SB.SDL; SBPEI.c

EIP Addressed
None

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-04-23
Source Control Label: 4.6.5.3_Intel_LPT-RC_140_035a
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_140_028b or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_140_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_140_024 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. Add token "ONLY_CLEAR_RTC_EN_IN_PEI" for improve "EIP120623".
a. 1: Only clear RTC_EN in PM1_EN \ 0: Clear all enable bits in PM1_EN.

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] None
[Category] Improvement
[Description] Add token "ONLY_CLEAR_RTC_EN_IN_PEI" for improve "EIP120623".
[Files] AcpiModeEnable.c; SB.SDL; SBPEI.c

EIP Addressed
None

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-04-24
Source Control Label: 4.6.5.3_Intel_LPT-RC_140_036
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_140_028b or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_140_027 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_140_024 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. Add token "ONLY_CLEAR_RTC_EN_IN_PEI" for improve "EIP120623".
a. 1: Only clear RTC_EN in PM1_EN \ 0: Clear all enable bits in PM1_EN.

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] None
[Category] Improvement
[Description] Support PCIE hot plug for PCIE root port swap function when native mode.
[Files] PciHotPlug.c, PciHotPlug.c

[TAG] None
[Category] Improvement
[Description] Porting GPI interrupt by LPT-LP EDS 1.5.
[Files] SB.sdl, SB.H, SBPPI.h, SBPEI.c
[TAG] None
[Category] Improvement
[Description] Update LPT C0 stepping and separate stepping between LPT and LPT-LP.
[Files] SBSetup.c
[TAG] None
[Category] Improvement
[Description] THe NMI read port should before index update.
[Files] SBGeneric.c

EIP Addressed
[TAG] EIP118667
[Category] Improvement
[Description] For ULT when GPIO is GPO will also set GPI_DIS_DISABLE.
[Files] SBPEI.c
[TAG] EIP121262
[Category] Bug Fix
[Severity] Normal
[Symptom] SWOL BSOD.
[RootCause] When resume to OS hardware signal not ready. That made a dead loop in OS.
[Solution] Remove while loop and add sychnorized the object in asl code.
[Files] SB.asl, PchPcie.asl
[TAG] EIP82149
[Category] Improvement
[Description] Intel(R) 8 Series Chipset Family Deep Sx and CPU Soft-Strap BIOS Override Co-Existence Issue. If the soft-strap override feature is required and enabled, BIOS must disable Deep Sx functionality.
[Files] SBDxe.c, SB.sd, SBPlatformData.h
[TAG] EIP114861
[Category] Improvement
[Description] For PTT(Fast boot) 15 can reduce post for CD-ROM.
[Files] SBPEI.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-05-13
Source Control Label: 4.6.5.3_Intel_LPT-RC_150_037
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_150_029 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_150_028 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_150_027 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. Add token "ONLY_CLEAR_RTC_EN_IN_PEI" for improve "EIP120623".
a. 1: Only clear RTC_EN in PM1_EN \ 0: Clear all enable bits in PM1_EN.

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] None
[Category] Improvement
[Description] Remover ULT_SUPPORT token at SB.h.(UsbSb.c also need change to label 20)
[Files] SB.h

[TAG] None
[Category] Improvement
[Description] Make sure Clear the Start and FIS Receive Enable bit
[Files] SBDxe.c
[TAG] None
[Category] Improvement
[Description] Update LPT C0 stepping and separate stepping between LPT and LPT-LP.
[Files] SBSetup.c
[TAG] None
[Category] Improvement
[Description] THe NMI read port should before index update.
[Files] SBGeneric.c
[TAG] None
[Category] Improvement
[Description] Set time to default when clear cmos by jumper or remove battery.
[Files] SBPEI.c
[TAG] None
[Category] Improvement
[Description] Set LpssIntMode default to ACPI.
[Files] SB.sd
[TAG] None
[Category] Bug Fix
[Severity] Normal
[Symptom] Enable bit set at wrong place
[RootCause] The offset error
[Solution] Make offset correct.
[Files] SBPEI.c
[TAG] None
[Category] Bug Fix
[Severity] Normal
[Symptom] S3 resume Verb table will error when enable token "AMI_INIT_VERB_TABLE_IN_S3".
[RootCause] The FrontPanel is wrong.
[Solution] Change FrontPanel to frontSideNo.
[Files] AcpiModeEnable.c
[TAG] None
[Category] Improvement
[Description] Set token for OEM easy to modify.
[Files] PchAcpiTables.sdl, PchXhci.asl

EIP Addressed
[TAG] EIP115528
[Category] Improvement
[Description] Support XHCI port recovery when reset after boot to OS with XHCI driver.
[Files] SBPEI.c
[TAG] EIP121889
[Category] Bug Fix
[Severity] Normal
[Symptom] Sata device will show at wrong port.
[RootCause] The RC will disable sata controller when no data form sata controller D31:F5.
[Solution] Remove while loop and add sychnorized the object in asl code.
[Files] SBSetup.c
[TAG] EIP123117
[Category] Improvement
[Description] Fixed enable USB precondition, and do power off, power on, it will hang 9C.
[Files] SBPEI.c
[TAG] EIP123496
[Category] Improvement
[Description] Update PCH RC1.5.0.
[Files] ..\ReferenceCode\Chipset\LynxPoint\*.* , SBDxe.C, SBPEI.c, SB.sd, SB.uni, SbSetupData.h, GetSetupData.c
[TAG] EIP118277
[Category] Improvement
[Description] Make the size of S3 parameter as changeable for a more data store (Ex: a large Verb Table).
[Files] PchS3Support.c, PchS3Support.sdl

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-06-03
Source Control Label: 4.6.5.3_Intel_LPT-RC_150_038
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_150_029 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_150_028 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_150_027 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] None
[Category] Improvement
[Description] Change IASL compiler path.
[Files] SB.mak

[TAG] None
[Category] Improvement
[Description] Set token for OEM to change PchEhxi1.asl and PchEhxi2.asl.
[Files] PchAcpiTables.sdl, PchEhci1.asl, PchEhci2.asl
[TAG] None
[Category] Improvement
[Description] Follow Intel Doc. 493798 for Denlow SVR.
[Files] PchSata.c, PchRootPorts.c
[TAG] None
[Category] Improvement
[Description] Remove some code that move to Thunder Bolt module.
[Files] SB.sd

[TAG] None
[Category] Bug Fix
[Severity] Normal
[Symptom] GbE cannot wake form S5 under DOS.
[RootCause] he base address is incorrect.
[Solution] Correct base address.
[Files] SBSMI.c

EIP Addressed
[TAG] EIP124245
[Category] Improvement
[Description] On S3 resume under Raid mode System may gets hangs.
[Files] SBDxe.c
[TAG] EIP121740
[Category] Bug Fix
[Severity] Critical
[Symptom] Event log has HAL error after resume from S3.
[RootCause] Coding error for S3 script type.
[Solution] Correct the S3 script type.
[Files] SBDxe.c
[TAG] EIP120623
[Category] Improvement
[Description] LCD turn on automatically when resume from S3.
[Files] SBPEI.c, SBDxe.c, AcpiModeEnable.c
[TAG] EIP122981
[Category] Improvement
[Description] Support HarrisBeach CRB.
[Files] SB.sd, ACPI.sd, CRB.sdl
[TAG] EIP125453
[Category] Bug Fix
[Severity] Normal
[Symptom] Build field when enable "FORCE_USER_TO_SETUP_IF_CMOS_BAD"
[RootCause] Miss the header file.
[Files] SBDxe.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-06-24
Source Control Label: 4.6.5.3_Intel_LPT-RC_160_039
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_160_030 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_160_029a or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_150_027 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] None
[Category] Improvement
[Description] Fixed for Ubuntu firmware test.
[Files] Pch.asl

[TAG] None
[Category] Improvement
[Description] Remove XHCB at Dsdt table update.
[Files] SBDxe.c
[TAG] None
[Category] Improvement
[Description] Make sure the USB preport disable call back function processing is performed only once.
[Files] SBDxe.c
[TAG] None
[Category] Improvement
[Description] Update RC 150 GNVS.
[Files] SBDxe.c, SB.uni, SB.sd

EIP Addressed
[TAG] EIP127297
[Category] Improvement
[Description] Update PCH RC 1.6.0.
[Files] SB.sd, SBDxe.c, ..\ReferenceCode\Chipset\LynxPoint\*.*
[TAG] EIP127217
[Category] Improvement
[Description] Only update RC's ASL code for L event.
[Files] SBDxe.c, GPE.asl

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-07-15
Source Control Label: 4.6.5.3_Intel_LPT-RC_161_040
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] None
[Category] Improvement
[Description] Create "PCH Cross Throttling" setup item.(Only ULT support).
[Files] SBDxe.c, SB.sd, SB.uni, GetSetupData.c, SB.sd

[TAG] None
[Category] Improvement
[Description] Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver.
[Files] PchSmmSx.c
[TAG] None
[Category] Improvement
[Description] Update LPT-LP steeping.
[Files] SBSetup.c

EIP Addressed
[TAG] EIP127410
[Category] Improvement
[Description] Update DSDT taable when PCIE port swap function enable.
[Files] SBDxe.c
[TAG] EIP124410
[Category] Improvement
[Description] Implement SMBIOS type 88h for CRID.
[Files] SBDxe.c, SB.sdl, SB.sd, SBSetup.c, SBSetup.sdl
[TAG] EIP126943
[Category] Improvement
[Description] Create S3 boot script tabel for SATA2 controller even SATA1 hiden.
[Files] SBDxe.c
[TAG] EIP129089
[Category] Improvement
[Description] Update PCH RC 1.6.1.
[Files] SBDxe.c, SB.asl, ..\ReferenceCode\Chipset\LynxPoint\*.*

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-07-16
Source Control Label: 4.6.5.3_Intel_LPT-RC_161_040a
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] None
[Category] Improvement
[Description] Fixed build error at SharkBay DT.
[Files] SBDxe.c

EIP Addressed
None

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-07-18
Source Control Label: 4.6.5.3_Intel_LPT-RC_161_040b
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] None
[Category] Improvement
[Description] Let's GPIO GPINDIS bit setting by custom define except GPO.
[Files] SBPEI.c

EIP Addressed
[TAG] EIP128233
[Category] Improvement
[Description] Improving UEFI PXE image downloading proformance.
[Files] RTC.h, SBRun.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-08-01
Source Control Label: 4.6.5.3_Intel_LPT-RC_161_040c
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
None

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] None
[Category] Improvement
[Description] Support CRB without Super IO.
[Files] SB.sdl, SB.mak
[TAG] None
[Category] Improvement
[Description] Add PCIE LTR setup items.
[Files] SB.sd, SB.uni, SBDxe.c, GetSetupData.c, SbSetupData.h

[TAG] None
[Category] Improvement
[Description] Hidden and disable "SLP_LAN# low on DC power" for DT or sever platform.
[Files] SB.sd

EIP Addressed

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-08-22
Source Control Label: 4.6.5.3_Intel_LPT-RC_161_040d
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030d or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel Pch SB Refcode

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
EIP N/A - remove setup item which already has
EIP N/A - make sure CRB without SIO solution only for SharkBay MB/ULT CRB

EIP Addressed
EIP132701 - coding error in SBDxe.c on SharkBay/Broadwell platform

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] EIP N/A
[Category] Improvement
[Description] Remove setup item which already has.
[Files] SB.sd

[TAG] EIP N/A
[Category] Improvement
[Description] make sure CRB without SIO solution only for SharkBay MB/ULT CRB
[Files] SB.sdl SB.mak

EIP Addressed
[TAG] EIP132701
[Category] Bug Fix
[Severity] Normal
[Symptom] Coding error.
[RootCause] Incorrect offset of IO APIC data register.
[Solution] Correct the offset.
[Files] SBDxe.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-08-23
Source Control Label: 4.6.5.3_Intel_LPT-RC_162_041
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030d or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_10 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.6.2

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
EIP133819 - Shark Bay 8 Series / C220 Series Chipset Family and Lynx Point-LP PCH Chipset Framework Reference Code Production Version 1.6.2 implemente

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None
EIP Addressed
[TAG] EIP133819
[Category] Improvement
[Description] update for Intel PCH RC 1.6.2.0.
[Files] SB.sdl SBPEI.c ..\ReferenceCode\Chipset\LynxPoint\*.*

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-09-18
Source Control Label: 4.6.5.3_Intel_LPT-RC_162_042
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030d or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_024 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.6.2

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
EIP132976 - fix after plugging USB key on Rear USB3_1 (TOP) port(HS03) , there's no remove and save item in bot right corner
EIP136354 - Remove setting RCBA Coprocessor Error Enable bit
EIP134850 - Save/Restore Bit25 of PxCMD in Aptio Chipset Module

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None
EIP Addressed
[TAG] EIP132976
[Category] Improvement
[Description] fix after plugging USB key on Rear USB3_1 (TOP) port(HS03) , there's no remove and save item in bot right corner
[Files] PchAcpiTables.sdl PchXhci.asl

[TAG] EIP136354
[Category] Improvement
[Description] Remove setting RCBA Coprocessor Error Enable bit
[Files] SB.sdl SBPei.c

[TAG] EIP134850
[Category] New Feature
[Description] Save/Restore Bit25 of PxCMD in Aptio Chipset Module
[Files] SBDxe.c

[TAG] EIP N/A
[Category] Improvement
[Description] update AhciPlatformPolicy default value for AHCI module rev. 24
[Files] SBDxe.c

[TAG] EIP N/A
[Category] Improvement
[Description] set a token to enable/disable SATA DLAE bit
[Files] SB.sdl SBDxe.c

[TAG] EIP N/A
[Category] Improvement
[Description] use token to decide SATA RxEq policy vaule
[Files] SB.sdl SBPei.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
NONE

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-10-29
Source Control Label: 4.6.5.3_Intel_LPT-RC_162_043
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030d or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_024 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.6.2

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None

EIP Addressed
EIP139300 - Mispellings in Sb.uni
EIP138340 - SATA drive detection issue in PCH Platform BIOS reference code revision 1.6.2
EIP141266 - CPU exception error after apply "Save/Restore Bit25 of PxCMD" solution
EIP137385 - System hang if power button pushed on BSU, after windows shutdown / reboot
EIP136997 - fix build error when SUPPORT_RAID_DRIVER token is 0

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None
EIP Addressed
[TAG] EIP139300
[Category] Improvement
[Description] Mispellings in Sb.uni
[Files] SB.uni

[TAG] EIP138340
[Category] Improvement
[Description] SATA drive detection issue in PCH Platform BIOS reference code revision 1.6.2
[Files] SB.sdl SBPEI.c

[TAG] EIP141266
[Category] Bug Fix
[Severity] Normal
[Symptom] CPU exception error after apply "Save/Restore Bit25 of PxCMD" solution
[Root Cause] PciIO point is NULL
[Solution] if PciIO point is NULL, skip this Option ROM, because it must not be SATA Option Rom
[Files] SBDxe.c

[TAG] EIP137385
[Category] Bug Fix
[Severity] Normal
[Symptom] System hang if power button pushed on BSU, after windows shutdown / reboot
[Root Cause] Push power button key on RF keyboard will triger xhci hw smi, but xhci is set D3hot state in power button handler, then we can't service it
[Solution] Stop xhci before we set D3hot state and check if hciversion is valid
[Files] SBSMI.c

[TAG] EIP136997
[Category] Improvement
[Description] fix build error when SUPPORT_RAID_DRIVER token is 0
[Files] SBPei.c

[TAG] EIP N/A
[Category] Improvement
[Description] add programming serial IO device's SSID
[Files] SB.sdl SB.h

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP141417 - SharkBay Aptio 4 Intel PCH module 4.6.5.3_Intel_LPT-RC_162_042 releasing with unit test.

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-11-07
Source Control Label: 4.6.5.3_Intel_LPT-RC_170_044
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030d or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_024 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.7.0

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None
EIP Addressed
EIP142529 - [PCH_SHB]Shark Bay PCH Chipset Framework Reference Code Production Version 1.7.0

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None
EIP Addressed
[TAG] EIP142529
[Category] Improvement
[Description] update for Intel PCH RC 1.7.0.0.
[Files] SB.sdl SBPEI.c ..\ReferenceCode\Chipset\LynxPoint\*.*

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP142624 - SharkBay Aptio 4 Intel PCH module 4.6.5.3_Intel_LPT-RC_170_044 releasing with unit test.

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_162_043
4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-11-11
Source Control Label: 4.6.5.3_Intel_LPT-RC_170_044a
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030d or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_024 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.7.0

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
None

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None
EIP Addressed
EIP142529 - [PCH_SHB]Shark Bay PCH Chipset Framework Reference Code Production Version 1.7.0

Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] EIP N/A
[Category] Improvement
[Description] Fix build error.
[Files] SBDxe.c

EIP Addressed
[TAG] EIP142529
[Category] Improvement
[Description] update for Intel PCH RC 1.7.0.0.
[Files] SB.sdl SBPEI.c ..\ReferenceCode\Chipset\LynxPoint\*.*

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP142624 - SharkBay Aptio 4 Intel PCH module 4.6.5.3_Intel_LPT-RC_170_044 releasing with unit test.

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_170_044
4.6.5.3_Intel_LPT-RC_162_043
4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-12-30
Source Control Label: 4.6.5.3_Intel_LPT-RC_170_045
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030d or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_024 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.7.0

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
EIP141917 - Support SetTimer() with HPET Timer on Lynx Point
EIP148198 - Support Thunderbolt BIOS additions 1.8

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None
EIP Addressed
EIP144559 - S3 can't resume via USB KB and MS
EIP145008 - Force Power button event phase always as entry to avoid some power button issue
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] EIP N/A
[Category] Improvement
[Description] Support Thunderbolt new feature - Change Thunderbolt AIC location in run time.
[Files] SB.sd

[TAG] EIP N/A
[Category] Improvement
[Description] Follow Intel BIOS rev.135 to change I2C device default value.
[Files] SB.sd Sb.uni

[TAG] EIP N/A
[Category] Improvement
[Description] Support Thunderbolt new feature - Change Thunderbolt AIC location in run time.
[Files] SB.sd

[TAG] EIP N/A
[Category] Improvement
[Description] remove AMI overwrite for xhci auto wake issue because Intel RC 1.7.0 has fix it. Please refer Intel RC release note 1.7.0 for more detail information.
[Files] PchSmmSx.c

EIP Addressed
[TAG] EIP144559
[Category] Improvement
[Description] S3 can't resume via USB KB and MS under USB3.0 port in special case.
[Files] SBSMI.c SBSMI.h SBGeneric.c

[TAG] EIP145008
[Category] Improvement
[Description] Force Power button event phase always as entry to avoid some power button issue.
[Files] PchSmiDispatcher.sdl PchSmmPowerButton.c

[TAG] EIP141917
[Category] New Feature
[Description] Support SetTimer() with HPET Timer on Lynx Point.
[Files] SB.sdl SBGeneric.c SBDxe.c SbHpet.h sbProtocal.cif SamrtTimer.sdl

[TAG] EIP48198
[Category] Spec Update
[Severity] Normal
[Description] Support Thunderbolt Sample code rev. 1.8.
[Files] PchPcie.asl

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP148849 - SharkBay Aptio 4 Intel PCH module 4.6.5.3_Intel_LPT-RC_170_045 releasing with unit test.

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_170_044a
4.6.5.3_Intel_LPT-RC_170_044
4.6.5.3_Intel_LPT-RC_162_043
4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2013-12-31
Source Control Label: 4.6.5.3_Intel_LPT-RC_170_045a
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030d or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_024 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USBPREPORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.7.0

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
EIP141917 - Support SetTimer() with HPET Timer on Lynx Point
EIP148198 - Support Thunderbolt BIOS additions 1.8

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None
EIP Addressed
EIP144559 - S3 can't resume via USB KB and MS
EIP145008 - Force Power button event phase always as entry to avoid some power button issue
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] EIP N/A
[Category] Improvement
[Description] Support Thunderbolt new feature - Change Thunderbolt AIC location in run time.
[Files] SB.sd

[TAG] EIP N/A
[Category] Improvement
[Description] Follow Intel BIOS rev.135 to change I2C device default value.
[Files] SB.sd Sb.uni

[TAG] EIP N/A
[Category] Improvement
[Description] Support Thunderbolt new feature - Change Thunderbolt AIC location in run time.
[Files] SB.sd

[TAG] EIP N/A
[Category] Improvement
[Description] remove AMI overwrite for xhci auto wake issue because Intel RC 1.7.0 has fix it. Please refer Intel RC release note 1.7.0 for more detail information.
[Files] PchSmmSx.c

EIP Addressed
[TAG] EIP144559
[Category] Improvement
[Description] S3 can't resume via USB KB and MS under USB3.0 port in special case.
[Files] SBSMI.c SBSMI.h SBGeneric.c

[TAG] EIP145008
[Category] Improvement
[Description] Force Power button event phase always as entry to avoid some power button issue.
[Files] PchSmiDispatcher.sdl PchSmmPowerButton.c

[TAG] EIP141917
[Category] New Feature
[Description] Support SetTimer() with HPET Timer on Lynx Point.
[Files] SB.sdl SBGeneric.c SBDxe.c SbHpet.h sbProtocal.cif SamrtTimer.sdl

[TAG] EIP148198
[Category] Spec Update
[Severity] Normal
[Description] Support Thunderbolt Sample code rev. 1.8.
[Files] PchPcie.asl

[TAG] EIP134111
[Category] Improvement
[Description] Unable to locate SMM EFI_SPI_PROTOCOL on label 28 code.
[Files] PchSpi.dxs

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP148849 - SharkBay Aptio 4 Intel PCH module 4.6.5.3_Intel_LPT-RC_170_045 releasing with unit test.

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_170_045
4.6.5.3_Intel_LPT-RC_170_044a
4.6.5.3_Intel_LPT-RC_170_044
4.6.5.3_Intel_LPT-RC_162_043
4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2014-03-14
Source Control Label: 4.6.5.3_Intel_LPT-RC_170_046
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030d or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_024 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USB_PER_PORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.
19. Change OEM_USBPREPORT_DISABLE_SUPPORT token name to OEM_USB_PER_PORT_DISABLE_SUPPORT

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.7.0

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
NONE

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
Fix EIP118277 generic solution not working.
Fix build error when remove or disable CSM module.
EIP Addressed
EIP136638 - Fix programming error.
EIP149596 - system cannot enter recovery mode when CMOS is bad.
EIP150529 - System hang due to dysfunctional MRC delay routine.
EIP153695 - USB Per port control is not reasonable when OEM_USBPREPORT_DISABLE_SUPPORT token is Enabled and USB devices are behind hubs.
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] EIP N/A
[Category] Improvement
[Description] Fix EIP118277 generic solution not working.
[Files] PchS3Support.sdl PchS3Support.c

[TAG] EIP N/A
[Category] Improvement
[Description] Fix build error when remove or disable CSM module.
[Files] SBDxe.c

[TAG] EIP N/A
[Category] Bug Fix
[Severity] Normal
[Symptom] FORCE_PWB_PHASE_AS_ENTRY definition is not includeing to PchSmmPowerButton.c
[Root Cause] Not include Token.h
[Solution] Include Token.h
[Files] PchSmmPowerButton.c

EIP Addressed
[TAG] EIP136638
[Category] Improvement
[Description] Fix programming error.
[Files] SBGeneric.c PchResetCommon.c

[TAG] EIP149596
[Category] Improvement
[Description] system cannot enter recovery mode when CMOS is bad.
[Files] SBPei.c

[TAG] EIP150529
[Category] Improvement
[Description] System hang due to dysfunctional MRC delay routine.
[Files] SBPei.c

[TAG] EIP153695
[Category] Improvement
[Description] USB Per port control is not reasonable when OEM_USBPREPORT_DISABLE_SUPPORT token is Enabled and USB devices are behind hubs.
[Files] Sb.sdl Sb.sd Sb.uni GetSetupData.c SbDxe.c PchUsbCommon.c PchRegsUsb.h

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP158775 - SharkBay Aptio 4 Intel PCH module 4.6.5.3_Intel_LPT-RC_170_046 releasing with unit test.

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_170_045a
4.6.5.3_Intel_LPT-RC_170_045
4.6.5.3_Intel_LPT-RC_170_044a
4.6.5.3_Intel_LPT-RC_170_044
4.6.5.3_Intel_LPT-RC_162_043
4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2014-03-14
Source Control Label: 4.6.5.3_Intel_LPT-RC_180_047
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030d or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_024 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USB_PER_PORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.
19. Change OEM_USBPREPORT_DISABLE_SUPPORT token name to OEM_USB_PER_PORT_DISABLE_SUPPORT

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.8.0

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
NONE

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE
EIP Addressed
EIP158783 - [PCH] Shark Bay-M/DT Reference Code Production Version 1.8.0.
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE
EIP Addressed
[TAG] EIP158783
[Category] Spec Update
[Description] Update Intel PCH RC 1.8.0.
[Files] ReferenceCode\*.*

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP158783 - [PCH] Shark Bay-M/DT Reference Code Production Version 1.8.0.

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_170_046
4.6.5.3_Intel_LPT-RC_170_045a
4.6.5.3_Intel_LPT-RC_170_045
4.6.5.3_Intel_LPT-RC_170_044a
4.6.5.3_Intel_LPT-RC_170_044
4.6.5.3_Intel_LPT-RC_162_043
4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2014-03-21
Source Control Label: 4.6.5.3_Intel_LPT-RC_180_047b
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030d or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_024 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL4.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USB_PER_PORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.
19. Change OEM_USBPREPORT_DISABLE_SUPPORT token name to OEM_USB_PER_PORT_DISABLE_SUPPORT

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.8.0

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
NONE

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE
EIP Addressed
EIP158783 - [PCH] Shark Bay-M/DT Reference Code Production Version 1.8.0.
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE
EIP Addressed
[TAG] EIP158783
[Category] Spec Update
[Description] Update Intel PCH RC 1.8.0.
[Files] ReferenceCode\*.*

[TAG] EIP158783
[Category] Improvement
[Description] Fix programming error.
[Files] SbDxe.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP158783 - [PCH] Shark Bay-M/DT Reference Code Production Version 1.8.0.

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_180_047
4.6.5.3_Intel_LPT-RC_170_046
4.6.5.3_Intel_LPT-RC_170_045a
4.6.5.3_Intel_LPT-RC_170_045
4.6.5.3_Intel_LPT-RC_170_044a
4.6.5.3_Intel_LPT-RC_170_044
4.6.5.3_Intel_LPT-RC_162_043
4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2014-05-21
Source Control Label: 4.6.5.3_Intel_LPT-RC_180_048a
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030d or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_024 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL5.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USB_PER_PORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.
19. Change OEM_USBPREPORT_DISABLE_SUPPORT token name to OEM_USB_PER_PORT_DISABLE_SUPPORT
20. Create five tokens "SPI_PROTECTED_RANGE_X" for SPI range protected security, when the range type for token item is BIOS Type/Gbe Type/Me Type, the protected base is rom type address not flash address

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.8.0

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
Add SPI Range Protected security

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE
EIP Addressed
EIP167028 - Variable's attribute needs to be reviewed by PCH component driver.
EIP167087 - BIOS security improvement on Haswell CRB project.
EIP165410 - Support Thunderbolt AIC at NB PCIE slot.
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE
EIP Addressed
[TAG] EIP167028
[Category] Improvement
[Description] Variable's attribute needs to be reviewed by PCH component driver.
[Files] SB.sd SBDxe.c WdtAppDxe.c SB.sdl

[TAG] EIP167087
[Category] Improvement
[Description] BIOS security improvement on Haswell CRB project.
[Files] SBGeneric.c SBDxe.c SBCspLib.h Sb.sdl Sb.sd Sb.h

[TAG] EIP165410
[Category] Improvement
[Description] Support Thunderbolt AIC at NB PCIE slot.
[Files] Sb.sd PciHotPlug.c

[TAG] EIP156783
[Category] Improvement
[Description] fix build error when removing usb recovery module.
[Files] SbPei.c

[TAG] EIP N/A
[Category] Improvement
[Description] remove unnecessary source code.
[Files] SbDxe.c

[TAG] EIP N/A
[Category] Improvement
[Description] Support new Thunderbolt module.
[Files] PchPcie.asl

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP169990 - SharkBay Aptio 4 Intel PCH module 4.6.5.3_Intel_LPT-RC_180_048 releasing with unit test.

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_180_047b
4.6.5.3_Intel_LPT-RC_180_047
4.6.5.3_Intel_LPT-RC_170_046
4.6.5.3_Intel_LPT-RC_170_045a
4.6.5.3_Intel_LPT-RC_170_045
4.6.5.3_Intel_LPT-RC_170_044a
4.6.5.3_Intel_LPT-RC_170_044
4.6.5.3_Intel_LPT-RC_162_043
4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2014-09-05
Source Control Label: 4.6.5.3_Intel_LPT-RC_180_049.1
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030d or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_024 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL5.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USB_PER_PORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.
19. Change OEM_USBPREPORT_DISABLE_SUPPORT token name to OEM_USB_PER_PORT_DISABLE_SUPPORT
20. Create five tokens "SPI_PROTECTED_RANGE_X" for SPI range protected security, when the range type for token item is BIOS Type/Gbe Type/Me Type, the protected base is rom type address not flash address

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.8.0

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
Add SPI Range Protected security

Intel Sightings Report in this label:
506558 [Lynx Point] Chipset – Intel® 8 Series / C220 Series Chipset Family (PCH) Sightings Report (SR) – Rev. 6.0

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE
EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG]None
[Category] Bug Fix
[Description] Fix Build Error when token "PI_0_9_CHILD_DISPATCHER_SUPPORT" = 0
[File]SmiHandlerGeneric2.c

EIP Addressed
[TAG] EIP182598
[Category] Bug Fix
[Severity] Normal
[Symptom] Missing ULT differentiation in InstallDxePchPlatformPolicy() for GbE slot number detection
[RootCause] In InstallDxePchPlatformPolicy(), there is a ULT differentiation missing.
[Solution] The strap readout, is not the same for LynxPoint LP. Add determine to set value.
[File]SBDxe.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP169990 - SharkBay Aptio 4 Intel PCH module 4.6.5.3_Intel_LPT-RC_180_048 releasing with unit test.

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_180_049a
4.6.5.3_Intel_LPT-RC_180_049
4.6.5.3_Intel_LPT-RC_180_048a
4.6.5.3_Intel_LPT-RC_180_047b
4.6.5.3_Intel_LPT-RC_180_047
4.6.5.3_Intel_LPT-RC_170_046
4.6.5.3_Intel_LPT-RC_170_045a
4.6.5.3_Intel_LPT-RC_170_045
4.6.5.3_Intel_LPT-RC_170_044a
4.6.5.3_Intel_LPT-RC_170_044
4.6.5.3_Intel_LPT-RC_162_043
4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2014-07-11
Source Control Label: 4.6.5.3_Intel_LPT-RC_180_049
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030d or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_024 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL5.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USB_PER_PORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.
19. Change OEM_USBPREPORT_DISABLE_SUPPORT token name to OEM_USB_PER_PORT_DISABLE_SUPPORT
20. Create five tokens "SPI_PROTECTED_RANGE_X" for SPI range protected security, when the range type for token item is BIOS Type/Gbe Type/Me Type, the protected base is rom type address not flash address

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.8.0

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
Add SPI Range Protected security

Intel Sightings Report in this label:
506558 [Lynx Point] Chipset – Intel® 8 Series / C220 Series Chipset Family (PCH) Sightings Report (SR) – Rev. 6.0

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE
EIP Addressed
176980 - Change "#else if" to "#elif"
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] EIP176980
[Category] Improvement
[Description] Change "#else if" to "#elif"

EIP Addressed
NONE

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP169990 - SharkBay Aptio 4 Intel PCH module 4.6.5.3_Intel_LPT-RC_180_048 releasing with unit test.

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_180_049
4.6.5.3_Intel_LPT-RC_180_048a
4.6.5.3_Intel_LPT-RC_180_047b
4.6.5.3_Intel_LPT-RC_180_047
4.6.5.3_Intel_LPT-RC_170_046
4.6.5.3_Intel_LPT-RC_170_045a
4.6.5.3_Intel_LPT-RC_170_045
4.6.5.3_Intel_LPT-RC_170_044a
4.6.5.3_Intel_LPT-RC_170_044
4.6.5.3_Intel_LPT-RC_162_043
4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2014-07-25
Source Control Label: 4.6.5.3_Intel_LPT-RC_180_049a
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030d or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_024 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL5.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USB_PER_PORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.
19. Change OEM_USBPREPORT_DISABLE_SUPPORT token name to OEM_USB_PER_PORT_DISABLE_SUPPORT
20. Create five tokens "SPI_PROTECTED_RANGE_X" for SPI range protected security, when the range type for token item is BIOS Type/Gbe Type/Me Type, the protected base is rom type address not flash address

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.8.0

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
Add SPI Range Protected security

Intel Sightings Report in this label:
506558 [Lynx Point] Chipset – Intel® 8 Series / C220 Series Chipset Family (PCH) Sightings Report (SR) – Rev. 6.0

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE
EIP Addressed
Add daylight savings features. Program BUC.SDO to 1 on normal boot in PCH component.
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
[TAG] NONE
[Category] Improvement
[Description] Daylight savings features. Program BUC.SDO to 1 on normal boot in PCH component.

EIP Addressed
NONE

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP169990 - SharkBay Aptio 4 Intel PCH module 4.6.5.3_Intel_LPT-RC_180_048 releasing with unit test.

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_180_049
4.6.5.3_Intel_LPT-RC_180_048a
4.6.5.3_Intel_LPT-RC_180_047b
4.6.5.3_Intel_LPT-RC_180_047
4.6.5.3_Intel_LPT-RC_170_046
4.6.5.3_Intel_LPT-RC_170_045a
4.6.5.3_Intel_LPT-RC_170_045
4.6.5.3_Intel_LPT-RC_170_044a
4.6.5.3_Intel_LPT-RC_170_044
4.6.5.3_Intel_LPT-RC_162_043
4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2015-01-29
Source Control Label: 4.6.5.3_Intel_LPT-RC_190_050.1
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_190_39 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_190_034 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK1117_Patch8_03 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_190_034 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL5.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USB_PER_PORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.
19. Change OEM_USBPREPORT_DISABLE_SUPPORT token name to OEM_USB_PER_PORT_DISABLE_SUPPORT
20. Create five tokens "SPI_PROTECTED_RANGE_X" for SPI range protected security, when the range type for token item is BIOS Type/Gbe Type/Me Type, the protected base is rom type address not flash address

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.9.0

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
Add SPI Range Protected security

Intel Sightings Report in this label:
506558 [Lynx Point] Chipset – Intel® 8 Series / C220 Series Chipset Family (PCH) Sightings Report (SR) – Rev. 6.0

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE
EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None
EIP Addressed
[TAG] EIP200269
[Category] New Feature
[Description] For add FlashSmi : Label 4.6.5.5_FlashSmi_00 ($/Alaska/SOURCE/Modules/FlashSmi)
[File] SBGeneric.c, SBDxe.c
[TAG] EIP20069
[Category] Bug Fix
[Severity] Normal
[Symptom] Add JMB36X module SATA setup status error
[RootCause] SBSetup.c is incomplete to difference betwenn device 28 and 31.
[Solution] Determine device 28 and 31.
[File] SBSetup.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP194525

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_190_050
4.6.5.3_Intel_LPT-RC_180_049.2
4.6.5.3_Intel_LPT-RC_180_049.1
4.6.5.3_Intel_LPT-RC_180_049a
4.6.5.3_Intel_LPT-RC_180_049
4.6.5.3_Intel_LPT-RC_180_048a
4.6.5.3_Intel_LPT-RC_180_047b
4.6.5.3_Intel_LPT-RC_180_047
4.6.5.3_Intel_LPT-RC_170_046
4.6.5.3_Intel_LPT-RC_170_045a
4.6.5.3_Intel_LPT-RC_170_045
4.6.5.3_Intel_LPT-RC_170_044a
4.6.5.3_Intel_LPT-RC_170_044
4.6.5.3_Intel_LPT-RC_162_043
4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2015-02-10
Source Control Label: 4.6.5.3_Intel_LPT-RC_190_050.2
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_190_39 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_190_034 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK1117_Patch8_03 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_190_034 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

SEVEN
Dependent Component Title: FLASH SMI
Dependent Component Reference Name: Flash_SMI
Dependent Source Control Label: 4.6.5.5_FlashSmi_00 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/FlashSmi;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL5.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USB_PER_PORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.
19. Change OEM_USBPREPORT_DISABLE_SUPPORT token name to OEM_USB_PER_PORT_DISABLE_SUPPORT
20. Create five tokens "SPI_PROTECTED_RANGE_X" for SPI range protected security, when the range type for token item is BIOS Type/Gbe Type/Me Type, the protected base is rom type address not flash address

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.9.0

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
Add SPI Range Protected security

Intel Sightings Report in this label:
506558 [Lynx Point] Chipset – Intel® 8 Series / C220 Series Chipset Family (PCH) Sightings Report (SR) – Rev. 6.0

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE
EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None
EIP Addressed
[TAG] EIP200269
[Category] New Feature
[Description] For add FlashSmi : Label 4.6.5.5_FlashSmi_00 ($/Alaska/SOURCE/Modules/FlashSmi)
[File] SBGeneric.c, SBDxe.c
[TAG] EIP20069
[Category] Bug Fix
[Severity] Normal
[Symptom] Add JMB36X module SATA setup status error
[RootCause] SBSetup.c is incomplete to difference betwenn device 28 and 31.
[Solution] Determine device 28 and 31.
[File] SBSetup.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP194525

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_190_050.1
4.6.5.3_Intel_LPT-RC_190_050
4.6.5.3_Intel_LPT-RC_180_049.2
4.6.5.3_Intel_LPT-RC_180_049.1
4.6.5.3_Intel_LPT-RC_180_049a
4.6.5.3_Intel_LPT-RC_180_049
4.6.5.3_Intel_LPT-RC_180_048a
4.6.5.3_Intel_LPT-RC_180_047b
4.6.5.3_Intel_LPT-RC_180_047
4.6.5.3_Intel_LPT-RC_170_046
4.6.5.3_Intel_LPT-RC_170_045a
4.6.5.3_Intel_LPT-RC_170_045
4.6.5.3_Intel_LPT-RC_170_044a
4.6.5.3_Intel_LPT-RC_170_044
4.6.5.3_Intel_LPT-RC_162_043
4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2014-12-02
Source Control Label: 4.6.5.3_Intel_LPT-RC_190_050
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_161_031 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_161_030d or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK_1117_Patch8_01 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_161_030 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_024 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL5.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USB_PER_PORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.
19. Change OEM_USBPREPORT_DISABLE_SUPPORT token name to OEM_USB_PER_PORT_DISABLE_SUPPORT
20. Create five tokens "SPI_PROTECTED_RANGE_X" for SPI range protected security, when the range type for token item is BIOS Type/Gbe Type/Me Type, the protected base is rom type address not flash address

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.9.0

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
Add SPI Range Protected security

Intel Sightings Report in this label:
506558 [Lynx Point] Chipset – Intel® 8 Series / C220 Series Chipset Family (PCH) Sightings Report (SR) – Rev. 6.0

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE
EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None
EIP Addressed
[TAG] EIP194525
[Category] New Feature
[Description] Shark Bay PCH Reference Code Production Version 1.9.0

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP194525

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_180_049.2
4.6.5.3_Intel_LPT-RC_180_049.1
4.6.5.3_Intel_LPT-RC_180_049a
4.6.5.3_Intel_LPT-RC_180_049
4.6.5.3_Intel_LPT-RC_180_048a
4.6.5.3_Intel_LPT-RC_180_047b
4.6.5.3_Intel_LPT-RC_180_047
4.6.5.3_Intel_LPT-RC_170_046
4.6.5.3_Intel_LPT-RC_170_045a
4.6.5.3_Intel_LPT-RC_170_045
4.6.5.3_Intel_LPT-RC_170_044a
4.6.5.3_Intel_LPT-RC_170_044
4.6.5.3_Intel_LPT-RC_162_043
4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2015-05-21
Source Control Label: 4.6.5.3_Intel_LPT-RC_191_051
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_190_39 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_190_034 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK1117_Patch8_03 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_190_034 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

SEVEN
Dependent Component Title: FLASH SMI
Dependent Component Reference Name: Flash_SMI
Dependent Source Control Label: 4.6.5.5_FlashSmi_00 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/FlashSmi;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL5.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USB_PER_PORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.
19. Change OEM_USBPREPORT_DISABLE_SUPPORT token name to OEM_USB_PER_PORT_DISABLE_SUPPORT
20. Create five tokens "SPI_PROTECTED_RANGE_X" for SPI range protected security, when the range type for token item is BIOS Type/Gbe Type/Me Type, the protected base is rom type address not flash address

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.9.1

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
Add SPI Range Protected security

Intel Sightings Report in this label:
506558 [Lynx Point] Chipset – Intel® 8 Series / C220 Series Chipset Family (PCH) Sightings Report (SR) – Rev. 6.0

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE
EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None
EIP Addressed
[TAG] EIP217847
[Category] Improvement
[Description] [PCH] Shark Bay-M/DT Reference Code Production Version 1.9.1

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP217847

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_190_050.2
4.6.5.3_Intel_LPT-RC_190_050.1
4.6.5.3_Intel_LPT-RC_190_050
4.6.5.3_Intel_LPT-RC_180_049.2
4.6.5.3_Intel_LPT-RC_180_049.1
4.6.5.3_Intel_LPT-RC_180_049a
4.6.5.3_Intel_LPT-RC_180_049
4.6.5.3_Intel_LPT-RC_180_048a
4.6.5.3_Intel_LPT-RC_180_047b
4.6.5.3_Intel_LPT-RC_180_047
4.6.5.3_Intel_LPT-RC_170_046
4.6.5.3_Intel_LPT-RC_170_045a
4.6.5.3_Intel_LPT-RC_170_045
4.6.5.3_Intel_LPT-RC_170_044a
4.6.5.3_Intel_LPT-RC_170_044
4.6.5.3_Intel_LPT-RC_162_043
4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2012 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2015-07-13
Source Control Label: 4.6.5.3_Intel_LPT-RC_191_051.2
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_190_39 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_190_034 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK1117_Patch8_03 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_190_034 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

SEVEN
Dependent Component Title: FLASH SMI
Dependent Component Reference Name: Flash_SMI
Dependent Source Control Label: 4.6.5.5_FlashSmi_00 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/FlashSmi;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL5.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USB_PER_PORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.
19. Change OEM_USBPREPORT_DISABLE_SUPPORT token name to OEM_USB_PER_PORT_DISABLE_SUPPORT
20. Create five tokens "SPI_PROTECTED_RANGE_X" for SPI range protected security, when the range type for token item is BIOS Type/Gbe Type/Me Type, the protected base is rom type address not flash address

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.9.1

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
Add SPI Range Protected security

Intel Sightings Report in this label:
506558 [Lynx Point] Chipset – Intel® 8 Series / C220 Series Chipset Family (PCH) Sightings Report (SR) – Rev. 6.0

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE
EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None
EIP Addressed
[TAG] None
[Category] Improvement
[Description] Coding error in ElogGenerateNmiNow ().
[Files] Chipset\SB\SBSMI.c
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP215945

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_191_051.1
4.6.5.3_Intel_LPT-RC_191_051
4.6.5.3_Intel_LPT-RC_190_050.2
4.6.5.3_Intel_LPT-RC_190_050.1
4.6.5.3_Intel_LPT-RC_190_050
4.6.5.3_Intel_LPT-RC_180_049.2
4.6.5.3_Intel_LPT-RC_180_049.1
4.6.5.3_Intel_LPT-RC_180_049a
4.6.5.3_Intel_LPT-RC_180_049
4.6.5.3_Intel_LPT-RC_180_048a
4.6.5.3_Intel_LPT-RC_180_047b
4.6.5.3_Intel_LPT-RC_180_047
4.6.5.3_Intel_LPT-RC_170_046
4.6.5.3_Intel_LPT-RC_170_045a
4.6.5.3_Intel_LPT-RC_170_045
4.6.5.3_Intel_LPT-RC_170_044a
4.6.5.3_Intel_LPT-RC_170_044
4.6.5.3_Intel_LPT-RC_162_043
4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Component Information:
Component Title: Intel PCH
Component Reference Name: Intel PCH
Component Type: eChipset
Release Date: 2015-05-27
Source Control Label: 4.6.5.3_Intel_LPT-RC_191_051.1
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint;

Dependencies

ONE
Dependent Component Title: Intel System Agent
Dependent Component Reference Name: Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_190_39 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/NorthBridge/Haswell;

TWO
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_190_034 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

THREE
Dependent Component Title: Intel EDK
Dependent Component Reference Name: Intel EDK
Dependent Source Control Label: 4.6.5.3_IntelEDK1117_Patch8_03 or above
Dependent Source Control Location: SS: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;

FOUR
Dependent Component Title: Post Time Tuning
Dependent Component Reference Name: FastBoot
Dependent Source Control Label: 4.6.4.0_PTT_16 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/PTT;

FIVE
Dependent Component Title: Intel Rapid Start Technology
Dependent Component Reference Name: Intel Rapid Start Technology
Dependent Source Control Label: 4.6.5.3_iRST-RC_190_034 or above
Dependent Source Control Location: SS: Alaska/SOURCE/Modules/Intel Fast Flash Standby/iRST_SharkBay;

SIX
Dependent Component Title: AHCI
Dependent Component Reference Name: AHCI
Dependent Source Control Label: 4.6.3_AhciSrc_026 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/SOURCE/Modules/AHCI;

SEVEN
Dependent Component Title: FLASH SMI
Dependent Component Reference Name: Flash_SMI
Dependent Source Control Label: 4.6.5.5_FlashSmi_00 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/FlashSmi;

File Dependencies
N0NE

Protocol Dependencies
N0NE

Non-Compiled BIN and LIB File(s) within this Component:

GbE_OR.BIN v1.3.95
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataOrom120.BIN v12.5.0.1815
Component Title: Intel Pch SB Chipset
Component Reference Name: Intel Pch SB Chipset
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset;

SataDriver.efi v12.5.0.1815
Component Title: PchSataDriver
Component Reference Name: SataDriver
Component Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Intel/SouthBridge/LynxPoint\Intel Pch SB Chipset/SataDriver;

Component Description:
Intel Platform Control Hub - Lynx Point initialization.
This is a caption
Filename | Description
sb.cif | Intel PCH eChipset CIF file.
ReleaseNotes.chm | Intel PCH eChipset CHM file.

ModulePart Name: Intel Pch SB Board
ModulePart Description: Intel Pch SB Board Component Settings.

Filename | Description
sbBOARD.CIF | Intel Pch SB Board CIF file.
SB.sdl | South Bridge parameters.
SB.mak | South Bridge make file.
SBSECInit.asm | South Bridge SEC initialization.
SBPEIBoard.c | This file contains PEI stage board component code for South Bridge.
SBDXEBoard.c | This file contains DXE stage board component code for South Bridge.
SB.H | South Bridge header file, define all the South Bridge specific equates and structures in this file.
HDAVBTBL.h | HDA Verb Table header file.
SBPEI.dxs | Protocol and Table Protocol defined.
SBDXE.dxs | This file is the dependency file for the SB DXE driver.
SBRun.dxs | This file is the dependency file for the SB Runtime driver.
SBPeiDebugger.c | This file contains PEI stage debugger code for SB.
GetSetupData.c | Custom South Bridge setup data behavior implementation.
SbSetupData.h | Custom South Bridge setup data behavior implementation.
Sb.ssp | Cmos Manager Setup Script Processor for SB.
ModulePart Name: SBSetup
ModulePart Description: South Bridge Setup Settings.
Filename | Description
SBSetup.cif | South Bridge Setup CIF file.
SBSetup.sdl | South Bridge Setup parameters.
SBSetup.mak | South Bridge Setup make file.
SB.sd | South Bridge setup form.
SB.uni | South Bridge setup string definitions.
SBSetup.c | South Bridge Setup Rountines.
ModulePart Name: Intel Pch SB Chipset
ModulePart Description: Intel Pch SB Chipset Settings.
Filename | Description
sbCSP.CIF | Intel Pch SB Chipset CIF file.
SBGeneric.c | South Bridge related code that is needed for both PEI & DXE stage.
SBPEI.c | South Bridge initialization in the PEI stage.
SBDxe.c | South Bridge initialization in the DXE stage.
SBCspLib.h | South Bridge chipset porting functions and data structures definition for both PEI & DXE stage.
RTC.h | Real Time Clock and CMOS Data bank registr definitions.
SBRun.c | South Bridge general runtime protocol.
SBSmm.c | South Bridge SMI related code.
RRIORDMA.asl | The ASL file for South Bridge LPC I/O Decoding & DMA assignment.
GbE_OR.BIN | Intel Gigabit ethernet option ROM.
SB.ASL | The ASL file for South Bridge specific function.
SataOrom120.bin | Intel RAID option ROM.
IDE.ASL | IDE Controller ASL file.
SATA.ASL | SATA Controller ASL file.
ModulePart Name: SB PPI
ModulePart Description: South Bridge PPI Definition.
Filename | Description
sbPPI.CIF | SB PPI CIF file.
SBPPI.h | This header file contains the PPI definition for the SB.
ModulePart Name: SB Protocols
ModulePart Description: South Bridge Protocol Definition.
Filename | Description
sbProtocols.CIF | SB Protocol CIF file.
PIDEController.h | The header file for the south bridge ATA controller(s).
SmmBiosWriteDispatch.h | SMM BIOS Write Dispatch Protocol header.
SBSmiProtocol.h | South Bridge SMI Dispatch Protocol header.
SmmIoTrapDispatch.h | The header file for I/O Trap SMM Dispatch Protocol.
SmmPchIoTrapDispatch2.h | The header file for I/O Trap#2 SMM Dispatch Protocol.
SBPlatformData.h | SB Specific Setup Variables and Structures.
ModulePart Name: SmBus
ModulePart Description: Smbus settings.
Filename | Description
SmBus.cif | SmBus CIF file.
SmBus.sdl | Smbus parameters.
SmBus.mak | Make file for SMBus PEI and DXE components.
SmBusCommon.h | SMBUS shared PEI and DXE Smbus functions and data structures definitions.
SmBusPei.h | SMBUS PEI Driver functions and data structures definition.
SmBusDxe.h | SMBUS DXE Driver functions and data structures definition.
SmBusCommon.c | SMBUS driver common functions implementation.
SmBusPorting.c | SMBUS driver porting functions.
SmBusPei.c | SMBUS driver PEI functions implementation.
SmBusDxe.c | SMBUS DXE functions implementation.
SmBusPciHooks.c | This file contains PCI initialized hooks for SMBus porting.
SmBusPei.dxs | This file is the dependency file for the Smbus PEI driver.
SmBusDxe.dxs | This file is the dependency file for the Smbus DXE driver.
SmBusSmm.dxs | This file is the dependency file for the Smbus Smm driver.
ModulePart Name: SmmChildDispatcher
ModulePart Description: SMM Child Dispatcher settings.
Filename | Description
SmmChildDispatcher.cif | SmmChildDispatcher CIF file.
SmmChildDispatcher.mak | Make file for the SMM Child Dispatcher driver.
SmmChildDispatcher.sdl | SMM Child Dispatcher parameters.
SmmChildDispatcher.dxs | Dependency expression for the SMM Child Dispatcher driver.
SmiHandlerGeneric.c | Generic SMI handler functions.
SmiHandlerPorting.c | SMM Child Dispatcher porting functions.
SmmChildDispatch.h | SMM Child dispatcher functions and data structures definition.
SmmChildDispatchMain.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatchProtocol.c | SMM Child dispatcher Protocols.
SmmChildDispatchProtocol.h | SMM Child dispatcher protocols functions definition.
ModulePart Name: SmmChildDispatcher2
ModulePart Description: SMM Child Dispatcher2 settings.
Filename | Description
SmmChildDispatcher2.cif | SmmChildDispatcher2 CIF file.
SmmChildDispatcher2.mak | Make file for the SMM Child Dispatcher2 driver.
SmmChildDispatcher2.sdl | SMM Child Dispatcher2 parameters.
SmmChildDispatcher2.dxs | Dependency expression for the SMM Child Dispatcher2 driver.
SmiHandlerGeneric2.c | Generic SMI handler functions.
SmiHandlerPorting2.c | SMM Child Dispatcher2 porting functions.
SmmChildDispatch2.h | SMM Child dispatcher2 functions and data structures definition.
SmmChildDispatch2Main.c | This file contains implementation of module entry point, generic RegisterHandler and UnregisterHandler routines and main dispatcher loop.
SmmChildDispatch2Protocol.c | SMM Child dispatcher2 Protocols.
SmmChildDispatch2Protocol.h | SMM Child dispatcher2 protocols functions definition.
ModulePart Name: AcpiModeEnable
ModulePart Description: Acpi Mode Enable settings.
Filename | Description
AcpiModeEnable.cif | AcpiModeEnable CIF file.
AcpiModeEnable.sdl | ACPI Mode Enabled module part parameters.
AcpiModeEnable.mak | Make file to enable/disable ACPI mode.
AcpiModeEnable.c | Provide functions to enable and disable ACPI mode.
AcpiModeEnable.dxs | Dependency file for the ACPI mode enable/disable driver.
AcpiModeEnable.h | AcpiModeEnable functions definition.
ModulePart Name: SleepSmi
ModulePart Description: Sleep SMI settings.
Filename | Description
SleepSmi.cif | SleepSmi CIF file.
SleepSmi.sdl | Sleep SMI parameters.
SleepSmi.mak | Make file for the SMM Sleep SMI handler code.
SleepSmi.c | Provide functions to register and handle Sleep SMI functionality.
SleepSmi.dxs | Dependency file for the sleep SMI handler driver.
ModulePart Name: SB SMI
ModulePart Description: SB SMI settings.
Filename | Description
SBSMI.cif | SBSMI CIF file.
SBSMI.sdl | SBSMI parameters.
SBSMI.c | This file contains code for all South Bridge SMI events.
SBSMI.h | This file contains all definitions for South Bridge SMI driver.
SBSMI.mak | Make file for the SB SMI handler code.
SBSMI.dxs | This file is the dependency file for the South Bridge SMI handler.
ModulePart Name: PchWrap
ModulePart Description: PCH Wrap settings.
Filename | Description
PchWrap.cif | SBSMI CIF file.
PchWrap.sdl | PCH wrap parameters.
ModulePart Name: PchSpiWrap
ModulePart Description: PCH SPI Wrap settings.
Filename | Description
PchSpiWrap.cif | PCH SPI Wrap CIF file.
PchSpiWrap.sdl | PCH SPI wrap parameters.
PchSpiWrap.mak | Make file for the PCH SPI Wrap.
PchSpiWrap.c | This file contains code for the PCH WSPI Wrap.
PchSpiWrap.dxs | This file is the dependency file the for PCH WSPI Wrap.
ModulePart Name: WdtApp
ModulePart Description: WDT App Settings.
Filename | Description
WdtApp.cif | WDT App CIF file.
WdtApp.sdl | WDT App parameters.
ModulePart Name: WdtAppDxe
ModulePart Description: WDT App Dxe Settings.
Filename | Description
WdtAppDxe.CIF | WDT App Dxe CIF file.
WdtAppDxe.sdl | WDT App DXE parameters.
WdtAppDxe.dxs | Dependency file for the WDT App DXE.
WdtAppDxe.mak | Make file for the WDT App DXE.
WdtAppDxe.c | This file contains code for the WDT App DXE.
ModulePart Name: WdtAppPei
ModulePart Description: WDT App Pei settings.
Filename | Description
WdtAppPei.CIF | WDT App Pei CIF file.
WdtAppPei.sdl | WDT App PEI parameters.
WdtAppPei.mak | Make file for the WDT App PEI.
WdtAppPei.c | This file contains code for the WDT App PEI.
WdtAppPei.dxs | Dependency file for the WDT App PEI.
ModulePart Name: WdtAppInclude
ModulePart Description: WDT App Include.
Filename | Description
WdtAppInclude.CIF | WDT App Include CIF file.
WdtAppInclude.sdl | WDT App Include parameters.
WdtAppVariable.h | WDT App Variable header file.
ModulePart Name: WdtAppProtocolLib
ModulePart Description: WDT App Protocol Library.
Filename | Description
WdtAppProtocolLib.CIF | WDT App Protocol Library CIF file.
WdtAppProtocolLib.sdl | WDT App Protocol parameters.
WdtAppProtocolLib.mak | Make file for the WDT App Protocol Library.
WdtApp\WdtApp.h | Header file for the WDT App.
WdtApp\WdtApp.c | This file contains code for the WDT App.
ModulePart Name: PciHotPlug
ModulePart Description: Pci HotPlug Settings.
Filename | Description
PciHotPlug.cif | CIF file.
PciHotPlug.sdl | PciHotPlug parameters.
PciHotPlug.mak | Make file for the PciHotPlug.
PciHotPlug.c | This file contains code for the PciHotPlug.
PciHotPlug.h | Header file for the PciHotPlug.
PciHotPlug.dxs | This file is the dependency file for the PciHotPlug.
ModulePart Name: PchSataDriver
ModulePart Description: PCH SATA UEFI Driver.
Filename | Description
SataDriver.cif | PCH SATA UEFI Driver CIF file.
SataDriver.sdl | SataDriver parameters.
SataDriver.mak | Make file for the SataDriver.
SataDriver.dxs | This file is the dependency file for the SataDriver.
SataDriver.efi | PCH SATA Raid UEFI Driver.

Porting Notes:
01. Set "ACPI_ASL_COMPILER" to "IASL5.exe" for build code compatible.
02. SB Setup XHCI Mode:
Disable - Hide XHCI.
Enable - Always use XHCI.
Auto - Always start with EHCI in BIOS and when OS driver loaded switch to XHCI.
Smart Auto - First boot start with EHCI in BIOS and when OS driver loaded switch to XHCI, continue using XHCI in BIOS during reboot.
Manual - Use by validation, not for end-user.
XHCI Pre-Boot Driver item have effect even if it is hidden.
03. Boot to USB 3.0 device: Set XHCI Mode to Enable.
04. After set SATA Mode to RAID, please select the launch policy of Legacy OpROM or UEFI Driver in CSM parameters if platform support CSM Opt-out.
05. Enable "PCHLP_SUPPORT" for Ultrabook flatform support.
Need IASL5 Compiler for ASL files.
06. If flash module support VSCC updated, please enable the token "SPI_INITIALIZE_WITH_VSCC" for VSCC updated.
SB module Provide a ELINK "OEM_SPI_VSCC_TABLE" for customer to override the VSCC value.
07. The token "SOLUTION_FOR_EIP95440" for EIP#95440 need update AHCI module and PAhciBus.h.
08. The token "PROGRAM_GPIO_TYPE" is use for ULT to select GPIO program function. If "PROGRAM_GPIO_TYPE" = "1" need set token "ULT_GPIO_000"~"ULT_GPIO_095".
10. For dummy TCO SMI please define "REGISTER_ALL_TCO_SMI_IN_DUMMY".
11. "COLD_RESET_WITH_POWER_CYCLE" for EfiResetCold do full reset.
12. When "FORCE_USER_TO_SETUP_IF_CMOS_BAD" is on, Setup will be automatically launched whenever CMOS is bad.
13. "PCIE_PORT_SWAP" to select PCIE port swap function support or not.
14. "OEM_USB_PER_PORT_DISABLE_SUPPORT" to select disable USB port after setup or not.
15. SMI Lock and BIOS Lock default are enable.
16. 4.6.5.3_Intel_LPT-RC_140_033 added new tokens:
a. PCH_RESET_CYCLE_DURATION: Set reset cycle duration, default is 4-5s (PCH RC v1.4.0.).
b. LEGACY_DMA_DISABLE: Enabled or disabled legacy DMA. (PCH RC v1.4.0.)
c. SX_NOTIFY_PWRB: Enabled or disabled power button notify in SB.ASL
17. For _PLD and _UPC method in ASL code for all USB ports should be porting case by case, now token setting is following Intel sample code.
18. After updating to Intel RC 1.6.2, OEM might need porting SATA RxEq setting, please refer token help message.
19. Change OEM_USBPREPORT_DISABLE_SUPPORT token name to OEM_USB_PER_PORT_DISABLE_SUPPORT
20. Create five tokens "SPI_PROTECTED_RANGE_X" for SPI range protected security, when the range type for token item is BIOS Type/Gbe Type/Me Type, the protected base is rom type address not flash address

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2013-04-21
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1

Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel PCH Chipset Framework Reference Code Production Version 1.9.1

Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None

Files changed in the Reference or 3rd Party Code:
Fixed the device name "RP0x" are redefined in PciTree.asl.
..\ReferenceCode\Chipset\PantherPoint\AcpiTables\Dsdt\Pch.asl
Modified for AMI Debug Rx.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed system endless reset on ULT Whitetip Mountain platform.
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
..\ReferenceCode\Chipset\LynxPoint\SampleCode\Library\AslUpdate\Dxe\PchAslUpdateLib.c
Support PCIE Hot-Plug(EIP84720)
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchRootPorts.c
Use Top down to allocate memory space
..\ReferenceCode\Chipset\LynxPoint\PchInit\Smm\PchLateInitSmm.c
..\ReferenceCode\Chipset\LynxPoint\PchInitDxe\PchPm.c
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support WS RAID device ID
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSata.c
Add GPI_ROUT function.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support SMM2.
..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmCore.c
Support OEM reset callback function Elink.(EIP111666)
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
OEM Fullreset function support.(EIP81593)
..\ReferenceCode\Chipset\LynxPoint\Reset\Common\PchResetCommon.c
Disable USB port after setup(EIP108803)
..\ReferenceCode\Chipset\LynxPoint\PchInit\Common\PchUsbCommon.c
Fixed Yellow mark of Serial Io Devices
..\ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchSerialIo.c
Boot time improvement
..\ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
Clear PCIE retrain bit for some device which cannot clear it.
..\ReferenceCode\Chipset\LynxPoint\Library\PchPciExpressHelpersLib\PchPciExpressHelpersLibrary.c
Fixed WoL BSOD(EIP121262)
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchPcie.asl
Set token for OEM easy to modify PchXhci.asl,PchEhci1.asl and PchEhci2.asl.
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchXhci.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci1.asl
..\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\PchEhci2.asl
Set token to make the size of S3 parameter as changeable for a more data store
..\ReferenceCode\Chipset\LynxPoint\S3Support\Dxe\PchS3Support.c
Fixed for Ubuntu firmware test
...\ReferenceCode\Chipset\LynxPoint\AcpiTables\Dsdt\Pch.asl
Function already done at NBDXE.c.
..\ReferenceCode\Chipset\LynxPoint\Reset\RuntimeDxe\PchReset.c
Fixed for WIN7 will auto resume form S3,S4 when without install XHCI driver(RC 1.6.0).

..\ReferenceCode\Chipset\LynxPoint\PchSmiDispatcher\Smm\PchSmmSx.c

New features added in this label:
Add SPI Range Protected security

Intel Sightings Report in this label:
506558 [Lynx Point] Chipset – Intel® 8 Series / C220 Series Chipset Family (PCH) Sightings Report (SR) – Rev. 6.0

General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE
EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
None
EIP Addressed
[TAG] EIP219399
[Category] Improvement
[Description] Static code analysis issue found in Aptio4 Intel LynxPoint PCH module
[Files] Chipset\SB\SBPEI.c
[TAG] EIP215945
[Category] Improvement
[Description] [SharkBay][PCH] Executing code outside TSEG check in SMM
[Files] Chipset\SB\Smm2\SmiHandlerPorting2.c
[TAG] EIP215677
[Category] Improvement
[Description] [SharkBay][USB] Executing code outside TSEG check in SMM
[Files] Chipset\SB\Smm2\SmiHandlerPorting2.c

Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE

Remaining Issues:
NONE

Unit Testing:
EIP215945

Validation Testing:
NONE

Release History:

4.6.5.3_Intel_LPT-RC_191_051
4.6.5.3_Intel_LPT-RC_190_050.2
4.6.5.3_Intel_LPT-RC_190_050.1
4.6.5.3_Intel_LPT-RC_190_050
4.6.5.3_Intel_LPT-RC_180_049.2
4.6.5.3_Intel_LPT-RC_180_049.1
4.6.5.3_Intel_LPT-RC_180_049a
4.6.5.3_Intel_LPT-RC_180_049
4.6.5.3_Intel_LPT-RC_180_048a
4.6.5.3_Intel_LPT-RC_180_047b
4.6.5.3_Intel_LPT-RC_180_047
4.6.5.3_Intel_LPT-RC_170_046
4.6.5.3_Intel_LPT-RC_170_045a
4.6.5.3_Intel_LPT-RC_170_045
4.6.5.3_Intel_LPT-RC_170_044a
4.6.5.3_Intel_LPT-RC_170_044
4.6.5.3_Intel_LPT-RC_162_043
4.6.5.3_Intel_LPT-RC_162_042
4.6.5.3_Intel_LPT-RC_162_041
4.6.5.3_Intel_LPT-RC_161_040d
4.6.5.3_Intel_LPT-RC_161_040c
4.6.5.3_Intel_LPT-RC_161_040b
4.6.5.3_Intel_LPT-RC_161_040a
4.6.5.3_Intel_LPT-RC_161_040
4.6.5.3_Intel_LPT-RC_160_039
4.6.5.3_Intel_LPT-RC_150_038
4.6.5.3_Intel_LPT-RC_150_037
4.6.5.3_Intel_LPT-RC_140_036
4.6.5.3_Intel_LPT-RC_140_035a
4.6.5.3_Intel_LPT-RC_140_035
4.6.5.3_Intel_LPT-RC_140_034
4.6.5.3_Intel_LPT-RC_140_033
4.6.5.3_Intel_LPT-RC_140_032
4.6.5.3_Intel_LPT-RC_131_031b
4.6.5.3_Intel_LPT-RC_131_031a
4.6.5.3_Intel_LPT-RC_131_031
4.6.5.3_Intel_LPT-RC_130_030a
4.6.5.3_Intel_LPT-RC_130_030
4.6.5.3_Intel_LPT-RC_120_029
4.6.5.3_Intel_LPT-RC_110_028b
4.6.5.3_Intel_LPT-RC_110_028a
4.6.5.3_Intel_LPT-RC_110_028
4.6.5.3_Intel_LPT-RC_101_027a
4.6.5.3_Intel_LPT-RC_101_027
4.6.5.3_Intel_LPT-RC_100_026
4.6.5.3_Intel_LPT-RC_090_025
4.6.5.3_Intel_LPT-RC_081_024c
4.6.5.3_Intel_LPT-RC_081_024b
4.6.5.3_Intel_LPT-RC_081_024a
4.6.5.3_Intel_LPT-RC_081_024
4.6.5.3_Intel_LPT-RC_080_023b
4.6.5.3_Intel_LPT-RC_080_023a
4.6.5.3_Intel_LPT-RC_080_023
4.6.5.3_Intel_LPT-RC_071_022
4.6.5.3_Intel_LPT-RC_071_021a
4.6.5.3_Intel_LPT-RC_071_021
4.6.5.3_Intel_LPT-RC_071_020
4.6.5.3_Intel_LPT-RC_071_019
4.6.5.3_Intel_LPT-RC_070_018
4.6.5.3_Intel_LPT-RC_070_017
4.6.5.3_Intel_LPT-RC_061_016
4.6.5.3_Intel_LPT-RC_061_015
4.6.5.3_Intel_LPT-RC_061_014
4.6.5.3_Intel_LPT-RC_061_013
4.6.5.3_Intel_LPT-RC_061_012
4.6.5.3_Intel_LPT-RC_060_011
4.6.5.3_Intel_LPT-RC_060_010
4.6.5.3_Intel_LPT-RC_057_009
4.6.5.3_Intel_LPT-RC_057_008
4.6.5.3_Intel_LPT-RC_056_007
4.6.5.3_Intel_LPT-RC_055_006


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.
For a list by segment, see By Segment.

  • SB.mak
  • SBSECInit.asm
  • SBSetup.mak
Built on 11:02:36 07/13/15


AMIBIOS Function Reference

SB.mak

Description:
This make file builds South bridge SEC,PEI & DXE
components and link them to respective binary
Built on 11:02:36 07/13/15


AMIBIOS Function Reference

SBSECInit.asm

Description:
Program any workaround or initialization needed before
enabling Cache as memory in the SEC stage

The following functions are used in the file: SBSECInit.asm.

Function | Description
SECSB_DmiGen2Init | This routine initializes South bridge DMI for PEI preparation
SECSB_EarlyInit | This routine initializes South bridge for PEI preparation

Built on 11:02:36 07/13/15


SECSB_DmiGen2Init in the SBSECInit.asm

AMIBIOS Function Reference

Function : SECSB_DmiGen2Init

File: SBSECInit.asm
Segment: STARTUP_SEG
Description:
This routine initializes South bridge DMI for PEI preparation
Input:
ESP BIST Info
EBP Reset ID (EDX at reset)
Stack not available
Output:
None
Modified:
All, except EBP and ESP
Notes:
None of the chipset initialization is done at this point.
System is exactly as if came out of RESET.
1. Enable Top of 4GB flash ROM access
Built on 11:02:36 07/13/15


SECSB_EarlyInit in the SBSECInit.asm

AMIBIOS Function Reference

Function : SECSB_EarlyInit

File: SBSECInit.asm
Segment: STARTUP_SEG
Description:
This routine initializes South bridge for PEI preparation
Input:
ESP BIST Info
EBP Reset ID (EDX at reset)
Stack not available
Output:
None
Modified:
All, except EBP and ESP
Notes:
None of the chipset initialization is done at this point.
System is exactly as if came out of RESET.
1. Enable Top of 4GB flash ROM access
Built on 11:02:36 07/13/15


AMIBIOS Function Reference

SBSetup.mak

Description:
This make file builds north bridge Setup
components and link them to respective binary
Built on 11:02:36 07/13/15


Function by Segment

AMIBIOS Function Reference

By Segment

The following is a list of the segments.
For a list in alphabetical order, see In Alphabetical Order.
For a list by file name, see By File Name.

  • STARTUP_SEG
Built on 11:02:36 07/13/15


AMIBIOS Function Reference

STARTUP_SEG

The following functions are used in the segment: STARTUP_SEG.

Function | Description
SECSB_DmiGen2Init | This routine initializes South bridge DMI for PEI preparation
SECSB_EarlyInit | This routine initializes South bridge for PEI preparation

Built on 11:02:36 07/13/15


Functions in Alphabetical Order

AMIBIOS Function Reference

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.
For a list by segment, see By Segment.

  • S
Built on 11:02:36 07/13/15


Functions in Alphabetical Order

AMIBIOS Function Reference

S

Function | Description
SECSB_DmiGen2Init | This routine initializes South bridge DMI for PEI preparation
SECSB_EarlyInit | This routine initializes South bridge for PEI preparation

Built on 11:02:36 07/13/15


AMIBIOS Function Reference

General Information

Built on 11:02:36 07/13/15