American Megatrends, Inc.

CSP Library

Copyright

Release Notes

© American Megatrends, Inc.


Release Notes - NDA Required

Component Information:
Component Title: CSP Library
Component Reference Name: CSP Library
Component Type: eBoard
Release Date: 2012-12-16
Source Control Label: 4.6.4.0_CSPLibrary_021
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary;

Dependencies
NONE
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
Component Description:
The CSP Library Provides a central location for Generic code that can be used across modules. The Chipset and CPU modules add functions to this library that they feel should be available to the rest of the source
Filename | Description
CspLib.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library eModule
CspLib.sdl | This file contains tokens and eLinks that are used to configure the module
CspLib.mak | This file contains the build options for this eModule
CspLibPei.c | This file contains code for Generic CSP Library PEI functions. The functions include PCI table updating
CspLibDxe.c | This file contains code for Generic CSP Library Protocol functions.
CspLibDxe.dxs | This file contains the Dependency Expression for this eModule
CspLibrary.chm | This file contains html linked help information about the functions and data structures used in this component.
CspLibGeneric.c | This file contains generic code to add functionality that can be used by any module.
CspLibGeneric.h | This file contains function headers, MACROs, typedefs and Constants that support the generic code defined in the CspLibGeneric.c.
CspLibInc.cif | This file is the Component Information File(CIF) that defines the files that are included in the CSP Library Include Module Part
AMICSPLib.h | This file can contain function headers, MACROs, typedefs and Constants that support the generic code defined in the the Csp Library
CspLibProtocols.cif | This file is the Component Information File(CIF) that defines the files that are included in the CSP Library Protocols Module Part
CspLibProtocols.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library Protocols.
CspLibPpi.cif | This file is the Component Information File(CIF) that defines the files that are included in the CSP Library PPI Module Part
CspLibPpi.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library PPIs.
FwVersion.h | This file contains the FwVersion Data Structure definition which is used by AFU flash and other AMI utilities.
Fid.c | This file contains the FwVersion Data Structure implementation which is used by AFU flash and other AMI utilities.

AMI Build Tools:
Tools Label: 4.5.5_Tools_34, Dated: 2010-10-06
Visual eBios: RSS.5.69.0132, Dated: 2010-03-24
Compiler Tool(s): Microsoft™s Windows Driver Kit (WDK) Ver. 7600.16385.1
Compiler Tool(s): Microsoft Windows Driver Development Kit (DDK) Ver. 3790.1830
New features added in this label:
UEFI specification 2.3.1 and PI specification 1.2 compliance
TopSwap support
General Bug Fixes:
None
EIP addressed in this label:
EIP 64106: Update source to be UEFI 2.3.1 and PI 1.2 compliant
Files changed:
CspLibPPI.h
CspLibPei.c
CspLibGeneric.c
CspLibGeneric.h
Known issues and limitations in this label:
None
Remaining Issues:
None
Unit Testing:
N/A
Validation Testing:
N/A
Release History:
Release_08
Release_07
Release_06
Release_05
Release_04
Release_03
Release_02
Release_01
Release_00

© American Megatrends Inc.


CSP Library eModule Release Notes

AMIBIOS Component Release Notes

Component Information:
Component Name: CSP Library
Component Type: eBoard
Release Date: 6/12/09
Source Control Label: 4.6.2_CSPLibrary_011
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary
Component Description:
The CSP Library Provides a central location for Generic code that can be used across modules. The Chipset and CPU modules add functions to this library that they feel should be available to the rest of the source
Filename | Description
CspLibrary.chm | This file contains html linked help information about the functions and data structures used in this component.
CspLib.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library eModule
CspLib.sdl | This file contains tokens and eLinks that are used to configure the module
CspLib.mak | This file contains the build options for this eModule
CspLibPei.C | This file contains code for Generic CSP Library PEI functions. The functions include PCI table updating
CspLibDxe.C | This file contains code for Generic CSP Library Protocol functions.
CspLibDxe.Dxs | This file contains the Dependency Expression for this eModule
CspLibGeneric.C | This file contains generic code to add functionality that can be used by any module.
CspLibGeneric.h | This file contains function headers, MACROs, typedefs and Constants that support the generic code defined in the CspLibGeneric.c.
CspLibInc.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library Include Module Part
AMICSPLib.h | This file can contain function headers, MACROs, typedefs and Constants that support the generic code defined in the the Csp Library
CspLibProtocols.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library Protocols Module Part
CspLibProtocols.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library Protocols.
CspLibPpi.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library PPI Module Part
CspLibPpi.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library PPIs.
FwVersion.h | This file contains the FwVersion Data Structure which is used by AFU flash and other AMI utilities.
Fixes
None
New Features in Latest Release
Only Comment updates were added and CHM file
Errata & Known Issues
None
Revision History
Initial Release Notes

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: CSP Library
Component Reference Name: CSP Library
Component Type: eBoard
Release Date: 2010-03-25
Source Control Label: 4.6.4.0_CSPLibrary_013
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary;
Component Description:
The CSP Library Provides a central location for Generic code that can be used across modules. The Chipset and CPU modules add functions to this library that they feel should be available to the rest of the source
Component file list
Filename | Description
CspLib.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library eModule
CspLib.sdl | This file contains tokens and eLinks that are used to configure the module
CspLib.mak | This file contains the build options for this eModule
CspLibPei.c | This file contains code for Generic CSP Library PEI functions. The functions include PCI table updating
CspLibDxe.c | This file contains code for Generic CSP Library Protocol functions.
CspLibDxe.dxs | This file contains the Dependency Expression for this eModule
CspLibrary.chm | This file contains html linked help information about the functions and data structures used in this component.
CspLibGeneric.c | This file contains generic code to add functionality that can be used by any module.
CspLibGeneric.h | This file contains function headers, MACROs, typedefs and Constants that support the generic code defined in the CspLibGeneric.c.
CspLibInc.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library Include Module Part
AMICSPLib.h | This file can contain function headers, MACROs, typedefs and Constants that support the generic code defined in the the Csp Library
CspLibProtocols.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library Protocols Module Part
CspLibProtocols.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library Protocols.
CspLibPpi.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library PPI Module Part
CspLibPpi.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library PPIs.
FwVersion.h | This file contains the FwVersion Data Structure which is used by AFU flash and other AMI utilities.

AMI Build Tools:
Tools Label: 4.5.5_Tools_30, Dated: 2010-02-23
Visual eBios: RSS.5.68.0063, Dated: 2009-07-29
New features added in this label:
Runtime Shadow RAM writing eLink infrastructure
General Bug Fixes:
None
EIP addressed in this label:
EIP 33953
Files changed:
CspLib.sdl
CspLib.mak
CspLibGeneric.h
CspLibGeneric.c
Known issues and limitations in this label:
CSP library doesn't support separate PEI/DXE build model
Remaining Issues:
None
Unit Testing:
N/A
Validation Testing:
N/A
Release History:
Release_00

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: CSP Library
Component Reference Name: CSP Library
Component Type: eBoard
Release Date: 2010-04-07
Source Control Label: 4.6.4.0_CSPLibrary_014
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary;
Component Description:
The CSP Library Provides a central location for Generic code that can be used across modules. The Chipset and CPU modules add functions to this library that they feel should be available to the rest of the source
Component file list
Filename | Description
CspLib.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library eModule
CspLib.sdl | This file contains tokens and eLinks that are used to configure the module
CspLib.mak | This file contains the build options for this eModule
CspLibPei.c | This file contains code for Generic CSP Library PEI functions. The functions include PCI table updating
CspLibDxe.c | This file contains code for Generic CSP Library Protocol functions.
CspLibDxe.dxs | This file contains the Dependency Expression for this eModule
CspLibrary.chm | This file contains html linked help information about the functions and data structures used in this component.
CspLibGeneric.c | This file contains generic code to add functionality that can be used by any module.
CspLibGeneric.h | This file contains function headers, MACROs, typedefs and Constants that support the generic code defined in the CspLibGeneric.c.
CspLibInc.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library Include Module Part
AMICSPLib.h | This file can contain function headers, MACROs, typedefs and Constants that support the generic code defined in the the Csp Library
CspLibProtocols.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library Protocols Module Part
CspLibProtocols.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library Protocols.
CspLibPpi.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library PPI Module Part
CspLibPpi.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library PPIs.
FwVersion.h | This file contains the FwVersion Data Structure which is used by AFU flash and other AMI utilities.

AMI Build Tools:
Tools Label: 4.5.5_Tools_30, Dated: 2010-02-23
Visual eBios: RSS.5.68.0063, Dated: 2009-07-29
New features added in this label:
None
General Bug Fixes:
Restored backward compatibility with Core 4.6.3
EIP addressed in this label:
None
Files changed:
CspLib.sdl
CspLib.mak
FwVersion.h
FID.c
Known issues and limitations in this label:
CSP library doesn't support separate PEI/DXE build model
Remaining Issues:
None
Unit Testing:
N/A
Validation Testing:
N/A
Release History:
Release_00
Release_01

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: CSP Library
Component Reference Name: CSP Library
Component Type: eBoard
Release Date: 2010-05-06
Source Control Label: 4.6.4.0_CSPLibrary_015
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary;
Component Description:
The CSP Library Provides a central location for Generic code that can be used across modules. The Chipset and CPU modules add functions to this library that they feel should be available to the rest of the source
Component file list
Filename | Description
CspLib.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library eModule
CspLib.sdl | This file contains tokens and eLinks that are used to configure the module
CspLib.mak | This file contains the build options for this eModule
CspLibPei.c | This file contains code for Generic CSP Library PEI functions. The functions include PCI table updating
CspLibDxe.c | This file contains code for Generic CSP Library Protocol functions.
CspLibDxe.dxs | This file contains the Dependency Expression for this eModule
CspLibrary.chm | This file contains html linked help information about the functions and data structures used in this component.
CspLibGeneric.c | This file contains generic code to add functionality that can be used by any module.
CspLibGeneric.h | This file contains function headers, MACROs, typedefs and Constants that support the generic code defined in the CspLibGeneric.c.
CspLibInc.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library Include Module Part
AMICSPLib.h | This file can contain function headers, MACROs, typedefs and Constants that support the generic code defined in the the Csp Library
CspLibProtocols.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library Protocols Module Part
CspLibProtocols.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library Protocols.
CspLibPpi.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library PPI Module Part
CspLibPpi.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library PPIs.
FwVersion.h | This file contains the FwVersion Data Structure which is used by AFU flash and other AMI utilities.

AMI Build Tools:
Tools Label: 4.5.5_Tools_30, Dated: 2010-02-23
Visual eBios: RSS.5.68.0063, Dated: 2009-07-29
New features added in this label:
None
General Bug Fixes:
Fixed bug that causes build error on DDK nmake
Fixed bug $FID signature is absent when use Core label 4.6.3.x
EIP addressed in this label:
38241
Files changed:
CspLibPei.c
CspLib.mak
Known issues and limitations in this label:
CSP library doesn't support separate PEI/DXE build model
Remaining Issues:
None
Unit Testing:
N/A
Validation Testing:
N/A
Release History:
Release_00
Release_01
Release_02

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: CSP Library
Component Reference Name: CSP Library
Component Type: eBoard
Release Date: 2010-05-21
Source Control Label: 4.6.4.0_CSPLibrary_016
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary;
Component Description:
The CSP Library Provides a central location for Generic code that can be used across modules. The Chipset and CPU modules add functions to this library that they feel should be available to the rest of the source
Component file list
Filename | Description
CspLib.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library eModule
CspLib.sdl | This file contains tokens and eLinks that are used to configure the module
CspLib.mak | This file contains the build options for this eModule
CspLibPei.c | This file contains code for Generic CSP Library PEI functions. The functions include PCI table updating
CspLibDxe.c | This file contains code for Generic CSP Library Protocol functions.
CspLibDxe.dxs | This file contains the Dependency Expression for this eModule
CspLibrary.chm | This file contains html linked help information about the functions and data structures used in this component.
CspLibGeneric.c | This file contains generic code to add functionality that can be used by any module.
CspLibGeneric.h | This file contains function headers, MACROs, typedefs and Constants that support the generic code defined in the CspLibGeneric.c.
CspLibInc.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library Include Module Part
AMICSPLib.h | This file can contain function headers, MACROs, typedefs and Constants that support the generic code defined in the the Csp Library
CspLibProtocols.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library Protocols Module Part
CspLibProtocols.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library Protocols.
CspLibPpi.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library PPI Module Part
CspLibPpi.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library PPIs.
FwVersion.h | This file contains the FwVersion Data Structure definition which is used by AFU flash and other AMI utilities.
Fid.c | This file contains the FwVersion Data Structure implementation which is used by AFU flash and other AMI utilities.

AMI Build Tools:
Tools Label: 4.5.5_Tools_30, Dated: 2010-02-23
Visual eBios: RSS.5.69.0132, Dated: 2010-03-24
New features added in this label:
FW data structure version 3 support
General Bug Fixes:
None
EIP addressed in this label:
None
Files changed:
Fid.c
CspLib.mak
FwVersion.h
Known issues and limitations in this label:
None
Remaining Issues:
None
Unit Testing:
N/A
Validation Testing:
N/A
Release History:
Release_00
Release_01
Release_02
Release_03

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: CSP Library
Component Reference Name: CSP Library
Component Type: eBoard
Release Date: 2010-12-17
Source Control Label: 4.6.4.0_CSPLibrary_017
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary;
Component Description:
The CSP Library Provides a central location for Generic code that can be used across modules. The Chipset and CPU modules add functions to this library that they feel should be available to the rest of the source
Component file list
Filename | Description
CspLib.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library eModule
CspLib.sdl | This file contains tokens and eLinks that are used to configure the module
CspLib.mak | This file contains the build options for this eModule
CspLibPei.c | This file contains code for Generic CSP Library PEI functions. The functions include PCI table updating
CspLibDxe.c | This file contains code for Generic CSP Library Protocol functions.
CspLibDxe.dxs | This file contains the Dependency Expression for this eModule
CspLibrary.chm | This file contains html linked help information about the functions and data structures used in this component.
CspLibGeneric.c | This file contains generic code to add functionality that can be used by any module.
CspLibGeneric.h | This file contains function headers, MACROs, typedefs and Constants that support the generic code defined in the CspLibGeneric.c.
CspLibInc.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library Include Module Part
AMICSPLib.h | This file can contain function headers, MACROs, typedefs and Constants that support the generic code defined in the the Csp Library
CspLibProtocols.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library Protocols Module Part
CspLibProtocols.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library Protocols.
CspLibPpi.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library PPI Module Part
CspLibPpi.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library PPIs.
FwVersion.h | This file contains the FwVersion Data Structure definition which is used by AFU flash and other AMI utilities.
Fid.c | This file contains the FwVersion Data Structure implementation which is used by AFU flash and other AMI utilities.

AMI Build Tools:
Tools Label: 4.5.5_Tools_30, Dated: 2010-02-23
Visual eBios: RSS.5.69.0132, Dated: 2010-03-24
New features added in this label:
FW data structure version 4 support
OEM activation key support
General Bug Fixes:
None
EIP addressed in this label:
None
Files changed:
Fid.c
CspLib.sdl
FwVersion.h
Known issues and limitations in this label:
None
Remaining Issues:
None
Unit Testing:
N/A
Validation Testing:
N/A
Release History:
Release_00
Release_01
Release_02
Release_03
Release_04

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: CSP Library
Component Reference Name: CSP Library
Component Type: eBoard
Release Date: 2011-01-06
Source Control Label: 4.6.4.0_CSPLibrary_018
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary;

Dependencies
N0NE
Component Description:
The CSP Library Provides a central location for Generic code that can be used across modules. The Chipset and CPU modules add functions to this library that they feel should be available to the rest of the source
Component file list
Filename | Description
CspLib.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library eModule
CspLib.sdl | This file contains tokens and eLinks that are used to configure the module
CspLib.mak | This file contains the build options for this eModule
CspLibPei.c | This file contains code for Generic CSP Library PEI functions. The functions include PCI table updating
CspLibDxe.c | This file contains code for Generic CSP Library Protocol functions.
CspLibDxe.dxs | This file contains the Dependency Expression for this eModule
CspLibrary.chm | This file contains html linked help information about the functions and data structures used in this component.
CspLibGeneric.c | This file contains generic code to add functionality that can be used by any module.
CspLibGeneric.h | This file contains function headers, MACROs, typedefs and Constants that support the generic code defined in the CspLibGeneric.c.
CspLibInc.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library Include Module Part
AMICSPLib.h | This file can contain function headers, MACROs, typedefs and Constants that support the generic code defined in the the Csp Library
CspLibProtocols.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library Protocols Module Part
CspLibProtocols.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library Protocols.
CspLibPpi.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library PPI Module Part
CspLibPpi.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library PPIs.
FwVersion.h | This file contains the FwVersion Data Structure definition which is used by AFU flash and other AMI utilities.
Fid.c | This file contains the FwVersion Data Structure implementation which is used by AFU flash and other AMI utilities.

AMI Build Tools:
Tools Label: 4.5.5_Tools_30, Dated: 2010-02-23
Visual eBios: RSS.5.69.0132, Dated: 2010-03-24
Compiler Tool(s): Microsoftâ€™s Windows Driver Kit (WDK) Ver. 7600.16385.1
Compiler Tool(s): Microsoft Windows Driver Development Kit (DDK) Ver. 3790.1830
New features added in this label:
None
General Bug Fixes:
None
EIP addressed in this label:
51420: added compiler information to the release notes
Files changed:
None
Known issues and limitations in this label:
None
Remaining Issues:
None
Unit Testing:
N/A
Validation Testing:
N/A
Release History:
Release_05
Release_04
Release_03
Release_02
Release_01
Release_00

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: CSP Library
Component Reference Name: CSP Library
Component Type: eBoard
Release Date: 2011-02-22
Source Control Label: 4.6.4.0_CSPLibrary_019
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary;

Dependencies
NONE
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
Component Description:
The CSP Library Provides a central location for Generic code that can be used across modules. The Chipset and CPU modules add functions to this library that they feel should be available to the rest of the source
Filename | Description
CspLib.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library eModule
CspLib.sdl | This file contains tokens and eLinks that are used to configure the module
CspLib.mak | This file contains the build options for this eModule
CspLibPei.c | This file contains code for Generic CSP Library PEI functions. The functions include PCI table updating
CspLibDxe.c | This file contains code for Generic CSP Library Protocol functions.
CspLibDxe.dxs | This file contains the Dependency Expression for this eModule
CspLibrary.chm | This file contains html linked help information about the functions and data structures used in this component.
CspLibGeneric.c | This file contains generic code to add functionality that can be used by any module.
CspLibGeneric.h | This file contains function headers, MACROs, typedefs and Constants that support the generic code defined in the CspLibGeneric.c.
CspLibInc.cif | This file is the Component Information File(CIF) that defines the files that are included in the CSP Library Include Module Part
AMICSPLib.h | This file can contain function headers, MACROs, typedefs and Constants that support the generic code defined in the the Csp Library
CspLibProtocols.cif | This file is the Component Information File(CIF) that defines the files that are included in the CSP Library Protocols Module Part
CspLibProtocols.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library Protocols.
CspLibPpi.cif | This file is the Component Information File(CIF) that defines the files that are included in the CSP Library PPI Module Part
CspLibPpi.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library PPIs.
FwVersion.h | This file contains the FwVersion Data Structure definition which is used by AFU flash and other AMI utilities.
Fid.c | This file contains the FwVersion Data Structure implementation which is used by AFU flash and other AMI utilities.

AMI Build Tools:
Tools Label: 4.5.5_Tools_34, Dated: 2010-10-06
Visual eBios: RSS.5.69.0132, Dated: 2010-03-24
Compiler Tool(s): Microsoft™s Windows Driver Kit (WDK) Ver. 7600.16385.1
Compiler Tool(s): Microsoft Windows Driver Development Kit (DDK) Ver. 3790.1830
New features added in this label:
Support of PI 1.1 specification
General Bug Fixes:
None
EIP addressed in this label:
51548: Added AMI copyright headers, replaced TABs with spaces
Files changed:
CspLib.mak
CspLibPei.c
CspLibDxe.c
CspLibDxe.dxs
CspLibGeneric.c
CspLibGeneric.h
Fid.c
AmiCspLib.h
CspLibProtocols.h
CspLibPpi.h
FwVersion.h
Known issues and limitations in this label:
None
Remaining Issues:
None
Unit Testing:
N/A
Validation Testing:
N/A
Release History:
Release_06
Release_05
Release_04
Release_03
Release_02
Release_01
Release_00

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: CSP Library
Component Reference Name: CSP Library
Component Type: eBoard
Release Date: 2011-03-28
Source Control Label: 4.6.4.0_CSPLibrary_020
Source Control Location: SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary;

Dependencies
NONE
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
Component Description:
The CSP Library Provides a central location for Generic code that can be used across modules. The Chipset and CPU modules add functions to this library that they feel should be available to the rest of the source
Filename | Description
CspLib.cif | This file is the Component Information File(CIF) that defines the files and the Module Parts that are included in the CSP Library eModule
CspLib.sdl | This file contains tokens and eLinks that are used to configure the module
CspLib.mak | This file contains the build options for this eModule
CspLibPei.c | This file contains code for Generic CSP Library PEI functions. The functions include PCI table updating
CspLibDxe.c | This file contains code for Generic CSP Library Protocol functions.
CspLibDxe.dxs | This file contains the Dependency Expression for this eModule
CspLibrary.chm | This file contains html linked help information about the functions and data structures used in this component.
CspLibGeneric.c | This file contains generic code to add functionality that can be used by any module.
CspLibGeneric.h | This file contains function headers, MACROs, typedefs and Constants that support the generic code defined in the CspLibGeneric.c.
CspLibInc.cif | This file is the Component Information File(CIF) that defines the files that are included in the CSP Library Include Module Part
AMICSPLib.h | This file can contain function headers, MACROs, typedefs and Constants that support the generic code defined in the the Csp Library
CspLibProtocols.cif | This file is the Component Information File(CIF) that defines the files that are included in the CSP Library Protocols Module Part
CspLibProtocols.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library Protocols.
CspLibPpi.cif | This file is the Component Information File(CIF) that defines the files that are included in the CSP Library PPI Module Part
CspLibPpi.h | This file contains function headers, MACROs, typedefs and Constants that support the the CSP Library PPIs.
FwVersion.h | This file contains the FwVersion Data Structure definition which is used by AFU flash and other AMI utilities.
Fid.c | This file contains the FwVersion Data Structure implementation which is used by AFU flash and other AMI utilities.

AMI Build Tools:
Tools Label: 4.5.5_Tools_34, Dated: 2010-10-06
Visual eBios: RSS.5.69.0132, Dated: 2010-03-24
Compiler Tool(s): Microsoft™s Windows Driver Kit (WDK) Ver. 7600.16385.1
Compiler Tool(s): Microsoft Windows Driver Development Kit (DDK) Ver. 3790.1830
New features added in this label:
None
General Bug Fixes:
Added function PciCfgModify to maintain backward compatibility with older Core
File CspLibGeneric.h moved to top of auto-generated file AmiCspLib.h
EIP addressed in this label:
None
Files changed:
CspLib.mak
CspLibPei.c
Known issues and limitations in this label:
None
Remaining Issues:
None
Unit Testing:
N/A
Validation Testing:
N/A
Release History:
Release_07
Release_06
Release_05
Release_04
Release_03
Release_02
Release_01
Release_00

© American Megatrends Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • AMICSPLib.h
  • CspLib.mak
  • CspLibDxe.C
  • CspLibDxe.Dxs
  • CspLibGeneric.C
  • CspLibGeneric.h
  • CspLibPei.C
  • CspLibPPI.h
  • CspLibProtocols.h
  • FID.c
  • FwVersion.h
Built on 18:04:36 12/16/11


AMICSPLib.h

Description:
This file contains generic code to add functionality that can be used
by any module.

The following functions are used in the file: AMICSPLib.h.

Function | Description
CSP_PCI_CFG_ADDRESS | This MACRO Converts bus, device function and register number into 64bit PCI configuration address


CSP_PCI_CFG_ADDRESS in the AMICSPLib.h

Function : CSP_PCI_CFG_ADDRESS

File: AMICSPLib.h
Description:
This MACRO Converts bus, device function and register number into 64bit
PCI configuration address
Input:
bus - PCI bus where the device resides
dev - PCI device number to access
func - function number of the device being accessed
reg - PCI register of the function being accessed
Notes:


CspLib.mak

Description:
Make file for the CSP Library. CSP library contains all library
functions related to chipset and CPU. The main idea for this library is
to consolidate porting hooks related to various components
(like CSM, SMM etc) in respective chipset files say NB, SB, CPU etc.
This library can be built us a LIB file or as various FFS files.
The MACROS and library init functions mask the actual implementation
which is controlled by the SDL token


CspLibDxe.C

Description:
This file contains code for Generic Csp protocols such as
PCI table init etc

The following functions are used in the file: CspLibDxe.C.

Function | Description
CspLibDxe_Init | This function is the entry point for this DXE. This function installs necessary Csp protocols


CspLibDxe_Init in the CspLibDxe.C

Function : CspLibDxe_Init

File: CspLibDxe.C
Description:
This function is the entry point for this DXE. This function installs
necessary Csp protocols
Input:
EFI_HANDLE ImageHandle - Image handle
EFI_SYSTEM_TABLE SystemTable - Pointer to the system table
Output:
Return Status currently always EFI_SUCCESS


CspLibDxe.Dxs

Description:
This file is the dependency file for the CspLib DXE
driver


CspLibGeneric.C

Description:
This file contains generic code to add functionality that can
be used by any module.

The following functions are used in the file: CspLibGeneric.C.

Function | Description
IsTopSwapOn | This function checks if TopSwap (A16 address line inversion) is on
LocateMultiplePpi | This function wraps the initialization and error checking of LocatePpi() in a table, in order to reduce code size in functions that use several PPI.
LocateMultipleProtocol | This function wraps the initialization and error checking of LocateProtocol() in a table, in order to reduce code size in functions that use several Protocol.
OemRuntimeShadowRamWrite | This function enables or disables runtime writing to shadow RAM (E000-F000 segment)
PeiReadPci | This function reads the value in a PCI Register using a PCI_CONTROL structure to simplify the call.
PeiWritePci | This function writes a value to a PCI register using a PCI_CONTROL structure to simplify the call.
RbReadPci | This function reads the value(s) in a PCI Register using a RTBRG_PCI_ARGS structure to simplify the call.
RbWritePci | This function writes the value(s) in a PCI Register using a RTBRG_PCI_ARGS structure to simplify the call.
SetTopSwap | This function sets TopSwap (A16 address line inversion) ON or OFF


IsTopSwapOn in the CspLibGeneric.C

Function : IsTopSwapOn

File: CspLibGeneric.C
Description:
This function checks if TopSwap (A16 address line inversion)
is on
Input:
None
Output:
TRUE - TopSwap is ON
FALSE - TopSwap is OFF


LocateMultiplePpi in the CspLibGeneric.C

Function : LocateMultiplePpi

File: CspLibGeneric.C
Description:
This function wraps the initialization and error checking of LocatePpi()
in a table, in order to reduce code size in functions that use several PPI.
Input:
EFI_PEI_SERVICES **PeiServices - Instance of a pointer to the PeiServices pointer
UINT32 PpiTableSize  - Size of argument table
PPI_LOCATE_STRUCT *Ppi - Table of arguments for LocatePpi()
Output:
Pointers in PPI_LOCATE_STRUCT are updated
Status is returned with values defined by the LocatePpi function

Note:
This function will use a Guid pointer or a Guid value defined locally
in the PPI_LOCATE_STRUCT of the caller.


LocateMultipleProtocol in the CspLibGeneric.C

Function : LocateMultipleProtocol

File: CspLibGeneric.C
Description:
This function wraps the initialization and error checking of
LocateProtocol() in a table, in order to reduce code size in functions
that use several Protocol.
Input:
EFI_BOOT_SERVICES *pBS - Instance of a pointer to the Boot Services Table
UINT32 ProtocolTableSize - Number of Protocols in the table
PROTOCOL_LOCATE_STRUCT *Protocol - Table of Parameters for LocateProtocol
Output:
Pointers in PROTOCOL_LOCATE_STRUCT are updated
Status is returned with values defined by the LocateProtocol function

Note:
This function will use a Guid pointer or a Guid value defined locally in
the PROTOCOL_LOCATE_STRUCT of the caller.


OemRuntimeShadowRamWrite in the CspLibGeneric.C

Function : OemRuntimeShadowRamWrite

File: CspLibGeneric.C
Description:
This function enables or disables runtime writing to shadow RAM
(E000-F000 segment)
Input:
IN BOOLEAN Enable - if TRUE - enable writing to shadow region
       if FALSE - disable writing to shadow region
Output:
VOID


PeiReadPci in the CspLibGeneric.C

Function : PeiReadPci

File: CspLibGeneric.C
Description:
This function reads the value in a PCI Register using a PCI_CONTROL
structure to simplify the call.
Input:
PEI_PCI_ARGS *Pci - control structure
Output:
Pci->Value is updated with the value read from the PCI device
Status is returned with values defined in the PCI PPI Read function


PeiWritePci in the CspLibGeneric.C

Function : PeiWritePci

File: CspLibGeneric.C
Description:
This function writes a value to a PCI register using a PCI_CONTROL
structure to simplify the call.
Input:
PEI_PCI_ARGS *Pci - control structure
Output:
Status is returned with values defined in the PCI PPI Write function


RbReadPci in the CspLibGeneric.C

Function : RbReadPci

File: CspLibGeneric.C
Description:
This function reads the value(s) in a PCI Register using a RTBRG_PCI_ARGS
structure to simplify the call.
Input:
RTBRG_PCI_ARGS *Arg - pointer to an instance of RTBRG_PCI_ARGS that contains parameters to the RootBrg PCI Read Function
Output:
Arg->Buffer is filled with the data read from the PCI device
Return the status returned by the PCI Read funcntion of the Root Bridge protocol


RbWritePci in the CspLibGeneric.C

Function : RbWritePci

File: CspLibGeneric.C
Description:
This function writes the value(s) in a PCI Register using a RTBRG_PCI_ARGS
structure to simplify the call.
Input:
RTBRG_PCI_ARGS *Arg - pointer to an instance of RTBRG_PCI_ARGS that contains parameters to the RootBrg PCI Read Function
Output:
Return the status


SetTopSwap in the CspLibGeneric.C

Function : SetTopSwap

File: CspLibGeneric.C
Description:
This function sets TopSwap (A16 address line inversion) ON or OFF
Input:
BOOLEAN On - if TRUE, set TopSwap to ON, if FALSE - set to OFF
Output:
None


CspLibGeneric.h

Description:
This file contains generic code to add functionality that can
be used by any module.

The following tables are used in the file: CspLibGeneric.h.

Table | Description
PEI_PCI_ARGS | This data structure contains the information that is used to read or write to PCI Devices using the PEI PciCfg PPI
PPI_LOCATE_STRUCT | This data structure contains the information that is used to make a call to LocatePpi and return the needed pointers
PROTOCOL_LOCATE_STRUCT | This data structure contains the information that is used to make a call to LocateProtocol and return the needed pointers
RTBRG_PCI_ARGS | This data structure contains the information that is used to read or write to PCI Devices using the DXE PCI Root Bridge Protocol


PEI_PCI_ARGS in the CspLibGeneric.h

Table : PEI_PCI_ARGS

File: CspLibGeneric.h
Fields:

Type | ParameterName | Description
EFI_PEI_SERVICES | **PeiServices | - instance of the PEI Services Table
EFI_PEI_PCI_CFG_PPI | *Cfg | - OPTIONAL Pointer to an Instance of the PciCfg PPI
EFI_PEI_PCI_CFG_PPI_WIDTH | Width | - Width of the data to be accessed in the PCI space
UINT32 | Address | - (B/D/F/R) PCI address of the device to read from
VOID | *Value | - Buffer to store Data to Write or Data that is read

Description:
This data structure contains the information that is used to
read or write to PCI Devices using the PEI PciCfg PPI
Notes:


PPI_LOCATE_STRUCT in the CspLibGeneric.h

Table : PPI_LOCATE_STRUCT

File: CspLibGeneric.h
Fields:

Type | ParameterName | Description
EFI_GUID | Guid | - GUID_ZERO or value of Guid
EFI_GUID | *GuidPtr | - NULL or pointer to Guid
UINTN | Instance | - Instance Number to discover
EFI_PEI_PPI_DESCRIPTOR | **Descriptor | - Pointer to a Pointer to reference the found descriptor. If not NULL, returns a pointer to the descriptor (includes flags, etc)
VOID | **Ptr | - Pointer to be updated with an instance of a pointer to a pointer of the PPI being located

Description:
This data structure contains the information that is used to
make a call to LocatePpi and return the needed pointers
Notes:


PROTOCOL_LOCATE_STRUCT in the CspLibGeneric.h

Table : PROTOCOL_LOCATE_STRUCT

File: CspLibGeneric.h
Fields:

Type | ParameterName | Description
EFI_GUID | Guid | - GUID_ZERO or value of Guid
EFI_GUID | *GuidPtr | - NULL or pointer to Guid
VOID | *Registration | - Optional Registration Key returned from RegisterProtocolNotify()
VOID | **Interface | - Pointer to be updated with an instance of a pointer to a pointer of the Protocol being located

Description:
This data structure contains the information that is used to
make a call to LocateProtocol and return the needed pointers
Notes:


RTBRG_PCI_ARGS in the CspLibGeneric.h

Table : RTBRG_PCI_ARGS

File: CspLibGeneric.h
Fields:

Type | ParameterName | Description
EFI_PCI_ROOT_BRIDGE_IO_PROTOCOL | *RtBrdg | - Pointer to an instance of the DXE PCI Root Bridge Protocol
EFI_PCI_ROOT_BRIDGE_IO_PROTOCOL_WIDTH | Width | - Width of the data to read from or write to the PCI Device
UINT64 | Address | - PCI Address of the Device to read from or write to
UINTN | Count | - Number of times to repeat the Read or write command
VOID | *Buffer | - Buffer to store Data to Write or Data that is read

Description:
This data structure contains the information that is used to
read or write to PCI Devices using the DXE PCI Root Bridge Protocol
Notes:


CspLibPei.C

Description:
This file contains code for Generic CSP Library PEI functions.  The
functions include PCI table update etc.

The following functions are used in the file: CspLibPei.C.

Function | Description
CspLibPei_Init | This function is the entry point for this PEI. This function initializes installs the CSP PPI
PciTableInit | This function programs the PCI device with the values provided in the init table provided
PciTableInit2 | This function is identical to PciTableInit with the addition of an extra parameter to specify PCI access width.


CspLibPei_Init in the CspLibPei.C

Function : CspLibPei_Init

File: CspLibPei.C
Description:
This function is the entry point for this PEI. This function initializes
installs the CSP PPI
Input:
FfsHeader   Pointer to the FFS file header
PeiServices Pointer to the PEI services table
Output:
Return Status based on errors that are returned by the InstallPpi function


PciTableInit in the CspLibPei.C

Function : PciTableInit

File: CspLibPei.C
Description:
This function programs the PCI device with the values provided
in the init table provided
Input:
EFI_PEI_SERVICES **PeiServices - Pointer to the PEI Core data Structure
AMI_PEI_PCI_TABLE_INIT_PPI *This - Pointer to an instance of the AMI PEI PCI TABLE INIT PPI
EFI_PEI_PCI_CFG_PPI *PciCfg - Optional pointer to an instance of the PciCfg PPI
UINT64 Address - PCI address of the register to write to (Bus/Dev/Func/Reg)
AMI_PEI_PCI_INIT_TABLE_STRUCT *PCIInitTable - Table with register number, set and clear bits
UINT16 wSize - Table length (multiples of structure)
Output:
Always returns EFI_SUCCESS


PciTableInit2 in the CspLibPei.C

Function : PciTableInit2

File: CspLibPei.C
Description:
This function is identical to PciTableInit with the addition of an extra
parameter to specify PCI access width.
Input:
EFI_PEI_SERVICES **PeiServices - Pointer to the PEI Core data Structure
AMI_PEI_PCI_TABLE_INIT_PPI *This - Pointer to an instance of the AMI PEI PCI TABLE INIT PPI
EFI_PEI_PCI_CFG_PPI *PciCfg - Optional pointer to an instance of the PciCfg PPI
UINT64 CfgAddress - PCI address of the register to write to (Bus/Dev/Func/Reg)
AMI_PEI_PCI_INIT_TABLE_STRUCT2 *PCIInitTable - Table with register number, set and clear bits
UINT16 TableEntries - Table length (multiples of structure)
EFI_PEI_PCI_CFG_PPI_WIDTH AccessWidth - Register-level access width
Output:
Always returns EFI_SUCCESS


CspLibPPI.h

Description:
This file contains PPI definitions that are defined in the CSP Library

The following descriptions are used in the file: CspLibPPI.h.

Header | Description
AMI_PEI_PCI_INIT_TABLE_STRUCT | This data structure contains the information that is used to modify PCI register of a PCI specific device
AMI_PEI_PCI_INIT_TABLE_STRUCT2 | This data structure contains the information that is used to modify PCI register of a PCI specific device
AMI_PEI_PCI_TABLE_INIT_PPI | This data structure is the AMI_PEI_PCI_TABLE_INIT_PPI definition This provides this PPI to any module that includes the chipset library. This provides a mechanism to program a table full of PCI information in one function call
AMI_PEI_PCI_TABLE_INIT_PPI_GUID | This is the GUID to use to locate the the instance of the AMI_PEI_PCI_TABLE_INIT_PPI


AMI_PEI_PCI_INIT_TABLE_STRUCT in the CspLibPPI.h

General : AMI_PEI_PCI_INIT_TABLE_STRUCT

File: CspLibPPI.h
Fields:

Type | ParameterName | Description
UINT8 | bRegIndex | - PCI Register to program
UINT8 | bANDMask | - AND mask to apply to data in PCI register
UINT8 | bORMask | - OR mask to apply to data in PCI register after AND mask

Description:
This data structure contains the information that is used to
modify PCI register of a PCI specific device
Notes:
Only can modify a one byte register at a time.
See AMI_PEI_PCI_INIT_TABLE_STRUCT2 to modify lager register
at once


AMI_PEI_PCI_INIT_TABLE_STRUCT2 in the CspLibPPI.h

General : AMI_PEI_PCI_INIT_TABLE_STRUCT2

File: CspLibPPI.h
Fields:

Type | ParameterName | Description
UINT8 | bRegIndex | - PCI Register to program
UINTN | bANDMask | - AND mask to apply to data in PCI register
UINTN | bORMask | - OR mask to apply to data in PCI register after AND mask

Description:
This data structure contains the information that is used to
modify PCI register of a PCI specific device
Notes:
This Structure is almost the same as AMI_PEI_PCI_INIT_TABLE_STRUCT
The difference is in the size of the AND and OR masks. to allow
modification of PCI registers larger than one byte


AMI_PEI_PCI_TABLE_INIT_PPI in the CspLibPPI.h

General : AMI_PEI_PCI_TABLE_INIT_PPI

File: CspLibPPI.h
Fields:

Type | ParameterName | Description
AMI_PEI_PCI_TABLE_INIT_FUNCTION | AMIPEIProgramPCITable | - PciTableInit
AMI_PEI_PCI_TABLE_INIT_FUNCTION_VARACCESS | ProgramPciTable | - PciTableInit2

Description:
This data structure is the AMI_PEI_PCI_TABLE_INIT_PPI definition
This provides this PPI to any module that includes the chipset
library.  This provides a mechanism to program a table full of
PCI information in one function call
Notes:
See the function headers for descriptions


AMI_PEI_PCI_TABLE_INIT_PPI_GUID in the CspLibPPI.h

General : AMI_PEI_PCI_TABLE_INIT_PPI_GUID

File: CspLibPPI.h
Description:
This is the GUID to use to locate the the instance of the
AMI_PEI_PCI_TABLE_INIT_PPI
Notes:
#define AMI_PEI_PCI_TABLE_INIT_PPI_GUID \
{ 0x97f91e78, 0xea12, 0x4ea6, 0xb7, 0xb3, 0x7b, 0x6, 0x78, 0xc2, 0x86, 0x73 }

============================================================================


CspLibProtocols.h

Description:
This file contains Protocol definitions that are defined in the CSP Library


FID.c

Description:
This file the Firmware Version Data Structure definition


FwVersion.h

Description:
This file the FW_VERSION data structure which is used by AMI utilities to
provide information about the BIOS

The following descriptions are used in the file: FwVersion.h.

Header | Description
FW_VERSION | This data structure contains the information used by AMI utilities to provide information about the current BIOS


FW_VERSION in the FwVersion.h

General : FW_VERSION

File: FwVersion.h
Fields:

Type | ParameterName | Description
CHAR8 | FirmwareID[4] | - Signature '$FID'
UINT8 | StructVersion | - Version of the FW_VERSION Structure
UINT16 | Size | - Size of this structure
CHAR8 | BiosTag[9] | - BIOS Tag
EFI_GUID | FirmwareGuid | - Firmware GUID
CHAR8 | CoreMajorVersion[3] | - Aptio Core Major Version
CHAR8 | CoreMinorVersion[3] | - Aptio Core Minor Version
CHAR8 | ProjectMajorVersion[3] | - Project Major Version
CHAR8 | ProjectMinorVersion[3] | - Project Minor Version
UINT16 | Year | - Build Year
UINT8 | Month | - Build Month
UINT8 | Day | - Build Day
UINT8 | Hour | - Build Hour
UINT8 | Minute | - Build Minute
UINT8 | Second | - Build Second
UINT32 | OemActivationKeyLength | - Length of the OEM Activation key
UINT8 | OemActivationKey | [49] - OEM Activation key

Description:
This data structure contains the information used by AMI utilities
to provide information about the current BIOS
Notes:
Data structure changed for version 2 of the Firmware Version Structure
Version 1 is no longer supported


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

  • C
  • I
  • L
  • O
  • P
  • R
  • S


Functions in Alphabetical Order

C

Function | Description
CSP_PCI_CFG_ADDRESS | This MACRO Converts bus, device function and register number into 64bit PCI configuration address
CspLibDxe_Init | This function is the entry point for this DXE. This function installs necessary Csp protocols
CspLibPei_Init | This function is the entry point for this PEI. This function initializes installs the CSP PPI


Functions in Alphabetical Order

I

Function | Description
IsTopSwapOn | This function checks if TopSwap (A16 address line inversion) is on


Functions in Alphabetical Order

L

Function | Description
LocateMultiplePpi | This function wraps the initialization and error checking of LocatePpi() in a table, in order to reduce code size in functions that use several PPI.
LocateMultipleProtocol | This function wraps the initialization and error checking of LocateProtocol() in a table, in order to reduce code size in functions that use several Protocol.


Functions in Alphabetical Order

O

Function | Description
OemRuntimeShadowRamWrite | This function enables or disables runtime writing to shadow RAM (E000-F000 segment)


Functions in Alphabetical Order

P

Function | Description
PciTableInit | This function programs the PCI device with the values provided in the init table provided
PciTableInit2 | This function is identical to PciTableInit with the addition of an extra parameter to specify PCI access width.
PeiReadPci | This function reads the value in a PCI Register using a PCI_CONTROL structure to simplify the call.
PeiWritePci | This function writes a value to a PCI register using a PCI_CONTROL structure to simplify the call.

Table | Description
PEI_PCI_ARGS | This data structure contains the information that is used to read or write to PCI Devices using the PEI PciCfg PPI
PPI_LOCATE_STRUCT | This data structure contains the information that is used to make a call to LocatePpi and return the needed pointers
PROTOCOL_LOCATE_STRUCT | This data structure contains the information that is used to make a call to LocateProtocol and return the needed pointers


Functions in Alphabetical Order

R

Function | Description
RbReadPci | This function reads the value(s) in a PCI Register using a RTBRG_PCI_ARGS structure to simplify the call.
RbWritePci | This function writes the value(s) in a PCI Register using a RTBRG_PCI_ARGS structure to simplify the call.

Table | Description
RTBRG_PCI_ARGS | This data structure contains the information that is used to read or write to PCI Devices using the DXE PCI Root Bridge Protocol


Functions in Alphabetical Order

S

Function | Description
SetTopSwap | This function sets TopSwap (A16 address line inversion) ON or OFF


General Information

Header | Description
AMI_PEI_PCI_INIT_TABLE_STRUCT | This data structure contains the information that is used to modify PCI register of a PCI specific device
AMI_PEI_PCI_INIT_TABLE_STRUCT2 | This data structure contains the information that is used to modify PCI register of a PCI specific device
AMI_PEI_PCI_TABLE_INIT_PPI | This data structure is the AMI_PEI_PCI_TABLE_INIT_PPI definition This provides this PPI to any module that includes the chipset library. This provides a mechanism to program a table full of PCI information in one function call
AMI_PEI_PCI_TABLE_INIT_PPI_GUID | This is the GUID to use to locate the the instance of the AMI_PEI_PCI_TABLE_INIT_PPI
FW_VERSION | This data structure contains the information used by AMI utilities to provide information about the current BIOS


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2011 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.