American Megatrends, Inc.

AMITSE

Copyright

Release Notes

© American Megatrends, Inc.


eModule Release Notes

AMIBIOS Component Release Notes

Component Information:

Component Name | : | AMITSE
Component Type | : | eModule
Release Date | : | 10/01/2014
Source Control Label | : | 4.6.2_TSE_2_17_1247
Source Control Location | : | $/Alaska/BIN/Modules/AMITSE2_0/AMITSE $/Alaska/SOURCE/Modules/AMITSE2_0/AMITSE

Build Tools:

Compiler Used | : | WDK version 7600.16385.1
Tool Directories | : | Label version: 4.5.5_Tools_33, Dated: July 07, 2010
WDK Tools | : | <WinDDK>/7600.16385.1/bin/x86 <WinDDK>/7600.16385.1/bin/x86/x86
Env.Variables | : | CCX86DIR = <WinDDK>\7600.16385.1\bin\x86\x86 CCX64DIR = <WinDDK>\7600.16385.1\bin\x86\amd64
Visual eBios | : | RSS 5.69.0148, Dated: July 07, 2010
Build Environment | : | UEFI 2.0, UEFI 2.1, x32 and X64

Component Description:

AMITSE is a firmware component that provides the following functionality:

· POST Manager

· Splash screen logo support

· BBS Popup support

· Boot device support

· Driver Order support

· Setup Configuration pages

· Manage Boot Process

· Firmware User Interface

· OEM Customizations

· Advanced Protocol Support

· Style Customization

· Choose between Ezport, Legacy and Ezport Styles support

· Keeping logos in ROMHole

· OSIndications Support

· ESRT support

· Native resolution support

· Print screen support

· Password encoding using hash algorithm

· Support to remove RT flag in HPKTOOL

Filename | Description
AMIPostMgr.h | AMI Post manager protocol related code
AMITSE.mak | AMI TSE BIN module makefile for Aptio.
AMIVfr.h | VFR related header
boot.h | UEFI Boot related header
bootflow.c | This file bootflow related functions and tables
bootflow.h | Bootflow header
CommonHelper.c | This file is Helper file for Boot only TSE module This functions may be overridden by Other Advanced TSE module.
commonoem.c | Contains default implementation of TSE hooks
commonoem.h | Header of commonoem.c
changelog.log | Change history of the file from previous release
FakeTokens.c | This file does not add any code. It has, all the string tokens that are used by Minisetup, to fake the usage to strgather.exe. Add to this list, the new string tokens that are defined in AmiTSEStrstr.uni and to be used by Minisetup
HotkeyBin.c | Contains generic hotkey scancode definitions.
HotkeyBin.h | Header file for HotkeyBin.c
HiiLib.h | Hii related functions
HiiString20.c | Hii string utils file for UEFI 2.0
HiiString21.c | Hii string utils file for UEFI 2.1
HookAnchor.h | TSE hook functions
HookList.c | AMITSE Hook definitions
Hpktool.exe | OffLine Hpk parser and nvram defaults creation tool for UEFI 2.0
Keymon.c | Keymon.c.
Keymon.h | Header of keymon.c
LogoLib.h | Logo related header
mem.h | Memory utility functions
Mouse.c | This file contains code to handle Mouse Operations
OemkeyHook.c | Contains oemkey hook functions
OEMLogo.c | To implement OEM Logo customizations
OemTokens.c | This file does not add any code. It has, all the string tokens that are used by Minisetup, to fake the usage to strgather.exe. Add to this list, the new string tokens that are defined in AmiTSEStrstr.uni and to be used by Minisetup
PwdLib.h | Password handling realted header
setup.ini | Ini file for hpktool
Setupdata.h | Header file for setup data
StyleTokens.c | This file does not add any code. It has, all the string tokens that are used by Minisetup, to fake the usage to strgather.exe. Add to this list, the new string tokens that are defined in AmiTSEStrstr.uni and to be used by Minisetup
TseBoard.c | This Module is to implement the OME Functions
TSECommon.h | Common header file that can be consumed by other modules that likes with TSE for TSE internal interfaces
TseElinks.h | Header file for Elink related customizations
TseOEM.C | The following functions are used in the file: TseOEM.C.
TseOem.h | Header file for TSE OEM
Uefihpktool.exe | OffLine Hpk parser and nvram defaults creation tool for UEFI 2.1
uefisetup.ini | INI file for uefihpktool.exe
variable.h | Variable handling header
HotclickBin.h | Contains generic hotclick information.
HotclickBin.c | Header file for HotclickBin.c
TseDrvHealth.h | Contains TSE specific driver health declarations
setupdbg.h | Header file for string functionalities.
AddDelBootDrvOpts.sd | SD File for Add/Del Boot/Driver options to show in Boot page in setup
AddDelBootDrvOpts.uni | UNI file contains strings for Add/Del Boot/Driver options to show in Boot page in setup
PasswordEncode.c | Password encoding functionalities
PasswordEncode.h | Header file for PasswordEncode module
PasswordEncodeBin.mak | Make file for PasswordEncode module
PasswordEncodeBin.sdl | Sdl file for PasswordEncode modules

Help Topics:

  • TSE Help Module
  • AMITSE SDL TOKENS

4.6.2_TSE_2_17_1247

New Features:

· Support to provide and load defaults for string controls.

· Support to use best text mode and resolutions before use TsePostInterfaces outside TSE.

· Support to select and focus grayed out controls.

Bug Fixes:

· Fixed mouse click\touch actions when soft keyboard is activated in setup.

· Fixed issue of mouse is not moving in post for whole screen in quiet boot

· Fixed issue of POST screen display gets delay when softkeyboard is present

· Fixed issue of when HDD boot option is selected to disabled in Boot Priority and the same HDD is disappeared under DOS.

· Fixed issue of System will display blue screen after use OEM command to boot to “BIOS Setup Utility” from Built-in EFI Shell.

· Fixed issue of Background of TextBox is not cleared after using TSE DisplayTextBox interface.

· Fixed issue of User password is not cleared when Admin password is cleared from NVRAM.

· Fixed issue of System hangs on using UefiVarsetnvramforCurrentform

· Fixed issue of HDD password prompt is not proper in post.

· Fixed issue of mouse pointer flicker continuously when softkbd is launched for string control.

· Fixed issue of Password window hangs on post.

· Fixed issue of TMM Settings page is moved to wrong position.

· Fixed issue of Post password popup window dislocation and distortion.

· Fixed issue of Arrow mark shown when driver health page published.

· Fixed issue of Setup hangs when sendform called from oemdriverhealth module.

· Fixed issue of PXE boot options are not booting from boot override menu if GROUP_BOOT_OPTIONS_BY_TAG is 0

· Fixed issue of Refresh_ID support is not working in TSE

· Removed TODO comments and added proper comments in those places

· Fixed build error when token TSE_USE_GETGYLPH_PRINTLENGH is enabled

Files changed from previous release:

- EIP comments will give the changed files.

Known Issues:

- In some pages with more number of controls scroll bar can move inconsistently.

- Hot clicks on navigation frame are not available for Legacy and Ezport Plus Setup.

Remaining Issues:

- NIL.

Unit Testing:

- Booting to different flavors of Dos and Windows.

- Refer EIPs on Review and AMITSE_EIP_UnitTestReport.xlsx/AMITSE_EIP_UnitTestReport_Generalized.xlsx document for Testing information

- Tested with System Recovery mode.

- Tested with FastBoot Enabled.

- Tested the Setup UI/Navigation with UEFI 2.0/UEFI 2.1 and above in both x64 and x32 builds.

- Tested Add/Del boot/driver option support with File browser support

Validation Testing:

- No pending issues.

Third Party Code:

- EdkHelper.c contains some of the functions from EDK 1117 module

- UEFI 2.1 Express evaluation done using EDK 1.05 code.

Notes:

- To enable FORM_BROWSER protocol support enable SETUP_FORM_BROWSER_SUPPORT and SETUP_RUNTIME_IFR_PROCESSING

- To enable Add/Del boot option, questions should be added in Boot.vfr and SETUP_SUPPORT_ADD_BOOT_OPTION SDL token should be enabled.

- Turn on MINISETUP_MOUSE_SUPPORT for mouse support

- Support to override TSE strings needs Aptio 4.6.4.0 and Tools Label "4.5.5_Tools_30 or above.

- TSE is a setup engine; it can’t check/correct the spelling/grammatical errors of setup pages. It needs to be fixed in modules that produce the Hii resources.

- Use the StatusCode Module version 16 to resolve the setup hanging for few minutes with some boot options.

- If using EDK library, BGRT support will not work properly unless the source is having the latest Include/Protocol/AcpiSupport.h file version 7 or the guid defined as

#define EFI_ACPI_TABLE_PROTOCOL_GUID \

{0xffe06bdd, 0x6107, 0x46a6, {0x7b, 0xb2, 0x5a, 0x9c, \ 0x7e, 0xc5, 0x27, 0x5c}}

- For debug trace messages, TSE sources are needed

- To increase the password length TSE sources are required

- TSE_HASH_PASSWORD should be enabled when the project has CryptoPkg.

- Mouse driver compatibility chart,

TSE Version | Recommended Mouse Driver
4.6.2_TSE_2_11_1210 | 4.6.0-MOUSE_SUPPORT-001
4.6.2_TSE_2_13_1213 and 4.6.2_TSE_2_14_1219 | 4.6.0-MOUSE_SUPPORT-007, 4.6.0-MOUSE_SUPPORT-008 and 4.6.0-MOUSE_SUPPORT-009
4.6.2_TSE_2_15_1224 or above | 4.6.0-MOUSE_SUPPORT-010 or above

Revision History:

4.6.2_TSE_2_17_1246

New Features:

· Provision to hide the dynamic formset through Elinks

· Password encoding using hash algorithm

· Removing run time flag for the variables

· Provision to provide default password through SDL tokens.

· Provided more override hooks

· Provision to disable ESC key in BBS popup menu

· Protocol interface to invalidate the status bit in BGRT

· Increased TSE variables for customization

· Event signaled before and after boot time out

· Provision to hide softkbd in BBS menu

· Copyright year updated with BIOS build year dynamically

· Application level hot click support for Ezport style in 80*25 mode also.

· Support to close messagebox, listbox using moue right button action.

· Provision to suppress the handle comparison for variable in dynamic parsing through Elink.

· Compatible with AMISetupNVLock module

Bug Fixes:

· On multiline control clicking on the control in the multi lines is not getting selected

· Security code check fixed

· EDK_1_05_RETRIEVE_DATA defined 1 or 0 based on core version.

· In 80*25 mode controls moving out of the frame

· Loading defaults on add/boot option hangs

· Softkbd not cleared properly when selecting shell from Boot override menu

· TSE hangs on having lengthier password titles

· Menu not selectable when numeric control is selected and also single click activation is enabled.

· Secure boot message hangs with softkbd displayed

· USB/PS2 keyboard not working in setup

· TSE hangs on RAID driver on disconnecting and connecting it.

· When token MATCH_BOOT_OPTION_BY_LOCATION = 0 and GROUP_BOOT_OPTIONS_BY_TAG = 0, then boot device is not displaying properly.

· Dynamic pages after removing and updating the pack, menu title is changing.

· Hpktool not throwing error on not mentioning EFI spec version.

· Action control not prompting save and reset when Reset required flag is set.

· Build error if more Elinks are provided

· Large string in listbox hangs

· Message box not closed on outside right click

· UefiVarsetnvramforCurrentform not saving values properly for current form.

· Closing password by clicking outside popup window displaying invalid password message box, when SINGLE_CLICK_ACTIVATION token is enabled

· BGRT status not cleared for shell v2.0

· When password keyboard is launched and mouse pointer is placed on softkbd mouse will flickers continuously.

· System Abnormal when execute Load Default (F9) in BIOS Setup.

· Add boot option failed to add the boot option if no boot option found initially.

· Removed global variable guid usage for TSE debug messages

· Removed RT attributes in some of the variables not needed it.

4.6.2_TSE_2_16_1243

New Features:

· Support to suppress formset other than EFI_HII_PLATFORM_SETUP_FORMSET_GUID and EFI_HII_DRIVER_HEALTH_FORMSET_GUID using elink

· Support to display multiple lines using single ANSI ESC code color.

· Support to show all HDD passwords in same page

· Added signal event to denote all boot option has exhausted.

· Support to restore resolution before signalling AMITSE_EVENT_BEFORE_BOOT_GUID event.

· ESA compatibility for Aptio5

Bug Fixes:

· Moved saving current screen resolution from DrawImage to DrawQuietBootLogo.

· Fixed switch language between Japanese and English will displaying broken Japanese character in pages

· Fix for add boot options support in ESA

· EfiCreateEventReadyToBoot is conflicted under UefiLib.h and EDKhelper.h. So changed function name to TseEfiCreateEventReadyToBoot

· Security code check fail in the function IsBootDeviceEnabled() in boot.c

· Legacy boot doesn't work after UEFI Shell is launched from LaunchAppHotkey menu

· Fixed DrawStringJustifiedWithAttribute function to avoid truncating passed original strings.

· When entered into setup with User mode and On pressing "Restore User Defaults" SystemAccess variable is loading and the user mode is changes to Admin mode so the controls are editable

· TSE Help window flickers when Mouse\Touch device used under boot page in Setup

· Support '\r' character to behave like line feed (‘\n’) to do line break.

· Fixed UI is not Displaying properly after enabling Quite Boot in ESA

· UefiHpkTool is throwing build error saying "UefiHpkTool stopped working" on using 8 byte value as default value for Numeric control

· The ParentPageID in the destination page of the Ref3 control is not updated properly

· Adding UEFI bootable RHEL OS(Bootx64.efi) from UEFI REHL6.4 DVD disk through add boot option causes setup hang

· Incorrect Driver Health name shown in BIOS (UEFI Mode) Setup for SAS Card.

· When password control label string has space as first character, then on selecting it setup hangs

· New opcodes added in controltypes in hpktool

· Fixed dynamic pages are not displaying all its root pages ie., showing 1 controller page not 2 controller pages

· Fixed issue not loading defaults for interactive controls

· Fixed menu order is not proper when entering into setup through BBS menu on using AMITSE_ROOT_PAGE_ORDER_SUPPORT

· Fixed dynamic pages crash issue on clicking its page

· Fixed EFI Windows Boot manager boot entry will not disappear after remove EFI-HDD from the target

· Fixed setup hang when legacydevorder variable is try to update using formcallback.

· Fixed for oprom published page, when both MINISETUP_MOUSE_SUPPORT and TSE_MULTILINE_CONTROLS are enabled, only the first line of wrapped controls are clickable.

· Fixed for oprom published page, action controls doesn’t handle mouse clicks.

· Fixed for oprom published page, text get truncated even if TSE_MULTILINE_CONTROLS enabled

· Fixed for oprom published page, checkbox is not grayed-out when checkbox is present in identical formset with two different handle

· Changed path size from 1 to 120 in NEW_BOOT_OPTION structure

· Fixed slowness in shell performance

· Fixed F1 not displaying help message

· Fixed screen clearing issue in UEFI PXE boot.

4.6.2_TSE_2_16_1240

New Features:

· Compatible with latest opcodes.

· Hook function for toggling between quiet boot and post screen.

· Opcode support for EFI_IFR_WRITE, EFI_IFR_READ, EFI_IFR_GET, EFI_IFR_SET, EFI_IFR_MAP_OP, EFI_IFR_VARSTORE_EFI, EFI_IFR_MODAL_TAG_OP, EFI_IFR_QUESTION_REF3_2, EFI_IFR_QUESTION_REF3_3, EFI_IFR_TYPE_REF, EFI_IFR_REF5

· Offline parsing support for EFI_IFR_REFRESH_ID

· Passing non encoded password string to callback.

· Romhole support for PI spec. version 0.91

· Checksum support in HPKTool

· EFI_BROWSER_ACTION_DEFAULT_MANUFACTURING support

· Hook provided for messagebox color change display for VT100

· Logo redrawn after HDD password popup

· Print screen support

· AMITSE_EVENT_BEFORE_BOOT_GUID signaled in fast boot path also

· _SaveValues without MessageBox

· Modal form support

· Support for grayout subtitle control

· Post message support for BBS popup menu

· Modify callback function behavior to match UEFI SPEC for submenu

· Ability to dump the Hii Pack from the Setup as part of TSE debug Infrastructure

· Print screen support in file browser feature

· Change resolution before boot in FastBoot path

· BGRT table header revision revised to 1 as per ACPI spec

· Moved password encoding part from binary to source

· Fool-proofing for BootOrder and LegacyDevOrder variables

Bug Fixes:

· Optimal Defaults are not loading on pressing ResetButton

· HDD pwd window title is not proper after enabling token TSE_SHOW_PROMPT_STRING_AS_TITLE inside setup

· Popup string control accepts CARRAGE_RETURN character while pressing CTRL+ENTER and causing page corruption

· Cursor is cleared after taking print screen on popup edit controls

· Fixed when post msg box overlapped with another message box then OK of top message box is consumed by further message box and so closing further message box

· Fixed system halt when 4GB memory installed with Quiet Boot enabled in 32 bit platform

· Fixed system hangs up when use the broken JPG file

· Resolved build error when tokens TSE_PRN_SCRN_EVENT_SUPPORT, TSE_DEBUG_MESSAGE are enabled in all flavors.

· Fixed HPKTool crashes when any suppressif, grayoutif, disableif present over the form

· Fixed issue in NameValue for string control

· Fixed issue faced in Interactive password and string controls

· Fixed setup hangs on first goto after entering from Shell twice. Using sendform.

· Fixed to not show post messages twice.

· System hangs while navigating SAS Card UEFI HII Page, when TSE_MULTILINE_CONTROLS is enabled.

· Dynamic parsing is modifying Checkbox controls optimal and failsafe defaults by setting size=1 irrespective of presence of defaults.

· Fix to load ffs from both FV and FV2 protocol.

· SETUP_GO_TO_EXIT_PAGE_ON_EXIT_KEY handled from binary.

· Boot Device name incorrect when defaults loaded.

· Fix to hide a page/show subpage as root page properly.

· TSE BootGetBBSOptionStatus asserts.

· Mouse shadow can’t refresh when mouse pointer is over top most of the screen.

· AMI small logo has damage on POST and boot.

· When User password alone is set, Setup gets hang in post while validating User Password.

· BIOS dialog box is crashed with special monitor (160, 53, 1280*1024).

· Ami Post Management functionalities reliant on ConOut need checks added.

· In Setup click\Touch from navigation window, options are not displayed properly.

· Boot override could not see all the devices when TSE_BOOT_NOW_IN_BOOT_ORDER is enabled with hidden boot options presented.

· Can't load default boot priorities if token "SETUP_SUPPORT_ADD_BOOT_OPTION" is enabled.

· Fixed to call ProcessProceedToBootHook function properly with respect to ShowPostMenu function.

· Multiline support for Hii String control does not wrap the string in some cases issues.

· Removed displaying error message for interactive string control.

· SAS controller card HII menus hang when selecting and HII pack update occurs.

4.6.2_TSE_2_15_1236

New Features:

· Support for ESRT.

· Support for EDID and maintaining native resolution.

· Tokenizing BootTimeout to control timeout value

· Provided help scrolling using ‘M’ and ‘K’ information in general help window

· Support REFRESH_ID for OrderedList and Password controls

· Option to display the post logo at (0, 0) graphics position.

· Support for choosing DISABLED_BOOT_OPTION and DISABLED_DRIVER_OPTION values at run time.

· Improvement for boots override options when firmware has a BootNext variable.

· Not waiting for key if fast boot is in progress.

· Adding AMIDiag guid default in setup.ini and uefisetup.ini.

· New token added to launch BBS popup with shift state also.

· Tokenized the feature for flushing keyboard after every key read.

· Tokenized the cursor support in password and string controls.

· Call stack operation for PostMenu with callback.

· Ordering root pages using ELINKS.

· Orphan page support in hpktool also.

· Support for suppressing multiline for one of options labels only.

· Optimized UefiHiiTestPrintLength function.

· Added submenu icon for driver health options.

· Improved TSE which does not access NVRAM during recovery.

· Include function "_RegisterShellGuid()" in fast boot path.

Bug Fixes:

· System gets hang while drawing message box when ConIn not present before launching TSE.

· When first EFI device fails to boot then screen is not cleared properly.

· Setup hangs on BBS Menu when string more than 200 characters.

· Splash logo is not displayed when "Quiet boot" was enabled, and password was set.

· Fixed "STYLE_DATE_FORMAT" sdl token to change the date display type to [yyyy/mm/dd] properly.

· Fix for sendform to display properly when it called more than once.

· Fix to call the ProcessProceedToBootHook properly from DisplayPostMenu.

· Fix to call ActivateInput immediately once ConIn avails.

· Minisetup crashes after controller reconnection during Hii callback.

· Fix to provide multiline support properly for submenu control.

· EFI_BROWSER_ACTION_REQUEST_FORM_DISCARD fixed not to load the changed value.

· Fix to show long strings in listbox.

· Help string support for ordered list.

4.6.2_TSE_2_15_1234

New Features:

· Support to check for enabled devices in BBS priority order before launching legacy boot.

· Saving password directly to NVRAM.

· Not loading defaults for password.

· Support to launch shell in particular mode.

· In no value is changed in BBS priorities then SetupConfigModifiedHook function won’t be invoked.

· Hii notifications created only when SETUP_RUNTIME_IFR_PROCESSING token is enabled.

· Support EFI_IFR_REFRESH_ID Opcode as per UEFI Spec.

· Triggering the amitsesetupenterguid for all the possible cases.

Bug Fixes:

· Fix to show all BBS device when SETUP_SHOW_ALL_BBS_DEVICES token is enabled.

· Avoided build issue when TSE built with old core.

· Fix to load defaults properly with TseDefaultBootOrder module.

· Fix to load user defaults properly when variables from OPROM are removed in consecutive boots.

· Boot Order and Driver Order cases are handled properly in _PopupSelGetSelection() function.

· Fix to not allowing system to hang when submenu has no controls in it.

4.6.2_TSE_2_15_1231

General Bug Fixes:

· EIP101218: Fixed to allow multiple sendform before PostMangerhandshake.

4.6.2_TSE_2_15_1229

New Features:

General Bug Fixes:

· Invalidating the BGRT table when boot device launched from BBS popup or from shell or launched as second boot device or for shell boot.

· Fixed the Shift + "+" combination keys not working for numeric controls.

4.6.2_TSE_2_15_1227

New Features:

· Secondary boot path will not be happen for disabled devices.

· Support added not to wait for GOP notification to display the post screen through terminal.

· SETUP_DELAY_LOGO_TILL_INPUT token handled from binary.

· Support for LegacyBootFailHook() in TSE.

· On password window softkbd displayed only with required keys depend upon SETUP_STORE_KEYCODE_PASSWORD.

· For numeric controls softkbd displayed only with required keys for different numeric format like Decimal, Hexa etc.,

· Mouse drag support in frame and list box.

· Load/Save defaults without message box(silently).

· Support for REF4 type control.

· Optimised UefiHiiTestPrintLength function.

· Resolution restored while booting to the one maintained to display the logo.

· Extended Popup password customization options.

· Inconsistency checked only for valid pages

· Support added for following callback action requests

Ø EFI_BROWSER_ACTION_REQUEST_FORM_SUBMIT_EXIT

Ø EFI_BROWSER_ACTION_REQUEST_FORM_DISCARD_EXIT

Ø EFI_BROWSER_ACTION_REQUEST_FORM_APPLY

Ø EFI_BROWSER_ACTION_REQUEST_FORM_DISCARD

General Bug Fixes:

· Secure boot violation message box in UefiBootFailHook function leads to assert.

· Baud rate 9600 refresh screen twice in list box display.

· When pop-up window is invoked in setup and click on ESC icon or ESC/Right click in navigation frame, it will respond as two times ESC is clicked.

· Assert happened in Add/Del Boot/Driver option.

· TSE 1224 never called callbacks with EFI_BROWSER_ACTION_FORM_CLOSE when reset is required.

· Setup hangs when retrieve callback produces add/remove/update form.

· gFailsafeDefaults leads memory corruption between _MergeVariableListAndInfo and TseVarBuildAMIDefaults.

4.6.2_TSE_2_15_1226

New Features:

· OSIndications support

· Implemented BGRT logo calculation based on Windows-8 requirement

· SoftKbd activate functionality in BBS Menu by AMITSE instead of SoftKbd module

· Updating Min/Max values for date and time in UefiGetDateTimeDetails().

· Changing GetUefiSpecVersion as board module hook and also controlling callback spec version from TSE itself.

· Providing mouse functions as board module hook(mouse.c file)

General Bug Fixes:

· Combination of keys handled properly in checkoemkey functionality

· Handled partial keys properly

· Handled hidden boot options properly in BBS Popup menu when TSE_BOOT_NOW_IN_BOOT_ORDER and POPUP_MENU_SHOW_ALL_BBS_DEVICES are Disabled

· ISCSI attempt order handled properly to change its order.

· HDD Port Number is updated properly when using "TseDefaultBootOrder" module.

· Bug fixed to display YUV122 sampling JPEG images properly.

· System hangs at password prompt when Administrator password set alone and no boot devices presented with softkbd.

· Mouse pointer stuck at post. If mouse alone present then it will not be shown at post and initialized only in setup.

· Mouse pointer will not be destroyed by TSE when it is on SETUP icon during POST.

· Allowing EFI_BROWSER_ACTION_RETRIEVE action for all Interactive controls from MiniSetupEntry.

· ProcessProceedToBootHook() invoked when selecting ESC key in the BBS popup Menu.

· ProcessConInAvailability restricted to display Post messages more than once on the POST screen when it is hooked many times.

· SUT hangs when "Exit without saving" prompt is select as 'yes' in setup.

· Strings are cleared after calling PostManagerSwitchToPostScreen () function.

4.6.2_TSE_2_15_1224

New Features:

· Driver order support

· Add/Del driver option support

· Support for UEFI Load Options - USB WWID

· Support for keeping logos in ROMHole

· Security operations in BootOnly module instead of TSELite.

· Added few extra variables and guids in uefisetup.ini and setup.ini for porting purpose

· Support to uninstall BGRT for legacy boot

· Support for drag and drop to rearrange the items in the orderlist

· Displaying password prompt old, new and confirm texts in the same window in the Ezportplus style

· Avoided flickering when booted to UEFI OS for seamless boot

· Added AmiPostManager interface for text entry.

· Displayed page title of submenu pages in the menu tab

· TSE debug print infrastructure.

· Support for graying out the condition for readonly controls.

· Control STYLE_HELP_AREA_SCROLLBAR and TSE_MULTILINE_CONTROLS from binary

· Cursor visibility for string and password windows

· MainSetupLoop and ProcessBrowserActionRequest as board module hook

· MAX_MSGBOX_WIDTH introduced to control the message box width

· EFI_IFR_INCONSISTENT_IF to follow 28.2.5.9.2 as per efi spec 2.3.1

· Zeroing password related buffers before freeing it.

· Provision to change the Numeric string format

· Providing the alternative way for _ActionReadKey

· Exposing the Handle of the image that's being launched or boot. This will help other elinks to do the processing. Needed for CsmOptOut Feature.

· Support for queuing UpdatePack notifications

· "-"key looping in the time setting

· Clearing the Screen whenever boot to EFI Shell and not to UEFI OS

· _BBSSetDevicePriorities to check current BootPriority before assigning a new BootPriority

· Support for loading defaults for Orderlist controls

· Provisioning to set manufacturing default language

· Core changed to create the boot variables in upper case from version 4.6.4.1. So making the TSE_CAPITAL_BOOT_OPTION token compatible with core.

General Bug Fixes:

· Partial keys not handled properly

· Screen not cleared properly while showing "Secure boot violation" warning message

· Softkeyboard not launched for Password control in EzportPlus style module

· GEOMETRICSHAPE_RIGHT_TRIANGLE mark not added for AddBoot option in TSE advanced

· Updated Defaults for Checkbox controls which doesn't support scope

· Mouse pointer corruption in GTSE

· IDE security login dialog was not displayed properly and also password dialog label name displayed in text field

· BOOT_FLOW_NORMAL_INFINITE_LOOP enabled and pressing F7 while displaying "No option to boot to" is not working properly

· Time not working properly

· Non RTC date control - decreasing from year value 0001 displayed 65535 without closing bracket

· Decreasing YEAR field displayed yearr with XX before 2005 and after 2098.

· Text srting is not wrapped properly when TSE_MULTILINE_CONTROLS token enabled.

· Add driver option displays select boot option as title

· BOOT_FLOW_NORMAL_INFINITE_LOOP option is not working properly

· HDDSecurity module - Issue in login with TSE, Master password disabled

· Two boot option entries displayed with the single name value

· Unable to set the date and time with the soft keyboard and mouse

· Cursor is not blinking in string and password windows when "Softkbd" support enabled

· Circular reference is not updated after pack update which leads to RSOD

· Day of week is not properly calculated for 2012 in Setup

· Scrollbar functionality with mouse was not working properly and While Clicking the arrow buttons in scroll bar moves the entry up not the scroll bar.

· TSE_MULTILINE_CONTROLS does not work for all control types

· HII Screen Titles displaying the wrong information

· Dynamic Pages need to List FormSet title instead of Form Title.

· Callback was invoked during periodic update for time and date controls without EFI_IFR_REFRESH_OP.

· BootFlow variable uses inconsistent attributes

· Incorrect static strings retrieved

· Callback for Date and Time doesn't pass the new value

· Progress bar in MSGBOX_TYPE_PROGRESS never displays the full 100%

· Maximum 8 byte signed integer not working properly

· System Time is not updated every second

· String wrapping corrected for one of option control.

· OffBoard card pages should begin with an > (arrow/sideways triagle)

· HDD user password and Admin password entries are disappeared after "Launch EFI shell from File system ".

· Softkbd will be displayed for date and time only when selected with mouse. Softkbd can be escaped by clicking outside of the mouse.

· Softkbd will be displayed only when selected with mouse.

· Mouse and SoftKbd does not work after displaying "No option to boot to" in POST.

· SoftKbd flickers when positioned near Top/Left end of the screen display.

· Stopping all the timers for mouse drivers before existing setup

· Mouse pointer gets disappear after selecting “Launch EFI shell from File system”.

· TSE hangs while clicking on the "link training time out". Handled the invalid range reporting in numeric control properly when mouse presented.

· Help page scroll bar not moving till end.

· System hangs with latest scudriver.efi

· Mouse pointer gets disappear after selecting “Launch EFI shell from FileSystem” without any filesystem.

· Orderlists not saving the correct value for next reboot

· If logo.ffs not present in TSE then BGRT table not formed for badging images

· Accepts invalid string for string control, mismatch in string length

· Setup Crash when iSCSI is loaded

· System execption error if print string +"*" in Japanese & French

· BIOS gets stuck in infinite loop On enabling TSE_LOAD_OPTION_HIDDEN token,

In first boot incorrect devices is disabled in Setup & BBS table but in second boot the correct device is disabled in both places.

· System hangs when there is no valid boot option to boot - EIP71223.

· Setup page Menu tab gets selected even when the click is below the menu separator line

· In Date and Time item Press Shift+Tab key can't move previous field

· Build fails when SETUP_BBS_POPUP_ENABLE is enabled and SETUP_ALT_ENTRY_ENABLE is disabled.

· Keyattribute support doesn't work in AMITSE Keymon support

· POST Logo 1024x768 not displayed properly

· English strings appears intermediately when Chinese is a current language

· Default bootorder is not loading for loading defautls

· Pressing esc from main menu is not showing the exit msgbox

· In serial redirection set to 9600bps, the BBS Popup menu goes away as soon as it appears.

· Password window hangs while pressing ESC.

· Advance page disappears when offline pages are updated dynamically.

· On Pressing ESC, the token SETUP_GO_TO_EXIT_PAGE_ON_EXIT_KEY key doesn’t work in UEFI2.1

· Setup: Boot Option Priority list items truncated, until you move within the tab.

· PCIe adapters incompatible to AMI setup engine

4.6.2_TSE_2_14_1219

New Features:

· Support for software created boot entry for USB.

· Boot manager algorithm for driver health protocol.

· Name value support.

· BGRT support for version 1.2

· Non removable media boot.

· Hot key boot.

· Load option hidden support.

· PNG support.

· Signed numeric value support.

· Handling mouse clicks in application level.

· Changing the quiet boot mode based on the screen resolution.

· REF2,REF3 and REF4 and default 2 support.

· Disabling BIOS signon message.

· Added BOOT_FLOW_CONDITION_PCI_OUT_OF_RESOURCE boot flow entry.

· Updating string token value dynamically for Title Bar and Copyright messages

· Silently Loading the Defaults including Boot Order Defaults.

General Bug Fixes:

· Fix to show the dynamic pages properly.

· Fix to not show the "Save & reset" twice.

· Fix to edit the time field when using new time format.

· Fix to hide the main Page when pressing F2 to enter setup.

· Fix to not miss the first password get status.

4.6.2_TSE_2_13_1213

New Features:

· UEFI 2.3 Support

Ø FormBrowser extended actions support

Ø Support the different default stores in UEFI 2.1 specification other than Standard and Manufacturing.

Ø Support for EFI_IFR_LOCKED opcode

Ø Support for EFI_IFR_RESET_BUTTON opcode

Ø Support for EFI_IFR_NO_SUBMIT_IF opcode

Ø Support for EFI_IFR_DEFAULT opcode

Ø Support for EFI_IFR_VERSION opcode

· Support to Move the Dynamic IFR Pages under subpages.

· Mouse support to select the system device entries during "Add boot option" in file browser support.

· Supported different style modules which includes EzportPlus and Legacy Styles Modules.

· Support to display Multiple GIFs and display other image format when Active animated Gif is displaying

· Support to hide the disabled device in boot override menu and the boot popup menu

· Hooks for Softkeyboard/Touch Screen Support.

· Support to work with new mouse driver (Label : 4.6.0-MOUSE_SUPPORT-006).

General Bug Fixes:

· Fix to properly suppress the interactive controls.

· Fix to show the title string properly

· Fix to update the defaults properly in the UEFI 2.0 version when Defaults loaded from HII.

· Fix to update the Interactive One of Control properly in UEFI 2.0.

· Fix to repeat animating the gif logo until the boottimeout.

· Fix to exit the PostMenu loop properly after the PostMenu exit from callback.

· Fix to redrawing the Post menu after the callback function gets executed

· Fix to not highlight the separator in a Post menu.

· Fix for proper working of BBS popup menu functionality if a device is added after a boot and then resetting the system.

· Fix for to avoid considering Esc, Caps, Num and Scroll Lock keys as selection key in post menu.

· Fix to remove the invalid strings appears for the network devices when GROUP_BOOT_OPTIONS_BY_TAG token is enabled.

· Fix to show the help frame properly if the location are customized.

· Fix the build error when the project is build without Main.vfr.

4.6.2_TSE_2_11_1210

New Features:

· Support for the Add boot option related controls to select the input using file browser.

· Added a new interface GetAttribute in AMI POST manager protocol and updating the DisplayPostMessageEx interface.

· Fixed Limits for TSE Controls, Pages and Variable etc from HPK tool.

· Support to build AMITSE without NVRAM module support.

· Support to configure Post Menu programmatically, for the requested items (Exit Keys, Font Colors and Background Colors).

· Support for UEFI 2.2 requirements related to Calling Formcallback with EFI_BROWSER_ACTION_CHANGING and EFI_BROWSER_ACTION_CHANGED action.

· Tokenized the Max Drive (MAX_DRIVE_NAME) Macro as TSE_MAX_DRIVE_NAME.

· Support to create Logo Support information Table

· Warning message for Variable Size mismatch is not shown correctly. Setup data was updated to hold Max variable size supported. Before that fix Warning was shown for non matching case.

· To support the Differ Default Stores in UEFI 2.1 Specifications other than Standard and Manufacturing.

· Support to Override the Setup.ini path.

· Enabled AMIKeyCode protocol support by Default. Needs TSE sources to turn off this protocol.

General Bug Fixes:

· Fix to show BIOS gui scroll bar indicate that there are more options available on the Advanced | CPU Configuration page.

· Fix to handle PostMangarProtocol Interfaces right if GOP is stopped and started as it is initially installed.

· Resolved the issue of system hangs on CP06 when go to SETUP if updated core to 4641 and added TSE source and X64 = 0.

· Resolved Shift key combinations to work properly.

· Fix to show Invalid Password Error message in POST properly, If the SETUP_PASSWORD_LENGTH Changed to smaller then while entering Password in POST.

· Fix to screen corruption issue with Post Manager's DisplayMsgBox displays When the French or Japanese languages are selected.

· Fix to the issue when setting both Date & Time controls of setup menu do not display gray-out color when the controls are in the gray-out state.

· Fix to the issue PostManagerDisplayMenu does not dynamically update Menu Title on language change

· Fix to the issues with grayingout the BBS priorities is not working and for UEFI 2.0 only supporess the first one.

· Fix to the issue while editing Date and Time control pressing Pageup/PageDown/Home keys causes to leave Date&Time in the Edit state but changes focus.

· Fix to the issue if the String length is different in different languages, Changing language causes TSE multiline function to not work correctly.

· Fix to Memory Leaks in Language reading functions.

· Fix to the issues with ISCSI Pages.

· Fix to the issue when some user action on PCIx with UEFI Hii Pages causes Setup screen pages and menu disappeared.

· Fixed the typo errors in AMITSE module.

· [TAG] EIP47274

· [Category] BUG FIX

· [Symptom] UefiHPKTOOL report error code '0x80000007'.

· [RootCause] reporting error because of a memory corruption

· [Solution] fixed the issue with memory allocation

· [Files] uefihpktool.exe

4.6.2_TSE_2_10_1208

New Features:

· Support to allow POST Screen scrolling for a defined region of the screen

· Support to add OEM multiple header files to TSE 2.x.

· Support to load defaults from NVRAM Defaults.

· Support to preserve the order of disabled BBS boot devices.

· Extended Message Box support via Post Manager interface

· Post menu support via Post Manager interface

· BBSPopup using Post Menu interface

· Control Mapping with gTseControlMap Table. Makes the Controls Customized/Added without modifying TSE Lite Sources

· Progress Box support via Post Manager interface

· Dynamic Parsing of HII. To support showing pages updated via Driver callback.

· ProcessProceedtoBootNow hook added.

· Support to add multiple OEM Key Hook functions in the Post screen

· Date/Time control Improvement to support TSE 2.01 spec Completely

· Sign ON Message Support in POST Screen.

· TSE as Setup Browser driver Support

· TSE Building support with out CSM module in the project

· BBSGetNonStandardGroupType Board module Hook function added to support latest BDS customization to create non-standard group type

· SETUP_PRINT_ENTER_SETUP_MSG Token to Control the Setup Entry String display

· Support to override HDD security calls. They made as board module hooks

· TSE_DEVICE_PATH_NAME support for all the device BBS Device types and support for EFI boot options also

· Support to show updated post menu string from post menu callback

· New hook ProcessUIInitHook added to call before.

· Support to work TSE and FASTBOOT together. Need FastBoot Module 4.6.4.0_Fast_Boot_09 or Above.

· Support from HPK tool to use default value instead of 0 if Manufacturing flag is not set for a setup question

· Alternate setup style support

· Support to work with customized Groups of BBS Devices with TSE_CONTINUE_BOOT_NOW_ON_FAIL.

· Support for controlling Storing Disabled BBS device's Device path in NVRAM via TSE_SAVE_DISABLED_BBS_DEVICEPATH Sdl token.

· [TAG] EIP35562

· [Category] IMPROVMENTS

· [Description] Support to create capital boot variables names.

· [Solution] SDL token TSE_CAPITAL_BOOT_OPTION provides that support.

· [Files] AmiTSE.SDL ,Boot.h , CommonHelper.c, Callback.c , AddBootOption.c

General Bug Fixes:

· Fix to make TSE 2.0x Binary module to work with older Cores

· Fix to not to Free the Logo ImageData multiple times.

· Fix to Support more then 256 pages.

· Fix for making sure to make the Variable to NULL after it is Freed up.

· Fix for suppressif used with grayout condition. Before this fix some condition was broken in UEFI 2.0

· Fix to the Menu title issue, in case of the string length is more than the screen width.

· Fix to included the OEM Header files for Exit page options

· Screen corruption happens when we use mouse to select different Menu in Setup

· Fix issues with "SETUP_PASSWORD_NON_CASE_SENSITIVE" SDL token

· Resolved the build issues with SETUP_FORM_BROWSER_SUPPORT

· Filtering Password Characters support

· Fix for the issues with GetCurPos()

· Fix the screen corrupt issue if boot from setup fails

· Fix issues with PreSystemResetHookHook. TSE want not calling the right hook function.

· Fix PostManagerDisplayProgress issues related to updating the message.

· Fix to return the right error status from PostManagerDisplayMenu

· Fix issue with Post popup menu with Hidden attribute.

· Fix build issues with because of some Non english unicode characters found in Tse sources

· Fix the issues with help frame scrolling

· Fix for Add password install status string in UEFI 2.1 hang up

· Fix to boot with TSE_PRESERVE_DISABLED_BBS_DEVICE_ORDER when first Boot option is disabled.

· Fix for Crash issue with UEFI 2.0 Runtime Parsing.

· [TAG] EIP36092

· [Category] BUG FIX

· [Symptom] UEFI 2.1 Error logging page hangs. Fix made in UEFI 2.1 Module

· [RootCause] --

· [Solution] Fixed in below file.

· [Files] Uefi21wrapper.c

· [TAG] EIP38608 and 39117

· [Category] BUG FIX

· [Symptom] Build fail at Hpktool.bat

· [RootCause] --

· [Solution] Fix made in hpktool.exe

· [Files] HpkTool.exe

· [TAG] EIP38197

· [Category] BUG FIX

· [Symptom] There is an input password error when password support Scan Code. Password with Scancode with failing for 9 and = keys

· [RootCause] Issue with wrapping the string in case of password.

· [Solution] skipped wrapping the string in case of popup password.

· [Files] PopupEdit.c

· [TAG] EIP39570 and EIP38555

· [Category] BUG FIX

· [Symptom] Setup menu can fit into one page even with enough space

· [RootCause] issue with handling the setup menu width

· [Solution] Utilize the space available in the menu bar to fill the titles

· [Files] Menu.c

4.6.2_TSE_2_01_1204

New Features:

· UEFI 2.1 Support. need Core version 4.6.4.0

· EIP-24971: TSE features need to be controlled from TSE binary.

· EIP-25075/24971: Hii functions moving from binary to UEFI module

· EIP-25288: To support Terminal host with high resolution.

· EIP-25416: Support have 1/10 sec Timeout (SETUP_TIMEOUT_IN_TENTHOFSEC)

· EIP-28005: A new interface PostManagerSetAttribute added in AMI_POST_MANAGER_PROTOCOL

· EIP-27161/29095: Added support for reserved boot options and conditions to not allow empty boot options

· EIP-28501: Updated for Keyboard scancode as password. Added a new Token SETUP_STORE_KEYCODE_PASSWORD to support the EFI key or Scan code as password

· Support for FAST Boot. To not depend on Console control and Conout. Stop handling the notification if we entered

· Image Support can control by binary module.

· Load setup defaults made as hook function.

· Hook function PreResetSystemHook added for any customizations before system reset.

· TSE Version numbers are SDL tokens

· Added support for handling string characters --- \n, \r in Post message

· Navigation help for mouse added

· OEM Special controls support

· Configurable mouse actions

· Support to Add strings from board or other modules to TSE.

· Support to override TSE strings (need Aptio 4.6.4.0 and Tools Label "4.5.5_Tools_30")

· TSE doesn't depend on default Board/OEM modules. If the Porting done to a platform from this version of TSE. It should reusable with later labels of TSE without any changes.

· Hpktool.exe v2.01.1024 and UefiHpktool.exe v2.11.1025 added.

· Ability to add NVRAM Defaults using Hpktool

· Ability to set the Default language using Hpktool

General Bug Fixes:

· Logo security updated

· EIP-26473: To support uppercase Hex numbers

· EIP-21807: Multi language issue

· EIP-22305: Fix for improper JPEG Image size calculation logic

· EIP-23354: Password encoding bug fix

· EIP-24980: Fix to properly display right area text

· EIP-24991: MultiLanguage Screen corruption issue.

· EIP-25092: Fix to Use the HiiChangeString () to Add the string for morethen one langs.

· EIP-25987: Load Optimized Defaults (F3) hangs in an empty page. Fixed by checking whether the frame has any controls before performing operations on a control.

· EIP-26029: Fix: UefiCreateOneOfWithOptionsTemplate() does not always return NULL when EfiLibAllocateZeroPool() returns NULL

· EIP-26893: string truncation issues in case of DisplayPostMessage() called multiple times

· EIP-28007: Flash all the screen in case of post message printed in the Quiteboot by using Set cur position

· EIP-28247: Fix for grayout color menu string not being grayed out.

· EIP-28551: Fixed TSE 2.0 Build error related to SETUP_STORE_EFI_KEY_PASSWORD and TSE_USE_AMI_EFI_KEYCODE_PROTOCOL

· EIP-28577: Fix to avoid "Checker: SIGN_EXTENSION"

· EIP-30111: fixed the issue to update the help if STYLE_PAGE_FIRSTITEM_FOCUS token enabled.

· EIP-31606: Fix for hanging issue in case of no active controls in a frame

· EIP-32242: Modified DrawBorder fn to check if Width or Height is zero

· EIP-32318: Fix for the crash issue when the page has many controls.

· EIP- 32350/32445: To fix the Add/Delete Boot option issues with TSE 2.0.

· EIP-32501: Fix to handle the Conditional control Focusing , in the Subform

· EIP-33804: Issue iSCSI initiator name is not saved.

· EIP-33837: Setup appearance corrupted if additional subtitles added Fix - Prevent memo draw if suppressed condition

· EIP-34119: Fix to solve issues, if the boot option name is set with max number of characters allowed.

· EIP-34679: Typo error fix

· To fix issue with BBS popup when more than 20 boot options are present

· To fix the Screen corruption if mouse pointer is on the popup.

· Legacy boot option can't be deleted.

· EIP 35522: Fix for Interactive control in TSE

· EIP 35517: Fix for UefiHpktool to work correctly for Interactive text/action control.

· Build issues with EDK module support resolved.

· SendForm interface in FormBrowser and FormBrowser2 protocol validates the HiiHandles passed.

4.6.2_TSE_2_00_1201

New Features:

· Hot Keys as Elinks

· Exit Page Callbacks as Elinks

· Control Keys as Elinks

· Customizable Page Order

· Advanced String Customization

· Board Module for Board specific customizations

· OEM Module

· Password Customization

· OEM Strings Customization

· Customizable Style Module

· UEFI2.0

· Ability to build with/without EDK.

General Bug Fixes:

· This is the first TSE2.0 product release

© American Megatrends Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • AMITSE SDL TOKENS
  • AMITSE.mak
  • Aptio Modules
  • boot.h
  • bootflow.c
  • bootflow.h
  • CommonHelper.c
  • commonoem.c
  • commonoem.h
  • FakeTokens.c
  • HiiLib.h
  • HookAnchor.h
  • HookList.c
  • Keymon.c
  • Keymon.h
  • LogoLib.h
  • mem.h
  • PwdLib.h
  • setupdata.h
  • setupdbg.h
  • TSE Help Module
  • TseCommon.h
  • TseDrvHealth.h
  • TseElinks.h
  • variable.h
Built on 16:15:54 10/01/14


AMITSE SDL TOKENS

The following data structures are used in the file: AMITSE SDL TOKENS.

Variable | Description
AMITSE_HIDE_ROOT_PAGE | 1 -> Hides the root page & 0 -> The support is disabled
AMITSE_ROOT_PAGE_ORDER_SUPPORT | 1 => Enable the Root Page Order support for TSE. 0 => Disable the Root Page Order support for TSE.
AMITSE_SUBPAGE_AS_ROOT_PAGE_LIST_SUPPORT | 1 -> Shows subpages as root page & 0 -> Shows subpages as is.
AMITSE_SUPPORT | Main switch to enable AMITSE support in Project
AMITSE_SUPPRESS_DYNAMIC_FORMSET | 0 is Default. 1 -> To suppress dynamic formset mentioned in elink AMITSE_SUPPRESS_DYNAMIC_FORMSET_LIST and do not show in setup. 0 -> Display dynamic page and not to suppress dynamic page.
AMITSE_VERSION | TSE Version for displaying in the init screen. If no need of version to display then use empty string, if changing the format specifiers then care should be taken in source.
BIOS_SIGNON_MESSAGE2 | Use this SDL token to update the BIOS Sign On Message 2.
BOOT_FLOW_NORMAL_INFINITE_LOOP | 1 = TSE tries to loads all the boot options and all fails checks for SETUP_ENTRY keys if found then enters the setup else TSE tries to load all the boot options once again and continues the mentioned procedure infinitely and 0 = Neglects the SETUP_ENTRY key check, always tries to load all the boot options infinitely.
BOOT_FLOW_NORMAL_LAUNCH_DEFAULT_BOOTIMAGE | Support for UEFI specification v 2.3.1 section 3.4.1.1 and 3.4.1.2 to load the default boot image (efi\boot\boot####.efi) from any of the available file system if no boot option found. 1 = Enabling default image boot and 0 = Disabling default image boot.
BOOT_OVERRIDE_BOOTNEXT_VARIABLE_FEATURE | DISABLE is default.1=> To show menu for BootOverride options to modifiy BootNext variable when BootNext variable is supported by project. 0=> Not to show menu for BootOverride options.
CONTRIB_BGRT_TABLE_TO_ACPI | Set to Contribute the BGRT table to ACPI.
DEFAULT_SETUP_PWD_AT_FIRSTBOOT_ONLY | 1 is default. 1 => Sets the TSE_ADMIN_PASSWORD and TSE_USER_PASSWORD at first boot only. 0 => Sets TSE_ADMIN_PASSWORD and TSE_USER_PASSWORD in TSE defaults, on load defaults these data will be loaded.
DISABLE_ESC_IN_BBS | 0 is DEFAULT.1 => To disable ESC behaviour in BBS menu and retain in BBS menu. 0 => To enable ESC behaviour in BBS menu.
DRAW_POST_LOGO_AT_0POS | Displays the Post logo at top(0,0) graphics position. Disable by default make it 1 to avail this feature.
DRIVER_HEALTH_SUPPORT | Enabling Driver health support in TSE and 0 = Disabling Driver health support in TSE.
EDK_1_05_RETRIEVE_DATA | Modified code to return BrowserCallback String according to either EDK browser or spec.
EXIT_PAGE_CLASS | Exit Page Formset class.
EXIT_PAGE_FORM_ID | Exit Page ID.
EXIT_PAGE_GUID | GUID used to identify exit page.
EXIT_PAGE_SUB_CLASS | Exit Page Formset Subclass.
FLUSH_KEYS_AFTER_READ | Disable to flush the key buffer.
HONOR_DRVHLTH_CONFIGREQD_ON_BOOTFAIL | 1 => If driver need to be configured during the device boot then this token should be enabled to display the form produced from dirver health protocol & 0 => Disables the form produced by the driver health protocol.
INI_FILE_PATH | To set path of the setup ini file which used as input to HPK tool .
MAX_MSGBOX_WIDTH | Set the value to change the message box dispaly width.
MAX_POST_GC_MODE | Port this SDL to select the Maximum Support Graphical module. Should be one of (GC_MODEx SDL tokens). Based on this token logo capability table created.
MINISETUP_MOUSE_SUPPORT | Mouse suport.
MSGBOX_PROGRESS_BAR_SEGMENT_COUNT | Mod of 100 with this number should be 0, for example (100 % 20 = 0).
NO_VARSTORE_SUPPORT | Enables and disables no var store support. This needs modification of VFRs. Need customization of board module.
OEMLogo_FILE_PATH | Path of OEMLogo to show in Postscreen. Default path is TSE_BIN.
OLD_MOUSE_DRIVER_SUPPORT | Old Mouse Driver Mouse suport. Need to be on if 4.6.0-MOUSE_SUPPORT-004 or older is used.
OSIndication_SUPPORT | Main token to disable or enable the OSIndication Support. If disable then OSIndication module can be used.
OVERRIDE_BBSBuildName | set to 1 if oem wants to override the BBSBuildName function from Board module.
OVERRIDE_BBSGetNonStandardGroupType | Set to 1 if oem wants to override the BBSGetNonStandardGroupType function from Board module.
OVERRIDE_BbsItkBoot | set to 1 if oem wants to override the BbsItkBoot function from Board module.
OVERRIDE_CheckAdvShiftState | set to 1 if OEM wants to override the CheckAdvShiftState function from Board module.
OVERRIDE_CheckIsAllowedPasswordChar | set to 1 if oem wants to override the CheckIsAllowedPasswordChar function from Board module.
OVERRIDE_CleanUpOEMLogo | set to 1 if oem wants to override the CleanUpOEMLogo function from Board module.
OVERRIDE_ConvertOEMFormatToUgaBlt | set to 1 if oem wants to override the ConvertOEMFormatToUgaBlt function from Board module.
OVERRIDE_CsmBBSBootOptionName | 0 is Default. Set to 1 if OEM wants to override the CsmBBSBootOptionName function from Board module.
OVERRIDE_DoOEMLogoAnimate | set to 1 if oem wants to override the DoOEMLogoAnimate function from Board module.
OVERRIDE_DriverHealthSystemReset | set to 1 if oem wants to override the DriverHealthSystemReset function from Board module.
OVERRIDE_FindVarFromITKQuestionId | set to 1 if oem wants to override the FindVarFromITKQuestionId function from Board module.
OVERRIDE_FixMergePagesExtraHook | set to 1 if OEM wants to override the FixMergePagesExtraHook function from Board module.
OVERRIDE_FramePasswordAdvancedCallback | set to 1 if OEM wants to override the FramePasswordAdvancedCallback function from Board module.
OVERRIDE_FramePwdCallbackIdePasswordUpdate | Set to 1 if oem wants to override the FramePwdCallbackIdePasswordUpdate function from Board module.
OVERRIDE_GetAMITSEVariable | set to 1 if oem wants to override the GetAMITSEVariable function from Board module.
OVERRIDE_GetBootTimeOut | set to 1 if oem wants to override the GetBootTimeOut function from Board module.
OVERRIDE_GetGraphicsBitMapFromFV | set to 1 if OEM wants to override the GetGraphicsBitMapFromFV function from Board module.
OVERRIDE_GetMessageboxColorHook | Set to 1 if oem wants to override the GetMessageboxColorHook function from Board module.
OVERRIDE_GetUefiSpecVersion | set to 1 if OEM wants to override the GetUEFISpecVersion function from Board module.
OVERRIDE_GOPSetScreenResolutionHook | Set to 1 if oem wants to override the GOPSetScreenResolutionHook function from Board module.
OVERRIDE_IsOEMLogoType | set to 1 if oem wants to override the IsOEMLogoType function from Board module.
OVERRIDE_ItkSupport | set to 1 if oem wants to override the ItkSupport function from Board module.
OVERRIDE_LaunchHotKeyBootOption | set to 1 if OEM wants to override the LaunchHotKeyBootOption function from Board module.
OVERRIDE_LaunchSecBootPathFromEnabledDevs | set to 1 if OEM wants to override the LaunchSecBootPathFromEnabledDevs function from Board module.
OVERRIDE_LaunchSecondaryBootPath | set to 1 if OEM wants to override the LaunchSecondaryBootPath function from Board module.
OVERRIDE_LegacyBootFailHook | set to 1 if OEM wants to override the OVERRIDE_LegacyBootFailHook function from Board module.
OVERRIDE_MainSetupLoopHook | set to 1 if OEM wants to override the MainSetupLoopHook function from Board module.
OVERRIDE_MainSetupLoopInitHook | set to 1 if OEM wants to override the MainSetupLoopInitHook function from Board module.
OVERRIDE_NoVarStoreSupport | set to 1 if oem wants to override the NoVarStoreSupport function from Board module.
OVERRIDE_NoVarStoreUpdateSystemAccess | set to 1 if oem wants to override the NoVarStoreUpdateSystemAccess function from Board module.
OVERRIDE_OEMCheckControlCondition | set to 1 if OEM wants to override the OemCheckControlCondition function from Board module.
OVERRIDE_OEMSpecialGetControlCount | set to 1 if oem wants to override the OEMSpecialGetControlCount function from Board module.
OVERRIDE_OEMSpecialGotoFixup | Modified code to return BrowserCallback String according to either EDK browser or spec.
OVERRIDE_OEMSpecialGotoSelect | set to 1 if oem wants to override the OEMSpecialGotoSelect function from Board module.
OVERRIDE_OEMSpecialOneOfFixup | set to 1 if oem wants to override the OEMSpecialOneOfFixup function from Board module.
OVERRIDE_OEMSpecialUpdateOneOf | set to 1 if oem wants to override the OEMSpecialGotoFixup function from Board module.
OVERRIDE_OsUpdateCapsuleWrap | set to 1 if OEM wants to override the OsUpdateCapsuleWrap function from Board module.
OVERRIDE_PageRemoveHook | set to 1 if OEM wants to override the PageRemoveHook function from Board module.
OVERRIDE_PasswordAuthenticate | set to 1 if oem wants to override the PasswordAuthenticate function from Board module.
OVERRIDE_PasswordCheckInstalled | set to 1 if oem wants to override the PasswordCheckInstalled function from Board module.
OVERRIDE_PasswordCommitChanges | set to 1 if oem wants to override the PasswordCommitChanges function from Board module.
OVERRIDE_PasswordUpdate | set to 1 if oem wants to override the PasswordUpdate function from Board module.
OVERRIDE_PopupPasswordAuthenticate | set to 1 if oem wants to override the PopupPasswordAuthenticate function from Board module.
OVERRIDE_PopupPasswordCheckInstalled | set to 1 if oem wants to override the PopupPasswordCheckInstalled function from Board module.
OVERRIDE_PopupPasswordFormCallback | set to 1 if oem wants to override the PopupPasswordFormCallback function from Board module.
OVERRIDE_PopupPwdAuthenticateIDEPwd | Set to 1 if oem wants to override the PopupPwdAuthenticateIDEPwd function from Board module.
OVERRIDE_PopupPwdHandleActionOverRide | set to 1 if oem wants to override the PopupPwdHandleActionOverRide function from Board module.
OVERRIDE_PopupPwdUpdateIDEPwd | Set to 1 if oem wants to override the PopupPwdUpdateIDEPwd function from Board module.
OVERRIDE_ProcessBrowserActionRequestHook | set to 1 if OEM wants to override the ProcessBrowserActionRequestHook function from Board module.
OVERRIDE_ProcessPackNotificationHook | set to 1 if OEM wants to override the ProcessPackNotification function from Board module.
OVERRIDE_SetSystemAccessValueItk | set to 1 if oem wants to override the SetSystemAccessValueItk function from Board module.
OVERRIDE_TSEGetactualScreentop | set to 1 if OEM wants to override the TSEGetactualScreentop function from Board module.
OVERRIDE_TSEGetCoordinates | set to 1 if OEM wants to override the TSEGetCoordinates function from Board module.
OVERRIDE_TSEIDEPasswordAuthenticate | Set to 1 if oem wants to override the TSEIDEPasswordAuthenticate function from Board module.
OVERRIDE_TSEIDEPasswordCheck | set to 1 if oem wants to override the TSEIDEPasswordCheck function from Board module.
OVERRIDE_TSEIDEPasswordFreezeDevices | set to 1 if oem wants to override the TSEIDEPasswordFreezeDevices function from Board module.
OVERRIDE_TSEIDEPasswordGetDataPtr | set to 1 if oem wants to override the TSEIDEPasswordGetDataPtr function from Board module.
OVERRIDE_TSEIDEPasswordGetLocked | set to 1 if oem wants to override the TSEIDEPasswordGetLocked function from Board module.
OVERRIDE_TSEIDEPasswordGetName | Set to 1 if oem wants to override the TSEIDEPasswordGetName function from Board module.
OVERRIDE_TSEIDEPasswordUpdate | set to 1 if oem wants to override the TSEIDEPasswordUpdate function from Board module.
OVERRIDE_TSEIDEUpdateConfig | set to 1 if oem wants to override the TSEIDEUpdateConfig function from Board module.
OVERRIDE_TSEIsMouseClickedonSoftkbd | set to 1 if OEM wants to override the TSEIsMouseClickedonSoftkbd function from Board module.
OVERRIDE_TseLaunchFileSystem | set to 1 if OEM wants to override the TseLaunchFileSystem function from Board module.
OVERRIDE_TSEMouseDestoryHook | set to 1 if oem/Modules wants to override the TSEMouseDestoryHook function from Board module.
OVERRIDE_TSEMouseDestroy | set to 1 if OEM wants to override the TSEMouseDestroy function from Board module.
OVERRIDE_TSEMouseFreeze | set to 1 if OEM wants to override the TSEMouseFreeze function from Board module.
OVERRIDE_TSEMouseIgnoreMouseActionHook | set to 1 if oem wants to override the TSEMouseIgnoreMouseActionHook function from Board module.
OVERRIDE_TSEMouseInit | set to 1 if OEM wants to override the TSEMouseInit function from Board module.
OVERRIDE_TSEMouseInitHook | set to 1 if oem/Modules wants to override the TSEMouseInitHook function from Board module.
OVERRIDE_TSEMouseReadInfo | set to 1 if OEM wants to override the TSEMouseReadInfo function from Board module.
OVERRIDE_TSEMouseRefresh | set to 1 if OEM wants to override the TSEMouseRefresh function from Board module.
OVERRIDE_TSEMouseRefreshHook | set to 1 if oem/Modules wants to override the TSEMouseRefreshHook function from Board module.
OVERRIDE_TSEMouseStart | set to 1 if OEM wants to override the TSEMouseStart function from Board module.
OVERRIDE_TSEMouseStartHook | set to 1 if oem wants to override the TSEMouseStartHook function from Board module.
OVERRIDE_TSEMouseStop | set to 1 if OEM wants to override the TSEMouseStop function from Board module.
OVERRIDE_TSEMouseStopHook | Modified code to return BrowserCallback String according to either EDK browser or spec.
OVERRIDE_TSENumericSoftKbdExit | set to 1 if OEM wants to override the TSENumericSoftKbdExit function from Board module.
OVERRIDE_TSENumericSoftKbdInit | set to 1 if OEM wants to override the TSENumericSoftKbdInit function from Board module.
OVERRIDE_TSESetHDDPassword | set to 1 if oem wants to override the TSESetHDDPassword function from Board module.
OVERRIDE_TSEStringReadLoopEntryHook | set to 1 if oem wants to override the TSEStringReadLoopEntryHook function from Board module.
OVERRIDE_TSEStringReadLoopExitHook | set to 1 if oem wants to override the TSEStringReadLoopExitHook function from Board module.
OVERRIDE_TSEUnlockHDD | set to 1 if oem wants to override the TSEUnlockHDD function from Board module.
OVERRIDE_UefiBootFailHook | set to 1 if OEM wants to override the OVERRIDE_UefiBootFailHook function from Board module.
OVERRIDE_UIUpdateCallbackHook | set to 1 if OEM wants to override the UIUpdateCallback function from Board module.
OVERRIDE_UpdateNumericDisplayString | set to 1 if OEM wants to override the UpdateNumericDisplayString function from Board module.
OVERRIDE_VarBuildItkDefaults | set to 1 if oem wants to override the VarBuildItkDefaults function from Board module.
PASSWORD_WITH_SPECIAL_CHAR_SUPPORT | 0 => Only alphanumeric characters are support in the Password 1 => Also supports printable special characters.
POPUP_MENU_ENTRY_LEGACY_CODE | Set legacy scan code for popup menu entry.
POPUP_MENU_ENTRY_SCAN | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol
POPUP_MENU_ENTRY_SHIFT_STATE | Set to one of the defined constants from AMI_KEY_CODE_PROTOCOL.
POPUP_MENU_ENTRY_UNICODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'
POPUP_MENU_HIDE_DISABLE_BOOT_OPTIONS | 1 => Hide the disabled boot options in BBS POPup menu. 0 => Shows all boot options in BBS POPup menu.
POPUP_MENU_SHOW_ALL_BBS_DEVICES | 1 => Shows all BBS devices in BBS POPup menu. 0 => Shows only the first device of a BBS type in BBS POPUP menu.
PROGRESSBAR_BACKGROUNDCOLOR | Set the value of progressbar bgcolor in EFI_UGA_PIXEL format
PROGRESSBAR_BORDERCOLOR | Set the value of progressbar border color in EFI_UGA_PIXEL format
PROGRESSBAR_FILLCOLOR | Set the value of progressbar fill color in EFI_UGA_PIXEL format
RESERVED_ADD_DEL_BOOT_OPTION_NAME | Reserved names that are not allowed to use for add or delete boot options.
ROMHOLE_BLOCK_SIZE | Size of Block used for ROMHOLE.
ROMHOLE_NUMBER_OF_BLOCK | Number of Block used for ROMHOLE.
RT_ACCESS_SUPPORT_IN_HPKTOOL | 0 is default. 0=> Not to set RT flag for variables. 1=> enable to add RT attribute for variables, uefisetup.ini attributes persists.
SECONDARY_BOOT_FROM_ENABLED_DEVICES | 0-> Loads \EFI\BOOT\BOOT{machine type short-name}.EFI from any of the devices & 1-> Loads the default image only from enabled devices.
SERIAL_DEBUG | A switch to print TSE Debug messages over Serial Port.
SETUP_ALT_ENTRY_ENABLE | Enable or disable the SETUP_ALT_ENTRY
SETUP_ALT_ENTRY_LEGACY_CODE | Set legacy code for Alternate entry key.
SETUP_ALT_ENTRY_SCAN | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol. Remember to check STR_DEL_ENTER_SETUP string in MiniSetupStr.uni.
SETUP_ALT_ENTRY_SHIFT_STATE | Set to one of the defined constants from AMI_KEY_CODE_PROTOCOL.
SETUP_ALT_ENTRY_UNICODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'. Remember to check STR_DEL_ENTER_SETUP string in MiniSetupStr.uni.
SETUP_BBS_POPUP_ENABLE | Enable or disable the SETUP_BBS_POPUP_ENABLE. CAUTION This works only if complete TSE sources are present.
SETUP_BMP_LOGO_SUPPORT | BMP Logo support in Setup
SETUP_DEFAULT_TIMEOUT | Default timeout value before system boots
SETUP_DELAY_LOGO_TILL_INPUT | 1 => delays logo display untill SIMPLE TEXT IN protocol is available. 0 => logo is displayed as soon as UGA DRAW, CONSOLE SPLITTER & SIMPLE TEXT OUT IS AVAILABLE (Will increase code size).
SETUP_DELAY_POST_TILL_GOP | ENABLE is default.Wait for GOP.
SETUP_DISPLAY_SUBMENU_PAGETITLE | Displays page title of submenu pages in the menu tab.
SETUP_ENTRY_LEGACY_CODE | Set legacy scan code for entry key.
SETUP_ENTRY_SCAN | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol. Remember to check STR_DEL_ENTER_SETUP string in MiniSetupStr.uni.
SETUP_ENTRY_SHIFT_STATE | Set to one of the defined constants from AMI_KEY_CODE_PROTOCOL.
SETUP_ENTRY_UNICODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'. Remember to check STR_DEL_ENTER_SETUP string in MiniSetupStr.uni.
SETUP_GIF_LOGO_SUPPORT | GIF Logo support in Setup
SETUP_GO_TO_EXIT_PAGE_ON_EXIT_KEY | DISABLE is default.Set to ENABLE to goto Exit page on pressing ESC key. If Enabled, on Pressing ESC key, by default it will go to Exit page.If user needs to change the page then user has provide proper FormID in the dependency tokens.
SETUP_GRAYOUT_READONLY_CONTROL | Diaplay readonly controls as grayout.
SETUP_GROUP_DYNAMIC_PAGES | Allows Dynamic IFR Pages to be relocated under subpages. Make sure to have the VFR changes to show the dynamic pages.
SETUP_HIDE_BIOS_SIGNON_MESSAGE2 | 1 => Hides the BIOS signon message. 0 => Shows the BIOS sign on message.
SETUP_HIDE_DISABLE_BOOT_OPTIONS | 1 => Hide the disabled boot options in boot override menu. 0 => Shows all boot options boot override menu.
SETUP_IDE_SECURITY_SUPPORT | To support IDE Security.
SETUP_ITK_COMPATIBILITY | Enables and disables ITK compatibility. Need customization in Board module to support ITK projects.
SETUP_JPEG_LOGO_SUPPORT | JPEG Logo support in Setup
SETUP_LINK_HISTORY_SUPPORT | Preserves navigation history of Ref linked pages. Pressing the <ESC> returns control to the previous page if the current page was linked from a REF control.
SETUP_OEM_FORMAT_LOGO_SUPPORT | OEM Specific Logo support in Setup
SETUP_OEM_KEY1_EFIKEY | Set to one of the defined EFI_KEY enumeration.
SETUP_OEM_KEY1_ENABLE | Enable or disable the SETUP_OEM_KEY1
SETUP_OEM_KEY1_LEGACY_CODE | Set legacy code for OEM key 1.
SETUP_OEM_KEY1_SCAN | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol
SETUP_OEM_KEY1_SHIFT | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
SETUP_OEM_KEY1_TOGGLE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
SETUP_OEM_KEY1_UNICODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'
SETUP_OEM_KEY2_EFIKEY | Set to one of the defined EFI_KEY enumeration.
SETUP_OEM_KEY2_ENABLE | Enable or disable the SETUP_OEM_KEY2
SETUP_OEM_KEY2_LEGACY_CODE | Set legacy code for OEM key 2.
SETUP_OEM_KEY2_SCAN | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol
SETUP_OEM_KEY2_SHIFT | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
SETUP_OEM_KEY2_TOGGLE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
SETUP_OEM_KEY2_UNICODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'
SETUP_OEM_KEY3_EFIKEY | Set to one of the defined EFI_KEY enumeration.
SETUP_OEM_KEY3_ENABLE | Enable or disable the SETUP_OEM_KEY3
SETUP_OEM_KEY3_LEGACY_CODE | Set legacy code for OEM key 3.
SETUP_OEM_KEY3_SCAN | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol
SETUP_OEM_KEY3_SHIFT | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
SETUP_OEM_KEY3_TOGGLE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
SETUP_OEM_KEY3_UNICODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'
SETUP_OEM_KEY4_EFIKEY | Set to one of the defined EFI_KEY enumeration.
SETUP_OEM_KEY4_ENABLE | Enable or disable the SETUP_OEM_KEY4
SETUP_OEM_KEY4_LEGACY_CODE | Set legacy code for OEM key 4.
SETUP_OEM_KEY4_SCAN | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol
SETUP_OEM_KEY4_SHIFT | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
SETUP_OEM_KEY4_TOGGLE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
SETUP_OEM_KEY4_UNICODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'
SETUP_ORPHAN_PAGES_AS_ROOT_PAGE | Allows Orphan IFR Pages to be relocated to root pages.
SETUP_PASSWORD_LENGTH | Default maximum password length.
SETUP_PASSWORD_NON_CASE_SENSITIVE | Allow to use of case sensitive password.
SETUP_PCX_LOGO_SUPPORT | PCX Logo support in Setup
SETUP_PNG_LOGO_SUPPORT | PNG Logo support in Setup.
SETUP_PRINT_ENTER_BBSPOPUP_MSG | Set to 1 to print the Setup BBS Popup Menu messages in Post.
SETUP_PRINT_ENTER_SETUP_MSG | Set to 1 to print the Setup Enter messages in Post
SETUP_PRINT_EVAL_MSG | Enable/Disable Evaluation message in Post screen
SETUP_ROOT_PAGE_ORDER_GUID | Setup root Page Order Guid.
SETUP_RUNTIME_IFR_PROCESSING | Processes IFR data that are added to hii at runtime. This will cause an increased FW footprint and remove AMIBCP compatibility for those new pages.
SETUP_SAVE_PSWD_TO_NVRAM | 1 => Save password to Nvram. 0 => Save password to cache.
SETUP_SHOW_ALL_BBS_DEVICES | 1 => Shows all BBS devices in boot override menu. 0 => Shows only the first device of a BBS type in override menu.
SETUP_STORE_EFI_KEY_PASSWORD | This Token becomes Obsolete after adding the Token SETUP_STORE_KEYCODE_PASSWORD. / Enables support to store EFI_KEYs as password. TSE Sources should be required to present to Enable this token.
SETUP_STORE_KEYCODE_PASSWORD | For Extened Password support, the Value can be 1 or 2. Set Value as 1 to support Efi Key as password. Set Value as 2 to support Scan Code in password. Need AMIKeyCode Protocol & TSE sources support.
SETUP_SUPPORT_ADD_BOOT_OPTION | Set to enable Add/Delete boot option.
SETUP_SUPPORT_ADD_DRIVER_OPTION | Set to enable Add/Delete Driver option.
SETUP_SUPPORT_KEY_MONITORING | Enable or Disable monitoring keys during Legacy mode.
SETUP_SUPPORT_PLATFORM_LANG_VAR | Set to enable PlatformLang and PlatformLangCode Vars.
SETUP_SUPPORT_RES_ADD_DEL_BOOT_OPTION_NAME | Not to allow Reserved Names (RESERVED_ADD_DEL_BOOT_OPTION_NAME) for new Boot Options. Reserved names defined in RESERVED_ADD_DEL_BOOT_OPTION_NAME SDL token.
SETUP_TIMEOUT_IN_TENTHOFSEC | Maks the Setup Timout value as 1/10 Sec to support fast boot. Makesure to change the Vfr and Strings if this is ON.
SETUP_TOGGLE_KEY_SCANCODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol.
SETUP_TOGGLE_KEY_UNICODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'.
SETUP_UPDATE_BOOT_ORDER_CURSOR | When the boot order is changed, the cursor moves with the selection. Else, the cursor remains in the same location as the current question.
SETUP_USE_AMI_DEFAULTS | Use AMIBCP compatible defaults instead of HII defaults
SETUP_USER_PASSWORD_POLICY | Allow to use system with Admin password set and User password NOT set (Boot Password policy)
SHELL_TEXT_MODE | Assign the GC_MODE while boot to SHELL.\0xFF = ignored, 0/1/2/.. = GC_MODE0/GC_MODE1/GC_MODE2/..
SHOW_FORMSETS_WITH_CLASSGUID | 1 is DEFAULT.1 => To display formset based on ClassGUID add formsetClassGUID in elink AMITSE_FILTER_CLASSGUID_FORMSETS(By default this elink has EFI_HII_PLATFORM_SETUP_FORMSET_GUID). 0 => To display all formset and no filter in formsets.
SINGLE_CLICK_ACTIVATION | On- Single click will be used to enter the subMenu and Select the option. OFF- Double Click will be used.
STYLE_DATE_FORMAT | Controls the Date Format. (Default 0 => mm/dd/yyyy) (1 => yyyy/dd/mm)
STYLE_HELP_AREA_SCROLLBAR | Support Scrollable Help Text.
STYLE_SHOW_DAY | Controls the display of Day in Date Format.
SUPPORT_ESRT | Enable to support ESRT.
SUPPRESS_HANDLE_FOR_VAR_CREATION | 0 is DEFAULT.0 => Includes handle comparison to create new variable cache in TSE. 1 => Won't compare handle to create new variable. The variable detail should present in AMITSE_DYNAMICPARSING_HANDLE_SUPPRESS_LIST to not compare handle.
SUPPRESS_PRINT | A switch to supress TSE Debug messages.
TSE_ADMIN_PASSWORD | Defaultly no password is given. Provide data to set as default admin password. Maximum string can be provide is based on SETUP_PASSWORD_LENGTH token. String should be atleat minimum length mentioned in vfr. If no password is given it will not set any default password. Note: specify EMPTY_DATA in value if default admin password is not required.
TSE_ANSI_ESC_CODE_SUPPORT | Tse advanced Esc colour support
TSE_APTIO_5_SUPPORT | Turn on to to build under Aptio 5.
TSE_BEST_TEXT_GOP_MODE | 0 is DEFAULT.1 => To save and restore text(100*31) and GOP(800*600) mode before using any TSE Interfaces in Post/after TSE. 0 => Not to ; handle text and GOP mode before using any TSE interfaces in Post/after TSE and use Post mode without any change.
TSE_BOOT_NOW_IN_BOOT_ORDER | Turn on to see boot override menu with in the devices listed in boot order.
TSE_BOOT_ONLY_SPLASH_LOGO_SUPPORT | Turn on the TSE to make boot only driver without UI
TSE_BOOT_TIME_OUT_AS_ZERO | 1=>Provides Boot time out value as zero 0=> Reads from the NVRAM, defaultly it is disabled.
TSE_CALLBACK_SPEC_VERSION | Version to change the callback functionality.
TSE_CAPITAL_BOOT_OPTION | This Token Stores/Creates the Boot Option numbers to Capital Hex Numbers.
TSE_CLEAR_USERPW_WITH_ADMINPW | Support to clear the User password if Admin password is empty
TSE_CONTINUE_BOOT_NOW_ON_FAIL | Turn on to continue boot to other device when selected one fails.
TSE_CSM_SUPPORT | Include CSM Support in TSE
TSE_CURSOR_SUPPORT | Token to display cursor for string, password type controls.ENABLE is default.1=>To display cursor in TSE.0=>Not to display cursor in TSE.
TSE_DBG_DISABLE_APPDESTRUCTOR | 0 => Free the TSE used memory. 1 => Won't free the TSE used memory, may be used only for debugging purposes. CAUTION: If making the token to 1 then TSE won't free the memory it used. We recommend not to make it enable..
TSE_DEBUG_MESSAGES | A switch to enable TSE Debug messages: Bit0: Uefi functions, Bit1: HiiCallbacks, Bit2: HiiNotifications, Bit3: HiiParsing.
TSE_DEFAULT_SETUP_PASSWORD_SUPPORT | 0 is default.set 1=> to Enable default setup password.
TSE_DEVICE_PATH_NAME | Turn on to be able to configure name for legacy devices.
TSE_DEVICE_PATH_UEFI_NAME | Turn on to be able to configure name for UEFI devices using Device path.
TSE_DONOT_LOAD_PASSWORD_ON_DEFAULTS | 1 => Will not load defaults for password when we press F3. 0 => Load default passowrd.
TSE_DONOT_LOAD_SYSTEM_ACCESS_FOR_USER_DEFAULT | 0 is DEFAULT.1 => To enable to not to load SystemAccess variable on pressing Restore User Default. 0=> To load SystemAccess variable on pressing Restore User Default
TSE_FOR_64BIT | Enable build support for 64 bit(x64/IA64) TSE
TSE_HASH_PASSWORD | 0 is Default. 1 => To encode the entered password using hash algorithm. 0 => Encode entered password using TSE logic.
TSE_HOOKBASE_VALUE | Base value for the HOOK defines that Allows to manage TSE HOOKs.Format 0xXXXX0000,Makeure it is not conflicts physical memory Address
TSE_IGNORE_KEY_FOR_FASTBOOT | DISABLE is default. 1=> To ignore check for key when FastBoot is enabled. 0=> Allow check for key when FastBoot is enabled.
TSE_LOAD_DEFAULTS_FROM_DEFAULTS_BUFFER | 0 => Will not load defaults from Default buffer(NVRAM.bin) on pressing F3. 1 => Will Load default from the default buffer.
TSE_LOAD_OPTION_HIDDEN | 1 => Hide LOAD_OPTION_HIDDEN Boot option. 0 => Shows all boot options.
TSE_LOAD_PASSWORD_ON_DEFAULTS | Loads the User/Admin password from Defaults.If Off, Passwords are unaffected while loading defaults
TSE_MAX_DRIVE_NAME | Set the value to dispaly number of characters for Drive name.
TSE_MULTILINE_CONTROLS | Turns on multi line controls. Currently subtitle and static text controls are supported. Default is DISABLE.
TSE_NVRAM_DEFAULTS_SUPPORT | To enable NVRAM support in TSE modules. This token requires TSE Sources support.
TSE_OEM_POSTLOGO_SUPPORT | Enable to support OEMLogo image in postscreen.
TSE_POSTSCREEN_SCROLL_AREA | {TopRow, TopCol, BottomRow, BottomCol}. Used to Configure the TSE PostScreen Scroll Area. Note Post message are still printed in whole Screen.
TSE_PRESERVE_DISABLED_BBS_DEVICE_ORDER | Prevents TSE from repositioning disabled BBS boot in the boot order.
TSE_PRN_SCRN_EVENT_SUPPORT | Turn on to generate Print screen event if TSE_PRN_SCRN_KEY_SCAN key pressed.
TSE_ROMHOLE_HEADER_GUID | One among 16-GUID used to identify ROMHOLE by AMI utilities such as AFU, BCP, and MMTool. This value should sync with TSE_ROMHOLE_MAKFILE_GUID token value.
TSE_ROMHOLE_MAKFILE_GUID | One among 16-GUID used to identify ROMHOLE by AMI utilities such as AFU, BCP, and MMTool. If TSE_ROMHOLE_MAKFILE_GUID token value is changed then TSE_ROMHOLE_HEADER_GUID token value should update.
TSE_ROMHOLE_SUPPORT | TEnable to support ROMHOLE generation.
TSE_SAVE_DISABLED_BBS_DEVICEPATH | 1 => Saves the DevicePaths of Disabled BBS devices to NVRAM Variable. \Depends on that varaible to keep device disbaled in next boot. \0 => Doesn't save the Disabled BBS devicepath.
TSE_SETUP_GRAYOUT_SELECTABLE | 0 is DEFAULT. set 1=> to allow grayed-out options set focus and to be selectable by the user. Set 0=> to make grayed-out options not to focus ; and editable
TSE_SHOW_PROMPT_STRING_AS_TITLE | 0 is DEFAULT.1 => To use password control's prompt's string for Password Title. 0 => To use standard TSE string for Password Title.
TSE_SUPPORT_DEFAULT_FOR_STRING_CONTROL | 0 is DEFAULT. 1 => To construct optimal and failsafe defaults for STRING type controls based on CONTROLPtr from controlInfo.0 => Not to construct and load optimal and failsafe defaults for STRING type controls.
TSE_SUPPORT_NATIVE_RESOLUTION | Sets the graphics mode for quiet boot from EDID. 1 - Defaultly enable make 0 to disable the feature.
TSE_SUPPRESS_MULTILINE_FOR_ONEOFLABEL | 1=> is to suppress multiline support for one of option . 0=> is to support multiline for one of option which is defalut behaviour.
TSE_USE_AMI_EFI_KEYCODE_PROTOCOL | AMIKeyCode Protocol support. TSE Sources need to be present to enable this token.
TSE_USE_GETGYLPH_PRINTLENGH | Turn on to to build under Aptio 5.
TSE_USE_OEM_ACTION_READ_KEY | If user likes to read the key in their own way then enable this token and define _OemActionReadKey function.
TSE_USER_PASSWORD | Defaultly no password is given. Provide data to set as default user password. Maximum string can be provide is based on SETUP_PASSWORD_LENGTH token. String should be minimum length mentioned in vfr. If no password is given it will not set any default password. Note: specify EMPTY_DATA in value if default user password is not required.
WIDE_GLYPH_SUPPORT | Far east language support

Built on 16:15:53 10/01/14


AMITSE_HIDE_ROOT_PAGE in the AMITSE SDL TOKENS

Variable : AMITSE_HIDE_ROOT_PAGE

File: AMITSE SDL TOKENS
Description:
1 -> Hides the root page & 0 -> The support is disabled
Built on 16:15:50 10/01/14


AMITSE_ROOT_PAGE_ORDER_SUPPORT in the AMITSE SDL TOKENS

Variable : AMITSE_ROOT_PAGE_ORDER_SUPPORT

Description:
1 => Enable the  Root Page Order support for TSE. 0 => Disable the  Root Page Order support for TSE.
Built on 16:15:50 10/01/14


AMITSE_SUBPAGE_AS_ROOT_PAGE_LIST_SUPPORT in the AMITSE SDL TOKENS

Variable : AMITSE_SUBPAGE_AS_ROOT_PAGE_LIST_SUPPORT

Description:
1 -> Shows subpages as root page & 0 -> Shows subpages as is.
Built on 16:15:50 10/01/14


AMITSE_SUPPORT in the AMITSE SDL TOKENS

Variable : AMITSE_SUPPORT

Description:
Main switch to enable AMITSE support in Project
Built on 16:15:50 10/01/14


AMITSE_SUPPRESS_DYNAMIC_FORMSET in the AMITSE SDL TOKENS

Variable : AMITSE_SUPPRESS_DYNAMIC_FORMSET

Description:
0 is Default. 1 -> To suppress dynamic formset mentioned in elink AMITSE_SUPPRESS_DYNAMIC_FORMSET_LIST and do not show in setup. 0 -> Display dynamic page and not to suppress dynamic page.
Built on 16:15:50 10/01/14


AMITSE_VERSION in the AMITSE SDL TOKENS

Variable : AMITSE_VERSION

Description:
TSE Version for displaying in the init screen. If no need of version to display then use empty string, if changing the format specifiers then care should be taken in source.
Built on 16:15:50 10/01/14


BIOS_SIGNON_MESSAGE2 in the AMITSE SDL TOKENS

Variable : BIOS_SIGNON_MESSAGE2

Description:
Use this SDL token to update the BIOS Sign On Message 2.
Built on 16:15:50 10/01/14


BOOT_FLOW_NORMAL_INFINITE_LOOP in the AMITSE SDL TOKENS

Variable : BOOT_FLOW_NORMAL_INFINITE_LOOP

Description:
1 = TSE tries to loads all the boot options and all fails checks for SETUP_ENTRY keys if found then enters the setup else TSE tries to load all the boot options once again and continues the mentioned procedure infinitely and 0 = Neglects the SETUP_ENTRY key check, always tries to load all the boot options infinitely.
Built on 16:15:50 10/01/14


BOOT_FLOW_NORMAL_LAUNCH_DEFAULT_BOOTIMAGE in the AMITSE SDL TOKENS

Variable : BOOT_FLOW_NORMAL_LAUNCH_DEFAULT_BOOTIMAGE

Description:
Support for UEFI specification v 2.3.1 section 3.4.1.1 and 3.4.1.2 to load the default boot image (efi\boot\boot####.efi) from any of the available file system if no boot option found. 1 = Enabling default image boot and 0 = Disabling default image boot.
Built on 16:15:50 10/01/14


BOOT_OVERRIDE_BOOTNEXT_VARIABLE_FEATURE in the AMITSE SDL TOKENS

Variable : BOOT_OVERRIDE_BOOTNEXT_VARIABLE_FEATURE

Description:
DISABLE is default.1=> To show menu for BootOverride options to modifiy BootNext variable when BootNext variable is supported by project. 0=> Not to show menu for BootOverride options.
Built on 16:15:50 10/01/14


CONTRIB_BGRT_TABLE_TO_ACPI in the AMITSE SDL TOKENS

Variable : CONTRIB_BGRT_TABLE_TO_ACPI

Description:
Set to Contribute the BGRT table to ACPI.
Built on 16:15:50 10/01/14


DEFAULT_SETUP_PWD_AT_FIRSTBOOT_ONLY in the AMITSE SDL TOKENS

Variable : DEFAULT_SETUP_PWD_AT_FIRSTBOOT_ONLY

Description:
1 is default. 1 => Sets the TSE_ADMIN_PASSWORD and TSE_USER_PASSWORD at first boot only. 0 => Sets TSE_ADMIN_PASSWORD and TSE_USER_PASSWORD in TSE defaults, on load defaults these data will be loaded.
Built on 16:15:50 10/01/14


DISABLE_ESC_IN_BBS in the AMITSE SDL TOKENS

Variable : DISABLE_ESC_IN_BBS

Description:
0 is DEFAULT.1 => To disable ESC behaviour in BBS menu and retain in BBS menu. 0 => To enable ESC behaviour in BBS menu.
Built on 16:15:50 10/01/14


DRAW_POST_LOGO_AT_0POS in the AMITSE SDL TOKENS

Variable : DRAW_POST_LOGO_AT_0POS

Description:
Displays the Post logo at top(0,0) graphics position. Disable by default make it 1 to avail this feature.
Built on 16:15:50 10/01/14


DRIVER_HEALTH_SUPPORT in the AMITSE SDL TOKENS

Variable : DRIVER_HEALTH_SUPPORT

Description:
Enabling Driver health support in TSE and 0 = Disabling Driver health support in TSE.
Built on 16:15:50 10/01/14


EDK_1_05_RETRIEVE_DATA in the AMITSE SDL TOKENS

Variable : EDK_1_05_RETRIEVE_DATA

Description:
Modified code to return BrowserCallback String according to either EDK browser or spec.
Built on 16:15:50 10/01/14


EXIT_PAGE_CLASS in the AMITSE SDL TOKENS

Variable : EXIT_PAGE_CLASS

Description:
Exit Page Formset class.
Built on 16:15:50 10/01/14


EXIT_PAGE_FORM_ID in the AMITSE SDL TOKENS

Variable : EXIT_PAGE_FORM_ID

Description:
Exit Page ID.
Built on 16:15:50 10/01/14


EXIT_PAGE_GUID in the AMITSE SDL TOKENS

Variable : EXIT_PAGE_GUID

Description:
GUID used to identify exit page.
Built on 16:15:50 10/01/14


EXIT_PAGE_SUB_CLASS in the AMITSE SDL TOKENS

Variable : EXIT_PAGE_SUB_CLASS

Description:
Exit Page Formset Subclass.
Built on 16:15:50 10/01/14


FLUSH_KEYS_AFTER_READ in the AMITSE SDL TOKENS

Variable : FLUSH_KEYS_AFTER_READ

Description:
Disable to flush the key buffer.
Built on 16:15:50 10/01/14


HONOR_DRVHLTH_CONFIGREQD_ON_BOOTFAIL in the AMITSE SDL TOKENS

Variable : HONOR_DRVHLTH_CONFIGREQD_ON_BOOTFAIL

Description:
1 => If driver need to be configured during the device boot then this token should be enabled to display the form produced from dirver health protocol & 0 => Disables the form produced by the driver health protocol.
Built on 16:15:50 10/01/14


INI_FILE_PATH in the AMITSE SDL TOKENS

Variable : INI_FILE_PATH

Description:
To set path of the setup ini file which used as input to HPK tool .
Built on 16:15:50 10/01/14


MAX_MSGBOX_WIDTH in the AMITSE SDL TOKENS

Variable : MAX_MSGBOX_WIDTH

Description:
Set the value to change the message box dispaly width.
Built on 16:15:51 10/01/14


MAX_POST_GC_MODE in the AMITSE SDL TOKENS

Variable : MAX_POST_GC_MODE

Description:
Port this SDL to select the Maximum Support Graphical module. Should be one of (GC_MODEx SDL tokens). Based on this token logo capability table created.
Built on 16:15:51 10/01/14


MINISETUP_MOUSE_SUPPORT in the AMITSE SDL TOKENS

Variable : MINISETUP_MOUSE_SUPPORT

Description:
Mouse suport.
Built on 16:15:51 10/01/14


MSGBOX_PROGRESS_BAR_SEGMENT_COUNT in the AMITSE SDL TOKENS

Variable : MSGBOX_PROGRESS_BAR_SEGMENT_COUNT

Description:
Mod of 100 with this number should be 0, for example (100 % 20 = 0).
Built on 16:15:51 10/01/14


NO_VARSTORE_SUPPORT in the AMITSE SDL TOKENS

Variable : NO_VARSTORE_SUPPORT

Description:
Enables and disables no var store support. This needs modification of VFRs. Need customization of board module.
Built on 16:15:51 10/01/14


OEMLogo_FILE_PATH in the AMITSE SDL TOKENS

Variable : OEMLogo_FILE_PATH

Description:
Path of OEMLogo to show in Postscreen. Default path is TSE_BIN.
Built on 16:15:51 10/01/14


OLD_MOUSE_DRIVER_SUPPORT in the AMITSE SDL TOKENS

Variable : OLD_MOUSE_DRIVER_SUPPORT

Description:
Old Mouse Driver Mouse suport. Need to be on if 4.6.0-MOUSE_SUPPORT-004 or older is used.
Built on 16:15:51 10/01/14


OSIndication_SUPPORT in the AMITSE SDL TOKENS

Variable : OSIndication_SUPPORT

Description:
Main token to disable or enable the OSIndication Support. If disable then OSIndication module can be used.
Built on 16:15:51 10/01/14


OVERRIDE_BBSBuildName in the AMITSE SDL TOKENS

Variable : OVERRIDE_BBSBuildName

Description:
set to 1 if oem wants to override the BBSBuildName function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_BBSGetNonStandardGroupType in the AMITSE SDL TOKENS

Variable : OVERRIDE_BBSGetNonStandardGroupType

Description:
Set to 1 if oem wants to override the BBSGetNonStandardGroupType function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_BbsItkBoot in the AMITSE SDL TOKENS

Variable : OVERRIDE_BbsItkBoot

Description:
set to 1 if oem wants to override the BbsItkBoot function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_CheckAdvShiftState in the AMITSE SDL TOKENS

Variable : OVERRIDE_CheckAdvShiftState

Description:
set to 1 if OEM wants to override the CheckAdvShiftState function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_CheckIsAllowedPasswordChar in the AMITSE SDL TOKENS

Variable : OVERRIDE_CheckIsAllowedPasswordChar

Description:
set to 1 if oem wants to override the CheckIsAllowedPasswordChar function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_CleanUpOEMLogo in the AMITSE SDL TOKENS

Variable : OVERRIDE_CleanUpOEMLogo

Description:
set to 1 if oem wants to override the CleanUpOEMLogo function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_ConvertOEMFormatToUgaBlt in the AMITSE SDL TOKENS

Variable : OVERRIDE_ConvertOEMFormatToUgaBlt

Description:
set to 1 if oem wants to override the ConvertOEMFormatToUgaBlt function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_CsmBBSBootOptionName in the AMITSE SDL TOKENS

Variable : OVERRIDE_CsmBBSBootOptionName

Description:
0 is Default. Set to 1 if OEM wants to override the CsmBBSBootOptionName function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_DoOEMLogoAnimate in the AMITSE SDL TOKENS

Variable : OVERRIDE_DoOEMLogoAnimate

Description:
set to 1 if oem wants to override the DoOEMLogoAnimate function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_DriverHealthSystemReset in the AMITSE SDL TOKENS

Variable : OVERRIDE_DriverHealthSystemReset

Description:
set to 1 if oem wants to override the DriverHealthSystemReset function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_FindVarFromITKQuestionId in the AMITSE SDL TOKENS

Variable : OVERRIDE_FindVarFromITKQuestionId

Description:
set to 1 if oem wants to override the FindVarFromITKQuestionId function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_FixMergePagesExtraHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_FixMergePagesExtraHook

Description:
set to 1 if OEM wants to override the FixMergePagesExtraHook function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_FramePasswordAdvancedCallback in the AMITSE SDL TOKENS

Variable : OVERRIDE_FramePasswordAdvancedCallback

Description:
set to 1 if OEM wants to override the FramePasswordAdvancedCallback function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_FramePwdCallbackIdePasswordUpdate in the AMITSE SDL TOKENS

Variable : OVERRIDE_FramePwdCallbackIdePasswordUpdate

Description:
Set to 1 if oem wants to override the FramePwdCallbackIdePasswordUpdate function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_GetAMITSEVariable in the AMITSE SDL TOKENS

Variable : OVERRIDE_GetAMITSEVariable

Description:
set to 1 if oem wants to override the GetAMITSEVariable function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_GetBootTimeOut in the AMITSE SDL TOKENS

Variable : OVERRIDE_GetBootTimeOut

Description:
set to 1 if oem wants to override the GetBootTimeOut function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_GetGraphicsBitMapFromFV in the AMITSE SDL TOKENS

Variable : OVERRIDE_GetGraphicsBitMapFromFV

Description:
set to 1 if OEM wants to override the GetGraphicsBitMapFromFV function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_GetMessageboxColorHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_GetMessageboxColorHook

Description:
Set to 1 if oem wants to override the GetMessageboxColorHook function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_GetUefiSpecVersion in the AMITSE SDL TOKENS

Variable : OVERRIDE_GetUefiSpecVersion

Description:
set to 1 if OEM wants to override the GetUEFISpecVersion function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_GOPSetScreenResolutionHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_GOPSetScreenResolutionHook

Description:
Set to 1 if oem wants to override the GOPSetScreenResolutionHook function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_IsOEMLogoType in the AMITSE SDL TOKENS

Variable : OVERRIDE_IsOEMLogoType

Description:
set to 1 if oem wants to override the IsOEMLogoType function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_ItkSupport in the AMITSE SDL TOKENS

Variable : OVERRIDE_ItkSupport

Description:
set to 1 if oem wants to override the ItkSupport function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_LaunchHotKeyBootOption in the AMITSE SDL TOKENS

Variable : OVERRIDE_LaunchHotKeyBootOption

Description:
set to 1 if OEM wants to override the LaunchHotKeyBootOption function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_LaunchSecBootPathFromEnabledDevs in the AMITSE SDL TOKENS

Variable : OVERRIDE_LaunchSecBootPathFromEnabledDevs

Description:
set to 1 if OEM wants to override the LaunchSecBootPathFromEnabledDevs function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_LaunchSecondaryBootPath in the AMITSE SDL TOKENS

Variable : OVERRIDE_LaunchSecondaryBootPath

Description:
set to 1 if OEM wants to override the LaunchSecondaryBootPath function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_LegacyBootFailHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_LegacyBootFailHook

Description:
set to 1 if OEM wants to override the OVERRIDE_LegacyBootFailHook function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_MainSetupLoopHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_MainSetupLoopHook

Description:
set to 1 if OEM wants to override the MainSetupLoopHook function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_MainSetupLoopInitHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_MainSetupLoopInitHook

Description:
set to 1 if OEM wants to override the MainSetupLoopInitHook function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_NoVarStoreSupport in the AMITSE SDL TOKENS

Variable : OVERRIDE_NoVarStoreSupport

Description:
set to 1 if oem wants to override the NoVarStoreSupport function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_NoVarStoreUpdateSystemAccess in the AMITSE SDL TOKENS

Variable : OVERRIDE_NoVarStoreUpdateSystemAccess

Description:
set to 1 if oem wants to override the NoVarStoreUpdateSystemAccess function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_OEMCheckControlCondition in the AMITSE SDL TOKENS

Variable : OVERRIDE_OEMCheckControlCondition

Description:
set to 1 if OEM wants to override the OemCheckControlCondition function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_OEMSpecialGetControlCount in the AMITSE SDL TOKENS

Variable : OVERRIDE_OEMSpecialGetControlCount

Description:
set to 1 if oem wants to override the OEMSpecialGetControlCount function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_OEMSpecialGotoFixup in the AMITSE SDL TOKENS

Variable : OVERRIDE_OEMSpecialGotoFixup

Description:
Modified code to return BrowserCallback String according to either EDK browser or spec.
Built on 16:15:51 10/01/14


OVERRIDE_OEMSpecialGotoSelect in the AMITSE SDL TOKENS

Variable : OVERRIDE_OEMSpecialGotoSelect

Description:
set to 1 if oem wants to override the OEMSpecialGotoSelect function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_OEMSpecialOneOfFixup in the AMITSE SDL TOKENS

Variable : OVERRIDE_OEMSpecialOneOfFixup

Description:
set to 1 if oem wants to override the OEMSpecialOneOfFixup function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_OEMSpecialUpdateOneOf in the AMITSE SDL TOKENS

Variable : OVERRIDE_OEMSpecialUpdateOneOf

Description:
set to 1 if oem wants to override the OEMSpecialGotoFixup function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_OsUpdateCapsuleWrap in the AMITSE SDL TOKENS

Variable : OVERRIDE_OsUpdateCapsuleWrap

Description:
set to 1 if OEM wants to override the OsUpdateCapsuleWrap function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_PageRemoveHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_PageRemoveHook

Description:
set to 1 if OEM wants to override the PageRemoveHook function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_PasswordAuthenticate in the AMITSE SDL TOKENS

Variable : OVERRIDE_PasswordAuthenticate

Description:
set to 1 if oem wants to override the PasswordAuthenticate function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_PasswordCheckInstalled in the AMITSE SDL TOKENS

Variable : OVERRIDE_PasswordCheckInstalled

Description:
set to 1 if oem wants to override the PasswordCheckInstalled function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_PasswordCommitChanges in the AMITSE SDL TOKENS

Variable : OVERRIDE_PasswordCommitChanges

Description:
set to 1 if oem wants to override the PasswordCommitChanges function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_PasswordUpdate in the AMITSE SDL TOKENS

Variable : OVERRIDE_PasswordUpdate

Description:
set to 1 if oem wants to override the PasswordUpdate function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_PopupPasswordAuthenticate in the AMITSE SDL TOKENS

Variable : OVERRIDE_PopupPasswordAuthenticate

Description:
set to 1 if oem wants to override the PopupPasswordAuthenticate function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_PopupPasswordCheckInstalled in the AMITSE SDL TOKENS

Variable : OVERRIDE_PopupPasswordCheckInstalled

Description:
set to 1 if oem wants to override the PopupPasswordCheckInstalled function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_PopupPasswordFormCallback in the AMITSE SDL TOKENS

Variable : OVERRIDE_PopupPasswordFormCallback

Description:
set to 1 if oem wants to override the PopupPasswordFormCallback function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_PopupPwdAuthenticateIDEPwd in the AMITSE SDL TOKENS

Variable : OVERRIDE_PopupPwdAuthenticateIDEPwd

Description:
Set to 1 if oem wants to override the PopupPwdAuthenticateIDEPwd function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_PopupPwdHandleActionOverRide in the AMITSE SDL TOKENS

Variable : OVERRIDE_PopupPwdHandleActionOverRide

Description:
set to 1 if oem wants to override the PopupPwdHandleActionOverRide function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_PopupPwdUpdateIDEPwd in the AMITSE SDL TOKENS

Variable : OVERRIDE_PopupPwdUpdateIDEPwd

Description:
Set to 1 if oem wants to override the PopupPwdUpdateIDEPwd function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_ProcessBrowserActionRequestHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_ProcessBrowserActionRequestHook

Description:
set to 1 if OEM wants to override the ProcessBrowserActionRequestHook function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_ProcessPackNotificationHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_ProcessPackNotificationHook

Description:
set to 1 if OEM wants to override the ProcessPackNotification function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_SetSystemAccessValueItk in the AMITSE SDL TOKENS

Variable : OVERRIDE_SetSystemAccessValueItk

Description:
set to 1 if oem wants to override the SetSystemAccessValueItk function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEGetactualScreentop in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEGetactualScreentop

Description:
set to 1 if OEM wants to override the TSEGetactualScreentop function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEGetCoordinates in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEGetCoordinates

Description:
set to 1 if OEM wants to override the TSEGetCoordinates function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEIDEPasswordAuthenticate in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEIDEPasswordAuthenticate

Description:
Set to 1 if oem wants to override the TSEIDEPasswordAuthenticate function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEIDEPasswordCheck in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEIDEPasswordCheck

Description:
set to 1 if oem wants to override the TSEIDEPasswordCheck function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEIDEPasswordFreezeDevices in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEIDEPasswordFreezeDevices

Description:
set to 1 if oem wants to override the TSEIDEPasswordFreezeDevices function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEIDEPasswordGetDataPtr in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEIDEPasswordGetDataPtr

Description:
set to 1 if oem wants to override the TSEIDEPasswordGetDataPtr function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEIDEPasswordGetLocked in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEIDEPasswordGetLocked

Description:
set to 1 if oem wants to override the TSEIDEPasswordGetLocked function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEIDEPasswordGetName in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEIDEPasswordGetName

Description:
Set to 1 if oem wants to override the TSEIDEPasswordGetName function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEIDEPasswordUpdate in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEIDEPasswordUpdate

Description:
set to 1 if oem wants to override the TSEIDEPasswordUpdate function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEIDEUpdateConfig in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEIDEUpdateConfig

Description:
set to 1 if oem wants to override the TSEIDEUpdateConfig function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEIsMouseClickedonSoftkbd in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEIsMouseClickedonSoftkbd

Description:
set to 1 if OEM wants to override the TSEIsMouseClickedonSoftkbd function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TseLaunchFileSystem in the AMITSE SDL TOKENS

Variable : OVERRIDE_TseLaunchFileSystem

Description:
set to 1 if OEM wants to override the TseLaunchFileSystem function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEMouseDestoryHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEMouseDestoryHook

Description:
set to 1 if oem/Modules wants to override the TSEMouseDestoryHook function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEMouseDestroy in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEMouseDestroy

Description:
set to 1 if OEM wants to override the TSEMouseDestroy function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEMouseFreeze in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEMouseFreeze

Description:
set to 1 if OEM wants to override the TSEMouseFreeze function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEMouseIgnoreMouseActionHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEMouseIgnoreMouseActionHook

Description:
set to 1 if oem wants to override the TSEMouseIgnoreMouseActionHook function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEMouseInit in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEMouseInit

Description:
set to 1 if OEM wants to override the TSEMouseInit function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEMouseInitHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEMouseInitHook

Description:
set to 1 if oem/Modules wants to override the TSEMouseInitHook function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEMouseReadInfo in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEMouseReadInfo

Description:
set to 1 if OEM wants to override the TSEMouseReadInfo function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEMouseRefresh in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEMouseRefresh

Description:
set to 1 if OEM wants to override the TSEMouseRefresh function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEMouseRefreshHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEMouseRefreshHook

Description:
set to 1 if oem/Modules wants to override the TSEMouseRefreshHook function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEMouseStart in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEMouseStart

Description:
set to 1 if OEM wants to override the TSEMouseStart function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEMouseStartHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEMouseStartHook

Description:
set to 1 if oem wants to override the TSEMouseStartHook function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEMouseStop in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEMouseStop

Description:
set to 1 if OEM wants to override the TSEMouseStop function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEMouseStopHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEMouseStopHook

Description:
Modified code to return BrowserCallback String according to either EDK browser or spec.
Built on 16:15:51 10/01/14


OVERRIDE_TSENumericSoftKbdExit in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSENumericSoftKbdExit

Description:
set to 1 if OEM wants to override the TSENumericSoftKbdExit function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSENumericSoftKbdInit in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSENumericSoftKbdInit

Description:
set to 1 if OEM wants to override the TSENumericSoftKbdInit function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSESetHDDPassword in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSESetHDDPassword

Description:
set to 1 if oem wants to override the TSESetHDDPassword function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEStringReadLoopEntryHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEStringReadLoopEntryHook

Description:
set to 1 if oem wants to override the TSEStringReadLoopEntryHook function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEStringReadLoopExitHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEStringReadLoopExitHook

Description:
set to 1 if oem wants to override the TSEStringReadLoopExitHook function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_TSEUnlockHDD in the AMITSE SDL TOKENS

Variable : OVERRIDE_TSEUnlockHDD

Description:
set to 1 if oem wants to override the TSEUnlockHDD function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_UefiBootFailHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_UefiBootFailHook

Description:
set to 1 if OEM wants to override the OVERRIDE_UefiBootFailHook function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_UIUpdateCallbackHook in the AMITSE SDL TOKENS

Variable : OVERRIDE_UIUpdateCallbackHook

Description:
set to 1 if OEM wants to override the UIUpdateCallback function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_UpdateNumericDisplayString in the AMITSE SDL TOKENS

Variable : OVERRIDE_UpdateNumericDisplayString

Description:
set to 1 if OEM wants to override the UpdateNumericDisplayString function from Board module.
Built on 16:15:51 10/01/14


OVERRIDE_VarBuildItkDefaults in the AMITSE SDL TOKENS

Variable : OVERRIDE_VarBuildItkDefaults

Description:
set to 1 if oem wants to override the VarBuildItkDefaults function from Board module.
Built on 16:15:51 10/01/14


PASSWORD_WITH_SPECIAL_CHAR_SUPPORT in the AMITSE SDL TOKENS

Variable : PASSWORD_WITH_SPECIAL_CHAR_SUPPORT

Description:
0 => Only alphanumeric characters are support in the Password 1 => Also supports printable special characters.
Built on 16:15:51 10/01/14


POPUP_MENU_ENTRY_LEGACY_CODE in the AMITSE SDL TOKENS

Variable : POPUP_MENU_ENTRY_LEGACY_CODE

Description:
Set legacy scan code for popup menu entry.
Built on 16:15:52 10/01/14


POPUP_MENU_ENTRY_SCAN in the AMITSE SDL TOKENS

Variable : POPUP_MENU_ENTRY_SCAN

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol
Built on 16:15:52 10/01/14


POPUP_MENU_ENTRY_SHIFT_STATE in the AMITSE SDL TOKENS

Variable : POPUP_MENU_ENTRY_SHIFT_STATE

Description:
Set to one of the defined constants from AMI_KEY_CODE_PROTOCOL.
Built on 16:15:52 10/01/14


POPUP_MENU_ENTRY_UNICODE in the AMITSE SDL TOKENS

Variable : POPUP_MENU_ENTRY_UNICODE

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'
Built on 16:15:52 10/01/14


POPUP_MENU_HIDE_DISABLE_BOOT_OPTIONS in the AMITSE SDL TOKENS

Variable : POPUP_MENU_HIDE_DISABLE_BOOT_OPTIONS

Description:
1 => Hide the disabled boot options in BBS POPup menu. 0 => Shows all boot options in BBS POPup menu.
Built on 16:15:52 10/01/14


POPUP_MENU_SHOW_ALL_BBS_DEVICES in the AMITSE SDL TOKENS

Variable : POPUP_MENU_SHOW_ALL_BBS_DEVICES

Description:
1 => Shows all BBS devices in BBS POPup menu. 0 => Shows only the first device of a BBS type in BBS POPUP menu.
Built on 16:15:52 10/01/14


PROGRESSBAR_BACKGROUNDCOLOR in the AMITSE SDL TOKENS

Variable : PROGRESSBAR_BACKGROUNDCOLOR

Description:
Set the value of progressbar bgcolor in EFI_UGA_PIXEL format
Built on 16:15:52 10/01/14


PROGRESSBAR_BORDERCOLOR in the AMITSE SDL TOKENS

Variable : PROGRESSBAR_BORDERCOLOR

Description:
Set the value of progressbar border color in EFI_UGA_PIXEL format
Built on 16:15:52 10/01/14


PROGRESSBAR_FILLCOLOR in the AMITSE SDL TOKENS

Variable : PROGRESSBAR_FILLCOLOR

Description:
Set the value of progressbar fill color in EFI_UGA_PIXEL format
Built on 16:15:52 10/01/14


RESERVED_ADD_DEL_BOOT_OPTION_NAME in the AMITSE SDL TOKENS

Variable : RESERVED_ADD_DEL_BOOT_OPTION_NAME

Description:
Reserved names that are not allowed to use for add or delete boot options.
Built on 16:15:52 10/01/14


ROMHOLE_BLOCK_SIZE in the AMITSE SDL TOKENS

Variable : ROMHOLE_BLOCK_SIZE

Description:
Size of Block used for ROMHOLE.
Built on 16:15:52 10/01/14


ROMHOLE_NUMBER_OF_BLOCK in the AMITSE SDL TOKENS

Variable : ROMHOLE_NUMBER_OF_BLOCK

Description:
Number of Block used for ROMHOLE.
Built on 16:15:52 10/01/14


RT_ACCESS_SUPPORT_IN_HPKTOOL in the AMITSE SDL TOKENS

Variable : RT_ACCESS_SUPPORT_IN_HPKTOOL

Description:
0 is default. 0=> Not to set RT flag for variables. 1=> enable to add RT attribute for variables, uefisetup.ini attributes persists.
Built on 16:15:52 10/01/14


SECONDARY_BOOT_FROM_ENABLED_DEVICES in the AMITSE SDL TOKENS

Variable : SECONDARY_BOOT_FROM_ENABLED_DEVICES

Description:
0-> Loads \EFI\BOOT\BOOT{machine type short-name}.EFI from any of the devices & 1-> Loads the default image only from enabled devices.
Built on 16:15:52 10/01/14


SERIAL_DEBUG in the AMITSE SDL TOKENS

Variable : SERIAL_DEBUG

Description:
A switch to print TSE Debug messages over Serial Port.
Built on 16:15:52 10/01/14


SETUP_ALT_ENTRY_ENABLE in the AMITSE SDL TOKENS

Variable : SETUP_ALT_ENTRY_ENABLE

Description:
Enable or disable the SETUP_ALT_ENTRY
Built on 16:15:52 10/01/14


SETUP_ALT_ENTRY_LEGACY_CODE in the AMITSE SDL TOKENS

Variable : SETUP_ALT_ENTRY_LEGACY_CODE

Description:
Set legacy code for Alternate entry key.
Built on 16:15:52 10/01/14


SETUP_ALT_ENTRY_SCAN in the AMITSE SDL TOKENS

Variable : SETUP_ALT_ENTRY_SCAN

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol. Remember to check STR_DEL_ENTER_SETUP string in MiniSetupStr.uni.
Built on 16:15:52 10/01/14


SETUP_ALT_ENTRY_SHIFT_STATE in the AMITSE SDL TOKENS

Variable : SETUP_ALT_ENTRY_SHIFT_STATE

Description:
Set to one of the defined constants from AMI_KEY_CODE_PROTOCOL.
Built on 16:15:52 10/01/14


SETUP_ALT_ENTRY_UNICODE in the AMITSE SDL TOKENS

Variable : SETUP_ALT_ENTRY_UNICODE

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'. Remember to check STR_DEL_ENTER_SETUP string in MiniSetupStr.uni.
Built on 16:15:52 10/01/14


SETUP_BBS_POPUP_ENABLE in the AMITSE SDL TOKENS

Variable : SETUP_BBS_POPUP_ENABLE

Description:
Enable or disable the SETUP_BBS_POPUP_ENABLE. CAUTION This works only if complete TSE sources are present.
Built on 16:15:52 10/01/14


SETUP_BMP_LOGO_SUPPORT in the AMITSE SDL TOKENS

Variable : SETUP_BMP_LOGO_SUPPORT

Description:
BMP Logo support in Setup
Built on 16:15:52 10/01/14


SETUP_DEFAULT_TIMEOUT in the AMITSE SDL TOKENS

Variable : SETUP_DEFAULT_TIMEOUT

Description:
Default timeout value before system boots
Built on 16:15:52 10/01/14


SETUP_DELAY_LOGO_TILL_INPUT in the AMITSE SDL TOKENS

Variable : SETUP_DELAY_LOGO_TILL_INPUT

Description:
1 => delays logo display untill SIMPLE TEXT IN protocol is available. 0 => logo is displayed as soon as UGA DRAW, CONSOLE SPLITTER & SIMPLE TEXT OUT IS AVAILABLE (Will increase code size).
Built on 16:15:52 10/01/14


SETUP_DELAY_POST_TILL_GOP in the AMITSE SDL TOKENS

Variable : SETUP_DELAY_POST_TILL_GOP

Description:
ENABLE is default.Wait for GOP.
Built on 16:15:52 10/01/14


SETUP_DISPLAY_SUBMENU_PAGETITLE in the AMITSE SDL TOKENS

Variable : SETUP_DISPLAY_SUBMENU_PAGETITLE

Description:
Displays page title of submenu pages in the menu tab.
Built on 16:15:52 10/01/14


SETUP_ENTRY_LEGACY_CODE in the AMITSE SDL TOKENS

Variable : SETUP_ENTRY_LEGACY_CODE

Description:
Set legacy scan code for entry key.
Built on 16:15:52 10/01/14


SETUP_ENTRY_SCAN in the AMITSE SDL TOKENS

Variable : SETUP_ENTRY_SCAN

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol. Remember to check STR_DEL_ENTER_SETUP string in MiniSetupStr.uni.
Built on 16:15:52 10/01/14


SETUP_ENTRY_SHIFT_STATE in the AMITSE SDL TOKENS

Variable : SETUP_ENTRY_SHIFT_STATE

Description:
Set to one of the defined constants from AMI_KEY_CODE_PROTOCOL.
Built on 16:15:52 10/01/14


SETUP_ENTRY_UNICODE in the AMITSE SDL TOKENS

Variable : SETUP_ENTRY_UNICODE

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'. Remember to check STR_DEL_ENTER_SETUP string in MiniSetupStr.uni.
Built on 16:15:52 10/01/14


SETUP_GIF_LOGO_SUPPORT in the AMITSE SDL TOKENS

Variable : SETUP_GIF_LOGO_SUPPORT

Description:
GIF Logo support in Setup
Built on 16:15:52 10/01/14


SETUP_GO_TO_EXIT_PAGE_ON_EXIT_KEY in the AMITSE SDL TOKENS

Variable : SETUP_GO_TO_EXIT_PAGE_ON_EXIT_KEY

Description:
DISABLE is default.Set to ENABLE to goto Exit page on pressing ESC key. If Enabled, on Pressing ESC key, by default it will go to Exit page.If user needs to change the page then user has provide proper FormID in the dependency tokens.
Built on 16:15:52 10/01/14


SETUP_GRAYOUT_READONLY_CONTROL in the AMITSE SDL TOKENS

Variable : SETUP_GRAYOUT_READONLY_CONTROL

Description:
Diaplay readonly controls as grayout.
Built on 16:15:52 10/01/14


SETUP_GROUP_DYNAMIC_PAGES in the AMITSE SDL TOKENS

Variable : SETUP_GROUP_DYNAMIC_PAGES

Description:
Allows Dynamic IFR Pages to be relocated under subpages. Make sure to have the VFR changes to show the dynamic pages.
Built on 16:15:52 10/01/14


SETUP_HIDE_BIOS_SIGNON_MESSAGE2 in the AMITSE SDL TOKENS

Variable : SETUP_HIDE_BIOS_SIGNON_MESSAGE2

Description:
1 => Hides the BIOS signon message. 0 => Shows the BIOS sign on message.
Built on 16:15:52 10/01/14


SETUP_HIDE_DISABLE_BOOT_OPTIONS in the AMITSE SDL TOKENS

Variable : SETUP_HIDE_DISABLE_BOOT_OPTIONS

Description:
1 => Hide the disabled boot options in boot override menu. 0 => Shows all boot options boot override menu.
Built on 16:15:52 10/01/14


SETUP_IDE_SECURITY_SUPPORT in the AMITSE SDL TOKENS

Variable : SETUP_IDE_SECURITY_SUPPORT

Description:
To support IDE Security.
Built on 16:15:52 10/01/14


SETUP_ITK_COMPATIBILITY in the AMITSE SDL TOKENS

Variable : SETUP_ITK_COMPATIBILITY

Description:
Enables and disables ITK compatibility. Need customization in Board module to support ITK projects.
Built on 16:15:52 10/01/14


SETUP_JPEG_LOGO_SUPPORT in the AMITSE SDL TOKENS

Variable : SETUP_JPEG_LOGO_SUPPORT

Description:
JPEG Logo support in Setup
Built on 16:15:52 10/01/14


SETUP_LINK_HISTORY_SUPPORT in the AMITSE SDL TOKENS

Variable : SETUP_LINK_HISTORY_SUPPORT

Description:
Preserves navigation history of Ref linked pages. Pressing the <ESC> returns control to the previous page if the current page was linked from a REF control.
Built on 16:15:52 10/01/14


SETUP_OEM_FORMAT_LOGO_SUPPORT in the AMITSE SDL TOKENS

Variable : SETUP_OEM_FORMAT_LOGO_SUPPORT

Description:
OEM Specific Logo support in Setup
Built on 16:15:52 10/01/14


SETUP_OEM_KEY1_EFIKEY in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY1_EFIKEY

Description:
Set to one of the defined EFI_KEY enumeration.
Built on 16:15:52 10/01/14


SETUP_OEM_KEY1_ENABLE in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY1_ENABLE

Description:
Enable or disable the SETUP_OEM_KEY1
Built on 16:15:52 10/01/14


SETUP_OEM_KEY1_LEGACY_CODE in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY1_LEGACY_CODE

Description:
Set legacy code for OEM key 1.
Built on 16:15:52 10/01/14


SETUP_OEM_KEY1_SCAN in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY1_SCAN

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol
Built on 16:15:52 10/01/14


SETUP_OEM_KEY1_SHIFT in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY1_SHIFT

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
Built on 16:15:52 10/01/14


SETUP_OEM_KEY1_TOGGLE in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY1_TOGGLE

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
Built on 16:15:52 10/01/14


SETUP_OEM_KEY1_UNICODE in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY1_UNICODE

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'
Built on 16:15:52 10/01/14


SETUP_OEM_KEY2_EFIKEY in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY2_EFIKEY

Description:
Set to one of the defined EFI_KEY enumeration.
Built on 16:15:52 10/01/14


SETUP_OEM_KEY2_ENABLE in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY2_ENABLE

Description:
Enable or disable the SETUP_OEM_KEY2
Built on 16:15:52 10/01/14


SETUP_OEM_KEY2_LEGACY_CODE in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY2_LEGACY_CODE

Description:
Set legacy code for OEM key 2.
Built on 16:15:52 10/01/14


SETUP_OEM_KEY2_SCAN in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY2_SCAN

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol
Built on 16:15:52 10/01/14


SETUP_OEM_KEY2_SHIFT in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY2_SHIFT

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
Built on 16:15:52 10/01/14


SETUP_OEM_KEY2_TOGGLE in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY2_TOGGLE

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
Built on 16:15:52 10/01/14


SETUP_OEM_KEY2_UNICODE in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY2_UNICODE

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'
Built on 16:15:52 10/01/14


SETUP_OEM_KEY3_EFIKEY in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY3_EFIKEY

Description:
Set to one of the defined EFI_KEY enumeration.
Built on 16:15:52 10/01/14


SETUP_OEM_KEY3_ENABLE in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY3_ENABLE

Description:
Enable or disable the SETUP_OEM_KEY3
Built on 16:15:52 10/01/14


SETUP_OEM_KEY3_LEGACY_CODE in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY3_LEGACY_CODE

Description:
Set legacy code for OEM key 3.
Built on 16:15:52 10/01/14


SETUP_OEM_KEY3_SCAN in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY3_SCAN

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol
Built on 16:15:52 10/01/14


SETUP_OEM_KEY3_SHIFT in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY3_SHIFT

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
Built on 16:15:52 10/01/14


SETUP_OEM_KEY3_TOGGLE in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY3_TOGGLE

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
Built on 16:15:52 10/01/14


SETUP_OEM_KEY3_UNICODE in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY3_UNICODE

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'
Built on 16:15:52 10/01/14


SETUP_OEM_KEY4_EFIKEY in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY4_EFIKEY

Description:
Set to one of the defined EFI_KEY enumeration.
Built on 16:15:52 10/01/14


SETUP_OEM_KEY4_ENABLE in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY4_ENABLE

Description:
Enable or disable the SETUP_OEM_KEY4
Built on 16:15:52 10/01/14


SETUP_OEM_KEY4_LEGACY_CODE in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY4_LEGACY_CODE

Description:
Set legacy code for OEM key 4.
Built on 16:15:52 10/01/14


SETUP_OEM_KEY4_SCAN in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY4_SCAN

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol
Built on 16:15:52 10/01/14


SETUP_OEM_KEY4_SHIFT in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY4_SHIFT

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
Built on 16:15:52 10/01/14


SETUP_OEM_KEY4_TOGGLE in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY4_TOGGLE

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
Built on 16:15:52 10/01/14


SETUP_OEM_KEY4_UNICODE in the AMITSE SDL TOKENS

Variable : SETUP_OEM_KEY4_UNICODE

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'
Built on 16:15:52 10/01/14


SETUP_ORPHAN_PAGES_AS_ROOT_PAGE in the AMITSE SDL TOKENS

Variable : SETUP_ORPHAN_PAGES_AS_ROOT_PAGE

Description:
Allows Orphan IFR Pages to be relocated to root pages.
Built on 16:15:52 10/01/14


SETUP_PASSWORD_LENGTH in the AMITSE SDL TOKENS

Variable : SETUP_PASSWORD_LENGTH

Description:
Default maximum password length.
Built on 16:15:52 10/01/14


SETUP_PASSWORD_NON_CASE_SENSITIVE in the AMITSE SDL TOKENS

Variable : SETUP_PASSWORD_NON_CASE_SENSITIVE

Description:
Allow to use of case sensitive password.
Built on 16:15:52 10/01/14


SETUP_PCX_LOGO_SUPPORT in the AMITSE SDL TOKENS

Variable : SETUP_PCX_LOGO_SUPPORT

Description:
PCX Logo support in Setup
Built on 16:15:52 10/01/14


SETUP_PNG_LOGO_SUPPORT in the AMITSE SDL TOKENS

Variable : SETUP_PNG_LOGO_SUPPORT

Description:
PNG Logo support in Setup.
Built on 16:15:52 10/01/14


SETUP_PRINT_ENTER_BBSPOPUP_MSG in the AMITSE SDL TOKENS

Variable : SETUP_PRINT_ENTER_BBSPOPUP_MSG

Description:
Set to 1 to print the Setup BBS Popup Menu messages in Post.
Built on 16:15:52 10/01/14


SETUP_PRINT_ENTER_SETUP_MSG in the AMITSE SDL TOKENS

Variable : SETUP_PRINT_ENTER_SETUP_MSG

Description:
Set to 1 to print the Setup Enter messages in Post
Built on 16:15:52 10/01/14


SETUP_PRINT_EVAL_MSG in the AMITSE SDL TOKENS

Variable : SETUP_PRINT_EVAL_MSG

Description:
Enable/Disable Evaluation message in Post screen
Built on 16:15:52 10/01/14


SETUP_ROOT_PAGE_ORDER_GUID in the AMITSE SDL TOKENS

Variable : SETUP_ROOT_PAGE_ORDER_GUID

Description:
Setup root Page Order Guid.
Built on 16:15:52 10/01/14


SETUP_RUNTIME_IFR_PROCESSING in the AMITSE SDL TOKENS

Variable : SETUP_RUNTIME_IFR_PROCESSING

Description:
Processes IFR data that are added to hii at runtime.  This will cause an increased FW footprint and remove AMIBCP compatibility for those new pages.
Built on 16:15:52 10/01/14


SETUP_SAVE_PSWD_TO_NVRAM in the AMITSE SDL TOKENS

Variable : SETUP_SAVE_PSWD_TO_NVRAM

Description:
1 => Save password to Nvram. 0 => Save password to cache.
Built on 16:15:52 10/01/14


SETUP_SHOW_ALL_BBS_DEVICES in the AMITSE SDL TOKENS

Variable : SETUP_SHOW_ALL_BBS_DEVICES

Description:
1 => Shows all BBS devices in boot override menu. 0 => Shows only the first device of a BBS type in override menu.
Built on 16:15:52 10/01/14


SETUP_STORE_EFI_KEY_PASSWORD in the AMITSE SDL TOKENS

Variable : SETUP_STORE_EFI_KEY_PASSWORD

Description:
This Token becomes Obsolete after adding the Token SETUP_STORE_KEYCODE_PASSWORD. / Enables support to store EFI_KEYs as password. TSE Sources should be required to present to Enable this token.
Built on 16:15:52 10/01/14


SETUP_STORE_KEYCODE_PASSWORD in the AMITSE SDL TOKENS

Variable : SETUP_STORE_KEYCODE_PASSWORD

Description:
For Extened Password support, the Value can be 1 or 2. Set Value as 1 to support Efi Key as password. Set Value as 2 to support Scan Code in password. Need AMIKeyCode Protocol & TSE sources support.
Built on 16:15:52 10/01/14


SETUP_SUPPORT_ADD_BOOT_OPTION in the AMITSE SDL TOKENS

Variable : SETUP_SUPPORT_ADD_BOOT_OPTION

Description:
Set to enable Add/Delete boot option.
Built on 16:15:52 10/01/14


SETUP_SUPPORT_ADD_DRIVER_OPTION in the AMITSE SDL TOKENS

Variable : SETUP_SUPPORT_ADD_DRIVER_OPTION

Description:
Set to enable Add/Delete Driver option.
Built on 16:15:52 10/01/14


SETUP_SUPPORT_KEY_MONITORING in the AMITSE SDL TOKENS

Variable : SETUP_SUPPORT_KEY_MONITORING

Description:
Enable or Disable monitoring keys during Legacy mode.
Built on 16:15:52 10/01/14


SETUP_SUPPORT_PLATFORM_LANG_VAR in the AMITSE SDL TOKENS

Variable : SETUP_SUPPORT_PLATFORM_LANG_VAR

Description:
Set to enable PlatformLang and PlatformLangCode Vars.
Built on 16:15:52 10/01/14


SETUP_SUPPORT_RES_ADD_DEL_BOOT_OPTION_NAME in the AMITSE SDL TOKENS

Variable : SETUP_SUPPORT_RES_ADD_DEL_BOOT_OPTION_NAME

Description:
Not to allow Reserved Names (RESERVED_ADD_DEL_BOOT_OPTION_NAME) for new Boot Options. Reserved names defined in RESERVED_ADD_DEL_BOOT_OPTION_NAME SDL token.
Built on 16:15:52 10/01/14


SETUP_TIMEOUT_IN_TENTHOFSEC in the AMITSE SDL TOKENS

Variable : SETUP_TIMEOUT_IN_TENTHOFSEC

Description:
Maks the Setup Timout value as 1/10 Sec to support fast boot. Makesure to change the Vfr and Strings if this is ON.
Built on 16:15:52 10/01/14


SETUP_TOGGLE_KEY_SCANCODE in the AMITSE SDL TOKENS

Variable : SETUP_TOGGLE_KEY_SCANCODE

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol.
Built on 16:15:52 10/01/14


SETUP_TOGGLE_KEY_UNICODE in the AMITSE SDL TOKENS

Variable : SETUP_TOGGLE_KEY_UNICODE

Description:
Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'.
Built on 16:15:52 10/01/14


SETUP_UPDATE_BOOT_ORDER_CURSOR in the AMITSE SDL TOKENS

Variable : SETUP_UPDATE_BOOT_ORDER_CURSOR

Description:
When the boot order is changed, the cursor moves with the selection. Else, the cursor remains in the same location as the current question.
Built on 16:15:52 10/01/14


SETUP_USE_AMI_DEFAULTS in the AMITSE SDL TOKENS

Variable : SETUP_USE_AMI_DEFAULTS

Description:
Use AMIBCP compatible defaults instead of HII defaults
Built on 16:15:52 10/01/14


SETUP_USER_PASSWORD_POLICY in the AMITSE SDL TOKENS

Variable : SETUP_USER_PASSWORD_POLICY

Description:
Allow to use system with Admin password set and User password NOT set (Boot Password policy)
Built on 16:15:52 10/01/14


SHELL_TEXT_MODE in the AMITSE SDL TOKENS

Variable : SHELL_TEXT_MODE

Description:
Assign the GC_MODE while boot to SHELL.\0xFF = ignored, 0/1/2/.. = GC_MODE0/GC_MODE1/GC_MODE2/..
Built on 16:15:52 10/01/14


SHOW_FORMSETS_WITH_CLASSGUID in the AMITSE SDL TOKENS

Variable : SHOW_FORMSETS_WITH_CLASSGUID

Description:
1 is DEFAULT.1 => To display formset based on ClassGUID add formsetClassGUID in elink AMITSE_FILTER_CLASSGUID_FORMSETS(By default this elink has EFI_HII_PLATFORM_SETUP_FORMSET_GUID). 0 => To display all formset and no filter in formsets.
Built on 16:15:52 10/01/14


SINGLE_CLICK_ACTIVATION in the AMITSE SDL TOKENS

Variable : SINGLE_CLICK_ACTIVATION

Description:
On- Single click will be used to enter the subMenu and Select the option. OFF- Double Click will be used.
Built on 16:15:52 10/01/14


STYLE_DATE_FORMAT in the AMITSE SDL TOKENS

Variable : STYLE_DATE_FORMAT

Description:
Controls the Date Format. (Default 0 => mm/dd/yyyy) (1 => yyyy/dd/mm)
Built on 16:15:52 10/01/14


STYLE_HELP_AREA_SCROLLBAR in the AMITSE SDL TOKENS

Variable : STYLE_HELP_AREA_SCROLLBAR

Description:
Support Scrollable Help Text.
Built on 16:15:52 10/01/14


STYLE_SHOW_DAY in the AMITSE SDL TOKENS

Variable : STYLE_SHOW_DAY

Description:
Controls the display of Day in Date Format.
Built on 16:15:52 10/01/14


SUPPORT_ESRT in the AMITSE SDL TOKENS

Variable : SUPPORT_ESRT

Description:
Enable to support ESRT.
Built on 16:15:52 10/01/14


SUPPRESS_HANDLE_FOR_VAR_CREATION in the AMITSE SDL TOKENS

Variable : SUPPRESS_HANDLE_FOR_VAR_CREATION

Description:
0 is DEFAULT.0 => Includes handle comparison to create new variable cache in TSE. 1 => Won't compare handle to create new variable. The variable detail should present in AMITSE_DYNAMICPARSING_HANDLE_SUPPRESS_LIST to not compare handle.
Built on 16:15:52 10/01/14


SUPPRESS_PRINT in the AMITSE SDL TOKENS

Variable : SUPPRESS_PRINT

Description:
A switch to supress TSE Debug messages.
Built on 16:15:52 10/01/14


TSE_ADMIN_PASSWORD in the AMITSE SDL TOKENS

Variable : TSE_ADMIN_PASSWORD

Description:
Defaultly no password is given. Provide data to set as default admin password. Maximum string can be provide is based on SETUP_PASSWORD_LENGTH token. String should be atleat minimum length mentioned in vfr. If no password is given it will not set any default password. Note: specify EMPTY_DATA in value if default admin password is not required.
Built on 16:15:52 10/01/14


TSE_ANSI_ESC_CODE_SUPPORT in the AMITSE SDL TOKENS

Variable : TSE_ANSI_ESC_CODE_SUPPORT

Description:
Tse advanced Esc colour support
Built on 16:15:52 10/01/14


TSE_APTIO_5_SUPPORT in the AMITSE SDL TOKENS

Variable : TSE_APTIO_5_SUPPORT

Description:
Turn on to to build under Aptio 5.
Built on 16:15:52 10/01/14


TSE_BEST_TEXT_GOP_MODE in the AMITSE SDL TOKENS

Variable : TSE_BEST_TEXT_GOP_MODE

Description:
0 is DEFAULT.1 => To save and restore text(100*31) and GOP(800*600) mode before using any TSE Interfaces in Post/after TSE. 0 => Not to    ;	handle text and GOP mode before using any TSE interfaces in Post/after TSE and use Post mode without any change.
Built on 16:15:52 10/01/14


TSE_BOOT_NOW_IN_BOOT_ORDER in the AMITSE SDL TOKENS

Variable : TSE_BOOT_NOW_IN_BOOT_ORDER

Description:
Turn on to see boot override menu with in the devices listed in boot order.
Built on 16:15:52 10/01/14


TSE_BOOT_ONLY_SPLASH_LOGO_SUPPORT in the AMITSE SDL TOKENS

Variable : TSE_BOOT_ONLY_SPLASH_LOGO_SUPPORT

Description:
Turn on the TSE to make boot only driver without UI
Built on 16:15:52 10/01/14


TSE_BOOT_TIME_OUT_AS_ZERO in the AMITSE SDL TOKENS

Variable : TSE_BOOT_TIME_OUT_AS_ZERO

Description:
1=>Provides Boot time out value as zero 0=> Reads from the NVRAM, defaultly it is disabled.
Built on 16:15:52 10/01/14


TSE_CALLBACK_SPEC_VERSION in the AMITSE SDL TOKENS

Variable : TSE_CALLBACK_SPEC_VERSION

Description:
Version to change the callback functionality.
Built on 16:15:52 10/01/14


TSE_CAPITAL_BOOT_OPTION in the AMITSE SDL TOKENS

Variable : TSE_CAPITAL_BOOT_OPTION

Description:
This Token Stores/Creates the Boot Option numbers to Capital Hex Numbers.
Built on 16:15:52 10/01/14


TSE_CLEAR_USERPW_WITH_ADMINPW in the AMITSE SDL TOKENS

Variable : TSE_CLEAR_USERPW_WITH_ADMINPW

Description:
Support to clear the User password if Admin password is empty
Built on 16:15:52 10/01/14


TSE_CONTINUE_BOOT_NOW_ON_FAIL in the AMITSE SDL TOKENS

Variable : TSE_CONTINUE_BOOT_NOW_ON_FAIL

Description:
Turn on to continue boot to other device when selected one fails.
Built on 16:15:52 10/01/14


TSE_CSM_SUPPORT in the AMITSE SDL TOKENS

Variable : TSE_CSM_SUPPORT

Description:
Include CSM Support in TSE
Built on 16:15:52 10/01/14


TSE_CURSOR_SUPPORT in the AMITSE SDL TOKENS

Variable : TSE_CURSOR_SUPPORT

Description:
Token to display cursor for string, password type controls.ENABLE is default.1=>To display cursor in TSE.0=>Not to display cursor in TSE.
Built on 16:15:52 10/01/14


TSE_DBG_DISABLE_APPDESTRUCTOR in the AMITSE SDL TOKENS

Variable : TSE_DBG_DISABLE_APPDESTRUCTOR

Description:
0 => Free the TSE used memory. 1 => Won't free the TSE used memory, may be used only for debugging purposes. CAUTION: If making the token to 1 then TSE won't free the memory it used. We recommend not to make it enable..
Built on 16:15:52 10/01/14


TSE_DEBUG_MESSAGES in the AMITSE SDL TOKENS

Variable : TSE_DEBUG_MESSAGES

Description:
A switch to enable TSE Debug messages: Bit0: Uefi functions, Bit1: HiiCallbacks, Bit2: HiiNotifications, Bit3: HiiParsing.
Built on 16:15:52 10/01/14


TSE_DEFAULT_SETUP_PASSWORD_SUPPORT in the AMITSE SDL TOKENS

Variable : TSE_DEFAULT_SETUP_PASSWORD_SUPPORT

Description:
0 is default.set 1=> to Enable default setup password.
Built on 16:15:52 10/01/14


TSE_DEVICE_PATH_NAME in the AMITSE SDL TOKENS

Variable : TSE_DEVICE_PATH_NAME

Description:
Turn on to be able to configure name for legacy devices.
Built on 16:15:52 10/01/14


TSE_DEVICE_PATH_UEFI_NAME in the AMITSE SDL TOKENS

Variable : TSE_DEVICE_PATH_UEFI_NAME

Description:
Turn on to be able to configure name for UEFI devices using Device path.
Built on 16:15:52 10/01/14


TSE_DONOT_LOAD_PASSWORD_ON_DEFAULTS in the AMITSE SDL TOKENS

Variable : TSE_DONOT_LOAD_PASSWORD_ON_DEFAULTS

Description:
1 => Will not load defaults for password when we press F3. 0 => Load default passowrd.
Built on 16:15:52 10/01/14


TSE_DONOT_LOAD_SYSTEM_ACCESS_FOR_USER_DEFAULT in the AMITSE SDL TOKENS

Variable : TSE_DONOT_LOAD_SYSTEM_ACCESS_FOR_USER_DEFAULT

Description:
0 is DEFAULT.1 => To enable to not to load SystemAccess variable on pressing Restore User Default. 0=> To load SystemAccess variable on pressing Restore User Default
Built on 16:15:52 10/01/14


TSE_FOR_64BIT in the AMITSE SDL TOKENS

Variable : TSE_FOR_64BIT

Description:
Enable build support for 64 bit(x64/IA64) TSE
Built on 16:15:52 10/01/14


TSE_HASH_PASSWORD in the AMITSE SDL TOKENS

Variable : TSE_HASH_PASSWORD

Description:
0 is Default. 1 => To encode the entered password using hash algorithm. 0 => Encode entered password using TSE logic.
Built on 16:15:52 10/01/14


TSE_HOOKBASE_VALUE in the AMITSE SDL TOKENS

Variable : TSE_HOOKBASE_VALUE

Description:
Base value for the HOOK defines that Allows to manage TSE HOOKs.Format 0xXXXX0000,Makeure it is not conflicts physical memory Address
Built on 16:15:53 10/01/14


TSE_IGNORE_KEY_FOR_FASTBOOT in the AMITSE SDL TOKENS

Variable : TSE_IGNORE_KEY_FOR_FASTBOOT

Description:
DISABLE is default. 1=> To ignore check for key when FastBoot is enabled. 0=> Allow check for key when FastBoot is enabled.
Built on 16:15:53 10/01/14


TSE_LOAD_DEFAULTS_FROM_DEFAULTS_BUFFER in the AMITSE SDL TOKENS

Variable : TSE_LOAD_DEFAULTS_FROM_DEFAULTS_BUFFER

Description:
0 => Will not load defaults from Default buffer(NVRAM.bin) on pressing F3. 1 => Will Load default from the default buffer.
Built on 16:15:53 10/01/14


TSE_LOAD_OPTION_HIDDEN in the AMITSE SDL TOKENS

Variable : TSE_LOAD_OPTION_HIDDEN

Description:
1 => Hide LOAD_OPTION_HIDDEN Boot option. 0 => Shows all boot options.
Built on 16:15:53 10/01/14


TSE_LOAD_PASSWORD_ON_DEFAULTS in the AMITSE SDL TOKENS

Variable : TSE_LOAD_PASSWORD_ON_DEFAULTS

Description:
Loads the User/Admin password from Defaults.If Off, Passwords are unaffected while loading defaults
Built on 16:15:53 10/01/14


TSE_MAX_DRIVE_NAME in the AMITSE SDL TOKENS

Variable : TSE_MAX_DRIVE_NAME

Description:
Set the value to dispaly number of characters for Drive name.
Built on 16:15:53 10/01/14


TSE_MULTILINE_CONTROLS in the AMITSE SDL TOKENS

Variable : TSE_MULTILINE_CONTROLS

Description:
Turns on multi line controls. Currently subtitle and static text controls are supported. Default is DISABLE.
Built on 16:15:53 10/01/14


TSE_NVRAM_DEFAULTS_SUPPORT in the AMITSE SDL TOKENS

Variable : TSE_NVRAM_DEFAULTS_SUPPORT

Description:
To enable NVRAM support in TSE modules. This token requires TSE Sources support.
Built on 16:15:53 10/01/14


TSE_OEM_POSTLOGO_SUPPORT in the AMITSE SDL TOKENS

Variable : TSE_OEM_POSTLOGO_SUPPORT

Description:
Enable to support OEMLogo image in postscreen.
Built on 16:15:53 10/01/14


TSE_POSTSCREEN_SCROLL_AREA in the AMITSE SDL TOKENS

Variable : TSE_POSTSCREEN_SCROLL_AREA

Description:
{TopRow, TopCol, BottomRow, BottomCol}. Used to Configure the TSE PostScreen Scroll Area. Note Post message are still printed in whole Screen.
Built on 16:15:53 10/01/14


TSE_PRESERVE_DISABLED_BBS_DEVICE_ORDER in the AMITSE SDL TOKENS

Variable : TSE_PRESERVE_DISABLED_BBS_DEVICE_ORDER

Description:
Prevents TSE from repositioning disabled BBS boot in the boot order.
Built on 16:15:53 10/01/14


TSE_PRN_SCRN_EVENT_SUPPORT in the AMITSE SDL TOKENS

Variable : TSE_PRN_SCRN_EVENT_SUPPORT

Description:
Turn on to generate Print screen event if TSE_PRN_SCRN_KEY_SCAN key pressed.
Built on 16:15:53 10/01/14


TSE_ROMHOLE_HEADER_GUID in the AMITSE SDL TOKENS

Variable : TSE_ROMHOLE_HEADER_GUID

Description:
One among 16-GUID used to identify ROMHOLE by AMI utilities such as AFU, BCP, and MMTool. This value should sync with TSE_ROMHOLE_MAKFILE_GUID token value.
Built on 16:15:53 10/01/14


TSE_ROMHOLE_MAKFILE_GUID in the AMITSE SDL TOKENS

Variable : TSE_ROMHOLE_MAKFILE_GUID

Description:
One among 16-GUID used to identify ROMHOLE by AMI utilities such as AFU, BCP, and MMTool. If TSE_ROMHOLE_MAKFILE_GUID token value is changed then TSE_ROMHOLE_HEADER_GUID token value should update.
Built on 16:15:53 10/01/14


TSE_ROMHOLE_SUPPORT in the AMITSE SDL TOKENS

Variable : TSE_ROMHOLE_SUPPORT

Description:
TEnable to support ROMHOLE generation.
Built on 16:15:53 10/01/14


TSE_SAVE_DISABLED_BBS_DEVICEPATH in the AMITSE SDL TOKENS

Variable : TSE_SAVE_DISABLED_BBS_DEVICEPATH

Description:
1 => Saves the DevicePaths of Disabled BBS devices to NVRAM Variable. \Depends on that varaible to keep device disbaled in next boot. \0 => Doesn't save the Disabled BBS devicepath.
Built on 16:15:53 10/01/14


TSE_SETUP_GRAYOUT_SELECTABLE in the AMITSE SDL TOKENS

Variable : TSE_SETUP_GRAYOUT_SELECTABLE

Description:
0 is DEFAULT. set 1=> to allow grayed-out options set focus and to be selectable by the user. Set 0=> to make grayed-out options not to focus ;   and editable
Built on 16:15:53 10/01/14


TSE_SHOW_PROMPT_STRING_AS_TITLE in the AMITSE SDL TOKENS

Variable : TSE_SHOW_PROMPT_STRING_AS_TITLE

Description:
0 is DEFAULT.1 => To use password control's prompt's string  for Password Title. 0 => To use standard TSE string for Password Title.
Built on 16:15:53 10/01/14


TSE_SUPPORT_DEFAULT_FOR_STRING_CONTROL in the AMITSE SDL TOKENS

Variable : TSE_SUPPORT_DEFAULT_FOR_STRING_CONTROL

Description:
0 is DEFAULT. 1 => To construct optimal and failsafe defaults for STRING type controls based on CONTROLPtr from controlInfo.0 => Not to
construct and load optimal and failsafe defaults for STRING type controls.
Built on 16:15:53 10/01/14


TSE_SUPPORT_NATIVE_RESOLUTION in the AMITSE SDL TOKENS

Variable : TSE_SUPPORT_NATIVE_RESOLUTION

Description:
Sets the graphics mode for quiet boot from EDID. 1 - Defaultly enable make 0 to disable the feature.
Built on 16:15:53 10/01/14


TSE_SUPPRESS_MULTILINE_FOR_ONEOFLABEL in the AMITSE SDL TOKENS

Variable : TSE_SUPPRESS_MULTILINE_FOR_ONEOFLABEL

Description:
1=> is to suppress multiline support for one of option . 0=> is to support multiline for one of option which is defalut behaviour.
Built on 16:15:53 10/01/14


TSE_USE_AMI_EFI_KEYCODE_PROTOCOL in the AMITSE SDL TOKENS

Variable : TSE_USE_AMI_EFI_KEYCODE_PROTOCOL

Description:
AMIKeyCode Protocol support. TSE Sources need to be present to enable this token.
Built on 16:15:53 10/01/14


TSE_USE_GETGYLPH_PRINTLENGH in the AMITSE SDL TOKENS

Variable : TSE_USE_GETGYLPH_PRINTLENGH

Description:
Turn on to to build under Aptio 5.
Built on 16:15:53 10/01/14


TSE_USE_OEM_ACTION_READ_KEY in the AMITSE SDL TOKENS

Variable : TSE_USE_OEM_ACTION_READ_KEY

Description:
If user likes to read the key in their own way then enable this token and define _OemActionReadKey function.
Built on 16:15:53 10/01/14


TSE_USER_PASSWORD in the AMITSE SDL TOKENS

Variable : TSE_USER_PASSWORD

Description:
Defaultly no password is given. Provide data to set as default user password. Maximum string can be provide is based on SETUP_PASSWORD_LENGTH token. String should be minimum length mentioned in vfr. If no password is given it will not set any default password. Note: specify EMPTY_DATA in value if default user password is not required.
Built on 16:15:53 10/01/14


WIDE_GLYPH_SUPPORT in the AMITSE SDL TOKENS

Variable : WIDE_GLYPH_SUPPORT

Description:
Far east language support
Built on 16:15:53 10/01/14


AMITSE.mak

Description:
AMI TSE BIN module makefile for Aptio.
Built on 16:15:53 10/01/14


Aptio Modules

Description:
"Core\Core.cif"= "SS: Alaska;$/Alaska/BIN/Core;4.6.4.0"
"Build.cif"= "SS: Alaska;$/Alaska/BIN/Core;4.6.4.0"
"Include\Include.cif"= "SS: Alaska;$/Alaska/BIN/Core\Include;4.6.4.0"
"Include\PPI\PPI.cif"= "SS: Alaska;$/Alaska/BIN/Core\Include/PPI;4.6.4.0"
"Include\Protocol\Protocol.cif"= "SS: Alaska;$/Alaska/BIN/Core\Include/Protocol;4.6.4.0"
"Library\Library.cif"= "SS: Alaska;$/Alaska/BIN/Core\Library;4.6.4.0"
"Core\CORE_PEI\CORE_PEI.cif"= "SS: Alaska;$/Alaska/BIN/Core\CORE_PEI;4.6.4.0"
"Core\CORE_DXE\CORE_DXE.cif"= "SS: Alaska;$/Alaska/BIN/Core\CORE_DXE;4.6.4.0"
"Include\Protocol\ArchProtocol.cif"= "SS: Alaska;$/Alaska/BIN/Core\CORE_DXE/ArchProtocol;4.6.4.0"
"Core\EM\Runtime\Runtime.cif"= "SS: Alaska;$/Alaska/BIN/Core\Runtime;4.6.4.0"
"Core\EM\IdeBus\IdeBus.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/IdeBus;4.6.4.0"
"Include\Protocol\PIDEBus.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/IdeBus;4.6.4.0"
"Core\EM\Recovery\Recovery.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/Recovery;4.6.4.0"
"Core\EM\Recovery\ReFlash\ReFlash.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/Recovery;4.6.4.0"
"Include\PPI\RecoveryPpi.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/Recovery;4.6.4.0"
"Core\CPU\IA32\IA32Core.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/IA32Core;4.6.4.0"
"Core\CPU\x64\x64Core.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/x64Core;4.6.4.0"
"Core\EM\PCI\PciBus.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/PciBus;4640_PCIBUSBIN_24_0_TEST"
"Include\PciBusIncludes.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/PciBus;4640_PCIBUSBIN_24_0_TEST"
"Core\EM\BoardInfo\AMIBoardInfo.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/BoardInfo;4640_AMI_BOARD_1.0.0"
"Include\AmiBoardInfoIncludes.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/BoardInfo;4640_AMI_BOARD_1.0.0"
"Core\CoreSrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Core;4.6.4.0"
"Library\LibSrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Library;4.6.4.0"
"Library\AmiLib.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Library;4.6.4.0"
"Library\AmiPeiLib.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Library;4.6.4.0"
"Library\AmiDxeLib.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Library;4.6.4.0"
"Core\CPU\IA32\AmiIa32Lib.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Modules/IA32Core;4.6.4.0"
"Core\CPU\x64\AmiX64Lib.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Modules/x64Core;4.6.4.0"
"Core\em\Runtime\RuntimeSrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Runtime;4.6.4.0"
"Core\em\IdeBus\IdeBusSrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Modules/IdeBus;4.6.4.0"
"Core\EM\FloppyCtrl\FloppyCtrl.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\CORE_DXE/FloppyCtrl;4.6.4.0"
"Core\EM\FileSystem\FileSystem.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Modules/FileSystem;4.6.4.0"
"Core\EM\Recovery\RecoverySrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Modules/Recovery;4.6.4.0"
"Core\Foundation.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\EDK;4.6.4.0"
"Core\CORE_PEI\CORE_PEISrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\EDK/PeiMain;4.6.4.0"
"Core\CORE_DXE\CORE_DXESrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\EDK/DxeMain;4.6.4.0"
"Core\CORE_DXE\ConSplitter\ConSplitter.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\CORE_DXE/ConSplitter;4.6.4.0"
"Core\CORE_DXE\Partition\Partition.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\CORE_DXE/Partition;4.6.4.0"
"Core\EM\PS2CTL\PS2Ctl.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\CORE_DXE/PS2CTL;4.6.4.0"
"Core\CORE_DXE\FrameworkHii\FrameworkHii.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\CORE_DXE/FrameworkHii;4.6.4.0"
"Core\CORE_DXE\UefiHii\UefiHii.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\CORE_DXE/UefiHii;4.6.4.0"
"Core\CPU\IA32\FoundationIa32.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\EDK/IA32;4.6.4.0"
"Core\CPU\x64\Foundationx64.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\EDK/x64;4.6.4.0"
"Core\CPU\IPF\FoundationIPF.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\EDK/IPF;4.6.4.0"
"Core\EM\NVRAM\NVRAM.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Modules/NVRAM;4.6.4.0"
"Core\EM\PCI\PciBusSrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Modules/PciBus;4640_PCIBUSSRC_24_0_TEST"
"Board\IO\W83627DHG\W83627DHG.CIF"= "SS: Alaska;$/Alaska/BIN/IO/Winbond/W83627DHG;4.6.3.5_IO_W83627DHG.A3"
"Board\EM\W83627DHGSetup\CallbackLib\Callback.cif"= "SS: Alaska;$/Alaska/BIN/IO/Winbond/W83627DHG;4.6.3.5_IO_W83627DHG.A3"
"Board\Flash\Flash.cif"= "SS: Alaska;$/Alaska/SOURCE/Flash_Combined_2/Core;4.6.3_Flash_Combined_2_20"
"Board\Flash\FWH\FwhFlash.cif"= "SS: Alaska;$/Alaska/SOURCE/Flash_Combined_2/Core\FWH;4.6.3_Flash_Combined_2_20"
"Board\Flash\LPC\LpcFlash.cif"= "SS: Alaska;$/Alaska/SOURCE/Flash_Combined_2/Core\LPC;4.6.3_Flash_Combined_2_20"
"Board\Flash\STD\StdFlash.cif"= "SS: Alaska;$/Alaska/SOURCE/Flash_Combined_2/Core\STD;4.6.3_Flash_Combined_2_20"
"Board\Flash\SPI\SpiFlash.cif"= "SS: Alaska;$/Alaska/SOURCE/Flash_Combined_2/Core\SPI;4.6.3_Flash_Combined_2_20"
"Board\Flash\SPI\Template\SpiCspSrc.cif"= "SS: ALASKA;$/Alaska/SOURCE/Flash_Combined_2\Core/SPI/Template;4.6.3_Flash_Combined_2_20"
"Include\FlashPart.cif"= "SS: Alaska;$/Alaska/SOURCE/Flash_Combined_2/Core;4.6.3_Flash_Combined_2_20"
"Board\Cpu\Specific\CpuSp.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Model/Gainestown;4.6.3_GAINESTOWN_4"
"Board\CPU\CPU.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Nehalem;4.6.3_INTEL_Nehalem_28"
"Board\CPU\CPUBSP.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Nehalem;4.6.3_INTEL_Nehalem_28"
"Core\CPU\CPUCore.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Nehalem;4.6.3_INTEL_Nehalem_29"
"Include\CPU Hobs.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Nehalem;4.6.3_INTEL_Nehalem_29"
"Include\ppi\CpuPPIs.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Nehalem;4.6.3_INTEL_Nehalem_29"
"Include\Protocol\CpuProtocols.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Nehalem;4.6.3_INTEL_Nehalem_29"
"Core\CPU\MicrocodeUpdate\MicrocodeUpdate.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Nehalem;4.6.3_INTEL_Nehalem_29"
"Core\Cpu\CpuTools.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Nehalem;4.6.3_INTEL_Nehalem_29"
"Chipset\NB\NB.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/NorthBridge/Havendale_Lynnfield;4.6.3_Intel_HVD_LFD_033"
"Board\NB\NBBOARD.CIF"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/NorthBridge/Havendale_Lynnfield\Board;4.6.3_Intel_HVD_LFD_033"
"Chipset\NB\NBCSP.CIF"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/NorthBridge/Havendale_Lynnfield\Chipset;4.6.3_Intel_HVD_LFD_033"
"INCLUDE\Protocol\NBProtocols.CIF"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/NorthBridge/Havendale_Lynnfield\Chipset/Protocols;4.6.3_Intel_HVD_LFD_033"
"INCLUDE\PPI\NBPPI.CIF"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/NorthBridge/Havendale_Lynnfield\Chipset/PPI;4.6.3_Intel_HVD_LFD_033"
"Chipset\NB\RC_LFD\LFDRefCodeInit.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/NorthBridge/Havendale_Lynnfield\Chipset/RC_LFD;4.6.3_Intel_HVD_LFD_033"
"Chipset\NB\RC_HVD\HVDRefCodeInit.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/NorthBridge/Havendale_Lynnfield\Chipset/RC_HVD;4.6.3_Intel_HVD_LFD_033"
"Chipset\NB\StdLib\std.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/NorthBridge/Havendale_Lynnfield\Chipset/StdLib;4.6.3_Intel_HVD_LFD_033"
"Chipset\SB\SB.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/SouthBridge/IbexPeak;4.6.3_Intel_IbexPeak_045"
"Board\SB\SBBOARD.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/SouthBridge/IbexPeak\Board;4.6.3_Intel_IbexPeak_045"
"Chipset\SB\SBCSP.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/SouthBridge/IbexPeak\Chipset;4.6.3_Intel_IbexPeak_045"
"INCLUDE\PPI\SBPPI.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/SouthBridge/IbexPeak\Chipset/PPI;4.6.3_Intel_IbexPeak_045"
"INCLUDE\Protocol\SBProtocols.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/SouthBridge/IbexPeak\Chipset/Protocols;4.6.3_Intel_IbexPeak_045"
"Chipset\SB\SmmChildDispatcher.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/SouthBridge/IbexPeak\Chipset/SmmChildDispatcher;4.6.3_Intel_IbexPeak_045"
"Chipset\SB\AcpiModeEnable.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/SouthBridge/IbexPeak\Chipset/AcpiModeEnable;4.6.3_Intel_IbexPeak_045"
"Core\em\Ahci\AhciSrc.cif"= "SS: ALASKA;$/Alaska/SOURCE/Modules/AHCI;4.6.3_AhciSrc_015"
"Core\eM\Ahci\Aint13.cif"= "SS: ALASKA;$/Alaska/SOURCE/Modules/AHCI\INT13;4.6.3_AhciSrc_015"
"Include\Aint13Protocol.cif"= "SS: ALASKA;$/Alaska/SOURCE/Modules/AHCI\INT13;4.6.3_AhciSrc_015"
"Addon\ahcibin.cif"= "SS: ALASKA;$/Alaska/SOURCE/Modules/AHCI\INT13/16-bit Binary;4.6.3_AhciSrc_015"
"Chipset\eM\Ahci\AhciCsp.cif"= "SS: ALASKA;$/Alaska/SOURCE/Modules/AHCI\INT13/CSP;4.6.3_AhciSrc_015"
"Chipset\eM\Ahci\AhciAccess.cif"= "SS: ALASKA;$/Alaska/SOURCE/Modules/AHCI;4.6.3_AhciSrc_015"
"CORE\EM\Ahci\AhciSmm\AhciSmm.cif"= "SS: ALASKA;$/Alaska/SOURCE/Modules/AHCI\AhciSmm;4.6.3_AhciSrc_015"
"INCLUDE\Protocol\AhciSmmProtocols.CIF"= "SS: ALASKA;$/Alaska/SOURCE/Modules/AHCI\AhciSmm;4.6.3_AhciSrc_015"
"BOARD\EM\ACPI\ACPI.cif"= "SS: Alaska;$/Alaska/BIN/Modules/ACPI/Template;4.6.4.0_ACPI_40"
"BOARD\EM\ACPI\ACPIBSP.CIF"= "SS: Alaska;$/Alaska/BIN/Modules/ACPI/Template\Board;4.6.4.0_ACPI_40"
"BOARD\EM\ACPI\ASLBSP.CIF"= "SS: Alaska;$/Alaska/BIN/Modules/ACPI/Template\Board;4.6.4.0_ACPI_40"
"Core\EM\ACPI\ACPICORE.CIF"= "SS: Alaska;$/Alaska/BIN/Modules/ACPI/Template\Core;4.6.4.0_ACPI_40"
"CORE\EM\ACPI\ASLCORE.CIF"= "SS: Alaska;$/Alaska/BIN/Modules/ACPI/Template\Core;4.6.4.0_ACPI_40"
"Board\eM\Csm\csm.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic;4.6.3.1_CSM.7.62_71"
"Core\EM\CSM\csmcore.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Core;4.6.3.1_CSM.7.62_71"
"core\em\csm\thunk\thunk.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Thunk;4.6.3.1_CSM.7.62_71"
"core\em\csm\thunk\x86\x86thunk.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Thunk/x86;4.6.3.1_CSM.7.62_71"
"core\em\csm\thunk\BlockIo\int13thunk.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Thunk/INT13;4.6.3.1_CSM.7.62_71"
"core\em\csm\thunk\Snp16\snp16.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Thunk/SNP16;4.6.3.1_CSM.7.62_71"
"Core\EM\CSM\Thunk\CsmVideo\CsmVideo.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Thunk/CsmVideo;4.6.3.1_CSM.7.62_71"
"Board\eM\Csm\csmoem.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\OEM Hooks;4.6.3.1_CSM.7.62_71"
"Addon\csm16.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\CSM16;4.6.3.1_CSM.7.62_71"
"Chipset\SB\CSM\csmsb.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Chipset/SouthBridge;4.6.3.1_CSM.7.62_71"
"Chipset\SB\CSM\LegacyInterrupt\LegacyInterrupt.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Chipset/SouthBridge;4.6.3.1_CSM.7.62_71"
"Chipset\NB\CSM\LegacyRegion\LegacyRegion.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Chipset/NorthBridge;4.6.3.1_CSM.7.62_71"
"include\CsmProtocols.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic;4.6.3.1_CSM.7.62_71"
"board\em\csm\csmsetup.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic;4.6.3.1_CSM.7.62_71"
"Core\EM\FastBoot\FastBoot.cif"= "SS: AlaskaVss;$/Alaska/SOURCE/Modules/FastBoot;(INT)4.6.4.0_Fast_Boot_08"
"Include\Protocol\FastBootProtocol.cif"= "SS: AlaskaVss;$/Alaska/SOURCE/Modules/FastBoot;(INT)4.6.4.0_Fast_Boot_08"
"Board\CPU\Microcode\Microcode.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/IntelMicrocode;4.6.0_INTEL_MICROCODE_12"
"Board\CPU\Microcode\DESKTOP\Desktop.CIF"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/IntelMicrocode\Desktop Processor Microcode Patch;4.6.0_INTEL_MICROCODE_12"
"Board\CPU\Microcode\VALUE\Value.CIF"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/IntelMicrocode\P4 Value CPU uCode Patches;4.6.0_INTEL_MICROCODE_12"
"Board\CPU\Microcode\ServWork\ServWork.CIF"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/IntelMicrocode\ServWork Processor Microcode Patch;4.6.0_INTEL_MICROCODE_12"
"Board\CPU\Microcode\MOBILE\Mobile.CIF"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/IntelMicrocode\P4 Mobile CPU uCode Patches;4.6.0_INTEL_MICROCODE_12"
"CORE\EM\SMIFlash\SMIFlash.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMIFlash;4.6.3.6_SMIFLASH_14"
"INCLUDE\Protocol\SMIFlashProtocols.CIF"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMIFlash;4.6.3.6_SMIFLASH_14"
"Core\EM\SMM\SMM.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMM;4.6.3_SMM_40"
"Core\EM\SMM\SmmDispatcher.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMM\SMMDispatcher;4.6.3_SMM_40"
"Core\EM\SMM\SmmBase.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMM\SMMBase;4.6.3_SMM_40"
"Include\Protocol\SmmProtocols.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMM;4.6.3_SMM_40"
"Chipset\SB\PowerButton.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMM\PowerButton;4.6.3_SMM_40"
"Core\EM\StatusCode\StatusCode.cif"= "SS: Alaska;$/Alaska/BIN/Modules/StatusCode;4.6.3_StatusCode_15"
"Core\em\UsbRecovery\UsbRecovery.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery;4.6.3_USB_RECOVERY_SRC_17"
"core\em\UsbRecovery\UhciPeiUsb\UhciPeiUsb.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery;4.6.3_USB_RECOVERY_SRC_17"
"INCLUDE\PPI\UhciPPI.CIF"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery;4.6.3_USB_RECOVERY_SRC_17"
"core\em\UsbRecovery\OhciPEI\OhciPei.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery;4.6.3_USB_RECOVERY_SRC_17"
"INCLUDE\PPI\OHCIPPI.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery;4.6.3_USB_RECOVERY_SRC_17"
"core\em\UsbRecovery\EhciPEI\EhciPei.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery;4.6.3_USB_RECOVERY_SRC_17"
"Core\em\UsbRecovery\UhcPeimSrc\UhcPeimSrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery\UhcPeimSrc;4.6.3_USB_RECOVERY_SRC_17"
"Include\Ppi\UsbHCPpi.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery\UhcPeimSrc;4.6.3_USB_RECOVERY_SRC_17"
"Core\EM\UsbRecovery\UsbPeimSrc\UsbPeimSrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery\UsbPeimSrc;4.6.3_USB_RECOVERY_SRC_17"
"Include\Ppi\UsbIoPpi.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery\UsbPeimSrc;4.6.3_USB_RECOVERY_SRC_17"
"Core\em\UsbRecovery\UsbBotPeimSrc\UsbBotPeim.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery\UsbBotPeimSrc;4.6.3_USB_RECOVERY_SRC_17"
"AddOn\Shell.cif"= "SS: ALASKA;$/Alaska/BIN/Modules/Shell;4.6.3_SHELL_20091214_00 "
"Core\EM\Capsule\Capsule.cif"= "SS: ALASKA;$/Alaska/SOURCE/Modules/Capsule;4.5.6_Capsule_04"
"board\em\usb\amiusb.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA;4.06.03_USB_08.09.00"
"core\em\usb\rt\usbrt.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA\RT;4.06.03_USB_08.09.00"
"core\em\usb\uhcd.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA;4.06.03_USB_08.09.00"
"core\em\usb\framework.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA;4.06.03_USB_08.09.00"
"include\AmiUSBProtocols.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA;4.06.03_USB_08.09.00"
"core\em\usb\setup\usbsetup.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA\Setup;4.06.03_USB_08.09.00"
"chipset\sb\usb\usbsb.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/Chipset/SouthBridge/Intel/IbexPeak_Desktop/;4.6.3.2_USB_IBEXPEAK_DT_00"
"Core\eM\USB\int13\UsbInt13.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA\Int13;4.06.03_USBI13_02"
"Addon\usbi13bin.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA\Int13;4.06.03_USBI13_02"
"Include\Protocol\emul6064Protocols.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA\EMUL6064;4.06.03_USB_08.09.00"
"Board\EM\SMBIOS\SMBIOSBoard.CIF"= "SS: Alaska;$/Alaska/BIN/Modules/SMBIOS;4.6.1_ALPHA_01.25"
"Include\Protocol\SMBIOSProto.CIF"= "SS: Alaska;$/Alaska/BIN/Modules/SMBIOS\SmbiosProtocol;4.6.1_ALPHA_01.25"
"Board\EM\SMBIOS\SMBiosStaticData\SmbiosStaticData.cif"= "SS: Alaska;$/Alaska/BIN/Modules/SMBIOS\SmbiosStaticData;4.6.1_ALPHA_01.25"
"Board\EM\SMBIOS\SmbiosDMIEdit\SmbiosDMIEditBoard.cif"= "SS: Alaska;$/Alaska/BIN/Modules/SMBIOS\SmbiosDMIEdit;4.6.1_ALPHA_01.25"
"Chipset\EM\IgdOpRegion\IgdOpRegion.cif"= "SS: Alaska;$/Alaska/Projects/Intel/Piketon/Havendale&Lynnfield_IbexPeak_1AEIQ/Chipset/EM/IgdOpRegion;4.6.3.7_VEB_1AEIQ018"
"Core\EM\SMBIOS\SMBIOSCore.CIF"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMBIOS;4.6.1_ALPHA_01.25"
"Core\EM\SMBios\SmbiosDMIEditSupport\SmbiosDMIEdit.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMBIOS\SmbiosDMIEditSupport;4.6.1_ALPHA_01.25"
"Core\EM\SMBios\SmbiosGetFlashData\SmbiosGetFlashData.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMBIOS\SmbiosGetFlashData;4.6.1_ALPHA_01.25"
"Core\EM\SMBios\SmbiosFlashData\SmbiosFlashData.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMBIOS\SmbiosFlashData;4.6.1_ALPHA_01.25"
"Board\Flash\SPI\SpiCspSrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Flash_Combined_2/CSP_SPI/Intel/ICHx;4.6.3_SPI-Intel-ICHx_05"
"Board\Board.cif"= "SS: Alaska;$/Alaska/BIN/Board;4.6.4.0_Board_24"
"Board\em\Setup\Setup.cif"= "SS: Alaska;$/Alaska/BIN/Board\Setup;4.6.4.0_Board_24"
"CRB\CRBoard.cif"= "SS: ALASKA;$/Alaska/Projects/Intel/Piketon/Havendale&Lynnfield_IbexPeak_1AEIQ\CRB;4.6.3.7_VEB_1AEIQ016"
"Core\CSPLib\CspLib.CIF"= "SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary;4.6.4.0_CSPLibrary_012"
"Include\CSPLibInc.CIF"= "SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary;4.6.4.0_CSPLibrary_012"
"Include\Protocol\CspLibProtocols.CIF"= "SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary;4.6.4.0_CSPLibrary_012"
"INCLUDE\PPI\CspLibPPI.CIF"= "SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary;4.6.4.0_CSPLibrary_012"
Built on 16:15:53 10/01/14


boot.h

Description:
UEFI Boot related header

The following functions are used in the file: boot.h.

Function | Description
EFI_LEGACY_BIOS_BOOT | Boots a traditional OS
EFI_LEGACY_BIOS_GET_BBS_INFO | Presents BBS information to external agents.

The following data structures are used in the file: boot.h.

Variable | Description
BBS_STATUS_FLAGS |
BBS_TABLE |
EFI_LEGACY_BIOS_PROTOCOL | Abstracts the traditional BIOS from the rest of EFI. The LegacyBoot() member function allows the BDS to support booting a traditional OS. EFI thunks drivers that make EFI bindings for BIOS INT services use all the other member functions.
HDD_INFO |

Built on 16:15:53 10/01/14


BBS_STATUS_FLAGS in the boot.h

Variable : BBS_STATUS_FLAGS

File: boot.h
Fields:

OldPosition | UINT16 | :4 Prior priority.
Reserved1 | UINT16 | :4 Reserved for future use.
Enabled | UINT16 | :1 If 0, ignore this entry.
Failed | UINT16 | :1 0-Not known if boot failure occurred; 1-Boot attempt failed.
MediaPresent | UINT16 | :2 State of media present, see notes.
Reserved2 | UINT16 | :4 Reserved for future use.

Notes:
MediaPresent field details:
00 = No bootable media is present in the device.
01 = Unknown if a bootable media present.
10 = Media is present and appears bootable.
11 = Reserved.
Built on 16:15:50 10/01/14


BBS_TABLE in the boot.h

Variable : BBS_TABLE

File: boot.h
Fields:

BootPriority | UINT16 | The boot priority for this boot device.
Bus | UINT32 | The PCI bus for this boot device.
Device | UINT32 | The PCI device for this boot device.
Function | UINT32 | The PCI function for the boot device.
Class | UINT8 | The PCI class for this boot device..
SubClass | UINT8 | The PCI Subclass for this boot device.
MfgString | UINT32 | Segment:offset address of an ASCIIZ description.
DeviceType | UINT16 | BBS device type.
StatusFlags | BBS_STATUS_FLAGS | Status of this boot device.
BootHandler | UINT32 | Segment:Offset address of boot loader for IPL devices.
DescString | UINT32 | Segment:offset address of an ASCIIZ description string.
InitPerReserved | UINT32 | Reserved.
AdditionalIrq | Handler | UINT32 See notes for details.
AssignedDriveNumber | UINT8 | The drive number(0x80 -0x8?) assigned by the 16-bit code.
IBV1 | UINT32 | IBV specific field.
IBV2 | UINT32 | IBV specific field.

Notes:
The use of AdditionalIrq??Handler fields is IBV dependent. They can be
used to flag that an OpROM has hooked the specified IRQ. The OpROM
may be BBS compliant as some SCSI BBS-compliant OpROMs also hook IRQ
vectors in order to run their BIOS Setup.
Built on 16:15:50 10/01/14


EFI_LEGACY_BIOS_BOOT in the boot.h

Function : EFI_LEGACY_BIOS_BOOT

File: boot.h
Description:
Boots a traditional OS
Input:
This            Indicates the EFI_LEGACY_BIOS_PROTOCOL instance.
BootOption      The EFI device path from BootXXXX variable.
LoadOptionSize  Size of LoadOption.
LoadOption      The load option from BootXXXX variable.
Output:
EFI_DEVICE_ERROR    Failed to boot from any boot device and
memory is uncorrupted.
Notes:
This function normally never returns. It will either boot the OS
or reset the system if memory has been "corrupted" by loading a
boot sector and passing control to it.
Built on 16:15:50 10/01/14


EFI_LEGACY_BIOS_GET_BBS_INFO in the boot.h

Function : EFI_LEGACY_BIOS_GET_BBS_INFO

File: boot.h
Description:
Presents BBS information to external agents.
Input:
This        Indicates the EFI_LEGACY_BIOS_PROTOCOL instance.
HddCount    Number of HDD_INFO structures.
HddInfo     Onboard IDE controller information.
BbsCount    Number of BBS_TABLE structures.
BbsTable    BBS entry.
Output:
EFI_SUCCESS
Built on 16:15:50 10/01/14


EFI_LEGACY_BIOS_PROTOCOL in the boot.h

Variable : EFI_LEGACY_BIOS_PROTOCOL

File: boot.h
Description:
Abstracts the traditional BIOS from the rest of EFI. The
LegacyBoot() member function allows the BDS to support booting
a traditional OS. EFI thunks drivers that make EFI bindings for
BIOS INT services use all the other member functions.
Built on 16:15:50 10/01/14


HDD_INFO in the boot.h

Variable : HDD_INFO

File: boot.h
Fields:

Status | UINT16 | Status of IDE device. See Notes for details.
Bus | UINT32 | PCI bus of IDE controller.
Device | UINT32 | PCI device of IDE controller.
Function | UINT32 | PCI function of IDE controller.
CommandBaseAddress | UINT16 | Command ports base address.
ControlBaseAddress | UINT16 | Control ports base address.
BusMasterAddress | UINT16 | Bus master address.
IdentifyDrive | ATAPI_IDENTIFY | Data that identifies the drive data.

Notes:
The values for the Status field are the following:
HDD_PRIMARY              0x01
HDD_SECONDARY            0x02
HDD_MASTER_ATAPI         0x04
HDD_SLAVE_ATAPI          0x08
HDD_MASTER_IDE           0x20
HDD_SLAVE_IDE            0x40
HDD_SATA_PATA            0x80
There is one HDD_INFO structure per IDE controller. The IdentifyDrive is
one per drive. Index 0 is master and index 1 is slave.
Built on 16:15:50 10/01/14


bootflow.c

Description:
This file bootflow related functions and tables

The following functions are used in the file: bootflow.c.

Function | Description
BootFlowManageEntry | Determines boot flow entry path based on the boot flow variable.
BootFlowManageExit | Determines boot flow exit path based on the boot flow variable.

Built on 16:15:53 10/01/14


BootFlowManageEntry in the bootflow.c

Function : BootFlowManageEntry

File: bootflow.c
Description:
Determines boot flow entry path based on the boot
flow variable.
Input:
VOID
Output:
EFI_SUCCESS: Normal boot
EFI_UNSUPPORTED: do not proceed to boot
EFI_NOT_STARTED: Do not enter setup
Built on 16:15:50 10/01/14


BootFlowManageExit in the bootflow.c

Function : BootFlowManageExit

File: bootflow.c
Description:
Determines boot flow exit path based on the boot
flow variable.
Input:
VOID
Output:
EFI_UNSUPPORTED: enter setup if all the boot options
fail
EFI_NOT_STARTED: try again and again if all boot
options fail
Built on 16:15:50 10/01/14


bootflow.h

Description:
bootflow header
Built on 16:15:53 10/01/14


CommonHelper.c

Description:
This file is Helper file for Boot only TSE module
        This functions may be overridden by Other Advanced TSE module.

The following functions are used in the file: CommonHelper.c.

Function | Description
AdvancedRepairSupported | Returns the SHOW_DRV_HEALTH_BOOT_TIME_SENDFORM token value
BBSGetNonStandardGroupType | Set OVERRIDE_BBSGetNonStandardGroupType to 1, then add the OEM specific function to override this function to provide a non standard group type for the given Device Type.
BootDevPathMatchEnabled | Checks whether the input device path matches exactly with any of the boot options device path. This will be useful for USB, Floppy....
CheckAdvShiftState | Checks the input shift state with the condition shift state
CheckForAddDelBootOption | Function to return the SETUP_SUPPORT_ADD_BOOT_OPTION token value
CheckForAddDelDriverOption | Function to return the SETUP_SUPPORT_ADD_DRIVER_OPTION token value
CheckIsAllowedPasswordChar | Check is the char allowed for password control based on SDL token.
CleanUpExtendedLogoWrapper | function to clear the logo
ClearNumericShiftState |
ContribBGRTTableToAcpi | Wrapper function to call ConvertBmpandAddBGRT
ConvertBmpToUgaBltWrapper | Wrapper function to process ConvertBmpToUgaBlt functionallity based on SDL token.
ConvertGifToUgaBltWrapper | Wrapper function to process ConvertGifToUgaBlt functionallity based on SDL token.
ConvertJPEGToUgaBltWrapper | Wrapper function to process ConvertJPEGToUgaBlt functionallity based on SDL token.
ConvertOEMFormatToUgaBltWrapper | Wrapper function to process ConvertOEMFormatToUgaBlt functionallity based on SDL token.
ConvertPCXToUgaBltWrapper | Wrapper function to process ConvertPCXToUgaBlt functionallity based on SDL token.
ConvertPNGToUgaBltWrapper | Wrapper function to process ConvertPNGToUgaBlt functionallity based on SDL token.
DefaultSetupPwdAtFirstBootOnly | Returns token value DEFAULT_SETUP_PWD_AT_FIRSTBOOT_ONLY
DoLogoAnimateWrapper | function to Handle logo animation
DrawPostLogoAt0Pos | Retrurns DRAW_POST_LOGO_AT_0POS token value Parameter: VOID Return value: BOOLEAN
DriverHealthSystemReset | Board module hook for DriverHealthSystemReset function
EDKVersion_1_05_RetrieveData | Returns the EDK_1_05_RETRIEVE_DATA token value
FBBootFlow |
FindDevPathTotLength | Find the length of the complete device path
FixMergePagesExtraHook | Set OVERRIDE_FixMergePagesExtraHook to 1, if OEM wants to override the UIUpdateCallbackHook function from Board module.
FlushKeysAfterRead | Returns value of disable FLUSH_KEYS_AFTER_READ
FramePasswordAdvancedCallback | This function to handle password callback inside setup
GetACPIOEMID | Returns the ACPI OEM ID
GetACPIOEMRevision | Returns the ACPI OEM Revision
GetACPIOEMTableID | Returns the ACPI OEM Table ID
GetactualScreentop | function to get the actual screen top value for mouse
GetFormSetTitleAndHelp | GetFormSetTitleAndHelp Parameter: EFI_HII_HANDLE Handle, EFI_STRING_ID *Title, EFI_STRING_ID *Help Return value: status
GetGraphicsBitMapFromFV | Return the graphics image file named FileNameGuid into Image and return it's size in ImageSize. All Firmware Volumes (FV) in the system are searched for the file name.
GetMsgboxWidth | Returns the message box width
GetNotifyMaskValue | Retrurns notify mask vaule
GetPasswordPopupTextBoxColor | Function to Get PasswordPopupTextBox Color
GetPasswordPopupWindowColor | Function to Get PasswordPopupWindow Color
GetPasswordReportInboxcolor | Function to Get PasswordReportInBox Color
GetTseBuildVersion | Function to fill the TSE build information
GetTseBuildYear | Function to fill the TSE build Year
GetUEFISpecVersion | Returns the Specification version assigned to TSE_CALLBACK_SPEC_VERSION
GOPScreenResolution | Hook function to set GOPScreen Resolution.
gotoExitOnEscKey | Returns value of disable SETUP_GO_TO_EXIT_PAGE_ON_EXIT_KEY
InvalidateStatusInBgrtWrapper | Wrapper function to call InvalidateStatusInBgrt
IsANSIEscapeCodeSupported | Returns token value TSE_ANSI_ESC_CODE_SUPPORT
IsBGRTSupported | Retrurns CONTRIB_BGRT_TABLE_TO_ACPI token value
IsBootOptionsGroupingEnabled | Returns the value for grouping the boot options
IsBootOverrideBootNextSupport | Function to return BOOT_OVERRIDE_BOOTNEXT_VARIABLE_FEATURE value Parameter: VOID Return value: BOOLEAN
IsBootTimeOutValueZero | function to return TSE_BOOT_TIME_OUT_AS_ZERO value
IsDelayLogoTillInputSupported | Retrurns SETUP_DELAY_LOGO_TILL_INPUT token value
IsDisableESCinBBSMenu | Returns token DISABLE_ESC_IN_BBS value
IsDriverHealthSupported | Retrurns DRIVER_HEALTH_SUPPORT token value
IsGrayoutSelectable | Returns token value TSE_SETUP_GRAYOUT_SELECTABLE
IsHelpAreaScrollBarSupport | Returns value as enable or disable STYLE_HELP_AREA_SCROLLBAR support
IsLoadSysteAccessOnUserDefault | Returns token value TSE_DONOT_LOAD_SYSTEM_ACCESS_FOR_USER_DEFAULT
IsMouseOnSoftkbd | Function to return whether MousePointer is on softkbd or not
IsOEMPOSTLogoSupport | To Return OEMLogo Draw Support token value
IsSetupHideBiosSignOnMsg | Returns the value for hiding the bios signon msg
IsShowPromptStringAsTitle | Returns token value TSE_SHOW_PROMPT_STRING_AS_TITLE
IsSupportDefaultForStringControl | Returns TSE_SUPPORT_DEFAULT_FOR_STRING_CONTROL token value
IsTseBestTextGOPModeSupported | Returns token TSE_BEST_TEXT_GOP_MODE value
IsTSECursorSupport | Function to return TSE_CURSOR_SUPPORT token value
IsTSEMultilineControlSupported | Retrurns TSE_MULTILINE_CONTROLS token value
LaunchHotKeyBootOption | Board module hook for LaunchHotKeyBootOption function
LaunchSecBootPathFromEnabledDevs | Launches default image from the path \EFI\BOOT\BOOT{machine type short-name}.EFI from the enabled devices in setup.
LaunchSecondaryPath | Launches default image from the path \EFI\BOOT\BOOT{machine type short-name}.EFI
LegacyBootFailHook | Board module hook for LegacyBootFailHook function This function invoked when LoadImage fails
LoadDefaultsFromDefaultBuffer | Wrapper function to provide TSE_LOAD_DEFAULTS_FROM_DEFAULTS_BUFFER
MainSetupLoopHook | Set OVERRIDE_MainSetupLoopHook to 1, if OEM wants to override the MainSetupLoopHook function from Board module.
MainSetupLoopInitHook | Set OVERRIDE_MainSetupLoopInitHook to 1, if OEM wants to override the MainSetupLoopInitHook function from Board module.
MediaDevPathMatchEnabled | Checks whether the input device path matches with any of the boot options media device path. This will be useful for drives with partition.
MouseListBoxScrollBarMove | Function to move scrollbar in ListBox using mouse Parameter: VOID *, BOOLEAN, UINT32 Return value: status
MouseScrollBarMove | Function to move scrollbar in Frame using mouse Parameter: VOID *, BOOLEAN, UINT32 Return value: status
OemCheckControlCondition | Set OVERRIDE_OEMCheckControlCondition to 1, if OEM wants to override the OemCheckControlCondition function from Board module.
OEMSpecialGetControlCount | OEM Hook Function can allows exploding into multiple controls. Based on the OEM policies it returns number controls need to exploded.
OEMSpecialGotoFixup | If the OEM Special control is Submenu Control. Based on the OEMSpecialGetControlCount The submenus are added with same promt/help. If OEM want to Fix the prompt and help fields of the submenu control. It can be done here. For each submenu of that OEM special control it is called.
OEMSpecialGotoSelect | Hook for OEM Goto control Action Handler. On Selection of the OEM Goto control it is called.
OEMSpecialOneOfFixup | If the OEM Special control is One of Control the members of the one of control Can be fixed up in this function. If OEM needs multiple control, for each one of it will be called. This function has to create dynamic IFR Oneof Options
OEMSpecialUpdateOneOf | Hook to update the OEM Variable based on Selection. TSE updates the varible buffer in the normal way (updates with option value selected) If any OEM Special updatation required OEM may use this function and return EFI_SUCCESS.
OsUpdateCapsuleWrap | Dispalys the image obtained form OS Update and calls the capsule to update
PageRemoveHook | Set OVERRIDE_PageRemoveHook to 1, if OEM wants to override the PageRemoveHook function from Board module.
PISpecVersion | Returns PI_SPECIFICATION_VERSION value
PrintableKeysSoftKbdExit | function to exit PrintableKeysSoftKbd and reset with default keyboard layout
PrintableKeysSoftKbdInit | function to launch PrintableKeysSoftKbd layout
PrntScrnKeyHandleactionWrapper | Wrapper function to call PrntScrnKeyHandleaction
ProcessBrowserActionRequestHook | Set OVERRIDE_ProcessBrowserActionRequestHook to 1, if OEM wants to override the ProcessBrowserActionRequestHook function from Board module.
ProcessPackNotificationHook | Set OVERRIDE_ProcessPackNotificationHook to 1, if OEM wants to override the ProcessPackNotificationHook function from Board module.
ResetPwdKeyboardLayout | function to exit ResetKeyboardLayout and reset with default keyboard layout
RTIfrProcessAddVarListAndPageIDListWrapper | Wrapper function to add runtime variable and Pages based on SDL token.
RTIfrProcessExitWrapper | Wrapper function to process the RuntimeParsing Exit functionallity based on SDL token.
RTIfrProcessFormIfUpdatedWrapper | Wrapper function to include RTIfrProcessFormIfUpdated based on SDL token.
RTIfrProcessRunTimeFormsWrapper | Wrapper function to process runtime Ifrs based on SDL token.
RTIfrRegFormNotificationWrapper | Wrapper function for RegFormNotification
RTIfrUnRegFormNotificationWrapper | Wrapper function for UnRegFormNotification
RTIfrUpdateVariableInfoWrapper | Wrapper function to include RTIfrUpdateVariableInfo based on SDL token.
SetPwdKeyboardLayout | function to initialize SetKeyboardLayout
ShellTextMode | Returns type of shell text mode
SingleClickActivation | Returns the SINGLE_CLICK_ACTIVATION token value
StyleGetMessageboxColorHook | Hook function to set Messagebox Color.
TseDebugDisableApplicationDestructor | Returns token value TSE_DBG_DISABLE_APPDESTRUCTOR
TseDefaultSetupPasswordSupported | Returns token value TSE_DEFAULT_SETUP_PASSWORD_SUPPORT
TSEDonotLoadPasswordOnDefaults | Returns the token value for TSE_DONOT_LOAD_PASSWORD_ON_DEFAULTS
TSEIDEPasswordAuthenticate | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TSEIDEPasswordCheck | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TSEIDEPasswordFreezeDevices | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TSEIDEPasswordGetDataPtr | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TSEIDEPasswordGetLocked | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TSEIDEPasswordGetName | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TSEIDEPasswordUpdate | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TSEIDEUpdateConfig | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TseIgnoreKeyForFastBoot | Function to return FastBoot is ENABLED or DISABLED Parameter: VOID Return value: BOOLEAN
TseLaunchFileSystem | This function to handle launching file system
TSEMouseDestroyHook | Hook function which is called when Mouse Destory is done.
TSEMouseIgnoreMouseActionHook | Hook function which can make TSE to Ignore the mouse action. This function is called whenever TSE read the mouse action This hook need to be used carefully. It can used in the cases when Mouse actions consumes by modules like Softkeyboard and not to be used by TSE
TSEMouseInitHook | Hook function which is called when Mouse init is done.
TSEMouseRefreshHook | Hook function which is called when Mouse Refresh action is done.
TSEMouseStartHook | Hook function which is called when Mouse start action is done.
TSEMouseStopHook | Hook function which is called when Mouse Stop is done.
TsePrintScreenSupport | Function to return print screen support feature
TSEPwdSavetoNvram | Returns the token value for SETUP_SAVE_PSWD_TO_NVRAM
TseRtAccessSupport | Returns token RT_ACCESS_SUPPORT_IN_HPKTOOL value
TSESetHDDPassword | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TSEStringReadLoopEntryHook | Hook function which is called when Strings/Password is going to be read.
TSEStringReadLoopExitHook | Hook function which is called after Strings/Password read.
TseSuppressOneofMultilineSupport | Function to return TSE_SUPPRESS_MULTILINE_FOR_ONEOFLABEL value Parameter: VOID Return value: BOOLEAN
TSEUnlockHDD | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
UefiBootFailHook | Board module hook for UefiBootFailHook function This function invoked when LoadImage fails
UIUpdateCallbackHook | Set OVERRIDE_UIUpdateCallbackHook to 1, if OEM wants to override the UIUpdateCallbackHook function from Board module.
UninstallBgrtWrapper | Wrapper function to call UninstallBgrtWrapper
UpdateNumericDisplayString | Board module hook for UpdateNumericDisplayString function This function invoked before displaying the numeric control Can use this function to change the display style of numeric control

Built on 16:15:53 10/01/14


AdvancedRepairSupported in the CommonHelper.c

Function : AdvancedRepairSupported

File: CommonHelper.c
Description:
Returns the SHOW_DRV_HEALTH_BOOT_TIME_SENDFORM token value
Input:
VOID
Output:
BOOLEAN
Built on 16:15:50 10/01/14


BBSGetNonStandardGroupType in the CommonHelper.c

Function : BBSGetNonStandardGroupType

File: CommonHelper.c
Description:
Set OVERRIDE_BBSGetNonStandardGroupType to 1, then add the OEM
specific function to override this function to provide a non standard
group type for the given Device Type.
Input:
BBS Device Type
Output:
String Token
Built on 16:15:50 10/01/14


BootDevPathMatchEnabled in the CommonHelper.c

Function : BootDevPathMatchEnabled

File: CommonHelper.c
Description:
Checks whether the input device path matches exactly with any of the boot options
                device path. This will be useful for USB, Floppy....
Input:
EFI_DEVICE_PATH_PROTOCOL *
Output:
BOOLEAN - TRUE - Device path matched and the corresponding boot option is enabled
                             FALSE - Device path matched and the corresponding boot option is disbled
Built on 16:15:50 10/01/14


CheckAdvShiftState in the CommonHelper.c

Function : CheckAdvShiftState

File: CommonHelper.c
Description:
Checks the input shift state with the condition shift state
Input:
UINT32 = Key shift state obtained from console input devices
UINT32 = Shift state condition to match with input key shift state
Output:
BOOLEAN = TRUE => When input and condition shift states matches
         FALSE => When input and condition shift states not matches
Built on 16:15:50 10/01/14


CheckForAddDelBootOption in the CommonHelper.c

Function : CheckForAddDelBootOption

File: CommonHelper.c
Description:
Function to return the SETUP_SUPPORT_ADD_BOOT_OPTION token value
Input:
None
Output:
BOOLEAN
Built on 16:15:50 10/01/14


CheckForAddDelDriverOption in the CommonHelper.c

Function : CheckForAddDelDriverOption

File: CommonHelper.c
Description:
Function to return the SETUP_SUPPORT_ADD_DRIVER_OPTION token value
Input:
None
Output:
BOOLEAN
Built on 16:15:50 10/01/14


CheckIsAllowedPasswordChar in the CommonHelper.c

Function : CheckIsAllowedPasswordChar

File: CommonHelper.c
Description:
Check is the char allowed for password control
based on SDL token.
Input:
Input character
Output:
Bool
Built on 16:15:50 10/01/14


CleanUpExtendedLogoWrapper in the CommonHelper.c

Function : CleanUpExtendedLogoWrapper

File: CommonHelper.c
Description:
function to clear the logo
Input:
None
Output:
None
Built on 16:15:50 10/01/14


ClearNumericShiftState in the CommonHelper.c

Function : ClearNumericShiftState

File: CommonHelper.c
Description:
Input:
VOID*
Output:

Built on 16:15:50 10/01/14


ContribBGRTTableToAcpi in the CommonHelper.c

Function : ContribBGRTTableToAcpi

File: CommonHelper.c
Description:
Wrapper function to call ConvertBmpandAddBGRT
Input:
BOOLEAN
Output:
VOID
Built on 16:15:50 10/01/14


ConvertBmpToUgaBltWrapper in the CommonHelper.c

Function : ConvertBmpToUgaBltWrapper

File: CommonHelper.c
Description:
Wrapper function to process ConvertBmpToUgaBlt
functionallity based on SDL token.
Input:
BmpImage      - Pointer to BMP file
            BmpImageSize  - Number of bytes in BmpImage
            UgaBlt        - Buffer containing UGA version of BmpImage.
            UgaBltSize    - Size of UgaBlt in bytes.
            PixelHeight   - Height of UgaBlt/BmpImage in pixels
            PixelWidth    - Width of UgaBlt/BmpImage in pixels
Output:
EFI_SUCCESS           - UgaBlt and UgaBltSize are returned.
            EFI_UNSUPPORTED       - BmpImage is not a valid *.BMP image
            EFI_BUFFER_TOO_SMALL  - The passed in UgaBlt buffer is not big enough.
       UgaBltSize will contain the required size.
            EFI_OUT_OF_RESOURCES  - No enough buffer to allocate
Built on 16:15:50 10/01/14


ConvertGifToUgaBltWrapper in the CommonHelper.c

Function : ConvertGifToUgaBltWrapper

File: CommonHelper.c
Description:
Wrapper function to process ConvertGifToUgaBlt
functionallity based on SDL token.
Input:
GifImage      - Pointer to GIF file
            GifImageSize  - Number of bytes in BmpImage
            UgaBlt        - Buffer containing UGA version of GifImage.
            UgaBltSize    - Size of UgaBlt in bytes.
            PixelHeight   - Height of UgaBlt/BmpImage in pixels
            PixelWidth    - Width of UgaBlt/BmpImage in pixels
            GifDelay      -
Output:
EFI_SUCCESS - UgaBlt and UgaBltSize are returned.
            EFI_UNSUPPORTED       - GifImage is not a valid *.GIF image
            EFI_BUFFER_TOO_SMALL  - The passed in UgaBlt buffer is not big enough.
           UgaBltSize will contain the required size.
            EFI_OUT_OF_RESOURCES  - No enough buffer to allocate
Built on 16:15:50 10/01/14


ConvertJPEGToUgaBltWrapper in the CommonHelper.c

Function : ConvertJPEGToUgaBltWrapper

File: CommonHelper.c
Description:
Wrapper function to process ConvertJPEGToUgaBlt
functionallity based on SDL token.
Input:
IN VOID *JPEGImage - Pointer to the memory that has the
                                 JPEG Image that need to be decoded.
            IN UINT32 JPEGImageSize - Size of the JPEG Image
            IN OUT VOID **UgaBlt - Two cases
                Case 1: Memory is expected to be allocated by the callee.
                        Address provided as input should be NULL.
                        pointer that will recieve the address of the UGA buffer.
                        The buffer is allocated by callee.
                        This buffer need to be freed by the caller.
                Case 2: Memory is allocated by the caller
            IN OUT UINT32 *UgaBltSize - Pointer that stores Size of UgaBlt
                in bytes. This will be treated as an input. This should have
                value ZERO for Case 2 above.
            OUT UINT32 *PixelHeight - Height of UgaBlt/JPEG Image in pixels
            OUT UINT32 *PixelWidth - Width of UgaBlt/JPEG Image in pixels
            OUT UINT32 *pun32BufferWidth - Width of UgaBlt/JPEG Buffer
Output:
EFI_SUCCESS	- The image was successfully decoded and placed in the buffer
            EFI_UNSUPPORTED
            EFI_BUFFER_TOO_SMALL
            EFI_OUT_OF_RESOURCES
Built on 16:15:50 10/01/14


ConvertOEMFormatToUgaBltWrapper in the CommonHelper.c

Function : ConvertOEMFormatToUgaBltWrapper

File: CommonHelper.c
Description:
Wrapper function to process ConvertOEMFormatToUgaBlt
functionallity based on SDL token.
Input:
OEMImage      - Pointer to GIF file
            OEMImageSize  	- Number of bytes in BmpImage
            UgaBlt        	- Buffer containing UGA version of GifImage.
            UgaBltSize	- Size of UgaBlt in bytes.
            Height   	- Height of UgaBlt/BmpImage in pixels
            Width    	- Width of UgaBlt/BmpImage in pixels
            Animate		-
Output:
EFI_SUCCESS - UgaBlt and UgaBltSize are returned.
            EFI_UNSUPPORTED       - GifImage is not a valid *.GIF image
            EFI_BUFFER_TOO_SMALL  - The passed in UgaBlt buffer is not big enough.
                   UgaBltSize will contain the required size.
            EFI_OUT_OF_RESOURCES  - No enough buffer to allocate
Built on 16:15:50 10/01/14


ConvertPCXToUgaBltWrapper in the CommonHelper.c

Function : ConvertPCXToUgaBltWrapper

File: CommonHelper.c
Description:
Wrapper function to process ConvertPCXToUgaBlt
functionallity based on SDL token.
Input:
VOID *PCXImage - Pointer to the memory that has the PCX
                Image that need to be decoded.
            UINT32 PCXImageSize - Size of the PCX Image
            OUT VOID **UgaBlt - Two cases
                Case 1: Memory is expected to be allocated by the callee.
                    Address provided as input should be NULL.
                    pointer that will receive the address of the UGA buffer.
                    The buffer is allocated by callee.
                    This buffer need to be freed by the caller.
                Case 2: Memory is allocated by the caller
            OUT UINT32 *UgaBltSize - Pointer that stores Size of UgaBlt in bytes.
                This will be treated as an input. This should have value ZERO for Case 2 above.
            UINT32 *PixelHeight - Height of UgaBlt/PCX Image in pixels
            UINT32 *PixelWidth - Width of UgaBlt/PCX Image in pixels
Output:
EFI_STATUS
Built on 16:15:50 10/01/14


ConvertPNGToUgaBltWrapper in the CommonHelper.c

Function : ConvertPNGToUgaBltWrapper

File: CommonHelper.c
Description:
Wrapper function to process ConvertPNGToUgaBlt
functionallity based on SDL token.
Input:
VOID *PNGImage - Pointer to the memory that has the PNG
                Image that need to be decoded.
            UINT32 PNGImageSize - Size of the PNG Image
            OUT VOID **UgaBlt - Two cases
                Case 1: Memory is expected to be allocated by the callee.
                    Address provided as input should be NULL.
                    pointer that will receive the address of the UGA buffer.
                    The buffer is allocated by callee.
                    This buffer need to be freed by the caller.
                Case 2: Memory is allocated by the caller
            OUT UINT32 *UgaBltSize - Pointer that stores Size of UgaBlt in bytes.
                This will be treated as an input. This should have value ZERO for Case 2 above.
            UINT32 *PixelHeight - Height of UgaBlt/PNG Image in pixels
            UINT32 *PixelWidth - Width of UgaBlt/PNG Image in pixels
Output:
EFI_STATUS
Built on 16:15:50 10/01/14


DefaultSetupPwdAtFirstBootOnly in the CommonHelper.c

Function : DefaultSetupPwdAtFirstBootOnly

File: CommonHelper.c
Description:
Returns token value DEFAULT_SETUP_PWD_AT_FIRSTBOOT_ONLY
Input:
VOID
Output:
BOOLEAN
Built on 16:15:50 10/01/14


DoLogoAnimateWrapper in the CommonHelper.c

Function : DoLogoAnimateWrapper

File: CommonHelper.c
Description:
function to Handle logo animation
Input:
CO_ORD_ATTRIBUTE Attribute,
        INTN CoordinateX,INTN CoordinateY
Output:
None
Built on 16:15:50 10/01/14


DrawPostLogoAt0Pos in the CommonHelper.c

Function : DrawPostLogoAt0Pos

File: CommonHelper.c
Description:
Retrurns DRAW_POST_LOGO_AT_0POS token value

Parameter:   VOID

Return value: BOOLEAN
Built on 16:15:50 10/01/14


DriverHealthSystemReset in the CommonHelper.c

Function : DriverHealthSystemReset

File: CommonHelper.c
Description:
Board module hook for DriverHealthSystemReset function
Input:
VOID
Output:
VOID
Built on 16:15:50 10/01/14


EDKVersion_1_05_RetrieveData in the CommonHelper.c

Function : EDKVersion_1_05_RetrieveData

File: CommonHelper.c
Description:
Returns the EDK_1_05_RETRIEVE_DATA token value
Input:
VOID
Output:
BOOLEAN
Built on 16:15:50 10/01/14


FBBootFlow in the CommonHelper.c

Function : FBBootFlow

File: CommonHelper.c
Description:
Input:
BOOT_FLOW *
Output:
EFI_STATUS
Built on 16:15:50 10/01/14


FindDevPathTotLength in the CommonHelper.c

Function : FindDevPathTotLength

File: CommonHelper.c
Description:
Find the length of the complete device path
Input:
EFI_DEVICE_PATH_PROTOCOL *
Output:
UINTN
Built on 16:15:50 10/01/14


FixMergePagesExtraHook in the CommonHelper.c

Function : FixMergePagesExtraHook

File: CommonHelper.c
Description:
Set OVERRIDE_FixMergePagesExtraHook to 1, if OEM wants to override the UIUpdateCallbackHook function from Board module.
Input:
VOID
Output:
EFI_STATUS
Built on 16:15:50 10/01/14


FlushKeysAfterRead in the CommonHelper.c

Function : FlushKeysAfterRead

File: CommonHelper.c
Description:
Returns value of disable FLUSH_KEYS_AFTER_READ
Input:
VOID
Output:
BOOLEAN
Built on 16:15:50 10/01/14


FramePasswordAdvancedCallback in the CommonHelper.c

Function : FramePasswordAdvancedCallback

File: CommonHelper.c
Description:
This function to handle password callback inside setup
Input:
VOID*, VOID*
Output:
VOID
Built on 16:15:50 10/01/14


GetACPIOEMID in the CommonHelper.c

Function : GetACPIOEMID

File: CommonHelper.c
Description:
Returns the ACPI OEM ID
Input:
VOID
Output:
UINT8 * => OEM ID String
Built on 16:15:50 10/01/14


GetACPIOEMRevision in the CommonHelper.c

Function : GetACPIOEMRevision

File: CommonHelper.c
Description:
Returns the ACPI OEM Revision
Input:
VOID
Output:
UINT32 => ACPI OEM Revision
Built on 16:15:50 10/01/14


GetACPIOEMTableID in the CommonHelper.c

Function : GetACPIOEMTableID

File: CommonHelper.c
Description:
Returns the ACPI OEM Table ID
Input:
VOID
Output:
UINT8 * => OEM Table ID String
Built on 16:15:50 10/01/14


GetactualScreentop in the CommonHelper.c

Function : GetactualScreentop

File: CommonHelper.c
Description:
function to get the actual screen top value for mouse
Input:
None
Output:
INT32
Built on 16:15:50 10/01/14


GetFormSetTitleAndHelp in the CommonHelper.c

Function : GetFormSetTitleAndHelp

File: CommonHelper.c
Description:
GetFormSetTitleAndHelp

Parameter:   EFI_HII_HANDLE Handle, EFI_STRING_ID *Title, EFI_STRING_ID *Help

Return value: status
Built on 16:15:50 10/01/14


GetGraphicsBitMapFromFV in the CommonHelper.c

Function : GetGraphicsBitMapFromFV

File: CommonHelper.c
Description:
Return the graphics image file named FileNameGuid into Image
            and return it's size in ImageSize. All Firmware Volumes (FV)
            in the system are searched for the file name.
Input:
FileNameGuid  - File Name of graphics file in the FV(s).
            Image         - Pointer to pointer to return graphics image.
                                If NULL, a buffer will be allocated.
            ImageSize     - Size of the graphics Image in bytes. Zero if no image found.
Output:
EFI_SUCCESS          - Image and ImageSize are valid.
            EFI_BUFFER_TOO_SMALL - Image not big enough. ImageSize has required size
            EFI_NOT_FOUND        - FileNameGuid not found
Built on 16:15:50 10/01/14


GetMsgboxWidth in the CommonHelper.c

Function : GetMsgboxWidth

File: CommonHelper.c
Description:
Returns the message box width
Input:
VOID
Output:
UINT32
Built on 16:15:50 10/01/14


GetNotifyMaskValue in the CommonHelper.c

Function : GetNotifyMaskValue

File: CommonHelper.c
Description:
Retrurns notify mask vaule
Input:
VOID
Output:
BOOLEAN
Built on 16:15:50 10/01/14


GetPasswordPopupTextBoxColor in the CommonHelper.c

Function : GetPasswordPopupTextBoxColor

File: CommonHelper.c
Description:
Function to Get PasswordPopupTextBox Color
Input:
VOID
Output:

Built on 16:15:50 10/01/14


GetPasswordPopupWindowColor in the CommonHelper.c

Function : GetPasswordPopupWindowColor

File: CommonHelper.c
Description:
Function to Get PasswordPopupWindow Color
Input:
VOID
Output:

Built on 16:15:50 10/01/14


GetPasswordReportInboxcolor in the CommonHelper.c

Function : GetPasswordReportInboxcolor

File: CommonHelper.c
Description:
Function to Get PasswordReportInBox Color
Input:
VOID
Output:

Built on 16:15:50 10/01/14


GetTseBuildVersion in the CommonHelper.c

Function : GetTseBuildVersion

File: CommonHelper.c
Description:
Function to fill the TSE build information
Input:
UINTN *TseMajor, UINTN *TseMinor, UINTN *TseBuild
Output:
VOID
Built on 16:15:50 10/01/14


GetTseBuildYear in the CommonHelper.c

Function : GetTseBuildYear

File: CommonHelper.c
Description:
Function to fill the TSE build Year
Input:
UINT16 *TseBuildYear
Output:
VOID
Built on 16:15:50 10/01/14


GetUEFISpecVersion in the CommonHelper.c

Function : GetUEFISpecVersion

File: CommonHelper.c
Description:
Returns the Specification version assigned to TSE_CALLBACK_SPEC_VERSION
Input:
VOID
Output:
UINT32 => Callback Version
Built on 16:15:50 10/01/14


GOPScreenResolution in the CommonHelper.c

Function : GOPScreenResolution

File: CommonHelper.c
Description:
Hook function to set GOPScreen Resolution.
Input:
VOID
Output:
VOID
Built on 16:15:50 10/01/14


gotoExitOnEscKey in the CommonHelper.c

Function : gotoExitOnEscKey

File: CommonHelper.c
Description:
Returns value of disable SETUP_GO_TO_EXIT_PAGE_ON_EXIT_KEY
Input:
VOID
Output:
BOOLEAN
Built on 16:15:50 10/01/14


InvalidateStatusInBgrtWrapper in the CommonHelper.c

Function : InvalidateStatusInBgrtWrapper

File: CommonHelper.c
Description:
Wrapper function to call InvalidateStatusInBgrt
Input:
BOOLEAN
Output:
VOID
Built on 16:15:50 10/01/14


IsANSIEscapeCodeSupported in the CommonHelper.c

Function : IsANSIEscapeCodeSupported

File: CommonHelper.c
Description:
Returns token value TSE_ANSI_ESC_CODE_SUPPORT
Input:
VOID
Output:
BOOLEAN
Built on 16:15:50 10/01/14


IsBGRTSupported in the CommonHelper.c

Function : IsBGRTSupported

File: CommonHelper.c
Description:
Retrurns CONTRIB_BGRT_TABLE_TO_ACPI token value
Input:
VOID
Output:
BOOLEAN
Built on 16:15:51 10/01/14


IsBootOptionsGroupingEnabled in the CommonHelper.c

Function : IsBootOptionsGroupingEnabled

File: CommonHelper.c
Description:
Returns the value for grouping the boot options
Input:
void
Output:
UINT8 - Value for grouping boot options
Built on 16:15:51 10/01/14


IsBootOverrideBootNextSupport in the CommonHelper.c

Function : IsBootOverrideBootNextSupport

File: CommonHelper.c
Description:
Function to return BOOT_OVERRIDE_BOOTNEXT_VARIABLE_FEATURE value

Parameter:   VOID

Return value: BOOLEAN
Built on 16:15:51 10/01/14


IsBootTimeOutValueZero in the CommonHelper.c

Function : IsBootTimeOutValueZero

File: CommonHelper.c
Description:
function to return  TSE_BOOT_TIME_OUT_AS_ZERO value
Input:
VOID
Output:
BOOLEAN
Built on 16:15:51 10/01/14


IsDelayLogoTillInputSupported in the CommonHelper.c

Function : IsDelayLogoTillInputSupported

File: CommonHelper.c
Description:
Retrurns SETUP_DELAY_LOGO_TILL_INPUT token value
Input:
VOID
Output:
BOOLEAN
Built on 16:15:51 10/01/14


IsDisableESCinBBSMenu in the CommonHelper.c

Function : IsDisableESCinBBSMenu

File: CommonHelper.c
Description:
Returns token DISABLE_ESC_IN_BBS value
Input:
VOID
Output:
BOOLEAN
Built on 16:15:51 10/01/14


IsDriverHealthSupported in the CommonHelper.c

Function : IsDriverHealthSupported

File: CommonHelper.c
Description:
Retrurns DRIVER_HEALTH_SUPPORT token value
Input:
VOID
Output:
BOOLEAN
Built on 16:15:51 10/01/14


IsGrayoutSelectable in the CommonHelper.c

Function : IsGrayoutSelectable

File: CommonHelper.c
Description:
Returns token value TSE_SETUP_GRAYOUT_SELECTABLE
Input:
VOID
Output:
BOOLEAN
Built on 16:15:51 10/01/14


IsHelpAreaScrollBarSupport in the CommonHelper.c

Function : IsHelpAreaScrollBarSupport

File: CommonHelper.c
Description:
Returns value as enable or disable STYLE_HELP_AREA_SCROLLBAR support
Input:
void
Output:
UINT8 - Value for grouping boot options
Built on 16:15:51 10/01/14


IsLoadSysteAccessOnUserDefault in the CommonHelper.c

Function : IsLoadSysteAccessOnUserDefault

File: CommonHelper.c
Description:
Returns token value TSE_DONOT_LOAD_SYSTEM_ACCESS_FOR_USER_DEFAULT
Input:
VOID
Output:
BOOLEAN
Built on 16:15:51 10/01/14


IsMouseOnSoftkbd in the CommonHelper.c

Function : IsMouseOnSoftkbd

File: CommonHelper.c
Description:
Function to return whether MousePointer is on softkbd or not
Input:
None
Output:
TRUE/FALSE
Built on 16:15:51 10/01/14


IsOEMPOSTLogoSupport in the CommonHelper.c

Function : IsOEMPOSTLogoSupport

File: CommonHelper.c
Description:
To Return OEMLogo Draw Support token value
Input:
VOID
Output:
BOOLEAN
Built on 16:15:51 10/01/14


IsSetupHideBiosSignOnMsg in the CommonHelper.c

Function : IsSetupHideBiosSignOnMsg

File: CommonHelper.c
Description:
Returns the value for hiding the bios signon msg
Input:
void
Output:
UINT8 - Value for hiding bios signon msg
Built on 16:15:51 10/01/14


IsShowPromptStringAsTitle in the CommonHelper.c

Function : IsShowPromptStringAsTitle

File: CommonHelper.c
Description:
Returns token value TSE_SHOW_PROMPT_STRING_AS_TITLE
Input:
VOID
Output:
BOOLEAN
Built on 16:15:51 10/01/14


IsSupportDefaultForStringControl in the CommonHelper.c

Function : IsSupportDefaultForStringControl

File: CommonHelper.c
Description:
Returns TSE_SUPPORT_DEFAULT_FOR_STRING_CONTROL token value
Input:
VOID
Output:
BOOLEAN
Built on 16:15:51 10/01/14


IsTseBestTextGOPModeSupported in the CommonHelper.c

Function : IsTseBestTextGOPModeSupported

File: CommonHelper.c
Description:
Returns token TSE_BEST_TEXT_GOP_MODE value
Input:
VOID
Output:
BOOLEAN
Built on 16:15:51 10/01/14


IsTSECursorSupport in the CommonHelper.c

Function : IsTSECursorSupport

File: CommonHelper.c
Description:
Function to return TSE_CURSOR_SUPPORT token value
Input:
VOID
Output:
BOOLEAN
Built on 16:15:51 10/01/14


IsTSEMultilineControlSupported in the CommonHelper.c

Function : IsTSEMultilineControlSupported

File: CommonHelper.c
Description:
Retrurns TSE_MULTILINE_CONTROLS token value
Input:
VOID
Output:
BOOLEAN
Built on 16:15:51 10/01/14


LaunchHotKeyBootOption in the CommonHelper.c

Function : LaunchHotKeyBootOption

File: CommonHelper.c
Description:
Board module hook for LaunchHotKeyBootOption function
Input:
BOOT_FLOW *
Output:
EFI_STATUS
Built on 16:15:51 10/01/14


LaunchSecBootPathFromEnabledDevs in the CommonHelper.c

Function : LaunchSecBootPathFromEnabledDevs

File: CommonHelper.c
Description:
Launches default image from the path \EFI\BOOT\BOOT{machine type short-name}.EFI
                from the enabled devices in setup.
Input:
CHAR16 *
Output:
EFI_STATUS - EFI_SUCCESS -> If default image loaded successfully
                                 !EFI_SUCCESS -> If default image not loaded successfully
Built on 16:15:51 10/01/14


LaunchSecondaryPath in the CommonHelper.c

Function : LaunchSecondaryPath

File: CommonHelper.c
Description:
Launches default image from the path \EFI\BOOT\BOOT{machine type short-name}.EFI
Input:
CHAR16 *
Output:
EFI_STATUS - EFI_SUCCESS -> If default image loaded successfully
                                 !EFI_SUCCESS -> If default image not loaded successfully
Built on 16:15:51 10/01/14


LegacyBootFailHook in the CommonHelper.c

Function : LegacyBootFailHook

File: CommonHelper.c
Description:
Board module hook for LegacyBootFailHook function
        This function invoked when LoadImage fails
Input:
EFI_STATUS => Status returned from CsmBBSLaunchDevicePath
Output:
VOID
Built on 16:15:51 10/01/14


LoadDefaultsFromDefaultBuffer in the CommonHelper.c

Function : LoadDefaultsFromDefaultBuffer

File: CommonHelper.c
Description:
Wrapper function to provide TSE_LOAD_DEFAULTS_FROM_DEFAULTS_BUFFER
Input:
BOOLEAN
Output:
VOID
Built on 16:15:51 10/01/14


MainSetupLoopHook in the CommonHelper.c

Function : MainSetupLoopHook

File: CommonHelper.c
Description:
Set OVERRIDE_MainSetupLoopHook to 1, if OEM wants to override the MainSetupLoopHook function from Board module.
Input:
VOID
Output:
EFI_STATUS
Built on 16:15:51 10/01/14


MainSetupLoopInitHook in the CommonHelper.c

Function : MainSetupLoopInitHook

File: CommonHelper.c
Description:
Set OVERRIDE_MainSetupLoopInitHook to 1, if OEM wants to override the MainSetupLoopInitHook function from Board module.
Input:
VOID
Output:
VOID
Built on 16:15:51 10/01/14


MediaDevPathMatchEnabled in the CommonHelper.c

Function : MediaDevPathMatchEnabled

File: CommonHelper.c
Description:
Checks whether the input device path matches with any of the boot options
                media device path. This will be useful for drives with partition.
Input:
EFI_DEVICE_PATH_PROTOCOL *
Output:
BOOLEAN - TRUE - Device path matched and the corresponding boot option is enabled
                             FALSE - Device path matched and the corresponding boot option is disbled
Built on 16:15:51 10/01/14


MouseListBoxScrollBarMove in the CommonHelper.c

Function : MouseListBoxScrollBarMove

File: CommonHelper.c
Description:
Function to move scrollbar in ListBox using mouse

Parameter:   VOID *, BOOLEAN, UINT32

Return value: status
Built on 16:15:51 10/01/14


MouseScrollBarMove in the CommonHelper.c

Function : MouseScrollBarMove

File: CommonHelper.c
Description:
Function to move scrollbar in Frame using mouse

Parameter:   VOID *, BOOLEAN, UINT32

Return value: status
Built on 16:15:51 10/01/14


OemCheckControlCondition in the CommonHelper.c

Function : OemCheckControlCondition

File: CommonHelper.c
Description:
Set OVERRIDE_OEMCheckControlCondition to 1, if OEM wants to override the OemCheckControlCondition function from Board module.
Input:
UINT8 FinalCond, CONTROL_INFO *controlInfo
Output:
UINT8
Built on 16:15:51 10/01/14


OEMSpecialGetControlCount in the CommonHelper.c

Function : OEMSpecialGetControlCount

File: CommonHelper.c
Description:
OEM Hook Function can allows exploding into multiple controls.
        Based on the OEM policies it returns number controls need to exploded.
Input:
CONTROL_INFO *controlInfo
Output:
UINT16 Control Count.
Built on 16:15:51 10/01/14


OEMSpecialGotoFixup in the CommonHelper.c

Function : OEMSpecialGotoFixup

File: CommonHelper.c
Description:
If the OEM Special control is Submenu Control. Based on the OEMSpecialGetControlCount
        The submenus are added with same promt/help. If OEM want to Fix the prompt and help fields
        of the submenu control. It can be done here.
        For  each submenu of that OEM special control it is called.
Input:
CONTROL_DATA *ctrlData - Control data.
        UINT16 value - Index of the control that need to be pathched.
Output:
None
Built on 16:15:51 10/01/14


OEMSpecialGotoSelect in the CommonHelper.c

Function : OEMSpecialGotoSelect

File: CommonHelper.c
Description:
Hook for OEM Goto control Action Handler.
        On Selection of the OEM Goto control it is called.
Input:
UINT16 value - Index of the control that is selected
Output:
None
Built on 16:15:51 10/01/14


OEMSpecialOneOfFixup in the CommonHelper.c

Function : OEMSpecialOneOfFixup

File: CommonHelper.c
Description:
If the OEM Special control is One of Control the members of the one of control
        Can be fixed up in this function. If OEM needs multiple control,
        for each one of it will be called.
        This function has to create dynamic IFR Oneof Options
Input:
CONTROL_INFO *control - ControlInfo that need to be patched.
        UINT16 value - Index of the control that need to be pathched.
Output:
NONE
Built on 16:15:51 10/01/14


OEMSpecialUpdateOneOf in the CommonHelper.c

Function : OEMSpecialUpdateOneOf

File: CommonHelper.c
Description:
Hook to update the OEM Variable based on Selection.
        TSE updates the varible buffer in the normal way (updates with option value selected)
        If any OEM Special updatation required OEM may use this function and return EFI_SUCCESS.
Input:
newOption - Option value selected.
        offset 	- Variable offset
        Size 	- size of the variable
        buffer - OutBuffer Allocate and fill this if OEM Updated the buffer. (Return Success)
Output:
EFI_SUCCESS - If OEM Updates the Buffer with OEM policy
        EFI_ERROR (EFI_INVALID_PARAMETER) - Standard TSE Update is enough. No Updates done for OEM
Built on 16:15:51 10/01/14


OsUpdateCapsuleWrap in the CommonHelper.c

Function : OsUpdateCapsuleWrap

File: CommonHelper.c
Description:
Dispalys the image obtained form OS Update and calls the capsule to update
Input:
BOOT_FLOW *
Output:
EFI_STATUS - EFI_SUCCESS -> Capsule update is success
                                 !EFI_SUCCESS -> Fault happenend in capsule update
Built on 16:15:51 10/01/14


PageRemoveHook in the CommonHelper.c

Function : PageRemoveHook

File: CommonHelper.c
Description:
Set OVERRIDE_PageRemoveHook to 1, if OEM wants to override the PageRemoveHook function from Board module.
Input:
VOID
Output:
EFI_STATUS
Built on 16:15:51 10/01/14


PISpecVersion in the CommonHelper.c

Function : PISpecVersion

File: CommonHelper.c
Description:
Returns PI_SPECIFICATION_VERSION value
Input:
VOID
Output:
UINTN
Built on 16:15:52 10/01/14


PrintableKeysSoftKbdExit in the CommonHelper.c

Function : PrintableKeysSoftKbdExit

File: CommonHelper.c
Description:
function to exit PrintableKeysSoftKbd and reset with default keyboard layout
Input:
VOID
Output:
VOID
Built on 16:15:52 10/01/14


PrintableKeysSoftKbdInit in the CommonHelper.c

Function : PrintableKeysSoftKbdInit

File: CommonHelper.c
Description:
function to launch PrintableKeysSoftKbd layout
Input:
VOID
Output:
VOID
Built on 16:15:52 10/01/14


PrntScrnKeyHandleactionWrapper in the CommonHelper.c

Function : PrntScrnKeyHandleactionWrapper

File: CommonHelper.c
Description:
Wrapper function to call PrntScrnKeyHandleaction
Input:
VOID
Output:
BOOLEAN
Built on 16:15:52 10/01/14


ProcessBrowserActionRequestHook in the CommonHelper.c

Function : ProcessBrowserActionRequestHook

File: CommonHelper.c
Description:
Set OVERRIDE_ProcessBrowserActionRequestHook to 1, if OEM wants to override the ProcessBrowserActionRequestHook function from Board module.
Input:
EFI_BROWSER_ACTION_REQUEST ActionReq
Output:
EFI_STATUS
Built on 16:15:52 10/01/14


ProcessPackNotificationHook in the CommonHelper.c

Function : ProcessPackNotificationHook

File: CommonHelper.c
Description:
Set OVERRIDE_ProcessPackNotificationHook to 1, if OEM wants to override the ProcessPackNotificationHook function from Board module.
Input:
VOID
Output:
EFI_STATUS
Built on 16:15:52 10/01/14


ResetPwdKeyboardLayout in the CommonHelper.c

Function : ResetPwdKeyboardLayout

File: CommonHelper.c
Description:
function to exit ResetKeyboardLayout and reset with default keyboard layout
Input:
VOID
Output:
VOID
Built on 16:15:52 10/01/14


RTIfrProcessAddVarListAndPageIDListWrapper in the CommonHelper.c

Function : RTIfrProcessAddVarListAndPageIDListWrapper

File: CommonHelper.c
Description:
Wrapper function to add runtime variable and Pages
based on SDL token.
Input:
none
Output:
none
Built on 16:15:52 10/01/14


RTIfrProcessExitWrapper in the CommonHelper.c

Function : RTIfrProcessExitWrapper

File: CommonHelper.c
Description:
Wrapper function to process the RuntimeParsing Exit
functionallity based on SDL token.
Input:
none
Output:
none
Built on 16:15:52 10/01/14


RTIfrProcessFormIfUpdatedWrapper in the CommonHelper.c

Function : RTIfrProcessFormIfUpdatedWrapper

File: CommonHelper.c
Description:
Wrapper function to include RTIfrProcessFormIfUpdated
based on SDL token.
Input:
Link
Output:
Bool
Built on 16:15:52 10/01/14


RTIfrProcessRunTimeFormsWrapper in the CommonHelper.c

Function : RTIfrProcessRunTimeFormsWrapper

File: CommonHelper.c
Description:
Wrapper function to process runtime Ifrs
based on SDL token.
Input:
Link
Output:
Bool
Built on 16:15:52 10/01/14


RTIfrRegFormNotificationWrapper in the CommonHelper.c

Function : RTIfrRegFormNotificationWrapper

File: CommonHelper.c
Description:
Wrapper function for RegFormNotification
Input:
VOID
Output:
EFI_STATUS
Built on 16:15:52 10/01/14


RTIfrUnRegFormNotificationWrapper in the CommonHelper.c

Function : RTIfrUnRegFormNotificationWrapper

File: CommonHelper.c
Description:
Wrapper function for UnRegFormNotification
Input:
VOID
Output:
VOID
Built on 16:15:52 10/01/14


RTIfrUpdateVariableInfoWrapper in the CommonHelper.c

Function : RTIfrUpdateVariableInfoWrapper

File: CommonHelper.c
Description:
Wrapper function to include RTIfrUpdateVariableInfo
based on SDL token.
Input:
ControlVariable, Handle
Output:
Bool
Built on 16:15:52 10/01/14


SetPwdKeyboardLayout in the CommonHelper.c

Function : SetPwdKeyboardLayout

File: CommonHelper.c
Description:
function to initialize SetKeyboardLayout
Input:
VOID
Output:
VOID
Built on 16:15:52 10/01/14


ShellTextMode in the CommonHelper.c

Function : ShellTextMode

File: CommonHelper.c
Description:
Returns type of shell text mode
Input:
VOID
Output:
UINT32
Built on 16:15:52 10/01/14


SingleClickActivation in the CommonHelper.c

Function : SingleClickActivation

File: CommonHelper.c
Description:
Returns the SINGLE_CLICK_ACTIVATION token value
Input:
VOID
Output:
BOOLEAN
Built on 16:15:52 10/01/14


StyleGetMessageboxColorHook in the CommonHelper.c

Function : StyleGetMessageboxColorHook

File: CommonHelper.c
Description:
Hook function to set Messagebox Color.
Input:
UINT8 **Color
Output:
VOID
Built on 16:15:52 10/01/14


TseDebugDisableApplicationDestructor in the CommonHelper.c

Function : TseDebugDisableApplicationDestructor

File: CommonHelper.c
Description:
Returns token value TSE_DBG_DISABLE_APPDESTRUCTOR
Input:
VOID
Output:
BOOLEAN
Built on 16:15:53 10/01/14


TseDefaultSetupPasswordSupported in the CommonHelper.c

Function : TseDefaultSetupPasswordSupported

File: CommonHelper.c
Description:
Returns token value TSE_DEFAULT_SETUP_PASSWORD_SUPPORT
Input:
VOID
Output:
BOOLEAN
Built on 16:15:53 10/01/14


TSEDonotLoadPasswordOnDefaults in the CommonHelper.c

Function : TSEDonotLoadPasswordOnDefaults

File: CommonHelper.c
Description:
Returns the token value for TSE_DONOT_LOAD_PASSWORD_ON_DEFAULTS
Input:
VOID
Output:
UINT32
Built on 16:15:53 10/01/14


TSEIDEPasswordAuthenticate in the CommonHelper.c

Function : TSEIDEPasswordAuthenticate

File: CommonHelper.c
Description:
Hook function for the IDE Password fuctionality based on
        the security token SETUP_IDE_SECURITY_SUPPORT
Input:
CHAR16 *Password,  VOID*  DataPtr, BOOLEAN bCheckUser
Output:
EFI_STATUS
Built on 16:15:53 10/01/14


TSEIDEPasswordCheck in the CommonHelper.c

Function : TSEIDEPasswordCheck

File: CommonHelper.c
Description:
Hook function for the IDE Password fuctionality based on
        the security token SETUP_IDE_SECURITY_SUPPORT
Input:
VOID
Output:
VOID
Built on 16:15:53 10/01/14


TSEIDEPasswordFreezeDevices in the CommonHelper.c

Function : TSEIDEPasswordFreezeDevices

File: CommonHelper.c
Description:
Hook function for the IDE Password fuctionality based on
        the security token SETUP_IDE_SECURITY_SUPPORT
Input:
VOID
Output:
VOID
Built on 16:15:53 10/01/14


TSEIDEPasswordGetDataPtr in the CommonHelper.c

Function : TSEIDEPasswordGetDataPtr

File: CommonHelper.c
Description:
Hook function for the IDE Password fuctionality based on
        the security token SETUP_IDE_SECURITY_SUPPORT
Input:
UINTN Index
Output:
VOID*
Built on 16:15:53 10/01/14


TSEIDEPasswordGetLocked in the CommonHelper.c

Function : TSEIDEPasswordGetLocked

File: CommonHelper.c
Description:
Hook function for the IDE Password fuctionality based on
        the security token SETUP_IDE_SECURITY_SUPPORT
Input:
UINTN Index
Output:
BOOLEAN
Built on 16:15:53 10/01/14


TSEIDEPasswordGetName in the CommonHelper.c

Function : TSEIDEPasswordGetName

File: CommonHelper.c
Description:
Hook function for the IDE Password fuctionality based on
        the security token SETUP_IDE_SECURITY_SUPPORT
Input:
UINT16 Index
Output:
UINT16
Built on 16:15:53 10/01/14


TSEIDEPasswordUpdate in the CommonHelper.c

Function : TSEIDEPasswordUpdate

File: CommonHelper.c
Description:
Hook function for the IDE Password fuctionality based on
        the security token SETUP_IDE_SECURITY_SUPPORT
Input:
UINT32 DeviceIndex, CHAR16 *Password, BOOLEAN bCheckUser
Output:
BOOLEAN
Built on 16:15:53 10/01/14


TSEIDEUpdateConfig in the CommonHelper.c

Function : TSEIDEUpdateConfig

File: CommonHelper.c
Description:
Hook function for the IDE Password fuctionality based on
        the security token SETUP_IDE_SECURITY_SUPPORT
Input:
VOID
Output:
VOID
Built on 16:15:53 10/01/14


TseIgnoreKeyForFastBoot in the CommonHelper.c

Function : TseIgnoreKeyForFastBoot

File: CommonHelper.c
Description:
Function to return FastBoot is ENABLED or DISABLED

Parameter:   VOID

Return value: BOOLEAN
Built on 16:15:53 10/01/14


TseLaunchFileSystem in the CommonHelper.c

Function : TseLaunchFileSystem

File: CommonHelper.c
Description:
This function to handle launching file system
Input:
UINT32
Output:
EFI_STATUS
Built on 16:15:53 10/01/14


TSEMouseDestroyHook in the CommonHelper.c

Function : TSEMouseDestroyHook

File: CommonHelper.c
Description:
Hook function which is called when Mouse Destory is done.
Input:
VOID
Output:
VOID
Built on 16:15:53 10/01/14


TSEMouseIgnoreMouseActionHook in the CommonHelper.c

Function : TSEMouseIgnoreMouseActionHook

File: CommonHelper.c
Description:
Hook function which can make TSE to Ignore the mouse action.
This function is called whenever TSE read the mouse action
This hook need to be used carefully. It can used in the cases when Mouse
actions consumes by modules like Softkeyboard and not to be used by TSE
Input:
VOID
Output:
BOOLEAN
TRUE - Mouse actions will be ignored by TSE
FALSE - Mouse action
Built on 16:15:53 10/01/14


TSEMouseInitHook in the CommonHelper.c

Function : TSEMouseInitHook

File: CommonHelper.c
Description:
Hook function which is called when Mouse init is done.
Input:
VOID
Output:
VOID
Built on 16:15:53 10/01/14


TSEMouseRefreshHook in the CommonHelper.c

Function : TSEMouseRefreshHook

File: CommonHelper.c
Description:
Hook function which is called when Mouse Refresh action is done.
Input:
VOID
Output:
VOID
Built on 16:15:53 10/01/14


TSEMouseStartHook in the CommonHelper.c

Function : TSEMouseStartHook

File: CommonHelper.c
Description:
Hook function which is called when Mouse start action is done.
Input:
VOID
Output:
VOID
Built on 16:15:53 10/01/14


TSEMouseStopHook in the CommonHelper.c

Function : TSEMouseStopHook

File: CommonHelper.c
Description:
Hook function which is called when Mouse Stop is done.
Input:
VOID
Output:
VOID
Built on 16:15:53 10/01/14


TsePrintScreenSupport in the CommonHelper.c

Function : TsePrintScreenSupport

File: CommonHelper.c
Description:
Function to return print screen support feature
Input:
UINT16 ScanCode
Output:
TRUE/FALSE
Built on 16:15:53 10/01/14


TSEPwdSavetoNvram in the CommonHelper.c

Function : TSEPwdSavetoNvram

File: CommonHelper.c
Description:
Returns the token value for SETUP_SAVE_PSWD_TO_NVRAM
Input:
VOID
Output:
UINT32
Built on 16:15:53 10/01/14


TseRtAccessSupport in the CommonHelper.c

Function : TseRtAccessSupport

File: CommonHelper.c
Description:
Returns token RT_ACCESS_SUPPORT_IN_HPKTOOL value
Input:
VOID
Output:
BOOLEAN
Built on 16:15:53 10/01/14


TSESetHDDPassword in the CommonHelper.c

Function : TSESetHDDPassword

File: CommonHelper.c
Description:
Hook function for the IDE Password fuctionality based on
        the security token SETUP_IDE_SECURITY_SUPPORT
Input:
VOID
Output:
VOID
Built on 16:15:53 10/01/14


TSEStringReadLoopEntryHook in the CommonHelper.c

Function : TSEStringReadLoopEntryHook

File: CommonHelper.c
Description:
Hook function which is called when Strings/Password is going to be read.
Input:
VOID
Output:
VOID
Built on 16:15:53 10/01/14


TSEStringReadLoopExitHook in the CommonHelper.c

Function : TSEStringReadLoopExitHook

File: CommonHelper.c
Description:
Hook function which is called after Strings/Password read.
Input:
VOID
Output:
VOID
Built on 16:15:53 10/01/14


TseSuppressOneofMultilineSupport in the CommonHelper.c

Function : TseSuppressOneofMultilineSupport

File: CommonHelper.c
Description:
Function to return TSE_SUPPRESS_MULTILINE_FOR_ONEOFLABEL value

Parameter:   VOID

Return value: BOOLEAN
Built on 16:15:53 10/01/14


TSEUnlockHDD in the CommonHelper.c

Function : TSEUnlockHDD

File: CommonHelper.c
Description:
Hook function for the IDE Password fuctionality based on
        the security token SETUP_IDE_SECURITY_SUPPORT
Input:
VOID
Output:
VOID
Built on 16:15:53 10/01/14


UefiBootFailHook in the CommonHelper.c

Function : UefiBootFailHook

File: CommonHelper.c
Description:
Board module hook for UefiBootFailHook function
        This function invoked when LoadImage fails
Input:
EFI_STATUS => Status returned from LoadImage
Output:
VOID
Built on 16:15:53 10/01/14


UIUpdateCallbackHook in the CommonHelper.c

Function : UIUpdateCallbackHook

File: CommonHelper.c
Description:
Set OVERRIDE_UIUpdateCallbackHook to 1, if OEM wants to override the UIUpdateCallbackHook function from Board module.
Input:
VOID
Output:
EFI_STATUS
Built on 16:15:53 10/01/14


UninstallBgrtWrapper in the CommonHelper.c

Function : UninstallBgrtWrapper

File: CommonHelper.c
Description:
Wrapper function to call UninstallBgrtWrapper
Input:
BOOLEAN
Output:
VOID
Built on 16:15:53 10/01/14


UpdateNumericDisplayString in the CommonHelper.c

Function : UpdateNumericDisplayString

File: CommonHelper.c
Description:
Board module hook for UpdateNumericDisplayString function
        This function invoked before displaying the numeric control
        Can use this function to change the display style of numeric control
Input:
CHAR16 ** => Numeric string to be formatted
        INT64 => Numeric data to be formatted
        UINT8 => Base of the numeric control, might be AMI_BASE_HEX, AMI_BASE_INT_DEC, AMI_BASE_DEC
        UINT16 => Width of the numeric control
        UINT16 => Size of the CHAR16 **Text
Output:
VOID
Built on 16:15:53 10/01/14


commonoem.c

Description:
contains default implementation of TSE hooks

The following functions are used in the file: commonoem.c.

Function | Description
AfterEfiBootLaunch | This function is a hook called after launching EFI boot option. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
AfterInitPostScreen | This function is a hook called After Post screen is initilzed. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
AfterLegacyBootLaunch | This function is a hook called after launching legacy boot option. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
BeforeEfiBootLaunch | This function is a hook called before launching EFI boot option. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
BeforeLegacyBootLaunch | This function is a hook called before launching legacy boot option. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
CheckandDeactivateSoftkbd | This function is called to check and Deactivate the Softkbd
CheckForClick | This function is a hook called to perform specific action for a Post hot key. This function is called periodically. This function is available as ELINK.
CheckForKey | This function is a hook called to perform specific action for a Post hot key. This function is called periodically. This function is available as ELINK.
CheckOEMKeyCallback | This function to check OEMKey is consumed by any of the modules that has child elink to OEM_KEY_CALLBACK_LIST. If it wants to handle the key It can return success and callback funciton. The callback function will be called in Bootflowentry.
DrawQuietBootLogo | This function is the generic implementation of drawing quiet boot logo. This function is available as an ELINK.
FixSubPageAsRootPageList | This function Fixes the SubPage as root pages from AMITSE_SUBPAGE_AS_ROOT_PAGE_LIST
GetKeySelection | Function to validate the selected key based the key data.
HideDynamicFormsets | This function suppress dynamic formset mentioned in the elink AMITSE_SUPPRESS_DYNAMIC_FORMSET_LIST
InvalidActionHook | This function is the hook call the appropriate InvalidActions function. OEMs may choose to do additional logic here.
IsHideFormsetsWithClassGuid | This function filter formset and display formset based on ClassGUID mentioned in elink AMITSE_FILTER_CLASSGUID_FORMSETS
LoadedBuildDefaults | This function is a hook called after setup utility loaded Oem defaults based on user input. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
LoadedConfigDefaults | This function is a hook called after setup utility loaded config defaults based on user input. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
LoadedPreviousValues | This function is a hook called after setup utility loaded previously saved values based on user input. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
LoadedUserDefaults | This function is a hook called after setup utility loaded user defaults based on user input. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
LoadSetupDefaults | This function is a hook called when user loads the manufacturing or optimal defaults. This function is available as ELINK. OEMs may override the function and decide the policy.
MapControlKeys | This function is a hook called inside setup utility to determine the action to be taken for a particular key press. This function is available as ELINK. OEMs may choose to have a different action or a different key. With this function OEMs can change key mappings for the controls in the setup utility. Post hot keys and Setup utility hot keys are out of this functions scope.
MapControlMouseAction | This function is a hook called inside setup utility to determine the action to be taken for a particular Mouse Click. This function is available as ELINK. OEMs may choose to have a different action or a different mouse click.
MinisetupDriverEntryHook | This function is a hook called at the end of TSE driver entry. This function is available as ELINK. In the generic implementation TSE installs Key monitoring protocol. OEMs may choose to do additional logic here.
OemKey1Hook | This function is a hook called when user activates configurable Post hot key 1. This function is available as ELINK. Generic implementation is empty. OEMs may choose to use different logic here.
OemKey2Hook | This function is a hook called when user activates configurable Post hot key 2. This function is available as ELINK. Generic implementation is empty. OEMs may choose to use different logic here.
OemKey3Hook | This function is a hook called when user activates configurable Post hot key 3. This function is available as ELINK. Generic implementation is empty. OEMs may choose to use different logic here.
OemKey4Hook | This function is a hook called when user activates configurable Post hot key 4. This function is available as ELINK. Generic implementation is empty. OEMs may choose to use different logic here.
PostManagerHandShakeHook | This function is a hook called at the begining of the PostManagerHandShake protocol function. This function is available as ELINK. In the generic implementation TSE gets keys from key monitor filter. OEMs may choose to do additional logic here.
PrintEnterBBSPopupMessage | Displays STR_ACK_BBS_POPUP message in screen
PrintEnterSetupMessage | Displays STR_ACK_ENTER_SETUP message in screen
ProcessConInAvailability | This function is a hook called when TSE determines that console is available. This function is available as ELINK. In the generic implementation boot password is prompted in this function.
ProcessConOutAvailable | This function is a hook called when TSE determines that console out is available. This function is available as ELINK.
ProcessEnterSetup | This function is a hook called when TSE determines that SETUP utility has to be displayed. This function is available as ELINK. In the generic implementation setup password is prompted in this function.
ProcessProceedToBootNow | This function is a hook called when Boots from BBS popup or Bootoverride page.
ProcessUIInitHook | This function is a hook called just before creating the setup application for oem customizations. This function is available as ELINK. OEMs may choose to do additional logic here.
SavedConfigChanges | This function is a hook called after setup utility saves changes based on user input. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
SetControlColors | This function is a hook called when colour of a control has to be decided. This function is available as ELINK. OEMs may choose to use different colour combination.
SetupConfigModified | This function is a hook called after some control modified in the setup utility by user. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
SupportOSIndication | Adds OSIndication support
SwitchToPostScreen | This function is a hook called during SwitchToPostScreen Post. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
TimeOutLoopHook | This function is a hook called in every iteration (not every second) while TSE is waiting for Post time out. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
TseUpdateRootPageOrder | This function is to update the Root page order from the specified elink.
VariableHandleSuppressed | This function informs to match the handle or not for creating new variable using VAR_DYNAMICPARSING_HANDLESUPPRESS_LIST ELink

Built on 16:15:53 10/01/14


AfterEfiBootLaunch in the commonoem.c

Function : AfterEfiBootLaunch

File: commonoem.c
Description:
This function is a hook called after launching EFI
boot option. This function is available as ELINK. In
the generic implementation this function is empty.
OEMs may choose to do additional logic here.
Input:
VOID
Output:
VOID
Built on 16:15:50 10/01/14


AfterInitPostScreen in the commonoem.c

Function : AfterInitPostScreen

File: commonoem.c
Description:
This function is a hook called After Post screen is initilzed.
This function is available as ELINK. In the generic implementation this function
is empty. OEMs may choose to do additional logic here.
Input:
VOID
Output:
VOID
Built on 16:15:50 10/01/14


AfterLegacyBootLaunch in the commonoem.c

Function : AfterLegacyBootLaunch

File: commonoem.c
Description:
This function is a hook called after launching
legacy boot option. This function is available as
ELINK. In the generic implementation this function is
empty. OEMs may choose to do additional logic here.
Input:
VOID
Output:
VOID
Built on 16:15:50 10/01/14


BeforeEfiBootLaunch in the commonoem.c

Function : BeforeEfiBootLaunch

File: commonoem.c
Description:
This function is a hook called before launching EFI
boot option. This function is available as ELINK. In
the generic implementation this function is empty.
OEMs may choose to do additional logic here.
Input:
VOID
Output:
VOID
Built on 16:15:50 10/01/14


BeforeLegacyBootLaunch in the commonoem.c

Function : BeforeLegacyBootLaunch

File: commonoem.c
Description:
This function is a hook called before launching
legacy boot option. This function is available as
ELINK. In the generic implementation this function is
empty. OEMs may choose to do additional logic here.
Input:
VOID
Output:
VOID
Built on 16:15:50 10/01/14


CheckandDeactivateSoftkbd in the commonoem.c

Function : CheckandDeactivateSoftkbd

File: commonoem.c
Description:
This function is  called to check and Deactivate the Softkbd
Input:
VOID
Output:
VOID
Built on 16:15:50 10/01/14


CheckForClick in the commonoem.c

Function : CheckForClick

File: commonoem.c
Description:
This function is a hook called to perform specific
action for a Post hot key. This function is called
periodically. This function is available as ELINK.
Input:
Event: Timer event.
Context: Event context; always NULL
Output:
VOID
Built on 16:15:50 10/01/14


CheckForKey in the commonoem.c

Function : CheckForKey

File: commonoem.c
Description:
This function is a hook called to perform specific
action for a Post hot key. This function is called
periodically. This function is available as ELINK.
Input:
Event: Timer event.
Context: Event context; always NULL
Output:
VOID
Built on 16:15:50 10/01/14


CheckOEMKeyCallback in the commonoem.c

Function : CheckOEMKeyCallback

File: commonoem.c
Description:
This function to check OEMKey is consumed by any of the modules that
        has child elink to OEM_KEY_CALLBACK_LIST. If it wants to handle the key
        It can return success and callback funciton. The callback function will be
        called in Bootflowentry.
Input:
AMI_EFI_KEY_DATA
Output:
BOOLEAN
Built on 16:15:50 10/01/14


DrawQuietBootLogo in the commonoem.c

Function : DrawQuietBootLogo

File: commonoem.c
Description:
This function is the generic implementation of
drawing quiet boot logo. This function is available
as an ELINK.
Input:
VOID
Output:
VOID
Built on 16:15:50 10/01/14


FixSubPageAsRootPageList in the commonoem.c

Function : FixSubPageAsRootPageList

File: commonoem.c
Description:
This function Fixes the SubPage as root pages from
        AMITSE_SUBPAGE_AS_ROOT_PAGE_LIST
Input:
VOID
Output:
VOID
Built on 16:15:50 10/01/14


GetKeySelection in the commonoem.c

Function : GetKeySelection

File: commonoem.c
Description:
Function to validate the selected key based the key data.
Input:
UserCtrlKeyData: User initialized data for the key
            Key: Key provided by SimpleTextIn protocol
            KeyCodeProtocolSupport: flag to verify KeyShiftState.
Output:
TRUE/FALSE
Built on 16:15:50 10/01/14


HideDynamicFormsets in the commonoem.c

Function : HideDynamicFormsets

File: commonoem.c
Description:
This function suppress dynamic formset mentioned in the elink AMITSE_SUPPRESS_DYNAMIC_FORMSET_LIST
Input:
GUID. Formset guid to compare with gSuppressDynamicFormsetList elink guids.
Output:
BOOLEAN. Return TRUE if any guid matches with gSuppressDynamicFormsetList elink else FALSE
Built on 16:15:50 10/01/14


InvalidActionHook in the commonoem.c

Function : InvalidActionHook

File: commonoem.c
Description:
This function is the hook call the appropriate InvalidActions function.
        OEMs may choose to do additional logic here.
Input:
VOID
Output:
VOID
Built on 16:15:50 10/01/14


IsHideFormsetsWithClassGuid in the commonoem.c

Function : IsHideFormsetsWithClassGuid

File: commonoem.c
Description:
This function filter formset and display formset based on ClassGUID mentioned in elink AMITSE_FILTER_CLASSGUID_FORMSETS
Input:
EFI_IFR_FORMSET. Formset to compare with elink classGuid.
Output:
BOOLEAN. Return TRUE formset matches with elink ClassGuid else FALSE
Built on 16:15:51 10/01/14


LoadedBuildDefaults in the commonoem.c

Function : LoadedBuildDefaults

File: commonoem.c
Description:
This function is a hook called after setup utility
loaded Oem defaults based on user input. This
function is available as ELINK. In the generic
implementation this function is empty. OEMs may
choose to do additional logic here.
Input:
VOID
Output:
VOID
Built on 16:15:51 10/01/14


LoadedConfigDefaults in the commonoem.c

Function : LoadedConfigDefaults

File: commonoem.c
Description:
This function is a hook called after setup utility
loaded config defaults based on user input. This
function is available as ELINK. In the generic
implementation this function is empty. OEMs may
choose to do additional logic here.
Input:
VOID
Output:
VOID
Built on 16:15:51 10/01/14


LoadedPreviousValues in the commonoem.c

Function : LoadedPreviousValues

File: commonoem.c
Description:
This function is a hook called after setup utility
loaded previously saved values based on user input. This
function is available as ELINK. In the generic
implementation this function is empty. OEMs may
choose to do additional logic here.
Input:
VOID
Output:
VOID
Built on 16:15:51 10/01/14


LoadedUserDefaults in the commonoem.c

Function : LoadedUserDefaults

File: commonoem.c
Description:
This function is a hook called after setup utility
loaded user defaults based on user input. This
function is available as ELINK. In the generic
implementation this function is empty. OEMs may
choose to do additional logic here.
Input:
VOID
Output:
VOID
Built on 16:15:51 10/01/14


LoadSetupDefaults in the commonoem.c

Function : LoadSetupDefaults

File: commonoem.c
Description:
This function is a hook called when user loads the manufacturing
or optimal defaults. This function is
available as ELINK. OEMs may override the function and
decide the policy.
Input:
defaults : (NVRAM_VARIABLE *)optimal or manufacturing
data : Messagebox
Output:
VOID
Built on 16:15:51 10/01/14


MapControlKeys in the commonoem.c

Function : MapControlKeys

File: commonoem.c
Description:
This function is a hook called inside setup utility
to determine the action to be taken for a particular
key press. This function is available as ELINK. OEMs
may choose to have a different action or a different
key. With this function OEMs can change key mappings
for the controls in the setup utility. Post hot keys
and Setup utility hot keys are out of this functions
scope.
Input:
Key: Key provided by SimpleTextIn protocol
Output:
CONTROL_ACTION: enumeration defined in commonoem.h.
Input EFI_INPUT_KEY has to mapped to one of the
enumerations in CONTROL_ACTION.
Built on 16:15:51 10/01/14


MapControlMouseAction in the commonoem.c

Function : MapControlMouseAction

File: commonoem.c
Description:
This function is a hook called inside setup utility
to determine the action to be taken for a particular
Mouse Click. This function is available as ELINK. OEMs
may choose to have a different action or a different
mouse click.
Input:
MOUSE_INFO *pMouseInfo
Output:
CONTROL_ACTION: enumeration defined in commonoem.h.
Input EFI_INPUT_KEY has to mapped to one of the
enumerations in CONTROL_ACTION.
Built on 16:15:51 10/01/14


MinisetupDriverEntryHook in the commonoem.c

Function : MinisetupDriverEntryHook

File: commonoem.c
Description:
This function is a hook called at the end of TSE
driver entry. This function is available as ELINK.
In the generic implementation TSE installs Key
monitoring protocol. OEMs may choose to do additional
logic here.
Input:
VOID
Output:
VOID
Built on 16:15:51 10/01/14


OemKey1Hook in the commonoem.c

Function : OemKey1Hook

File: commonoem.c
Description:
This function is a hook called when user activates
configurable Post hot key 1. This function is
available as ELINK. Generic implementation is empty.
OEMs may choose to use different logic here.
Input:
bootFlowPtr: Boot flow entry that triggered this call
Output:
always EFI_SUCCESS
Built on 16:15:51 10/01/14


OemKey2Hook in the commonoem.c

Function : OemKey2Hook

File: commonoem.c
Description:
This function is a hook called when user activates
configurable Post hot key 2. This function is
available as ELINK. Generic implementation is empty.
OEMs may choose to use different logic here.
Input:
bootFlowPtr: Boot flow entry that triggered this call
Output:
always EFI_SUCCESS
Built on 16:15:51 10/01/14


OemKey3Hook in the commonoem.c

Function : OemKey3Hook

File: commonoem.c
Description:
This function is a hook called when user activates
configurable Post hot key 3. This function is
available as ELINK. Generic implementation is empty.
OEMs may choose to use different logic here.
Input:
bootFlowPtr: Boot flow entry that triggered this call
Output:
always EFI_SUCCESS
Built on 16:15:51 10/01/14


OemKey4Hook in the commonoem.c

Function : OemKey4Hook

File: commonoem.c
Description:
This function is a hook called when user activates
configurable Post hot key 4. This function is
available as ELINK. Generic implementation is empty.
OEMs may choose to use different logic here.
Input:
bootFlowPtr: Boot flow entry that triggered this call
Output:
always EFI_SUCCESS
Built on 16:15:51 10/01/14


PostManagerHandShakeHook in the commonoem.c

Function : PostManagerHandShakeHook

File: commonoem.c
Description:
This function is a hook called at the begining of the
PostManagerHandShake protocol function. This function
is available as ELINK. In the generic implementation
TSE gets keys from key monitor filter. OEMs may choose
to do additional logic here.
Input:
VOID
Output:
VOID
Built on 16:15:52 10/01/14


PrintEnterBBSPopupMessage in the commonoem.c

Function : PrintEnterBBSPopupMessage

File: commonoem.c
Description:
Displays STR_ACK_BBS_POPUP message in screen
Input:
VOID
Output:
VOID
Built on 16:15:52 10/01/14


PrintEnterSetupMessage in the commonoem.c

Function : PrintEnterSetupMessage

File: commonoem.c
Description:
Displays STR_ACK_ENTER_SETUP message in screen
Input:
VOID
Output:
VOID
Built on 16:15:52 10/01/14


ProcessConInAvailability in the commonoem.c

Function : ProcessConInAvailability

File: commonoem.c
Description:
This function is a hook called when TSE determines
that console is available. This function is available
as ELINK. In the generic implementation boot password
is prompted in this function.
Input:
VOID
Output:
BOOLEAN. Should return TRUE if the screen was used to
ask password; FALSE if the screen was not used to ask
password.
Built on 16:15:52 10/01/14


ProcessConOutAvailable in the commonoem.c

Function : ProcessConOutAvailable

File: commonoem.c
Description:
This function is a hook called when TSE determines
that console out is available. This function is available
as ELINK.
Input:
VOID
Output:
VOID
Built on 16:15:52 10/01/14


ProcessEnterSetup in the commonoem.c

Function : ProcessEnterSetup

File: commonoem.c
Description:
This function is a hook called when TSE determines
that SETUP utility has to be displayed. This function
is available as ELINK. In the generic implementation
setup password is prompted in this function.
Input:
VOID
Output:
VOID
Built on 16:15:52 10/01/14


ProcessProceedToBootNow in the commonoem.c

Function : ProcessProceedToBootNow

File: commonoem.c
Description:
This function is a hook called when Boots from
        BBS popup or Bootoverride page.
Input:
VOID
Output:
VOID
Built on 16:15:52 10/01/14


ProcessUIInitHook in the commonoem.c

Function : ProcessUIInitHook

File: commonoem.c
Description:
This function is a hook called just before creating
                the setup application for oem customizations. This function is
            available as ELINK. OEMs may choose to do additional logic here.
Input:
VOID
Output:
VOID
Built on 16:15:52 10/01/14


SavedConfigChanges in the commonoem.c

Function : SavedConfigChanges

File: commonoem.c
Description:
This function is a hook called after setup utility
saves changes based on user input. This function is
available as ELINK. In the generic implementation
this function is empty. OEMs may choose to do
additional logic here.
Input:
VOID
Output:
VOID
Built on 16:15:52 10/01/14


SetControlColors in the commonoem.c

Function : SetControlColors

File: commonoem.c
Description:
This function is a hook called when colour of a
control has to be decided. This function is available
as ELINK. OEMs may choose to use different colour
combination.
Input:
BGColor: Back ground colour
FGColor: Fore ground colour
SecBGColor: Secondary back ground colour used for
time, date and menu
SecFGColor: Secondary fore ground colour used for
time, date and menu
SelBGColor: Selected back ground colour
SelFGColor: Selected fore ground colour
NSelBGColor: Not selected back ground colour
NSelFGColor: Not selected fore ground colour
LabelBGColor: Label back ground colour
LabelFGColor: Label fore ground colour
NSelLabelFGColor: Not selected label fore ground
EditBGColor: Edit box back ground
EditFGColor: Edit box fore ground
PopupFGColor: Popup fore ground
PopupBGColor: Popup back ground
Output:
EFI_STATUS: always EFI_SUCCESS
Built on 16:15:52 10/01/14


SetupConfigModified in the commonoem.c

Function : SetupConfigModified

File: commonoem.c
Description:
This function is a hook called after some control
        modified in the setup utility by user. This
function is available as ELINK. In the generic
implementation this function is empty. OEMs may
choose to do additional logic here.
Input:
VOID
Output:
VOID
Built on 16:15:52 10/01/14


SupportOSIndication in the commonoem.c

Function : SupportOSIndication

File: commonoem.c
Description:
Adds OSIndication support
Input:
VOID
Output:
VOID
Built on 16:15:52 10/01/14


SwitchToPostScreen in the commonoem.c

Function : SwitchToPostScreen

File: commonoem.c
Description:
This function is a hook called during SwitchToPostScreen Post.
        This function is available as ELINK. In the generic implementation this function
                is empty. OEMs may choose to do additional logic here.
Input:
VOID
Output:
VOID
Built on 16:15:52 10/01/14


TimeOutLoopHook in the commonoem.c

Function : TimeOutLoopHook

File: commonoem.c
Description:
This function is a hook called in every iteration
(not every second) while TSE is waiting for Post time
out. This function is available as ELINK. In the generic
implementation this function is empty. OEMs may
choose to do additional logic here.
Input:
VOID
Output:
VOID
Built on 16:15:52 10/01/14


TseUpdateRootPageOrder in the commonoem.c

Function : TseUpdateRootPageOrder

File: commonoem.c
Description:
This function is to update the Root page order from the specified elink.
Input:
VOID
Output:
VOID
Built on 16:15:53 10/01/14


VariableHandleSuppressed in the commonoem.c

Function : VariableHandleSuppressed

File: commonoem.c
Description:
This function informs to match the handle or not for creating new variable using VAR_DYNAMICPARSING_HANDLESUPPRESS_LIST ELink
Input:
EFI_GUID *, CHAR16	*
Output:
BOOLEAN. Return TRUE handle matches with elink else FALSE
Built on 16:15:53 10/01/14


commonoem.h

Description:
header of commonoem.h
Built on 16:15:53 10/01/14


FakeTokens.c

Description:
This file does not add any code. It has, all the string tokens that
are used by Minisetup, to fake the usage to strgather.exe. Add to
this list, the new string tokens that are defined in
AmiTSEStrstr.uni and to be used by Minisetup
Built on 16:15:53 10/01/14


HiiLib.h

Description:
Hii related functions
Built on 16:15:53 10/01/14


HookAnchor.h

Description:
TSE hook functions
Built on 16:15:53 10/01/14


HookList.c

Description:
AMITSE Hook definitions
Built on 16:15:53 10/01/14


Keymon.c

Description:
Contains key monitoring functions.

The following functions are used in the file: Keymon.c.

Function | Description
GetKeysFromKeyMonFilter | This function receives keys from key monitor filter
GetPlatformMonitorKeyOptions | This function registers keys with key monitor driver for monitoring in the legacy mode.

Built on 16:15:53 10/01/14


GetKeysFromKeyMonFilter in the Keymon.c

Function : GetKeysFromKeyMonFilter

File: Keymon.c
Description:
This function receives keys from key monitor filter
Input:
VOID
Output:
VOID
Built on 16:15:50 10/01/14


GetPlatformMonitorKeyOptions in the Keymon.c

Function : GetPlatformMonitorKeyOptions

File: Keymon.c
Description:
This function registers keys with key monitor driver
for monitoring in the legacy mode.
Input:
EFI_USB_LEGACY_PLATFORM_PROTOCOL *This
KEY_ELEMENT **KeyList: List of keys to be monitored.
UINTN *KeyListSize: Size of data returned in KeyList.
Output:
Return Status based on errors that occurred in library
functions.
Built on 16:15:50 10/01/14


Keymon.h

Description:
header of keymon.c
Built on 16:15:53 10/01/14


LogoLib.h

Description:
logo related header
Built on 16:15:53 10/01/14


mem.h

Description:
memory utility functions
Built on 16:15:53 10/01/14


PwdLib.h

Description:
password handling realted header
Built on 16:15:53 10/01/14


setupdata.h

Description:
Header file for setup data
Built on 16:15:53 10/01/14


setupdbg.h

Description:
Header file for string functionalities.
Built on 16:15:53 10/01/14


TSE Help Module

The following descriptions are used in the file: TSE Help Module.

Header | Description
Driver_Integration | * This is the case adding a new driver into an Aptio project. If driver source code is available, add the driver source and rebuild the project. * Verify all the protocols used are present in the project * Make sure the dependencies are compatible between driver and project * The new setup page can only appear as top level menu item * In case only binary form is available, next are requirements, * The adding driver must have a unique GUID from the project * If the adding driver uses platform variables, make sure the setup definition in the project and the adding driver is completely identical * If private variables are used, make sure it has a different GUID and variable names are unique * Both the driver’s DXE and HPK files are required to put into the project * Use Setup.ini to indicate the location of driver setup page * It’s impossible the new page to be a submenu of an existing page
HII_Package_files | Aptio TSE performs a Post-processing of the information that will be stored into HII and saves the result into a separate section of the driver in order to allow Post-build configuration. This requires that the HII Package files, created by Intel’s VFRCOMPILE utility, be generated as inputs to the Aptio TSE build. These files are generated based on a command line parameter to the VFRCOMPILE utility. This command line can be specified using the VFRCOMPILE_FLAGS SDL token. This SDL token must be set to "-ibin" in order to generate the HPK files.
How_to_add_a_page | Adding a page to a VFR is quite simple. There are 2 pieces that make up a new page: the reference to the page from an existing page, and the new page definition itself: // inside an existing form goto MY_SETUP_FORM_ID, prompt = STRING_TOKEN(STR_MY_SETUP_PAGE), help = STRING_TOKEN(STR_MY_SETUP_PAGE_HELP); // after all form definitions form formid = MY_SETUP_FORM_ID, title = STRING_TOKEN(STR_MY_SETUP_PAGE); subtitle text = STRING_TOKEN(STR_SOME_TEXT_STRING); // additional controls go here endform;
How_to_display_a_dynamic_value | Dynamic text is fully supported by TSE. Creating and modifying dynamic text needs to follow certain rules. A dynamic text control is simply a TEXT VFR control with the INTERACTIVE flag set to true. In this case, the FORM_CALLBACK.Callback function is called every 100ms to refresh the contents of the displayed control. It is the requirement of the callback routine to update the string in the HII database with the new value to be displayed. The callback interval can be managed in multiple ways. It can be changed in the setup data using a tool such as AMIBCP. It can also be managed programmatically in the callback routine itself. Example: #define CPU1_TEMP_KEY 0x1234 text help = STRING_TOKEN(STR_NULL_STRING), text = STRING_TOKEN(STR_CPU1_TEMP_PROMPT), text = STRING_TOKEN(STR_CPU1_TEMP_VAL), flags = INTERACTIVE, key = CPU1_TEMP_KEY; This definition into the VFR file will automatically cause TSE to create a dynamic text control. It is the responsibility of the callback routine (most likely published by a separate DXE driver) to update the temperature data. Sample pseudo-code for the callback is listed below: CHAR16 gUpdateString[256]; EFI_STATUS Callback( ..., UINT16 key, ... ) { switch ( key ) { case CPU1_TEMP_KEY : UINT16 stringRef = STRING_TOKEN(STR_CPU1_TEMP_VAL); UINTN cpuTemp = GetCPUTemp( CPU1 ); SPrint( gUpdateString, sizeof( gUpdateString ), L"%d", cpuTemp ); // this call to NewString replaces the string in HII HII->NewString( HII, L"eng", handle, &stringRef, gUpdateString ); break; } }
How_to_display_message_in_the_POST_screen | TSE publishes a function called DisplayPostMessage as part of AMI_POST_MANAGER (formerly MRE_HAND_SHAKE) protocol. Other drivers can use this function to display UNICODE strings in Post screen. Prototype for DisplayPostMessage is provided in AMIPostMgr.h typedef EFI_STATUS (EFIAPI *AMI_POST_MANAGER_DISPLAY_MESSAGE) ( CHAR16 *Message typedef struct _AMI_POST_MANAGER_PROTOCOL { AMI_POST_MANAGER_HANDSHAKE Handshake; AMI_POST_MANAGER_DISPLAY_MESSAGE DisplayPostMessage; }AMI_POST_MANAGER_PROTOCOL;
How_to_display_value_which_may_change_from_boot_to_boot | Changing strings can be accomplished through a couple of different means. One, which is used for such facilities as memory sizing and hard drive identification, is to update a string into HII that has been put there as a placeholder. For example, a memory VFR might look like: text help = STRING_TOKEN(STR_NULL_STRING), text = STRING_TOKEN(STR_TOTAL_MEMORY_SIZE_PROMPT), text = STRING_TOKEN(STR_MEMORY_SIZE_VAL), flags = 0, key = 0; In the firmware, there will be code that updates the place holder string STR_MEMORY_SIZE_VAL with the actual string for the size. For example, CHAR16 string[20] ; SPrint( string, 20, L"%dMB", memosrySize ) ; Hii->AddString( Hii, &token, string ) ; This can also be accomplished in concert by code into the firmware and the VFRs themselves. First, a structure should be defined into which the data to be shared is stored. Then, along with a name and GUID, a volatile EFI variable my be defined. This is accomplished by setting the variable WITHOUT the EFI_VARIABLE_NON_VOLATILE flag. // inside a firmware driver Status = gRT->SetVariable( L"MyVariable", &myGuid, EFI_VARIABLE_BOOTSERVICE_ACCESS, &myVariableStruct, sizeof(myVariableStruct) Into the VFR, a varstore must be created (similar to the one above) and used to access this variable.
How_to_gray_out_or_suppress_a_control | The following example shows how to gray out or suppress a control from within the VFR definition file. grayoutif ideqval SYSTEM_ACCESS.Access == SYSTEM_PASSWORD_USER; oneof varid = SetupMap.IdeMode, prompt = STRING_TOKEN(STR_IDE_MODE_PROMPT), help = STRING_TOKEN(STR_IDE_MODE_HELP), option text = STRING_TOKEN(STR_DISABLE), value = 0, flags = RESET_REQUIRED; option text = STRING_TOKEN(STR_ENABLE), value = 1, flags = DEFAULT | RESET_REQUIRED; endoneof; endif;
How_to_integrate_an_EFI_application | Integrating an EFI application into the setup data is very simply done, using AMI’s extensions. There are multiple steps involved in creating a launch, but none involve modifying source code. First, define your variable store within your VFR file. The actual structure of the variable store is not used, so we simply define a basic structure: typedef struct _MY_OEM_PACK { UINT16 Value; } MY_OEM_PACK; varstore MY_OEM_PACK, key = MY_OEM_PACK_KEY_ID, name = application.efi, guid = MY_OEM_PACK_GUID; The important things to keep in mind with the above definitions are that the GUID and the key uniquely identify your application. Next, define VFR entry as follows. It will always be a reference wrapped by a suppress clause: // compare against a non-zero value so the suppress condition will fail. suppressif ideqval MY_OEM_PACK.Value == 1; // OEM_FORM_ID can be either an empty form defined elsewhere in the VFR // or the containing form’s formid value goto OEM_FORM_ID, prompt = STRING_TOKEN(STR_MY_OEM_APPLICATION), help = STRING_TOKEN(STR_MY_APPLICATION_HELP); endif; Last step is to define your behavior into the SETUP.INI file so that TSE will understand the overridden HII construct. [GUIDx] ; where x is the next available GUID number in the file guid = XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX name = unused key = XXXX ; this should be the same key value defined in the varstore flags = 6 ; these are the flags that tell what the action to perform is ; the values can be Ored togeteher to create multiple actions: ; 1 – signifies that the callback is AMI internal ; 2 – the GUID is treated as a filename in FV and launched ; 4 – the name defined in the varstore is treated as an EFI ; executable name and is launched from the filesystem ; Using 4 and 2 together will try FV first, then filesystem
How_to_provide_Default_boot_order | To have this functionality; on every boot in addition to creating / updating "BootOrder" and "LegacyDevOrder" variables based on the addition and removal of boot devices; BDS should also create / update the variables "DefaultBootOrder" and "DefaultLegacyDevOrder". "DefaultBootOrder" and "DefaultLegacyDevOrder" are variables introduced to provide TSE with the default ordering of devices. TSE displays these default orders when the user is loading optimal defaults. Details of default boot order variable VariableName: "DefaultBootOrder" Guid: 45cf35f6-0d6e-4d04-856a-0370a5b16f53 Details of default legacy device order variable VariableName: "DefaultLegacyDeviceOrder" Guid: 3c4ead08-45ae-4315-8d15-a60eaa8caf69 PS: If these variables are not present TSE will load the values of the BootOrder and LeagacyDevOrder variables it entered with as default values
How_To_Switch_to_different_Style | Clone and change the following SDL token settings. Ezport Style TSE_STYLE_EZPORT_BIN_SUPPORT = ON TSE_STYLE_EZPORT_SUPPORT = ON TSE_STYLE_LEGACY_BIN_SUPPORT = OFF TSE_STYLE_LEGACY_SUPPORT = OFF TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = OFF TSE_STYLE_EZPORTPLUS_SUPPORT = OFF Legacy Style TSE_STYLE_EZPORT_BIN_SUPPORT = OFF TSE_STYLE_EZPORT_SUPPORT = OFF TSE_STYLE_LEGACY_BIN_SUPPORT = ON TSE_STYLE_LEGACY_SUPPORT = ON TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = OFF TSE_STYLE_EZPORTPLUS_SUPPORT = OFF EzportPlus Style TSE_STYLE_EZPORT_BIN_SUPPORT = OFF TSE_STYLE_EZPORT_SUPPORT = OFF TSE_STYLE_LEGACY_BIN_SUPPORT = OFF TSE_STYLE_LEGACY_SUPPORT = OFF TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = ON TSE_STYLE_EZPORTPLUS_SUPPORT = ON
Image_formats | The OEM logo image that is used in Aptio TSE is BMP and GIF format. Future versions will support other image formats (like PCX and JPG). There are no color depth restrictions for this image. The image cannot be an RLE encoded bitmap or otherwise compressed bitmap. Compression is referring to image compression as defined by the BMP format, not EFI compression. The image is designed to fit into a specified area of the screen. The dimensions of the image file should be set accordingly. The default image dimensions are listed below, SmLogo: 400x100
Localization | One of the many features of Aptio, is the ability to easily work with multiple languages. Aptio TSE is no exception. Aptio TSE uses the exact same .UNI string management as the Aptio project itself.
Post | Any of the images associated with Aptio can be modified after the firmware has been built using the AMI ChangeLogo tool. The rendering information may be modified together with other information like Optimal and Failsafe values may be customized after the firmware has been built using the AMIBCP tool.
Setup_path_in_MINISETUP | Since Aptio TSE accesses the default setup NVRAM storage directly, it is important that the correct layout of the NVRAM variable is known by TSE. This requires TSE to include the SetupVariable.h header file specific to the current project. This header file will be located in the SAME directory where the setup .VFR files are kept. The SETUP_PATH variable in the MINISETUP.MAK must match the path, relative to the root of the Aptio project. For example, for an Intel D865GCH R6-based Aptio project, this should be set as follows, SETUP_PATH = Platform\IntelDpg\D865GCH\DXE\D865GCHPlatform\Setup
TSE_FAQ | Q: The strings do not show up on the screen. A: There are several possible solutions to this problem. There could be an issue with the VFR creation. TSE expects each formset in the VFR files to have the same GUID but unique CLASS and SUBCLASS identifiers. There could be strings that are not defined into the .UNI file. This is unlikely as this would be caught during the build process. Q: Setup doesn't find any of my pages. A: Make sure that the GUID defined for your formsets matches the GUID defined into the main section of the SETUP.INI file. Q: How do I use multiple variables? A: TSE fully supports multiple variables defined into the VFR files. But, there is a caveat. The default variable (usually defined using the formset GUID and the name "Setup") must also be re-defined. This is a workaround for a faulty VFR compiler. These variables should be defined using the VFR command varstore. See the previous section for examples of how to use the varstore command. Q: How do I use the reference VFR files that are included into the TSE package? A: These VFR files are used in exactly the same way the platform VFR files are used. There are a couple of things that need to be modified into the platform code to install them. The .CIF file that includes the VFR files for the platform should be modified to reflect the new files. The file PLATFORM.C should be modified to install the new HII packs into the HII database. This includes defining new variables for the new VFR binaries, adding these binaries to the function call that installs the HII packs, etc. The VFR files should be copied to the platform setup directory to be included into the build process.

Built on 16:15:54 10/01/14


Driver_Integration in the TSE Help Module

General : Driver_Integration

File: TSE Help Module
Description:
* This is the case adding a new driver into an Aptio project. If driver source
  code is available, add the driver source and rebuild the project.
* Verify all the protocols used are present in the project
* Make sure the dependencies are compatible between driver and project
* The new setup page can only appear as top level menu item
* In case only binary form is available, next are requirements,
* The adding driver must have a unique GUID from the project
* If the adding driver uses platform variables, make sure the setup definition in the
  project and the adding driver is completely identical
* If private variables are used, make sure it has a different GUID and variable names
  are unique
* Both the driver’s DXE and HPK files are required to put into the project
* Use Setup.ini to indicate the location of driver setup page
* It’s impossible the new page to be a submenu of an existing page
Built on 16:15:50 10/01/14


HII_Package_files in the TSE Help Module

General : HII_Package_files

File: TSE Help Module
Description:
Aptio TSE performs a Post-processing of the information that will be
stored into HII and saves the result into a separate section of the driver in order
to allow Post-build configuration.  This requires that the HII Package files, created
by Intel’s VFRCOMPILE utility, be generated as inputs to the Aptio TSE build.
These files are generated based on a command line parameter to the VFRCOMPILE utility.
This command line can be specified using the VFRCOMPILE_FLAGS SDL token.  This SDL
token must be set to "-ibin" in order to generate the HPK files.
Built on 16:15:50 10/01/14


How_to_add_a_page in the TSE Help Module

General : How_to_add_a_page

File: TSE Help Module
Description:
Adding a page to a VFR is quite simple.  There are 2 pieces that make up
a new page: the reference to the page from an existing page, and the new page
definition itself:

    // inside an existing form
    goto MY_SETUP_FORM_ID,
    prompt = STRING_TOKEN(STR_MY_SETUP_PAGE),
    help = STRING_TOKEN(STR_MY_SETUP_PAGE_HELP);

    // after all form definitions
    form
        formid = MY_SETUP_FORM_ID,
        title = STRING_TOKEN(STR_MY_SETUP_PAGE);

    subtitle text = STRING_TOKEN(STR_SOME_TEXT_STRING);

    // additional controls go here

    endform;
Built on 16:15:50 10/01/14


How_to_display_a_dynamic_value in the TSE Help Module

General : How_to_display_a_dynamic_value

File: TSE Help Module
Description:
Dynamic text is fully supported by TSE.  Creating and modifying
dynamic text needs to follow certain rules. A dynamic text control is simply a
TEXT VFR control with the INTERACTIVE flag set to true.  In this case, the
FORM_CALLBACK.Callback function is called every 100ms to refresh the contents
of the displayed control.  It is the requirement of the callback routine to
update the string in the HII database with the new value to be displayed.

The callback interval can be managed in multiple ways.  It can be changed in
the setup data using a tool such as AMIBCP.  It can also be managed
programmatically in the callback routine itself.
    Example:

    #define	CPU1_TEMP_KEY	0x1234

    text
            help   = STRING_TOKEN(STR_NULL_STRING),
            text   = STRING_TOKEN(STR_CPU1_TEMP_PROMPT),
            text   = STRING_TOKEN(STR_CPU1_TEMP_VAL),
            flags  = INTERACTIVE,
            key    = CPU1_TEMP_KEY;

This definition into the VFR file will automatically cause TSE to create a dynamic
text control.  It is the responsibility of the callback routine (most likely
published by a separate DXE driver) to update the temperature data.  Sample
pseudo-code for the callback is listed below:

        CHAR16	gUpdateString[256];

        EFI_STATUS Callback( ..., UINT16 key, ... )
        {
        switch ( key )
        {
        case CPU1_TEMP_KEY :
            UINT16 stringRef = STRING_TOKEN(STR_CPU1_TEMP_VAL);
            UINTN cpuTemp = GetCPUTemp( CPU1 );
            SPrint( gUpdateString, sizeof( gUpdateString ),
        L"%d", cpuTemp );
                    // this call to NewString replaces the string in HII
                    HII->NewString( HII, L"eng", handle,
        &stringRef, gUpdateString );
                    break;
        }
        }
Built on 16:15:50 10/01/14


How_to_display_message_in_the_POST_screen in the TSE Help Module

General : How_to_display_message_in_the_POST_screen

File: TSE Help Module
Description:
TSE publishes a function called DisplayPostMessage as part of
AMI_POST_MANAGER (formerly MRE_HAND_SHAKE) protocol. Other drivers can use
this function to display UNICODE strings in Post screen.

Prototype for DisplayPostMessage is provided in AMIPostMgr.h

typedef
EFI_STATUS
(EFIAPI *AMI_POST_MANAGER_DISPLAY_MESSAGE) (
    CHAR16	*Message
typedef struct _AMI_POST_MANAGER_PROTOCOL
{
    AMI_POST_MANAGER_HANDSHAKE			Handshake;
    AMI_POST_MANAGER_DISPLAY_MESSAGE	DisplayPostMessage;
}AMI_POST_MANAGER_PROTOCOL;
Built on 16:15:50 10/01/14


How_to_display_value_which_may_change_from_boot_to_boot in the TSE Help Module

General : How_to_display_value_which_may_change_from_boot_to_boot

File: TSE Help Module
Description:
Changing strings can be accomplished through a couple of different
means.  One, which is used for such facilities as memory sizing and hard drive
identification, is to update a string into HII that has been put there as a
placeholder.  For example, a memory VFR might look like:

    text
            help   = STRING_TOKEN(STR_NULL_STRING),
            text   = STRING_TOKEN(STR_TOTAL_MEMORY_SIZE_PROMPT),
            text   = STRING_TOKEN(STR_MEMORY_SIZE_VAL),
            flags  = 0,
            key    = 0;

In the firmware, there will be code that updates the place holder string
STR_MEMORY_SIZE_VAL with the actual string for the size.  For example,

    CHAR16 string[20] ;
    SPrint( string, 20, L"%dMB", memosrySize ) ;
    Hii->AddString( Hii, &token, string ) ;

This can also be accomplished in concert by code into the firmware and the
VFRs themselves.  First, a structure should be defined into which the data to
be shared is stored.  Then, along with a name and GUID, a volatile EFI
variable my be defined.  This is accomplished by setting the variable WITHOUT
the EFI_VARIABLE_NON_VOLATILE flag.

    // inside a firmware driver
    Status = gRT->SetVariable(
    L"MyVariable",
    &myGuid,
    EFI_VARIABLE_BOOTSERVICE_ACCESS,
    &myVariableStruct,
    sizeof(myVariableStruct)
Into the VFR, a varstore must be created (similar to the one above) and used
to access this variable.
Built on 16:15:50 10/01/14


How_to_gray_out_or_suppress_a_control in the TSE Help Module

General : How_to_gray_out_or_suppress_a_control

File: TSE Help Module
Description:
The following example shows how to gray out or suppress a control from
within the VFR definition file.

    grayoutif ideqval SYSTEM_ACCESS.Access == SYSTEM_PASSWORD_USER;
        oneof
        varid = SetupMap.IdeMode,
        prompt = STRING_TOKEN(STR_IDE_MODE_PROMPT),
        help = STRING_TOKEN(STR_IDE_MODE_HELP),
        option
            text = STRING_TOKEN(STR_DISABLE),
            value = 0,
            flags = RESET_REQUIRED;
        option
            text = STRING_TOKEN(STR_ENABLE),
            value = 1,
            flags = DEFAULT | RESET_REQUIRED;
        endoneof;
    endif;
Built on 16:15:50 10/01/14


How_to_integrate_an_EFI_application in the TSE Help Module

General : How_to_integrate_an_EFI_application

File: TSE Help Module
Description:
Integrating an EFI application into the setup data is very simply done,
using AMI’s extensions.  There are multiple steps involved in creating a launch, but
none involve modifying source code.
First, define your variable store within your VFR file.  The actual structure of the
variable store is not used, so we simply define a basic structure:

    typedef struct _MY_OEM_PACK
    {
    UINT16 Value;
    }
    MY_OEM_PACK;

    varstore MY_OEM_PACK,
    key = MY_OEM_PACK_KEY_ID,
    name = application.efi,
    guid = MY_OEM_PACK_GUID;

The important things to keep in mind with the above definitions are that the GUID and
the key uniquely identify your application.
Next, define VFR entry as follows.  It will always be a reference wrapped by a
suppress clause:

    // compare against a non-zero value so the suppress condition will fail.
    suppressif ideqval MY_OEM_PACK.Value == 1;
    // OEM_FORM_ID can be either an empty form defined elsewhere in the VFR
    // or the containing form’s formid value
    goto OEM_FORM_ID,
    prompt = STRING_TOKEN(STR_MY_OEM_APPLICATION),
    help = STRING_TOKEN(STR_MY_APPLICATION_HELP);
    endif;

Last step is to define your behavior into the SETUP.INI file so that TSE will
understand the overridden HII construct.

    [GUIDx]	; where x is the next available GUID number in the file
    guid = XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX
    name = unused
    key = XXXX ; this should be the same key value defined in the varstore
    flags = 6 ; these are the flags that tell what the action to perform is
            ; the values can be Ored togeteher to create multiple actions:
            ; 1 – signifies that the callback is AMI internal
            ; 2 – the GUID is treated as a filename in FV and launched
            ; 4 – the name defined in the varstore is treated as an EFI
            ;     executable name and is launched from the filesystem
            ; Using 4 and 2 together will try FV first, then filesystem
Built on 16:15:50 10/01/14


How_to_provide_Default_boot_order in the TSE Help Module

General : How_to_provide_Default_boot_order

File: TSE Help Module
Description:
To have this functionality; on every boot in addition to
creating / updating "BootOrder" and "LegacyDevOrder" variables based on the addition
and removal of boot devices; BDS should also create / update the variables
"DefaultBootOrder" and "DefaultLegacyDevOrder". "DefaultBootOrder" and
"DefaultLegacyDevOrder" are variables introduced to provide TSE with the default
ordering of devices. TSE displays these default orders when the user is
loading optimal defaults.

    Details of default boot order variable
    VariableName: "DefaultBootOrder"
    Guid: 45cf35f6-0d6e-4d04-856a-0370a5b16f53

    Details of default legacy device order variable
    VariableName: "DefaultLegacyDeviceOrder"
    Guid: 3c4ead08-45ae-4315-8d15-a60eaa8caf69

PS: If these variables are not present TSE will load the values of the BootOrder
and LeagacyDevOrder variables it entered with as default values
Built on 16:15:50 10/01/14


How_To_Switch_to_different_Style in the TSE Help Module

General : How_To_Switch_to_different_Style

File: TSE Help Module
Description:
Clone and change the following SDL token settings.

Ezport Style
    TSE_STYLE_EZPORT_BIN_SUPPORT = ON
    TSE_STYLE_EZPORT_SUPPORT = ON
    TSE_STYLE_LEGACY_BIN_SUPPORT = OFF
    TSE_STYLE_LEGACY_SUPPORT = OFF
    TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = OFF
    TSE_STYLE_EZPORTPLUS_SUPPORT = OFF

Legacy Style
    TSE_STYLE_EZPORT_BIN_SUPPORT = OFF
    TSE_STYLE_EZPORT_SUPPORT = OFF
    TSE_STYLE_LEGACY_BIN_SUPPORT = ON
    TSE_STYLE_LEGACY_SUPPORT = ON
    TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = OFF
    TSE_STYLE_EZPORTPLUS_SUPPORT = OFF

EzportPlus Style
    TSE_STYLE_EZPORT_BIN_SUPPORT = OFF
    TSE_STYLE_EZPORT_SUPPORT = OFF
    TSE_STYLE_LEGACY_BIN_SUPPORT = OFF
    TSE_STYLE_LEGACY_SUPPORT = OFF
    TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = ON
    TSE_STYLE_EZPORTPLUS_SUPPORT = ON
Built on 16:15:50 10/01/14


Image_formats in the TSE Help Module

General : Image_formats

File: TSE Help Module
Description:
The OEM logo image that is used in Aptio TSE is BMP and GIF format.  Future versions
will support other image formats (like PCX and JPG).  There are no color depth restrictions
for this image.  The image cannot be an RLE encoded bitmap or otherwise compressed bitmap.
Compression is referring to image compression as defined by the BMP format, not EFI compression.
The image is designed to fit into a specified area of the screen.  The dimensions of the
image file should be set accordingly.  The default image dimensions are listed below,

SmLogo: 400x100
Built on 16:15:50 10/01/14


Localization in the TSE Help Module

General : Localization

File: TSE Help Module
Description:
One of the many features of Aptio, is the ability to easily work with multiple
languages. Aptio TSE is no exception. Aptio TSE uses the exact same .UNI string management
as the Aptio project itself.
Built on 16:15:51 10/01/14


Post in the TSE Help Module

General : Post

File: TSE Help Module
Description:
Any of the images associated with Aptio can be modified after the firmware has
been built using the AMI ChangeLogo tool. The rendering information may be modified together
with other information like Optimal and Failsafe values may be customized after the firmware
has been built using the AMIBCP tool.
Built on 16:15:52 10/01/14


Setup_path_in_MINISETUP in the TSE Help Module

General : Setup_path_in_MINISETUP

File: TSE Help Module
Description:
Since Aptio TSE accesses the default setup NVRAM storage directly, it is
important that the correct layout of the NVRAM variable is known by TSE.  This requires
TSE to include the SetupVariable.h header file specific to the current project.
This header file will be located in the SAME directory where the setup .VFR files are kept.
The SETUP_PATH variable in the MINISETUP.MAK must match the path, relative to the root
of the Aptio project.

For example, for an Intel D865GCH R6-based Aptio project, this should be set as follows,

SETUP_PATH = Platform\IntelDpg\D865GCH\DXE\D865GCHPlatform\Setup
Built on 16:15:52 10/01/14


TSE_FAQ in the TSE Help Module

General : TSE_FAQ

File: TSE Help Module
Description:
Q:	The strings do not show up on the screen.
A:	There are several possible solutions to this problem.
    There could be an issue with the VFR creation.  TSE expects each formset
    in the VFR files to have the same GUID but unique CLASS and SUBCLASS identifiers.
    There could be strings that are not defined into the .UNI file.  This is unlikely
    as this would be caught during the build process.

Q:	Setup doesn't find any of my pages.
A:	Make sure that the GUID defined for your formsets matches the GUID defined
    into the main section of the SETUP.INI file.

Q:	How do I use multiple variables?
A:	TSE fully supports multiple variables defined into the VFR files. But, there
    is a caveat.  The default variable (usually defined using the formset GUID
    and the name "Setup") must also be re-defined.  This is a workaround for a
    faulty VFR compiler.  These variables should be defined using the VFR command
    varstore.  See the previous section for examples of how to use the varstore command.

Q:	How do I use the reference VFR files that are included into the TSE package?
A:	These VFR files are used in exactly the same way the platform VFR files are used.
    There are a couple of things that need to be modified into the platform code to
    install them.
    The .CIF file that includes the VFR files for the platform should be modified to
    reflect the new files.
    The file PLATFORM.C should be modified to install the new HII packs into
    the HII database.  This includes defining new variables for the new VFR binaries,
    adding these binaries to the function call that installs the HII packs, etc.
    The VFR files should be copied to the platform setup directory to be
    included into the build process.
Built on 16:15:52 10/01/14


TseCommon.h

Description:
Tse Common Helper header file
Built on 16:15:54 10/01/14


TseDrvHealth.h

Description:
Header file for driver health only contains TSE specific.
Built on 16:15:54 10/01/14


TseElinks.h

Description:
Header file for Elink related customizations
Built on 16:15:54 10/01/14


variable.h

Description:
Variable handling header
Built on 16:15:54 10/01/14


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

  • A
  • B
  • C
  • D
  • E
  • F
  • G
  • H
  • I
  • L
  • M
  • N
  • O
  • P
  • R
  • S
  • T
  • U
  • V
  • W
Built on 16:15:50 10/01/14


Functions in Alphabetical Order

A

Function | Description
AdvancedRepairSupported | Returns the SHOW_DRV_HEALTH_BOOT_TIME_SENDFORM token value
AfterEfiBootLaunch | This function is a hook called after launching EFI boot option. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
AfterInitPostScreen | This function is a hook called After Post screen is initilzed. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
AfterLegacyBootLaunch | This function is a hook called after launching legacy boot option. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.

Data Structure | Description
AMITSE_HIDE_ROOT_PAGE | 1 -> Hides the root page & 0 -> The support is disabled
AMITSE_ROOT_PAGE_ORDER_SUPPORT | 1 => Enable the Root Page Order support for TSE. 0 => Disable the Root Page Order support for TSE.
AMITSE_SUBPAGE_AS_ROOT_PAGE_LIST_SUPPORT | 1 -> Shows subpages as root page & 0 -> Shows subpages as is.
AMITSE_SUPPORT | Main switch to enable AMITSE support in Project
AMITSE_SUPPRESS_DYNAMIC_FORMSET | 0 is Default. 1 -> To suppress dynamic formset mentioned in elink AMITSE_SUPPRESS_DYNAMIC_FORMSET_LIST and do not show in setup. 0 -> Display dynamic page and not to suppress dynamic page.
AMITSE_VERSION | TSE Version for displaying in the init screen. If no need of version to display then use empty string, if changing the format specifiers then care should be taken in source.

Built on 16:15:49 10/01/14


Functions in Alphabetical Order

B

Function | Description
BBSGetNonStandardGroupType | Set OVERRIDE_BBSGetNonStandardGroupType to 1, then add the OEM specific function to override this function to provide a non standard group type for the given Device Type.
BeforeEfiBootLaunch | This function is a hook called before launching EFI boot option. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
BeforeLegacyBootLaunch | This function is a hook called before launching legacy boot option. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
BootDevPathMatchEnabled | Checks whether the input device path matches exactly with any of the boot options device path. This will be useful for USB, Floppy....
BootFlowManageEntry | Determines boot flow entry path based on the boot flow variable.
BootFlowManageExit | Determines boot flow exit path based on the boot flow variable.

Data Structure | Description
BBS_STATUS_FLAGS |
BBS_TABLE |
BIOS_SIGNON_MESSAGE2 | Use this SDL token to update the BIOS Sign On Message 2.
BOOT_FLOW_NORMAL_INFINITE_LOOP | 1 = TSE tries to loads all the boot options and all fails checks for SETUP_ENTRY keys if found then enters the setup else TSE tries to load all the boot options once again and continues the mentioned procedure infinitely and 0 = Neglects the SETUP_ENTRY key check, always tries to load all the boot options infinitely.
BOOT_FLOW_NORMAL_LAUNCH_DEFAULT_BOOTIMAGE | Support for UEFI specification v 2.3.1 section 3.4.1.1 and 3.4.1.2 to load the default boot image (efi\boot\boot####.efi) from any of the available file system if no boot option found. 1 = Enabling default image boot and 0 = Disabling default image boot.
BOOT_OVERRIDE_BOOTNEXT_VARIABLE_FEATURE | DISABLE is default.1=> To show menu for BootOverride options to modifiy BootNext variable when BootNext variable is supported by project. 0=> Not to show menu for BootOverride options.

Built on 16:15:49 10/01/14


Functions in Alphabetical Order

C

Function | Description
CheckAdvShiftState | Checks the input shift state with the condition shift state
CheckandDeactivateSoftkbd | This function is called to check and Deactivate the Softkbd
CheckForAddDelBootOption | Function to return the SETUP_SUPPORT_ADD_BOOT_OPTION token value
CheckForAddDelDriverOption | Function to return the SETUP_SUPPORT_ADD_DRIVER_OPTION token value
CheckForClick | This function is a hook called to perform specific action for a Post hot key. This function is called periodically. This function is available as ELINK.
CheckForKey | This function is a hook called to perform specific action for a Post hot key. This function is called periodically. This function is available as ELINK.
CheckIsAllowedPasswordChar | Check is the char allowed for password control based on SDL token.
CheckOEMKeyCallback | This function to check OEMKey is consumed by any of the modules that has child elink to OEM_KEY_CALLBACK_LIST. If it wants to handle the key It can return success and callback funciton. The callback function will be called in Bootflowentry.
CleanUpExtendedLogoWrapper | function to clear the logo
ClearNumericShiftState |
ContribBGRTTableToAcpi | Wrapper function to call ConvertBmpandAddBGRT
ConvertBmpToUgaBltWrapper | Wrapper function to process ConvertBmpToUgaBlt functionallity based on SDL token.
ConvertGifToUgaBltWrapper | Wrapper function to process ConvertGifToUgaBlt functionallity based on SDL token.
ConvertJPEGToUgaBltWrapper | Wrapper function to process ConvertJPEGToUgaBlt functionallity based on SDL token.
ConvertOEMFormatToUgaBltWrapper | Wrapper function to process ConvertOEMFormatToUgaBlt functionallity based on SDL token.
ConvertPCXToUgaBltWrapper | Wrapper function to process ConvertPCXToUgaBlt functionallity based on SDL token.
ConvertPNGToUgaBltWrapper | Wrapper function to process ConvertPNGToUgaBlt functionallity based on SDL token.

Data Structure | Description
CONTRIB_BGRT_TABLE_TO_ACPI | Set to Contribute the BGRT table to ACPI.

Built on 16:15:49 10/01/14


Functions in Alphabetical Order

D

Function | Description
DefaultSetupPwdAtFirstBootOnly | Returns token value DEFAULT_SETUP_PWD_AT_FIRSTBOOT_ONLY
DoLogoAnimateWrapper | function to Handle logo animation
DrawPostLogoAt0Pos | Retrurns DRAW_POST_LOGO_AT_0POS token value Parameter: VOID Return value: BOOLEAN
DrawQuietBootLogo | This function is the generic implementation of drawing quiet boot logo. This function is available as an ELINK.
DriverHealthSystemReset | Board module hook for DriverHealthSystemReset function

Data Structure | Description
DEFAULT_SETUP_PWD_AT_FIRSTBOOT_ONLY | 1 is default. 1 => Sets the TSE_ADMIN_PASSWORD and TSE_USER_PASSWORD at first boot only. 0 => Sets TSE_ADMIN_PASSWORD and TSE_USER_PASSWORD in TSE defaults, on load defaults these data will be loaded.
DISABLE_ESC_IN_BBS | 0 is DEFAULT.1 => To disable ESC behaviour in BBS menu and retain in BBS menu. 0 => To enable ESC behaviour in BBS menu.
DRAW_POST_LOGO_AT_0POS | Displays the Post logo at top(0,0) graphics position. Disable by default make it 1 to avail this feature.
DRIVER_HEALTH_SUPPORT | Enabling Driver health support in TSE and 0 = Disabling Driver health support in TSE.

Built on 16:15:49 10/01/14


Functions in Alphabetical Order

E

Function | Description
EDKVersion_1_05_RetrieveData | Returns the EDK_1_05_RETRIEVE_DATA token value
EFI_LEGACY_BIOS_BOOT | Boots a traditional OS
EFI_LEGACY_BIOS_GET_BBS_INFO | Presents BBS information to external agents.

Data Structure | Description
EDK_1_05_RETRIEVE_DATA | Modified code to return BrowserCallback String according to either EDK browser or spec.
EFI_LEGACY_BIOS_PROTOCOL | Abstracts the traditional BIOS from the rest of EFI. The LegacyBoot() member function allows the BDS to support booting a traditional OS. EFI thunks drivers that make EFI bindings for BIOS INT services use all the other member functions.
EXIT_PAGE_CLASS | Exit Page Formset class.
EXIT_PAGE_FORM_ID | Exit Page ID.
EXIT_PAGE_GUID | GUID used to identify exit page.
EXIT_PAGE_SUB_CLASS | Exit Page Formset Subclass.

Built on 16:15:49 10/01/14


Functions in Alphabetical Order

F

Function | Description
FBBootFlow |
FindDevPathTotLength | Find the length of the complete device path
FixMergePagesExtraHook | Set OVERRIDE_FixMergePagesExtraHook to 1, if OEM wants to override the UIUpdateCallbackHook function from Board module.
FixSubPageAsRootPageList | This function Fixes the SubPage as root pages from AMITSE_SUBPAGE_AS_ROOT_PAGE_LIST
FlushKeysAfterRead | Returns value of disable FLUSH_KEYS_AFTER_READ
FramePasswordAdvancedCallback | This function to handle password callback inside setup

Data Structure | Description
FLUSH_KEYS_AFTER_READ | Disable to flush the key buffer.

Built on 16:15:49 10/01/14


Functions in Alphabetical Order

G

Function | Description
GetACPIOEMID | Returns the ACPI OEM ID
GetACPIOEMRevision | Returns the ACPI OEM Revision
GetACPIOEMTableID | Returns the ACPI OEM Table ID
GetactualScreentop | function to get the actual screen top value for mouse
GetFormSetTitleAndHelp | GetFormSetTitleAndHelp Parameter: EFI_HII_HANDLE Handle, EFI_STRING_ID *Title, EFI_STRING_ID *Help Return value: status
GetGraphicsBitMapFromFV | Return the graphics image file named FileNameGuid into Image and return it's size in ImageSize. All Firmware Volumes (FV) in the system are searched for the file name.
GetKeySelection | Function to validate the selected key based the key data.
GetKeysFromKeyMonFilter | This function receives keys from key monitor filter
GetMsgboxWidth | Returns the message box width
GetNotifyMaskValue | Retrurns notify mask vaule
GetPasswordPopupTextBoxColor | Function to Get PasswordPopupTextBox Color
GetPasswordPopupWindowColor | Function to Get PasswordPopupWindow Color
GetPasswordReportInboxcolor | Function to Get PasswordReportInBox Color
GetPlatformMonitorKeyOptions | This function registers keys with key monitor driver for monitoring in the legacy mode.
GetTseBuildVersion | Function to fill the TSE build information
GetTseBuildYear | Function to fill the TSE build Year
GetUEFISpecVersion | Returns the Specification version assigned to TSE_CALLBACK_SPEC_VERSION
GOPScreenResolution | Hook function to set GOPScreen Resolution.
gotoExitOnEscKey | Returns value of disable SETUP_GO_TO_EXIT_PAGE_ON_EXIT_KEY

Built on 16:15:49 10/01/14


Functions in Alphabetical Order

H

Function | Description
HideDynamicFormsets | This function suppress dynamic formset mentioned in the elink AMITSE_SUPPRESS_DYNAMIC_FORMSET_LIST

Data Structure | Description
HDD_INFO |
HONOR_DRVHLTH_CONFIGREQD_ON_BOOTFAIL | 1 => If driver need to be configured during the device boot then this token should be enabled to display the form produced from dirver health protocol & 0 => Disables the form produced by the driver health protocol.

Built on 16:15:49 10/01/14


Functions in Alphabetical Order

I

Function | Description
InvalidActionHook | This function is the hook call the appropriate InvalidActions function. OEMs may choose to do additional logic here.
InvalidateStatusInBgrtWrapper | Wrapper function to call InvalidateStatusInBgrt
IsANSIEscapeCodeSupported | Returns token value TSE_ANSI_ESC_CODE_SUPPORT
IsBGRTSupported | Retrurns CONTRIB_BGRT_TABLE_TO_ACPI token value
IsBootOptionsGroupingEnabled | Returns the value for grouping the boot options
IsBootOverrideBootNextSupport | Function to return BOOT_OVERRIDE_BOOTNEXT_VARIABLE_FEATURE value Parameter: VOID Return value: BOOLEAN
IsBootTimeOutValueZero | function to return TSE_BOOT_TIME_OUT_AS_ZERO value
IsDelayLogoTillInputSupported | Retrurns SETUP_DELAY_LOGO_TILL_INPUT token value
IsDisableESCinBBSMenu | Returns token DISABLE_ESC_IN_BBS value
IsDriverHealthSupported | Retrurns DRIVER_HEALTH_SUPPORT token value
IsGrayoutSelectable | Returns token value TSE_SETUP_GRAYOUT_SELECTABLE
IsHelpAreaScrollBarSupport | Returns value as enable or disable STYLE_HELP_AREA_SCROLLBAR support
IsHideFormsetsWithClassGuid | This function filter formset and display formset based on ClassGUID mentioned in elink AMITSE_FILTER_CLASSGUID_FORMSETS
IsLoadSysteAccessOnUserDefault | Returns token value TSE_DONOT_LOAD_SYSTEM_ACCESS_FOR_USER_DEFAULT
IsMouseOnSoftkbd | Function to return whether MousePointer is on softkbd or not
IsOEMPOSTLogoSupport | To Return OEMLogo Draw Support token value
IsSetupHideBiosSignOnMsg | Returns the value for hiding the bios signon msg
IsShowPromptStringAsTitle | Returns token value TSE_SHOW_PROMPT_STRING_AS_TITLE
IsSupportDefaultForStringControl | Returns TSE_SUPPORT_DEFAULT_FOR_STRING_CONTROL token value
IsTseBestTextGOPModeSupported | Returns token TSE_BEST_TEXT_GOP_MODE value
IsTSECursorSupport | Function to return TSE_CURSOR_SUPPORT token value
IsTSEMultilineControlSupported | Retrurns TSE_MULTILINE_CONTROLS token value

Data Structure | Description
INI_FILE_PATH | To set path of the setup ini file which used as input to HPK tool .

Built on 16:15:49 10/01/14


Functions in Alphabetical Order

L

Function | Description
LaunchHotKeyBootOption | Board module hook for LaunchHotKeyBootOption function
LaunchSecBootPathFromEnabledDevs | Launches default image from the path \EFI\BOOT\BOOT{machine type short-name}.EFI from the enabled devices in setup.
LaunchSecondaryPath | Launches default image from the path \EFI\BOOT\BOOT{machine type short-name}.EFI
LegacyBootFailHook | Board module hook for LegacyBootFailHook function This function invoked when LoadImage fails
LoadDefaultsFromDefaultBuffer | Wrapper function to provide TSE_LOAD_DEFAULTS_FROM_DEFAULTS_BUFFER
LoadedBuildDefaults | This function is a hook called after setup utility loaded Oem defaults based on user input. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
LoadedConfigDefaults | This function is a hook called after setup utility loaded config defaults based on user input. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
LoadedPreviousValues | This function is a hook called after setup utility loaded previously saved values based on user input. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
LoadedUserDefaults | This function is a hook called after setup utility loaded user defaults based on user input. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
LoadSetupDefaults | This function is a hook called when user loads the manufacturing or optimal defaults. This function is available as ELINK. OEMs may override the function and decide the policy.

Built on 16:15:49 10/01/14


Functions in Alphabetical Order

M

Function | Description
MainSetupLoopHook | Set OVERRIDE_MainSetupLoopHook to 1, if OEM wants to override the MainSetupLoopHook function from Board module.
MainSetupLoopInitHook | Set OVERRIDE_MainSetupLoopInitHook to 1, if OEM wants to override the MainSetupLoopInitHook function from Board module.
MapControlKeys | This function is a hook called inside setup utility to determine the action to be taken for a particular key press. This function is available as ELINK. OEMs may choose to have a different action or a different key. With this function OEMs can change key mappings for the controls in the setup utility. Post hot keys and Setup utility hot keys are out of this functions scope.
MapControlMouseAction | This function is a hook called inside setup utility to determine the action to be taken for a particular Mouse Click. This function is available as ELINK. OEMs may choose to have a different action or a different mouse click.
MediaDevPathMatchEnabled | Checks whether the input device path matches with any of the boot options media device path. This will be useful for drives with partition.
MinisetupDriverEntryHook | This function is a hook called at the end of TSE driver entry. This function is available as ELINK. In the generic implementation TSE installs Key monitoring protocol. OEMs may choose to do additional logic here.
MouseListBoxScrollBarMove | Function to move scrollbar in ListBox using mouse Parameter: VOID *, BOOLEAN, UINT32 Return value: status
MouseScrollBarMove | Function to move scrollbar in Frame using mouse Parameter: VOID *, BOOLEAN, UINT32 Return value: status

Data Structure | Description
MAX_MSGBOX_WIDTH | Set the value to change the message box dispaly width.
MAX_POST_GC_MODE | Port this SDL to select the Maximum Support Graphical module. Should be one of (GC_MODEx SDL tokens). Based on this token logo capability table created.
MINISETUP_MOUSE_SUPPORT | Mouse suport.
MSGBOX_PROGRESS_BAR_SEGMENT_COUNT | Mod of 100 with this number should be 0, for example (100 % 20 = 0).

Built on 16:15:49 10/01/14


Functions in Alphabetical Order

N

Data Structure | Description
NO_VARSTORE_SUPPORT | Enables and disables no var store support. This needs modification of VFRs. Need customization of board module.

Built on 16:15:49 10/01/14


Functions in Alphabetical Order

O

Function | Description
OemCheckControlCondition | Set OVERRIDE_OEMCheckControlCondition to 1, if OEM wants to override the OemCheckControlCondition function from Board module.
OemKey1Hook | This function is a hook called when user activates configurable Post hot key 1. This function is available as ELINK. Generic implementation is empty. OEMs may choose to use different logic here.
OemKey2Hook | This function is a hook called when user activates configurable Post hot key 2. This function is available as ELINK. Generic implementation is empty. OEMs may choose to use different logic here.
OemKey3Hook | This function is a hook called when user activates configurable Post hot key 3. This function is available as ELINK. Generic implementation is empty. OEMs may choose to use different logic here.
OemKey4Hook | This function is a hook called when user activates configurable Post hot key 4. This function is available as ELINK. Generic implementation is empty. OEMs may choose to use different logic here.
OEMSpecialGetControlCount | OEM Hook Function can allows exploding into multiple controls. Based on the OEM policies it returns number controls need to exploded.
OEMSpecialGotoFixup | If the OEM Special control is Submenu Control. Based on the OEMSpecialGetControlCount The submenus are added with same promt/help. If OEM want to Fix the prompt and help fields of the submenu control. It can be done here. For each submenu of that OEM special control it is called.
OEMSpecialGotoSelect | Hook for OEM Goto control Action Handler. On Selection of the OEM Goto control it is called.
OEMSpecialOneOfFixup | If the OEM Special control is One of Control the members of the one of control Can be fixed up in this function. If OEM needs multiple control, for each one of it will be called. This function has to create dynamic IFR Oneof Options
OEMSpecialUpdateOneOf | Hook to update the OEM Variable based on Selection. TSE updates the varible buffer in the normal way (updates with option value selected) If any OEM Special updatation required OEM may use this function and return EFI_SUCCESS.
OsUpdateCapsuleWrap | Dispalys the image obtained form OS Update and calls the capsule to update

Data Structure | Description
OEMLogo_FILE_PATH | Path of OEMLogo to show in Postscreen. Default path is TSE_BIN.
OLD_MOUSE_DRIVER_SUPPORT | Old Mouse Driver Mouse suport. Need to be on if 4.6.0-MOUSE_SUPPORT-004 or older is used.
OSIndication_SUPPORT | Main token to disable or enable the OSIndication Support. If disable then OSIndication module can be used.
OVERRIDE_BBSBuildName | set to 1 if oem wants to override the BBSBuildName function from Board module.
OVERRIDE_BBSGetNonStandardGroupType | Set to 1 if oem wants to override the BBSGetNonStandardGroupType function from Board module.
OVERRIDE_BbsItkBoot | set to 1 if oem wants to override the BbsItkBoot function from Board module.
OVERRIDE_CheckAdvShiftState | set to 1 if OEM wants to override the CheckAdvShiftState function from Board module.
OVERRIDE_CheckIsAllowedPasswordChar | set to 1 if oem wants to override the CheckIsAllowedPasswordChar function from Board module.
OVERRIDE_CleanUpOEMLogo | set to 1 if oem wants to override the CleanUpOEMLogo function from Board module.
OVERRIDE_ConvertOEMFormatToUgaBlt | set to 1 if oem wants to override the ConvertOEMFormatToUgaBlt function from Board module.
OVERRIDE_CsmBBSBootOptionName | 0 is Default. Set to 1 if OEM wants to override the CsmBBSBootOptionName function from Board module.
OVERRIDE_DoOEMLogoAnimate | set to 1 if oem wants to override the DoOEMLogoAnimate function from Board module.
OVERRIDE_DriverHealthSystemReset | set to 1 if oem wants to override the DriverHealthSystemReset function from Board module.
OVERRIDE_FindVarFromITKQuestionId | set to 1 if oem wants to override the FindVarFromITKQuestionId function from Board module.
OVERRIDE_FixMergePagesExtraHook | set to 1 if OEM wants to override the FixMergePagesExtraHook function from Board module.
OVERRIDE_FramePasswordAdvancedCallback | set to 1 if OEM wants to override the FramePasswordAdvancedCallback function from Board module.
OVERRIDE_FramePwdCallbackIdePasswordUpdate | Set to 1 if oem wants to override the FramePwdCallbackIdePasswordUpdate function from Board module.
OVERRIDE_GetAMITSEVariable | set to 1 if oem wants to override the GetAMITSEVariable function from Board module.
OVERRIDE_GetBootTimeOut | set to 1 if oem wants to override the GetBootTimeOut function from Board module.
OVERRIDE_GetGraphicsBitMapFromFV | set to 1 if OEM wants to override the GetGraphicsBitMapFromFV function from Board module.
OVERRIDE_GetMessageboxColorHook | Set to 1 if oem wants to override the GetMessageboxColorHook function from Board module.
OVERRIDE_GetUefiSpecVersion | set to 1 if OEM wants to override the GetUEFISpecVersion function from Board module.
OVERRIDE_GOPSetScreenResolutionHook | Set to 1 if oem wants to override the GOPSetScreenResolutionHook function from Board module.
OVERRIDE_IsOEMLogoType | set to 1 if oem wants to override the IsOEMLogoType function from Board module.
OVERRIDE_ItkSupport | set to 1 if oem wants to override the ItkSupport function from Board module.
OVERRIDE_LaunchHotKeyBootOption | set to 1 if OEM wants to override the LaunchHotKeyBootOption function from Board module.
OVERRIDE_LaunchSecBootPathFromEnabledDevs | set to 1 if OEM wants to override the LaunchSecBootPathFromEnabledDevs function from Board module.
OVERRIDE_LaunchSecondaryBootPath | set to 1 if OEM wants to override the LaunchSecondaryBootPath function from Board module.
OVERRIDE_LegacyBootFailHook | set to 1 if OEM wants to override the OVERRIDE_LegacyBootFailHook function from Board module.
OVERRIDE_MainSetupLoopHook | set to 1 if OEM wants to override the MainSetupLoopHook function from Board module.
OVERRIDE_MainSetupLoopInitHook | set to 1 if OEM wants to override the MainSetupLoopInitHook function from Board module.
OVERRIDE_NoVarStoreSupport | set to 1 if oem wants to override the NoVarStoreSupport function from Board module.
OVERRIDE_NoVarStoreUpdateSystemAccess | set to 1 if oem wants to override the NoVarStoreUpdateSystemAccess function from Board module.
OVERRIDE_OEMCheckControlCondition | set to 1 if OEM wants to override the OemCheckControlCondition function from Board module.
OVERRIDE_OEMSpecialGetControlCount | set to 1 if oem wants to override the OEMSpecialGetControlCount function from Board module.
OVERRIDE_OEMSpecialGotoFixup | Modified code to return BrowserCallback String according to either EDK browser or spec.
OVERRIDE_OEMSpecialGotoSelect | set to 1 if oem wants to override the OEMSpecialGotoSelect function from Board module.
OVERRIDE_OEMSpecialOneOfFixup | set to 1 if oem wants to override the OEMSpecialOneOfFixup function from Board module.
OVERRIDE_OEMSpecialUpdateOneOf | set to 1 if oem wants to override the OEMSpecialGotoFixup function from Board module.
OVERRIDE_OsUpdateCapsuleWrap | set to 1 if OEM wants to override the OsUpdateCapsuleWrap function from Board module.
OVERRIDE_PageRemoveHook | set to 1 if OEM wants to override the PageRemoveHook function from Board module.
OVERRIDE_PasswordAuthenticate | set to 1 if oem wants to override the PasswordAuthenticate function from Board module.
OVERRIDE_PasswordCheckInstalled | set to 1 if oem wants to override the PasswordCheckInstalled function from Board module.
OVERRIDE_PasswordCommitChanges | set to 1 if oem wants to override the PasswordCommitChanges function from Board module.
OVERRIDE_PasswordUpdate | set to 1 if oem wants to override the PasswordUpdate function from Board module.
OVERRIDE_PopupPasswordAuthenticate | set to 1 if oem wants to override the PopupPasswordAuthenticate function from Board module.
OVERRIDE_PopupPasswordCheckInstalled | set to 1 if oem wants to override the PopupPasswordCheckInstalled function from Board module.
OVERRIDE_PopupPasswordFormCallback | set to 1 if oem wants to override the PopupPasswordFormCallback function from Board module.
OVERRIDE_PopupPwdAuthenticateIDEPwd | Set to 1 if oem wants to override the PopupPwdAuthenticateIDEPwd function from Board module.
OVERRIDE_PopupPwdHandleActionOverRide | set to 1 if oem wants to override the PopupPwdHandleActionOverRide function from Board module.
OVERRIDE_PopupPwdUpdateIDEPwd | Set to 1 if oem wants to override the PopupPwdUpdateIDEPwd function from Board module.
OVERRIDE_ProcessBrowserActionRequestHook | set to 1 if OEM wants to override the ProcessBrowserActionRequestHook function from Board module.
OVERRIDE_ProcessPackNotificationHook | set to 1 if OEM wants to override the ProcessPackNotification function from Board module.
OVERRIDE_SetSystemAccessValueItk | set to 1 if oem wants to override the SetSystemAccessValueItk function from Board module.
OVERRIDE_TSEGetactualScreentop | set to 1 if OEM wants to override the TSEGetactualScreentop function from Board module.
OVERRIDE_TSEGetCoordinates | set to 1 if OEM wants to override the TSEGetCoordinates function from Board module.
OVERRIDE_TSEIDEPasswordAuthenticate | Set to 1 if oem wants to override the TSEIDEPasswordAuthenticate function from Board module.
OVERRIDE_TSEIDEPasswordCheck | set to 1 if oem wants to override the TSEIDEPasswordCheck function from Board module.
OVERRIDE_TSEIDEPasswordFreezeDevices | set to 1 if oem wants to override the TSEIDEPasswordFreezeDevices function from Board module.
OVERRIDE_TSEIDEPasswordGetDataPtr | set to 1 if oem wants to override the TSEIDEPasswordGetDataPtr function from Board module.
OVERRIDE_TSEIDEPasswordGetLocked | set to 1 if oem wants to override the TSEIDEPasswordGetLocked function from Board module.
OVERRIDE_TSEIDEPasswordGetName | Set to 1 if oem wants to override the TSEIDEPasswordGetName function from Board module.
OVERRIDE_TSEIDEPasswordUpdate | set to 1 if oem wants to override the TSEIDEPasswordUpdate function from Board module.
OVERRIDE_TSEIDEUpdateConfig | set to 1 if oem wants to override the TSEIDEUpdateConfig function from Board module.
OVERRIDE_TSEIsMouseClickedonSoftkbd | set to 1 if OEM wants to override the TSEIsMouseClickedonSoftkbd function from Board module.
OVERRIDE_TseLaunchFileSystem | set to 1 if OEM wants to override the TseLaunchFileSystem function from Board module.
OVERRIDE_TSEMouseDestoryHook | set to 1 if oem/Modules wants to override the TSEMouseDestoryHook function from Board module.
OVERRIDE_TSEMouseDestroy | set to 1 if OEM wants to override the TSEMouseDestroy function from Board module.
OVERRIDE_TSEMouseFreeze | set to 1 if OEM wants to override the TSEMouseFreeze function from Board module.
OVERRIDE_TSEMouseIgnoreMouseActionHook | set to 1 if oem wants to override the TSEMouseIgnoreMouseActionHook function from Board module.
OVERRIDE_TSEMouseInit | set to 1 if OEM wants to override the TSEMouseInit function from Board module.
OVERRIDE_TSEMouseInitHook | set to 1 if oem/Modules wants to override the TSEMouseInitHook function from Board module.
OVERRIDE_TSEMouseReadInfo | set to 1 if OEM wants to override the TSEMouseReadInfo function from Board module.
OVERRIDE_TSEMouseRefresh | set to 1 if OEM wants to override the TSEMouseRefresh function from Board module.
OVERRIDE_TSEMouseRefreshHook | set to 1 if oem/Modules wants to override the TSEMouseRefreshHook function from Board module.
OVERRIDE_TSEMouseStart | set to 1 if OEM wants to override the TSEMouseStart function from Board module.
OVERRIDE_TSEMouseStartHook | set to 1 if oem wants to override the TSEMouseStartHook function from Board module.
OVERRIDE_TSEMouseStop | set to 1 if OEM wants to override the TSEMouseStop function from Board module.
OVERRIDE_TSEMouseStopHook | Modified code to return BrowserCallback String according to either EDK browser or spec.
OVERRIDE_TSENumericSoftKbdExit | set to 1 if OEM wants to override the TSENumericSoftKbdExit function from Board module.
OVERRIDE_TSENumericSoftKbdInit | set to 1 if OEM wants to override the TSENumericSoftKbdInit function from Board module.
OVERRIDE_TSESetHDDPassword | set to 1 if oem wants to override the TSESetHDDPassword function from Board module.
OVERRIDE_TSEStringReadLoopEntryHook | set to 1 if oem wants to override the TSEStringReadLoopEntryHook function from Board module.
OVERRIDE_TSEStringReadLoopExitHook | set to 1 if oem wants to override the TSEStringReadLoopExitHook function from Board module.
OVERRIDE_TSEUnlockHDD | set to 1 if oem wants to override the TSEUnlockHDD function from Board module.
OVERRIDE_UefiBootFailHook | set to 1 if OEM wants to override the OVERRIDE_UefiBootFailHook function from Board module.
OVERRIDE_UIUpdateCallbackHook | set to 1 if OEM wants to override the UIUpdateCallback function from Board module.
OVERRIDE_UpdateNumericDisplayString | set to 1 if OEM wants to override the UpdateNumericDisplayString function from Board module.
OVERRIDE_VarBuildItkDefaults | set to 1 if oem wants to override the VarBuildItkDefaults function from Board module.

Built on 16:15:49 10/01/14


Functions in Alphabetical Order

P

Function | Description
PageRemoveHook | Set OVERRIDE_PageRemoveHook to 1, if OEM wants to override the PageRemoveHook function from Board module.
PISpecVersion | Returns PI_SPECIFICATION_VERSION value
PostManagerHandShakeHook | This function is a hook called at the begining of the PostManagerHandShake protocol function. This function is available as ELINK. In the generic implementation TSE gets keys from key monitor filter. OEMs may choose to do additional logic here.
PrintableKeysSoftKbdExit | function to exit PrintableKeysSoftKbd and reset with default keyboard layout
PrintableKeysSoftKbdInit | function to launch PrintableKeysSoftKbd layout
PrintEnterBBSPopupMessage | Displays STR_ACK_BBS_POPUP message in screen
PrintEnterSetupMessage | Displays STR_ACK_ENTER_SETUP message in screen
PrntScrnKeyHandleactionWrapper | Wrapper function to call PrntScrnKeyHandleaction
ProcessBrowserActionRequestHook | Set OVERRIDE_ProcessBrowserActionRequestHook to 1, if OEM wants to override the ProcessBrowserActionRequestHook function from Board module.
ProcessConInAvailability | This function is a hook called when TSE determines that console is available. This function is available as ELINK. In the generic implementation boot password is prompted in this function.
ProcessConOutAvailable | This function is a hook called when TSE determines that console out is available. This function is available as ELINK.
ProcessEnterSetup | This function is a hook called when TSE determines that SETUP utility has to be displayed. This function is available as ELINK. In the generic implementation setup password is prompted in this function.
ProcessPackNotificationHook | Set OVERRIDE_ProcessPackNotificationHook to 1, if OEM wants to override the ProcessPackNotificationHook function from Board module.
ProcessProceedToBootNow | This function is a hook called when Boots from BBS popup or Bootoverride page.
ProcessUIInitHook | This function is a hook called just before creating the setup application for oem customizations. This function is available as ELINK. OEMs may choose to do additional logic here.

Data Structure | Description
PASSWORD_WITH_SPECIAL_CHAR_SUPPORT | 0 => Only alphanumeric characters are support in the Password 1 => Also supports printable special characters.
POPUP_MENU_ENTRY_LEGACY_CODE | Set legacy scan code for popup menu entry.
POPUP_MENU_ENTRY_SCAN | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol
POPUP_MENU_ENTRY_SHIFT_STATE | Set to one of the defined constants from AMI_KEY_CODE_PROTOCOL.
POPUP_MENU_ENTRY_UNICODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'
POPUP_MENU_HIDE_DISABLE_BOOT_OPTIONS | 1 => Hide the disabled boot options in BBS POPup menu. 0 => Shows all boot options in BBS POPup menu.
POPUP_MENU_SHOW_ALL_BBS_DEVICES | 1 => Shows all BBS devices in BBS POPup menu. 0 => Shows only the first device of a BBS type in BBS POPUP menu.
PROGRESSBAR_BACKGROUNDCOLOR | Set the value of progressbar bgcolor in EFI_UGA_PIXEL format
PROGRESSBAR_BORDERCOLOR | Set the value of progressbar border color in EFI_UGA_PIXEL format
PROGRESSBAR_FILLCOLOR | Set the value of progressbar fill color in EFI_UGA_PIXEL format

Built on 16:15:49 10/01/14


Functions in Alphabetical Order

R

Function | Description
ResetPwdKeyboardLayout | function to exit ResetKeyboardLayout and reset with default keyboard layout
RTIfrProcessAddVarListAndPageIDListWrapper | Wrapper function to add runtime variable and Pages based on SDL token.
RTIfrProcessExitWrapper | Wrapper function to process the RuntimeParsing Exit functionallity based on SDL token.
RTIfrProcessFormIfUpdatedWrapper | Wrapper function to include RTIfrProcessFormIfUpdated based on SDL token.
RTIfrProcessRunTimeFormsWrapper | Wrapper function to process runtime Ifrs based on SDL token.
RTIfrRegFormNotificationWrapper | Wrapper function for RegFormNotification
RTIfrUnRegFormNotificationWrapper | Wrapper function for UnRegFormNotification
RTIfrUpdateVariableInfoWrapper | Wrapper function to include RTIfrUpdateVariableInfo based on SDL token.

Data Structure | Description
RESERVED_ADD_DEL_BOOT_OPTION_NAME | Reserved names that are not allowed to use for add or delete boot options.
ROMHOLE_BLOCK_SIZE | Size of Block used for ROMHOLE.
ROMHOLE_NUMBER_OF_BLOCK | Number of Block used for ROMHOLE.
RT_ACCESS_SUPPORT_IN_HPKTOOL | 0 is default. 0=> Not to set RT flag for variables. 1=> enable to add RT attribute for variables, uefisetup.ini attributes persists.

Built on 16:15:49 10/01/14


Functions in Alphabetical Order

S

Function | Description
SavedConfigChanges | This function is a hook called after setup utility saves changes based on user input. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
SetControlColors | This function is a hook called when colour of a control has to be decided. This function is available as ELINK. OEMs may choose to use different colour combination.
SetPwdKeyboardLayout | function to initialize SetKeyboardLayout
SetupConfigModified | This function is a hook called after some control modified in the setup utility by user. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
ShellTextMode | Returns type of shell text mode
SingleClickActivation | Returns the SINGLE_CLICK_ACTIVATION token value
StyleGetMessageboxColorHook | Hook function to set Messagebox Color.
SupportOSIndication | Adds OSIndication support
SwitchToPostScreen | This function is a hook called during SwitchToPostScreen Post. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.

Data Structure | Description
SECONDARY_BOOT_FROM_ENABLED_DEVICES | 0-> Loads \EFI\BOOT\BOOT{machine type short-name}.EFI from any of the devices & 1-> Loads the default image only from enabled devices.
SERIAL_DEBUG | A switch to print TSE Debug messages over Serial Port.
SETUP_ALT_ENTRY_ENABLE | Enable or disable the SETUP_ALT_ENTRY
SETUP_ALT_ENTRY_LEGACY_CODE | Set legacy code for Alternate entry key.
SETUP_ALT_ENTRY_SCAN | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol. Remember to check STR_DEL_ENTER_SETUP string in MiniSetupStr.uni.
SETUP_ALT_ENTRY_SHIFT_STATE | Set to one of the defined constants from AMI_KEY_CODE_PROTOCOL.
SETUP_ALT_ENTRY_UNICODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'. Remember to check STR_DEL_ENTER_SETUP string in MiniSetupStr.uni.
SETUP_BBS_POPUP_ENABLE | Enable or disable the SETUP_BBS_POPUP_ENABLE. CAUTION This works only if complete TSE sources are present.
SETUP_BMP_LOGO_SUPPORT | BMP Logo support in Setup
SETUP_DEFAULT_TIMEOUT | Default timeout value before system boots
SETUP_DELAY_LOGO_TILL_INPUT | 1 => delays logo display untill SIMPLE TEXT IN protocol is available. 0 => logo is displayed as soon as UGA DRAW, CONSOLE SPLITTER & SIMPLE TEXT OUT IS AVAILABLE (Will increase code size).
SETUP_DELAY_POST_TILL_GOP | ENABLE is default.Wait for GOP.
SETUP_DISPLAY_SUBMENU_PAGETITLE | Displays page title of submenu pages in the menu tab.
SETUP_ENTRY_LEGACY_CODE | Set legacy scan code for entry key.
SETUP_ENTRY_SCAN | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol. Remember to check STR_DEL_ENTER_SETUP string in MiniSetupStr.uni.
SETUP_ENTRY_SHIFT_STATE | Set to one of the defined constants from AMI_KEY_CODE_PROTOCOL.
SETUP_ENTRY_UNICODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'. Remember to check STR_DEL_ENTER_SETUP string in MiniSetupStr.uni.
SETUP_GIF_LOGO_SUPPORT | GIF Logo support in Setup
SETUP_GO_TO_EXIT_PAGE_ON_EXIT_KEY | DISABLE is default.Set to ENABLE to goto Exit page on pressing ESC key. If Enabled, on Pressing ESC key, by default it will go to Exit page.If user needs to change the page then user has provide proper FormID in the dependency tokens.
SETUP_GRAYOUT_READONLY_CONTROL | Diaplay readonly controls as grayout.
SETUP_GROUP_DYNAMIC_PAGES | Allows Dynamic IFR Pages to be relocated under subpages. Make sure to have the VFR changes to show the dynamic pages.
SETUP_HIDE_BIOS_SIGNON_MESSAGE2 | 1 => Hides the BIOS signon message. 0 => Shows the BIOS sign on message.
SETUP_HIDE_DISABLE_BOOT_OPTIONS | 1 => Hide the disabled boot options in boot override menu. 0 => Shows all boot options boot override menu.
SETUP_IDE_SECURITY_SUPPORT | To support IDE Security.
SETUP_ITK_COMPATIBILITY | Enables and disables ITK compatibility. Need customization in Board module to support ITK projects.
SETUP_JPEG_LOGO_SUPPORT | JPEG Logo support in Setup
SETUP_LINK_HISTORY_SUPPORT | Preserves navigation history of Ref linked pages. Pressing the <ESC> returns control to the previous page if the current page was linked from a REF control.
SETUP_OEM_FORMAT_LOGO_SUPPORT | OEM Specific Logo support in Setup
SETUP_OEM_KEY1_EFIKEY | Set to one of the defined EFI_KEY enumeration.
SETUP_OEM_KEY1_ENABLE | Enable or disable the SETUP_OEM_KEY1
SETUP_OEM_KEY1_LEGACY_CODE | Set legacy code for OEM key 1.
SETUP_OEM_KEY1_SCAN | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol
SETUP_OEM_KEY1_SHIFT | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
SETUP_OEM_KEY1_TOGGLE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
SETUP_OEM_KEY1_UNICODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'
SETUP_OEM_KEY2_EFIKEY | Set to one of the defined EFI_KEY enumeration.
SETUP_OEM_KEY2_ENABLE | Enable or disable the SETUP_OEM_KEY2
SETUP_OEM_KEY2_LEGACY_CODE | Set legacy code for OEM key 2.
SETUP_OEM_KEY2_SCAN | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol
SETUP_OEM_KEY2_SHIFT | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
SETUP_OEM_KEY2_TOGGLE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
SETUP_OEM_KEY2_UNICODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'
SETUP_OEM_KEY3_EFIKEY | Set to one of the defined EFI_KEY enumeration.
SETUP_OEM_KEY3_ENABLE | Enable or disable the SETUP_OEM_KEY3
SETUP_OEM_KEY3_LEGACY_CODE | Set legacy code for OEM key 3.
SETUP_OEM_KEY3_SCAN | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol
SETUP_OEM_KEY3_SHIFT | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
SETUP_OEM_KEY3_TOGGLE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
SETUP_OEM_KEY3_UNICODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'
SETUP_OEM_KEY4_EFIKEY | Set to one of the defined EFI_KEY enumeration.
SETUP_OEM_KEY4_ENABLE | Enable or disable the SETUP_OEM_KEY4
SETUP_OEM_KEY4_LEGACY_CODE | Set legacy code for OEM key 4.
SETUP_OEM_KEY4_SCAN | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol
SETUP_OEM_KEY4_SHIFT | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
SETUP_OEM_KEY4_TOGGLE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT_EX protocol.
SETUP_OEM_KEY4_UNICODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'
SETUP_ORPHAN_PAGES_AS_ROOT_PAGE | Allows Orphan IFR Pages to be relocated to root pages.
SETUP_PASSWORD_LENGTH | Default maximum password length.
SETUP_PASSWORD_NON_CASE_SENSITIVE | Allow to use of case sensitive password.
SETUP_PCX_LOGO_SUPPORT | PCX Logo support in Setup
SETUP_PNG_LOGO_SUPPORT | PNG Logo support in Setup.
SETUP_PRINT_ENTER_BBSPOPUP_MSG | Set to 1 to print the Setup BBS Popup Menu messages in Post.
SETUP_PRINT_ENTER_SETUP_MSG | Set to 1 to print the Setup Enter messages in Post
SETUP_PRINT_EVAL_MSG | Enable/Disable Evaluation message in Post screen
SETUP_ROOT_PAGE_ORDER_GUID | Setup root Page Order Guid.
SETUP_RUNTIME_IFR_PROCESSING | Processes IFR data that are added to hii at runtime. This will cause an increased FW footprint and remove AMIBCP compatibility for those new pages.
SETUP_SAVE_PSWD_TO_NVRAM | 1 => Save password to Nvram. 0 => Save password to cache.
SETUP_SHOW_ALL_BBS_DEVICES | 1 => Shows all BBS devices in boot override menu. 0 => Shows only the first device of a BBS type in override menu.
SETUP_STORE_EFI_KEY_PASSWORD | This Token becomes Obsolete after adding the Token SETUP_STORE_KEYCODE_PASSWORD. / Enables support to store EFI_KEYs as password. TSE Sources should be required to present to Enable this token.
SETUP_STORE_KEYCODE_PASSWORD | For Extened Password support, the Value can be 1 or 2. Set Value as 1 to support Efi Key as password. Set Value as 2 to support Scan Code in password. Need AMIKeyCode Protocol & TSE sources support.
SETUP_SUPPORT_ADD_BOOT_OPTION | Set to enable Add/Delete boot option.
SETUP_SUPPORT_ADD_DRIVER_OPTION | Set to enable Add/Delete Driver option.
SETUP_SUPPORT_KEY_MONITORING | Enable or Disable monitoring keys during Legacy mode.
SETUP_SUPPORT_PLATFORM_LANG_VAR | Set to enable PlatformLang and PlatformLangCode Vars.
SETUP_SUPPORT_RES_ADD_DEL_BOOT_OPTION_NAME | Not to allow Reserved Names (RESERVED_ADD_DEL_BOOT_OPTION_NAME) for new Boot Options. Reserved names defined in RESERVED_ADD_DEL_BOOT_OPTION_NAME SDL token.
SETUP_TIMEOUT_IN_TENTHOFSEC | Maks the Setup Timout value as 1/10 Sec to support fast boot. Makesure to change the Vfr and Strings if this is ON.
SETUP_TOGGLE_KEY_SCANCODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol.
SETUP_TOGGLE_KEY_UNICODE | Set to one of the defined constants from EFI_SIMPLE_TEXT_INPUT protocol or a character value like L'a'.
SETUP_UPDATE_BOOT_ORDER_CURSOR | When the boot order is changed, the cursor moves with the selection. Else, the cursor remains in the same location as the current question.
SETUP_USE_AMI_DEFAULTS | Use AMIBCP compatible defaults instead of HII defaults
SETUP_USER_PASSWORD_POLICY | Allow to use system with Admin password set and User password NOT set (Boot Password policy)
SHELL_TEXT_MODE | Assign the GC_MODE while boot to SHELL.\0xFF = ignored, 0/1/2/.. = GC_MODE0/GC_MODE1/GC_MODE2/..
SHOW_FORMSETS_WITH_CLASSGUID | 1 is DEFAULT.1 => To display formset based on ClassGUID add formsetClassGUID in elink AMITSE_FILTER_CLASSGUID_FORMSETS(By default this elink has EFI_HII_PLATFORM_SETUP_FORMSET_GUID). 0 => To display all formset and no filter in formsets.
SINGLE_CLICK_ACTIVATION | On- Single click will be used to enter the subMenu and Select the option. OFF- Double Click will be used.
STYLE_DATE_FORMAT | Controls the Date Format. (Default 0 => mm/dd/yyyy) (1 => yyyy/dd/mm)
STYLE_HELP_AREA_SCROLLBAR | Support Scrollable Help Text.
STYLE_SHOW_DAY | Controls the display of Day in Date Format.
SUPPORT_ESRT | Enable to support ESRT.
SUPPRESS_HANDLE_FOR_VAR_CREATION | 0 is DEFAULT.0 => Includes handle comparison to create new variable cache in TSE. 1 => Won't compare handle to create new variable. The variable detail should present in AMITSE_DYNAMICPARSING_HANDLE_SUPPRESS_LIST to not compare handle.
SUPPRESS_PRINT | A switch to supress TSE Debug messages.

Built on 16:15:49 10/01/14


Functions in Alphabetical Order

T

Function | Description
TimeOutLoopHook | This function is a hook called in every iteration (not every second) while TSE is waiting for Post time out. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
TseDebugDisableApplicationDestructor | Returns token value TSE_DBG_DISABLE_APPDESTRUCTOR
TseDefaultSetupPasswordSupported | Returns token value TSE_DEFAULT_SETUP_PASSWORD_SUPPORT
TSEDonotLoadPasswordOnDefaults | Returns the token value for TSE_DONOT_LOAD_PASSWORD_ON_DEFAULTS
TSEIDEPasswordAuthenticate | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TSEIDEPasswordCheck | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TSEIDEPasswordFreezeDevices | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TSEIDEPasswordGetDataPtr | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TSEIDEPasswordGetLocked | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TSEIDEPasswordGetName | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TSEIDEPasswordUpdate | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TSEIDEUpdateConfig | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TseIgnoreKeyForFastBoot | Function to return FastBoot is ENABLED or DISABLED Parameter: VOID Return value: BOOLEAN
TseLaunchFileSystem | This function to handle launching file system
TSEMouseDestroyHook | Hook function which is called when Mouse Destory is done.
TSEMouseIgnoreMouseActionHook | Hook function which can make TSE to Ignore the mouse action. This function is called whenever TSE read the mouse action This hook need to be used carefully. It can used in the cases when Mouse actions consumes by modules like Softkeyboard and not to be used by TSE
TSEMouseInitHook | Hook function which is called when Mouse init is done.
TSEMouseRefreshHook | Hook function which is called when Mouse Refresh action is done.
TSEMouseStartHook | Hook function which is called when Mouse start action is done.
TSEMouseStopHook | Hook function which is called when Mouse Stop is done.
TsePrintScreenSupport | Function to return print screen support feature
TSEPwdSavetoNvram | Returns the token value for SETUP_SAVE_PSWD_TO_NVRAM
TseRtAccessSupport | Returns token RT_ACCESS_SUPPORT_IN_HPKTOOL value
TSESetHDDPassword | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TSEStringReadLoopEntryHook | Hook function which is called when Strings/Password is going to be read.
TSEStringReadLoopExitHook | Hook function which is called after Strings/Password read.
TseSuppressOneofMultilineSupport | Function to return TSE_SUPPRESS_MULTILINE_FOR_ONEOFLABEL value Parameter: VOID Return value: BOOLEAN
TSEUnlockHDD | Hook function for the IDE Password fuctionality based on the security token SETUP_IDE_SECURITY_SUPPORT
TseUpdateRootPageOrder | This function is to update the Root page order from the specified elink.

Data Structure | Description
TSE_ADMIN_PASSWORD | Defaultly no password is given. Provide data to set as default admin password. Maximum string can be provide is based on SETUP_PASSWORD_LENGTH token. String should be atleat minimum length mentioned in vfr. If no password is given it will not set any default password. Note: specify EMPTY_DATA in value if default admin password is not required.
TSE_ANSI_ESC_CODE_SUPPORT | Tse advanced Esc colour support
TSE_APTIO_5_SUPPORT | Turn on to to build under Aptio 5.
TSE_BEST_TEXT_GOP_MODE | 0 is DEFAULT.1 => To save and restore text(100*31) and GOP(800*600) mode before using any TSE Interfaces in Post/after TSE. 0 => Not to ; handle text and GOP mode before using any TSE interfaces in Post/after TSE and use Post mode without any change.
TSE_BOOT_NOW_IN_BOOT_ORDER | Turn on to see boot override menu with in the devices listed in boot order.
TSE_BOOT_ONLY_SPLASH_LOGO_SUPPORT | Turn on the TSE to make boot only driver without UI
TSE_BOOT_TIME_OUT_AS_ZERO | 1=>Provides Boot time out value as zero 0=> Reads from the NVRAM, defaultly it is disabled.
TSE_CALLBACK_SPEC_VERSION | Version to change the callback functionality.
TSE_CAPITAL_BOOT_OPTION | This Token Stores/Creates the Boot Option numbers to Capital Hex Numbers.
TSE_CLEAR_USERPW_WITH_ADMINPW | Support to clear the User password if Admin password is empty
TSE_CONTINUE_BOOT_NOW_ON_FAIL | Turn on to continue boot to other device when selected one fails.
TSE_CSM_SUPPORT | Include CSM Support in TSE
TSE_CURSOR_SUPPORT | Token to display cursor for string, password type controls.ENABLE is default.1=>To display cursor in TSE.0=>Not to display cursor in TSE.
TSE_DBG_DISABLE_APPDESTRUCTOR | 0 => Free the TSE used memory. 1 => Won't free the TSE used memory, may be used only for debugging purposes. CAUTION: If making the token to 1 then TSE won't free the memory it used. We recommend not to make it enable..
TSE_DEBUG_MESSAGES | A switch to enable TSE Debug messages: Bit0: Uefi functions, Bit1: HiiCallbacks, Bit2: HiiNotifications, Bit3: HiiParsing.
TSE_DEFAULT_SETUP_PASSWORD_SUPPORT | 0 is default.set 1=> to Enable default setup password.
TSE_DEVICE_PATH_NAME | Turn on to be able to configure name for legacy devices.
TSE_DEVICE_PATH_UEFI_NAME | Turn on to be able to configure name for UEFI devices using Device path.
TSE_DONOT_LOAD_PASSWORD_ON_DEFAULTS | 1 => Will not load defaults for password when we press F3. 0 => Load default passowrd.
TSE_DONOT_LOAD_SYSTEM_ACCESS_FOR_USER_DEFAULT | 0 is DEFAULT.1 => To enable to not to load SystemAccess variable on pressing Restore User Default. 0=> To load SystemAccess variable on pressing Restore User Default
TSE_FOR_64BIT | Enable build support for 64 bit(x64/IA64) TSE
TSE_HASH_PASSWORD | 0 is Default. 1 => To encode the entered password using hash algorithm. 0 => Encode entered password using TSE logic.
TSE_HOOKBASE_VALUE | Base value for the HOOK defines that Allows to manage TSE HOOKs.Format 0xXXXX0000,Makeure it is not conflicts physical memory Address
TSE_IGNORE_KEY_FOR_FASTBOOT | DISABLE is default. 1=> To ignore check for key when FastBoot is enabled. 0=> Allow check for key when FastBoot is enabled.
TSE_LOAD_DEFAULTS_FROM_DEFAULTS_BUFFER | 0 => Will not load defaults from Default buffer(NVRAM.bin) on pressing F3. 1 => Will Load default from the default buffer.
TSE_LOAD_OPTION_HIDDEN | 1 => Hide LOAD_OPTION_HIDDEN Boot option. 0 => Shows all boot options.
TSE_LOAD_PASSWORD_ON_DEFAULTS | Loads the User/Admin password from Defaults.If Off, Passwords are unaffected while loading defaults
TSE_MAX_DRIVE_NAME | Set the value to dispaly number of characters for Drive name.
TSE_MULTILINE_CONTROLS | Turns on multi line controls. Currently subtitle and static text controls are supported. Default is DISABLE.
TSE_NVRAM_DEFAULTS_SUPPORT | To enable NVRAM support in TSE modules. This token requires TSE Sources support.
TSE_OEM_POSTLOGO_SUPPORT | Enable to support OEMLogo image in postscreen.
TSE_POSTSCREEN_SCROLL_AREA | {TopRow, TopCol, BottomRow, BottomCol}. Used to Configure the TSE PostScreen Scroll Area. Note Post message are still printed in whole Screen.
TSE_PRESERVE_DISABLED_BBS_DEVICE_ORDER | Prevents TSE from repositioning disabled BBS boot in the boot order.
TSE_PRN_SCRN_EVENT_SUPPORT | Turn on to generate Print screen event if TSE_PRN_SCRN_KEY_SCAN key pressed.
TSE_ROMHOLE_HEADER_GUID | One among 16-GUID used to identify ROMHOLE by AMI utilities such as AFU, BCP, and MMTool. This value should sync with TSE_ROMHOLE_MAKFILE_GUID token value.
TSE_ROMHOLE_MAKFILE_GUID | One among 16-GUID used to identify ROMHOLE by AMI utilities such as AFU, BCP, and MMTool. If TSE_ROMHOLE_MAKFILE_GUID token value is changed then TSE_ROMHOLE_HEADER_GUID token value should update.
TSE_ROMHOLE_SUPPORT | TEnable to support ROMHOLE generation.
TSE_SAVE_DISABLED_BBS_DEVICEPATH | 1 => Saves the DevicePaths of Disabled BBS devices to NVRAM Variable. \Depends on that varaible to keep device disbaled in next boot. \0 => Doesn't save the Disabled BBS devicepath.
TSE_SETUP_GRAYOUT_SELECTABLE | 0 is DEFAULT. set 1=> to allow grayed-out options set focus and to be selectable by the user. Set 0=> to make grayed-out options not to focus ; and editable
TSE_SHOW_PROMPT_STRING_AS_TITLE | 0 is DEFAULT.1 => To use password control's prompt's string for Password Title. 0 => To use standard TSE string for Password Title.
TSE_SUPPORT_DEFAULT_FOR_STRING_CONTROL | 0 is DEFAULT. 1 => To construct optimal and failsafe defaults for STRING type controls based on CONTROLPtr from controlInfo.0 => Not to construct and load optimal and failsafe defaults for STRING type controls.
TSE_SUPPORT_NATIVE_RESOLUTION | Sets the graphics mode for quiet boot from EDID. 1 - Defaultly enable make 0 to disable the feature.
TSE_SUPPRESS_MULTILINE_FOR_ONEOFLABEL | 1=> is to suppress multiline support for one of option . 0=> is to support multiline for one of option which is defalut behaviour.
TSE_USE_AMI_EFI_KEYCODE_PROTOCOL | AMIKeyCode Protocol support. TSE Sources need to be present to enable this token.
TSE_USE_GETGYLPH_PRINTLENGH | Turn on to to build under Aptio 5.
TSE_USE_OEM_ACTION_READ_KEY | If user likes to read the key in their own way then enable this token and define _OemActionReadKey function.
TSE_USER_PASSWORD | Defaultly no password is given. Provide data to set as default user password. Maximum string can be provide is based on SETUP_PASSWORD_LENGTH token. String should be minimum length mentioned in vfr. If no password is given it will not set any default password. Note: specify EMPTY_DATA in value if default user password is not required.

Built on 16:15:50 10/01/14


Functions in Alphabetical Order

U

Function | Description
UefiBootFailHook | Board module hook for UefiBootFailHook function This function invoked when LoadImage fails
UIUpdateCallbackHook | Set OVERRIDE_UIUpdateCallbackHook to 1, if OEM wants to override the UIUpdateCallbackHook function from Board module.
UninstallBgrtWrapper | Wrapper function to call UninstallBgrtWrapper
UpdateNumericDisplayString | Board module hook for UpdateNumericDisplayString function This function invoked before displaying the numeric control Can use this function to change the display style of numeric control

Built on 16:15:50 10/01/14


Functions in Alphabetical Order

V

Function | Description
VariableHandleSuppressed | This function informs to match the handle or not for creating new variable using VAR_DYNAMICPARSING_HANDLESUPPRESS_LIST ELink

Built on 16:15:50 10/01/14


Functions in Alphabetical Order

W

Data Structure | Description
WIDE_GLYPH_SUPPORT | Far east language support

Built on 16:15:50 10/01/14


General Information

Header | Description
Driver_Integration | * This is the case adding a new driver into an Aptio project. If driver source code is available, add the driver source and rebuild the project. * Verify all the protocols used are present in the project * Make sure the dependencies are compatible between driver and project * The new setup page can only appear as top level menu item * In case only binary form is available, next are requirements, * The adding driver must have a unique GUID from the project * If the adding driver uses platform variables, make sure the setup definition in the project and the adding driver is completely identical * If private variables are used, make sure it has a different GUID and variable names are unique * Both the driver’s DXE and HPK files are required to put into the project * Use Setup.ini to indicate the location of driver setup page * It’s impossible the new page to be a submenu of an existing page
HII_Package_files | Aptio TSE performs a Post-processing of the information that will be stored into HII and saves the result into a separate section of the driver in order to allow Post-build configuration. This requires that the HII Package files, created by Intel’s VFRCOMPILE utility, be generated as inputs to the Aptio TSE build. These files are generated based on a command line parameter to the VFRCOMPILE utility. This command line can be specified using the VFRCOMPILE_FLAGS SDL token. This SDL token must be set to "-ibin" in order to generate the HPK files.
How_to_add_a_page | Adding a page to a VFR is quite simple. There are 2 pieces that make up a new page: the reference to the page from an existing page, and the new page definition itself: // inside an existing form goto MY_SETUP_FORM_ID, prompt = STRING_TOKEN(STR_MY_SETUP_PAGE), help = STRING_TOKEN(STR_MY_SETUP_PAGE_HELP); // after all form definitions form formid = MY_SETUP_FORM_ID, title = STRING_TOKEN(STR_MY_SETUP_PAGE); subtitle text = STRING_TOKEN(STR_SOME_TEXT_STRING); // additional controls go here endform;
How_to_display_a_dynamic_value | Dynamic text is fully supported by TSE. Creating and modifying dynamic text needs to follow certain rules. A dynamic text control is simply a TEXT VFR control with the INTERACTIVE flag set to true. In this case, the FORM_CALLBACK.Callback function is called every 100ms to refresh the contents of the displayed control. It is the requirement of the callback routine to update the string in the HII database with the new value to be displayed. The callback interval can be managed in multiple ways. It can be changed in the setup data using a tool such as AMIBCP. It can also be managed programmatically in the callback routine itself. Example: #define CPU1_TEMP_KEY 0x1234 text help = STRING_TOKEN(STR_NULL_STRING), text = STRING_TOKEN(STR_CPU1_TEMP_PROMPT), text = STRING_TOKEN(STR_CPU1_TEMP_VAL), flags = INTERACTIVE, key = CPU1_TEMP_KEY; This definition into the VFR file will automatically cause TSE to create a dynamic text control. It is the responsibility of the callback routine (most likely published by a separate DXE driver) to update the temperature data. Sample pseudo-code for the callback is listed below: CHAR16 gUpdateString[256]; EFI_STATUS Callback( ..., UINT16 key, ... ) { switch ( key ) { case CPU1_TEMP_KEY : UINT16 stringRef = STRING_TOKEN(STR_CPU1_TEMP_VAL); UINTN cpuTemp = GetCPUTemp( CPU1 ); SPrint( gUpdateString, sizeof( gUpdateString ), L"%d", cpuTemp ); // this call to NewString replaces the string in HII HII->NewString( HII, L"eng", handle, &stringRef, gUpdateString ); break; } }
How_to_display_message_in_the_POST_screen | TSE publishes a function called DisplayPostMessage as part of AMI_POST_MANAGER (formerly MRE_HAND_SHAKE) protocol. Other drivers can use this function to display UNICODE strings in Post screen. Prototype for DisplayPostMessage is provided in AMIPostMgr.h typedef EFI_STATUS (EFIAPI *AMI_POST_MANAGER_DISPLAY_MESSAGE) ( CHAR16 *Message typedef struct _AMI_POST_MANAGER_PROTOCOL { AMI_POST_MANAGER_HANDSHAKE Handshake; AMI_POST_MANAGER_DISPLAY_MESSAGE DisplayPostMessage; }AMI_POST_MANAGER_PROTOCOL;
How_to_display_value_which_may_change_from_boot_to_boot | Changing strings can be accomplished through a couple of different means. One, which is used for such facilities as memory sizing and hard drive identification, is to update a string into HII that has been put there as a placeholder. For example, a memory VFR might look like: text help = STRING_TOKEN(STR_NULL_STRING), text = STRING_TOKEN(STR_TOTAL_MEMORY_SIZE_PROMPT), text = STRING_TOKEN(STR_MEMORY_SIZE_VAL), flags = 0, key = 0; In the firmware, there will be code that updates the place holder string STR_MEMORY_SIZE_VAL with the actual string for the size. For example, CHAR16 string[20] ; SPrint( string, 20, L"%dMB", memosrySize ) ; Hii->AddString( Hii, &token, string ) ; This can also be accomplished in concert by code into the firmware and the VFRs themselves. First, a structure should be defined into which the data to be shared is stored. Then, along with a name and GUID, a volatile EFI variable my be defined. This is accomplished by setting the variable WITHOUT the EFI_VARIABLE_NON_VOLATILE flag. // inside a firmware driver Status = gRT->SetVariable( L"MyVariable", &myGuid, EFI_VARIABLE_BOOTSERVICE_ACCESS, &myVariableStruct, sizeof(myVariableStruct) Into the VFR, a varstore must be created (similar to the one above) and used to access this variable.
How_to_gray_out_or_suppress_a_control | The following example shows how to gray out or suppress a control from within the VFR definition file. grayoutif ideqval SYSTEM_ACCESS.Access == SYSTEM_PASSWORD_USER; oneof varid = SetupMap.IdeMode, prompt = STRING_TOKEN(STR_IDE_MODE_PROMPT), help = STRING_TOKEN(STR_IDE_MODE_HELP), option text = STRING_TOKEN(STR_DISABLE), value = 0, flags = RESET_REQUIRED; option text = STRING_TOKEN(STR_ENABLE), value = 1, flags = DEFAULT | RESET_REQUIRED; endoneof; endif;
How_to_integrate_an_EFI_application | Integrating an EFI application into the setup data is very simply done, using AMI’s extensions. There are multiple steps involved in creating a launch, but none involve modifying source code. First, define your variable store within your VFR file. The actual structure of the variable store is not used, so we simply define a basic structure: typedef struct _MY_OEM_PACK { UINT16 Value; } MY_OEM_PACK; varstore MY_OEM_PACK, key = MY_OEM_PACK_KEY_ID, name = application.efi, guid = MY_OEM_PACK_GUID; The important things to keep in mind with the above definitions are that the GUID and the key uniquely identify your application. Next, define VFR entry as follows. It will always be a reference wrapped by a suppress clause: // compare against a non-zero value so the suppress condition will fail. suppressif ideqval MY_OEM_PACK.Value == 1; // OEM_FORM_ID can be either an empty form defined elsewhere in the VFR // or the containing form’s formid value goto OEM_FORM_ID, prompt = STRING_TOKEN(STR_MY_OEM_APPLICATION), help = STRING_TOKEN(STR_MY_APPLICATION_HELP); endif; Last step is to define your behavior into the SETUP.INI file so that TSE will understand the overridden HII construct. [GUIDx] ; where x is the next available GUID number in the file guid = XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX name = unused key = XXXX ; this should be the same key value defined in the varstore flags = 6 ; these are the flags that tell what the action to perform is ; the values can be Ored togeteher to create multiple actions: ; 1 – signifies that the callback is AMI internal ; 2 – the GUID is treated as a filename in FV and launched ; 4 – the name defined in the varstore is treated as an EFI ; executable name and is launched from the filesystem ; Using 4 and 2 together will try FV first, then filesystem
How_to_provide_Default_boot_order | To have this functionality; on every boot in addition to creating / updating "BootOrder" and "LegacyDevOrder" variables based on the addition and removal of boot devices; BDS should also create / update the variables "DefaultBootOrder" and "DefaultLegacyDevOrder". "DefaultBootOrder" and "DefaultLegacyDevOrder" are variables introduced to provide TSE with the default ordering of devices. TSE displays these default orders when the user is loading optimal defaults. Details of default boot order variable VariableName: "DefaultBootOrder" Guid: 45cf35f6-0d6e-4d04-856a-0370a5b16f53 Details of default legacy device order variable VariableName: "DefaultLegacyDeviceOrder" Guid: 3c4ead08-45ae-4315-8d15-a60eaa8caf69 PS: If these variables are not present TSE will load the values of the BootOrder and LeagacyDevOrder variables it entered with as default values
How_To_Switch_to_different_Style | Clone and change the following SDL token settings. Ezport Style TSE_STYLE_EZPORT_BIN_SUPPORT = ON TSE_STYLE_EZPORT_SUPPORT = ON TSE_STYLE_LEGACY_BIN_SUPPORT = OFF TSE_STYLE_LEGACY_SUPPORT = OFF TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = OFF TSE_STYLE_EZPORTPLUS_SUPPORT = OFF Legacy Style TSE_STYLE_EZPORT_BIN_SUPPORT = OFF TSE_STYLE_EZPORT_SUPPORT = OFF TSE_STYLE_LEGACY_BIN_SUPPORT = ON TSE_STYLE_LEGACY_SUPPORT = ON TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = OFF TSE_STYLE_EZPORTPLUS_SUPPORT = OFF EzportPlus Style TSE_STYLE_EZPORT_BIN_SUPPORT = OFF TSE_STYLE_EZPORT_SUPPORT = OFF TSE_STYLE_LEGACY_BIN_SUPPORT = OFF TSE_STYLE_LEGACY_SUPPORT = OFF TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = ON TSE_STYLE_EZPORTPLUS_SUPPORT = ON
Image_formats | The OEM logo image that is used in Aptio TSE is BMP and GIF format. Future versions will support other image formats (like PCX and JPG). There are no color depth restrictions for this image. The image cannot be an RLE encoded bitmap or otherwise compressed bitmap. Compression is referring to image compression as defined by the BMP format, not EFI compression. The image is designed to fit into a specified area of the screen. The dimensions of the image file should be set accordingly. The default image dimensions are listed below, SmLogo: 400x100
Localization | One of the many features of Aptio, is the ability to easily work with multiple languages. Aptio TSE is no exception. Aptio TSE uses the exact same .UNI string management as the Aptio project itself.
Post | Any of the images associated with Aptio can be modified after the firmware has been built using the AMI ChangeLogo tool. The rendering information may be modified together with other information like Optimal and Failsafe values may be customized after the firmware has been built using the AMIBCP tool.
Setup_path_in_MINISETUP | Since Aptio TSE accesses the default setup NVRAM storage directly, it is important that the correct layout of the NVRAM variable is known by TSE. This requires TSE to include the SetupVariable.h header file specific to the current project. This header file will be located in the SAME directory where the setup .VFR files are kept. The SETUP_PATH variable in the MINISETUP.MAK must match the path, relative to the root of the Aptio project. For example, for an Intel D865GCH R6-based Aptio project, this should be set as follows, SETUP_PATH = Platform\IntelDpg\D865GCH\DXE\D865GCHPlatform\Setup
TSE_FAQ | Q: The strings do not show up on the screen. A: There are several possible solutions to this problem. There could be an issue with the VFR creation. TSE expects each formset in the VFR files to have the same GUID but unique CLASS and SUBCLASS identifiers. There could be strings that are not defined into the .UNI file. This is unlikely as this would be caught during the build process. Q: Setup doesn't find any of my pages. A: Make sure that the GUID defined for your formsets matches the GUID defined into the main section of the SETUP.INI file. Q: How do I use multiple variables? A: TSE fully supports multiple variables defined into the VFR files. But, there is a caveat. The default variable (usually defined using the formset GUID and the name "Setup") must also be re-defined. This is a workaround for a faulty VFR compiler. These variables should be defined using the VFR command varstore. See the previous section for examples of how to use the varstore command. Q: How do I use the reference VFR files that are included into the TSE package? A: These VFR files are used in exactly the same way the platform VFR files are used. There are a couple of things that need to be modified into the platform code to install them. The .CIF file that includes the VFR files for the platform should be modified to reflect the new files. The file PLATFORM.C should be modified to install the new HII packs into the HII database. This includes defining new variables for the new VFR binaries, adding these binaries to the function call that installs the HII packs, etc. The VFR files should be copied to the platform setup directory to be included into the build process.

Built on 16:15:54 10/01/14


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2011 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.