American Megatrends, Inc.

AmiBoardInfo

Copyright

Release Notes

© American Megatrends, Inc.


Release Notes - NDA Required

Component Information:
Component Title: AMI Board Information Driver
Component Reference Name: AmiBoardInfo
Component Type: ModulePart
Release Date: 2011-12-16
Source Control Label: 4651_AMI_BOARD_2.1.0
Source Control Location: SS: $/Alaska/BIN/Core\Modules/BoardInfo;

Dependencies
EFI Architecture Protocols
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
This SubComponent is a part of Aptio Core
. It groups together AMI SDL AUTOGENERATED OUTPUT data used for Platform porting and provides it to all possible consumers of this information in a form of AMI_BOARD_INFO_PROTOCOL.
AmiBoardInfo Component Files
Filename | Description
AmiBoardInfo.cif | AmiBoardInfo Component Information File
AmiBoardInfo.c | AmiBoardInfo Driver Code
AmiBoardInfo.chm | Component CHM Help File
AmiBoardInfo.dxs | AmiBoardInfo dependency File
AmiBoardInfo.mak | Component MAKE file.
AmiBoardInfo.sdl | Component SDL file
PciBoard.c | File that groups AMI SDL generated OUTPUT Data

ModulePart Name: AmiBoardInfoIncludes
ModulePart Description: Allows locate AmiBoardInfo.h file in <\Include\Protocol> Folder.
Filename | Description
AmiBoardInfoIncludes.cif | SubComponent for Component Common Include files
AmiBoardInfo.h | AMI Board Info Protocol Definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_38 or UPPER, Dated: 2011-12-16
Visual eBios: RSS.VeB 5.72.0217 or UPPER, Dated: 2011-12-16
Compiler Tool(s): NAME with VERSION
New features added in this label:
Added Nested FFS section to have BCP tool ipdate IRQ Routing info.
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
N/A
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bu General Bug Fixes
N/A

EIP Addressed
(EIP #64425 New AMISDL output format for PCI IRQ
Known Limitations and Erratas in this label:
N/A
Remaining Issues:
N/A
Unit Testing:
Core Release procedure
Validation Testing:
Core Release procedure
Release History:
N/A

© American Megatrends Inc.=======================-->


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • AmiBoardInfo.c
  • AmiBoardInfo.dxs
  • AmiBoardInfo.h
  • AmiBoardInfo.mak
  • PciBoard.c
Built on 16:57:32 12/16/11


AmiBoardInfo.c

Description:

The following functions are used in the file: AmiBoardInfo.c.

Function | Description
ParseAmiSdlData | Seaarches SDL Generated Data structures for specific table Signature.
PciBusEntryPoint | This function is the entry point for AMI Board Info Driver. There it will initialize some global data and install an instance of AMI_BOARD_INFO_PROTOCOL.

The following data structures are used in the file: AmiBoardInfo.c.

Variable | Description
gAmiBoardProtocol | Ami Board Info Protocol Instance.
gAmiBoardProtocolHandle | Ami Board Info Protocol Handle.


gAmiBoardProtocol in the AmiBoardInfo.c

Variable : gAmiBoardProtocol

File: AmiBoardInfo.c
Description:
Ami Board Info Protocol Instance.


gAmiBoardProtocolHandle in the AmiBoardInfo.c

Variable : gAmiBoardProtocolHandle

File: AmiBoardInfo.c
Description:
Ami Board Info Protocol Handle.


ParseAmiSdlData in the AmiBoardInfo.c

Function : ParseAmiSdlData

File: AmiBoardInfo.c
Description:
Seaarches SDL Generated Data structures for specific table
Signature.
Input:
UINT8*  IN   *DataPtr    Pointer To the beginning of SDL Data.
UINTN   IN   DataLen     Number of bytes to parse.
UINT32  IN   Signature   Table Signature to Look for.
VOID**  IN OUT TblPtr    Double Pointer To return desired tble start address.
Output:
EFI_STATUS
EFI_SUCCESS             When everything is going on fine!
EFI_NOT_FOUND		    When there are no more handles to override.
EFI_INVALID_PARAMETER   When Parameter passed is invalid.


PciBusEntryPoint in the AmiBoardInfo.c

Function : PciBusEntryPoint

File: AmiBoardInfo.c
Description:
This function is the entry point for AMI Board Info Driver.
There it will initialize some global data and install an instance of
AMI_BOARD_INFO_PROTOCOL.
Input:
EFI_HANDLE          ImageHandle     Image handle.
EFI_SYSTEM_TABLE    *SystemTable    Pointer to the EFI system table.
Output:
EFI_STATUS
EFI_SUCCESS         When everything is going on fine!
EFI_NOT_FOUND       When something required is not found!
EFI_DEVICE_ERROR    When the device is not responding!


AmiBoardInfo.dxs

Description:
Dependency expression for the AMI Board Info Driver


AmiBoardInfo.h

The following data structures are used in the file: AmiBoardInfo.h.

Variable | Description
AMI_APIC_INFO | Structure used to describe IO/APIC Information
PCI_APIC_IRQ_DATA | Structure used to describe (APIC) IRQ Routing DATA.
PCI_BUS_XLAT_HDR | Structure used to describe Extended (IO/APIC) IRQ Routing Information. AUTOGENERATED DATA.
PCI_DEV_FUN | UNION of UINT8 and a Structure used to describe AMISDL format for PCI Device Function Package. Packed PCI DEV/FUNCTION number.
PCI_IRQ_APIC_ROUTE | Structure used to describe Extended (IO/APIC) IRQ Routing Information. AUTOGENERATED DATA.
PCI_IRQ_PIC_ROUTE | Structure used to describe Legacy (PIC) IRQ Routing Information. AUTOGENERATED DATA.
PCI_PIC_IRQ_DATA | Structure used to describe PCI IRQ Router Register and available IRQ MASK used by AMISDL output format.


AMI_APIC_INFO in the AmiBoardInfo.h

Variable : AMI_APIC_INFO

File: AmiBoardInfo.h
Fields:

Name | Type | Description
BusBuild | UINT8 | PCI Bus# Assigned at BIOS build time
BusRun | UINT8 | PCI Bus# Assigned at run time
Bridge | PCI_DEV_FUN | Describes bridges chain

Description:
Structure used to describe IO/APIC Information


PCI_APIC_IRQ_DATA in the AmiBoardInfo.h

Variable : PCI_APIC_IRQ_DATA

File: AmiBoardInfo.h
Fields:

Name | Type | Description
IoApicItin | UINT8 | IO/APIC INTIN pin
IoApicId | UINT8 | IO/APIC ID value

Description:
Structure used to describe (APIC) IRQ Routing DATA.


PCI_BUS_XLAT_HDR in the AmiBoardInfo.h

Variable : PCI_BUS_XLAT_HDR

File: AmiBoardInfo.h
Fields:

Name | Type | Description
BusBuild | UINT8 | PCI Bus# Assigned at BIOS build time
BusRun | UINT8 | PCI Bus# Assigned at run time
Bridge | PCI_DEV_FUN | Describes bridges chain

Description:
Structure used to describe Extended (IO/APIC) IRQ Routing
Information. AUTOGENERATED DATA.


PCI_DEV_FUN in the AmiBoardInfo.h

Variable : PCI_DEV_FUN

File: AmiBoardInfo.h
Fields:

Name | Type | Description
DEV_FUN | UINT8 | Device / Function all together
Fun | UINT8 | PCI Device's Function
Dev | UINT8 | PCI Device's Device

Description:
UNION of UINT8 and a Structure used to describe AMISDL format
for PCI Device Function Package. Packed PCI DEV/FUNCTION number.


PCI_IRQ_APIC_ROUTE in the AmiBoardInfo.h

Variable : PCI_IRQ_APIC_ROUTE

File: AmiBoardInfo.h
Fields:

Name | Type | Description
PciBusNumber | UINT8 | PCI Bus
DeviceNumber | UINT8 | PCI Device
Intn | 4 | ] PCI_APIC_IRQ_DATA APIC IRQ Routing Info.
Reserved | UINT8

Description:
Structure used to describe Extended (IO/APIC) IRQ Routing
Information. AUTOGENERATED DATA.


PCI_IRQ_PIC_ROUTE in the AmiBoardInfo.h

Variable : PCI_IRQ_PIC_ROUTE

File: AmiBoardInfo.h
Fields:

Name | Type | Description
PciBusNumber | UINT8 | PCI Bus
DevFun | PCI_DEV_FUN | PCI Device # \ Function
PciIrq | 4 | ] PCI_PIC_IRQ_DATA Register \ IRQ MASK
SlotNum | UINT8 | Pci Slot # or 0 if embeded device
Reserved | UINT8

Description:
Structure used to describe Legacy (PIC) IRQ Routing Information.
AUTOGENERATED DATA.


PCI_PIC_IRQ_DATA in the AmiBoardInfo.h

Variable : PCI_PIC_IRQ_DATA

File: AmiBoardInfo.h
Fields:

Name | Type | Description
ChipsetReg | UINT8 | Chipset register number
IrqMask | UINT16 | IRQ MASK for legacy Interrupts

Description:
Structure used to describe PCI IRQ Router Register and available
IRQ MASK used by AMISDL output format.


AmiBoardInfo.mak

Description:
Make file to create AmiBoardInfo Driver


PciBoard.c

Description:


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

  • A
  • G
  • P


Functions in Alphabetical Order

A

Data Structure | Description
AMI_APIC_INFO | Structure used to describe IO/APIC Information


Functions in Alphabetical Order

G

Data Structure | Description
gAmiBoardProtocol | Ami Board Info Protocol Instance.
gAmiBoardProtocolHandle | Ami Board Info Protocol Handle.


Functions in Alphabetical Order

P

Function | Description
ParseAmiSdlData | Seaarches SDL Generated Data structures for specific table Signature.
PciBusEntryPoint | This function is the entry point for AMI Board Info Driver. There it will initialize some global data and install an instance of AMI_BOARD_INFO_PROTOCOL.

Data Structure | Description
PCI_APIC_IRQ_DATA | Structure used to describe (APIC) IRQ Routing DATA.
PCI_BUS_XLAT_HDR | Structure used to describe Extended (IO/APIC) IRQ Routing Information. AUTOGENERATED DATA.
PCI_DEV_FUN | UNION of UINT8 and a Structure used to describe AMISDL format for PCI Device Function Package. Packed PCI DEV/FUNCTION number.
PCI_IRQ_APIC_ROUTE | Structure used to describe Extended (IO/APIC) IRQ Routing Information. AUTOGENERATED DATA.
PCI_IRQ_PIC_ROUTE | Structure used to describe Legacy (PIC) IRQ Routing Information. AUTOGENERATED DATA.
PCI_PIC_IRQ_DATA | Structure used to describe PCI IRQ Router Register and available IRQ MASK used by AMISDL output format.


General Information


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2011 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.