American Megatrends, Inc.

CSM Opt-out module

Copyright

Release Notes

© American Megatrends, Inc.


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2012 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.


Release Notes - NDA Required

Component Information:
Component Title: CsmOptOut
Component Reference Name: CsmOptOut
Component Type: eModule
Release Date: 2013-11-01
Source Control Label: 4.6.5.4_Csm_OptOut_05
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/CsmOptOut;

Dependencies
NONE
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
Component Description:
CsmOptOut allows to enable/disable CSM usage, filters UEFI/Legacy boot options, selects UEFI/Legacy OptionROM execution order
Filename | Description
CsmOptOut.cif | VeB component description file
CsmOptOut.sdl | Component configuration file
CsmOptOut.mak | Component make file
CsmOptOut.c | Main functionality implementation file
CsmOptOut.chm | Component help file
CsmOptOut.sd | Component setup controls definition file
CsmOptOut.uni | Component setup strings file
CsmOptOutRuntime.c | Component runtime entrypoint
CsmOptOutSetup.c | Setup control callback

AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft™s Windows Driver Kit (WDK) Ver. 7600.16385.1
Compiler Tool(s): Microsoft Windows Driver Development Kit (DDK) Ver. 3790.1830
New features added in this label:
Added option "UEFI only" for OptionRoms of unknown types
General Bug Fixes:
None
EIP addressed in this label:
106504
126445
Files changed:
CsmOptOut.c
CsmOptOut.uni
CsmOptOut.sd
CsmOptOut.sdl
Known issues and limitations in this label:
None
Remaining Issues:
None
Unit Testing:
Passed
Validation Testing:
Passed
Release History:
Release_04
Release_03
Release_02
Release_01
Release_00

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: CsmOptOut
Component Reference Name: CsmOptOut
Component Type: eModule
Release Date: 2011-12-16
Source Control Label: 4.6.5.2_Csm_OptOut_00
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/CsmOptOut;

Dependencies
NONE
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
Component Description:
CsmOptOut allows to enable/disable CSM usage, filters UEFI/Legacy boot options, selects UEFI/Legacy OptionROM execution order
Filename | Description
CsmOptOut.cif | VeB component description file
CsmOptOut.sdl | Component configuration file
CsmOptOut.mak | Component make file
CsmOptOut.c | Main functionality implementation file
CsmOptOut.chm | Component help file
CsmOptOut.sd | Component setup controls definition file
CsmOptOut.uni | Component setup strings file
CsmOptOutTseHook.c | Check OS loader TSE component

AMI Build Tools:
Tools Label: 4.5.5_Tools_36, Dated: 2011-06-30
Visual eBios: RSS.5.68.0063, Dated: 2009-07-29
Compiler Tool(s): Microsoft™s Windows Driver Kit (WDK) Ver. 7600.16385.1
Compiler Tool(s): Microsoft Windows Driver Development Kit (DDK) Ver. 3790.1830
New features added in this label:
Initial release
General Bug Fixes:
None
EIP addressed in this label:
None
Files changed:
None
Known issues and limitations in this label:
None
Remaining Issues:
None
Unit Testing:
Passed
Validation Testing:
Passed
Release History:

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: CsmOptOut
Component Reference Name: CsmOptOut
Component Type: eModule
Release Date: 2012-01-27
Source Control Label: 4.6.5.3_Csm_OptOut_01
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/CsmOptOut;

Dependencies
NONE
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
Component Description:
CsmOptOut allows to enable/disable CSM usage, filters UEFI/Legacy boot options, selects UEFI/Legacy OptionROM execution order
Filename | Description
CsmOptOut.cif | VeB component description file
CsmOptOut.sdl | Component configuration file
CsmOptOut.mak | Component make file
CsmOptOut.c | Main functionality implementation file
CsmOptOut.chm | Component help file
CsmOptOut.sd | Component setup controls definition file
CsmOptOut.uni | Component setup strings file
CsmOptOutTseHook.c | Check OS loader TSE component

AMI Build Tools:
Tools Label: 4.5.5_Tools_36, Dated: 2011-06-30
Visual eBios: RSS.5.68.0063, Dated: 2009-07-29
Compiler Tool(s): Microsoft™s Windows Driver Kit (WDK) Ver. 7600.16385.1
Compiler Tool(s): Microsoft Windows Driver Development Kit (DDK) Ver. 3790.1830
New features added in this label:
Added OpROM execution sequence support for PCI devices, other than Video, Mass Storage and Network
CsmOptOut.sd file updated to comply with setup customization guidelines
General Bug Fixes:
Function CsmOptOutConnectVga used wrong array of pointers when connecting onboard video devices
Made module master token dependent on presence of CSM in the project
EIP addressed in this label:
76939
78227
70101
Files changed:
CsmOptOut.c
CsmOptOut.sd
CsmOptOut.uni
CsmOptOut.sdl
Known issues and limitations in this label:
None
Remaining Issues:
None
Unit Testing:
Passed
Validation Testing:
Passed
Release History:
Release_00

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: CsmOptOut
Component Reference Name: CsmOptOut
Component Type: eModule
Release Date: 2012-05-25
Source Control Label: 4.6.5.4_Csm_OptOut_02
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/CsmOptOut;

Dependencies
NONE
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
Component Description:
CsmOptOut allows to enable/disable CSM usage, filters UEFI/Legacy boot options, selects UEFI/Legacy OptionROM execution order
Filename | Description
CsmOptOut.cif | VeB component description file
CsmOptOut.sdl | Component configuration file
CsmOptOut.mak | Component make file
CsmOptOut.c | Main functionality implementation file
CsmOptOut.chm | Component help file
CsmOptOut.sd | Component setup controls definition file
CsmOptOut.uni | Component setup strings file
CsmOptOutTseHook.c | Check OS loader TSE component
CsmOptOutRuntime.c | Component runtime entrypoint
CsmOptOutSetup.c | Setup control callback

AMI Build Tools:
Tools Label: 4.5.5_Tools_38, Dated: 2011-12-20
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft™s Windows Driver Kit (WDK) Ver. 7600.16385.1
Compiler Tool(s): Microsoft Windows Driver Development Kit (DDK) Ver. 3790.1830
New features added in this label:
Changed logic of OpROM execution sequence control
Added porting hook to control OpROM execution sequence for particular PCI device
Added dependency on Secure Boot state
Added code to prevent disabling CSM vhen active video is legacy
General Bug Fixes:
Non-PCI handles weren't connected
EIP addressed in this label:
86097
84012
Files changed:
CsmOptOut.cif
CsmOptOut.c
CsmOptOut.sd
CsmOptOut.uni
CsmOptOut.sdl
Known issues and limitations in this label:
None
Remaining Issues:
None
Unit Testing:
Passed
Validation Testing:
Passed
Release History:
Release_01
Release_00

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: CsmOptOut
Component Reference Name: CsmOptOut
Component Type: eModule
Release Date: 2012-06-25
Source Control Label: 4.6.5.4_Csm_OptOut_03
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/CsmOptOut;

Dependencies
NONE
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
Component Description:
CsmOptOut allows to enable/disable CSM usage, filters UEFI/Legacy boot options, selects UEFI/Legacy OptionROM execution order
Filename | Description
CsmOptOut.cif | VeB component description file
CsmOptOut.sdl | Component configuration file
CsmOptOut.mak | Component make file
CsmOptOut.c | Main functionality implementation file
CsmOptOut.chm | Component help file
CsmOptOut.sd | Component setup controls definition file
CsmOptOut.uni | Component setup strings file
CsmOptOutRuntime.c | Component runtime entrypoint
CsmOptOutSetup.c | Setup control callback

AMI Build Tools:
Tools Label: 4.5.5_Tools_38, Dated: 2011-12-20
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft™s Windows Driver Kit (WDK) Ver. 7600.16385.1
Compiler Tool(s): Microsoft Windows Driver Development Kit (DDK) Ver. 3790.1830
New features added in this label:
Removed "Auto" option from CSM load policy setup control
General Bug Fixes:
SCT errors for platform-override protocol
EIP addressed in this label:
83692
Files changed:
CsmOptOut.cif
CsmOptOut.c
CsmOptOutSetup.c
CsmOptOutRuntime.c
CsmOptOut.mak
CsmOptOut.sd
CsmOptOut.uni
CsmOptOut.sdl
Known issues and limitations in this label:
None
Remaining Issues:
None
Unit Testing:
Passed
Validation Testing:
Passed
Release History:
Release_02
Release_01
Release_00

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: CsmOptOut
Component Reference Name: CsmOptOut
Component Type: eModule
Release Date: 2012-10-03
Source Control Label: 4.6.5.4_Csm_OptOut_04
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/CsmOptOut;

Dependencies
NONE
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
Component Description:
CsmOptOut allows to enable/disable CSM usage, filters UEFI/Legacy boot options, selects UEFI/Legacy OptionROM execution order
Filename | Description
CsmOptOut.cif | VeB component description file
CsmOptOut.sdl | Component configuration file
CsmOptOut.mak | Component make file
CsmOptOut.c | Main functionality implementation file
CsmOptOut.chm | Component help file
CsmOptOut.sd | Component setup controls definition file
CsmOptOut.uni | Component setup strings file
CsmOptOutRuntime.c | Component runtime entrypoint
CsmOptOutSetup.c | Setup control callback

AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft™s Windows Driver Kit (WDK) Ver. 7600.16385.1
Compiler Tool(s): Microsoft Windows Driver Development Kit (DDK) Ver. 3790.1830
New features added in this label:
CSM OptOut controls state is preserved when CSM is disabled. Once enabled CSM OptOut controls values are restored to previous state
CSM OptOut controls become hidden once Secure boot is enabled
General Bug Fixes:
If OpROM execution was disabled by OEM eLink it was reenabled by CsmOptOut
EIP addressed in this label:
98995
Files changed:
CsmOptOut.c
CsmOptOutSetup.c
CsmOptOutRuntime.c
CsmOptOut.sd
CsmOptOut.sdl
Known issues and limitations in this label:
None
Remaining Issues:
None
Unit Testing:
Passed
Validation Testing:
Passed
Release History:
Release_03
Release_02
Release_01
Release_00

© American Megatrends Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • CsmOptOut.c
  • CsmOptOut.mak
  • CsmOptOut.sd
  • CsmOptOutRuntime.c
  • CsmOptOutSetup.c
Built on 21:29:50 11/01/13


CsmOptOut.c

Description:
This is main file of the CsmOptOut module

The following functions are used in the file: CsmOptOut.c.

Function | Description
AddHandle | This function stores handles in allocated buffer
CheckOpRomExecution | This function determines should OpROM be executed
CsmOptOutEntry | This function is CsmOptOut driver entry point
CsmOptOutFilter | This function filters available boot options based on Setup control value
CsmOptOutGetDriver | Implementation of Platform Drive Override protocol GetDriver function
DisconnectUefiGop | This function disconnects native UEFI GOP driver before executing legacy video BIOS
GetBusSpecificHandle | This function returns bus-specific handle for given controller
GetOpRomPolicy | This function returns OpROM policy for given PCI class of the device
GetUefiOpRomPolicy | This function is HII driver entry point
IncreaseHandleBuffer | This function increases and reallocates buffer to store DriverBinding handles
InitHandleBuffer | This function allocates buffer to store DriverBinding handles
IsManageable | This function returns if given PCI device class supports controlled UEFI/Legacy OpROM execution sequence
LocateHandlesCallback | This callback executed every time DriverBinding is installed
ProceedToBootCallback | This callback executed when all drivers are connected and system proceeds to boot
ProcessOpRomCallback | This callback will be called before and after installing legacy OpROM


AddHandle in the CsmOptOut.c

Function : AddHandle

File: CsmOptOut.c
Description:
This function stores handles in allocated buffer
Input:
IN OUT HANDLE_BUFFER *Target - pointer to buffer to store handle in
EFI_HANDLE Handle - handle to be stored
Output:
EFI_STATUS


CheckOpRomExecution in the CsmOptOut.c

Function : CheckOpRomExecution

File: CsmOptOut.c
Description:
This function determines should OpROM be executed
Input:
UINT8 PciClass - class of PCI device to check
BOOLEAN UefiOprom - TRUE if verifying UEFI OpROM, FALSE for Legacy OpROM
Output:
EFI_SUCCESS - OpROM should be executed
EFI_UNSUPPORTED - OpROM should not be executed


CsmOptOutEntry in the CsmOptOut.c

Function : CsmOptOutEntry

File: CsmOptOut.c
Description:
This function is CsmOptOut driver entry point
Input:
IN EFI_HANDLE ImageHandle - Image handle
IN EFI_SYSTEM_TABLE *SystemTable - pointer to system table
Output:
EFI_SUCCESS - Function executed successfully
EFI_ERROR - Some error occured during execution


CsmOptOutFilter in the CsmOptOut.c

Function : CsmOptOutFilter

File: CsmOptOut.c
Description:
This function filters available boot options based on Setup
control value
Input:
IN BOOT_DEVICE *Device - pointer to boot device
Output:
TRUE - boot option will be removed from boot list
FALSE - boot option won't be removed from boot list


CsmOptOutGetDriver in the CsmOptOut.c

Function : CsmOptOutGetDriver

File: CsmOptOut.c
Description:
Implementation of Platform Drive Override protocol
GetDriver function
Input:
IN EFI_PLATFORM_DRIVER_OVERRIDE_PROTOCOL *This - pointer to the instance of
the protocol
IN EFI_HANDLE ControllerHandle - handle of controller for which to retrieve
DriverBinding handle
IN OUT EFI_HANDLE *DriverImageHandle - pointer to returned handle placeholder
Output:
EFI_SUCCESS - handle returned
EFI_NOT_FOUND - handle not found


DisconnectUefiGop in the CsmOptOut.c

Function : DisconnectUefiGop

File: CsmOptOut.c
Description:
This function disconnects native UEFI GOP driver before
executing legacy video BIOS
Input:
IN EFI_PCI_IO_PROTOCOL *PciIo - instance of PciIo protocol on handle,
                   that have to be disconnected
Output:
EFI_SUCCESS - driver was disconnected
EFI_UNSUPPORTED - driver can't be disconnected


GetBusSpecificHandle in the CsmOptOut.c

Function : GetBusSpecificHandle

File: CsmOptOut.c
Description:
This function returns bus-specific handle for given controller
Input:
IN EFI_HANDLE ControllerHandle - handle of the controller
IN OUT EFI_HANDLE *DriverImageHandle - pointer to returned handle placeholder
Output:
EFI_SUCCESS - handle returned
EFI_NOT_FOUND - handle not found


GetOpRomPolicy in the CsmOptOut.c

Function : GetOpRomPolicy

File: CsmOptOut.c
Description:
This function returns OpROM policy for given PCI class of the device
Input:
UINT8 PciClass - class of PCI device to check
Output:
UINT8 - policy (0-disable all, 1-disable Legacy, 2-disable UEFI, 3-Legacy before UEFI
   4-UEFI before Legacy)


GetUefiOpRomPolicy in the CsmOptOut.c

Function : GetUefiOpRomPolicy

File: CsmOptOut.c
Description:
This function is HII driver entry point
Input:
IN EFI_HANDLE ImageHandle - Image handle
IN EFI_SYSTEM_TABLE *SystemTable - pointer to system table
Output:
EFI_SUCCESS - Function executed successfully, HII protocols installed
EFI_ERROR - Some error occured during execution


IncreaseHandleBuffer in the CsmOptOut.c

Function : IncreaseHandleBuffer

File: CsmOptOut.c
Description:
This function increases and reallocates buffer to store
DriverBinding handles
Input:
IN OUT HANDLE_BUFFER *Target - pointer to buffer to be increased
Output:
EFI_STATUS


InitHandleBuffer in the CsmOptOut.c

Function : InitHandleBuffer

File: CsmOptOut.c
Description:
This function allocates buffer to store DriverBinding handles
Input:
IN OUT HANDLE_BUFFER *Target - pointer to buffer to be initialized
Output:
EFI_STATUS


IsManageable in the CsmOptOut.c

Function : IsManageable

File: CsmOptOut.c
Description:
This function returns if given PCI device class supports
controlled UEFI/Legacy OpROM execution sequence
Input:
IN UINT8 PciClass - class of the device
Output:
TRUE - controlled sequence supported
FALSE - controlled sequence not supported


LocateHandlesCallback in the CsmOptOut.c

Function : LocateHandlesCallback

File: CsmOptOut.c
Description:
This callback executed every time DriverBinding is installed
Input:
IN EFI_EVENT Event - Callback event
IN VOID *Context - pointer to calling context
Output:
None


ProceedToBootCallback in the CsmOptOut.c

Function : ProceedToBootCallback

File: CsmOptOut.c
Description:
This callback executed when all drivers are connected and system
proceeds to boot
Input:
IN EFI_EVENT Event - Callback event
IN VOID *Context - pointer to calling context
Output:
None


ProcessOpRomCallback in the CsmOptOut.c

Function : ProcessOpRomCallback

File: CsmOptOut.c
Description:
This callback will be called before and after installing legacy OpROM
Input:
IN EFI_EVENT Event - Callback event
IN VOID *Context - pointer to calling context
Output:
None


CsmOptOut.mak

Description:
Make file of the CSM OptOut module


CsmOptOut.sd

Description:
Definition of CsmOptOut module setup controls


CsmOptOutRuntime.c

Description:
This is the entry point of CsmOptOut driver

The following functions are used in the file: CsmOptOutRuntime.c.

Function | Description
CsmOptOutNotInSmmEntry | CsmOptOut runtime callback for variable services
CsmOptOutRuntimeEntry | CsmOptOut runtime callback for variable services


CsmOptOutNotInSmmEntry in the CsmOptOutRuntime.c

Function : CsmOptOutNotInSmmEntry

File: CsmOptOutRuntime.c
Description:
CsmOptOut runtime callback for variable services
Input:
IN EFI_EVENT Event - Callback event
IN VOID *Context - pointer to calling context
Output:
None


CsmOptOutRuntimeEntry in the CsmOptOutRuntime.c

Function : CsmOptOutRuntimeEntry

File: CsmOptOutRuntime.c
Description:
CsmOptOut runtime callback for variable services
Input:
IN EFI_EVENT Event - Callback event
IN VOID *Context - pointer to calling context
Output:
None


CsmOptOutSetup.c

Description:
Implementation of interactive callback to "Launch CSM" setup control

The following functions are used in the file: CsmOptOutSetup.c.

Function | Description
CsmOptOutLaunchCallback | This function checks if CSM can be disabled in current boot
GetCurrentLanguage | This function retrieves current platform language and stores it in passed pointer
GetLangString | This function reads a string from HII database with different languages
GetUniString | This function reads a string from HII database
IsLegacyVideo | This function checks if active video is Legacy or UEFI
IsUefiGop | This function checks wheter passed controller is managed by UEFI GOP driver


CsmOptOutLaunchCallback in the CsmOptOutSetup.c

Function : CsmOptOutLaunchCallback

File: CsmOptOutSetup.c
Description:
This function checks if CSM can be disabled in current boot
Input:
IN EFI_HII_HANDLE HiiHandle - HII handle of formset
IN UINT16 Class - class of formset
IN UINT16 SubClass - subclass of formset
IN UINT16 Key - Id of setup control
Output:
EF_SUCCESS


GetCurrentLanguage in the CsmOptOutSetup.c

Function : GetCurrentLanguage

File: CsmOptOutSetup.c
Description:
This function retrieves current platform language and stores it in
passed pointer
Input:
CHAR8 ** Lang - pointer to where to store current language
BOOLEAN *Allocated - flag if memory was allocated for language
Output:
None


GetLangString in the CsmOptOutSetup.c

Function : GetLangString

File: CsmOptOutSetup.c
Description:
This function reads a string from HII database with different languages
Input:
IN EFI_HII_HANDLE   HiiHandle - Efi Hii Handle
IN STRING_REF       Token     - String Token
IN OUT UINTN        *StringSize - Length of the StringBuffer in bytes
OUT EFI_STRING      *StringBuffer - The pointer to the buffer to receive
                   the characters in the string.
Output:
EFI_STATUS - Depending on result


GetUniString in the CsmOptOutSetup.c

Function : GetUniString

File: CsmOptOutSetup.c
Description:
This function reads a string from HII database
Input:
IN EFI_HII_HANDLE   HiiHandle - Efi Hii Handle
IN STRING_REF       Token     - String Token
IN OUT UINTN        *StringSize - Length of the StringBuffer in bytes
OUT EFI_STRING      *StringBuffer - The pointer to the buffer to receive
                   the characters in the string.
Output:
EFI_STATUS - Depending on result


IsLegacyVideo in the CsmOptOutSetup.c

Function : IsLegacyVideo

File: CsmOptOutSetup.c
Description:
This function checks if active video is Legacy or UEFI
Input:
None
Output:
0 - active video is UEFI
1 - active vide is Legacy


IsUefiGop in the CsmOptOutSetup.c

Function : IsUefiGop

File: CsmOptOutSetup.c
Description:
This function checks wheter passed controller is managed by  UEFI GOP driver
Input:
IN EFI_HANDLE pci_hnd - handle of the controller
Output:
0 - controller managed by legacy driver
1 - controller managed by UEFI driver


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

  • A
  • C
  • D
  • G
  • I
  • L
  • P


Functions in Alphabetical Order

A

Function | Description
AddHandle | This function stores handles in allocated buffer

Built on 21:29:49 11/01/13


Functions in Alphabetical Order

C

Function | Description
CheckOpRomExecution | This function determines should OpROM be executed
CsmOptOutEntry | This function is CsmOptOut driver entry point
CsmOptOutFilter | This function filters available boot options based on Setup control value
CsmOptOutGetDriver | Implementation of Platform Drive Override protocol GetDriver function
CsmOptOutLaunchCallback | This function checks if CSM can be disabled in current boot
CsmOptOutNotInSmmEntry | CsmOptOut runtime callback for variable services
CsmOptOutRuntimeEntry | CsmOptOut runtime callback for variable services

Built on 21:29:49 11/01/13


Functions in Alphabetical Order

D

Function | Description
DisconnectUefiGop | This function disconnects native UEFI GOP driver before executing legacy video BIOS

Built on 21:29:49 11/01/13


Functions in Alphabetical Order

G

Function | Description
GetBusSpecificHandle | This function returns bus-specific handle for given controller
GetCurrentLanguage | This function retrieves current platform language and stores it in passed pointer
GetLangString | This function reads a string from HII database with different languages
GetOpRomPolicy | This function returns OpROM policy for given PCI class of the device
GetUefiOpRomPolicy | This function is HII driver entry point
GetUniString | This function reads a string from HII database


Functions in Alphabetical Order

I

Function | Description
IncreaseHandleBuffer | This function increases and reallocates buffer to store DriverBinding handles
InitHandleBuffer | This function allocates buffer to store DriverBinding handles
IsLegacyVideo | This function checks if active video is Legacy or UEFI
IsManageable | This function returns if given PCI device class supports controlled UEFI/Legacy OpROM execution sequence
IsUefiGop | This function checks wheter passed controller is managed by UEFI GOP driver


Functions in Alphabetical Order

L

Function | Description
LocateHandlesCallback | This callback executed every time DriverBinding is installed


Functions in Alphabetical Order

P

Function | Description
ProceedToBootCallback | This callback executed when all drivers are connected and system proceeds to boot
ProcessOpRomCallback | This callback will be called before and after installing legacy OpROM


General Information