American Megatrends, Inc.

FlashSmi

Copyright

Release Notes

© American Megatrends, Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • FlashSmi.c
  • FlashSmi.dxs
  • FlashSmi.mak
Built on 10:49:36 01/16/15


FlashSmi.c

Description:
FLASH SMI DXE driver.

The following functions are used in the file: FlashSmi.c.

Function | Description
BeginCriticalSection | This function calls when critical section begins. It disables interupts, and Smi and fills CRITICAL_SECTION structure fields
EndCriticalSection | This function calls when critical section ends. It enable interupts, and Smi and fills CRITICAL_SECTION structure fields
FlashDriverErase | Implementation of the Erase Function of the Flash protocol
FlashDriverUpdate | Implementation of the Update Function of the Flash protocol
FlashDriverWrite | Implementation of the Write Function of the Flash protocol
FlashSmiConnectDrivers | This function will be called when Connect Drivers Protocol is installed and will update FlashProtocol function in RunTime.
FlashSmiEntryPoint | DXE Entry Point for FlashSmi Driver.
FlashSmiHandler |
FlashSmiReadyToBoot | This function will be called when Ready To Boot and will restore oringinal FlashProtocol function.
FlashSmiSmmSwDispatchCallback |
FlashSmiVirtualFixup |
InSmmFunction |
NotInSmmFunction |


BeginCriticalSection in the FlashSmi.c

Function : BeginCriticalSection

File: FlashSmi.c
Description:
This function calls when critical section begins. It disables interupts,
and Smi and fills CRITICAL_SECTION structure fields
Input:
CRITICAL_SECTION *Cs - pointer to CRITICAL_SECTION structure
Output:
VOID


EndCriticalSection in the FlashSmi.c

Function : EndCriticalSection

File: FlashSmi.c
Description:
This function calls when critical section ends. It enable interupts,
and Smi and fills CRITICAL_SECTION structure fields
Input:
CRITICAL_SECTION *Cs - pointer to CRITICAL_SECTION structure
Output:
VOID


FlashDriverErase in the FlashSmi.c

Function : FlashDriverErase

File: FlashSmi.c
Description:
Implementation of the Erase Function of the Flash protocol
Input:
VOID*       FlashAddress    Pointer to address of a flash to erase
UINTN       Size            Size to erase
Output:
EFI_SUCCESS or EFI_DEVICE_ERROR depending on result


FlashDriverUpdate in the FlashSmi.c

Function : FlashDriverUpdate

File: FlashSmi.c
Description:
Implementation of the Update Function of the Flash protocol
Input:
VOID*       FlashAddress    Pointer to address of a flash to update (must
               be aligned to FlashBlockSize)
UINTN       Size            Size to update (must be multiple of FlashBlockSize)
VOID*       DataBuffer -    pointer to data to write to the flash part
Output:
EFI_SUCCESS or EFI_DEVICE_ERROR depending on result


FlashDriverWrite in the FlashSmi.c

Function : FlashDriverWrite

File: FlashSmi.c
Description:
Implementation of the Write Function of the Flash protocol
Input:
VOID*       FlashAddress    Pointer to address of a flash to write to
UINTN       Size            Size to write
VOID*       DataBuffer -    pointer to data to write to the flash part
Output:
EFI_SUCCESS or EFI_DEVICE_ERROR depending on result


FlashSmiConnectDrivers in the FlashSmi.c

Function : FlashSmiConnectDrivers

File: FlashSmi.c
Description:
This function will be called when Connect Drivers Protocol is
installed and will update FlashProtocol function in RunTime.
Input:
IN EFI_EVENT Event - signalled event
IN VOID *Context - calling context
Output:
VOID


FlashSmiEntryPoint in the FlashSmi.c

Function : FlashSmiEntryPoint

File: FlashSmi.c
Description:
DXE Entry Point for FlashSmi Driver.
Input:
EFI_HANDLE          - ImageHandle
EFI_SYSTEM_TABLE*   - SystemTable
Output:
EFI_STATUS


FlashSmiHandler in the FlashSmi.c

Function : FlashSmiHandler

File: FlashSmi.c
Description:
Input:

Output:

EFI_STATUS


FlashSmiReadyToBoot in the FlashSmi.c

Function : FlashSmiReadyToBoot

File: FlashSmi.c
Description:
This function will be called when Ready To Boot and will
restore oringinal FlashProtocol function.
Input:
IN EFI_EVENT Event - signalled event
IN VOID *Context - calling context
Output:
VOID


FlashSmiSmmSwDispatchCallback in the FlashSmi.c

Function : FlashSmiSmmSwDispatchCallback

File: FlashSmi.c
Description:
Input:
Output:


FlashSmiVirtualFixup in the FlashSmi.c

Function : FlashSmiVirtualFixup

File: FlashSmi.c
Description:
Input:
IN EFI_EVENT Event - signalled event
IN VOID *Context - calling context
Output:
VOID


InSmmFunction in the FlashSmi.c

Function : InSmmFunction

File: FlashSmi.c
Description:
Input:
EFI_HANDLE          - ImageHandle
EFI_SYSTEM_TABLE*   - SystemTable
Output:
EFI_STATUS


NotInSmmFunction in the FlashSmi.c

Function : NotInSmmFunction

File: FlashSmi.c
Description:
Input:
EFI_HANDLE          - ImageHandle
EFI_SYSTEM_TABLE*   - SystemTable
Output:
EFI_STATUS


FlashSmi.dxs

Description:


FlashSmi.mak

Description:
Make file for FlashSmi.


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

  • B
  • E
  • F
  • I
  • N


Functions in Alphabetical Order

B

Function | Description
BeginCriticalSection | This function calls when critical section begins. It disables interupts, and Smi and fills CRITICAL_SECTION structure fields


Functions in Alphabetical Order

E

Function | Description
EndCriticalSection | This function calls when critical section ends. It enable interupts, and Smi and fills CRITICAL_SECTION structure fields


Functions in Alphabetical Order

F

Function | Description
FlashDriverErase | Implementation of the Erase Function of the Flash protocol
FlashDriverUpdate | Implementation of the Update Function of the Flash protocol
FlashDriverWrite | Implementation of the Write Function of the Flash protocol
FlashSmiConnectDrivers | This function will be called when Connect Drivers Protocol is installed and will update FlashProtocol function in RunTime.
FlashSmiEntryPoint | DXE Entry Point for FlashSmi Driver.
FlashSmiHandler |
FlashSmiReadyToBoot | This function will be called when Ready To Boot and will restore oringinal FlashProtocol function.
FlashSmiSmmSwDispatchCallback |
FlashSmiVirtualFixup |


Functions in Alphabetical Order

I

Function | Description
InSmmFunction |


Functions in Alphabetical Order

N

Function | Description
NotInSmmFunction |


General Information


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2011 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.


Release Notes - NDA Required

Component Information:
Component Title: FlashSmi
Component Reference Name: Flash_SMI
Component Type: eModule
Release Date: 2015-01-20
Source Control Label: FlashSmi_00
Source Control Location: $/Alaska/SOURCE/Modules/FlashSmi
Component Description:
FlashSmi module will change flash protocol to generate SMI to call the flash function in SMM.
Filename | Description
FlashSmi.cif | Cif file for FlashSmi module
FlashSmi.chm | Chm file for FlashSmi module
FlashSmi.sdl | File containing the SDL tokens used by FlashSmi module
FlashSmi.c | File contains FlashSmi routines such as Entry point of the FlashSmi driver
FlashSmi.dxs | Dxs file for FlashSmi module
FlashSmi.mak | Mak file for FlashSmi module

AMI Build Tools:
Visual eBios: 4.5.5_TOOLS_41, Dated: 2013-Mar
Compiler Tool(s): WinDDK 7600.16385.1
New features added in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
NONE

© American Megatrends Inc.