American Megatrends, Inc.

MEUD

Copyright

Release Notes

© American Megatrends, Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • AutoUpdate.c
  • AutoUpdate.dxs
  • AutoUpdate.h
  • AutoUpdate.mak
  • InitMEUDString.c
  • MEUD.c
  • MEUD.h
  • MEUD.mak
  • MEUD.sd
  • MEUD_MSG.c
Built on 14:03:53 10/01/13


AutoUpdate.c

Description:

The following functions are used in the file: AutoUpdate.c.

Function | Description
AllDriverConnectEvent | This routine for reset the TPM Establishment flag.
GetRawImage | Find ME binary in FV_MAIN.
MEAutoUpdate | System updaete ME in POST.
NeedtoUpdate | Check ME version.
ProgressMEUpdate | Do ME update
ReFlashEntry | This is the standard EFI driver entry point called for Recovery flash module initlaization


AllDriverConnectEvent in the AutoUpdate.c

Function : AllDriverConnectEvent

File: AutoUpdate.c
Description:
This routine for reset the TPM Establishment flag.
Input:
EFI_EVENT   - Efi event.
VOID*       - Image handle.
Output:
None.


GetRawImage in the AutoUpdate.c

Function : GetRawImage

File: AutoUpdate.c
Description:
Find ME binary in FV_MAIN.
Input:
NameGuid - Guid of FFS need to find.
Buffer   - Input buffer
Size     - Size of Input buffer
Output:
Status
Buffer   - FFS data
Size     - Size of Output buffer


MEAutoUpdate in the AutoUpdate.c

Function : MEAutoUpdate

File: AutoUpdate.c
Description:
System updaete ME in POST.
Input:
VOID
Output:
VOID


NeedtoUpdate in the AutoUpdate.c

Function : NeedtoUpdate

File: AutoUpdate.c
Description:
Check ME version.
Input:
VOID
Output:
TRUE - Update ME in this BOOT.


ProgressMEUpdate in the AutoUpdate.c

Function : ProgressMEUpdate

File: AutoUpdate.c
Description:
Do ME update
Input:
NameGuid - Guid of FFS need to find.
Buffer   - Input buffer
Size     - Size of Input buffer
Output:
Status
Buffer   - FFS data
Size     - Size of Output buffer


ReFlashEntry in the AutoUpdate.c

Function : ReFlashEntry

File: AutoUpdate.c
Description:
This is the standard EFI driver entry point called for
Recovery flash module initlaization
Input:
IN EFI_HANDLE ImageHandle - ImageHandle of the loaded driver
IN EFI_SYSTEM_TABLE SystemTable - Pointer to the System Table
Output:
EFI_SUCCESS


AutoUpdate.dxs

Description:
Dependancy expression for the component


AutoUpdate.h

Description:
Header file for component


AutoUpdate.mak

Description:


InitMEUDString.c

Description:

The following functions are used in the file: InitMEUDString.c.

Function | Description
InitMEUDInfo | Register a Setup Item CallBack Info.
MEUDSetupCallbackFunction | TSE Callbeck Function. To make ME enter Disable Mode.


InitMEUDInfo in the InitMEUDString.c

Function : InitMEUDInfo

File: InitMEUDString.c
Description:
Register a Setup Item CallBack Info.
Input:
IN EFI_HII_HANDLE   HiiHandle
IN UINT16           Class
Output:
VOID


MEUDSetupCallbackFunction in the InitMEUDString.c

Function : MEUDSetupCallbackFunction

File: InitMEUDString.c
Description:
TSE Callbeck Function.
To make ME enter Disable Mode.
Input:
VOID
Output:
VOID


MEUD.c

Description:

The following functions are used in the file: MEUD.c.

Function | Description
MEUDCallback | Locate SmiFlash protocol callback
MEUDEntry | OFBD ME Firmware Update Entry point
MEUDInSmm | OFBD ME Firmware Update InSmm Function


MEUDCallback in the MEUD.c

Function : MEUDCallback

File: MEUD.c
Description:
Locate SmiFlash protocol callback
Input:
IN EFI_EVENT    Event
IN VOID         *Context
Output:
VOID


MEUDEntry in the MEUD.c

Function : MEUDEntry

File: MEUD.c
Description:
OFBD ME Firmware Update Entry point
Input:
IN VOID             *Buffer
IN OUT UINT8        *pOFBDDataHandled
Output:
VOID


MEUDInSmm in the MEUD.c

Function : MEUDInSmm

File: MEUD.c
Description:
OFBD ME Firmware Update InSmm Function
Input:
VOID
Output:
VOID


MEUD.h

Description:


MEUD.mak

Description:


MEUD.sd

Description:
Setup definition for MEUD.


MEUD_MSG.c

Description:

The following functions are used in the file: MEUD_MSG.c.

Function | Description
ShowMEUDErrors | Show Message on Screen If Ignition FW runs on Factory Default


ShowMEUDErrors in the MEUD_MSG.c

Function : ShowMEUDErrors

File: MEUD_MSG.c
Description:
Show Message on Screen If Ignition FW runs on Factory Default
Input:
VOID
Output:
BOOLEAN. Should return TRUE if the screen was used to
ask password; FALSE if the screen was not used to ask
password.


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

  • A
  • G
  • I
  • M
  • N
  • P
  • R
  • S


Functions in Alphabetical Order

A

Function | Description
AllDriverConnectEvent | This routine for reset the TPM Establishment flag.


Functions in Alphabetical Order

G

Function | Description
GetRawImage | Find ME binary in FV_MAIN.


Functions in Alphabetical Order

I

Function | Description
InitMEUDInfo | Register a Setup Item CallBack Info.


Functions in Alphabetical Order

M

Function | Description
MEAutoUpdate | System updaete ME in POST.
MEUDCallback | Locate SmiFlash protocol callback
MEUDEntry | OFBD ME Firmware Update Entry point
MEUDInSmm | OFBD ME Firmware Update InSmm Function
MEUDSetupCallbackFunction | TSE Callbeck Function. To make ME enter Disable Mode.


Functions in Alphabetical Order

N

Function | Description
NeedtoUpdate | Check ME version.


Functions in Alphabetical Order

P

Function | Description
ProgressMEUpdate | Do ME update


Functions in Alphabetical Order

R

Function | Description
ReFlashEntry | This is the standard EFI driver entry point called for Recovery flash module initlaization


Functions in Alphabetical Order

S

Function | Description
ShowMEUDErrors | Show Message on Screen If Ignition FW runs on Factory Default


General Information


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2011 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.


AMIBIOS Component Release Notes

Component Information:

Component Name: On Flash Block Description(APTIO) – Intel ME Update

Component Type: eModule

Release Date: 06/03/2015

Source Control Label: 4.6.3.2_OFBD_ME_UPDATE_015

Source Control Location: SS:Alaska \\Alaska\Source\Modules\OFBD INTEL ME Update

CSP_MEUD Source Control Location: SS:Alaska \\Alaska\Source\Modules\OFBD INTEL ME Update\CSP_MEUD

Component Description:

1. Support ME update by AFU.

2. OFBD Module is needed.

CSP_MEUD :

If A-code, Please download IbexPeak.

If OA-code or MPG-code, Please download Capella.

If A-code server, Please download Server.

If A+-code ME8.0, Please download ME8.0.

TOKENS :

ME_IGNITION_FW_MSG_SUPPORTà ME7.0 doesn’t support Ignition FW.

ME_SECOVR_MEI_MSG_SUPPORTàMPG-Code please disable this.

How To Update ME :

DESKTOP/MOBILE :

There are two ways to update ME region.

1. Assert GPIO33, When GPIO33 is low then power on, ME will be in Disable Mode.

In this way, it allows user to update ME, GBE and flash descriptor region.

2. Sending Enable Message to ME.

In this way, it allows user to update ME and GBE region.

When ME runs in disabled mode, User can update ME by AFU(/ME is for ME firmware, /MEUF is for Ignition FW).

PS : For Desktop/Mobile :

Checking ME State in HECI Device Register 0x40 Bit [19:16] = 4 mean GPIO33 assert, 5 = Message Disabled

For Server :

Checking ME State in HECI Device Register 0x40 Bit [3:0] = 2 mean GPIO33 or Message Disabled

Errata & Known Issues :

None

Revision History :

4.6.3.2_OFBD_ME_UPDATE_015

CSP : ME 8.0 Firmware Update - Fix ME update capsule can’t be generated.

4.6.3.2_OFBD_ME_UPDATE_014

CSP : ME 8.0 Firmware Update - ME capsule update support on SharkBay platform .

NOTE:

The default of this feature is off, set MEFwUpdLcl_SUPPORT to enable it.

Please turn token MEFWUPDLCL_ON_SHARKBAY_PLATFORM on, if you build this module with SharkBay project.

To generate ME capsule, please modify ME_BIN_FILE, ME_FW_IMAGE_VERSION and FV_MEFWCAP_SIZE.

4.6.3.2_OFBD_ME_UPDATE_013

Improvement : Remove the MEUD module variables' RT attribute.

4.6.3.2_OFBD_ME_UPDATE_012

Support ME FWUpdate API in CSP : ME 8.0 Firmware Update

NOTE: The ME Firmware Update Local module part default is off. Because of it needs HeciSmm and now only tested in DOS.

4.6.3.2_OFBD_ME_UPDATE_011

CSP_MEUD for server suppport PI 1.2.

4.6.3.2_OFBD_ME_UPDATE_010

Fix system hang with OFBD Label 4.6.3.2_OFBD.1.0.5

4.6.3.2_OFBD_ME_UPDATE_008

Improvement : Allocate memory during POST(avoid "Error : No Memory Allocated!!").

Improvement : Support update ME when PDR region is on TOP of SPI ROM (AFU 3.05 is needed, and 4.6.3_Flash_Combined_2_36) for ME8 and ME9.

4.6.3.2_OFBD_ME_UPDATE_007

Improvement : Support SPS FW Update.

Improvement : New Token “BITS_OF_SPI_DENSITY” Added, to calculate flash capacity.

BugFix : Fix resotre variables fail with AFU /ME

OFBD_ME_UPDATE_SERVER_BETA2

BugFix : Remove MEAUTOUPD.

BufFix : Build Error when enable AutoUpdate.

OFBD_ME_UPDATE_SERVER_BETA1

Add: ME auto update.

Improvement : Support New AFU, to support commands for each regions(FD , GBE, ME and PDR)

NOTE : Need to set OFBD_VERSION to 0x210 and new AFU(2.39), and set all tokens in CSP_MEUD.sdl.

4.6.3.2_OFBD_ME_UPDATE_006

Remove : Support ME auto update.

Improvement : Support ME8.0 with A-plus code.

Improvement : Update ME though OFBD module.(Need to set OFBD_VERSION to 0x210 and new AFU)

4.6.3.2_OFBD_ME_UPDATE_005_BETA

Improvement : Support ME auto update.

BugFix : Fix building error with Server ME mobulde version 03.

4.6.3.2_OFBD_ME_UPDATE_004

Improvement : Support Server SPS firmware update.

BugFix : Fix wrong behavior on whole binary(BIOS + ME) input to AFU.

4.6.3.2_OFBD_ME_UPDATE_003

Improvement : Set ME_SECOVR_MEI_MSG_SUPPORT to default disable.

Improvement : Restore FlashCapacity after program for AFUWin.

Improvement : ME_SECOVR_MEI_MSG_SUPPORT control setup item enable/disable.

Improvement : Support ME 7.0.

Improvement : Add a token for Intel RC support.(Capella ModulePart)

Improvement : Implement Setup item call back by Elink.

BugFix : Fix sometimes System hangs when GetFlashCapacity.