American Megatrends, Inc.

SecureFlash

Copyright

Release Notes

© American Megatrends, Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • SecureFlash.c
  • SecureFlash.h
  • SecureFlash.mak
Built on 16:04:34 01/18/12


SecureFlash.c

Description:
This file provides OFBD Secure Flash function.

The following functions are used in the file: SecureFlash.c.

Function | Description
ASFUEntry | OFBD Secure Flash Update Entry point
ASFUInSmm | This function installs the ASFU Protocol.
GetFlashUpdatePolicy | Get Flash Update Policy from Secure Flash module.
LoadFirmwareImage | Transfer ROM image from AFU's buffer to Secure Flash Module through EFI_SEC_SMI_FLASH_PROTOCOL.
SecureFlashProtocolCallback | Locate SecSmiFlash protocol callback
SetFlashUpdateMethod | Set Flash Update Policy to Secure Flash module.
SmmFlashProtocolCallback | Locate Flash protocol callback


ASFUEntry in the SecureFlash.c

Function : ASFUEntry

File: SecureFlash.c
Description:
OFBD Secure Flash Update Entry point
Input:
IN VOID				*Buffer
IN OUT UINT8		*pOFBDDataHandled
Output:
VOID


ASFUInSmm in the SecureFlash.c

Function : ASFUInSmm

File: SecureFlash.c
Description:
This function installs the ASFU Protocol.
Input:
VOID
Output:
VOID


GetFlashUpdatePolicy in the SecureFlash.c

Function : GetFlashUpdatePolicy

File: SecureFlash.c
Description:
Get Flash Update Policy from Secure Flash module.
Input:
IN VOID		*Data	The data is a memory buffer. Its content is
                    FLASH_POLICY_INFO_BLOCK defined in SecSmiFlash.h.
Output:
EFI_STATUS


LoadFirmwareImage in the SecureFlash.c

Function : LoadFirmwareImage

File: SecureFlash.c
Description:
Transfer ROM image from AFU's buffer to Secure Flash Module
        through EFI_SEC_SMI_FLASH_PROTOCOL.
Input:
IN VOID		*Data	The data is a memory buffer. Its content is FUNC_BLOCK
                    defined in SmiFlash.h. The member function
                    LOAD_FLASH_IMAGE in EFI_SEC_SMI_FLASH_PROTOCOL only
                    accepts this type of parameter.
Output:
EFI_STATUS


SecureFlashProtocolCallback in the SecureFlash.c

Function : SecureFlashProtocolCallback

File: SecureFlash.c
Description:
Locate SecSmiFlash protocol callback
Input:
IN EFI_EVENT		Event
IN VOID				*Context
Output:
VOID


SetFlashUpdateMethod in the SecureFlash.c

Function : SetFlashUpdateMethod

File: SecureFlash.c
Description:
Set Flash Update Policy to Secure Flash module.
Input:
IN VOID		*Data	The data is a memory buffer. Its content is
                    FUNC_FLASH_SESSION_BLOCK defined in SecSmiFlash.h.
Output:
EFI_STATUS


SmmFlashProtocolCallback in the SecureFlash.c

Function : SmmFlashProtocolCallback

File: SecureFlash.c
Description:
Locate Flash protocol callback
Input:
IN EFI_EVENT		Event
IN VOID				*Context
Output:
VOID


SecureFlash.h

Description:
Header file for OFBD Secure Flash module.


SecureFlash.mak

Description:
Make file for OFBD Secure Flash module.


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

  • A
  • G
  • L
  • S


Functions in Alphabetical Order

A

Function | Description
ASFUEntry | OFBD Secure Flash Update Entry point
ASFUInSmm | This function installs the ASFU Protocol.


Functions in Alphabetical Order

G

Function | Description
GetFlashUpdatePolicy | Get Flash Update Policy from Secure Flash module.


Functions in Alphabetical Order

L

Function | Description
LoadFirmwareImage | Transfer ROM image from AFU's buffer to Secure Flash Module through EFI_SEC_SMI_FLASH_PROTOCOL.


Functions in Alphabetical Order

S

Function | Description
SecureFlashProtocolCallback | Locate SecSmiFlash protocol callback
SetFlashUpdateMethod | Set Flash Update Policy to Secure Flash module.
SmmFlashProtocolCallback | Locate Flash protocol callback


General Information


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2012 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.


Release Notes - NDA Required

Information:

AMI BIOS Core: Aptio 4.6.5.0
Location on Sourcesafe: SS: Alaska;$/Alaska/SOURCE/Modules/OFBD Secure Flash;
Label: 4.6.5.0_OFBD_SECURE_FLASH_0.0.5
Date: 2012-01-18

© American Megatrends Inc.