American Megatrends, Inc.

RestoreSpecialBootOptions

Copyright

Release Notes

© American Megatrends, Inc.


Release Notes - NDA Required

Component Information:
Component Title: Restore Special Boot Options
Component Reference Name: RestoreSpecialBootOptions
Component Type: eModule
Release Date: 2013-07-12
Source Control Label: 4.6.5.4_RSBO_00
Source Control Location: SS: Alaska;$/Alaska/BIN/Modules/BootOptionPolicies/RestoreSpecialBootOptions;
Dependencies
N0NE
Component Description:
This module restores some special boot options that have been applied orphan boot options policy on.
Component file list
RestoreSpecialBootOptions.cif | Component Information File
RestoreSpecialBootOptions.c | Main file
RestoreSpecialBootOptions.chm | CHM file
RestoreSpecialBootOptions.sdl | SDL file
RestoreSpecialBootOptions.mak | Make file to generate RestoreSpecialBootOptions.h that contains the defines of eLink and to build objs with CORE_DXEBin.

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
N0NE
EIP Addressed in this Label:
N0NE
Files Changed for EIP fixes:
N0NE
Known Limitations and Erratas in this label:
N0NE
Remaining Issues:
N0NE
Unit Testing:
N0NE
Validation Testing:
N0NE
Release History:
Initial Release.

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Restore Special Boot Options
Component Reference Name: RestoreSpecialBootOptions
Component Type: eModule
Release Date: 2013-09-10
Source Control Label: 4.6.5.4_RSBO_01
Source Control Location: SS: Alaska;$/Alaska/BIN/Modules/BootOptionPolicies/RestoreSpecialBootOptions;
Dependencies
N0NE
Component Description:
This module restores some special boot options that have been applied orphan boot options policy on.
Component file list
RestoreSpecialBootOptions.cif | Component Information File
RestoreSpecialBootOptions.c | Main file
RestoreSpecialBootOptions.chm | CHM file
RestoreSpecialBootOptions.sdl | SDL file
RestoreSpecialBootOptions.mak | Make file to generate RestoreSpecialBootOptions.h that contains the defines of eLink and to build objs with CORE_DXEBin.

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
N0NE
EIP Addressed in this Label:
EIP #135544 - RestoreSpecialOrphanBootOptions don’t compare multi ELINK names
Files Changed for EIP fixes:
RestoreSpecialBootOptions.c (EIP #135544)
RestoreSpecialBootOptions.sdl (EIP #135544)
Known Limitations and Erratas in this label:
N0NE
Remaining Issues:
N0NE
Unit Testing:
N0NE
Validation Testing:
N0NE
Release History:
RestoreSpecialBootOptions 00

© American Megatrends Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • RestoreSpecialBootOptions.c
  • RestoreSpecialBootOptions.mak
Built on 11:20:56 09/10/13


RestoreSpecialBootOptions.c

Description:
Restore some special boot options.

The following functions are used in the file: RestoreSpecialBootOptions.c.

Function | Description
RestoreBootOptionByPolicy | Restore the orphan boot option by policy.
RestoreSpecialOrphanBootOptions | This function restores the target orphan boot options that have been applied policy on.
UnMaskFilePathList | Unmask the file path that was masked before.


RestoreBootOptionByPolicy in the RestoreSpecialBootOptions.c

Function : RestoreBootOptionByPolicy

File: RestoreSpecialBootOptions.c
Description:
Restore the orphan boot option by policy.
Input:
DLIST *BootOptionList - the master boot option list
BOOT_OPTION *Option - The orphaned boot option
UINTN Policy - the policy to follow, valid values are
   ORPHAN_BOOT_OPTIONS_POLICY_DELETE
   ORPHAN_BOOT_OPTIONS_POLICY_DISABLE
   ORPHAN_BOOT_OPTIONS_POLICY_KEEP
Output:
none


RestoreSpecialOrphanBootOptions in the RestoreSpecialBootOptions.c

Function : RestoreSpecialOrphanBootOptions

File: RestoreSpecialBootOptions.c
Description:
This function restores the target orphan boot options that
have been applied policy on.
Input:
none
Output:
none


UnMaskFilePathList in the RestoreSpecialBootOptions.c

Function : UnMaskFilePathList

File: RestoreSpecialBootOptions.c
Description:
Unmask the file path that was masked before.
Input:
BOOT_OPTION *Option - the boot option's file path to be unmasked
Output:
none


RestoreSpecialBootOptions.mak

Description:
Makefile for the RestoreSpecialBootOptions component.


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

  • R
  • U


Functions in Alphabetical Order

R

Function | Description
RestoreBootOptionByPolicy | Restore the orphan boot option by policy.
RestoreSpecialOrphanBootOptions | This function restores the target orphan boot options that have been applied policy on.


Functions in Alphabetical Order

U

Function | Description
UnMaskFilePathList | Unmask the file path that was masked before.


General Information


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2011 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.