American Megatrends, Inc.

Slp10

Copyright

Release Notes

© American Megatrends, Inc.


AMIBIOS Function Reference

General Information

Built on 12:34:24 06/18/09


eModule Release Notes

AMIBIOS Component Release Notes

Component Information:
Component Name: Slp10
Component Type: eModule
Release Date: July 14, 2009
Source Control Label: 4.5.00_SLP10_02
Source Control Location: $/Alaska/SOURCE/Modules/Slp10
Component Description:
This is an implementation of the SLP 1.0
Filename | Description
Slp10.chm | Help file
Slp10.cif | eModule CIF file
Slp10.mak | Make file
Slp10.h | Internal header file of the Slp10 eModule
Slp10.c | Main file
Slp10.dxs | Dependency file
Slp10.sdl | SDL file
Fixes
July 14, 2009 - Removed $(BUILD_DIR)\AmiHpLibrary.lib from Slp10.mak file
New Features in Latest Release
BLANK
Errata & Known Issues
Slp10 eModule label 4.5.00_SLP10_01 has building issue on the platform different from HP EagleLake. Fixed in the next label.
Revision History
7/14/09 Labeled 4.5.00_SLP10_02
6/26/09 Labeled 4.5.00_SLP10_01
6/19/09 Initial Creation

© American Megatrends Inc.


Function by File Name

By File Name

The following is a list of the .asm files.
For a list in alphabetical order, see In Alphabetical Order.

  • OemTable.asm
  • Slp10.c
  • Slp10.dxs
  • Slp10.h
  • Slp10.mak
Built on 12:27:24 07/14/09


OemTable.asm

Description:
This is OEM table binary for Aptio Firmware Volume.


Slp10.c

Description:
Implementation of the SLP 1.0 eModule.

The following functions are used in the file: Slp10.c.

Function | Description
Slp10_EntryPoint | This function is the entry point of the Slp10 eModule. Parameter: ImageHandle - Image handle for this driver image. SystemTable - Pointer to the EFI system table. Return value: EFI_STATUS


Slp10_EntryPoint in the Slp10.c

Function : Slp10_EntryPoint

File: Slp10.c
Description:
This function is the entry point of the Slp10 eModule.

Parameter:
ImageHandle - Image handle for this driver image.
SystemTable - Pointer to the EFI system table.

Return value: EFI_STATUS


Slp10.dxs

Description:
This file is the dependency file for Slp10 driver


Slp10.h

Description:
Internal header file of the Slp10 eModule.

The following data structures are used in the file: Slp10.h.

Variable | Description
BIOS_OEM_DATA | This structure comes out of the AMI Utility Specification.


BIOS_OEM_DATA in the Slp10.h

Variable : BIOS_OEM_DATA

File: Slp10.h
Fields:

Name | Type | Description
Guid | EFI_GUID | Firmware Section GUID
Identifier | CHAR8 | Identifier String "$ODB$"
Flag | UINT16 | Data Flag
Size | UINT16 | Data Size
Data | UINT8 | Data Buffer (SLP String)

Description:
This structure comes out of the AMI Utility Specification.


Slp10.mak

Description:
Make file for Slp10 eModule.


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

  • B
  • S


Functions in Alphabetical Order

B

Data Structure | Description
BIOS_OEM_DATA | This structure comes out of the AMI Utility Specification.


Functions in Alphabetical Order

S

Function | Description
Slp10_EntryPoint | This function is the entry point of the Slp10 eModule. Parameter: ImageHandle - Image handle for this driver image. SystemTable - Pointer to the EFI system table. Return value: EFI_STATUS


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway, Bldg.200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2009 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.