American Megatrends, Inc.

TCG2 Support

Copyright

General Information

Release Notes

© American Megatrends, Inc.


Release Notes - NDA Required

Component Information:
Component Title: TCG2
Component Reference Name: TCG2
Component Type: eModule
Release Date: 2014-04-21
Source Control Label: 4.6.5.5_TCG2_01
Source Control Location: $/Alaska/SOURCE/Modules/TCG2

Dependencies
The following modules need to be disabled if TCG2 is included in BIOS
Component Title: PTTHCISmm
Component Reference Name: PTTHCISmm
Source Control Location: $/Alaska/SOURCE/Modules/SharkBayRefCodes/ME/Ptt/Smm/;

Component Title: Intel Platform Trust Technology (TPM 2.0)
Component Reference Name: Intel Platform Trust Technology (TPM 2.0)
Source Control Location: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelPTT_TPM20/;

The following modules need to be deleted from project if TCG2 is included in BIOS
Component Title: TCG
Component Reference Name: TCG
Source Control Location: $/Alaska/SOURCE/Modules/TCG;

TCG2 requires NVRAM component
Dependent Component Title: 4.6.5.5_NVRAM
Dependent Component Reference Name: NVRAM
Dependent Source Control Location:$/Alaska/SOURCE/Core/Modules/NvRam;
Non-Compiled BIN and LIB File(s) within this Component:

Component Description:
This component enables Tpm 1.2 and 2.0 support in BIOS
Note: This this module requires that PTTHCISmm module be disabled else Firmware TPM might not function properly under Windows8
AMI Build Tools:
Tools Label: Alaska_Tools_41, Dated: 2013-03-19
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
Remaining Issues:
NONE
Unit Testing:
Booting to BIOS Setup with TPM 1.2, TPM 2.0 Discrete and Intel Firmware TPM 2.0
Booting to Windows 8 with all the aforementioned TPM with no yellow bangs in device drivers
WHCK Testing
PCR7 and Bitlocker Testing
Validation Testing:
Release History:

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: TCG2
Component Reference Name: TCG2
Component Type: eModule
Release Date: 2014-07-2
Source Control Label: 4.6.5.5_TCG2_02
Source Control Location: $/Alaska/SOURCE/Modules/TCG2

Dependencies
The following modules need to be disabled if TCG2 is included in BIOS
Component Title: PTTHCISmm
Component Reference Name: PTTHCISmm
Source Control Location: $/Alaska/SOURCE/Modules/SharkBayRefCodes/ME/Ptt/Smm/;

Component Title: Intel Platform Trust Technology (TPM 2.0)
Component Reference Name: Intel Platform Trust Technology (TPM 2.0)
Source Control Location: $/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelPTT_TPM20/;

The following modules need to be deleted from project if TCG2 is included in BIOS
Component Title: TCG
Component Reference Name: TCG
Source Control Location: $/Alaska/SOURCE/Modules/TCG;

TCG2 requires NVRAM component
Dependent Component Title: 4.6.5.5_NVRAM
Dependent Component Reference Name: NVRAM
Dependent Source Control Location:$/Alaska/SOURCE/Core/Modules/NvRam;
Non-Compiled BIN and LIB File(s) within this Component:

Component Description:
This component enables Tpm 1.2 and 2.0 support in BIOS
Note: This this module requires that PTTHCISmm module be disabled else Firmware TPM might not function properly under Windows8
AMI Build Tools:
Tools Label: Alaska_Tools_41, Dated: 2013-03-19
Visual eBios: RSS.5.73.0244, Dated: 2013-03-19
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
Remaining Issues:
NONE
Unit Testing:
Booting to BIOS Setup with TPM 1.2, TPM 2.0 Discrete and Intel Firmware TPM 2.0
Booting to Windows 8 with all the aforementioned TPM with no yellow bangs in device drivers
WHCK Testing
PCR7 and Bitlocker Testing
WHCK TPM 1.2 and TPM 2.0 testing
Validation Testing:
Release History:
4.6.5.5_TCG2_01_a

© American Megatrends Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • AmiTcgNvflagSample.c
  • AmiTcgNvflagSample.dxs
  • AmiTcgNvflagSample.h
  • AmiTcgNvflagSample.mak
  • AmiTcgPlatformDxe.c
  • AmiTcgPlatformDxe.dxs
  • AmiTcgPlatformDxe.h
  • AmiTcgPlatformDxe.mak
  • AmiTcgPlatformDxeLib.c
  • AmiTcgPlatformDxeLib.h
  • AmiTcgPlatformPei.dxs
  • AmiTcgPlatformPei.h
  • AmiTcgPlatformPeiAfterMem.c
  • AmiTcgPlatformPeiAfterMem.mak
  • AmiTcgPlatformPeiBeforeMem.c
  • AmiTcgPlatformPeiBeforeMem.mak
  • AmiTcgPlatformPeiLib.c
  • AmiTcmlib.c
  • AmiTcmlib.dxs
  • AmiTcmlib.h
  • AmiTcmlib.mak
  • EMpCallBin.asm
  • EMpCallBin32.asm
  • EMpTcmDxe.c
  • EMpTcmPei.c
  • HandleLoadDefaultsSetup.c
  • INTTcgAcpi.h
  • sha.h
  • tcg_ppi1_2.asl
  • tcg_ppi1_2_Ex.asl
  • TcgBins.mak
  • TcgCommon.c
  • TcgCommon.h
  • TcgDxe.c
  • TcgDxe.dxs
  • TcgDxe.mak
  • TcgDxeplatform.c
  • TcgDxeplatform.dxs
  • TcgDxeplatform.h
  • TcgDxeplatform.mak
  • TcgEFI12.h
  • TcgEfiTpm.h
  • TcgLegacy.c
  • TcgLegacy.dxs
  • TcgLegacy.h
  • TcgLegacy.mak
  • TCGMisc.h
  • TcgPc.h
  • TcgPei.dxs
  • TcgPei.mak
  • TcgPeiAfterMem.c
  • TcgPeiAfterMem.mak
  • TcgPeiplatform.c
  • TcgPeiplatform.dxs
  • TcgPeiplatform.h
  • TcgPeiplatform.mak
  • TcgPlatformSetupPeiPolicy.c
  • TcgPlatformSetupPeiPolicy.dxs
  • TcgPlatformSetupPeiPolicy.h
  • TcgPlatformSetupPeiPolicy.mak
  • TcgPlatformSetupPolicy.c
  • TcgPlatformSetupPolicy.dxs
  • TcgPlatformSetupPolicy.h
  • TcgPlatformSetupPolicy.mak
  • TcgPrivate.c
  • TcgPrivate.h
  • TcgService.c
  • TcgService.h
  • TcgSetup.c
  • TcgSetup.mak
  • TcgSetup.sd
  • TcgSetupBoard.h
  • TCGSmm.c
  • TCGSmm.DXS
  • TCGSmm.h
  • TCGSmm.mak
  • TcgTcmPei.c
  • TcgTcmPeiAfterMem.c
  • TcgTcmService.c
  • TcgTcmService.h
  • TcgTisPei.c
  • TcgTpm12.h
  • TcmPc.h
  • TisLib.mak
  • TisPei.c
  • Tpm20.h
  • Tpm20Acpi.DXS
  • Tpm20Acpi.mak
  • Tpm20CRBLib.mak
  • Tpm20PlatformDxe.dxs
  • Tpm20PlatformDxe.h
  • Tpm20PlatformDxeLib.h
  • TpmClearOnRollback.c
  • TpmClearOnRollback.dxs
  • TpmDevice.c
  • TpmDevice.h
  • TpmDxe.c
  • TpmLib.c
  • TpmLib.h
  • TPMPwd.c
  • xTcgDxe.c
  • xTcgPei.c
  • xTcgPeiAfterMem.c
  • ZTEICTcmOrdinals.h
Built on 22:29:33 07/02/14


AmiTcgNvflagSample.c

Description:
This is a sample file for support TCG Ppi. It creates and installed
a protocal to access the persistent bios tpm flags in Tpm NV 0x50010000.
See Ppi Spec 1.2

The following functions are used in the file: AmiTcgNvflagSample.c.

Function | Description
AmiTcgPpiNvflagEntry | Entry point
NvSendTpmCommand | Sends a command to the TPM
Read_Persistent_Bios_TPM_Flags | Read persistent bios flags in TPM NV
Set_Persistent_Bios_TPM_Flags | Sets persistent bios flags in TPM NV
TcmRead_Persistent_Bios_TPM_Flags | Sets persistent bios flags in TPM NV
TcmSet_Persistent_Bios_TPM_Flags | Sets persistent bios flags in TPM NV


AmiTcgPpiNvflagEntry in the AmiTcgNvflagSample.c

Function : AmiTcgPpiNvflagEntry

File: AmiTcgNvflagSample.c
Description:
Entry point
Input:
IN      EFI_FFS_FILE_HEADER       *FfsHeader
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


NvSendTpmCommand in the AmiTcgNvflagSample.c

Function : NvSendTpmCommand

File: AmiTcgNvflagSample.c
Description:
Sends a command to the TPM
Input:
*EFI_TCG_PROTOCOL   - Tcg Protocol type.
UINT32              - Tcg Command ordinal.
int                 - cmd datasize.
VOID*               - cmd data.
Output:
UINT32              - TPM_RESULT


Read_Persistent_Bios_TPM_Flags in the AmiTcgNvflagSample.c

Function : Read_Persistent_Bios_TPM_Flags

File: AmiTcgNvflagSample.c
Description:
Read persistent bios flags in TPM NV
Input:
IN PERSISTENT_BIOS_TPM_FLAGS *
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


Set_Persistent_Bios_TPM_Flags in the AmiTcgNvflagSample.c

Function : Set_Persistent_Bios_TPM_Flags

File: AmiTcgNvflagSample.c
Description:
Sets persistent bios flags in TPM NV
Input:
IN PERSISTENT_BIOS_TPM_FLAGS *
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcmRead_Persistent_Bios_TPM_Flags in the AmiTcgNvflagSample.c

Function : TcmRead_Persistent_Bios_TPM_Flags

File: AmiTcgNvflagSample.c
Description:
Sets persistent bios flags in TPM NV
Input:
IN PERSISTENT_BIOS_TPM_FLAGS *
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcmSet_Persistent_Bios_TPM_Flags in the AmiTcgNvflagSample.c

Function : TcmSet_Persistent_Bios_TPM_Flags

File: AmiTcgNvflagSample.c
Description:
Sets persistent bios flags in TPM NV
Input:
IN PERSISTENT_BIOS_TPM_FLAGS *
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


AmiTcgNvflagSample.dxs


AmiTcgNvflagSample.h

Description:
This is a sample file for support TCG Ppi. It creates and installed
a protocal to access the persistent bios tpm flags in Tpm NV 0x50010000.
See Ppi Spec 1.2


AmiTcgNvflagSample.mak

Description:


AmiTcgPlatformDxe.c

Description:
Function file for AmiTcgPlatformDxe

The following functions are used in the file: AmiTcgPlatformDxe.c.

Function | Description
check_authenticate_set | checks if password authentication set in Setup
check_user_is_administrator | check if user was authenticated as an administrator (optional)
CheckTpmOwnership | Executes TPM operation to read capabilities
ClearFastBootLastBootFailedFlag | FastBoot clear boot fail flag callback
confirmUser | Wait on key press from ConIn; Accept Esc or F10. Timeout if user doesn't respond INPUT: OUTPUT: UINT8
displOperations | Display requested actions as a list of operations INPUT: IN extended_request erqst, IN int count, IN CHAR16 *DesStr OUTPUT: VOID
displTpmNvOperations | Display requested actions as a list of operations INPUT: IN extended_request erqst, IN CHAR16 *DesStr OUTPUT: VOID
doCpuMicrocodeTcgEvent | Measures EV_CPU_MICROCODE event
DoResetNow | Callback function to execute TPM reset
doTcmCpuMicrocodeTcgEvent | Measures EV_CPU_MICROCODE event
DummySkipPhysicalPresencePtr | Always return false. Can be overridden with OEM function
EfiLibGetSystemConfigurationTable | Get table from configuration table by name
execute_request | Execute TPM operation INPUT: IN UINT8 rqst OUTPUT: error code if any as result of executing the operation
extend_request | Convert the opcode into array of 2-bit values.For each 2-bit: 0 - no change; 1 - turn off; 2 - turn on indexes: 0 - enable flag; 1 - active flag; 2 - onwership 3 - clear INPUT: IN UINT8 rqst OUTPUT: extended_request
GET_PFA | Returns PCI device Bus Device Function infomation
GetPCIOPROMImage | Finds Onboard Option ROM Images
GetStringFromToken | Gets a UNI string by Token
MeasureAllBootVariables | Measures all the boot Variables
measureCpuMicroCode | Locates CPU Microcode update and measures it as a TCG event
MeasureHandoffTables | Measures, Logs and Extends EFI Handoff Tables. eg: SMBIOS
MeasurePCIOproms | Sets callback to measure PCI option roms that are given control
MeasurePciOptionRom | Measures EV_ID_OPROM_EXECUTE event address (PFA) and with digest of the specified PCI device OpRom image
MeasureSeparatorEvent | Measure Tcg Event Separator
MeasureVariable | Measures a provided variable
OnAdminPasswordValid | Sets AdminPasswordValid to TRUE [If TPM_PASSWORD_AUTHENTICATION]
OnPasswordSupplied | Sets PasswordSupplied to TRUE and runs PPI User Interface
OnPciIOInstalled | Checks if PCI device has an Option Rom and initiates the Option rom measurment
ProcessTcgPpiRequest | Process Tcg Ppi requests
ProcessTcgSetup | Handles Tcg Setup functionality
prompt_operation | Display information on the requested TPM operation to the user; INPUT: IN int rqst OUTPUT: VOID
read_TPM_capabilities | Executes TPM operation to read capabilities
read_volatile_flags | Executes TPM operation to read capabilities
ReadAndMeasureBootVariable | Read and Measures Boot Variable
ReadVariable | Reads Boot Variable
RequestSystemReset | Requests for system reset through core else creates a call back to execute reset
ResetOSTcgVar | Function to reset TCG variables on certain scenerions
SendTpmCommand | Sends a command to the TPM
SetTcgReadyToBoot | Sets ready to boot callback on ready to boot for security device
SignalProtocolEvent | Internal function that installs/uninstalls protocol with a specified GUID and NULL interface. Such protocols can be used as event signaling mechanism.
tcgReadyToBoot | Generic Measurements done before EFI boots OS
TcmMeasureHandoffTables | Measures, Logs and Extends EFI Handoff Tables. eg: SMBIOS
TcmMeasureSeparatorEvent | Measure Tcg Event Separator
TcmMeasureVariable | Measures a provided variable


check_authenticate_set in the AmiTcgPlatformDxe.c

Function : check_authenticate_set

File: AmiTcgPlatformDxe.c
Description:
checks if password authentication set in Setup
Input:
Output:
BOOLEAN
Modified:
Notes:

Referrals:


check_user_is_administrator in the AmiTcgPlatformDxe.c

Function : check_user_is_administrator

File: AmiTcgPlatformDxe.c
Description:
check if user was authenticated as an administrator (optional)
Input:
Output:
BOOLEAN
Modified:
Notes:

Referrals:


CheckTpmOwnership in the AmiTcgPlatformDxe.c

Function : CheckTpmOwnership

File: AmiTcgPlatformDxe.c
Description:
Executes TPM operation to read capabilities
Input:
IN EFI_TCG_PROTOCOL *tcg
Output:
void
Modified:
Notes:

Referrals:


ClearFastBootLastBootFailedFlag in the AmiTcgPlatformDxe.c

Function : ClearFastBootLastBootFailedFlag

File: AmiTcgPlatformDxe.c
Description:
FastBoot clear boot fail flag callback
Input:
IN EFI_EVENT Event - Callback event
IN VOID *Context - pointer to calling context
Output:
None


confirmUser in the AmiTcgPlatformDxe.c

Function : confirmUser

File: AmiTcgPlatformDxe.c
Description:
Wait on key press from ConIn; Accept Esc or F10.
Timeout if user doesn't respond

INPUT:

OUTPUT:       UINT8
Modified:
Notes:

Referrals:


displOperations in the AmiTcgPlatformDxe.c

Function : displOperations

File: AmiTcgPlatformDxe.c
Description:
Display requested actions as a list of operations

INPUT:       IN extended_request erqst,
IN int              count,
IN CHAR16           *DesStr

OUTPUT:      VOID
Modified:
Notes:

Referrals:


displTpmNvOperations in the AmiTcgPlatformDxe.c

Function : displTpmNvOperations

File: AmiTcgPlatformDxe.c
Description:
Display requested actions as a list of operations

INPUT:       IN extended_request erqst,
IN CHAR16           *DesStr

OUTPUT:      VOID
Modified:
Notes:

Referrals:


doCpuMicrocodeTcgEvent in the AmiTcgPlatformDxe.c

Function : doCpuMicrocodeTcgEvent

File: AmiTcgPlatformDxe.c
Description:
Measures EV_CPU_MICROCODE event
Input:
IN      Buffer
IN      size
Output:
Device path size
Modified:
Notes:

Referrals:


DoResetNow in the AmiTcgPlatformDxe.c

Function : DoResetNow

File: AmiTcgPlatformDxe.c
Description:
Callback function to execute TPM reset
Input:
IN EFI_EVENT ev,
IN VOID      *ctx
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


doTcmCpuMicrocodeTcgEvent in the AmiTcgPlatformDxe.c

Function : doTcmCpuMicrocodeTcgEvent

File: AmiTcgPlatformDxe.c
Description:
Measures EV_CPU_MICROCODE event
Input:
IN      Buffer
IN      size
Output:
Device path size
Modified:
Notes:

Referrals:


DummySkipPhysicalPresencePtr in the AmiTcgPlatformDxe.c

Function : DummySkipPhysicalPresencePtr

File: AmiTcgPlatformDxe.c
Description:
Always return false. Can be overridden with OEM function
Input:
IN  EFI_EVENT       efiev
IN  VOID            *ctx
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


EfiLibGetSystemConfigurationTable in the AmiTcgPlatformDxe.c

Function : EfiLibGetSystemConfigurationTable

File: AmiTcgPlatformDxe.c
Description:
Get table from configuration table by name
Input:
IN EFI_GUID *TableGuid,
IN OUT VOID **Table
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


execute_request in the AmiTcgPlatformDxe.c

Function : execute_request

File: AmiTcgPlatformDxe.c
Description:
Execute TPM operation

INPUT:       IN UINT8 rqst

OUTPUT:      error code if any as result of executing the operation
Modified:
Notes:

Referrals:


extend_request in the AmiTcgPlatformDxe.c

Function : extend_request

File: AmiTcgPlatformDxe.c
Description:
Convert the opcode into array of 2-bit values.For each 2-bit: 0 - no change; 1 - turn off; 2 - turn on
indexes: 0 - enable flag; 1 - active flag; 2 - onwership
3 - clear

INPUT:       IN UINT8 rqst

OUTPUT:      extended_request
Modified:
Notes:

Referrals:


GET_PFA in the AmiTcgPlatformDxe.c

Function : GET_PFA

File: AmiTcgPlatformDxe.c
Description:
Returns PCI device Bus Device Function infomation
Input:
EFI_PCI_IO_PROTOCOL   *pciIo
Output:
UINT16
Modified:
Notes:

Referrals:


GetPCIOPROMImage in the AmiTcgPlatformDxe.c

Function : GetPCIOPROMImage

File: AmiTcgPlatformDxe.c
Description:
Finds Onboard Option ROM Images
Input:
IN  EFI_HANDLE   PciHandle,
OUT VOID         *RomImage,
OUT UINTN        *Romsize,
OUT UINTN        *Flags
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


GetStringFromToken in the AmiTcgPlatformDxe.c

Function : GetStringFromToken

File: AmiTcgPlatformDxe.c
Description:
Gets a UNI string by Token
Input:
IN      STRING_REF                Token,
OUT     CHAR16                    **String
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


MeasureAllBootVariables in the AmiTcgPlatformDxe.c

Function : MeasureAllBootVariables

File: AmiTcgPlatformDxe.c
Description:
Measures all the boot Variables
Input:
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


measureCpuMicroCode in the AmiTcgPlatformDxe.c

Function : measureCpuMicroCode

File: AmiTcgPlatformDxe.c
Description:
Locates CPU Microcode update and measures it as a TCG event
Input:
NONE
Output:
Device path size
Modified:
Notes:

Referrals:


MeasureHandoffTables in the AmiTcgPlatformDxe.c

Function : MeasureHandoffTables

File: AmiTcgPlatformDxe.c
Description:
Measures, Logs and Extends EFI Handoff Tables. eg: SMBIOS
Input:
VOID
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


MeasurePCIOproms in the AmiTcgPlatformDxe.c

Function : MeasurePCIOproms

File: AmiTcgPlatformDxe.c
Description:
Sets callback to measure PCI option roms that are given control
Input:
NONE
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


MeasurePciOptionRom in the AmiTcgPlatformDxe.c

Function : MeasurePciOptionRom

File: AmiTcgPlatformDxe.c
Description:
Measures EV_ID_OPROM_EXECUTE event
address (PFA) and with digest of the specified PCI device
OpRom image
Input:
IN VOID  *pImage,
IN UINTN len,
IN UINT16   pfa
Output:
Modified:
Notes:

Referrals:


MeasureSeparatorEvent in the AmiTcgPlatformDxe.c

Function : MeasureSeparatorEvent

File: AmiTcgPlatformDxe.c
Description:
Measure Tcg Event Separator
Input:
IN      TPM_PCRINDEX              PCRIndex,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


MeasureVariable in the AmiTcgPlatformDxe.c

Function : MeasureVariable

File: AmiTcgPlatformDxe.c
Description:
Measures a provided variable
Input:
IN      TPM_PCRINDEX              PCRIndex,
IN      TCG_EVENTTYPE             EventType,
IN      CHAR16                    *VarName,
IN      EFI_GUID                  *VendorGuid,
IN      VOID                      *VarData,
IN      UINTN                     VarSize
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


OnAdminPasswordValid in the AmiTcgPlatformDxe.c

Function : OnAdminPasswordValid

File: AmiTcgPlatformDxe.c
Description:
Sets AdminPasswordValid to TRUE [If TPM_PASSWORD_AUTHENTICATION]
Input:
IN EFI_EVENT ev,
IN VOID *ctx
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


OnPasswordSupplied in the AmiTcgPlatformDxe.c

Function : OnPasswordSupplied

File: AmiTcgPlatformDxe.c
Description:
Sets PasswordSupplied to TRUE and runs PPI User Interface
Input:
IN EFI_EVENT ev,
IN VOID *ctx
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


OnPciIOInstalled in the AmiTcgPlatformDxe.c

Function : OnPciIOInstalled

File: AmiTcgPlatformDxe.c
Description:
Checks if PCI device has an Option Rom and initiates the
Option rom measurment
Input:
IN  EFI_EVENT       ev
IN  VOID            *ctx
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


ProcessTcgPpiRequest in the AmiTcgPlatformDxe.c

Function : ProcessTcgPpiRequest

File: AmiTcgPlatformDxe.c
Description:
Process Tcg Ppi requests
Input:
NONE
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


ProcessTcgSetup in the AmiTcgPlatformDxe.c

Function : ProcessTcgSetup

File: AmiTcgPlatformDxe.c
Description:
Handles Tcg Setup functionality
Input:
NONE
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


prompt_operation in the AmiTcgPlatformDxe.c

Function : prompt_operation

File: AmiTcgPlatformDxe.c
Description:
Display information on the requested TPM operation to the user;

INPUT:       IN int rqst

OUTPUT:      VOID
Modified:
Notes:

Referrals:


read_TPM_capabilities in the AmiTcgPlatformDxe.c

Function : read_TPM_capabilities

File: AmiTcgPlatformDxe.c
Description:
Executes TPM operation to read capabilities
Input:
IN EFI_TCG_PROTOCOL* tcg
Output:
TPM capabilities structure
Modified:
Notes:

Referrals:


read_volatile_flags in the AmiTcgPlatformDxe.c

Function : read_volatile_flags

File: AmiTcgPlatformDxe.c
Description:
Executes TPM operation to read capabilities
Input:
IN EFI_TCG_PROTOCOL* tcg
Output:
TPM capabilities structure
Modified:
Notes:

Referrals:


ReadAndMeasureBootVariable in the AmiTcgPlatformDxe.c

Function : ReadAndMeasureBootVariable

File: AmiTcgPlatformDxe.c
Description:
Read and Measures Boot Variable
Input:
IN      CHAR16      *VarName,
IN      EFI_GUID    *VendorGuid,
OUT     UINTN       *VarSize
OUT     VOID        **VarData
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


ReadVariable in the AmiTcgPlatformDxe.c

Function : ReadVariable

File: AmiTcgPlatformDxe.c
Description:
Reads Boot Variable
Input:
IN      CHAR16      *VarName,
IN      EFI_GUID    *VendorGuid,
OUT     UINTN       *VarSize
Output:
VOID*
Modified:
Notes:

Referrals:


RequestSystemReset in the AmiTcgPlatformDxe.c

Function : RequestSystemReset

File: AmiTcgPlatformDxe.c
Description:
Requests for system reset through core else creates a call
 back to execute reset
Input:
IN EFI_RESET_TYPE type
Output:
VOID
Modified:
Notes:

Referrals:


ResetOSTcgVar in the AmiTcgPlatformDxe.c

Function : ResetOSTcgVar

File: AmiTcgPlatformDxe.c
Description:
Function to reset TCG variables on certain scenerions
Input:
Output:
VOID
Modified:
Notes:

Referrals:


SendTpmCommand in the AmiTcgPlatformDxe.c

Function : SendTpmCommand

File: AmiTcgPlatformDxe.c
Description:
Sends a command to the TPM
Input:
IN      EFI_TCG_PROTOCOL *tcg,
IN      UINT32           ord,
IN      int dataSize,
IN OUT  VOID  *data
Output:
TPM_RESULT
Modified:
Notes:

Referrals:


SetTcgReadyToBoot in the AmiTcgPlatformDxe.c

Function : SetTcgReadyToBoot

File: AmiTcgPlatformDxe.c
Description:
Sets ready to boot callback on ready to boot for security device
Input:
NONE
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


SignalProtocolEvent in the AmiTcgPlatformDxe.c

Function : SignalProtocolEvent

File: AmiTcgPlatformDxe.c
Description:
Internal function that installs/uninstalls protocol with a specified
GUID and NULL interface. Such protocols can be used as event
signaling mechanism.
Input:
IN EFI_GUID *TcgPasswordAuthenticationGuid - Pointer to the protocol GUID
Output:
VOID
Modified:
Notes:

Referrals:


tcgReadyToBoot in the AmiTcgPlatformDxe.c

Function : tcgReadyToBoot

File: AmiTcgPlatformDxe.c
Description:
Generic Measurements done before EFI boots OS
Input:
IN  EFI_EVENT       efiev
IN  VOID            *ctx
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcmMeasureHandoffTables in the AmiTcgPlatformDxe.c

Function : TcmMeasureHandoffTables

File: AmiTcgPlatformDxe.c
Description:
Measures, Logs and Extends EFI Handoff Tables. eg: SMBIOS
Input:
VOID
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcmMeasureSeparatorEvent in the AmiTcgPlatformDxe.c

Function : TcmMeasureSeparatorEvent

File: AmiTcgPlatformDxe.c
Description:
Measure Tcg Event Separator
Input:
IN      TPM_PCRINDEX              PCRIndex,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcmMeasureVariable in the AmiTcgPlatformDxe.c

Function : TcmMeasureVariable

File: AmiTcgPlatformDxe.c
Description:
Measures a provided variable
Input:
IN      TPM_PCRINDEX              PCRIndex,
IN      TCG_EVENTTYPE             EventType,
IN      CHAR16                    *VarName,
IN      EFI_GUID                  *VendorGuid,
IN      VOID                      *VarData,
IN      UINTN                     VarSize
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


AmiTcgPlatformDxe.dxs

Description:
Dependency file for AmiTcgPlatformDxe


AmiTcgPlatformDxe.h

Description:
Header file for AmiTcgPlatformDxe


AmiTcgPlatformDxe.mak

Description:
Make file for AmiTcgPlatformDxe


AmiTcgPlatformDxeLib.c

Description:
Function file for AmiTcgPlatformDxe library

The following functions are used in the file: AmiTcgPlatformDxeLib.c.

Function | Description
CompareGuid | Compares two input GUIDs
GetDsdt | Locates ACPI Table Protocol
GetHob | Find instance of a HOB type in a HOB list
GetNextGuidHob | Find GUID HOB
getSetupData | Retrieved SETUP_DATA structure from NVRAM
GetTcgWakeEventType | Reads and Reports the source of the wake-up event.
LocateACPITableProtocol | Locates ACPI Table Protocol
LocateATcgHob | Finds a Tcg HOB
read_PPI_request | Reads and returns TCG PPI requests Value
TcgCheckOpCode | converts String a to ASL string NAME
TcgConvertAslName | converts String a to ASL string NAME
TcgFindAslObjectName | converts String a to ASL string NAME
TcgGetAslObj | converts String a to ASL string NAME
TcgGetDSDTTable | Gets Acpi DSDT table
TcgUpdateAslNameObject | Locates ACPI Table Protocol
TcgUpdateAslObj | Updates TPM acpi variable for TPM support
UpDateASL | Update TCG ASL Support in ACPI base
write_PPI_result | Updates TCG PPI variable in NVRAM


CompareGuid in the AmiTcgPlatformDxeLib.c

Function : CompareGuid

File: AmiTcgPlatformDxeLib.c
Description:
Compares two input GUIDs
Input:
IN    EFI_GUID *G1,
IN    EFI_GUID *G2
Output:
BOOLEAN
Modified:
Notes:

Referrals:


GetDsdt in the AmiTcgPlatformDxeLib.c

Function : GetDsdt

File: AmiTcgPlatformDxeLib.c
Description:
Locates ACPI Table Protocol
Input:
IN   OUT  mem_in *dsdt
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


GetHob in the AmiTcgPlatformDxeLib.c

Function : GetHob

File: AmiTcgPlatformDxeLib.c
Description:
Find instance of a HOB type in a HOB list
Input:
IN UINT16  Type,
IN VOID    *HobStart
Output:
VOID*
Modified:
Notes:

Referrals:


GetNextGuidHob in the AmiTcgPlatformDxeLib.c

Function : GetNextGuidHob

File: AmiTcgPlatformDxeLib.c
Description:
Find GUID HOB
Input:
HobStart    A pointer to the start hob.
Guid        A pointer to a guid.
Output:
Buffer          A pointer to the buffer.
BufferSize      Buffer size.
Modified:
Notes:

Referrals:


getSetupData in the AmiTcgPlatformDxeLib.c

Function : getSetupData

File: AmiTcgPlatformDxeLib.c
Description:
Retrieved SETUP_DATA structure from NVRAM
Input:
IN  OUT   SETUP_DATA** ppsd,
IN  UINT32* pattr,
IN  UINTN* psz
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


GetTcgWakeEventType in the AmiTcgPlatformDxeLib.c

Function : GetTcgWakeEventType

File: AmiTcgPlatformDxeLib.c
Description:
Reads and Reports the source of the wake-up event.
Input:
IN OUT UINT8   *pWake   - output parameter returns the indication of the
                         type of the wakup source:
               one of the following:
               SMBIOS_WAKEUP_TYPE_OTHERS
               SMBIOS_WAKEUP_TYPE_UNKNOWN
               SMBIOS_WAKEUP_TYPE_APM_TIMER
               SMBIOS_WAKEUP_TYPE_MODEM_RING
               SMBIOS_WAKEUP_TYPE_LAN_REMOTE
               SMBIOS_WAKEUP_TYPE_POWER_SWITCH
               SMBIOS_WAKEUP_TYPE_PCI_PME
               SMBIOS_WAKEUP_TYPE_AC_POWER_RESTORED
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


LocateACPITableProtocol in the AmiTcgPlatformDxeLib.c

Function : LocateACPITableProtocol

File: AmiTcgPlatformDxeLib.c
Description:
Locates ACPI Table Protocol
Input:
IN   EFI_GUID *Protocol,
OUT  VOID **Instance
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


LocateATcgHob in the AmiTcgPlatformDxeLib.c

Function : LocateATcgHob

File: AmiTcgPlatformDxeLib.c
Description:
Finds a Tcg HOB
Input:
IN    UINTN NoTableEntries,
IN    EFI_CONFIGURATION_TABLE   *ConfigTable,
IN    EFI_GUID    *HOB_guid
Output:
VOID*
Modified:
Notes:

Referrals:


read_PPI_request in the AmiTcgPlatformDxeLib.c

Function : read_PPI_request

File: AmiTcgPlatformDxeLib.c
Description:
Reads and returns TCG PPI requests Value
Input:
Output:
UINT8
Modified:
Notes:

Referrals:


TcgCheckOpCode in the AmiTcgPlatformDxeLib.c

Function : TcgCheckOpCode

File: AmiTcgPlatformDxeLib.c
Description:
converts String a to ASL string NAME
Input:
IN         UINT8 *NameStart,
IN         UINT8 OpCode,
IN         UINT8 ExtOpCode,
IN  OUT    ASL_OBJ_INFO *ObjInfo
Output:
BOOLEAN
Modified:
Notes:

Referrals:


TcgConvertAslName in the AmiTcgPlatformDxeLib.c

Function : TcgConvertAslName

File: AmiTcgPlatformDxeLib.c
Description:
converts String a to ASL string NAME
Input:
IN UINT8 *AslName
Output:
UINT32
Modified:
Notes:

Referrals:


TcgFindAslObjectName in the AmiTcgPlatformDxeLib.c

Function : TcgFindAslObjectName

File: AmiTcgPlatformDxeLib.c
Description:
converts String a to ASL string NAME
Input:
IN      UINT8 *Start,
IN      UINT8 *ObjName,
IN      UINTN Len
Output:
VOID    *
Modified:
Notes:

Referrals:


TcgGetAslObj in the AmiTcgPlatformDxeLib.c

Function : TcgGetAslObj

File: AmiTcgPlatformDxeLib.c
Description:
converts String a to ASL string NAME
Input:
IN      UINT8 *Start,
IN      UINTN Length,
IN      UINT8 *Name,
IN      ASL_OBJ_TYPE ObjType,
IN      ASL_OBJ_INFO *ObjInfo
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcgGetDSDTTable in the AmiTcgPlatformDxeLib.c

Function : TcgGetDSDTTable

File: AmiTcgPlatformDxeLib.c
Description:
Gets Acpi DSDT table
Input:
Output:
VOID *
Modified:
Notes:

Referrals:


TcgUpdateAslNameObject in the AmiTcgPlatformDxeLib.c

Function : TcgUpdateAslNameObject

File: AmiTcgPlatformDxeLib.c
Description:
Locates ACPI Table Protocol
Input:
IN   PACPI_HDR PDsdt,
IN   UINT8 *ObjName,
IN   UINT64 Value
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcgUpdateAslObj in the AmiTcgPlatformDxeLib.c

Function : TcgUpdateAslObj

File: AmiTcgPlatformDxeLib.c
Description:
Updates TPM acpi variable for TPM support
Input:
IN   EFI_EVENT ev,
IN   VOID *ctx,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


UpDateASL in the AmiTcgPlatformDxeLib.c

Function : UpDateASL

File: AmiTcgPlatformDxeLib.c
Description:
Update TCG ASL Support in ACPI base
Input:
IN    UINT8    TcgSupport
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


write_PPI_result in the AmiTcgPlatformDxeLib.c

Function : write_PPI_result

File: AmiTcgPlatformDxeLib.c
Description:
Updates TCG PPI variable in NVRAM
Input:
IN  UINT8 last_op,
IN  UINT16 status
Output:
VOID
Modified:
Notes:

Referrals:


AmiTcgPlatformDxeLib.h

Description:
Header firl for AmiTcgPlatformDxe library


AmiTcgPlatformPei.dxs

Description:
Dependency file


AmiTcgPlatformPei.h

Description:
Header file for AmiTcgPlatformPei


AmiTcgPlatformPeiAfterMem.c

Description:
Function file for AmiTcgPlatformPeiAfterMem

The following functions are used in the file: AmiTcgPlatformPeiAfterMem.c.

Function | Description
AmiTcgPlatformPEI_EntryAfterMem | Installs AMIplatform PPI for initialization in PEI after memory is installed
MemoryPresentEntry | This function performs TPM MP initialization
Set_TCMPhysicalPresence | Sets TCM physical Presence
Set_TPMPhysicalPresence | Sets TPM physical Presence
TcgPeiGetRawImage | Loads binary from RAW section of main firwmare volume
VerifyTcgVariables | Function to check whether we need to reset TCG variables


AmiTcgPlatformPEI_EntryAfterMem in the AmiTcgPlatformPeiAfterMem.c

Function : AmiTcgPlatformPEI_EntryAfterMem

File: AmiTcgPlatformPeiAfterMem.c
Description:
Installs AMIplatform PPI for initialization in PEI after
memory is installed
Input:
IN EFI_FFS_FILE_HEADER *FfsHeader,
IN EFI_PEI_SERVICES    **PeiServices
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


MemoryPresentEntry in the AmiTcgPlatformPeiAfterMem.c

Function : MemoryPresentEntry

File: AmiTcgPlatformPeiAfterMem.c
Description:
This function performs TPM MP initialization
Input:
IN     EFI_PEI_SERVICES  **PeiServices,
Output:
EFI STATUS
Modified:
Notes:

Referrals:


Set_TCMPhysicalPresence in the AmiTcgPlatformPeiAfterMem.c

Function : Set_TCMPhysicalPresence

File: AmiTcgPlatformPeiAfterMem.c
Description:
Sets TCM physical Presence
Input:
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


Set_TPMPhysicalPresence in the AmiTcgPlatformPeiAfterMem.c

Function : Set_TPMPhysicalPresence

File: AmiTcgPlatformPeiAfterMem.c
Description:
Sets TPM physical Presence
Input:
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcgPeiGetRawImage in the AmiTcgPlatformPeiAfterMem.c

Function : TcgPeiGetRawImage

File: AmiTcgPlatformPeiAfterMem.c
Description:
Loads binary from RAW section of main firwmare volume
Input:
IN EFI_PEI_SERVICES **PeiServices
IN OUT VOID         **Buffer
IN OUT UINT16       *size
IN     EFI_GUID     guid
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


VerifyTcgVariables in the AmiTcgPlatformPeiAfterMem.c

Function : VerifyTcgVariables

File: AmiTcgPlatformPeiAfterMem.c
Description:
Function to check whether we need to reset TCG variables
Input:
EFI_PEI_SERVICES **PeiServices
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


AmiTcgPlatformPeiAfterMem.mak

Description:
Make file for AmiTcgPlatformPeiAfterMem


AmiTcgPlatformPeiBeforeMem.c

Description:
Function file for AmiTcgPlatformPeiBeforeMem

The following functions are used in the file: AmiTcgPlatformPeiBeforeMem.c.

Function | Description
AmiTcgPlatformPEI_EntryBeforeMem | Installs AMIplatform PPI for initialization in PEI before memory is installed
MemoryAbsentEntry | This function performs TPM MA initialization


AmiTcgPlatformPEI_EntryBeforeMem in the AmiTcgPlatformPeiBeforeMem.c

Function : AmiTcgPlatformPEI_EntryBeforeMem

File: AmiTcgPlatformPeiBeforeMem.c
Description:
Installs AMIplatform PPI for initialization in PEI before
memory is installed
Input:
IN EFI_FFS_FILE_HEADER *FfsHeader,
IN EFI_PEI_SERVICES    **PeiServices
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


MemoryAbsentEntry in the AmiTcgPlatformPeiBeforeMem.c

Function : MemoryAbsentEntry

File: AmiTcgPlatformPeiBeforeMem.c
Description:
This function performs TPM MA initialization
Input:
IN      EFI_FFS_FILE_HEADER       *FfsHeader
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


AmiTcgPlatformPeiBeforeMem.mak

Description:
Make file for AmiTcgPlatformPeiBeforeMem


AmiTcgPlatformPeiLib.c

Description:
Function file that contains library files for AmiTcgPlatformPei

The following functions are used in the file: AmiTcgPlatformPeiLib.c.

Function | Description
ContinueTCMSelfTest | Executes ContinueSelfTest operation on TPM. Certain TPM operation require this operation to be execute before.
ContinueTPMSelfTest | Executes ContinueSelfTest operation on TPM. Certain TPM operation require this operation to be execute before.
FillDriverLoc | Minor function to fill in MPDriver Offsets for TPM Device PPI
FillDriverLocByFile | Helper function to locate a Driver by guid and fill in Offset data about it. Mainly for MA Driver
LocateTcgPpi | Locates and initializes TCG Ppi
Lock_TPMPhysicalPresence | check whether to Lock TPM physical Presence
MeasureCRTMVersion | Measures EFI CRTM Version Demo Version[546BFB1E1D0C4055A4AD4EF4BF17B83A]
MeasureDxeCoreFwVol | Measures the firmware volume as a EV_POST_CODE event
MeasureTCGPcClientSpecID | Includes a measurement of the TcgSpecID into PCR[0]
MeasureTcmCRTMVersion | Measures EFI CRTM Version Demo Version[546BFB1E1D0C4055A4AD4EF4BF17B83A]
SendStartupandSelftest | This function performs TPM MA initialization
TCGPEI_GETCAP | Executes TPM operation to read capabilities
TcgPeiBuildHobGuid | Internal abstracted function to create a Hob
TcgPeiTpmStartup | Sends Initial TPM Startup Command
TcmMeasureDxeCoreFwVol | Measures the firmware volume as a EV_POST_CODE event
TcmPeiStartup | Sends Initial TPM Startup Command


ContinueTCMSelfTest in the AmiTcgPlatformPeiLib.c

Function : ContinueTCMSelfTest

File: AmiTcgPlatformPeiLib.c
Description:
Executes ContinueSelfTest operation on TPM. Certain TPM
operation require this operation to be execute before.
Input:
IN  EFI_PEI_SERVICES **ps
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


ContinueTPMSelfTest in the AmiTcgPlatformPeiLib.c

Function : ContinueTPMSelfTest

File: AmiTcgPlatformPeiLib.c
Description:
Executes ContinueSelfTest operation on TPM. Certain TPM
operation require this operation to be execute before.
Input:
IN  EFI_PEI_SERVICES **ps
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


FillDriverLoc in the AmiTcgPlatformPeiLib.c

Function : FillDriverLoc

File: AmiTcgPlatformPeiLib.c
Description:
Minor function to fill in MPDriver Offsets for TPM
Device PPI
Input:
IN  OUT  UINT32* Offset,
IN       EFI_PEI_SERVICES  **ps,
IN       EFI_GUID *Driveguid
Output:
VOID
Modified:
Notes:

Referrals:


FillDriverLocByFile in the AmiTcgPlatformPeiLib.c

Function : FillDriverLocByFile

File: AmiTcgPlatformPeiLib.c
Description:
Helper function to locate a Driver by guid and fill in
Offset data about it. Mainly for MA Driver
Input:
IN OUT UINT32* Offset,
IN     EFI_PEI_SERVICES  **ps,
IN     EFI_GUID *Driveguid,
IN OUT VOID **MAStart,
IN OUT UINTN *MASize
Output:
VOID
Modified:
Notes:

Referrals:


LocateTcgPpi in the AmiTcgPlatformPeiLib.c

Function : LocateTcgPpi

File: AmiTcgPlatformPeiLib.c
Description:
Locates and initializes TCG Ppi
Input:
IN      EFI_FFS_FILE_HEADER       *FfsHeader
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


Lock_TPMPhysicalPresence in the AmiTcgPlatformPeiLib.c

Function : Lock_TPMPhysicalPresence

File: AmiTcgPlatformPeiLib.c
Description:
check whether to Lock TPM physical Presence
Input:
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
BOOLEAN
Modified:
Notes:

Referrals:


MeasureCRTMVersion in the AmiTcgPlatformPeiLib.c

Function : MeasureCRTMVersion

File: AmiTcgPlatformPeiLib.c
Description:
Measures EFI CRTM Version
Demo Version[546BFB1E1D0C4055A4AD4EF4BF17B83A]
Input:
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


MeasureDxeCoreFwVol in the AmiTcgPlatformPeiLib.c

Function : MeasureDxeCoreFwVol

File: AmiTcgPlatformPeiLib.c
Description:
Measures the firmware volume as a EV_POST_CODE event
Input:
IN    PEI_TCG_PPI* tcg,
IN    EFI_PEI_SERVICES              **ps,
IN    EFI_FIRMWARE_VOLUME_HEADER    *fwv
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


MeasureTCGPcClientSpecID in the AmiTcgPlatformPeiLib.c

Function : MeasureTCGPcClientSpecID

File: AmiTcgPlatformPeiLib.c
Description:
Includes a measurement of the TcgSpecID into PCR[0]
Input:
IN  PEI_TCG_PPI* tcg,
IN  EFI_PEI_SERVICES      **ps
Output:
Modified:
Notes:

Referrals:


MeasureTcmCRTMVersion in the AmiTcgPlatformPeiLib.c

Function : MeasureTcmCRTMVersion

File: AmiTcgPlatformPeiLib.c
Description:
Measures EFI CRTM Version
Demo Version[546BFB1E1D0C4055A4AD4EF4BF17B83A]
Input:
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


SendStartupandSelftest in the AmiTcgPlatformPeiLib.c

Function : SendStartupandSelftest

File: AmiTcgPlatformPeiLib.c
Description:
This function performs TPM MA initialization
Input:
IN      EFI_FFS_FILE_HEADER       *FfsHeader
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TCGPEI_GETCAP in the AmiTcgPlatformPeiLib.c

Function : TCGPEI_GETCAP

File: AmiTcgPlatformPeiLib.c
Description:
Executes TPM operation to read capabilities
Input:
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
TPM_Capabilities_PermanentFlag
Modified:
Notes:

Referrals:


TcgPeiBuildHobGuid in the AmiTcgPlatformPeiLib.c

Function : TcgPeiBuildHobGuid

File: AmiTcgPlatformPeiLib.c
Description:
Internal abstracted function to create a Hob
Input:
IN  EFI_PEI_SERVICES  **PeiServices,
IN  EFI_GUID          *Guid,
IN  UINTN             DataLength,
OUT VOID              **Hob
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcgPeiTpmStartup in the AmiTcgPlatformPeiLib.c

Function : TcgPeiTpmStartup

File: AmiTcgPlatformPeiLib.c
Description:
Sends Initial TPM Startup Command
Input:
IN      EFI_PEI_SERVICES          **PeiServices,
IN      EFI_BOOT_MODE                BootMode
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TcmMeasureDxeCoreFwVol in the AmiTcgPlatformPeiLib.c

Function : TcmMeasureDxeCoreFwVol

File: AmiTcgPlatformPeiLib.c
Description:
Measures the firmware volume as a EV_POST_CODE event
Input:
IN    PEI_TCM_PPI* tcg,
IN    EFI_PEI_SERVICES              **ps,
IN    EFI_FIRMWARE_VOLUME_HEADER    *fwv
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcmPeiStartup in the AmiTcgPlatformPeiLib.c

Function : TcmPeiStartup

File: AmiTcgPlatformPeiLib.c
Description:
Sends Initial TPM Startup Command
Input:
IN      EFI_PEI_SERVICES          **PeiServices,
IN      EFI_BOOT_MODE                BootMode
Output:
EFI STATUS
Modified:
Notes:

Referrals:


AmiTcmlib.c

Description:
AmiTcmlibrary functions

The following functions are used in the file: AmiTcmlib.c.

Function | Description
AutoSupportType | verifies support for a TCM module on a platform


AutoSupportType in the AmiTcmlib.c

Function : AutoSupportType

File: AmiTcmlib.c
Description:
verifies support for a TCM module on a platform
Input:
NONE
Output:
BOOLEAN
Modified:
Notes:

Referrals:


AmiTcmlib.dxs

Description:
AmiTcmlib Dependency file


AmiTcmlib.h

Description:
Header file for AmiTcmlib.h


AmiTcmlib.mak

Description:
Make file for AmiTcmlib


EMpCallBin.asm

Description:
Contains functions for legacy TCG calls in 32 bit Binaries

The following functions are used in the file: EMpCallBin.asm.

Function | Description
Prepare2Thunkproc | Function to setup location of Mp Driver as a local variable
TcgDxeCallMPDriver | Makes a function call into MP Driver
TcgThunk32 | Go to compatibility mode for MP driver
TcgThunkSwitchback | Switch back to 64bit mode


Prepare2Thunkproc in the EMpCallBin.asm

Function : Prepare2Thunkproc

File: EMpCallBin.asm
Description:
Function to setup location of Mp Driver as a local variable
Input:
ecx - Location of MP Driver
dx  - Segment for MP Driver
Output:
Modified:
Notes:

Referrals:


TcgDxeCallMPDriver in the EMpCallBin.asm

Function : TcgDxeCallMPDriver

File: EMpCallBin.asm
Description:
Makes a function call into MP Driver
Input:
rcx - Call type: 4-Buffer Transmission call
rsi - Buffer to be tansmitted
Output:
rax - TCG return code
Modified:
Notes:

Referrals:


TcgThunk32 in the EMpCallBin.asm

Function : TcgThunk32

File: EMpCallBin.asm
Description:
Go to compatibility mode for MP driver
Input:
Output:
Modified:
Notes:

Referrals:


TcgThunkSwitchback in the EMpCallBin.asm

Function : TcgThunkSwitchback

File: EMpCallBin.asm
Description:
Switch back to 64bit mode
Input:
Output:
Modified:
Notes:

Referrals:


EMpCallBin32.asm

Description:
The following functions are used in the file: EMpCallBin32.asm.

Function | Description
Prepare2Thunkproc | Function to setup location of Mp Driver as a local variable
TcgDxeCallMPDriver | Makes a function call into MP Driver
TcgThunk32 | Go to compatibility mode for MP driver
TcgThunkSwitchback | Switch back to 64bit mode


Prepare2Thunkproc in the EMpCallBin32.asm

Function : Prepare2Thunkproc

File: EMpCallBin32.asm
Description:
Function to setup location of Mp Driver as a local variable
Input:
ecx - Location of MP Driver
dx  - Segment for MP Driver
Output:
Modified:
Notes:

Referrals:


TcgDxeCallMPDriver in the EMpCallBin32.asm

Function : TcgDxeCallMPDriver

File: EMpCallBin32.asm
Description:
Makes a function call into MP Driver
Input:
rcx - Call type: 4-Buffer Transmission call
rsi - Buffer to be tansmitted
Output:
rax - TCG return code
Modified:
Notes:

Referrals:


TcgThunk32 in the EMpCallBin32.asm

Function : TcgThunk32

File: EMpCallBin32.asm
Description:
Go to compatibility mode for MP driver
Input:
Output:
Modified:
Notes:

Referrals:


TcgThunkSwitchback in the EMpCallBin32.asm

Function : TcgThunkSwitchback

File: EMpCallBin32.asm
Description:
Switch back to 64bit mode
Input:
Output:
Modified:
Notes:

Referrals:


EMpTcmDxe.c

Description:
Contains function that help with making legacy TCG calls

The following functions are used in the file: EMpTcmDxe.c.

Function | Description
EMpTcmDxeClose | Close TPM connection for locality 0
EMpTcmDxeGetStatusInfo | GetStatus Info from MP driver
EMpTcmDxeInit | Call to OEM driver to initialize TPM.
EMpTcmDxeTransmit | Dxe Transmit Tcg Data
TcmDxeEntry | TpmDxeEntry, Init TpmDxeDriver and install protocol


EMpTcmDxeClose in the EMpTcmDxe.c

Function : EMpTcmDxeClose

File: EMpTcmDxe.c
Description:
Close TPM connection for locality 0
Input:
IN  PEI_TPM_PPI               *This,
IN  EFI_PEI_SERVICES          **PeiServices
Output:
EFI STATUS
Modified:
Notes:

Referrals:


EMpTcmDxeGetStatusInfo in the EMpTcmDxe.c

Function : EMpTcmDxeGetStatusInfo

File: EMpTcmDxe.c
Description:
GetStatus Info from MP driver
Input:
IN  PEI_TPM_PPI               *This,
IN  EFI_PEI_SERVICES          **PeiServices
Output:
EFI STATUS
Modified:
Notes:

Referrals:


EMpTcmDxeInit in the EMpTcmDxe.c

Function : EMpTcmDxeInit

File: EMpTcmDxe.c
Description:
Call to OEM driver to initialize TPM.
Input:
IN  EFI_TPM_DEVICE_PROTOCOL   *This
Output:
Returns:
EFI_STATUS
Modified:
Notes:

Referrals:


EMpTcmDxeTransmit in the EMpTcmDxe.c

Function : EMpTcmDxeTransmit

File: EMpTcmDxe.c
Description:
Dxe Transmit Tcg Data
Input:
IN      EFI_TPM_DEVICE_PROTOCOL   *This,
IN      UINTN                     NoInBuffers,
IN      TPM_TRANSMIT_BUFFER       *InBuffers,
IN      UINTN                     NoOutBuffers,
IN OUT  TPM_TRANSMIT_BUFFER       *OutBuffers
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TcmDxeEntry in the EMpTcmDxe.c

Function : TcmDxeEntry

File: EMpTcmDxe.c
Description:
TpmDxeEntry, Init TpmDxeDriver and install protocol
Input:
EFI_HANDLE                ImageHandle
EFI_SYSTEM_TABLE          *SystemTable
Output:
EFI STATUS
Modified:
Notes:

Referrals:


EMpTcmPei.c

Description:
Handles legacy calls into 32bit Binaries

The following functions are used in the file: EMpTcmPei.c.

Function | Description
EMpTcmPeiClose | Call to OEM driver to Close TCM
EMpTcmPeiGetStatusInfo | Function call to get status infomation
EMpTcmPeiInit | Call to OEM driver to initialize TCM
EMpTcmPeiSHA1Setup | Helper function to help with Command transmission to TCM
EMpTcmPeiTransmit | TCM Transmit function
InitTcmEntry | Entry point for TCM ppi initialization after memory is installed
TcmPeiCallMPDriver | Interface to performing MP driver function calls in PEI Uses _ASM directives. Return Value in EAX return as status
TcmPeiEntry | Entry for TcmPei Device when TCM_Support is enabled


EMpTcmPeiClose in the EMpTcmPei.c

Function : EMpTcmPeiClose

File: EMpTcmPei.c
Description:
Call to OEM driver to Close TCM
Input:
IN  PEI_TPM_PPI       *This,
IN  EFI_PEI_SERVICES  **PeiServices
Output:
EFI STATUS
Modified:
Notes:

Referrals:


EMpTcmPeiGetStatusInfo in the EMpTcmPei.c

Function : EMpTcmPeiGetStatusInfo

File: EMpTcmPei.c
Description:
Function call to get status infomation
Input:
IN  PEI_TPM_PPI               *This,
IN  EFI_PEI_SERVICES          **PeiServices
Output:
EFI_UNSUPPORTED
Modified:
Notes:

Referrals:


EMpTcmPeiInit in the EMpTcmPei.c

Function : EMpTcmPeiInit

File: EMpTcmPei.c
Description:
Call to OEM driver to initialize TCM
Input:
IN      PEI_TPM_PPI       *This,
IN      EFI_PEI_SERVICES  **PeiServices
Output:
EFI STATUS
Modified:
Notes:

Referrals:


EMpTcmPeiSHA1Setup in the EMpTcmPei.c

Function : EMpTcmPeiSHA1Setup

File: EMpTcmPei.c
Description:
Helper function to help with Command transmission to TCM
Input:
IN  PEI_TPM_PPI               *This,
IN  EFI_PEI_SERVICES          **PeiServices
IN  UINTN                     NoInputBuffers
IN  TPM_TRANSMIT_BUFFER       *InputBuffers
IN  OUT void                  **Buffer
IN  UINT8                      *SHA_ARRAY
Output:
BOOLEAN
Modified:
Notes:

Referrals:


EMpTcmPeiTransmit in the EMpTcmPei.c

Function : EMpTcmPeiTransmit

File: EMpTcmPei.c
Description:
TCM Transmit function
Input:
IN      PEI_TPM_PPI               *This,
IN      EFI_PEI_SERVICES          **PeiServices,
IN      UINTN                     NoInputBuffers,
IN      TPM_TRANSMIT_BUFFER       *InputBuffers,
IN      UINTN                     NoOutputBuffers,
IN OUT  TPM_TRANSMIT_BUFFER       *OutputBuffers
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


InitTcmEntry in the EMpTcmPei.c

Function : InitTcmEntry

File: EMpTcmPei.c
Description:
Entry point for TCM ppi initialization after memory is installed
Input:
IN      EFI_FFS_FILE_HEADER       *FfsHeader
IN      EFI_PEI_SERVICES          **PeiServices
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TcmPeiCallMPDriver in the EMpTcmPei.c

Function : TcmPeiCallMPDriver

File: EMpTcmPei.c
Description:
Interface to performing MP driver function calls in PEI
Uses _ASM directives. Return Value in EAX return as status
Input:
IN   EFI_PEI_SERVICES **PeiServices,
IN   UINT8 CFuncID,
IN   TPMTransmitEntryStruct * CData,
OUT  UINT32* CRetVal
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcmPeiEntry in the EMpTcmPei.c

Function : TcmPeiEntry

File: EMpTcmPei.c
Description:
Entry for TcmPei Device when TCM_Support is enabled
Input:
IN      EFI_FFS_FILE_HEADER       *FfsHeader
IN      EFI_PEI_SERVICES          **PeiServices
Output:
EFI STATUS
Modified:
Notes:

Referrals:


HandleLoadDefaultsSetup.c

Description:
Contains functions that handle TPM authentication

The following functions are used in the file: HandleLoadDefaultsSetup.c.

Function | Description
TcgUpdateDefaultsHook | Updates TCG status on F3


TcgUpdateDefaultsHook in the HandleLoadDefaultsSetup.c

Function : TcgUpdateDefaultsHook

File: HandleLoadDefaultsSetup.c
Description:
Updates TCG status on F3
Input:
VOID
Output:
BOOLEAN
Modified:
Notes:

Referrals:


INTTcgAcpi.h

Description:
Acpi definitions for TCG module


sha.h

Description:
Header file for sha1.c


tcg_ppi1_2.asl

The following functions are used in the file: tcg_ppi1_2.asl.

Function | Description
_DSM | Implement Phisical Presence Interface


_DSM in the tcg_ppi1_2.asl

Function : _DSM

File: tcg_ppi1_2.asl
Description:
Implement Phisical Presence Interface
Input:
\_SB.PCI0.LPCB.TP
Output:
PPI result
Modified:
Notes:

Referrals:


tcg_ppi1_2_Ex.asl

The following functions are used in the file: tcg_ppi1_2_Ex.asl.

Function | Description
_DSM | Implement Phisical Presence Interface using WordAcc


_DSM in the tcg_ppi1_2_Ex.asl

Function : _DSM

File: tcg_ppi1_2_Ex.asl
Description:
Implement Phisical Presence Interface using WordAcc
Input:
\_SB.PCI0.LPCB.TP
Output:
PPI result
Modified:
Notes:

Referrals:


TcgBins.mak

Description:
Make file for the tcgdxe component


TcgCommon.c

Description:
common TCG functions can be found here

The following functions are used in the file: TcgCommon.c.

Function | Description
CompareGuid | Compares two input GUIDs
GetHob | Find instance of a HOB type in a HOB list
GetNextGuidHob | Find GUID HOB
LocateATcgHob |


CompareGuid in the TcgCommon.c

Function : CompareGuid

File: TcgCommon.c
Description:
Compares two input GUIDs
Input:
Comparision status
Output:
None
Modified:
Notes:

Referrals:


GetHob in the TcgCommon.c

Function : GetHob

File: TcgCommon.c
Description:
Find instance of a HOB type in a HOB list
Input:
Type          The HOB type to return.
HobStart      The first HOB in the HOB list.
Output:
Pointer to the Hob matching the type or NULL
Modified:
Notes:

Referrals:


GetNextGuidHob in the TcgCommon.c

Function : GetNextGuidHob

File: TcgCommon.c
Description:
Find GUID HOB
Input:
HobStart    A pointer to the start hob.
Guid        A pointer to a guid.
Output:
Buffer          A pointer to the buffer.
BufferSize      Buffer size.
Modified:
Notes:

Referrals:


LocateATcgHob in the TcgCommon.c

Function : LocateATcgHob

File: TcgCommon.c
Description:
Input:
Output:
None
Modified:
Notes:

Referrals:


TcgCommon.h

Description:
Header file for TcgCommon.c


TcgDxe.c

Description:
Abstracted functions for Tcg protocol are defined here

The following functions are used in the file: TcgDxe.c.

Function | Description
EfiOSReadyToBoot | Sets ready to boot callback on ready to boot
FindAndMeasureDxeFWVol |
OnAcpiInstalled | Adds Tcg Table to Acpi Tables
OverwriteSystemMemory | Overwrites system memory
ReadMORValue | Reads TCG MOR variable
TcgDxeHashLogExtendEventTcm | TcgDxe common function to Hash, Log and Extend data using TPM
TcgDxeHashLogExtendEventTpm | TcgDxe common function to Hash, Log and Extend data using TPM
TcgDxeLogEvent | Logs TCG events in DXE
TcgDxePassThroughToTcm | Helper function for TCM transmit function
TcgTcmDxeStatusCheck | Tcm Dxe status check function
TcmBootDone | SetEfiOSTransitions
TcmCommonPassThrough | Helper function for TCM transmit command
TcmDxeHashAll | TcmDxeHashAll function [SHA1]
TcmDxeLogEvent | Logs TCM events in DXE


EfiOSReadyToBoot in the TcgDxe.c

Function : EfiOSReadyToBoot

File: TcgDxe.c
Description:
Sets ready to boot callback on ready to boot
Input:
NONE
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


FindAndMeasureDxeFWVol in the TcgDxe.c

Function : FindAndMeasureDxeFWVol

File: TcgDxe.c
Description:
Input:
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


OnAcpiInstalled in the TcgDxe.c

Function : OnAcpiInstalled

File: TcgDxe.c
Description:
Adds Tcg Table to Acpi Tables
Input:
IN      EFI_EVENT ev
IN      Callback Context *ctx
Output:
Device path size
Modified:
Notes:

Referrals:


OverwriteSystemMemory in the TcgDxe.c

Function : OverwriteSystemMemory

File: TcgDxe.c
Description:
Overwrites system memory
Input:
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


ReadMORValue in the TcgDxe.c

Function : ReadMORValue

File: TcgDxe.c
Description:
Reads TCG MOR variable
Input:
IN  EFI_PEI_SERVICES  **PeiServices,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcgDxeHashLogExtendEventTcm in the TcgDxe.c

Function : TcgDxeHashLogExtendEventTcm

File: TcgDxe.c
Description:
TcgDxe common function to Hash, Log and Extend data using TPM
Input:
*This
*HashData
HashDataLen
AlgorithmId,
*TCGLogData,
*EventNum,
*EventLogLastEntry
Output:
EFI STATUS
Modified:
Notes:

Referrals:

TcgCommonSha1Start, TcgCommonSha1Start, TcgCommonSha1CompleteExtend


TcgDxeHashLogExtendEventTpm in the TcgDxe.c

Function : TcgDxeHashLogExtendEventTpm

File: TcgDxe.c
Description:
TcgDxe common function to Hash, Log and Extend data using TPM
Input:
*This
*HashData
HashDataLen
AlgorithmId,
*TCGLogData,
*EventNum,
*EventLogLastEntry
Output:
EFI STATUS
Modified:
Notes:

Referrals:

TcgCommonSha1Start, TcgCommonSha1Start, TcgCommonSha1CompleteExtend


TcgDxeLogEvent in the TcgDxe.c

Function : TcgDxeLogEvent

File: TcgDxe.c
Description:
Logs TCG events in DXE
Input:
IN EFI_TCG_PROTOCOL *This,
       IN TCG_PCR_EVENT    *TCGLogData,
       IN OUT UINT32       *EventNumber,
       IN UINT32           Flags
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcgDxePassThroughToTcm in the TcgDxe.c

Function : TcgDxePassThroughToTcm

File: TcgDxe.c
Description:
Helper function for TCM transmit function
Input:
IN EFI_TCM_PROTOCOL *This,
       IN UINT32           TpmInputParamterBlockSize,
       IN UINT8            *TpmInputParamterBlock,
       IN UINT32           TpmOutputParameterBlockSize,
       IN UINT8            *TpmOutputParameterBlock
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcgTcmDxeStatusCheck in the TcgDxe.c

Function : TcgTcmDxeStatusCheck

File: TcgDxe.c
Description:
Tcm Dxe status check function
Input:
IN EFI_TCM_PROTOCOL                 *This,
OUT TCM_EFI_BOOT_SERVICE_CAPABILITY *ProtocolCapability,
OUT UINT32                          *TCGFeatureFlags,
OUT EFI_PHYSICAL_ADDRESS            *EventLogLocation,
OUT EFI_PHYSICAL_ADDRESS            *LastEvent
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcmBootDone in the TcgDxe.c

Function : TcmBootDone

File: TcgDxe.c
Description:
SetEfiOSTransitions
Input:
IN  EFI_EVENT       efiev
IN  VOID            *ctx
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcmCommonPassThrough in the TcgDxe.c

Function : TcmCommonPassThrough

File: TcgDxe.c
Description:
Helper function for TCM transmit command
Input:
VOID *Context
UINT32 NoInputBuffers
TPM_TRANSMIT_BUFFER InputBuffers
UINT32 NoOutputBuffers
TPM_TRANSMIT_BUFFER OutputBuffers
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcmDxeHashAll in the TcgDxe.c

Function : TcmDxeHashAll

File: TcgDxe.c
Description:
TcmDxeHashAll function [SHA1]
Input:
IN EFI_TCG_PROTOCOL *This,
   IN UINT8            *HashData,
   IN UINT64           HashDataLen,
   IN TCG_ALGORITHM_ID AlgorithmId,
   IN OUT UINT64       *HashedDataLen,
   IN OUT UINT8        **HashedDataResult
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcmDxeLogEvent in the TcgDxe.c

Function : TcmDxeLogEvent

File: TcgDxe.c
Description:
Logs TCM events in DXE
Input:
IN EFI_TCG_PROTOCOL *This,
       IN TCG_PCR_EVENT    *TCGLogData,
       IN OUT UINT32       *EventNumber,
       IN UINT32           Flags
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcgDxe.dxs

Description:
TcgDxe dependency file


TcgDxe.mak

Description:
Make file for the tcgdxe component


TcgDxeplatform.c

Description:
Function file for TcgDxeplatform

The following functions are used in the file: TcgDxeplatform.c.

Function | Description
TcgDxeplatformEntry |


TcgDxeplatformEntry in the TcgDxeplatform.c

Function : TcgDxeplatformEntry

File: TcgDxeplatform.c
Description:
Input:
IN EFI_HANDLE       ImageHandle,
IN EFI_SYSTEM_TABLE *SystemTable
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcgDxeplatform.dxs

Description:
Dependency file


TcgDxeplatform.h

Description:
Header file for TcgDxeplatform


TcgDxeplatform.mak

Description:
Make file for the TcgDxeplatform component


TcgEFI12.h

Description:
Contains Industry Standard structures for TCG


TcgEfiTpm.h

Description:
Contains Industry Standard #defines and structures for TCG


TcgLegacy.c

Description:
Contains functions that handle setting up the handoff between EFI and Legacy

The following functions are used in the file: TcgLegacy.c.

Function | Description
AllocateRTMemory | Allocates memory used by TCG Legacy code during run-time
FindCompatibility16Table | This function identifies the validity of CSM16 binary by searching "$EFI" and verifying table checksum and returs the location of $EFI table
GetRawImage | Loads binary from RAW section of main firwmare volume
GetTCGLegacyInterface | Loads legacy BIOS binary extensions (TcgLegX16, TPM32 and MPTPM ) and initializes the TCG Legacy support.
linkTPMDriver | Establishes link used to synchronize change to the LOG when done through the INT1A interface while DXE is still in control.
UnlinkTPM32fromEFI | Breaks the link that exist between TPM32 code and DXE TCG driver. The established link was used to synchronize change to the LOG when done through the INT1A interface while DXE is still in control. Need to break this link one DXE driver is stoped or EFI boots OS ( including calling INT19)


AllocateRTMemory in the TcgLegacy.c

Function : AllocateRTMemory

File: TcgLegacy.c
Description:
Allocates memory used by TCG Legacy code during run-time
Input:
IN  UINTN size
Output:
VOID*
Modified:
Notes:

Referrals:


FindCompatibility16Table in the TcgLegacy.c

Function : FindCompatibility16Table

File: TcgLegacy.c
Description:
This function identifies the validity of CSM16 binary by
 searching "$EFI" and verifying table checksum and returs the
 location of $EFI table
Input:
Output:
EFI_COMPATIBILITY16_TABLE*
Modified:
Notes:

Referrals:


GetRawImage in the TcgLegacy.c

Function : GetRawImage

File: TcgLegacy.c
Description:
Loads binary from RAW section of main firwmare volume
Input:
IN     EFI_GUID   *NameGuid,
IN OUT VOID   **Buffer,
IN OUT UINTN  *Size
Output:
EFI STATUS
Modified:
Notes:

Referrals:


GetTCGLegacyInterface in the TcgLegacy.c

Function : GetTCGLegacyInterface

File: TcgLegacy.c
Description:
Loads legacy BIOS binary extensions (TcgLegX16,
 TPM32 and MPTPM ) and initializes the TCG Legacy support.
Input:
IN EFI_HANDLE        ImageHandle,
IN EFI_SYSTEM_TABLE *SystemTable
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


linkTPMDriver in the TcgLegacy.c

Function : linkTPMDriver

File: TcgLegacy.c
Description:
Establishes link used to synchronize change to the
LOG when done through the INT1A interface while DXE is still in
control.
Input:
IN     EFI_PEI_SERVICES  **PeiServices,
Output:
EFI STATUS
Modified:
Notes:

Referrals:


UnlinkTPM32fromEFI in the TcgLegacy.c

Function : UnlinkTPM32fromEFI

File: TcgLegacy.c
Description:
Breaks the link that exist between TPM32 code and DXE TCG
driver. The established link was used to synchronize change to the
LOG when done through the INT1A interface while DXE is still in
control. Need to break this link one DXE driver is stoped or EFI
boots OS ( including calling INT19)
Input:
IN     EFI_EVENT  Event,
IN       VOID     *Context
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TcgLegacy.dxs

Description:
dependecy file


TcgLegacy.h

Description:
Header file for TCG Legacy subcomponent


TcgLegacy.mak

Description:


TCGMisc.h

Description:
Miscellaneous Tcg Header file


TcgPc.h

Description:
Contains Industry Standard #defines and Structures for TCG


TcgPei.dxs

Description:
Dependency file for TcgPei subcomponent


TcgPei.mak

Description:
Make file for the TcgPei component


TcgPeiAfterMem.c

Description:
Functions for early initialization of TPM are executed here

The following functions are used in the file: TcgPeiAfterMem.c.

Function | Description
TcgPeiEntry | Entry point to Memory Absent and Memory Present Initialization for TPM
TcgPeiHashLogExtendEventSW | TCGPEI Software function to Hash, Log and Extend data using software SHA-1
TcgPeiLogEvent | TCGPEI common function to Hash, Log and Extend data using software SHA-1
TcgPeiPassThroughToTpm | TCGPEI common function to abstract passing commands to the TPM FIFO


TcgPeiEntry in the TcgPeiAfterMem.c

Function : TcgPeiEntry

File: TcgPeiAfterMem.c
Description:
Entry point to Memory Absent and Memory Present Initialization
for TPM
Input:
IN      EFI_FFS_FILE_HEADER       *FfsHeader
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcgPeiHashLogExtendEventSW in the TcgPeiAfterMem.c

Function : TcgPeiHashLogExtendEventSW

File: TcgPeiAfterMem.c
Description:
TCGPEI Software function to Hash, Log and Extend data
using software SHA-1
Input:
IN        *This
IN        **PeiServices
IN        *HashData
IN        HashDataLen
IN OUT    *NewEvent,
OUT       *EventNum
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TcgPeiLogEvent in the TcgPeiAfterMem.c

Function : TcgPeiLogEvent

File: TcgPeiAfterMem.c
Description:
TCGPEI common function to Hash, Log and Extend data
using software SHA-1
Input:
IN   *This
IN   **PeiServices
IN   *Event,
IN   *EventNum
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TcgPeiPassThroughToTpm in the TcgPeiAfterMem.c

Function : TcgPeiPassThroughToTpm

File: TcgPeiAfterMem.c
Description:
TCGPEI common function to abstract passing commands to the TPM
 FIFO
Input:
IN   *This
IN   **PeiServices
IN   TpmInputParameterBlockSize
IN   *TpmInputParameterBlock
IN   TpmOutputParameterBlockSize
IN   *TpmOutputParameterBlock
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TcgPeiAfterMem.mak

Description:
Make file for the TcgPei component


TcgPeiplatform.c

Description:
Function file for TcgPeiPlatform

The following functions are used in the file: TcgPeiplatform.c.

Function | Description
OnMemoryDiscovered | Call Memory Present initialization on memory Installation
TcgPeiPlatformEntry |


OnMemoryDiscovered in the TcgPeiplatform.c

Function : OnMemoryDiscovered

File: TcgPeiplatform.c
Description:
Call Memory Present initialization on memory Installation
Input:
IN      EFI_PEI_SERVICES          **PeiServices,
IN      EFI_PEI_NOTIFY_DESCRIPTOR *NotifyDesc,
IN      VOID                      *Ppi
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TcgPeiPlatformEntry in the TcgPeiplatform.c

Function : TcgPeiPlatformEntry

File: TcgPeiplatform.c
Description:
Input:
IN      EFI_FFS_FILE_HEADER       *FfsHeader
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcgPeiplatform.dxs

Description:
Dependency file


TcgPeiplatform.h

Description:
Header file for TcgPeiplatform


TcgPeiplatform.mak

Description:
Make file for the TcgPeiplatform component


TcgPlatformSetupPeiPolicy.c

Description:
Installs Tcg policy from setup variables in Pei

The following functions are used in the file: TcgPlatformSetupPeiPolicy.c.

Function | Description
TcgPlatformSetupPolicyEntryPoint | Entry point for TcgPlatformSetupPolicyEntryPoint


TcgPlatformSetupPolicyEntryPoint in the TcgPlatformSetupPeiPolicy.c

Function : TcgPlatformSetupPolicyEntryPoint

File: TcgPlatformSetupPeiPolicy.c
Description:
Entry point for

 TcgPlatformSetupPolicyEntryPoint
Input:
ImageHandle       Image handle of this driver.
SystemTable       Global system service table.
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcgPlatformSetupPeiPolicy.dxs

Description:
Dependency file for TcgPlatformpeipolicy


TcgPlatformSetupPeiPolicy.h

Description:
Header file for TcgPlatformpeipolicy


TcgPlatformSetupPeiPolicy.mak

Description:
Make file for TcgPlatformpeipolicy


TcgPlatformSetupPolicy.c

Description:
Policy file to allow reading and update of TCG policy

The following functions are used in the file: TcgPlatformSetupPolicy.c.

Function | Description
TcgPlatformSetupPolicyEntryPoint | Entry point for TcgPlatformSetupPolicyEntryPoint


TcgPlatformSetupPolicyEntryPoint in the TcgPlatformSetupPolicy.c

Function : TcgPlatformSetupPolicyEntryPoint

File: TcgPlatformSetupPolicy.c
Description:
Entry point for

 TcgPlatformSetupPolicyEntryPoint
Input:
ImageHandle       Image handle of this driver.
SystemTable       Global system service table.
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcgPlatformSetupPolicy.dxs

Description:
dependency file for TcgPlatformpolicy


TcgPlatformSetupPolicy.h

Description:
Header file for TcgPlatformpolicy


TcgPlatformSetupPolicy.mak

Description:
Make file for TcgPlatformpolicy


TcgPrivate.c

Description:
Contains guid definition for Tcg Private protocol


TcgPrivate.h

Description:
Header file for Tcg private protocol definitions


TcgService.c

Description:
Defines TcgPpiguid


TcgService.h

Description:
Header file for TcgService.c


TcgSetup.c

Description:


TcgSetup.mak

Description:
Make file for the OEM-specific sub-component of TCG


TcgSetup.sd

Description:
TCG Form Template


TcgSetupBoard.h

Description:


TCGSmm.c

Description:
Function definition file for TCGSMM subcomponent

The following functions are used in the file: TCGSmm.c.

Function | Description
HelpRegisterPPISMI | Common function to handle TCG SMI's
NVOSread_PPI_request | Returns TCG PPI variable values to the Operating system
NVOSWrite_MOR_request | Writes TCG PPI MOR variable to NVRAM on SMI request the Operating system
NVWrite_PPI_request | Writes TCG PPI variable values to NVRAM on SMI request the Operating system
Read_User_Confirmation_Status | Reads the user confirmation satus for PPI requests
TcgCommonSetFlag | Common function to set flag for PPI write transactions
TcgSmiCommonHandler | Common function to handle TCG SMI's
TCGSmmInit | Entry point for subcomponent


HelpRegisterPPISMI in the TCGSmm.c

Function : HelpRegisterPPISMI

File: TCGSmm.c
Description:
Common function to handle TCG SMI's
Input:
IN    EFI_HANDLE ImageHandle,
IN    EFI_SYSTEM_TABLE *SystemTable
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


NVOSread_PPI_request in the TCGSmm.c

Function : NVOSread_PPI_request

File: TCGSmm.c
Description:
Returns TCG PPI variable values to the Operating system
Input:
IN    EFI_HANDLE        DispatchHandle,
IN    EFI_SMM_SW_DISPATCH_CONTEXT    *DispatchContext
Output:
VOID
Modified:
Notes:

Referrals:


NVOSWrite_MOR_request in the TCGSmm.c

Function : NVOSWrite_MOR_request

File: TCGSmm.c
Description:
Writes TCG PPI MOR variable to NVRAM on SMI request the Operating system
Input:
IN    EFI_HANDLE        DispatchHandle,
IN    EFI_SMM_SW_DISPATCH_CONTEXT    *DispatchContext
Output:
VOID
Modified:
Notes:

Referrals:


NVWrite_PPI_request in the TCGSmm.c

Function : NVWrite_PPI_request

File: TCGSmm.c
Description:
Writes TCG PPI variable values to NVRAM on SMI request the Operating system
Input:
IN    EFI_HANDLE        DispatchHandle,
IN    EFI_SMM_SW_DISPATCH_CONTEXT    *DispatchContext
Output:
VOID
Modified:
Notes:

Referrals:


Read_User_Confirmation_Status in the TCGSmm.c

Function : Read_User_Confirmation_Status

File: TCGSmm.c
Description:
Reads the user confirmation satus for PPI requests
Input:
IN    EFI_HANDLE        DispatchHandle,
IN    EFI_SMM_SW_DISPATCH_CONTEXT    *DispatchContext
Output:
VOID
Modified:
Notes:

Referrals:


TcgCommonSetFlag in the TCGSmm.c

Function : TcgCommonSetFlag

File: TCGSmm.c
Description:
Common function to set flag for PPI write transactions
Input:
UINT8 Data
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcgSmiCommonHandler in the TCGSmm.c

Function : TcgSmiCommonHandler

File: TCGSmm.c
Description:
Common function to handle TCG SMI's
Input:
IN    EFI_HANDLE        DispatchHandle,
IN    EFI_SMM_SW_DISPATCH_CONTEXT    *DispatchContext
Output:
VOID
Modified:
Notes:

Referrals:


TCGSmmInit in the TCGSmm.c

Function : TCGSmmInit

File: TCGSmm.c
Description:
Entry point for subcomponent
Input:
IN    EFI_HANDLE ImageHandle,
IN    EFI_SYSTEM_TABLE *SystemTable
Output:
EFI_STATUS
Modified:
Notes:
Referrals:


TCGSmm.DXS

Description:
Dependency for TcgSmm


TCGSmm.h

Description:
Header file for TCGSMM subcomponent


TCGSmm.mak

Description:
Make file for TCG SMM module


TcgTcmPei.c

Description:
Functions for early initialization of TPM are executed here

The following functions are used in the file: TcgTcmPei.c.

Function | Description
IntTcmTcgPeiGetCapabilities | Executes TCM operation to read capabilities
TcgPeiHashLogExtendEventTcm | Tcm common function to Hash, Log and Extend data
TcgPeiPassThroughToTpm | TCGPEI common function to abstract passing commands to the TPM FIFO
TcgTcmPeiEntry | Entry point for TCM device initialization
TcmPeiGetEventLog | Helper function for logging TCM events
TcmPeiLogEvent | TCM common function to log PEI events


IntTcmTcgPeiGetCapabilities in the TcgTcmPei.c

Function : IntTcmTcgPeiGetCapabilities

File: TcgTcmPei.c
Description:
Executes TCM operation to read capabilities
Input:
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
TCM_Capabilities_PermanentFlag
Modified:
Notes:

Referrals:


TcgPeiHashLogExtendEventTcm in the TcgTcmPei.c

Function : TcgPeiHashLogExtendEventTcm

File: TcgTcmPei.c
Description:
Tcm common function to Hash, Log and Extend data
Input:
IN  *This
IN  **PeiServices
IN  *HashData
IN  HashDataLen
IN  *NewEvent,
IN  *EventNum
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TcgPeiPassThroughToTpm in the TcgTcmPei.c

Function : TcgPeiPassThroughToTpm

File: TcgTcmPei.c
Description:
TCGPEI common function to abstract passing commands to the TPM
 FIFO
Input:
IN   *This
IN   **PeiServices
IN   TpmInputParameterBlockSize
IN   *TpmInputParameterBlock
IN   TpmOutputParameterBlockSize
IN   *TpmOutputParameterBlock
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TcgTcmPeiEntry in the TcgTcmPei.c

Function : TcgTcmPeiEntry

File: TcgTcmPei.c
Description:
Entry point for TCM device initialization
Input:
IN      EFI_FFS_FILE_HEADER       *FfsHeader
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcmPeiGetEventLog in the TcgTcmPei.c

Function : TcmPeiGetEventLog

File: TcgTcmPei.c
Description:
Helper function for logging TCM events
Input:
IN EFI_PEI_SERVICES **PeiServices,
OUT TCG_LOG_HOB     **EventLog
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcmPeiLogEvent in the TcgTcmPei.c

Function : TcmPeiLogEvent

File: TcgTcmPei.c
Description:
TCM common function to log PEI events
Input:
IN   *This
IN   **PeiServices
IN   *Event,
IN   *EventNum
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TcgTcmPeiAfterMem.c

The following functions are used in the file: TcgTcmPeiAfterMem.c.

Function | Description
IntTcmTcgPeiGetCapabilities | Executes TCM operation to read capabilities
TcgPeiEntry | Entry point to Memory Absent and Memory Present Initialization for TPM
TcgPeiHashLogExtendEventTcm | Tcm common function to Hash, Log and Extend data
TcgPeiPassThroughToTcm | TCGPEI common function to abstract passing commands to the TPM FIFO
TcmPeiGetEventLog | Helper function for logging TCM events
TcmPeiLogEvent | TCM common function to log PEI events


IntTcmTcgPeiGetCapabilities in the TcgTcmPeiAfterMem.c

Function : IntTcmTcgPeiGetCapabilities

File: TcgTcmPeiAfterMem.c
Description:
Executes TCM operation to read capabilities
Input:
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
TCM_Capabilities_PermanentFlag
Modified:
Notes:

Referrals:


TcgPeiEntry in the TcgTcmPeiAfterMem.c

Function : TcgPeiEntry

File: TcgTcmPeiAfterMem.c
Description:
Entry point to Memory Absent and Memory Present Initialization
for TPM
Input:
IN      EFI_FFS_FILE_HEADER       *FfsHeader
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcgPeiHashLogExtendEventTcm in the TcgTcmPeiAfterMem.c

Function : TcgPeiHashLogExtendEventTcm

File: TcgTcmPeiAfterMem.c
Description:
Tcm common function to Hash, Log and Extend data
Input:
IN  *This
IN  **PeiServices
IN  *HashData
IN  HashDataLen
IN  *NewEvent,
IN  *EventNum
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TcgPeiPassThroughToTcm in the TcgTcmPeiAfterMem.c

Function : TcgPeiPassThroughToTcm

File: TcgTcmPeiAfterMem.c
Description:
TCGPEI common function to abstract passing commands to the TPM
 FIFO
Input:
IN   *This
IN   **PeiServices
IN   TpmInputParameterBlockSize
IN   *TpmInputParameterBlock
IN   TpmOutputParameterBlockSize
IN   *TpmOutputParameterBlock
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TcmPeiGetEventLog in the TcgTcmPeiAfterMem.c

Function : TcmPeiGetEventLog

File: TcgTcmPeiAfterMem.c
Description:
Helper function for logging TCM events
Input:
IN EFI_PEI_SERVICES **PeiServices,
OUT TCG_LOG_HOB     **EventLog
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcmPeiLogEvent in the TcgTcmPeiAfterMem.c

Function : TcmPeiLogEvent

File: TcgTcmPeiAfterMem.c
Description:
TCM common function to log PEI events
Input:
IN   *This
IN   **PeiServices
IN   *Event,
IN   *EventNum
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TcgTcmService.c

Description:
Defines TcgPpiguid


TcgTcmService.h

Description:
Header file for TCMService.c


TcgTisPei.c

Description:
Functions for early initialization of TPM are executed here

The following functions are used in the file: TcgTisPei.c.

Function | Description
TcgPeiEntry | Entry point to Memory Absent and Memory Present Initialization for TPM
TcgPeiHashLogExtendEventSW | TCGPEI Software function to Hash, Log and Extend data using software SHA-1
TcgPeiLogEvent | TCGPEI common function to Hash, Log and Extend data using software SHA-1
TcgPeiPassThroughToTpm | TCGPEI common function to abstract passing commands to the TPM FIFO


TcgPeiEntry in the TcgTisPei.c

Function : TcgPeiEntry

File: TcgTisPei.c
Description:
Entry point to Memory Absent and Memory Present Initialization
for TPM
Input:
IN      EFI_FFS_FILE_HEADER       *FfsHeader
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TcgPeiHashLogExtendEventSW in the TcgTisPei.c

Function : TcgPeiHashLogExtendEventSW

File: TcgTisPei.c
Description:
TCGPEI Software function to Hash, Log and Extend data
using software SHA-1
Input:
IN        *This
IN        **PeiServices
IN        *HashData
IN        HashDataLen
IN OUT    *NewEvent,
OUT       *EventNum
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TcgPeiLogEvent in the TcgTisPei.c

Function : TcgPeiLogEvent

File: TcgTisPei.c
Description:
TCGPEI common function to Hash, Log and Extend data
using software SHA-1
Input:
IN   *This
IN   **PeiServices
IN   *Event,
IN   *EventNum
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TcgPeiPassThroughToTpm in the TcgTisPei.c

Function : TcgPeiPassThroughToTpm

File: TcgTisPei.c
Description:
TCGPEI common function to abstract passing commands to the TPM
 FIFO
Input:
IN   *This
IN   **PeiServices
IN   TpmInputParameterBlockSize
IN   *TpmInputParameterBlock
IN   TpmOutputParameterBlockSize
IN   *TpmOutputParameterBlock
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TcgTpm12.h

Description:
Contains Industry Standard #defines for TCG


TcmPc.h

Description:
Header file for Tcm structures


TisLib.mak

Description:
Make file for the tcglib component


TisPei.c

Description:
Abstracted functions for Tpm ppis' are defined here

The following functions are used in the file: TisPei.c.

Function | Description
EMpTpmPeiClose | Call to OEM driver to Close TPM
EMpTpmPeiInit | Call to OEM driver to initialize TPM
EMpTpmPeiSHA1Setup | Helper function to help with Command transmission to TPM
EMpTpmPeiTransmit | TPM Transmit function
InitLegacyTpmEntry | Entry point for TPM initialization after memory is installed
TpmPeiCallMPDriver | Interface to performing MP driver function calls in PEI Uses _ASM directives. Return Value in EAX return as status


EMpTpmPeiClose in the TisPei.c

Function : EMpTpmPeiClose

File: TisPei.c
Description:
Call to OEM driver to Close TPM
Input:
IN  PEI_TPM_PPI       *This,
IN  EFI_PEI_SERVICES  **PeiServices
Output:
EFI STATUS
Modified:
Notes:

Referrals:


EMpTpmPeiInit in the TisPei.c

Function : EMpTpmPeiInit

File: TisPei.c
Description:
Call to OEM driver to initialize TPM
Input:
IN      PEI_TPM_PPI       *This,
IN      EFI_PEI_SERVICES  **PeiServices
Output:
EFI STATUS
Modified:
Notes:

Referrals:


EMpTpmPeiSHA1Setup in the TisPei.c

Function : EMpTpmPeiSHA1Setup

File: TisPei.c
Description:
Helper function to help with Command transmission to TPM
Input:
IN  PEI_TPM_PPI               *This,
IN  EFI_PEI_SERVICES          **PeiServices
IN  UINTN                     NoInputBuffers
IN  TPM_TRANSMIT_BUFFER       *InputBuffers
IN  OUT void                  **Buffer
IN  UINT8                      *SHA_ARRAY
Output:
BOOLEAN
Modified:
Notes:

Referrals:


EMpTpmPeiTransmit in the TisPei.c

Function : EMpTpmPeiTransmit

File: TisPei.c
Description:
TPM Transmit function
Input:
IN      PEI_TPM_PPI               *This,
IN      EFI_PEI_SERVICES          **PeiServices,
IN      UINTN                     NoInputBuffers,
IN      TPM_TRANSMIT_BUFFER       *InputBuffers,
IN      UINTN                     NoOutputBuffers,
IN OUT  TPM_TRANSMIT_BUFFER       *OutputBuffers
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


InitLegacyTpmEntry in the TisPei.c

Function : InitLegacyTpmEntry

File: TisPei.c
Description:
Entry point for TPM initialization after memory is installed
Input:
IN      EFI_FFS_FILE_HEADER       *FfsHeader
IN      EFI_PEI_SERVICES          **PeiServices
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TpmPeiCallMPDriver in the TisPei.c

Function : TpmPeiCallMPDriver

File: TisPei.c
Description:
Interface to performing MP driver function calls in PEI
Uses _ASM directives. Return Value in EAX return as status
Input:
IN   EFI_PEI_SERVICES **PeiServices,
IN   UINT8 CFuncID,
IN   TPMTransmitEntryStruct * CData,
OUT  UINT32* CRetVal
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


Tpm20.h

Description:
Contains Industry Standard #defines and Structures for TPM20


Tpm20Acpi.DXS

Description:
Dependency for TcgSmm


Tpm20Acpi.mak

Description:
Make file for TCG SMM module


Tpm20CRBLib.mak

Description:
Make file for the Tpm20CrbLib component


Tpm20PlatformDxe.dxs

Description:
Dependency file for AmiTcgPlatformDxe


Tpm20PlatformDxe.h

Description:
Header file for AmiTcgPlatformDxe


Tpm20PlatformDxeLib.h

Description:
Header firl for AmiTcgPlatformDxe library


TpmClearOnRollback.c

The following functions are used in the file: TpmClearOnRollback.c.

Function | Description
RecoveryClearTpmBeforeFlash | Process TPM clear on Rollback policy


RecoveryClearTpmBeforeFlash in the TpmClearOnRollback.c

Function : RecoveryClearTpmBeforeFlash

File: TpmClearOnRollback.c
Description:
Process TPM clear on Rollback policy
Input:
VOID
Output:
VOID


TpmClearOnRollback.dxs

Description:
Dependency for TcgSmm


TpmDevice.c

Description:
Defines Tpm Device Ppis' GUID


TpmDevice.h

Description:
Header file for TpmDevice.c[Ppi]


TpmDxe.c

Description:
Abstracted functions for Tpm protocol are defined here

The following functions are used in the file: TpmDxe.c.

Function | Description
EfiOSReadyToBoot | Sets ready to boot callback on ready to boot
SetEfiOSTransitions | SetEfiOSTransitions
TpmDxeClose | Close TPM connection for locality 0
TpmDxeGetStatusInfo | GetStatus Info from MP driver
TpmDxeInit | Call to OEM driver to initialize TPM.
TpmDxeTransmit | Dxe Transmit Tcg Data


EfiOSReadyToBoot in the TpmDxe.c

Function : EfiOSReadyToBoot

File: TpmDxe.c
Description:
Sets ready to boot callback on ready to boot
Input:
NONE
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


SetEfiOSTransitions in the TpmDxe.c

Function : SetEfiOSTransitions

File: TpmDxe.c
Description:
SetEfiOSTransitions
Input:
IN  EFI_EVENT       efiev
IN  VOID            *ctx
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


TpmDxeClose in the TpmDxe.c

Function : TpmDxeClose

File: TpmDxe.c
Description:
Close TPM connection for locality 0
Input:
IN  PEI_TPM_PPI               *This,
IN  EFI_PEI_SERVICES          **PeiServices
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TpmDxeGetStatusInfo in the TpmDxe.c

Function : TpmDxeGetStatusInfo

File: TpmDxe.c
Description:
GetStatus Info from MP driver
Input:
IN  PEI_TPM_PPI               *This,
IN  EFI_PEI_SERVICES          **PeiServices
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TpmDxeInit in the TpmDxe.c

Function : TpmDxeInit

File: TpmDxe.c
Description:
Call to OEM driver to initialize TPM.
Input:
IN  EFI_TPM_DEVICE_PROTOCOL   *This
Output:
Returns:
EFI_STATUS
Modified:
Notes:

Referrals:


TpmDxeTransmit in the TpmDxe.c

Function : TpmDxeTransmit

File: TpmDxe.c
Description:
Dxe Transmit Tcg Data
Input:
IN      EFI_TPM_DEVICE_PROTOCOL   *This,
IN      UINTN                     NoInBuffers,
IN      TPM_TRANSMIT_BUFFER       *InBuffers,
IN      UINTN                     NoOutBuffers,
IN OUT  TPM_TRANSMIT_BUFFER       *OutBuffers
Output:
EFI STATUS
Modified:
Notes:

Referrals:


TpmLib.c

Description:
Contains low level TCG functions

The following functions are used in the file: TpmLib.c.

Function | Description
FixedDelay | This routine delays for specified number of micro seconds


FixedDelay in the TpmLib.c

Function : FixedDelay

File: TpmLib.c
Description:
This routine delays for specified number of micro seconds
Input:
IN UINT32  dCount      Amount of delay (count in 20microsec)
Output:
NONE
Modified:
Notes:

Referrals:

Div64, CountTime


TpmLib.h

Description:
Header file for TpmLib.c


TPMPwd.c

Description:
Contains functions that handle TPM authentication

The following functions are used in the file: TPMPwd.c.

Function | Description
AutoSupportType | verifies support for a TCM module on a platform
PasswordAuthentication | This function is available as ELINK. In will create a Event for password authenication
TCGProcessConInAvailability | This is a replacement for the ProcessConInAvailability hook in TSE, to provide password verification in the TCG eModule. This function is a hook called when TSE determines that console is available. This function is available as ELINK. In the generic implementation boot password is prompted in this function.


AutoSupportType in the TPMPwd.c

Function : AutoSupportType

File: TPMPwd.c
Description:
verifies support for a TCM module on a platform
Input:
NONE
Output:
BOOLEAN
Modified:
Notes:

Referrals:


PasswordAuthentication in the TPMPwd.c

Function : PasswordAuthentication

File: TPMPwd.c
Description:
This function is available as ELINK. In will create a Event for password
authenication
Input:
VOID
Output:

Notes:


TCGProcessConInAvailability in the TPMPwd.c

Function : TCGProcessConInAvailability

File: TPMPwd.c
Description:
This is a replacement for the ProcessConInAvailability
hook in TSE, to provide password verification in the
TCG eModule.
This function is a hook called when TSE determines
that console is available. This function is available
as ELINK. In the generic implementation boot password
is prompted in this function.
Input:
VOID
Output:
BOOLEAN
Modified:
Notes:

Referrals:


xTcgDxe.c

Description:
Most Tcg DXE initialization and measurements are done here

The following functions are used in the file: xTcgDxe.c.

Function | Description
AppendDevicePath | Appends Two given Device Path
CommonTcgDxEntryPoint | Common entry point for Tcgdxe
EfiLibAllocatePool | Allocate BootServicesData pool.
TcgEfiLibAllocateZeroPool | Allocate BootServicesData pool and zero the pool.


AppendDevicePath in the xTcgDxe.c

Function : AppendDevicePath

File: xTcgDxe.c
Description:
Appends Two given Device Path
Input:
IN     EFI_DEVICE_PATH_PROTOCOL        *Path1
IN     EFI_DEVICE_PATH_PROTOCOL        *Path2
Output:
None
Modified:
Notes:

Referrals:


CommonTcgDxEntryPoint in the xTcgDxe.c

Function : CommonTcgDxEntryPoint

File: xTcgDxe.c
Description:
Common entry point for Tcgdxe
Input:
IN EFI_HANDLE        ImageHandle
IN EFI_SYSTEM_TABLE *SystemTable
Output:
Modified:
Notes:

Referrals:


EfiLibAllocatePool in the xTcgDxe.c

Function : EfiLibAllocatePool

File: xTcgDxe.c
Description:
Allocate BootServicesData pool.
Input:
AllocationSize  - The size to allocate
Output:
Pointer of the buffer allocated.


TcgEfiLibAllocateZeroPool in the xTcgDxe.c

Function : TcgEfiLibAllocateZeroPool

File: xTcgDxe.c
Description:
Allocate BootServicesData pool and zero the pool.
Input:
AllocationSize  - The size to allocate
Output:
Pointer of the buffer allocated.


xTcgPei.c

Description:
Contians entry point function for TcgPei Subcomponent

The following functions are used in the file: xTcgPei.c.

Function | Description
CommonTcgPeiEntryPoint | Entry point for Tcg PEI component


CommonTcgPeiEntryPoint in the xTcgPei.c

Function : CommonTcgPeiEntryPoint

File: xTcgPei.c
Description:
Entry point for Tcg PEI component
Input:
IN      EFI_FFS_FILE_HEADER       *FfsHeader
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


xTcgPeiAfterMem.c

Description:
Contians entry point function for TcgPei Subcomponent

The following functions are used in the file: xTcgPeiAfterMem.c.

Function | Description
CommonTcgPeiEntryPoint | Entry point for Tcg PEI component
OnMemoryDiscovered | Call Memory Present initialization on memory Installation


CommonTcgPeiEntryPoint in the xTcgPeiAfterMem.c

Function : CommonTcgPeiEntryPoint

File: xTcgPeiAfterMem.c
Description:
Entry point for Tcg PEI component
Input:
IN      EFI_FFS_FILE_HEADER       *FfsHeader
IN      EFI_PEI_SERVICES          **PeiServices,
Output:
EFI_STATUS
Modified:
Notes:

Referrals:


OnMemoryDiscovered in the xTcgPeiAfterMem.c

Function : OnMemoryDiscovered

File: xTcgPeiAfterMem.c
Description:
Call Memory Present initialization on memory Installation
Input:
IN      EFI_PEI_SERVICES          **PeiServices,
IN      EFI_PEI_NOTIFY_DESCRIPTOR *NotifyDesc,
IN      VOID                      *Ppi
Output:
EFI STATUS
Modified:
Notes:

Referrals:


ZTEICTcmOrdinals.h

Description:
Header file for ZTEIC specific ordinals


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

  • ?
  • A
  • C
  • D
  • E
  • F
  • G
  • H
  • I
  • L
  • M
  • N
  • O
  • P
  • R
  • S
  • T
  • U
  • V
  • W


Functions in Alphabetical Order

?

Function | Description
_DSM | Implement Phisical Presence Interface
_DSM | Implement Phisical Presence Interface using WordAcc


Functions in Alphabetical Order

A

Function | Description
AllocateRTMemory | Allocates memory used by TCG Legacy code during run-time
AmiTcgPlatformPEI_EntryAfterMem | Installs AMIplatform PPI for initialization in PEI after memory is installed
AmiTcgPlatformPEI_EntryBeforeMem | Installs AMIplatform PPI for initialization in PEI before memory is installed
AmiTcgPpiNvflagEntry | Entry point
AppendDevicePath | Appends Two given Device Path
AutoSupportType | verifies support for a TCM module on a platform
AutoSupportType | verifies support for a TCM module on a platform


Functions in Alphabetical Order

C

Function | Description
check_authenticate_set | checks if password authentication set in Setup
check_user_is_administrator | check if user was authenticated as an administrator (optional)
CheckTpmOwnership | Executes TPM operation to read capabilities
ClearFastBootLastBootFailedFlag | FastBoot clear boot fail flag callback
CommonTcgDxEntryPoint | Common entry point for Tcgdxe
CommonTcgPeiEntryPoint | Entry point for Tcg PEI component
CommonTcgPeiEntryPoint | Entry point for Tcg PEI component
CompareGuid | Compares two input GUIDs
CompareGuid | Compares two input GUIDs
confirmUser | Wait on key press from ConIn; Accept Esc or F10. Timeout if user doesn't respond INPUT: OUTPUT: UINT8
ContinueTCMSelfTest | Executes ContinueSelfTest operation on TPM. Certain TPM operation require this operation to be execute before.
ContinueTPMSelfTest | Executes ContinueSelfTest operation on TPM. Certain TPM operation require this operation to be execute before.


Functions in Alphabetical Order

D

Function | Description
displOperations | Display requested actions as a list of operations INPUT: IN extended_request erqst, IN int count, IN CHAR16 *DesStr OUTPUT: VOID
displTpmNvOperations | Display requested actions as a list of operations INPUT: IN extended_request erqst, IN CHAR16 *DesStr OUTPUT: VOID
doCpuMicrocodeTcgEvent | Measures EV_CPU_MICROCODE event
DoResetNow | Callback function to execute TPM reset
doTcmCpuMicrocodeTcgEvent | Measures EV_CPU_MICROCODE event
DummySkipPhysicalPresencePtr | Always return false. Can be overridden with OEM function


Functions in Alphabetical Order

E

Function | Description
EfiLibAllocatePool | Allocate BootServicesData pool.
EfiLibGetSystemConfigurationTable | Get table from configuration table by name
EfiOSReadyToBoot | Sets ready to boot callback on ready to boot
EfiOSReadyToBoot | Sets ready to boot callback on ready to boot
EMpTcmDxeClose | Close TPM connection for locality 0
EMpTcmDxeGetStatusInfo | GetStatus Info from MP driver
EMpTcmDxeInit | Call to OEM driver to initialize TPM.
EMpTcmDxeTransmit | Dxe Transmit Tcg Data
EMpTcmPeiClose | Call to OEM driver to Close TCM
EMpTcmPeiGetStatusInfo | Function call to get status infomation
EMpTcmPeiInit | Call to OEM driver to initialize TCM
EMpTcmPeiSHA1Setup | Helper function to help with Command transmission to TCM
EMpTcmPeiTransmit | TCM Transmit function
EMpTpmPeiClose | Call to OEM driver to Close TPM
EMpTpmPeiInit | Call to OEM driver to initialize TPM
EMpTpmPeiSHA1Setup | Helper function to help with Command transmission to TPM
EMpTpmPeiTransmit | TPM Transmit function
execute_request | Execute TPM operation INPUT: IN UINT8 rqst OUTPUT: error code if any as result of executing the operation
extend_request | Convert the opcode into array of 2-bit values.For each 2-bit: 0 - no change; 1 - turn off; 2 - turn on indexes: 0 - enable flag; 1 - active flag; 2 - onwership 3 - clear INPUT: IN UINT8 rqst OUTPUT: extended_request


Functions in Alphabetical Order

F

Function | Description
FillDriverLoc | Minor function to fill in MPDriver Offsets for TPM Device PPI
FillDriverLocByFile | Helper function to locate a Driver by guid and fill in Offset data about it. Mainly for MA Driver
FindAndMeasureDxeFWVol |
FindCompatibility16Table | This function identifies the validity of CSM16 binary by searching "$EFI" and verifying table checksum and returs the location of $EFI table
FixedDelay | This routine delays for specified number of micro seconds


Functions in Alphabetical Order

G

Function | Description
GET_PFA | Returns PCI device Bus Device Function infomation
GetDsdt | Locates ACPI Table Protocol
GetHob | Find instance of a HOB type in a HOB list
GetHob | Find instance of a HOB type in a HOB list
GetNextGuidHob | Find GUID HOB
GetNextGuidHob | Find GUID HOB
GetPCIOPROMImage | Finds Onboard Option ROM Images
GetRawImage | Loads binary from RAW section of main firwmare volume
getSetupData | Retrieved SETUP_DATA structure from NVRAM
GetStringFromToken | Gets a UNI string by Token
GetTCGLegacyInterface | Loads legacy BIOS binary extensions (TcgLegX16, TPM32 and MPTPM ) and initializes the TCG Legacy support.
GetTcgWakeEventType | Reads and Reports the source of the wake-up event.


Functions in Alphabetical Order

H

Function | Description
HelpRegisterPPISMI | Common function to handle TCG SMI's


Functions in Alphabetical Order

I

Function | Description
InitLegacyTpmEntry | Entry point for TPM initialization after memory is installed
InitTcmEntry | Entry point for TCM ppi initialization after memory is installed
IntTcmTcgPeiGetCapabilities | Executes TCM operation to read capabilities
IntTcmTcgPeiGetCapabilities | Executes TCM operation to read capabilities


Functions in Alphabetical Order

L

Function | Description
linkTPMDriver | Establishes link used to synchronize change to the LOG when done through the INT1A interface while DXE is still in control.
LocateACPITableProtocol | Locates ACPI Table Protocol
LocateATcgHob | Finds a Tcg HOB
LocateATcgHob |
LocateTcgPpi | Locates and initializes TCG Ppi
Lock_TPMPhysicalPresence | check whether to Lock TPM physical Presence


Functions in Alphabetical Order

M

Function | Description
MeasureAllBootVariables | Measures all the boot Variables
measureCpuMicroCode | Locates CPU Microcode update and measures it as a TCG event
MeasureCRTMVersion | Measures EFI CRTM Version Demo Version[546BFB1E1D0C4055A4AD4EF4BF17B83A]
MeasureDxeCoreFwVol | Measures the firmware volume as a EV_POST_CODE event
MeasureHandoffTables | Measures, Logs and Extends EFI Handoff Tables. eg: SMBIOS
MeasurePCIOproms | Sets callback to measure PCI option roms that are given control
MeasurePciOptionRom | Measures EV_ID_OPROM_EXECUTE event address (PFA) and with digest of the specified PCI device OpRom image
MeasureSeparatorEvent | Measure Tcg Event Separator
MeasureTCGPcClientSpecID | Includes a measurement of the TcgSpecID into PCR[0]
MeasureTcmCRTMVersion | Measures EFI CRTM Version Demo Version[546BFB1E1D0C4055A4AD4EF4BF17B83A]
MeasureVariable | Measures a provided variable
MemoryAbsentEntry | This function performs TPM MA initialization
MemoryPresentEntry | This function performs TPM MP initialization


Functions in Alphabetical Order

N

Function | Description
NVOSread_PPI_request | Returns TCG PPI variable values to the Operating system
NVOSWrite_MOR_request | Writes TCG PPI MOR variable to NVRAM on SMI request the Operating system
NvSendTpmCommand | Sends a command to the TPM
NVWrite_PPI_request | Writes TCG PPI variable values to NVRAM on SMI request the Operating system


Functions in Alphabetical Order

O

Function | Description
OnAcpiInstalled | Adds Tcg Table to Acpi Tables
OnAdminPasswordValid | Sets AdminPasswordValid to TRUE [If TPM_PASSWORD_AUTHENTICATION]
OnMemoryDiscovered | Call Memory Present initialization on memory Installation
OnMemoryDiscovered | Call Memory Present initialization on memory Installation
OnPasswordSupplied | Sets PasswordSupplied to TRUE and runs PPI User Interface
OnPciIOInstalled | Checks if PCI device has an Option Rom and initiates the Option rom measurment
OverwriteSystemMemory | Overwrites system memory


Functions in Alphabetical Order

P

Function | Description
PasswordAuthentication | This function is available as ELINK. In will create a Event for password authenication
Prepare2Thunkproc | Function to setup location of Mp Driver as a local variable
Prepare2Thunkproc | Function to setup location of Mp Driver as a local variable
ProcessTcgPpiRequest | Process Tcg Ppi requests
ProcessTcgSetup | Handles Tcg Setup functionality
prompt_operation | Display information on the requested TPM operation to the user; INPUT: IN int rqst OUTPUT: VOID


Functions in Alphabetical Order

R

Function | Description
Read_Persistent_Bios_TPM_Flags | Read persistent bios flags in TPM NV
read_PPI_request | Reads and returns TCG PPI requests Value
read_TPM_capabilities | Executes TPM operation to read capabilities
Read_User_Confirmation_Status | Reads the user confirmation satus for PPI requests
read_volatile_flags | Executes TPM operation to read capabilities
ReadAndMeasureBootVariable | Read and Measures Boot Variable
ReadMORValue | Reads TCG MOR variable
ReadVariable | Reads Boot Variable
RecoveryClearTpmBeforeFlash | Process TPM clear on Rollback policy
RequestSystemReset | Requests for system reset through core else creates a call back to execute reset
ResetOSTcgVar | Function to reset TCG variables on certain scenerions


Functions in Alphabetical Order

S

Function | Description
SendStartupandSelftest | This function performs TPM MA initialization
SendTpmCommand | Sends a command to the TPM
Set_Persistent_Bios_TPM_Flags | Sets persistent bios flags in TPM NV
Set_TCMPhysicalPresence | Sets TCM physical Presence
Set_TPMPhysicalPresence | Sets TPM physical Presence
SetEfiOSTransitions | SetEfiOSTransitions
SetTcgReadyToBoot | Sets ready to boot callback on ready to boot for security device
SignalProtocolEvent | Internal function that installs/uninstalls protocol with a specified GUID and NULL interface. Such protocols can be used as event signaling mechanism.


Functions in Alphabetical Order

T

Function | Description
TcgCheckOpCode | converts String a to ASL string NAME
TcgCommonSetFlag | Common function to set flag for PPI write transactions
TcgConvertAslName | converts String a to ASL string NAME
TcgDxeCallMPDriver | Makes a function call into MP Driver
TcgDxeCallMPDriver | Makes a function call into MP Driver
TcgDxeHashLogExtendEventTcm | TcgDxe common function to Hash, Log and Extend data using TPM
TcgDxeHashLogExtendEventTpm | TcgDxe common function to Hash, Log and Extend data using TPM
TcgDxeLogEvent | Logs TCG events in DXE
TcgDxePassThroughToTcm | Helper function for TCM transmit function
TcgDxeplatformEntry
TcgEfiLibAllocateZeroPool | Allocate BootServicesData pool and zero the pool.
TcgFindAslObjectName | converts String a to ASL string NAME
TcgGetAslObj | converts String a to ASL string NAME
TcgGetDSDTTable | Gets Acpi DSDT table
TCGPEI_GETCAP | Executes TPM operation to read capabilities
TcgPeiBuildHobGuid | Internal abstracted function to create a Hob
TcgPeiEntry | Entry point to Memory Absent and Memory Present Initialization for TPM
TcgPeiEntry | Entry point to Memory Absent and Memory Present Initialization for TPM
TcgPeiEntry | Entry point to Memory Absent and Memory Present Initialization for TPM
TcgPeiGetRawImage | Loads binary from RAW section of main firwmare volume
TcgPeiHashLogExtendEventSW | TCGPEI Software function to Hash, Log and Extend data using software SHA-1
TcgPeiHashLogExtendEventSW | TCGPEI Software function to Hash, Log and Extend data using software SHA-1
TcgPeiHashLogExtendEventTcm | Tcm common function to Hash, Log and Extend data
TcgPeiHashLogExtendEventTcm | Tcm common function to Hash, Log and Extend data
TcgPeiLogEvent | TCGPEI common function to Hash, Log and Extend data using software SHA-1
TcgPeiLogEvent | TCGPEI common function to Hash, Log and Extend data using software SHA-1
TcgPeiPassThroughToTcm | TCGPEI common function to abstract passing commands to the TPM FIFO
TcgPeiPassThroughToTpm | TCGPEI common function to abstract passing commands to the TPM FIFO
TcgPeiPassThroughToTpm | TCGPEI common function to abstract passing commands to the TPM FIFO
TcgPeiPassThroughToTpm | TCGPEI common function to abstract passing commands to the TPM FIFO
TcgPeiPlatformEntry
TcgPeiTpmStartup | Sends Initial TPM Startup Command
TcgPlatformSetupPolicyEntryPoint | Entry point for TcgPlatformSetupPolicyEntryPoint
TcgPlatformSetupPolicyEntryPoint | Entry point for TcgPlatformSetupPolicyEntryPoint
TCGProcessConInAvailability | This is a replacement for the ProcessConInAvailability hook in TSE, to provide password verification in the TCG eModule. This function is a hook called when TSE determines that console is available. This function is available as ELINK. In the generic implementation boot password is prompted in this function.
tcgReadyToBoot | Generic Measurements done before EFI boots OS
TcgSmiCommonHandler | Common function to handle TCG SMI's
TCGSmmInit | Entry point for subcomponent
TcgTcmDxeStatusCheck | Tcm Dxe status check function
TcgTcmPeiEntry | Entry point for TCM device initialization
TcgThunk32 | Go to compatibility mode for MP driver
TcgThunk32 | Go to compatibility mode for MP driver
TcgThunkSwitchback | Switch back to 64bit mode
TcgThunkSwitchback | Switch back to 64bit mode
TcgUpdateAslNameObject | Locates ACPI Table Protocol
TcgUpdateAslObj | Updates TPM acpi variable for TPM support
TcgUpdateDefaultsHook | Updates TCG status on F3
TcmBootDone SetEfiOSTransitions
TcmCommonPassThrough | Helper function for TCM transmit command
TcmDxeEntry | TpmDxeEntry, Init TpmDxeDriver and install protocol
TcmDxeHashAll | TcmDxeHashAll function [SHA1]
TcmDxeLogEvent | Logs TCM events in DXE
TcmMeasureDxeCoreFwVol | Measures the firmware volume as a EV_POST_CODE event
TcmMeasureHandoffTables | Measures, Logs and Extends EFI Handoff Tables. eg: SMBIOS
TcmMeasureSeparatorEvent | Measure Tcg Event Separator
TcmMeasureVariable | Measures a provided variable
TcmPeiCallMPDriver | Interface to performing MP driver function calls in PEI Uses _ASM directives. Return Value in EAX return as status
TcmPeiEntry | Entry for TcmPei Device when TCM_Support is enabled
TcmPeiGetEventLog | Helper function for logging TCM events
TcmPeiGetEventLog | Helper function for logging TCM events
TcmPeiLogEvent | TCM common function to log PEI events
TcmPeiLogEvent | TCM common function to log PEI events
TcmPeiStartup | Sends Initial TPM Startup Command
TcmRead_Persistent_Bios_TPM_Flags | Sets persistent bios flags in TPM NV
TcmSet_Persistent_Bios_TPM_Flags | Sets persistent bios flags in TPM NV
TpmDxeClose | Close TPM connection for locality 0
TpmDxeGetStatusInfo | GetStatus Info from MP driver
TpmDxeInit | Call to OEM driver to initialize TPM.
TpmDxeTransmit | Dxe Transmit Tcg Data
TpmPeiCallMPDriver | Interface to performing MP driver function calls in PEI Uses _ASM directives. Return Value in EAX return as status


Functions in Alphabetical Order

U

Function | Description
UnlinkTPM32fromEFI | Breaks the link that exist between TPM32 code and DXE TCG driver. The established link was used to synchronize change to the LOG when done through the INT1A interface while DXE is still in control. Need to break this link one DXE driver is stoped or EFI boots OS ( including calling INT19)
UpDateASL | Update TCG ASL Support in ACPI base


Functions in Alphabetical Order

V

Function | Description
VerifyTcgVariables | Function to check whether we need to reset TCG variables


Functions in Alphabetical Order

W

Function | Description
write_PPI_result | Updates TCG PPI variable in NVRAM


General Information


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2014 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.