American Megatrends, Inc.

TseDefaultBootOrder

Copyright

Release Notes

© American Megatrends, Inc.


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2010 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.


Release Notes - NDA Required

Component Information:
Component Title: TseDefaultBootOrder
Component Reference Name: TseDefaultBootOrder
Component Type: eModule
Release Date: 2013-01-03
Source Control Label: 4.6.4.1_DefBootOrder_1.3
Source Control Location: SS: $/Alaska/BIN/Modules/BootOptionPolicies/TseDefaultBootOrder
Component Description:
This eModule is implementation of the TSE Default Boot Order as described in the "How to Provide Default Boot Order" section of "Aptio TSE Porting Guide".
This is a caption
Filename | Description
TseDefaultBootOrder.cif | eModule CIF file
TseDefaultBootOrder.sdl | SDL file
TseDefaultBootOrder.mak | Make file
TseDefaultBootOrder.c | Main file
TseDefaultBootOrder.h | Header file
TseDefaultBootOrder.chm | Help file

BIOS Information:
AMI BIOS Core: Aptio Core 4.6.4.1
Release Date: 2010/11/18
Source Control Label: 4.6.4.0
Source Control Location: SS: $/Alaska/BIN/Core
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39, Dated: 2012-01-04
Visual eBios: RSS.5.68.0116,Dated: 2010-02-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
NONE
General Bug Fixes:
Added modification to check for LOAD_OPTION_HIDDEN and ignore hidden boot options in creating "DefaultBootOrder" variable.
EIP addressed in this label:
EIP#65859
Files changed for EIP fixes:
TseDefaultBootOrder.c
TseDefaultBootOrder.chm
Known issues and limitations in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
Passed
Validation Testing:
Passed
Release History:
Release 1.2
Release 1.1
Release 1.0

© American Megatrends, Inc.


Release Notes - NDA Required

Component Information:
Component Title: TseDefaultBootOrder
Component Reference Name: TseDefaultBootOrder
Component Type: eModule
Release Date: 2011-02-15
Source Control Label: 4.6.4.1_DefBootOrder_1.0
Source Control Location: SS: $/Alaska/BIN/Modules/BootOptionPolicies/TseDefaultBootOrder
Component Description:
This eModule is implementation of the TSE Default Boot Order as described in the "How to Provide Default Boot Order" section of "Aptio TSE Porting Guide".
This is a caption
Filename | Description
TseDefaultBootOrder.cif | eModule CIF file
TseDefaultBootOrder.sdl | SDL file
TseDefaultBootOrder.mak | Make file
TseDefaultBootOrder.c | Main file
TseDefaultBootOrder.h | Header file
TseDefaultBootOrder.chm | Help file

BIOS Information:
AMI BIOS Core: Aptio Core 4.6.4.0
Release Date: 2010/11/08
Source Control Label: 4.6.4.0
Source Control Location: SS: $/Alaska/BIN/Core
AMI Build Tools:
Visual eBios: RSS.5.68.0116, Dated: 2010-02-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
EIP#52313 Synopsis: In 4.6.4.1, TSE will not load the default for boot order, it just rstore the original value instead. Description: In 4.6.4.1 when change the boot order in setup, save and reset. Enter setup again, load default, the boot order can't load default.
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
Passed
Validation Testing:
Passed
Release History:
Release (INT)_TseDefaultBootOrder_1.0

© American Megatrends, Inc.


Release Notes - NDA Required

Component Information:
Component Title: TseDefaultBootOrder
Component Reference Name: TseDefaultBootOrder
Component Type: eModule
Release Date: 2011-05-05
Source Control Label: 4.6.4.1_DefBootOrder_1.1
Source Control Location: SS: $/Alaska/BIN/Modules/BootOptionPolicies/TseDefaultBootOrder
Component Description:
This eModule is implementation of the TSE Default Boot Order as described in the "How to Provide Default Boot Order" section of "Aptio TSE Porting Guide".
This is a caption
Filename | Description
TseDefaultBootOrder.cif | eModule CIF file
TseDefaultBootOrder.sdl | SDL file
TseDefaultBootOrder.mak | Make file
TseDefaultBootOrder.c | Main file
TseDefaultBootOrder.h | Header file
TseDefaultBootOrder.chm | Help file

BIOS Information:
AMI BIOS Core: Aptio Core 4.6.4.0
Release Date: 2010/11/08
Source Control Label: 4.6.4.0
Source Control Location: SS: $/Alaska/BIN/Core
AMI Build Tools:
Visual eBios: RSS.5.68.0116,Dated: 2010-02-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
EIP#58592
Files changed for EIP fixes:
TseDefaultBootOrder.c
Known issues and limitations in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
Passed
Validation Testing:
Passed
Release History:
Release_01
Release_00

© American Megatrends, Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • TseDefaultBootOrder.c
  • TseDefaultBootOrder.h
  • TseDefaultBootOrder.mak
Built on 09:57:59 09/13/11


TseDefaultBootOrder.c

Description:
This is main file of the TseDefaultBootOrder eModule.

The following functions are used in the file: TseDefaultBootOrder.c.

Function | Description
CompareTagThenBbsIndex | This function returns result of compairing two DLINK tags.
SetDefaultTseBootOrder | This function sets variables: DefaultLegacyDevOrder and DefaultBootOrder.


CompareTagThenBbsIndex in the TseDefaultBootOrder.c

Function : CompareTagThenBbsIndex

File: TseDefaultBootOrder.c
Description:
This function returns result of compairing two DLINK tags.
Input:
Link1 - pointer to the first tag for compare
Link1 - pointer to the second tag for compare
Output:
INT32 - result of comparing.


SetDefaultTseBootOrder in the TseDefaultBootOrder.c

Function : SetDefaultTseBootOrder

File: TseDefaultBootOrder.c
Description:
This function sets variables: DefaultLegacyDevOrder and DefaultBootOrder.
Input:
VOID
Output:
VOID


TseDefaultBootOrder.h

Description:
Internal header file for TseDefaultBootOrder eModule.


TseDefaultBootOrder.mak

Description:


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

  • C
  • S


Functions in Alphabetical Order

C

Function | Description
CompareTagThenBbsIndex | This function returns result of compairing two DLINK tags.


Functions in Alphabetical Order

S

Function | Description
SetDefaultTseBootOrder | This function sets variables: DefaultLegacyDevOrder and DefaultBootOrder.


General Information


Release Notes - NDA Required

Component Information:
Component Title: TseDefaultBootOrder
Component Reference Name: TseDefaultBootOrder
Component Type: eModule
Release Date: 2011-09-13
Source Control Label: 4.6.4.1_DefBootOrder_1.2
Source Control Location: SS: $/Alaska/BIN/Modules/BootOptionPolicies/TseDefaultBootOrder
Component Description:
This eModule is implementation of the TSE Default Boot Order as described in the "How to Provide Default Boot Order" section of "Aptio TSE Porting Guide".
This is a caption
Filename | Description
TseDefaultBootOrder.cif | eModule CIF file
TseDefaultBootOrder.sdl | SDL file
TseDefaultBootOrder.mak | Make file
TseDefaultBootOrder.c | Main file
TseDefaultBootOrder.h | Header file
TseDefaultBootOrder.chm | Help file

BIOS Information:
AMI BIOS Core: Aptio Core 4.6.4.1
Release Date: 2010/11/18
Source Control Label: 4.6.4.0
Source Control Location: SS: $/Alaska/BIN/Core
AMI Build Tools:
Visual eBios: RSS.5.68.0116,Dated: 2010-02-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
EIP#65859
Files changed for EIP fixes:
TseDefaultBootOrder.c
TseDefaultBootOrder.chm
Known issues and limitations in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
Passed
Validation Testing:
Passed
Release History:
Release 1.1
Release 1.0

© American Megatrends, Inc.