American Megatrends, Inc.

ReleaseNotes

Copyright

Release Notes

© American Megatrends, Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel EDK
Component Reference Name: Intel EDK
Component Type: eModule
Release Date: 2012/04/25
Source Control Label: 4.6.5.3_IntelEDK1117_Patch8_03
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelEDK;
Component Description:
The component includes:
  • EDK RC code: EDK1117_Client_Framework_Dev_Patch_8.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39 , Dated: 2012-04-04
Visual eBios: RSS 5.72.0220, Dated: Sep., 2012
Compiler Tool(s): Microsoft?™s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
None
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
None
General Bug Fixes:
None
EIP addressed in this label:
None
Files changed for EIP Fixes:
None
Known issues and limitations in this label:
Please search *** AMI PORTING BEGIN *** for changes.
Remaining Issues:
None
Release History:
  • 4.6.5.3_IntelEDK1117_Patch8_03
    EFI_BOOT_SCRIPT_MEM_POLL_OPCODE Support PI1.2 (PI1.2 0x0E, PI0.91 0x81).

  • 4.6.5.3_IntelEDK1117_Patch8_02
    Fixed build error on IBMI module + DEBUG_MODE on.

  • 4.6.5.3_IntelEDK1117_Patch8_01
  • (INT)4.6.5.3_IntelEDK1117_Patch8
    Intel EDK 1117 Patch8 initially releases.

  • 4.6.5.3_IntelEDK_1117_Patch7_000
    Intel EDK 1117 Patch7 initially releases.

© American Megatrends Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.
For a list by segment, see By Segment.

  • CRB.mak
  • CRBSec.ASM
Built on 17:19:35 04/25/12


CRB.mak

Description:
This make file builds Chipset Reference Board SEC,PEI & DXE
components and link them to respective binary


CRBSec.ASM

Description:
Program any workaround or initialization needed before
enabling Cache as memory in the SEC stage for CRB.

The following functions are used in the file: CRBSec.ASM.

Function | Description
SECCRB_EarlyInit | This routine initializes CRB for PEI preparation


SECCRB_EarlyInit in the CRBSec.ASM

Function : SECCRB_EarlyInit

File: CRBSec.ASM
Segment: STARTUP_SEG
Description:
This routine initializes CRB for PEI preparation
Input:
ESP BIST Info
EBP Reset ID (EDX at reset)
Stack not available
Output:
None
Modified:
All, except EBP and ESP
Notes:
NBSEC & SBSEC initialization is done at this point.


Function by Segment

By Segment

The following is a list of the segments.
For a list in alphabetical order, see In Alphabetical Order.
For a list by file name, see By File Name.

  • STARTUP_SEG


STARTUP_SEG

The following functions are used in the segment: STARTUP_SEG.

Function | Description
SECCRB_EarlyInit | This routine initializes CRB for PEI preparation


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.
For a list by segment, see By Segment.

  • S


Functions in Alphabetical Order

S

Function | Description
SECCRB_EarlyInit | This routine initializes CRB for PEI preparation


General Information


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2011 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.