American Megatrends, Inc.

AMITSE

Copyright

Release Notes

© American Megatrends, Inc.


eModule Release Notes

AMIBIOS Component Release Notes

Component Information:

Component Name | : | AMITSE
Component Type | : | eModule
Release Date | : | 10/01/2014
Source Control Label | : | 4.6.2_TSE_2_17_1247
Source Control Location | : | $/Alaska/BIN/Modules/AMITSE2_0/AMITSE $/Alaska/SOURCE/Modules/AMITSE2_0/AMITSE

Build Tools:

Compiler Used | : | WDK version 7600.16385.1
Tool Directories | : | Label version: 4.5.5_Tools_33, Dated: July 07, 2010
WDK Tools | : | <WinDDK>/7600.16385.1/bin/x86 <WinDDK>/7600.16385.1/bin/x86/x86
Env.Variables | : | CCX86DIR = <WinDDK>\7600.16385.1\bin\x86\x86 CCX64DIR = <WinDDK>\7600.16385.1\bin\x86\amd64
Visual eBios | : | RSS 5.69.0148, Dated: July 07, 2010
Build Environment | : | UEFI 2.0, UEFI 2.1, x32 and X64

Component Description:

AMITSE is a firmware component that provides the following functionality:

· POST Manager

· Splash screen logo support

· BBS Popup support

· Boot device support

· Driver Order support

· Setup Configuration pages

· Manage Boot Process

· Firmware User Interface

· OEM Customizations

· Advanced Protocol Support

· Style Customization

· Choose between Ezport, Legacy and Ezport Styles support

· Keeping logos in ROMHole

· OSIndications support

· ESRT support

· Native resolution support

· Print screen support

· Password encoding using hash algorithm

· Support to remove RT flag in HPKTOOL

Filename

Description

Action.c

Contains code to handle different actions.

Action.h

Header file for code to handle different actions.

AddBootOption.c

Contains code to handle the Add boot option operation.

AMILogo.c

Contains logo related code

AMILogo.h

Header file to define logo related code.

Amiver.h

Contains version macros

Application.c

Contains code to handle Application.

Application.h

Header file for code to handle Application.

bbs.c

Handles bbs/legacy boot management.

bbs.h

Header file for bbs/legacy boot management.

boot.c

This file contains code for Boot management.

BootflowLib.c

This file contains code for Boot Flow management.

box.c

Contains box related functions.

box.h

Header file for box related functions.

Buffer.c

This file contains code to manage buffers.

Buffer.h

Header file for code to manage buffers.

Callback.c

This file contains code to handle callbacks.

Callback.h

Header file for code to handle callbacks.

Control.c

This file contains code to handle controls.

Control.h

Header file for controls.

Ctrlcond.c

This file contains code for control conditions.

Ctrlcond.h

Header file for control conditions.

Date.c

This file contains code to handle Date control operations.

Date.h

Header file for Date controls.

Dobmpmgr.c

This file contains code taken from graphics.c to eliminate library dependency.

Dogif.c

This file contains code for gif image handling.

Dogifmgr.c

This file contains code for gif image handling.

edit.c

This file contains code to handle Edit control operations.

edit.h

Header file for Edit controls.

EDKhelper.c

This file contains code from EDK library.

EDKhelper.h

Edk helper header file

Expression.c

This file contains Expression evaluation.

Ezport.c

Main file for Ezport style module.

Ezport.h

Main header file for Ezport style module.

ezportplus.c

Main file for EzportPlus style module.

ezportplus.h

Main header file for EzportPlus style module.

FormBrowser.c

This file contains code for form browser.

FormBrowser2.c

This file contains code for form browser2.

FormBrowser2.h

Header file for form browser2.

Frame.c

This file contains code to handle frame operations.

Frame.h

Header file for Frame control related functions.

Globals.c

This file contains code for globals in boot only.

hii.c

This file contains code to handle the uefi2.0 based hii operations.

hii.h

Header file for Hii functionality.

Hiicallback.c

This file contains code for Hii callback operations.

HiiNotificationHandler.c

This file contains code to handle Notification arising from Dynamic Form Modification

Hiistring.c

This file contains code to handle the hii sting operations.

Hiistring.h

Header file for code to handle the hii sting operations.

Hiistring20.c

This file contains code to handle UEFI2.0 supported hii strings

Hiistring21.c

This file contains code to handle UEFI2.1 supported hii strings.

HookAnchor.c

This file handles the hook functions.

Hotkey.c

This file contains code to handle hotkey operations.

Hotkey.h

Header file for hotkey code to handling.

IJpeg.c

Contains code for jpeg image handling

ipcx.c

This file contains code related to pcx image handling.

jpeg.h

Header file for jpeg image format related code.

jpeg6.c

Contains jpeg image related code

Jpeg6.h

Header file for jpeg6 image format related code.

Label.c

This file contains code to handle Label operations.

Label.h

Header file for Label controls.

legacy.c

Legacy Style file

legacy.h

Legacy Style header file

ListBox.c

This file contains code to handle Listbox controls.

ListBox.h

Header file for Listbox controls.

logo.c

Contains code to handle the logo operations and to eliminate library dependency.

Mem.c

Contains code to handle the memory operations.

Memo.c

Contains code to handle Memo controls.

Memo.h

Header file for Memo controls.

Menu.c

Contains code to handle Menu operations.

Menu.h

Header file for Menu controls.

MessageBox.c

Contains code to handle Message Box operations.

MessageBox.h

Header file for Message Box control.

Minisetup.c

Contains code for entry point and setup loop.

Minisetup.h

Main header file takes care of TSE includes.

Minisetupext.c

Contains code for entry point and setup loop.

Minisetupext.h

Header file for FULL TSE specific minisetup entry and exit functionality.

Mouse.c

This file contains code to handle Mouse Operations

MyDefs.h

Header file common definitions.

Notify.c

Contains code to support the notification functions.

Numeric.c

Contains code to handle Label operations.

Numeric.h

Header file for numeric control.

Object.c

This file contains code to handle Objects.

Object.h

Header file for code to handle Objects.

Ordlistbox.c

Contains code to handle ordered list box controls.

Ordlistbox.h

Header file for code to handle ordered list box controls.

Page.c

This file contains code to handle page level operations.

Page.h

Header file for code to handle page level operations.

Parse.c

This file contains UEFI2.1 parsing code.

Password.c

Contains code to handle password operations.

Password.h

Header file for code to handle password operations.

pcx.h

Header file for pcx image format related code.

Pcxc.c

This file contains code for pcx image handling.

Popup.c

Contains code to handle popup operations.

Popup.h

Header file for code to handle popup operations.

PopupEdit.c

Contains code to handle Popup Edit operations.

PopupEdit.h

Contains definitions to handle Popup Edit operations.

PopupPassword.c

Contains code to handle Popup Passwords.

PopupPassword.h

Header file for Popup Passwords.

PopupSel.c

Contains code to handle Popup selections.

PopupSel.h

Header file for Popup selections.

PopupString.c

Contains code to handle Popup Strings.

PopupString.h

Header file for popupstring control.

Postmgmt.c

Handles the Post management operations.

Postmgmtext.c

Contains code extended Post management operations.

print.c

Contains code to support the print functionality.

protocol.c

Contains code for TSE exported protocol functions.

protocol.h

Header file for protocol.

ResetButton.c

UEFI reset button control file.

ResetButton.h

Header for UEFI reset button control

Resources.c

Library routines to load image resources.

screen.c

Contains code for screen operations.

Screen.h

Header file for screen.

setupdata.h

Header file for setup data.

special.c

Contains code to handle special operations.

special.h

Header file for TSE special controls like AMI callback controls.

string.c

Contains code for string functionality.

string.h

Header file for string functionality.

style.c

Contains style override functions.

style.h

Style override prototypes.

stylecommon.c

Contains generic or default style functions.

StyleHook.h

Souce file of StyleHook Module that contains empty Style hook function

StyleHook.mak

Makefile of StyleHook Module that contains empty Style hook function

styleHook1.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook10.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook11.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook12.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook13.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook14.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook15.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook16.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook17.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook18.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook19.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook2.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook20.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook21.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook22.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook23.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook24.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook25.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook26.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook27.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook28.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook29.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook3.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook30.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook31.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook32.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook33.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook34.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook35.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook36.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook37.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook38.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook39.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook4.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook5.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook6.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook7.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook8.c

Souce file of StyleHook Module that contains empty Style hook function

styleHook9.c

Souce file of StyleHook Module that contains empty Style hook function

SubMenu.c

Contains code to handle submenu operations.

SubMenu.h

Header file for submenu related functionality.

Text.c

Contains code to handle text operations.

Text.h

Header file for code to handle text operations.

time.c

Contains code to handle Time control operations.

Time.h

Header file for code to handle Time control operations.

timer.c

Contains code to handle the timer.

Timer.h

Header file for code to handle the timer.

TianoHii.h

Header file contains Tiano Hii info.

TseAdvanced.c

Contains code to handle the Advanced TSE operations.

TseLiteCommon.c

Contains code for the TSE Lite common functions.

TseLitehelper.c

Contains code specific to TSE Lite flavor.

TseUefiHii.h

Header file contains TSE Hii info.

uefi20Wapper.c

Contains code for UEFI2.0 wrapper.

Uefi21Wapper.c

Contains code for UEFI2.1 wrapper.

UefiAction.c

Contains code to handle the uefi actions.

UefiAction.h

Header file for Uefi Action data.

variable.c

This file contains code to handle bootonly variables operations.

StyleHook

This is the module part in TseLite for Style related hook functions.

Hotclick.c

This file contains code to handle hotclick operations

Hotclick.h

Header file for hotclick code handling

Help Topics:

  • TSE Help Module
  • MINISETUP SDL Tokens
  • TSELITE SDL Tokens
  • TSEADVANCED SDL Tokens
  • EZPORT SDL Tokens
  • UEFI20 SDL Tokens

4.6.2_TSE_2_17_1247

New Features:

· Support to provide and load defaults for string controls.

· Support to use best text mode and resolutions before use TsePostInterfaces outside TSE.

· Support to select and focus grayed out controls.

Bug Fixes:

· Fixed mouse click\touch actions when soft keyboard is activated in setup.

· Fixed issue of mouse is not moving in post for whole screen in quiet boot

· Fixed issue of POST screen display gets delay when softkeyboard is present

· Fixed issue of when HDD boot option is selected to disabled in Boot Priority and the same HDD is disappeared under DOS.

· Fixed issue of System will display blue screen after use OEM command to boot to “BIOS Setup Utility” from Built-in EFI Shell.

· Fixed issue of Background of TextBox is not cleared after using TSE DisplayTextBox interface.

· Fixed issue of User password is not cleared when Admin password is cleared from NVRAM.

· Fixed issue of System hangs on using UefiVarsetnvramforCurrentform

· Fixed issue of HDD password prompt is not proper in post.

· Fixed issue of mouse pointer flicker continuously when softkbd is launched for string control.

· Fixed issue of Password window hangs on post.

· Fixed issue of TMM Settings page is moved to wrong position.

· Fixed issue of Post password popup window dislocation and distortion.

· Fixed issue of Arrow mark shown when driver health page published.

· Fixed issue of Setup hangs when sendform called from oemdriverhealth module.

· Fixed issue of PXE boot options are not booting from boot override menu if GROUP_BOOT_OPTIONS_BY_TAG is 0

· Fixed issue of Refresh_ID support is not working in TSE

· Removed TODO comments and added proper comments in those places

· Fixed build error when token TSE_USE_GETGYLPH_PRINTLENGH is enabled

Files changed from previous release:

- EIP comments will give the changed files.

Known Issues:

- In some pages with more number of controls scroll bar can move inconsistently.

- Hot clicks on navigation frame are not available for Legacy and Ezport Plus Setup.

Remaining Issues:

- NIL.

Unit Testing:

- Booting to different flavors of Dos and Windows.

- Refer EIPs on Review and AMITSE_EIP_UnitTestReport.xlsx/AMITSE_EIP_UnitTestReport_Generalized.xlsx document for Testing information

- Tested with System Recovery mode.

- Tested with FastBoot Enabled.

- Tested the Setup UI/Navigation with UEFI 2.0/UEFI 2.1 and above in both x64 and x32 builds.

- Tested Add/Del boot/driver option support with File browser support

Validation Testing:

- No pending issues.

Third Party Code:

- EdkHelper.c contains some of the functions from EDK 1117 module

- UEFI 2.1 Express evaluation done using EDK 1.05 code.

Notes:

- To enable FORM_BROWSER protocol support enable SETUP_FORM_BROWSER_SUPPORT and SETUP_RUNTIME_IFR_PROCESSING

- To enable Add/Del boot option, questions should be added in Boot.vfr and SETUP_SUPPORT_ADD_BOOT_OPTION SDL token should be enabled.

- Turn on MINISETUP_MOUSE_SUPPORT for mouse support

- Support to override TSE strings needs Aptio 4.6.4.0 and Tools Label "4.5.5_Tools_30 or above.

- TSE is a setup engine; it can’t check/correct the spelling/grammatical errors of setup pages. It needs to be fixed in modules that produce the Hii resources.

- Use the StatusCode Module version 16 to resolve the setup hanging for few minutes with some boot options.

- If using EDK library, BGRT support will not work properly unless the source is having the latest Include/Protocol/AcpiSupport.h file version 7 or the guid defined as

#define EFI_ACPI_TABLE_PROTOCOL_GUID \

{0xffe06bdd, 0x6107, 0x46a6, {0x7b, 0xb2, 0x5a, 0x9c, \ 0x7e, 0xc5, 0x27, 0x5c}}

- For debug trace messages, TSE sources are needed

- To increase the password length TSE sources are required

- TSE_HASH_PASSWORD should be enabled when the project has CryptoPkg.

- Mouse driver compatibility chart,

TSE Version | Recommended Mouse Driver
4.6.2_TSE_2_11_1210 | 4.6.0-MOUSE_SUPPORT-001
4.6.2_TSE_2_13_1213 and 4.6.2_TSE_2_14_1219 | 4.6.0-MOUSE_SUPPORT-007, 4.6.0-MOUSE_SUPPORT-008 and 4.6.0-MOUSE_SUPPORT-009
4.6.2_TSE_2_15_1224 or above | 4.6.0-MOUSE_SUPPORT-010 or above

Revision History:

4.6.2_TSE_2_17_1246

New Features:

· Provision to hide the dynamic formset through Elinks

· Password encoding using hash algorithm

· Removing run time flag for the variables

· Provision to provide default password through SDL tokens.

· Provided more override hooks

· Provision to disable ESC key in BBS popup menu

· Protocol interface to invalidate the status bit in BGRT

· Increased TSE variables for customization

· Event signaled before and after boot time out

· Provision to hide softkbd in BBS menu

· Copyright year updated with BIOS build year dynamically

· Application level hot click support for Ezport style in 80*25 mode also.

· Support to close messagebox, listbox using moue right button action.

· Provision to suppress the handle comparison for variable in dynamic parsing through Elink.

· Compatible with AMISetupNVLock module

Bug Fixes:

· On multiline control clicking on the control in the multi lines is not getting selected

· Security code check fixed

· EDK_1_05_RETRIEVE_DATA defined 1 or 0 based on core version.

· In 80*25 mode controls moving out of the frame

· Loading defaults on add/boot option hangs

· Softkbd not cleared properly when selecting shell from Boot override menu

· TSE hangs on having lengthier password titles

· Menu not selectable when numeric control is selected and also single click activation is enabled.

· Secure boot message hangs with softkbd displayed

· USB/PS2 keyboard not working in setup

· TSE hangs on RAID driver on disconnecting and connecting it.

· When token MATCH_BOOT_OPTION_BY_LOCATION = 0 and GROUP_BOOT_OPTIONS_BY_TAG = 0, then boot device is not displaying properly.

· Dynamic pages after removing and updating the pack, menu title is changing.

· Hpktool not throwing error on not mentioning EFI spec version.

· Action control not prompting save and reset when Reset required flag is set.

· Build error if more Elinks are provided

· Large string in listbox hangs

· Message box not closed on outside right click

· UefiVarsetnvramforCurrentform not saving values properly for current form.

· Closing password by clicking outside popup window displaying invalid password message box, when SINGLE_CLICK_ACTIVATION token is enabled

· BGRT status not cleared for shell v2.0

· When password keyboard is launched and mouse pointer is placed on softkbd mouse will flickers continuously.

· System Abnormal when execute Load Default (F9) in BIOS Setup.

· Add boot option failed to add the boot option if no boot option found initially.

· Removed global variable guid usage for TSE debug messages

· Removed RT attributes in some of the variables not needed it.

4.6.2_TSE_2_16_1243

New Features:

· Support to suppress formset other than EFI_HII_PLATFORM_SETUP_FORMSET_GUID and EFI_HII_DRIVER_HEALTH_FORMSET_GUID using elink

· Support to display multiple lines using single ANSI ESC code color.

· Support to show all HDD passwords in same page

· Added signal event to denote all boot option has exhausted.

· Support to restore resolution before signalling AMITSE_EVENT_BEFORE_BOOT_GUID event.

· ESA compatibility for Aptio5

Bug Fixes:

· Moved saving current screen resolution from DrawImage to DrawQuietBootLogo.

· Fixed switch language between Japanese and English will displaying broken Japanese character in pages

· Fix for add boot options support in ESA

· EfiCreateEventReadyToBoot is conflicted under UefiLib.h and EDKhelper.h. So changed function name to TseEfiCreateEventReadyToBoot

· Security code check fail in the function IsBootDeviceEnabled() in boot.c

· Legacy boot doesn't work after UEFI Shell is launched from LaunchAppHotkey menu

· Fixed DrawStringJustifiedWithAttribute function to avoid truncating passed original strings.

· When entered into setup with User mode and On pressing "Restore User Defaults" SystemAccess variable is loading and the user mode is changes to Admin mode so the controls are editable

· TSE Help window flickers when Mouse\Touch device used under boot page in Setup

· Support '\r' character to behave like line feed (‘\n’) to do line break.

· Fixed UI is not Displaying properly after enabling Quite Boot in ESA

· UefiHpkTool is throwing build error saying "UefiHpkTool stopped working" on using 8 byte value as default value for Numeric control

· The ParentPageID in the destination page of the Ref3 control is not updated properly

· Adding UEFI bootable RHEL OS(Bootx64.efi) from UEFI REHL6.4 DVD disk through add boot option causes setup hang

· Incorrect Driver Health name shown in BIOS (UEFI Mode) Setup for SAS Card.

· When password control label string has space as first character, then on selecting it setup hangs

· New opcodes added in controltypes in hpktool

· Fixed dynamic pages are not displaying all its root pages ie., showing 1 controller page not 2 controller pages

· Fixed issue not loading defaults for interactive controls

· Fixed menu order is not proper when entering into setup through BBS menu on using AMITSE_ROOT_PAGE_ORDER_SUPPORT

· Fixed dynamic pages crash issue on clicking its page

· Fixed EFI Windows Boot manager boot entry will not disappear after remove EFI-HDD from the target

· Fixed setup hang when legacydevorder variable is try to update using formcallback.

· Fixed for oprom published page, when both MINISETUP_MOUSE_SUPPORT and TSE_MULTILINE_CONTROLS are enabled, only the first line of wrapped controls are clickable.

· Fixed for oprom published page, action controls doesn’t handle mouse clicks.

· Fixed for oprom published page, text get truncated even if TSE_MULTILINE_CONTROLS enabled

· Fixed for oprom published page, checkbox is not grayed-out when checkbox is present in identical formset with two different handle

· Changed path size from 1 to 120 in NEW_BOOT_OPTION structure

· Fixed slowness in shell performance

· Fixed F1 not displaying help message

· Fixed screen clearing issue in UEFI PXE boot.

4.6.2_TSE_2_16_1240

New Features:

· Compatible with latest opcodes.

· Hook function for toggling between quiet boot and post screen.

· Opcode support for EFI_IFR_WRITE, EFI_IFR_READ, EFI_IFR_GET, EFI_IFR_SET, EFI_IFR_MAP_OP, EFI_IFR_VARSTORE_EFI, EFI_IFR_MODAL_TAG_OP, EFI_IFR_QUESTION_REF3_2, EFI_IFR_QUESTION_REF3_3, EFI_IFR_TYPE_REF, EFI_IFR_REF5

· Offline parsing support for EFI_IFR_REFRESH_ID

· Passing non encoded password string to callback.

· Romhole support for PI spec. version 0.91

· Checksum support in HPKTool

· EFI_BROWSER_ACTION_DEFAULT_MANUFACTURING support

· Hook provided for messagebox color change display for VT100

· Logo redrawn after HDD password popup

· Print screen support

· AMITSE_EVENT_BEFORE_BOOT_GUID signaled in fast boot path also

· _SaveValues without MessageBox

· Modal form support

· Support for grayout subtitle control

· Post message support for BBS popup menu

· Modify callback function behavior to match UEFI SPEC for submenu

· Ability to dump the Hii Pack from the Setup as part of TSE debug Infrastructure

· Print screen support in file browser feature

· Change resolution before boot in FastBoot path

· BGRT table header revision revised to 1 as per ACPI spec

· Moved password encoding part from binary to source

· Fool-proofing for BootOrder and LegacyDevOrder variables

Bug Fixes:

· Optimal Defaults are not loading on pressing ResetButton

· HDD pwd window title is not proper after enabling token TSE_SHOW_PROMPT_STRING_AS_TITLE inside setup

· Popup string control accepts CARRAGE_RETURN character while pressing CTRL+ENTER and causing page corruption

· Cursor is cleared after taking print screen on popup edit controls

· Fixed when post msg box overlapped with another message box then OK of top message box is consumed by further message box and so closing further message box

· Fixed system halt when 4GB memory installed with Quiet Boot enabled in 32 bit platform

· Fixed system hangs up when use the broken JPG file

· Resolved build error when tokens TSE_PRN_SCRN_EVENT_SUPPORT, TSE_DEBUG_MESSAGE are enabled in all flavors.

· Fixed HPKTool crashes when any suppressif, grayoutif, disableif present over the form

· Fixed issue in NameValue for string control

· Fixed issue faced in Interactive password and string controls

· Fixed setup hangs on first goto after entering from Shell twice. Using sendform.

· Fixed to not show post messages twice.

· System hangs while navigating SAS Card UEFI HII Page, when TSE_MULTILINE_CONTROLS is enabled.

· Dynamic parsing is modifying Checkbox controls optimal and failsafe defaults by setting size=1 irrespective of presence of defaults.

· Fix to load ffs from both FV and FV2 protocol.

· SETUP_GO_TO_EXIT_PAGE_ON_EXIT_KEY handled from binary.

· Boot Device name incorrect when defaults loaded.

· Fix to hide a page/show subpage as root page properly.

· TSE BootGetBBSOptionStatus asserts.

· Mouse shadow can’t refresh when mouse pointer is over top most of the screen.

· AMI small logo has damage on POST and boot.

· When User password alone is set, Setup gets hang in post while validating User Password.

· BIOS dialog box is crashed with special monitor (160, 53, 1280*1024).

· Ami Post Management functionalities reliant on ConOut need checks added.

· In Setup click\Touch from navigation window, options are not displayed properly.

· Boot override could not see all the devices when TSE_BOOT_NOW_IN_BOOT_ORDER is enabled with hidden boot options presented.

· Can't load default boot priorities if token "SETUP_SUPPORT_ADD_BOOT_OPTION" is enabled.

· Fixed to call ProcessProceedToBootHook function properly with respect to ShowPostMenu function.

· Multiline support for Hii String control does not wrap the string in some cases issues.

· Removed displaying error message for interactive string control.

· SAS controller card HII menus hang when selecting and HII pack update occurs.

4.6.2_TSE_2_15_1236

New Features:

· Support for ESRT.

· Support for EDID and maintaining native resolution.

· Tokenizing BootTimeout to control timeout value

· Provided help scrolling using ‘M’ and ‘K’ information in general help window

· Support REFRESH_ID for OrderedList and Password controls

· Option to display the post logo at (0, 0) graphics position.

· Support for choosing DISABLED_BOOT_OPTION and DISABLED_DRIVER_OPTION values at run time.

· Improvement for boots override options when firmware has a BootNext variable.

· Not waiting for key if fast boot is in progress.

· Adding AMIDiag guid default in setup.ini and uefisetup.ini.

· New token added to launch BBS popup with shift state also.

· Tokenized the feature for flushing keyboard after every key read.

· Tokenized the cursor support in password and string controls.

· Call stack operation for PostMenu with callback.

· Ordering root pages using ELINKS.

· Orphan page support in hpktool also.

· Support for suppressing multiline for one of options labels only.

· Optimized UefiHiiTestPrintLength function.

· Added submenu icon for driver health options.

· Improved TSE which does not access NVRAM during recovery.

· Include function "_RegisterShellGuid()" in fast boot path.

Bug Fixes:

· System gets hang while drawing message box when ConIn not present before launching TSE

· When first EFI device fails to boot then screen is not cleared properly

· Setup hangs on BBS Menu when string more than 200 characters

· Splash logo is not displayed when "Quiet boot" was enabled, and password was set

· Fixed "STYLE_DATE_FORMAT" sdl token to change the date display type to [yyyy/mm/dd] properly

· Fix for multiline display when non printable characters are presented.

· Fix for sendform to display properly when it called more than once.

· Fix to call the ProcessProceedToBootHook properly from DisplayPostMenu.

· Fix to call ActivateInput immediately once ConIn avails.

· Minisetup crashes after controller reconnection during Hii callback.

· Fix to provide multiline support properly for submenu control.

· EFI_BROWSER_ACTION_REQUEST_FORM_DISCARD fixed not to load the changed value.

· Fix to show long strings in listbox.

4.6.2_TSE_2_15_1234

New Features:

· Support to check for enabled device in BBS priority order before launching legacy boot.

· Saving password directly to NVRAM.

· Not loading defaults for password.

· Support to launch shell in particular mode.

· In no value is changed in BBS priorities then SetupConfigModifiedHook function won’t be invoked.

· Hii notifications created only when SETUP_RUNTIME_IFR_PROCESSING token is enabled.

· Support EFI_IFR_REFRESH_ID Opcode as per UEFI Spec.

· Triggering the amitsesetupenterguid for all possible cases.

Bug Fixes:

· Fix to show all BBS device when SETUP_SHOW_ALL_BBS_DEVICES token is enabled.

· Avoided build issue when TSE built with old core.

· Fix to load defaults properly with TseDefaultBootOrder module.

· Fix to load user defaults properly when variables from OPROM are removed in consecutive boots.

· Boot Order and Driver Order cases are handled properly in _PopupSelGetSelection() function.

· Fix to not allowing system to hang when submenu has no controls in it.

4.6.2_TSE_2_15_1231

General Bug Fixes:

· EIP101218: Fixed to allow multiple sendform before PostMangerhandshake.

4.6.2_TSE_2_15_1229

New Features:

General Bug Fixes:

· Invalidating the BGRT table when boot device launched from BBS popup or from shell or launched as second boot device or for shell boot.

· Fixed the Shift + "+" combination keys not working for numeric controls.

4.6.2_TSE_2_15_1227

New Features:

· Secondary boot path will not be happen for disabled devices.

· Support added not to wait for GOP notification to display the post screen through terminal.

· SETUP_DELAY_LOGO_TILL_INPUT token handled from binary.

· Support for LegacyBootFailHook() in TSE.

· On password window softkbd displayed only with required keys depend upon SETUP_STORE_KEYCODE_PASSWORD.

· For numeric controls softkbd displayed only with required keys for different numeric format like Decimal, Hexa etc.,

· Mouse drag support in frame and list box.

· Load/Save defaults without message box(silently).

· Support for REF4 type control.

· Optimised UefiHiiTestPrintLength function.

· Resolution restored while booting to the one maintained to display the logo.

· Extended Popup password customization options.

· Inconsistency checked only for valid pages

· Support added for following callback action requests

Ø EFI_BROWSER_ACTION_REQUEST_FORM_SUBMIT_EXIT

Ø EFI_BROWSER_ACTION_REQUEST_FORM_DISCARD_EXIT

Ø EFI_BROWSER_ACTION_REQUEST_FORM_APPLY

Ø EFI_BROWSER_ACTION_REQUEST_FORM_DISCARD

General Bug Fixes:

· Secure boot violation message box in UefiBootFailHook function leads to assert.

· Baud rate 9600 refresh screen twice in list box display.

· When pop-up window is invoked in setup and click on ESC icon or ESC/Right click in navigation frame, it will respond as two times ESC is clicked.

· Assert happened in Add/Del Boot/Driver option.

· TSE 1224 never called callbacks with EFI_BROWSER_ACTION_FORM_CLOSE when reset is required.

· Setup hangs when retrieve callback produces add/remove/update form.

· gFailsafeDefaults leads memory corruption between _MergeVariableListAndInfo and TseVarBuildAMIDefaults.

4.6.2_TSE_2_15_1226

New Features:

· OSIndications support

· Implemented BGRT logo calculation based on Windows-8 requirement

· SoftKbd activate functionality in BBS Menu by AMITSE instead of SoftKbd module

· Updating Min/Max values for date and time in UefiGetDateTimeDetails().

· Changing GetUefiSpecVersion as board module hook and also controlling callback spec version from TSE itself.

· Providing mouse functions as board module hook(mouse.c file)

General Bug Fixes:

· Combination of keys handled properly in checkoemkey functionality

· Handled partial keys properly

· Handled hidden boot options properly in BBS Popup menu when TSE_BOOT_NOW_IN_BOOT_ORDER and POPUP_MENU_SHOW_ALL_BBS_DEVICES are Disabled

· ISCSI attempt order handled properly to change its order.

· HDD Port Number is updated properly when using "TseDefaultBootOrder" module.

· Bug fixed to display YUV122 sampling JPEG images properly.

· System hangs at password prompt when Administrator password set alone and no boot devices presented with softkbd.

· Mouse pointer stuck at post. If mouse alone present then it will not be shown at post and initialized only in setup.

· Mouse pointer will not be destroyed by TSE when it is on SETUP icon during POST.

· Allowing EFI_BROWSER_ACTION_RETRIEVE action for all Interactive controls from MiniSetupEntry.

· ProcessProceedToBootHook() invoked when selecting ESC key in the BBS popup Menu.

· ProcessConInAvailability restricted to display Post messages more than once on the POST screen when it is hooked many times.

· SUT hangs when "Exit without saving" prompt is select as 'yes' in setup.

· Strings are cleared after calling PostManagerSwitchToPostScreen () function.

4.6.2_TSE_2_15_1224

New Features:

· Driver order support

· Add/Del driver option support

· Support for UEFI Load Options - USB WWID

· Support for keeping logos in ROMHole

· Security operations in BootOnly module instead of TSELite.

· Added few extra variables and guids in uefisetup.ini and setup.ini for porting purpose

· Support to uninstall BGRT for legacy boot

· Support for drag and drop to rearrange the items in the orderlist

· Displaying password prompt old, new and confirm texts in the same window in the Ezportplus style

· Avoided flickering when booted to UEFI OS for seamless boot

· Added AmiPostManager interface for text entry.

· Displayed page title of submenu pages in the menu tab

· TSE debug print infrastructure.

· Support for graying out the condition for readonly controls.

· Control STYLE_HELP_AREA_SCROLLBAR and TSE_MULTILINE_CONTROLS from binary

· Cursor visibility for string and password windows

· MainSetupLoop and ProcessBrowserActionRequest as board module hook

· MAX_MSGBOX_WIDTH introduced to control the message box width

· EFI_IFR_INCONSISTENT_IF to follow 28.2.5.9.2 as per efi spec 2.3.1

· Zeroing password related buffers before freeing it.

· Provision to change the Numeric string format

· Providing the alternative way for _ActionReadKey

· Exposing the Handle of the image that's being launched or boot. This will help other elinks to do the processing. Needed for CsmOptOut Feature.

· Support for queuing UpdatePack notifications

· "-"key looping in the time setting

· Clearing the Screen whenever boot to EFI Shell and not to UEFI OS

· _BBSSetDevicePriorities to check current BootPriority before assigning a new BootPriority

· Support for loading defaults for Orderlist controls

· Provisioning to set manufacturing default language

· Core changed to create the boot variables in upper case from version 4.6.4.1. So making the TSE_CAPITAL_BOOT_OPTION token compatible with core.

General Bug Fixes:

· Partial keys not handled properly

· Screen not cleared properly while showing "Secure boot violation" warning message

· Softkeyboard not launched for Password control in EzportPlus style module

· GEOMETRICSHAPE_RIGHT_TRIANGLE mark not added for AddBoot option in TSE advanced

· Updated Defaults for Checkbox controls which doesn't support scope

· Mouse pointer corruption in GTSE

· IDE security login dialog was not displayed properly and also password dialog label name displayed in text field

· BOOT_FLOW_NORMAL_INFINITE_LOOP enabled and pressing F7 while displaying "No option to boot to" is not working properly

· Time not working properly

· Non RTC date control - decreasing from year value 0001 displayed 65535 without closing bracket

· Decreasing YEAR field displayed yearr with XX before 2005 and after 2098.

· Text srting is not wrapped properly when TSE_MULTILINE_CONTROLS token enabled.

· Add driver option displays select boot option as title

· BOOT_FLOW_NORMAL_INFINITE_LOOP option is not working properly

· HDDSecurity module - Issue in login with TSE, Master password disabled

· Two boot option entries displayed with the single name value

· Unable to set the date and time with the soft keyboard and mouse

· Cursor is not blinking in string and password windows when "Softkbd" support enabled

· Circular reference is not updated after pack update which leads to RSOD

· Day of week is not properly calculated for 2012 in Setup

· Scrollbar functionality with mouse was not working properly and While Clicking the arrow buttons in scroll bar moves the entry up not the scroll bar.

· TSE_MULTILINE_CONTROLS does not work for all control types

· HII Screen Titles displaying the wrong information

· Dynamic Pages need to List FormSet title instead of Form Title.

· Callback was invoked during periodic update for time and date controls without EFI_IFR_REFRESH_OP.

· BootFlow variable uses inconsistent attributes

· Incorrect static strings retrieved

· Callback for Date and Time doesn't pass the new value

· Progress bar in MSGBOX_TYPE_PROGRESS never displays the full 100%

· Maximum 8 byte signed integer not working properly

· System Time is not updated every second

· String wrapping corrected for one of option control.

· OffBoard card pages should begin with an > (arrow/sideways triagle)

· HDD user password and Admin password entries are disappeared after "Launch EFI shell from File system ".

· Softkbd will be displayed for date and time only when selected with mouse. Softkbd can be escaped by clicking outside of the mouse.

· Softkbd will be displayed only when selected with mouse.

· Mouse and SoftKbd does not work after displaying "No option to boot to" in POST.

· SoftKbd flickers when positioned near Top/Left end of the screen display.

· Stopping all the timers for mouse drivers before existing setup

· Mouse pointer gets disappear after selecting “Launch EFI shell from File system”.

· TSE hangs while clicking on the "link training time out". Handled the invalid range reporting in numeric control properly when mouse presented.

· Help page scroll bar not moving till end.

· System hangs with latest scudriver.efi

· Mouse pointer gets disappear after selecting “Launch EFI shell from FileSystem” without any filesystem.

· Orderlists not saving the correct value for next reboot

· If logo.ffs not present in TSE then BGRT table not formed for badging images

· Accepts invalid string for string control, mismatch in string length

· Setup Crash when iSCSI is loaded

· System execption error if print string +"*" in Japanese & French

· BIOS gets stuck in infinite loop On enabling TSE_LOAD_OPTION_HIDDEN token,

In first boot incorrect devices is disabled in Setup & BBS table but in second boot the correct device is disabled in both places.

· System hangs when there is no valid boot option to boot - EIP71223.

· Setup page Menu tab gets selected even when the click is below the menu separator line

· In Date and Time item Press Shift+Tab key can't move previous field

· Build fails when SETUP_BBS_POPUP_ENABLE is enabled and SETUP_ALT_ENTRY_ENABLE is disabled.

· Keyattribute support doesn't work in AMITSE Keymon support

· POST Logo 1024x768 not displayed properly

· English strings appears intermediately when Chinese is a current language

· Default bootorder is not loading for loading defautls

· Pressing esc from main menu is not showing the exit msgbox

· In serial redirection set to 9600bps, the BBS Popup menu goes away as soon as it appears.

· Password window hangs while pressing ESC.

· Advance page disappears when offline pages are updated dynamically.

· On Pressing ESC, the token SETUP_GO_TO_EXIT_PAGE_ON_EXIT_KEY key doesn’t work in UEFI2.1

· Setup: Boot Option Priority list items truncated, until you move within the tab.

· PCIe adapters incompatible to AMI setup engine

4.6.2_TSE_2_14_1219

New Features:

· Support for software created boot entry for USB.

· Boot manager algorithm for driver health protocol.

· Name value support.

· BGRT support for version 1.2

· Non removable media boot.

· Hot key boot.

· Load option hidden support.

· PNG support.

· Signed numeric value support.

· Handling mouse clicks in application level.

· Changing the quiet boot mode based on the screen resolution.

· REF2,REF3 and REF4 and default 2 support.

· Disabling BIOS signon message in post screen.

· Added BOOT_FLOW_CONDITION_PCI_OUT_OF_RESOURCE boot flow entry.

· Updating string token value dynamically for Title Bar and Copyright messages

· Silently Loading the Defaults including Boot Order Defaults.

General Bug Fixes:

· Fix to show the dynamic pages properly.

· Fix to not show the "Save & reset" twice.

· Fix to edit the time field when using new time format.

· Fix to hide the main Page when pressing F2 to enter setup.

· Fix to not miss the first password get status.

4.6.2_TSE_2_13_1213

New Features:

· UEFI 2.3 Support

Ø FormBrowser extended actions support

Ø Support the different default stores in UEFI 2.1 specification other than Standard and Manufacturing.

Ø Support for EFI_IFR_LOCKED opcode

Ø Support for EFI_IFR_RESET_BUTTON opcode

Ø Support for EFI_IFR_NO_SUBMIT_IF opcode

Ø Support for EFI_IFR_DEFAULT opcode

Ø Support for EFI_IFR_VERSION opcode

· Support to Move the Dynamic IFR Pages under subpages.

· Mouse support to select the system device entries during "Add boot option" in file browser support.

· Supported different style modules which includes EzportPlus and Legacy Styles Modules.

· Support to display Multiple GIFs and display other image format when Active animated Gif is displaying

· Support to hide the disabled device in boot override menu and the boot popup menu

· Hooks for Softkeyboard/Touch Screen Support.

· Support to work with new mouse driver (Label : 4.6.0-MOUSE_SUPPORT-006).

General Bug Fixes:

· Fix to properly suppress the interactive controls.

· Fix to show the title string properly

· Fix to update the defaults properly in the UEFI 2.0 version when Defaults loaded from HII.

· Fix to update the Interactive One of Control properly in UEFI 2.0.

· Fix to repeat animating the gif logo until the boottimeout.

· Fix to exit the PostMenu loop properly after the PostMenu exit from callback.

· Fix to redrawing the Post menu after the callback function gets executed

· Fix to not highlight the separator in a Post menu.

· Fix for proper working of BBS popup menu functionality if a device is added after a boot and then resetting the system.

· Fix for to avoid considering Esc, Caps, Num and Scroll Lock keys as selection key in post menu.

· Fix to remove the invalid strings appears for the network devices when GROUP_BOOT_OPTIONS_BY_TAG token is enabled.

· Fix to show the help frame properly if the location are customized.

· Fix the build error when the project is build without Main.vfr.

4.6.2_TSE_2_11_1210

New Features:

· Support for the Add boot option related controls to select the input using file browser.

· Added a new interface GetAttribute in AMI POST manager protocol and updating the DisplayPostMessageEx interface.

· Fixed Limits for TSE Controls, Pages and Variable etc from HPK tool.

· Support to build AMITSE without NVRAM module support.

· Support to configure Post Menu programmatically, for the requested items (Exit Keys, Font Colors and Background Colors).

· Support for UEFI 2.2 requirements related to Calling Formcallback with EFI_BROWSER_ACTION_CHANGING and EFI_BROWSER_ACTION_CHANGED action.

· Tokenized the Max Drive (MAX_DRIVE_NAME) Macro as TSE_MAX_DRIVE_NAME.

· Support to create Logo Support information Table

· Warning message for Variable Size mismatch is not shown correctly. Setup data was updated to hold Max variable size supported. Before that fix Warning was shown for non matching case.

· To support the Differ Default Stores in UEFI 2.1 Specifications other than Standard and Manufacturing.

· Support to Override the Setup.ini path.

· Enabled AMIKeyCode protocol support by Default. Needs TSE sources to turn off this protocol.

General Bug Fixes:

· Fix to show BIOS gui scroll bar indicate that there are more options available on the Advanced | CPU Configuration page.

· Fix to handle PostMangarProtocol Interfaces right if GOP is stopped and started as it is initially installed.

· Resolved the issue of system hangs on CP06 when go to SETUP if updated core to 4641 and added TSE source and X64 = 0.

· Resolved Shift key combinations to work properly.

· Fix to show Invalid Password Error message in POST properly, If the SETUP_PASSWORD_LENGTH Changed to smaller then while entering Password in POST.

· Fix to screen corruption issue with Post Manager's DisplayMsgBox displays When the French or Japanese languages are selected.

· Fix to the issue when setting both Date & Time controls of setup menu do not display gray-out color when the controls are in the gray-out state.

· Fix to the issue PostManagerDisplayMenu does not dynamically update Menu Title on language change

· Fix to the issues with grayingout the BBS priorities is not working and for UEFI 2.0 only supporess the first one.

· Fix to the issue while editing Date and Time control pressing Pageup/PageDown/Home keys causes to leave Date&Time in the Edit state but changes focus.

· Fix to the issue if the String length is different in different languages, Changing language causes TSE multiline function to not work correctly.

· Fix to Memory Leaks in Language reading functions.

· Fix to the issues with ISCSI Pages.

· Fix to the issue when some user action on PCIx with UEFI Hii Pages causes Setup screen pages and menu disappeared.

· Fixed the typo errors in AMITSE module.

· [TAG] EIP47274

· [Category] BUG FIX

· [Symptom] UefiHPKTOOL report error code '0x80000007'.

· [RootCause] reporting error because of a memory corruption

· [Solution] fixed the issue with memory allocation

· [Files] uefihpktool.exe

4.6.2_TSE_2_10_1208

New Features:

· Support to allow POST Screen scrolling for a defined region of the screen

· Support to add OEM multiple header files to TSE 2.x.

· Support to load defaults from NVRAM Defaults.

· Support to preserve the order of disabled BBS boot devices.

· Extended Message Box support via Post Manager interface

· Post menu support via Post Manager interface

· BBSPopup using Post Menu interface

· Control Mapping with gTseControlMap Table. Makes the Controls Customized/Added without modifying TSE Lite Sources

· Progress Box support via Post Manager interface

· Dynamic Parsing of HII. To support showing pages updated via Driver callback.

· ProcessProceedtoBootNow hook added.

· Support to add multiple OEM Key Hook functions in the Post screen

· Date/Time control Improvement to support TSE 2.01 spec Completely

· Sign ON Message Support in POST Screen.

· TSE as Setup Browser driver Support

· TSE Building support with out CSM module in the project

· BBSGetNonStandardGroupType Board module Hook function added to support latest BDS customization to create non-standard group type

· SETUP_PRINT_ENTER_SETUP_MSG Token to Control the Setup Entry String display

· Support to override HDD security calls. They made as board module hooks

· TSE_DEVICE_PATH_NAME support for all the device BBS Device types and support for EFI boot options also

· Support to show updated post menu string from post menu callback

· New hook ProcessUIInitHook added to call before.

· Support to work TSE and FASTBOOT together. Need FastBoot Module 4.6.4.0_Fast_Boot_09 or Above.

· Support from HPK tool to use default value instead of 0 if Manufacturing flag is not set for a setup question

· Alternate setup style support

· Support to work with customized Groups of BBS Devices with TSE_CONTINUE_BOOT_NOW_ON_FAIL.

· Support for controlling Storing Disabled BBS device's Device path in NVRAM via TSE_SAVE_DISABLED_BBS_DEVICEPATH Sdl token.

· [TAG] EIP35562

· [Category] IMPROVMENTS

· [Description] Support to create capital boot variables names.

· [Solution] SDL token TSE_CAPITAL_BOOT_OPTION provides that support.

· [Files] AmiTSE.SDL ,Boot.h , CommonHelper.c, Callback.c , AddBootOption.c

General Bug Fixes:

· Fix to make TSE 2.0x Binary module to work with older Cores

· Fix to not to Free the Logo ImageData multiple times.

· Fix to Support more then 256 pages.

· Fix for making sure to make the Variable to NULL after it is Freed up.

· Fix for suppressif used with grayout condition. Before this fix some condition was broken in UEFI 2.0

· Fix to the Menu title issue, in case of the string length is more than the screen width.

· Fix to included the OEM Header files for Exit page options

· Screen corruption happens when we use mouse to select different Menu in Setup

· Fix issues with "SETUP_PASSWORD_NON_CASE_SENSITIVE" SDL token

· Resolved the build issues with SETUP_FORM_BROWSER_SUPPORT

· Filtering Password Characters support

· Fix for the issues with GetCurPos()

· Fix the screen corrupt issue if boot from setup fails

· Fix issues with PreSystemResetHookHook. TSE want not calling the right hook function.

· Fix PostManagerDisplayProgress issues related to updating the message.

· Fix to return the right error status from PostManagerDisplayMenu

· Fix issue with Post popup menu with Hidden attribute.

· Fix build issues with because of some Non english unicode characters found in Tse sources

· Fix the issues with help frame scrolling

· Fix for Add password install status string in UEFI 2.1 hang up

· Fix to boot with TSE_PRESERVE_DISABLED_BBS_DEVICE_ORDER when first Boot option is disabled.

· Fix for Crash issue with UEFI 2.0 Runtime Parsing.

· [TAG] EIP36092

· [Category] BUG FIX

· [Symptom] UEFI 2.1 Error logging page hangs. Fix made in UEFI 2.1 Module

· [RootCause] --

· [Solution] Fixed in below file.

· [Files] Uefi21wrapper.c

· [TAG] EIP38608 and 39117

· [Category] BUG FIX

· [Symptom] Build fail at Hpktool.bat

· [RootCause] --

· [Solution] Fix made in hpktool.exe

· [Files] HpkTool.exe

· [TAG] EIP38197

· [Category] BUG FIX

· [Symptom] There is an input password error when password support Scan Code. Password with Scancode with failing for 9 and = keys

· [RootCause] Issue with wrapping the string in case of password.

· [Solution] skipped wrapping the string in case of popup password.

· [Files] PopupEdit.c

· [TAG] EIP39570 and EIP38555

· [Category] BUG FIX

· [Symptom] Setup menu can fit into one page even with enough space

· [RootCause] issue with handling the setup menu width

· [Solution] Utilize the space available in the menu bar to fill the titles

· [Files] Menu.c

4.6.2_TSE_2_01_1204

New Features:

· UEFI 2.1 Support. need Core version 4.6.4.0

· EIP-24971: TSE features need to be controlled from TSE binary.

· EIP-25075/24971: Hii functions moving from binary to UEFI module

· EIP-25288: To support Terminal host with high resolution.

· EIP-25416: Support have 1/10 sec Timeout (SETUP_TIMEOUT_IN_TENTHOFSEC)

· EIP-28005: A new interface PostManagerSetAttribute added in AMI_POST_MANAGER_PROTOCOL

· EIP-27161/29095: Added support for reserved boot options and conditions to not allow empty boot options

· EIP-28501: Updated for Keyboard scancode as password. Added a new Token SETUP_STORE_KEYCODE_PASSWORD to support the EFI key or Scan code as password

· Support for FAST Boot. To not depend on Console control and Conout. Stop handling the notification if we entered

· Image Support can control by binary module.

· Load setup defaults made as hook function.

· Hook function PreResetSystemHook added for any customizations before system reset.

· TSE Version numbers are SDL tokens

· Added support for handling string characters --- \n, \r in Post message

· Navigation help for mouse added

· OEM Special controls support

· Configurable mouse actions

· Support to Add strings from board or other modules to TSE.

· Support to override TSE strings (need Aptio 4.6.4.0 and Tools Label "4.5.5_Tools_30")

· TSE doesn't depend on default Board/OEM modules. If the Porting done to a platform from this version of TSE. It should reusable with later labels of TSE without any changes.

· Hpktool.exe v2.01.1024 and UefiHpktool.exe v2.11.1025 added.

· Ability to add NVRAM Defaults using Hpktool

· Ability to set the Default language using Hpktool

General Bug Fixes:

· Logo security updated

· EIP-26473: To support uppercase Hex numbers

· EIP-21807: Multi language issue

· EIP-22305: Fix for improper JPEG Image size calculation logic

· EIP-23354: Password encoding bug fix

· EIP-24980: Fix to properly display right area text

· EIP-24991: MultiLanguage Screen corruption issue.

· EIP-25092: Fix to Use the HiiChangeString () to Add the string for morethen one langs.

· EIP-25987: Load Optimized Defaults (F3) hangs in an empty page. Fixed by checking whether the frame has any controls before performing operations on a control.

· EIP-26029: Fix: UefiCreateOneOfWithOptionsTemplate() does not always return NULL when EfiLibAllocateZeroPool() returns NULL

· EIP-26893: string truncation issues in case of DisplayPostMessage() called multiple times

· EIP-28007: Flash all the screen in case of post message printed in the Quiteboot by using Set cur position

· EIP-28247: Fix for grayout color menu string not being grayed out.

· EIP-28551: Fixed TSE 2.0 Build error related to SETUP_STORE_EFI_KEY_PASSWORD and TSE_USE_AMI_EFI_KEYCODE_PROTOCOL

· EIP-28577: Fix to avoid "Checker: SIGN_EXTENSION"

· EIP-30111: fixed the issue to update the help if STYLE_PAGE_FIRSTITEM_FOCUS token enabled.

· EIP-31606: Fix for hanging issue in case of no active controls in a frame

· EIP-32242: Modified DrawBorder fn to check if Width or Height is zero

· EIP-32318: Fix for the crash issue when the page has many controls.

· EIP- 32350/32445: To fix the Add/Delete Boot option issues with TSE 2.0.

· EIP-32501: Fix to handle the Conditional control Focusing , in the Subform

· EIP-33804: Issue iSCSI initiator name is not saved.

· EIP-33837: Setup appearance corrupted if additional subtitles added Fix - Prevent memo draw if suppressed condition

· EIP-34119: Fix to solve issues, if the boot option name is set with max number of characters allowed.

· EIP-34679: Typo error fix

· To fix issue with BBS popup when more than 20 boot options are present

· To fix the Screen corruption if mouse pointer is on the popup.

· Legacy boot option can't be deleted.

· EIP 35522: Fix for Interactive control in TSE

· EIP 35517: Fix for UefiHpktool to work correctly for Interactive text/action control.

· Build issues with EDK module support resolved.

· SendForm interface in FormBrowser and FormBrowser2 protocol validates the HiiHandles passed.

4.6.2_TSE_2_00_1201

New Features:

· Hot Keys as Elinks

· Exit Page Callbacks as Elinks

· Control Keys as Elinks

· Customizable Page Order

· Advanced String Customization

· Board Module for Board specific customizations

· OEM Module

· Password Customization

· OEM Strings Customization

· Customizable Style Module

· UEFI2.0

· Ability to build with/without EDK.

General Bug Fixes:

· This is the first TSE2.0 product release

© American Megatrends Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • Action.c
  • action.h
  • AddBootOption.c
  • AddDelBootDrvOpts.sd
  • AMILogo.c
  • AMILogo.h
  • amiver.h
  • application.c
  • application.h
  • Aptio Modules
  • bbs.c
  • bbs.h
  • boot.c
  • box.c
  • box.h
  • buffer.c
  • buffer.h
  • callback.c
  • callback.h
  • control.c
  • ctrlcond.c
  • ctrlcond.h
  • Date.c
  • Date.h
  • dobmpmgr.c
  • dogif.c
  • dogifmgr.c
  • edit.c
  • edit.h
  • EDKhelper.c
  • EDKhelper.h
  • Expression.c
  • EZPORT SDL Tokens
  • ezport.c
  • ezport.h
  • ezportplus.c
  • ezportplus.h
  • FormBrowser.c
  • FormBrowser2.c
  • FormBrowser2.h
  • frame.c
  • frame.h
  • globals.c
  • hii.c
  • hii.h
  • Hiicallback.c
  • HiiNotificationHandler.c
  • hiistring.c
  • hiistring.h
  • hiistring20.c
  • hiistring21.c
  • HookAnchor.c
  • hotclick.c
  • hotclick.h
  • hotkey.c
  • hotkey.h
  • iJpeg.c
  • ipcx.c
  • jpeg.h
  • jpeg6.c
  • Jpeg6.h
  • Label.c
  • Label.h
  • legacy.c
  • legacy.h
  • ListBox.c
  • ListBox.h
  • logo.c
  • mem.c
  • Memo.c
  • Memo.h
  • Menu.c
  • Menu.h
  • MessageBox.c
  • MINISETUP SDL Tokens
  • minisetup.c
  • minisetup.h
  • minisetupext.c
  • minisetupext.h
  • Mouse.c
  • MyDefs.h
  • notify.c
  • numeric.c
  • numeric.h
  • object.c
  • object.h
  • ordlistbox.c
  • ordlistbox.h
  • page.c
  • page.h
  • Parse.c
  • password.c
  • password.h
  • PasswordEncode.c
  • PasswordEncode.h
  • pcx.h
  • pcxc.c
  • png.c
  • png.h
  • pnguncmp.c
  • popup.c
  • popup.h
  • PopupEdit.c
  • PopupEdit.h
  • PopupPassword.c
  • PopupPassword.h
  • PopupSel.c
  • PopupSel.h
  • PopupString.c
  • PopupString.h
  • postmgmt.c
  • postmgmtext.c
  • print.c
  • protocol.c
  • ResetButton.c
  • ResetButton.h
  • Resources.c
  • screen.c
  • special.c
  • special.h
  • string.c
  • string.h
  • style.c
  • style.h
  • stylecommon.c
  • StyleHook.h
  • StyleHook.mak
  • styleHook1.c
  • styleHook10.c
  • styleHook11.c
  • styleHook12.c
  • styleHook13.c
  • styleHook14.c
  • styleHook15.c
  • styleHook16.c
  • styleHook17.c
  • styleHook18.c
  • styleHook19.c
  • styleHook2.c
  • styleHook20.c
  • styleHook21.c
  • styleHook22.c
  • styleHook23.c
  • styleHook24.c
  • styleHook25.c
  • styleHook26.c
  • styleHook27.c
  • styleHook28.c
  • styleHook29.c
  • styleHook3.c
  • styleHook30.c
  • styleHook31.c
  • styleHook32.c
  • styleHook33.c
  • styleHook34.c
  • styleHook35.c
  • styleHook36.c
  • styleHook37.c
  • styleHook38.c
  • styleHook39.c
  • styleHook4.c
  • styleHook5.c
  • styleHook6.c
  • styleHook7.c
  • styleHook8.c
  • styleHook9.c
  • StyleTokens.c
  • SubMenu.c
  • SubMenu.h
  • Text.c
  • Text.h
  • time.c
  • Time.h
  • timer.c
  • Timer.h
  • TSE Help Module
  • TSEADVANCED SDL Tokens
  • TseAdvanced.c
  • TSELITE SDL Tokens
  • TseLiteCommon.c
  • TseLitehelper.c
  • TseOEM.C
  • TsePasswordEncode.c
  • TseUefiHii.h
  • UEFI20 SDL Tokens
  • uefi20Wapper.c
  • UEFI21 SDL Tokens
  • Uefi21Wapper.c
  • UefiAction.c
  • UefiAction.h
  • UefiTianoHii.h
  • variable.c
Built on 16:20:23 10/01/14


Action.c

Description:
This file contains code to handle different actions.

The following functions are used in the file: Action.c.

Function | Description
_ActionInstallTimer | Function to install action timer
_ActionReadKey | Function to read a key.
_ActionReadMouse | Function to get mouse action
_ActionTimer | Function action timer
ActionClearAction | Function to clear actions
ActionCreate | Function to create an action.
ActionDestroy | Function to destroy an action.
ActionGetAction | Function to get an action.

Built on 16:20:18 10/01/14


_ActionInstallTimer in the Action.c

Function : _ActionInstallTimer

File: Action.c
Description:
Function to install action timer
Input:
ACTION_DATA *action, UINT64 TriggerTime
Output:
VOID
Built on 16:20:03 10/01/14


_ActionReadKey in the Action.c

Function : _ActionReadKey

File: Action.c
Description:
Function to read a key.
Input:
AMI_EFI_KEY_DATA *pAmiKey, UINT64 Timeout
Output:
status
Built on 16:20:03 10/01/14


_ActionReadMouse in the Action.c

Function : _ActionReadMouse

File: Action.c
Description:
Function to get mouse action
Input:
MOUSE_INFO *MouseInfo
Output:
STATUS
Built on 16:20:03 10/01/14


_ActionTimer in the Action.c

Function : _ActionTimer

File: Action.c
Description:
Function action timer
Input:
EFI_EVENT Event, VOID *Context
Output:
VOID
Built on 16:20:03 10/01/14


ActionClearAction in the Action.c

Function : ActionClearAction

File: Action.c
Description:
Function to clear actions
Input:
ACTION_DATA *action
Output:
STATUS
Built on 16:20:04 10/01/14


ActionCreate in the Action.c

Function : ActionCreate

File: Action.c
Description:
Function to create an action.
Input:
ACTION_DATA **object
Output:
status
Built on 16:20:04 10/01/14


ActionDestroy in the Action.c

Function : ActionDestroy

File: Action.c
Description:
Function to destroy an action.
Input:
ACTION_DATA *action, BOOLEAN freeMem
Output:
status
Built on 16:20:04 10/01/14


ActionGetAction in the Action.c

Function : ActionGetAction

File: Action.c
Description:
Function to get an action.
Input:
ACTION_DATA *action
Output:
status
Built on 16:20:04 10/01/14


action.h

Description:
Header file for code to handle different actions.
Built on 16:20:18 10/01/14


AddBootOption.c

Description:
This file contains code to handle the Add boot option operation.

The following functions are used in the file: AddBootOption.c.

Function | Description
_DevicePathToStr | Convert Device Path of type to string. Str is allocated by this routine. It must be freed by the caller.
_DisableRestorePrevOptions | Function to make the boot/driver option as disable in bootorder/driverorder if it is inactive and non hidden
_GetFsLists | function to get the file system details
_HWToStr | Convert Device Path of type to string.
_MEDIAToStr | Convert Device Path of type to string.
_MSGToStr | Convert Device Path of type to string.
_UnknownToStr | Convert Device Path of type to string.
ACPIToStr | Convert Device Path of type to string.
AddFileTypeEntry | Creates a new entry in the FILE_TYPE array and adds the current File into the array.
BootAddBootOption | Function to add boot option
BootDelBootOption | Function to handle the del boot option
CheckDirectoryType | Checks if the EFI_FILE_INFO is a directory (and not the current directory)
CheckExtension | Check is the EFI_FILE_INFO has the same extension as the extension passed in the second parameter
CleanFileTypes | Frees all allocated memory associated with the FILE_TYPE structure and resets the InternalString current strings next available string token to be the first dynamically added string
CreateFileList | Parse all the files in the current directory and add valid files to the FILE_TYPE list and update the filecount
DiscardAddDelBootOptions | Function to discarding the add/del boot option
DiscardAddDelDriverOptions | Function to discarding the add/del driver option
DisplayFileListMenu | Display a menu of the FILE_TYPE items and return the selected item in the Selection
DriverAddDriverOption | Function to add driver options
DriverDelDriverOption | Function to handle the del Driver option
FileBrowserLaunchFilePath | To select the Boot file for the new boot option with the help of file browser.
FileBrowserLaunchFileSystem | To select the File System for the new boot option with the help of file browser.
FindInsertionIndex | Finds the inded where directories items turn into file items
SaveAddDelBootOptions | function to save the added/deleted boot option
SaveAddDelDriverOptions | Function to save the added/deleted Driver option
TSELiteFixAddBootOptionFileList | Function to fix Add Boot Option file list
TseUpdateAddDeleteBootVar | Function to update add and delete boot variables
TseUpdateAddDeleteDriverVar | Function to update add and delete driver variables
UpdateFilePathString | To create the File Path string based on the file selected.

Built on 16:20:18 10/01/14


_DevicePathToStr in the AddBootOption.c

Function : _DevicePathToStr

File: AddBootOption.c
Description:
Convert Device Path of type to string. Str is allocated by
this routine. It must be freed by the caller.
Input:
IN EFI_DEVICE_PATH_PROTOCOL	*Path - Device Path
Output:
OUT UINT16			*Str  - String form of device path.
Notes:

Built on 16:20:03 10/01/14


_DisableRestorePrevOptions in the AddBootOption.c

Function : _DisableRestorePrevOptions

File: AddBootOption.c
Description:
Function to make the boot/driver option as disable in bootorder/driverorder
        if it is inactive and non hidden
Input:
BOOLEAN , UINT16 **, UINTN
Output:
VOID
Built on 16:20:03 10/01/14


_GetFsLists in the AddBootOption.c

Function : _GetFsLists

File: AddBootOption.c
Description:
function to get the file system details
Input:
None
Output:
None
Built on 16:20:04 10/01/14


_HWToStr in the AddBootOption.c

Function : _HWToStr

File: AddBootOption.c
Description:
Convert Device Path of type to string.
Input:
IN EFI_DEVICE_PATH_PROTOCOL	*Path - Device Path
OUT UINT16			*Str  - String form of device path.
Output:
int - number of characters not including \0 or -1 if error.
Notes:

Built on 16:20:04 10/01/14


_MEDIAToStr in the AddBootOption.c

Function : _MEDIAToStr

File: AddBootOption.c
Description:
Convert Device Path of type to string.
Input:
IN EFI_DEVICE_PATH_PROTOCOL	*Path - Device Path
OUT UINT16			*Str  - String form of device path.
Output:
int - number of characters not including \0 or -1 if error.
Notes:

Built on 16:20:04 10/01/14


_MSGToStr in the AddBootOption.c

Function : _MSGToStr

File: AddBootOption.c
Description:
Convert Device Path of type to string.
Input:
IN EFI_DEVICE_PATH_PROTOCOL	*Path - Device Path
OUT UINT16			*Str  - String form of device path.
Output:
int - number of characters not including \0 or -1 if error.
Notes:

Built on 16:20:04 10/01/14


_UnknownToStr in the AddBootOption.c

Function : _UnknownToStr

File: AddBootOption.c
Description:
Convert Device Path of type to string.
Input:
IN EFI_DEVICE_PATH_PROTOCOL	*Path - Device Path
OUT UINT16			*Str  - String form of device path.
Output:
int - number of characters not including \0 or -1 if error.
Notes:

Built on 16:20:04 10/01/14


ACPIToStr in the AddBootOption.c

Function : ACPIToStr

File: AddBootOption.c
Description:
Convert Device Path of type to string.
Input:
IN EFI_DEVICE_PATH_PROTOCOL	*Path - Device Path
OUT UINT16			*Str  - String form of device path.
Output:
int - number of characters not including \0 or -1 if error.
Notes:

Built on 16:20:04 10/01/14


AddFileTypeEntry in the AddBootOption.c

Function : AddFileTypeEntry

File: AddBootOption.c
Description:
Creates a new entry in the FILE_TYPE array and adds the current File into
the array.
Input:
FILE_TYPE **List - Array of FILE_TYPE structures alread found
UINTN *FileCount - number of entries in the FILE_TYPE array
EFI_FILE_INFO *FileInfo - file info of the file that should be added
Output:
Returns:

Built on 16:20:05 10/01/14


BootAddBootOption in the AddBootOption.c

Function : BootAddBootOption

File: AddBootOption.c
Description:
Function to add boot option
Input:
VOID
Output:
VOID
Built on 16:20:05 10/01/14


BootDelBootOption in the AddBootOption.c

Function : BootDelBootOption

File: AddBootOption.c
Description:
Function to handle the del boot option
Input:
UINT16 index
Output:
VOID
Built on 16:20:05 10/01/14


CheckDirectoryType in the AddBootOption.c

Function : CheckDirectoryType

File: AddBootOption.c
Description:
Checks if the EFI_FILE_INFO is a directory (and not the current directory)
Input:
EFI_FILE_INFO *File
Output:
Returns:
BOOLEAN - TRUE - item is a directory, and not the current directory
     FALSE - item is not a directory, or is the current directory
Built on 16:20:05 10/01/14


CheckExtension in the AddBootOption.c

Function : CheckExtension

File: AddBootOption.c
Description:
Check is the EFI_FILE_INFO has the same extension as the
extension passed in the second parameter
Input:
EFI_FILE_INFO *File - The file entry whose extension should be checked
CHAR16 *ExtensionEfi - the extension
Output:
Returns:
BOOLEAN - TRUE - The extension matches
     FALSE - the extension does not match
Built on 16:20:05 10/01/14


CleanFileTypes in the AddBootOption.c

Function : CleanFileTypes

File: AddBootOption.c
Description:
Frees all allocated memory associated with the FILE_TYPE structure
and resets the InternalString current strings next available string token
to be the first dynamically added string
Input:
FILE_TYPE **FileList - The array of FILE_TYPE structures found in
a directory
UINTN *FileCount - pointer to the number of entries in the FileList
Output:
Returns:

Built on 16:20:06 10/01/14


CreateFileList in the AddBootOption.c

Function : CreateFileList

File: AddBootOption.c
Description:
Parse all the files in the current directory and add valid files to the
FILE_TYPE list and update the filecount
Input:
EFI_FILE_PROTOCOL *FileProtocol - the current direcotry to parse
Output:
FILE_TYPE **FileList - pointer in which to return the array of FileType items
UINTN *FileCount - the count of filetype items discovered
Returns:
EFI_STATUS
Built on 16:20:06 10/01/14


DiscardAddDelBootOptions in the AddBootOption.c

Function : DiscardAddDelBootOptions

File: AddBootOption.c
Description:
Function to discarding the add/del boot option
Input:
VOID
Output:
VOID
Built on 16:20:06 10/01/14


DiscardAddDelDriverOptions in the AddBootOption.c

Function : DiscardAddDelDriverOptions

File: AddBootOption.c
Description:
Function to discarding the add/del driver option
Input:
VOID
Output:
VOID
Built on 16:20:06 10/01/14


DisplayFileListMenu in the AddBootOption.c

Function : DisplayFileListMenu

File: AddBootOption.c
Description:
Display a menu of the FILE_TYPE items and return the selected item
in the Selection
Input:
FILE_TYPE *FileList - List of FILE_TYPE items to display in the menu
UINTN FileCount - the number of FILE_TYPE items in the list
Output:
UINT16 *Selection - The index of the selected FILE_TYPE item
Returns:

Built on 16:20:06 10/01/14


DriverAddDriverOption in the AddBootOption.c

Function : DriverAddDriverOption

File: AddBootOption.c
Description:
Function to add driver options
Input:
VOID
Output:
VOID
Built on 16:20:07 10/01/14


DriverDelDriverOption in the AddBootOption.c

Function : DriverDelDriverOption

File: AddBootOption.c
Description:
Function to handle the del Driver option
Input:
UINT16 index
Output:
VOID
Built on 16:20:07 10/01/14


FileBrowserLaunchFilePath in the AddBootOption.c

Function : FileBrowserLaunchFilePath

File: AddBootOption.c
Description:
To select the Boot file for the new boot option with the help of file browser.
Input:
VOID
Output:
File Path string
Returns:
EFI_STATUS
Built on 16:20:07 10/01/14


FileBrowserLaunchFileSystem in the AddBootOption.c

Function : FileBrowserLaunchFileSystem

File: AddBootOption.c
Description:
To select the File System for the new boot option with the help of file browser.
Input:
VOID
Output:
Selected File System Index
Returns:
EFI_STATUS
Built on 16:20:07 10/01/14


FindInsertionIndex in the AddBootOption.c

Function : FindInsertionIndex

File: AddBootOption.c
Description:
Finds the inded where directories items turn into file items
Input:
FILE_TYPE *List - the current array of File Type structures
UINTN FileCount - the count of File Type structures in the array
Output:
Returns:
the index to insert a new item
Built on 16:20:07 10/01/14


SaveAddDelBootOptions in the AddBootOption.c

Function : SaveAddDelBootOptions

File: AddBootOption.c
Description:
function to save the added/deleted boot option
Input:
VOID
Output:
VOID
Built on 16:20:14 10/01/14


SaveAddDelDriverOptions in the AddBootOption.c

Function : SaveAddDelDriverOptions

File: AddBootOption.c
Description:
Function to save the added/deleted Driver option
Input:
VOID
Output:
VOID
Built on 16:20:14 10/01/14


TSELiteFixAddBootOptionFileList in the AddBootOption.c

Function : TSELiteFixAddBootOptionFileList

File: AddBootOption.c
Description:
Function to fix Add Boot Option file list
Input:
CONTROL_DATA *ControlData
Output:
VOID
Built on 16:20:16 10/01/14


TseUpdateAddDeleteBootVar in the AddBootOption.c

Function : TseUpdateAddDeleteBootVar

File: AddBootOption.c
Description:
Function to update add and delete boot variables
Input:
None
Output:
None
Built on 16:20:17 10/01/14


TseUpdateAddDeleteDriverVar in the AddBootOption.c

Function : TseUpdateAddDeleteDriverVar

File: AddBootOption.c
Description:
Function to update add and delete driver variables
Input:
None
Output:
None
Built on 16:20:17 10/01/14


UpdateFilePathString in the AddBootOption.c

Function : UpdateFilePathString

File: AddBootOption.c
Description:
To create the File Path string based on the file selected.
Input:
CHAR16 *FilePath  - Buffer to fill with the file path
CHAR16 * CurFile  - current file selected
UINT16 idx        - Index of the file in the current directory
Output:
CHAR16 *FilePath - Updated File Path
Returns:

Built on 16:20:18 10/01/14


AddDelBootDrvOpts.sd

Description:
SD File for Add/Del Boot/Driver options to show in setup
Built on 16:20:18 10/01/14


AMILogo.c

Description:
This file contains code to handle logo.
Built on 16:20:18 10/01/14


AMILogo.h

Description:
header file to define logo related stuff.
Built on 16:20:18 10/01/14


amiver.h

Description:
This file contains version macros.
Built on 16:20:18 10/01/14


application.c

Description:
This file contains code to handle Application.

The following functions are used in the file: application.c.

Function | Description
ApplicationAddPage | Function to add a page to the application.
ApplicationCreate | Function to create an application, which uses the Object functions.
ApplicationDestroy | Function to destroy an application, which uses the Object functions.
ApplicationHandleAction | Function to handle the application actions.
ApplicationInitialize | Function to Initialize an application, which uses the Object functions.

Built on 16:20:18 10/01/14


ApplicationAddPage in the application.c

Function : ApplicationAddPage

File: application.c
Description:
Function to add a page to the application.
Input:
APPLICATION_DATA *app, VOID *data
Output:
status
Built on 16:20:05 10/01/14


ApplicationCreate in the application.c

Function : ApplicationCreate

File: application.c
Description:
Function to create an application, which uses the Object functions.
Input:
APPLICATION_DATA **object
Output:
status
Built on 16:20:05 10/01/14


ApplicationDestroy in the application.c

Function : ApplicationDestroy

File: application.c
Description:
Function to destroy an application, which uses the Object functions.
Input:
APPLICATION_DATA *app, BOOLEAN freeMem
Output:
status
Built on 16:20:05 10/01/14


ApplicationHandleAction in the application.c

Function : ApplicationHandleAction

File: application.c
Description:
Function to handle the application actions.
Input:
APPLICATION_DATA *app, ACTION_DATA *action
Output:
status
Built on 16:20:05 10/01/14


ApplicationInitialize in the application.c

Function : ApplicationInitialize

File: application.c
Description:
Function to Initialize an application, which uses the Object functions.
Input:
APPLICATION_DATA *app, VOID *data
Output:
status
Built on 16:20:05 10/01/14


application.h

Description:
Header file for code to handle Application.
Built on 16:20:18 10/01/14


Aptio Modules

Description:
"Core\Core.cif"= "SS: Alaska;$/Alaska/BIN/Core;4.6.4.0"
"Build.cif"= "SS: Alaska;$/Alaska/BIN/Core;4.6.4.0"
"Include\Include.cif"= "SS: Alaska;$/Alaska/BIN/Core\Include;4.6.4.0"
"Include\PPI\PPI.cif"= "SS: Alaska;$/Alaska/BIN/Core\Include/PPI;4.6.4.0"
"Include\Protocol\Protocol.cif"= "SS: Alaska;$/Alaska/BIN/Core\Include/Protocol;4.6.4.0"
"Library\Library.cif"= "SS: Alaska;$/Alaska/BIN/Core\Library;4.6.4.0"
"Core\CORE_PEI\CORE_PEI.cif"= "SS: Alaska;$/Alaska/BIN/Core\CORE_PEI;4.6.4.0"
"Core\CORE_DXE\CORE_DXE.cif"= "SS: Alaska;$/Alaska/BIN/Core\CORE_DXE;4.6.4.0"
"Include\Protocol\ArchProtocol.cif"= "SS: Alaska;$/Alaska/BIN/Core\CORE_DXE/ArchProtocol;4.6.4.0"
"Core\EM\Runtime\Runtime.cif"= "SS: Alaska;$/Alaska/BIN/Core\Runtime;4.6.4.0"
"Core\EM\IdeBus\IdeBus.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/IdeBus;4.6.4.0"
"Include\Protocol\PIDEBus.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/IdeBus;4.6.4.0"
"Core\EM\Recovery\Recovery.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/Recovery;4.6.4.0"
"Core\EM\Recovery\ReFlash\ReFlash.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/Recovery;4.6.4.0"
"Include\PPI\RecoveryPpi.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/Recovery;4.6.4.0"
"Core\CPU\IA32\IA32Core.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/IA32Core;4.6.4.0"
"Core\CPU\x64\x64Core.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/x64Core;4.6.4.0"
"Core\EM\PCI\PciBus.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/PciBus;4640_PCIBUSBIN_24_0_TEST"
"Include\PciBusIncludes.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/PciBus;4640_PCIBUSBIN_24_0_TEST"
"Core\EM\BoardInfo\AMIBoardInfo.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/BoardInfo;4640_AMI_BOARD_1.0.0"
"Include\AmiBoardInfoIncludes.cif"= "SS: Alaska;$/Alaska/BIN/Core\Modules/BoardInfo;4640_AMI_BOARD_1.0.0"
"Core\CoreSrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Core;4.6.4.0"
"Library\LibSrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Library;4.6.4.0"
"Library\AmiLib.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Library;4.6.4.0"
"Library\AmiPeiLib.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Library;4.6.4.0"
"Library\AmiDxeLib.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Library;4.6.4.0"
"Core\CPU\IA32\AmiIa32Lib.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Modules/IA32Core;4.6.4.0"
"Core\CPU\x64\AmiX64Lib.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Modules/x64Core;4.6.4.0"
"Core\em\Runtime\RuntimeSrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Runtime;4.6.4.0"
"Core\em\IdeBus\IdeBusSrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Modules/IdeBus;4.6.4.0"
"Core\EM\FloppyCtrl\FloppyCtrl.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\CORE_DXE/FloppyCtrl;4.6.4.0"
"Core\EM\FileSystem\FileSystem.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Modules/FileSystem;4.6.4.0"
"Core\EM\Recovery\RecoverySrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Modules/Recovery;4.6.4.0"
"Core\Foundation.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\EDK;4.6.4.0"
"Core\CORE_PEI\CORE_PEISrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\EDK/PeiMain;4.6.4.0"
"Core\CORE_DXE\CORE_DXESrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\EDK/DxeMain;4.6.4.0"
"Core\CORE_DXE\ConSplitter\ConSplitter.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\CORE_DXE/ConSplitter;4.6.4.0"
"Core\CORE_DXE\Partition\Partition.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\CORE_DXE/Partition;4.6.4.0"
"Core\EM\PS2CTL\PS2Ctl.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\CORE_DXE/PS2CTL;4.6.4.0"
"Core\CORE_DXE\FrameworkHii\FrameworkHii.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\CORE_DXE/FrameworkHii;4.6.4.0"
"Core\CORE_DXE\UefiHii\UefiHii.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\CORE_DXE/UefiHii;4.6.4.0"
"Core\CPU\IA32\FoundationIa32.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\EDK/IA32;4.6.4.0"
"Core\CPU\x64\Foundationx64.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\EDK/x64;4.6.4.0"
"Core\CPU\IPF\FoundationIPF.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\EDK/IPF;4.6.4.0"
"Core\EM\NVRAM\NVRAM.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Modules/NVRAM;4.6.4.0"
"Core\EM\PCI\PciBusSrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Core\Modules/PciBus;4640_PCIBUSSRC_24_0_TEST"
"Board\IO\W83627DHG\W83627DHG.CIF"= "SS: Alaska;$/Alaska/BIN/IO/Winbond/W83627DHG;4.6.3.5_IO_W83627DHG.A3"
"Board\EM\W83627DHGSetup\CallbackLib\Callback.cif"= "SS: Alaska;$/Alaska/BIN/IO/Winbond/W83627DHG;4.6.3.5_IO_W83627DHG.A3"
"Board\Flash\Flash.cif"= "SS: Alaska;$/Alaska/SOURCE/Flash_Combined_2/Core;4.6.3_Flash_Combined_2_20"
"Board\Flash\FWH\FwhFlash.cif"= "SS: Alaska;$/Alaska/SOURCE/Flash_Combined_2/Core\FWH;4.6.3_Flash_Combined_2_20"
"Board\Flash\LPC\LpcFlash.cif"= "SS: Alaska;$/Alaska/SOURCE/Flash_Combined_2/Core\LPC;4.6.3_Flash_Combined_2_20"
"Board\Flash\STD\StdFlash.cif"= "SS: Alaska;$/Alaska/SOURCE/Flash_Combined_2/Core\STD;4.6.3_Flash_Combined_2_20"
"Board\Flash\SPI\SpiFlash.cif"= "SS: Alaska;$/Alaska/SOURCE/Flash_Combined_2/Core\SPI;4.6.3_Flash_Combined_2_20"
"Board\Flash\SPI\Template\SpiCspSrc.cif"= "SS: ALASKA;$/Alaska/SOURCE/Flash_Combined_2\Core/SPI/Template;4.6.3_Flash_Combined_2_20"
"Include\FlashPart.cif"= "SS: Alaska;$/Alaska/SOURCE/Flash_Combined_2/Core;4.6.3_Flash_Combined_2_20"
"Board\Cpu\Specific\CpuSp.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Model/Gainestown;4.6.3_GAINESTOWN_4"
"Board\CPU\CPU.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Nehalem;4.6.3_INTEL_Nehalem_28"
"Board\CPU\CPUBSP.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Nehalem;4.6.3_INTEL_Nehalem_28"
"Core\CPU\CPUCore.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Nehalem;4.6.3_INTEL_Nehalem_29"
"Include\CPU Hobs.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Nehalem;4.6.3_INTEL_Nehalem_29"
"Include\ppi\CpuPPIs.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Nehalem;4.6.3_INTEL_Nehalem_29"
"Include\Protocol\CpuProtocols.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Nehalem;4.6.3_INTEL_Nehalem_29"
"Core\CPU\MicrocodeUpdate\MicrocodeUpdate.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Nehalem;4.6.3_INTEL_Nehalem_29"
"Core\Cpu\CpuTools.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/Nehalem;4.6.3_INTEL_Nehalem_29"
"Chipset\NB\NB.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/NorthBridge/Havendale_Lynnfield;4.6.3_Intel_HVD_LFD_033"
"Board\NB\NBBOARD.CIF"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/NorthBridge/Havendale_Lynnfield\Board;4.6.3_Intel_HVD_LFD_033"
"Chipset\NB\NBCSP.CIF"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/NorthBridge/Havendale_Lynnfield\Chipset;4.6.3_Intel_HVD_LFD_033"
"INCLUDE\Protocol\NBProtocols.CIF"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/NorthBridge/Havendale_Lynnfield\Chipset/Protocols;4.6.3_Intel_HVD_LFD_033"
"INCLUDE\PPI\NBPPI.CIF"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/NorthBridge/Havendale_Lynnfield\Chipset/PPI;4.6.3_Intel_HVD_LFD_033"
"Chipset\NB\RC_LFD\LFDRefCodeInit.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/NorthBridge/Havendale_Lynnfield\Chipset/RC_LFD;4.6.3_Intel_HVD_LFD_033"
"Chipset\NB\RC_HVD\HVDRefCodeInit.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/NorthBridge/Havendale_Lynnfield\Chipset/RC_HVD;4.6.3_Intel_HVD_LFD_033"
"Chipset\NB\StdLib\std.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/NorthBridge/Havendale_Lynnfield\Chipset/StdLib;4.6.3_Intel_HVD_LFD_033"
"Chipset\SB\SB.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/SouthBridge/IbexPeak;4.6.3_Intel_IbexPeak_045"
"Board\SB\SBBOARD.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/SouthBridge/IbexPeak\Board;4.6.3_Intel_IbexPeak_045"
"Chipset\SB\SBCSP.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/SouthBridge/IbexPeak\Chipset;4.6.3_Intel_IbexPeak_045"
"INCLUDE\PPI\SBPPI.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/SouthBridge/IbexPeak\Chipset/PPI;4.6.3_Intel_IbexPeak_045"
"INCLUDE\Protocol\SBProtocols.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/SouthBridge/IbexPeak\Chipset/Protocols;4.6.3_Intel_IbexPeak_045"
"Chipset\SB\SmmChildDispatcher.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/SouthBridge/IbexPeak\Chipset/SmmChildDispatcher;4.6.3_Intel_IbexPeak_045"
"Chipset\SB\AcpiModeEnable.cif"= "SS: ALASKA;$/Alaska/BIN/Chipset/Intel/SouthBridge/IbexPeak\Chipset/AcpiModeEnable;4.6.3_Intel_IbexPeak_045"
"Core\em\Ahci\AhciSrc.cif"= "SS: ALASKA;$/Alaska/SOURCE/Modules/AHCI;4.6.3_AhciSrc_015"
"Core\eM\Ahci\Aint13.cif"= "SS: ALASKA;$/Alaska/SOURCE/Modules/AHCI\INT13;4.6.3_AhciSrc_015"
"Include\Aint13Protocol.cif"= "SS: ALASKA;$/Alaska/SOURCE/Modules/AHCI\INT13;4.6.3_AhciSrc_015"
"Addon\ahcibin.cif"= "SS: ALASKA;$/Alaska/SOURCE/Modules/AHCI\INT13/16-bit Binary;4.6.3_AhciSrc_015"
"Chipset\eM\Ahci\AhciCsp.cif"= "SS: ALASKA;$/Alaska/SOURCE/Modules/AHCI\INT13/CSP;4.6.3_AhciSrc_015"
"Chipset\eM\Ahci\AhciAccess.cif"= "SS: ALASKA;$/Alaska/SOURCE/Modules/AHCI;4.6.3_AhciSrc_015"
"CORE\EM\Ahci\AhciSmm\AhciSmm.cif"= "SS: ALASKA;$/Alaska/SOURCE/Modules/AHCI\AhciSmm;4.6.3_AhciSrc_015"
"INCLUDE\Protocol\AhciSmmProtocols.CIF"= "SS: ALASKA;$/Alaska/SOURCE/Modules/AHCI\AhciSmm;4.6.3_AhciSrc_015"
"BOARD\EM\ACPI\ACPI.cif"= "SS: Alaska;$/Alaska/BIN/Modules/ACPI/Template;4.6.4.0_ACPI_40"
"BOARD\EM\ACPI\ACPIBSP.CIF"= "SS: Alaska;$/Alaska/BIN/Modules/ACPI/Template\Board;4.6.4.0_ACPI_40"
"BOARD\EM\ACPI\ASLBSP.CIF"= "SS: Alaska;$/Alaska/BIN/Modules/ACPI/Template\Board;4.6.4.0_ACPI_40"
"Core\EM\ACPI\ACPICORE.CIF"= "SS: Alaska;$/Alaska/BIN/Modules/ACPI/Template\Core;4.6.4.0_ACPI_40"
"CORE\EM\ACPI\ASLCORE.CIF"= "SS: Alaska;$/Alaska/BIN/Modules/ACPI/Template\Core;4.6.4.0_ACPI_40"
"Board\eM\Csm\csm.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic;4.6.3.1_CSM.7.62_71"
"Core\EM\CSM\csmcore.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Core;4.6.3.1_CSM.7.62_71"
"core\em\csm\thunk\thunk.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Thunk;4.6.3.1_CSM.7.62_71"
"core\em\csm\thunk\x86\x86thunk.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Thunk/x86;4.6.3.1_CSM.7.62_71"
"core\em\csm\thunk\BlockIo\int13thunk.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Thunk/INT13;4.6.3.1_CSM.7.62_71"
"core\em\csm\thunk\Snp16\snp16.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Thunk/SNP16;4.6.3.1_CSM.7.62_71"
"Core\EM\CSM\Thunk\CsmVideo\CsmVideo.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Thunk/CsmVideo;4.6.3.1_CSM.7.62_71"
"Board\eM\Csm\csmoem.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\OEM Hooks;4.6.3.1_CSM.7.62_71"
"Addon\csm16.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\CSM16;4.6.3.1_CSM.7.62_71"
"Chipset\SB\CSM\csmsb.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Chipset/SouthBridge;4.6.3.1_CSM.7.62_71"
"Chipset\SB\CSM\LegacyInterrupt\LegacyInterrupt.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Chipset/SouthBridge;4.6.3.1_CSM.7.62_71"
"Chipset\NB\CSM\LegacyRegion\LegacyRegion.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic\Chipset/NorthBridge;4.6.3.1_CSM.7.62_71"
"include\CsmProtocols.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic;4.6.3.1_CSM.7.62_71"
"board\em\csm\csmsetup.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/CSM/Generic;4.6.3.1_CSM.7.62_71"
"Core\EM\FastBoot\FastBoot.cif"= "SS: AlaskaVss;$/Alaska/SOURCE/Modules/FastBoot;(INT)4.6.4.0_Fast_Boot_08"
"Include\Protocol\FastBootProtocol.cif"= "SS: AlaskaVss;$/Alaska/SOURCE/Modules/FastBoot;(INT)4.6.4.0_Fast_Boot_08"
"Board\CPU\Microcode\Microcode.cif"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/IntelMicrocode;4.6.0_INTEL_MICROCODE_12"
"Board\CPU\Microcode\DESKTOP\Desktop.CIF"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/IntelMicrocode\Desktop Processor Microcode Patch;4.6.0_INTEL_MICROCODE_12"
"Board\CPU\Microcode\VALUE\Value.CIF"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/IntelMicrocode\P4 Value CPU uCode Patches;4.6.0_INTEL_MICROCODE_12"
"Board\CPU\Microcode\ServWork\ServWork.CIF"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/IntelMicrocode\ServWork Processor Microcode Patch;4.6.0_INTEL_MICROCODE_12"
"Board\CPU\Microcode\MOBILE\Mobile.CIF"= "SS: Alaska;$/Alaska/SOURCE/CPU/Intel/IntelMicrocode\P4 Mobile CPU uCode Patches;4.6.0_INTEL_MICROCODE_12"
"CORE\EM\SMIFlash\SMIFlash.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMIFlash;4.6.3.6_SMIFLASH_14"
"INCLUDE\Protocol\SMIFlashProtocols.CIF"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMIFlash;4.6.3.6_SMIFLASH_14"
"Core\EM\SMM\SMM.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMM;4.6.3_SMM_40"
"Core\EM\SMM\SmmDispatcher.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMM\SMMDispatcher;4.6.3_SMM_40"
"Core\EM\SMM\SmmBase.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMM\SMMBase;4.6.3_SMM_40"
"Include\Protocol\SmmProtocols.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMM;4.6.3_SMM_40"
"Chipset\SB\PowerButton.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMM\PowerButton;4.6.3_SMM_40"
"Core\EM\StatusCode\StatusCode.cif"= "SS: Alaska;$/Alaska/BIN/Modules/StatusCode;4.6.3_StatusCode_15"
"Core\em\UsbRecovery\UsbRecovery.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery;4.6.3_USB_RECOVERY_SRC_17"
"core\em\UsbRecovery\UhciPeiUsb\UhciPeiUsb.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery;4.6.3_USB_RECOVERY_SRC_17"
"INCLUDE\PPI\UhciPPI.CIF"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery;4.6.3_USB_RECOVERY_SRC_17"
"core\em\UsbRecovery\OhciPEI\OhciPei.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery;4.6.3_USB_RECOVERY_SRC_17"
"INCLUDE\PPI\OHCIPPI.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery;4.6.3_USB_RECOVERY_SRC_17"
"core\em\UsbRecovery\EhciPEI\EhciPei.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery;4.6.3_USB_RECOVERY_SRC_17"
"Core\em\UsbRecovery\UhcPeimSrc\UhcPeimSrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery\UhcPeimSrc;4.6.3_USB_RECOVERY_SRC_17"
"Include\Ppi\UsbHCPpi.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery\UhcPeimSrc;4.6.3_USB_RECOVERY_SRC_17"
"Core\EM\UsbRecovery\UsbPeimSrc\UsbPeimSrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery\UsbPeimSrc;4.6.3_USB_RECOVERY_SRC_17"
"Include\Ppi\UsbIoPpi.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery\UsbPeimSrc;4.6.3_USB_RECOVERY_SRC_17"
"Core\em\UsbRecovery\UsbBotPeimSrc\UsbBotPeim.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USBRecovery\UsbBotPeimSrc;4.6.3_USB_RECOVERY_SRC_17"
"AddOn\Shell.cif"= "SS: ALASKA;$/Alaska/BIN/Modules/Shell;4.6.3_SHELL_20091214_00 "
"Core\EM\Capsule\Capsule.cif"= "SS: ALASKA;$/Alaska/SOURCE/Modules/Capsule;4.5.6_Capsule_04"
"board\em\usb\amiusb.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA;4.06.03_USB_08.09.00"
"core\em\usb\rt\usbrt.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA\RT;4.06.03_USB_08.09.00"
"core\em\usb\uhcd.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA;4.06.03_USB_08.09.00"
"core\em\usb\framework.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA;4.06.03_USB_08.09.00"
"include\AmiUSBProtocols.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA;4.06.03_USB_08.09.00"
"core\em\usb\setup\usbsetup.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA\Setup;4.06.03_USB_08.09.00"
"chipset\sb\usb\usbsb.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/Chipset/SouthBridge/Intel/IbexPeak_Desktop/;4.6.3.2_USB_IBEXPEAK_DT_00"
"Core\eM\USB\int13\UsbInt13.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA\Int13;4.06.03_USBI13_02"
"Addon\usbi13bin.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA\Int13;4.06.03_USBI13_02"
"Include\Protocol\emul6064Protocols.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/USB/ALASKA\EMUL6064;4.06.03_USB_08.09.00"
"Board\EM\SMBIOS\SMBIOSBoard.CIF"= "SS: Alaska;$/Alaska/BIN/Modules/SMBIOS;4.6.1_ALPHA_01.25"
"Include\Protocol\SMBIOSProto.CIF"= "SS: Alaska;$/Alaska/BIN/Modules/SMBIOS\SmbiosProtocol;4.6.1_ALPHA_01.25"
"Board\EM\SMBIOS\SMBiosStaticData\SmbiosStaticData.cif"= "SS: Alaska;$/Alaska/BIN/Modules/SMBIOS\SmbiosStaticData;4.6.1_ALPHA_01.25"
"Board\EM\SMBIOS\SmbiosDMIEdit\SmbiosDMIEditBoard.cif"= "SS: Alaska;$/Alaska/BIN/Modules/SMBIOS\SmbiosDMIEdit;4.6.1_ALPHA_01.25"
"Chipset\EM\IgdOpRegion\IgdOpRegion.cif"= "SS: Alaska;$/Alaska/Projects/Intel/Piketon/Havendale&Lynnfield_IbexPeak_1AEIQ/Chipset/EM/IgdOpRegion;4.6.3.7_VEB_1AEIQ018"
"Core\EM\SMBIOS\SMBIOSCore.CIF"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMBIOS;4.6.1_ALPHA_01.25"
"Core\EM\SMBios\SmbiosDMIEditSupport\SmbiosDMIEdit.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMBIOS\SmbiosDMIEditSupport;4.6.1_ALPHA_01.25"
"Core\EM\SMBios\SmbiosGetFlashData\SmbiosGetFlashData.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMBIOS\SmbiosGetFlashData;4.6.1_ALPHA_01.25"
"Core\EM\SMBios\SmbiosFlashData\SmbiosFlashData.cif"= "SS: Alaska;$/Alaska/SOURCE/Modules/SMBIOS\SmbiosFlashData;4.6.1_ALPHA_01.25"
"Board\Flash\SPI\SpiCspSrc.cif"= "SS: Alaska;$/Alaska/SOURCE/Flash_Combined_2/CSP_SPI/Intel/ICHx;4.6.3_SPI-Intel-ICHx_05"
"Board\Board.cif"= "SS: Alaska;$/Alaska/BIN/Board;4.6.4.0_Board_24"
"Board\em\Setup\Setup.cif"= "SS: Alaska;$/Alaska/BIN/Board\Setup;4.6.4.0_Board_24"
"CRB\CRBoard.cif"= "SS: ALASKA;$/Alaska/Projects/Intel/Piketon/Havendale&Lynnfield_IbexPeak_1AEIQ\CRB;4.6.3.7_VEB_1AEIQ016"
"Core\CSPLib\CspLib.CIF"= "SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary;4.6.4.0_CSPLibrary_012"
"Include\CSPLibInc.CIF"= "SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary;4.6.4.0_CSPLibrary_012"
"Include\Protocol\CspLibProtocols.CIF"= "SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary;4.6.4.0_CSPLibrary_012"
"INCLUDE\PPI\CspLibPPI.CIF"= "SS: Alaska;$/Alaska/BIN/Chipset/Template/CSPLibrary;4.6.4.0_CSPLibrary_012"
Built on 16:20:18 10/01/14


bbs.c

Description:
takecare of bbs/legacy boot management.

The following functions are used in the file: bbs.c.

Function | Description
_BBSCheckDisabled | function to Check whether a perticular entry is disabled.
_BBSInitProtocol | function to Initialize the bbs protocol.
_BBSSetDevicePriorities | function to set boot device priorities
BBSBuildDefaultName | function to build the default boot device name
BBSBuildDevicePathName | function to build the bbs device path
BBSGetDeviceList | function to get the list of all the devices
BBSGetOptionName | function to get the name of the option
BBSLaunchDevicePath | function to launch the device path
BBSSetBootNowPriority | Sets BBS priority for the BootNow devices.
BBSSetBootPriorities | function to set boot priorities
BBSSetBootPriorities_BootOrder | Assign priority as per boot order other than 0 priority devices
BBSSetDisabled | function to disable a perticular entry.
BBSUpdateBootData | function to update boot related data
BBSUpdateOrder | function to update Bbs device order
CreateDriveString | function to create the device string
GetBBSBootOptionName | function to get the Boot option name.
GetBBSOptionStatus | function to get for bbs option status
GetBusStr | function to get the bus type string
GetDevStr | function to get the device strings
GetUefiDevPathString | function to get the device string using device path for UEFI options.
IsBBSDevicePath | function to Check for bbs device path support.
IsSATADevice | function to Check for SATA Devices
MatchDevicePath | Matches the Device path from the BootOption to BBS Device path to locate the right Device
RearrangeBBSOrder | Rearranges the bootdata legacy entries with legacydevorder defaults
UpdateBootVariables | Update the BootOrder,BBSOrder Cache From the NVRAM.
UpdateDriverVariables | Update the DriverOrder Cache From the NVRAM.
UpdateLegacyDevVariable |

Built on 16:20:19 10/01/14


_BBSCheckDisabled in the bbs.c

Function : _BBSCheckDisabled

File: bbs.c
Description:
function to Check whether a perticular entry is disabled.
Input:
UINT16 *Option, UINT16 Pos
Output:
TRUE/FALSE
Built on 16:20:03 10/01/14


_BBSInitProtocol in the bbs.c

Function : _BBSInitProtocol

File: bbs.c
Description:
function to Initialize the bbs protocol.
Input:
void
Output:
device path
Built on 16:20:03 10/01/14


_BBSSetDevicePriorities in the bbs.c

Function : _BBSSetDevicePriorities

File: bbs.c
Description:
function to set boot device priorities
Input:
BBS_TABLE *BBSInfo, UINT16 *Priority, BOOT_DATA *BootData
Output:
void
Built on 16:20:03 10/01/14


BBSBuildDefaultName in the bbs.c

Function : BBSBuildDefaultName

File: bbs.c
Description:
function to build the default boot device name
Input:
CHAR16 *String, BBS_TABLE *info, UINTN index, HDD_INFO *HDDInfo
Output:
void
Built on 16:20:05 10/01/14


BBSBuildDevicePathName in the bbs.c

Function : BBSBuildDevicePathName

File: bbs.c
Description:
function to build the bbs device path
Input:
CHAR16 *String, BBS_TABLE *info, UINTN index, HDD_INFO *HDDInfo
Output:
None
Built on 16:20:05 10/01/14


BBSGetDeviceList in the bbs.c

Function : BBSGetDeviceList

File: bbs.c
Description:
function to get the list of all the devices
Input:
void
Output:
void
Built on 16:20:05 10/01/14


BBSGetOptionName in the bbs.c

Function : BBSGetOptionName

File: bbs.c
Description:
function to get the name of the option
Input:
UINT16 *Option, UINT16 Pos
Output:
string
Built on 16:20:05 10/01/14


BBSLaunchDevicePath in the bbs.c

Function : BBSLaunchDevicePath

File: bbs.c
Description:
function to launch the device path
Input:
EFI_DEVICE_PATH_PROTOCOL *DevicePath
Output:
status
Built on 16:20:05 10/01/14


BBSSetBootNowPriority in the bbs.c

Function : BBSSetBootNowPriority

File: bbs.c
Description:
Sets BBS priority for the BootNow devices.
Input:
BootData - Boot data
        uiPrefferedDevice - prefered Device type valid in ShowAllBBSDev case
        ShowAllBbsDev - SETUP_SHOW_ALL_BBS_DEVICES
Output:
EFI_STATUS
Built on 16:20:05 10/01/14


BBSSetBootPriorities in the bbs.c

Function : BBSSetBootPriorities

File: bbs.c
Description:
function to set boot priorities
Input:
BOOT_DATA *pBootData, UINT16 *pOrder, UINTN u16OrderCount
Output:
void
Built on 16:20:05 10/01/14


BBSSetBootPriorities_BootOrder in the bbs.c

Function : BBSSetBootPriorities_BootOrder

File: bbs.c
Description:
Assign priority as per boot order other than 0 priority devices
Input:
void
Output:
void
Built on 16:20:05 10/01/14


BBSSetDisabled in the bbs.c

Function : BBSSetDisabled

File: bbs.c
Description:
function to disable a perticular entry.
Input:
UINT16 Index, VOID **DisDPs, UINTN *DPSize
Output:
void
Built on 16:20:05 10/01/14


BBSUpdateBootData in the bbs.c

Function : BBSUpdateBootData

File: bbs.c
Description:
function to update boot related data
Input:
UINT16 GroupNo
Output:
void
Built on 16:20:05 10/01/14


BBSUpdateOrder in the bbs.c

Function : BBSUpdateOrder

File: bbs.c
Description:
function to update Bbs device order
Input:
UINT16 *newOption,UINT32 *offset,UINTN *size, VOID **buffer
Output:
None
Built on 16:20:05 10/01/14


CreateDriveString in the bbs.c

Function : CreateDriveString

File: bbs.c
Description:
function to create the device string
Input:
CHAR16 *String, UINT16 *IdentifyDriveData
Output:
void
Built on 16:20:06 10/01/14


GetBBSBootOptionName in the bbs.c

Function : GetBBSBootOptionName

File: bbs.c
Description:
function to get the Boot option name.
Input:
BOOT_DATA *bootData
Output:
CHAR16* - BootOptionName
Built on 16:20:08 10/01/14


GetBBSOptionStatus in the bbs.c

Function : GetBBSOptionStatus

File: bbs.c
Description:
function to get for bbs option status
Input:
BOOT_DATA
Output:
BOOLEAN
Built on 16:20:08 10/01/14


GetBusStr in the bbs.c

Function : GetBusStr

File: bbs.c
Description:
function to get the bus type string
Input:
EFI_HANDLE Handle, UINTN index, HDD_INFO *HDDInfo
Output:
Bus string
Built on 16:20:08 10/01/14


GetDevStr in the bbs.c

Function : GetDevStr

File: bbs.c
Description:
function to get the device strings
Input:
UINT16 DevType
Output:
device string
Built on 16:20:08 10/01/14


GetUefiDevPathString in the bbs.c

Function : GetUefiDevPathString

File: bbs.c
Description:
function to get the device string using device path for UEFI options.
Input:
EFI_DEVICE_PATH_PROTOCOL *DevPath
Output:
Device string.
Built on 16:20:08 10/01/14


IsBBSDevicePath in the bbs.c

Function : IsBBSDevicePath

File: bbs.c
Description:
function to Check for bbs device path support.
Input:
EFI_DEVICE_PATH_PROTOCOL *DevicePath
Output:
TRUE/FALSE
Built on 16:20:10 10/01/14


IsSATADevice in the bbs.c

Function : IsSATADevice

File: bbs.c
Description:
function to Check for SATA Devices
Input:
UINT16 *IdentifyDriveData - 512 bytes of device information
Output:
TRUE/FALSE
Built on 16:20:10 10/01/14


MatchDevicePath in the bbs.c

Function : MatchDevicePath

File: bbs.c
Description:
Matches the Device path from the BootOption to BBS Device path to locate the
right Device
Input:
pBootData - Boot Data of Boot Option
LegacyOrder - LegacyDevOrder Entry for Boot Option
DevHandle   - BBS device Handle
Output:
BOOLEAN - TRUE - Device path matched betweend LegacyOrder and pBootData.
Built on 16:20:11 10/01/14


RearrangeBBSOrder in the bbs.c

Function : RearrangeBBSOrder

File: bbs.c
Description:
Rearranges the bootdata legacy entries with legacydevorder defaults
Input:
VOID * - Cache Buffer
Output:
VOID
Built on 16:20:14 10/01/14


UpdateBootVariables in the bbs.c

Function : UpdateBootVariables

File: bbs.c
Description:
Update the BootOrder,BBSOrder Cache From the NVRAM.
Input:
VOID
Output:
VOID
Built on 16:20:18 10/01/14


UpdateDriverVariables in the bbs.c

Function : UpdateDriverVariables

File: bbs.c
Description:
Update the DriverOrder Cache From the NVRAM.
Input:
VOID
Output:
VOID
Built on 16:20:18 10/01/14


UpdateLegacyDevVariable in the bbs.c

Function : UpdateLegacyDevVariable

File: bbs.c
Description:
Input:
UINT16 NoOfLegacyGroups
Output:
None
Built on 16:20:18 10/01/14


bbs.h

Description:
Header file for bbs/legacy boot management.
Built on 16:20:19 10/01/14


boot.c

Description:
This file contains code for Boot management

The following functions are used in the file: boot.c.

Function | Description
_BootBuildFileDevicePath | function to build File device path protocol.
_BootBuildFVDevicePath | function to build firmware volume device path protocol.
_BootInstallLoadOptions | function to install the load options
_BootLaunchDevicePath | function to launch the boot operation
_BootSetBootManagerVariables | function to set the variables for the boot manager
_BootSetBootNowCount | function to set boot new devices count
_DiscoverPartition | function to launch the boot operation
_RegisterShellGuid | Registers the shell guid
_SetDriverManagerVariables | Sets DriverManager variable for drivers count and sets DriverOrder
_ShellClearScreen | Clears the screen for shell boot
BootGetBBSOptionStatus | Function to Check the Legacy boot option status
BootGetBootData | Finds and returns internal data structure BOOT_DATA for a given boot option number.
BootGetBootNowName | Provides the unicode name for the given boot option.
BootGetBootOptions | This function collects all the boot options, both efi and legacy boot options, that are present in the system and sets various boot manager variables that are used to expand boot manager questions.
BootGetLanguages | Finds the languages that the firmware supports.
BootGetOptionName | Provides the unicode name for the given boot option in the form of internal data structure BOOT_DATA.
BootGetOptionStatus | Function to Check the boot option status in Boot Order
BootLaunchBootNow | Launches the boot option provided.
BootLaunchBootOption | This function launches the boot option supplied
BootLaunchFilename | Launches the file mentioned in file path from the available FS.
BootLaunchGuid | Launches the guided file from FV.
CheckBootOptionMatch | Checks the input boot option matches with any of the boot option in the system
CheckDevSupShortFormPath | Matches the device path with USB class device path (Table 60) and returns the corresponding USB's file system handle
CheckHiddenforBootDriverOption | Check whether the Boot/Driver option has hidden property
DriverGetDriverData | Finds and returns internal data structure BOOT_DATA for a given Driver option number.
DriverGetOptionName | Provides the unicode name for the given driver option in the form of internal data structure BOOT_DATA.
FixHiddenOptions | Function to move the hidden option at last of the boot order
IsBootDeviceEnabled | Function to Check the boot option status
LoadOptionhidden | Function to Check the Boot option status if gLoadOptionhidden token is Enabled
SetBootOptionSupportVariable | Function to set the BootOptionSupport variable

Built on 16:20:19 10/01/14


_BootBuildFileDevicePath in the boot.c

Function : _BootBuildFileDevicePath

File: boot.c
Description:
function to build File device path protocol.
Input:
UINT32 *index, CHAR16 *fileName
Output:
device path
Built on 16:20:03 10/01/14


_BootBuildFVDevicePath in the boot.c

Function : _BootBuildFVDevicePath

File: boot.c
Description:
function to build firmware volume device path protocol.
Input:
UINT32 *index, EFI_GUID *guidPtr
Output:
device path
Built on 16:20:03 10/01/14


_BootInstallLoadOptions in the boot.c

Function : _BootInstallLoadOptions

File: boot.c
Description:
function to install the load options
Input:
EFI_HANDLE handle, VOID *Options, UINTN OptionSize
Output:
void
Built on 16:20:03 10/01/14


_BootLaunchDevicePath in the boot.c

Function : _BootLaunchDevicePath

File: boot.c
Description:
function to launch the boot operation
Input:
EFI_DEVICE_PATH_PROTOCOL *DevicePath, VOID *Options, UINTN OptionSize, BOOLEAN ValidBootOption
Output:
status
Built on 16:20:03 10/01/14


_BootSetBootManagerVariables in the boot.c

Function : _BootSetBootManagerVariables

File: boot.c
Description:
function to set the variables for the boot manager
Input:
void
Output:
void
Built on 16:20:03 10/01/14


_BootSetBootNowCount in the boot.c

Function : _BootSetBootNowCount

File: boot.c
Description:
function to set boot new devices count
Input:
void
Output:
void
Built on 16:20:03 10/01/14


_DiscoverPartition in the boot.c

Function : _DiscoverPartition

File: boot.c
Description:
function to launch the boot operation
Input:
EFI_DEVICE_PATH_PROTOCOL *DevicePath
Output:
device path
Built on 16:20:03 10/01/14


_RegisterShellGuid in the boot.c

Function : _RegisterShellGuid

File: boot.c
Description:
Registers the shell guid
Input:
VOID
Output:
VOID
Built on 16:20:04 10/01/14


_SetDriverManagerVariables in the boot.c

Function : _SetDriverManagerVariables

File: boot.c
Description:
Sets DriverManager variable for drivers count and sets DriverOrder
Input:
void
Output:
void
Built on 16:20:04 10/01/14


_ShellClearScreen in the boot.c

Function : _ShellClearScreen

File: boot.c
Description:
Clears the screen for shell boot
Input:
EFI_EVENT , VOID *
Output:
VOID
Built on 16:20:04 10/01/14


BootGetBBSOptionStatus in the boot.c

Function : BootGetBBSOptionStatus

File: boot.c
Description:
Function to Check the Legacy boot option status
Input:
BOOT_DATA *bootData, BOOLEAN FromSetup, BOOLEAN ShowAllBBSDev
Output:

Built on 16:20:05 10/01/14


BootGetBootData in the boot.c

Function : BootGetBootData

File: boot.c
Description:
Finds and returns internal data structure BOOT_DATA
for a given boot option number.
Input:
Option: Option number for which BOOT_DATA is needed
Output:
Returns pointer to BOOT_DATA if found. Returns NULL
if BOOT_DATA not found.
Built on 16:20:05 10/01/14


BootGetBootNowName in the boot.c

Function : BootGetBootNowName

File: boot.c
Description:
Provides the unicode name for the given boot option.
Input:
value: boot option for which unicode name is needed
Output:
Returns unicode string corresponding to the provided
boot option.
Built on 16:20:05 10/01/14


BootGetBootOptions in the boot.c

Function : BootGetBootOptions

File: boot.c
Description:
This function collects all the boot options, both efi
and legacy boot options, that are present in the
system and sets various boot manager variables that
are used to expand boot manager questions.
Input:
VOID
Output:
Return Status based on errors that occurred in library
functions.
Built on 16:20:05 10/01/14


BootGetLanguages in the boot.c

Function : BootGetLanguages

File: boot.c
Description:
Finds the languages that the firmware supports.
Input:
VOID
Output:
VOID
Built on 16:20:05 10/01/14


BootGetOptionName in the boot.c

Function : BootGetOptionName

File: boot.c
Description:
Provides the unicode name for the given boot option
in the form of internal data structure BOOT_DATA.
Input:
bootData: BOOT_DATA struct for which unicode name is
needed.
Output:
Returns unicode string corresponding to the provided
BOOT_DATA. If the BOOT_DATA provided is for legacy
option then the name for the first legacy option in
that category is returned.
Built on 16:20:05 10/01/14


BootGetOptionStatus in the boot.c

Function : BootGetOptionStatus

File: boot.c
Description:
Function to Check the boot option status in Boot Order
Input:
BOOT_DATA *bootData, BOOLEAN FromSetup
Output:

Built on 16:20:05 10/01/14


BootLaunchBootNow in the boot.c

Function : BootLaunchBootNow

File: boot.c
Description:
Launches the boot option provided.
Input:
index: The nth option in the boot now menu.
        ShowAllBbsDev - SETUP_SHOW_ALL_BBS_DEVICES
Output:
Return Status based on errors that occurred in library
functions.
Built on 16:20:05 10/01/14


BootLaunchBootOption in the boot.c

Function : BootLaunchBootOption

File: boot.c
Description:
This function launches the boot option supplied
Input:
u16Option: BootOption to be launched
pOrder: The order in which to set BBS priorities
u16OrderCount: No of options in pOrder
Output:
Return Status based on errors that occurred in library
functions.
Built on 16:20:05 10/01/14


BootLaunchFilename in the boot.c

Function : BootLaunchFilename

File: boot.c
Description:
Launches the file mentioned in file path from the
available FS.
Input:
fileName: Path of the file to be launched.
Output:
Return Status based on errors that occurred in library
functions.
Built on 16:20:05 10/01/14


BootLaunchGuid in the boot.c

Function : BootLaunchGuid

File: boot.c
Description:
Launches the guided file from FV.
Input:
guid: Guid of the file to be launched.
Output:
Return Status based on errors that occurred in library
functions.
Built on 16:20:05 10/01/14


CheckBootOptionMatch in the boot.c

Function : CheckBootOptionMatch

File: boot.c
Description:
Checks the input boot option matches with any of the boot option in the system
Input:
UINT16 = Boot option to which match to be find
Output:
UINT32 = Returns 0 if no match found
      = 32 bit CRC value of boot option if match found
Built on 16:20:05 10/01/14


CheckDevSupShortFormPath in the boot.c

Function : CheckDevSupShortFormPath

File: boot.c
Description:
Matches the device path with USB class device path (Table 60) and returns
   the corresponding USB's file system handle
Input:
EFI_DEVICE_PATH_PROTOCOL * -> Device path for the boot option
Output:
EFI_HANDLE -> Handle for the file system
Built on 16:20:05 10/01/14


CheckHiddenforBootDriverOption in the boot.c

Function : CheckHiddenforBootDriverOption

File: boot.c
Description:
Check whether the Boot/Driver option has hidden property
Input:
UINT16, BOOLEAN
Output:
BOOLEAN
Built on 16:20:05 10/01/14


DriverGetDriverData in the boot.c

Function : DriverGetDriverData

File: boot.c
Description:
Finds and returns internal data structure BOOT_DATA
for a given Driver option number.
Input:
Option: Option number for which BOOT_DATA is needed
Output:
Returns pointer to BOOT_DATA if found. Returns NULL
if BOOT_DATA not found.
Built on 16:20:07 10/01/14


DriverGetOptionName in the boot.c

Function : DriverGetOptionName

File: boot.c
Description:
Provides the unicode name for the given driver option
in the form of internal data structure BOOT_DATA.
Input:
DriverData: BOOT_DATA struct for which unicode name is
needed.
Output:
Returns unicode string corresponding to the provided BOOT_DATA
Built on 16:20:07 10/01/14


FixHiddenOptions in the boot.c

Function : FixHiddenOptions

File: boot.c
Description:
Function to move the hidden option at last of the boot order
Input:
UINT16 ** => Boot order to be reformed
Output:
VOID
Built on 16:20:07 10/01/14


IsBootDeviceEnabled in the boot.c

Function : IsBootDeviceEnabled

File: boot.c
Description:
Function to Check the boot option status
Input:
UINT16 value, BOOLEAN ShowAllBBSDev, BOOLEAN TseBootNowInBootOrde, BOOLEAN FromSetup
Output:

Built on 16:20:10 10/01/14


LoadOptionhidden in the boot.c

Function : LoadOptionhidden

File: boot.c
Description:
Function to Check the Boot option status if gLoadOptionhidden token is Enabled
Input:
UINT16 value
Output:
BOOLEAN
Built on 16:20:11 10/01/14


SetBootOptionSupportVariable in the boot.c

Function : SetBootOptionSupportVariable

File: boot.c
Description:
Function to set the BootOptionSupport variable
Input:
UINT32 = Capabilities for the BootOptionSupport variable
Output:
VOID
Built on 16:20:14 10/01/14


box.c

The following functions are used in the file: box.c.

Function | Description
DrawBorder | function to draw the border
DrawBox | function to draw a box
DrawLineWithAttribute | function to draw the lines with attributes
DrawWindow | function to draw a window

Built on 16:20:19 10/01/14


DrawBorder in the box.c

Function : DrawBorder

File: box.c
Description:
function to draw the border
Input:
UINTN Left, UINTN Top, UINTN Width, UINTN Height
Output:
void
Built on 16:20:06 10/01/14


DrawBox in the box.c

Function : DrawBox

File: box.c
Description:
function to draw a box
Input:
UINTN Left, UINTN Top, UINTN Width, UINTN Height, UINT8 Attrib
Output:
void
Built on 16:20:06 10/01/14


DrawLineWithAttribute in the box.c

Function : DrawLineWithAttribute

File: box.c
Description:
function to draw the lines with attributes
Input:
UINTN Col, UINTN Row, UINTN Length, CHAR16 Type, UINT8 Attrib
Output:
void
Built on 16:20:07 10/01/14


DrawWindow in the box.c

Function : DrawWindow

File: box.c
Description:
function to draw a window
Input:
UINTN Left, UINTN Top, UINTN Width, UINTN Height,
        UINT8 Attrib, BOOLEAN Border, BOOLEAN Shadow
Output:
void
Built on 16:20:07 10/01/14


box.h

Description:
Header file for box related functions
Built on 16:20:19 10/01/14


buffer.c

Description:
This file contains code to manage buffers

The following functions are used in the file: buffer.c.

Function | Description
DoRealFlushLines | function to flush lines
FlushLines | function to set the positions for flush lines
InitializeScreenBuffer | function to Initialize the screen buffer
SetDesiredTextMode | function to set the test mode
SlowFlushLines | function to slow flush lines

Built on 16:20:19 10/01/14


DoRealFlushLines in the buffer.c

Function : DoRealFlushLines

File: buffer.c
Description:
function to flush lines
Input:
NIL
Output:
void
Built on 16:20:06 10/01/14


FlushLines in the buffer.c

Function : FlushLines

File: buffer.c
Description:
function to set the positions for flush lines
Input:
UINTN Top, UINTN Bottom
Output:
void
Built on 16:20:07 10/01/14


InitializeScreenBuffer in the buffer.c

Function : InitializeScreenBuffer

File: buffer.c
Description:
function to Initialize the screen buffer
Input:
UINT8 attrib
Output:
status
Built on 16:20:10 10/01/14


SetDesiredTextMode in the buffer.c

Function : SetDesiredTextMode

File: buffer.c
Description:
function to set the test mode
Input:
nil
Output:
void
Built on 16:20:14 10/01/14


SlowFlushLines in the buffer.c

Function : SlowFlushLines

File: buffer.c
Description:
function to slow flush lines
Input:
UINTN Top, UINTN Bottom
Output:
void
Built on 16:20:15 10/01/14


buffer.h

Description:
Header file for code to manage buffers
Built on 16:20:19 10/01/14


callback.c

Description:
This file contains code to handle callbacks

The following functions are used in the file: callback.c.

Function | Description
_CallbackGetValue | Callback function to get the message box return value
_LoadDefaults | Loads the defaults with optimal or Failsafe data.
_SaveValues | Function to save the given values
CallbackShowMessageBox | Callback function to Display the message box Input : UINTN data, UINT8 type
ExitApplication | Function to exit form the setup application
LoadFailsafeDefaults | Loads the failsafe defaults.
LoadOptimalDefaults | Loads the optimal defaults.
LoadPreviousValues | Callback function for LoadPreviousValue.
ResetSys | Function to reset
SaveAndExit | Function to save and exit
SaveAndReset | Function to save and reset
SaveBBSOrder | Function to save the bbs device order
SaveWithoutExit | Function to save without exit
ShowHelpMessageBox | Function to Display the help message box

Built on 16:20:19 10/01/14


_CallbackGetValue in the callback.c

Function : _CallbackGetValue

File: callback.c
Description:
Callback function to get the message box return value
Input:
MSGBOX_DATA *msgbox
Output:
Message box return value
Built on 16:20:03 10/01/14


_LoadDefaults in the callback.c

Function : _LoadDefaults

File: callback.c
Description:
Loads the defaults with optimal or Failsafe data.
Input:
Bool ShowMsgBox.
Output:
none
Built on 16:20:04 10/01/14


_SaveValues in the callback.c

Function : _SaveValues

File: callback.c
Description:
Function to save the given values
Input:
UINTN data
Output:
TRUE/FALSE
Built on 16:20:04 10/01/14


CallbackShowMessageBox in the callback.c

Function : CallbackShowMessageBox

File: callback.c
Description:
Callback function to Display the message box

Input		:	UINTN data,
            UINT8 type
Output:
None
Built on 16:20:05 10/01/14


ExitApplication in the callback.c

Function : ExitApplication

File: callback.c
Description:
Function to exit form the setup application
Input:
None
Output:
TRUE/FALSE
Built on 16:20:07 10/01/14


LoadFailsafeDefaults in the callback.c

Function : LoadFailsafeDefaults

File: callback.c
Description:
Loads the failsafe defaults.
Input:
VOID
Output:
VOID
Built on 16:20:11 10/01/14


LoadOptimalDefaults in the callback.c

Function : LoadOptimalDefaults

File: callback.c
Description:
Loads the optimal defaults.
Input:
VOID
Output:
VOID
Built on 16:20:11 10/01/14


LoadPreviousValues in the callback.c

Function : LoadPreviousValues

File: callback.c
Description:
Callback function for LoadPreviousValue.
Input:
Bool ShowMsgBox.
Output:
none
Built on 16:20:11 10/01/14


ResetSys in the callback.c

Function : ResetSys

File: callback.c
Description:
Function to reset
Input:
VOID
Output:
BOOLEAN
Built on 16:20:14 10/01/14


SaveAndExit in the callback.c

Function : SaveAndExit

File: callback.c
Description:
Function to save and exit
Input:
VOID
Output:
BOOLEAN
Built on 16:20:14 10/01/14


SaveAndReset in the callback.c

Function : SaveAndReset

File: callback.c
Description:
Function to save and reset
Input:
VOID
Output:
BOOLEAN
Built on 16:20:14 10/01/14


SaveBBSOrder in the callback.c

Function : SaveBBSOrder

File: callback.c
Description:
Function to save the bbs device order
Input:
NVRAM_VARIABLE *nvPtr
Output:
None
Built on 16:20:14 10/01/14


SaveWithoutExit in the callback.c

Function : SaveWithoutExit

File: callback.c
Description:
Function to save without exit
Input:
VOID
Output:
VOID
Built on 16:20:14 10/01/14


ShowHelpMessageBox in the callback.c

Function : ShowHelpMessageBox

File: callback.c
Description:
Function to Display the help message box
Input:
None
Output:
None
Built on 16:20:15 10/01/14


callback.h

Description:
Header file for code to handle callbacks
Built on 16:20:19 10/01/14


control.c

Description:
This file contains code to handle controls

The following functions are used in the file: control.c.

Function | Description
ControlCreate | Function to create the cotrol options using object functions.
ControlDestroy | Function to destroy the cotrol options using object functions.
ControlEmptyMethod | Empty control method.
ControlHandleAction | Function to handle action.
ControlInitialize | Function to Initialize the cotrol options using object functions.
ControlSetAttributes | Function to set the control attributes
ControlSetCallback | Function to set callback.
ControlSetDimensions | Function to set dimensions.
ControlSetFocus | Function to set focus.
ControlSetPosition | Function to set the position.

Built on 16:20:19 10/01/14


ControlCreate in the control.c

Function : ControlCreate

File: control.c
Description:
Function to create the cotrol options using object functions.
Input:
CONTROL_DATA **object
Output:
status
Built on 16:20:06 10/01/14


ControlDestroy in the control.c

Function : ControlDestroy

File: control.c
Description:
Function to destroy the cotrol options using object functions.
Input:
CONTROL_DATA *control, BOOLEAN freeMem
Output:
status
Built on 16:20:06 10/01/14


ControlEmptyMethod in the control.c

Function : ControlEmptyMethod

File: control.c
Description:
Empty control method.
Input:
CONTROL_DATA *control
Output:
status
Built on 16:20:06 10/01/14


ControlHandleAction in the control.c

Function : ControlHandleAction

File: control.c
Description:
Function to handle action.
Input:
CONTROL_DATA *control, ACTION_DATA *Data
Output:
STATUS
Built on 16:20:06 10/01/14


ControlInitialize in the control.c

Function : ControlInitialize

File: control.c
Description:
Function to Initialize the cotrol options using object functions.
Input:
CONTROL_DATA *control, VOID *data
Output:
status
Built on 16:20:06 10/01/14


ControlSetAttributes in the control.c

Function : ControlSetAttributes

File: control.c
Description:
Function to set the control attributes
Input:
CONTROL_DATA *control, UINT8 FGColor, UINT8 BGColor
Output:
status
Built on 16:20:06 10/01/14


ControlSetCallback in the control.c

Function : ControlSetCallback

File: control.c
Description:
Function to set callback.
Input:
CONTROL_DATA *control, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
STATUS
Built on 16:20:06 10/01/14


ControlSetDimensions in the control.c

Function : ControlSetDimensions

File: control.c
Description:
Function to set dimensions.
Input:
CONTROL_DATA *control, UINT16 Width, UINT16 Height
Output:
status
Built on 16:20:06 10/01/14


ControlSetFocus in the control.c

Function : ControlSetFocus

File: control.c
Description:
Function to set focus.
Input:
CONTROL_DATA *control, BOOLEAN focus
Output:
status
Built on 16:20:06 10/01/14


ControlSetPosition in the control.c

Function : ControlSetPosition

File: control.c
Description:
Function to set the position.
Input:
CONTROL_DATA *control, UINT16 Left, UINT16 Top
Output:
status
Built on 16:20:06 10/01/14


ctrlcond.c

Description:
This file contains code for control conditions

The following functions are used in the file: ctrlcond.c.

Function | Description
CheckControlAccess | To Check control flags
CheckControlCondition | This function eveluates the condition and retuns the result
CheckInconsistence | Check for inconsistancy
CheckNoSubmitIf | checks NoSubmitIf Parameter: VOID Return value: BOOLEAN
CheckOneOfOptionSuppressIf | Parameter: CONTROL_INFO *ParentCtrlInfo, UINT8* CtrlCondPtr Return value: UINT8
DrawMessageBox | Draw MessageBox Parameter: CONTROL_INFO, UINT16, EFI_STRING_ID Return value: BOOLEAN
EvaluateControlDefault | Parameter: CONTROL_INFO *CtrlInfo Return value: UINT64
EvaluateOpcode | To perform the stack operations based on the opcode
GetExpResult | Function to get exp result
GetVarNumFromID | To get var number from ID
UpdateFinalCondition | To finalize the codition flag

Built on 16:20:19 10/01/14


CheckControlAccess in the ctrlcond.c

Function : CheckControlAccess

File: ctrlcond.c
Description:
To Check control flags
Input:
UINT32 ControlAccess
Output:
Condition
Built on 16:20:05 10/01/14


CheckControlCondition in the ctrlcond.c

Function : CheckControlCondition

File: ctrlcond.c
Description:
This function eveluates the condition and retuns the result
Input:
Control Info
Output:
COND_NONE 		- Condition failed.
        COND_SUPPRESS	- Condition matchs suppress
        COND_GRAYOUT	- Condition matchs Grayout
        COND_HIDDEN		- Condition matchs and Hide
        COND_INCONSISTENT - Inconsistent Condition matchs
Built on 16:20:05 10/01/14


CheckInconsistence in the ctrlcond.c

Function : CheckInconsistence

File: ctrlcond.c
Description:
Check for inconsistancy
Input:
PAGE_INFO *pPageInfo
Output:
TRUE/FALSE
Built on 16:20:05 10/01/14


CheckNoSubmitIf in the ctrlcond.c

Function : CheckNoSubmitIf

File: ctrlcond.c
Description:
checks NoSubmitIf

Parameter:	    VOID

Return value:  	BOOLEAN
Built on 16:20:05 10/01/14


CheckOneOfOptionSuppressIf in the ctrlcond.c

Function : CheckOneOfOptionSuppressIf

File: ctrlcond.c
Description:

Parameter:	    CONTROL_INFO *ParentCtrlInfo, UINT8* CtrlCondPtr

Return value:  UINT8
Built on 16:20:05 10/01/14


DrawMessageBox in the ctrlcond.c

Function : DrawMessageBox

File: ctrlcond.c
Description:
Draw MessageBox

Parameter:	  CONTROL_INFO, UINT16, EFI_STRING_ID

Return value:  	BOOLEAN
Built on 16:20:07 10/01/14


EvaluateControlDefault in the ctrlcond.c

Function : EvaluateControlDefault

File: ctrlcond.c
Description:

Parameter:	    CONTROL_INFO *CtrlInfo

Return value:  UINT64
Built on 16:20:07 10/01/14


EvaluateOpcode in the ctrlcond.c

Function : EvaluateOpcode

File: ctrlcond.c
Description:
To perform the stack operations based on the opcode
Input:
UINT8 OpCode
Output:
void
Built on 16:20:07 10/01/14


GetExpResult in the ctrlcond.c

Function : GetExpResult

File: ctrlcond.c
Description:
Function to get exp result
Input:
nil
Output:
result
Built on 16:20:08 10/01/14


GetVarNumFromID in the ctrlcond.c

Function : GetVarNumFromID

File: ctrlcond.c
Description:
To get var number from ID
Input:
unsigned int ID
Output:
VarCount
Built on 16:20:08 10/01/14


UpdateFinalCondition in the ctrlcond.c

Function : UpdateFinalCondition

File: ctrlcond.c
Description:
To finalize the codition flag
Input:
UINT8 FinalCond, UINT8 Cond
Output:
Condition
Built on 16:20:18 10/01/14


ctrlcond.h

Description:
Header file for control conditions
Built on 16:20:19 10/01/14


Date.c

Description:
This file contains code to handle Date control operations

The following functions are used in the file: Date.c.

Function | Description
_DateDecrease | Function to decrement date.
_DateGetWeekDay | Function to get weekday.
_DateIncrease | Function to increment date.
_DateUpdateEntry | Function to update entry.
_DateUpdateHelp | Function to update help.
DateCreate | Function to create the date, which uses the Control fucntions.
DateDestroy | Function to destroy the date, which uses the Control fucntions.
DateGetControlHeight | Function to get the data label height.
DateInitialize | Function to Initialize the date, which uses the Control fucntions.
DateSetAttributes | Function to set the date attributes.
DateSetCallback | Function to set callback.
DateSetDimensions | Function to set the date dimensions.
DateSetFocus | Function to set the Date focus.
DateSetPosition | Function to set the date position.

Built on 16:20:19 10/01/14


_DateDecrease in the Date.c

Function : _DateDecrease

File: Date.c
Description:
Function to decrement date.
Input:
DATE_DATA *date
Output:
VOID
Built on 16:20:03 10/01/14


_DateGetWeekDay in the Date.c

Function : _DateGetWeekDay

File: Date.c
Description:
Function to get weekday.
Input:
EFI_TIME *tm
Output:
UINTN
Built on 16:20:03 10/01/14


_DateIncrease in the Date.c

Function : _DateIncrease

File: Date.c
Description:
Function to increment date.
Input:
DATE_DATA *date
Output:
VOID
Built on 16:20:03 10/01/14


_DateUpdateEntry in the Date.c

Function : _DateUpdateEntry

File: Date.c
Description:
Function to update entry.
Input:
DATE_DATA *date
Output:
VOID
Built on 16:20:03 10/01/14


_DateUpdateHelp in the Date.c

Function : _DateUpdateHelp

File: Date.c
Description:
Function to update help.
Input:
DATE_DATA *date
Output:
VOID
Built on 16:20:03 10/01/14


DateCreate in the Date.c

Function : DateCreate

File: Date.c
Description:
Function to create the date, which uses the Control fucntions.
Input:
DATE_DATA **object
Output:
status
Built on 16:20:06 10/01/14


DateDestroy in the Date.c

Function : DateDestroy

File: Date.c
Description:
Function to destroy the date, which uses the Control fucntions.
Input:
DATE_DATA *date, BOOLEAN freeMem
Output:
status
Built on 16:20:06 10/01/14


DateGetControlHeight in the Date.c

Function : DateGetControlHeight

File: Date.c
Description:
Function to get the data label height.
Input:
DATE_DATA *date, frame, UINT16 *height
Output:
status
Built on 16:20:06 10/01/14


DateInitialize in the Date.c

Function : DateInitialize

File: Date.c
Description:
Function to Initialize the date, which uses the Control fucntions.
Input:
DATE_DATA *date, VOID *data
Output:
status
Built on 16:20:06 10/01/14


DateSetAttributes in the Date.c

Function : DateSetAttributes

File: Date.c
Description:
Function to set the date attributes.
Input:
DATE_DATA *date, UINT8 FGColor, UINT8 BGColor
Output:
status
Built on 16:20:06 10/01/14


DateSetCallback in the Date.c

Function : DateSetCallback

File: Date.c
Description:
Function to set callback.
Input:
DATE_DATA *date, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
STATUS
Built on 16:20:06 10/01/14


DateSetDimensions in the Date.c

Function : DateSetDimensions

File: Date.c
Description:
Function to set the date dimensions.
Input:
DATE_DATA *date, UINT16 Width, UINT16 Height
Output:
status
Built on 16:20:06 10/01/14


DateSetFocus in the Date.c

Function : DateSetFocus

File: Date.c
Description:
Function to set the Date focus.
Input:
DATE_DATA *date, BOOLEAN focus
Output:
status
Built on 16:20:06 10/01/14


DateSetPosition in the Date.c

Function : DateSetPosition

File: Date.c
Description:
Function to set the date position.
Input:
DATE_DATA *date, UINT16 Left, UINT16 Top
Output:
status
Built on 16:20:06 10/01/14


Date.h

Description:
Header file for Date controls
Built on 16:20:19 10/01/14


dobmpmgr.c

Description:
file contains code that is  taken from graphics.c
        to eliminnate library dependancy

The following functions are used in the file: dobmpmgr.c.

Function | Description
MemFreePointer | Convert a *.BMP graphics image to a UGA blt buffer. If a NULL UgaBlt buffer is passed in a UgaBlt buffer will be allocated by this routine. If a UgaBlt buffer is passed in it will be used if it is big enough.

Built on 16:20:19 10/01/14


MemFreePointer in the dobmpmgr.c

Function : MemFreePointer

File: dobmpmgr.c
Description:
Convert a *.BMP graphics image to a UGA blt buffer.
            If a NULL UgaBlt buffer is passed in a UgaBlt buffer will
            be allocated by this routine. If a UgaBlt buffer is passed
            in it will be used if it is big enough.
Input:
BmpImage      - Pointer to BMP file
            BmpImageSize  - Number of bytes in BmpImage
            UgaBlt        - Buffer containing UGA version of BmpImage.
            UgaBltSize    - Size of UgaBlt in bytes.
            PixelHeight   - Height of UgaBlt/BmpImage in pixels
            PixelWidth    - Width of UgaBlt/BmpImage in pixels
Output:
EFI_SUCCESS           - UgaBlt and UgaBltSize are returned.
            EFI_UNSUPPORTED       - BmpImage is not a valid *.BMP image
            EFI_BUFFER_TOO_SMALL  - The passed in UgaBlt buffer is not big enough.
       UgaBltSize will contain the required size.
            EFI_OUT_OF_RESOURCES  - No enough buffer to allocate
Built on 16:20:11 10/01/14


dogif.c

Description:
This file contains code for gif image handling

The following functions are used in the file: dogif.c.

Function | Description
Expand_Data | Decompress a LZW compressed data stream.
readbuf | Read the next byte from buffer
ReadImageDesc | Read the image description and the optional color map.
ReadScreenDesc | Read the signature, the screen description, and the optional default color map.
SkipObject | Skip over an extended GIF object.
writepixel | Write a pixel at (X,Y) on the screen.

Built on 16:20:19 10/01/14


Expand_Data in the dogif.c

Function : Expand_Data

File: dogif.c
Description:
Decompress a LZW compressed data stream.
Input:
None
Output:
0       OK
            -1      expected end-of-file
            -2      cannot allocate memory
            -3      bad "min_code_size"
            < -3    error status from the get_byte or put_byte routine
Built on 16:20:07 10/01/14


readbuf in the dogif.c

Function : readbuf

File: dogif.c
Description:
Read the next byte from buffer
Input:
None
Output:
0 .. 255        the byte
            -1              end of file
Built on 16:20:14 10/01/14


ReadImageDesc in the dogif.c

Function : ReadImageDesc

File: dogif.c
Description:
Read the image description and the optional color map.
Input:
None
Output:
TRUE/FALSE
Built on 16:20:14 10/01/14


ReadScreenDesc in the dogif.c

Function : ReadScreenDesc

File: dogif.c
Description:
Read the signature, the screen description, and the optional
            default color map.
Input:
None
Output:
TRUE/FALSE
Built on 16:20:14 10/01/14


SkipObject in the dogif.c

Function : SkipObject

File: dogif.c
Description:
Skip over an extended GIF object.
Input:
None
Output:
TRUE/FALSE
Built on 16:20:15 10/01/14


writepixel in the dogif.c

Function : writepixel

File: dogif.c
Description:
Write a pixel at (X,Y) on the screen.
Input:
unsigned char Pixel
Output:
None
Built on 16:20:18 10/01/14


dogifmgr.c

Description:
This file contains code for gif image handling

The following functions are used in the file: dogifmgr.c.

Function | Description
CleanUpGif | Cleans the gif datas
ConvertGifToUgaBlt | Convert a *.GIF graphics image to a UGA blt buffer. If a NULL UgaBlt buffer is passed in a UgaBlt buffer will be allocated by this routine. If a UgaBlt buffer is passed in it will be used if it is big enough.
DoGifAnimate | function to Handle gif logo animation
GetGifNextFrame |
NextFrame | function to get the next frame.
SaveCleanUpGifDatas | Saves the structures used for preserving the gif images

Built on 16:20:19 10/01/14


CleanUpGif in the dogifmgr.c

Function : CleanUpGif

File: dogifmgr.c
Description:
Cleans the gif datas
Input:
void
Output:
void
Built on 16:20:06 10/01/14


ConvertGifToUgaBlt in the dogifmgr.c

Function : ConvertGifToUgaBlt

File: dogifmgr.c
Description:
Convert a *.GIF graphics image to a UGA blt buffer. If a
            NULL UgaBlt buffer is passed in a UgaBlt buffer will be
            allocated by this routine. If a UgaBlt buffer is passed in
            it will be used if it is big enough.
Input:
GifImage      - Pointer to GIF file
            GifImageSize  - Number of bytes in BmpImage
            UgaBlt        - Buffer containing UGA version of GifImage.
            UgaBltSize    - Size of UgaBlt in bytes.
            PixelHeight   - Height of UgaBlt/BmpImage in pixels
            PixelWidth    - Width of UgaBlt/BmpImage in pixels
            GifDelay      -
Output:
EFI_SUCCESS - UgaBlt and UgaBltSize are returned.
            EFI_UNSUPPORTED       - GifImage is not a valid *.GIF image
            EFI_BUFFER_TOO_SMALL  - The passed in UgaBlt buffer is not big enough.
           UgaBltSize will contain the required size.
            EFI_OUT_OF_RESOURCES  - No enough buffer to allocate
Built on 16:20:06 10/01/14


DoGifAnimate in the dogifmgr.c

Function : DoGifAnimate

File: dogifmgr.c
Description:
function to Handle gif logo animation
Input:
CO_ORD_ATTRIBUTE Attribute,
        INTN CoordinateX,INTN CoordinateY
Output:
None
Built on 16:20:06 10/01/14


GetGifNextFrame in the dogifmgr.c

Function : GetGifNextFrame

File: dogifmgr.c
Description:
Input:
VOID **UgaBlt , UINTN *GifDelay
Output:
EFI_STATUS
Built on 16:20:08 10/01/14


NextFrame in the dogifmgr.c

Function : NextFrame

File: dogifmgr.c
Description:
function to get the next frame.
Input:
EFI_EVENT Event, VOID *Context
Output:
void
Built on 16:20:12 10/01/14


SaveCleanUpGifDatas in the dogifmgr.c

Function : SaveCleanUpGifDatas

File: dogifmgr.c
Description:
Saves the structures used for preserving the gif images
Input:
GifDatas - Pointer to a pointer for GIF image structure
Output:
void
Built on 16:20:14 10/01/14


edit.c

Description:
This file contains code to handle Edit control operations

The following functions are used in the file: edit.c.

Function | Description
_EditHandleActionKey | Function to handle Edit actions.
EditCreate | Function to create Edit Controls, which uses the control functions.
EditDestroy | Function to Destroy Edit Controls, which uses the control functions.
EditDraw | Function to draw Edit Controls.
EditGetControlHight | Function unsuppored.
EditHandleAction | Function to handle Edit actions.
EditInitialize | Function to Initialize Edit Controls, which uses the control functions.
EditSetAttributes | Function to set the edit attributes.
EditSetCallback | Function to set callback.
EditSetDimensions | Function to set the edit dimensions.
EditSetFocus | Function to set the edit focus.
EditSetPosition | Function to set the edit position.

Built on 16:20:19 10/01/14


_EditHandleActionKey in the edit.c

Function : _EditHandleActionKey

File: edit.c
Description:
Function to handle Edit actions.
Input:
EDIT_DATA *edit, AMI_EFI_KEY_DATA key
Output:
EFI_STATUS
Built on 16:20:03 10/01/14


EditCreate in the edit.c

Function : EditCreate

File: edit.c
Description:
Function to create Edit Controls, which uses the control functions.
Input:
EDIT_DATA **object
Output:
status
Built on 16:20:07 10/01/14


EditDestroy in the edit.c

Function : EditDestroy

File: edit.c
Description:
Function to Destroy Edit Controls, which uses the control functions.
Input:
EDIT_DATA *edit, BOOLEAN freeMem
Output:
status
Built on 16:20:07 10/01/14


EditDraw in the edit.c

Function : EditDraw

File: edit.c
Description:
Function to draw Edit Controls.
Input:
EDIT_DATA *edit
Output:
status
Built on 16:20:07 10/01/14


EditGetControlHight in the edit.c

Function : EditGetControlHight

File: edit.c
Description:
Function unsuppored.
Input:
VOID *object,VOID *frame, UINT16 *height
Output:
status
Built on 16:20:07 10/01/14


EditHandleAction in the edit.c

Function : EditHandleAction

File: edit.c
Description:
Function to handle Edit actions.
Input:
EDIT_DATA *edit, ACTION_DATA *Data
Output:
status
Built on 16:20:07 10/01/14


EditInitialize in the edit.c

Function : EditInitialize

File: edit.c
Description:
Function to Initialize Edit Controls, which uses the control functions.
Input:
EDIT_DATA *edit, VOID *data
Output:
status
Built on 16:20:07 10/01/14


EditSetAttributes in the edit.c

Function : EditSetAttributes

File: edit.c
Description:
Function to set the edit attributes.
Input:
EDIT_DATA *edit, UINT8 FGColor, UINT8 BGColor
Output:
status
Built on 16:20:07 10/01/14


EditSetCallback in the edit.c

Function : EditSetCallback

File: edit.c
Description:
Function to set callback.
Input:
EDIT_DATA *edit, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
STATUS
Built on 16:20:07 10/01/14


EditSetDimensions in the edit.c

Function : EditSetDimensions

File: edit.c
Description:
Function to set the edit dimensions.
Input:
EDIT_DATA *edit, UINT16 Width, UINT16 Height
Output:
status
Built on 16:20:07 10/01/14


EditSetFocus in the edit.c

Function : EditSetFocus

File: edit.c
Description:
Function to set the edit focus.
Input:
EDIT_DATA *edit, BOOLEAN focus
Output:
status
Built on 16:20:07 10/01/14


EditSetPosition in the edit.c

Function : EditSetPosition

File: edit.c
Description:
Function to set the edit position.
Input:
EDIT_DATA *edit, UINT16 Left, UINT16 Top
Output:
status
Built on 16:20:07 10/01/14


edit.h

Description:
Header file for Edit controls
Built on 16:20:19 10/01/14


EDKhelper.c

Description:
This file contains code from EDK library.

The following functions are used in the file: EDKhelper.c.

Function | Description
BufferToHexString | Converts binary buffer to Unicode string in reversed byte order from BufToHexString().
BufToHexString | Converts binary buffer to Unicode string. At a minimum, any blob of data could be represented as a hex string.
DPAdd | To avoid including EDK libs.
DPAddNode | To avoid including EDK libs.
EfiCompareGuid | To avoid including EDK libs.
EfiCompareMem | To avoid including EDK libs.
EfiDevicePathFromHandle | To avoid including EDK libs.
EfiFileDevicePath | To avoid including EDK libs.
EfiInitializeDriverLib | To avoid including EDK libs.
EfiInitializeFwVolDevicepathNode | To avoid including EDK libs.
EfiLibAllocateCopyPool | Allocate BootServicesData pool and use a buffer provided by caller to fill it.
EfiLibAllocatePool | To avoid including EDK libs.
EfiLibAllocateZeroPool | To avoid including EDK libs.
EfiLibNamedEventSignal | To avoid including EDK libs.
EfiStrStr | Find a substring.
HexStringToBuf | To avoid including EDK libs.
HexToNibbleChar | Converts the hex value to character.
IsHexDigit | To avoid including EDK libs.
LibReportStatusCode | To avoid including EDK libs.
Mul64 | To avoid including EDK libs.
NameValueBufToHexString | Converts binary buffer to Unicode string. At a minimum, any blob of data could be represented as a hex string. Used only for name value implementaion
NameValueHexStringToBuf | Converts name value string to buffer
NibbleToHexChar | Converts the low nibble of a byte to hex unicode character.
SwapBuffer | Swap bytes in the buffer.
ToLower | Converts the unicode character of the string from uppercase to lowercase.
TseEfiCreateEventReadyToBoot | To avoid including EDK libs.
UnicodeToConfigString | Convert Unicode string to binary representation Config string, e.g. "ABCD" => "0041004200430044". Config string appears in <ConfigHdr> (i.e. "&NAME=<string>"), or Name/Value pair in <ConfigBody> (i.e. "label=<string>").
Wcscmp | To avoid including EDK libs.
Wcscpy | To avoid including EDK libs.
Wcslen | To avoid including EDK libs.

Built on 16:20:19 10/01/14


BufferToHexString in the EDKhelper.c

Function : BufferToHexString

File: EDKhelper.c
Description:
Converts binary buffer to Unicode string in reversed byte order from BufToHexString().
Input:
Str        -  String for Output
            Buffer     -  Binary buffer.
            BufferSize -  Size of the buffer in bytes.
Output:
EFI_SUCCESS  -  The function completed successfully.
Built on 16:20:05 10/01/14


BufToHexString in the EDKhelper.c

Function : BufToHexString

File: EDKhelper.c
Description:
Converts binary buffer to Unicode string.
            At a minimum, any blob of data could be represented as a hex string.
Input:
Str - Pointer to the string.
            HexStringBufferLength - Length in bytes of buffer to hold the hex string. Includes tailing '\0' character.
                         If routine return with EFI_SUCCESS, containing length of hex string buffer.
                         If routine return with EFI_BUFFER_TOO_SMALL, containg length of hex string buffer desired.
            Buf - Buffer to be converted from.
            Len - Length in bytes of the buffer to be converted.
Output:
EFI_SUCCESS: Routine success.
            EFI_BUFFER_TOO_SMALL: The hex string buffer is too small.
Built on 16:20:05 10/01/14


DPAdd in the EDKhelper.c

Function : DPAdd

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
EFI_DEVICE_PATH_PROTOCOL *pDp1, EFI_DEVICE_PATH_PROTOCOL *pDp2
Output:
VOID*
Built on 16:20:06 10/01/14


DPAddNode in the EDKhelper.c

Function : DPAddNode

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
EFI_DEVICE_PATH_PROTOCOL *pDp1, EFI_DEVICE_PATH_PROTOCOL *pDp2
Output:
VOID*
Built on 16:20:06 10/01/14


EfiCompareGuid in the EDKhelper.c

Function : EfiCompareGuid

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
IN EFI_GUID *Guid1,  IN EFI_GUID *Guid2
Output:
BOOLEAN
Built on 16:20:07 10/01/14


EfiCompareMem in the EDKhelper.c

Function : EfiCompareMem

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
IN VOID *MemOne, IN VOID *MemTwo,
Output:
INTN
Built on 16:20:07 10/01/14


EfiDevicePathFromHandle in the EDKhelper.c

Function : EfiDevicePathFromHandle

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
IN EFI_HANDLE  Handle
Output:
EFI_DEVICE_PATH_PROTOCOL *
Built on 16:20:07 10/01/14


EfiFileDevicePath in the EDKhelper.c

Function : EfiFileDevicePath

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
IN EFI_HANDLE Device  OPTIONAL, IN CHAR16 *FileName
Output:
EFI_DEVICE_PATH_PROTOCOL *
Built on 16:20:07 10/01/14


EfiInitializeDriverLib in the EDKhelper.c

Function : EfiInitializeDriverLib

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
ImageHandle and Systemtable
Output:
Status
Built on 16:20:07 10/01/14


EfiInitializeFwVolDevicepathNode in the EDKhelper.c

Function : EfiInitializeFwVolDevicepathNode

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
IN  MEDIA_FW_VOL_FILEPATH_DEVICE_PATH *FvDevicePathNode,
        IN EFI_GUID *NameGuid
Output:
VOID EFIAPI
Built on 16:20:07 10/01/14


EfiLibAllocateCopyPool in the EDKhelper.c

Function : EfiLibAllocateCopyPool

File: EDKhelper.c
Description:
Allocate BootServicesData pool and use a buffer provided by
            caller to fill it.
Input:
AllocationSize  - The size to allocate
            Buffer          - Buffer that will be filled into the buffer allocated
Output:
Pointer of the buffer allocated.
Built on 16:20:07 10/01/14


EfiLibAllocatePool in the EDKhelper.c

Function : EfiLibAllocatePool

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
size
Output:
pointer
Built on 16:20:07 10/01/14


EfiLibAllocateZeroPool in the EDKhelper.c

Function : EfiLibAllocateZeroPool

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
size
Output:
pointer
Built on 16:20:07 10/01/14


EfiLibNamedEventSignal in the EDKhelper.c

Function : EfiLibNamedEventSignal

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
IN EFI_GUID            *Name
Output:
STATUS
Built on 16:20:07 10/01/14


EfiStrStr in the EDKhelper.c

Function : EfiStrStr

File: EDKhelper.c
Description:
Find a substring.
Input:
String      - Null-terminated string to search.
            StrCharSet  - Null-terminated string to search for.
Output:
The address of the first occurrence of the matching substring if successful,
            or NULL otherwise.
Built on 16:20:07 10/01/14


HexStringToBuf in the EDKhelper.c

Function : HexStringToBuf

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
Output:

Built on 16:20:09 10/01/14


HexToNibbleChar in the EDKhelper.c

Function : HexToNibbleChar

File: EDKhelper.c
Description:
Converts the hex value to character.
Input:
Nibble - lower nibble of a byte.
Output:
Hex unicode character.
Built on 16:20:09 10/01/14


IsHexDigit in the EDKhelper.c

Function : IsHexDigit

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
Output:

Built on 16:20:10 10/01/14


LibReportStatusCode in the EDKhelper.c

Function : LibReportStatusCode

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
IN EFI_STATUS_CODE_TYPE Type, IN EFI_STATUS_CODE_VALUE Value,
        IN UINT32 Instance, IN EFI_GUID *CallerId OPTIONAL,
        IN EFI_STATUS_CODE_DATA *Data OPTIONAL
Output:
STATUS
Built on 16:20:10 10/01/14


Mul64 in the EDKhelper.c

Function : Mul64

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
Output:

Built on 16:20:11 10/01/14


NameValueBufToHexString in the EDKhelper.c

Function : NameValueBufToHexString

File: EDKhelper.c
Description:
Converts binary buffer to Unicode string.
            At a minimum, any blob of data could be represented as a hex string.
            Used only for name value implementaion
Input:
Str - Pointer to the string.
            HexStringBufferLength - Length in bytes of buffer to hold the hex string. Includes tailing '\0' character.
                         If routine return with EFI_SUCCESS, containing length of hex string buffer.
                         If routine return with EFI_BUFFER_TOO_SMALL, containg length of hex string buffer desired.
            Buf - Buffer to be converted from.
            Len - Length in bytes of the buffer to be converted.
Output:
EFI_SUCCESS: Routine success.
            EFI_BUFFER_TOO_SMALL: The hex string buffer is too small.
Built on 16:20:11 10/01/14


NameValueHexStringToBuf in the EDKhelper.c

Function : NameValueHexStringToBuf

File: EDKhelper.c
Description:
Converts name value string to buffer
Input:
: 	Buf    - Pointer to buffer that receives the data.
    Len    - Length in bytes of the buffer to hold converted data.
    If routine return with EFI_SUCCESS, containing length of converted data.
    If routine return with EFI_BUFFER_TOO_SMALL, containg length of buffer desired.
    Str    - String to be converted from.
    ConvertedStrLen - Length of the Hex String consumed.
Output:
EFI_SUCCESS: Routine Success.
    EFI_BUFFER_TOO_SMALL: The buffer is too small to hold converted data.
Built on 16:20:12 10/01/14


NibbleToHexChar in the EDKhelper.c

Function : NibbleToHexChar

File: EDKhelper.c
Description:
Converts the low nibble of a byte  to hex unicode character.
Input:
Nibble - lower nibble of a byte.
Output:
Hex unicode character.
Built on 16:20:12 10/01/14


SwapBuffer in the EDKhelper.c

Function : SwapBuffer

File: EDKhelper.c
Description:
Swap bytes in the buffer.
Input:
Buffer     -  Binary buffer.
            BufferSize -  Size of the buffer in bytes.
Output:
None
Built on 16:20:16 10/01/14


ToLower in the EDKhelper.c

Function : ToLower

File: EDKhelper.c
Description:
Converts the unicode character of the string from uppercase to lowercase.
Input:
Str        -  String to be converted
Output:
None
Built on 16:20:16 10/01/14


TseEfiCreateEventReadyToBoot in the EDKhelper.c

Function : TseEfiCreateEventReadyToBoot

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
IN EFI_TPL                      NotifyTpl,
        IN EFI_EVENT_NOTIFY             NotifyFunction,
        IN VOID                         *NotifyContext,
        OUT EFI_EVENT                   *ReadyToBootEvent
Output:
EFI_STATUS
Built on 16:20:16 10/01/14


UnicodeToConfigString in the EDKhelper.c

Function : UnicodeToConfigString

File: EDKhelper.c
Description:
Convert Unicode string to binary representation Config string, e.g.
            "ABCD" => "0041004200430044". Config string appears in <ConfigHdr> (i.e.
            "&NAME=<string>"), or Name/Value pair in <ConfigBody> (i.e. "label=<string>").
Input:
ConfigString  - Binary representation of Unicode String, <string> := (<HexCh>4)+
            StrBufferLen  - On input: Length in bytes of buffer to hold the Unicode string.
        Includes tailing '\0' character.
            On Output:
                If return EFI_SUCCESS, containing length of Unicode string buffer.
                If return EFI_BUFFER_TOO_SMALL, containg length of string buffer desired.
            UnicodeString - Original Unicode string.
Output:
EFI_SUCCESS          - Routine success.
            EFI_BUFFER_TOO_SMALL - The string buffer is too small.
Built on 16:20:17 10/01/14


Wcscmp in the EDKhelper.c

Function : Wcscmp

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
CHAR16 *string1, CHAR16 *string2
Output:
int
Built on 16:20:18 10/01/14


Wcscpy in the EDKhelper.c

Function : Wcscpy

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
CHAR16 *string1, CHAR16* string2
Output:
CHAR16*
Built on 16:20:18 10/01/14


Wcslen in the EDKhelper.c

Function : Wcslen

File: EDKhelper.c
Description:
To avoid including EDK libs.
Input:
CHAR16 *string
Output:
UINTN
Built on 16:20:18 10/01/14


EDKhelper.h

Description:
Edk helper header file.
Built on 16:20:19 10/01/14


Expression.c

Description:
Expression evaluation.

The following functions are used in the file: Expression.c.

Function | Description
_GetRuleControlfromId | Parameter: UINT8 *IFRData, CONTROL_INFO **RuleControl Return value: EFI_STATUS
_GetValueFromQuestionId | Parameter: UINT16 QuestionId, UINT16 PageId, UINT64 *Value Return value: EFI_STATUS
_SetValueFromQuestionId | Parameter: UINT16 QuestionId, UINT16 PageId, UINT64 *Value Return value: EFI_STATUS
_SkipExpression | Travels till the end of the current Expression and returns the offset Parameter: ControlCondPtr - Pointer to the Expression beginning. Return value: UINTN - Offsets to skip the current expression.
checkforpushthispresence | Checks the condition has EFI_IFR_THIS_OP Parameter: UINT8 * Return value: TRUE if EFI_IFR_THIS_OP presents else FALSE
CompareHiiValue | Compare two Hii Value Parameter: Value1 - Expression value to compare on left-hand Value2 - Expression value to compare on right-hand HiiHandle - Only required for string compare Return value: EFI_INVALID_PARAMETER - Could not perform comparation on two values 0 - Two operators equeal < 0 - Value1 is greater than Value2 > 0 - Value1 is less than Value2
EvaluateExpression | Evaluate the result of a HII expression Parameter: IN CONTROL_INFO *ControlInfo, IN OUT BOOLEAN *ExpressionResult, OUT UINTN *Offset Return value: EFI_SUCCESS - The expression evaluated successfuly EFI_NOT_FOUND - The Question which referenced by a QuestionId could not be found. EFI_OUT_OF_RESOURCES - There is not enough system memory to grow the stack. EFI_ACCESS_DENIED - The pop operation underflowed the stack EFI_INVALID_PARAMETER - Syntax error with the Expression
ExtendValueToU64 | Zero extend integer/boolean/date/time to UINT64 for comparing. Parameter: Value - HII Value to be converted. Return value: None.
GetPageIdFromGuid | Finds the page ID with matching Guid from the page list
GetValueFromParentControl | Gets the value for inconsistent/submitif from its parent control Parameter: UINT16, UINT16, EFI_HII_VALUE **, PAGE_INFO *, VOID * Return value: EFI_SUCCESS if value retrieved successfully else some other EFI Status
GrowStack | Grow size of the stack Parameter: Stack - On input: old stack; On Output: new stack StackPtr - On input: old stack pointer; On Output: new stack pointer StackPtr - On input: old stack end; On Output: new stack end Return value: EFI_SUCCESS - Grow stack success. EFI_OUT_OF_RESOURCES - No enough memory for stack space.
IfrCatenate | Evaluate opcode EFI_IFR_TO_UINT. Parameter: FormSet - Formset which contains this opcode. Result - Evaluation result for this opcode. Return value: EFI_SUCCESS - Opcode evaluation success. Other - Opcode evaluation failed.
IfrFind | Evaluate opcode EFI_IFR_FIND. Parameter: FormSet - Formset which contains this opcode. Format - Case sensitive or insensitive. Result - Evaluation result for this opcode. Return value: EFI_SUCCESS - Opcode evaluation success. Other - Opcode evaluation failed.
IfrMatch | Evaluate opcode EFI_IFR_MATCH. Parameter: FormSet - Formset which contains this opcode. Result - Evaluation result for this opcode. Return value: EFI_SUCCESS - Opcode evaluation success. Other - Opcode evaluation failed.
IfrMid | Evaluate opcode EFI_IFR_MID. Parameter: FormSet - Formset which contains this opcode. Result - Evaluation result for this opcode. Return value: EFI_SUCCESS - Opcode evaluation success. Other - Opcode evaluation failed.
IfrSpan | Evaluate opcode EFI_IFR_SPAN. Parameter: FormSet - Formset which contains this opcode. Flags - FIRST_MATCHING or FIRST_NON_MATCHING. Result - Evaluation result for this opcode. Return value: EFI_SUCCESS - Opcode evaluation success. Other - Opcode evaluation failed.
IfrStrToUpper | function to conver the lower case string to upper Parameter: Return value: None
IfrToken | Evaluate opcode EFI_IFR_TOKEN. Parameter: FormSet - Formset which contains this opcode. Result - Evaluation result for this opcode. Return value: EFI_SUCCESS - Opcode evaluation success. Other - Opcode evaluation failed.
IfrToString | Evaluate opcode EFI_IFR_TO_STRING. Parameter: FormSet - Formset which contains this opcode. Format - String format in EFI_IFR_TO_STRING. Result - Evaluation result for this opcode. Return value: EFI_SUCCESS - Opcode evaluation success. Other - Opcode evaluation failed.
IfrToUint | Evaluate opcode EFI_IFR_TO_UINT. Parameter: FormSet - Formset which contains this opcode. Result - Evaluation result for this opcode. Return value: EFI_SUCCESS - Opcode evaluation success. Other - Opcode evaluation failed.
InitializeUnicodeCollationProtocol | Locate the Unicode Collation Protocol interface for later use. Parameter: None Return value: EFI_SUCCESS - Protocol interface Initialize success. Other - Protocol interface Initialize failed.
IsScopeStackEmpty | Parameter: VOID Return value: BOOLEAN
PopExpression | Pop an Expression value from the Stack Parameter: Value - Expression value to pop. Return value: EFI_SUCCESS - The value was popped onto the stack. EFI_OUT_OF_RESOURCES - The pop operation underflowed the stack
PopScope | Pop an Operand from the Stack Parameter: Operand to pop. Return value: EFI_SUCCESS - The value was pushed onto the stack. EFI_OUT_OF_RESOURCES - There is not enough system memory to grow the stack.
PopStack | Pop an element from the stack. Parameter: Stack - On input: old stack; On Output: new stack StackPtr - On input: old stack pointer; On Output: new stack pointer StackPtr - On input: old stack end; On Output: new stack end Data - Data to pop. Return value: EFI_SUCCESS - The value was popped onto the stack. EFI_ACCESS_DENIED - The pop operation underflowed the stack
PushExpression | Push an Expression value onto the Stack Parameter: Value - Expression value to push. Return value: EFI_SUCCESS - The value was pushed onto the stack. EFI_OUT_OF_RESOURCES - There is not enough system memory to grow the stack.
PushScope | Push an Operand onto the Stack Parameter: Operand to push. Return value: EFI_SUCCESS - The value was pushed onto the stack. EFI_OUT_OF_RESOURCES - There is not enough system memory to grow the stack.
PushStack | Push an element onto the Boolean Stack Parameter: Stack - On input: old stack; On Output: new stack StackPtr - On input: old stack pointer; On Output: new stack pointer StackPtr - On input: old stack end; On Output: new stack end Data - Data to push. Return value: EFI_SUCCESS - Push stack success.
ResetExpressionStack | Reset stack pointer to begin of the stack. Parameter: None. Return value: None
ResetScopeStack | Reset stack pointer to begin of the stack. Parameter: None. Return value: None.

Built on 16:20:19 10/01/14


_GetRuleControlfromId in the Expression.c

Function : _GetRuleControlfromId

File: Expression.c
Description:

Parameter:	 UINT8 *IFRData, CONTROL_INFO **RuleControl

Return value: EFI_STATUS
Built on 16:20:04 10/01/14


_GetValueFromQuestionId in the Expression.c

Function : _GetValueFromQuestionId

File: Expression.c
Description:

Parameter:	 UINT16 QuestionId, UINT16 PageId, UINT64 *Value

Return value: EFI_STATUS
Built on 16:20:04 10/01/14


_SetValueFromQuestionId in the Expression.c

Function : _SetValueFromQuestionId

File: Expression.c
Description:

Parameter:	 UINT16 QuestionId, UINT16 PageId, UINT64 *Value

Return value: EFI_STATUS
Built on 16:20:04 10/01/14


_SkipExpression in the Expression.c

Function : _SkipExpression

File: Expression.c
Description:
Travels till the end of the current Expression and returns the offset

Parameter:	  ControlCondPtr - Pointer to the Expression beginning.

Return value:  UINTN  - Offsets to skip the current expression.
Built on 16:20:04 10/01/14


checkforpushthispresence in the Expression.c

Function : checkforpushthispresence

File: Expression.c
Description:
Checks the condition has EFI_IFR_THIS_OP

Parameter:	 UINT8  *

Return value: TRUE if EFI_IFR_THIS_OP presents else FALSE
Built on 16:20:05 10/01/14


CompareHiiValue in the Expression.c

Function : CompareHiiValue

File: Expression.c
Description:
Compare two Hii Value

Parameter:	   Value1    - Expression value to compare on left-hand
  Value2    - Expression value to compare on right-hand
  HiiHandle - Only required for string compare

Return value:    EFI_INVALID_PARAMETER  - Could not perform comparation on two values
            0                      - Two operators equeal
        < 0                    - Value1 is greater than Value2
        > 0                    - Value1 is less than Value2
Built on 16:20:06 10/01/14


EvaluateExpression in the Expression.c

Function : EvaluateExpression

File: Expression.c
Description:
Evaluate the result of a HII expression

Parameter:	 IN CONTROL_INFO *ControlInfo,
IN OUT BOOLEAN  *ExpressionResult,
OUT UINTN       *Offset

Return value: EFI_SUCCESS           - The expression evaluated successfuly
EFI_NOT_FOUND         - The Question which referenced by a
                        QuestionId could not be found.
EFI_OUT_OF_RESOURCES  - There is not enough system memory to
                        grow the stack.
EFI_ACCESS_DENIED     - The pop operation underflowed the stack
EFI_INVALID_PARAMETER - Syntax error with the Expression
Built on 16:20:07 10/01/14


ExtendValueToU64 in the Expression.c

Function : ExtendValueToU64

File: Expression.c
Description:
Zero extend integer/boolean/date/time to UINT64 for comparing.

Parameter:	  Value    - HII Value to be converted.

Return value:  None.
Built on 16:20:07 10/01/14


GetPageIdFromGuid in the Expression.c

Function : GetPageIdFromGuid

File: Expression.c
Description:
Finds the page ID with matching Guid from the page list
Input:
EFI_GUID *FormSetGuid
UINT16 *PageID
Output:
EFI_STATUS status - EFI_SUCCESS, if successful,
               EFI_INVALID_PARAMETER, if invalid values found
Built on 16:20:08 10/01/14


GetValueFromParentControl in the Expression.c

Function : GetValueFromParentControl

File: Expression.c
Description:
Gets the value for inconsistent/submitif from its parent control

Parameter:	 UINT16, UINT16, EFI_HII_VALUE **, PAGE_INFO *, VOID *

Return value: EFI_SUCCESS if value retrieved successfully else some other EFI Status
Built on 16:20:08 10/01/14


GrowStack in the Expression.c

Function : GrowStack

File: Expression.c
Description:
Grow size of the stack

Parameter:	  Stack     - On input: old stack; On Output: new stack
      StackPtr  - On input: old stack pointer; On Output: new stack pointer
      StackPtr  - On input: old stack end; On Output: new stack end

Return value:  EFI_SUCCESS          - Grow stack success.
          EFI_OUT_OF_RESOURCES - No enough memory for stack space.
Built on 16:20:08 10/01/14


IfrCatenate in the Expression.c

Function : IfrCatenate

File: Expression.c
Description:
Evaluate opcode EFI_IFR_TO_UINT.

Parameter:	 FormSet     - Formset which contains this opcode.
         Result      - Evaluation result for this opcode.

Return value: EFI_SUCCESS - Opcode evaluation success.
         Other       - Opcode evaluation failed.
Built on 16:20:09 10/01/14


IfrFind in the Expression.c

Function : IfrFind

File: Expression.c
Description:
Evaluate opcode EFI_IFR_FIND.

Parameter:	  FormSet     - Formset which contains this opcode.
          Format      - Case sensitive or insensitive.
      Result      - Evaluation result for this opcode.

Return value:  EFI_SUCCESS - Opcode evaluation success.
          Other       - Opcode evaluation failed.
Built on 16:20:10 10/01/14


IfrMatch in the Expression.c

Function : IfrMatch

File: Expression.c
Description:
Evaluate opcode EFI_IFR_MATCH.

Parameter:	 FormSet     - Formset which contains this opcode.
         Result      - Evaluation result for this opcode.

Return value: EFI_SUCCESS - Opcode evaluation success.
         Other       - Opcode evaluation failed.
Built on 16:20:10 10/01/14


IfrMid in the Expression.c

Function : IfrMid

File: Expression.c
Description:
Evaluate opcode EFI_IFR_MID.

Parameter:	  FormSet     - Formset which contains this opcode.
          Result      - Evaluation result for this opcode.

Return value:  EFI_SUCCESS - Opcode evaluation success.
          Other       - Opcode evaluation failed.
Built on 16:20:10 10/01/14


IfrSpan in the Expression.c

Function : IfrSpan

File: Expression.c
Description:
Evaluate opcode EFI_IFR_SPAN.

Parameter:	   FormSet     - Formset which contains this opcode.
  Flags       - FIRST_MATCHING or FIRST_NON_MATCHING.
  Result      - Evaluation result for this opcode.

Return value:   EFI_SUCCESS - Opcode evaluation success.
           Other       - Opcode evaluation failed.
Built on 16:20:10 10/01/14


IfrStrToUpper in the Expression.c

Function : IfrStrToUpper

File: Expression.c
Description:
function to conver the lower case string to upper

Parameter:

Return value:  None
Built on 16:20:10 10/01/14


IfrToken in the Expression.c

Function : IfrToken

File: Expression.c
Description:
Evaluate opcode EFI_IFR_TOKEN.

Parameter:	  FormSet     - Formset which contains this opcode.
          Result      - Evaluation result for this opcode.

Return value:  EFI_SUCCESS - Opcode evaluation success.
          Other       - Opcode evaluation failed.
Built on 16:20:10 10/01/14


IfrToString in the Expression.c

Function : IfrToString

File: Expression.c
Description:
Evaluate opcode EFI_IFR_TO_STRING.

Parameter:	  FormSet     - Formset which contains this opcode.
      Format      - String format in EFI_IFR_TO_STRING.
      Result      - Evaluation result for this opcode.

Return value:  EFI_SUCCESS - Opcode evaluation success.
          Other       - Opcode evaluation failed.
Built on 16:20:10 10/01/14


IfrToUint in the Expression.c

Function : IfrToUint

File: Expression.c
Description:
Evaluate opcode EFI_IFR_TO_UINT.

Parameter:	 FormSet     - Formset which contains this opcode.
         Result      - Evaluation result for this opcode.

Return value: EFI_SUCCESS - Opcode evaluation success.
         Other       - Opcode evaluation failed.
Built on 16:20:10 10/01/14


InitializeUnicodeCollationProtocol in the Expression.c

Function : InitializeUnicodeCollationProtocol

File: Expression.c
Description:
Locate the Unicode Collation Protocol interface for later use.

Parameter:	  None

Return value:  EFI_SUCCESS - Protocol interface Initialize success.
          Other       - Protocol interface Initialize failed.
Built on 16:20:10 10/01/14


IsScopeStackEmpty in the Expression.c

Function : IsScopeStackEmpty

File: Expression.c
Description:

Parameter:	 VOID

Return value: BOOLEAN
Built on 16:20:10 10/01/14


PopExpression in the Expression.c

Function : PopExpression

File: Expression.c
Description:
Pop an Expression value from the Stack

Parameter:	  Value - Expression value to pop.

Return value:  EFI_SUCCESS          - The value was popped onto the stack.
          EFI_OUT_OF_RESOURCES - The pop operation underflowed the stack
Built on 16:20:13 10/01/14


PopScope in the Expression.c

Function : PopScope

File: Expression.c
Description:
Pop an Operand from the Stack

Parameter:	  Operand to pop.

Return value:  EFI_SUCCESS          - The value was pushed onto the stack.
          EFI_OUT_OF_RESOURCES - There is not enough system memory to
                                 grow the stack.
Built on 16:20:13 10/01/14


PopStack in the Expression.c

Function : PopStack

File: Expression.c
Description:
Pop an element from the stack.

Parameter:	  Stack     - On input: old stack; On Output: new stack
          StackPtr  - On input: old stack pointer; On Output: new stack pointer
          StackPtr  - On input: old stack end; On Output: new stack end
          Data      - Data to pop.

Return value:    EFI_SUCCESS       - The value was popped onto the stack.
            EFI_ACCESS_DENIED - The pop operation underflowed the stack
Built on 16:20:13 10/01/14


PushExpression in the Expression.c

Function : PushExpression

File: Expression.c
Description:
Push an Expression value onto the Stack

Parameter:	  Value - Expression value to push.

Return value:  EFI_SUCCESS          - The value was pushed onto the stack.
          EFI_OUT_OF_RESOURCES - There is not enough system memory to grow the stack.
Built on 16:20:14 10/01/14


PushScope in the Expression.c

Function : PushScope

File: Expression.c
Description:
Push an Operand onto the Stack

Parameter:	  Operand to push.

Return value:  EFI_SUCCESS          - The value was pushed onto the stack.
          EFI_OUT_OF_RESOURCES - There is not enough system memory to grow the stack.
Built on 16:20:14 10/01/14


PushStack in the Expression.c

Function : PushStack

File: Expression.c
Description:
Push an element onto the Boolean Stack

Parameter:	  Stack     - On input: old stack; On Output: new stack
          StackPtr  - On input: old stack pointer; On Output: new stack pointer
          StackPtr  - On input: old stack end; On Output: new stack end
          Data      - Data to push.

Return value:  EFI_SUCCESS - Push stack success.
Built on 16:20:14 10/01/14


ResetExpressionStack in the Expression.c

Function : ResetExpressionStack

File: Expression.c
Description:
Reset stack pointer to begin of the stack.

Parameter:	  None.

Return value:  None
Built on 16:20:14 10/01/14


ResetScopeStack in the Expression.c

Function : ResetScopeStack

File: Expression.c
Description:
Reset stack pointer to begin of the stack.

Parameter:	 None.

Return value: None.
Built on 16:20:14 10/01/14


EZPORT SDL Tokens

The following data structures are used in the file: EZPORT SDL Tokens.

Variable | Description
CONTROL_FOCUS_COLOR | Focused control text color (Default same as FOCUS_COLOR)
CONTROL_NON_FOCUS_COLOR | Non Focused control text color (Default same as NON_FOCUS_COLOR)
EDIT_BGCOLOR | Background color of focused edit controls
EDIT_FGCOLOR | Foreground color of focused edit controls
FOCUS_COLOR | Focused label and control text color (Default EFI_WHITE)
FULL_HORIZONTAL_HELP_DIVIDER | Horizontal divider (border) position between Help and Navigation frame windows.
FULL_STYLE_CONTROL_LEFT_MARGIN | Control column left margin in full screen mode
FULL_STYLE_CONTROL_LEFT_PAD | Control left padding in full screen mode
FULL_STYLE_CONTROL_RIGHT_AREA_WIDTH | Control column width in full screen mode
FULL_STYLE_LABEL_LEFT_MARGIN | Label column left margin in full screen mode
FULL_VERTICAL_MAIN_DIVIDER | Vertical divider (border) position between the MainFrame window and (helper and Navigation) frame windows.
HELP_BGCOLOR | Background color of the Help Frame (Default PAGE_BGCOLOR)
HELP_FGCOLOR | Foreground Color of the Help Frame (Default PAGE_FGCOLOR)
HELP_FULL_H | Vertical Height of the Help frame window.
HELP_FULL_W | Horizontal Width of the Help frame window.
HELP_FULL_X | X-Coordinate position of the Help frame window.
HELP_FULL_Y | Y-Coordinate position of the Help frame window.
HELP_H | Vertical Height of the Help frame window.
HELP_W | Horizontal Width of the Help frame window.
HELP_X | X-Coordinate position of the Help frame window.
HELP_Y | Y-Coordinate position of the Help frame window.
HELPTITLE_BGCOLOR | Background color of the Help Title Frame
HELPTITLE_FGCOLOR | Foreground Color of the Help Title Frame
HELPTITLE_FULL_H | Vertical Height of the Help Title frame window
HELPTITLE_FULL_W | Horizontal Width of the Help Title frame window
HELPTITLE_FULL_X | X-Coordinate position of the Help Title frame window
HELPTITLE_FULL_Y | Y-Coordinate position of the Help Title frame window.
HELPTITLE_H | Vertical Height of the Help Title frame window
HELPTITLE_W | Horizontal Width of the Help Title frame window
HELPTITLE_X | X-Coordinate position of the Help Title frame window
HELPTITLE_Y | Y-Coordinate position of the Help Title frame window.
HORIZONTAL_HELP_DIVIDER | Horizontal divider (border) position between Help and Navigation frame windows.
LABEL_FOCUS_COLOR | Focused label text color (Default same as FOCUS_COLOR)
LABEL_NON_FOCUS_COLOR | Non Focused label text color (Default same as NON_FOCUS_COLOR)
MAIN_BGCOLOR | Background Color of the Main frame.
MAIN_FGCOLOR | Foreground Color of the Main frame.
MAIN_FULL_H | Vertical Height of the Main frame window.
MAIN_FULL_W | Horizontal Width of the Main frame window.
MAIN_FULL_X | X-Coordinate position of the Main frame window.
MAIN_FULL_Y | Y-Coordinate position of the Main frame window.
MAIN_H | Vertical Height of the Main frame window.
MAIN_W | Horizontal Width of the Main frame window.
MAIN_X | X-Coordinate position of the Main frame window.
MAIN_Y | Y-Coordinate position of the Main frame window.
MEMO_COLOR | Foreground color of Memo controls
MENU_BGCOLOR | Background color of the Menu bar frame
MENU_FGCOLOR | Foreground Color of the Menu bar frame
MENU_FULL_H | Vertical Height of the Menu bar frame
MENU_FULL_W | Horizontal Width of the Menu bar frame
MENU_FULL_X | X-Coordinate position of the Menu bar frame
MENU_FULL_Y | Y-Coordinate position of the Menu bar frame
MENU_H | Vertical Height of the Menu bar frame
MENU_W | Horizontal Width of the Menu bar frame
MENU_X | X-Coordinate position of the Menu bar frame
MENU_Y | Y-Coordinate position of the Menu bar frame
NAV_BGCOLOR | Background color of the Navigation Frame
NAV_FGCOLOR | Foreground Color of the Navigation Frame
NAV_FULL_H | Vertical Height of the Navigation frame window.
NAV_FULL_W | Horizontal Width of the Navigation frame window.
NAV_FULL_X | X-Coordinate position of the Navigation frame window.
NAV_FULL_Y | Y-Coordinate position of the Navigation frame window.
NAV_H | Vertical Height of the Navigation frame window.
NAV_W | Horizontal Width of the Navigation frame window.
NAV_X | X-Coordinate position of the Navigation frame window.
NAV_Y | Y-Coordinate position of the Navigation frame window.
NON_FOCUS_COLOR | Non Focused label and control text color (Default PAGE_FGCOLOR)
OVERRIDE_PopupPwdAuthenticateIDEPwd | set to 1 if oem wants to override the PopupPwdAuthenticateIDEPwd function from Board module.
OVERRIDE_PopupPwdHandleActionOverRide | set to 1 to display password prompts for old, new, and confirm in the same window.
PAGE_BGCOLOR | Background Color of the main area (Main, Help, and Navigation Frames) in a page.
PAGE_FGCOLOR | Foreground and Border Color of main area in a page (Default EFI_BLUE)
PAGE_LINK_COLOR | Submenu text color (Default PAGE_FGCOLOR)
PAGEBORDER_FULL_H | Vertical height of the page border
PAGEBORDER_FULL_W | Horizontal width of the page border
PAGEBORDER_FULL_X | X-Coordinate position of the Page border. (Default 0)
PAGEBORDER_FULL_Y | Y-Coordinate position of the Page border. (Default 2)
PAGEBORDER_H | Vertical height of the page border.
PAGEBORDER_W | Horizontal width of the page border
PAGEBORDER_X | X-Coordinate position of the Page border. (Default 0)
PAGEBORDER_Y | Y-Coordinate position of the Page border. (Default 2)
POPUP_BGCOLOR | Background Color of Popup Windows, and Message Boxes (Default EFI_BACKGROUND_BLUE)
POPUP_FGCOLOR | Foreground Color of Popup Windows, and Message Boxes (Default EFI_WHITE)
SCROLLBAR_BGCOLOR | Background color of the Scroll bar (Default PAGE_BGCOLOR)
SCROLLBAR_DOWNARROW_BGCOLOR | Background color of the Scroll bar Down-Arrow (Default PAGE_BGCOLOR)
SCROLLBAR_DOWNARROW_FGCOLOR | Foreground Color of the Scroll bar Down-Arrow (Default PAGE_FGCOLOR)
SCROLLBAR_FGCOLOR | Foreground Color of the Scroll bar (Default PAGE_FGCOLOR)
SCROLLBAR_UPARROW_BGCOLOR | Background color of the Scroll bar Up-Arrow (Default PAGE_BGCOLOR)
SCROLLBAR_UPARROW_FGCOLOR | Foreground Color of the Scroll bar Up-Arrow (Default PAGE_FGCOLOR)
SELECTED_MENU_BGCOLOR | Background color of the Selected Menu in the Menu bar frame
SELECTED_MENU_FGCOLOR | Foreground Color of the Selected Menu in the Menu bar frame
SETUP_STYLE_EZPORT | Condition to support Ezport Style Sources
SETUP_STYLE_FULL_SCREEN | Condition to support full screen layout
STYLE_CONTROL_LEFT_MARGIN | Control column left margin
STYLE_CONTROL_LEFT_PAD | Control left padding
STYLE_CONTROL_RIGHT_AREA_WIDTH | Control column width
STYLE_FULL_MAX_COLS | Maximum columns in full screen mode
STYLE_FULL_MAX_ROWS | Maximum rows in full screen mode
STYLE_HOTKEY_FAILSAFE | Hot Key to load fail safe values
STYLE_LABEL_LEFT_MARGIN | Label column left margin in normal screen mode
STYLE_PAGE_FIRSTITEM_FOCUS | Reset focus to the first item when navigating to a new page. (Default 0 => Set focus to previously selected item)
STYLE_SCROLLBAR_ROLLOVER | Support rollover when the scroll limit has been reached
STYLE_SHADOW_SUPPORT | To enable/disable shadow support
STYLE_SPACEKEY_INCREMENT | To enable space key increment
STYLE_STD_MAX_COLS | Maximum columns in Standard mode
STYLE_STD_MAX_ROWS | Maximum rows in standard mode
STYLE_SUBPAGE_FIRSTITEM_FOCUS | Reset focus to the first item when navigating back from submenu. (Default 0 => Set focus to previously selected item)
TEXT_COLOR | Foreround color of text controls
TITLE_BGCOLOR | Background Color of the Title bar frame.
TITLE_FGCOLOR | Foreground Color of the Title bar frame
TITLE_FULL_H | Vertical Height of the Title bar frame
TITLE_FULL_W | Horizontal Width of the Title bar frame.
TITLE_FULL_X | X-Coordinate position of the Title bar frame. (Default 0)
TITLE_FULL_Y | Y-Coordinate position of the Title bar frame. (Default 0)
TITLE_H | Vertical Height of the Title bar frame
TITLE_W | Horizontal Width of the Title bar frame
TITLE_X | X-Coordinate position of the Title bar frame. (Default 0)
TITLE_Y | Y-Coordinate position of the Title bar frame. (Default 0)
TSE_STYLE_EZPORT_SUPPORT | Main switch to enable Ezport Style in TSE
TSE_STYLE_SOURCES_SUPPORT | Don't Edit.
VERTICAL_MAIN_DIVIDER | Vertical divider (border) position between the MainFrame window and (helper and Navigation) frame windows.

Built on 16:20:19 10/01/14


CONTROL_FOCUS_COLOR in the EZPORT SDL Tokens

Variable : CONTROL_FOCUS_COLOR

File: EZPORT SDL Tokens
Description:
Focused control text color (Default same as FOCUS_COLOR)
Built on 16:20:06 10/01/14


CONTROL_NON_FOCUS_COLOR in the EZPORT SDL Tokens

Variable : CONTROL_NON_FOCUS_COLOR

File: EZPORT SDL Tokens
Description:
Non Focused control text color (Default same as NON_FOCUS_COLOR)
Built on 16:20:06 10/01/14


EDIT_BGCOLOR in the EZPORT SDL Tokens

Variable : EDIT_BGCOLOR

File: EZPORT SDL Tokens
Description:
Background color of focused edit controls
Built on 16:20:07 10/01/14


EDIT_FGCOLOR in the EZPORT SDL Tokens

Variable : EDIT_FGCOLOR

File: EZPORT SDL Tokens
Description:
Foreground color of focused edit controls
Built on 16:20:07 10/01/14


FOCUS_COLOR in the EZPORT SDL Tokens

Variable : FOCUS_COLOR

File: EZPORT SDL Tokens
Description:
Focused label and control text color (Default EFI_WHITE)
Built on 16:20:07 10/01/14


FULL_HORIZONTAL_HELP_DIVIDER in the EZPORT SDL Tokens

Variable : FULL_HORIZONTAL_HELP_DIVIDER

File: EZPORT SDL Tokens
Description:
Horizontal divider (border) position between Help and Navigation frame windows.
Built on 16:20:08 10/01/14


FULL_STYLE_CONTROL_LEFT_MARGIN in the EZPORT SDL Tokens

Variable : FULL_STYLE_CONTROL_LEFT_MARGIN

File: EZPORT SDL Tokens
Description:
Control column left margin in full screen mode
Built on 16:20:08 10/01/14


FULL_STYLE_CONTROL_LEFT_PAD in the EZPORT SDL Tokens

Variable : FULL_STYLE_CONTROL_LEFT_PAD

File: EZPORT SDL Tokens
Description:
Control left padding in full screen mode
Built on 16:20:08 10/01/14


FULL_STYLE_CONTROL_RIGHT_AREA_WIDTH in the EZPORT SDL Tokens

Variable : FULL_STYLE_CONTROL_RIGHT_AREA_WIDTH

File: EZPORT SDL Tokens
Description:
Control column width in full screen mode
Built on 16:20:08 10/01/14


FULL_STYLE_LABEL_LEFT_MARGIN in the EZPORT SDL Tokens

Variable : FULL_STYLE_LABEL_LEFT_MARGIN

File: EZPORT SDL Tokens
Description:
Label column left margin in full screen mode
Built on 16:20:08 10/01/14


FULL_VERTICAL_MAIN_DIVIDER in the EZPORT SDL Tokens

Variable : FULL_VERTICAL_MAIN_DIVIDER

File: EZPORT SDL Tokens
Description:
Vertical divider (border) position between the MainFrame window and (helper and Navigation) frame windows.
Built on 16:20:08 10/01/14


HELP_BGCOLOR in the EZPORT SDL Tokens

Variable : HELP_BGCOLOR

File: EZPORT SDL Tokens
Description:
Background color of the Help Frame (Default PAGE_BGCOLOR)
Built on 16:20:09 10/01/14


HELP_FGCOLOR in the EZPORT SDL Tokens

Variable : HELP_FGCOLOR

File: EZPORT SDL Tokens
Description:
Foreground Color of the Help Frame (Default PAGE_FGCOLOR)
Built on 16:20:09 10/01/14


HELP_FULL_H in the EZPORT SDL Tokens

Variable : HELP_FULL_H

File: EZPORT SDL Tokens
Description:
Vertical Height of the Help frame window.
Built on 16:20:09 10/01/14


HELP_FULL_W in the EZPORT SDL Tokens

Variable : HELP_FULL_W

File: EZPORT SDL Tokens
Description:
Horizontal Width of the Help frame window.
Built on 16:20:09 10/01/14


HELP_FULL_X in the EZPORT SDL Tokens

Variable : HELP_FULL_X

File: EZPORT SDL Tokens
Description:
X-Coordinate position of the Help frame window.
Built on 16:20:09 10/01/14


HELP_FULL_Y in the EZPORT SDL Tokens

Variable : HELP_FULL_Y

File: EZPORT SDL Tokens
Description:
Y-Coordinate position of the Help frame window.
Built on 16:20:09 10/01/14


HELP_H in the EZPORT SDL Tokens

Variable : HELP_H

File: EZPORT SDL Tokens
Description:
Vertical Height of the Help frame window.
Built on 16:20:09 10/01/14


HELP_W in the EZPORT SDL Tokens

Variable : HELP_W

File: EZPORT SDL Tokens
Description:
Horizontal Width of the Help frame window.
Built on 16:20:09 10/01/14


HELP_X in the EZPORT SDL Tokens

Variable : HELP_X

File: EZPORT SDL Tokens
Description:
X-Coordinate position of the Help frame window.
Built on 16:20:09 10/01/14


HELP_Y in the EZPORT SDL Tokens

Variable : HELP_Y

File: EZPORT SDL Tokens
Description:
Y-Coordinate position of the Help frame window.
Built on 16:20:09 10/01/14


HELPTITLE_BGCOLOR in the EZPORT SDL Tokens

Variable : HELPTITLE_BGCOLOR

File: EZPORT SDL Tokens
Description:
Background color of the Help Title Frame
Built on 16:20:09 10/01/14


HELPTITLE_FGCOLOR in the EZPORT SDL Tokens

Variable : HELPTITLE_FGCOLOR

File: EZPORT SDL Tokens
Description:
Foreground Color of the Help Title Frame
Built on 16:20:09 10/01/14


HELPTITLE_FULL_H in the EZPORT SDL Tokens

Variable : HELPTITLE_FULL_H

File: EZPORT SDL Tokens
Description:
Vertical Height of the Help Title frame window
Built on 16:20:09 10/01/14


HELPTITLE_FULL_W in the EZPORT SDL Tokens

Variable : HELPTITLE_FULL_W

File: EZPORT SDL Tokens
Description:
Horizontal Width of the Help Title frame window
Built on 16:20:09 10/01/14


HELPTITLE_FULL_X in the EZPORT SDL Tokens

Variable : HELPTITLE_FULL_X

File: EZPORT SDL Tokens
Description:
X-Coordinate position of the Help Title frame window
Built on 16:20:09 10/01/14


HELPTITLE_FULL_Y in the EZPORT SDL Tokens

Variable : HELPTITLE_FULL_Y

File: EZPORT SDL Tokens
Description:
Y-Coordinate position of the Help Title frame window.
Built on 16:20:09 10/01/14


HELPTITLE_H in the EZPORT SDL Tokens

Variable : HELPTITLE_H

File: EZPORT SDL Tokens
Description:
Vertical Height of the Help Title frame window
Built on 16:20:09 10/01/14


HELPTITLE_W in the EZPORT SDL Tokens

Variable : HELPTITLE_W

File: EZPORT SDL Tokens
Description:
Horizontal Width of the Help Title frame window
Built on 16:20:09 10/01/14


HELPTITLE_X in the EZPORT SDL Tokens

Variable : HELPTITLE_X

File: EZPORT SDL Tokens
Description:
X-Coordinate position of the Help Title frame window
Built on 16:20:09 10/01/14


HELPTITLE_Y in the EZPORT SDL Tokens

Variable : HELPTITLE_Y

File: EZPORT SDL Tokens
Description:
Y-Coordinate position of the Help Title frame window.
Built on 16:20:09 10/01/14


HORIZONTAL_HELP_DIVIDER in the EZPORT SDL Tokens

Variable : HORIZONTAL_HELP_DIVIDER

File: EZPORT SDL Tokens
Description:
Horizontal divider (border) position between Help and Navigation frame windows.
Built on 16:20:09 10/01/14


LABEL_FOCUS_COLOR in the EZPORT SDL Tokens

Variable : LABEL_FOCUS_COLOR

File: EZPORT SDL Tokens
Description:
Focused label text color (Default same as FOCUS_COLOR)
Built on 16:20:10 10/01/14


LABEL_NON_FOCUS_COLOR in the EZPORT SDL Tokens

Variable : LABEL_NON_FOCUS_COLOR

File: EZPORT SDL Tokens
Description:
Non Focused label text color (Default same as NON_FOCUS_COLOR)
Built on 16:20:10 10/01/14


MAIN_BGCOLOR in the EZPORT SDL Tokens

Variable : MAIN_BGCOLOR

File: EZPORT SDL Tokens
Description:
Background Color of the Main frame.
Built on 16:20:11 10/01/14


MAIN_FGCOLOR in the EZPORT SDL Tokens

Variable : MAIN_FGCOLOR

File: EZPORT SDL Tokens
Description:
Foreground Color of the Main frame.
Built on 16:20:11 10/01/14


MAIN_FULL_H in the EZPORT SDL Tokens

Variable : MAIN_FULL_H

File: EZPORT SDL Tokens
Description:
Vertical Height of the Main frame window.
Built on 16:20:11 10/01/14


MAIN_FULL_W in the EZPORT SDL Tokens

Variable : MAIN_FULL_W

File: EZPORT SDL Tokens
Description:
Horizontal Width of the Main frame window.
Built on 16:20:11 10/01/14


MAIN_FULL_X in the EZPORT SDL Tokens

Variable : MAIN_FULL_X

File: EZPORT SDL Tokens
Description:
X-Coordinate position of the Main frame window.
Built on 16:20:11 10/01/14


MAIN_FULL_Y in the EZPORT SDL Tokens

Variable : MAIN_FULL_Y

File: EZPORT SDL Tokens
Description:
Y-Coordinate position of the Main frame window.
Built on 16:20:11 10/01/14


MAIN_H in the EZPORT SDL Tokens

Variable : MAIN_H

File: EZPORT SDL Tokens
Description:
Vertical Height of the Main frame window.
Built on 16:20:11 10/01/14


MAIN_W in the EZPORT SDL Tokens

Variable : MAIN_W

File: EZPORT SDL Tokens
Description:
Horizontal Width of the Main frame window.
Built on 16:20:11 10/01/14


MAIN_X in the EZPORT SDL Tokens

Variable : MAIN_X

File: EZPORT SDL Tokens
Description:
X-Coordinate position of the Main frame window.
Built on 16:20:11 10/01/14


MAIN_Y in the EZPORT SDL Tokens

Variable : MAIN_Y

File: EZPORT SDL Tokens
Description:
Y-Coordinate position of the Main frame window.
Built on 16:20:11 10/01/14


MEMO_COLOR in the EZPORT SDL Tokens

Variable : MEMO_COLOR

File: EZPORT SDL Tokens
Description:
Foreground color of Memo controls
Built on 16:20:11 10/01/14


MENU_BGCOLOR in the EZPORT SDL Tokens

Variable : MENU_BGCOLOR

File: EZPORT SDL Tokens
Description:
Background color of the Menu bar frame
Built on 16:20:11 10/01/14


MENU_FGCOLOR in the EZPORT SDL Tokens

Variable : MENU_FGCOLOR

File: EZPORT SDL Tokens
Description:
Foreground Color of the Menu bar frame
Built on 16:20:11 10/01/14


MENU_FULL_H in the EZPORT SDL Tokens

Variable : MENU_FULL_H

File: EZPORT SDL Tokens
Description:
Vertical Height of the Menu bar frame
Built on 16:20:11 10/01/14


MENU_FULL_W in the EZPORT SDL Tokens

Variable : MENU_FULL_W

File: EZPORT SDL Tokens
Description:
Horizontal Width of the Menu bar frame
Built on 16:20:11 10/01/14


MENU_FULL_X in the EZPORT SDL Tokens

Variable : MENU_FULL_X

File: EZPORT SDL Tokens
Description:
X-Coordinate position of the Menu bar frame
Built on 16:20:11 10/01/14


MENU_FULL_Y in the EZPORT SDL Tokens

Variable : MENU_FULL_Y

File: EZPORT SDL Tokens
Description:
Y-Coordinate position of the Menu bar frame
Built on 16:20:11 10/01/14


MENU_H in the EZPORT SDL Tokens

Variable : MENU_H

File: EZPORT SDL Tokens
Description:
Vertical Height of the Menu bar frame
Built on 16:20:11 10/01/14


MENU_W in the EZPORT SDL Tokens

Variable : MENU_W

File: EZPORT SDL Tokens
Description:
Horizontal Width of the Menu bar frame
Built on 16:20:11 10/01/14


MENU_X in the EZPORT SDL Tokens

Variable : MENU_X

File: EZPORT SDL Tokens
Description:
X-Coordinate position of the Menu bar frame
Built on 16:20:11 10/01/14


MENU_Y in the EZPORT SDL Tokens

Variable : MENU_Y

File: EZPORT SDL Tokens
Description:
Y-Coordinate position of the Menu bar frame
Built on 16:20:11 10/01/14


NAV_BGCOLOR in the EZPORT SDL Tokens

Variable : NAV_BGCOLOR

File: EZPORT SDL Tokens
Description:
Background color of the Navigation Frame
Built on 16:20:12 10/01/14


NAV_FGCOLOR in the EZPORT SDL Tokens

Variable : NAV_FGCOLOR

File: EZPORT SDL Tokens
Description:
Foreground Color of the Navigation Frame
Built on 16:20:12 10/01/14


NAV_FULL_H in the EZPORT SDL Tokens

Variable : NAV_FULL_H

File: EZPORT SDL Tokens
Description:
Vertical Height of the Navigation frame window.
Built on 16:20:12 10/01/14


NAV_FULL_W in the EZPORT SDL Tokens

Variable : NAV_FULL_W

File: EZPORT SDL Tokens
Description:
Horizontal Width of the Navigation frame window.
Built on 16:20:12 10/01/14


NAV_FULL_X in the EZPORT SDL Tokens

Variable : NAV_FULL_X

File: EZPORT SDL Tokens
Description:
X-Coordinate position of the Navigation frame window.
Built on 16:20:12 10/01/14


NAV_FULL_Y in the EZPORT SDL Tokens

Variable : NAV_FULL_Y

File: EZPORT SDL Tokens
Description:
Y-Coordinate position of the Navigation frame window.
Built on 16:20:12 10/01/14


NAV_H in the EZPORT SDL Tokens

Variable : NAV_H

File: EZPORT SDL Tokens
Description:
Vertical Height of the Navigation frame window.
Built on 16:20:12 10/01/14


NAV_W in the EZPORT SDL Tokens

Variable : NAV_W

File: EZPORT SDL Tokens
Description:
Horizontal Width of the Navigation frame window.
Built on 16:20:12 10/01/14


NAV_X in the EZPORT SDL Tokens

Variable : NAV_X

File: EZPORT SDL Tokens
Description:
X-Coordinate position of the Navigation frame window.
Built on 16:20:12 10/01/14


NAV_Y in the EZPORT SDL Tokens

Variable : NAV_Y

File: EZPORT SDL Tokens
Description:
Y-Coordinate position of the Navigation frame window.
Built on 16:20:12 10/01/14


NON_FOCUS_COLOR in the EZPORT SDL Tokens

Variable : NON_FOCUS_COLOR

File: EZPORT SDL Tokens
Description:
Non Focused label and control text color (Default PAGE_FGCOLOR)
Built on 16:20:12 10/01/14


OVERRIDE_PopupPwdAuthenticateIDEPwd in the EZPORT SDL Tokens

Variable : OVERRIDE_PopupPwdAuthenticateIDEPwd

File: EZPORT SDL Tokens
Description:
set to 1 if oem wants to override the PopupPwdAuthenticateIDEPwd function from Board module.
Built on 16:20:12 10/01/14


OVERRIDE_PopupPwdHandleActionOverRide in the EZPORT SDL Tokens

Variable : OVERRIDE_PopupPwdHandleActionOverRide

File: EZPORT SDL Tokens
Description:
set to 1 to display password prompts for old, new, and confirm in the same window.
Built on 16:20:12 10/01/14


PAGE_BGCOLOR in the EZPORT SDL Tokens

Variable : PAGE_BGCOLOR

File: EZPORT SDL Tokens
Description:
Background Color of the main area (Main, Help, and Navigation Frames) in a page.
Built on 16:20:12 10/01/14


PAGE_FGCOLOR in the EZPORT SDL Tokens

Variable : PAGE_FGCOLOR

File: EZPORT SDL Tokens
Description:
Foreground and Border Color of main area in a page (Default EFI_BLUE)
Built on 16:20:12 10/01/14


PAGE_LINK_COLOR in the EZPORT SDL Tokens

Variable : PAGE_LINK_COLOR

File: EZPORT SDL Tokens
Description:
Submenu text color (Default PAGE_FGCOLOR)
Built on 16:20:12 10/01/14


PAGEBORDER_FULL_H in the EZPORT SDL Tokens

Variable : PAGEBORDER_FULL_H

File: EZPORT SDL Tokens
Description:
Vertical height of the page border
Built on 16:20:12 10/01/14


PAGEBORDER_FULL_W in the EZPORT SDL Tokens

Variable : PAGEBORDER_FULL_W

File: EZPORT SDL Tokens
Description:
Horizontal width of the page border
Built on 16:20:12 10/01/14


PAGEBORDER_FULL_X in the EZPORT SDL Tokens

Variable : PAGEBORDER_FULL_X

File: EZPORT SDL Tokens
Description:
X-Coordinate position of the Page border. (Default 0)
Built on 16:20:12 10/01/14


PAGEBORDER_FULL_Y in the EZPORT SDL Tokens

Variable : PAGEBORDER_FULL_Y

File: EZPORT SDL Tokens
Description:
Y-Coordinate position of the Page border. (Default 2)
Built on 16:20:12 10/01/14


PAGEBORDER_H in the EZPORT SDL Tokens

Variable : PAGEBORDER_H

File: EZPORT SDL Tokens
Description:
Vertical height of the page border.
Built on 16:20:12 10/01/14


PAGEBORDER_W in the EZPORT SDL Tokens

Variable : PAGEBORDER_W

File: EZPORT SDL Tokens
Description:
Horizontal width of the page border
Built on 16:20:12 10/01/14


PAGEBORDER_X in the EZPORT SDL Tokens

Variable : PAGEBORDER_X

File: EZPORT SDL Tokens
Description:
X-Coordinate position of the Page border. (Default 0)
Built on 16:20:12 10/01/14


PAGEBORDER_Y in the EZPORT SDL Tokens

Variable : PAGEBORDER_Y

File: EZPORT SDL Tokens
Description:
Y-Coordinate position of the Page border. (Default 2)
Built on 16:20:12 10/01/14


POPUP_BGCOLOR in the EZPORT SDL Tokens

Variable : POPUP_BGCOLOR

File: EZPORT SDL Tokens
Description:
Background Color of Popup Windows, and Message Boxes (Default EFI_BACKGROUND_BLUE)
Built on 16:20:13 10/01/14


POPUP_FGCOLOR in the EZPORT SDL Tokens

Variable : POPUP_FGCOLOR

File: EZPORT SDL Tokens
Description:
Foreground Color of Popup Windows, and Message Boxes (Default EFI_WHITE)
Built on 16:20:13 10/01/14


SCROLLBAR_BGCOLOR in the EZPORT SDL Tokens

Variable : SCROLLBAR_BGCOLOR

File: EZPORT SDL Tokens
Description:
Background color of the Scroll bar (Default PAGE_BGCOLOR)
Built on 16:20:14 10/01/14


SCROLLBAR_DOWNARROW_BGCOLOR in the EZPORT SDL Tokens

Variable : SCROLLBAR_DOWNARROW_BGCOLOR

File: EZPORT SDL Tokens
Description:
Background color of the Scroll bar Down-Arrow (Default PAGE_BGCOLOR)
Built on 16:20:14 10/01/14


SCROLLBAR_DOWNARROW_FGCOLOR in the EZPORT SDL Tokens

Variable : SCROLLBAR_DOWNARROW_FGCOLOR

File: EZPORT SDL Tokens
Description:
Foreground Color of the Scroll bar Down-Arrow (Default PAGE_FGCOLOR)
Built on 16:20:14 10/01/14


SCROLLBAR_FGCOLOR in the EZPORT SDL Tokens

Variable : SCROLLBAR_FGCOLOR

File: EZPORT SDL Tokens
Description:
Foreground Color of the Scroll bar (Default PAGE_FGCOLOR)
Built on 16:20:14 10/01/14


SCROLLBAR_UPARROW_BGCOLOR in the EZPORT SDL Tokens

Variable : SCROLLBAR_UPARROW_BGCOLOR

File: EZPORT SDL Tokens
Description:
Background color of the Scroll bar Up-Arrow (Default PAGE_BGCOLOR)
Built on 16:20:14 10/01/14


SCROLLBAR_UPARROW_FGCOLOR in the EZPORT SDL Tokens

Variable : SCROLLBAR_UPARROW_FGCOLOR

File: EZPORT SDL Tokens
Description:
Foreground Color of the Scroll bar Up-Arrow (Default PAGE_FGCOLOR)
Built on 16:20:14 10/01/14


SELECTED_MENU_BGCOLOR in the EZPORT SDL Tokens

Variable : SELECTED_MENU_BGCOLOR

File: EZPORT SDL Tokens
Description:
Background color of the Selected Menu in the Menu bar frame
Built on 16:20:14 10/01/14


SELECTED_MENU_FGCOLOR in the EZPORT SDL Tokens

Variable : SELECTED_MENU_FGCOLOR

File: EZPORT SDL Tokens
Description:
Foreground Color of the Selected Menu in the Menu bar frame
Built on 16:20:14 10/01/14


SETUP_STYLE_EZPORT in the EZPORT SDL Tokens

Variable : SETUP_STYLE_EZPORT

File: EZPORT SDL Tokens
Description:
Condition to support Ezport Style Sources
Built on 16:20:15 10/01/14


SETUP_STYLE_FULL_SCREEN in the EZPORT SDL Tokens

Variable : SETUP_STYLE_FULL_SCREEN

File: EZPORT SDL Tokens
Description:
Condition to support full screen layout
Built on 16:20:15 10/01/14


STYLE_CONTROL_LEFT_MARGIN in the EZPORT SDL Tokens

Variable : STYLE_CONTROL_LEFT_MARGIN

File: EZPORT SDL Tokens
Description:
Control column left margin
Built on 16:20:15 10/01/14


STYLE_CONTROL_LEFT_PAD in the EZPORT SDL Tokens

Variable : STYLE_CONTROL_LEFT_PAD

File: EZPORT SDL Tokens
Description:
Control left padding
Built on 16:20:15 10/01/14


STYLE_CONTROL_RIGHT_AREA_WIDTH in the EZPORT SDL Tokens

Variable : STYLE_CONTROL_RIGHT_AREA_WIDTH

File: EZPORT SDL Tokens
Description:
Control column width
Built on 16:20:15 10/01/14


STYLE_FULL_MAX_COLS in the EZPORT SDL Tokens

Variable : STYLE_FULL_MAX_COLS

File: EZPORT SDL Tokens
Description:
Maximum columns in full screen mode
Built on 16:20:15 10/01/14


STYLE_FULL_MAX_ROWS in the EZPORT SDL Tokens

Variable : STYLE_FULL_MAX_ROWS

File: EZPORT SDL Tokens
Description:
Maximum rows in full screen mode
Built on 16:20:15 10/01/14


STYLE_HOTKEY_FAILSAFE in the EZPORT SDL Tokens

Variable : STYLE_HOTKEY_FAILSAFE

File: EZPORT SDL Tokens
Description:
Hot Key to load fail safe values
Built on 16:20:15 10/01/14


STYLE_LABEL_LEFT_MARGIN in the EZPORT SDL Tokens

Variable : STYLE_LABEL_LEFT_MARGIN

File: EZPORT SDL Tokens
Description:
Label column left margin in normal screen mode
Built on 16:20:15 10/01/14


STYLE_PAGE_FIRSTITEM_FOCUS in the EZPORT SDL Tokens

Variable : STYLE_PAGE_FIRSTITEM_FOCUS

File: EZPORT SDL Tokens
Description:
Reset focus to the first item when navigating to a new page. (Default 0 => Set focus to previously selected item)
Built on 16:20:15 10/01/14


STYLE_SCROLLBAR_ROLLOVER in the EZPORT SDL Tokens

Variable : STYLE_SCROLLBAR_ROLLOVER

File: EZPORT SDL Tokens
Description:
Support rollover when the scroll limit has been reached
Built on 16:20:15 10/01/14


STYLE_SHADOW_SUPPORT in the EZPORT SDL Tokens

Variable : STYLE_SHADOW_SUPPORT

File: EZPORT SDL Tokens
Description:
To enable/disable shadow support
Built on 16:20:15 10/01/14


STYLE_SPACEKEY_INCREMENT in the EZPORT SDL Tokens

Variable : STYLE_SPACEKEY_INCREMENT

File: EZPORT SDL Tokens
Description:
To enable space key increment
Built on 16:20:15 10/01/14


STYLE_STD_MAX_COLS in the EZPORT SDL Tokens

Variable : STYLE_STD_MAX_COLS

File: EZPORT SDL Tokens
Description:
Maximum columns in Standard mode
Built on 16:20:15 10/01/14


STYLE_STD_MAX_ROWS in the EZPORT SDL Tokens

Variable : STYLE_STD_MAX_ROWS

File: EZPORT SDL Tokens
Description:
Maximum rows in standard mode
Built on 16:20:15 10/01/14


STYLE_SUBPAGE_FIRSTITEM_FOCUS in the EZPORT SDL Tokens

Variable : STYLE_SUBPAGE_FIRSTITEM_FOCUS

File: EZPORT SDL Tokens
Description:
Reset focus to the first item when navigating back from submenu. (Default 0 => Set focus to previously selected item)
Built on 16:20:15 10/01/14


TEXT_COLOR in the EZPORT SDL Tokens

Variable : TEXT_COLOR

File: EZPORT SDL Tokens
Description:
Foreround color of text controls
Built on 16:20:16 10/01/14


TITLE_BGCOLOR in the EZPORT SDL Tokens

Variable : TITLE_BGCOLOR

File: EZPORT SDL Tokens
Description:
Background Color of the Title bar frame.
Built on 16:20:16 10/01/14


TITLE_FGCOLOR in the EZPORT SDL Tokens

Variable : TITLE_FGCOLOR

File: EZPORT SDL Tokens
Description:
Foreground Color of the Title bar frame
Built on 16:20:16 10/01/14


TITLE_FULL_H in the EZPORT SDL Tokens

Variable : TITLE_FULL_H

File: EZPORT SDL Tokens
Description:
Vertical Height of the Title bar frame
Built on 16:20:16 10/01/14


TITLE_FULL_W in the EZPORT SDL Tokens

Variable : TITLE_FULL_W

File: EZPORT SDL Tokens
Description:
Horizontal Width of the Title bar frame.
Built on 16:20:16 10/01/14


TITLE_FULL_X in the EZPORT SDL Tokens

Variable : TITLE_FULL_X

File: EZPORT SDL Tokens
Description:
X-Coordinate position of the Title bar frame. (Default 0)
Built on 16:20:16 10/01/14


TITLE_FULL_Y in the EZPORT SDL Tokens

Variable : TITLE_FULL_Y

File: EZPORT SDL Tokens
Description:
Y-Coordinate position of the Title bar frame. (Default 0)
Built on 16:20:16 10/01/14


TITLE_H in the EZPORT SDL Tokens

Variable : TITLE_H

File: EZPORT SDL Tokens
Description:
Vertical Height of the Title bar frame
Built on 16:20:16 10/01/14


TITLE_W in the EZPORT SDL Tokens

Variable : TITLE_W

File: EZPORT SDL Tokens
Description:
Horizontal Width of the Title bar frame
Built on 16:20:16 10/01/14


TITLE_X in the EZPORT SDL Tokens

Variable : TITLE_X

File: EZPORT SDL Tokens
Description:
X-Coordinate position of the Title bar frame. (Default 0)
Built on 16:20:16 10/01/14


TITLE_Y in the EZPORT SDL Tokens

Variable : TITLE_Y

File: EZPORT SDL Tokens
Description:
Y-Coordinate position of the Title bar frame. (Default 0)
Built on 16:20:16 10/01/14


TSE_STYLE_EZPORT_SUPPORT in the EZPORT SDL Tokens

Variable : TSE_STYLE_EZPORT_SUPPORT

File: EZPORT SDL Tokens
Description:
Main switch to enable Ezport Style in TSE
Built on 16:20:16 10/01/14


TSE_STYLE_SOURCES_SUPPORT in the EZPORT SDL Tokens

Variable : TSE_STYLE_SOURCES_SUPPORT

File: EZPORT SDL Tokens
Description:
Don't Edit.
Built on 16:20:16 10/01/14


VERTICAL_MAIN_DIVIDER in the EZPORT SDL Tokens

Variable : VERTICAL_MAIN_DIVIDER

File: EZPORT SDL Tokens
Description:
Vertical divider (border) position between the MainFrame window and (helper and Navigation) frame windows.
Built on 16:20:18 10/01/14


ezport.c

Description:
Main file for ezport style module.

The following functions are used in the file: ezport.c.

Function | Description
HandleEscKey | Function to handle ESC Hotkey action
HandleFailsafeKey | Function to handle Load Failsafe values Hotkey action
HandleHelpKey | Function to handle Help Hotkey action
HandleOptimalKey | Function to handle Load Optimal values Hotkey action
HandlePrevValuesKey | Function to handle Load Previous value Hotkey action
HandlePrnScrnKey | Function to handle print screen Hotkey action
HandleSaveExitKey | Function to handle Save and Exit Hotkey action
HelpFrameHandlewithMouse | Function to handle Help Frame with Mouse
MainFrameHandlewithMouse | Function to handle Main Frame with Mouse
NavFrameHandlewithMouse | Function to handle Navigation Frame with Mouse
OverRideStyleDrawPageBorder | Function to draw page border
OverRideStyleGetFrameInitData | Function to get frame initialization data
OverRideStyleInit | Function to Initialize style
StyleFrameAddTitle | Function to add frame title
StyleFrameIndexOf | Function to get frame index
StyleGetPageFrames | Function to number of frames

Built on 16:20:19 10/01/14


HandleEscKey in the ezport.c

Function : HandleEscKey

File: ezport.c
Description:
Function to handle ESC Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:08 10/01/14


HandleFailsafeKey in the ezport.c

Function : HandleFailsafeKey

File: ezport.c
Description:
Function to handle Load Failsafe values Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:09 10/01/14


HandleHelpKey in the ezport.c

Function : HandleHelpKey

File: ezport.c
Description:
Function to handle Help Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:09 10/01/14


HandleOptimalKey in the ezport.c

Function : HandleOptimalKey

File: ezport.c
Description:
Function to handle Load Optimal values Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:09 10/01/14


HandlePrevValuesKey in the ezport.c

Function : HandlePrevValuesKey

File: ezport.c
Description:
Function to handle Load Previous value Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:09 10/01/14


HandlePrnScrnKey in the ezport.c

Function : HandlePrnScrnKey

File: ezport.c
Description:
Function to handle print screen Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:09 10/01/14


HandleSaveExitKey in the ezport.c

Function : HandleSaveExitKey

File: ezport.c
Description:
Function to handle Save and Exit Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:09 10/01/14


HelpFrameHandlewithMouse in the ezport.c

Function : HelpFrameHandlewithMouse

File: ezport.c
Description:
Function to handle Help Frame with Mouse
Input:
APPLICATION_DATA *app, HOTCLICK_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:09 10/01/14


MainFrameHandlewithMouse in the ezport.c

Function : MainFrameHandlewithMouse

File: ezport.c
Description:
Function to handle Main Frame with Mouse
Input:
APPLICATION_DATA *app, HOTCLICK_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:11 10/01/14


NavFrameHandlewithMouse in the ezport.c

Function : NavFrameHandlewithMouse

File: ezport.c
Description:
Function to handle Navigation Frame with Mouse
Input:
APPLICATION_DATA *app, HOTCLICK_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:12 10/01/14


OverRideStyleDrawPageBorder in the ezport.c

Function : OverRideStyleDrawPageBorder

File: ezport.c
Description:
Function to draw page border
Input:
UINT32 page
Output:
VOID
Built on 16:20:12 10/01/14


OverRideStyleGetFrameInitData in the ezport.c

Function : OverRideStyleGetFrameInitData

File: ezport.c
Description:
Function to get frame initialization data
Input:
UINT32 page, UINT32 frame
Output:
VOID*
Built on 16:20:12 10/01/14


OverRideStyleInit in the ezport.c

Function : OverRideStyleInit

File: ezport.c
Description:
Function to Initialize style
Input:
VOID
Output:
VOID
Built on 16:20:12 10/01/14


StyleFrameAddTitle in the ezport.c

Function : StyleFrameAddTitle

File: ezport.c
Description:
Function to add frame title
Input:
FRAME_DATA *frame, UINT32 frameType, CONTROL_INFO * dummy
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


StyleFrameIndexOf in the ezport.c

Function : StyleFrameIndexOf

File: ezport.c
Description:
Function to get frame index
Input:
UINT32 frameType
Output:
UINT32 index
Built on 16:20:15 10/01/14


StyleGetPageFrames in the ezport.c

Function : StyleGetPageFrames

File: ezport.c
Description:
Function to number of frames
Input:
UINT32 page
Output:
UINT32 number of frames
Built on 16:20:15 10/01/14


ezport.h

Description:
Main header file for ezport style module.
Built on 16:20:19 10/01/14


ezportplus.c

Description:
Main file for ezportplus style module.

The following functions are used in the file: ezportplus.c.

Function | Description
_EzportPlusPopupPasswordActivate | function to set and activate a password
_EzportPlusPopupPasswordHandleAction | function to handle the password actions
EzportPlusHandleEscKey | Function to handle ESC Hotkey action
EzportPlusHandleFailsafeKey | Function to handle Load Failsafe values Hotkey action
EzportPlusHandleHelpKey | Function to handle Help Hotkey action
EzportPlusHandleOptimalKey | Function to handle Load Optimal values Hotkey action
EzportPlusHandlePrevValuesKey | Function to handle Load Previous value Hotkey action
EzportPlusHandlePrnScrnKey | Function to handle print screen Hotkey action
EzportPlusHandleSaveExitKey | Function to handle Save and Exit Hotkey action
EzportPlusHelpFrameHandlewithMouse | Function to handle Help Frame with Mouse
EzportPlusMainFrameHandlewithMouse | Function to handle Main Frame with Mouse
EzportPlusNavFrameHandlewithMouse | Function to handle Navigation Frame with Mouse
EzportPlusPopupPasswordChangePrompt | Function to display password prompts for old, new, and confirm in the same window.
EzportPlusPopupPasswordSetPrompt | Function to display password prompts for new, and confirm in the same window.
EzportPlusShowPasswordClearedMessageBox | Function to Display the password success message box
EzportPlusShowPasswordErrorMessageBox | Function to Display the password failed message box
EzportPlusShowPasswordSuccessMessageBox | Function to Display the password success message box
OverRideStyleDrawPageBorder | Function to draw page border
OverRideStyleGetFrameInitData | Function to get frame initialization data
OverRideStyleInit | Function to Initialize style
StyleFrameAddTitle | Function to add frame title
StyleFrameIndexOf | Function to get frame index
StyleGetPageFrames | Function to number of frames

Built on 16:20:19 10/01/14


_EzportPlusPopupPasswordActivate in the ezportplus.c

Function : _EzportPlusPopupPasswordActivate

File: ezportplus.c
Description:
function to set and activate a password
Input:
POPUP_PASSWORD_DATA *popuppassword
Output:
status
Built on 16:20:03 10/01/14


_EzportPlusPopupPasswordHandleAction in the ezportplus.c

Function : _EzportPlusPopupPasswordHandleAction

File: ezportplus.c
Description:
function to handle the password actions
Input:
POPUP_PASSWORD_DATA *popuppassword, , ACTION_DATA *Data
Output:
status
Built on 16:20:03 10/01/14


EzportPlusHandleEscKey in the ezportplus.c

Function : EzportPlusHandleEscKey

File: ezportplus.c
Description:
Function to handle ESC Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:07 10/01/14


EzportPlusHandleFailsafeKey in the ezportplus.c

Function : EzportPlusHandleFailsafeKey

File: ezportplus.c
Description:
Function to handle Load Failsafe values Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:07 10/01/14


EzportPlusHandleHelpKey in the ezportplus.c

Function : EzportPlusHandleHelpKey

File: ezportplus.c
Description:
Function to handle Help Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:07 10/01/14


EzportPlusHandleOptimalKey in the ezportplus.c

Function : EzportPlusHandleOptimalKey

File: ezportplus.c
Description:
Function to handle Load Optimal values Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:07 10/01/14


EzportPlusHandlePrevValuesKey in the ezportplus.c

Function : EzportPlusHandlePrevValuesKey

File: ezportplus.c
Description:
Function to handle Load Previous value Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:07 10/01/14


EzportPlusHandlePrnScrnKey in the ezportplus.c

Function : EzportPlusHandlePrnScrnKey

File: ezportplus.c
Description:
Function to handle print screen Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:07 10/01/14


EzportPlusHandleSaveExitKey in the ezportplus.c

Function : EzportPlusHandleSaveExitKey

File: ezportplus.c
Description:
Function to handle Save and Exit Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:07 10/01/14


EzportPlusHelpFrameHandlewithMouse in the ezportplus.c

Function : EzportPlusHelpFrameHandlewithMouse

File: ezportplus.c
Description:
Function to handle Help Frame with Mouse
Input:
APPLICATION_DATA *app, HOTCLICK_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:07 10/01/14


EzportPlusMainFrameHandlewithMouse in the ezportplus.c

Function : EzportPlusMainFrameHandlewithMouse

File: ezportplus.c
Description:
Function to handle Main Frame with Mouse
Input:
APPLICATION_DATA *app, HOTCLICK_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:07 10/01/14


EzportPlusNavFrameHandlewithMouse in the ezportplus.c

Function : EzportPlusNavFrameHandlewithMouse

File: ezportplus.c
Description:
Function to handle Navigation Frame with Mouse
Input:
APPLICATION_DATA *app, HOTCLICK_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:07 10/01/14


EzportPlusPopupPasswordChangePrompt in the ezportplus.c

Function : EzportPlusPopupPasswordChangePrompt

File: ezportplus.c
Description:
Function to display password prompts for old, new, and confirm in the same window.
Input:
POPUP_PASSWORD_DATA *PopupPassword,
UINT16 OldPrompt,
CHAR16 **OldPwd,
UINT16 NewPrompt,
CHAR16 **NewPwd,
UINT16 ConfirmPrompt,
CHAR16 **ConfirmPwd,
Output:
Status
Built on 16:20:07 10/01/14


EzportPlusPopupPasswordSetPrompt in the ezportplus.c

Function : EzportPlusPopupPasswordSetPrompt

File: ezportplus.c
Description:
Function to display password prompts for new, and confirm in the same window.
Input:
POPUP_PASSWORD_DATA *PopupPassword,
UINT16 NewPrompt,
CHAR16 **NewPwd,
UINT16 ConfirmPrompt,
CHAR16 **ConfirmPwd,
Output:
Status
Built on 16:20:07 10/01/14


EzportPlusShowPasswordClearedMessageBox in the ezportplus.c

Function : EzportPlusShowPasswordClearedMessageBox

File: ezportplus.c
Description:
Function to Display the password success message box
Input:
None
Output:
None
Built on 16:20:07 10/01/14


EzportPlusShowPasswordErrorMessageBox in the ezportplus.c

Function : EzportPlusShowPasswordErrorMessageBox

File: ezportplus.c
Description:
Function to Display the password failed message box
Input:
None
Output:
None
Built on 16:20:07 10/01/14


EzportPlusShowPasswordSuccessMessageBox in the ezportplus.c

Function : EzportPlusShowPasswordSuccessMessageBox

File: ezportplus.c
Description:
Function to Display the password success message box
Input:
None
Output:
None
Built on 16:20:07 10/01/14


OverRideStyleDrawPageBorder in the ezportplus.c

Function : OverRideStyleDrawPageBorder

File: ezportplus.c
Description:
Function to draw page border
Input:
UINT32 page
Output:
VOID
Built on 16:20:12 10/01/14


OverRideStyleGetFrameInitData in the ezportplus.c

Function : OverRideStyleGetFrameInitData

File: ezportplus.c
Description:
Function to get frame initialization data
Input:
UINT32 page, UINT32 frame
Output:
VOID*
Built on 16:20:12 10/01/14


OverRideStyleInit in the ezportplus.c

Function : OverRideStyleInit

File: ezportplus.c
Description:
Function to Initialize style
Input:
VOID
Output:
VOID
Built on 16:20:12 10/01/14


StyleFrameAddTitle in the ezportplus.c

Function : StyleFrameAddTitle

File: ezportplus.c
Description:
Function to add frame title
Input:
FRAME_DATA *frame, UINT32 frameType, CONTROL_INFO * dummy
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


StyleFrameIndexOf in the ezportplus.c

Function : StyleFrameIndexOf

File: ezportplus.c
Description:
Function to get frame index
Input:
UINT32 frameType
Output:
UINT32 index
Built on 16:20:15 10/01/14


StyleGetPageFrames in the ezportplus.c

Function : StyleGetPageFrames

File: ezportplus.c
Description:
Function to number of frames
Input:
UINT32 page
Output:
UINT32 number of frames
Built on 16:20:15 10/01/14


ezportplus.h

Description:
Main header file for ezportplus style module.
Built on 16:20:19 10/01/14


FormBrowser.c

Description:
This file contains code for form browser

The following functions are used in the file: FormBrowser.c.

Function | Description
FormBrowserHandleValid | return True Browser is showing forms from SendForm interface.
FormBrowserLocateSetupHandles | return Handles and count that is passed to SendForm interface.
InstallFormBrowserProtocol | Installs the Formbrowser Protocol in the given handle if SETUP_FORM_BROWSER_SUPPORT is on.
MinisetupCreatePopup | Function implements the CreatePopup interface of Formbrowser Protocol.
MinisetupSendForm | Function implements the SendForm interface of Formbrowser Protocol. UseDatabase=True is only supported.
UnInstallFormBrowserProtocol | Uninstalls the Formbrowser Protocol in the given handle if SETUP_FORM_BROWSER_SUPPORT is on.

Built on 16:20:19 10/01/14


FormBrowserHandleValid in the FormBrowser.c

Function : FormBrowserHandleValid

File: FormBrowser.c
Description:
return True Browser is showing forms from SendForm interface.
Input:
none
Output:
BOOLEAN
Built on 16:20:07 10/01/14


FormBrowserLocateSetupHandles in the FormBrowser.c

Function : FormBrowserLocateSetupHandles

File: FormBrowser.c
Description:
return Handles and count that is passed to SendForm interface.
Input:
OUT handleBuffer and count
Output:
Status
Built on 16:20:07 10/01/14


InstallFormBrowserProtocol in the FormBrowser.c

Function : InstallFormBrowserProtocol

File: FormBrowser.c
Description:
Installs the Formbrowser Protocol in the given handle if

 SETUP_FORM_BROWSER_SUPPORT
 is on.
Input:
IN  EFI_HANDLE Handle
Output:
Status
Built on 16:20:10 10/01/14


MinisetupCreatePopup in the FormBrowser.c

Function : MinisetupCreatePopup

File: FormBrowser.c
Description:
Function implements the CreatePopup interface of Formbrowser
            Protocol.
Input:
            IN  UINTN                           NumberOfLines,
            IN  BOOLEAN                         HotKey,
            IN  UINTN                           MaximumStringSize,
            OUT CHAR16                          *StringBuffer,
            OUT EFI_INPUT_KEY                   * KeyValue,
            IN  CHAR16                          *String,
Output:
Status
Built on 16:20:11 10/01/14


MinisetupSendForm in the FormBrowser.c

Function : MinisetupSendForm

File: FormBrowser.c
Description:
Function implements the SendForm interface of Formbrowser
            Protocol. UseDatabase=True is only supported.
Input:
Refer Spec. Packet,CallbackHandle, ScreenDimensions and ResetRequired
            parameters ignored.

            IN EFI_FORM_BROWSER_PROTOCOL        * This,
            IN BOOLEAN                          UseDatabase,
            IN EFI_HII_HANDLE                   * Handle,
            IN UINTN                            HandleCount,
            IN EFI_IFR_PACKET                   * Packet,
            IN EFI_HANDLE                       CallbackHandle,
            IN UINT8                            *NvMapOverride,
            IN SCREEN_DESCRIPTOR                * ScreenDimensions,
            OUT BOOLEAN                         *ResetRequired
Output:
Status
Built on 16:20:11 10/01/14


UnInstallFormBrowserProtocol in the FormBrowser.c

Function : UnInstallFormBrowserProtocol

File: FormBrowser.c
Description:
Uninstalls the Formbrowser Protocol in the given handle if

 SETUP_FORM_BROWSER_SUPPORT
 is on.
Input:
IN  EFI_HANDLE Handle
Output:
Status
Built on 16:20:18 10/01/14


FormBrowser2.c

Description:

The following functions are used in the file: FormBrowser2.c.

Function | Description
_ConfigRespToStorage | Parameter: VARIABLE_INFO *VariableInfo VOID **Buffer UINTN *Size EFI_STRING ConfigResp Return value:EFI_STATUS
_StorageToConfigResp | Parameter: VARIABLE_INFO *VariableInfo VOID *Buffer CHAR16 *ConfigHdr CHAR16 **ConfigResp Return value:EFI_STATUS
BrowserCallback | This function is called by a callback handler to retrieve uncommitted state data from the browser.
InstallFormBrowserProtocol | Install FormBrowser Protocol Parameter: EFI_HANDLE Handle Return value:EFI_STATUS
SendForm | This is the routine which an external caller uses to direct the browser where to obtain it's information.
SetCallBackControlInfo | Set the variable inforamtion Parameter: EFI_HANDLE VarHandle - Variable handle to process UINT32 VarIndex - Variable index in the gVariables->VariableList Return value:VOID
UnInstallFormBrowserProtocol | UnInstall FormBrowser Protocol Parameter: EFI_HANDLE Handle Return value:VOID

Built on 16:20:19 10/01/14


_ConfigRespToStorage in the FormBrowser2.c

Function : _ConfigRespToStorage

File: FormBrowser2.c
Description:

Parameter:	VARIABLE_INFO *VariableInfo
        VOID **Buffer
        UINTN *Size
        EFI_STRING ConfigResp

Return value:EFI_STATUS
Built on 16:20:03 10/01/14


_StorageToConfigResp in the FormBrowser2.c

Function : _StorageToConfigResp

File: FormBrowser2.c
Description:

Parameter:	VARIABLE_INFO *VariableInfo
        VOID *Buffer
        CHAR16 *ConfigHdr
        CHAR16 **ConfigResp

Return value:EFI_STATUS
Built on 16:20:04 10/01/14


BrowserCallback in the FormBrowser2.c

Function : BrowserCallback

File: FormBrowser2.c
Description:
This function is called by a callback handler to retrieve
uncommitted state data from the browser.
Input:
IN CONST EFI_FORM_BROWSER2_PROTOCOL *This - A pointer to the
   EFI_FORM_BROWSER2_PROTOCOL instance.
IN OUT UINTN *ResultsDataSize - A pointer to the size of the
   buffer associated with ResultsData.
IN OUT EFI_STRING ResultsData - A string returned from an IFR
   browser or equivalent. The results string will have no
   routing information in them.
IN BOOLEAN RetrieveData - A BOOLEAN field which allows an agent
   to retrieve (if RetrieveData = TRUE) data from the
   uncommitted browser state information or set
   (if RetrieveData = FALSE) data in the uncommitted browser
   state information.
IN CONST EFI_GUID *VariableGuid, OPTIONAL - An optional field to
   indicate the target variable GUID name to use.
IN CONST CHAR16 *VariableName  OPTIONAL - An optional field to
   indicate the target human-readable variable name.
Output:
EFI_STATUS status - EFI_SUCCESS, The results have been distributed
           or are awaiting distribution.
               EFI_BUFFER_TOO_SMALL, The ResultsDataSize
           specified was too small to contain the results data.
Built on 16:20:05 10/01/14


InstallFormBrowserProtocol in the FormBrowser2.c

Function : InstallFormBrowserProtocol

File: FormBrowser2.c
Description:
Install FormBrowser Protocol

Parameter:	EFI_HANDLE Handle

Return value:EFI_STATUS
Built on 16:20:10 10/01/14


SendForm in the FormBrowser2.c

Function : SendForm

File: FormBrowser2.c
Description:
This is the routine which an external caller uses to direct
        the browser where to obtain it's information.
Input:
EFI_FORM_BROWSER2_PROTOCOL *This - The Form Browser protocol instanse.
EFI_HII_HANDLE *Handles - A pointer to an array of Handles. If
   HandleCount > 1 we display a list of the formsets for the
   handles specified.
UINTN HandleCount - The number of Handles specified in Handle.
EFI_GUID *FormSetGuid [OPTIONAL] - This field points to the EFI_GUID
   which must match the Guid field in the EFI_IFR_FORM_SET
   op-code for the specified forms-based package. If
   FormSetGuid is NULL, then this function will display the
   first found forms package.
UINT16 FormId [OPTIONAL] - This field specifies which EFI_IFR_FORM
   to render as the first displayable page. If this field has
   a value of 0x0000, then the forms browser will render the
   specified forms in their encoded order.
EFI_SCREEN_DESCRIPTOR *ScreenDimenions [OPTIONAL] - Points to
   recommended form dimensions, including any non-content
   area, in characters. This allows the browser to be called
   so that it occupies a portion of the physical screen
   instead of dynamically determining the screen dimensions.
EFI_BROWSER_ACTION_REQUEST *ActionRequest [OPTIONAL] - Points to
   the action recommended by the form.
Output:
EFI_STATUS status - EFI_SUCCESS, The function completed successfully.
    EFI_INVALID_PARAMETER - One of the parameters has an invalid value.
    EFI_NOT_FOUND - No valid forms could be found to display.
Built on 16:20:14 10/01/14


SetCallBackControlInfo in the FormBrowser2.c

Function : SetCallBackControlInfo

File: FormBrowser2.c
Description:
Set the variable inforamtion

Parameter:	EFI_HANDLE VarHandle - Variable handle to process
UINT32 VarIndex - Variable index in the gVariables->VariableList

Return value:VOID
Built on 16:20:14 10/01/14


UnInstallFormBrowserProtocol in the FormBrowser2.c

Function : UnInstallFormBrowserProtocol

File: FormBrowser2.c
Description:
UnInstall FormBrowser Protocol

Parameter:	EFI_HANDLE Handle

Return value:VOID
Built on 16:20:18 10/01/14


FormBrowser2.h

Description:
Built on 16:20:19 10/01/14


frame.c

Description:
This file contains code to handle frame operations

The following functions are used in the file: frame.c.

Function | Description
_FocusFirst | Set focus to the first control in the frame (in the first page).
_FocusLast | Set focus to the last control in the frame.
_FrameAddControls | Function to add controls in the frame
_FrameAddTitle | Function to add tittle to a frame.
_FrameHandleKey | Controls Keyboard action for each frame
_FrameHandleMouse | Function to hadnle frame using mouse
_FrameMenuCallback | Function to set frame menu callback.
_FramePasswordCallback | Function to set frame password callback.
_FrameScroll | Adds scroll bar functionality for frames with many controls
_FrameSetControlFocus | Sets focus on a defined control in the frame
_FrameSubmenuCallback | Function to set frame submenu callback.
_FrameVariableCallback | Function to set frame variable callback.
_HelpFrameScroll | Function to hadnle help frame scroll using mouse
_NextFrame | Loads the controls from the next frame into the screen.
_PreviousFrame | Loads the controls from the previous frame into the screen.
CheckKeyinHotKeysList | For Inconsistence condition checking for Hotkeys pressed to show the popup
FrameAddControl | Adds controls to the frame
FrameCreate | Allocated memory size and creates frame
FrameDestroy | Destroys an existing frame and frees memory
FrameDraw | Draws the controls for the given frame
FrameDrawScrollBar | Draws the scrollbar controls for the frame..
FrameHandleAction | Action handler for specific frame
FrameInitialize | Initializes the frame data
FrameSetCallback | Function to set callback.
IsScrollSupportRequired | To know whether the scroll supprot required befor drawing the frame
TSEMouseFrameHandleAction | Function to hadnle frame using mouse
TSEMouseHelpFrameHandleAction | Function to hadnle help frame using mouse
TSEMouseScrollBarMove | Adds scroll bar functionality for frames with many controls

Built on 16:20:19 10/01/14


_FocusFirst in the frame.c

Function : _FocusFirst

File: frame.c
Description:
Set focus to the first control in the frame (in the first page).
Input:
FRAME_DATA *frame = Pointer to the current frame
Output:
EFI_STATUS status -
            EFI_SUCCESS - If there exists a previous page and the
                           function successfully loads it
            EFI_OUT_PF_RESOURCES - If there are know previous page
Built on 16:20:03 10/01/14


_FocusLast in the frame.c

Function : _FocusLast

File: frame.c
Description:
Set focus to the last control in the frame.
Input:
FRAME_DATA *frame = Pointer to the current frame
Output:
EFI_STATUS status -
            EFI_SUCCESS - If there exists a previous page and the
                           function successfully loads it
            EFI_OUT_PF_RESOURCES - If there are know previous page
Built on 16:20:03 10/01/14


_FrameAddControls in the frame.c

Function : _FrameAddControls

File: frame.c
Description:
Function to add controls in the frame
Input:
FRAME_DATA *frame, PAGE_INFO *data
Output:
STATUS
Built on 16:20:03 10/01/14


_FrameAddTitle in the frame.c

Function : _FrameAddTitle

File: frame.c
Description:
Function to add tittle to a frame.
Input:
FRAME_DATA *frame, UINT32 frameNumber, PAGE_INFO *data
Output:
status
Built on 16:20:03 10/01/14


_FrameHandleKey in the frame.c

Function : _FrameHandleKey

File: frame.c
Description:
Controls Keyboard action for each frame
Input:
FRAME_DATA *frame - Pointer to the frame data
        EFI_INPUT_KEY key - Key pressed in the keyboard
Output:
EFI_STATUS Status - EFI_SUCCESS if successful, else
                                EFI_UNSUPPORTED
Built on 16:20:03 10/01/14


_FrameHandleMouse in the frame.c

Function : _FrameHandleMouse

File: frame.c
Description:
Function to hadnle frame using mouse
Input:
FRAME_DATA *frame,
        MOUSE_INFO MouseInfo
Output:
EFI_STATUS
Built on 16:20:03 10/01/14


_FrameMenuCallback in the frame.c

Function : _FrameMenuCallback

File: frame.c
Description:
Function to set frame menu callback.
Input:
FRAME_DATA *frame, MENU_DATA *menu, VOID *cookie
Output:
VOID
Built on 16:20:03 10/01/14


_FramePasswordCallback in the frame.c

Function : _FramePasswordCallback

File: frame.c
Description:
Function to set frame password callback.
Input:
FRAME_DATA *frame, CONTROL_DATA *control, VOID *cookie
Output:
VOID
Built on 16:20:03 10/01/14


_FrameScroll in the frame.c

Function : _FrameScroll

File: frame.c
Description:
Adds scroll bar functionality for frames with many controls
Input:
FRAME_DATA *frame - Pointer to the frame data
        BOOLEAN bScrollUp - Go up is TRUE, else to down one control
Output:
EFI_STATUS Status - EFI_SUCCESS if successful, else
                                EFI_UNSUPPORTED
Built on 16:20:03 10/01/14


_FrameSetControlFocus in the frame.c

Function : _FrameSetControlFocus

File: frame.c
Description:
Sets focus on a defined control in the frame
Input:
FRAME_DATA *frame - Date for a specific frame
         UINT32 index - Index of the control
Output:
BOOLEAN focusSet - TRUE if focus is set, FALSE otherwise
Built on 16:20:03 10/01/14


_FrameSubmenuCallback in the frame.c

Function : _FrameSubmenuCallback

File: frame.c
Description:
Function to set frame submenu callback.
Input:
FRAME_DATA *frame, SUBMENU_DATA *submenu, VOID *cookie
Output:
VOID
Built on 16:20:03 10/01/14


_FrameVariableCallback in the frame.c

Function : _FrameVariableCallback

File: frame.c
Description:
Function to set frame variable callback.
Input:
FRAME_DATA *frame, CONTROL_DATA *control, VOID *cookie
Output:
VOID
Built on 16:20:03 10/01/14


_HelpFrameScroll in the frame.c

Function : _HelpFrameScroll

File: frame.c
Description:
Function to hadnle help frame scroll using mouse
Input:
FRAME_DATA *frame,
        ACTION_DATA *action,
        CONTROL_DATA **control
Output:
EFI_STATUS
Built on 16:20:04 10/01/14


_NextFrame in the frame.c

Function : _NextFrame

File: frame.c
Description:
Loads the controls from the next frame into the screen.
Input:
FRAME_DATA *frame = Pointer to the current frame
Output:
EFI_STATUS status -
            EFI_SUCCESS - If there exists a next page and the
                           function successfully loads it
            EFI_OUT_PF_RESOURCES - If there are know previous page
Built on 16:20:04 10/01/14


_PreviousFrame in the frame.c

Function : _PreviousFrame

File: frame.c
Description:
Loads the controls from the previous frame into the screen.
Input:
FRAME_DATA *frame = Pointer to the current frame
Output:
EFI_STATUS status -
            EFI_SUCCESS - If there exists a previous page and the
                           function successfully loads it
            EFI_OUT_PF_RESOURCES - If there are know previous page
Built on 16:20:04 10/01/14


CheckKeyinHotKeysList in the frame.c

Function : CheckKeyinHotKeysList

File: frame.c
Description:
For Inconsistence condition checking for Hotkeys pressed to show the popup
Input:
AMI_EFI_KEY_DATA Key
Output:
BOOLEAN
Built on 16:20:05 10/01/14


FrameAddControl in the frame.c

Function : FrameAddControl

File: frame.c
Description:
Adds controls to the frame
Input:
FRAME_DATA *frame - Pointer to the frame data
        CONTROL_INFO *controlData - Control date to be added
Output:
EFI_STATUS Status - EFI_SUCCESS if successful, else
                                EFI_UNSUPPORTED
Built on 16:20:07 10/01/14


FrameCreate in the frame.c

Function : FrameCreate

File: frame.c
Description:
Allocated memory size and creates frame
Input:
FRAME_DATA **object
Output:
EFI_STATUS status -
        EFI_SUCCESS -
        EFI_OUT_OF_RESOURCES - if the object is NULL
        EFI_ERROR - If there are any the error in the object
                    creating process
Built on 16:20:07 10/01/14


FrameDestroy in the frame.c

Function : FrameDestroy

File: frame.c
Description:
Destroys an existing frame and frees memory
Input:
FRAME_DATA *frame - Frame to be destroyed
        BOOLEAN freeMem - Frees frame memory if TRUE, ignores
                            otherwise
Output:
EFI_STATUS - EFI_SUCCESS
Built on 16:20:07 10/01/14


FrameDraw in the frame.c

Function : FrameDraw

File: frame.c
Description:
Draws the controls for the given frame
Input:
FRAME_DATA *frame - Frame information to draw controls
Output:
EFI_STATUS - EFI_SUCCESS if successful, else EFI_ERROR
Built on 16:20:07 10/01/14


FrameDrawScrollBar in the frame.c

Function : FrameDrawScrollBar

File: frame.c
Description:
Draws the scrollbar controls for the frame..
Input:
FRAME_DATA *frame	- Pointer to the current frame
        UINT32	FirstLine	- FirstLine of the scrollbar
        UINT32 LastLine		- LastLine
        UINT32	modVal		- modVal
        UINT32	sizeOfBar	- Size of the Scrollbar
        UINT32 numOfBlocks	- Number of blocks
        BOOLEAN bEraseScrollBar	- flag to erase the scrollbar
Output:
EFI_STATUS status -
            EFI_SUCCESS - If there exists a next page and the
                           function successfully loads it
            EFI_OUT_PF_RESOURCES - If there are know previous page
Built on 16:20:07 10/01/14


FrameHandleAction in the frame.c

Function : FrameHandleAction

File: frame.c
Description:
Action handler for specific frame
Input:
FRAME_DATA *frame - Pointer to the frame data
        ACTION_DATA *action - Specific action for the frame
Output:
EFI_STATUS Status - EFI_SUCCESS if successful, else
                                EFI_UNSUPPORTED
Built on 16:20:07 10/01/14


FrameInitialize in the frame.c

Function : FrameInitialize

File: frame.c
Description:
Initializes the frame data
Input:
FRAME_DATA *frame - Frame to be intialized
         FRAME_INFO *data - Related frame data
Output:
EFI_STATUS - EFI_SUCCESS
Built on 16:20:07 10/01/14


FrameSetCallback in the frame.c

Function : FrameSetCallback

File: frame.c
Description:
Function to set callback.
Input:
FRAME_DATA *frame, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
STATUS
Built on 16:20:07 10/01/14


IsScrollSupportRequired in the frame.c

Function : IsScrollSupportRequired

File: frame.c
Description:
To know whether the scroll supprot required befor drawing the frame
Input:
FRAME_DATA *frame - Frame information to get frame info
Output:
BOOLEAN - TRUE/FALSE
Built on 16:20:10 10/01/14


TSEMouseFrameHandleAction in the frame.c

Function : TSEMouseFrameHandleAction

File: frame.c
Description:
Function to hadnle frame using mouse
Input:
FRAME_DATA *frame,
        ACTION_DATA *action,
        CONTROL_DATA **control
Output:
EFI_STATUS
Built on 16:20:16 10/01/14


TSEMouseHelpFrameHandleAction in the frame.c

Function : TSEMouseHelpFrameHandleAction

File: frame.c
Description:
Function to hadnle help frame using mouse
Input:
FRAME_DATA *frame,
        ACTION_DATA *action,
        CONTROL_DATA **control
Output:
EFI_STATUS
Built on 16:20:16 10/01/14


TSEMouseScrollBarMove in the frame.c

Function : TSEMouseScrollBarMove

File: frame.c
Description:
Adds scroll bar functionality for frames with many controls
Input:
FRAME_DATA *frame - Pointer to the frame data
        BOOLEAN bScrollUp - Go up is TRUE, else to down one control
Output:
EFI_STATUS Status - EFI_SUCCESS if successful, else
                                EFI_UNSUPPORTED
Built on 16:20:16 10/01/14


frame.h

Description:
Header file for Frame control related functions
Built on 16:20:19 10/01/14


globals.c

Description:
file contains code to take care of the globals in boot only
Built on 16:20:19 10/01/14


hii.c

Description:
This file contains code to handle the uefi2.0 based hii operations

The following functions are used in the file: hii.c.

Function | Description
_FxiupNotificationData | Parameter: Return value:
_GetClassSubClassID | Parameter: VOID *DefValue Return value: EFI_STATUS - The status
_HiiGetForm | to get data using the input handle
_HiiGetFormSet | Parameter: Return value: EFI_IFR_FORM_SET
_HiiGetHandles | Function to get HII handles
_HiiGetLinkIndex | to get the index of the link
_HiiLocateSetupHandles | Function to find the Setup Handles
_HiiParseVariablePack | To parse the variable pack and Update the Current Values with Default Values
_IsFormFound | Parameter: Return value: UINT16 - 1 Form Found 0 Form Not Found
_MergePageIdListAndInfo | Parameter: Return value: EFI_STATUS
_MergePageListAndInfo | Parameter: Return value: EFI_STATUS EFI_SUCCESS EFI_OUT_OF_RESOURCES
_MergeVariableListAndInfo | Parameter: Return value: EFI_STATUS
_ReInitializeSetupdataPointers | Parameter: Return value:
AddControlToList | to add a control to list
AddDynamicForm |
AddFormSetVariable |
AddHpkControls |
AddPageIdToList | Function to add page id to list
AddPageToList | to add a page to list
AddVariable | Function to add variable
AddVariableToList | Function to add variable to list
CleanVarKeyTable | To clear the key table specific buffers
CreatePage | function used to create a page
FindHandleWithInSetupData | Checks if the given handle is avaiable in the scope of the current formset.
FixIFRRefXControl | Updates the parent pageID for the EFI_IFR_REFX control
FixSetupData | Parameter: Return value:
GetAcknowledgementKey | Waits for a Key Press Parameter: VOID Return value: EFI_STATUS
GetDevPathFromHandle | Get the device path for the the given handle
GetFormByFormID | Parameter: Return value:
GetFormSetTitleAndHelp | GetFormSetTitleAndHelp Parameter: EFI_HII_HANDLE Handle, EFI_STRING_ID *Title, EFI_STRING_ID *Help Return value: status
GetHelpToken |
GetNextForm | Parameter: Return value:
GetPageIdFromGuid | Finds the page ID with matching Guid from the page list
GetPageIdIndex | To get the index of a perticular page
GetPageNumFromFormID |
GetPageParent | Function to get parent page
GetQuestionToken |
GetRWVariableID | Returns the variable ID for read write operation
GetStringFromDevPath | Gets the string presentation of the given DevicePath
GetSubFormCount | function to count the subform and Ref inside the formset.
GetVarNumFromVarID | Function to get variable number from var ID
HandleAddIFRPack | Adds a IFR pack data from gSetupData
HandleNewIFRPack | Added a new IFR pack data in gSetupData
HandleRemoveIFRPack | Removes a IFR pack data from gSetupData
HiiChangeString | to change a existing string
HiiExit | performs the operations that required to exit from HII
HiiFindHandle | Function to find the perticular HII handle
HiiFixupData | Function to fixup hhi data
HiiGetEfiKey | Function to Encode the password key
HiiGetForm | Get HII form package by handle and form ID
HiiGetFormSet | Function to get formset
HiiGetFormSetFromHandle | Function to get formset handle
HiiGetStringLength | Function to get the string length
HiiLoadDefaults | function to load the default values
HiiMyGetMultiLineStringLength | returns Max length of the in the paragraph
HiiMyGetStringLength | user function to get the string length
HiiRemoveString | Parameter: EFI_HII_HANDLE Handle, UINT16 Token Return value: VOID
InitFormsetLinks | Function to init formset links
IsFormFound | to Check whether the perticular form found or not
IsVarGuidPresent |
MergePageIdListAndInfo | Function to merge page id list and info
MergePageListAndInfo | To merge the information
MergeVariableListAndInfo | Function to merge variable list and info
RegFormNotification | Registers the hii pack notification Parameter: VOID Return value: EFI_STATUS
RTIfrProcessAddVarListAndPageIDList | Function to add var list page ID list
RTIfrProcessExit | Function to process ifr exit
RTIfrProcessFormIfUpdated | Fuction to process form if updated
RTIfrProcessRunTimeForms | Function to process runtime forms
RTIfrUpdateVariableInfo | Wrapper function to include RTIfrUpdateVariableInfo based on SDL token.
SavePswdString | Dummy fucntion to avoid build error Parameter: CONTROL_INFO * ControlData, CHAR16 *String Return Value: VOID
SpecialControlsFixup | Fixes control information for special control in the varstore Parameter: None Return value: EFI_STATUS
StopRefreshOpEvent | Stops the refresh event
UefiGetActionWapper | The Wrapper function to get the actual action for the driver Parameter: UINTN Action Return Value: EFI_BROWSER_ACTION
UefiupdateResetButtonDefault | Function to update defaults depending on the Default Id on Selecting the Reset Button
UnRegFormNotification | Unregisters the form notification Parameter: VOID Return value: VOID
Updatedefaults | Function to update defsaults
UpdateIFRRefXControls | Updates the reference link information in for the EFI_IFR_REFX controls

Built on 16:20:20 10/01/14


_FxiupNotificationData in the hii.c

Function : _FxiupNotificationData

File: hii.c
Description:

Parameter:

Return value:
Built on 16:20:03 10/01/14


_GetClassSubClassID in the hii.c

Function : _GetClassSubClassID

File: hii.c
Description:

Parameter:    VOID *DefValue

Return value: EFI_STATUS - The status
Built on 16:20:03 10/01/14


_HiiGetForm in the hii.c

Function : _HiiGetForm

File: hii.c
Description:
to get data using the input handle
Input:
VOID* handle, UINT16 form, UINTN *Length
Output:
info buffer
Built on 16:20:04 10/01/14


_HiiGetFormSet in the hii.c

Function : _HiiGetFormSet

File: hii.c
Description:

Parameter:

Return value: EFI_IFR_FORM_SET
Built on 16:20:04 10/01/14


_HiiGetHandles in the hii.c

Function : _HiiGetHandles

File: hii.c
Description:
Function to get HII handles
Input:
UINT16 *bufferSize
Output:
Status
Built on 16:20:04 10/01/14


_HiiGetLinkIndex in the hii.c

Function : _HiiGetLinkIndex

File: hii.c
Description:
to get the index of the link
Input:
EFI_GUID *guid, UINT16 class, UINT16 subclass, UINT16 formid
Output:
Index
Built on 16:20:04 10/01/14


_HiiLocateSetupHandles in the hii.c

Function : _HiiLocateSetupHandles

File: hii.c
Description:
Function to find the Setup Handles
Input:
void
Output:
Status
Built on 16:20:04 10/01/14


_HiiParseVariablePack in the hii.c

Function : _HiiParseVariablePack

File: hii.c
Description:
To parse the variable pack and Update the Current Values with Default Values
Input:
EFI_HII_VARIABLE_PACK_LIST *packList, NVRAM_VARIABLE **pVarList
Output:
void
Built on 16:20:04 10/01/14


_IsFormFound in the hii.c

Function : _IsFormFound

File: hii.c
Description:

Parameter:

Return value: UINT16 -
            1 Form Found
            0 Form Not Found
Built on 16:20:04 10/01/14


_MergePageIdListAndInfo in the hii.c

Function : _MergePageIdListAndInfo

File: hii.c
Description:

Parameter:

Return value: EFI_STATUS
Built on 16:20:04 10/01/14


_MergePageListAndInfo in the hii.c

Function : _MergePageListAndInfo

File: hii.c
Description:

Parameter:

Return value: EFI_STATUS
            EFI_SUCCESS
            EFI_OUT_OF_RESOURCES
Built on 16:20:04 10/01/14


_MergeVariableListAndInfo in the hii.c

Function : _MergeVariableListAndInfo

File: hii.c
Description:

Parameter:

Return value: EFI_STATUS
Built on 16:20:04 10/01/14


_ReInitializeSetupdataPointers in the hii.c

Function : _ReInitializeSetupdataPointers

File: hii.c
Description:

Parameter:

Return value:
Built on 16:20:04 10/01/14


AddControlToList in the hii.c

Function : AddControlToList

File: hii.c
Description:
to add a control to list
Input:
CONTROL_INFO *NewControlInfo, UINT32 ControlSize
Output:
offset
Built on 16:20:05 10/01/14


AddDynamicForm in the hii.c

Function : AddDynamicForm

File: hii.c
Description:
Input:
UINT32 HiiIndex
Output:
VOID
Built on 16:20:05 10/01/14


AddFormSetVariable in the hii.c

Function : AddFormSetVariable

File: hii.c
Description:
Input:
EFI_GUID * VarGuid
Output:
VarCount
Built on 16:20:05 10/01/14


AddHpkControls in the hii.c

Function : AddHpkControls

File: hii.c
Description:
Input:
UINT32 HiiIndex, UINT8 *buff,UINTN size, PAGE_INFO **NewPageInfo,
            UINT32 *AllocatedPageSize, UINT32 *PageOffset
Output:
UINTN
Built on 16:20:05 10/01/14


AddPageIdToList in the hii.c

Function : AddPageIdToList

File: hii.c
Description:
Function to add page id to list
Input:
PAGE_ID_INFO *NewPageIdInfo, UINT32 PageIdSize
Output:
VOID
Built on 16:20:05 10/01/14


AddPageToList in the hii.c

Function : AddPageToList

File: hii.c
Description:
to add a page to list
Input:
PAGE_INFO *NewPageInfo, UINT32 PageSize
Output:
void
Built on 16:20:05 10/01/14


AddVariable in the hii.c

Function : AddVariable

File: hii.c
Description:
Function to add variable
Input:
EFI_IFR_VARSTORE *Varstore
Output:
success
Built on 16:20:05 10/01/14


AddVariableToList in the hii.c

Function : AddVariableToList

File: hii.c
Description:
Function to add variable to list
Input:
VARIABLE_INFO *NewVariableInfo, UINT32 VariableSize
Output:
VOID
Built on 16:20:05 10/01/14


CleanVarKeyTable in the hii.c

Function : CleanVarKeyTable

File: hii.c
Description:
To clear the key table specific buffers
Input:
NIL
Output:
VOID
Built on 16:20:06 10/01/14


CreatePage in the hii.c

Function : CreatePage

File: hii.c
Description:
function used to create a page
Input:
PAGE_INFO **PageInfo, UINT32 *AllocatedSize,
        UINT32 *Offset, VOID *Buff, UINT32 BuffSize
Output:
void
Built on 16:20:06 10/01/14


FindHandleWithInSetupData in the hii.c

Function : FindHandleWithInSetupData

File: hii.c
Description:
Checks if the given handle is avaiable in the scope of the
current formset.
Input:
EFI_HII_HANDLE Handle
Output:
EFI_STATUS Status - EFI_NOT_FOUND, if not found, else EFI_SUCCESS
Built on 16:20:07 10/01/14


FixIFRRefXControl in the hii.c

Function : FixIFRRefXControl

File: hii.c
Description:
Updates the parent pageID for the EFI_IFR_REFX
control
Input:
CONTROL_INFO * CtrlInfo - Control Info in the library
PAGE_INFO *PageInfo - Page Info in the library
Output:
EFI_STATUS status - EFI_SUCCESS if successful, else EFI_ERROR
Built on 16:20:07 10/01/14


FixSetupData in the hii.c

Function : FixSetupData

File: hii.c
Description:

Parameter:

Return value:
Built on 16:20:07 10/01/14


GetAcknowledgementKey in the hii.c

Function : GetAcknowledgementKey

File: hii.c
Description:
Waits for a Key Press

Parameter:		VOID

Return value:	EFI_STATUS
Built on 16:20:08 10/01/14


GetDevPathFromHandle in the hii.c

Function : GetDevPathFromHandle

File: hii.c
Description:
Get the device path for the the given handle
Input:
EFI_HII_HANDLE HiiHandle - Input handle
EFI_DEVICE_PATH_PROTOCOL **DevicePath - Corresponding device path
                      if successful.
Output:
EFI_STATUS Status - EFI_SUCCESS, if successful, else EFI_ERROR
Built on 16:20:08 10/01/14


GetFormByFormID in the hii.c

Function : GetFormByFormID

File: hii.c
Description:

Parameter:

Return value:
Built on 16:20:08 10/01/14


GetFormSetTitleAndHelp in the hii.c

Function : GetFormSetTitleAndHelp

File: hii.c
Description:
GetFormSetTitleAndHelp

Parameter:   EFI_HII_HANDLE Handle, EFI_STRING_ID *Title, EFI_STRING_ID *Help

Return value: status
Built on 16:20:08 10/01/14


GetHelpToken in the hii.c

Function : GetHelpToken

File: hii.c
Description:
Input:
UINT8 *ifr
Output:
token
Built on 16:20:08 10/01/14


GetNextForm in the hii.c

Function : GetNextForm

File: hii.c
Description:

Parameter:

Return value:
Built on 16:20:08 10/01/14


GetPageIdFromGuid in the hii.c

Function : GetPageIdFromGuid

File: hii.c
Description:
Finds the page ID with matching Guid from the page list
Input:
EFI_GUID *FormGuid
UINT16 *PageID
Output:
EFI_STATUS status - EFI_SUCCESS, if successful,
               EFI_INVALID_PARAMETER, if invalid values found
Built on 16:20:08 10/01/14


GetPageIdIndex in the hii.c

Function : GetPageIdIndex

File: hii.c
Description:
To get the index of a perticular page
Input:
EFI_GUID * FormGuid, UINT16 FormClass, UINT16 FormSubClass
Output:
PageIndex
Built on 16:20:08 10/01/14


GetPageNumFromFormID in the hii.c

Function : GetPageNumFromFormID

File: hii.c
Description:
Input:
UINTN FormID
Output:
PageNum
Built on 16:20:08 10/01/14


GetPageParent in the hii.c

Function : GetPageParent

File: hii.c
Description:
Function to get parent page
Input:
int PageNum
Output:
UINT16
Built on 16:20:08 10/01/14


GetQuestionToken in the hii.c

Function : GetQuestionToken

File: hii.c
Description:
Input:
UINT8 *ifr
Output:
token
Built on 16:20:08 10/01/14


GetRWVariableID in the hii.c

Function : GetRWVariableID

File: hii.c
Description:
Returns the variable ID for read write operation
Input:
UINT16, CONTROL_INFO *, UINT16 *
Output:
EFI_STATUS
Built on 16:20:08 10/01/14


GetStringFromDevPath in the hii.c

Function : GetStringFromDevPath

File: hii.c
Description:
Gets the string presentation of the given DevicePath
Input:
EFI_DEVICE_PATH_PROTOCOL *DevPath - Given device path
CHAR16 **DevPathStr - Return pointer to the string presentation
Output:
EFI_STATUS status - EFI_SUCCESS, if successful, else EFI_ERROR
Built on 16:20:08 10/01/14


GetSubFormCount in the hii.c

Function : GetSubFormCount

File: hii.c
Description:
function to count the subform and Ref inside the formset.
Input:
UINT8 *buff	- Pointer to form to search for links to other forms
Output:
count - no of subforms
Built on 16:20:08 10/01/14


GetVarNumFromVarID in the hii.c

Function : GetVarNumFromVarID

File: hii.c
Description:
Function to get variable number from var ID
Input:
UINT32 ID
Output:
Variable Index
Built on 16:20:08 10/01/14


HandleAddIFRPack in the hii.c

Function : HandleAddIFRPack

File: hii.c
Description:
Adds a IFR pack data from gSetupData
Input:
EFI_HANDLE Handle - Formset handle
UINT8 *PackData - Update pack data to add
Output:
EFI_STATUS status - EFI_OUT_OF_RESOURCES if memory allocation fails
                        EFI_SUCCESS if successful
Built on 16:20:08 10/01/14


HandleNewIFRPack in the hii.c

Function : HandleNewIFRPack

File: hii.c
Description:
Added a new IFR pack data in gSetupData
Input:
EFI_HANDLE Handle - Formset handle
UINT8 *PackData - New pack data to add
Output:
EFI_STATUS status - EFI_OUT_OF_RESOURCES if memory allocation fails
                        EFI_SUCCESS if successful
Built on 16:20:09 10/01/14


HandleRemoveIFRPack in the hii.c

Function : HandleRemoveIFRPack

File: hii.c
Description:
Removes a IFR pack data from gSetupData
Input:
EFI_HANDLE Handle - Formset handle
Output:
EFI_STATUS status - EFI_OUT_OF_RESOURCES if memory allocation fails
                        EFI_SUCCESS if successful
Built on 16:20:09 10/01/14


HiiChangeString in the hii.c

Function : HiiChangeString

File: hii.c
Description:
to change a existing string
Input:
VOID* handle, UINT16 token, CHAR16 *string
Output:
Status
Built on 16:20:09 10/01/14


HiiExit in the hii.c

Function : HiiExit

File: hii.c
Description:
performs the operations that required to exit from HII
Input:
VOID
Output:
Status
Built on 16:20:09 10/01/14


HiiFindHandle in the hii.c

Function : HiiFindHandle

File: hii.c
Description:
Function to find the perticular HII handle
Input:
EFI_GUID *guid, UINT16 *index
Output:
Handle
Built on 16:20:09 10/01/14


HiiFixupData in the hii.c

Function : HiiFixupData

File: hii.c
Description:
Function to fixup hhi data
Input:
NIL
Output:
Status
Built on 16:20:09 10/01/14


HiiGetEfiKey in the hii.c

Function : HiiGetEfiKey

File: hii.c
Description:
Function to Encode the password key
Input:
CHAR16 *PwKey
Output:
VOID
Built on 16:20:09 10/01/14


HiiGetForm in the hii.c

Function : HiiGetForm

File: hii.c
Description:
Get HII form package by handle and form ID
Input:
EFI_HII_HANDLE Handle
UINT16 form
UINTN *Length
Output:
VOID *formPkBuffer -
Built on 16:20:09 10/01/14


HiiGetFormSet in the hii.c

Function : HiiGetFormSet

File: hii.c
Description:
Function to get formset
Input:
UINTN index
Output:
formset
Built on 16:20:09 10/01/14


HiiGetFormSetFromHandle in the hii.c

Function : HiiGetFormSetFromHandle

File: hii.c
Description:
Function to get formset handle
Input:
VOID* handle
Output:
Formset
Built on 16:20:09 10/01/14


HiiGetStringLength in the hii.c

Function : HiiGetStringLength

File: hii.c
Description:
Function to get the string length
Input:
VOID* handle,
        UINT16 token
Output:
Length
Built on 16:20:09 10/01/14


HiiLoadDefaults in the hii.c

Function : HiiLoadDefaults

File: hii.c
Description:
function to load the default values
Input:
NVRAM_VARIABLE **varList, UINTN Mask
Output:
Status
Built on 16:20:09 10/01/14


HiiMyGetMultiLineStringLength in the hii.c

Function : HiiMyGetMultiLineStringLength

File: hii.c
Description:
returns Max length of the in the paragraph
Input:
Handle and token
Output:
Length
Built on 16:20:09 10/01/14


HiiMyGetStringLength in the hii.c

Function : HiiMyGetStringLength

File: hii.c
Description:
user function to get the string length
Input:
VOID* handle, UINT16 token
Output:
Length
Built on 16:20:09 10/01/14


HiiRemoveString in the hii.c

Function : HiiRemoveString

File: hii.c
Description:

Parameter:	    EFI_HII_HANDLE Handle, UINT16 Token

Return value:  	VOID
Built on 16:20:09 10/01/14


InitFormsetLinks in the hii.c

Function : InitFormsetLinks

File: hii.c
Description:
Function to init formset links
Input:
char *buff, UINTN InitFormNum
Output:
VOID
Built on 16:20:10 10/01/14


IsFormFound in the hii.c

Function : IsFormFound

File: hii.c
Description:
to Check whether the perticular form found or not
Input:
EFI_IFR_FORM_SET *formSet,UINT16 formid
Output:
0/1
Built on 16:20:10 10/01/14


IsVarGuidPresent in the hii.c

Function : IsVarGuidPresent

File: hii.c
Description:
Input:
EFI_GUID * VarGuid, int * Index
Output:
TRUE/FALSE
Built on 16:20:10 10/01/14


MergePageIdListAndInfo in the hii.c

Function : MergePageIdListAndInfo

File: hii.c
Description:
Function to merge page id list and info
Input:
NIL
Output:
VOID
Built on 16:20:11 10/01/14


MergePageListAndInfo in the hii.c

Function : MergePageListAndInfo

File: hii.c
Description:
To merge the information
Input:
NIL
Output:
VOID
Built on 16:20:11 10/01/14


MergeVariableListAndInfo in the hii.c

Function : MergeVariableListAndInfo

File: hii.c
Description:
Function to merge variable list and info
Input:
NIL
Output:
VOID
Built on 16:20:11 10/01/14


RegFormNotification in the hii.c

Function : RegFormNotification

File: hii.c
Description:
Registers the hii pack notification

Parameter: VOID

Return value: EFI_STATUS
Built on 16:20:14 10/01/14


RTIfrProcessAddVarListAndPageIDList in the hii.c

Function : RTIfrProcessAddVarListAndPageIDList

File: hii.c
Description:
Function to add var list page ID list
Input:
void
Output:
void
Built on 16:20:14 10/01/14


RTIfrProcessExit in the hii.c

Function : RTIfrProcessExit

File: hii.c
Description:
Function to process ifr exit
Input:
void
Output:
void
Built on 16:20:14 10/01/14


RTIfrProcessFormIfUpdated in the hii.c

Function : RTIfrProcessFormIfUpdated

File: hii.c
Description:
Fuction to process form if updated
Input:
UINT16 link
Output:
TRUE/FALSE
Built on 16:20:14 10/01/14


RTIfrProcessRunTimeForms in the hii.c

Function : RTIfrProcessRunTimeForms

File: hii.c
Description:
Function to process runtime forms
Input:
EFI_IFR_REF **ref
Output:
VOID
Built on 16:20:14 10/01/14


RTIfrUpdateVariableInfo in the hii.c

Function : RTIfrUpdateVariableInfo

File: hii.c
Description:
Wrapper function to include RTIfrUpdateVariableInfo
based on SDL token.
Input:
ControlVariable
Output:
VOID
Built on 16:20:14 10/01/14


SavePswdString in the hii.c

Function : SavePswdString

File: hii.c
Description:
Dummy fucntion to avoid build error

Parameter:     CONTROL_INFO * ControlData, CHAR16 *String

Return Value:  VOID
Built on 16:20:14 10/01/14


SpecialControlsFixup in the hii.c

Function : SpecialControlsFixup

File: hii.c
Description:
Fixes control information for special control in the varstore

Parameter:    None

Return value: EFI_STATUS
Built on 16:20:15 10/01/14


StopRefreshOpEvent in the hii.c

Function : StopRefreshOpEvent

File: hii.c
Description:
Stops the refresh event
Input:
CONTROL_INFO *
Output:
VOID
Built on 16:20:15 10/01/14


UefiGetActionWapper in the hii.c

Function : UefiGetActionWapper

File: hii.c
Description:
The Wrapper function to get the actual action for the driver

Parameter:     UINTN Action

Return Value:  EFI_BROWSER_ACTION
Built on 16:20:17 10/01/14


UefiupdateResetButtonDefault in the hii.c

Function : UefiupdateResetButtonDefault

File: hii.c
Description:
Function to update defaults depending on the Default Id on Selecting the Reset Button
Input:
CONTROL_INFO ControlData, UINT16 DefaultId
Output:
EFI_STATUS
Built on 16:20:17 10/01/14


UnRegFormNotification in the hii.c

Function : UnRegFormNotification

File: hii.c
Description:
Unregisters the form notification

Parameter:	VOID

Return value: VOID
Built on 16:20:18 10/01/14


Updatedefaults in the hii.c

Function : Updatedefaults

File: hii.c
Description:
Function to update defsaults
Input:
VOID *Data, UINT16 *size, VOID *Failsafe, VOID *Optimal,
            struct _CONTROL_FLAGS *ControlFlags
Output:
void
Built on 16:20:18 10/01/14


UpdateIFRRefXControls in the hii.c

Function : UpdateIFRRefXControls

File: hii.c
Description:
Updates the reference link information in for the EFI_IFR_REFX
controls
Input:
CONTROL_INFO * CtrlInfo - Control Info in the library
BOOLEAN *PgHasRefXCtrl - Return TRUE if REF4 control found
Output:
EFI_STATUS status - EFI_SUCCESS if successful, else EFI_ERROR
Built on 16:20:18 10/01/14


hii.h

Description:
Header file for Hii functionallities
Built on 16:20:20 10/01/14


Hiicallback.c

Description:
This file contains code for Hii callback operations

The following functions are used in the file: Hiicallback.c.

Function | Description
CallFormCallBack | To call form callback
CallTextCallBack | Fuction to call text callback
FormCallBack | Parameter: EFI_HII_HANDLE Handle, EFI_QUESTION_ID QuestionID, UINT8 Type, EFI_IFR_TYPE_VALUE *Value Return Value: EFI_STATUS
SavePswdString | fucntion to save the password string. Parameter: CONTROL_INFO * ControlData, CHAR16 *String Return Value: VOID
SpecialActionCallBack | Callback for UEFI Action control. This is used only in UEFI 2.1
UEFICallSetupFormCallBack | Wrapper function for the Implementation of FormBrowser with actions support .This is used only in UEFI 2.1
UefiGetActionWapper | The Wrapper function to get the actual action for the driver Parameter: UINTN Action Return Value: EFI_BROWSER_ACTION
UefiIsProceedWithPageChange | If the FormCallBack returns status is EFI_UNSUPPORTED or EFI_SUCCESS. Change page is allowed. Otherwise changeing of page should not happen For UEFI 2.0 Just return EFI_SUCCESS; Parameter: EFI_STATUS Return Value: EFI_STATUS
UefiPreControlUpdate | store the Control value before updating and calling the callback. Parameter: CONTROL_INFO * ControlData Return Value: EFI_STATUS

Built on 16:20:20 10/01/14


CallFormCallBack in the Hiicallback.c

Function : CallFormCallBack

File: Hiicallback.c
Description:
To call form callback
Input:
CONTROL_INFO * pControlData,
        UINT16 Key,
        UINT8 Flags
        UINTN Action
Output:
Status
Built on 16:20:05 10/01/14


CallTextCallBack in the Hiicallback.c

Function : CallTextCallBack

File: Hiicallback.c
Description:
Fuction to call text callback
Input:
TEXT_DATA *text, ACTION_DATA *Data
Output:
Status
Built on 16:20:05 10/01/14


FormCallBack in the Hiicallback.c

Function : FormCallBack

File: Hiicallback.c
Description:

Parameter:     EFI_HII_HANDLE Handle, EFI_QUESTION_ID QuestionID,
  UINT8 Type, EFI_IFR_TYPE_VALUE *Value

Return Value:  EFI_STATUS
Built on 16:20:07 10/01/14


SavePswdString in the Hiicallback.c

Function : SavePswdString

File: Hiicallback.c
Description:
fucntion to save the password string.

Parameter:     CONTROL_INFO * ControlData, CHAR16 *String

Return Value:  VOID
Built on 16:20:14 10/01/14


SpecialActionCallBack in the Hiicallback.c

Function : SpecialActionCallBack

File: Hiicallback.c
Description:
Callback for UEFI Action control. This is used only in UEFI 2.1
Input:
CONTROL_INFO * ControlData, UINT16 Key
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


UEFICallSetupFormCallBack in the Hiicallback.c

Function : UEFICallSetupFormCallBack

File: Hiicallback.c
Description:
Wrapper function for the Implementation of FormBrowser with actions support .This is used only in UEFI 2.1
Input:
UINTN Action
Output:
VOID
Built on 16:20:17 10/01/14


UefiGetActionWapper in the Hiicallback.c

Function : UefiGetActionWapper

File: Hiicallback.c
Description:
The Wrapper function to get the actual action for the driver

Parameter:     UINTN Action

Return Value:  EFI_BROWSER_ACTION
Built on 16:20:17 10/01/14


UefiIsProceedWithPageChange in the Hiicallback.c

Function : UefiIsProceedWithPageChange

File: Hiicallback.c
Description:
If the FormCallBack returns status is EFI_UNSUPPORTED or EFI_SUCCESS.
            Change page is allowed. Otherwise changeing of page should not happen
            For UEFI 2.0 Just return EFI_SUCCESS;

Parameter:     EFI_STATUS

Return Value:  EFI_STATUS
Built on 16:20:17 10/01/14


UefiPreControlUpdate in the Hiicallback.c

Function : UefiPreControlUpdate

File: Hiicallback.c
Description:
store the Control value before updating and calling the callback.

Parameter:     CONTROL_INFO * ControlData

Return Value:  EFI_STATUS
Built on 16:20:17 10/01/14


HiiNotificationHandler.c

Description:
Contains Hii related Functions

The following functions are used in the file: HiiNotificationHandler.c.

Function | Description
AddNotificationToQueue | Adds new notification to the queue and increments queue size
CleanNotificationQueue | Cleans the IFR notification queue
IFRChangeNotifyFn | Function that handles IFR change notification Parameter: IN UINT8 PackageType, IN CONST EFI_GUID *PackageGuid, IN CONST EFI_HII_PACKAGE_HEADER *Package, IN EFI_HII_HANDLE Handle, IN EFI_HII_DATABASE_NOTIFY_TYPE NotifyType Return value: EFI_STATUS EFI_SUCCESS
ProcessPackNotification | Processes the IFR notification queue
RegisterFormNotification | Notification Registering Function Parameter: EFI_HII_DATABASE_NOTIFY PackageNotifyFn, EFI_HII_DATABASE_NOTIFY_TYPE NotifyType, EFI_HANDLE *NotifyHandle Return value: EFI_STATUS EFI_SUCCESS
RemoveDuplicateIFRNotification | Finds duplicate notification on the same handle and remove
RemoveFromQueueByEntry | Removes the notification entry from the queue, and returns the pointer to the next notification node
RemoveNotifFromQueueByHandleType | Removes the all the node with same notification handle and type except the passed the entry from the queue
UnRegisterFormNotification | Notification UnRegistering Function Parameter: EFI_HANDLE *NotifyHandle Return value: EFI_STATUS EFI_SUCCESS

Built on 16:20:20 10/01/14


AddNotificationToQueue in the HiiNotificationHandler.c

Function : AddNotificationToQueue

File: HiiNotificationHandler.c
Description:
Adds new notification to the queue and increments queue size
Input:
EFI_HII_HANDLE Handle, EFI_HII_DATABASE_NOTIFY_TYPE Type
Output:
EFI_STATUS status - EFI_ABORTED, By default
               EFI_OUT_OF_RESOURCES, if memory allocation fails
               EFI_SUCCESS, if successful
Built on 16:20:05 10/01/14


CleanNotificationQueue in the HiiNotificationHandler.c

Function : CleanNotificationQueue

File: HiiNotificationHandler.c
Description:
Cleans the IFR notification queue
Input:
None
Output:
EFI_STATUS status - EFI_SUCCESS, if successful
Built on 16:20:06 10/01/14


IFRChangeNotifyFn in the HiiNotificationHandler.c

Function : IFRChangeNotifyFn

File: HiiNotificationHandler.c
Description:
Function that handles IFR change notification

Parameter:     IN UINT8 PackageType,
 IN CONST EFI_GUID *PackageGuid,
 IN CONST EFI_HII_PACKAGE_HEADER *Package,
 IN EFI_HII_HANDLE Handle,
 IN EFI_HII_DATABASE_NOTIFY_TYPE NotifyType

Return value:  EFI_STATUS
                  EFI_SUCCESS
Built on 16:20:10 10/01/14


ProcessPackNotification in the HiiNotificationHandler.c

Function : ProcessPackNotification

File: HiiNotificationHandler.c
Description:
Processes the IFR notification queue
Input:
None
Output:
EFI_STATUS status - EFI_ABORTED, By default
               EFI_SUCCESS, if successful
               EFI_ERROR, otherwise
Built on 16:20:14 10/01/14


RegisterFormNotification in the HiiNotificationHandler.c

Function : RegisterFormNotification

File: HiiNotificationHandler.c
Description:
Notification Registering Function

Parameter:     EFI_HII_DATABASE_NOTIFY PackageNotifyFn,
 EFI_HII_DATABASE_NOTIFY_TYPE NotifyType,
 EFI_HANDLE *NotifyHandle

Return value:  EFI_STATUS
                  EFI_SUCCESS
Built on 16:20:14 10/01/14


RemoveDuplicateIFRNotification in the HiiNotificationHandler.c

Function : RemoveDuplicateIFRNotification

File: HiiNotificationHandler.c
Description:
Finds duplicate notification on the same handle and remove
Input:
None
Output:
EFI_STATUS status - EFI_ABORTED, By default ;
               EFI_INVALID_PARAMETER, if invalid gNotificationQueue
               EFI_SUCCESS, if successful
Built on 16:20:14 10/01/14


RemoveFromQueueByEntry in the HiiNotificationHandler.c

Function : RemoveFromQueueByEntry

File: HiiNotificationHandler.c
Description:
Removes the notification entry from the queue, and returns
the pointer to the next notification node
Input:
NOTIFICATION_INFO *matchingNotifInfo
Output:
VOID
Built on 16:20:14 10/01/14


RemoveNotifFromQueueByHandleType in the HiiNotificationHandler.c

Function : RemoveNotifFromQueueByHandleType

File: HiiNotificationHandler.c
Description:
Removes the all the node with same notification handle and
type except the passed the entry from the queue
Input:
EFI_HII_HANDLE Handle
EFI_HII_DATABASE_NOTIFY_TYPE Type
NOTIFICATION_INFO *matchingNotifInfo
Output:
EFI_STATUS status - EFI_ABORTED, By default ;
               EFI_INVALID_PARAMETER, if invalid gNotificationQueue
               EFI_SUCCESS, if successful
Built on 16:20:14 10/01/14


UnRegisterFormNotification in the HiiNotificationHandler.c

Function : UnRegisterFormNotification

File: HiiNotificationHandler.c
Description:
Notification UnRegistering Function

Parameter:     EFI_HANDLE *NotifyHandle

Return value:  EFI_STATUS
                  EFI_SUCCESS
Built on 16:20:18 10/01/14


hiistring.c

Description:
file contains code to handle the hii sting operations

The following functions are used in the file: hiistring.c.

Function | Description
EfiTestPrintLength | function to get the printable lenght of the string
HiiAddString | function to add a string
HiiFindStrPrintBoundary | function to Check the boundary of the print stirng. Find out the index of the character from where the print boundry will be met
IsCharWide | function to Check the given character is wide

Built on 16:20:20 10/01/14


EfiTestPrintLength in the hiistring.c

Function : EfiTestPrintLength

File: hiistring.c
Description:
function to get the printable lenght of the string
Input:
CHAR16 *string
Output:
Size of string
Built on 16:20:07 10/01/14


HiiAddString in the hiistring.c

Function : HiiAddString

File: hiistring.c
Description:
function to add a string
Input:
VOID* handle, CHAR16 *string
Output:
token
Built on 16:20:09 10/01/14


HiiFindStrPrintBoundary in the hiistring.c

Function : HiiFindStrPrintBoundary

File: hiistring.c
Description:
function to Check the boundary of the print stirng.
            Find out the index of the character from where the print boundry will be met
Input:
IN CHAR16   *String, IN UINTN PrintWidth
Output:
count
Built on 16:20:09 10/01/14


IsCharWide in the hiistring.c

Function : IsCharWide

File: hiistring.c
Description:
function to Check the given character is wide
Input:
CHAR16 strWide
Output:
TRUE/FALSE
Built on 16:20:10 10/01/14


hiistring.h

Description:
Header file for code to handle the hii sting operations
Built on 16:20:20 10/01/14


hiistring20.c

Description:
This file contains code to handle UEFI2.0 supported hii strings.

The following functions are used in the file: hiistring20.c.

Function | Description
CheckForDeviceNeedRepair | Repairs the driver for the input device path protocol
FindandSetHotKeys | Dummy function for FindandSetHotKeys function
FormHotBootKeys | Dummy function for FormHotBootKeys function
FreeExtraKeyMemories | Dummy function for FreeExtraKeyMemories function
GetDefaultPasswordFromTokens | Gets default password throug sdl tokens
LoadStrings | Function to load the strings from Hii.
ReadPlatformLang | Dummy function for PlatformLang function
RefreshBootKeysDetails | Dummy function for RefreshBootKeysDetails function
Uefi20HiiChangeStringLanguage | function to change the language string
Uefi20HiiGetStringLanguage | function to get the language string
Uefi20HiiInitializeProtocol | function to Initialize the Hii protocol

Built on 16:20:20 10/01/14


CheckForDeviceNeedRepair in the hiistring20.c

Function : CheckForDeviceNeedRepair

File: hiistring20.c
Description:
Repairs the driver for the input device path protocol
Input:
EFI_DEVICE_PATH_PROTOCOL * = Device path for the handle to which repair operation to be done
Output:
VOID
Built on 16:20:05 10/01/14


FindandSetHotKeys in the hiistring20.c

Function : FindandSetHotKeys

File: hiistring20.c
Description:
Dummy function for

 FindandSetHotKeys
 function
Input:
VOID
Output:
VOID
Built on 16:20:07 10/01/14


FormHotBootKeys in the hiistring20.c

Function : FormHotBootKeys

File: hiistring20.c
Description:
Dummy function for

 FormHotBootKeys
 function
Input:
VOID
Output:
VOID
Built on 16:20:07 10/01/14


FreeExtraKeyMemories in the hiistring20.c

Function : FreeExtraKeyMemories

File: hiistring20.c
Description:
Dummy function for

 FreeExtraKeyMemories
 function
Input:
VOID
Output:
VOID
Built on 16:20:07 10/01/14


GetDefaultPasswordFromTokens in the hiistring20.c

Function : GetDefaultPasswordFromTokens

File: hiistring20.c
Description:
Gets default password throug sdl tokens
Input:
UINT32 PasswordType
Output:
CHAR16 * Password
Built on 16:20:08 10/01/14


LoadStrings in the hiistring20.c

Function : LoadStrings

File: hiistring20.c
Description:
Function to load the strings from Hii.
Input:
EFI_HANDLE ImageHandle, VOID * *pHiiHandle
Output:
Status
Built on 16:20:11 10/01/14


ReadPlatformLang in the hiistring20.c

Function : ReadPlatformLang

File: hiistring20.c
Description:
Dummy function for PlatformLang function
Input:
UINTN *Size
Output:
NULL
Built on 16:20:14 10/01/14


RefreshBootKeysDetails in the hiistring20.c

Function : RefreshBootKeysDetails

File: hiistring20.c
Description:
Dummy function for

 RefreshBootKeysDetails
 function
Input:
VOID
Output:
VOID
Built on 16:20:14 10/01/14


Uefi20HiiChangeStringLanguage in the hiistring20.c

Function : Uefi20HiiChangeStringLanguage

File: hiistring20.c
Description:
function to change the language string
Input:
VOID* handle, UINT16 token, CHAR16 *lang, CHAR16 *string
Output:
token
Built on 16:20:17 10/01/14


Uefi20HiiGetStringLanguage in the hiistring20.c

Function : Uefi20HiiGetStringLanguage

File: hiistring20.c
Description:
function to get the language string
Input:
VOID* handle, UINT16 token, CHAR16 *lang
Output:
sting
Built on 16:20:17 10/01/14


Uefi20HiiInitializeProtocol in the hiistring20.c

Function : Uefi20HiiInitializeProtocol

File: hiistring20.c
Description:
function to Initialize the Hii protocol
Input:
void
Output:
status
Built on 16:20:17 10/01/14


hiistring21.c

Description:
This file contains code to handle UEFI2.1 supported hii strings.

The following functions are used in the file: hiistring21.c.

Function | Description
_GetSupportedLanguages | Parameter: Return value:
CheckForDeviceNeedRepair | Repairs the driver for the input device path protocol
CheckforHotKey | Checks for the key pressed by user matches the boot key options
EfiTestPrintLength | function to get the printable lenght of the string
FindandSetHotKeys | Function to form the hot keys from NVRAM
FindtheMatchUptoEndNode | Finds all agent handle which opens the input handle upto the last agent for the controller
FormHotBootKeys | Function to form the boot option hot keys
FreeExtraKeyMemories | Function to free the extra memories allocated
GetDefaultPasswordFromTokens | Gets default password throug sdl tokens
HiiInitializeProtocol | Parameter: Return value: EFI_STATUS EFI_SUCCESS
HiiString2BltBuffer | function to get the Blt for the message with the given attributes
MatchDPHandleWithDrvHlthHndls | Checks whether the input handle has the driver health support
ReadPlatformLang | Function to return the PlatformLang
RefreshBootKeysDetails | Clears the boot key gloabl details
Uefi21HiiGetStringLanguage | Returns the string for incoming token. If lang is valid then return string for this lang else return string for PlatformLang variable else return english string - default

Built on 16:20:20 10/01/14


_GetSupportedLanguages in the hiistring21.c

Function : _GetSupportedLanguages

File: hiistring21.c
Description:

Parameter:

Return value:
Built on 16:20:04 10/01/14


CheckForDeviceNeedRepair in the hiistring21.c

Function : CheckForDeviceNeedRepair

File: hiistring21.c
Description:
Repairs the driver for the input device path protocol
Input:
EFI_DEVICE_PATH_PROTOCOL * = Device path for the handle to which repair operation to be done
Output:
VOID
Built on 16:20:05 10/01/14


CheckforHotKey in the hiistring21.c

Function : CheckforHotKey

File: hiistring21.c
Description:
Checks for the key pressed by user matches the boot key options
Input:
AMI_EFI_KEY_DATA = Input key details pressed by user
UINT16 * = Boot index to return; Memory should be allocated by user
Output:
BOOLEAN TRUE = If boot option found for user pressed key
       FALSE = If boot index not found for user pressed key
Built on 16:20:05 10/01/14


EfiTestPrintLength in the hiistring21.c

Function : EfiTestPrintLength

File: hiistring21.c
Description:
function to get the printable lenght of the string
Input:
CHAR16 *string
Output:
Size of string
Built on 16:20:07 10/01/14


FindandSetHotKeys in the hiistring21.c

Function : FindandSetHotKeys

File: hiistring21.c
Description:
Function to form the hot keys from NVRAM
Input:
VOID
Output:
VOID
Built on 16:20:07 10/01/14


FindtheMatchUptoEndNode in the hiistring21.c

Function : FindtheMatchUptoEndNode

File: hiistring21.c
Description:
Finds all agent handle which opens the input handle upto the last agent for the controller
Input:
EFI_HANDLE = Handle to be examined
EFI_HANDLE = Handle to be matched
Output:
BOOLEAN => If handle matches return TRUE else FALSE
Built on 16:20:07 10/01/14


FormHotBootKeys in the hiistring21.c

Function : FormHotBootKeys

File: hiistring21.c
Description:
Function to form the boot option hot keys
Input:
CHAR16 * = Hot key name to retrieve the hot key details
Output:
VOID
Built on 16:20:07 10/01/14


FreeExtraKeyMemories in the hiistring21.c

Function : FreeExtraKeyMemories

File: hiistring21.c
Description:
Function to free the extra memories allocated
Input:
VOID
Output:
VOID
Built on 16:20:07 10/01/14


GetDefaultPasswordFromTokens in the hiistring21.c

Function : GetDefaultPasswordFromTokens

File: hiistring21.c
Description:
Gets default password throug sdl tokens
Input:
UINT32 PasswordType
Output:
CHAR16 * Password
Built on 16:20:08 10/01/14


HiiInitializeProtocol in the hiistring21.c

Function : HiiInitializeProtocol

File: hiistring21.c
Description:

Parameter:

Return value: EFI_STATUS
            EFI_SUCCESS
Built on 16:20:09 10/01/14


HiiString2BltBuffer in the hiistring21.c

Function : HiiString2BltBuffer

File: hiistring21.c
Description:
function to get the Blt for the message with the given attributes
Input:
CHAR16 *Message, EFI_UGA_PIXEL Foreground, EFI_UGA_PIXEL Background,
        OUT	UINTN *Width, OUT EFI_UGA_PIXEL **BltBuffer
Output:
Size of string
Built on 16:20:09 10/01/14


MatchDPHandleWithDrvHlthHndls in the hiistring21.c

Function : MatchDPHandleWithDrvHlthHndls

File: hiistring21.c
Description:
Checks whether the input handle has the driver health support
Input:
EFI_HANDLE = Handle to be examined
Output:
BOOLEAN => TRUE if input handle has the driver health support else FALSE
Built on 16:20:11 10/01/14


ReadPlatformLang in the hiistring21.c

Function : ReadPlatformLang

File: hiistring21.c
Description:
Function to return the PlatformLang
Input:
UINTN *Size
Output:
PlatformLang String
Built on 16:20:14 10/01/14


RefreshBootKeysDetails in the hiistring21.c

Function : RefreshBootKeysDetails

File: hiistring21.c
Description:
Clears the boot key gloabl details
Input:
VOID
Output:
VOID
Built on 16:20:14 10/01/14


Uefi21HiiGetStringLanguage in the hiistring21.c

Function : Uefi21HiiGetStringLanguage

File: hiistring21.c
Description:
Returns the string for incoming token.
                If lang is valid then return string for this lang
                else return string for PlatformLang variable
                else return english string - default
Input:
Handle, string token and lang code
Output:
Sting buffer
Built on 16:20:17 10/01/14


HookAnchor.c

Description:
file to handle the hook functions

The following functions are used in the file: HookAnchor.c.

Function | Description
GenericHook | Locates the hook based on hooknum and calls them If hook not found it calls the default function.
GenericHookType1 | Locates the hook based on hooknum and calls them If hook not found it calls the default function.
GenericHookType2 | Locates the hook based on hooknum and calls them If hook not found it calls the default function.
GenericHookType3 | Locates the hook based on hooknum and calls them If hook not found it calls the default function.
GenericHookType4 | Locates the hook based on hooknum and calls them If hook not found it calls the default function.
GenericHookType5 | Locates the hook based on hooknum and calls them If hook not found it calls the default function.
GenericHookType6 | Locates the hook based on hooknum and calls them If hook not found it calls the default function.
GenericHookType7 | Locates the hook based on hooknum and calls them If hook not found it calls the default function.
SearchHook | Finds the Firsthookfn and Lasthookfn of HookNum
SearchLastHook | Returns the lasthookfn number

Built on 16:20:20 10/01/14


GenericHook in the HookAnchor.c

Function : GenericHook

File: HookAnchor.c
Description:
Locates the hook based on hooknum and calls them
        If hook not found it calls the default function.
Input:
HookNum , default function.
Output:
none
Built on 16:20:08 10/01/14


GenericHookType1 in the HookAnchor.c

Function : GenericHookType1

File: HookAnchor.c
Description:
Locates the hook based on hooknum and calls them
        If hook not found it calls the default function.
Input:
HookNum , default function.
Output:
Boolean
Built on 16:20:08 10/01/14


GenericHookType2 in the HookAnchor.c

Function : GenericHookType2

File: HookAnchor.c
Description:
Locates the hook based on hooknum and calls them
        If hook not found it calls the default function.
Input:
HookNum , default function and Key.
Output:
CONTROL_ACTION
Built on 16:20:08 10/01/14


GenericHookType3 in the HookAnchor.c

Function : GenericHookType3

File: HookAnchor.c
Description:
Locates the hook based on hooknum and calls them
        If hook not found it calls the default function.
Input:
HookNum , default function, Event and Context.
Output:
none
Built on 16:20:08 10/01/14


GenericHookType4 in the HookAnchor.c

Function : GenericHookType4

File: HookAnchor.c
Description:
Locates the hook based on hooknum and calls them
        If hook not found it calls the default function.
Input:
HookNum , default function, Event and Context.
Output:
none
Built on 16:20:08 10/01/14


GenericHookType5 in the HookAnchor.c

Function : GenericHookType5

File: HookAnchor.c
Description:
Locates the hook based on hooknum and calls them
        If hook not found it calls the default function.
Input:
HookNum , default function, Password and MaxSize.
Output:
none
Built on 16:20:08 10/01/14


GenericHookType6 in the HookAnchor.c

Function : GenericHookType6

File: HookAnchor.c
Description:
Locates the hook based on hooknum and calls them
        If hook not found it calls the default function.
Input:
HookNum , default function and Variable pointers to hold colors.
Output:
none
Built on 16:20:08 10/01/14


GenericHookType7 in the HookAnchor.c

Function : GenericHookType7

File: HookAnchor.c
Description:
Locates the hook based on hooknum and calls them
        If hook not found it calls the default function.
Input:
HookNum , default function and Key.
Output:
CONTROL_ACTION
Built on 16:20:08 10/01/14


SearchHook in the HookAnchor.c

Function : SearchHook

File: HookAnchor.c
Description:
Finds the Firsthookfn and Lasthookfn of HookNum
Input:
HookNum
Output:
firsthookfn , lastHookfn
        returns zero if hook not found. Non Zero on success.
Built on 16:20:14 10/01/14


SearchLastHook in the HookAnchor.c

Function : SearchLastHook

File: HookAnchor.c
Description:
Returns the lasthookfn number
Input:
firsthookfn
Output:
lastHookfn
Built on 16:20:14 10/01/14


hotclick.c

Description:
This file contains code to handle hotclick operations

The following functions are used in the file: hotclick.c.

Function | Description
HotClickCreate | Function create a HotClick, which uses the Object functions.
HotClickDestroy | Function destroy a HotClick, which uses the Object functions.
HotClickHandleAction | Function to handle the HotClick actions.
HotClickInitialize | Function Initialize a Hotclick, which uses the Object functions.
HotClickSetCallback | Function to set callback.

Built on 16:20:20 10/01/14


HotClickCreate in the hotclick.c

Function : HotClickCreate

File: hotclick.c
Description:
Function create a HotClick, which uses the Object functions.
Input:
HOTCLICK_DATA **object
Output:
status
Built on 16:20:09 10/01/14


HotClickDestroy in the hotclick.c

Function : HotClickDestroy

File: hotclick.c
Description:
Function destroy a HotClick, which uses the Object functions.
Input:
HOTCLICK_DATA *hotkey, BOOLEAN freeMem
Output:
status
Built on 16:20:09 10/01/14


HotClickHandleAction in the hotclick.c

Function : HotClickHandleAction

File: hotclick.c
Description:
Function to handle the HotClick actions.
Input:
HOTCLICK_DATA *hotkey, ACTION_DATA *action
Output:
status
Built on 16:20:09 10/01/14


HotClickInitialize in the hotclick.c

Function : HotClickInitialize

File: hotclick.c
Description:
Function Initialize a Hotclick, which uses the Object functions.
Input:
HOTCLICK_DATA *hotkey, VOID *data
Output:
status
Built on 16:20:09 10/01/14


HotClickSetCallback in the hotclick.c

Function : HotClickSetCallback

File: hotclick.c
Description:
Function to set callback.
Input:
HOTCLICK_DATA *hotkey, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
STATUS
Built on 16:20:09 10/01/14


hotclick.h

Description:
Header file for hotclick code to handling
Built on 16:20:20 10/01/14


hotkey.c

Description:
This file contains code to handle hotkey operations

The following functions are used in the file: hotkey.c.

Function | Description
HotKeyCreate | Function create a Hotkey, which uses the Object functions.
HotKeyDestroy | Function destroy a Hotkey, which uses the Object functions.
HotKeyHandleAction | Function to handle the HotKey actions.
HotKeyInitialize | Function Initialize a Hotkey, which uses the Object functions.
HotKeySetCallback | Function to set callback.

Built on 16:20:20 10/01/14


HotKeyCreate in the hotkey.c

Function : HotKeyCreate

File: hotkey.c
Description:
Function create a Hotkey, which uses the Object functions.
Input:
HOTKEY_DATA **object
Output:
status
Built on 16:20:09 10/01/14


HotKeyDestroy in the hotkey.c

Function : HotKeyDestroy

File: hotkey.c
Description:
Function destroy a Hotkey, which uses the Object functions.
Input:
HOTKEY_DATA *hotkey, BOOLEAN freeMem
Output:
status
Built on 16:20:09 10/01/14


HotKeyHandleAction in the hotkey.c

Function : HotKeyHandleAction

File: hotkey.c
Description:
Function to handle the HotKey actions.
Input:
HOTKEY_DATA *hotkey, ACTION_DATA *action
Output:
status
Built on 16:20:09 10/01/14


HotKeyInitialize in the hotkey.c

Function : HotKeyInitialize

File: hotkey.c
Description:
Function Initialize a Hotkey, which uses the Object functions.
Input:
HOTKEY_DATA *hotkey, VOID *data
Output:
status
Built on 16:20:09 10/01/14


HotKeySetCallback in the hotkey.c

Function : HotKeySetCallback

File: hotkey.c
Description:
Function to set callback.
Input:
HOTKEY_DATA *hotkey, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
STATUS
Built on 16:20:09 10/01/14


hotkey.h

Description:
Header file for hotkey code to handling
Built on 16:20:20 10/01/14


iJpeg.c

Description:
Adds jpeg Support.

The following functions are used in the file: iJpeg.c.

Function | Description
ConvertJPEGToUgaBlt | Decode the JPEG and store the Output in UGA format. The JPEG images are stored in 16X16 blocks. Hence Buffer will require width and hieght that are equal to or more than the actual width and hieght. Buffer Width and Height will be the lowest multipe of 16 that is equal to or greater than the actual width and height. Eg: For decoding an image with Actual sizes being 17X33 will require a buffer of 32X48.

Built on 16:20:20 10/01/14


ConvertJPEGToUgaBlt in the iJpeg.c

Function : ConvertJPEGToUgaBlt

File: iJpeg.c
Description:
Decode the JPEG and store the Output in UGA format. The
            JPEG images are stored in 16X16 blocks. Hence Buffer will
            require width and hieght that are equal to or more than
            the actual width and hieght. Buffer Width and Height will
            be the lowest multipe of 16 that is equal to or greater than
            the actual width and height.
            Eg: For decoding an image with Actual sizes being 17X33 will
                require a buffer of 32X48.
Input:
IN VOID *JPEGImage - Pointer to the memory that has the
                                 JPEG Image that need to be decoded.
            IN UINT32 JPEGImageSize - Size of the JPEG Image
            IN OUT VOID **UgaBlt - Two cases
                Case 1: Memory is expected to be allocated by the callee.
                        Address provided as input should be NULL.
                        pointer that will recieve the address of the UGA buffer.
                        The buffer is allocated by callee.
                        This buffer need to be freed by the caller.
                Case 2: Memory is allocated by the caller
            IN OUT UINT32 *UgaBltSize - Pointer that stores Size of UgaBlt
                in bytes. This will be treated as an input. This should have
                value ZERO for Case 2 above.
            OUT UINT32 *PixelHeight - Height of UgaBlt/JPEG Image in pixels
            OUT UINT32 *PixelWidth - Width of UgaBlt/JPEG Image in pixels
            OUT UINT32 *pun32BufferWidth - Width of UgaBlt/JPEG Buffer
Output:
EFI_SUCCESS	- The image was successfully decoded and placed in the buffer
            EFI_UNSUPPORTED
            EFI_BUFFER_TOO_SMALL
            EFI_OUT_OF_RESOURCES
Built on 16:20:06 10/01/14


ipcx.c

Description:
This file contains code related to pcx image handling

The following functions are used in the file: ipcx.c.

Function | Description
ConvertPCXToUgaBlt | Decode the PCX Image and store the Output in UGA Format

Built on 16:20:20 10/01/14


ConvertPCXToUgaBlt in the ipcx.c

Function : ConvertPCXToUgaBlt

File: ipcx.c
Description:
Decode the PCX Image and store the Output in UGA Format
Input:
VOID *PCXImage - Pointer to the memory that has the PCX
                Image that need to be decoded.
            UINT32 PCXImageSize - Size of the PCX Image
            OUT VOID **UgaBlt - Two cases
                Case 1: Memory is expected to be allocated by the callee.
                    Address provided as input should be NULL.
                    pointer that will receive the address of the UGA buffer.
                    The buffer is allocated by callee.
                    This buffer need to be freed by the caller.
                Case 2: Memory is allocated by the caller
            OUT UINT32 *UgaBltSize - Pointer that stores Size of UgaBlt in bytes.
                This will be treated as an input. This should have value ZERO for Case 2 above.
            UINT32 *PixelHeight - Height of UgaBlt/PCX Image in pixels
            UINT32 *PixelWidth - Width of UgaBlt/PCX Image in pixels
Output:
EFI_STATUS
Built on 16:20:06 10/01/14


jpeg.h

Description:
Header file for jpeg image format related code
Built on 16:20:20 10/01/14


jpeg6.c

Description:
Support for JPEG decoding

The following functions are used in the file: jpeg6.c.

Function | Description
BuildHuffmanCodeTable | Builds the Huffman codes for the particular JPEG Huffman table. By incrementing the offset of the Huffman table by 3, the offset of the actual data is obtained. The first 16 bytes represent the no: of code words for a paricular bit-size. Having the bit-size and the no: of code words for each bit-size, the Huffman code table is built.
Check | Internal function for doing a Check for each color component
ConvertYCbCrToRGB | Converts the luminance(Y) and chrominance(Cb and Cr) values of the image to R, G, B values. The R,G, B values are stored in a DWORD variable.
DecodeJPEG | Decode the JPEG image into the given buffer at given position, subject to the limit of the Buffer Width and Height
GetDCValue | This routine returns the differences(DCCoefficientpresent - DCCoefficientprev) for the DC coefficient. For AC coefficients, it returns the actual AC coefficient value and Run/Size.
GetEncodedBit | Reads bits from the stream and returns whether the carry flag is set or not.
GetJPEGDimensions | Get the dimensions (Width and Height) for the JPEG image
GetTables | Gets the 2 Quantization Tables and 4 Huffman Tables. Checks the type of table and then builds the corresponding table.
HuffmanDecoding | This routine decodes the AC and DC coefficients using the Huffman tables stored in the JPEG image.
InitGlobals | Initializes required global variables
InitJpegParams | Reads the image parameters and checks whether the image is supported or not. TSE Jpeg Algorithm Supports following Markers ================================================== 0C0h - Start Of Frame (Baseline DCT) (REQUIRED) 0C4h - Define Huffman Table (REQUIRED) 0D0h - RSI0 Marker (OPTIONAL) 0D1h - RSI1 Marker (OPTIONAL) 0D2h - RSI2 Marker (OPTIONAL) 0D3h - RSI3 Marker (OPTIONAL) 0D4h - RSI4 Marker (OPTIONAL) 0D5h - RSI5 Marker (OPTIONAL) 0D6h - RSI6 Marker (OPTIONAL) 0D7h - RSI7 Marker (OPTIONAL) 0D8h - Start of Image (REQUIRED) 0D9h - End of Image (REQUIRED) 0DAh - Start Of Scan (REQUIRED) 0DBh - Define Quantization Table (REQUIRED) 0DDh - Define Restart Interval (OPTIONAL) 0E0h - 0xEF - APPx Markers (Does Depend on and just Skips marker) (DON'T CARE) 0F0h - 0xFD - Reserved for JPEG extensions (Does Depend on and just Skips marker) (DON'T CARE) 0FEh - Jpeg Comment (Does Depend on and just Skips marker) (DON'T CARE) TSE Jpeg Algorithom Does not Support following Markers ====================================================== 000h-0BFh - RESERVED 0C1h - Start Of Frame (Extended sequential DCT) 0C2h - Start Of Frame (Progressive DCT) 0C3h - Start Of Frame (Lossless (sequential)) 0C5h - Start Of Frame (Differential sequential DCT) 0C6h - Start Of Frame (Differential progressive DCT) 0C7h - Start Of Frame (Differential lossless (sequential)) 0C8h - Start Of Frame (Reserved for JPEG extensions) 0C9h - Start Of Frame (Extended sequential DCT) 0CAh - Start Of Frame (Progressive DCT) 0CBh - Start Of Frame (Lossless (sequential)) 0CDh - Start Of Frame (Differential sequential DCT) 0CEh - Start Of Frame (Differential progressive DCT) 0CFh - Start Of Frame (Differential lossless (sequential)) 0CCh - Arithmetic coding conditioning 0DCh - Define number of lines 0DEh - Define hierarchical progression 0DFh - Expand reference component(s) 0FFh - RESERVED
InvertDCT | Performs inverse discrete cosine transform on dequantized data.
InvertDCT_xy | Performs inverse discrete cosine transform on dequantized data in x and y direction.
Output8x8Image | This functions writes to the Global Screen Buffer.
OutputJPEGImage_YUV | This functions writes to the Global Screen Buffer by calling Output8x8Image function.
ReadJPEGImage | Reads the 8x8 matrix data for each of Y_0,Y_1,Y_2,Y_3,Cb and Cr. The final Output will be image data after inverse DCT is applied.
ReadJPEGImage_YUV | Reads the 8x8 matrix data for each of Y_0,Y_1,Y_2,Y_3,Cb and Cr. The final Output will be RGB pixel data.
SearchHuffmanCode | Searches the Huffman code of the DC/AC Luminance/Chrominace values in Huffman code tables and find the appropriate HuffmanCodeValue.

Built on 16:20:20 10/01/14


BuildHuffmanCodeTable in the jpeg6.c

Function : BuildHuffmanCodeTable

File: jpeg6.c
Description:
Builds the Huffman codes for the particular JPEG Huffman table.
            By incrementing the offset of the Huffman table by 3,
            the offset of the actual data is obtained. The first
            16 bytes represent the no: of code words for a paricular
            bit-size. Having the bit-size and the no: of code words
            for each bit-size, the Huffman code table is built.
Input:
WORD * pwHuffCodeTable - Pointer to the memory location
                    that contains the Huffman codes for the particular JPEG Huffman table.
            BYTE * pbySrcHT - Pointer to the memory location that contains
                    the offset of the JPEG Huffman Table.
Output:
None
Built on 16:20:05 10/01/14


Check in the jpeg6.c

Function : Check

File: jpeg6.c
Description:
Internal function for doing a Check for each color component
Input:
INT32 n32ColorComp - Color Component (R, G or B).
Output:
The color component value after the Check.
Built on 16:20:05 10/01/14


ConvertYCbCrToRGB in the jpeg6.c

Function : ConvertYCbCrToRGB

File: jpeg6.c
Description:
Converts the luminance(Y) and chrominance(Cb and Cr) values
            of the image to R, G, B values.	The R,G, B values are stored
            in a DWORD variable.
Input:
short Y - Y is the luminance value.
            short Cb - Cb is the chrominance Hue value.
            short Cr - Cr is the chrominance Saturation value.
Output:
Variable having the RGB value, which is a DWORD.
Built on 16:20:06 10/01/14


DecodeJPEG in the jpeg6.c

Function : DecodeJPEG

File: jpeg6.c
Description:
Decode the JPEG image into the given buffer at given position,
            subject to the limit of the Buffer Width and Height
Input:
WORD wXPos - X Start Postion with in the Buffer
                            where the image need to be decoded
            WORD wYPos - Y Start Postion with in the Buffer
                            where the image need to be decoded
            BYTE * pbyJPEGInputData - Pointer that gives the memory location
                                      where the Input data is available
            BYTE * pbyJPEGOutputData - Pointer that gives the pointer
                                       for the Output buffer
            UINT32 un32BufferWidth - Width of the Output Buffer
            UINT32 un32BufferHeight	- Height of the Output Buffer
Output:
BOOL - TRUE/FALSE Indicate whether the Decoding was successful
Built on 16:20:06 10/01/14


GetDCValue in the jpeg6.c

Function : GetDCValue

File: jpeg6.c
Description:
This routine returns the differences(DCCoefficientpresent -
            DCCoefficientprev) for the DC coefficient. For AC coefficients,
            it returns the actual AC coefficient value and Run/Size.
Input:
WORD * pwHuffmanTable - Pointer to the huffman table ?DC Luminance,
                DC Chrominance, AC Luminance, AC Chrominance.
            WORD * pwValue - Code Word (Actual Bit representation).
            WORD * pwLengthDC_RunSizeAC - Indicates the no: of zeroes.
Output:
None
Built on 16:20:08 10/01/14


GetEncodedBit in the jpeg6.c

Function : GetEncodedBit

File: jpeg6.c
Description:
Reads bits from the stream and returns whether the carry
            flag is set or not.
Input:
None
Output:
BOOL - TRUE/FALSE depending on whether the Carry flag is set or not.
Built on 16:20:08 10/01/14


GetJPEGDimensions in the jpeg6.c

Function : GetJPEGDimensions

File: jpeg6.c
Description:
Get the dimensions (Width and Height) for the JPEG image
Input:
BYTE * pbyJPEGInputData - Pointer that gives the memory
                            location where the Input data is available
            UINT32 * pun32Width - Pointer to the UINT32 variable that
                            will recieve the Width of the Image
            UINT32 * pun32Height - Pointer to the UINT32 variable that
                            will recieve the Height of the Image
Output:
BOOL - TRUE/FALSE.
Built on 16:20:08 10/01/14


GetTables in the jpeg6.c

Function : GetTables

File: jpeg6.c
Description:
Gets the 2 Quantization Tables and 4 Huffman Tables.
            Checks the type of table and then builds the corresponding table.
Input:
BYTE bNumQT - Number of Quantization Tables.
            BYTE bNumHT - Number of Huffman Tables.
Output:
None
Built on 16:20:08 10/01/14


HuffmanDecoding in the jpeg6.c

Function : HuffmanDecoding

File: jpeg6.c
Description:
This routine decodes the AC and DC coefficients using the
            Huffman tables stored in the JPEG image.
Input:
WORD * pwDCCoeffTable - DC Luminance/ Chrominance Huffman Table.
            WORD * pwACCoeffTable - AC Luminance/ Chrominance Huffman Table.
            WORD * pwImage -Pointer to the memory location that contains the decoded data.
Output:
None
Built on 16:20:09 10/01/14


InitGlobals in the jpeg6.c

Function : InitGlobals

File: jpeg6.c
Description:
Initializes required global variables
Input:
None
Output:
None
Built on 16:20:10 10/01/14


InitJpegParams in the jpeg6.c

Function : InitJpegParams

File: jpeg6.c
Description:
Reads the image parameters and checks whether the image
        is supported or not.
TSE Jpeg Algorithm Supports following Markers
==================================================
0C0h - Start Of Frame (Baseline DCT) (REQUIRED)
0C4h - Define Huffman Table (REQUIRED)
0D0h - RSI0 Marker (OPTIONAL)
0D1h - RSI1 Marker (OPTIONAL)
0D2h - RSI2 Marker (OPTIONAL)
0D3h - RSI3 Marker (OPTIONAL)
0D4h - RSI4 Marker (OPTIONAL)
0D5h - RSI5 Marker (OPTIONAL)
0D6h - RSI6 Marker (OPTIONAL)
0D7h - RSI7 Marker (OPTIONAL)
0D8h - Start of Image (REQUIRED)
0D9h - End of Image (REQUIRED)
0DAh - Start Of Scan (REQUIRED)
0DBh - Define Quantization Table (REQUIRED)
0DDh - Define Restart Interval (OPTIONAL)
0E0h - 0xEF - APPx Markers (Does Depend on and just Skips marker) (DON'T CARE)
0F0h - 0xFD - Reserved for JPEG extensions (Does Depend on and just Skips marker) (DON'T CARE)
0FEh - Jpeg Comment (Does Depend on and just Skips marker) (DON'T CARE)

TSE Jpeg Algorithom Does not Support following Markers
======================================================
000h-0BFh - RESERVED
0C1h - Start Of Frame (Extended sequential DCT)
0C2h - Start Of Frame (Progressive DCT)
0C3h - Start Of Frame (Lossless (sequential))
0C5h - Start Of Frame (Differential sequential DCT)
0C6h - Start Of Frame (Differential progressive DCT)
0C7h - Start Of Frame (Differential lossless (sequential))
0C8h - Start Of Frame (Reserved for JPEG extensions)
0C9h - Start Of Frame (Extended sequential DCT)
0CAh - Start Of Frame (Progressive DCT)
0CBh - Start Of Frame (Lossless (sequential))
0CDh - Start Of Frame (Differential sequential DCT)
0CEh - Start Of Frame (Differential progressive DCT)
0CFh - Start Of Frame (Differential lossless (sequential))
0CCh - Arithmetic coding conditioning
0DCh - Define number of lines
0DEh - Define hierarchical progression
0DFh - Expand reference component(s)
0FFh - RESERVED
Input:
BYTE * pbyImage - Pointer to the JPEG image.
Output:
BOOL TRUE/FALSE.
Built on 16:20:10 10/01/14


InvertDCT in the jpeg6.c

Function : InvertDCT

File: jpeg6.c
Description:
Performs inverse discrete cosine transform on dequantized data.
Input:
WORD * pwSource - Input is dequantized array of 8x8 pixels and
                Output is data after  applying inverse discrete cosine transform.
Output:
None
Built on 16:20:10 10/01/14


InvertDCT_xy in the jpeg6.c

Function : InvertDCT_xy

File: jpeg6.c
Description:
Performs inverse discrete cosine transform on dequantized
            data in x and y direction.
Input:
WORD * pwSource - Input is dequantized array of 8x8 pixels
                and Output is data after applying inverse discrete cosine transform.
            WORD wVal -
                wVal = 1, then the routine performs inverse discrete
                    cosine transform on dequantized data in x direction.
                wVal = 8, then the routine performs inverse discrete cosine
                    transform on dequantized data in y direction.
Output:
None
Built on 16:20:10 10/01/14


Output8x8Image in the jpeg6.c

Function : Output8x8Image

File: jpeg6.c
Description:
This functions writes to the Global Screen Buffer.
Input:
WORD wLeft - Left coordinate from where the Screen buffer
                is to be filled.
            WORD wTop - Top coordinate from where the Screen buffer is to be filled.
            BYTE * pspace_image - Pointer to 8x8 block of image.
Output:
None
Built on 16:20:12 10/01/14


OutputJPEGImage_YUV in the jpeg6.c

Function : OutputJPEGImage_YUV

File: jpeg6.c
Description:
This functions writes to the Global Screen Buffer by calling
            Output8x8Image function.
Input:
WORD wX_position - X Start Position within the Output buffer
                from where the image needs to be decoded.
            WORD wY_position - Y Start Position within the Output buffer
                from where the image needs to be decoded.
            WORD wX_length - Width of the image.
            WORD wY_length - Height of the image.
            WORD wSampling - Value tells whether image is YUV111(luminance
                as well as chrominance is taken for every pixel) or YUV122
                (luminance is taken for every pixel while chrominance is
                taken as medium value for 2x2 block of pixels).
Output:
None
Built on 16:20:12 10/01/14


ReadJPEGImage in the jpeg6.c

Function : ReadJPEGImage

File: jpeg6.c
Description:
Reads the 8x8 matrix data for each of Y_0,Y_1,Y_2,Y_3,Cb and Cr.
            The final Output will be image data after inverse DCT is applied.
Input:
WORD * pwDCCoeffTable - DC Luminance/ Chrominance Huffman Table.
            WORD * pwACCoeffTable - AC Luminance/ Chrominance Huffman Table.
            WORD * pwImage - Pointer to the 8x8 matrix data for each of Y_0,Y_1,Y_2,Y_3,Cb and Cr.
            WORD * pwDiff  - Pointer to the variable that hold the differences of the DC coefficients.
                Adds the difference to the Prev Dc coefficient value to get the present DC coefficient value.
            BYTE * pbySrcQT - Pointer to the Quantization table.
            int nLumFlag - Flag if it is set, indicates that the image component is luminance.
Output:
None
Built on 16:20:14 10/01/14


ReadJPEGImage_YUV in the jpeg6.c

Function : ReadJPEGImage_YUV

File: jpeg6.c
Description:
Reads the 8x8 matrix data for each of Y_0,Y_1,Y_2,Y_3,Cb and Cr.
            The final Output will be RGB pixel data.
Input:
DWORD * pdwBuffer - RGB format of image data.
            WORD wSampling - Value tells whether image is YUV111(luminance
                as well as chrominance is taken for every pixel) or
                YUV122(luminance is taken for every pixel while chrominance
                is taken as medium value for 2x2 block of pixels).
                Since the sampling factor for Luminance is 2, all the pixel
                values are stored, where as for Cb and Cr, only the average
                of 2x2 pixels is stored.
Output:
None
Built on 16:20:14 10/01/14


SearchHuffmanCode in the jpeg6.c

Function : SearchHuffmanCode

File: jpeg6.c
Description:
Searches the Huffman code of the DC/AC Luminance/Chrominace
            values in Huffman code tables and find the appropriate HuffmanCodeValue.
Input:
WORD * pwSearchTablePos - Pointer to the huffman table ?DC Luminance,
                DC Chrominance, AC Luminance, AC Chrominance.
            WORD * pwHuffmanCodeValue - Pointer to the variable that contains
                the Huffman code value.
            WORD wDc_value_length - No: of bits in the Huffman code.
Output:
BOOL - TRUE/FALSE.
Built on 16:20:14 10/01/14


Jpeg6.h

Description:
Header file for jpeg6 image format related code
Built on 16:20:20 10/01/14


Label.c

Description:
This file contains code to handle Label operations

The following functions are used in the file: Label.c.

Function | Description
LabelCreate | Function to create a Label, which uses the Control functions.
LabelDestroy | Function to destroy a Label, which uses the Control functions.
LabelDraw | Function to draw a Label.
LabelGetLabelHeight | Function to get label height.
LabelHandleAction | Function to handle the Label actions.
LabelInitialize | Function to Initialize a Label, which uses the Control functions.
LabelSetAttributes | Function to set attributes.
LabelSetCallback | Function to set callback.
LabelSetDimensions | Function to set dimension.
LabelSetFocus | Function to set the Label focus.
LabelSetPosition | Function to set position.

Built on 16:20:20 10/01/14


LabelCreate in the Label.c

Function : LabelCreate

File: Label.c
Description:
Function to create a Label, which uses the Control functions.
Input:
LABEL_DATA **object
Output:
status
Built on 16:20:10 10/01/14


LabelDestroy in the Label.c

Function : LabelDestroy

File: Label.c
Description:
Function to destroy a Label, which uses the Control functions.
Input:
LABEL_DATA *label, BOOLEAN freeMem
Output:
status
Built on 16:20:10 10/01/14


LabelDraw in the Label.c

Function : LabelDraw

File: Label.c
Description:
Function to draw a Label.
Input:
LABEL_DATA *label
Output:
status
Built on 16:20:10 10/01/14


LabelGetLabelHeight in the Label.c

Function : LabelGetLabelHeight

File: Label.c
Description:
Function to get label height.
Input:
LABEL_DATA *label, UINT16 Width, UINT16 *height
Output:
STATUS
Built on 16:20:10 10/01/14


LabelHandleAction in the Label.c

Function : LabelHandleAction

File: Label.c
Description:
Function to handle the Label actions.
Input:
LABEL_DATA *label, ACTION_DATA *Data
Output:
status
Built on 16:20:10 10/01/14


LabelInitialize in the Label.c

Function : LabelInitialize

File: Label.c
Description:
Function to Initialize a Label, which uses the Control functions.
Input:
LABEL_DATA *label, VOID *data
Output:
status
Built on 16:20:10 10/01/14


LabelSetAttributes in the Label.c

Function : LabelSetAttributes

File: Label.c
Description:
Function to set attributes.
Input:
LABEL_DATA *label, UINT8 FGColor, UINT8 BGColor
Output:
STATUS
Built on 16:20:10 10/01/14


LabelSetCallback in the Label.c

Function : LabelSetCallback

File: Label.c
Description:
Function to set callback.
Input:
LABEL_DATA *label, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
STATUS
Built on 16:20:10 10/01/14


LabelSetDimensions in the Label.c

Function : LabelSetDimensions

File: Label.c
Description:
Function to set dimension.
Input:
LABEL_DATA *label, UINT16 Width, UINT16 Height
Output:
STATUS
Built on 16:20:10 10/01/14


LabelSetFocus in the Label.c

Function : LabelSetFocus

File: Label.c
Description:
Function to set the Label focus.
Input:
LABEL_DATA *label, BOOLEAN focus
Output:
status
Built on 16:20:10 10/01/14


LabelSetPosition in the Label.c

Function : LabelSetPosition

File: Label.c
Description:
Function to set position.
Input:
LABEL_DATA *label, UINT16 Left, UINT16 Top
Output:
STATUS
Built on 16:20:10 10/01/14


Label.h

Description:
Header file for Label controls.
Built on 16:20:20 10/01/14


legacy.c

Description:
Main file for alternate1 style module.

The following functions are used in the file: legacy.c.

Function | Description
HandleEscKey | Function to handle ESC Hotkey action
HandleFailsafeKey | Function to handle Load Failsafe values Hotkey action
HandleHelpKey | Function to handle Help Hotkey action
HandleOptimalKey | Function to handle Load Optimal values Hotkey action
HandlePrevValuesKey | Function to handle Load Previous value Hotkey action
HandlePrnScrnKey | Function to handle print screen Hotkey action
HandleSaveExitKey | Function to handle Save and Exit Hotkey action
LegacyFrameAddControl | Adds controls to the frame
LegacyFrameDraw | Draws the controls for the given frame
LegacyFrameDrawScrollBar | Draws the scrollbar controls for the frame..
LegacyHelpFrameHandlewithMouse | Function to handle Help Frame with Mouse
LegacyMainFrameHandlewithMouse | Function to handle Main Frame with Mouse
LegacyMsgBoxInitialize | Function to Initialize Message Box, which uses the Popup functions.
LegacyNavFrameHandlewithMouse | Function to handle Navigation Frame with Mouse
LegacyPageHandleAction | function to handle the page actions
LegacySubMenuDraw | function to draw a sub-menu.
LegacySubMenuInitialize | this function uses the Initialize function of control and initializes the submenu.
OverRideComponent | Function to override component or control functionality
OverRideStyleDrawPageBorder | Function to draw page border
OverRideStyleGetFrameInitData | Function to get frame initialization data
OverRideStyleInit | Function to Initialize style
StyleFrameAddTitle | Function to add frame title
StyleFrameIndexOf | Function to get frame index
StyleGetPageFrames | Function to number of frames

Built on 16:20:20 10/01/14


HandleEscKey in the legacy.c

Function : HandleEscKey

File: legacy.c
Description:
Function to handle ESC Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:08 10/01/14


HandleFailsafeKey in the legacy.c

Function : HandleFailsafeKey

File: legacy.c
Description:
Function to handle Load Failsafe values Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:09 10/01/14


HandleHelpKey in the legacy.c

Function : HandleHelpKey

File: legacy.c
Description:
Function to handle Help Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:09 10/01/14


HandleOptimalKey in the legacy.c

Function : HandleOptimalKey

File: legacy.c
Description:
Function to handle Load Optimal values Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:09 10/01/14


HandlePrevValuesKey in the legacy.c

Function : HandlePrevValuesKey

File: legacy.c
Description:
Function to handle Load Previous value Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:09 10/01/14


HandlePrnScrnKey in the legacy.c

Function : HandlePrnScrnKey

File: legacy.c
Description:
Function to handle print screen Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:09 10/01/14


HandleSaveExitKey in the legacy.c

Function : HandleSaveExitKey

File: legacy.c
Description:
Function to handle Save and Exit Hotkey action
Input:
APPLICATION_DATA *app, HOTKEY_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:09 10/01/14


LegacyFrameAddControl in the legacy.c

Function : LegacyFrameAddControl

File: legacy.c
Description:
Adds controls to the frame
Input:
FRAME_DATA *frame - Pointer to the frame data
        CONTROL_INFO *controlData - Control date to be added
Output:
EFI_STATUS Status - EFI_SUCCESS if successful, else
                                EFI_UNSUPPORTED
Built on 16:20:10 10/01/14


LegacyFrameDraw in the legacy.c

Function : LegacyFrameDraw

File: legacy.c
Description:
Draws the controls for the given frame
Input:
FRAME_DATA *frame - Frame information to draw controls
Output:
EFI_STATUS - EFI_SUCCESS if successful, else EFI_ERROR
Built on 16:20:10 10/01/14


LegacyFrameDrawScrollBar in the legacy.c

Function : LegacyFrameDrawScrollBar

File: legacy.c
Description:
Draws the scrollbar controls for the frame..
Input:
FRAME_DATA *frame	- Pointer to the current frame
        UINT32	FirstLine	- FirstLine of the scrollbar
        UINT32 LastLine		- LastLine
        UINT32	modVal		- modVal
        UINT32	sizeOfBar	- Size of the Scrollbar
        UINT32 numOfBlocks	- Number of blocks
        BOOLEAN bEraseScrollBar	- flag to erase the scrollbar
Output:
EFI_STATUS status -
            EFI_SUCCESS - If there exists a next page and the
                           function successfully loads it
            EFI_OUT_PF_RESOURCES - If there are know previous page
Built on 16:20:10 10/01/14


LegacyHelpFrameHandlewithMouse in the legacy.c

Function : LegacyHelpFrameHandlewithMouse

File: legacy.c
Description:
Function to handle Help Frame with Mouse
Input:
APPLICATION_DATA *app, HOTCLICK_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:10 10/01/14


LegacyMainFrameHandlewithMouse in the legacy.c

Function : LegacyMainFrameHandlewithMouse

File: legacy.c
Description:
Function to handle Main Frame with Mouse
Input:
APPLICATION_DATA *app, HOTCLICK_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:10 10/01/14


LegacyMsgBoxInitialize in the legacy.c

Function : LegacyMsgBoxInitialize

File: legacy.c
Description:
Function to Initialize Message Box, which uses the Popup functions.
Input:
MSGBOX_DATA *msgbox, VOID *data
Output:
status
Built on 16:20:10 10/01/14


LegacyNavFrameHandlewithMouse in the legacy.c

Function : LegacyNavFrameHandlewithMouse

File: legacy.c
Description:
Function to handle Navigation Frame with Mouse
Input:
APPLICATION_DATA *app, HOTCLICK_DATA *hotkey, VOID *cookie
Output:
VOID
Built on 16:20:10 10/01/14


LegacyPageHandleAction in the legacy.c

Function : LegacyPageHandleAction

File: legacy.c
Description:
function to handle the page actions
Input:
PAGE_DATA *page, ACTION_DATA *action
Output:
status
Built on 16:20:10 10/01/14


LegacySubMenuDraw in the legacy.c

Function : LegacySubMenuDraw

File: legacy.c
Description:
function to draw a sub-menu.
Input:
SUBMENU_DATA *submenu
Output:
status
Built on 16:20:10 10/01/14


LegacySubMenuInitialize in the legacy.c

Function : LegacySubMenuInitialize

File: legacy.c
Description:
this function uses the Initialize function of control
            and initializes the submenu.
Input:
SUBMENU_DATA *submenu, VOID *data
Output:
status
Built on 16:20:10 10/01/14


OverRideComponent in the legacy.c

Function : OverRideComponent

File: legacy.c
Description:
Function to override component or control functionality
Input:
VOID
Output:
VOID
Built on 16:20:12 10/01/14


OverRideStyleDrawPageBorder in the legacy.c

Function : OverRideStyleDrawPageBorder

File: legacy.c
Description:
Function to draw page border
Input:
UINT32 page
Output:
VOID
Built on 16:20:12 10/01/14


OverRideStyleGetFrameInitData in the legacy.c

Function : OverRideStyleGetFrameInitData

File: legacy.c
Description:
Function to get frame initialization data
Input:
UINT32 page, UINT32 frame
Output:
VOID*
Built on 16:20:12 10/01/14


OverRideStyleInit in the legacy.c

Function : OverRideStyleInit

File: legacy.c
Description:
Function to Initialize style
Input:
VOID
Output:
VOID
Built on 16:20:12 10/01/14


StyleFrameAddTitle in the legacy.c

Function : StyleFrameAddTitle

File: legacy.c
Description:
Function to add frame title
Input:
FRAME_DATA *frame, UINT32 frameType, CONTROL_INFO * dummy
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


StyleFrameIndexOf in the legacy.c

Function : StyleFrameIndexOf

File: legacy.c
Description:
Function to get frame index
Input:
UINT32 frameType
Output:
UINT32 index
Built on 16:20:15 10/01/14


StyleGetPageFrames in the legacy.c

Function : StyleGetPageFrames

File: legacy.c
Description:
Function to number of frames
Input:
UINT32 page
Output:
UINT32 number of frames
Built on 16:20:15 10/01/14


legacy.h

Description:
Main header file for alternate1 style module.
Built on 16:20:20 10/01/14


ListBox.c

Description:
This file contains code to handle Listbox controls

The following functions are used in the file: ListBox.c.

Function | Description
GetLineCount | function to get line count and max width.
ListBoxCreate | Function to create a List Box, which uses the popup controls.
ListBoxDestroy | Function to Destroy a List Box, which uses the popup controls.
ListBoxDraw | Function to draw a List Box.
ListBoxGetControlHight | Function unsupported.
ListBoxHandleAction | Function to handle the List Box actions.
ListBoxSetAttributes | Function to set attributes.
ListBoxSetCallback | Function to set callback.
ListBoxSetDimensions | Function to set dimension.
ListBoxSetFocus | Function to set focus.
ListBoxSetPosition | Function to set position.
SetListBoxHelpString | Function to set a string in List Box.
SetListBoxString | Function to set a string in List Box.
TSEMouseListBoxHandleAction | Function to hadnle List Box using mouse
TSEMouseListBoxScrollBarMove | Adds scroll bar functionality for frames with many controls

Built on 16:20:20 10/01/14


GetLineCount in the ListBox.c

Function : GetLineCount

File: ListBox.c
Description:
function to get line count and max width.
Input:
CHAR16 *line, UINT8 *Width
Output:
UINTN
Built on 16:20:08 10/01/14


ListBoxCreate in the ListBox.c

Function : ListBoxCreate

File: ListBox.c
Description:
Function to create a List Box, which uses the popup controls.
Input:
LISTBOX_DATA **object
Output:
status
Built on 16:20:11 10/01/14


ListBoxDestroy in the ListBox.c

Function : ListBoxDestroy

File: ListBox.c
Description:
Function to Destroy a List Box, which uses the popup controls.
Input:
LISTBOX_DATA *listbox, BOOLEAN freeMem
Output:
status
Built on 16:20:11 10/01/14


ListBoxDraw in the ListBox.c

Function : ListBoxDraw

File: ListBox.c
Description:
Function to draw a List Box.
Input:
LISTBOX_DATA *listbox
Output:
status
Built on 16:20:11 10/01/14


ListBoxGetControlHight in the ListBox.c

Function : ListBoxGetControlHight

File: ListBox.c
Description:
Function unsupported.
Input:
VOID *object,VOID *frame, UINT16 *height
Output:
EFI_STATUS
Built on 16:20:11 10/01/14


ListBoxHandleAction in the ListBox.c

Function : ListBoxHandleAction

File: ListBox.c
Description:
Function to handle the List Box actions.
Input:
LISTBOX_DATA *listbox, ACTION_DATA *Data
Output:
status
Built on 16:20:11 10/01/14


ListBoxSetAttributes in the ListBox.c

Function : ListBoxSetAttributes

File: ListBox.c
Description:
Function to set attributes.
Input:
LISTBOX_DATA *listbox, UINT8 FGColor, UINT8 BGColor
Output:
STATUS
Built on 16:20:11 10/01/14


ListBoxSetCallback in the ListBox.c

Function : ListBoxSetCallback

File: ListBox.c
Description:
Function to set callback.
Input:
LISTBOX_DATA *listbox, OBJECT_DATA *container,   OBJECT_CALLBACK callback, VOID *cookie
Output:
STATUS
Built on 16:20:11 10/01/14


ListBoxSetDimensions in the ListBox.c

Function : ListBoxSetDimensions

File: ListBox.c
Description:
Function to set dimension.
Input:
LISTBOX_DATA *listbox, UINT16 Width, UINT16 Height
Output:
STATUS
Built on 16:20:11 10/01/14


ListBoxSetFocus in the ListBox.c

Function : ListBoxSetFocus

File: ListBox.c
Description:
Function to set focus.
Input:
LISTBOX_DATA *listbox, BOOLEAN focus
Output:
STATUS
Built on 16:20:11 10/01/14


ListBoxSetPosition in the ListBox.c

Function : ListBoxSetPosition

File: ListBox.c
Description:
Function to set position.
Input:
LISTBOX_DATA *listbox, UINT16 Left, UINT16 Top
Output:
STATUS
Built on 16:20:11 10/01/14


SetListBoxHelpString in the ListBox.c

Function : SetListBoxHelpString

File: ListBox.c
Description:
Function to set a string in List Box.
Input:
LISTBOX_DATA *listbox, CHAR16 **pStr,UINT16 Toke
Output:
void
Built on 16:20:14 10/01/14


SetListBoxString in the ListBox.c

Function : SetListBoxString

File: ListBox.c
Description:
Function to set a string in List Box.
Input:
LISTBOX_DATA *listbox, CHAR16 **pStr,UINT16 Toke
Output:
void
Built on 16:20:14 10/01/14


TSEMouseListBoxHandleAction in the ListBox.c

Function : TSEMouseListBoxHandleAction

File: ListBox.c
Description:
Function to hadnle List Box using mouse
Input:
LISTBOX_DATA *listbox,
        ACTION_DATA *action,
Output:
EFI_STATUS
Built on 16:20:16 10/01/14


TSEMouseListBoxScrollBarMove in the ListBox.c

Function : TSEMouseListBoxScrollBarMove

File: ListBox.c
Description:
Adds scroll bar functionality for frames with many controls
Input:
FRAME_DATA *frame - Pointer to the frame data
        BOOLEAN bScrollUp - Go up is TRUE, else to down one control
Output:
EFI_STATUS Status - EFI_SUCCESS if successful, else
                                EFI_UNSUPPORTED
Built on 16:20:16 10/01/14


ListBox.h

Description:
Header file for Listbox controls.
Built on 16:20:20 10/01/14


logo.c

Description:
file contains code to handle the logo operations.
        Taken from graphics.c to eliminnate library dependancy

The following functions are used in the file: logo.c.

Function | Description
CleanUpLogo | function to Clear all the logo buffers.
ConvertAdvancedImageToUgaBlt | Convert a advanced graphics image to a UGA blt buffer.
ConvertBlt2Bmp | Converts the Blt in the screen to Bmp buffer
ConvertBmpandAddBGRT | Converts Blt to Bmp buffer and form BGRT table and add to ACPI.
DoLogoAnimate | function to Handle logo animation
DrawBlock | function to draw draw a block
DrawBltBuffer | function to draw draw a block
DrawBltProgressBar | function to draw a progress bar
DrawImage | function to draw a image
DrawProgressBarBorder | function to draw the border of a progress bar
GetExtendedLogoType | function to get the type of extended logo
GetScreenResolution | function to get the screen resolutions.
GOPSetScreenResolution | Sets the mode which approximately fits the current image resolution
SetGetBgrtCoordinates | Sets the BGRT logo coordinates
SetGraphicsResolution | Sets the graphical resolution corresponding to the input parameter
SetNativeResFromEdid | Finds and sets the resolution from EDID
SetScreenResolution | function to set the screen resolutions.

Built on 16:20:20 10/01/14


CleanUpLogo in the logo.c

Function : CleanUpLogo

File: logo.c
Description:
function to Clear all the logo buffers.
Input:
nil
Output:
void
Built on 16:20:06 10/01/14


ConvertAdvancedImageToUgaBlt in the logo.c

Function : ConvertAdvancedImageToUgaBlt

File: logo.c
Description:
Convert a advanced graphics image to a UGA blt buffer.
Input:
IN  VOID      *ImageData,
            IN  UINTN     ImageSize,
            IN OUT VOID   **UgaBlt,
            IN OUT UINTN  *UgaBltSize,
            OUT UINTN     *Height,
            OUT UINTN     *Width,
            OUT BOOLEAN *Animate
Output:
EFI_STATUS
Built on 16:20:06 10/01/14


ConvertBlt2Bmp in the logo.c

Function : ConvertBlt2Bmp

File: logo.c
Description:
Converts the Blt in the screen to Bmp buffer
Input:
VOID
Output:
VOID *
Built on 16:20:06 10/01/14


ConvertBmpandAddBGRT in the logo.c

Function : ConvertBmpandAddBGRT

File: logo.c
Description:
Converts Blt to Bmp buffer and form BGRT table and add to ACPI.
Input:
BOOLEAN  = Indicates whether to set the BGRT status field or not.
Output:
VOID
Built on 16:20:06 10/01/14


DoLogoAnimate in the logo.c

Function : DoLogoAnimate

File: logo.c
Description:
function to Handle logo animation
Input:
CO_ORD_ATTRIBUTE Attribute,
        INTN CoordinateX,INTN CoordinateY
Output:
None
Built on 16:20:06 10/01/14


DrawBlock in the logo.c

Function : DrawBlock

File: logo.c
Description:
function to draw draw a block
Input:
UINTN DestX, UINTN DestY, UINTN	Width, UINTN Height, EFI_UGA_PIXEL *BltBuffer
Output:
void
Built on 16:20:06 10/01/14


DrawBltBuffer in the logo.c

Function : DrawBltBuffer

File: logo.c
Description:
function to draw draw a block
Input:
EFI_UGA_PIXEL *UgaBlt, CO_ORD_ATTRIBUTE Attribute,
            UINTN Width, UINTN Height, INTN DestX, INTN DestY,
            UINTN BufferWidth
Output:
void
Built on 16:20:06 10/01/14


DrawBltProgressBar in the logo.c

Function : DrawBltProgressBar

File: logo.c
Description:
function to draw a progress bar
Input:
nil
Output:
void
Built on 16:20:06 10/01/14


DrawImage in the logo.c

Function : DrawImage

File: logo.c
Description:
function to draw a image
Input:
UINT8 *ImageData, UINTN ImageSize, CO_ORD_ATTRIBUTE Attribute,
            INTN CoordinateX, INTN CoordinateY, BOOLEAN AdjustScreenResolution,
            UINTN *Width, UINTN *Height
Output:
status
Built on 16:20:07 10/01/14


DrawProgressBarBorder in the logo.c

Function : DrawProgressBarBorder

File: logo.c
Description:
function to draw the border of a progress bar
Input:
UINTN DestX, UINTN DestY, UINTN Width, UINTN Height,
            EFI_UGA_PIXEL *BltBuffer, UINTN	bw
Output:
void
Built on 16:20:07 10/01/14


GetExtendedLogoType in the logo.c

Function : GetExtendedLogoType

File: logo.c
Description:
function to get the type of extended logo
Input:
UINT8 *ImageData
Output:
LOGO_TYPE
Built on 16:20:08 10/01/14


GetScreenResolution in the logo.c

Function : GetScreenResolution

File: logo.c
Description:
function to get the screen resolutions.
Input:
UINTN *ResX, UINTN *ResY
Output:
status
Built on 16:20:08 10/01/14


GOPSetScreenResolution in the logo.c

Function : GOPSetScreenResolution

File: logo.c
Description:
Sets the mode which approximately fits the current image resolution
Input:
UINTN *, UINTN * -> Pointer to the width and height of the image to be drawn
Output:
EFI_STATUS -> Status for the operation
Built on 16:20:08 10/01/14


SetGetBgrtCoordinates in the logo.c

Function : SetGetBgrtCoordinates

File: logo.c
Description:
Sets the BGRT logo coordinates
Input:
UINTN	*DestX = X coordinate
        UINTN	*DestY = Y coordinate
        UINTN   *Width = Width of the logo
        UINTN   *Height = Heigth of the logo
        BOOLEAN Command = To set or get the Bgrt logo resolutions
Output:
VOID
Built on 16:20:14 10/01/14


SetGraphicsResolution in the logo.c

Function : SetGraphicsResolution

File: logo.c
Description:
Sets the graphical resolution corresponding to the input parameter
Input:
UINT32 - Horizontal resolution of the mode to set
                UINT32 - Vertical resolution of the mode to set
Output:
EFI_STATUS - EFI_SUCCESS - If input resolutions are set successfully
                                 !EFI_SUCCESS - If input resolutions are not set successfully
Built on 16:20:14 10/01/14


SetNativeResFromEdid in the logo.c

Function : SetNativeResFromEdid

File: logo.c
Description:
Finds and sets the resolution from EDID
Input:
VOID
Output:
VOID
Built on 16:20:14 10/01/14


SetScreenResolution in the logo.c

Function : SetScreenResolution

File: logo.c
Description:
function to set the screen resolutions.
Input:
UINTN ResX, UINTN ResY
Output:
status
Built on 16:20:14 10/01/14


mem.c

Description:
file contains code to handle the memory operations.

The following functions are used in the file: mem.c.

Function | Description
MemCmp | function to compare the memory of two buffers.
MemCopy | function to copy a memory
MemFillUINT16Buffer | function to fill a UINT16 Buffer
MemFreePointer | function to free the pointers
MemReallocateZeroPool | function to reuse a allocated buffer
MemSet | function to set the memory with the specified value
StringZeroFreeMemory | Function to free the string pointers and zeroing its memory, used for strings Care should be taken String Length identification function is used

Built on 16:20:20 10/01/14


MemCmp in the mem.c

Function : MemCmp

File: mem.c
Description:
function to compare the memory of two buffers.
Input:
UINT8 *dest, UINT8 *src, UINTN size
Output:
0/1/-1
Built on 16:20:11 10/01/14


MemCopy in the mem.c

Function : MemCopy

File: mem.c
Description:
function to copy a memory
Input:
VOID *dest, VOID *src, UINTN size
Output:
void
Built on 16:20:11 10/01/14


MemFillUINT16Buffer in the mem.c

Function : MemFillUINT16Buffer

File: mem.c
Description:
function to fill a UINT16 Buffer
Input:
VOID *buffer, UINTN bufferSize, UINT16 value
Output:
void
Built on 16:20:11 10/01/14


MemFreePointer in the mem.c

Function : MemFreePointer

File: mem.c
Description:
function to free the pointers
Input:
VOID **ptr
Output:
void
Built on 16:20:11 10/01/14


MemReallocateZeroPool in the mem.c

Function : MemReallocateZeroPool

File: mem.c
Description:
function to reuse a allocated buffer
Input:
VOID *oldBuffer, UINTN oldSize, UINTN newSize
Output:
void
Built on 16:20:11 10/01/14


MemSet in the mem.c

Function : MemSet

File: mem.c
Description:
function to set the memory with the specified value
Input:
VOID *buffer, UINTN size, UINT8 value
Output:
void
Built on 16:20:11 10/01/14


StringZeroFreeMemory in the mem.c

Function : StringZeroFreeMemory

File: mem.c
Description:
Function to free the string pointers and zeroing its memory, used for strings
        Care should be taken String Length identification function is used
Input:
VOID **ptr
Output:
void
Built on 16:20:15 10/01/14


Memo.c

The following functions are used in the file: Memo.c.

Function | Description
MemoCreate | Function to create a Memo, which uses the Control Functions.
MemoDestroy | Function to Destroy a Memo, which uses the Control Functions.
MemoDraw | Function to draw a Memo.
MemoDrawScrollBar | Function to draw memo scrollbar
MemoEraseScrollBar | Function to erase memo scrollbar
MemoGetControlHeight | Function to get the memo text height.
MemoInitialize | Function to Initialize a Memo, which uses the Control Functions.
MemoSetAttributes | Function to set attributes.
MemoSetCallback | Function to set callback.
MemoSetDimensions | Function to set dimension.
MemoSetFocus | Function to set focus.
MemoSetJustify | Function to set justify.
MemoSetPosition | Function to set position.
MenuHandleAction | Function to set callback.

Built on 16:20:20 10/01/14


MemoCreate in the Memo.c

Function : MemoCreate

File: Memo.c
Description:
Function to create a Memo, which uses the Control Functions.
Input:
MEMO_DATA **object
Output:
status
Built on 16:20:11 10/01/14


MemoDestroy in the Memo.c

Function : MemoDestroy

File: Memo.c
Description:
Function to Destroy a Memo, which uses the Control Functions.
Input:
MEMO_DATA *memo, BOOLEAN freeMem
Output:
status
Built on 16:20:11 10/01/14


MemoDraw in the Memo.c

Function : MemoDraw

File: Memo.c
Description:
Function to draw a Memo.
Input:
MEMO_DATA *memo
Output:
status
Built on 16:20:11 10/01/14


MemoDrawScrollBar in the Memo.c

Function : MemoDrawScrollBar

File: Memo.c
Description:
Function to draw memo scrollbar
Input:
MEMO_DATA *memo, UINT16 height
Output:
VOID
Built on 16:20:11 10/01/14


MemoEraseScrollBar in the Memo.c

Function : MemoEraseScrollBar

File: Memo.c
Description:
Function to erase memo scrollbar
Input:
MEMO_DATA *memo
Output:
VOID
Built on 16:20:11 10/01/14


MemoGetControlHeight in the Memo.c

Function : MemoGetControlHeight

File: Memo.c
Description:
Function to get the memo text height.
Input:
MEMO_DATA *memo, UINT16 *height
Output:
status
Built on 16:20:11 10/01/14


MemoInitialize in the Memo.c

Function : MemoInitialize

File: Memo.c
Description:
Function to Initialize a Memo, which uses the Control Functions.
Input:
MEMO_DATA *memo, VOID *data
Output:
status
Built on 16:20:11 10/01/14


MemoSetAttributes in the Memo.c

Function : MemoSetAttributes

File: Memo.c
Description:
Function to set attributes.
Input:
MEMO_DATA *memo, UINT8 FGColor, UINT8 BGColor
Output:
STATUS
Built on 16:20:11 10/01/14


MemoSetCallback in the Memo.c

Function : MemoSetCallback

File: Memo.c
Description:
Function to set callback.
Input:
MEMO_DATA *memo, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
STATUS
Built on 16:20:11 10/01/14


MemoSetDimensions in the Memo.c

Function : MemoSetDimensions

File: Memo.c
Description:
Function to set dimension.
Input:
MEMO_DATA *memo, UINT16 width, UINT16 height
Output:
STATUS
Built on 16:20:11 10/01/14


MemoSetFocus in the Memo.c

Function : MemoSetFocus

File: Memo.c
Description:
Function to set focus.
Input:
MEMO_DATA *memo, BOOLEAN focus
Output:
STATUS
Built on 16:20:11 10/01/14


MemoSetJustify in the Memo.c

Function : MemoSetJustify

File: Memo.c
Description:
Function to set justify.
Input:
MEMO_DATA *memo, UINT8 justify
Output:
STATUS
Built on 16:20:11 10/01/14


MemoSetPosition in the Memo.c

Function : MemoSetPosition

File: Memo.c
Description:
Function to set position.
Input:
MEMO_DATA *memo, UINT16 Left, UINT16 Top
Output:
STATUS
Built on 16:20:11 10/01/14


MenuHandleAction in the Memo.c

Function : MenuHandleAction

File: Memo.c
Description:
Function to set callback.
Input:
MEMO_DATA *memo, ACTION_DATA *Data
Output:
STATUS
Built on 16:20:11 10/01/14


Memo.h

Description:
Header file for Memo controls.
Built on 16:20:20 10/01/14


Menu.c

Description:
This file contains code to handle Menu operations

The following functions are used in the file: Menu.c.

Function | Description
_MenuCallCallback | Internal Helper Function to Call the callback
MenuCreate | Function to create Menu, Which uses the control functions.
MenuDestroy | Function to Destroy Menu, Which uses the control functions.
MenuDraw | Function to draw a Menu.
MenuGetControlHight | Function unsupported.
MenuHandleAction | Function to handle actions.
MenuInitialize | Function to Initialize Menu, Which uses the control functions.
MenuSetAttributes | Function to set attributes.
MenuSetCallback | Function to set callback.
MenuSetDimensions | Function to set dimension.
MenuSetFocus | Function to set focus.
MenuSetPosition | Function to set position.
MenuSetWidth | Function to set width.
TSEMouseMenuHandleAction | Function to hadnle Menu using mouse

Built on 16:20:20 10/01/14


_MenuCallCallback in the Menu.c

Function : _MenuCallCallback

File: Menu.c
Description:
Internal Helper Function to Call the callback
Input:
MENU_DATA *menu, UINT8 MenuEntry
Output:
STATUS
Built on 16:20:04 10/01/14


MenuCreate in the Menu.c

Function : MenuCreate

File: Menu.c
Description:
Function to create Menu, Which uses the control functions.
Input:
MENU_DATA **object
Output:
status
Built on 16:20:11 10/01/14


MenuDestroy in the Menu.c

Function : MenuDestroy

File: Menu.c
Description:
Function to Destroy Menu, Which uses the control functions.
Input:
MENU_DATA *menu, BOOLEAN freeMem
Output:
status
Built on 16:20:11 10/01/14


MenuDraw in the Menu.c

Function : MenuDraw

File: Menu.c
Description:
Function to draw a Menu.
Input:
MENU_DATA *menu
Output:
status
Built on 16:20:11 10/01/14


MenuGetControlHight in the Menu.c

Function : MenuGetControlHight

File: Menu.c
Description:
Function unsupported.
Input:
VOID *object,VOID *frame, UINT16 *height
Output:
EFI_STATUS
Built on 16:20:11 10/01/14


MenuHandleAction in the Menu.c

Function : MenuHandleAction

File: Menu.c
Description:
Function to handle actions.
Input:
MENU_DATA *menu, ACTION_DATA *Data
Output:
STATUS
Built on 16:20:11 10/01/14


MenuInitialize in the Menu.c

Function : MenuInitialize

File: Menu.c
Description:
Function to Initialize Menu, Which uses the control functions.
Input:
MENU_DATA *menu, VOID *data
Output:
status
Built on 16:20:11 10/01/14


MenuSetAttributes in the Menu.c

Function : MenuSetAttributes

File: Menu.c
Description:
Function to set attributes.
Input:
MENU_DATA *menu, UINT8 FGColor, UINT8 BGColor
Output:
STATUS
Built on 16:20:11 10/01/14


MenuSetCallback in the Menu.c

Function : MenuSetCallback

File: Menu.c
Description:
Function to set callback.
Input:
MENU_DATA *menu, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
STATUS
Built on 16:20:11 10/01/14


MenuSetDimensions in the Menu.c

Function : MenuSetDimensions

File: Menu.c
Description:
Function to set dimension.
Input:
MENU_DATA *menu, UINT16 Width, UINT16 Height
Output:
STATUS
Built on 16:20:11 10/01/14


MenuSetFocus in the Menu.c

Function : MenuSetFocus

File: Menu.c
Description:
Function to set focus.
Input:
MENU_DATA *menu, BOOLEAN focus
Output:
STATUS
Built on 16:20:11 10/01/14


MenuSetPosition in the Menu.c

Function : MenuSetPosition

File: Menu.c
Description:
Function to set position.
Input:
MENU_DATA *menu, UINT16 Left, UINT16 Top
Output:
STATUS
Built on 16:20:11 10/01/14


MenuSetWidth in the Menu.c

Function : MenuSetWidth

File: Menu.c
Description:
Function to set width.
Input:
VOID *menu, UINT8 Width
Output:
STATUS
Built on 16:20:11 10/01/14


TSEMouseMenuHandleAction in the Menu.c

Function : TSEMouseMenuHandleAction

File: Menu.c
Description:
Function to hadnle Menu using mouse
Input:
MENU_DATA *menu,
        ACTION_DATA *Data
Output:
EFI_STATUS
Built on 16:20:16 10/01/14


Menu.h

Description:
Header file for Menu controls
Built on 16:20:20 10/01/14


MessageBox.c

Description:
This file contains code to handle Message Box operations

The following functions are used in the file: MessageBox.c.

Function | Description
_MsgBoxCallCallback | Internal Helper Function to Call the callback
_MsgBoxDrawOpts | Function to Draw Message box options
_MsgBoxOptSize | Function returns and fix the option string
MsgBoxCreate | Function to Create Message Box, which uses the Popup functions.
MsgBoxDestroy | Function to Destroy Message Box, which uses the Popup functions.
MsgBoxDraw | Function to Draw Message box
MsgBoxGetControlHight | Function unsupported.
MsgBoxHandleAction | Function to Handle the Message Box Actions.
MsgBoxInitialize | Function to Initialize Message Box, which uses the Popup functions.
MsgBoxSetAttributes | Function to set attrinutes.
MsgBoxSetCallback | Function to set callback.
MsgBoxSetDimensions | Function to set dimensions.
MsgBoxSetFocus | Function to set focus.
MsgBoxSetPosition | Function to set position.
MsgBoxSetType | Function to set message box type.
TSEMouseMsgBoxHandleAction | Function to hadnle Message Box using mouse

Built on 16:20:20 10/01/14


_MsgBoxCallCallback in the MessageBox.c

Function : _MsgBoxCallCallback

File: MessageBox.c
Description:
Internal Helper Function to Call the callback
Input:
MENU_DATA *menu, UINT8 MenuEntry
Output:
STATUS
Built on 16:20:04 10/01/14


_MsgBoxDrawOpts in the MessageBox.c

Function : _MsgBoxDrawOpts

File: MessageBox.c
Description:
Function to Draw Message box options
Input:
MSGBOX_DATA *msgbox
Output:
status
Built on 16:20:04 10/01/14


_MsgBoxOptSize in the MessageBox.c

Function : _MsgBoxOptSize

File: MessageBox.c
Description:
Function returns and fix the option string
Input:
MSGBOX_DATA *msgbox
Output:
status
Built on 16:20:04 10/01/14


MsgBoxCreate in the MessageBox.c

Function : MsgBoxCreate

File: MessageBox.c
Description:
Function to Create Message Box, which uses the Popup functions.
Input:
MSGBOX_DATA **object
Output:
status
Built on 16:20:11 10/01/14


MsgBoxDestroy in the MessageBox.c

Function : MsgBoxDestroy

File: MessageBox.c
Description:
Function to Destroy Message Box, which uses the Popup functions.
Input:
MSGBOX_DATA *msgbox, BOOLEAN freeMem
Output:
status
Built on 16:20:11 10/01/14


MsgBoxDraw in the MessageBox.c

Function : MsgBoxDraw

File: MessageBox.c
Description:
Function to Draw Message box
Input:
MSGBOX_DATA *msgbox
Output:
status
Built on 16:20:11 10/01/14


MsgBoxGetControlHight in the MessageBox.c

Function : MsgBoxGetControlHight

File: MessageBox.c
Description:
Function unsupported.
Input:
VOID *object,VOID *frame, UINT16 *height
Output:
EFI_STATUS
Built on 16:20:11 10/01/14


MsgBoxHandleAction in the MessageBox.c

Function : MsgBoxHandleAction

File: MessageBox.c
Description:
Function to Handle the Message Box Actions.
Input:
MSGBOX_DATA *msgbox
Output:
status
Built on 16:20:11 10/01/14


MsgBoxInitialize in the MessageBox.c

Function : MsgBoxInitialize

File: MessageBox.c
Description:
Function to Initialize Message Box, which uses the Popup functions.
Input:
MSGBOX_DATA *msgbox, VOID *data
Output:
status
Built on 16:20:11 10/01/14


MsgBoxSetAttributes in the MessageBox.c

Function : MsgBoxSetAttributes

File: MessageBox.c
Description:
Function to set attrinutes.
Input:
MSGBOX_DATA *msgbox, UINT8 FGColor, UINT8 BGColor
Output:
STATUS
Built on 16:20:11 10/01/14


MsgBoxSetCallback in the MessageBox.c

Function : MsgBoxSetCallback

File: MessageBox.c
Description:
Function to set callback.
Input:
MSGBOX_DATA *msgbox, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
STATUS
Built on 16:20:11 10/01/14


MsgBoxSetDimensions in the MessageBox.c

Function : MsgBoxSetDimensions

File: MessageBox.c
Description:
Function to set dimensions.
Input:
MSGBOX_DATA *msgbox, UINT16 Width, UINT16 Height
Output:
STATUS
Built on 16:20:11 10/01/14


MsgBoxSetFocus in the MessageBox.c

Function : MsgBoxSetFocus

File: MessageBox.c
Description:
Function to set focus.
Input:
MSGBOX_DATA *msgbox, BOOLEAN focus
Output:
STATUS
Built on 16:20:11 10/01/14


MsgBoxSetPosition in the MessageBox.c

Function : MsgBoxSetPosition

File: MessageBox.c
Description:
Function to set position.
Input:
MSGBOX_DATA *msgbox, UINT16 Left, UINT16 Top
Output:
STATUS
Built on 16:20:11 10/01/14


MsgBoxSetType in the MessageBox.c

Function : MsgBoxSetType

File: MessageBox.c
Description:
Function to set message box type.
Input:
MSGBOX_DATA *msgbox, UINT8 Type
Output:
STATUS
Built on 16:20:11 10/01/14


TSEMouseMsgBoxHandleAction in the MessageBox.c

Function : TSEMouseMsgBoxHandleAction

File: MessageBox.c
Description:
Function to hadnle Message Box using mouse
Input:
MSGBOX_DATA *msgbox,
        ACTION_DATA *action,
        BOOLEAN * pRedraw
Output:
EFI_STATUS
Built on 16:20:16 10/01/14


MINISETUP SDL Tokens

The following data structures are used in the file: MINISETUP SDL Tokens.

Variable | Description
MiniSetup_SUPPORT | Main switch to enable BootOnly Sources support in Project
SETUP_OEM_SPECIAL_CONTROL_SUPPORT | Turn on to have OEM Special Control Support.
SETUP_USE_GRAPHICS_OUTPUT_PROTOCOL | 1 => Uses Graphics Output protocol. 0 => Uses UgaDraw protocol.
SETUP_USE_GUIDED_SECTION | Enable to have BCP compatibility in Aptio 3.x
TSE_BEST_HORIZONTAL_RESOLUTION | Set TSE standard Horizontal resolution. 800 is Standard horizontal resolution for TSE.
TSE_BEST_VERTICAL_RESOLUTION | Set TSE standard Vertical resolution. 600 is Standard Vertical resolution for TSE.
TSE_MAX_DRIVE_NAME | Set the value to dispaly number of characters for Drive name
TSE_USE_EDK_LIBRARY | Turn on to Depend on the EDK Libraries, OFF makes use of Aptio Libaray

Built on 16:20:20 10/01/14


MiniSetup_SUPPORT in the MINISETUP SDL Tokens

Variable : MiniSetup_SUPPORT

File: MINISETUP SDL Tokens
Description:
Main switch to enable BootOnly Sources support in Project
Built on 16:20:11 10/01/14


SETUP_OEM_SPECIAL_CONTROL_SUPPORT in the MINISETUP SDL Tokens

Variable : SETUP_OEM_SPECIAL_CONTROL_SUPPORT

File: MINISETUP SDL Tokens
Description:
Turn on to have OEM Special Control Support.
Built on 16:20:15 10/01/14


SETUP_USE_GRAPHICS_OUTPUT_PROTOCOL in the MINISETUP SDL Tokens

Variable : SETUP_USE_GRAPHICS_OUTPUT_PROTOCOL

File: MINISETUP SDL Tokens
Description:
1 => Uses Graphics Output protocol. 0 => Uses UgaDraw protocol.
Built on 16:20:15 10/01/14


SETUP_USE_GUIDED_SECTION in the MINISETUP SDL Tokens

Variable : SETUP_USE_GUIDED_SECTION

File: MINISETUP SDL Tokens
Description:
Enable to have BCP compatibility in Aptio 3.x
Built on 16:20:15 10/01/14


TSE_BEST_HORIZONTAL_RESOLUTION in the MINISETUP SDL Tokens

Variable : TSE_BEST_HORIZONTAL_RESOLUTION

File: MINISETUP SDL Tokens
Description:
Set TSE standard Horizontal resolution. 800 is Standard horizontal resolution for TSE.
Built on 16:20:16 10/01/14


TSE_BEST_VERTICAL_RESOLUTION in the MINISETUP SDL Tokens

Variable : TSE_BEST_VERTICAL_RESOLUTION

File: MINISETUP SDL Tokens
Description:
Set TSE standard Vertical resolution. 600 is Standard Vertical resolution for TSE.
Built on 16:20:16 10/01/14


TSE_MAX_DRIVE_NAME in the MINISETUP SDL Tokens

Variable : TSE_MAX_DRIVE_NAME

File: MINISETUP SDL Tokens
Description:
Set the value to dispaly number of characters for Drive name
Built on 16:20:16 10/01/14


TSE_USE_EDK_LIBRARY in the MINISETUP SDL Tokens

Variable : TSE_USE_EDK_LIBRARY

File: MINISETUP SDL Tokens
Description:
Turn on to Depend on the EDK Libraries, OFF makes use of Aptio Libaray
Built on 16:20:16 10/01/14


minisetup.c

Description:
This file contains code for entrypoint and setup loop

The following functions are used in the file: minisetup.c.

Function | Description
DoPopup | This function runs the loop for Pop up boot menu. This function is responsible for creating the list box control. It also gathers actions and passes them to list box control and initiates draw sequence.
GetDefaultPassword | Getting default password from SDL token based on USER/ADMIN token
MainSetupLoopInit | Main function that initializes the setup Loops.
MiniSetupApplication | This function is the entry point for TSE. It loads resources like strings and setup-data. It registers notification for console protocols. It Installs TSE protocols.
MiniSetupExit | This function is responsible for releasing the memory allocated during MinisetuEntry(). It destroys the application hierarchy; clears the memory used for variables; clears the memory used for fixup of setup-data.
SetDefaultPassword | Function to set defaults password in NVRAM, if any present in SDL

Built on 16:20:20 10/01/14


DoPopup in the minisetup.c

Function : DoPopup

File: minisetup.c
Description:
This function runs the loop for Pop up boot menu.
This function is responsible for creating the list
box control. It also gathers actions and passes them
to list box control and initiates draw sequence.
Input:
BOOT_FLOW *BootFlow: Ptr to BOOT_FLOW responsible for
the call.
Output:
Return Status based on errors that occurred in
library functions.
Built on 16:20:06 10/01/14


GetDefaultPassword in the minisetup.c

Function : GetDefaultPassword

File: minisetup.c
Description:
Getting default password from SDL token based on USER/ADMIN token
Input:
UINT32, AMITSESETUP*
Output:
EFI_STATUS
Built on 16:20:08 10/01/14


MainSetupLoopInit in the minisetup.c

Function : MainSetupLoopInit

File: minisetup.c
Description:
Main function that initializes the setup Loops.
Input:
void
Output:
void
Built on 16:20:11 10/01/14


MiniSetupApplication in the minisetup.c

Function : MiniSetupApplication

File: minisetup.c
Description:
This function is the entry point for TSE. It loads
resources like strings and setup-data. It registers
notification for console protocols. It Installs TSE
protocols.
Input:
EFI_HANDLE ImageHandle
EFI_SYSTEM_TABLE *SystemTable
Output:
Return Status based on errors that occurred in library
functions.
Built on 16:20:11 10/01/14


MiniSetupExit in the minisetup.c

Function : MiniSetupExit

File: minisetup.c
Description:
This function is responsible for releasing the memory
allocated during MinisetuEntry(). It destroys the
application hierarchy; clears the memory used for
variables; clears the memory used for fixup of
setup-data.
Input:
EFI_STATUS Status: Guideline status for MiniSetupExit
to return with.
Output:
Return Status based on input status and errors that
occurred in library functions.
Built on 16:20:11 10/01/14


SetDefaultPassword in the minisetup.c

Function : SetDefaultPassword

File: minisetup.c
Description:
Function to set defaults password in NVRAM, if any present in SDL
Input:
void
Output:
EFI_STATUS
Built on 16:20:14 10/01/14


minisetup.h

Description:
Main header file takes care of TSE includes.
Built on 16:20:20 10/01/14


minisetupext.c

Description:
This file contains code for entrypoint and setup loop

The following functions are used in the file: minisetupext.c.

Function | Description
_LoadPageDefaults | Function to updated defaults for specific page for both Optimal and FailSafe defaults
BBS_GetKey | function to read the input key
BbsBoot | This function is a hook called after launching BBS Popup Menu. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
BbsStrnCpy | function the string copy
BootOnlyUpdateVersionString | Function to update version string
CheckEnableQuietBoot | Function to Check the quick boot enable option
CheckStrings | function to validate the stings
ClearGrphxScreen | Function to clear the graphics screen.
DoBbsPopupInit | This function runs the loop for Pop up boot menu. This function is responsible for creating the list box control. It also gathers actions and passes them to list box control and initiates draw sequence.
DownDisplayList | function to display the downside list
DrawBbsPopupMenu | function for the BBS Popup menu
DrawBootOnlyBbsPopupMenu | function for the BBS Popup menu
GetAMITSEVariableLocal | function to get the local NvRam variable
GetParentFormID | Gets the parent page ID from given child page ID
GetUpdatedControlData | Try to get the updated control.
HighLightLine | function to hilight a perticular line
InitGlobalPointers | function to Initialize all the global pointer declared.
InitgProgress |
MainSetupLoop | This function runs the loop for setup execution. This function is responsible for creating the application hierarchy. It also gathers actions and passes them thru application hierarchy and initiates draw sequence.
MiniSetupEntry | This function prepares system so that setup can be launched. Preparation mainly includes Setup data fixup and variable details gathering.
ResetNavStack | Resets the navigation stack
RestorePostScreen | Function to restore the saved screen
SavePostScreen | Function to save the Post screen
SetParentFormID | Updated NAV_PAGE_STACK with current page and parent page info
SetScrollPosition | function to set the position of the Scroll bar
ShowPostMenu | Function to show menu
UIUpdateCallback | UI callback function for dynamic form updates.
UpdategScreenParams | Verifies and corrects the gScreen params with the current uni strings
UpDisplayList | function to display the upside list

Built on 16:20:20 10/01/14


_LoadPageDefaults in the minisetupext.c

Function : _LoadPageDefaults

File: minisetupext.c
Description:
Function to updated defaults for specific page for both Optimal and FailSafe defaults
Input:
PAGE_INFO, UINT32
Output:
VOID
Built on 16:20:04 10/01/14


BBS_GetKey in the minisetupext.c

Function : BBS_GetKey

File: minisetupext.c
Description:
function to read the input key
Input:
void
Output:
ScanCode/UniCode
Built on 16:20:05 10/01/14


BbsBoot in the minisetupext.c

Function : BbsBoot

File: minisetupext.c
Description:
This function is a hook called after launching
BBS Popup Menu. This function is available as
ELINK. In the generic implementation this function is
empty. OEMs may choose to do additional logic here.
Input:
index: The nth option in the boot now menu.
        ShowAllBbsDev - SETUP_SHOW_ALL_BBS_DEVICES
Output:
VOID
Built on 16:20:05 10/01/14


BbsStrnCpy in the minisetupext.c

Function : BbsStrnCpy

File: minisetupext.c
Description:
function the string copy
Input:
CHAR16  *Dst, CHAR16  *Src, UINTN   Length
Output:
void
Built on 16:20:05 10/01/14


BootOnlyUpdateVersionString in the minisetupext.c

Function : BootOnlyUpdateVersionString

File: minisetupext.c
Description:
Function to update version string
Input:
VOID
Output:
VOID
Built on 16:20:05 10/01/14


CheckEnableQuietBoot in the minisetupext.c

Function : CheckEnableQuietBoot

File: minisetupext.c
Description:
Function to Check the quick boot enable option
Input:
void
Output:
void

Notes		:	if NVRAM variable field AMISilentBoot = 0, then disable silent
            mode else enable In case of error reading the Setup variable,
            then return as silent boot disable
Built on 16:20:05 10/01/14


CheckStrings in the minisetupext.c

Function : CheckStrings

File: minisetupext.c
Description:
function to validate the stings
Input:
void
Output:
void
Built on 16:20:05 10/01/14


ClearGrphxScreen in the minisetupext.c

Function : ClearGrphxScreen

File: minisetupext.c
Description:
Function to clear the graphics screen.
Input:
void
Output:
void
Built on 16:20:06 10/01/14


DoBbsPopupInit in the minisetupext.c

Function : DoBbsPopupInit

File: minisetupext.c
Description:
This function runs the loop for Pop up boot menu.
This function is responsible for creating the list
box control. It also gathers actions and passes them
to list box control and initiates draw sequence.
Input:
BOOT_FLOW *BootFlow: Ptr to BOOT_FLOW responsible for
the call.
Output:
Return Status based on errors that occurred in
library functions.
Built on 16:20:06 10/01/14


DownDisplayList in the minisetupext.c

Function : DownDisplayList

File: minisetupext.c
Description:
function to display the downside list
Input:
int Start, int End, int NumLines
Output:
void
Built on 16:20:06 10/01/14


DrawBbsPopupMenu in the minisetupext.c

Function : DrawBbsPopupMenu

File: minisetupext.c
Description:
function for the BBS Popup menu
Input:
void
Output:
void
Built on 16:20:06 10/01/14


DrawBootOnlyBbsPopupMenu in the minisetupext.c

Function : DrawBootOnlyBbsPopupMenu

File: minisetupext.c
Description:
function for the BBS Popup menu
Input:
void
Output:
void
Built on 16:20:06 10/01/14


GetAMITSEVariableLocal in the minisetupext.c

Function : GetAMITSEVariableLocal

File: minisetupext.c
Description:
function to get the local NvRam variable
Input:
AMITSESETUP **mSysConf, UINT8 **setup, UINTN *VarSize
Output:
void
Built on 16:20:08 10/01/14


GetParentFormID in the minisetupext.c

Function : GetParentFormID

File: minisetupext.c
Description:
Gets the parent page ID from given child page ID
Input:
UINT16 ChildID - Child page ID
    UINT16 *ParentID - Parent page ID
Output:
EFI_STATUS Status - EFI_SUCCESS if successful, else EFI_ERROR
Built on 16:20:08 10/01/14


GetUpdatedControlData in the minisetupext.c

Function : GetUpdatedControlData

File: minisetupext.c
Description:
Try to get the updated control.
Input:
CONTROL_DATA * ControlData,UINT16 ControlType,VOID *Handle,UINT16 Key
Output:
controlData. Null if not found.
Built on 16:20:08 10/01/14


HighLightLine in the minisetupext.c

Function : HighLightLine

File: minisetupext.c
Description:
function to hilight a perticular line
Input:
int UpDown, int NumLines
Output:
void
Built on 16:20:09 10/01/14


InitGlobalPointers in the minisetupext.c

Function : InitGlobalPointers

File: minisetupext.c
Description:
function to Initialize all the global pointer declared.
Input:
void
Output:
void
Built on 16:20:10 10/01/14


InitgProgress in the minisetupext.c

Function : InitgProgress

File: minisetupext.c
Description:
Input:
No Arguments
Output:
void
Built on 16:20:10 10/01/14


MainSetupLoop in the minisetupext.c

Function : MainSetupLoop

File: minisetupext.c
Description:
This function runs the loop for setup execution. This
function is responsible for creating the application
hierarchy. It also gathers actions and passes them
thru application hierarchy and initiates draw
sequence.
Input:
VOID
Output:
Return Status based on errors that occurred in library
functions.
Built on 16:20:11 10/01/14


MiniSetupEntry in the minisetupext.c

Function : MiniSetupEntry

File: minisetupext.c
Description:
This function prepares system so that setup can be
launched. Preparation mainly includes Setup data
fixup and variable details gathering.
Input:
VOID
Output:
Return Status based on errors that occurred in library
functions.
Built on 16:20:11 10/01/14


ResetNavStack in the minisetupext.c

Function : ResetNavStack

File: minisetupext.c
Description:
Resets the navigation stack
Input:
None
Output:
VOID
Built on 16:20:14 10/01/14


RestorePostScreen in the minisetupext.c

Function : RestorePostScreen

File: minisetupext.c
Description:
Function to restore the saved screen
Input:
VOID *UgaBlt, UINTN SizeOfX, UINTN SizeOfY
Output:
VOID
Built on 16:20:14 10/01/14


SavePostScreen in the minisetupext.c

Function : SavePostScreen

File: minisetupext.c
Description:
Function to save the Post screen
Input:
UINTN *SizeOfX, UINTN *SizeOfY
Output:
VOID*
Built on 16:20:14 10/01/14


SetParentFormID in the minisetupext.c

Function : SetParentFormID

File: minisetupext.c
Description:
Updated NAV_PAGE_STACK with current page and parent page info
Input:
UINT16 ParentID - Current/Parent Page ID
        UINT16 TargetID - Target/child page ID
Output:
EFI_STATUS Status - EFI_SUCCESS if successful, else EFI_ERROR
Built on 16:20:14 10/01/14


SetScrollPosition in the minisetupext.c

Function : SetScrollPosition

File: minisetupext.c
Description:
function to set the position of the Scroll bar
Input:
int Index, int DirFlg
Output:
void
Built on 16:20:15 10/01/14


ShowPostMenu in the minisetupext.c

Function : ShowPostMenu

File: minisetupext.c
Description:
Function to show menu
Input:
IN CHAR16 *Title, IN POSTMENU_TEMPLATE *MenuData, IN UINT32 menucount, OUT UINT16  *pSelection
Output:
STATUS
Built on 16:20:15 10/01/14


UIUpdateCallback in the minisetupext.c

Function : UIUpdateCallback

File: minisetupext.c
Description:
UI callback function for dynamic form updates.
Input:
IN Handle of Affected page
Output:
None
Built on 16:20:17 10/01/14


UpdategScreenParams in the minisetupext.c

Function : UpdategScreenParams

File: minisetupext.c
Description:
Verifies and corrects the gScreen params with the current uni strings
Input:
VOID
Output:
VOID
Built on 16:20:18 10/01/14


UpDisplayList in the minisetupext.c

Function : UpDisplayList

File: minisetupext.c
Description:
function to display the upside list
Input:
int Start, int End, int flag, int NumLines
Output:
void
Built on 16:20:18 10/01/14


minisetupext.h

Description:
Header file for FULL TSE specific minisetup entery and exit	funtionallies
Built on 16:20:20 10/01/14


Mouse.c

Description:
This file contains code to handle Mouse Operations

The following functions are used in the file: Mouse.c.

Function | Description
TSE_SOFTKBD_GetButtonStatus | Function to return the mouse button status if it is over softkbd
TSE_SOFTKBD_GetMouseCoordinates | Function to return the mouse co-ordinates if it is over softkbd
TSEGetactualScreentop | Function to retrun the actual Screen Top value
TSEGetCoordinates | Function to handle the mouse Destory
TSEIsMouseClickedonSoftkbd | Function to handle the mouse Clicked on Softkbd
TSEIsMouseOnSoftkbd | Function to return whether MousePointer is on softkbd or not
TSEMouseDestroy | Function to handle the mouse Destory
TSEMouseFreeze | Function to handle the mouse Destory
TSEMouseInit | Function to Initialize the mouse
TSEMouseReadInfo | Function to read the information using mouse
TSEMouseRefresh | Function to handle the mouse Refresh
TSEMouseStart | Function to handle the mouse Startd
TSEMouseStop | Function to handle the mouse stop
TSENumericSoftKbdExit | Function to destroy the numeric softkbd display
TSENumericSoftKbdInit | Function to display the numeric softkbd
TSEPrintableKeysSoftKbdExit | function to exit PrintableKeysSoftkbd layout and reset with default keyboard layout
TSEPrintableKeysSoftKbdInit | function to launch PrintableKeysSoftkbd layout
TSEResetPwdKeyboardLayout | function to exit TSEResetKeyboardLayout and reset with default keyboard layout
TSESetPwdKeyboardLayout | function to Initialize TSESetKeyboardLayout

Built on 16:20:20 10/01/14


TSE_SOFTKBD_GetButtonStatus in the Mouse.c

Function : TSE_SOFTKBD_GetButtonStatus

File: Mouse.c
Description:
Function to return the mouse button status if it is over softkbd
Input:
DXE_MOUSE_PROTOCOL *, INT32 *
Output:
EFI_STATUS
Built on 16:20:16 10/01/14


TSE_SOFTKBD_GetMouseCoordinates in the Mouse.c

Function : TSE_SOFTKBD_GetMouseCoordinates

File: Mouse.c
Description:
Function to return the mouse co-ordinates if it is over softkbd
Input:
DXE_MOUSE_PROTOCOL *, INT32 *, INT32 *, INT32 *
Output:
EFI_STATUS
Built on 16:20:16 10/01/14


TSEGetactualScreentop in the Mouse.c

Function : TSEGetactualScreentop

File: Mouse.c
Description:
Function to retrun the actual Screen Top value
Input:
None
Output:
INT32
Built on 16:20:16 10/01/14


TSEGetCoordinates in the Mouse.c

Function : TSEGetCoordinates

File: Mouse.c
Description:
Function to handle the mouse Destory
Input:
None
Output:
EFI_STATUS
Built on 16:20:16 10/01/14


TSEIsMouseClickedonSoftkbd in the Mouse.c

Function : TSEIsMouseClickedonSoftkbd

File: Mouse.c
Description:
Function to handle the mouse Clicked on Softkbd
Input:
None
Output:
None
Built on 16:20:16 10/01/14


TSEIsMouseOnSoftkbd in the Mouse.c

Function : TSEIsMouseOnSoftkbd

File: Mouse.c
Description:
Function to return whether MousePointer is on softkbd or not
Input:
None
Output:
TRUE/FALSE
Built on 16:20:16 10/01/14


TSEMouseDestroy in the Mouse.c

Function : TSEMouseDestroy

File: Mouse.c
Description:
Function to handle the mouse Destory
Input:
None
Output:
None
Built on 16:20:16 10/01/14


TSEMouseFreeze in the Mouse.c

Function : TSEMouseFreeze

File: Mouse.c
Description:
Function to handle the mouse Destory
Input:
None
Output:
None
Built on 16:20:16 10/01/14


TSEMouseInit in the Mouse.c

Function : TSEMouseInit

File: Mouse.c
Description:
Function to Initialize the mouse
Input:
None
Output:
VOID
Built on 16:20:16 10/01/14


TSEMouseReadInfo in the Mouse.c

Function : TSEMouseReadInfo

File: Mouse.c
Description:
Function to read the information using mouse
Input:
MOUSE_INFO *MouseInfo
Output:
EFI_STATUS
Built on 16:20:16 10/01/14


TSEMouseRefresh in the Mouse.c

Function : TSEMouseRefresh

File: Mouse.c
Description:
Function to handle the mouse Refresh
Input:
None
Output:
None
Built on 16:20:16 10/01/14


TSEMouseStart in the Mouse.c

Function : TSEMouseStart

File: Mouse.c
Description:
Function to handle the mouse Startd
Input:
None
Output:
None
Built on 16:20:16 10/01/14


TSEMouseStop in the Mouse.c

Function : TSEMouseStop

File: Mouse.c
Description:
Function to handle the mouse stop
Input:
None
Output:
None
Built on 16:20:16 10/01/14


TSENumericSoftKbdExit in the Mouse.c

Function : TSENumericSoftKbdExit

File: Mouse.c
Description:
Function to destroy the numeric softkbd display
Input:
None
Output:
INT32
Built on 16:20:16 10/01/14


TSENumericSoftKbdInit in the Mouse.c

Function : TSENumericSoftKbdInit

File: Mouse.c
Description:
Function to display the numeric softkbd
Input:
None
Output:
INT32
Built on 16:20:16 10/01/14


TSEPrintableKeysSoftKbdExit in the Mouse.c

Function : TSEPrintableKeysSoftKbdExit

File: Mouse.c
Description:
function to exit PrintableKeysSoftkbd layout and reset with default keyboard layout
Input:
VOID
Output:
VOID
Built on 16:20:16 10/01/14


TSEPrintableKeysSoftKbdInit in the Mouse.c

Function : TSEPrintableKeysSoftKbdInit

File: Mouse.c
Description:
function to launch PrintableKeysSoftkbd layout
Input:
VOID
Output:
VOID
Built on 16:20:16 10/01/14


TSEResetPwdKeyboardLayout in the Mouse.c

Function : TSEResetPwdKeyboardLayout

File: Mouse.c
Description:
function to exit TSEResetKeyboardLayout and reset with default keyboard layout
Input:
VOID
Output:
VOID
Built on 16:20:16 10/01/14


TSESetPwdKeyboardLayout in the Mouse.c

Function : TSESetPwdKeyboardLayout

File: Mouse.c
Description:
function to Initialize TSESetKeyboardLayout
Input:
VOID
Output:
VOID
Built on 16:20:16 10/01/14


MyDefs.h

Description:
Header file common definitions
Built on 16:20:20 10/01/14


notify.c

Description:
file contains code to support the notification functions

The following functions are used in the file: notify.c.

Function | Description
_DrvHealthNotifyFunction | Notification function for driver health protocol instal.
_UpdateGoPNotifyFunction | Notification function for driver health protocol instal.
ActivateApplication | function for the Active application operations.
ActivateInput | function for the active Input.
NotificationFunction | function to perform the notification operations.
RegisterNotification | It will create a notify event and register a notification.
UpdateGoPUgaDraw | function to update the Gop when controls comes to TSE.

Built on 16:20:20 10/01/14


_DrvHealthNotifyFunction in the notify.c

Function : _DrvHealthNotifyFunction

File: notify.c
Description:
Notification function for driver health protocol instal.
Input:
EFI_EVENT , VOID *
Output:
VOID
Built on 16:20:03 10/01/14


_UpdateGoPNotifyFunction in the notify.c

Function : _UpdateGoPNotifyFunction

File: notify.c
Description:
Notification function for driver health protocol instal.
Input:
EFI_EVENT , VOID *
Output:
VOID
Built on 16:20:04 10/01/14


ActivateApplication in the notify.c

Function : ActivateApplication

File: notify.c
Description:
function for the Active application operations.
Input:
void
Output:
void
Built on 16:20:04 10/01/14


ActivateInput in the notify.c

Function : ActivateInput

File: notify.c
Description:
function for the active Input.
Input:
void
Output:
void
Built on 16:20:04 10/01/14


NotificationFunction in the notify.c

Function : NotificationFunction

File: notify.c
Description:
function to perform the notification operations.
Input:
EFI_EVENT Event, NOTIFICATION_INFO *Context
Output:
void
Built on 16:20:12 10/01/14


RegisterNotification in the notify.c

Function : RegisterNotification

File: notify.c
Description:
It will create a notify event and register a notification.
Input:
VOID
Output:
Status
Built on 16:20:14 10/01/14


UpdateGoPUgaDraw in the notify.c

Function : UpdateGoPUgaDraw

File: notify.c
Description:
function to update the Gop when controls comes to TSE.
Input:
void
Output:
void
Built on 16:20:18 10/01/14


numeric.c

Description:
This file contains code to handle Label operations

The following functions are used in the file: numeric.c.

Function | Description
CheckforIncrementandDecreament | function used handle the Numeric controls Increment and Decreament operation
CheckForRange | function used to Check the range for the negative numbers and positive nubmers.
CheckForRangefromsetup | function used to Check the range for the negative numbers and positive nubmers from setup.
NumericCreate | function used for Numeric control Create, which uses the Edit functions.
NumericDestroy | function used to destroy Numeric controls, which uses the Edit functions.
NumericDraw | function used to draw the numeric controls
NumericGetControlHeight | Function to get label height.
NumericHandleAction | function used handle the Numeric controls
NumericHandleActionKey | function used handle the Numeric control keys
NumericInitialize | function used to Initialize the Numeric controls, which uses the Edit functions.
NumericSetAttributes | Function to set attributes.
NumericSetCallback | function used for setting Numeric control callback.
NumericSetDimensions | Function to set dimensions.
NumericSetFocus | Function to set focus.
NumericSetPosition | Function to set position.
NumSPrint | Function to print nums.

Built on 16:20:20 10/01/14


CheckforIncrementandDecreament in the numeric.c

Function : CheckforIncrementandDecreament

File: numeric.c
Description:
function used handle the Numeric controls Increment and Decreament operation
Input:
NUMERIC_MIN_MAX_BASE *Num, NUMERIC_DATA *numeric,  CONTROL_ACTION Action,UINT8 *bValueChanged
Output:
VOID
Built on 16:20:05 10/01/14


CheckForRange in the numeric.c

Function : CheckForRange

File: numeric.c
Description:
function used to Check the range for the negative numbers and positive nubmers.
Input:
NUMERIC_DATA *numeric, NUMERIC_VALUE_BASE *Num
Output:
BOOLEAN
Built on 16:20:05 10/01/14


CheckForRangefromsetup in the numeric.c

Function : CheckForRangefromsetup

File: numeric.c
Description:
function used to Check the range for the negative numbers and positive nubmers from setup.
Input:
NUMERIC_DATA *numeric, NUMERIC_VALUE_BASE *Num
Output:
BOOLEAN
Built on 16:20:05 10/01/14


NumericCreate in the numeric.c

Function : NumericCreate

File: numeric.c
Description:
function used for Numeric control Create, which uses the Edit functions.
Input:
NUMERIC_DATA **object
Output:
status
Built on 16:20:12 10/01/14


NumericDestroy in the numeric.c

Function : NumericDestroy

File: numeric.c
Description:
function used to destroy Numeric controls, which uses the Edit functions.
Input:
NUMERIC_DATA **object, BOOLEAN freeMem
Output:
status
Built on 16:20:12 10/01/14


NumericDraw in the numeric.c

Function : NumericDraw

File: numeric.c
Description:
function used to draw the numeric controls
Input:
NUMERIC_DATA **object
Output:
status
Built on 16:20:12 10/01/14


NumericGetControlHeight in the numeric.c

Function : NumericGetControlHeight

File: numeric.c
Description:
Function to get label height.
Input:
NUMERIC_DATA *numeric, UINT16 Width, UINT16 *height
Output:
status
Built on 16:20:12 10/01/14


NumericHandleAction in the numeric.c

Function : NumericHandleAction

File: numeric.c
Description:
function used handle the Numeric controls
Input:
NUMERIC_DATA *numeric, ACTION_DATA *Data
Output:
status
Built on 16:20:12 10/01/14


NumericHandleActionKey in the numeric.c

Function : NumericHandleActionKey

File: numeric.c
Description:
function used handle the Numeric control keys
Input:
NUMERIC_DATA *numeric, ACTION_DATA *Data
Output:
status
Built on 16:20:12 10/01/14


NumericInitialize in the numeric.c

Function : NumericInitialize

File: numeric.c
Description:
function used to Initialize the Numeric controls, which uses the Edit functions.
Input:
NUMERIC_DATA **object, VOID *data
Output:
status
Built on 16:20:12 10/01/14


NumericSetAttributes in the numeric.c

Function : NumericSetAttributes

File: numeric.c
Description:
Function to set attributes.
Input:
NUMERIC_DATA *numeric, UINT8 FGColor, UINT8 BGColor
Output:
status
Built on 16:20:12 10/01/14


NumericSetCallback in the numeric.c

Function : NumericSetCallback

File: numeric.c
Description:
function used for setting Numeric control callback.
Input:
NUMERIC_DATA *numeric, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
status
Built on 16:20:12 10/01/14


NumericSetDimensions in the numeric.c

Function : NumericSetDimensions

File: numeric.c
Description:
Function to set dimensions.
Input:
NUMERIC_DATA *numeric, UINT16 Width, UINT16 Height
Output:
status
Built on 16:20:12 10/01/14


NumericSetFocus in the numeric.c

Function : NumericSetFocus

File: numeric.c
Description:
Function to set focus.
Input:
NUMERIC_DATA *numeric, BOOLEAN focus
Output:
status
Built on 16:20:12 10/01/14


NumericSetPosition in the numeric.c

Function : NumericSetPosition

File: numeric.c
Description:
Function to set position.
Input:
NUMERIC_DATA *numeric, UINT16 Left, UINT16 Top
Output:
status
Built on 16:20:12 10/01/14


NumSPrint in the numeric.c

Function : NumSPrint

File: numeric.c
Description:
Function to print nums.
Input:
NUMERIC_DATA *numeric,NUMERIC_MIN_MAX_BASE Num
Output:
VOID
Built on 16:20:12 10/01/14


numeric.h

Description:
Header file for numeric control
Built on 16:20:20 10/01/14


object.c

Description:
This file contains code to handle Objects

The following functions are used in the file: object.c.

Function | Description
ObjectCreate | function to create an object
ObjectDestroy | function to Destroy an object
ObjectDraw | Function to draw an object
ObjectHandleAction | Function to handle object action
ObjectInitialize | Function to Initialize an object
ObjectSetCallback | Function to set object callback

Built on 16:20:21 10/01/14


ObjectCreate in the object.c

Function : ObjectCreate

File: object.c
Description:
function to create an object
Input:
OBJECT_DATA **object
Output:
status
Built on 16:20:12 10/01/14


ObjectDestroy in the object.c

Function : ObjectDestroy

File: object.c
Description:
function to Destroy an object
Input:
OBJECT_DATA **object, BOOLEAN freeMem
Output:
status
Built on 16:20:12 10/01/14


ObjectDraw in the object.c

Function : ObjectDraw

File: object.c
Description:
Function to draw an object
Input:
OBJECT_DATA *object
Output:
status
Built on 16:20:12 10/01/14


ObjectHandleAction in the object.c

Function : ObjectHandleAction

File: object.c
Description:
Function to handle object action
Input:
OBJECT_DATA *object, ACTION_DATA *Data
Output:
status
Built on 16:20:12 10/01/14


ObjectInitialize in the object.c

Function : ObjectInitialize

File: object.c
Description:
Function to Initialize an object
Input:
OBJECT_DATA *object, VOID *data
Output:
status
Built on 16:20:12 10/01/14


ObjectSetCallback in the object.c

Function : ObjectSetCallback

File: object.c
Description:
Function to set  object callback
Input:
OBJECT_DATA *object, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
status
Built on 16:20:12 10/01/14


object.h

Description:
Header file for code to handle Objects
Built on 16:20:21 10/01/14


ordlistbox.c

Description:
This file contains code to handle ordered list box controls

The following functions are used in the file: ordlistbox.c.

Function | Description
_OrdListBoxCallback | Ordered List Box callback function
_OrdListBoxShift | Function used in OrdListBoxHandleAction to handle actions
_OrdListGetSelection | Function to ordering the option in OrderList
_OrdListMultiLIneDraw | Function used to draw teh Ordered list box
DoOrdListCallBack | Call back function of ordered List Box
OrdListBoxCreate | function to Create a Order List Box, which uses the PopupSel Fucntions
OrdListBoxDestroy | function to Destroy a Order List Box, which uses the PopupSel Fucntions
OrdListBoxDraw | function to draw a ordered List Box
OrdListBoxHandleAction | Function to handle the ordered List Box actions
OrdListBoxSetAttributes | Function to set atributes for ordered List Box
OrdListBoxSetCallback | Function to set callback for ordered List Box
OrdListBoxSetDimensions | Function to set dimension for ordered List Box
OrdListBoxSetFocus | Function to set focus for ordered List Box
OrdListBoxSetPosition | Function to set position for ordered List Box
OrdListGetControlHeight | Function used get the hight of control
UpdateOrderlistcount | Function to update the orderlist count.

Built on 16:20:21 10/01/14


_OrdListBoxCallback in the ordlistbox.c

Function : _OrdListBoxCallback

File: ordlistbox.c
Description:
Ordered List Box callback function
Input:
ORD_LISTBOX_DATA *container, CONTROL_DATA *listbox, VOID *cookie
Output:
VOID
Built on 16:20:04 10/01/14


_OrdListBoxShift in the ordlistbox.c

Function : _OrdListBoxShift

File: ordlistbox.c
Description:
Function used in OrdListBoxHandleAction to handle actions
Input:
ORD_LISTBOX_DATA *listbox, UINT8 bShiftUp
Output:
status
Built on 16:20:04 10/01/14


_OrdListGetSelection in the ordlistbox.c

Function : _OrdListGetSelection

File: ordlistbox.c
Description:
Function to ordering the option in OrderList
Input:
ORD_LISTBOX_DATA *ordlist
Output:

Built on 16:20:04 10/01/14


_OrdListMultiLIneDraw in the ordlistbox.c

Function : _OrdListMultiLIneDraw

File: ordlistbox.c
Description:
Function used to draw teh Ordered list box
Input:
ORD_LISTBOX_DATA *OrdList
Output:
status
Built on 16:20:04 10/01/14


DoOrdListCallBack in the ordlistbox.c

Function : DoOrdListCallBack

File: ordlistbox.c
Description:
Call back function of ordered List Box
Input:
ORD_LISTBOX_DATA *listbox
Output:
status
Built on 16:20:06 10/01/14


OrdListBoxCreate in the ordlistbox.c

Function : OrdListBoxCreate

File: ordlistbox.c
Description:
function to Create a Order List Box, which uses the PopupSel Fucntions
Input:
ORD_LISTBOX_DATA **object
Output:
status
Built on 16:20:12 10/01/14


OrdListBoxDestroy in the ordlistbox.c

Function : OrdListBoxDestroy

File: ordlistbox.c
Description:
function to Destroy a Order List Box, which uses the PopupSel Fucntions
Input:
ORD_LISTBOX_DATA *listbox, BOOLEAN freeMem
Output:
status
Built on 16:20:12 10/01/14


OrdListBoxDraw in the ordlistbox.c

Function : OrdListBoxDraw

File: ordlistbox.c
Description:
function to draw a ordered List Box
Input:
ORD_LISTBOX_DATA *listbox
Output:
status
Built on 16:20:12 10/01/14


OrdListBoxHandleAction in the ordlistbox.c

Function : OrdListBoxHandleAction

File: ordlistbox.c
Description:
Function to handle the ordered List Box actions
Input:
ORD_LISTBOX_DATA *listbox, ACTION_DATA *Data
Output:
status
Built on 16:20:12 10/01/14


OrdListBoxSetAttributes in the ordlistbox.c

Function : OrdListBoxSetAttributes

File: ordlistbox.c
Description:
Function to set atributes for ordered List Box
Input:
ORD_LISTBOX_DATA *listbox, UINT8 FGColor, UINT8 BGColor
Output:
status
Built on 16:20:12 10/01/14


OrdListBoxSetCallback in the ordlistbox.c

Function : OrdListBoxSetCallback

File: ordlistbox.c
Description:
Function to set callback for ordered List Box
Input:
ORD_LISTBOX_DATA *listbox, OBJECT_DATA *container,   OBJECT_CALLBACK callback, VOID *cookie
Output:
status
Built on 16:20:12 10/01/14


OrdListBoxSetDimensions in the ordlistbox.c

Function : OrdListBoxSetDimensions

File: ordlistbox.c
Description:
Function to set dimension for ordered List Box
Input:
ORD_LISTBOX_DATA *listbox, UINT16 Width, UINT16 Height
Output:
status
Built on 16:20:12 10/01/14


OrdListBoxSetFocus in the ordlistbox.c

Function : OrdListBoxSetFocus

File: ordlistbox.c
Description:
Function to set focus for ordered List Box
Input:
ORD_LISTBOX_DATA *listbox, BOOLEAN focus
Output:
status
Built on 16:20:12 10/01/14


OrdListBoxSetPosition in the ordlistbox.c

Function : OrdListBoxSetPosition

File: ordlistbox.c
Description:
Function to set position for ordered List Box
Input:
ORD_LISTBOX_DATA *listbox, UINT16 Left, UINT16 Top
Output:
status
Built on 16:20:12 10/01/14


OrdListGetControlHeight in the ordlistbox.c

Function : OrdListGetControlHeight

File: ordlistbox.c
Description:
Function used get the hight of control
Input:
ORD_LISTBOX_DATA *OrdList, VOID* frame, UINT16 *height
Output:
status
Built on 16:20:12 10/01/14


UpdateOrderlistcount in the ordlistbox.c

Function : UpdateOrderlistcount

File: ordlistbox.c
Description:
Function to update the orderlist count.
Input:
UINT16 ItemCount
Output:
VOID
Built on 16:20:18 10/01/14


ordlistbox.h

Description:
Header file for code to handle ordered list box controls
Built on 16:20:21 10/01/14


page.c

Description:
This file contains code to handle page level operations

The following functions are used in the file: page.c.

Function | Description
_PageUpdateFrameStrings | function to update the title of the page
_PageUpdateHelp | function to update the page help
_PageUpdateMemo | function to update the memo
_PageUpdateNavStrings | function to update the title of the page
_PageUpdateSubtitle | function to update the subtitle of the page
_PageUpdateTitle | function to update the title of the page
HotclickESCaction | function to handle the left click on ESC in Navigation frame.
PageCreate | function to create a page
PageDestroy | function to destroy a page, which uses the HotKey Fucntions
PageDraw | function to draw a page with attributes
PageHandleAction | function to handle the page actions
PageInitialize | function to Initialize a page, which uses the Frame Fucntions
PrntScrnKeyHandleaction | Function to handle PrintScreenKeyto get screen image as BltBuffer and save as BMP file to a available filesystem
PrntScrnKeyNotification | PrntScrnKeyNotification Function handle PrntScrnKey action
UpdatePageFocusedItemHelp | function to update the Help in case of First Item focus set.

Built on 16:20:21 10/01/14


_PageUpdateFrameStrings in the page.c

Function : _PageUpdateFrameStrings

File: page.c
Description:
function to update the title of the page
Input:
PAGE_DATA *page
Output:
void
Built on 16:20:04 10/01/14


_PageUpdateHelp in the page.c

Function : _PageUpdateHelp

File: page.c
Description:
function to update the page help
Input:
PAGE_DATA *page
Output:
void
Built on 16:20:04 10/01/14


_PageUpdateMemo in the page.c

Function : _PageUpdateMemo

File: page.c
Description:
function to update the memo
Input:
PAGE_DATA *page, UINT16 frameNumber, VOID* handle, UINT16 token
Output:
void
Built on 16:20:04 10/01/14


_PageUpdateNavStrings in the page.c

Function : _PageUpdateNavStrings

File: page.c
Description:
function to update the title of the page
Input:
PAGE_DATA *page
Output:
void
Built on 16:20:04 10/01/14


_PageUpdateSubtitle in the page.c

Function : _PageUpdateSubtitle

File: page.c
Description:
function to update the subtitle of the page
Input:
PAGE_DATA *page
Output:
void
Built on 16:20:04 10/01/14


_PageUpdateTitle in the page.c

Function : _PageUpdateTitle

File: page.c
Description:
function to update the title of the page
Input:
PAGE_DATA *page
Output:
void
Built on 16:20:04 10/01/14


HotclickESCaction in the page.c

Function : HotclickESCaction

File: page.c
Description:
function to handle the left click on ESC in Navigation frame.
Input:
VOID
Output:
VOID
Built on 16:20:09 10/01/14


PageCreate in the page.c

Function : PageCreate

File: page.c
Description:
function to create a page
Input:
PAGE_DATA **object
Output:
status
Built on 16:20:12 10/01/14


PageDestroy in the page.c

Function : PageDestroy

File: page.c
Description:
function to destroy a page, which uses the HotKey Fucntions
Input:
PAGE_DATA *page, BOOLEAN freeMem
Output:
status
Built on 16:20:12 10/01/14


PageDraw in the page.c

Function : PageDraw

File: page.c
Description:
function to draw a page with attributes
Input:
PAGE_DATA *page
Output:
status
Built on 16:20:12 10/01/14


PageHandleAction in the page.c

Function : PageHandleAction

File: page.c
Description:
function to handle the page actions
Input:
PAGE_DATA *page, ACTION_DATA *action
Output:
status
Built on 16:20:12 10/01/14


PageInitialize in the page.c

Function : PageInitialize

File: page.c
Description:
function to Initialize a page, which uses the Frame Fucntions
Input:
PAGE_DATA *page, PAGE_INFO *data
Output:
status
Built on 16:20:12 10/01/14


PrntScrnKeyHandleaction in the page.c

Function : PrntScrnKeyHandleaction

File: page.c
Description:
Function to handle PrintScreenKeyto get screen image as BltBuffer and save as BMP file to a available filesystem
Input:
VOID
Output:
EFI_STATUS
Built on 16:20:13 10/01/14


PrntScrnKeyNotification in the page.c

Function : PrntScrnKeyNotification

File: page.c
Description:
PrntScrnKeyNotification Function handle PrntScrnKey action
Input:
CHAR16 *
Output:
EFI_STATUS
Built on 16:20:13 10/01/14


UpdatePageFocusedItemHelp in the page.c

Function : UpdatePageFocusedItemHelp

File: page.c
Description:
function to update the Help in case of First Item focus set.
Input:
PAGE_DATA *page
Output:
void
Built on 16:20:18 10/01/14


page.h

Description:
Header file for code to handle page level operations
Built on 16:20:21 10/01/14


Parse.c

Description:

The following functions are used in the file: Parse.c.

Function | Description
_AddFormSetVariable | Parameter: Return value:
_AddHpkControls | Add Control Setup Data Parameter: Return value: UINTN
_AdvAddControlToList | Add control info the control list
_AdvAddPageToList | Add page into to the page list
_CleanVarKeyTable | Clean VarKey Table Parameter: None Return value: None
_GetControlDevicePathId | Get Control DevicePathId Parameter: Return value: UINT16
_GetControlKeyToken | Get ControlKey Token Parameter: None Return value: None
_GetHelpToken | Get Control Question Help Token Parameter: Return value: UINT16
_GetPageIdIndex | Get Page ID index Parameter: Return value: UINT16
_GetPageNumFromFormID | Get Page Id from Form Id Parameter: Return value: UINT16
_GetPageParent | Get Parent Page PageID Parameter: Return value: UINT16
_GetQuestionToken | Get Control Question Prompt Parameter: Return value: UINT16
_GetSubFormCount | Count the subform and Ref inside the formset Parameter: Return value: UINTN
_GetVarNumFromVarID | Get Variable Index Parameter: Return value: UINT32
_InitFormsetLinks | Init Formset Links Parameter: Return value:
_InvalidateExistingPage | Parameter: Return value:
_IsVarGuidPresent | Check if the Variable Guid is already defined Parameter: Return value: UINT8
_ReplacePageWithNewPage | Parameter: Return value:
_UpdateDefaults | Get Control Defaults Parameter: EFI_HII_HANDLE Handle, VOID *Data, UINT16 *size, VOID *Failsafe, VOID *Optimal, DEFAULT_VALUE **defaultValue, struct _CONTROL_FLAGS *Control_Flags, VOID *ConditionalPtr Return value: UINT8
AddControlToList | Parameter: CONTROL_INFO *ControlInfo UINT32 ControlSize Return value: EFI_STATUS EFI_SUCCESS
AddPageIdToList | Parameter: PAGE_ID_INFO *NewPageIdInfo Return value: EFI_STATUS - EFI_SUCCESS - EFI_OUT_OF_RESOURCES -
AddPageToList | Parameter: PAGE_INFO *NewPageInfo UINT32 PageSize Return value: EFI_STATUS EFI_SUCCESS
AddVariableToList | Parameter: Return value: EFI_STATUS EFI_SUCCESS - EFI_OUT_OF_RESOURCES -
CreateEventforIFR | To create Event if any control has RefreshID opcode Parameter: CONTROL_INFO* Return value: EFI_STATUS
CreatePage | Parameter: PAGE_INFO **PageInfo UINT32 *AllocatedSize UINT32 *Offset VOID *Buff UINT32 BuffSize Return value: EFI_STATUS EFI_SUCCESS - EFI_OUT_OF_RESOURCES -
EvaluateReadWrite | Evaluates read write conditions Parameter: UINT8 *, CONTROL_INFO *, EFI_HII_VALUE * Return value: VOID
GetDefaultValue | Get Default Value
GetValueFromOpCode | Gets the value from the opcode Parameter: EFI_IFR_OP_HEADER *, EFI_HII_VALUE *, INTN Return value: VOID
ParseForm | Parse the HII Package for the Form Pack and parse the FormPack Parameter: IFRPackage - The Header of the Package to parse. Return value: EFI_STATUS - Return the Status of the Parsing
RefreshGroupOnCallBack | Callback function which refreshes Controls of a Group which are set with refresh Id Parameter: EFI_EVENT Event, VOID *Context Return value:

The following data structures are used in the file: Parse.c.

Variable | Description
FormSetLinks |
PageLink |
PVAR_KEY_TABLE |

Built on 16:20:21 10/01/14


_AddFormSetVariable in the Parse.c

Function : _AddFormSetVariable

File: Parse.c
Description:

Parameter:

Return value:
Built on 16:20:03 10/01/14


_AddHpkControls in the Parse.c

Function : _AddHpkControls

File: Parse.c
Description:
Add Control Setup Data

Parameter:

Return value: UINTN
Built on 16:20:03 10/01/14


_AdvAddControlToList in the Parse.c

Function : _AdvAddControlToList

File: Parse.c
Description:
Add control info the control list
Input:
CONTROL_INFO *ControlInfo - Pointer to the CONTROL_INFO
UINT32 ControlSize - Size the control info
Output:
UINT32 offset - Return the control list offset
Built on 16:20:03 10/01/14


_AdvAddPageToList in the Parse.c

Function : _AdvAddPageToList

File: Parse.c
Description:
Add page into to the page list
Input:
PAGE_INFO *NewPageInfo - Pointer to new page info structure
UINT32 PageSize - Page into size
Output:
EFI_STATUS status - EFI_SUCCESS if successful, else EFI_ERROR
Built on 16:20:03 10/01/14


_CleanVarKeyTable in the Parse.c

Function : _CleanVarKeyTable

File: Parse.c
Description:
Clean VarKey Table

Parameter:    None

Return value: None
Built on 16:20:03 10/01/14


_GetControlDevicePathId in the Parse.c

Function : _GetControlDevicePathId

File: Parse.c
Description:
Get Control DevicePathId

Parameter:

Return value: UINT16
Built on 16:20:03 10/01/14


_GetControlKeyToken in the Parse.c

Function : _GetControlKeyToken

File: Parse.c
Description:
Get ControlKey Token

Parameter:    None

Return value: None
Built on 16:20:03 10/01/14


_GetHelpToken in the Parse.c

Function : _GetHelpToken

File: Parse.c
Description:
Get Control Question Help Token

Parameter:

Return value: UINT16
Built on 16:20:04 10/01/14


_GetPageIdIndex in the Parse.c

Function : _GetPageIdIndex

File: Parse.c
Description:
Get Page ID index

Parameter:

Return value: UINT16
Built on 16:20:04 10/01/14


_GetPageNumFromFormID in the Parse.c

Function : _GetPageNumFromFormID

File: Parse.c
Description:
Get Page Id from Form Id

Parameter:

Return value: UINT16
Built on 16:20:04 10/01/14


_GetPageParent in the Parse.c

Function : _GetPageParent

File: Parse.c
Description:
Get Parent Page PageID

Parameter:

Return value: UINT16
Built on 16:20:04 10/01/14


_GetQuestionToken in the Parse.c

Function : _GetQuestionToken

File: Parse.c
Description:
Get Control Question Prompt

Parameter:

Return value: UINT16
Built on 16:20:04 10/01/14


_GetSubFormCount in the Parse.c

Function : _GetSubFormCount

File: Parse.c
Description:
Count the subform and Ref inside the formset

Parameter:

Return value: UINTN
Built on 16:20:04 10/01/14


_GetVarNumFromVarID in the Parse.c

Function : _GetVarNumFromVarID

File: Parse.c
Description:
Get Variable Index

Parameter:

Return value: UINT32
Built on 16:20:04 10/01/14


_InitFormsetLinks in the Parse.c

Function : _InitFormsetLinks

File: Parse.c
Description:
Init Formset Links

Parameter:

Return value:
Built on 16:20:04 10/01/14


_InvalidateExistingPage in the Parse.c

Function : _InvalidateExistingPage

File: Parse.c
Description:

Parameter:

Return value:
Built on 16:20:04 10/01/14


_IsVarGuidPresent in the Parse.c

Function : _IsVarGuidPresent

File: Parse.c
Description:
Check if the Variable Guid is already defined

Parameter:

Return value: UINT8
Built on 16:20:04 10/01/14


_ReplacePageWithNewPage in the Parse.c

Function : _ReplacePageWithNewPage

File: Parse.c
Description:

Parameter:

Return value:
Built on 16:20:04 10/01/14


_UpdateDefaults in the Parse.c

Function : _UpdateDefaults

File: Parse.c
Description:
Get Control Defaults

Parameter:    EFI_HII_HANDLE Handle,
VOID *Data,
UINT16 *size,
VOID *Failsafe,
VOID *Optimal,
DEFAULT_VALUE **defaultValue,
struct _CONTROL_FLAGS *Control_Flags,
VOID *ConditionalPtr

Return value: UINT8
Built on 16:20:04 10/01/14


AddControlToList in the Parse.c

Function : AddControlToList

File: Parse.c
Description:

Parameter:     CONTROL_INFO *ControlInfo
 UINT32 ControlSize

Return value:  EFI_STATUS
                  EFI_SUCCESS
Built on 16:20:05 10/01/14


AddPageIdToList in the Parse.c

Function : AddPageIdToList

File: Parse.c
Description:

Parameter:   PAGE_ID_INFO *NewPageIdInfo

Return value: EFI_STATUS -
                  EFI_SUCCESS -
                  EFI_OUT_OF_RESOURCES -
Built on 16:20:05 10/01/14


AddPageToList in the Parse.c

Function : AddPageToList

File: Parse.c
Description:

Parameter:     PAGE_INFO *NewPageInfo
 UINT32 PageSize

Return value:  EFI_STATUS
                  EFI_SUCCESS
Built on 16:20:05 10/01/14


AddVariableToList in the Parse.c

Function : AddVariableToList

File: Parse.c
Description:

Parameter:
Return value: EFI_STATUS
            EFI_SUCCESS -
            EFI_OUT_OF_RESOURCES -
Built on 16:20:05 10/01/14


CreateEventforIFR in the Parse.c

Function : CreateEventforIFR

File: Parse.c
Description:
To create Event if any control has RefreshID opcode
Parameter:   CONTROL_INFO*

Return value:	EFI_STATUS
Built on 16:20:06 10/01/14


CreatePage in the Parse.c

Function : CreatePage

File: Parse.c
Description:

Parameter:     PAGE_INFO **PageInfo
 UINT32 *AllocatedSize
 UINT32 *Offset
 VOID *Buff
 UINT32 BuffSize

Return value: EFI_STATUS
            EFI_SUCCESS -
            EFI_OUT_OF_RESOURCES -
Built on 16:20:06 10/01/14


EvaluateReadWrite in the Parse.c

Function : EvaluateReadWrite

File: Parse.c
Description:
Evaluates read write conditions

Parameter:    UINT8 *,
CONTROL_INFO *,
EFI_HII_VALUE *

Return value: VOID
Built on 16:20:07 10/01/14


FormSetLinks in the Parse.c

Variable : FormSetLinks

File: Parse.c
Fields:

Name | Type | Description
PageCount | UINT16
PageLink | 20 | ] PageLink

Description:
Built on 16:20:07 10/01/14


GetDefaultValue in the Parse.c

Function : GetDefaultValue

File: Parse.c
Description:
Get Default Value
Input:
UINT8 Type
        EFI_IFR_TYPE_VALUE *Value
            UINT16 *Size - [IN/OUT] parameter - IN for the type
                    EFI_IFR_TYPE_BUFFER. For all other types,
                    as OUT parameter
            VOID *DefValue
Output:
Void
Built on 16:20:08 10/01/14


GetValueFromOpCode in the Parse.c

Function : GetValueFromOpCode

File: Parse.c
Description:
Gets the value from the opcode

Parameter:    EFI_IFR_OP_HEADER *,
EFI_HII_VALUE *,
INTN

Return value: VOID
Built on 16:20:08 10/01/14


PageLink in the Parse.c

Variable : PageLink

File: Parse.c
Fields:

Name | Type | Description
FormID | UINT16
ParentPageID | UINT16
PageNum | UINT16

Description:
Built on 16:20:12 10/01/14


ParseForm in the Parse.c

Function : ParseForm

File: Parse.c
Description:
Parse the HII Package for the Form Pack and parse the FormPack

Parameter:    IFRPackage - The Header of the Package to parse.

Return value: EFI_STATUS - Return the Status of the Parsing
Built on 16:20:13 10/01/14


PVAR_KEY_TABLE in the Parse.c

Variable : PVAR_KEY_TABLE

File: Parse.c
Fields:

Name | Type | Description
VarId | UINT16
Index | PageLink
Handle | EFI_HII_HANDLE
*Next | struct | _VAR_KEY_TABLE

Description:
Built on 16:20:14 10/01/14


RefreshGroupOnCallBack in the Parse.c

Function : RefreshGroupOnCallBack

File: Parse.c
Description:
Callback function which refreshes Controls of a Group which are
        set with refresh Id

Parameter:   EFI_EVENT Event, VOID *Context

Return value:
Built on 16:20:14 10/01/14


password.c

Description:
This file contains code to handle password operations

The following functions are used in the file: password.c.

Function | Description
PasswordAuthenticateLocal | function to Check the authentication of the password
PasswordCheckInstalledLocal | function to Check the password type
PasswordUpdateLocal | function to ubdate the password

Built on 16:20:21 10/01/14


PasswordAuthenticateLocal in the password.c

Function : PasswordAuthenticateLocal

File: password.c
Description:
function to Check the authentication of the password
Input:
CHAR16 *Password
Output:
password type
Built on 16:20:13 10/01/14


PasswordCheckInstalledLocal in the password.c

Function : PasswordCheckInstalledLocal

File: password.c
Description:
function to Check the password type
Input:
void
Output:
void
Built on 16:20:13 10/01/14


PasswordUpdateLocal in the password.c

Function : PasswordUpdateLocal

File: password.c
Description:
function to ubdate the password
Input:
CHAR16 *Password, , UINTN Size
Output:
updated password
Built on 16:20:13 10/01/14


password.h

Description:
Header file for code to handle password operations
Built on 16:20:21 10/01/14


PasswordEncode.c

Description:
This file contains code to handle password encoding feature

The following functions are used in the file: PasswordEncode.c.

Function | Description
Hash | Allows creating a Hash of an arbitrary message digest using one or more Hash algorithms
IsPasswordSupportNonCaseSensitive | Returns SETUP_PASSWORD_NON_CASE_SENSITIVE token value
PasswordEncodeLocal | Encodes the input string

Built on 16:20:21 10/01/14


Hash in the PasswordEncode.c

Function : Hash

File: PasswordEncode.c
Description:
Allows creating a Hash of an arbitrary message digest using one or more Hash algorithms
Input:
This          Pointer to the AMI_DIGITAL_SIGNATURE_PROTOCOL instance.
HashAlgorithm Points to the EFI_GUID which identifies the algorithm to use.
num_elem      Number of blocks to be passed via next argument:addr[]
addr[]        Pointer to array of UINT8* addresses of data blocks to be hashed
len           Pointer to array of integers containing length of each block listed by addr[]
Hash          Holds the resulting Hash computed from the message.
Output:
EFI_SUCCESS           Hash returned successfully.
EFI_INVALID_PARAMETER Message or Hash is NULL
EFI_UNSUPPORTED       The algorithm specified by HashAlgorithm is not supported by this
             driver. Or extend is TRUE and the algorithm doesn't support extending the Hash.
Built on 16:20:09 10/01/14


IsPasswordSupportNonCaseSensitive in the PasswordEncode.c

Function : IsPasswordSupportNonCaseSensitive

File: PasswordEncode.c
Description:
Returns SETUP_PASSWORD_NON_CASE_SENSITIVE token value
Input:
void
Output:
BOOLEAN
Built on 16:20:10 10/01/14


PasswordEncodeLocal in the PasswordEncode.c

Function : PasswordEncodeLocal

File: PasswordEncode.c
Description:
Encodes the input string
Input:
Password : Password array to be encrypted. Encryped
password is returned in the same array.
MaxSize : Max size of Password
Output:
VOID
Built on 16:20:13 10/01/14


PasswordEncode.h

Description:
Header file for code to handle password operations
Built on 16:20:21 10/01/14


pcx.h

Description:
Header file for pcx image format related code
Built on 16:20:21 10/01/14


pcxc.c

Description:
This file contains code for pcx image handling

The following functions are used in the file: pcxc.c.

Function | Description
Decode_Line | This routine will first Check whether the PCX image is 16 color or 256 color and then Decode the PCX image data one line at a time and put the decoded data in a One Line Buffer.
DecodePCX | This routine will call functions to Decode both 16 and 256 color PCX images of version 5 (with palette information) and fill the Screen Buffer.
GetPCXDimensions | Get the dimensions (Width and Height of the PCX Image).
Output_Line | This routine is used to map the decoded data to the palette and fill the global Screen Buffer.
PCX_Init | This routine is used to fill the PCX_INFO structure.

Built on 16:20:21 10/01/14


Decode_Line in the pcxc.c

Function : Decode_Line

File: pcxc.c
Description:
This routine will first Check whether the PCX image is 16
            color or 256 color and then Decode the PCX image data one
            line at a time and put the decoded data in a One Line Buffer.
Input:
WORD *wCountX - Pointer to the index of the image data after 128 byte header
            PCX_INFO *pPCX_INFO - Pointer to PCX_INFO structure
            BYTE *pbOneLineBuffer - Pointer to the buffer that holds one line of decoded data.
Output:
None
Built on 16:20:06 10/01/14


DecodePCX in the pcxc.c

Function : DecodePCX

File: pcxc.c
Description:
This routine will call functions to Decode both 16 and 256
            color PCX images of version 5 (with palette information) and
            fill the Screen Buffer.
Input:
BYTE * pbyPCXInputData - Pointer that gives the memory location
                where the PCX input data is available.
            BYTE * pbyPCXOutputData - Pointer to the buffer that will
                receive the decoded PCX image
            DWORD dwPCXImageSize - Size of the PCX Image
Output:
BOOL - TRUE/FALSE
Built on 16:20:06 10/01/14


GetPCXDimensions in the pcxc.c

Function : GetPCXDimensions

File: pcxc.c
Description:
Get the dimensions (Width and Height of the PCX Image).
Input:
BYTE * pbyPCXImageData - Pointer to the buffer that contains the PCX data
            UINT32 * pun32Width - Pointer to the UINT32 variable that will
                receive the Width of the PCX Image
            UINT32 * pun32Height - Pointer to the UINT32 variable that
                will receive the Height of the PCX Image
Output:
BOOL - TRUE/FALSE
Built on 16:20:08 10/01/14


Output_Line in the pcxc.c

Function : Output_Line

File: pcxc.c
Description:
This routine is used to map the decoded data to the palette
            and fill the global Screen Buffer.
Input:
WORD wTop - This variable gives the position from where a
                line should start in the Screen Buffer
            PCX_INFO *pPCX_INFO - Pointer to PCX_INFO structure
            BYTE *pbOneLineBuffer - Pointer to the buffer that holds one line of decoded data.
Output:
None
Built on 16:20:12 10/01/14


PCX_Init in the pcxc.c

Function : PCX_Init

File: pcxc.c
Description:
This routine is used to fill the PCX_INFO structure.
Input:
BYTE * pbyPCXImage - Pointer that gives the memory location
                where the PCX input data is available.
            PCX_INFO *pPCX_INFO	- Pointer to PCX_INFO structure
            DWORD dwPCXImageSize - Size of the PCX Image
Output:
BOOL - TRUE/FALSE
Built on 16:20:13 10/01/14


png.c

Description:
This file contains code for png image handling

The following functions are used in the file: png.c.

Function | Description
ConvertPNGToBlt | Decode the PNG and store the Output in RGB format
Decode | Read all the PNG chunks and do convert the png format to RGB format.
Filter8 |
FindImageSize | To find the PNG image size
Header_Decode | To Store the header values in the PngHeader variables
Initialize | to Initialize the PngImageDecoder member variables
Output | To create the Output values in the RGB format.
Paeth |
Palette_Decode | To store the PLTE data values in PngPalette variables
PngGetUnsignedInt | To get decimal values
PrepareOutput | To validate the colorType and bitDepth combination and prepare the Output data
ReadChunk | To Read all the chunk data
ShiftTwoLineBuf |
Transparency_Decode | To store the tRNS data values in PngPalette variables

Built on 16:20:21 10/01/14


ConvertPNGToBlt in the png.c

Function : ConvertPNGToBlt

File: png.c
Description:
Decode the PNG and store the Output in RGB format
Input:
IN VOID *PNGImage, IN UINT32 PNGImageSize, IN OUT VOID **Blt,
        IN OUT UINTN *BltSize, OUT UINT32 *PixelHeight, OUT UINT32 *PixelWidth
Output:
EFI_STATUS
Built on 16:20:06 10/01/14


Decode in the png.c

Function : Decode

File: png.c
Description:
Read all the PNG chunks and do convert the png format to RGB format.
Input:
unsigned char *PNGImage,UINT32 PNGImageSize
Output:
int
Built on 16:20:06 10/01/14


Filter8 in the png.c

Function : Filter8

File: png.c
Description:
Input:
unsigned char curLine[],unsigned char prvLine[],int x,int y,int unitLng,int filter
Output:
none
Built on 16:20:07 10/01/14


FindImageSize in the png.c

Function : FindImageSize

File: png.c
Description:
To find the PNG image size
Input:
none
Output:
unsigned int
Built on 16:20:07 10/01/14


Header_Decode in the png.c

Function : Header_Decode

File: png.c
Description:
To Store the header values in the PngHeader variables
Input:
unsigned char dat[]
Output:
none
Built on 16:20:09 10/01/14


Initialize in the png.c

Function : Initialize

File: png.c
Description:
to Initialize the PngImageDecoder member variables
Input:
none
Output:
none
Built on 16:20:10 10/01/14


Output in the png.c

Function : Output

File: png.c
Description:
To create the Output values in the RGB format.
Input:
unsigned char dat
Output:
int
Built on 16:20:12 10/01/14


Paeth in the png.c

Function : Paeth

File: png.c
Description:
Input:
unsigned int ua,unsigned int ub,unsigned int uc
Output:
unsigned char
Built on 16:20:12 10/01/14


Palette_Decode in the png.c

Function : Palette_Decode

File: png.c
Description:
To store the PLTE data values in PngPalette variables
Input:
unsigned length,unsigned char dat[]
Output:
int
Built on 16:20:12 10/01/14


PngGetUnsignedInt in the png.c

Function : PngGetUnsignedInt

File: png.c
Description:
To get decimal values
Input:
const unsigned char dat[]
Output:
unsigned int
Built on 16:20:13 10/01/14


PrepareOutput in the png.c

Function : PrepareOutput

File: png.c
Description:
To validate the colorType and bitDepth combination and prepare the Output data
Input:
none
Output:
int
Built on 16:20:13 10/01/14


ReadChunk in the png.c

Function : ReadChunk

File: png.c
Description:
To Read all the chunk data
Input:
unsigned &length,unsigned char *&buf,unsigned &chunkType,unsigned &crc
Output:
int
Built on 16:20:14 10/01/14


ShiftTwoLineBuf in the png.c

Function : ShiftTwoLineBuf

File: png.c
Description:
Input:
none
Output:
none
Built on 16:20:15 10/01/14


Transparency_Decode in the png.c

Function : Transparency_Decode

File: png.c
Description:
To store the tRNS data values in PngPalette variables
Input:
unsigned int length,unsigned char dat[],unsigned int colorType
Output:
int
Built on 16:20:16 10/01/14


png.h

Description:
Header file for png image format related code
Built on 16:20:21 10/01/14


pnguncmp.c

Description:
This file contains code for pcx image handling

The following functions are used in the file: pnguncmp.c.

Function | Description
DecodeDynamicHuffmanCode | Decodeing the Dynamic Huffman Code
DeleteHuffmanTree | Deleting the created Trees
GetBackwardDistance | To get the Backward Distance
GetCopyLength | To Get the correct Copy Length
GetNextBit | To get the Next Bit
GetNextMultiBit | To get the Next multiple Bits.
MakeDynamicHuffmanCode | To make the Dynamic Huffman Code
MakeFixedHuffmanCode | To make the fixed huffman code
MakeHuffmanTree | To create the huffman tree
Uncompress | Used to Uncompress the Image data and to convert the RGB format.

Built on 16:20:21 10/01/14


DecodeDynamicHuffmanCode in the pnguncmp.c

Function : DecodeDynamicHuffmanCode

File: pnguncmp.c
Description:
Decodeing the Dynamic Huffman Code
Input:
unsigned int &hLit,unsigned int &hDist,unsigned int &hCLen,
        unsigned int *&hLengthLiteral,unsigned int *&hCodeLiteral,
        unsigned int *&hLengthDist,unsigned int *&hCodeDist,
        unsigned int hLengthBuf[322],unsigned int hCodeBuf[322],
        const unsigned char dat[],unsigned int &bytePtr,unsigned int &bitPtr
Output:
int
Built on 16:20:06 10/01/14


DeleteHuffmanTree in the pnguncmp.c

Function : DeleteHuffmanTree

File: pnguncmp.c
Description:
Deleting the created Trees
Input:
PngHuffmanTree *node
Output:
String size
Built on 16:20:06 10/01/14


GetBackwardDistance in the pnguncmp.c

Function : GetBackwardDistance

File: pnguncmp.c
Description:
To get the Backward Distance
Input:
unsigned distCode,unsigned char dat[],unsigned &bytePtr,unsigned &bitPtr
Output:
unsigned int
Built on 16:20:08 10/01/14


GetCopyLength in the pnguncmp.c

Function : GetCopyLength

File: pnguncmp.c
Description:
To Get the correct Copy Length
Input:
unsigned value,unsigned char dat[],unsigned &bytePtr,unsigned &bitPtr
Output:
unsigned int
Built on 16:20:08 10/01/14


GetNextBit in the pnguncmp.c

Function : GetNextBit

File: pnguncmp.c
Description:
To get the Next Bit
Input:
const unsigned char dat[], unsigned *bytePtr, unsigned *bitPtr
Output:
unsigned int
Built on 16:20:08 10/01/14


GetNextMultiBit in the pnguncmp.c

Function : GetNextMultiBit

File: pnguncmp.c
Description:
To get the Next multiple Bits.
Input:
const unsigned char dat[], unsigned *bytePtr, unsigned *bitPtr, unsigned n
Output:
unsigned int
Built on 16:20:08 10/01/14


MakeDynamicHuffmanCode in the pnguncmp.c

Function : MakeDynamicHuffmanCode

File: pnguncmp.c
Description:
To make the Dynamic Huffman Code
Input:
unsigned hLength[],unsigned hCode[],unsigned nLng,unsigned lng[]
Output:
none
Built on 16:20:11 10/01/14


MakeFixedHuffmanCode in the pnguncmp.c

Function : MakeFixedHuffmanCode

File: pnguncmp.c
Description:
To make the fixed huffman code
Input:
unsigned hLength[288],unsigned hCode[288]
Output:
none
Built on 16:20:11 10/01/14


MakeHuffmanTree in the pnguncmp.c

Function : MakeHuffmanTree

File: pnguncmp.c
Description:
To create the huffman tree
Input:
unsigned n,unsigned hLength[],unsigned hCode[]
Output:
PngHuffmanTree
Built on 16:20:11 10/01/14


Uncompress in the pnguncmp.c

Function : Uncompress

File: pnguncmp.c
Description:
Used to Uncompress the Image data and to convert the RGB format.
Input:
unsigned length,unsigned char dat[]
Output:
int
Built on 16:20:17 10/01/14


popup.c

Description:
This file contains code to handle popup operations

The following functions are used in the file: popup.c.

Function | Description
GetLineCount | function to get line count and max width.
PopupCreate | this function uses the create function of control and creates the Popup menu
PopupDestroy | this function uses the destroy function of control and destroys the Popup menu
PopupDraw | function to draw popup menu with attributes
PopupDrawString | function to draw string in a popup menu with attributes
PopupGetControlHight | Function unsuppored.
PopupHandleAction | Function to handle the Popup Edit actions
PopupInitialize | this function uses the Initialize function of control and initializes the Popup menu
PopupSetAttributes | Function to set the dimentions of the editable popup menu
PopupSetCallback | Function to set the Popup callback
PopupSetDimensions | Function to set the dimentions of the editable popup menu
PopupSetFocus | Function to set focus
PopupSetPosition | Function to set focus

Built on 16:20:21 10/01/14


GetLineCount in the popup.c

Function : GetLineCount

File: popup.c
Description:
function to get line count and max width.
Input:
CHAR16 *line, UINT8 *Width
Output:
UINTN
Built on 16:20:08 10/01/14


PopupCreate in the popup.c

Function : PopupCreate

File: popup.c
Description:
this function uses the create function of control
            and creates the Popup menu
Input:
POPUP_DATA **object
Output:
status
Built on 16:20:13 10/01/14


PopupDestroy in the popup.c

Function : PopupDestroy

File: popup.c
Description:
this function uses the destroy function of control
            and destroys the Popup menu
Input:
POPUP_DATA *popup, BOOLEAN freeMem
Output:
status
Built on 16:20:13 10/01/14


PopupDraw in the popup.c

Function : PopupDraw

File: popup.c
Description:
function to draw popup menu with attributes
Input:
POPUP_DATA *popup
Output:
status
Built on 16:20:13 10/01/14


PopupDrawString in the popup.c

Function : PopupDrawString

File: popup.c
Description:
function to draw string in a popup menu with attributes
Input:
POPUP_DATA *popup, CHAR16 *Str,UINT16 Top
Output:
void
Built on 16:20:13 10/01/14


PopupGetControlHight in the popup.c

Function : PopupGetControlHight

File: popup.c
Description:
Function unsuppored.
Input:
VOID *object,VOID *frame, UINT16 *height
Output:
status
Built on 16:20:13 10/01/14


PopupHandleAction in the popup.c

Function : PopupHandleAction

File: popup.c
Description:
Function to handle the Popup Edit actions
Input:
POPUP_DATA *popup, ACTION_DATA *Data
Output:
status
Built on 16:20:13 10/01/14


PopupInitialize in the popup.c

Function : PopupInitialize

File: popup.c
Description:
this function uses the Initialize function of control
            and initializes the Popup menu
Input:
POPUP_DATA *popup, VOID *data
Output:
status
Built on 16:20:13 10/01/14


PopupSetAttributes in the popup.c

Function : PopupSetAttributes

File: popup.c
Description:
Function to set the dimentions of the editable popup menu
Input:
POPUP_DATA *popup, UINT8 FGColor, UINT8 BGColor
Output:
status
Built on 16:20:13 10/01/14


PopupSetCallback in the popup.c

Function : PopupSetCallback

File: popup.c
Description:
Function to set the Popup callback
Input:
POPUP_DATA *popup, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
STATUS
Built on 16:20:13 10/01/14


PopupSetDimensions in the popup.c

Function : PopupSetDimensions

File: popup.c
Description:
Function to set the dimentions of the editable popup menu
Input:
POPUP_DATA *popup, UINT16 Width, UINT16 Height
Output:
status
Built on 16:20:13 10/01/14


PopupSetFocus in the popup.c

Function : PopupSetFocus

File: popup.c
Description:
Function to set focus
Input:
POPUP_DATA *popup, BOOLEAN focus
Output:
Status
Built on 16:20:13 10/01/14


PopupSetPosition in the popup.c

Function : PopupSetPosition

File: popup.c
Description:
Function to set focus
Input:
POPUP_DATA *popup, UINT16 Left, UINT16 Top
Output:
Status
Built on 16:20:13 10/01/14


popup.h

Description:
Header file for code to handle popup operations
Built on 16:20:21 10/01/14


PopupEdit.c

Description:
This file contains code to handle Popup Edit operations

The following functions are used in the file: PopupEdit.c.

Function | Description
PopupEditCreate | this function uses the create function of control and creates the Popup Edit
PopupEditDestroy | this function uses the destroy function of control and destroys the Popup Edit
PopupEditDraw | function to draw the popup to edit with attributes
PopupEditGetControlHight | Function unsuppored.
PopupEditHandleAction | function to handle the Popup Edit actions
PopupEditInitialize | this function uses the Initialize function of control and initializes the Popup Edit
PopupEditSetAttributes | Function to set the dimentions of the editable popup menu
PopupEditSetCallback | Function to set the PopupSel callback
PopupEditSetDimensions | function to set the dimentions of the editable popup menu
PopupEditSetFocus | Function to set focus
PopupEditSetPosition | Function to set focus
PopupEditSetText | Function to set the PopupEdit text
PopupEditSetType | Function to set the PopupEdit type

Built on 16:20:21 10/01/14


PopupEditCreate in the PopupEdit.c

Function : PopupEditCreate

File: PopupEdit.c
Description:
this function uses the create function of control
            and creates the Popup Edit
Input:
POPUPEDIT_DATA **object
Output:
status
Built on 16:20:13 10/01/14


PopupEditDestroy in the PopupEdit.c

Function : PopupEditDestroy

File: PopupEdit.c
Description:
this function uses the destroy function of control
            and destroys the Popup Edit
Input:
POPUPEDIT_DATA **object, BOOLEAN freeMem
Output:
status
Built on 16:20:13 10/01/14


PopupEditDraw in the PopupEdit.c

Function : PopupEditDraw

File: PopupEdit.c
Description:
function to draw the popup to edit with attributes
Input:
POPUPEDIT_DATA *PopupEdit
Output:
status
Built on 16:20:13 10/01/14


PopupEditGetControlHight in the PopupEdit.c

Function : PopupEditGetControlHight

File: PopupEdit.c
Description:
Function unsuppored.
Input:
VOID *object,VOID *frame, UINT16 *height
Output:
status
Built on 16:20:13 10/01/14


PopupEditHandleAction in the PopupEdit.c

Function : PopupEditHandleAction

File: PopupEdit.c
Description:
function to handle the Popup Edit actions
Input:
POPUPEDIT_DATA *PopupEdit, ACTION_DATA *Data
Output:
status
Built on 16:20:13 10/01/14


PopupEditInitialize in the PopupEdit.c

Function : PopupEditInitialize

File: PopupEdit.c
Description:
this function uses the Initialize function of control
            and initializes the Popup Edit
Input:
POPUPEDIT_DATA *PopupEdit, VOID *data
Output:
status
Built on 16:20:13 10/01/14


PopupEditSetAttributes in the PopupEdit.c

Function : PopupEditSetAttributes

File: PopupEdit.c
Description:
Function to set the dimentions of the editable popup menu
Input:
POPUPEDIT_DATA *PopupEdit, UINT8 FGColor, UINT8 BGColor
Output:
status
Built on 16:20:13 10/01/14


PopupEditSetCallback in the PopupEdit.c

Function : PopupEditSetCallback

File: PopupEdit.c
Description:
Function to set the PopupSel callback
Input:
POPUPEDIT_DATA *PopupEdit, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
STATUS
Built on 16:20:13 10/01/14


PopupEditSetDimensions in the PopupEdit.c

Function : PopupEditSetDimensions

File: PopupEdit.c
Description:
function to set the dimentions of the editable popup menu
Input:
POPUPEDIT_DATA *PopupEdit, UINT16 Width, UINT16 Height
Output:
status
Built on 16:20:13 10/01/14


PopupEditSetFocus in the PopupEdit.c

Function : PopupEditSetFocus

File: PopupEdit.c
Description:
Function to set focus
Input:
POPUPEDIT_DATA *PopupEdit, BOOLEAN focus
Output:
Status
Built on 16:20:13 10/01/14


PopupEditSetPosition in the PopupEdit.c

Function : PopupEditSetPosition

File: PopupEdit.c
Description:
Function to set focus
Input:
POPUPEDIT_DATA *PopupEdit, UINT16 Left, UINT16 Top
Output:
Status
Built on 16:20:13 10/01/14


PopupEditSetText in the PopupEdit.c

Function : PopupEditSetText

File: PopupEdit.c
Description:
Function to set the PopupEdit text
Input:
POPUPEDIT_DATA *PopupEdit, CHAR16 *String
Output:
STATUS
Built on 16:20:13 10/01/14


PopupEditSetType in the PopupEdit.c

Function : PopupEditSetType

File: PopupEdit.c
Description:
Function to set the PopupEdit type
Input:
POPUPEDIT_DATA *PopupEdit, UINT8 Type
Output:
STATUS
Built on 16:20:13 10/01/14


PopupEdit.h

Description:
This file contains definitions to handle Popup Edit operations
Built on 16:20:21 10/01/14


PopupPassword.c

Description:
This file contains code to handle Popup Passwords

The following functions are used in the file: PopupPassword.c.

Function | Description
_CBPopupEdit | Function for PopupEdit callback.
_DoPopupEdit | function to perform the edit operations on popup
_PopupEditGetValue | Function to get edit value.
_PopupPasswordActivate | function to set and activate a password
_PopupPasswordHandleAction | function to handle the password actions
PopupPasswordAuthenticateLocal | function to Check authentication of the password
PopupPasswordCheckInstalledLocal | function to Check the local installation of popup password
PopupPasswordCreate | this function uses the create function of control and creates the popup password
PopupPasswordDestroy | this function uses the destroy function of control and destroys the popup password
PopupPasswordDraw | function to draw the popup password with attributes
PopupPasswordGetControlHeight | function to get the height of the label
PopupPasswordHandleAction | Function to handle the PopupPassword Actions
PopupPasswordInitialize | this function uses the Initialize function of control and initializes the popup password
PopupPasswordSetAttributes | Function to set attributes.
PopupPasswordSetDimensions | Function to set dimension.
PopupPasswordSetFocus | Function to set focus
PopupPasswordSetPosition | Function to set position.
UpdatePasswordToNonCaseSensitive | function to update the given password to non case sensitive

Built on 16:20:21 10/01/14


_CBPopupEdit in the PopupPassword.c

Function : _CBPopupEdit

File: PopupPassword.c
Description:
Function for PopupEdit callback.
Input:
VOID *container, VOID *object, VOID *cookie
Output:
STATUS
Built on 16:20:03 10/01/14


_DoPopupEdit in the PopupPassword.c

Function : _DoPopupEdit

File: PopupPassword.c
Description:
function to perform the edit operations on popup
Input:
POPUP_PASSWORD_DATA *PopupPassword, UINT16 Title, CHAR16 **Text
Output:
status
Built on 16:20:03 10/01/14


_PopupEditGetValue in the PopupPassword.c

Function : _PopupEditGetValue

File: PopupPassword.c
Description:
Function to get edit value.
Input:
POPUPEDIT_DATA *popupedit
Output:
UINTN
Built on 16:20:04 10/01/14


_PopupPasswordActivate in the PopupPassword.c

Function : _PopupPasswordActivate

File: PopupPassword.c
Description:
function to set and activate a password
Input:
POPUP_PASSWORD_DATA *popuppassword
Output:
status
Built on 16:20:04 10/01/14


_PopupPasswordHandleAction in the PopupPassword.c

Function : _PopupPasswordHandleAction

File: PopupPassword.c
Description:
function to handle the password actions
Input:
POPUP_PASSWORD_DATA *popuppassword, , ACTION_DATA *Data
Output:
status
Built on 16:20:04 10/01/14


PopupPasswordAuthenticateLocal in the PopupPassword.c

Function : PopupPasswordAuthenticateLocal

File: PopupPassword.c
Description:
function to Check authentication of the password
Input:
POPUP_PASSWORD_DATA *popuppassword, CHAR16 *Password
Output:
TRUE/FALSE
Built on 16:20:13 10/01/14


PopupPasswordCheckInstalledLocal in the PopupPassword.c

Function : PopupPasswordCheckInstalledLocal

File: PopupPassword.c
Description:
function to Check the local installation of popup password
Input:
POPUP_PASSWORD_DATA *popuppassword
Output:
True/False
Built on 16:20:13 10/01/14


PopupPasswordCreate in the PopupPassword.c

Function : PopupPasswordCreate

File: PopupPassword.c
Description:
this function uses the create function of control
            and creates the popup password
Input:
POPUP_PASSWORD_DATA **object
Output:
status
Built on 16:20:13 10/01/14


PopupPasswordDestroy in the PopupPassword.c

Function : PopupPasswordDestroy

File: PopupPassword.c
Description:
this function uses the destroy function of control
            and destroys the popup password
Input:
POPUP_PASSWORD_DATA *popuppassword, BOOLEAN freeMem
Output:
status
Built on 16:20:13 10/01/14


PopupPasswordDraw in the PopupPassword.c

Function : PopupPasswordDraw

File: PopupPassword.c
Description:
function to draw the popup password with attributes
Input:
POPUP_PASSWORD_DATA *popuppassword
Output:
status
Built on 16:20:13 10/01/14


PopupPasswordGetControlHeight in the PopupPassword.c

Function : PopupPasswordGetControlHeight

File: PopupPassword.c
Description:
function to get the height of the label
Input:
POPUP_PASSWORD_DATA *popuppassword, frame, UINT16 *height
Output:
status
Built on 16:20:13 10/01/14


PopupPasswordHandleAction in the PopupPassword.c

Function : PopupPasswordHandleAction

File: PopupPassword.c
Description:
Function to handle the PopupPassword Actions
Input:
POPUP_PASSWORD_DATA *popuppassword, ACTION_DATA *Data
Output:
Status
Built on 16:20:13 10/01/14


PopupPasswordInitialize in the PopupPassword.c

Function : PopupPasswordInitialize

File: PopupPassword.c
Description:
this function uses the Initialize function of control
            and initializes the popup password
Input:
POPUP_PASSWORD_DATA *popuppassword, VOID *data
Output:
status
Built on 16:20:13 10/01/14


PopupPasswordSetAttributes in the PopupPassword.c

Function : PopupPasswordSetAttributes

File: PopupPassword.c
Description:
Function to set attributes.
Input:
POPUP_PASSWORD_DATA *popuppassword, UINT8 FGColor, UINT8 BGColor
Output:
STATUS
Built on 16:20:13 10/01/14


PopupPasswordSetDimensions in the PopupPassword.c

Function : PopupPasswordSetDimensions

File: PopupPassword.c
Description:
Function to set dimension.
Input:
POPUP_PASSWORD_DATA *popuppassword, UINT16 Width, UINT16 Height
Output:
STATUS
Built on 16:20:13 10/01/14


PopupPasswordSetFocus in the PopupPassword.c

Function : PopupPasswordSetFocus

File: PopupPassword.c
Description:
Function to set focus
Input:
POPUP_PASSWORD_DATA *popuppassword, BOOLEAN focus
Output:
Status
Built on 16:20:13 10/01/14


PopupPasswordSetPosition in the PopupPassword.c

Function : PopupPasswordSetPosition

File: PopupPassword.c
Description:
Function to set position.
Input:
POPUP_PASSWORD_DATA *popuppassword, UINT16 Left, UINT16 Top
Output:
STATUS
Built on 16:20:13 10/01/14


UpdatePasswordToNonCaseSensitive in the PopupPassword.c

Function : UpdatePasswordToNonCaseSensitive

File: PopupPassword.c
Description:
function to update the given password to non case sensitive
Input:
CHAR16 *Password, UINTN PwdLength
Output:
VOID
Built on 16:20:18 10/01/14


PopupPassword.h

Description:
Header file for Popup Passwords
Built on 16:20:21 10/01/14


PopupSel.c

Description:
This file contains code to handle Popup selections

The following functions are used in the file: PopupSel.c.

Function | Description
_GetPopUpSelectionFromVariable | Fucntion to return the current selection based on the variable. If not matched with variable value Selection will be 0
_PopupSelCallback | PopupSel callback function.
_PopupSelHandleActionKey | function to handle the PopupSel Action keys
DoBootDelBootOption | Function to delete the boot option
DoDriverDelDriverOption | Function to delete the driver option
DoPopupSelCallBack | Callback function of the PopupSel
PopupSelCreate | this function uses the create function of control and creates the Popup Selected
PopupSelDestroy | this function uses the destroy function of control and destroys the Popup Selected
PopupSelDraw | function to draw the specific popup window
PopupSelGetControlHeight | function to get the height of the label
PopupSelHandleAction | function to handle the PopupSel Actions
PopupSelInitialize | this function uses the Initialize function of control and initializes the Popup Selected
PopupSelSetAttributes | Function to set attributes.
PopupSelSetCallback | Function to handle the PopupString actions
PopupSelSetDimensions | Function to set dimension.
PopupSelSetFocus | Function to set focus
PopupSelSetPosition | Function to set position.
RearrangeBBSOrderVariable | Function to reorder the BBS order variable
RearrangeBootDriverOrderVariable | Function to rearrange the boot/driver order variables

Built on 16:20:21 10/01/14


_GetPopUpSelectionFromVariable in the PopupSel.c

Function : _GetPopUpSelectionFromVariable

File: PopupSel.c
Description:
Fucntion to return the current selection based on the variable. If not matched with variable value
                Selection will be 0
Input:
POPUPSEL_DATA *
Output:
VOID
Built on 16:20:04 10/01/14


_PopupSelCallback in the PopupSel.c

Function : _PopupSelCallback

File: PopupSel.c
Description:
PopupSel callback function.
Input:
POPUPSEL_DATA *container, CONTROL_DATA *popupSel, VOID *cookie
Output:
VOID
Built on 16:20:04 10/01/14


_PopupSelHandleActionKey in the PopupSel.c

Function : _PopupSelHandleActionKey

File: PopupSel.c
Description:
function to handle the PopupSel Action keys
Input:
POPUPSEL_DATA *popupSel, AMI_EFI_KEY_DATA key
Output:
status
Built on 16:20:04 10/01/14


DoBootDelBootOption in the PopupSel.c

Function : DoBootDelBootOption

File: PopupSel.c
Description:
Function to delete the boot option
Input:
POPUPSEL_DATA *
Output:
BOOLEAN
Built on 16:20:06 10/01/14


DoDriverDelDriverOption in the PopupSel.c

Function : DoDriverDelDriverOption

File: PopupSel.c
Description:
Function to delete the driver option
Input:
POPUPSEL_DATA *
Output:
BOOLEAN
Built on 16:20:06 10/01/14


DoPopupSelCallBack in the PopupSel.c

Function : DoPopupSelCallBack

File: PopupSel.c
Description:
Callback function of the PopupSel
Input:
POPUPSEL_DATA *popupSel
Output:
void
Built on 16:20:06 10/01/14


PopupSelCreate in the PopupSel.c

Function : PopupSelCreate

File: PopupSel.c
Description:
this function uses the create function of control
            and creates the Popup Selected
Input:
POPUPSEL_DATA **object
Output:
status
Built on 16:20:13 10/01/14


PopupSelDestroy in the PopupSel.c

Function : PopupSelDestroy

File: PopupSel.c
Description:
this function uses the destroy function of control
            and destroys the Popup Selected
Input:
POPUPSEL_DATA *popupSel, BOOLEAN freeMem
Output:
status
Built on 16:20:13 10/01/14


PopupSelDraw in the PopupSel.c

Function : PopupSelDraw

File: PopupSel.c
Description:
function to draw the specific popup window
Input:
POPUPSEL_DATA *popupSel
Output:
status
Built on 16:20:13 10/01/14


PopupSelGetControlHeight in the PopupSel.c

Function : PopupSelGetControlHeight

File: PopupSel.c
Description:
function to get the height of the label
Input:
POPUPSEL_DATA *popupSel,Frame, UINT16 *height
Output:
status
Built on 16:20:13 10/01/14


PopupSelHandleAction in the PopupSel.c

Function : PopupSelHandleAction

File: PopupSel.c
Description:
function to handle the PopupSel Actions
Input:
POPUPSEL_DATA *popupSel, ACTION_DATA *Data
Output:
status
Built on 16:20:13 10/01/14


PopupSelInitialize in the PopupSel.c

Function : PopupSelInitialize

File: PopupSel.c
Description:
this function uses the Initialize function of control
            and initializes the Popup Selected
Input:
POPUPSEL_DATA *popupSel, VOID *data
Output:
status
Built on 16:20:13 10/01/14


PopupSelSetAttributes in the PopupSel.c

Function : PopupSelSetAttributes

File: PopupSel.c
Description:
Function to set attributes.
Input:
POPUPSEL_DATA *popupSel, UINT8 FGColor, UINT8 BGColor
Output:
STATUS
Built on 16:20:13 10/01/14


PopupSelSetCallback in the PopupSel.c

Function : PopupSelSetCallback

File: PopupSel.c
Description:
Function to handle the PopupString actions
Input:
POPUPSEL_DATA *popupSel, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
STATUS
Built on 16:20:13 10/01/14


PopupSelSetDimensions in the PopupSel.c

Function : PopupSelSetDimensions

File: PopupSel.c
Description:
Function to set dimension.
Input:
POPUPSEL_DATA *popupSel, UINT16 Width, UINT16 Height
Output:
STATUS
Built on 16:20:13 10/01/14


PopupSelSetFocus in the PopupSel.c

Function : PopupSelSetFocus

File: PopupSel.c
Description:
Function to set focus
Input:
POPUPSEL_DATA *popupSel, BOOLEAN focus
Output:
Status
Built on 16:20:13 10/01/14


PopupSelSetPosition in the PopupSel.c

Function : PopupSelSetPosition

File: PopupSel.c
Description:
Function to set position.
Input:
POPUPSEL_DATA *popupSel, UINT16 Left, UINT16 Top
Output:
STATUS
Built on 16:20:13 10/01/14


RearrangeBBSOrderVariable in the PopupSel.c

Function : RearrangeBBSOrderVariable

File: PopupSel.c
Description:
Function to reorder the BBS order variable
Input:
POPUPSEL_DATA *popupSel, UINT8 bIncrease,UINT16 *newOption
Output:
void
Built on 16:20:14 10/01/14


RearrangeBootDriverOrderVariable in the PopupSel.c

Function : RearrangeBootDriverOrderVariable

File: PopupSel.c
Description:
Function to rearrange the boot/driver order variables
Input:
POPUPSEL_DATA *popupSel, UINT8 bIncrease
Output:
void
Built on 16:20:14 10/01/14


PopupSel.h

Description:
Header file for Popup selections
Built on 16:20:21 10/01/14


PopupString.c

Description:
This file contains code to handle Popup Stirngs

The following functions are used in the file: PopupString.c.

Function | Description
_CBPopupStringEdit | Function for PopupStringEdit callback.
_DoPopupStringEdit | Function to initiate PopupString editing
_PopupStringEditGetValue | function to get values for popup menu using edit functions.
PopupStringCreate | this function uses the create function of control and creates popup strings
PopupStringDestroy | this function uses the destroy function of control and destroys popup strings
PopupStringDraw | this function is to draw the popup strings
PopupStringGetControlHeight | Function to get the lable height of the PopupString
PopupStringHandleAction | function to handle the Popup string actions.
PopupStringSetAttributes | Function to set attributes.
PopupStringSetCallback | function to handle the PopupString actions
PopupStringSetDimensions | Function to set dimension.
PopupStringSetFocus | Function to handle the PopupString actions
PopupStringSetPosition | Function to set position.

Built on 16:20:21 10/01/14


_CBPopupStringEdit in the PopupString.c

Function : _CBPopupStringEdit

File: PopupString.c
Description:
Function for PopupStringEdit callback.
Input:
VOID *container, VOID *object, VOID *cookie
Output:
STATUS
Built on 16:20:03 10/01/14


_DoPopupStringEdit in the PopupString.c

Function : _DoPopupStringEdit

File: PopupString.c
Description:
Function to initiate PopupString editing
Input:
POPUP_STRING_DATA PopupString, UINT16 Title, CHAR16 **Text
Output:
STATUS
Built on 16:20:03 10/01/14


_PopupStringEditGetValue in the PopupString.c

Function : _PopupStringEditGetValue

File: PopupString.c
Description:
function to get values for popup menu using edit functions.
Input:
POPUP_STRING_DATA *popupedit
Output:
UINTN
Built on 16:20:04 10/01/14


PopupStringCreate in the PopupString.c

Function : PopupStringCreate

File: PopupString.c
Description:
this function uses the create function of control
            and creates popup strings
Input:
TPOPUP_STRING_DATA **object
Output:
status
Built on 16:20:13 10/01/14


PopupStringDestroy in the PopupString.c

Function : PopupStringDestroy

File: PopupString.c
Description:
this function uses the destroy function of control
            and destroys popup strings
Input:
POPUP_STRING_DATA *popupstring, BOOLEAN freeMem
Output:
status
Built on 16:20:13 10/01/14


PopupStringDraw in the PopupString.c

Function : PopupStringDraw

File: PopupString.c
Description:
this function is to draw the popup strings
Input:
POPUP_STRING_DATA *popupstring
Output:
status
Built on 16:20:13 10/01/14


PopupStringGetControlHeight in the PopupString.c

Function : PopupStringGetControlHeight

File: PopupString.c
Description:
Function to get the lable height of the PopupString
Input:
POPUP_STRING_DATA *popupstring, frame, UINT16 *height
Output:
Status
Built on 16:20:13 10/01/14


PopupStringHandleAction in the PopupString.c

Function : PopupStringHandleAction

File: PopupString.c
Description:
function to handle the Popup string actions.
Input:
POPUP_STRING_DATA *popupstring, ACTION_DATA *Data
Output:
status
Built on 16:20:13 10/01/14


PopupStringSetAttributes in the PopupString.c

Function : PopupStringSetAttributes

File: PopupString.c
Description:
Function to set attributes.
Input:
POPUP_STRING_DATA *popuppassword, UINT8 FGColor, UINT8 BGColor
Output:
STATUS
Built on 16:20:13 10/01/14


PopupStringSetCallback in the PopupString.c

Function : PopupStringSetCallback

File: PopupString.c
Description:
function to handle the PopupString actions
Input:
POPUP_STRING_DATA *popupstring, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
status
Built on 16:20:13 10/01/14


PopupStringSetDimensions in the PopupString.c

Function : PopupStringSetDimensions

File: PopupString.c
Description:
Function to set dimension.
Input:
POPUP_STRING_DATA *popuppassword, UINT16 Width, UINT16 Height
Output:
STATUS
Built on 16:20:13 10/01/14


PopupStringSetFocus in the PopupString.c

Function : PopupStringSetFocus

File: PopupString.c
Description:
Function to handle the PopupString actions
Input:
POPUP_STRING_DATA *popuppassword, BOOLEAN focus
Output:
Status
Built on 16:20:13 10/01/14


PopupStringSetPosition in the PopupString.c

Function : PopupStringSetPosition

File: PopupString.c
Description:
Function to set position.
Input:
POPUP_STRING_DATA *popuppassword, UINT16 Left, UINT16 Top
Output:
STATUS
Built on 16:20:13 10/01/14


PopupString.h

Description:
Header file for popupstring control
Built on 16:20:21 10/01/14


postmgmt.c

Description:
file to handle the Post management operations

The following functions are used in the file: postmgmt.c.

Function | Description
AddImageDetailToACPI | Adds the image data to the ACPI Table.
BGRTSupportedLogoType | Checks whether the BGRT data supports the specified logo
CalculateChecksum | Calculates the checksum for the given structure
DrawOEMImage | Function to draw OEMLogo to in Post screen operations
FormBGRTTable | Created the BGRT table with the input params
InitPostScreen | fucntion to perform the Post screen operations
InstallClickHandlers | fucntion to install the timer event
InstallKeyHandlers | fucntion to install the timer event
InvalidateStatusInBgrt | Disables the BGRT status field if any changes happened in screen other than the image display
UninstallBGRT | UninstallsBGRT table, Called for Legacy Boot

Built on 16:20:21 10/01/14


AddImageDetailToACPI in the postmgmt.c

Function : AddImageDetailToACPI

File: postmgmt.c
Description:
Adds the image data to the ACPI Table.
Input:
UINT8 * = Address of the image to be to stored
         INTN = X coordinate of the image
        INTN = Y coordinate of the image
        BOOLEAN = Indicates whether to set the BGRT status field or not
Output:
VOID
Built on 16:20:05 10/01/14


BGRTSupportedLogoType in the postmgmt.c

Function : BGRTSupportedLogoType

File: postmgmt.c
Description:
Checks whether the BGRT data supports the specified logo
Input:
UINT8 * => Data for the image
Output:
BOOLEAN => TRUE if BGRT supports otherwise FALSE
Built on 16:20:05 10/01/14


CalculateChecksum in the postmgmt.c

Function : CalculateChecksum

File: postmgmt.c
Description:
Calculates the checksum for the given structure
Input:
VOID => Table structure
UINT8 => Table Size
Output:
UINT8 => Checksum for the table
Built on 16:20:05 10/01/14


DrawOEMImage in the postmgmt.c

Function : DrawOEMImage

File: postmgmt.c
Description:
Function to draw OEMLogo to in Post screen operations
Input:
UINTN *, UINTN*, INTN, INTN
Output:
EFI_STATUS
Built on 16:20:07 10/01/14


FormBGRTTable in the postmgmt.c

Function : FormBGRTTable

File: postmgmt.c
Description:
Created the BGRT table with the input params
Input:
VOID * = Buffer to store the ACPI table
        UINTN * = To store the size of the ACPI + BGRT table
        UINT8 * = Address of the image to be to stored
         INTN = X coordinate of the image
        INTN = Y coordinate of the image
        BOOLEAN = Indicates whether to set the BGRT status field or not.
Output:
VOID
Built on 16:20:07 10/01/14


InitPostScreen in the postmgmt.c

Function : InitPostScreen

File: postmgmt.c
Description:
fucntion to perform the Post screen operations
Input:
VOID
Output:
VOID
Built on 16:20:10 10/01/14


InstallClickHandlers in the postmgmt.c

Function : InstallClickHandlers

File: postmgmt.c
Description:
fucntion to install the timer event
Input:
VOID
Output:
VOID
Built on 16:20:10 10/01/14


InstallKeyHandlers in the postmgmt.c

Function : InstallKeyHandlers

File: postmgmt.c
Description:
fucntion to install the timer event
Input:
VOID
Output:
VOID
Built on 16:20:10 10/01/14


InvalidateStatusInBgrt in the postmgmt.c

Function : InvalidateStatusInBgrt

File: postmgmt.c
Description:
Disables the BGRT status field if any changes happened in screen other than the image display
Input:
VOID
Output:
VOID
Built on 16:20:10 10/01/14


UninstallBGRT in the postmgmt.c

Function : UninstallBGRT

File: postmgmt.c
Description:
UninstallsBGRT table, Called for Legacy Boot
Input:
VOID
Output:
VOID
Built on 16:20:18 10/01/14


postmgmtext.c

Description:
This file contains code extended Post management operations

The following functions are used in the file: postmgmtext.c.

Function | Description
_DrawPasswordWindow | Function to draw password window with attributes
_GetPassword | Function to get password from the user
_ReportInBox | Function to report using Box
CheckEnableQuietBoot | Function to Check the quick boot enable option
CheckSystemPassword | Function to Check the system password
SetPasswordType | function to set the type of password
SetSystemAccessValue | function to set the system access Value

Built on 16:20:21 10/01/14


_DrawPasswordWindow in the postmgmtext.c

Function : _DrawPasswordWindow

File: postmgmtext.c
Description:
Function to draw password window with attributes
Input:
UINT16 PromptToken, UINTN PasswordLength, UINTN *CurrXPos, UINTN *CurrYPos
Output:
void
Built on 16:20:03 10/01/14


_GetPassword in the postmgmtext.c

Function : _GetPassword

File: postmgmtext.c
Description:
Function to get password from the user
Input:
CHAR16 *PasswordEntered, UINTN PasswordLength, UINTN CurrXPos,
            UINTN CurrYPos, UINTN *pTimeOut
Output:
status
Built on 16:20:04 10/01/14


_ReportInBox in the postmgmtext.c

Function : _ReportInBox

File: postmgmtext.c
Description:
Function to report using Box
Input:
UINTN PasswordLength, UINT16 BoxToken, UINTN CurrXPos,
            UINTN CurrYPos, BOOLEAN bWaitForReturn
Output:
void
Built on 16:20:04 10/01/14


CheckEnableQuietBoot in the postmgmtext.c

Function : CheckEnableQuietBoot

File: postmgmtext.c
Description:
Function to Check the quick boot enable option
Input:
void
Output:
void

Notes		:	if NVRAM variable field AMISilentBoot = 0, then disable silent
            mode else enable In case of error reading the Setup variable,
            then return as silent boot disable
Built on 16:20:05 10/01/14


CheckSystemPassword in the postmgmtext.c

Function : CheckSystemPassword

File: postmgmtext.c
Description:
Function to Check the system password
Input:
UINT32 EmptyPasswordType, UINTN *NoOfRetries, UINTN *TimeOut
Output:
PasswordCheck
Built on 16:20:06 10/01/14


SetPasswordType in the postmgmtext.c

Function : SetPasswordType

File: postmgmtext.c
Description:
function to set the type of password
Input:
UINT32 PasswordType
Output:
void
Built on 16:20:14 10/01/14


SetSystemAccessValue in the postmgmtext.c

Function : SetSystemAccessValue

File: postmgmtext.c
Description:
function to set the system access  Value
Input:
UINT8 sysAccessValue
Output:
void
Built on 16:20:15 10/01/14


print.c

Description:
file contains code to support the print functionalities

The following functions are used in the file: print.c.

Function | Description
SetupDebugKeyHandler | Parameter: Return value:
SetupDebugPrint |
SetupShowDebugScreen | Parameter: Return value:
SPrint | SPrint function to process format and place the results in Buffer
VSPrint | VSPrint function to process format and place the results in Buffer. Since a VA_LIST is used this rountine allows the nesting of Vararg routines. Thus this is the main print working routine

Built on 16:20:21 10/01/14


SetupDebugKeyHandler in the print.c

Function : SetupDebugKeyHandler

File: print.c
Description:

Parameter:

Return value:
Built on 16:20:15 10/01/14


SetupDebugPrint in the print.c

Function : SetupDebugPrint

File: print.c
Description:
Input:
Output:

Built on 16:20:15 10/01/14


SetupShowDebugScreen in the print.c

Function : SetupShowDebugScreen

File: print.c
Description:

Parameter:

Return value:
Built on 16:20:15 10/01/14


SPrint in the print.c

Function : SPrint

File: print.c
Description:
SPrint function to process format and place the results in Buffer
Input:
Buffer     - Wide char buffer to print the results of the parsing of Format into.
            BufferSize - Maximum number of characters to put into buffer. Zero means no limit.
            Format - Format string see file header for more details.
            ...    - Vararg list consumed by processing Format.
Output:
Number of characters printed.
Built on 16:20:15 10/01/14


VSPrint in the print.c

Function : VSPrint

File: print.c
Description:
VSPrint function to process format and place the results in Buffer. Since a
        VA_LIST is used this rountine allows the nesting of Vararg routines. Thus
        this is the main print working routine
Input:
StartOfBuffer - Unicode buffer to print the results of the parsing of Format into.
        BufferSize    - Maximum number of characters to put into buffer. Zero means no limit.
        FormatString  - Unicode format string see file header for more details.
        Marker        - Vararg list consumed by processing Format.
Output:
Number of characters printed.
Built on 16:20:18 10/01/14


protocol.c

Description:
This file contains code for TSE exported protocol
functions.

The following functions are used in the file: protocol.c.

Function | Description
InstallProtocol | This function installs different protocols exported.
InvalidateBgrtStatusByProtocol | Protocol interface to invalidate BGRT status
InvalidateBGRTStatusProtocol | Install Invalidate BGRT status protocol Parameter: EFI_HANDLE Handle Return value:EFI_STATUS
PostManagerDisplayInfoBox | Function to display the Information box
PostManagerDisplayMenu | Wrapper function for Display Menu.
PostManagerDisplayMsgBox |
PostManagerDisplayMsgBoxEx | Wrapper function for Display OEM Message box.
PostManagerDisplayPostMessage | This function is the protocol to display messages in the Post screen.
PostManagerDisplayPostMessageEx | This function is the protocol to display messages with attributes in the Post screen.
PostManagerDisplayProgress | Wrapper function for Display OEM Message box.
PostManagerDisplayQuietBootMessage | Function for the quit booting display.
PostManagerDisplayTextBox | Function to display text entry interface
PostManagerGetAttribute | Function to Get color
PostManagerGetCursorPosition | Wrapper function for GetCurPos Writes cursor position into given X and Y locations.
PostManagerGetPostStatus | Function returns current Post status.
PostManagerHandshake | This function is the handshake function to which BDS hands-off.
PostManagerInitProgressBar | Initializes the PostManagerProgressBar
PostManagerSetAtribute | Function to set color
PostManagerSetCursorPosition | Wrapper function for SetCurPos
PostManagerSetProgressBarPosition | Increments the PostManagerProgressBar
PostManagerSwitchToPostScreen | This function is the protocol to switch to Post screen
StopClickEvent | Function to Stop the Click Event
UninstallProtocol | This function uninstalls different protocols exported.

Built on 16:20:21 10/01/14


InstallProtocol in the protocol.c

Function : InstallProtocol

File: protocol.c
Description:
This function installs different protocols exported.
Input:
VOID
Output:
Return Status based on errors that occurred in library
functions.
Built on 16:20:10 10/01/14


InvalidateBgrtStatusByProtocol in the protocol.c

Function : InvalidateBgrtStatusByProtocol

File: protocol.c
Description:
Protocol interface to invalidate BGRT status
Input:
VOID
Output:
EFI_STATUS
Built on 16:20:10 10/01/14


InvalidateBGRTStatusProtocol in the protocol.c

Function : InvalidateBGRTStatusProtocol

File: protocol.c
Description:
Install Invalidate BGRT status protocol

Parameter:	EFI_HANDLE Handle

Return value:EFI_STATUS
Built on 16:20:10 10/01/14


PostManagerDisplayInfoBox in the protocol.c

Function : PostManagerDisplayInfoBox

File: protocol.c
Description:
Function to display the Information box
Input:
none
Output:
One of the TSE_POST_STATUS
            TSE_POST_STATUS_BEFORE_POST_SCREEN 	- TSE Loaded and yet goto Post screen
            TSE_POST_STATUS_IN_POST_SCREEN		- In the Post screen
            TSE_POST_STATUS_IN_QUITE_BOOT_SCREEN- In the quite boot screen
            TSE_POST_STATUS_IN_BOOT_TIME_OUT	- Witing for Boot timeout
            TSE_POST_STATUS_ENTERING_TSE		- Entering TSE
            TSE_POST_STATUS_IN_TSE				- Inside TSE
            TSE_POST_STATUS_IN_BBS_POPUP		- Inside BBS Poupup
            TSE_POST_STATUS_PROCEED_TO_BOOT		- Outside TSE and Booting or in Shell
Built on 16:20:13 10/01/14


PostManagerDisplayMenu in the protocol.c

Function : PostManagerDisplayMenu

File: protocol.c
Description:
Wrapper function for Display Menu.
Input:
IN VOID	*HiiHandle, 		- Handle that contains String
IN UINT16 	TitleToken,     - Menu Title Token
IN UINT16 	LegendToken,	- Menu Legend Token
IN POSTMENU_TEMPLATE *MenuData, - Menu Items to be displayed
IN UINT16 	MenuCount,	- Number of Menu items
OUT UINT16  *pSelection		- Menu selection (DEFAULT)
Output:
EFI_STATUS status 		- EFI_SUCCESS if OK,
                          EFI_INVALID_PARAMETER if NULL pointer
Built on 16:20:13 10/01/14


PostManagerDisplayMsgBox in the protocol.c

Function : PostManagerDisplayMsgBox

File: protocol.c
Description:

Input:

IN CHAR16  *MsgBoxTitle,
IN CHAR16  *Message,
IN UINT8   MsgBoxType,

Output:

EFI_STATUS status and UINT8 MsgBoxSel

Built on 16:20:13 10/01/14


PostManagerDisplayMsgBoxEx in the protocol.c

Function : PostManagerDisplayMsgBoxEx

File: protocol.c
Description:
Wrapper function for Display OEM Message box.
Input:
IN CHAR16  *MsgBoxTitle - Caption of the Message Box
     IN CHAR16  *Message	 - String to be displayed by the Message Box
     IN CHAR16  *Legend		 - Legend String to be displayed by the Message Box
     IN UINT8   MsgBoxType   - Message Box type
Output:
EFI_STATUS status - EFI_SUCCESS if OK,
              EFI_INVALID_PARAMETER if NULL pointer
Built on 16:20:13 10/01/14


PostManagerDisplayPostMessage in the protocol.c

Function : PostManagerDisplayPostMessage

File: protocol.c
Description:
This function is the protocol to display messages in
the Post screen.
Input:
CHAR16 *message: Unicode string to be displayed.
Output:
Return Status based on errors that occurred in library
functions.
Built on 16:20:13 10/01/14


PostManagerDisplayPostMessageEx in the protocol.c

Function : PostManagerDisplayPostMessageEx

File: protocol.c
Description:
This function is the protocol to display messages with
attributes in the Post screen.
Input:
CHAR16 *message: Unicode string to be displayed.
UINTN Attribute: Attribute for the message
Output:
Return Status based on errors that occurred in library
functions.
Built on 16:20:13 10/01/14


PostManagerDisplayProgress in the protocol.c

Function : PostManagerDisplayProgress

File: protocol.c
Description:
Wrapper function for Display OEM Message box.
Input:
IIN UINTN Percent  - Percent Complete
Output:
EFI_STATUS status - EFI_SUCCESS if OK,
              EFI_INVALID_PARAMETER if NULL pointer
Built on 16:20:13 10/01/14


PostManagerDisplayQuietBootMessage in the protocol.c

Function : PostManagerDisplayQuietBootMessage

File: protocol.c
Description:
Function for the quit booting display.
Input:
CHAR16 *Message, INTN CoOrdX, INTN CoOrdY,
            CO_ORD_ATTRIBUTE Attribute, EFI_UGA_PIXEL Foreground,
            EFI_UGA_PIXEL Background
Output:
Status
Built on 16:20:13 10/01/14


PostManagerDisplayTextBox in the protocol.c

Function : PostManagerDisplayTextBox

File: protocol.c
Description:
Function to display text entry interface
Input:
IN VOID    *HiiHandle,
IN UINT16 	TitleToken,
IN TEXT_INPUT_TEMPLATE *InputData,
IN UINT16 	ItemCount,
IN DISPLAY_TEXT_KEY_VALIDATE ValidateKeyFunc
Output:
EFI_STATUS
Built on 16:20:13 10/01/14


PostManagerGetAttribute in the protocol.c

Function : PostManagerGetAttribute

File: protocol.c
Description:
Function to Get color
Input:
UINT8 *Attrib - Pointer to get Text color
Output:
EFI_STATUS status - If the function runs correctly, returns
    EFI_SUCCESS, else other EFI defined error values.
Built on 16:20:13 10/01/14


PostManagerGetCursorPosition in the protocol.c

Function : PostManagerGetCursorPosition

File: protocol.c
Description:
Wrapper function for GetCurPos
Writes cursor position into given X and Y locations.
Input:
UINTN *pX - Pointer to storage for current column value
     UINTN *pY - Pointer to storage for current row value
Output:
EFI_STATUS status - EFI_SUCCESS if OK,
              EFI_INVALID_PARAMETER if NULL pointer
Built on 16:20:13 10/01/14


PostManagerGetPostStatus in the protocol.c

Function : PostManagerGetPostStatus

File: protocol.c
Description:
Function returns current Post status.
Input:
none
Output:
One of the TSE_POST_STATUS
            TSE_POST_STATUS_BEFORE_POST_SCREEN 	- TSE Loaded and yet goto Post screen
            TSE_POST_STATUS_IN_POST_SCREEN		- In the Post screen
            TSE_POST_STATUS_IN_QUITE_BOOT_SCREEN- In the quite boot screen
            TSE_POST_STATUS_IN_BOOT_TIME_OUT	- Witing for Boot timeout
            TSE_POST_STATUS_ENTERING_TSE		- Entering TSE
            TSE_POST_STATUS_IN_TSE				- Inside TSE
            TSE_POST_STATUS_IN_BBS_POPUP		- Inside BBS Poupup
            TSE_POST_STATUS_PROCEED_TO_BOOT		- Outside TSE and Booting or in Shell
Built on 16:20:13 10/01/14


PostManagerHandshake in the protocol.c

Function : PostManagerHandshake

File: protocol.c
Description:
This function is the handshake function to which BDS
hands-off.
Input:
VOID
Output:
This function never returns. It only boots different
options.
Built on 16:20:13 10/01/14


PostManagerInitProgressBar in the protocol.c

Function : PostManagerInitProgressBar

File: protocol.c
Description:
Initializes the PostManagerProgressBar
Input:
UINTN x - Column or Left screen position of ProgressBar in pixels
         UINTN y - Row or Top screen position of ProgressBar in pixels
         UINTN w - Width of ProgressBar in pixels
         UINTN h - Height of ProgressBar in pixels
         UINTN iterate - Total number of iterations or Calls
                         to advanced the progressbar to 100% of the given width.
                         The delta or changed value will be computed.
Output:
EFI_STATUS status - If the function runs correctly, returns
         EFI_SUCCESS, else other EFI defined error values.
Built on 16:20:13 10/01/14


PostManagerSetAtribute in the protocol.c

Function : PostManagerSetAtribute

File: protocol.c
Description:
Function to set color
Input:
UINT8 Attrib - Text color
Output:
EFI_STATUS status - If the function runs correctly, returns
    EFI_SUCCESS, else other EFI defined error values.
Built on 16:20:13 10/01/14


PostManagerSetCursorPosition in the protocol.c

Function : PostManagerSetCursorPosition

File: protocol.c
Description:
Wrapper function for SetCurPos
Input:
UINTN X - Value of the column
         UINTN Y - Number of row below the last written line
Output:
EFI_STATUS status - If the function runs correctly, returns
         EFI_SUCCESS, else other EFI defined error values.
Built on 16:20:13 10/01/14


PostManagerSetProgressBarPosition in the protocol.c

Function : PostManagerSetProgressBarPosition

File: protocol.c
Description:
Increments the PostManagerProgressBar
Input:
None
Output:
EFI_STATUS status - If the function runs correctly, returns
         EFI_SUCCESS, else other EFI defined error values.
Built on 16:20:13 10/01/14


PostManagerSwitchToPostScreen in the protocol.c

Function : PostManagerSwitchToPostScreen

File: protocol.c
Description:
This function is the protocol to switch to Post screen
Input:
VOID
Output:
Return Status based on errors that occurred in library
functions.
Built on 16:20:13 10/01/14


StopClickEvent in the protocol.c

Function : StopClickEvent

File: protocol.c
Description:
Function to Stop the Click Event
Input:
VOID
Output:
VOID
Built on 16:20:15 10/01/14


UninstallProtocol in the protocol.c

Function : UninstallProtocol

File: protocol.c
Description:
This function uninstalls different protocols exported.
Input:
VOID
Output:
VOID
Built on 16:20:18 10/01/14


ResetButton.c

Description:
This file contains code to handle the uefi actions

The following functions are used in the file: ResetButton.c.

Function | Description
ResetButtonCreate | Function to create an ResetButton Control.
ResetButtonDraw | Function to draw ResetButton.
ResetButtonHandleAction | Function to handle the ResetButton.
ResetButtonInitialize | Function to Initialize an Action Control.

Built on 16:20:21 10/01/14


ResetButtonCreate in the ResetButton.c

Function : ResetButtonCreate

File: ResetButton.c
Description:
Function to create an ResetButton Control.
Input:
VOID **object
Output:
EFI_STATUS
Built on 16:20:14 10/01/14


ResetButtonDraw in the ResetButton.c

Function : ResetButtonDraw

File: ResetButton.c
Description:
Function to draw ResetButton.
Input:
VOID *object
Output:
EFI_STATUS
Built on 16:20:14 10/01/14


ResetButtonHandleAction in the ResetButton.c

Function : ResetButtonHandleAction

File: ResetButton.c
Description:
Function to handle the ResetButton.
Input:
VOID *object, ACTION_DATA *data
Output:
EFI_STATUS
Built on 16:20:14 10/01/14


ResetButtonInitialize in the ResetButton.c

Function : ResetButtonInitialize

File: ResetButton.c
Description:
Function to Initialize an Action Control.
Input:
VOID *object, VOID *data
Output:
EFI_STATUS
Built on 16:20:14 10/01/14


ResetButton.h

Description:
Header file for ResetButton data
Built on 16:20:21 10/01/14


Resources.c

Description:
Library routines to load image resources.

The following functions are used in the file: Resources.c.

Function | Description
FvReadResources | Function to read all the section from of specified image.
ReadImageResource | Function to read all the resources of a image.

Built on 16:20:21 10/01/14


FvReadResources in the Resources.c

Function : FvReadResources

File: Resources.c
Description:
Function to read all the section from of specified image.
Input:
IN EFI_GUID *NameGuid,IN EFI_GUID *pGuid,IN OUT VOID **Buffer,IN OUT UINTN *BufferSize
Output:
Status
Built on 16:20:08 10/01/14


ReadImageResource in the Resources.c

Function : ReadImageResource

File: Resources.c
Description:
Function to read all the resources of a image.
Input:
EFI_HANDLE ImageHandle, EFI_GUID *pGuid,
        VOID **ppData, UINTN *pDataSize
Output:
Status
Built on 16:20:14 10/01/14


screen.c

Description:
This file contains code for screen operations.

The following functions are used in the file: screen.c.

Function | Description
ClearLinesWithoutFlush | function to clear lines without flushing.
ClearScreen | function to clear the screen.
ClearScreenWithoutFlush | function to clear screen without flushing.
RestoreGraphicsScreen | Restores the saved Post graphics screen
RestoreScreen | function to restore the screen from the saved screen buffer.
SaveGraphicsScreen | Saves Post graphics screen
SaveScreen | function to get the backup of the screen.

Built on 16:20:21 10/01/14


ClearLinesWithoutFlush in the screen.c

Function : ClearLinesWithoutFlush

File: screen.c
Description:
function to clear lines without flushing.
Input:
UINT8 LineStart, UINT8 NumLines, UINT8 Attrib
Output:
void
Built on 16:20:06 10/01/14


ClearScreen in the screen.c

Function : ClearScreen

File: screen.c
Description:
function to clear the screen.
Input:
UINT8 Attrib
Output:
void
Built on 16:20:06 10/01/14


ClearScreenWithoutFlush in the screen.c

Function : ClearScreenWithoutFlush

File: screen.c
Description:
function to clear screen without flushing.
Input:
UINT8 Attrib
Output:
void
Built on 16:20:06 10/01/14


RestoreGraphicsScreen in the screen.c

Function : RestoreGraphicsScreen

File: screen.c
Description:
Restores the saved Post graphics screen
Input:
VOID
Output:
VOID
Built on 16:20:14 10/01/14


RestoreScreen in the screen.c

Function : RestoreScreen

File: screen.c
Description:
function to restore the screen from the saved screen buffer.
Input:
VOID *ScreenBuffer
Output:
void
Built on 16:20:14 10/01/14


SaveGraphicsScreen in the screen.c

Function : SaveGraphicsScreen

File: screen.c
Description:
Saves Post graphics screen
Input:
VOID
Output:
VOID
Built on 16:20:14 10/01/14


SaveScreen in the screen.c

Function : SaveScreen

File: screen.c
Description:
function to get the backup of the screen.
Input:
void
Output:
void
Built on 16:20:14 10/01/14


special.c

Description:
This file contains code to handle special Operations

The following functions are used in the file: special.c.

Function | Description
_GetSpecialDriveroptionToken | function to get the boot option token properly when loading the boot page
_SpecialAddControl | function to Handle adding a control.
_SpecialAddMultipleControls | Adds Multiple controls for special controls
_SpecialControlExtras | special handling of extra operations
_SpecialExplodeControl | function to explode a perticular contorller
_SpecialFixupAddBootOption | function to fixup the adding of a boot device option
_SpecialFixupBBSCondition | This function updates the Condition to avoid more then one disabled option in BBS Dev order.
_SpecialFixupBBSOrder | function to fixup the Legacy Boot device order
_SpecialFixupBootCondition | This function updates the Condition to avoid more then one disabled option in Boot order.
_SpecialFixupBootOrder | function to fixup the Boot device order
_SpecialFixupDriverOrder | Function to fixup the driver order
_SpecialFixupLanguages | function to fixup the languages
_SpecialGetIfrPtr | function to handle the operation of getting the Ifr Pointer.
_SpecialGetValue | function to handle the operation of getting the Ifr Value.
DoAddBootOptionFixup |
GetSpecialBootoptionToken | function to get the boot option token properly when loading the boot page
SpecialFixupDelBootOption | function to fixup the deletion of a boot device option
SpecialFixupDelDriverOption | Function to fixup the deletion of a driver option
SpecialGetValue | function to handle the operation of getting the Ifr Value.
SpecialUpdatePageControls | special fucntion to update the page controls

Built on 16:20:21 10/01/14


_GetSpecialDriveroptionToken in the special.c

Function : _GetSpecialDriveroptionToken

File: special.c
Description:
function to get the boot option token properly when loading the boot page
Input:
VOID* handle, UINTN Index
Output:
TOKEN
Built on 16:20:04 10/01/14


_SpecialAddControl in the special.c

Function : _SpecialAddControl

File: special.c
Description:
function to Handle adding a control.
Input:
FRAME_DATA *frame ,
        CONTROL_INFO *controlinfo,
        BOOLEAN *SetFocus
Output:
EFI_STATUS
Built on 16:20:04 10/01/14


_SpecialAddMultipleControls in the special.c

Function : _SpecialAddMultipleControls

File: special.c
Description:
Adds Multiple controls for special controls
Input:
FRAME_DATA *frame , CONTROL_INFO *controlInfo, GUID_INFO *guidInfo, BOOLEAN *SetFocus
Output:
VOID
Built on 16:20:04 10/01/14


_SpecialControlExtras in the special.c

Function : _SpecialControlExtras

File: special.c
Description:
special handling of extra operations
Input:
CONTROL_DATA *ctrlData
Output:
None
Built on 16:20:04 10/01/14


_SpecialExplodeControl in the special.c

Function : _SpecialExplodeControl

File: special.c
Description:
function to explode a perticular contorller
Input:
FRAME_DATA *frame,
        CONTROL_INFO *ctrlData,
        BOOLEAN *SetFocus
Output:
control Value
Built on 16:20:04 10/01/14


_SpecialFixupAddBootOption in the special.c

Function : _SpecialFixupAddBootOption

File: special.c
Description:
function to fixup the adding of a boot device option
Input:
CONTROL_INFO *control,
Output:
None
Built on 16:20:04 10/01/14


_SpecialFixupBBSCondition in the special.c

Function : _SpecialFixupBBSCondition

File: special.c
Description:
This function updates the Condition to avoid more then one
        disabled option in BBS Dev order.
Input:
ControlIndex, Control Info, PrevControlQuestionID
Output:
VOID
Built on 16:20:04 10/01/14


_SpecialFixupBBSOrder in the special.c

Function : _SpecialFixupBBSOrder

File: special.c
Description:
function to fixup the Legacy Boot device order
Input:
CONTROL_INFO *control,
        UINT16 value
Output:
None
Built on 16:20:04 10/01/14


_SpecialFixupBootCondition in the special.c

Function : _SpecialFixupBootCondition

File: special.c
Description:
This function updates the Condition to avoid more then one
        disabled option in Boot order.
Input:
ControlIndex, Control Info, PrevControlQuestionID
Output:
VOID
Built on 16:20:04 10/01/14


_SpecialFixupBootOrder in the special.c

Function : _SpecialFixupBootOrder

File: special.c
Description:
function to fixup the Boot device order
Input:
CONTROL_INFO *control,
        UINT16 value
Output:
None
Built on 16:20:04 10/01/14


_SpecialFixupDriverOrder in the special.c

Function : _SpecialFixupDriverOrder

File: special.c
Description:
Function to fixup the driver order
Input:
CONTROL_INFO *control,
        UINT16 value
Output:
None
Built on 16:20:04 10/01/14


_SpecialFixupLanguages in the special.c

Function : _SpecialFixupLanguages

File: special.c
Description:
function to fixup the languages
Input:
CONTROL_INFO *control
Output:
None
Built on 16:20:04 10/01/14


_SpecialGetIfrPtr in the special.c

Function : _SpecialGetIfrPtr

File: special.c
Description:
function to handle the operation of getting the Ifr Pointer.
Input:
VOID* conditional,
        UINT32 variable,
        GUID_INFO **guidInfo
Output:
None
Built on 16:20:04 10/01/14


_SpecialGetValue in the special.c

Function : _SpecialGetValue

File: special.c
Description:
function to handle the operation of getting the Ifr Value.
Input:
CONTROL_INFO *controlinfo,
        GUID_INFO **guidInfo
Output:
UINT16
Built on 16:20:04 10/01/14


DoAddBootOptionFixup in the special.c

Function : DoAddBootOptionFixup

File: special.c
Description:
Input:
CONTROL_INFO *newControlInfo
Output:
None
Built on 16:20:06 10/01/14


GetSpecialBootoptionToken in the special.c

Function : GetSpecialBootoptionToken

File: special.c
Description:
function to get the boot option token properly when loading the boot page
Input:
VOID* handle, UINTN Index
Output:
TOKEN
Built on 16:20:08 10/01/14


SpecialFixupDelBootOption in the special.c

Function : SpecialFixupDelBootOption

File: special.c
Description:
function to fixup the deletion of a boot device option
Input:
CONTROL_INFO *control,
Output:
None
Built on 16:20:15 10/01/14


SpecialFixupDelDriverOption in the special.c

Function : SpecialFixupDelDriverOption

File: special.c
Description:
Function to fixup the deletion of a driver option
Input:
CONTROL_INFO *control,
Output:
None
Built on 16:20:15 10/01/14


SpecialGetValue in the special.c

Function : SpecialGetValue

File: special.c
Description:
function to handle the operation of getting the Ifr Value.
Input:
CONTROL_DATA *control,
        GUID_INFO **guidInfo
Output:
UINT16
Built on 16:20:15 10/01/14


SpecialUpdatePageControls in the special.c

Function : SpecialUpdatePageControls

File: special.c
Description:
special fucntion to update the page controls
Input:
UINT32 CurrentPage
Output:
None
Built on 16:20:15 10/01/14


special.h

Description:
Header file for TSE special controls like AMI callback controls
Built on 16:20:21 10/01/14


string.c

Description:
This file contains code for string functionalities.

The following functions are used in the file: string.c.

Function | Description
atoi | function to convet a string to integer
DisplayActivePostMsgs | function to Display active messages
DrawAttribute | function to write a attribute
DrawAttributeOffset | function to write in a peticular offset.
DrawMultiLineStringWithAttribute | function to write a multiline string.
DrawPostStringWithAttribute | function to write a multiline string in the Post screen.
DrawStringJustifiedWithAttribute | function to write a string with justify and attributes.
DrawStringWithAttribute | function to write a string with attributes.
FindAnsiEscCode | Fills the EscCode in current line
GetCurPos | Writes cursor position into given X and Y locations.
GetTokenCount |
GetTokenString |
PreservePostMessages | function to take care the postmessages when Screen mode changes Only supported if OldMaxCols <= NewMaxCols
PrintPostMessage | function to Print the Post massages
SetCurPos | Sets the cursor to the position defined by X and Y.
SetPostScreenScrollArea | Sets the PostScreen Scroll Area.
StrCpy8 | Copies a CHAR8 String from source to destination
StrDup | function to dump and return the string
StrDup16to8 | Duplicates a String from CHAR16 to CHAR8
StrDup8 | Duplicates a String of type CHAR8
StrDup8to16 | Duplicates a String from CHAR8 to CHAR16
StringWrapText | function to create a new text by wrapping the given text.
StrLen8 | Returns Length of a String of type CHAR8
StrZeroPad | function to pad with zero

Built on 16:20:21 10/01/14


atoi in the string.c

Function : atoi

File: string.c
Description:
function to convet a string to integer
Input:
CHAR16 *string, UINT8 base
Output:
integer
Built on 16:20:05 10/01/14


DisplayActivePostMsgs in the string.c

Function : DisplayActivePostMsgs

File: string.c
Description:
function to Display active messages
Input:
UINTN LogoHeight
Output:
void
Built on 16:20:06 10/01/14


DrawAttribute in the string.c

Function : DrawAttribute

File: string.c
Description:
function to write a attribute
Input:
UINTN Col, UINTN Row, UINT8 Attrib, UINTN Length
Output:
void
Built on 16:20:06 10/01/14


DrawAttributeOffset in the string.c

Function : DrawAttributeOffset

File: string.c
Description:
function to write in a peticular offset.
Input:
UINTN Offset, UINT8 Attrib, UINTN Length
Output:
void
Built on 16:20:06 10/01/14


DrawMultiLineStringWithAttribute in the string.c

Function : DrawMultiLineStringWithAttribute

File: string.c
Description:
function to write a multiline string.
Input:
UINTN Col, UINTN Row,UINTN Width, UINTN Height,
            CHAR16 *line, UINT8 Attrib
Output:
void
Built on 16:20:07 10/01/14


DrawPostStringWithAttribute in the string.c

Function : DrawPostStringWithAttribute

File: string.c
Description:
function to write a multiline string in the Post screen.
Input:
UINTN Col, UINTN Row,
            CHAR16 *line, UINT8 Attrib
Output:
UINTN
Built on 16:20:07 10/01/14


DrawStringJustifiedWithAttribute in the string.c

Function : DrawStringJustifiedWithAttribute

File: string.c
Description:
function to write a string with justify and attributes.
Input:
UINTN MinCol, UINTN MaxCol, UINTN Row, UINTN Justify,
            CHAR16 *String, UINT8 Attrib
Output:
void
Built on 16:20:07 10/01/14


DrawStringWithAttribute in the string.c

Function : DrawStringWithAttribute

File: string.c
Description:
function to write a string with attributes.
Input:
UINTN Col, UINTN Row, CHAR16 *String, UINT8 Attrib
Output:
void
Built on 16:20:07 10/01/14


FindAnsiEscCode in the string.c

Function : FindAnsiEscCode

File: string.c
Description:
Fills the EscCode in current line
Input:
CHAR16 *, CHAR16 **
Output:
void
Built on 16:20:07 10/01/14


GetCurPos in the string.c

Function : GetCurPos

File: string.c
Description:
Writes cursor position into given X and Y locations.
Input:
UINTN *pX - Pointer to storage for current column value
        UINTN *pY - Pointer to storage for current row value
Output:
EFI_STATUS status - EFI_SUCCESS if OK,
EFI_INVALID_PARAMETER if NULL pointer
Built on 16:20:08 10/01/14


GetTokenCount in the string.c

Function : GetTokenCount

File: string.c
Description:
Input:
CHAR8 *String
Output:
UINTN
Built on 16:20:08 10/01/14


GetTokenString in the string.c

Function : GetTokenString

File: string.c
Description:
Input:
CHAR8 *String, UINTN *pos
Output:
CHAR8 *
Built on 16:20:08 10/01/14


PreservePostMessages in the string.c

Function : PreservePostMessages

File: string.c
Description:
function to take care the postmessages when Screen mode changes
        Only supported if OldMaxCols <= NewMaxCols
Input:
UINTN NewMaxCols, UINTN OldMaxCols
Output:
void
Built on 16:20:13 10/01/14


PrintPostMessage in the string.c

Function : PrintPostMessage

File: string.c
Description:
function to Print the Post massages
Input:
CHAR16 *message, BOOLEAN bAdvanceLine
Output:
status
Built on 16:20:13 10/01/14


SetCurPos in the string.c

Function : SetCurPos

File: string.c
Description:
Sets the cursor to the position defined by X and Y.
Input:
UINTN X - Value of the column
        UINTN Y - Number of row below the last written line
Output:
EFI_STATUS status - If the function runs correctly, returns
        EFI_SUCCESS, else other EFI defined error values.
Built on 16:20:14 10/01/14


SetPostScreenScrollArea in the string.c

Function : SetPostScreenScrollArea

File: string.c
Description:
Sets the PostScreen Scroll Area.
Input:
UINTN TopX, UINTN TopY, UINTN BottomX, UINTN BottomY
Output:
None
Built on 16:20:14 10/01/14


StrCpy8 in the string.c

Function : StrCpy8

File: string.c
Description:
Copies a CHAR8 String from source to destination
Input:
CHAR8 *dest, CHAR8 *src
Output:
VOID
Built on 16:20:15 10/01/14


StrDup in the string.c

Function : StrDup

File: string.c
Description:
function to dump and return the string
Input:
CHAR16 *String
Output:
String
Built on 16:20:15 10/01/14


StrDup16to8 in the string.c

Function : StrDup16to8

File: string.c
Description:
Duplicates a String from CHAR16 to CHAR8
Input:
CHAR16 *String
Output:
CHAR8 *
Built on 16:20:15 10/01/14


StrDup8 in the string.c

Function : StrDup8

File: string.c
Description:
Duplicates a String of type CHAR8
Input:
CHAR8* string
Output:
CHAR8 *
Built on 16:20:15 10/01/14


StrDup8to16 in the string.c

Function : StrDup8to16

File: string.c
Description:
Duplicates a String from CHAR8 to CHAR16
Input:
CHAR8* string
Output:
CHAR16 *
Built on 16:20:15 10/01/14


StringWrapText in the string.c

Function : StringWrapText

File: string.c
Description:
function to create a new text by wrapping the given text.
Input:
CHAR16 *OrgText, UINT16 width, UINT16 *height
Output:
text
Built on 16:20:15 10/01/14


StrLen8 in the string.c

Function : StrLen8

File: string.c
Description:
Returns Length of a String of type CHAR8
Input:
CHAR8* string
Output:
UINTN
Built on 16:20:15 10/01/14


StrZeroPad in the string.c

Function : StrZeroPad

File: string.c
Description:
function to pad with zero
Input:
INT32 Tm, CHAR16 *Str
Output:
String
Built on 16:20:15 10/01/14


string.h

Description:
Header file for string functionalities.
Built on 16:20:21 10/01/14


style.c

Description:
Contains style override functions.

The following functions are used in the file: style.c.

Function | Description
_StyleAddControl | Function to add controls
_StyleAddSpacing | Function to add spacing
OverRideStyleAddAdditionalControls | Function to add additional controls
OverRideStyleFrameDrawable | Function to determine if frame is drawable
OverRideStyleFrameHandleKey | Function to handle action key
OverRideStyleGetNavToken | Function to get navigation frame token
OverRideStyleHandleControlOverflow | Function to handle contro overflow
OverRideStyleInitializeFrame | Function to Initialize frame
OverRideStyleLabelCallback | Function to set label callback
OverRideStyleSelectFirstDisplayPage | Function to set first page display
OverRideStyleUpdateVersionString | Function to update version string

Built on 16:20:21 10/01/14


_StyleAddControl in the style.c

Function : _StyleAddControl

File: style.c
Description:
Function to add controls
Input:
FRAME_DATA *frame, UINT16 type, VOID *data, UINT32 *controlNumber, BOOLEAN *focus
Output:
EFI_STATUS
Built on 16:20:04 10/01/14


_StyleAddSpacing in the style.c

Function : _StyleAddSpacing

File: style.c
Description:
Function to add spacing
Input:
FRAME_DATA *frame
Output:
VOID
Built on 16:20:04 10/01/14


OverRideStyleAddAdditionalControls in the style.c

Function : OverRideStyleAddAdditionalControls

File: style.c
Description:
Function to add additional controls
Input:
FRAME_DATA *frame, UINT32 controlNumber, BOOLEAN focus
Output:
EFI_STATUS
Built on 16:20:12 10/01/14


OverRideStyleFrameDrawable in the style.c

Function : OverRideStyleFrameDrawable

File: style.c
Description:
Function to determine if frame is drawable
Input:
FRAME_DATA *frame
Output:
EFI_STATUS
Built on 16:20:12 10/01/14


OverRideStyleFrameHandleKey in the style.c

Function : OverRideStyleFrameHandleKey

File: style.c
Description:
Function to handle action key
Input:
FRAME_DATA *frame, EFI_INPUT_KEY Key
Output:
STATUS
Built on 16:20:12 10/01/14


OverRideStyleGetNavToken in the style.c

Function : OverRideStyleGetNavToken

File: style.c
Description:
Function to get navigation frame token
Input:
UINT32 page number
Output:
UINT16 token
Built on 16:20:12 10/01/14


OverRideStyleHandleControlOverflow in the style.c

Function : OverRideStyleHandleControlOverflow

File: style.c
Description:
Function to handle contro overflow
Input:
FRAME_DATA *frame, CONTROL_DATA *control, UINT16 count
Output:
VOID
Built on 16:20:12 10/01/14


OverRideStyleInitializeFrame in the style.c

Function : OverRideStyleInitializeFrame

File: style.c
Description:
Function to Initialize frame
Input:
FRAME_DATA *frame, UINT32 frameType, PAGE_INFO *data
Output:
VOID
Built on 16:20:12 10/01/14


OverRideStyleLabelCallback in the style.c

Function : OverRideStyleLabelCallback

File: style.c
Description:
Function to set label callback
Input:
FRAME_DATA *frame, LABEL_DATA *label, VOID *cookie
Output:
VOID
Built on 16:20:12 10/01/14


OverRideStyleSelectFirstDisplayPage in the style.c

Function : OverRideStyleSelectFirstDisplayPage

File: style.c
Description:
Function to set first page display
Input:
VOID
Output:
VOID
Built on 16:20:12 10/01/14


OverRideStyleUpdateVersionString in the style.c

Function : OverRideStyleUpdateVersionString

File: style.c
Description:
Function to update version string
Input:
VOID
Output:
VOID
Built on 16:20:12 10/01/14


style.h

Description:
Style override prototypes.
Built on 16:20:21 10/01/14


stylecommon.c

Description:
Contains generic or default style functions.

The following functions are used in the file: stylecommon.c.

Function | Description
_StyleControlSubmenu | Function to Initialize submenu control
GetWindowLevel | Function to get window level
StyleAddAdditionalControls | Function to add additinal controls
StyleAddExtraPagesData | Function to add extra pages
StyleBeforeFrame | Function to alter frame styling before frame is drawn
StyleBootManagerPage | Function to set boot manager page
StyleControlColor | Adds controls to the frame
StyleDrawHelpScrollBar | Function to draw the help frame scrollbar
StyleDrawPageBorder | Function to draw the page border
StyleDrawScrollBar | Function to draw the frame scrollbar
StyleExit | Function to do style initialization on exit
StyleFrameDrawable | Function to determine if frame is drawable
StyleFrameHandleKey | Function to handle frame action keys
StyleFrameHandleMouse | Function to handle frame using mouse
StyleFrameHandleTimer | Function to handle frame timer action
StyleFrameSetControlPositions | Function to set control positioning in a frame
StyleGetClearScreenColor | Function to Get Clear Screen Color
StyleGetDateFormat | Function to get date format
StyleGetFrameInitData | Function to get frame initialization data
StyleGetMessageboxColor | Function to get control Messagebox color
StyleGetNavToken | Function to get navigation token
StyleGetPageLinkColor | Function to PageLink (Submenu) color
StyleGetScrollBarColor | Function to get scrollbar color
StyleGetScrollBarDownArrowColor | Function to get scrollbar downarrow color
StyleGetScrollBarUpArrowColor | Function to get scrollbar UpArrow Color
StyleGetScrollBehavior | Function to get scroll behavior
StyleGetShadowSupport | Function to get shadow support
StyleGetSpecialColor | Function to get control special color
StyleGetStdMaxCols | Function to get max number of rows
StyleGetStdMaxRows | Function to max number of columns
StyleGetTextMode | Function to get text mode
StyleGetWindowColor | Function to get window color
StyleHandleControlOverflow | Function to handle control overflow
StyleHelpAreaScrollable | Function to get Help area scroll support
StyleInit | Function to Initialize style
StyleInitializeFrame | Function to Initialize frame
StyleLabelCallback | Function to set label callback
StyleLanguagePage | Function to set Language page
StyleOverRideComponent | Function to override component or control functionality
StylePageItemFocus | This function is called whenever a user navigates to a new page. OEMs may use this hook to set item focus. The default behavior sets focus to the previously focused page item.
StyleSelectFirstDisplayPage | Function to set the first display page
StyleShowDay | Function to show day in date format
StyleSubPageItemFocus | This function is called whenever a user returns (or navigates back) from a submenu page causing a complete page redraw. OEMs may use this hook to set item focus. The default behavior sets focus to the previously focused page item.
StyleUpdateFrameStrings | Function to update frame strings
StyleUpdateVersionString | Function to set the version string

Built on 16:20:21 10/01/14


_StyleControlSubmenu in the stylecommon.c

Function : _StyleControlSubmenu

File: stylecommon.c
Description:
Function to Initialize submenu control
Input:
CONTROL_INFO control, UINT16 pageID, VOID *ref
Output:
VOID
Built on 16:20:04 10/01/14


GetWindowLevel in the stylecommon.c

Function : GetWindowLevel

File: stylecommon.c
Description:
Function to get window level
Input:
UINT16	PageID
Output:
INTN Level
Built on 16:20:08 10/01/14


StyleAddAdditionalControls in the stylecommon.c

Function : StyleAddAdditionalControls

File: stylecommon.c
Description:
Function to add additinal controls
Input:
FRAME_DATA *frame, UINT32 controlNumber, BOOLEAN focus
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


StyleAddExtraPagesData in the stylecommon.c

Function : StyleAddExtraPagesData

File: stylecommon.c
Description:
Function to add extra pages
Input:
VOID
Output:
VOID
Built on 16:20:15 10/01/14


StyleBeforeFrame in the stylecommon.c

Function : StyleBeforeFrame

File: stylecommon.c
Description:
Function to alter frame styling before frame is drawn
Input:
FRAME_DATA *frame
Output:
VOID
Built on 16:20:15 10/01/14


StyleBootManagerPage in the stylecommon.c

Function : StyleBootManagerPage

File: stylecommon.c
Description:
Function to set boot manager page
Input:
SUBMENU_DATA *submenu
Output:
UINT16 page number
Built on 16:20:15 10/01/14


StyleControlColor in the stylecommon.c

Function : StyleControlColor

File: stylecommon.c
Description:
Adds controls to the frame
Input:
FRAME_DATA *frame  - Pointer to the frame data
    STYLECOLORS Colors - Color scheme
Output:
EFI_STATUS Status - EFI_SUCCESS if successful, else
                                EFI_UNSUPPORTED
Built on 16:20:15 10/01/14


StyleDrawHelpScrollBar in the stylecommon.c

Function : StyleDrawHelpScrollBar

File: stylecommon.c
Description:
Function to draw the help frame scrollbar
Input:
MEMO_DATA *memo, UINT16 height
Output:
VOID
Built on 16:20:15 10/01/14


StyleDrawPageBorder in the stylecommon.c

Function : StyleDrawPageBorder

File: stylecommon.c
Description:
Function to draw the page border
Input:
UINT32 page number
Output:
VOID
Built on 16:20:15 10/01/14


StyleDrawScrollBar in the stylecommon.c

Function : StyleDrawScrollBar

File: stylecommon.c
Description:
Function to draw the frame scrollbar
Input:
FRAME_DATA *frame, UINT32 FirstLine, UINT32 LastLine, UINT32 modVal, UINT32 sizeOfBar, UINT32 numOfBlocks, BOOLEAN bEraseScrollBar
Output:
VOID
Built on 16:20:15 10/01/14


StyleExit in the stylecommon.c

Function : StyleExit

File: stylecommon.c
Description:
Function to do style initialization on exit
Input:
VOID
Output:
VOID
Built on 16:20:15 10/01/14


StyleFrameDrawable in the stylecommon.c

Function : StyleFrameDrawable

File: stylecommon.c
Description:
Function to determine if frame is drawable
Input:
FRAME_DATA *frame
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


StyleFrameHandleKey in the stylecommon.c

Function : StyleFrameHandleKey

File: stylecommon.c
Description:
Function to handle frame action keys
Input:
FRAME_DATA *frame, EFI_INPUT_KEY Key
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


StyleFrameHandleMouse in the stylecommon.c

Function : StyleFrameHandleMouse

File: stylecommon.c
Description:
Function to handle frame using mouse
Input:
FRAME_DATA *frame,
        MOUSE_INFO MouseInfo
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


StyleFrameHandleTimer in the stylecommon.c

Function : StyleFrameHandleTimer

File: stylecommon.c
Description:
Function to handle frame timer action
Input:
FRAME_DATA *frame, ACTION_DATA *action
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


StyleFrameSetControlPositions in the stylecommon.c

Function : StyleFrameSetControlPositions

File: stylecommon.c
Description:
Function to set control positioning in a frame
Input:
FRAME_DATA *frame, UINT32 *pOtherEnd
Output:
VOID
Built on 16:20:15 10/01/14


StyleGetClearScreenColor in the stylecommon.c

Function : StyleGetClearScreenColor

File: stylecommon.c
Description:
Function to Get Clear Screen Color
Input:
VOID
Output:
STYLE_CLEAR_SCREEN_COLOR
Built on 16:20:15 10/01/14


StyleGetDateFormat in the stylecommon.c

Function : StyleGetDateFormat

File: stylecommon.c
Description:
Function to get date format
Input:
VOID
Output:
BOOLEAN
Built on 16:20:15 10/01/14


StyleGetFrameInitData in the stylecommon.c

Function : StyleGetFrameInitData

File: stylecommon.c
Description:
Function to get frame initialization data
Input:
UINT32 page number, UINT32 frame number
Output:
VOID
Built on 16:20:15 10/01/14


StyleGetMessageboxColor in the stylecommon.c

Function : StyleGetMessageboxColor

File: stylecommon.c
Description:
Function to get control Messagebox color
Input:
UINT16 ControlType, UINT8 *Color
Output:
status
Built on 16:20:15 10/01/14


StyleGetNavToken in the stylecommon.c

Function : StyleGetNavToken

File: stylecommon.c
Description:
Function to get navigation token
Input:
UINT32 page
Output:
UINT16 token number
Built on 16:20:15 10/01/14


StyleGetPageLinkColor in the stylecommon.c

Function : StyleGetPageLinkColor

File: stylecommon.c
Description:
Function to PageLink (Submenu) color
Input:
VOID
Output:
PAGE_LINK_FGCOLOR
Built on 16:20:15 10/01/14


StyleGetScrollBarColor in the stylecommon.c

Function : StyleGetScrollBarColor

File: stylecommon.c
Description:
Function to get scrollbar color
Input:
VOID
Output:
FGCOLOR|BGCOLOR
Built on 16:20:15 10/01/14


StyleGetScrollBarDownArrowColor in the stylecommon.c

Function : StyleGetScrollBarDownArrowColor

File: stylecommon.c
Description:
Function to get scrollbar downarrow color
Input:
VOID
Output:
FGCOLOR|BGCOLOR
Built on 16:20:15 10/01/14


StyleGetScrollBarUpArrowColor in the stylecommon.c

Function : StyleGetScrollBarUpArrowColor

File: stylecommon.c
Description:
Function to get scrollbar UpArrow Color
Input:
VOID
Output:
FGCOLOR|BGCOLOR
Built on 16:20:15 10/01/14


StyleGetScrollBehavior in the stylecommon.c

Function : StyleGetScrollBehavior

File: stylecommon.c
Description:
Function to get scroll behavior
Input:
VOID
Output:
BOOLEAN
Built on 16:20:15 10/01/14


StyleGetShadowSupport in the stylecommon.c

Function : StyleGetShadowSupport

File: stylecommon.c
Description:
Function to get shadow support
Input:
VOID
Output:
BOOLEAN
Built on 16:20:15 10/01/14


StyleGetSpecialColor in the stylecommon.c

Function : StyleGetSpecialColor

File: stylecommon.c
Description:
Function to get control special color
Input:
UINT16 ControlType, UINT8 *Color
Output:
status
Built on 16:20:15 10/01/14


StyleGetStdMaxCols in the stylecommon.c

Function : StyleGetStdMaxCols

File: stylecommon.c
Description:
Function to get max number of rows
Input:
VOID
Output:
STYLE_STD_MAX_COLS
Built on 16:20:15 10/01/14


StyleGetStdMaxRows in the stylecommon.c

Function : StyleGetStdMaxRows

File: stylecommon.c
Description:
Function to max number of columns
Input:
VOID
Output:
STYLE_STD_MAX_ROWS
Built on 16:20:15 10/01/14


StyleGetTextMode in the stylecommon.c

Function : StyleGetTextMode

File: stylecommon.c
Description:
Function to get text mode
Input:
UINTN Rows, UINTN Cols
Output:
UNNTN mode
Built on 16:20:15 10/01/14


StyleGetWindowColor in the stylecommon.c

Function : StyleGetWindowColor

File: stylecommon.c
Description:
Function to get window color
Input:
UINT8 *Color	- Window Color
        INTN Level 		- Window Level
        UINT8 Type		- Window Type (0->Setup, 1->PostMenu)
Output:
status
Built on 16:20:15 10/01/14


StyleHandleControlOverflow in the stylecommon.c

Function : StyleHandleControlOverflow

File: stylecommon.c
Description:
Function to handle control overflow
Input:
FRAME_DATA *frame, CONTROL_DATA *control, UINT16 count
Output:
EFI_STATUS
Built on 16:20:16 10/01/14


StyleHelpAreaScrollable in the stylecommon.c

Function : StyleHelpAreaScrollable

File: stylecommon.c
Description:
Function to get Help area scroll support
Input:
VOID
Output:
BOOLEAN
Built on 16:20:16 10/01/14


StyleInit in the stylecommon.c

Function : StyleInit

File: stylecommon.c
Description:
Function to Initialize style
Input:
VOID
Output:
VOID
Built on 16:20:16 10/01/14


StyleInitializeFrame in the stylecommon.c

Function : StyleInitializeFrame

File: stylecommon.c
Description:
Function to Initialize frame
Input:
FRAME_DATA *frame, UINT32 frameType, PAGE_INFO *data
Output:
EFI_STATUS
Built on 16:20:16 10/01/14


StyleLabelCallback in the stylecommon.c

Function : StyleLabelCallback

File: stylecommon.c
Description:
Function to set label callback
Input:
FRAME_DATA *frame, LABEL_DATA *label, VOID *cookie
Output:
VOID
Built on 16:20:16 10/01/14


StyleLanguagePage in the stylecommon.c

Function : StyleLanguagePage

File: stylecommon.c
Description:
Function to set Language page
Input:
SUBMENU_DATA *submenu
Output:
UINT16 page number
Built on 16:20:16 10/01/14


StyleOverRideComponent in the stylecommon.c

Function : StyleOverRideComponent

File: stylecommon.c
Description:
Function to override component or control functionality
Input:
VOID
Output:
VOID
Built on 16:20:16 10/01/14


StylePageItemFocus in the stylecommon.c

Function : StylePageItemFocus

File: stylecommon.c
Description:
This function is called whenever a user navigates to a new page.
        OEMs may use this hook to set item focus.
        The default behavior sets focus to the previously focused page item.
Input:
PAGE_DATA *page, FRAME_DATA *frame
Output:
VOID
Built on 16:20:16 10/01/14


StyleSelectFirstDisplayPage in the stylecommon.c

Function : StyleSelectFirstDisplayPage

File: stylecommon.c
Description:
Function to set the first display page
Input:
VOID
Output:
VOID
Built on 16:20:16 10/01/14


StyleShowDay in the stylecommon.c

Function : StyleShowDay

File: stylecommon.c
Description:
Function to show day in date format
Input:
VOID
Output:
BOOLEAN
Built on 16:20:16 10/01/14


StyleSubPageItemFocus in the stylecommon.c

Function : StyleSubPageItemFocus

File: stylecommon.c
Description:
This function is called whenever a user returns (or navigates back)
        from a submenu page causing a complete page redraw. OEMs may use this hook to set item focus.
        The default behavior sets focus to the previously focused page item.
Input:
PAGE_DATA *page, FRAME_DATA *frame
Output:
VOID
Built on 16:20:16 10/01/14


StyleUpdateFrameStrings in the stylecommon.c

Function : StyleUpdateFrameStrings

File: stylecommon.c
Description:
Function to update frame strings
Input:
PAGE_DATA *page
Output:
VOID
Built on 16:20:16 10/01/14


StyleUpdateVersionString in the stylecommon.c

Function : StyleUpdateVersionString

File: stylecommon.c
Description:
Function to set the version string
Input:
VOID
Output:
VOID
Built on 16:20:16 10/01/14


StyleHook.h

Description:
Style Hook List.
Built on 16:20:21 10/01/14


StyleHook.mak

Description:
Empty Style Hooks Module part makefile
Built on 16:20:21 10/01/14


styleHook1.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook1.c.

Function | Description
StyleGetPageFrames | Function to number of frames

Built on 16:20:21 10/01/14


StyleGetPageFrames in the styleHook1.c

Function : StyleGetPageFrames

File: styleHook1.c
Description:
Function to number of frames
Input:
UINT32 page
Output:
UINT32 number of frames
Built on 16:20:15 10/01/14


styleHook10.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook10.c.

Function | Description
StyleInit | Function to Initialize style

Built on 16:20:21 10/01/14


StyleInit in the styleHook10.c

Function : StyleInit

File: styleHook10.c
Description:
Function to Initialize style
Input:
VOID
Output:
VOID
Built on 16:20:16 10/01/14


styleHook11.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook11.c.

Function | Description
StyleDrawPageBorder | Function to draw the page border

Built on 16:20:21 10/01/14


StyleDrawPageBorder in the styleHook11.c

Function : StyleDrawPageBorder

File: styleHook11.c
Description:
Function to draw the page border
Input:
UINT32 page number
Output:
VOID
Built on 16:20:15 10/01/14


styleHook12.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook12.c.

Function | Description
StyleSelectFirstDisplayPage | Function to set the first display page

Built on 16:20:21 10/01/14


StyleSelectFirstDisplayPage in the styleHook12.c

Function : StyleSelectFirstDisplayPage

File: styleHook12.c
Description:
Function to set the first display page
Input:
VOID
Output:
VOID
Built on 16:20:16 10/01/14


styleHook13.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook13.c.

Function | Description
StyleAddExtraPagesData | Function to add extra pages

Built on 16:20:21 10/01/14


StyleAddExtraPagesData in the styleHook13.c

Function : StyleAddExtraPagesData

File: styleHook13.c
Description:
Function to add extra pages
Input:
VOID
Output:
VOID
Built on 16:20:15 10/01/14


styleHook14.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook14.c.

Function | Description
StyleGetWindowColor | Function to get window color

Built on 16:20:21 10/01/14


StyleGetWindowColor in the styleHook14.c

Function : StyleGetWindowColor

File: styleHook14.c
Description:
Function to get window color
Input:
UINT8 *Color	- Window Color
        INTN Level 		- Window Level
        UINT8 Type		- Window Type (0->Setup, 1->PostMenu)
Output:
status
Built on 16:20:16 10/01/14


styleHook15.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook15.c.

Function | Description
StyleInitializeFrame | Function to Initialize frame

Built on 16:20:21 10/01/14


StyleInitializeFrame in the styleHook15.c

Function : StyleInitializeFrame

File: styleHook15.c
Description:
Function to Initialize frame
Input:
FRAME_DATA *frame, UINT32 frameType, PAGE_INFO *data
Output:
EFI_STATUS
Built on 16:20:16 10/01/14


styleHook16.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook16.c.

Function | Description
StyleGetMessageboxColor | Function to get control Messagebox color

Built on 16:20:21 10/01/14


StyleGetMessageboxColor in the styleHook16.c

Function : StyleGetMessageboxColor

File: styleHook16.c
Description:
Function to get control Messagebox color
Input:
UINT16 ControlType, UINT8 *Color
Output:
status
Built on 16:20:15 10/01/14


styleHook17.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook17.c.

Function | Description
StyleDrawScrollBar | Function to draw the frame scrollbar

Built on 16:20:21 10/01/14


StyleDrawScrollBar in the styleHook17.c

Function : StyleDrawScrollBar

File: styleHook17.c
Description:
Function to draw the frame scrollbar
Input:
FRAME_DATA *frame, UINT32 FirstLine, UINT32 LastLine, UINT32 modVal, UINT32 sizeOfBar, UINT32 numOfBlocks, BOOLEAN bEraseScrollBar
Output:
VOID
Built on 16:20:15 10/01/14


styleHook18.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook18.c.

Function | Description
StyleFrameDrawable | Function to determine if frame is drawable

Built on 16:20:21 10/01/14


StyleFrameDrawable in the styleHook18.c

Function : StyleFrameDrawable

File: styleHook18.c
Description:
Function to determine if frame is drawable
Input:
FRAME_DATA *frame
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


styleHook19.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook19.c.

Function | Description
StyleGetScrollBarColor | Function to get scrollbar color

Built on 16:20:21 10/01/14


StyleGetScrollBarColor in the styleHook19.c

Function : StyleGetScrollBarColor

File: styleHook19.c
Description:
Function to get scrollbar color
Input:
VOID
Output:
FGCOLOR|BGCOLOR
Built on 16:20:15 10/01/14


styleHook2.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook2.c.

Function | Description
StyleControlColor | Adds controls to the frame

Built on 16:20:21 10/01/14


StyleControlColor in the styleHook2.c

Function : StyleControlColor

File: styleHook2.c
Description:
Adds controls to the frame
Input:
FRAME_DATA *frame  - Pointer to the frame data
    STYLECOLORS Colors - Color scheme
Output:
EFI_STATUS Status - EFI_SUCCESS if successful, else
                                EFI_UNSUPPORTED
Built on 16:20:15 10/01/14


styleHook20.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook20.c.

Function | Description
StyleGetScrollBarDownArrowColor | Function to get scrollbar downarrow color

Built on 16:20:21 10/01/14


StyleGetScrollBarDownArrowColor in the styleHook20.c

Function : StyleGetScrollBarDownArrowColor

File: styleHook20.c
Description:
Function to get scrollbar downarrow color
Input:
VOID
Output:
FGCOLOR|BGCOLOR
Built on 16:20:15 10/01/14


styleHook21.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook21.c.

Function | Description
StyleHandleControlOverflow | Function to handle control overflow

Built on 16:20:21 10/01/14


StyleHandleControlOverflow in the styleHook21.c

Function : StyleHandleControlOverflow

File: styleHook21.c
Description:
Function to handle control overflow
Input:
FRAME_DATA *frame, CONTROL_DATA *control, UINT16 count
Output:
EFI_STATUS
Built on 16:20:16 10/01/14


styleHook22.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook22.c.

Function | Description
StyleFrameSetControlPositions | Function to set control positioning in a frame

Built on 16:20:21 10/01/14


StyleFrameSetControlPositions in the styleHook22.c

Function : StyleFrameSetControlPositions

File: styleHook22.c
Description:
Function to set control positioning in a frame
Input:
FRAME_DATA *frame, UINT32 *pOtherEnd
Output:
VOID
Built on 16:20:15 10/01/14


styleHook23.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook23.c.

Function | Description
StyleGetScrollBehavior | Function to get scroll behavior

Built on 16:20:21 10/01/14


StyleGetScrollBehavior in the styleHook23.c

Function : StyleGetScrollBehavior

File: styleHook23.c
Description:
Function to get scroll behavior
Input:
VOID
Output:
BOOLEAN
Built on 16:20:15 10/01/14


styleHook24.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook24.c.

Function | Description
StyleFrameHandleTimer | Function to handle frame timer action

Built on 16:20:21 10/01/14


StyleFrameHandleTimer in the styleHook24.c

Function : StyleFrameHandleTimer

File: styleHook24.c
Description:
Function to handle frame timer action
Input:
FRAME_DATA *frame, ACTION_DATA *action
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


styleHook25.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook25.c.

Function | Description
StyleFrameHandleMouse | Function to handle frame using mouse

Built on 16:20:21 10/01/14


StyleFrameHandleMouse in the styleHook25.c

Function : StyleFrameHandleMouse

File: styleHook25.c
Description:
Function to handle frame using mouse
Input:
FRAME_DATA *frame,
        MOUSE_INFO MouseInfo
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


styleHook26.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook26.c.

Function | Description
StyleFrameHandleKey | Function to handle frame action keys

Built on 16:20:21 10/01/14


StyleFrameHandleKey in the styleHook26.c

Function : StyleFrameHandleKey

File: styleHook26.c
Description:
Function to handle frame action keys
Input:
FRAME_DATA *frame, EFI_INPUT_KEY Key
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


styleHook27.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook27.c.

Function | Description
StyleGetFrameInitData | Function to get frame initialization data

Built on 16:20:21 10/01/14


StyleGetFrameInitData in the styleHook27.c

Function : StyleGetFrameInitData

File: styleHook27.c
Description:
Function to get frame initialization data
Input:
UINT32 page number, UINT32 frame number
Output:
VOID
Built on 16:20:15 10/01/14


styleHook28.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook28.c.

Function | Description
StyleGetNavToken | Function to get navigation token

Built on 16:20:21 10/01/14


StyleGetNavToken in the styleHook28.c

Function : StyleGetNavToken

File: styleHook28.c
Description:
Function to get navigation token
Input:
UINT32 page
Output:
UINT16 token number
Built on 16:20:15 10/01/14


styleHook29.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook29.c.

Function | Description
StyleUpdateFrameStrings | Function to update frame strings

Built on 16:20:21 10/01/14


StyleUpdateFrameStrings in the styleHook29.c

Function : StyleUpdateFrameStrings

File: styleHook29.c
Description:
Function to update frame strings
Input:
PAGE_DATA *page
Output:
VOID
Built on 16:20:16 10/01/14


styleHook3.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook3.c.

Function | Description
StyleGetClearScreenColor | Function to Get Clear Screen Color

Built on 16:20:21 10/01/14


StyleGetClearScreenColor in the styleHook3.c

Function : StyleGetClearScreenColor

File: styleHook3.c
Description:
Function to Get Clear Screen Color
Input:
VOID
Output:
STYLE_CLEAR_SCREEN_COLOR
Built on 16:20:15 10/01/14


styleHook30.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook30.c.

Function | Description
StyleAddAdditionalControls | Function to add additinal controls

Built on 16:20:21 10/01/14


StyleAddAdditionalControls in the styleHook30.c

Function : StyleAddAdditionalControls

File: styleHook30.c
Description:
Function to add additinal controls
Input:
FRAME_DATA *frame, UINT32 controlNumber, BOOLEAN focus
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


styleHook31.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook31.c.

Function | Description
StyleSubPageItemFocus | This function is called whenever a user returns (or navigates back) from a submenu page causing a complete page redraw. OEMs may use this hook to set item focus. The default behavior sets focus to the previously focused page item.

Built on 16:20:21 10/01/14


StyleSubPageItemFocus in the styleHook31.c

Function : StyleSubPageItemFocus

File: styleHook31.c
Description:
This function is called whenever a user returns (or navigates back)
        from a submenu page causing a complete page redraw. OEMs may use this hook to set item focus.
        The default behavior sets focus to the previously focused page item.
Input:
PAGE_DATA *page, FRAME_DATA *frame
Output:
VOID
Built on 16:20:16 10/01/14


styleHook32.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook32.c.

Function | Description
StylePageItemFocus | This function is called whenever a user navigates to a new page. OEMs may use this hook to set item focus. The default behavior sets focus to the previously focused page item.

Built on 16:20:21 10/01/14


StylePageItemFocus in the styleHook32.c

Function : StylePageItemFocus

File: styleHook32.c
Description:
This function is called whenever a user navigates to a new page.
        OEMs may use this hook to set item focus.
        The default behavior sets focus to the previously focused page item.
Input:
PAGE_DATA *page, FRAME_DATA *frame
Output:
VOID
Built on 16:20:16 10/01/14


styleHook33.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook33.c.

Function | Description
StyleBeforeFrame | Function to alter frame styling before frame is drawn

Built on 16:20:21 10/01/14


StyleBeforeFrame in the styleHook33.c

Function : StyleBeforeFrame

File: styleHook33.c
Description:
Function to alter frame styling before frame is drawn
Input:
FRAME_DATA *frame
Output:
VOID
Built on 16:20:15 10/01/14


styleHook34.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook34.c.

Function | Description
StyleGetSpecialColor | Function to get control special color

Built on 16:20:21 10/01/14


StyleGetSpecialColor in the styleHook34.c

Function : StyleGetSpecialColor

File: styleHook34.c
Description:
Function to get control special color
Input:
UINT16 ControlType, UINT8 *Color
Output:
status
Built on 16:20:15 10/01/14


styleHook35.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook35.c.

Function | Description
StyleDrawHelpScrollBar | Function to draw the help frame scrollbar

Built on 16:20:21 10/01/14


StyleDrawHelpScrollBar in the styleHook35.c

Function : StyleDrawHelpScrollBar

File: styleHook35.c
Description:
Function to draw the help frame scrollbar
Input:
MEMO_DATA *memo, UINT16 height
Output:
VOID
Built on 16:20:15 10/01/14


styleHook36.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook36.c.

Function | Description
StyleGetShadowSupport | Function to get shadow support

Built on 16:20:21 10/01/14


StyleGetShadowSupport in the styleHook36.c

Function : StyleGetShadowSupport

File: styleHook36.c
Description:
Function to get shadow support
Input:
VOID
Output:
BOOLEAN
Built on 16:20:15 10/01/14


styleHook37.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook37.c.

Function | Description
StyleFrameIndexOf | Function to get frame index

Built on 16:20:21 10/01/14


StyleFrameIndexOf in the styleHook37.c

Function : StyleFrameIndexOf

File: styleHook37.c
Description:
Function to get frame index
Input:
UINT32 frameType
Output:
UINT32 index
Built on 16:20:15 10/01/14


styleHook38.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook38.c.

Function | Description
StyleFrameAddTitle | Function to add frame title

Built on 16:20:21 10/01/14


StyleFrameAddTitle in the styleHook38.c

Function : StyleFrameAddTitle

File: styleHook38.c
Description:
Function to add frame title
Input:
FRAME_DATA *frame, UINT32 frameType, CONTROL_INFO * dummy
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


styleHook39.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook39.c.

Function | Description
StyleGetScrollBarUpArrowColor | Function to get scrollbar UpArrow Color

Built on 16:20:22 10/01/14


StyleGetScrollBarUpArrowColor in the styleHook39.c

Function : StyleGetScrollBarUpArrowColor

File: styleHook39.c
Description:
Function to get scrollbar UpArrow Color
Input:
VOID
Output:
FGCOLOR|BGCOLOR
Built on 16:20:15 10/01/14


styleHook4.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook4.c.

Function | Description
StyleOverRideComponent | Function to override component or control functionality

Built on 16:20:22 10/01/14


StyleOverRideComponent in the styleHook4.c

Function : StyleOverRideComponent

File: styleHook4.c
Description:
Function to override component or control functionality
Input:
VOID
Output:
VOID
Built on 16:20:16 10/01/14


styleHook5.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook5.c.

Function | Description
StyleUpdateVersionString | Function to set the version string

Built on 16:20:22 10/01/14


StyleUpdateVersionString in the styleHook5.c

Function : StyleUpdateVersionString

File: styleHook5.c
Description:
Function to set the version string
Input:
VOID
Output:
VOID
Built on 16:20:16 10/01/14


styleHook6.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook6.c.

Function | Description
StyleGetStdMaxCols | Function to get max number of rows

Built on 16:20:22 10/01/14


StyleGetStdMaxCols in the styleHook6.c

Function : StyleGetStdMaxCols

File: styleHook6.c
Description:
Function to get max number of rows
Input:
VOID
Output:
STYLE_STD_MAX_COLS
Built on 16:20:15 10/01/14


styleHook7.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook7.c.

Function | Description
StyleGetStdMaxRows | Function to max number of columns

Built on 16:20:22 10/01/14


StyleGetStdMaxRows in the styleHook7.c

Function : StyleGetStdMaxRows

File: styleHook7.c
Description:
Function to max number of columns
Input:
VOID
Output:
STYLE_STD_MAX_ROWS
Built on 16:20:15 10/01/14


styleHook8.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook8.c.

Function | Description
StyleGetTextMode | Function to get text mode

Built on 16:20:22 10/01/14


StyleGetTextMode in the styleHook8.c

Function : StyleGetTextMode

File: styleHook8.c
Description:
Function to get text mode
Input:
UINTN Rows, UINTN Cols
Output:
UNNTN mode
Built on 16:20:15 10/01/14


styleHook9.c

Description:
Contains generic or default style functions.

The following functions are used in the file: styleHook9.c.

Function | Description
StyleExit | Function to do style initialization on exit

Built on 16:20:22 10/01/14


StyleExit in the styleHook9.c

Function : StyleExit

File: styleHook9.c
Description:
Function to do style initialization on exit
Input:
VOID
Output:
VOID
Built on 16:20:15 10/01/14


StyleTokens.c

Description:
This file does not add any code. It has, all the string tokens that
are used by Minisetup, to fake the usage to strgather.exe. Add to
this list, the new string tokens that are defined in
AmiTSEStrstr.uni and to be used by Minisetup
Built on 16:20:22 10/01/14


SubMenu.c

Description:
This file contains code to handle submenu operations

The following functions are used in the file: SubMenu.c.

Function | Description
SubMenuCreate | this function uses the create function of control and create submenu.
SubMenuDestroy | this function uses the destroy function of control and destroys submenu.
SubMenuDraw | function to draw a sub-menu.
SubMenuGetControlHeight | Function to get the label height of the submenu
SubMenuHandleAction | function to handle the submenu actions
SubMenuSetAttributes | Function to set attributes.
SubMenuSetCallback | function to handle the submenu actions
SubMenuSetDimensions | Function to set dimension.
SubMenuSetFocus | Function to handle the submenu actions
SubMenuSetPosition | Function to set position.

Built on 16:20:22 10/01/14


SubMenuCreate in the SubMenu.c

Function : SubMenuCreate

File: SubMenu.c
Description:
this function uses the create function of control
            and create submenu.
Input:
SUBMENU_DATA **object
Output:
status
Built on 16:20:16 10/01/14


SubMenuDestroy in the SubMenu.c

Function : SubMenuDestroy

File: SubMenu.c
Description:
this function uses the destroy function of control
            and destroys submenu.
Input:
SUBMENU_DATA *submenu, BOOLEAN freeMem
Output:
status
Built on 16:20:16 10/01/14


SubMenuDraw in the SubMenu.c

Function : SubMenuDraw

File: SubMenu.c
Description:
function to draw a sub-menu.
Input:
SUBMENU_DATA *submenu
Output:
status
Built on 16:20:16 10/01/14


SubMenuGetControlHeight in the SubMenu.c

Function : SubMenuGetControlHeight

File: SubMenu.c
Description:
Function to get the label height of the submenu
Input:
SUBMENU_DATA *submenu, Frame Data, UINT16 *height
Output:
Status
Built on 16:20:16 10/01/14


SubMenuHandleAction in the SubMenu.c

Function : SubMenuHandleAction

File: SubMenu.c
Description:
function to handle the submenu actions
Input:
SUBMENU_DATA *submenu, ACTION_DATA *Data
Output:
status
Built on 16:20:16 10/01/14


SubMenuSetAttributes in the SubMenu.c

Function : SubMenuSetAttributes

File: SubMenu.c
Description:
Function to set attributes.
Input:
SUBMENU_DATA *submenu, UINT8 FGColor, UINT8 BGColor
Output:
STATUS
Built on 16:20:16 10/01/14


SubMenuSetCallback in the SubMenu.c

Function : SubMenuSetCallback

File: SubMenu.c
Description:
function to handle the submenu actions
Input:
SUBMENU_DATA *submenu, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
status
Built on 16:20:16 10/01/14


SubMenuSetDimensions in the SubMenu.c

Function : SubMenuSetDimensions

File: SubMenu.c
Description:
Function to set dimension.
Input:
SUBMENU_DATA *submenu, UINT16 Width, UINT16 Height
Output:
STATUS
Built on 16:20:16 10/01/14


SubMenuSetFocus in the SubMenu.c

Function : SubMenuSetFocus

File: SubMenu.c
Description:
Function to handle the submenu actions
Input:
SUBMENU_DATA *submenu, BOOLEAN focus
Output:
Status
Built on 16:20:16 10/01/14


SubMenuSetPosition in the SubMenu.c

Function : SubMenuSetPosition

File: SubMenu.c
Description:
Function to set position.
Input:
SUBMENU_DATA *submenu, UINT16 Left, UINT16 Top
Output:
STATUS
Built on 16:20:16 10/01/14


SubMenu.h

Description:
Header file for submenu related functionalities
Built on 16:20:22 10/01/14


Text.c

Description:
This file contains code to handle text operations

The following functions are used in the file: Text.c.

Function | Description
TextCreate | this function uses the create function of control and creates text
TextDestroy | this function uses the destroy function of control and destroys the text
TextDraw | function to draw the text with attributes.
TextGetControlHeight | function to get the text height
TextHandleAction | function to handle the text actions
TextSetAttributes | Function to set text attributes.
TextSetCallback | Function to set callback.
TextSetDimensions | Function to set text dimension.
TextSetFocus | Function to set focus.
TextSetPosition | Function to set position.
TextSetText | function to set the text

Built on 16:20:22 10/01/14


TextCreate in the Text.c

Function : TextCreate

File: Text.c
Description:
this function uses the create function of control
            and creates text
Input:
TEXT_DATA **object
Output:
status
Built on 16:20:16 10/01/14


TextDestroy in the Text.c

Function : TextDestroy

File: Text.c
Description:
this function uses the destroy function of control
            and destroys the text
Input:
TEXT_DATA *text, BOOLEAN freeMem
Output:
status
Built on 16:20:16 10/01/14


TextDraw in the Text.c

Function : TextDraw

File: Text.c
Description:
function to draw the text with attributes.
Input:
TEXT_DATA *text
Output:
status
Built on 16:20:16 10/01/14


TextGetControlHeight in the Text.c

Function : TextGetControlHeight

File: Text.c
Description:
function to get the text height
Input:
TEXT_DATA *text, Frame,  UINT16 *height
Output:
status
Built on 16:20:16 10/01/14


TextHandleAction in the Text.c

Function : TextHandleAction

File: Text.c
Description:
function to handle the text actions
Input:
TEXT_DATA *text, ACTION_DATA *Data
Output:
status
Built on 16:20:16 10/01/14


TextSetAttributes in the Text.c

Function : TextSetAttributes

File: Text.c
Description:
Function to set text attributes.
Input:
TEXT_DATA *text, UINT8 FGColor, UINT8 BGColor
Output:
STATUS
Built on 16:20:16 10/01/14


TextSetCallback in the Text.c

Function : TextSetCallback

File: Text.c
Description:
Function to set callback.
Input:
TEXT_DATA *text, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
STATUS
Built on 16:20:16 10/01/14


TextSetDimensions in the Text.c

Function : TextSetDimensions

File: Text.c
Description:
Function to set text dimension.
Input:
TEXT_DATA *text, UINT16 Width, UINT16 Height
Output:
STATUS
Built on 16:20:16 10/01/14


TextSetFocus in the Text.c

Function : TextSetFocus

File: Text.c
Description:
Function to set focus.
Input:
TEXT_DATA *text, BOOLEAN focus
Output:
STATUS
Built on 16:20:16 10/01/14


TextSetPosition in the Text.c

Function : TextSetPosition

File: Text.c
Description:
Function to set position.
Input:
TEXT_DATA *text, UINT16 Left, UINT16 Top
Output:
STATUS
Built on 16:20:16 10/01/14


TextSetText in the Text.c

Function : TextSetText

File: Text.c
Description:
function to set the text
Input:
TEXT_DATA *text, CHAR16 *label, CHAR16 *value
Output:
status
Built on 16:20:16 10/01/14


Text.h

Description:
Header file for code to handle text operations
Built on 16:20:22 10/01/14


time.c

Description:
This file contains code to handle Time control operations

The following functions are used in the file: time.c.

Function | Description
_TimeDecrease | to decrease the time, i.e. Hours/Mins/Secs based on the selection
_TimeHandleActionKeyMouse | function to handle the action key of time
_TimeIncrease | to increase the time, i.e. Hours/Mins/Secs based on the selection
_TimeUpdateEntry | function to update the entries in Time
_TimeUpdateHelp | function to update the help of time
TimeCreate | this function uses the create function of control and creates and sets the timer
TimeDestroy | this function uses the destroy function of control and destroys the timer
TimeDraw | function to draw time with attributes
TimeGetControlHeight | Function to set time height.
TimeHandleAction | function to handle the actions of time
TimeInitialize | this function uses the Initialize function of control and initializes the time
TimeSetAttributes | Function to set time attributes.
TimeSetCallback | Function to set callback.
TimeSetDimensions | Function to set time dimension.
TimeSetFocus | Function to set focus.
TimeSetPosition | Function to set position.

Built on 16:20:22 10/01/14


_TimeDecrease in the time.c

Function : _TimeDecrease

File: time.c
Description:
to decrease the time, i.e. Hours/Mins/Secs based on the selection
Input:
TIME_DATA *time, UINT16 Selection
Output:
void
Built on 16:20:04 10/01/14


_TimeHandleActionKeyMouse in the time.c

Function : _TimeHandleActionKeyMouse

File: time.c
Description:
function to handle the action key of time
Input:
TIME_DATA *time,  ACTION_DATA *Data
Output:
status
Built on 16:20:04 10/01/14


_TimeIncrease in the time.c

Function : _TimeIncrease

File: time.c
Description:
to increase the time, i.e. Hours/Mins/Secs based on the selection
Input:
TIME_DATA *time, UINT16 Selection
Output:
void
Built on 16:20:04 10/01/14


_TimeUpdateEntry in the time.c

Function : _TimeUpdateEntry

File: time.c
Description:
function to update the entries in Time
Input:
TIME_DATA *time
Output:
void
Built on 16:20:04 10/01/14


_TimeUpdateHelp in the time.c

Function : _TimeUpdateHelp

File: time.c
Description:
function to update the help of time
Input:
TIME_DATA *time
Output:
void
Built on 16:20:04 10/01/14


TimeCreate in the time.c

Function : TimeCreate

File: time.c
Description:
this function uses the create function of control
            and creates and sets the timer
Input:
TIME_DATA **object
Output:
status
Built on 16:20:16 10/01/14


TimeDestroy in the time.c

Function : TimeDestroy

File: time.c
Description:
this function uses the destroy function of control
            and destroys the timer
Input:
TIME_DATA *time, BOOLEAN freeMem
Output:
status
Built on 16:20:16 10/01/14


TimeDraw in the time.c

Function : TimeDraw

File: time.c
Description:
function to draw time with attributes
Input:
TIME_DATA *time
Output:
status
Built on 16:20:16 10/01/14


TimeGetControlHeight in the time.c

Function : TimeGetControlHeight

File: time.c
Description:
Function to set time height.
Input:
TIME_DATA *time, frame, UINT16 *height
Output:
STATUS
Built on 16:20:16 10/01/14


TimeHandleAction in the time.c

Function : TimeHandleAction

File: time.c
Description:
function to handle the actions of time
Input:
TIME_DATA *time, ACTION_DATA *Data
Output:
status
Built on 16:20:16 10/01/14


TimeInitialize in the time.c

Function : TimeInitialize

File: time.c
Description:
this function uses the Initialize function of control
            and initializes the time
Input:
TIME_DATA *time, VOID *data
Output:
status
Built on 16:20:16 10/01/14


TimeSetAttributes in the time.c

Function : TimeSetAttributes

File: time.c
Description:
Function to set time attributes.
Input:
TIME_DATA *time, UINT8 FGColor, UINT8 BGColor
Output:
STATUS
Built on 16:20:16 10/01/14


TimeSetCallback in the time.c

Function : TimeSetCallback

File: time.c
Description:
Function to set callback.
Input:
TIME_DATA *time, OBJECT_DATA *container, OBJECT_CALLBACK callback, VOID *cookie
Output:
STATUS
Built on 16:20:16 10/01/14


TimeSetDimensions in the time.c

Function : TimeSetDimensions

File: time.c
Description:
Function to set time dimension.
Input:
TIME_DATA *time, UINT16 Width, UINT16 Height
Output:
STATUS
Built on 16:20:16 10/01/14


TimeSetFocus in the time.c

Function : TimeSetFocus

File: time.c
Description:
Function to set focus.
Input:
TIME_DATA *time, BOOLEAN focus
Output:
STATUS
Built on 16:20:16 10/01/14


TimeSetPosition in the time.c

Function : TimeSetPosition

File: time.c
Description:
Function to set position.
Input:
TIME_DATA *time, UINT16 Left, UINT16 Top
Output:
STATUS
Built on 16:20:16 10/01/14


Time.h

Description:
Header file for code to handle Time control operations
Built on 16:20:22 10/01/14


timer.c

Description:
This file contains code to handle the timer.

The following functions are used in the file: timer.c.

Function | Description
TimerCreateTimer | function to create a timer event and to set the timer
TimerStopTimer | function to stop the timer event.

Built on 16:20:22 10/01/14


TimerCreateTimer in the timer.c

Function : TimerCreateTimer

File: timer.c
Description:
function to create a timer event and to set the timer
Input:
EFI_EVENT *Event, EFI_EVENT_NOTIFY Callback,
        VOID *Context, EFI_TIMER_DELAY Delay, UINT64 Trigger,
        EFI_TPL CallBackTPL
Output:
status
Built on 16:20:16 10/01/14


TimerStopTimer in the timer.c

Function : TimerStopTimer

File: timer.c
Description:
function to stop the timer event.
Input:
EFI_EVENT *Event
Output:
status
Built on 16:20:16 10/01/14


Timer.h

Description:
Header file for code to handle the timer.
Built on 16:20:22 10/01/14


TSE Help Module

The following descriptions are used in the file: TSE Help Module.

Header | Description
Driver_Integration | * This is the case adding a new driver into an Aptio project. If driver source code is available, add the driver source and rebuild the project. * Verify all the protocols used are present in the project * Make sure the dependencies are compatible between driver and project * The new setup page can only appear as top level menu item * In case only binary form is available, next are requirements, * The adding driver must have a unique GUID from the project * If the adding driver uses platform variables, make sure the setup definition in the project and the adding driver is completely identical * If private variables are used, make sure it has a different GUID and variable names are unique * Both the driver’s DXE and HPK files are required to put into the project * Use Setup.ini to indicate the location of driver setup page * It’s impossible the new page to be a submenu of an existing page
HII_Package_files | Aptio TSE performs a Post-processing of the information that will be stored into HII and saves the result into a separate section of the driver in order to allow Post-build configuration. This requires that the HII Package files, created by Intel’s VFRCOMPILE utility, be generated as inputs to the Aptio TSE build. These files are generated based on a command line parameter to the VFRCOMPILE utility. This command line can be specified using the VFRCOMPILE_FLAGS SDL token. This SDL token must be set to "-ibin" in order to generate the HPK files.
How_to_add_a_page | Adding a page to a VFR is quite simple. There are 2 pieces that make up a new page: the reference to the page from an existing page, and the new page definition itself: // inside an existing form goto MY_SETUP_FORM_ID, prompt = STRING_TOKEN(STR_MY_SETUP_PAGE), help = STRING_TOKEN(STR_MY_SETUP_PAGE_HELP); // after all form definitions form formid = MY_SETUP_FORM_ID, title = STRING_TOKEN(STR_MY_SETUP_PAGE); subtitle text = STRING_TOKEN(STR_SOME_TEXT_STRING); // additional controls go here endform;
How_to_display_a_dynamic_value | Dynamic text is fully supported by TSE. Creating and modifying dynamic text needs to follow certain rules. A dynamic text control is simply a TEXT VFR control with the INTERACTIVE flag set to true. In this case, the FORM_CALLBACK.Callback function is called every 100ms to refresh the contents of the displayed control. It is the requirement of the callback routine to update the string in the HII database with the new value to be displayed. The callback interval can be managed in multiple ways. It can be changed in the setup data using a tool such as AMIBCP. It can also be managed programmatically in the callback routine itself. Example: #define CPU1_TEMP_KEY 0x1234 text help = STRING_TOKEN(STR_NULL_STRING), text = STRING_TOKEN(STR_CPU1_TEMP_PROMPT), text = STRING_TOKEN(STR_CPU1_TEMP_VAL), flags = INTERACTIVE, key = CPU1_TEMP_KEY; This definition into the VFR file will automatically cause TSE to create a dynamic text control. It is the responsibility of the callback routine (most likely published by a separate DXE driver) to update the temperature data. Sample pseudo-code for the callback is listed below: CHAR16 gUpdateString[256]; EFI_STATUS Callback( ..., UINT16 key, ... ) { switch ( key ) { case CPU1_TEMP_KEY : UINT16 stringRef = STRING_TOKEN(STR_CPU1_TEMP_VAL); UINTN cpuTemp = GetCPUTemp( CPU1 ); SPrint( gUpdateString, sizeof( gUpdateString ), L"%d", cpuTemp ); // this call to NewString replaces the string in HII HII->NewString( HII, L"eng", handle, &stringRef, gUpdateString ); break; } }
How_to_display_message_in_the_POST_screen | TSE publishes a function called DisplayPostMessage as part of AMI_POST_MANAGER (formerly MRE_HAND_SHAKE) protocol. Other drivers can use this function to display UNICODE strings in Post screen. Prototype for DisplayPostMessage is provided in AMIPostMgr.h typedef EFI_STATUS (EFIAPI *AMI_POST_MANAGER_DISPLAY_MESSAGE) ( CHAR16 *Message typedef struct _AMI_POST_MANAGER_PROTOCOL { AMI_POST_MANAGER_HANDSHAKE Handshake; AMI_POST_MANAGER_DISPLAY_MESSAGE DisplayPostMessage; }AMI_POST_MANAGER_PROTOCOL;
How_to_display_value_which_may_change_from_boot_to_boot | Changing strings can be accomplished through a couple of different means. One, which is used for such facilities as memory sizing and hard drive identification, is to update a string into HII that has been put there as a placeholder. For example, a memory VFR might look like: text help = STRING_TOKEN(STR_NULL_STRING), text = STRING_TOKEN(STR_TOTAL_MEMORY_SIZE_PROMPT), text = STRING_TOKEN(STR_MEMORY_SIZE_VAL), flags = 0, key = 0; In the firmware, there will be code that updates the place holder string STR_MEMORY_SIZE_VAL with the actual string for the size. For example, CHAR16 string[20] ; SPrint( string, 20, L"%dMB", memosrySize ) ; Hii->AddString( Hii, &token, string ) ; This can also be accomplished in concert by code into the firmware and the VFRs themselves. First, a structure should be defined into which the data to be shared is stored. Then, along with a name and GUID, a volatile EFI variable my be defined. This is accomplished by setting the variable WITHOUT the EFI_VARIABLE_NON_VOLATILE flag. // inside a firmware driver Status = gRT->SetVariable( L"MyVariable", &myGuid, EFI_VARIABLE_BOOTSERVICE_ACCESS, &myVariableStruct, sizeof(myVariableStruct) Into the VFR, a varstore must be created (similar to the one above) and used to access this variable.
How_to_gray_out_or_suppress_a_control | The following example shows how to gray out or suppress a control from within the VFR definition file. grayoutif ideqval SYSTEM_ACCESS.Access == SYSTEM_PASSWORD_USER; oneof varid = SetupMap.IdeMode, prompt = STRING_TOKEN(STR_IDE_MODE_PROMPT), help = STRING_TOKEN(STR_IDE_MODE_HELP), option text = STRING_TOKEN(STR_DISABLE), value = 0, flags = RESET_REQUIRED; option text = STRING_TOKEN(STR_ENABLE), value = 1, flags = DEFAULT | RESET_REQUIRED; endoneof; endif;
How_to_integrate_an_EFI_application | Integrating an EFI application into the setup data is very simply done, using AMI’s extensions. There are multiple steps involved in creating a launch, but none involve modifying source code. First, define your variable store within your VFR file. The actual structure of the variable store is not used, so we simply define a basic structure: typedef struct _MY_OEM_PACK { UINT16 Value; } MY_OEM_PACK; varstore MY_OEM_PACK, key = MY_OEM_PACK_KEY_ID, name = application.efi, guid = MY_OEM_PACK_GUID; The important things to keep in mind with the above definitions are that the GUID and the key uniquely identify your application. Next, define VFR entry as follows. It will always be a reference wrapped by a suppress clause: // compare against a non-zero value so the suppress condition will fail. suppressif ideqval MY_OEM_PACK.Value == 1; // OEM_FORM_ID can be either an empty form defined elsewhere in the VFR // or the containing form’s formid value goto OEM_FORM_ID, prompt = STRING_TOKEN(STR_MY_OEM_APPLICATION), help = STRING_TOKEN(STR_MY_APPLICATION_HELP); endif; Last step is to define your behavior into the SETUP.INI file so that TSE will understand the overridden HII construct. [GUIDx] ; where x is the next available GUID number in the file guid = XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX name = unused key = XXXX ; this should be the same key value defined in the varstore flags = 6 ; these are the flags that tell what the action to perform is ; the values can be Ored togeteher to create multiple actions: ; 1 – signifies that the callback is AMI internal ; 2 – the GUID is treated as a filename in FV and launched ; 4 – the name defined in the varstore is treated as an EFI ; executable name and is launched from the filesystem ; Using 4 and 2 together will try FV first, then filesystem
How_to_provide_Default_boot_order | To have this functionality; on every boot in addition to creating / updating "BootOrder" and "LegacyDevOrder" variables based on the addition and removal of boot devices; BDS should also create / update the variables "DefaultBootOrder" and "DefaultLegacyDevOrder". "DefaultBootOrder" and "DefaultLegacyDevOrder" are variables introduced to provide TSE with the default ordering of devices. TSE displays these default orders when the user is loading optimal defaults. Details of default boot order variable VariableName: "DefaultBootOrder" Guid: 45cf35f6-0d6e-4d04-856a-0370a5b16f53 Details of default legacy device order variable VariableName: "DefaultLegacyDeviceOrder" Guid: 3c4ead08-45ae-4315-8d15-a60eaa8caf69 PS: If these variables are not present TSE will load the values of the BootOrder and LeagacyDevOrder variables it entered with as default values
How_To_Switch_to_different_Style | Clone and change the following SDL token settings. Ezport Style TSE_STYLE_EZPORT_BIN_SUPPORT = ON TSE_STYLE_EZPORT_SUPPORT = ON TSE_STYLE_LEGACY_BIN_SUPPORT = OFF TSE_STYLE_LEGACY_SUPPORT = OFF TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = OFF TSE_STYLE_EZPORTPLUS_SUPPORT = OFF Legacy Style TSE_STYLE_EZPORT_BIN_SUPPORT = OFF TSE_STYLE_EZPORT_SUPPORT = OFF TSE_STYLE_LEGACY_BIN_SUPPORT = ON TSE_STYLE_LEGACY_SUPPORT = ON TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = OFF TSE_STYLE_EZPORTPLUS_SUPPORT = OFF EzportPlus Style TSE_STYLE_EZPORT_BIN_SUPPORT = OFF TSE_STYLE_EZPORT_SUPPORT = OFF TSE_STYLE_LEGACY_BIN_SUPPORT = OFF TSE_STYLE_LEGACY_SUPPORT = OFF TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = ON TSE_STYLE_EZPORTPLUS_SUPPORT = ON
Image_formats | The OEM logo image that is used in Aptio TSE is BMP and GIF format. Future versions will support other image formats (like PCX and JPG). There are no color depth restrictions for this image. The image cannot be an RLE encoded bitmap or otherwise compressed bitmap. Compression is referring to image compression as defined by the BMP format, not EFI compression. The image is designed to fit into a specified area of the screen. The dimensions of the image file should be set accordingly. The default image dimensions are listed below, SmLogo: 400x100
Localization | One of the many features of Aptio, is the ability to easily work with multiple languages. Aptio TSE is no exception. Aptio TSE uses the exact same .UNI string management as the Aptio project itself.
Post | Any of the images associated with Aptio can be modified after the firmware has been built using the AMI ChangeLogo tool. The rendering information may be modified together with other information like Optimal and Failsafe values may be customized after the firmware has been built using the AMIBCP tool.
Setup_path_in_MINISETUP | Since Aptio TSE accesses the default setup NVRAM storage directly, it is important that the correct layout of the NVRAM variable is known by TSE. This requires TSE to include the SetupVariable.h header file specific to the current project. This header file will be located in the SAME directory where the setup .VFR files are kept. The SETUP_PATH variable in the MINISETUP.MAK must match the path, relative to the root of the Aptio project. For example, for an Intel D865GCH R6-based Aptio project, this should be set as follows, SETUP_PATH = Platform\IntelDpg\D865GCH\DXE\D865GCHPlatform\Setup
TSE_FAQ | Q: The strings do not show up on the screen. A: There are several possible solutions to this problem. There could be an issue with the VFR creation. TSE expects each formset in the VFR files to have the same GUID but unique CLASS and SUBCLASS identifiers. There could be strings that are not defined into the .UNI file. This is unlikely as this would be caught during the build process. Q: Setup doesn't find any of my pages. A: Make sure that the GUID defined for your formsets matches the GUID defined into the main section of the SETUP.INI file. Q: How do I use multiple variables? A: TSE fully supports multiple variables defined into the VFR files. But, there is a caveat. The default variable (usually defined using the formset GUID and the name "Setup") must also be re-defined. This is a workaround for a faulty VFR compiler. These variables should be defined using the VFR command varstore. See the previous section for examples of how to use the varstore command. Q: How do I use the reference VFR files that are included into the TSE package? A: These VFR files are used in exactly the same way the platform VFR files are used. There are a couple of things that need to be modified into the platform code to install them. The .CIF file that includes the VFR files for the platform should be modified to reflect the new files. The file PLATFORM.C should be modified to install the new HII packs into the HII database. This includes defining new variables for the new VFR binaries, adding these binaries to the function call that installs the HII packs, etc. The VFR files should be copied to the platform setup directory to be included into the build process.

Built on 16:20:22 10/01/14


Driver_Integration in the TSE Help Module

General : Driver_Integration

File: TSE Help Module
Description:
* This is the case adding a new driver into an Aptio project. If driver source
  code is available, add the driver source and rebuild the project.
* Verify all the protocols used are present in the project
* Make sure the dependencies are compatible between driver and project
* The new setup page can only appear as top level menu item
* In case only binary form is available, next are requirements,
* The adding driver must have a unique GUID from the project
* If the adding driver uses platform variables, make sure the setup definition in the
  project and the adding driver is completely identical
* If private variables are used, make sure it has a different GUID and variable names
  are unique
* Both the driver’s DXE and HPK files are required to put into the project
* Use Setup.ini to indicate the location of driver setup page
* It’s impossible the new page to be a submenu of an existing page
Built on 16:20:07 10/01/14


HII_Package_files in the TSE Help Module

General : HII_Package_files

File: TSE Help Module
Description:
Aptio TSE performs a Post-processing of the information that will be
stored into HII and saves the result into a separate section of the driver in order
to allow Post-build configuration.  This requires that the HII Package files, created
by Intel’s VFRCOMPILE utility, be generated as inputs to the Aptio TSE build.
These files are generated based on a command line parameter to the VFRCOMPILE utility.
This command line can be specified using the VFRCOMPILE_FLAGS SDL token.  This SDL
token must be set to "-ibin" in order to generate the HPK files.
Built on 16:20:09 10/01/14


How_to_add_a_page in the TSE Help Module

General : How_to_add_a_page

File: TSE Help Module
Description:
Adding a page to a VFR is quite simple.  There are 2 pieces that make up
a new page: the reference to the page from an existing page, and the new page
definition itself:

    // inside an existing form
    goto MY_SETUP_FORM_ID,
    prompt = STRING_TOKEN(STR_MY_SETUP_PAGE),
    help = STRING_TOKEN(STR_MY_SETUP_PAGE_HELP);

    // after all form definitions
    form
        formid = MY_SETUP_FORM_ID,
        title = STRING_TOKEN(STR_MY_SETUP_PAGE);

    subtitle text = STRING_TOKEN(STR_SOME_TEXT_STRING);

    // additional controls go here

    endform;
Built on 16:20:09 10/01/14


How_to_display_a_dynamic_value in the TSE Help Module

General : How_to_display_a_dynamic_value

File: TSE Help Module
Description:
Dynamic text is fully supported by TSE.  Creating and modifying
dynamic text needs to follow certain rules. A dynamic text control is simply a
TEXT VFR control with the INTERACTIVE flag set to true.  In this case, the
FORM_CALLBACK.Callback function is called every 100ms to refresh the contents
of the displayed control.  It is the requirement of the callback routine to
update the string in the HII database with the new value to be displayed.

The callback interval can be managed in multiple ways.  It can be changed in
the setup data using a tool such as AMIBCP.  It can also be managed
programmatically in the callback routine itself.
    Example:

    #define	CPU1_TEMP_KEY	0x1234

    text
            help   = STRING_TOKEN(STR_NULL_STRING),
            text   = STRING_TOKEN(STR_CPU1_TEMP_PROMPT),
            text   = STRING_TOKEN(STR_CPU1_TEMP_VAL),
            flags  = INTERACTIVE,
            key    = CPU1_TEMP_KEY;

This definition into the VFR file will automatically cause TSE to create a dynamic
text control.  It is the responsibility of the callback routine (most likely
published by a separate DXE driver) to update the temperature data.  Sample
pseudo-code for the callback is listed below:

        CHAR16	gUpdateString[256];

        EFI_STATUS Callback( ..., UINT16 key, ... )
        {
        switch ( key )
        {
        case CPU1_TEMP_KEY :
            UINT16 stringRef = STRING_TOKEN(STR_CPU1_TEMP_VAL);
            UINTN cpuTemp = GetCPUTemp( CPU1 );
            SPrint( gUpdateString, sizeof( gUpdateString ),
        L"%d", cpuTemp );
                    // this call to NewString replaces the string in HII
                    HII->NewString( HII, L"eng", handle,
        &stringRef, gUpdateString );
                    break;
        }
        }
Built on 16:20:09 10/01/14


How_to_display_message_in_the_POST_screen in the TSE Help Module

General : How_to_display_message_in_the_POST_screen

File: TSE Help Module
Description:
TSE publishes a function called DisplayPostMessage as part of
AMI_POST_MANAGER (formerly MRE_HAND_SHAKE) protocol. Other drivers can use
this function to display UNICODE strings in Post screen.

Prototype for DisplayPostMessage is provided in AMIPostMgr.h

typedef
EFI_STATUS
(EFIAPI *AMI_POST_MANAGER_DISPLAY_MESSAGE) (
    CHAR16	*Message
typedef struct _AMI_POST_MANAGER_PROTOCOL
{
    AMI_POST_MANAGER_HANDSHAKE			Handshake;
    AMI_POST_MANAGER_DISPLAY_MESSAGE	DisplayPostMessage;
}AMI_POST_MANAGER_PROTOCOL;
Built on 16:20:09 10/01/14


How_to_display_value_which_may_change_from_boot_to_boot in the TSE Help Module

General : How_to_display_value_which_may_change_from_boot_to_boot

File: TSE Help Module
Description:
Changing strings can be accomplished through a couple of different
means.  One, which is used for such facilities as memory sizing and hard drive
identification, is to update a string into HII that has been put there as a
placeholder.  For example, a memory VFR might look like:

    text
            help   = STRING_TOKEN(STR_NULL_STRING),
            text   = STRING_TOKEN(STR_TOTAL_MEMORY_SIZE_PROMPT),
            text   = STRING_TOKEN(STR_MEMORY_SIZE_VAL),
            flags  = 0,
            key    = 0;

In the firmware, there will be code that updates the place holder string
STR_MEMORY_SIZE_VAL with the actual string for the size.  For example,

    CHAR16 string[20] ;
    SPrint( string, 20, L"%dMB", memosrySize ) ;
    Hii->AddString( Hii, &token, string ) ;

This can also be accomplished in concert by code into the firmware and the
VFRs themselves.  First, a structure should be defined into which the data to
be shared is stored.  Then, along with a name and GUID, a volatile EFI
variable my be defined.  This is accomplished by setting the variable WITHOUT
the EFI_VARIABLE_NON_VOLATILE flag.

    // inside a firmware driver
    Status = gRT->SetVariable(
    L"MyVariable",
    &myGuid,
    EFI_VARIABLE_BOOTSERVICE_ACCESS,
    &myVariableStruct,
    sizeof(myVariableStruct)
Into the VFR, a varstore must be created (similar to the one above) and used
to access this variable.
Built on 16:20:09 10/01/14


How_to_gray_out_or_suppress_a_control in the TSE Help Module

General : How_to_gray_out_or_suppress_a_control

File: TSE Help Module
Description:
The following example shows how to gray out or suppress a control from
within the VFR definition file.

    grayoutif ideqval SYSTEM_ACCESS.Access == SYSTEM_PASSWORD_USER;
        oneof
        varid = SetupMap.IdeMode,
        prompt = STRING_TOKEN(STR_IDE_MODE_PROMPT),
        help = STRING_TOKEN(STR_IDE_MODE_HELP),
        option
            text = STRING_TOKEN(STR_DISABLE),
            value = 0,
            flags = RESET_REQUIRED;
        option
            text = STRING_TOKEN(STR_ENABLE),
            value = 1,
            flags = DEFAULT | RESET_REQUIRED;
        endoneof;
    endif;
Built on 16:20:09 10/01/14


How_to_integrate_an_EFI_application in the TSE Help Module

General : How_to_integrate_an_EFI_application

File: TSE Help Module
Description:
Integrating an EFI application into the setup data is very simply done,
using AMI’s extensions.  There are multiple steps involved in creating a launch, but
none involve modifying source code.
First, define your variable store within your VFR file.  The actual structure of the
variable store is not used, so we simply define a basic structure:

    typedef struct _MY_OEM_PACK
    {
    UINT16 Value;
    }
    MY_OEM_PACK;

    varstore MY_OEM_PACK,
    key = MY_OEM_PACK_KEY_ID,
    name = application.efi,
    guid = MY_OEM_PACK_GUID;

The important things to keep in mind with the above definitions are that the GUID and
the key uniquely identify your application.
Next, define VFR entry as follows.  It will always be a reference wrapped by a
suppress clause:

    // compare against a non-zero value so the suppress condition will fail.
    suppressif ideqval MY_OEM_PACK.Value == 1;
    // OEM_FORM_ID can be either an empty form defined elsewhere in the VFR
    // or the containing form’s formid value
    goto OEM_FORM_ID,
    prompt = STRING_TOKEN(STR_MY_OEM_APPLICATION),
    help = STRING_TOKEN(STR_MY_APPLICATION_HELP);
    endif;

Last step is to define your behavior into the SETUP.INI file so that TSE will
understand the overridden HII construct.

    [GUIDx]	; where x is the next available GUID number in the file
    guid = XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX
    name = unused
    key = XXXX ; this should be the same key value defined in the varstore
    flags = 6 ; these are the flags that tell what the action to perform is
            ; the values can be Ored togeteher to create multiple actions:
            ; 1 – signifies that the callback is AMI internal
            ; 2 – the GUID is treated as a filename in FV and launched
            ; 4 – the name defined in the varstore is treated as an EFI
            ;     executable name and is launched from the filesystem
            ; Using 4 and 2 together will try FV first, then filesystem
Built on 16:20:09 10/01/14


How_to_provide_Default_boot_order in the TSE Help Module

General : How_to_provide_Default_boot_order

File: TSE Help Module
Description:
To have this functionality; on every boot in addition to
creating / updating "BootOrder" and "LegacyDevOrder" variables based on the addition
and removal of boot devices; BDS should also create / update the variables
"DefaultBootOrder" and "DefaultLegacyDevOrder". "DefaultBootOrder" and
"DefaultLegacyDevOrder" are variables introduced to provide TSE with the default
ordering of devices. TSE displays these default orders when the user is
loading optimal defaults.

    Details of default boot order variable
    VariableName: "DefaultBootOrder"
    Guid: 45cf35f6-0d6e-4d04-856a-0370a5b16f53

    Details of default legacy device order variable
    VariableName: "DefaultLegacyDeviceOrder"
    Guid: 3c4ead08-45ae-4315-8d15-a60eaa8caf69

PS: If these variables are not present TSE will load the values of the BootOrder
and LeagacyDevOrder variables it entered with as default values
Built on 16:20:09 10/01/14


How_To_Switch_to_different_Style in the TSE Help Module

General : How_To_Switch_to_different_Style

File: TSE Help Module
Description:
Clone and change the following SDL token settings.

Ezport Style
    TSE_STYLE_EZPORT_BIN_SUPPORT = ON
    TSE_STYLE_EZPORT_SUPPORT = ON
    TSE_STYLE_LEGACY_BIN_SUPPORT = OFF
    TSE_STYLE_LEGACY_SUPPORT = OFF
    TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = OFF
    TSE_STYLE_EZPORTPLUS_SUPPORT = OFF

Legacy Style
    TSE_STYLE_EZPORT_BIN_SUPPORT = OFF
    TSE_STYLE_EZPORT_SUPPORT = OFF
    TSE_STYLE_LEGACY_BIN_SUPPORT = ON
    TSE_STYLE_LEGACY_SUPPORT = ON
    TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = OFF
    TSE_STYLE_EZPORTPLUS_SUPPORT = OFF

EzportPlus Style
    TSE_STYLE_EZPORT_BIN_SUPPORT = OFF
    TSE_STYLE_EZPORT_SUPPORT = OFF
    TSE_STYLE_LEGACY_BIN_SUPPORT = OFF
    TSE_STYLE_LEGACY_SUPPORT = OFF
    TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = ON
    TSE_STYLE_EZPORTPLUS_SUPPORT = ON
Built on 16:20:09 10/01/14


Image_formats in the TSE Help Module

General : Image_formats

File: TSE Help Module
Description:
The OEM logo image that is used in Aptio TSE is BMP and GIF format.  Future versions
will support other image formats (like PCX and JPG).  There are no color depth restrictions
for this image.  The image cannot be an RLE encoded bitmap or otherwise compressed bitmap.
Compression is referring to image compression as defined by the BMP format, not EFI compression.
The image is designed to fit into a specified area of the screen.  The dimensions of the
image file should be set accordingly.  The default image dimensions are listed below,

SmLogo: 400x100
Built on 16:20:10 10/01/14


Localization in the TSE Help Module

General : Localization

File: TSE Help Module
Description:
One of the many features of Aptio, is the ability to easily work with multiple
languages. Aptio TSE is no exception. Aptio TSE uses the exact same .UNI string management
as the Aptio project itself.
Built on 16:20:11 10/01/14


Post in the TSE Help Module

General : Post

File: TSE Help Module
Description:
Any of the images associated with Aptio can be modified after the firmware has
been built using the AMI ChangeLogo tool. The rendering information may be modified together
with other information like Optimal and Failsafe values may be customized after the firmware
has been built using the AMIBCP tool.
Built on 16:20:13 10/01/14


Setup_path_in_MINISETUP in the TSE Help Module

General : Setup_path_in_MINISETUP

File: TSE Help Module
Description:
Since Aptio TSE accesses the default setup NVRAM storage directly, it is
important that the correct layout of the NVRAM variable is known by TSE.  This requires
TSE to include the SetupVariable.h header file specific to the current project.
This header file will be located in the SAME directory where the setup .VFR files are kept.
The SETUP_PATH variable in the MINISETUP.MAK must match the path, relative to the root
of the Aptio project.

For example, for an Intel D865GCH R6-based Aptio project, this should be set as follows,

SETUP_PATH = Platform\IntelDpg\D865GCH\DXE\D865GCHPlatform\Setup
Built on 16:20:15 10/01/14


TSE_FAQ in the TSE Help Module

General : TSE_FAQ

File: TSE Help Module
Description:
Q:	The strings do not show up on the screen.
A:	There are several possible solutions to this problem.
    There could be an issue with the VFR creation.  TSE expects each formset
    in the VFR files to have the same GUID but unique CLASS and SUBCLASS identifiers.
    There could be strings that are not defined into the .UNI file.  This is unlikely
    as this would be caught during the build process.

Q:	Setup doesn't find any of my pages.
A:	Make sure that the GUID defined for your formsets matches the GUID defined
    into the main section of the SETUP.INI file.

Q:	How do I use multiple variables?
A:	TSE fully supports multiple variables defined into the VFR files. But, there
    is a caveat.  The default variable (usually defined using the formset GUID
    and the name "Setup") must also be re-defined.  This is a workaround for a
    faulty VFR compiler.  These variables should be defined using the VFR command
    varstore.  See the previous section for examples of how to use the varstore command.

Q:	How do I use the reference VFR files that are included into the TSE package?
A:	These VFR files are used in exactly the same way the platform VFR files are used.
    There are a couple of things that need to be modified into the platform code to
    install them.
    The .CIF file that includes the VFR files for the platform should be modified to
    reflect the new files.
    The file PLATFORM.C should be modified to install the new HII packs into
    the HII database.  This includes defining new variables for the new VFR binaries,
    adding these binaries to the function call that installs the HII packs, etc.
    The VFR files should be copied to the platform setup directory to be
    included into the build process.
Built on 16:20:16 10/01/14


TSEADVANCED SDL Tokens

The following data structures are used in the file: TSEADVANCED SDL Tokens.

Variable | Description
TSE_ADVANCED_SUPPORT | Main switch to enable Ezport Style in TSE
TSE_NVRAM_DEFAULTS_SUPPORT | Turn on to use NVRAM module to get the default values.
TSE_SEPERATE_EFI_LEGACY_OPTIONS | Turn on to have EFI options and Legacy options seperate. This will have effect only if BDS also seperates EFI and Legacy options.

Built on 16:20:22 10/01/14


TSE_ADVANCED_SUPPORT in the TSEADVANCED SDL Tokens

Variable : TSE_ADVANCED_SUPPORT

File: TSEADVANCED SDL Tokens
Description:
Main switch to enable Ezport Style in TSE
Built on 16:20:16 10/01/14


TSE_NVRAM_DEFAULTS_SUPPORT in the TSEADVANCED SDL Tokens

Variable : TSE_NVRAM_DEFAULTS_SUPPORT

File: TSEADVANCED SDL Tokens
Description:
Turn on to use NVRAM module to get the default values.
Built on 16:20:16 10/01/14


TSE_SEPERATE_EFI_LEGACY_OPTIONS in the TSEADVANCED SDL Tokens

Variable : TSE_SEPERATE_EFI_LEGACY_OPTIONS

File: TSEADVANCED SDL Tokens
Description:
Turn on to have EFI options and Legacy options seperate. This will have effect only if BDS also seperates EFI and Legacy options.
Built on 16:20:16 10/01/14


TseAdvanced.c

Description:
This file contains code to handle the Advanced TSE Operations

The following functions are used in the file: TseAdvanced.c.

Function | Description
_CallbackGetValueEx | Callback function to get the message box return value
_DisplayInfoCancelTimer | Timer notify fucntion
_PostEditCallback | Callback function for text entry popup
_PostEditDraw | Function to draw text entry edit box
_PostPopupEditDraw | Function to draw text entry popup window
_PostPopupEditGetValues | Function to draw text entry popup window
_SubMenuAmiCallback | Function implemented to handle the Exit page options using Elinks.
_SubMenuHandleSpecialOp | Sub menu handle for Special operations.
ActionReadKey | fucntion to handle the read key action
ActionReadKeyWithAMIKeyCode | fucntion to read the a key using AMI Key Code Protocol
AMIReadKeyStroke | function to read a key stroke
BootUpdateOrder | Function to update the boot/driver order
CheckShiftState | function to Check the shift state value
ClearUserPasswordPolicy | fucntion to clear the user password if admin password is empty, Only Valid with Password Local
DriverUpdateOrder | Function to update the driver order
GetANSIEscapeCode | Return Size of Escape Code and gets the FG,BGColor.
GetSetDefaultsFromControlPtr | Function to get default stringID for String Type control from controlPtr and fetch respective string from Hii database and set as default to NVRAM, gOptimalDefaults, gFailSafeDefaults buffer
HelperIsPasswordCharValid | function to Check whether the password char is valid
InitApplicationData | function to Initialize the application data
IsLegacyOption | function to Check for legacy option
IsToggleStateKey | function to Check Is any of ToggleStateKey (CapsLock,Numlock ScrollLock) Keys pressed.
LoadUserDefaults | Function to load the user set defaults
LoadUserDefaultsSilently | Function to load the user set defaults Silently
PopupEditHandlePassword | function to handle the popup password edit
ReGroupOptions | function to regroup the boot options
SaveUserDefaults | Function to save the user specified defaults
SaveUserDefaultsSilently | Function to save the user set defaults Silently
ShowBootOverrideSelectOption | function to Show menu with below option on selecting options under Boot Override 1) Override now and clear the BootNext data 2) Override now but keep the BootNext data 3) Boot to BootNext and clear BootNext data
ShowInfoBox | fucntiont to display the information box
ShowPostMsgBox | Function to display the message box
ShowPostMsgBoxEx | Function to display the message box
ShowPostProgress | Function to display the progress bar
ShowPostTextBox | Function to display text entry interface
SkipEscCode | function to perform the esc key operation
SupportPrintScreen | function to support the print screen.
SupportPrintScreenEvent | function to Check the print screen supprot event.
TseBootNowinBootOrderInit | function build the AMI defaults
TseFramePwdCallbackIdePasswordUpdate | function to update the ide password
TSEGetNVVariable | reads the NV Varaiable from Nram buffer using NVLib.
TsePopupPwdAuthenticateIDEPwd | Function to authenticate the IDE password
TsePopupPwdUpdateIDEPwd | function to update the IDE password
TseVarBuildAMIDefaults | function build the AMI defaults
UpdateNVDefautls | Updated the Variable buffer with NVRam Defaults buffer.

Built on 16:20:22 10/01/14


_CallbackGetValueEx in the TseAdvanced.c

Function : _CallbackGetValueEx

File: TseAdvanced.c
Description:
Callback function to get the message box return value
Input:
MSGBOX_DATA *msgbox
Output:
Message box return value
Built on 16:20:03 10/01/14


_DisplayInfoCancelTimer in the TseAdvanced.c

Function : _DisplayInfoCancelTimer

File: TseAdvanced.c
Description:
Timer notify fucntion
Input:
EFI_EVENT Event
        VOID *Context
Output:
VOID
Built on 16:20:03 10/01/14


_PostEditCallback in the TseAdvanced.c

Function : _PostEditCallback

File: TseAdvanced.c
Description:
Callback function for text entry popup
Input:
VOID *container, VOID *object, VOID *cookie
Output:
EFI_STATUS
Built on 16:20:04 10/01/14


_PostEditDraw in the TseAdvanced.c

Function : _PostEditDraw

File: TseAdvanced.c
Description:
Function to draw text entry edit box
Input:
POPUPEDIT_DATA *popup
Output:
EFI_STATUS
Built on 16:20:04 10/01/14


_PostPopupEditDraw in the TseAdvanced.c

Function : _PostPopupEditDraw

File: TseAdvanced.c
Description:
Function to draw text entry popup window
Input:
POPUPEDIT_DATA *PopupEdit
Output:
EFI_STATUS
Built on 16:20:04 10/01/14


_PostPopupEditGetValues in the TseAdvanced.c

Function : _PostPopupEditGetValues

File: TseAdvanced.c
Description:
Function to draw text entry popup window
Input:
POPUP_DATA          *popup,
POPUPEDIT_DATA      *editList,
TEXT_INPUT_TEMPLATE *InputData,
UINT16              ItemCount,
DISPLAY_TEXT_KEY_VALIDATE ValidateKeyFunc
Output:
UINTN  - 0/1 (success/abort)
Built on 16:20:04 10/01/14


_SubMenuAmiCallback in the TseAdvanced.c

Function : _SubMenuAmiCallback

File: TseAdvanced.c
Description:
Function implemented to handle the Exit page
        options using Elinks.
Input:
UINT16 value - index of the exit page option
Output:
TRUE
Built on 16:20:04 10/01/14


_SubMenuHandleSpecialOp in the TseAdvanced.c

Function : _SubMenuHandleSpecialOp

File: TseAdvanced.c
Description:
Sub menu handle for Special operations.
Input:
Submenu data
Output:
Bool - Interpreted by the Caller.
Built on 16:20:04 10/01/14


ActionReadKey in the TseAdvanced.c

Function : ActionReadKey

File: TseAdvanced.c
Description:
fucntion to handle the read key action
Input:
AMI_EFI_KEY_DATA *pAmiKey,
        UINT64 Timeout
Output:
EFI_STATUS
Built on 16:20:04 10/01/14


ActionReadKeyWithAMIKeyCode in the TseAdvanced.c

Function : ActionReadKeyWithAMIKeyCode

File: TseAdvanced.c
Description:
fucntion to read the a key using AMI Key Code Protocol
Input:
AMI_EFI_KEY_DATA *pAmiKey,
        UINT64 Timeout
Output:
EFI_STATUS
Built on 16:20:04 10/01/14


AMIReadKeyStroke in the TseAdvanced.c

Function : AMIReadKeyStroke

File: TseAdvanced.c
Description:
function to read a key stroke
Input:
EFI_INPUT_KEY *Key,
        AMI_EFI_KEY_DATA *KeyData
Output:
EFI_STATUS
Built on 16:20:05 10/01/14


BootUpdateOrder in the TseAdvanced.c

Function : BootUpdateOrder

File: TseAdvanced.c
Description:
Function to update the boot/driver order
Input:
UINT16 *buffer
        UINT32 *offset
        UINTN *size
        VOID **realBuffer
Output:
VOID
Built on 16:20:05 10/01/14


CheckShiftState in the TseAdvanced.c

Function : CheckShiftState

File: TseAdvanced.c
Description:
function to Check the shift state value
Input:
None
Output:
1 - valid shift state
        0 - invalid shift state
Built on 16:20:05 10/01/14


ClearUserPasswordPolicy in the TseAdvanced.c

Function : ClearUserPasswordPolicy

File: TseAdvanced.c
Description:
fucntion to clear the user password if admin password is empty,
        Only Valid with Password Local
Input:
CALLBACK_PASSWORD *callbackData,
        CHAR16 *saveData
Output:
None
Built on 16:20:06 10/01/14


DriverUpdateOrder in the TseAdvanced.c

Function : DriverUpdateOrder

File: TseAdvanced.c
Description:
Function to update the driver order
Input:
UINT16 *buffer
        UINT32 *offset
        UINTN *size
        VOID **realBuffer
Output:
VOID
Built on 16:20:07 10/01/14


GetANSIEscapeCode in the TseAdvanced.c

Function : GetANSIEscapeCode

File: TseAdvanced.c
Description:
Return Size of Escape Code and gets the FG,BGColor.
Input:
CHAR16 *String,
        UINT8 *Bold,
        UINT8 *Foreground,
        UINT8 *Background
Output:
UINTN	- Escape code length (in CHAR16), 0 if not an escape code
            Bold, Forground, Background - Filled with -1 if value not found in Escape Code
Built on 16:20:08 10/01/14


GetSetDefaultsFromControlPtr in the TseAdvanced.c

Function : GetSetDefaultsFromControlPtr

File: TseAdvanced.c
Description:
Function to get default stringID for String Type control from controlPtr and
                fetch respective string from Hii database and set as default to NVRAM, gOptimalDefaults, gFailSafeDefaults buffer
Input:
NVRAM_VARIABLE *OptimalDefs, NVRAM_VARIABLE *FailSafeDefs
Output:
EFI_STATUS
Built on 16:20:08 10/01/14


HelperIsPasswordCharValid in the TseAdvanced.c

Function : HelperIsPasswordCharValid

File: TseAdvanced.c
Description:
function to Check whether the password char is valid
Input:
EFI_INPUT_KEY *Key,
        AMI_EFI_KEY_DATA *KeyData,
        UINTN StrIndex,
        UINTN PasswordLength,
        CHAR16 *OutChar
Output:
EFI_STATUS
Built on 16:20:09 10/01/14


InitApplicationData in the TseAdvanced.c

Function : InitApplicationData

File: TseAdvanced.c
Description:
function to Initialize the application data
Input:
EFI_HANDLE ImageHandle
Output:
EFI_STATUS
Built on 16:20:10 10/01/14


IsLegacyOption in the TseAdvanced.c

Function : IsLegacyOption

File: TseAdvanced.c
Description:
function to Check for legacy option
Input:
UINT16 Option
Output:
TRUE/FALSE
Built on 16:20:10 10/01/14


IsToggleStateKey in the TseAdvanced.c

Function : IsToggleStateKey

File: TseAdvanced.c
Description:
function to Check Is any of ToggleStateKey (CapsLock,Numlock ScrollLock) Keys pressed.
Input:
ACTION_DATA *Data
Output:
TRUE/FALSE
Built on 16:20:10 10/01/14


LoadUserDefaults in the TseAdvanced.c

Function : LoadUserDefaults

File: TseAdvanced.c
Description:
Function to load the user set defaults
Input:
VOID
Output:
VOID
Built on 16:20:11 10/01/14


LoadUserDefaultsSilently in the TseAdvanced.c

Function : LoadUserDefaultsSilently

File: TseAdvanced.c
Description:
Function to load the user set defaults Silently
Input:
VOID
Output:
VOID
Built on 16:20:11 10/01/14


PopupEditHandlePassword in the TseAdvanced.c

Function : PopupEditHandlePassword

File: TseAdvanced.c
Description:
function to handle the popup password edit
Input:
VOID *pPopupEdit,
        VOID *pData
Output:
EFI_STATUS
Built on 16:20:13 10/01/14


ReGroupOptions in the TseAdvanced.c

Function : ReGroupOptions

File: TseAdvanced.c
Description:
function to regroup the boot options
Input:
UINT16 *optionList,
        UINT16 *OrgOptionList
Output:
None
Built on 16:20:14 10/01/14


SaveUserDefaults in the TseAdvanced.c

Function : SaveUserDefaults

File: TseAdvanced.c
Description:
Function to save the user specified defaults
Input:
VOID
Output:
VOID
Built on 16:20:14 10/01/14


SaveUserDefaultsSilently in the TseAdvanced.c

Function : SaveUserDefaultsSilently

File: TseAdvanced.c
Description:
Function to save the user set defaults Silently
Input:
VOID
Output:
VOID
Built on 16:20:14 10/01/14


ShowBootOverrideSelectOption in the TseAdvanced.c

Function : ShowBootOverrideSelectOption

File: TseAdvanced.c
Description:
function to Show menu with below option on selecting options under Boot Override
                1) Override now and clear the BootNext data
                2) Override now but keep the BootNext data
                3) Boot to BootNext and clear BootNext data
Input:
VOID
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


ShowInfoBox in the TseAdvanced.c

Function : ShowInfoBox

File: TseAdvanced.c
Description:
fucntiont to display the information box
Input:
CHAR16  *InfoBoxTitle,
        CHAR16  *Message,
        UINTN   TimeLimit,
        EFI_EVENT  *RetEvent)
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


ShowPostMsgBox in the TseAdvanced.c

Function : ShowPostMsgBox

File: TseAdvanced.c
Description:
Function to display the message box
Input:
CHAR16  *MsgBoxTitle,
            CHAR16  *Message,
            UINT8  MsgBoxType,
            UINT8 *pSelection
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


ShowPostMsgBoxEx in the TseAdvanced.c

Function : ShowPostMsgBoxEx

File: TseAdvanced.c
Description:
Function to display the message box
Input:
CHAR16  *MsgBoxTitle,
            CHAR16  *Message,
            UINT8  MsgBoxType,
            UINT8 *pSelection
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


ShowPostProgress in the TseAdvanced.c

Function : ShowPostProgress

File: TseAdvanced.c
Description:
Function to display the progress bar
Input:
IN UINT8	ProgressBoxState - Progress bar state
IN CHAR16	*Title		 - Progress bar title
IN CHAR16	*Message,	 - Progress bar message string
IN CHAR16	*Legend,	 - Progress bar legend string
IN UINTN 	Percent,	 - Percent Complete (0 - 100)
IN OUT VOID	**Handle,	 - HANDLE. Valid Handle for update and close
OUT AMI_POST_MGR_KEY	*OutKey  - Out Key
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


ShowPostTextBox in the TseAdvanced.c

Function : ShowPostTextBox

File: TseAdvanced.c
Description:
Function to display text entry interface
Input:
IN VOID    *HiiHandle,
IN UINT16 	TitleToken,
IN TEXT_INPUT_TEMPLATE *InputData,
IN UINT16 	ItemCount,
IN DISPLAY_TEXT_KEY_VALIDATE ValidateKeyFunc
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


SkipEscCode in the TseAdvanced.c

Function : SkipEscCode

File: TseAdvanced.c
Description:
function to perform the esc key operation
Input:
CHAR16 *string
Output:
string
Built on 16:20:15 10/01/14


SupportPrintScreen in the TseAdvanced.c

Function : SupportPrintScreen

File: TseAdvanced.c
Description:
function to support the print screen.
Input:
None
Output:
None
Built on 16:20:16 10/01/14


SupportPrintScreenEvent in the TseAdvanced.c

Function : SupportPrintScreenEvent

File: TseAdvanced.c
Description:
function to Check the print screen supprot event.
Input:
UINT16 ScanCode
Output:
TRUE/FALSE
Built on 16:20:16 10/01/14


TseBootNowinBootOrderInit in the TseAdvanced.c

Function : TseBootNowinBootOrderInit

File: TseAdvanced.c
Description:
function build the AMI defaults
Input:
None
Output:
boot order string
Built on 16:20:16 10/01/14


TseFramePwdCallbackIdePasswordUpdate in the TseAdvanced.c

Function : TseFramePwdCallbackIdePasswordUpdate

File: TseAdvanced.c
Description:
function to update the ide password
Input:
CONTROL_DATA *control,
        CHAR16 *saveData
Output:
EFI_STATUS
Built on 16:20:16 10/01/14


TSEGetNVVariable in the TseAdvanced.c

Function : TSEGetNVVariable

File: TseAdvanced.c
Description:
reads the NV Varaiable from Nram buffer using NVLib.
Input:
UINT32 variable, NVRAM_STORE_INFO *pInfo , UINTN *size
Output:
None
Built on 16:20:16 10/01/14


TsePopupPwdAuthenticateIDEPwd in the TseAdvanced.c

Function : TsePopupPwdAuthenticateIDEPwd

File: TseAdvanced.c
Description:
Function to authenticate the IDE password
Input:
POPUP_PASSWORD_DATA *popuppassword,
        BOOLEAN *AbortUpdate,
        VOID *data
Output:
EFI_STATUS
Built on 16:20:16 10/01/14


TsePopupPwdUpdateIDEPwd in the TseAdvanced.c

Function : TsePopupPwdUpdateIDEPwd

File: TseAdvanced.c
Description:
function to update the IDE password
Input:
None
Output:
None
Built on 16:20:16 10/01/14


TseVarBuildAMIDefaults in the TseAdvanced.c

Function : TseVarBuildAMIDefaults

File: TseAdvanced.c
Description:
function build the AMI defaults
Input:
None
Output:
EFI_STATUS
Built on 16:20:17 10/01/14


UpdateNVDefautls in the TseAdvanced.c

Function : UpdateNVDefautls

File: TseAdvanced.c
Description:
Updated the Variable buffer with NVRam Defaults buffer.
Input:
UINT32 index, NVRAM_STORE_INFO *NvInfo, NVRAM_VARIABLE * VarPtr
Output:
None
Built on 16:20:18 10/01/14


TSELITE SDL Tokens

The following data structures are used in the file: TSELITE SDL Tokens.

Variable | Description
POPUP_MENU_ENTER_SETUP | 1 => Allows to enter setup from BBS popup
TseLite_SUPPORT | Main switch to enable TseLite sources support in Project

Built on 16:20:22 10/01/14


POPUP_MENU_ENTER_SETUP in the TSELITE SDL Tokens

Variable : POPUP_MENU_ENTER_SETUP

File: TSELITE SDL Tokens
Description:
1 => Allows to enter setup from BBS popup
Built on 16:20:13 10/01/14


TseLite_SUPPORT in the TSELITE SDL Tokens

Variable : TseLite_SUPPORT

File: TSELITE SDL Tokens
Description:
Main switch to enable TseLite sources support in Project
Built on 16:20:16 10/01/14


TseLiteCommon.c

Description:
This file contains code for the TSE Lite common functions

The following functions are used in the file: TseLiteCommon.c.

Function | Description
_GetControlVariable | Function to get control variable.
_GetPageInfo | Returns pointer to the PAGE_INFO struct of given PgIndex
GetBootTimeOut | Timeout value from the variable.
GetPageSubTitle | Get the Page Subtitle String Index Parameter: IN UINTN PgIndex OUT UINT16 *subtitleToken Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
IsPageModal | Is this a modal page Parameter: IN UINT32 PgIndex Return Value: BOOLEAN
MiniSetupUIExit | Freesup UI related resources.

Built on 16:20:22 10/01/14


_GetControlVariable in the TseLiteCommon.c

Function : _GetControlVariable

File: TseLiteCommon.c
Description:
Function to get control variable.
Input:
CONTROL_INFO *control
Output:
UINT32
Built on 16:20:03 10/01/14


_GetPageInfo in the TseLiteCommon.c

Function : _GetPageInfo

File: TseLiteCommon.c
Description:
Returns pointer to the PAGE_INFO struct of given PgIndex
Input:
UINT32 PgIndex - Page index
    PAGE_INFO **PageInfo - Pointer to the page information struct
Output:
EFI_STATUS status - EFI_SUCCESS if successful, else EFI_ERROR
Built on 16:20:04 10/01/14


GetBootTimeOut in the TseLiteCommon.c

Function : GetBootTimeOut

File: TseLiteCommon.c
Description:
Timeout value from the variable.
Input:
DefaultValue
Output:
Timeout value
Built on 16:20:08 10/01/14


GetPageSubTitle in the TseLiteCommon.c

Function : GetPageSubTitle

File: TseLiteCommon.c
Description:
Get the Page Subtitle String Index

Parameter:     IN  UINTN  PgIndex
 OUT UINT16 *subtitleToken

Return Value:  EFI_STATUS
     EFI_SUCCESS
     EFI_NOT_READY
     EFI_INVALID_PARAMETER
Built on 16:20:08 10/01/14


IsPageModal in the TseLiteCommon.c

Function : IsPageModal

File: TseLiteCommon.c
Description:
Is this a modal page

Parameter:     IN  UINT32 PgIndex

Return Value:  BOOLEAN
Built on 16:20:10 10/01/14


MiniSetupUIExit in the TseLiteCommon.c

Function : MiniSetupUIExit

File: TseLiteCommon.c
Description:
Freesup UI related resources.
Input:
none
Output:
none
Built on 16:20:11 10/01/14


TseLitehelper.c

Description:
This file contains code specific to TSE Lite flavor

The following functions are used in the file: TseLitehelper.c.

Function | Description
_SubMenuAmiCallback | Function to handle the exit page options.
_SubMenuHandleSpecialOp | Sub menu handle for Special operations.
ActionReadKey | Function to read action key
AMIReadKeyStroke | Function to read key strokes
BBSUpdateOrder | Updates the Legacydevorder variable base on the user input
BootUpdateOrder | Updates the boot order variable
DriverUpdateOrder | Updates the driver order variable
HelperIsPasswordCharValid | Function to Check for valid password character
InitApplicationData | Initlizes the TSE Lite Setupdata.
IsToggleStateKey | function to Check Is any of ToggleStateKey (CapsLock,Numlock ScrollLock) Keys pressed.
PopupEditHandlePassword | Function to handle PopupEdit password.
PopupPasswordFormCallback | Function to handle PopupPassword form callbacks.
ShowPostMsgBox | Function to show messagebox
ShowPostMsgBoxEx | Function to show messagebox
ShowPostProgress | Function to display the progress bar
ShowPostTextBox | Function to display text entry interface
SpecialUpdatePageControls | Fix the Boot Order, BBS Order and Boot Override controls.
TSELiteFixBBSOrder | Fixes the BBS Order Orderlist.
TSELiteFixBootOrder | Fixes the Boot Order OrderList.
TSELiteFixBootOrderRide | Function to fix boot override
TseLiteIsSpecialOptionList | Function that decided to re evaluate the option list/Name from the Vfr. For TSE Special Controls it should return TRUE. for other controls it may return FALSE. For UEFI 2.0 it may return TRUE by default.
UpdateBootVariables | Dummy function for UpdateBootVariables
UpdateDriverVariables | Dummy function for UpdateDriverVariables
UpdateLegacyDevVariable | Update the LegacyDev variable with Device count in each BBS type

Built on 16:20:22 10/01/14


_SubMenuAmiCallback in the TseLitehelper.c

Function : _SubMenuAmiCallback

File: TseLitehelper.c
Description:
Function to handle the exit page options.
Input:
UINT16 value
Output:
TRUE/FALSE.
Built on 16:20:04 10/01/14


_SubMenuHandleSpecialOp in the TseLitehelper.c

Function : _SubMenuHandleSpecialOp

File: TseLitehelper.c
Description:
Sub menu handle for Special operations.
Input:
Submenu data
Output:
Bool - Interpreted by the Caller.
Built on 16:20:04 10/01/14


ActionReadKey in the TseLitehelper.c

Function : ActionReadKey

File: TseLitehelper.c
Description:
Function to read action key
Input:
AMI_EFI_KEY_DATA *pAmiKey, UINT64 Timeout
Output:
STATUS
Built on 16:20:04 10/01/14


AMIReadKeyStroke in the TseLitehelper.c

Function : AMIReadKeyStroke

File: TseLitehelper.c
Description:
Function to read key strokes
Input:
EFI_INPUT_KEY *Key,AMI_EFI_KEY_DATA *KeyData
Output:
STATUS
Built on 16:20:05 10/01/14


BBSUpdateOrder in the TseLitehelper.c

Function : BBSUpdateOrder

File: TseLitehelper.c
Description:
Updates the Legacydevorder variable base on the user input
Input:
UINT16 *newOption,UINT32 *offset,UINTN *size, VOID **buffer
Output:
VOID
Built on 16:20:05 10/01/14


BootUpdateOrder in the TseLitehelper.c

Function : BootUpdateOrder

File: TseLitehelper.c
Description:
Updates the boot order variable
Input:
New options, offset, size and Outbuffer
Output:
none
Built on 16:20:05 10/01/14


DriverUpdateOrder in the TseLitehelper.c

Function : DriverUpdateOrder

File: TseLitehelper.c
Description:
Updates the driver order variable
Input:
New options, offset, size and Outbuffer
Output:
none
Built on 16:20:07 10/01/14


HelperIsPasswordCharValid in the TseLitehelper.c

Function : HelperIsPasswordCharValid

File: TseLitehelper.c
Description:
Function to Check for valid password character
Input:
EFI_INPUT_KEY *Key,AMI_EFI_KEY_DATA *KeyData,UINTN StrIndex,UINTN PasswordLength, CHAR16 *OutChar
Output:
STATUS
Built on 16:20:09 10/01/14


InitApplicationData in the TseLitehelper.c

Function : InitApplicationData

File: TseLitehelper.c
Description:
Initlizes the TSE Lite Setupdata.
Input:
ImageHandle
Output:
Status
Built on 16:20:10 10/01/14


IsToggleStateKey in the TseLitehelper.c

Function : IsToggleStateKey

File: TseLitehelper.c
Description:
function to Check Is any of ToggleStateKey (CapsLock,Numlock ScrollLock) Keys pressed.
Input:
ACTION_DATA *Data
Output:
TRUE/FALSE
Built on 16:20:10 10/01/14


PopupEditHandlePassword in the TseLitehelper.c

Function : PopupEditHandlePassword

File: TseLitehelper.c
Description:
Function to handle PopupEdit password.
Input:
VOID *pPopupEdit, VOID *pData
Output:
STATUS
Built on 16:20:13 10/01/14


PopupPasswordFormCallback in the TseLitehelper.c

Function : PopupPasswordFormCallback

File: TseLitehelper.c
Description:
Function to handle PopupPassword form callbacks.
Input:
CONTROL_INFO * pControlData, UINT16 Key, UINT8 Flags
Output:
STATUS
Built on 16:20:13 10/01/14


ShowPostMsgBox in the TseLitehelper.c

Function : ShowPostMsgBox

File: TseLitehelper.c
Description:
Function to show messagebox
Input:
IN CHAR16  *MsgBoxTitle,IN CHAR16  *Message,IN UINT8  MsgBoxType, UINT8 *pSelection
Output:
STATUS
Built on 16:20:15 10/01/14


ShowPostMsgBoxEx in the TseLitehelper.c

Function : ShowPostMsgBoxEx

File: TseLitehelper.c
Description:
Function to show messagebox
Input:
IN CHAR16  *MsgBoxTitle,IN CHAR16  *Message,IN UINT8  MsgBoxType, UINT8 *pSelection
Output:
STATUS
Built on 16:20:15 10/01/14


ShowPostProgress in the TseLitehelper.c

Function : ShowPostProgress

File: TseLitehelper.c
Description:
Function to display the progress bar
Input:
IN UINT8	ProgressBoxState - Progress bar state
IN CHAR16	*Title		 - Progress bar title
IN CHAR16	*Message,	 - Progress bar message string
IN CHAR16	*Legend,	 - Progress bar legend string
IN UINTN 	Percent,	 - Percent Complete (0 - 100)
IN OUT VOID	**Handle,	 - HANDLE. Valid Handle for update and close
OUT AMI_POST_MGR_KEY	*OutKey  - Out Key
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


ShowPostTextBox in the TseLitehelper.c

Function : ShowPostTextBox

File: TseLitehelper.c
Description:
Function to display text entry interface
Input:
IN VOID    *HiiHandle,
IN UINT16 	TitleToken,
IN TEXT_INPUT_TEMPLATE *InputData,
IN UINT16 	ItemCount,
IN DISPLAY_TEXT_KEY_VALIDATE ValidateKeyFunc
Output:
EFI_STATUS
Built on 16:20:15 10/01/14


SpecialUpdatePageControls in the TseLitehelper.c

Function : SpecialUpdatePageControls

File: TseLitehelper.c
Description:
Fix the Boot Order, BBS Order and Boot Override controls.
Input:
CurrentPage
Output:
none
Built on 16:20:15 10/01/14


TSELiteFixBBSOrder in the TseLitehelper.c

Function : TSELiteFixBBSOrder

File: TseLitehelper.c
Description:
Fixes the BBS Order Orderlist.
Input:
ControlData
Output:
none
Built on 16:20:16 10/01/14


TSELiteFixBootOrder in the TseLitehelper.c

Function : TSELiteFixBootOrder

File: TseLitehelper.c
Description:
Fixes the Boot Order OrderList.
Input:
ControlData
Output:
none
Built on 16:20:16 10/01/14


TSELiteFixBootOrderRide in the TseLitehelper.c

Function : TSELiteFixBootOrderRide

File: TseLitehelper.c
Description:
Function to fix boot override
Input:
CONTROL_DATA *ControlData
Output:
VOID
Built on 16:20:16 10/01/14


TseLiteIsSpecialOptionList in the TseLitehelper.c

Function : TseLiteIsSpecialOptionList

File: TseLitehelper.c
Description:
Function that decided to re evaluate the option list/Name from the Vfr.
        For TSE Special Controls it should return TRUE. for other controls it may return FALSE.
        For UEFI 2.0 it may return TRUE by default.
Input:
NONE
Output:
Boolean
Built on 16:20:16 10/01/14


UpdateBootVariables in the TseLitehelper.c

Function : UpdateBootVariables

File: TseLitehelper.c
Description:
Dummy function for

 UpdateBootVariables
Input:
VOID
Output:
VOID
Built on 16:20:18 10/01/14


UpdateDriverVariables in the TseLitehelper.c

Function : UpdateDriverVariables

File: TseLitehelper.c
Description:
Dummy function for

 UpdateDriverVariables
Input:
VOID
Output:
VOID
Built on 16:20:18 10/01/14


UpdateLegacyDevVariable in the TseLitehelper.c

Function : UpdateLegacyDevVariable

File: TseLitehelper.c
Description:
Update the LegacyDev variable with Device count in each BBS type
Input:
NoOfLegacyGroups
Output:
none
Built on 16:20:18 10/01/14


TseOEM.C

The following functions are used in the file: TseOEM.C.

Function | Description
OEMEmpty | Empty Template

Built on 16:20:22 10/01/14


OEMEmpty in the TseOEM.C

Function : OEMEmpty

File: TseOEM.C
Description:
Empty Template
Input:
None
Output:
None
Built on 16:20:12 10/01/14


TsePasswordEncode.c

Description:

The following functions are used in the file: TsePasswordEncode.c.

Function | Description
TsePasswordEncodeLocal | Function to encode the password string Parameter: CHAR16 *Password, UINTN MaxSize Return value: VOID

Built on 16:20:22 10/01/14


TsePasswordEncodeLocal in the TsePasswordEncode.c

Function : TsePasswordEncodeLocal

File: TsePasswordEncode.c
Description:
Function to encode the password string

Parameter:	    CHAR16 *Password, UINTN MaxSize

Return value:  	VOID
Built on 16:20:16 10/01/14


TseUefiHii.h

Description:

The following data structures are used in the file: TseUefiHii.h.

Variable | Description
EFI_HII_VALUE |
SETUP_LINK |

Built on 16:20:22 10/01/14


EFI_HII_VALUE in the TseUefiHii.h

Variable : EFI_HII_VALUE

File: TseUefiHii.h
Fields:

Name | Type | Description
Type | UINT8
Value | EFI_IFR_TYPE_VALUE

Description:
Built on 16:20:07 10/01/14


SETUP_LINK in the TseUefiHii.h

Variable : SETUP_LINK

File: TseUefiHii.h
Fields:

Name | Type | Description
FormSet | UINT8*
Handle | VOID*
ClassID | UINT16
FormSetLength | UINTN
Added | UINT8
SubClassID | UINT16
ClassGuidCount | UINT16
ClassGuid | EFI_GUID*

Description:
Built on 16:20:15 10/01/14


UEFI20 SDL Tokens

The following data structures are used in the file: UEFI20 SDL Tokens.

Variable | Description
SETUP_FORM_BROWSER_SUPPORT | 1 => Installs form browser protocol should turn on SETUP_RUNTIME_IFR_PROCESSING. 0 => Does not install form browser protocol.
TSE_SUPPORT_VFRCOMPILE_1_88 | Turn on to support vfrcompiler version 1.88 and later
UEFI_2_0_SUPPORT | Main switch to enable UEFI 2.0 sources support in Project

Built on 16:20:22 10/01/14


SETUP_FORM_BROWSER_SUPPORT in the UEFI20 SDL Tokens

Variable : SETUP_FORM_BROWSER_SUPPORT

File: UEFI20 SDL Tokens
Description:
1 => Installs form browser protocol should turn on SETUP_RUNTIME_IFR_PROCESSING. 0 => Does not install form browser protocol.
Built on 16:20:15 10/01/14


TSE_SUPPORT_VFRCOMPILE_1_88 in the UEFI20 SDL Tokens

Variable : TSE_SUPPORT_VFRCOMPILE_1_88

File: UEFI20 SDL Tokens
Description:
Turn on to support vfrcompiler version 1.88 and later
Built on 16:20:16 10/01/14


UEFI_2_0_SUPPORT in the UEFI20 SDL Tokens

Variable : UEFI_2_0_SUPPORT

File: UEFI20 SDL Tokens
Description:
Main switch to enable UEFI 2.0 sources support in Project
Built on 16:20:17 10/01/14


uefi20Wapper.c

Description:
This file contains code for UEFI2.0 wrapper

The following functions are used in the file: uefi20Wapper.c.

Function | Description
BBSUpdateControlOffset | Function to update control offset
CheckDateFlags | Function to Check the Date flags.
CheckTimeFlags | Function to Check the time flags.
CtrlsSupportsHealthProtocol | Finds the number of controllers supports driver health protocol for the driver entry
DoDriverHealthOperation | Performs the driver health operations for the corresponding controller entry
EvaluateControlDefault | Parameter: CONTROL_INFO *CtrlInfo Return value: UINT64
FindDriverHealthDriverName | Finds the driver name which supports driver health protocol
GetControlConditionVarId | Function to get control variable id
GetCtrlNameAndHealth | Finds the controller name with its health
HiiGetDefaultMask | Function to get default mask
HiiGetManufactuingMask | Function to get manufacturing mask
InitMiniSetupStrings | Function to init minisetup strings
IsPasswordEncodeEnabled | Function to Password Encoding Status.
ProcessActionQuestionConfiguration | Function to process Action Control Configuration String. UEFI Action control is a 2.1 control
ProcessPackNotification | Processes the IFR notification queue
RegFormNotification | Registers the hii pack notification Parameter: VOID Return value: EFI_STATUS
SetDriverHealthCount | Sets the DriverHealthCount and DriverHlthEnable variables
SetDrvHealthHandleAndCtrlCount | Finds and sets the number of controllers supports the driver health handle
UefiAddEndOp | Function to add end op code
UefiCreateDynamicControlCondition | Function to create dynamic control condition
UefiCreateOneOfWithOptionsTemplate | Function to create OneOf option template
UefiCreateStringTemplate | Function to create uefi string template Parameter: UINT16 Token Return value: VOID *
UefiCreateSubTitleTemplate | Function to prepare the template for sub-title
UefiFormCallbackNVRead | Function to get callback nvread
UefiFormCallbackNVWrite | Function to get callback nvwrite
UefiGetBaseValue | Function to get the base value
UefiGetControlKey | Helper function in obtaining Control Key
UefiGetDateTimeDetails | Function to get the details of data and time
UefiGetEqIDQuestionID | Function to Check EqID question ID
UefiGetFlagsField | to get the Flags field from ifr
UefiGetHelpField | To get the specific help field
UefiGetIfrLength | Function to get the length of Ifr
UefiGetKeyField | To get the Key field from ifr
UefiGetMaxEntries | Function to get max entries
UefiGetMaxValue | Function to get the max value
UefiGetMinValue | Function to get the minimum value
UefiGetOneOfOptions | Function to get OneOf options
UefiGetPromptField | To get the prompt field from ifr
UefiGetQuestionID | Function to get question ID
UefiGetQuestionOffset | Function to get question offset
UefiGetResetButtonDefaultid | In UEFI 2.0 this is Dummy function. Parameter: VOID *IfrPtr Return value: UINT16
UefiGetSpecialEqIDIfrPtr | Function to get special eqID Ifr pointer
UefiGetSpecialEqIDValue | Function to get special eqID value
UefiGetStepValue | Function to get the step value
UefiGetTextField | Function to get the Text Field.
UefiGetTextTwoField | Function to get the Text Field.
UefiGetTime | Function to get time Parameter: CONTROL_INFO *control, EFI_TIME *Tm Return value: STATUS
UefiGetTitleField | To get the Title field from ifr
UefiGetValidOptionSize | Function to get sizeof option.UEFI2.0 doesn't have EFI_IFR_TYPE support
UefiGetWidth | Function to get width
UefiIsEfiVariable | Function to Check efi variable
UefiIsInteractive | To get Uefi Interactive
UefiIsOneOfControl | Function to Check for OneOf controls
UefiIsProceedWithPageChange | For UEFI 2.0 Just return EFI_SUCCESS; Parameter: EFI_STATUS Return Value: EFI_STATUS
UefiPreControlUpdate | In UEFI 2.0 this is Dummy function. Parameter: CONTROL_INFO * ControlData Return Value: EFI_STATUS
UefiRefershQuestionValueNvRAM | Function Refresh the question Parameter: CONTROL_INFO *control Return value: STATUS
UefiSetEqIDQuestionID | Function to set EqID question ID
UefiSetEqIDValue | Function to set EqID value
UefiSetHelpField | To Set the specific help field
UefiSetOneOfOption | Function to set OneOf option
UefiSetPromptField | Function to set the prompt Field.
UefiSetSubTitleField | Function to Set the Sub-Title Field.
UefiSetTime | Function to set time Parameter: CONTROL_INFO *control, EFI_TIME *Tm Return value: STATUS
UefiSetWidth | Function to set width
UefiSpecialGuidCallback | Function to get special guid callback
UefiTseLiteGetAmiCallbackIndex | Function to get ami callback index
UefiTseLiteGetBootOverRideIndex | Function to get boot override index
UefiUpdateControlVarOffset | Function to update control variable offset
UefiupdateResetButtonDefault | In UEFI 2.0 this is Dummy function.
UefiVarGetNvram | Function to get nvram Parameter: VARIABLE_INFO *VariableInfo, VOID **Buffer, UINTN Offset, UINTN Size
UnRegFormNotification | Unregisters the form notification Parameter: VOID Return value: VOID
UpdateDestiantionQuestion | Dummy function for 2.0

Built on 16:20:22 10/01/14


BBSUpdateControlOffset in the uefi20Wapper.c

Function : BBSUpdateControlOffset

File: uefi20Wapper.c
Description:
Function to update control offset
Input:
CONTROL_INFO *control
Output:
VOID
Built on 16:20:05 10/01/14


CheckDateFlags in the uefi20Wapper.c

Function : CheckDateFlags

File: uefi20Wapper.c
Description:
Function to Check the Date flags.
Input:
UINT8 Flags
Output:
BOOLEAN
Built on 16:20:05 10/01/14


CheckTimeFlags in the uefi20Wapper.c

Function : CheckTimeFlags

File: uefi20Wapper.c
Description:
Function to Check the time flags.
Input:
UINT8 Flags
Output:
BOOLEAN
Built on 16:20:06 10/01/14


CtrlsSupportsHealthProtocol in the uefi20Wapper.c

Function : CtrlsSupportsHealthProtocol

File: uefi20Wapper.c
Description:
Finds the number of controllers supports driver health protocol for the driver entry
Input:
UINT16 = Entry for driver to which total controllers has to be find
Output:
UINT16 = Total number of controllers supports driver health
Built on 16:20:06 10/01/14


DoDriverHealthOperation in the uefi20Wapper.c

Function : DoDriverHealthOperation

File: uefi20Wapper.c
Description:
Performs the driver health operations for the corresponding controller entry
Input:
VOID * = Control Info for the correponding controller entry
        UINT16 = Controller entry in the page
Output:
VOID
Built on 16:20:06 10/01/14


EvaluateControlDefault in the uefi20Wapper.c

Function : EvaluateControlDefault

File: uefi20Wapper.c
Description:

Parameter:	    CONTROL_INFO *CtrlInfo

Return value:  UINT64
Built on 16:20:07 10/01/14


FindDriverHealthDriverName in the uefi20Wapper.c

Function : FindDriverHealthDriverName

File: uefi20Wapper.c
Description:
Finds the driver name which supports driver health protocol
Input:
UINT16 = Entry for which driver name has to be return
Output:
CHAR16 * = Driver Name
Built on 16:20:07 10/01/14


GetControlConditionVarId in the uefi20Wapper.c

Function : GetControlConditionVarId

File: uefi20Wapper.c
Description:
Function to get control variable id
Input:
CONTROL_INFO *control
Output:
UINT32
Built on 16:20:08 10/01/14


GetCtrlNameAndHealth in the uefi20Wapper.c

Function : GetCtrlNameAndHealth

File: uefi20Wapper.c
Description:
Finds the controller name with its health
Input:
UINT16 = Entry for controller to which name has to be find
Output:
CHAR16 * = Controller name with its health status
Built on 16:20:08 10/01/14


HiiGetDefaultMask in the uefi20Wapper.c

Function : HiiGetDefaultMask

File: uefi20Wapper.c
Description:
Function to get default mask
Input:
VOID
Output:
UINTN
Built on 16:20:09 10/01/14


HiiGetManufactuingMask in the uefi20Wapper.c

Function : HiiGetManufactuingMask

File: uefi20Wapper.c
Description:
Function to get manufacturing mask
Input:
VOID
Output:
UINTN
Built on 16:20:09 10/01/14


InitMiniSetupStrings in the uefi20Wapper.c

Function : InitMiniSetupStrings

File: uefi20Wapper.c
Description:
Function to init minisetup strings
Input:
VOID
Output:
Status
Built on 16:20:10 10/01/14


IsPasswordEncodeEnabled in the uefi20Wapper.c

Function : IsPasswordEncodeEnabled

File: uefi20Wapper.c
Description:
Function to Password Encoding Status.
Input:
VOID *PwDataPtr
Output:
TRUE/FALSE
Built on 16:20:10 10/01/14


ProcessActionQuestionConfiguration in the uefi20Wapper.c

Function : ProcessActionQuestionConfiguration

File: uefi20Wapper.c
Description:
Function to process Action Control Configuration String.
        UEFI Action control is a 2.1 control
Input:
CONTROL_INFO *control
Output:
EFI_STATUS
Built on 16:20:13 10/01/14


ProcessPackNotification in the uefi20Wapper.c

Function : ProcessPackNotification

File: uefi20Wapper.c
Description:
Processes the IFR notification queue
Input:
None
Output:
EFI_STATUS status - EFI_ABORTED, By default
               EFI_SUCCESS, if successful
               EFI_ERROR, otherwise
Built on 16:20:13 10/01/14


RegFormNotification in the uefi20Wapper.c

Function : RegFormNotification

File: uefi20Wapper.c
Description:
Registers the hii pack notification

Parameter: VOID

Return value: EFI_STATUS
Built on 16:20:14 10/01/14


SetDriverHealthCount in the uefi20Wapper.c

Function : SetDriverHealthCount

File: uefi20Wapper.c
Description:
Sets the DriverHealthCount and DriverHlthEnable variables
Input:
VOID
Output:
VOID
Built on 16:20:14 10/01/14


SetDrvHealthHandleAndCtrlCount in the uefi20Wapper.c

Function : SetDrvHealthHandleAndCtrlCount

File: uefi20Wapper.c
Description:
Finds and sets the number of controllers supports the driver health handle
Input:
UINT16 = Driver health handle entry
Output:
VOID
Built on 16:20:14 10/01/14


UefiAddEndOp in the uefi20Wapper.c

Function : UefiAddEndOp

File: uefi20Wapper.c
Description:
Function to add end op code
Input:
VOID *IfrPtr
Output:
VOID
Built on 16:20:17 10/01/14


UefiCreateDynamicControlCondition in the uefi20Wapper.c

Function : UefiCreateDynamicControlCondition

File: uefi20Wapper.c
Description:
Function to create dynamic control condition
Input:
CONTROL_INFO *control,UINT16 VarId, UINT16 PrevControlQuestionID,UINT16 Value
Output:
VOID
Built on 16:20:17 10/01/14


UefiCreateOneOfWithOptionsTemplate in the uefi20Wapper.c

Function : UefiCreateOneOfWithOptionsTemplate

File: uefi20Wapper.c
Description:
Function to create OneOf option template
Input:
UINTN OptionCount, CONTROL_INFO *CtrlInfo
Output:
VOID*
Built on 16:20:17 10/01/14


UefiCreateStringTemplate in the uefi20Wapper.c

Function : UefiCreateStringTemplate

File: uefi20Wapper.c
Description:
Function to create uefi string template

Parameter:	    UINT16 Token

Return value:  VOID *
Built on 16:20:17 10/01/14


UefiCreateSubTitleTemplate in the uefi20Wapper.c

Function : UefiCreateSubTitleTemplate

File: uefi20Wapper.c
Description:
Function to prepare the template for sub-title
Input:
UINT16 Token
Output:
VOID
Built on 16:20:17 10/01/14


UefiFormCallbackNVRead in the uefi20Wapper.c

Function : UefiFormCallbackNVRead

File: uefi20Wapper.c
Description:
Function to get callback nvread
Input:
CHAR16 *name,
            EFI_GUID *guid,
            UINT32 *attributes,
            UINTN *size,
            VOID **buffer
Output:
Status
Built on 16:20:17 10/01/14


UefiFormCallbackNVWrite in the uefi20Wapper.c

Function : UefiFormCallbackNVWrite

File: uefi20Wapper.c
Description:
Function to get callback nvwrite
Input:
CHAR16 *name,
        EFI_GUID *guid,
        UINT32 *attributes,
        VOID **buffer
        UINTN *size,
Output:
Status
Built on 16:20:17 10/01/14


UefiGetBaseValue in the uefi20Wapper.c

Function : UefiGetBaseValue

File: uefi20Wapper.c
Description:
Function to get the base value
Input:
VOID *IfrPtr
Output:
UINT8
Built on 16:20:17 10/01/14


UefiGetControlKey in the uefi20Wapper.c

Function : UefiGetControlKey

File: uefi20Wapper.c
Description:
Helper function in obtaining Control Key
Input:
CONTROL_INFO *ControlData
Output:
Key Field
Built on 16:20:17 10/01/14


UefiGetDateTimeDetails in the uefi20Wapper.c

Function : UefiGetDateTimeDetails

File: uefi20Wapper.c
Description:
Function to get the details of data and time
Input:
VOID *IfrPtr,
        UINT8 Type,
        UINT16 * Help,
        UINT16 * Min,
        UINT16 * Max
Output:
VOID
Built on 16:20:17 10/01/14


UefiGetEqIDQuestionID in the uefi20Wapper.c

Function : UefiGetEqIDQuestionID

File: uefi20Wapper.c
Description:
Function to Check EqID question ID
Input:
VOID *IfrPtr
Output:
UINT16
Built on 16:20:17 10/01/14


UefiGetFlagsField in the uefi20Wapper.c

Function : UefiGetFlagsField

File: uefi20Wapper.c
Description:
to get the Flags field from ifr
Input:
VOID *IfrPtr
Output:
Flags Field
Built on 16:20:17 10/01/14


UefiGetHelpField in the uefi20Wapper.c

Function : UefiGetHelpField

File: uefi20Wapper.c
Description:
To get the specific help field
Input:
VOID *IfrPtr
Output:
Help Field
Built on 16:20:17 10/01/14


UefiGetIfrLength in the uefi20Wapper.c

Function : UefiGetIfrLength

File: uefi20Wapper.c
Description:
Function to get the length of Ifr
Input:
VOID *IfrPtr
Output:
Length
Built on 16:20:17 10/01/14


UefiGetKeyField in the uefi20Wapper.c

Function : UefiGetKeyField

File: uefi20Wapper.c
Description:
To get the Key field from ifr
Input:
VOID *IfrPtr
Output:
Key Field
Built on 16:20:17 10/01/14


UefiGetMaxEntries in the uefi20Wapper.c

Function : UefiGetMaxEntries

File: uefi20Wapper.c
Description:
Function to get max entries
Input:
VOID *IfrPtr,
Output:
UINT8
Built on 16:20:17 10/01/14


UefiGetMaxValue in the uefi20Wapper.c

Function : UefiGetMaxValue

File: uefi20Wapper.c
Description:
Function to get the max value
Input:
VOID *IfrPtr
Output:
UINT64
Built on 16:20:17 10/01/14


UefiGetMinValue in the uefi20Wapper.c

Function : UefiGetMinValue

File: uefi20Wapper.c
Description:
Function to get the minimum value
Input:
VOID *IfrPtr
Output:
UINT64
Built on 16:20:17 10/01/14


UefiGetOneOfOptions in the uefi20Wapper.c

Function : UefiGetOneOfOptions

File: uefi20Wapper.c
Description:
Function to get OneOf options
Input:
VOID *IfrPtr,
            VOID **Handle,
            UINT16  **OptionPtrTokens,
            UINT64 **ValuePtrTokens,
            UINT16 * ItemCount,
            UINT16 * Interactive,
            UINT16 * CallBackKey
Output:
Status
Built on 16:20:17 10/01/14


UefiGetPromptField in the uefi20Wapper.c

Function : UefiGetPromptField

File: uefi20Wapper.c
Description:
To get the prompt field from ifr
Input:
VOID *IfrPtr
Output:
Prompt Field
Built on 16:20:17 10/01/14


UefiGetQuestionID in the uefi20Wapper.c

Function : UefiGetQuestionID

File: uefi20Wapper.c
Description:
Function to get question ID
Input:
CONTROL_INFO *control
Output:
UINT16
Built on 16:20:17 10/01/14


UefiGetQuestionOffset in the uefi20Wapper.c

Function : UefiGetQuestionOffset

File: uefi20Wapper.c
Description:
Function to get question offset
Input:
VOID *IfrPtr
Output:
UINT16
Built on 16:20:17 10/01/14


UefiGetResetButtonDefaultid in the uefi20Wapper.c

Function : UefiGetResetButtonDefaultid

File: uefi20Wapper.c
Description:
In UEFI 2.0 this is Dummy function.

Parameter:	    VOID *IfrPtr

Return value:    UINT16
Built on 16:20:17 10/01/14


UefiGetSpecialEqIDIfrPtr in the uefi20Wapper.c

Function : UefiGetSpecialEqIDIfrPtr

File: uefi20Wapper.c
Description:
Function to get special eqID Ifr pointer
Input:
VOID *Conditional, UINT32 Variable, GUID_INFO **GuidInfo
Output:
VOID*
Built on 16:20:17 10/01/14


UefiGetSpecialEqIDValue in the uefi20Wapper.c

Function : UefiGetSpecialEqIDValue

File: uefi20Wapper.c
Description:
Function to get special eqID value
Input:
CONTROL_INFO *ControlInfo, GUID_INFO **GuidInfo
Output:
UINT16
Built on 16:20:17 10/01/14


UefiGetStepValue in the uefi20Wapper.c

Function : UefiGetStepValue

File: uefi20Wapper.c
Description:
Function to get the step value
Input:
VOID *IfrPtr
Output:
UINT64
Built on 16:20:17 10/01/14


UefiGetTextField in the uefi20Wapper.c

Function : UefiGetTextField

File: uefi20Wapper.c
Description:
Function to get the Text Field.
Input:
VOID *IfrPtr
Output:
Text Field
Built on 16:20:17 10/01/14


UefiGetTextTwoField in the uefi20Wapper.c

Function : UefiGetTextTwoField

File: uefi20Wapper.c
Description:
Function to get the Text Field.
Input:
VOID *IfrPtr
Output:
Text Field
Built on 16:20:17 10/01/14


UefiGetTime in the uefi20Wapper.c

Function : UefiGetTime

File: uefi20Wapper.c
Description:
Function to get time

Parameter:	    CONTROL_INFO *control, EFI_TIME *Tm

Return value:    STATUS
Built on 16:20:17 10/01/14


UefiGetTitleField in the uefi20Wapper.c

Function : UefiGetTitleField

File: uefi20Wapper.c
Description:
To get the Title field from ifr
Input:
VOID *IfrPtr
Output:
Title Field
Built on 16:20:17 10/01/14


UefiGetValidOptionSize in the uefi20Wapper.c

Function : UefiGetValidOptionSize

File: uefi20Wapper.c
Description:
Function to get sizeof option.UEFI2.0 doesn't have EFI_IFR_TYPE support
Input:
CONTROL_INFO *CtrlInfo - Pointer to the control info data
UINTN *Type - Returns EFI_IFR_TYPE_NUM_SIZE
Output:
VOID
Built on 16:20:17 10/01/14


UefiGetWidth in the uefi20Wapper.c

Function : UefiGetWidth

File: uefi20Wapper.c
Description:
Function to get width
Input:
VOID *IfrPtr
Output:
UINT16
Built on 16:20:17 10/01/14


UefiIsEfiVariable in the uefi20Wapper.c

Function : UefiIsEfiVariable

File: uefi20Wapper.c
Description:
Function to Check efi variable
Input:
UINT32 variable, VARIABLE_INFO *varInfo
Output:
BOOLEAN
Built on 16:20:17 10/01/14


UefiIsInteractive in the uefi20Wapper.c

Function : UefiIsInteractive

File: uefi20Wapper.c
Description:
To get Uefi Interactive
Input:
CONTROL_INFO *ControlData
Output:
TRUE/FALSE
Built on 16:20:17 10/01/14


UefiIsOneOfControl in the uefi20Wapper.c

Function : UefiIsOneOfControl

File: uefi20Wapper.c
Description:
Function to Check for OneOf controls
Input:
VOID *IfrPtr
Output:
BOOLEAN
Built on 16:20:17 10/01/14


UefiIsProceedWithPageChange in the uefi20Wapper.c

Function : UefiIsProceedWithPageChange

File: uefi20Wapper.c
Description:
For UEFI 2.0 Just return EFI_SUCCESS;

Parameter:     EFI_STATUS

Return Value:  EFI_STATUS
Built on 16:20:17 10/01/14


UefiPreControlUpdate in the uefi20Wapper.c

Function : UefiPreControlUpdate

File: uefi20Wapper.c
Description:
In UEFI 2.0 this is Dummy function.

Parameter:     CONTROL_INFO * ControlData

Return Value:  EFI_STATUS
Built on 16:20:17 10/01/14


UefiRefershQuestionValueNvRAM in the uefi20Wapper.c

Function : UefiRefershQuestionValueNvRAM

File: uefi20Wapper.c
Description:
Function Refresh the question

Parameter:	    CONTROL_INFO *control

Return value:    STATUS
Built on 16:20:17 10/01/14


UefiSetEqIDQuestionID in the uefi20Wapper.c

Function : UefiSetEqIDQuestionID

File: uefi20Wapper.c
Description:
Function to set EqID question ID
Input:
VOID *IfrPtr, UINT16 Value
Output:
VOID
Built on 16:20:17 10/01/14


UefiSetEqIDValue in the uefi20Wapper.c

Function : UefiSetEqIDValue

File: uefi20Wapper.c
Description:
Function to set EqID value
Input:
VOID *IfrPtr, UINT16 Value
Output:
VOID
Built on 16:20:17 10/01/14


UefiSetHelpField in the uefi20Wapper.c

Function : UefiSetHelpField

File: uefi20Wapper.c
Description:
To Set the specific help field
Input:
VOID *IfrPtr,	UINT16 Token
Output:
VOID
Built on 16:20:17 10/01/14


UefiSetOneOfOption in the uefi20Wapper.c

Function : UefiSetOneOfOption

File: uefi20Wapper.c
Description:
Function to set OneOf option
Input:
VOID *IfrPtr, UINT64 Value, UINT32 Size, UINT8 Flag, UINT16 Option
Output:
VOID
Built on 16:20:17 10/01/14


UefiSetPromptField in the uefi20Wapper.c

Function : UefiSetPromptField

File: uefi20Wapper.c
Description:
Function to set the prompt Field.
Input:
VOID *IfrPtr,	UINT16 Token
Output:
VOID
Built on 16:20:17 10/01/14


UefiSetSubTitleField in the uefi20Wapper.c

Function : UefiSetSubTitleField

File: uefi20Wapper.c
Description:
Function to Set the Sub-Title Field.
Input:
VOID *IfrPtr,	UINT16 Token
Output:
VOID
Built on 16:20:17 10/01/14


UefiSetTime in the uefi20Wapper.c

Function : UefiSetTime

File: uefi20Wapper.c
Description:
Function to set time

Parameter:	    CONTROL_INFO *control, EFI_TIME *Tm

Return value:    STATUS
Built on 16:20:17 10/01/14


UefiSetWidth in the uefi20Wapper.c

Function : UefiSetWidth

File: uefi20Wapper.c
Description:
Function to set width
Input:
VOID *IfrPtr
Output:
UINT16
Built on 16:20:17 10/01/14


UefiSpecialGuidCallback in the uefi20Wapper.c

Function : UefiSpecialGuidCallback

File: uefi20Wapper.c
Description:
Function to get special guid callback
Input:
VOID * HiiHandle, UINT16 Key, EFI_GUID *pGUID
Output:
VOID
Built on 16:20:17 10/01/14


UefiTseLiteGetAmiCallbackIndex in the uefi20Wapper.c

Function : UefiTseLiteGetAmiCallbackIndex

File: uefi20Wapper.c
Description:
Function to get ami callback index
Input:
VOID *Ptr,
Output:
UINT16
Built on 16:20:17 10/01/14


UefiTseLiteGetBootOverRideIndex in the uefi20Wapper.c

Function : UefiTseLiteGetBootOverRideIndex

File: uefi20Wapper.c
Description:
Function to get boot override index
Input:
VOID *Ptr,
Output:
UINT16
Built on 16:20:17 10/01/14


UefiUpdateControlVarOffset in the uefi20Wapper.c

Function : UefiUpdateControlVarOffset

File: uefi20Wapper.c
Description:
Function to update control variable offset
Input:
VOID *IfrPtr, UINT16 Value
Output:
VOID
Built on 16:20:17 10/01/14


UefiupdateResetButtonDefault in the uefi20Wapper.c

Function : UefiupdateResetButtonDefault

File: uefi20Wapper.c
Description:
In UEFI 2.0 this is Dummy function.
Input:
CONTROL_INFO ControlData, UINT16 DefaultId
Output:
EFI_STATUS
Built on 16:20:17 10/01/14


UefiVarGetNvram in the uefi20Wapper.c

Function : UefiVarGetNvram

File: uefi20Wapper.c
Description:
Function to get nvram

Parameter:	    VARIABLE_INFO *VariableInfo, VOID **Buffer, UINTN Offset,
            UINTN Size
Output:
STATUS
Built on 16:20:17 10/01/14


UnRegFormNotification in the uefi20Wapper.c

Function : UnRegFormNotification

File: uefi20Wapper.c
Description:
Unregisters the form notification

Parameter:	VOID

Return value: VOID
Built on 16:20:18 10/01/14


UpdateDestiantionQuestion in the uefi20Wapper.c

Function : UpdateDestiantionQuestion

File: uefi20Wapper.c
Description:
Dummy function for 2.0
Input:
UINT32 CurrPageID - Current page ID
UINT32 DestQuestionId - Destination question ID to set focus
UINT32 *FocusControlIndex -
Output:
EFI_STATUS status - EFI_SUCCESS is successful
Built on 16:20:18 10/01/14


UEFI21 SDL Tokens

The following data structures are used in the file: UEFI21 SDL Tokens.

Variable | Description
SETUP_FORM_BROWSER_SUPPORT | 1 => Installs form browser protocol should turn on SETUP_RUNTIME_IFR_PROCESSING. 0 => Does not install form browser protocol.
TianoHII_SUPPORT | Switch to enable Tiano defined HII support in Project
TSE_SUPPORT_VFRCOMPILE_1_88 | Turn on to support vfrcompiler version 1.88 and later
UEFI_HII_2_1_SUPPORT | Main switch to enable UEFI 2.1 sources support in Project

Built on 16:20:22 10/01/14


SETUP_FORM_BROWSER_SUPPORT in the UEFI21 SDL Tokens

Variable : SETUP_FORM_BROWSER_SUPPORT

File: UEFI21 SDL Tokens
Description:
1 => Installs form browser protocol should turn on SETUP_RUNTIME_IFR_PROCESSING. 0 => Does not install form browser protocol.
Built on 16:20:15 10/01/14


TianoHII_SUPPORT in the UEFI21 SDL Tokens

Variable : TianoHII_SUPPORT

File: UEFI21 SDL Tokens
Description:
Switch to enable Tiano defined HII support in Project
Built on 16:20:16 10/01/14


TSE_SUPPORT_VFRCOMPILE_1_88 in the UEFI21 SDL Tokens

Variable : TSE_SUPPORT_VFRCOMPILE_1_88

File: UEFI21 SDL Tokens
Description:
Turn on to support vfrcompiler version 1.88 and later
Built on 16:20:16 10/01/14


UEFI_HII_2_1_SUPPORT in the UEFI21 SDL Tokens

Variable : UEFI_HII_2_1_SUPPORT

File: UEFI21 SDL Tokens
Description:
Main switch to enable UEFI 2.1 sources support in Project
Built on 16:20:17 10/01/14


Uefi21Wapper.c

Description:

The following functions are used in the file: Uefi21Wapper.c.

Function | Description
_ConstructConfigHdr | Construct <ConfigHdr> using routing information GUID/NAME/PATH. Parameter: IN OUT CHAR16 *ConfigHdr, IN OUT UINTN *StrBufferLen, IN EFI_GUID *Guid, IN CHAR16 *Name, OPTIONAL IN EFI_HANDLE *DriverHandle Return value: EFI_STATUS
_DestinationFormProcessed | Is this form Processed Parameter: IN UINT32 FormID Return Value: BOOLEAN
_DestinationPageProcessed | Checks whether the page is already processed or not.
_GetCheckBoxOptions | Get the List of Options for the Checkbox Control Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex OUT UINTN *optionCount OUT OPTION_LIST *optionArray Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
_GetControlFlag | Gets attribute flag for a given CtrlIndex in a page
_GetControlInfo | Returns pointer to the CONTROL_INFO struct of given CtrlIndex
_GetDefaultNvramVariableIDList | To get the default variable names.
_GetVariableIDList | function to get the list of all variables that are need to update Parameter: UINT32 FormID, UINT32 **VarIDList Return Value: EFI_STATUS
_InconsistenceCheck | Checks if the controls in a page is inconsistent
_NoSubmitCheck | Checks if the controls in a page has no submit
_UefiGetValidOptions | Parameter: CONTROL_INFO *CtrlInfo, UINT16 **OptionPtrTokens, UINT64 **ValuePtrTokens, UINT16 *ItemCount,UINT8 MaxItems Return value: VOID
_VerifyResponseString | Verifies Correctness of Response String. This is to prevent crashing if the result pointer is pointing to an invalid location. Parameter: EFI_STRING *Configuration Return value: EFI_STATUS
AddEntryIngProcessedForms | Adds the formid in gProcessedForms
AddHandleIntoList | Adds the driver health details to the linked list
BBSUpdateControlOffset | Parameter: CONTROL_INFO *control Return value: VOID
CheckDateFlags | Function to Check the date flags.
CheckforNosubmitIf | Check for no submit if Parameter: UINT32 FormID, BOOLEAN Recursive, UINT16 *ErrToken Return Value: BOOLEAN
CheckTimeFlags | Function to Check the time flags.
CleanCurrLoadVarBuffer | Cleans the temporary variables
CleargProcessedForms | Clears gProcessedForms data
CreateFile | Creates a file to Output hpk data
CtrlsSupportsHealthProtocol | Finds the number of controllers supports driver health protocol for the driver entry
DebugLibShowHiiControlState | Prints the AMI Setup Lib control states
DebugShowAllHiiVariable | Prints the variable information in the list
DebugShowBufferContent | Prints the buffer, 16 characters max in a line
DebugShowControlInfo | Prints the cache controls information
DebugShowHiiVariable | Prints the variable information for the given parameter
DebugShowPageInfo | Shows the Page information
DisplayMsgListMessageBox | Displays the messages from EFI_DRIVER_HEALTH_HII_MESSAGE
DisplayParseFormSetData | Prints the current FormSet data
DoDriverHealthOperation | Performs the driver health operations for the corresponding controller entry
EvaluateControlCondition | Evaluate control HII expression and return display Result Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex OUT UINTN *expResult Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
FindDriverHealthDriverName | Finds the driver name which supports driver health protocol
FreeControllersList | Frees the driver health details linked list
FreeOptionList | Parameter: OPTION_LIST *OptionArray Return Value: VOID
GetBlockName | Parameter: EFI_STRING *Configuration, UINTN *Length, UINTN Size Return value: EFI_STATUS
GetConfigHeader | Parameter: VARIABLE_INFO *VariableInfo, EFI_STRING *Configuration, UINTN *Length Return value: EFI_STATUS
GetControlAccess | Get the Control Access Specifier for a Control Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex Return Value: UINT8
GetControlConditionVariable | Parameter: CONTROL_INFO *ControlInfo Return value: UINT32
GetControlConditionVarId | Parameter: CONTROL_INFO *controlInfo Return value: UINT32
GetControlDataLength | This function will return width of questions Parameter: CONTROL_INFO * Return value: UINTN
GetControlDataWidth | Get the Data size Parameter: UINT32 PgIndex, UINT32 CtrlIndex, UINT16 *controlWidth Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetControlDefault | Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex UINT64 *Def BOOLEAN Optimal Return Value: EFI_STATUS
GetControlDestinationPage | Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex OUT UINT16 *ctrlDestPg Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetControlDisplayFormat | Parameter: UINT32 PgIndex UINT32 CtrlIndex UINT16 *Format Return Value: EFI_STATUS
GetControlHelpStr | Get the Control Help String ID Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex OUT UINT16 *ctrlHelp Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetControlMinMax | Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex UINT64 *Min UINT64 *Max Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER EFI_OUT_OF_RESOURCES
GetControlQuestionPrompt | Get the Control Question Prompt's String Id Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex OUT UINT16 *ctrlPrompt Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetControlRefresh | Get the Control Refresh for a Control Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex Return Value: UINT8
GetControlType | Get the AMI Control Type Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex OUT UINT16 *ctrlType Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetCtrlNameAndHealth | Finds the controller name with its health
GetCtrlsDestCtrlId | Returns the QuestionID to select in the destination page
GetDrvHlthCtrlName | Finds the controller name
GetHexStringAsBuffer | Parameter: CHAR8 *Buffer UINT16 *HexStringBuffer UINTN Size Return value: EFI_STATUS
GetNumOfControls | Get the Number of Control for a Page
GetNumOfPages | Get the Total Number of HII Form Pages to display Parameter: OUT UINT32 *numOfPages Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_OUT_OF_RESOURCES
GetOrderedListDataTypeWidth | Gets OrderedList DataType Width Parameter: UINT32 PgIndex, UINT32 CtrlIndex, UINT32 *DataWidth
GetOrderedListMaxEntries | Create a Timer Event
GetOrderedListOptionDataWidth | Gets OrderedList Data Width Parameter: CONTROL_INFO *ControlInfo, UINT32 *DataWidth
GetPageGuidFromFormId | To get the form GUID from the page index
GetPageHandle | Get the Handle for the Page Parameter: IN UINTN PgIndex OUT EFI_HII_HANDLE *handle Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetPageHiiId | Get the Page Title String Index Parameter: IN UINT32 PgIndex OUT UINT16 *PageId Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetPageIdIndex | Get the page ID index for the Page Parameter: IN UINTN PgIndex OUT UINT16 *PgIdIndex Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetPageParentId | Get the parent page ID from the page index Parameter: IN UINT32 PgIndex - Current page Index/ID OUT UINT16 *PageParentId - Parent page ID Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetPageTitle | Get the Page Title String Index Parameter: IN UINT32 PgIndex OUT UINT16 *titleToken Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetQuestionValue | Get the Question Value Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex OUT UINT8 *Value OUT UINTN *ValueSize Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER EFI_OUT_OF_RESOURCES
HiiExtendedInitializeProtocol | Parameter: Return value: EFI_STATUS EFI_SUCCESS
HiiGetDefaultMask | Parameter: VOID Return value: UINTN
HiiGetManufactuingMask | Parameter: VOID Return value: UINTN
HiiGetPackList | Get HII form package by handle and form ID
HiiRemoveString | Parameter: EFI_HII_HANDLE Handle, UINT16 Token Return value: VOID
IdentifyFormHasDefault | Is this formset has the default set Parameter: IN UINT32 FormID Return Value: BOOLEAN
IfNoCommitVariable | Is this a no commit variable Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex Return Value: BOOLEAN
InitMiniSetupStrings | Parameter: VOID Return value: EFI_STATUS
IsControlCheckBox | Check if the control is a Check box Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex Return Value: BOOLEAN
IsControlInteractive | Get the Control Interactive Specifier for a Control Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex Return Value: EFI_STATUS BOOLEAN
IsControlReadOnly | Get the Control Readonly Specifier for a Control Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex Return Value: BOOLEAN
IsControlResetRequired | Get the Control Reset status for a Control Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex Return Value: BOOLEAN
IsControlVisible | Get the Control Visiblity for a Control Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex Return Value: BOOLEAN
IsFormsetHasDefault | Is this formset has the default set Parameter: IN UINT32 FormID Return Value: BOOLEAN
IsNoSubmitOfForms | Is this formset or form has the no submit if Parameter: IN UINT32 FormID OUT UINT16* ErrToken Return Value: BOOLEAN
IsPageRefreshable | Is this page can be refreshable Parameter: IN UINT32 PgIndex Return Value: BOOLEAN
IsParentPage | Is this page a parent page Parameter: IN UINT32 PgIndex Return Value: BOOLEAN
IsPasswordEncodeEnabled | Function to return Password Encoding Status.
LoadDefaults | function to load the defaults to the nvram cache Parameter: UINT32 FormID - form identifier BOOLEAN *ResetVal - Reboot flag of the control variable BOOLEAN * ValChanged - flag to Check whether the value changed Return Value: EFI_STATUS
LoadNvram | Intermediate function to get the nvram variables to restore. Parameter: UINT32 PageID Return Value: EFI_STATUS
NameValueGetHexStringAsBuffer | Parameter: CHAR8 *Buffer UINT16 *HexStringBuffer UINTN Size Return value: EFI_STATUS
ProcessBrowserActionRequest | Parameter: EFI_BROWSER_ACTION_REQUEST actionReq Return Value: EFI_STATUS
ProcessPackToFile | Prints the HPK data to file
SaveQuestionValues | Save all the values to the system Parameter: VOID Return Value: EFI_STATUS EFI_SUCCESS
SetDriverHealthCount | Sets the DriverHealthCount and DriverHlthEnable variables
SetDrvHealthHandleAndCtrlCount | Finds and sets the number of controllers supports the driver health handle
SetQuestionValue | Set the Value for a Question Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex IN UINT8 *Value IN UINTN ValueSize OUT UINT16 *ErrStrToken Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
UefiAddEndOp | Parameter: VOID *IfrPtr Return value: VOID
UefiCreateDynamicControlCondition | Parameter: CONTROL_INFO *control,UINT16 VarId, UINT16 PrevControlQuestionID,UINT16 Value Return value: VOID
UefiCreateOneOfWithOptionsTemplate | Parameter: UINTN OptionCount, CONTROL_INFO *CtrlInfo Return value: VOID*
UefiCreateStringTemplate | Function to create uefi string template Parameter: UINT16 Token Return value: VOID *
UefiCreateSubTitleTemplate | Parameter: UINT16 Token Return value: VOID *
UefiFormCallbackNVRead | Parameter: CHAR16 *name, EFI_GUID *guid, UINT32 *attributes, UINTN *size, VOID **buffer Return value: EFI_STATUS
UefiFormCallbackNVWrite | Parameter: CHAR16 *name, EFI_GUID *guid, UINT32 attributes, VOID *buffer, UINTN size Return value: EFI_STATUS
UefiGetBaseValue | Parameter: VOID *IfrPtr Return value: UINT8
UefiGetControlKey | Parameter: CONTROL_INFO *ControlData Return value: UINT16
UefiGetDateTimeDetails | Parameter: VOID *IfrPtr,UINT8 Type,UINT16 * Help,UINT16 * Min,UINT16 * Max Return value: VOID
UefiGetEqIDQuestionID | Parameter: VOID *IfrPtr Return value: UINT16
UefiGetFlagsField | Parameter: VOID *IfrPtr Return value: UINT8
UefiGetHelpField | Parameter: VOID *IfrPtr Return value: UINT16
UefiGetIfrLength | Parameter: VOID *IfrPtr Return value: UINT8
UefiGetKeyField | Parameter: VOID *IfrPtr Return value: UINT16
UefiGetMaxEntries | Parameter: VOID *IfrPtr Return value: UINT8
UefiGetMaxValue | Parameter: VOID *IfrPtr Return value: UINT64
UefiGetMinValue | Parameter: VOID *IfrPtr Return value: UINT64
UefiGetOneOfOptions | Parameter: VOID *IfrPtr,VOID **Handle,UINT16 **OptionPtrTokens, UINT64 **ValuePtrTokens, UINT16 *ItemCount, UINT16 *Interactive,UINT16 *CallBackKey Return value: EFI_STATUS
UefiGetPromptField | Parameter: VOID *IfrPtr Return value: UINT16
UefiGetQuestionID | Parameter: CONTROL_INFO *Control Return value: UINT16
UefiGetQuestionOffset | Parameter: VOID *IfrPtr Return value: UINT16
UefiGetResetButtonDefaultid | Funtion get the ResetButton Default Id from the Opcode information Parameter: VOID *IfrPtr Return value: UINT16
UefiGetSpecialEqIDValue | Parameter: CONTROL_INFO *ControlInfo, GUID_INFO **GuidInfo Return value: UINT16
UefiGetStepValue | Parameter: VOID *IfrPtr Return value: UINT64
UefiGetTextField | Parameter: VOID *IfrPtr Return value: UINT16
UefiGetTextTwoField | Parameter: VOID *IfrPtr Return value: UINT16
UefiGetTime | Function to get time Parameter: CONTROL_INFO *control, EFI_TIME *Tm Return value: STATUS
UefiGetTitleField | Parameter: VOID *IfrPtr Return value: UINT16
UefiGetValidOptionType | Assuming all the options in this control has option with same type and length
UefiGetWidth | Parameter: VOID *IfrPtr Return value: UINT16
UefiIsEfiVariable | Parameter: UINT32 variable, VARIABLE_INFO *varInfo Return value: BOOLEAN
UefiIsInteractive | Parameter: CONTROL_INFO *ControlData Return value: BOOLEAN
UefiIsOneOfControl | Parameter: VOID *IfrPtr Return value: BOOLEAN
UefiLoadPreviousValuesforCurrentform | Loads previous value for the current form
UefiRefershQuestionValueNvRAM | Function to Refresh the questions Parameter: CONTROL_INFO *ControlData Return value: EFI_STATUS
UefiSetEqIDQuestionID | Parameter: VOID *IfrPtr, UINT16 Value Return value: VOID
UefiSetEqIDValue | Parameter: VOID *IfrPtr, UINT16 Value Return value: VOID
UefiSetHelpField | Parameter: VOID *IfrPtr,UINT16 Token Return value: VOID
UefiSetOneOfOption | Parameter: VOID *IfrPtr, UINT64 Value, UINT32 Size, UINT8 Flag, UINT16 Option Return value: VOID
UefiSetPromptField | Parameter: VOID *IfrPtr,UINT16 Token Return value: VOID
UefiSetSubTitleField | Parameter: VOID *IfrPtr,UINT16 Token Return value: VOID
UefiSetTime | Function to set time Parameter: CONTROL_INFO *control, EFI_TIME *Tm Return value: STATUS
UefiSetWidth | Parameter: VOID *IfrPtr,UINT8 Width Return value: VOID
UefiSpecialGuidCallback | Parameter: VOID * HiiHandle, UINT16 Key, EFI_GUID *pGUID Return value: VOID
UefiTseLiteGetAmiCallbackIndex | Parameter: VOID * Ptr Return value: UINT16
UefiTseLiteGetBootOverRideIndex | Parameter: VOID *IfrPtr Return value: UINT16
UefiUpdateControlQuestionID | Parameter: VOID *IfrPtr, UINT16 Value Return value: VOID
UefiUpdateControlVarOffset | Parameter: VOID *IfrPtr, UINT16 Value Return value: VOID
UefiVarGetNvram | Parameter: VARIABLE_INFO *VariableInfo, VOID **Buffer, UINTN Offset, UINTN Size Return value: EFI_STATUS
UefiVarSetNvram | Parameter: VARIABLE_INFO *VariableInfo, VOID *Buffer, UINTN Offset, UINTN Size Return value: EFI_STATUS
UefiVarsetnvramforCurrentform | Save the values for the passed pageID If this function is not called as part of browser action then it is caller responsibility to reset the gProFormOffset and gProcessedForms gProFormOffset = 0; MemSet (gProcessedForms, MAX_FORMS_TO_PROCESS, 0);
UpdateDestiantionQuestion | Finds the destination question ID for the current destination
WriteDataToFile | Writes data to file
WritePackToFile | Writes Hpk data to file

Built on 16:20:23 10/01/14


_ConstructConfigHdr in the Uefi21Wapper.c

Function : _ConstructConfigHdr

File: Uefi21Wapper.c
Description:
Construct <ConfigHdr> using routing information GUID/NAME/PATH.

Parameter:	  	IN OUT CHAR16 *ConfigHdr,
     IN OUT UINTN  *StrBufferLen,
     IN EFI_GUID   *Guid,
     IN CHAR16     *Name, OPTIONAL
     IN EFI_HANDLE *DriverHandle

Return value:  	EFI_STATUS
Built on 16:20:03 10/01/14


_DestinationFormProcessed in the Uefi21Wapper.c

Function : _DestinationFormProcessed

File: Uefi21Wapper.c
Description:
Is this form Processed

Parameter:		IN	UINT32 FormID
Return Value:	BOOLEAN
Built on 16:20:03 10/01/14


_DestinationPageProcessed in the Uefi21Wapper.c

Function : _DestinationPageProcessed

File: Uefi21Wapper.c
Description:
Checks whether the page is already processed or not.
Input:
UINT32 PageID
Output:
BOOLEAN
Built on 16:20:03 10/01/14


_GetCheckBoxOptions in the Uefi21Wapper.c

Function : _GetCheckBoxOptions

File: Uefi21Wapper.c
Description:
Get the List of Options for the Checkbox Control

Parameter:     IN  UINT32 PgIndex
 IN  UINT32 CtrlIndex
 OUT UINTN  *optionCount
 OUT OPTION_LIST *optionArray

Return Value:  EFI_STATUS
     EFI_SUCCESS
     EFI_NOT_READY
     EFI_INVALID_PARAMETER
Built on 16:20:03 10/01/14


_GetControlFlag in the Uefi21Wapper.c

Function : _GetControlFlag

File: Uefi21Wapper.c
Description:
Gets attribute flag for a given CtrlIndex in a page
Input:
UINT32 PgIndex - Page index containing the control
    UINT32 CtrlIndex - Control index
    CONTROL_FLAGS **CtrlFlag - Pointer to the flag attribute structure
Output:
EFI_STATUS status - EFI_SUCCESS if successful, else EFI_ERROR
Built on 16:20:03 10/01/14


_GetControlInfo in the Uefi21Wapper.c

Function : _GetControlInfo

File: Uefi21Wapper.c
Description:
Returns pointer to the CONTROL_INFO struct of given CtrlIndex
Input:
UINT32 PgIndex - Page index containing the control
    UINT32 CtrlIndex - HII Control index
    CONTROL_INFO **CtrlInfo - Pointer to the CONTROL_INFO structure
Output:
EFI_STATUS status - EFI_SUCCESS if successful, else EFI_ERROR
Built on 16:20:03 10/01/14


_GetDefaultNvramVariableIDList in the Uefi21Wapper.c

Function : _GetDefaultNvramVariableIDList

File: Uefi21Wapper.c
Description:
To get the default variable names.
Input:
UINT32 FormID
            BOOLEAN DefaultsFlag
            BOOLEAN *ResetVal
            BOOLEAN *ValChanged
Output:
EFI_STATUS
Built on 16:20:03 10/01/14


_GetVariableIDList in the Uefi21Wapper.c

Function : _GetVariableIDList

File: Uefi21Wapper.c
Description:
function to get the list of all variables that are need to update

Parameter:     UINT32 FormID,
 UINT32 **VarIDList

Return Value:  EFI_STATUS
Built on 16:20:04 10/01/14


_InconsistenceCheck in the Uefi21Wapper.c

Function : _InconsistenceCheck

File: Uefi21Wapper.c
Description:
Checks if the controls in a page is inconsistent
Input:
PAGE_INFO *PgInfo - Input page info
    UINT16 *ErrStrToken - Pointer to the Output error code
Output:
BOOLEAN flag - TRUE if inconsistence, else FALSE
Built on 16:20:04 10/01/14


_NoSubmitCheck in the Uefi21Wapper.c

Function : _NoSubmitCheck

File: Uefi21Wapper.c
Description:
Checks if the controls in a page has no submit
Input:
CONTROL_INFO *ctrlInfo - Input control info
    UINT16 *ErrStrToken - Pointer to the Output error code
Output:
BOOLEAN flag - TRUE if nosubmit, else FALSE
Built on 16:20:04 10/01/14


_UefiGetValidOptions in the Uefi21Wapper.c

Function : _UefiGetValidOptions

File: Uefi21Wapper.c
Description:

Parameter:	    CONTROL_INFO *CtrlInfo, UINT16 **OptionPtrTokens,
   UINT64 **ValuePtrTokens, UINT16 *ItemCount,UINT8 MaxItems

Return value:  	VOID
Built on 16:20:04 10/01/14


_VerifyResponseString in the Uefi21Wapper.c

Function : _VerifyResponseString

File: Uefi21Wapper.c
Description:
Verifies Correctness of Response String. This is to prevent
          crashing if the result pointer is pointing to an invalid location.

Parameter:	    EFI_STRING *Configuration

Return value:  EFI_STATUS
Built on 16:20:04 10/01/14


AddEntryIngProcessedForms in the Uefi21Wapper.c

Function : AddEntryIngProcessedForms

File: Uefi21Wapper.c
Description:
Adds the formid in gProcessedForms
Input:
UINT32 FormID
Output:
void
Built on 16:20:05 10/01/14


AddHandleIntoList in the Uefi21Wapper.c

Function : AddHandleIntoList

File: Uefi21Wapper.c
Description:
Adds the driver health details to the linked list
Input:
EFI_HANDLE = Controller handle
        EFI_HANDLE = Child handle
        EFI_DRIVER_HEALTH_STATUS = Health status corresponding to controller and child handle
Output:
VOID
Built on 16:20:05 10/01/14


BBSUpdateControlOffset in the Uefi21Wapper.c

Function : BBSUpdateControlOffset

File: Uefi21Wapper.c
Description:

Parameter:	    CONTROL_INFO *control

Return value:  	VOID
Built on 16:20:05 10/01/14


CheckDateFlags in the Uefi21Wapper.c

Function : CheckDateFlags

File: Uefi21Wapper.c
Description:
Function to Check the date flags.
Input:
UINT16 ItemCount
Output:
VOID
Built on 16:20:05 10/01/14


CheckforNosubmitIf in the Uefi21Wapper.c

Function : CheckforNosubmitIf

File: Uefi21Wapper.c
Description:
Check for no submit if

Parameter:     UINT32 FormID, BOOLEAN Recursive, UINT16 *ErrToken

Return Value:  BOOLEAN
Built on 16:20:05 10/01/14


CheckTimeFlags in the Uefi21Wapper.c

Function : CheckTimeFlags

File: Uefi21Wapper.c
Description:
Function to Check the time flags.
Input:
UINT16 ItemCount
Output:
VOID
Built on 16:20:06 10/01/14


CleanCurrLoadVarBuffer in the Uefi21Wapper.c

Function : CleanCurrLoadVarBuffer

File: Uefi21Wapper.c
Description:
Cleans the temporary variables
Input:
None
Output:
VOID
Built on 16:20:06 10/01/14


CleargProcessedForms in the Uefi21Wapper.c

Function : CleargProcessedForms

File: Uefi21Wapper.c
Description:
Clears gProcessedForms data
Input:
void
Output:
void
Built on 16:20:06 10/01/14


CreateFile in the Uefi21Wapper.c

Function : CreateFile

File: Uefi21Wapper.c
Description:
Creates a file to Output hpk data
Input:
CHAR16 *filenameFormat,
    EFI_HII_HANDLE *Handle,
    UINTN Index
Output:
EFI_FILE_PROTOCOL*
Built on 16:20:06 10/01/14


CtrlsSupportsHealthProtocol in the Uefi21Wapper.c

Function : CtrlsSupportsHealthProtocol

File: Uefi21Wapper.c
Description:
Finds the number of controllers supports driver health protocol for the driver entry
Input:
UINT16 = Entry for driver to which total controllers has to be find
Output:
UINT16 = Total number of controllers supports driver health
Built on 16:20:06 10/01/14


DebugLibShowHiiControlState in the Uefi21Wapper.c

Function : DebugLibShowHiiControlState

File: Uefi21Wapper.c
Description:
Prints the AMI Setup Lib control states
Input:
None
Output:
VOID
Built on 16:20:06 10/01/14


DebugShowAllHiiVariable in the Uefi21Wapper.c

Function : DebugShowAllHiiVariable

File: Uefi21Wapper.c
Description:
Prints the variable information in the list
Input:
UINT32 formID
Output:
EFI_STATUS status - EFI_SUCCESS if successful, else EFI_ERROR
Built on 16:20:06 10/01/14


DebugShowBufferContent in the Uefi21Wapper.c

Function : DebugShowBufferContent

File: Uefi21Wapper.c
Description:
Prints the buffer, 16 characters max in a line
Input:
UINTN bufSize - Buffer length to print
    VOID *buffer - Buffer to print
Output:
VOID
Built on 16:20:06 10/01/14


DebugShowControlInfo in the Uefi21Wapper.c

Function : DebugShowControlInfo

File: Uefi21Wapper.c
Description:
Prints the cache controls information
Input:
UINT32 formID
    UINTN count
    VOID *passedCtrlInfo
BOOLEAN detailed - If TRUE, prints the control buffers
Output:
EFI_STATUS status - EFI_SUCCESS if successful, else EFI_ERROR
Built on 16:20:06 10/01/14


DebugShowHiiVariable in the Uefi21Wapper.c

Function : DebugShowHiiVariable

File: Uefi21Wapper.c
Description:
Prints the variable information for the given parameter
Input:
UINT32 formID
Output:
EFI_STATUS status - EFI_SUCCESS if successful, else EFI_ERROR
Built on 16:20:06 10/01/14


DebugShowPageInfo in the Uefi21Wapper.c

Function : DebugShowPageInfo

File: Uefi21Wapper.c
Description:
Shows the Page information
Input:
UINT32 formID - The form
    PAGE_INFO *passedPageInfo
Output:
VOID
Built on 16:20:06 10/01/14


DisplayMsgListMessageBox in the Uefi21Wapper.c

Function : DisplayMsgListMessageBox

File: Uefi21Wapper.c
Description:
Displays the messages from EFI_DRIVER_HEALTH_HII_MESSAGE
Input:
EFI_DRIVER_HEALTH_HII_MESSAGE * = Message to show
Output:
VOID
Built on 16:20:06 10/01/14


DisplayParseFormSetData in the Uefi21Wapper.c

Function : DisplayParseFormSetData

File: Uefi21Wapper.c
Description:
Prints the current FormSet data
Input:
UINT32 FormID - Library formID of a FormSet
Output:
EFI_STATUS status - EFI_SUCCESS if successful, else EFI_ERROR
Built on 16:20:06 10/01/14


DoDriverHealthOperation in the Uefi21Wapper.c

Function : DoDriverHealthOperation

File: Uefi21Wapper.c
Description:
Performs the driver health operations for the corresponding controller entry
Input:
VOID * = Control Info for the correponding controller entry
        UINT16 = Controller entry in the page
Output:
VOID
Built on 16:20:06 10/01/14


EvaluateControlCondition in the Uefi21Wapper.c

Function : EvaluateControlCondition

File: Uefi21Wapper.c
Description:
Evaluate control HII expression and return display Result

Parameter:     IN  UINT32 PgIndex
 IN  UINT32 CtrlIndex
 OUT UINTN *expResult

Return Value:  EFI_STATUS
     EFI_SUCCESS
     EFI_NOT_READY
     EFI_INVALID_PARAMETER
Built on 16:20:07 10/01/14


FindDriverHealthDriverName in the Uefi21Wapper.c

Function : FindDriverHealthDriverName

File: Uefi21Wapper.c
Description:
Finds the driver name which supports driver health protocol
Input:
UINT16 = Entry for which driver name has to be return
Output:
CHAR16 * = Driver Name
Built on 16:20:07 10/01/14


FreeControllersList in the Uefi21Wapper.c

Function : FreeControllersList

File: Uefi21Wapper.c
Description:
Frees the driver health details linked list
Input:
VOID
Output:
VOID
Built on 16:20:07 10/01/14


FreeOptionList in the Uefi21Wapper.c

Function : FreeOptionList

File: Uefi21Wapper.c
Description:

Parameter:     OPTION_LIST *OptionArray

Return Value:  VOID
Built on 16:20:07 10/01/14


GetBlockName in the Uefi21Wapper.c

Function : GetBlockName

File: Uefi21Wapper.c
Description:

Parameter:	    EFI_STRING *Configuration, UINTN *Length, UINTN Size

Return value:  EFI_STATUS
Built on 16:20:08 10/01/14


GetConfigHeader in the Uefi21Wapper.c

Function : GetConfigHeader

File: Uefi21Wapper.c
Description:

Parameter:	  	VARIABLE_INFO *VariableInfo, EFI_STRING *Configuration, UINTN *Length

Return value:  	EFI_STATUS
Built on 16:20:08 10/01/14


GetControlAccess in the Uefi21Wapper.c

Function : GetControlAccess

File: Uefi21Wapper.c
Description:
Get the Control Access Specifier for a Control

Parameter:     IN  UINT32 PgIndex
 IN  UINT32 CtrlIndex

Return Value:  UINT8
Built on 16:20:08 10/01/14


GetControlConditionVariable in the Uefi21Wapper.c

Function : GetControlConditionVariable

File: Uefi21Wapper.c
Description:

Parameter:	    CONTROL_INFO *ControlInfo

Return value:  	UINT32
Built on 16:20:08 10/01/14


GetControlConditionVarId in the Uefi21Wapper.c

Function : GetControlConditionVarId

File: Uefi21Wapper.c
Description:

Parameter:	    CONTROL_INFO *controlInfo

Return value:  	UINT32
Built on 16:20:08 10/01/14


GetControlDataLength in the Uefi21Wapper.c

Function : GetControlDataLength

File: Uefi21Wapper.c
Description:
This function will return width of questions

Parameter:		CONTROL_INFO *

Return value:	UINTN
Built on 16:20:08 10/01/14


GetControlDataWidth in the Uefi21Wapper.c

Function : GetControlDataWidth

File: Uefi21Wapper.c
Description:
Get the Data size

Parameter:     UINT32 PgIndex, UINT32 CtrlIndex, UINT16 *controlWidth

Return Value:  EFI_STATUS
     EFI_SUCCESS
     EFI_NOT_READY
     EFI_INVALID_PARAMETER
Built on 16:20:08 10/01/14


GetControlDefault in the Uefi21Wapper.c

Function : GetControlDefault

File: Uefi21Wapper.c
Description:

Parameter:     IN  UINT32 PgIndex
 IN  UINT32 CtrlIndex
 UINT64 *Def
 BOOLEAN Optimal

Return Value:  EFI_STATUS
Built on 16:20:08 10/01/14


GetControlDestinationPage in the Uefi21Wapper.c

Function : GetControlDestinationPage

File: Uefi21Wapper.c
Description:

Parameter:     IN  UINT32 PgIndex
 IN  UINT32 CtrlIndex
 OUT UINT16 *ctrlDestPg

Return Value:  EFI_STATUS
     EFI_SUCCESS
     EFI_NOT_READY
     EFI_INVALID_PARAMETER
Built on 16:20:08 10/01/14


GetControlDisplayFormat in the Uefi21Wapper.c

Function : GetControlDisplayFormat

File: Uefi21Wapper.c
Description:

Parameter:     UINT32 PgIndex
 UINT32 CtrlIndex
 UINT16 *Format

Return Value:  EFI_STATUS
Built on 16:20:08 10/01/14


GetControlHelpStr in the Uefi21Wapper.c

Function : GetControlHelpStr

File: Uefi21Wapper.c
Description:
Get the Control Help String ID

Parameter:     IN  UINT32 PgIndex
 IN  UINT32 CtrlIndex
 OUT UINT16 *ctrlHelp

Return Value:  EFI_STATUS
     EFI_SUCCESS
     EFI_NOT_READY
     EFI_INVALID_PARAMETER
Built on 16:20:08 10/01/14


GetControlMinMax in the Uefi21Wapper.c

Function : GetControlMinMax

File: Uefi21Wapper.c
Description:

Parameter:     IN  UINT32 PgIndex
 IN  UINT32 CtrlIndex
 UINT64 *Min
 UINT64 *Max

Return Value:  EFI_STATUS
     EFI_SUCCESS
     EFI_NOT_READY
     EFI_INVALID_PARAMETER
     EFI_OUT_OF_RESOURCES
Built on 16:20:08 10/01/14


GetControlQuestionPrompt in the Uefi21Wapper.c

Function : GetControlQuestionPrompt

File: Uefi21Wapper.c
Description:
Get the Control Question Prompt's String Id

Parameter:     IN  UINT32 PgIndex
 IN  UINT32 CtrlIndex
 OUT UINT16 *ctrlPrompt

Return Value:  EFI_STATUS
     EFI_SUCCESS
     EFI_NOT_READY
     EFI_INVALID_PARAMETER
Built on 16:20:08 10/01/14


GetControlRefresh in the Uefi21Wapper.c

Function : GetControlRefresh

File: Uefi21Wapper.c
Description:
Get the Control Refresh for a Control

Parameter:     IN  UINT32 PgIndex
 IN  UINT32 CtrlIndex

Return Value:  UINT8
Built on 16:20:08 10/01/14


GetControlType in the Uefi21Wapper.c

Function : GetControlType

File: Uefi21Wapper.c
Description:
Get the AMI Control Type

Parameter:     IN  UINT32 PgIndex
 IN  UINT32 CtrlIndex
 OUT UINT16 *ctrlType

Return Value:  EFI_STATUS
     EFI_SUCCESS
     EFI_NOT_READY
     EFI_INVALID_PARAMETER
Built on 16:20:08 10/01/14


GetCtrlNameAndHealth in the Uefi21Wapper.c

Function : GetCtrlNameAndHealth

File: Uefi21Wapper.c
Description:
Finds the controller name with its health
Input:
UINT16 = Entry for controller to which name has to be find
Output:
CHAR16 * = Controller name with its health status
Built on 16:20:08 10/01/14


GetCtrlsDestCtrlId in the Uefi21Wapper.c

Function : GetCtrlsDestCtrlId

File: Uefi21Wapper.c
Description:
Returns the QuestionID to select in the destination page
Input:
UINT32 PgIndex - ASL page ID
UINT32 CtrlIndex - Control index, Lib control ID
UINT16 *DestCtrlId - Destination control index
Output:
EFI_STATUS status
Built on 16:20:08 10/01/14


GetDrvHlthCtrlName in the Uefi21Wapper.c

Function : GetDrvHlthCtrlName

File: Uefi21Wapper.c
Description:
Finds the controller name
Input:
DRV_HEALTH_HNDLS * = Details for finding the controller name
Output:
CHAR16 * = Controller name for the controller and child handle
Built on 16:20:08 10/01/14


GetHexStringAsBuffer in the Uefi21Wapper.c

Function : GetHexStringAsBuffer

File: Uefi21Wapper.c
Description:

Parameter:		CHAR8 *Buffer
            UINT16 *HexStringBuffer
            UINTN Size

Return value:	EFI_STATUS
Built on 16:20:08 10/01/14


GetNumOfControls in the Uefi21Wapper.c

Function : GetNumOfControls

File: Uefi21Wapper.c
Description:
Get the Number of Control for a Page
Input:
IN  UINT32 PgIndex
     OUT UINT32 *numOfControls
Output:
EFI_STATUS
   EFI_SUCCESS
   EFI_NOT_READY
   EFI_INVALID_PARAMETER
Built on 16:20:08 10/01/14


GetNumOfPages in the Uefi21Wapper.c

Function : GetNumOfPages

File: Uefi21Wapper.c
Description:
Get the Total Number of HII Form Pages to display

Parameter:     OUT UINT32 *numOfPages

Return Value:  EFI_STATUS
     EFI_SUCCESS
     EFI_NOT_READY
     EFI_OUT_OF_RESOURCES
Built on 16:20:08 10/01/14


GetOrderedListDataTypeWidth in the Uefi21Wapper.c

Function : GetOrderedListDataTypeWidth

File: Uefi21Wapper.c
Description:
Gets OrderedList DataType Width

Parameter:     UINT32 PgIndex, UINT32 CtrlIndex, UINT32 *DataWidth
Output:
EFI_STATUS
Built on 16:20:08 10/01/14


GetOrderedListMaxEntries in the Uefi21Wapper.c

Function : GetOrderedListMaxEntries

File: Uefi21Wapper.c
Description:
Create a Timer Event
Input:
UINT32 PgIndex, UINT32 CtrlIndex, UINT8 *MaxEntry
Output:
EFI_STATUS
Built on 16:20:08 10/01/14


GetOrderedListOptionDataWidth in the Uefi21Wapper.c

Function : GetOrderedListOptionDataWidth

File: Uefi21Wapper.c
Description:
Gets OrderedList Data Width

Parameter:     CONTROL_INFO *ControlInfo, UINT32 *DataWidth
Output:
EFI_STATUS
Built on 16:20:08 10/01/14


GetPageGuidFromFormId in the Uefi21Wapper.c

Function : GetPageGuidFromFormId

File: Uefi21Wapper.c
Description:
To get the form GUID from the page index
Input:
UINT32 PgIndex
        EFI_GUID *FormGuid
Output:
EFI_STATUS
Built on 16:20:08 10/01/14


GetPageHandle in the Uefi21Wapper.c

Function : GetPageHandle

File: Uefi21Wapper.c
Description:
Get the Handle for the Page

Parameter:     IN  UINTN           PgIndex
 OUT EFI_HII_HANDLE  *handle

Return Value:  EFI_STATUS
     EFI_SUCCESS
     EFI_NOT_READY
     EFI_INVALID_PARAMETER
Built on 16:20:08 10/01/14


GetPageHiiId in the Uefi21Wapper.c

Function : GetPageHiiId

File: Uefi21Wapper.c
Description:
Get the Page Title String Index

Parameter:     IN  UINT32 PgIndex
 OUT UINT16 *PageId

Return Value:  EFI_STATUS
     EFI_SUCCESS
     EFI_NOT_READY
     EFI_INVALID_PARAMETER
Built on 16:20:08 10/01/14


GetPageIdIndex in the Uefi21Wapper.c

Function : GetPageIdIndex

File: Uefi21Wapper.c
Description:
Get the page ID index for the Page

Parameter:     IN  UINTN  PgIndex
 OUT UINT16 *PgIdIndex

Return Value:  EFI_STATUS
     EFI_SUCCESS
     EFI_NOT_READY
     EFI_INVALID_PARAMETER
Built on 16:20:08 10/01/14


GetPageParentId in the Uefi21Wapper.c

Function : GetPageParentId

File: Uefi21Wapper.c
Description:
Get the parent page ID from the page index

Parameter:     IN  UINT32 PgIndex - Current page Index/ID
 OUT UINT16 *PageParentId - Parent page ID

Return Value:  EFI_STATUS
     EFI_SUCCESS
     EFI_NOT_READY
     EFI_INVALID_PARAMETER
Built on 16:20:08 10/01/14


GetPageTitle in the Uefi21Wapper.c

Function : GetPageTitle

File: Uefi21Wapper.c
Description:
Get the Page Title String Index

Parameter:     IN  UINT32 PgIndex
 OUT UINT16 *titleToken

Return Value:  EFI_STATUS
     EFI_SUCCESS
     EFI_NOT_READY
     EFI_INVALID_PARAMETER
Built on 16:20:08 10/01/14


GetQuestionValue in the Uefi21Wapper.c

Function : GetQuestionValue

File: Uefi21Wapper.c
Description:
Get the Question Value

Parameter:     IN  UINT32 PgIndex
 IN  UINT32 CtrlIndex
 OUT UINT8  *Value
 OUT UINTN  *ValueSize

Return Value:  EFI_STATUS
     EFI_SUCCESS
     EFI_NOT_READY
     EFI_INVALID_PARAMETER
     EFI_OUT_OF_RESOURCES
Built on 16:20:08 10/01/14


HiiExtendedInitializeProtocol in the Uefi21Wapper.c

Function : HiiExtendedInitializeProtocol

File: Uefi21Wapper.c
Description:

Parameter:

Return value: EFI_STATUS
            EFI_SUCCESS
Built on 16:20:09 10/01/14


HiiGetDefaultMask in the Uefi21Wapper.c

Function : HiiGetDefaultMask

File: Uefi21Wapper.c
Description:

Parameter:	    VOID

Return value:  	UINTN
Built on 16:20:09 10/01/14


HiiGetManufactuingMask in the Uefi21Wapper.c

Function : HiiGetManufactuingMask

File: Uefi21Wapper.c
Description:

Parameter:	    VOID

Return value:  	UINTN
Built on 16:20:09 10/01/14


HiiGetPackList in the Uefi21Wapper.c

Function : HiiGetPackList

File: Uefi21Wapper.c
Description:
Get HII form package by handle and form ID
Input:
EFI_HII_HANDLE Handle
UINT16 form
UINTN *Length
Output:
VOID *formPkBuffer -
Built on 16:20:09 10/01/14


HiiRemoveString in the Uefi21Wapper.c

Function : HiiRemoveString

File: Uefi21Wapper.c
Description:

Parameter:	    EFI_HII_HANDLE Handle, UINT16 Token

Return value:  	VOID
Built on 16:20:09 10/01/14


IdentifyFormHasDefault in the Uefi21Wapper.c

Function : IdentifyFormHasDefault

File: Uefi21Wapper.c
Description:
Is this formset has the default set

Parameter:     IN  UINT32 FormID

Return Value:  BOOLEAN
Built on 16:20:09 10/01/14


IfNoCommitVariable in the Uefi21Wapper.c

Function : IfNoCommitVariable

File: Uefi21Wapper.c
Description:
Is this a no commit variable

Parameter:     IN  UINT32 PgIndex
          IN  UINT32 CtrlIndex

Return Value:  BOOLEAN
Built on 16:20:09 10/01/14


InitMiniSetupStrings in the Uefi21Wapper.c

Function : InitMiniSetupStrings

File: Uefi21Wapper.c
Description:

Parameter:	    VOID

Return value:  	EFI_STATUS
Built on 16:20:10 10/01/14


IsControlCheckBox in the Uefi21Wapper.c

Function : IsControlCheckBox

File: Uefi21Wapper.c
Description:
Check if the control is a Check box

Parameter:     IN  UINT32 PgIndex
 IN  UINT32 CtrlIndex

Return Value:  BOOLEAN
Built on 16:20:10 10/01/14


IsControlInteractive in the Uefi21Wapper.c

Function : IsControlInteractive

File: Uefi21Wapper.c
Description:
Get the Control Interactive Specifier for a Control

Parameter:     IN  UINT32 PgIndex
 IN  UINT32 CtrlIndex

Return Value:  EFI_STATUS
     BOOLEAN
Built on 16:20:10 10/01/14


IsControlReadOnly in the Uefi21Wapper.c

Function : IsControlReadOnly

File: Uefi21Wapper.c
Description:
Get the Control Readonly Specifier for a Control

Parameter:     IN  UINT32 PgIndex
 IN  UINT32 CtrlIndex

Return Value:  BOOLEAN
Built on 16:20:10 10/01/14


IsControlResetRequired in the Uefi21Wapper.c

Function : IsControlResetRequired

File: Uefi21Wapper.c
Description:
Get the Control Reset status for a Control

Parameter:     IN  UINT32 PgIndex
 IN  UINT32 CtrlIndex

Return Value:  BOOLEAN
Built on 16:20:10 10/01/14


IsControlVisible in the Uefi21Wapper.c

Function : IsControlVisible

File: Uefi21Wapper.c
Description:
Get the Control Visiblity for a Control

Parameter:     IN  UINT32 PgIndex
 IN  UINT32 CtrlIndex

Return Value:  BOOLEAN
Built on 16:20:10 10/01/14


IsFormsetHasDefault in the Uefi21Wapper.c

Function : IsFormsetHasDefault

File: Uefi21Wapper.c
Description:
Is this formset has the default set

Parameter:     IN  UINT32 FormID

Return Value:  BOOLEAN
Built on 16:20:10 10/01/14


IsNoSubmitOfForms in the Uefi21Wapper.c

Function : IsNoSubmitOfForms

File: Uefi21Wapper.c
Description:
Is this formset or form has the no submit if

Parameter:		IN	UINT32 FormID
            OUT	UINT16* ErrToken

Return Value:	BOOLEAN
Built on 16:20:10 10/01/14


IsPageRefreshable in the Uefi21Wapper.c

Function : IsPageRefreshable

File: Uefi21Wapper.c
Description:
Is this page can be refreshable

Parameter:     IN  UINT32 PgIndex

Return Value:  BOOLEAN
Built on 16:20:10 10/01/14


IsParentPage in the Uefi21Wapper.c

Function : IsParentPage

File: Uefi21Wapper.c
Description:
Is this page a parent page

Parameter:     IN  UINT32 PgIndex

Return Value:  BOOLEAN
Built on 16:20:10 10/01/14


IsPasswordEncodeEnabled in the Uefi21Wapper.c

Function : IsPasswordEncodeEnabled

File: Uefi21Wapper.c
Description:
Function to return Password Encoding Status.
Input:
CONTROL_INFO
Output:
TRUE/FALSE
Built on 16:20:10 10/01/14


LoadDefaults in the Uefi21Wapper.c

Function : LoadDefaults

File: Uefi21Wapper.c
Description:
function to load the defaults to the nvram cache

Parameter:     UINT32 FormID - form identifier
          BOOLEAN *ResetVal - Reboot flag of the control variable
          BOOLEAN * ValChanged - flag to Check whether the value changed

Return Value:  EFI_STATUS
Built on 16:20:11 10/01/14


LoadNvram in the Uefi21Wapper.c

Function : LoadNvram

File: Uefi21Wapper.c
Description:
Intermediate function to get the nvram variables to restore.

Parameter:		UINT32 PageID

Return Value:	EFI_STATUS
Built on 16:20:11 10/01/14


NameValueGetHexStringAsBuffer in the Uefi21Wapper.c

Function : NameValueGetHexStringAsBuffer

File: Uefi21Wapper.c
Description:

Parameter:		CHAR8 *Buffer
            UINT16 *HexStringBuffer
            UINTN Size

Return value:	EFI_STATUS
Built on 16:20:11 10/01/14


ProcessBrowserActionRequest in the Uefi21Wapper.c

Function : ProcessBrowserActionRequest

File: Uefi21Wapper.c
Description:

Parameter:     EFI_BROWSER_ACTION_REQUEST actionReq

Return Value:  EFI_STATUS
Built on 16:20:13 10/01/14


ProcessPackToFile in the Uefi21Wapper.c

Function : ProcessPackToFile

File: Uefi21Wapper.c
Description:
Prints the HPK data to file
Input:
EFI_HII_DATABASE_NOTIFY_TYPE NotifyType, EFI_HANDLE Handle
Output:
VOID
Built on 16:20:14 10/01/14


SaveQuestionValues in the Uefi21Wapper.c

Function : SaveQuestionValues

File: Uefi21Wapper.c
Description:
Save all the values to the system

Parameter:     VOID

Return Value:  EFI_STATUS
     EFI_SUCCESS
Built on 16:20:14 10/01/14


SetDriverHealthCount in the Uefi21Wapper.c

Function : SetDriverHealthCount

File: Uefi21Wapper.c
Description:
Sets the DriverHealthCount and DriverHlthEnable variables
Input:
VOID
Output:
VOID
Built on 16:20:14 10/01/14


SetDrvHealthHandleAndCtrlCount in the Uefi21Wapper.c

Function : SetDrvHealthHandleAndCtrlCount

File: Uefi21Wapper.c
Description:
Finds and sets the number of controllers supports the driver health handle
Input:
UINT16 = Driver health handle entry
Output:
VOID
Built on 16:20:14 10/01/14


SetQuestionValue in the Uefi21Wapper.c

Function : SetQuestionValue

File: Uefi21Wapper.c
Description:
Set the Value for a Question

Parameter:     IN  UINT32 PgIndex
 IN  UINT32 CtrlIndex
 IN  UINT8  *Value
 IN  UINTN  ValueSize
 OUT UINT16 *ErrStrToken

Return Value:  EFI_STATUS
     EFI_SUCCESS
     EFI_NOT_READY
     EFI_INVALID_PARAMETER
Built on 16:20:14 10/01/14


UefiAddEndOp in the Uefi21Wapper.c

Function : UefiAddEndOp

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  	VOID
Built on 16:20:17 10/01/14


UefiCreateDynamicControlCondition in the Uefi21Wapper.c

Function : UefiCreateDynamicControlCondition

File: Uefi21Wapper.c
Description:

Parameter:	    CONTROL_INFO *control,UINT16 VarId, UINT16 PrevControlQuestionID,UINT16 Value

Return value:  	VOID
Built on 16:20:17 10/01/14


UefiCreateOneOfWithOptionsTemplate in the Uefi21Wapper.c

Function : UefiCreateOneOfWithOptionsTemplate

File: Uefi21Wapper.c
Description:

Parameter:	    UINTN OptionCount, CONTROL_INFO *CtrlInfo

Return value:  	VOID*
Built on 16:20:17 10/01/14


UefiCreateStringTemplate in the Uefi21Wapper.c

Function : UefiCreateStringTemplate

File: Uefi21Wapper.c
Description:
Function to create uefi string template

Parameter:	    UINT16 Token

Return value:  VOID *
Built on 16:20:17 10/01/14


UefiCreateSubTitleTemplate in the Uefi21Wapper.c

Function : UefiCreateSubTitleTemplate

File: Uefi21Wapper.c
Description:

Parameter:	    UINT16 Token

Return value:  VOID *
Built on 16:20:17 10/01/14


UefiFormCallbackNVRead in the Uefi21Wapper.c

Function : UefiFormCallbackNVRead

File: Uefi21Wapper.c
Description:

Parameter:	    CHAR16 *name, EFI_GUID *guid, UINT32 *attributes,
 UINTN *size, VOID **buffer

Return value:  EFI_STATUS
Built on 16:20:17 10/01/14


UefiFormCallbackNVWrite in the Uefi21Wapper.c

Function : UefiFormCallbackNVWrite

File: Uefi21Wapper.c
Description:

Parameter:	    CHAR16 *name, EFI_GUID *guid, UINT32 attributes,
 VOID *buffer, UINTN size

Return value:  EFI_STATUS
Built on 16:20:17 10/01/14


UefiGetBaseValue in the Uefi21Wapper.c

Function : UefiGetBaseValue

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  UINT8
Built on 16:20:17 10/01/14


UefiGetControlKey in the Uefi21Wapper.c

Function : UefiGetControlKey

File: Uefi21Wapper.c
Description:

Parameter:	    CONTROL_INFO *ControlData

Return value:  UINT16
Built on 16:20:17 10/01/14


UefiGetDateTimeDetails in the Uefi21Wapper.c

Function : UefiGetDateTimeDetails

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr,UINT8 Type,UINT16 * Help,UINT16 * Min,UINT16 * Max

Return value:  VOID
Built on 16:20:17 10/01/14


UefiGetEqIDQuestionID in the Uefi21Wapper.c

Function : UefiGetEqIDQuestionID

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  	UINT16
Built on 16:20:17 10/01/14


UefiGetFlagsField in the Uefi21Wapper.c

Function : UefiGetFlagsField

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  UINT8
Built on 16:20:17 10/01/14


UefiGetHelpField in the Uefi21Wapper.c

Function : UefiGetHelpField

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  UINT16
Built on 16:20:17 10/01/14


UefiGetIfrLength in the Uefi21Wapper.c

Function : UefiGetIfrLength

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  UINT8
Built on 16:20:17 10/01/14


UefiGetKeyField in the Uefi21Wapper.c

Function : UefiGetKeyField

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  UINT16
Built on 16:20:17 10/01/14


UefiGetMaxEntries in the Uefi21Wapper.c

Function : UefiGetMaxEntries

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  UINT8
Built on 16:20:17 10/01/14


UefiGetMaxValue in the Uefi21Wapper.c

Function : UefiGetMaxValue

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  UINT64
Built on 16:20:17 10/01/14


UefiGetMinValue in the Uefi21Wapper.c

Function : UefiGetMinValue

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  UINT64
Built on 16:20:17 10/01/14


UefiGetOneOfOptions in the Uefi21Wapper.c

Function : UefiGetOneOfOptions

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr,VOID **Handle,UINT16  **OptionPtrTokens,
 UINT64 **ValuePtrTokens, UINT16 *ItemCount,
 UINT16 *Interactive,UINT16 *CallBackKey

Return value:  EFI_STATUS
Built on 16:20:17 10/01/14


UefiGetPromptField in the Uefi21Wapper.c

Function : UefiGetPromptField

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  UINT16
Built on 16:20:17 10/01/14


UefiGetQuestionID in the Uefi21Wapper.c

Function : UefiGetQuestionID

File: Uefi21Wapper.c
Description:

Parameter:	    CONTROL_INFO *Control

Return value:  	UINT16
Built on 16:20:17 10/01/14


UefiGetQuestionOffset in the Uefi21Wapper.c

Function : UefiGetQuestionOffset

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  UINT16
Built on 16:20:17 10/01/14


UefiGetResetButtonDefaultid in the Uefi21Wapper.c

Function : UefiGetResetButtonDefaultid

File: Uefi21Wapper.c
Description:
Funtion get the ResetButton Default Id from the Opcode information

Parameter:	    VOID *IfrPtr

Return value:    UINT16
Built on 16:20:17 10/01/14


UefiGetSpecialEqIDValue in the Uefi21Wapper.c

Function : UefiGetSpecialEqIDValue

File: Uefi21Wapper.c
Description:

Parameter:	    CONTROL_INFO *ControlInfo, GUID_INFO **GuidInfo

Return value:  	UINT16
Built on 16:20:17 10/01/14


UefiGetStepValue in the Uefi21Wapper.c

Function : UefiGetStepValue

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  UINT64
Built on 16:20:17 10/01/14


UefiGetTextField in the Uefi21Wapper.c

Function : UefiGetTextField

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  UINT16
Built on 16:20:17 10/01/14


UefiGetTextTwoField in the Uefi21Wapper.c

Function : UefiGetTextTwoField

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  UINT16
Built on 16:20:17 10/01/14


UefiGetTime in the Uefi21Wapper.c

Function : UefiGetTime

File: Uefi21Wapper.c
Description:
Function to get time

Parameter:	    CONTROL_INFO *control, EFI_TIME *Tm

Return value:    STATUS
Built on 16:20:17 10/01/14


UefiGetTitleField in the Uefi21Wapper.c

Function : UefiGetTitleField

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  UINT16
Built on 16:20:17 10/01/14


UefiGetValidOptionType in the Uefi21Wapper.c

Function : UefiGetValidOptionType

File: Uefi21Wapper.c
Description:
Assuming all the options in this control has option with
same type and length
Input:
CONTROL_INFO *CtrlInfo - Pointer to the control info data
UINTN *Type - Returns EFI_IFR_TYPE_NUM_SIZE
Output:
VOID
Built on 16:20:17 10/01/14


UefiGetWidth in the Uefi21Wapper.c

Function : UefiGetWidth

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  UINT16
Built on 16:20:17 10/01/14


UefiIsEfiVariable in the Uefi21Wapper.c

Function : UefiIsEfiVariable

File: Uefi21Wapper.c
Description:

Parameter:	    UINT32 variable, VARIABLE_INFO *varInfo

Return value:  	BOOLEAN
Built on 16:20:17 10/01/14


UefiIsInteractive in the Uefi21Wapper.c

Function : UefiIsInteractive

File: Uefi21Wapper.c
Description:

Parameter:	    CONTROL_INFO *ControlData

Return value:  BOOLEAN
Built on 16:20:17 10/01/14


UefiIsOneOfControl in the Uefi21Wapper.c

Function : UefiIsOneOfControl

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  	BOOLEAN
Built on 16:20:17 10/01/14


UefiLoadPreviousValuesforCurrentform in the Uefi21Wapper.c

Function : UefiLoadPreviousValuesforCurrentform

File: Uefi21Wapper.c
Description:
Loads previous value for the current form
Input:
FormID - Current page ID
Output:
EFI_STATUS
Built on 16:20:17 10/01/14


UefiRefershQuestionValueNvRAM in the Uefi21Wapper.c

Function : UefiRefershQuestionValueNvRAM

File: Uefi21Wapper.c
Description:
Function to Refresh the questions

Parameter:	   CONTROL_INFO *ControlData

Return value:  EFI_STATUS
Built on 16:20:17 10/01/14


UefiSetEqIDQuestionID in the Uefi21Wapper.c

Function : UefiSetEqIDQuestionID

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr, UINT16 Value

Return value:  	VOID
Built on 16:20:17 10/01/14


UefiSetEqIDValue in the Uefi21Wapper.c

Function : UefiSetEqIDValue

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr, UINT16 Value

Return value:  	VOID
Built on 16:20:17 10/01/14


UefiSetHelpField in the Uefi21Wapper.c

Function : UefiSetHelpField

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr,UINT16 Token

Return value:  VOID
Built on 16:20:17 10/01/14


UefiSetOneOfOption in the Uefi21Wapper.c

Function : UefiSetOneOfOption

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr, UINT64 Value, UINT32 Size, UINT8 Flag, UINT16 Option

Return value:  	VOID
Built on 16:20:17 10/01/14


UefiSetPromptField in the Uefi21Wapper.c

Function : UefiSetPromptField

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr,UINT16 Token

Return value:  VOID
Built on 16:20:17 10/01/14


UefiSetSubTitleField in the Uefi21Wapper.c

Function : UefiSetSubTitleField

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr,UINT16 Token

Return value:  VOID
Built on 16:20:17 10/01/14


UefiSetTime in the Uefi21Wapper.c

Function : UefiSetTime

File: Uefi21Wapper.c
Description:
Function to set time

Parameter:	    CONTROL_INFO *control, EFI_TIME *Tm

Return value:    STATUS
Built on 16:20:17 10/01/14


UefiSetWidth in the Uefi21Wapper.c

Function : UefiSetWidth

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr,UINT8 Width

Return value:  	VOID
Built on 16:20:17 10/01/14


UefiSpecialGuidCallback in the Uefi21Wapper.c

Function : UefiSpecialGuidCallback

File: Uefi21Wapper.c
Description:

Parameter:	    VOID * HiiHandle, UINT16 Key, EFI_GUID *pGUID

Return value:  	VOID
Built on 16:20:17 10/01/14


UefiTseLiteGetAmiCallbackIndex in the Uefi21Wapper.c

Function : UefiTseLiteGetAmiCallbackIndex

File: Uefi21Wapper.c
Description:

Parameter:	    VOID * Ptr

Return value:  UINT16
Built on 16:20:17 10/01/14


UefiTseLiteGetBootOverRideIndex in the Uefi21Wapper.c

Function : UefiTseLiteGetBootOverRideIndex

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr

Return value:  UINT16
Built on 16:20:17 10/01/14


UefiUpdateControlQuestionID in the Uefi21Wapper.c

Function : UefiUpdateControlQuestionID

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr, UINT16 Value

Return value:  	VOID
Built on 16:20:17 10/01/14


UefiUpdateControlVarOffset in the Uefi21Wapper.c

Function : UefiUpdateControlVarOffset

File: Uefi21Wapper.c
Description:

Parameter:	    VOID *IfrPtr, UINT16 Value

Return value:  	VOID
Built on 16:20:17 10/01/14


UefiVarGetNvram in the Uefi21Wapper.c

Function : UefiVarGetNvram

File: Uefi21Wapper.c
Description:

Parameter:	    VARIABLE_INFO *VariableInfo, VOID **Buffer, UINTN Offset,
            UINTN Size

Return value:  EFI_STATUS
Built on 16:20:17 10/01/14


UefiVarSetNvram in the Uefi21Wapper.c

Function : UefiVarSetNvram

File: Uefi21Wapper.c
Description:

Parameter:	    VARIABLE_INFO *VariableInfo, VOID *Buffer, UINTN Offset,
            UINTN Size

Return value:  EFI_STATUS
Built on 16:20:17 10/01/14


UefiVarsetnvramforCurrentform in the Uefi21Wapper.c

Function : UefiVarsetnvramforCurrentform

File: Uefi21Wapper.c
Description:
Save the values for the passed pageID
        If this function is not called as part of browser action then it is
        caller responsibility to reset the gProFormOffset and gProcessedForms
        gProFormOffset = 0;
        MemSet (gProcessedForms, MAX_FORMS_TO_PROCESS, 0);
Input:
UINT32 - page ID to save the values
Output:
EFI_STATUS - Status of the operation
Built on 16:20:17 10/01/14


UpdateDestiantionQuestion in the Uefi21Wapper.c

Function : UpdateDestiantionQuestion

File: Uefi21Wapper.c
Description:
Finds the destination question ID for the current destination
Input:
UINT32 CurrPageID - Current page ID
UINT32 DestQuestionId - Destination question ID to set focus
UINT32 *FocusControlIndex -
Output:
EFI_STATUS status - EFI_SUCCESS is successful, else EFI_ERROR
Built on 16:20:18 10/01/14


WriteDataToFile in the Uefi21Wapper.c

Function : WriteDataToFile

File: Uefi21Wapper.c
Description:
Writes data to file
Input:
CHAR16 *filename, VOID *Data, UINTN length
Output:
VOID
Built on 16:20:18 10/01/14


WritePackToFile in the Uefi21Wapper.c

Function : WritePackToFile

File: Uefi21Wapper.c
Description:
Writes Hpk data to file
Input:
CHAR16 *filenameFormat, EFI_HANDLE Handle, UINT8 *PackData, UINTN length
Output:
VOID
Built on 16:20:18 10/01/14


UefiAction.c

Description:
This file contains code to handle the uefi actions

The following functions are used in the file: UefiAction.c.

Function | Description
_ProcessActionCallback | Function process action callbacks
UefiActionCreate | Function to create an Action Control.
UefiActionDraw | Function to draw an Action Control.
UefiActionHandleAction | Function to handle the Label actions.
UefiActionInitialize | Function to Initialize an Action Control.

Built on 16:20:23 10/01/14


_ProcessActionCallback in the UefiAction.c

Function : _ProcessActionCallback

File: UefiAction.c
Description:
Function process action callbacks
Input:
CONTROL_INFO * ControlData, BOOLEAN InteractiveText
Output:
STATUS
Built on 16:20:04 10/01/14


UefiActionCreate in the UefiAction.c

Function : UefiActionCreate

File: UefiAction.c
Description:
Function to create an Action Control.
Input:
VOID **object
Output:
EFI_STATUS
Built on 16:20:17 10/01/14


UefiActionDraw in the UefiAction.c

Function : UefiActionDraw

File: UefiAction.c
Description:
Function to draw an Action Control.
Input:
VOID *object
Output:
EFI_STATUS
Built on 16:20:17 10/01/14


UefiActionHandleAction in the UefiAction.c

Function : UefiActionHandleAction

File: UefiAction.c
Description:
Function to handle the Label actions.
Input:
VOID *object, ACTION_DATA *data
Output:
EFI_STATUS
Built on 16:20:17 10/01/14


UefiActionInitialize in the UefiAction.c

Function : UefiActionInitialize

File: UefiAction.c
Description:
Function to Initialize an Action Control.
Input:
VOID *object, VOID *data
Output:
EFI_STATUS
Built on 16:20:17 10/01/14


UefiAction.h

Description:
Header file for UefiAction data
Built on 16:20:23 10/01/14


UefiTianoHii.h

Description:

The following data structures are used in the file: UefiTianoHii.h.

Variable | Description
EFI_IFR_GUID_BANNER |
EFI_IFR_GUID_CLASS |
EFI_IFR_GUID_LABEL |
EFI_IFR_GUID_SUBCLASS |
EFI_IFR_GUID_TIMEOUT |

Built on 16:20:23 10/01/14


EFI_IFR_GUID_BANNER in the UefiTianoHii.h

Variable : EFI_IFR_GUID_BANNER

File: UefiTianoHii.h
Fields:

Name | Type | Description
Header | EFI_IFR_OP_HEADER
Guid | EFI_GUID
ExtendOpCode | UINT8
Title | EFI_STRING_ID
LineNumber | UINT16
Alignment | UINT8

Description:
Built on 16:20:07 10/01/14


EFI_IFR_GUID_CLASS in the UefiTianoHii.h

Variable : EFI_IFR_GUID_CLASS

File: UefiTianoHii.h
Fields:

Name | Type | Description
Header | EFI_IFR_OP_HEADER
Guid | EFI_GUID
ExtendOpCode | UINT8
Class | UINT16

Description:
Built on 16:20:07 10/01/14


EFI_IFR_GUID_LABEL in the UefiTianoHii.h

Variable : EFI_IFR_GUID_LABEL

File: UefiTianoHii.h
Fields:

Name | Type | Description
Header | EFI_IFR_OP_HEADER
Guid | EFI_GUID
ExtendOpCode | UINT8
Number | UINT16

Description:
Built on 16:20:07 10/01/14


EFI_IFR_GUID_SUBCLASS in the UefiTianoHii.h

Variable : EFI_IFR_GUID_SUBCLASS

File: UefiTianoHii.h
Fields:

Name | Type | Description
Header | EFI_IFR_OP_HEADER
Guid | EFI_GUID
ExtendOpCode | UINT8
SubClass | UINT16

Description:
Built on 16:20:07 10/01/14


EFI_IFR_GUID_TIMEOUT in the UefiTianoHii.h

Variable : EFI_IFR_GUID_TIMEOUT

File: UefiTianoHii.h
Fields:

Name | Type | Description
Header | EFI_IFR_OP_HEADER
Guid | EFI_GUID
ExtendOpCode | UINT8
TimeOut | UINT16

Description:
Built on 16:20:07 10/01/14


variable.c

Description:
This file contains code to handle bootonly lever variables operations.

The following functions are used in the file: variable.c.

Function | Description
_VarGetData | function to get variable data
_VarGetRealValue | function to get the real value of the variable
_VarGetSetValue | intermediate function for the set and get operations
_VarSetRealValue | function to set the real value of the variable
_VarUpdate | Function to update variable
BBSReOrderDefultLegacyDevOrder | To reoder the DefaultLegacyDevOrder Variable as TSE reorders the LegacyDevOrder based on Boot Order
CleanTempNvramVariableList | Clean up the current retrive variable list
CopyNvramVariableList | Copies variable buffer from one var list to another var list
GetNvramVariableList | Gets all system variables
HelperGetVariable | Function helper to get variable
LoadDefaultLegDevOrder | Function to load default legacy boot order
VarBuildDefaults | function to build the default variables
VarGetDefaults | Function to get var defaults
VarGetNvram | function to get the NvRam varible names
VarGetNvramName | function to get the NvRam Variable Name
VarGetNvramQuestionValue | Gets the question value buffer from a specific offset of a variable buffer
VarGetValue | Function to get var value
VarGetVariableInfoId | function to get the ID of the variable information
VarGetVariableInfoIndex | Function to get variable info index
VarLoadVariables | function to load the variables
VarSetNvram | function to set the NvRam varible names
VarSetNvramName | function to Set the NvRam Variable Name
VarSetValue | Function to set variable value
VarUpdateDefaults | Function to update variable defaults
VarUpdateVariable | Function to update variable

Built on 16:20:23 10/01/14


_VarGetData in the variable.c

Function : _VarGetData

File: variable.c
Description:
function to get variable data
Input:
UINT32 variable, UINT32 offset, UINTN size,
            VOID *buffer, BOOLEAN useDefaults
Output:
status
Built on 16:20:04 10/01/14


_VarGetRealValue in the variable.c

Function : _VarGetRealValue

File: variable.c
Description:
function to get the real value of the variable
Input:
UINT32 variable, UINTN offset, UINTN size, VOID *buffer
Output:
status
Built on 16:20:04 10/01/14


_VarGetSetValue in the variable.c

Function : _VarGetSetValue

File: variable.c
Description:
intermediate function for the set and get operations
Input:
UINTN command, NVRAM_VARIABLE *list, UINT32 variable,
            UINT32 offset, UINTN size, VOID *buffer
Output:
status
Built on 16:20:04 10/01/14


_VarSetRealValue in the variable.c

Function : _VarSetRealValue

File: variable.c
Description:
function to set the real value of the variable
Input:
UINT32 variable, UINT32 *offset, UINTN *size,
            VOID *buffer, VOID **realBuffer
Output:
status
Built on 16:20:04 10/01/14


_VarUpdate in the variable.c

Function : _VarUpdate

File: variable.c
Description:
Function to update variable
Input:
NVRAM_VARIABLE *nvramVar, UINT32 variable
Output:
VOID
Built on 16:20:04 10/01/14


BBSReOrderDefultLegacyDevOrder in the variable.c

Function : BBSReOrderDefultLegacyDevOrder

File: variable.c
Description:
To reoder the DefaultLegacyDevOrder Variable as TSE reorders
        the LegacyDevOrder based on Boot Order
Input:
DefaultLegDevOrder and DefaultLegDevOrderSize
Output:
NewDefultLegacyDevOrder
        NULL = if DefaultLegDevOrderSize is not Equal with LegacuDevOrderSize
Built on 16:20:05 10/01/14


CleanTempNvramVariableList in the variable.c

Function : CleanTempNvramVariableList

File: variable.c
Description:
Clean up the current retrive variable list
Input:
None
Output:
VOID
Built on 16:20:06 10/01/14


CopyNvramVariableList in the variable.c

Function : CopyNvramVariableList

File: variable.c
Description:
Copies variable buffer from one var list to another var list
Input:
NVRAM_VARIABLE *SrcVarList - Source variable list
NVRAM_VARIABLE **DestVarList - Destination variable list
Output:
EFI_STATUS status - EFI_SUCCESS if successful, else EFI_ERROR
Built on 16:20:06 10/01/14


GetNvramVariableList in the variable.c

Function : GetNvramVariableList

File: variable.c
Description:
Gets all system variables
Input:
NVRAM_VARIABLE **RetNvramVarList - Returns pointer to the var list
Output:
EFI_STATUS status - EFI_SUCCESS if successful, else EFI_ERROR
Built on 16:20:08 10/01/14


HelperGetVariable in the variable.c

Function : HelperGetVariable

File: variable.c
Description:
Function helper to get variable
Input:
UINT32 variable, CHAR16 *name, EFI_GUID *guid, UINT32 *attributes, UINTN *size
Output:
VOID *
Built on 16:20:09 10/01/14


LoadDefaultLegDevOrder in the variable.c

Function : LoadDefaultLegDevOrder

File: variable.c
Description:
Function to load default legacy boot order
Input:
VOID
Output:
VOID
Built on 16:20:11 10/01/14


VarBuildDefaults in the variable.c

Function : VarBuildDefaults

File: variable.c
Description:
function to build the default variables
Input:
VOID
Output:
status
Built on 16:20:18 10/01/14


VarGetDefaults in the variable.c

Function : VarGetDefaults

File: variable.c
Description:
Function to get var defaults
Input:
UINT32 variable, UINT32 offset, UINTN size, VOID *buffer
Output:
STATUS
Built on 16:20:18 10/01/14


VarGetNvram in the variable.c

Function : VarGetNvram

File: variable.c
Description:
function to get the NvRam varible names
Input:
UINT32 variable, UINTN *size
Output:
void
Built on 16:20:18 10/01/14


VarGetNvramName in the variable.c

Function : VarGetNvramName

File: variable.c
Description:
function to get the NvRam Variable Name
Input:
CHAR16 *name, EFI_GUID *guid, UINT32 *attributes, UINTN *size
Output:
Name String
Built on 16:20:18 10/01/14


VarGetNvramQuestionValue in the variable.c

Function : VarGetNvramQuestionValue

File: variable.c
Description:
Gets the question value buffer from a specific offset of a
variable buffer
Input:
UINT32 variable
UINTN offset
UINTN *size
Output:
VOID *buffer - Question value buffer
Built on 16:20:18 10/01/14


VarGetValue in the variable.c

Function : VarGetValue

File: variable.c
Description:
Function to get var value
Input:
UINT32 variable, UINT32 offset, UINTN size, VOID *buffer
Output:
STATUS
Built on 16:20:18 10/01/14


VarGetVariableInfoId in the variable.c

Function : VarGetVariableInfoId

File: variable.c
Description:
function to get the ID of the variable information
Input:
UINTN command, NVRAM_VARIABLE *list, UINT32 variable,
            UINT32 offset, UINTN size, VOID *buffer
Output:
Variable Info
Built on 16:20:18 10/01/14


VarGetVariableInfoIndex in the variable.c

Function : VarGetVariableInfoIndex

File: variable.c
Description:
Function to get variable info index
Input:
UINT32 index
Output:
VARIABLE_INFO *
Built on 16:20:18 10/01/14


VarLoadVariables in the variable.c

Function : VarLoadVariables

File: variable.c
Description:
function to load the variables
Input:
VOID **list, NVRAM_VARIABLE *defaultList
Output:
status
Built on 16:20:18 10/01/14


VarSetNvram in the variable.c

Function : VarSetNvram

File: variable.c
Description:
function to set the NvRam varible names
Input:
UINT32 variable, VOID *buffer, UINTN *size
Output:
status
Built on 16:20:18 10/01/14


VarSetNvramName in the variable.c

Function : VarSetNvramName

File: variable.c
Description:
function to Set the NvRam Variable Name
Input:
CHAR16 *name, EFI_GUID *guid, UINT32 *attributes,
            VOID *buffer, UINTN *size
Output:
status
Built on 16:20:18 10/01/14


VarSetValue in the variable.c

Function : VarSetValue

File: variable.c
Description:
Function to set variable value
Input:
UINT32 variable, UINT32 offset, UINTN size, VOID *buffer
Output:
status
Built on 16:20:18 10/01/14


VarUpdateDefaults in the variable.c

Function : VarUpdateDefaults

File: variable.c
Description:
Function to update variable defaults
Input:
UINT32 variable
Output:
VOID
Built on 16:20:18 10/01/14


VarUpdateVariable in the variable.c

Function : VarUpdateVariable

File: variable.c
Description:
Function to update variable
Input:
UINT32 variable
Output:
VOID
Built on 16:20:18 10/01/14


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

  • ?
  • A
  • B
  • C
  • D
  • E
  • F
  • G
  • H
  • I
  • L
  • M
  • N
  • O
  • P
  • R
  • S
  • T
  • U
  • V
  • W
Built on 16:20:03 10/01/14


Functions in Alphabetical Order

?

Function | Description
_ActionInstallTimer | Function to install action timer
_ActionReadKey | Function to read a key.
_ActionReadMouse | Function to get mouse action
_ActionTimer | Function action timer
_AddFormSetVariable | Parameter: Return value:
_AddHpkControls | Add Control Setup Data Parameter: Return value: UINTN
_AdvAddControlToList | Add control info the control list
_AdvAddPageToList | Add page into to the page list
_BBSCheckDisabled | function to Check whether a perticular entry is disabled.
_BBSInitProtocol | function to Initialize the bbs protocol.
_BBSSetDevicePriorities | function to set boot device priorities
_BootBuildFileDevicePath | function to build File device path protocol.
_BootBuildFVDevicePath | function to build firmware volume device path protocol.
_BootInstallLoadOptions | function to install the load options
_BootLaunchDevicePath | function to launch the boot operation
_BootSetBootManagerVariables | function to set the variables for the boot manager
_BootSetBootNowCount | function to set boot new devices count
_CallbackGetValue | Callback function to get the message box return value
_CallbackGetValueEx | Callback function to get the message box return value
_CBPopupEdit | Function for PopupEdit callback.
_CBPopupStringEdit | Function for PopupStringEdit callback.
_CleanVarKeyTable | Clean VarKey Table Parameter: None Return value: None
_ConfigRespToStorage | Parameter: VARIABLE_INFO *VariableInfo VOID **Buffer UINTN *Size EFI_STRING ConfigResp Return value:EFI_STATUS
_ConstructConfigHdr | Construct <ConfigHdr> using routing information GUID/NAME/PATH. Parameter: IN OUT CHAR16 *ConfigHdr, IN OUT UINTN *StrBufferLen, IN EFI_GUID *Guid, IN CHAR16 *Name, OPTIONAL IN EFI_HANDLE *DriverHandle Return value: EFI_STATUS
_DateDecrease | Function to decrement date.
_DateGetWeekDay | Function to get weekday.
_DateIncrease | Function to increment date.
_DateUpdateEntry | Function to update entry.
_DateUpdateHelp | Function to update help.
_DestinationFormProcessed | Is this form Processed Parameter: IN UINT32 FormID Return Value: BOOLEAN
_DestinationPageProcessed | Checks whether the page is already processed or not.
_DevicePathToStr | Convert Device Path of type to string. Str is allocated by this routine. It must be freed by the caller.
_DisableRestorePrevOptions | Function to make the boot/driver option as disable in bootorder/driverorder if it is inactive and non hidden
_DiscoverPartition | function to launch the boot operation
_DisplayInfoCancelTimer | Timer notify fucntion
_DoPopupEdit | function to perform the edit operations on popup
_DoPopupStringEdit | Function to initiate PopupString editing
_DrawPasswordWindow | Function to draw password window with attributes
_DrvHealthNotifyFunction | Notification function for driver health protocol instal.
_EditHandleActionKey | Function to handle Edit actions.
_EzportPlusPopupPasswordActivate | function to set and activate a password
_EzportPlusPopupPasswordHandleAction | function to handle the password actions
_FocusFirst | Set focus to the first control in the frame (in the first page).
_FocusLast | Set focus to the last control in the frame.
_FrameAddControls | Function to add controls in the frame
_FrameAddTitle | Function to add tittle to a frame.
_FrameHandleKey | Controls Keyboard action for each frame
_FrameHandleMouse | Function to hadnle frame using mouse
_FrameMenuCallback | Function to set frame menu callback.
_FramePasswordCallback | Function to set frame password callback.
_FrameScroll | Adds scroll bar functionality for frames with many controls
_FrameSetControlFocus | Sets focus on a defined control in the frame
_FrameSubmenuCallback | Function to set frame submenu callback.
_FrameVariableCallback | Function to set frame variable callback.
_FxiupNotificationData | Parameter: Return value:
_GetCheckBoxOptions | Get the List of Options for the Checkbox Control Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex OUT UINTN *optionCount OUT OPTION_LIST *optionArray Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
_GetClassSubClassID | Parameter: VOID *DefValue Return value: EFI_STATUS - The status
_GetControlDevicePathId | Get Control DevicePathId Parameter: Return value: UINT16
_GetControlFlag | Gets attribute flag for a given CtrlIndex in a page
_GetControlInfo | Returns pointer to the CONTROL_INFO struct of given CtrlIndex
_GetControlKeyToken | Get ControlKey Token Parameter: None Return value: None
_GetControlVariable | Function to get control variable.
_GetDefaultNvramVariableIDList | To get the default variable names.
_GetFsLists | function to get the file system details
_GetHelpToken | Get Control Question Help Token Parameter: Return value: UINT16
_GetPageIdIndex | Get Page ID index Parameter: Return value: UINT16
_GetPageInfo | Returns pointer to the PAGE_INFO struct of given PgIndex
_GetPageNumFromFormID | Get Page Id from Form Id Parameter: Return value: UINT16
_GetPageParent | Get Parent Page PageID Parameter: Return value: UINT16
_GetPassword | Function to get password from the user
_GetPopUpSelectionFromVariable | Fucntion to return the current selection based on the variable. If not matched with variable value Selection will be 0
_GetQuestionToken | Get Control Question Prompt Parameter: Return value: UINT16
_GetRuleControlfromId | Parameter: UINT8 *IFRData, CONTROL_INFO **RuleControl Return value: EFI_STATUS
_GetSpecialDriveroptionToken | function to get the boot option token properly when loading the boot page
_GetSubFormCount | Count the subform and Ref inside the formset Parameter: Return value: UINTN
_GetSupportedLanguages | Parameter: Return value:
_GetValueFromQuestionId | Parameter: UINT16 QuestionId, UINT16 PageId, UINT64 *Value Return value: EFI_STATUS
_GetVariableIDList | function to get the list of all variables that are need to update Parameter: UINT32 FormID, UINT32 **VarIDList Return Value: EFI_STATUS
_GetVarNumFromVarID | Get Variable Index Parameter: Return value: UINT32
_HelpFrameScroll | Function to hadnle help frame scroll using mouse
_HiiGetForm | to get data using the input handle
_HiiGetFormSet | Parameter: Return value: EFI_IFR_FORM_SET
_HiiGetHandles | Function to get HII handles
_HiiGetLinkIndex | to get the index of the link
_HiiLocateSetupHandles | Function to find the Setup Handles
_HiiParseVariablePack | To parse the variable pack and Update the Current Values with Default Values
_HWToStr | Convert Device Path of type to string.
_InconsistenceCheck | Checks if the controls in a page is inconsistent
_InitFormsetLinks | Init Formset Links Parameter: Return value:
_InvalidateExistingPage | Parameter: Return value:
_IsFormFound | Parameter: Return value: UINT16 - 1 Form Found 0 Form Not Found
_IsVarGuidPresent | Check if the Variable Guid is already defined Parameter: Return value: UINT8
_LoadDefaults | Loads the defaults with optimal or Failsafe data.
_LoadPageDefaults | Function to updated defaults for specific page for both Optimal and FailSafe defaults
_MEDIAToStr | Convert Device Path of type to string.
_MenuCallCallback | Internal Helper Function to Call the callback
_MergePageIdListAndInfo | Parameter: Return value: EFI_STATUS
_MergePageListAndInfo | Parameter: Return value: EFI_STATUS EFI_SUCCESS EFI_OUT_OF_RESOURCES
_MergeVariableListAndInfo | Parameter: Return value: EFI_STATUS
_MsgBoxCallCallback | Internal Helper Function to Call the callback
_MsgBoxDrawOpts | Function to Draw Message box options
_MsgBoxOptSize | Function returns and fix the option string
_MSGToStr | Convert Device Path of type to string.
_NextFrame | Loads the controls from the next frame into the screen.
_NoSubmitCheck | Checks if the controls in a page has no submit
_OrdListBoxCallback | Ordered List Box callback function
_OrdListBoxShift | Function used in OrdListBoxHandleAction to handle actions
_OrdListGetSelection | Function to ordering the option in OrderList
_OrdListMultiLIneDraw | Function used to draw teh Ordered list box
_PageUpdateFrameStrings | function to update the title of the page
_PageUpdateHelp | function to update the page help
_PageUpdateMemo | function to update the memo
_PageUpdateNavStrings | function to update the title of the page
_PageUpdateSubtitle | function to update the subtitle of the page
_PageUpdateTitle | function to update the title of the page
_PopupEditGetValue | Function to get edit value.
_PopupPasswordActivate | function to set and activate a password
_PopupPasswordHandleAction | function to handle the password actions
_PopupSelCallback | PopupSel callback function.
_PopupSelHandleActionKey | function to handle the PopupSel Action keys
_PopupStringEditGetValue | function to get values for popup menu using edit functions.
_PostEditCallback | Callback function for text entry popup
_PostEditDraw | Function to draw text entry edit box
_PostPopupEditDraw | Function to draw text entry popup window
_PostPopupEditGetValues | Function to draw text entry popup window
_PreviousFrame | Loads the controls from the previous frame into the screen.
_ProcessActionCallback | Function process action callbacks
_RegisterShellGuid | Registers the shell guid
_ReInitializeSetupdataPointers | Parameter: Return value:
_ReplacePageWithNewPage | Parameter: Return value:
_ReportInBox | Function to report using Box
_SaveValues | Function to save the given values
_SetDriverManagerVariables | Sets DriverManager variable for drivers count and sets DriverOrder
_SetValueFromQuestionId | Parameter: UINT16 QuestionId, UINT16 PageId, UINT64 *Value Return value: EFI_STATUS
_ShellClearScreen | Clears the screen for shell boot
_SkipExpression | Travels till the end of the current Expression and returns the offset Parameter: ControlCondPtr - Pointer to the Expression beginning. Return value: UINTN - Offsets to skip the current expression.
_SpecialAddControl | function to Handle adding a control.
_SpecialAddMultipleControls | Adds Multiple controls for special controls
_SpecialControlExtras | special handling of extra operations
_SpecialExplodeControl | function to explode a perticular contorller
_SpecialFixupAddBootOption | function to fixup the adding of a boot device option
_SpecialFixupBBSCondition | This function updates the Condition to avoid more then one disabled option in BBS Dev order.
_SpecialFixupBBSOrder | function to fixup the Legacy Boot device order
_SpecialFixupBootCondition | This function updates the Condition to avoid more then one disabled option in Boot order.
_SpecialFixupBootOrder | function to fixup the Boot device order
_SpecialFixupDriverOrder | Function to fixup the driver order
_SpecialFixupLanguages | function to fixup the languages
_SpecialGetIfrPtr | function to handle the operation of getting the Ifr Pointer.
_SpecialGetValue | function to handle the operation of getting the Ifr Value.
_StorageToConfigResp | Parameter: VARIABLE_INFO *VariableInfo VOID *Buffer CHAR16 *ConfigHdr CHAR16 **ConfigResp Return value:EFI_STATUS
_StyleAddControl | Function to add controls
_StyleAddSpacing | Function to add spacing
_StyleControlSubmenu | Function to Initialize submenu control
_SubMenuAmiCallback | Function implemented to handle the Exit page options using Elinks.
_SubMenuAmiCallback | Function to handle the exit page options.
_SubMenuHandleSpecialOp | Sub menu handle for Special operations.
_SubMenuHandleSpecialOp | Sub menu handle for Special operations.
_TimeDecrease | to decrease the time, i.e. Hours/Mins/Secs based on the selection
_TimeHandleActionKeyMouse | function to handle the action key of time
_TimeIncrease | to increase the time, i.e. Hours/Mins/Secs based on the selection
_TimeUpdateEntry | function to update the entries in Time
_TimeUpdateHelp | function to update the help of time
_UefiGetValidOptions | Parameter: CONTROL_INFO *CtrlInfo, UINT16 **OptionPtrTokens, UINT64 **ValuePtrTokens, UINT16 *ItemCount,UINT8 MaxItems Return value: VOID
_UnknownToStr | Convert Device Path of type to string.
_UpdateDefaults | Get Control Defaults Parameter: EFI_HII_HANDLE Handle, VOID *Data, UINT16 *size, VOID *Failsafe, VOID *Optimal, DEFAULT_VALUE **defaultValue, struct _CONTROL_FLAGS *Control_Flags, VOID *ConditionalPtr Return value: UINT8
_UpdateGoPNotifyFunction | Notification function for driver health protocol instal.
_VarGetData | function to get variable data
_VarGetRealValue | function to get the real value of the variable
_VarGetSetValue | intermediate function for the set and get operations
_VarSetRealValue | function to set the real value of the variable
_VarUpdate | Function to update variable
_VerifyResponseString | Verifies Correctness of Response String. This is to prevent crashing if the result pointer is pointing to an invalid location. Parameter: EFI_STRING *Configuration Return value: EFI_STATUS

Built on 16:20:00 10/01/14


Functions in Alphabetical Order

A

Function | Description
ACPIToStr | Convert Device Path of type to string.
ActionClearAction | Function to clear actions
ActionCreate | Function to create an action.
ActionDestroy | Function to destroy an action.
ActionGetAction | Function to get an action.
ActionReadKey | fucntion to handle the read key action
ActionReadKey | Function to read action key
ActionReadKeyWithAMIKeyCode | fucntion to read the a key using AMI Key Code Protocol
ActivateApplication | function for the Active application operations.
ActivateInput | function for the active Input.
AddControlToList | to add a control to list
AddControlToList | Parameter: CONTROL_INFO *ControlInfo UINT32 ControlSize Return value: EFI_STATUS EFI_SUCCESS
AddDynamicForm |
AddEntryIngProcessedForms | Adds the formid in gProcessedForms
AddFileTypeEntry | Creates a new entry in the FILE_TYPE array and adds the current File into the array.
AddFormSetVariable |
AddHandleIntoList | Adds the driver health details to the linked list
AddHpkControls |
AddImageDetailToACPI | Adds the image data to the ACPI Table.
AddNotificationToQueue | Adds new notification to the queue and increments queue size
AddPageIdToList | Function to add page id to list
AddPageIdToList | Parameter: PAGE_ID_INFO *NewPageIdInfo Return value: EFI_STATUS - EFI_SUCCESS - EFI_OUT_OF_RESOURCES -
AddPageToList | to add a page to list
AddPageToList | Parameter: PAGE_INFO *NewPageInfo UINT32 PageSize Return value: EFI_STATUS EFI_SUCCESS
AddVariable | Function to add variable
AddVariableToList | Function to add variable to list
AddVariableToList | Parameter: Return value: EFI_STATUS EFI_SUCCESS - EFI_OUT_OF_RESOURCES -
AMIReadKeyStroke | function to read a key stroke
AMIReadKeyStroke | Function to read key strokes
ApplicationAddPage | Function to add a page to the application.
ApplicationCreate | Function to create an application, which uses the Object functions.
ApplicationDestroy | Function to destroy an application, which uses the Object functions.
ApplicationHandleAction | Function to handle the application actions.
ApplicationInitialize | Function to Initialize an application, which uses the Object functions.
atoi | function to convet a string to integer

Built on 16:20:00 10/01/14


Functions in Alphabetical Order

B

Function | Description
BBS_GetKey | function to read the input key
BbsBoot | This function is a hook called after launching BBS Popup Menu. This function is available as ELINK. In the generic implementation this function is empty. OEMs may choose to do additional logic here.
BBSBuildDefaultName | function to build the default boot device name
BBSBuildDevicePathName | function to build the bbs device path
BBSGetDeviceList | function to get the list of all the devices
BBSGetOptionName | function to get the name of the option
BBSLaunchDevicePath | function to launch the device path
BBSReOrderDefultLegacyDevOrder | To reoder the DefaultLegacyDevOrder Variable as TSE reorders the LegacyDevOrder based on Boot Order
BBSSetBootNowPriority | Sets BBS priority for the BootNow devices.
BBSSetBootPriorities | function to set boot priorities
BBSSetBootPriorities_BootOrder | Assign priority as per boot order other than 0 priority devices
BBSSetDisabled | function to disable a perticular entry.
BbsStrnCpy | function the string copy
BBSUpdateBootData | function to update boot related data
BBSUpdateControlOffset | Function to update control offset
BBSUpdateControlOffset | Parameter: CONTROL_INFO *control Return value: VOID
BBSUpdateOrder | function to update Bbs device order
BBSUpdateOrder | Updates the Legacydevorder variable base on the user input
BGRTSupportedLogoType | Checks whether the BGRT data supports the specified logo
BootAddBootOption | Function to add boot option
BootDelBootOption | Function to handle the del boot option
BootGetBBSOptionStatus | Function to Check the Legacy boot option status
BootGetBootData | Finds and returns internal data structure BOOT_DATA for a given boot option number.
BootGetBootNowName | Provides the unicode name for the given boot option.
BootGetBootOptions | This function collects all the boot options, both efi and legacy boot options, that are present in the system and sets various boot manager variables that are used to expand boot manager questions.
BootGetLanguages | Finds the languages that the firmware supports.
BootGetOptionName | Provides the unicode name for the given boot option in the form of internal data structure BOOT_DATA.
BootGetOptionStatus | Function to Check the boot option status in Boot Order
BootLaunchBootNow | Launches the boot option provided.
BootLaunchBootOption | This function launches the boot option supplied
BootLaunchFilename | Launches the file mentioned in file path from the available FS.
BootLaunchGuid | Launches the guided file from FV.
BootOnlyUpdateVersionString | Function to update version string
BootUpdateOrder | Function to update the boot/driver order
BootUpdateOrder | Updates the boot order variable
BrowserCallback | This function is called by a callback handler to retrieve uncommitted state data from the browser.
BufferToHexString | Converts binary buffer to Unicode string in reversed byte order from BufToHexString().
BufToHexString | Converts binary buffer to Unicode string. At a minimum, any blob of data could be represented as a hex string.
BuildHuffmanCodeTable | Builds the Huffman codes for the particular JPEG Huffman table. By incrementing the offset of the Huffman table by 3, the offset of the actual data is obtained. The first 16 bytes represent the no: of code words for a paricular bit-size. Having the bit-size and the no: of code words for each bit-size, the Huffman code table is built.

Built on 16:20:00 10/01/14


Functions in Alphabetical Order

C

Function | Description
CalculateChecksum | Calculates the checksum for the given structure
CallbackShowMessageBox | Callback function to Display the message box Input : UINTN data, UINT8 type
CallFormCallBack | To call form callback
CallTextCallBack | Fuction to call text callback
Check | Internal function for doing a Check for each color component
CheckBootOptionMatch | Checks the input boot option matches with any of the boot option in the system
CheckControlAccess | To Check control flags
CheckControlCondition | This function eveluates the condition and retuns the result
CheckDateFlags | Function to Check the Date flags.
CheckDateFlags | Function to Check the date flags.
CheckDevSupShortFormPath | Matches the device path with USB class device path (Table 60) and returns the corresponding USB's file system handle
CheckDirectoryType | Checks if the EFI_FILE_INFO is a directory (and not the current directory)
CheckEnableQuietBoot | Function to Check the quick boot enable option
CheckEnableQuietBoot | Function to Check the quick boot enable option
CheckExtension | Check is the EFI_FILE_INFO has the same extension as the extension passed in the second parameter
CheckForDeviceNeedRepair | Repairs the driver for the input device path protocol
CheckForDeviceNeedRepair | Repairs the driver for the input device path protocol
CheckforHotKey | Checks for the key pressed by user matches the boot key options
CheckforIncrementandDecreament | function used handle the Numeric controls Increment and Decreament operation
CheckforNosubmitIf | Check for no submit if Parameter: UINT32 FormID, BOOLEAN Recursive, UINT16 *ErrToken Return Value: BOOLEAN
checkforpushthispresence | Checks the condition has EFI_IFR_THIS_OP Parameter: UINT8 * Return value: TRUE if EFI_IFR_THIS_OP presents else FALSE
CheckForRange | function used to Check the range for the negative numbers and positive nubmers.
CheckForRangefromsetup | function used to Check the range for the negative numbers and positive nubmers from setup.
CheckHiddenforBootDriverOption | Check whether the Boot/Driver option has hidden property
CheckInconsistence | Check for inconsistancy
CheckKeyinHotKeysList | For Inconsistence condition checking for Hotkeys pressed to show the popup
CheckNoSubmitIf | checks NoSubmitIf Parameter: VOID Return value: BOOLEAN
CheckOneOfOptionSuppressIf | Parameter: CONTROL_INFO *ParentCtrlInfo, UINT8* CtrlCondPtr Return value: UINT8
CheckShiftState | function to Check the shift state value
CheckStrings | function to validate the stings
CheckSystemPassword | Function to Check the system password
CheckTimeFlags | Function to Check the time flags.
CheckTimeFlags | Function to Check the time flags.
CleanCurrLoadVarBuffer | Cleans the temporary variables
CleanFileTypes | Frees all allocated memory associated with the FILE_TYPE structure and resets the InternalString current strings next available string token to be the first dynamically added string
CleanNotificationQueue | Cleans the IFR notification queue
CleanTempNvramVariableList | Clean up the current retrive variable list
CleanUpGif | Cleans the gif datas
CleanUpLogo | function to Clear all the logo buffers.
CleanVarKeyTable | To clear the key table specific buffers
CleargProcessedForms | Clears gProcessedForms data
ClearGrphxScreen | Function to clear the graphics screen.
ClearLinesWithoutFlush | function to clear lines without flushing.
ClearScreen | function to clear the screen.
ClearScreenWithoutFlush | function to clear screen without flushing.
ClearUserPasswordPolicy | fucntion to clear the user password if admin password is empty, Only Valid with Password Local
CompareHiiValue | Compare two Hii Value Parameter: Value1 - Expression value to compare on left-hand Value2 - Expression value to compare on right-hand HiiHandle - Only required for string compare Return value: EFI_INVALID_PARAMETER - Could not perform comparation on two values 0 - Two operators equeal < 0 - Value1 is greater than Value2 > 0 - Value1 is less than Value2
ControlCreate | Function to create the cotrol options using object functions.
ControlDestroy | Function to destroy the cotrol options using object functions.
ControlEmptyMethod | Empty control method.
ControlHandleAction | Function to handle action.
ControlInitialize | Function to Initialize the cotrol options using object functions.
ControlSetAttributes | Function to set the control attributes
ControlSetCallback | Function to set callback.
ControlSetDimensions | Function to set dimensions.
ControlSetFocus | Function to set focus.
ControlSetPosition | Function to set the position.
ConvertAdvancedImageToUgaBlt | Convert a advanced graphics image to a UGA blt buffer.
ConvertBlt2Bmp | Converts the Blt in the screen to Bmp buffer
ConvertBmpandAddBGRT | Converts Blt to Bmp buffer and form BGRT table and add to ACPI.
ConvertGifToUgaBlt | Convert a *.GIF graphics image to a UGA blt buffer. If a NULL UgaBlt buffer is passed in a UgaBlt buffer will be allocated by this routine. If a UgaBlt buffer is passed in it will be used if it is big enough.
ConvertJPEGToUgaBlt | Decode the JPEG and store the Output in UGA format. The JPEG images are stored in 16X16 blocks. Hence Buffer will require width and hieght that are equal to or more than the actual width and hieght. Buffer Width and Height will be the lowest multipe of 16 that is equal to or greater than the actual width and height. Eg: For decoding an image with Actual sizes being 17X33 will require a buffer of 32X48.
ConvertPCXToUgaBlt | Decode the PCX Image and store the Output in UGA Format
ConvertPNGToBlt | Decode the PNG and store the Output in RGB format
ConvertYCbCrToRGB | Converts the luminance(Y) and chrominance(Cb and Cr) values of the image to R, G, B values. The R,G, B values are stored in a DWORD variable.
CopyNvramVariableList | Copies variable buffer from one var list to another var list
CreateDriveString | function to create the device string
CreateEventforIFR | To create Event if any control has RefreshID opcode Parameter: CONTROL_INFO* Return value: EFI_STATUS
CreateFile | Creates a file to Output hpk data
CreateFileList | Parse all the files in the current directory and add valid files to the FILE_TYPE list and update the filecount
CreatePage | function used to create a page
CreatePage | Parameter: PAGE_INFO **PageInfo UINT32 *AllocatedSize UINT32 *Offset VOID *Buff UINT32 BuffSize Return value: EFI_STATUS EFI_SUCCESS - EFI_OUT_OF_RESOURCES -
CtrlsSupportsHealthProtocol | Finds the number of controllers supports driver health protocol for the driver entry
CtrlsSupportsHealthProtocol | Finds the number of controllers supports driver health protocol for the driver entry

Data Structure | Description
CONTROL_FOCUS_COLOR | Focused control text color (Default same as FOCUS_COLOR)
CONTROL_NON_FOCUS_COLOR | Non Focused control text color (Default same as NON_FOCUS_COLOR)

Built on 16:20:01 10/01/14


Functions in Alphabetical Order

D

Function | Description
DateCreate | Function to create the date, which uses the Control fucntions.
DateDestroy | Function to destroy the date, which uses the Control fucntions.
DateGetControlHeight | Function to get the data label height.
DateInitialize | Function to Initialize the date, which uses the Control fucntions.
DateSetAttributes | Function to set the date attributes.
DateSetCallback | Function to set callback.
DateSetDimensions | Function to set the date dimensions.
DateSetFocus | Function to set the Date focus.
DateSetPosition | Function to set the date position.
DebugLibShowHiiControlState | Prints the AMI Setup Lib control states
DebugShowAllHiiVariable | Prints the variable information in the list
DebugShowBufferContent | Prints the buffer, 16 characters max in a line
DebugShowControlInfo | Prints the cache controls information
DebugShowHiiVariable | Prints the variable information for the given parameter
DebugShowPageInfo | Shows the Page information
Decode | Read all the PNG chunks and do convert the png format to RGB format.
Decode_Line | This routine will first Check whether the PCX image is 16 color or 256 color and then Decode the PCX image data one line at a time and put the decoded data in a One Line Buffer.
DecodeDynamicHuffmanCode | Decodeing the Dynamic Huffman Code
DecodeJPEG | Decode the JPEG image into the given buffer at given position, subject to the limit of the Buffer Width and Height
DecodePCX | This routine will call functions to Decode both 16 and 256 color PCX images of version 5 (with palette information) and fill the Screen Buffer.
DeleteHuffmanTree | Deleting the created Trees
DiscardAddDelBootOptions | Function to discarding the add/del boot option
DiscardAddDelDriverOptions | Function to discarding the add/del driver option
DisplayActivePostMsgs | function to Display active messages
DisplayFileListMenu | Display a menu of the FILE_TYPE items and return the selected item in the Selection
DisplayMsgListMessageBox | Displays the messages from EFI_DRIVER_HEALTH_HII_MESSAGE
DisplayParseFormSetData | Prints the current FormSet data
DoAddBootOptionFixup |
DoBbsPopupInit | This function runs the loop for Pop up boot menu. This function is responsible for creating the list box control. It also gathers actions and passes them to list box control and initiates draw sequence.
DoBootDelBootOption | Function to delete the boot option
DoDriverDelDriverOption | Function to delete the driver option
DoDriverHealthOperation | Performs the driver health operations for the corresponding controller entry
DoDriverHealthOperation | Performs the driver health operations for the corresponding controller entry
DoGifAnimate | function to Handle gif logo animation
DoLogoAnimate | function to Handle logo animation
DoOrdListCallBack | Call back function of ordered List Box
DoPopup | This function runs the loop for Pop up boot menu. This function is responsible for creating the list box control. It also gathers actions and passes them to list box control and initiates draw sequence.
DoPopupSelCallBack | Callback function of the PopupSel
DoRealFlushLines | function to flush lines
DownDisplayList | function to display the downside list
DPAdd | To avoid including EDK libs.
DPAddNode | To avoid including EDK libs.
DrawAttribute | function to write a attribute
DrawAttributeOffset | function to write in a peticular offset.
DrawBbsPopupMenu | function for the BBS Popup menu
DrawBlock | function to draw draw a block
DrawBltBuffer | function to draw draw a block
DrawBltProgressBar | function to draw a progress bar
DrawBootOnlyBbsPopupMenu | function for the BBS Popup menu
DrawBorder | function to draw the border
DrawBox | function to draw a box
DrawImage | function to draw a image
DrawLineWithAttribute | function to draw the lines with attributes
DrawMessageBox | Draw MessageBox Parameter: CONTROL_INFO, UINT16, EFI_STRING_ID Return value: BOOLEAN
DrawMultiLineStringWithAttribute | function to write a multiline string.
DrawOEMImage | Function to draw OEMLogo to in Post screen operations
DrawPostStringWithAttribute | function to write a multiline string in the Post screen.
DrawProgressBarBorder | function to draw the border of a progress bar
DrawStringJustifiedWithAttribute | function to write a string with justify and attributes.
DrawStringWithAttribute | function to write a string with attributes.
DrawWindow | function to draw a window
DriverAddDriverOption | Function to add driver options
DriverDelDriverOption | Function to handle the del Driver option
DriverGetDriverData | Finds and returns internal data structure BOOT_DATA for a given Driver option number.
DriverGetOptionName | Provides the unicode name for the given driver option in the form of internal data structure BOOT_DATA.
DriverUpdateOrder | Function to update the driver order
DriverUpdateOrder | Updates the driver order variable

Built on 16:20:01 10/01/14


Functions in Alphabetical Order

E

Function | Description
EditCreate | Function to create Edit Controls, which uses the control functions.
EditDestroy | Function to Destroy Edit Controls, which uses the control functions.
EditDraw | Function to draw Edit Controls.
EditGetControlHight | Function unsuppored.
EditHandleAction | Function to handle Edit actions.
EditInitialize | Function to Initialize Edit Controls, which uses the control functions.
EditSetAttributes | Function to set the edit attributes.
EditSetCallback | Function to set callback.
EditSetDimensions | Function to set the edit dimensions.
EditSetFocus | Function to set the edit focus.
EditSetPosition | Function to set the edit position.
EfiCompareGuid | To avoid including EDK libs.
EfiCompareMem | To avoid including EDK libs.
EfiDevicePathFromHandle | To avoid including EDK libs.
EfiFileDevicePath | To avoid including EDK libs.
EfiInitializeDriverLib | To avoid including EDK libs.
EfiInitializeFwVolDevicepathNode | To avoid including EDK libs.
EfiLibAllocateCopyPool | Allocate BootServicesData pool and use a buffer provided by caller to fill it.
EfiLibAllocatePool | To avoid including EDK libs.
EfiLibAllocateZeroPool | To avoid including EDK libs.
EfiLibNamedEventSignal | To avoid including EDK libs.
EfiStrStr | Find a substring.
EfiTestPrintLength | function to get the printable lenght of the string
EfiTestPrintLength | function to get the printable lenght of the string
EvaluateControlCondition | Evaluate control HII expression and return display Result Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex OUT UINTN *expResult Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
EvaluateControlDefault | Parameter: CONTROL_INFO *CtrlInfo Return value: UINT64
EvaluateControlDefault | Parameter: CONTROL_INFO *CtrlInfo Return value: UINT64
EvaluateExpression | Evaluate the result of a HII expression Parameter: IN CONTROL_INFO *ControlInfo, IN OUT BOOLEAN *ExpressionResult, OUT UINTN *Offset Return value: EFI_SUCCESS - The expression evaluated successfuly EFI_NOT_FOUND - The Question which referenced by a QuestionId could not be found. EFI_OUT_OF_RESOURCES - There is not enough system memory to grow the stack. EFI_ACCESS_DENIED - The pop operation underflowed the stack EFI_INVALID_PARAMETER - Syntax error with the Expression
EvaluateOpcode | To perform the stack operations based on the opcode
EvaluateReadWrite | Evaluates read write conditions Parameter: UINT8 *, CONTROL_INFO *, EFI_HII_VALUE * Return value: VOID
ExitApplication | Function to exit form the setup application
Expand_Data | Decompress a LZW compressed data stream.
ExtendValueToU64 | Zero extend integer/boolean/date/time to UINT64 for comparing. Parameter: Value - HII Value to be converted. Return value: None.
EzportPlusHandleEscKey | Function to handle ESC Hotkey action
EzportPlusHandleFailsafeKey | Function to handle Load Failsafe values Hotkey action
EzportPlusHandleHelpKey | Function to handle Help Hotkey action
EzportPlusHandleOptimalKey | Function to handle Load Optimal values Hotkey action
EzportPlusHandlePrevValuesKey | Function to handle Load Previous value Hotkey action
EzportPlusHandlePrnScrnKey | Function to handle print screen Hotkey action
EzportPlusHandleSaveExitKey | Function to handle Save and Exit Hotkey action
EzportPlusHelpFrameHandlewithMouse | Function to handle Help Frame with Mouse
EzportPlusMainFrameHandlewithMouse | Function to handle Main Frame with Mouse
EzportPlusNavFrameHandlewithMouse | Function to handle Navigation Frame with Mouse
EzportPlusPopupPasswordChangePrompt | Function to display password prompts for old, new, and confirm in the same window.
EzportPlusPopupPasswordSetPrompt | Function to display password prompts for new, and confirm in the same window.
EzportPlusShowPasswordClearedMessageBox | Function to Display the password success message box
EzportPlusShowPasswordErrorMessageBox | Function to Display the password failed message box
EzportPlusShowPasswordSuccessMessageBox | Function to Display the password success message box

Data Structure | Description
EDIT_BGCOLOR | Background color of focused edit controls
EDIT_FGCOLOR | Foreground color of focused edit controls
EFI_HII_VALUE |
EFI_IFR_GUID_BANNER |
EFI_IFR_GUID_CLASS |
EFI_IFR_GUID_LABEL |
EFI_IFR_GUID_SUBCLASS |
EFI_IFR_GUID_TIMEOUT |

Built on 16:20:01 10/01/14


Functions in Alphabetical Order

F

Function | Description
FileBrowserLaunchFilePath | To select the Boot file for the new boot option with the help of file browser.
FileBrowserLaunchFileSystem | To select the File System for the new boot option with the help of file browser.
Filter8
FindandSetHotKeys | Dummy function for FindandSetHotKeys function
FindandSetHotKeys | Function to form the hot keys from NVRAM
FindAnsiEscCode | Fills the EscCode in current line
FindDriverHealthDriverName | Finds the driver name which supports driver health protocol
FindDriverHealthDriverName | Finds the driver name which supports driver health protocol
FindHandleWithInSetupData | Checks if the given handle is avaiable in the scope of the current formset.
FindImageSize | To find the PNG image size
FindInsertionIndex | Finds the inded where directories items turn into file items
FindtheMatchUptoEndNode | Finds all agent handle which opens the input handle upto the last agent for the controller
FixHiddenOptions | Function to move the hidden option at last of the boot order
FixIFRRefXControl | Updates the parent pageID for the EFI_IFR_REFX control
FixSetupData | Parameter: Return value:
FlushLines | function to set the positions for flush lines
FormBGRTTable | Created the BGRT table with the input params
FormBrowserHandleValid | return True Browser is showing forms from SendForm interface.
FormBrowserLocateSetupHandles | return Handles and count that is passed to SendForm interface.
FormCallBack | Parameter: EFI_HII_HANDLE Handle, EFI_QUESTION_ID QuestionID, UINT8 Type, EFI_IFR_TYPE_VALUE *Value Return Value: EFI_STATUS
FormHotBootKeys | Dummy function for FormHotBootKeys function
FormHotBootKeys | Function to form the boot option hot keys
FrameAddControl | Adds controls to the frame
FrameCreate | Allocated memory size and creates frame
FrameDestroy | Destroys an existing frame and frees memory
FrameDraw | Draws the controls for the given frame
FrameDrawScrollBar | Draws the scrollbar controls for the frame..
FrameHandleAction | Action handler for specific frame
FrameInitialize | Initializes the frame data
FrameSetCallback | Function to set callback.
FreeControllersList | Frees the driver health details linked list
FreeExtraKeyMemories | Dummy function for FreeExtraKeyMemories function
FreeExtraKeyMemories | Function to free the extra memories allocated
FreeOptionList | Parameter: OPTION_LIST *OptionArray Return Value: VOID
FvReadResources | Function to read all the section from of specified image.

Data Structure | Description
FOCUS_COLOR | Focused label and control text color (Default EFI_WHITE)
FormSetLinks |
FULL_HORIZONTAL_HELP_DIVIDER | Horizontal divider (border) position between Help and Navigation frame windows.
FULL_STYLE_CONTROL_LEFT_MARGIN | Control column left margin in full screen mode
FULL_STYLE_CONTROL_LEFT_PAD | Control left padding in full screen mode
FULL_STYLE_CONTROL_RIGHT_AREA_WIDTH | Control column width in full screen mode
FULL_STYLE_LABEL_LEFT_MARGIN | Label column left margin in full screen mode
FULL_VERTICAL_MAIN_DIVIDER | Vertical divider (border) position between the MainFrame window and (helper and Navigation) frame windows.

Built on 16:20:01 10/01/14


Functions in Alphabetical Order

G

Function | Description
GenericHook | Locates the hook based on hooknum and calls them If hook not found it calls the default function.
GenericHookType1 | Locates the hook based on hooknum and calls them If hook not found it calls the default function.
GenericHookType2 | Locates the hook based on hooknum and calls them If hook not found it calls the default function.
GenericHookType3 | Locates the hook based on hooknum and calls them If hook not found it calls the default function.
GenericHookType4 | Locates the hook based on hooknum and calls them If hook not found it calls the default function.
GenericHookType5 | Locates the hook based on hooknum and calls them If hook not found it calls the default function.
GenericHookType6 | Locates the hook based on hooknum and calls them If hook not found it calls the default function.
GenericHookType7 | Locates the hook based on hooknum and calls them If hook not found it calls the default function.
GetAcknowledgementKey | Waits for a Key Press Parameter: VOID Return value: EFI_STATUS
GetAMITSEVariableLocal | function to get the local NvRam variable
GetANSIEscapeCode | Return Size of Escape Code and gets the FG,BGColor.
GetBackwardDistance | To get the Backward Distance
GetBBSBootOptionName | function to get the Boot option name.
GetBBSOptionStatus | function to get for bbs option status
GetBlockName | Parameter: EFI_STRING *Configuration, UINTN *Length, UINTN Size Return value: EFI_STATUS
GetBootTimeOut | Timeout value from the variable.
GetBusStr | function to get the bus type string
GetConfigHeader | Parameter: VARIABLE_INFO *VariableInfo, EFI_STRING *Configuration, UINTN *Length Return value: EFI_STATUS
GetControlAccess | Get the Control Access Specifier for a Control Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex Return Value: UINT8
GetControlConditionVariable | Parameter: CONTROL_INFO *ControlInfo Return value: UINT32
GetControlConditionVarId | Function to get control variable id
GetControlConditionVarId | Parameter: CONTROL_INFO *controlInfo Return value: UINT32
GetControlDataLength | This function will return width of questions Parameter: CONTROL_INFO * Return value: UINTN
GetControlDataWidth | Get the Data size Parameter: UINT32 PgIndex, UINT32 CtrlIndex, UINT16 *controlWidth Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetControlDefault | Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex UINT64 *Def BOOLEAN Optimal Return Value: EFI_STATUS
GetControlDestinationPage | Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex OUT UINT16 *ctrlDestPg Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetControlDisplayFormat | Parameter: UINT32 PgIndex UINT32 CtrlIndex UINT16 *Format Return Value: EFI_STATUS
GetControlHelpStr | Get the Control Help String ID Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex OUT UINT16 *ctrlHelp Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetControlMinMax | Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex UINT64 *Min UINT64 *Max Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER EFI_OUT_OF_RESOURCES
GetControlQuestionPrompt | Get the Control Question Prompt's String Id Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex OUT UINT16 *ctrlPrompt Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetControlRefresh | Get the Control Refresh for a Control Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex Return Value: UINT8
GetControlType | Get the AMI Control Type Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex OUT UINT16 *ctrlType Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetCopyLength | To Get the correct Copy Length
GetCtrlNameAndHealth | Finds the controller name with its health
GetCtrlNameAndHealth | Finds the controller name with its health
GetCtrlsDestCtrlId | Returns the QuestionID to select in the destination page
GetCurPos | Writes cursor position into given X and Y locations.
GetDCValue | This routine returns the differences(DCCoefficientpresent - DCCoefficientprev) for the DC coefficient. For AC coefficients, it returns the actual AC coefficient value and Run/Size.
GetDefaultPassword | Getting default password from SDL token based on USER/ADMIN token
GetDefaultPasswordFromTokens | Gets default password throug sdl tokens
GetDefaultPasswordFromTokens | Gets default password throug sdl tokens
GetDefaultValue | Get Default Value
GetDevPathFromHandle | Get the device path for the the given handle
GetDevStr | function to get the device strings
GetDrvHlthCtrlName | Finds the controller name
GetEncodedBit | Reads bits from the stream and returns whether the carry flag is set or not.
GetExpResult | Function to get exp result
GetExtendedLogoType | function to get the type of extended logo
GetFormByFormID | Parameter: Return value:
GetFormSetTitleAndHelp | GetFormSetTitleAndHelp Parameter: EFI_HII_HANDLE Handle, EFI_STRING_ID *Title, EFI_STRING_ID *Help Return value: status
GetGifNextFrame |
GetHelpToken |
GetHexStringAsBuffer | Parameter: CHAR8 *Buffer UINT16 *HexStringBuffer UINTN Size Return value: EFI_STATUS
GetJPEGDimensions | Get the dimensions (Width and Height) for the JPEG image
GetLineCount | function to get line count and max width.
GetLineCount | function to get line count and max width.
GetNextBit | To get the Next Bit
GetNextForm | Parameter: Return value:
GetNextMultiBit | To get the Next multiple Bits.
GetNumOfControls | Get the Number of Control for a Page
GetNumOfPages | Get the Total Number of HII Form Pages to display Parameter: OUT UINT32 *numOfPages Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_OUT_OF_RESOURCES
GetNvramVariableList | Gets all system variables
GetOrderedListDataTypeWidth | Gets OrderedList DataType Width Parameter: UINT32 PgIndex, UINT32 CtrlIndex, UINT32 *DataWidth
GetOrderedListMaxEntries | Create a Timer Event
GetOrderedListOptionDataWidth | Gets OrderedList Data Width Parameter: CONTROL_INFO *ControlInfo, UINT32 *DataWidth
GetPageGuidFromFormId | To get the form GUID from the page index
GetPageHandle | Get the Handle for the Page Parameter: IN UINTN PgIndex OUT EFI_HII_HANDLE *handle Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetPageHiiId | Get the Page Title String Index Parameter: IN UINT32 PgIndex OUT UINT16 *PageId Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetPageIdFromGuid | Finds the page ID with matching Guid from the page list
GetPageIdFromGuid | Finds the page ID with matching Guid from the page list
GetPageIdIndex | To get the index of a perticular page
GetPageIdIndex | Get the page ID index for the Page Parameter: IN UINTN PgIndex OUT UINT16 *PgIdIndex Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetPageNumFromFormID |
GetPageParent | Function to get parent page
GetPageParentId | Get the parent page ID from the page index Parameter: IN UINT32 PgIndex - Current page Index/ID OUT UINT16 *PageParentId - Parent page ID Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetPageSubTitle | Get the Page Subtitle String Index Parameter: IN UINTN PgIndex OUT UINT16 *subtitleToken Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetPageTitle | Get the Page Title String Index Parameter: IN UINT32 PgIndex OUT UINT16 *titleToken Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
GetParentFormID | Gets the parent page ID from given child page ID
GetPCXDimensions | Get the dimensions (Width and Height of the PCX Image).
GetQuestionToken |
GetQuestionValue | Get the Question Value Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex OUT UINT8 *Value OUT UINTN *ValueSize Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER EFI_OUT_OF_RESOURCES
GetRWVariableID | Returns the variable ID for read write operation
GetScreenResolution | function to get the screen resolutions.
GetSetDefaultsFromControlPtr | Function to get default stringID for String Type control from controlPtr and fetch respective string from Hii database and set as default to NVRAM, gOptimalDefaults, gFailSafeDefaults buffer
GetSpecialBootoptionToken | function to get the boot option token properly when loading the boot page
GetStringFromDevPath | Gets the string presentation of the given DevicePath
GetSubFormCount | function to count the subform and Ref inside the formset.
GetTables | Gets the 2 Quantization Tables and 4 Huffman Tables. Checks the type of table and then builds the corresponding table.
GetTokenCount |
GetTokenString |
GetUefiDevPathString | function to get the device string using device path for UEFI options.
GetUpdatedControlData | Try to get the updated control.
GetValueFromOpCode | Gets the value from the opcode Parameter: EFI_IFR_OP_HEADER *, EFI_HII_VALUE *, INTN Return value: VOID
GetValueFromParentControl | Gets the value for inconsistent/submitif from its parent control Parameter: UINT16, UINT16, EFI_HII_VALUE **, PAGE_INFO *, VOID * Return value: EFI_SUCCESS if value retrieved successfully else some other EFI Status
GetVarNumFromID | To get var number from ID
GetVarNumFromVarID | Function to get variable number from var ID
GetWindowLevel | Function to get window level
GOPSetScreenResolution | Sets the mode which approximately fits the current image resolution
GrowStack | Grow size of the stack Parameter: Stack - On input: old stack; On Output: new stack StackPtr - On input: old stack pointer; On Output: new stack pointer StackPtr - On input: old stack end; On Output: new stack end Return value: EFI_SUCCESS - Grow stack success. EFI_OUT_OF_RESOURCES - No enough memory for stack space.

Built on 16:20:01 10/01/14


Functions in Alphabetical Order

H

Function | Description
HandleAddIFRPack | Adds a IFR pack data from gSetupData
HandleEscKey | Function to handle ESC Hotkey action
HandleEscKey | Function to handle ESC Hotkey action
HandleFailsafeKey | Function to handle Load Failsafe values Hotkey action
HandleFailsafeKey | Function to handle Load Failsafe values Hotkey action
HandleHelpKey | Function to handle Help Hotkey action
HandleHelpKey | Function to handle Help Hotkey action
HandleNewIFRPack | Added a new IFR pack data in gSetupData
HandleOptimalKey | Function to handle Load Optimal values Hotkey action
HandleOptimalKey | Function to handle Load Optimal values Hotkey action
HandlePrevValuesKey | Function to handle Load Previous value Hotkey action
HandlePrevValuesKey | Function to handle Load Previous value Hotkey action
HandlePrnScrnKey | Function to handle print screen Hotkey action
HandlePrnScrnKey | Function to handle print screen Hotkey action
HandleRemoveIFRPack | Removes a IFR pack data from gSetupData
HandleSaveExitKey | Function to handle Save and Exit Hotkey action
HandleSaveExitKey | Function to handle Save and Exit Hotkey action
Hash | Allows creating a Hash of an arbitrary message digest using one or more Hash algorithms
Header_Decode | To Store the header values in the PngHeader variables
HelperGetVariable | Function helper to get variable
HelperIsPasswordCharValid | function to Check whether the password char is valid
HelperIsPasswordCharValid | Function to Check for valid password character
HelpFrameHandlewithMouse | Function to handle Help Frame with Mouse
HexStringToBuf | To avoid including EDK libs.
HexToNibbleChar | Converts the hex value to character.
HighLightLine | function to hilight a perticular line
HiiAddString | function to add a string
HiiChangeString | to change a existing string
HiiExit | performs the operations that required to exit from HII
HiiExtendedInitializeProtocol | Parameter: Return value: EFI_STATUS EFI_SUCCESS
HiiFindHandle | Function to find the perticular HII handle
HiiFindStrPrintBoundary | function to Check the boundary of the print stirng. Find out the index of the character from where the print boundry will be met
HiiFixupData | Function to fixup hhi data
HiiGetDefaultMask | Function to get default mask
HiiGetDefaultMask | Parameter: VOID Return value: UINTN
HiiGetEfiKey | Function to Encode the password key
HiiGetForm | Get HII form package by handle and form ID
HiiGetFormSet | Function to get formset
HiiGetFormSetFromHandle | Function to get formset handle
HiiGetManufactuingMask | Function to get manufacturing mask
HiiGetManufactuingMask | Parameter: VOID Return value: UINTN
HiiGetPackList | Get HII form package by handle and form ID
HiiGetStringLength | Function to get the string length
HiiInitializeProtocol | Parameter: Return value: EFI_STATUS EFI_SUCCESS
HiiLoadDefaults | function to load the default values
HiiMyGetMultiLineStringLength | returns Max length of the in the paragraph
HiiMyGetStringLength | user function to get the string length
HiiRemoveString | Parameter: EFI_HII_HANDLE Handle, UINT16 Token Return value: VOID
HiiRemoveString | Parameter: EFI_HII_HANDLE Handle, UINT16 Token Return value: VOID
HiiString2BltBuffer | function to get the Blt for the message with the given attributes
HotClickCreate | Function create a HotClick, which uses the Object functions.
HotClickDestroy | Function destroy a HotClick, which uses the Object functions.
HotclickESCaction | function to handle the left click on ESC in Navigation frame.
HotClickHandleAction | Function to handle the HotClick actions.
HotClickInitialize | Function Initialize a Hotclick, which uses the Object functions.
HotClickSetCallback | Function to set callback.
HotKeyCreate | Function create a Hotkey, which uses the Object functions.
HotKeyDestroy | Function destroy a Hotkey, which uses the Object functions.
HotKeyHandleAction | Function to handle the HotKey actions.
HotKeyInitialize | Function Initialize a Hotkey, which uses the Object functions.
HotKeySetCallback | Function to set callback.
HuffmanDecoding | This routine decodes the AC and DC coefficients using the Huffman tables stored in the JPEG image.

Data Structure | Description
HELP_BGCOLOR | Background color of the Help Frame (Default PAGE_BGCOLOR)
HELP_FGCOLOR | Foreground Color of the Help Frame (Default PAGE_FGCOLOR)
HELP_FULL_H | Vertical Height of the Help frame window.
HELP_FULL_W | Horizontal Width of the Help frame window.
HELP_FULL_X | X-Coordinate position of the Help frame window.
HELP_FULL_Y | Y-Coordinate position of the Help frame window.
HELP_H | Vertical Height of the Help frame window.
HELP_W | Horizontal Width of the Help frame window.
HELP_X | X-Coordinate position of the Help frame window.
HELP_Y | Y-Coordinate position of the Help frame window.
HELPTITLE_BGCOLOR | Background color of the Help Title Frame
HELPTITLE_FGCOLOR | Foreground Color of the Help Title Frame
HELPTITLE_FULL_H | Vertical Height of the Help Title frame window
HELPTITLE_FULL_W | Horizontal Width of the Help Title frame window
HELPTITLE_FULL_X | X-Coordinate position of the Help Title frame window
HELPTITLE_FULL_Y | Y-Coordinate position of the Help Title frame window.
HELPTITLE_H | Vertical Height of the Help Title frame window
HELPTITLE_W | Horizontal Width of the Help Title frame window
HELPTITLE_X | X-Coordinate position of the Help Title frame window
HELPTITLE_Y | Y-Coordinate position of the Help Title frame window.
HORIZONTAL_HELP_DIVIDER | Horizontal divider (border) position between Help and Navigation frame windows.

Built on 16:20:01 10/01/14


Functions in Alphabetical Order

I

Function | Description
IdentifyFormHasDefault | Is this formset has the default set Parameter: IN UINT32 FormID Return Value: BOOLEAN
IfNoCommitVariable | Is this a no commit variable Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex Return Value: BOOLEAN
IfrCatenate | Evaluate opcode EFI_IFR_TO_UINT. Parameter: FormSet - Formset which contains this opcode. Result - Evaluation result for this opcode. Return value: EFI_SUCCESS - Opcode evaluation success. Other - Opcode evaluation failed.
IFRChangeNotifyFn | Function that handles IFR change notification Parameter: IN UINT8 PackageType, IN CONST EFI_GUID *PackageGuid, IN CONST EFI_HII_PACKAGE_HEADER *Package, IN EFI_HII_HANDLE Handle, IN EFI_HII_DATABASE_NOTIFY_TYPE NotifyType Return value: EFI_STATUS EFI_SUCCESS
IfrFind | Evaluate opcode EFI_IFR_FIND. Parameter: FormSet - Formset which contains this opcode. Format - Case sensitive or insensitive. Result - Evaluation result for this opcode. Return value: EFI_SUCCESS - Opcode evaluation success. Other - Opcode evaluation failed.
IfrMatch | Evaluate opcode EFI_IFR_MATCH. Parameter: FormSet - Formset which contains this opcode. Result - Evaluation result for this opcode. Return value: EFI_SUCCESS - Opcode evaluation success. Other - Opcode evaluation failed.
IfrMid | Evaluate opcode EFI_IFR_MID. Parameter: FormSet - Formset which contains this opcode. Result - Evaluation result for this opcode. Return value: EFI_SUCCESS - Opcode evaluation success. Other - Opcode evaluation failed.
IfrSpan | Evaluate opcode EFI_IFR_SPAN. Parameter: FormSet - Formset which contains this opcode. Flags - FIRST_MATCHING or FIRST_NON_MATCHING. Result - Evaluation result for this opcode. Return value: EFI_SUCCESS - Opcode evaluation success. Other - Opcode evaluation failed.
IfrStrToUpper | function to conver the lower case string to upper Parameter: Return value: None
IfrToken | Evaluate opcode EFI_IFR_TOKEN. Parameter: FormSet - Formset which contains this opcode. Result - Evaluation result for this opcode. Return value: EFI_SUCCESS - Opcode evaluation success. Other - Opcode evaluation failed.
IfrToString | Evaluate opcode EFI_IFR_TO_STRING. Parameter: FormSet - Formset which contains this opcode. Format - String format in EFI_IFR_TO_STRING. Result - Evaluation result for this opcode. Return value: EFI_SUCCESS - Opcode evaluation success. Other - Opcode evaluation failed.
IfrToUint | Evaluate opcode EFI_IFR_TO_UINT. Parameter: FormSet - Formset which contains this opcode. Result - Evaluation result for this opcode. Return value: EFI_SUCCESS - Opcode evaluation success. Other - Opcode evaluation failed.
InitApplicationData | function to Initialize the application data
InitApplicationData | Initlizes the TSE Lite Setupdata.
InitFormsetLinks | Function to init formset links
InitGlobalPointers | function to Initialize all the global pointer declared.
InitGlobals | Initializes required global variables
InitgProgress
Initialize | to Initialize the PngImageDecoder member variables
InitializeScreenBuffer | function to Initialize the screen buffer
InitializeUnicodeCollationProtocol | Locate the Unicode Collation Protocol interface for later use. Parameter: None Return value: EFI_SUCCESS - Protocol interface Initialize success. Other - Protocol interface Initialize failed.
InitJpegParams | Reads the image parameters and checks whether the image is supported or not. TSE Jpeg Algorithm Supports following Markers ================================================== 0C0h - Start Of Frame (Baseline DCT) (REQUIRED) 0C4h - Define Huffman Table (REQUIRED) 0D0h - RSI0 Marker (OPTIONAL) 0D1h - RSI1 Marker (OPTIONAL) 0D2h - RSI2 Marker (OPTIONAL) 0D3h - RSI3 Marker (OPTIONAL) 0D4h - RSI4 Marker (OPTIONAL) 0D5h - RSI5 Marker (OPTIONAL) 0D6h - RSI6 Marker (OPTIONAL) 0D7h - RSI7 Marker (OPTIONAL) 0D8h - Start of Image (REQUIRED) 0D9h - End of Image (REQUIRED) 0DAh - Start Of Scan (REQUIRED) 0DBh - Define Quantization Table (REQUIRED) 0DDh - Define Restart Interval (OPTIONAL) 0E0h - 0xEF - APPx Markers (Does Depend on and just Skips marker) (DON'T CARE) 0F0h - 0xFD - Reserved for JPEG extensions (Does Depend on and just Skips marker) (DON'T CARE) 0FEh - Jpeg Comment (Does Depend on and just Skips marker) (DON'T CARE) TSE Jpeg Algorithom Does not Support following Markers ====================================================== 000h-0BFh - RESERVED 0C1h - Start Of Frame (Extended sequential DCT) 0C2h - Start Of Frame (Progressive DCT) 0C3h - Start Of Frame (Lossless (sequential)) 0C5h - Start Of Frame (Differential sequential DCT) 0C6h - Start Of Frame (Differential progressive DCT) 0C7h - Start Of Frame (Differential lossless (sequential)) 0C8h - Start Of Frame (Reserved for JPEG extensions) 0C9h - Start Of Frame (Extended sequential DCT) 0CAh - Start Of Frame (Progressive DCT) 0CBh - Start Of Frame (Lossless (sequential)) 0CDh - Start Of Frame (Differential sequential DCT) 0CEh - Start Of Frame (Differential progressive DCT) 0CFh - Start Of Frame (Differential lossless (sequential)) 0CCh - Arithmetic coding conditioning 0DCh - Define number of lines 0DEh - Define hierarchical progression 0DFh - Expand reference component(s) 0FFh - RESERVED
InitMiniSetupStrings | Function to init minisetup strings
InitMiniSetupStrings | Parameter: VOID Return value: EFI_STATUS
InitPostScreen | fucntion to perform the Post screen operations
InstallClickHandlers | fucntion to install the timer event
InstallFormBrowserProtocol | Installs the Formbrowser Protocol in the given handle if SETUP_FORM_BROWSER_SUPPORT is on.
InstallFormBrowserProtocol | Install FormBrowser Protocol Parameter: EFI_HANDLE Handle Return value:EFI_STATUS
InstallKeyHandlers | fucntion to install the timer event
InstallProtocol | This function installs different protocols exported.
InvalidateBgrtStatusByProtocol | Protocol interface to invalidate BGRT status
InvalidateBGRTStatusProtocol | Install Invalidate BGRT status protocol Parameter: EFI_HANDLE Handle Return value:EFI_STATUS
InvalidateStatusInBgrt | Disables the BGRT status field if any changes happened in screen other than the image display
InvertDCT | Performs inverse discrete cosine transform on dequantized data.
InvertDCT_xy | Performs inverse discrete cosine transform on dequantized data in x and y direction.
IsBBSDevicePath | function to Check for bbs device path support.
IsBootDeviceEnabled | Function to Check the boot option status
IsCharWide | function to Check the given character is wide
IsControlCheckBox | Check if the control is a Check box Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex Return Value: BOOLEAN
IsControlInteractive | Get the Control Interactive Specifier for a Control Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex Return Value: EFI_STATUS BOOLEAN
IsControlReadOnly | Get the Control Readonly Specifier for a Control Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex Return Value: BOOLEAN
IsControlResetRequired | Get the Control Reset status for a Control Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex Return Value: BOOLEAN
IsControlVisible | Get the Control Visiblity for a Control Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex Return Value: BOOLEAN
IsFormFound | to Check whether the perticular form found or not
IsFormsetHasDefault | Is this formset has the default set Parameter: IN UINT32 FormID Return Value: BOOLEAN
IsHexDigit | To avoid including EDK libs.
IsLegacyOption | function to Check for legacy option
IsNoSubmitOfForms | Is this formset or form has the no submit if Parameter: IN UINT32 FormID OUT UINT16* ErrToken Return Value: BOOLEAN
IsPageModal | Is this a modal page Parameter: IN UINT32 PgIndex Return Value: BOOLEAN
IsPageRefreshable | Is this page can be refreshable Parameter: IN UINT32 PgIndex Return Value: BOOLEAN
IsParentPage | Is this page a parent page Parameter: IN UINT32 PgIndex Return Value: BOOLEAN
IsPasswordEncodeEnabled | Function to Password Encoding Status.
IsPasswordEncodeEnabled | Function to return Password Encoding Status.
IsPasswordSupportNonCaseSensitive | Returns SETUP_PASSWORD_NON_CASE_SENSITIVE token value
IsSATADevice | function to Check for SATA Devices
IsScopeStackEmpty | Parameter: VOID Return value: BOOLEAN
IsScrollSupportRequired | To know whether the scroll supprot required befor drawing the frame
IsToggleStateKey | function to Check Is any of ToggleStateKey (CapsLock,Numlock ScrollLock) Keys pressed.
IsToggleStateKey | function to Check Is any of ToggleStateKey (CapsLock,Numlock ScrollLock) Keys pressed.
IsVarGuidPresent

Built on 16:20:01 10/01/14


Functions in Alphabetical Order

L

Function | Description
LabelCreate | Function to create a Label, which uses the Control functions.
LabelDestroy | Function to destroy a Label, which uses the Control functions.
LabelDraw | Function to draw a Label.
LabelGetLabelHeight | Function to get label height.
LabelHandleAction | Function to handle the Label actions.
LabelInitialize | Function to Initialize a Label, which uses the Control functions.
LabelSetAttributes | Function to set attributes.
LabelSetCallback | Function to set callback.
LabelSetDimensions | Function to set dimension.
LabelSetFocus | Function to set the Label focus.
LabelSetPosition | Function to set position.
LegacyFrameAddControl | Adds controls to the frame
LegacyFrameDraw | Draws the controls for the given frame
LegacyFrameDrawScrollBar | Draws the scrollbar controls for the frame..
LegacyHelpFrameHandlewithMouse | Function to handle Help Frame with Mouse
LegacyMainFrameHandlewithMouse | Function to handle Main Frame with Mouse
LegacyMsgBoxInitialize | Function to Initialize Message Box, which uses the Popup functions.
LegacyNavFrameHandlewithMouse | Function to handle Navigation Frame with Mouse
LegacyPageHandleAction | function to handle the page actions
LegacySubMenuDraw | function to draw a sub-menu.
LegacySubMenuInitialize | this function uses the Initialize function of control and initializes the submenu.
LibReportStatusCode | To avoid including EDK libs.
ListBoxCreate | Function to create a List Box, which uses the popup controls.
ListBoxDestroy | Function to Destroy a List Box, which uses the popup controls.
ListBoxDraw | Function to draw a List Box.
ListBoxGetControlHight | Function unsupported.
ListBoxHandleAction | Function to handle the List Box actions.
ListBoxSetAttributes | Function to set attributes.
ListBoxSetCallback | Function to set callback.
ListBoxSetDimensions | Function to set dimension.
ListBoxSetFocus | Function to set focus.
ListBoxSetPosition | Function to set position.
LoadDefaultLegDevOrder | Function to load default legacy boot order
LoadDefaults | function to load the defaults to the nvram cache Parameter: UINT32 FormID - form identifier BOOLEAN *ResetVal - Reboot flag of the control variable BOOLEAN * ValChanged - flag to Check whether the value changed Return Value: EFI_STATUS
LoadFailsafeDefaults | Loads the failsafe defaults.
LoadNvram | Intermediate function to get the nvram variables to restore. Parameter: UINT32 PageID Return Value: EFI_STATUS
LoadOptimalDefaults | Loads the optimal defaults.
LoadOptionhidden | Function to Check the Boot option status if gLoadOptionhidden token is Enabled
LoadPreviousValues | Callback function for LoadPreviousValue.
LoadStrings | Function to load the strings from Hii.
LoadUserDefaults | Function to load the user set defaults
LoadUserDefaultsSilently | Function to load the user set defaults Silently

Data Structure | Description
LABEL_FOCUS_COLOR | Focused label text color (Default same as FOCUS_COLOR)
LABEL_NON_FOCUS_COLOR | Non Focused label text color (Default same as NON_FOCUS_COLOR)

Built on 16:20:02 10/01/14


Functions in Alphabetical Order

M

Function | Description
MainFrameHandlewithMouse | Function to handle Main Frame with Mouse
MainSetupLoop | This function runs the loop for setup execution. This function is responsible for creating the application hierarchy. It also gathers actions and passes them thru application hierarchy and initiates draw sequence.
MainSetupLoopInit | Main function that initializes the setup Loops.
MakeDynamicHuffmanCode | To make the Dynamic Huffman Code
MakeFixedHuffmanCode | To make the fixed huffman code
MakeHuffmanTree | To create the huffman tree
MatchDevicePath | Matches the Device path from the BootOption to BBS Device path to locate the right Device
MatchDPHandleWithDrvHlthHndls | Checks whether the input handle has the driver health support
MemCmp | function to compare the memory of two buffers.
MemCopy | function to copy a memory
MemFillUINT16Buffer | function to fill a UINT16 Buffer
MemFreePointer | Convert a *.BMP graphics image to a UGA blt buffer. If a NULL UgaBlt buffer is passed in a UgaBlt buffer will be allocated by this routine. If a UgaBlt buffer is passed in it will be used if it is big enough.
MemFreePointer | function to free the pointers
MemoCreate | Function to create a Memo, which uses the Control Functions.
MemoDestroy | Function to Destroy a Memo, which uses the Control Functions.
MemoDraw | Function to draw a Memo.
MemoDrawScrollBar | Function to draw memo scrollbar
MemoEraseScrollBar | Function to erase memo scrollbar
MemoGetControlHeight | Function to get the memo text height.
MemoInitialize | Function to Initialize a Memo, which uses the Control Functions.
MemoSetAttributes | Function to set attributes.
MemoSetCallback | Function to set callback.
MemoSetDimensions | Function to set dimension.
MemoSetFocus | Function to set focus.
MemoSetJustify | Function to set justify.
MemoSetPosition | Function to set position.
MemReallocateZeroPool | function to reuse a allocated buffer
MemSet | function to set the memory with the specified value
MenuCreate | Function to create Menu, Which uses the control functions.
MenuDestroy | Function to Destroy Menu, Which uses the control functions.
MenuDraw | Function to draw a Menu.
MenuGetControlHight | Function unsupported.
MenuHandleAction | Function to set callback.
MenuHandleAction | Function to handle actions.
MenuInitialize | Function to Initialize Menu, Which uses the control functions.
MenuSetAttributes | Function to set attributes.
MenuSetCallback | Function to set callback.
MenuSetDimensions | Function to set dimension.
MenuSetFocus | Function to set focus.
MenuSetPosition | Function to set position.
MenuSetWidth | Function to set width.
MergePageIdListAndInfo | Function to merge page id list and info
MergePageListAndInfo | To merge the information
MergeVariableListAndInfo | Function to merge variable list and info
MiniSetupApplication | This function is the entry point for TSE. It loads resources like strings and setup-data. It registers notification for console protocols. It Installs TSE protocols.
MinisetupCreatePopup | Function implements the CreatePopup interface of Formbrowser Protocol.
MiniSetupEntry | This function prepares system so that setup can be launched. Preparation mainly includes Setup data fixup and variable details gathering.
MiniSetupExit | This function is responsible for releasing the memory allocated during MinisetuEntry(). It destroys the application hierarchy; clears the memory used for variables; clears the memory used for fixup of setup-data.
MinisetupSendForm | Function implements the SendForm interface of Formbrowser Protocol. UseDatabase=True is only supported.
MiniSetupUIExit | Freesup UI related resources.
MsgBoxCreate | Function to Create Message Box, which uses the Popup functions.
MsgBoxDestroy | Function to Destroy Message Box, which uses the Popup functions.
MsgBoxDraw | Function to Draw Message box
MsgBoxGetControlHight | Function unsupported.
MsgBoxHandleAction | Function to Handle the Message Box Actions.
MsgBoxInitialize | Function to Initialize Message Box, which uses the Popup functions.
MsgBoxSetAttributes | Function to set attrinutes.
MsgBoxSetCallback | Function to set callback.
MsgBoxSetDimensions | Function to set dimensions.
MsgBoxSetFocus | Function to set focus.
MsgBoxSetPosition | Function to set position.
MsgBoxSetType | Function to set message box type.
Mul64 | To avoid including EDK libs.

Data Structure | Description
MAIN_BGCOLOR | Background Color of the Main frame.
MAIN_FGCOLOR | Foreground Color of the Main frame.
MAIN_FULL_H | Vertical Height of the Main frame window.
MAIN_FULL_W | Horizontal Width of the Main frame window.
MAIN_FULL_X | X-Coordinate position of the Main frame window.
MAIN_FULL_Y | Y-Coordinate position of the Main frame window.
MAIN_H | Vertical Height of the Main frame window.
MAIN_W | Horizontal Width of the Main frame window.
MAIN_X | X-Coordinate position of the Main frame window.
MAIN_Y | Y-Coordinate position of the Main frame window.
MEMO_COLOR | Foreground color of Memo controls
MENU_BGCOLOR | Background color of the Menu bar frame
MENU_FGCOLOR | Foreground Color of the Menu bar frame
MENU_FULL_H | Vertical Height of the Menu bar frame
MENU_FULL_W | Horizontal Width of the Menu bar frame
MENU_FULL_X | X-Coordinate position of the Menu bar frame
MENU_FULL_Y | Y-Coordinate position of the Menu bar frame
MENU_H | Vertical Height of the Menu bar frame
MENU_W | Horizontal Width of the Menu bar frame
MENU_X | X-Coordinate position of the Menu bar frame
MENU_Y | Y-Coordinate position of the Menu bar frame
MiniSetup_SUPPORT | Main switch to enable BootOnly Sources support in Project

Built on 16:20:02 10/01/14


Functions in Alphabetical Order

N

Function | Description
NameValueBufToHexString | Converts binary buffer to Unicode string. At a minimum, any blob of data could be represented as a hex string. Used only for name value implementaion
NameValueGetHexStringAsBuffer | Parameter: CHAR8 *Buffer UINT16 *HexStringBuffer UINTN Size Return value: EFI_STATUS
NameValueHexStringToBuf | Converts name value string to buffer
NavFrameHandlewithMouse | Function to handle Navigation Frame with Mouse
NextFrame | function to get the next frame.
NibbleToHexChar | Converts the low nibble of a byte to hex unicode character.
NotificationFunction | function to perform the notification operations.
NumericCreate | function used for Numeric control Create, which uses the Edit functions.
NumericDestroy | function used to destroy Numeric controls, which uses the Edit functions.
NumericDraw | function used to draw the numeric controls
NumericGetControlHeight | Function to get label height.
NumericHandleAction | function used handle the Numeric controls
NumericHandleActionKey | function used handle the Numeric control keys
NumericInitialize | function used to Initialize the Numeric controls, which uses the Edit functions.
NumericSetAttributes | Function to set attributes.
NumericSetCallback | function used for setting Numeric control callback.
NumericSetDimensions | Function to set dimensions.
NumericSetFocus | Function to set focus.
NumericSetPosition | Function to set position.
NumSPrint | Function to print nums.

Data Structure | Description
NAV_BGCOLOR | Background color of the Navigation Frame
NAV_FGCOLOR | Foreground Color of the Navigation Frame
NAV_FULL_H | Vertical Height of the Navigation frame window.
NAV_FULL_W | Horizontal Width of the Navigation frame window.
NAV_FULL_X | X-Coordinate position of the Navigation frame window.
NAV_FULL_Y | Y-Coordinate position of the Navigation frame window.
NAV_H | Vertical Height of the Navigation frame window.
NAV_W | Horizontal Width of the Navigation frame window.
NAV_X | X-Coordinate position of the Navigation frame window.
NAV_Y | Y-Coordinate position of the Navigation frame window.
NON_FOCUS_COLOR | Non Focused label and control text color (Default PAGE_FGCOLOR)

Built on 16:20:02 10/01/14


Functions in Alphabetical Order

O

Function | Description
ObjectCreate | function to create an object
ObjectDestroy | function to Destroy an object
ObjectDraw | Function to draw an object
ObjectHandleAction | Function to handle object action
ObjectInitialize | Function to Initialize an object
ObjectSetCallback | Function to set object callback
OEMEmpty | Empty Template
OrdListBoxCreate | function to Create a Order List Box, which uses the PopupSel Fucntions
OrdListBoxDestroy | function to Destroy a Order List Box, which uses the PopupSel Fucntions
OrdListBoxDraw | function to draw a ordered List Box
OrdListBoxHandleAction | Function to handle the ordered List Box actions
OrdListBoxSetAttributes | Function to set atributes for ordered List Box
OrdListBoxSetCallback | Function to set callback for ordered List Box
OrdListBoxSetDimensions | Function to set dimension for ordered List Box
OrdListBoxSetFocus | Function to set focus for ordered List Box
OrdListBoxSetPosition | Function to set position for ordered List Box
OrdListGetControlHeight | Function used get the hight of control
Output | To create the Output values in the RGB format.
Output8x8Image | This functions writes to the Global Screen Buffer.
Output_Line | This routine is used to map the decoded data to the palette and fill the global Screen Buffer.
OutputJPEGImage_YUV | This functions writes to the Global Screen Buffer by calling Output8x8Image function.
OverRideComponent | Function to override component or control functionality
OverRideStyleAddAdditionalControls | Function to add additional controls
OverRideStyleDrawPageBorder | Function to draw page border
OverRideStyleDrawPageBorder | Function to draw page border
OverRideStyleDrawPageBorder | Function to draw page border
OverRideStyleFrameDrawable | Function to determine if frame is drawable
OverRideStyleFrameHandleKey | Function to handle action key
OverRideStyleGetFrameInitData | Function to get frame initialization data
OverRideStyleGetFrameInitData | Function to get frame initialization data
OverRideStyleGetFrameInitData | Function to get frame initialization data
OverRideStyleGetNavToken | Function to get navigation frame token
OverRideStyleHandleControlOverflow | Function to handle contro overflow
OverRideStyleInit | Function to Initialize style
OverRideStyleInit | Function to Initialize style
OverRideStyleInit | Function to Initialize style
OverRideStyleInitializeFrame | Function to Initialize frame
OverRideStyleLabelCallback | Function to set label callback
OverRideStyleSelectFirstDisplayPage | Function to set first page display
OverRideStyleUpdateVersionString | Function to update version string

Data Structure | Description
OVERRIDE_PopupPwdAuthenticateIDEPwd | set to 1 if oem wants to override the PopupPwdAuthenticateIDEPwd function from Board module.
OVERRIDE_PopupPwdHandleActionOverRide | set to 1 to display password prompts for old, new, and confirm in the same window.

Built on 16:20:02 10/01/14


Functions in Alphabetical Order

P

Function | Description
Paeth |
PageCreate | function to create a page
PageDestroy | function to destroy a page, which uses the HotKey Fucntions
PageDraw | function to draw a page with attributes
PageHandleAction | function to handle the page actions
PageInitialize | function to Initialize a page, which uses the Frame Fucntions
Palette_Decode | To store the PLTE data values in PngPalette variables
ParseForm | Parse the HII Package for the Form Pack and parse the FormPack Parameter: IFRPackage - The Header of the Package to parse. Return value: EFI_STATUS - Return the Status of the Parsing
PasswordAuthenticateLocal | function to Check the authentication of the password
PasswordCheckInstalledLocal | function to Check the password type
PasswordEncodeLocal | Encodes the input string
PasswordUpdateLocal | function to ubdate the password
PCX_Init | This routine is used to fill the PCX_INFO structure.
PngGetUnsignedInt | To get decimal values
PopExpression | Pop an Expression value from the Stack Parameter: Value - Expression value to pop. Return value: EFI_SUCCESS - The value was popped onto the stack. EFI_OUT_OF_RESOURCES - The pop operation underflowed the stack
PopScope | Pop an Operand from the Stack Parameter: Operand to pop. Return value: EFI_SUCCESS - The value was pushed onto the stack. EFI_OUT_OF_RESOURCES - There is not enough system memory to grow the stack.
PopStack | Pop an element from the stack. Parameter: Stack - On input: old stack; On Output: new stack StackPtr - On input: old stack pointer; On Output: new stack pointer StackPtr - On input: old stack end; On Output: new stack end Data - Data to pop. Return value: EFI_SUCCESS - The value was popped onto the stack. EFI_ACCESS_DENIED - The pop operation underflowed the stack
PopupCreate | this function uses the create function of control and creates the Popup menu
PopupDestroy | this function uses the destroy function of control and destroys the Popup menu
PopupDraw | function to draw popup menu with attributes
PopupDrawString | function to draw string in a popup menu with attributes
PopupEditCreate | this function uses the create function of control and creates the Popup Edit
PopupEditDestroy | this function uses the destroy function of control and destroys the Popup Edit
PopupEditDraw | function to draw the popup to edit with attributes
PopupEditGetControlHight | Function unsuppored.
PopupEditHandleAction | function to handle the Popup Edit actions
PopupEditHandlePassword | function to handle the popup password edit
PopupEditHandlePassword | Function to handle PopupEdit password.
PopupEditInitialize | this function uses the Initialize function of control and initializes the Popup Edit
PopupEditSetAttributes | Function to set the dimentions of the editable popup menu
PopupEditSetCallback | Function to set the PopupSel callback
PopupEditSetDimensions | function to set the dimentions of the editable popup menu
PopupEditSetFocus | Function to set focus
PopupEditSetPosition | Function to set focus
PopupEditSetText | Function to set the PopupEdit text
PopupEditSetType | Function to set the PopupEdit type
PopupGetControlHight | Function unsuppored.
PopupHandleAction | Function to handle the Popup Edit actions
PopupInitialize | this function uses the Initialize function of control and initializes the Popup menu
PopupPasswordAuthenticateLocal | function to Check authentication of the password
PopupPasswordCheckInstalledLocal | function to Check the local installation of popup password
PopupPasswordCreate | this function uses the create function of control and creates the popup password
PopupPasswordDestroy | this function uses the destroy function of control and destroys the popup password
PopupPasswordDraw | function to draw the popup password with attributes
PopupPasswordFormCallback | Function to handle PopupPassword form callbacks.
PopupPasswordGetControlHeight | function to get the height of the label
PopupPasswordHandleAction | Function to handle the PopupPassword Actions
PopupPasswordInitialize | this function uses the Initialize function of control and initializes the popup password
PopupPasswordSetAttributes | Function to set attributes.
PopupPasswordSetDimensions | Function to set dimension.
PopupPasswordSetFocus | Function to set focus
PopupPasswordSetPosition | Function to set position.
PopupSelCreate | this function uses the create function of control and creates the Popup Selected
PopupSelDestroy | this function uses the destroy function of control and destroys the Popup Selected
PopupSelDraw | function to draw the specific popup window
PopupSelGetControlHeight | function to get the height of the label
PopupSelHandleAction | function to handle the PopupSel Actions
PopupSelInitialize | this function uses the Initialize function of control and initializes the Popup Selected
PopupSelSetAttributes | Function to set attributes.
PopupSelSetCallback | Function to handle the PopupString actions
PopupSelSetDimensions | Function to set dimension.
PopupSelSetFocus | Function to set focus
PopupSelSetPosition | Function to set position.
PopupSetAttributes | Function to set the dimentions of the editable popup menu
PopupSetCallback | Function to set the Popup callback
PopupSetDimensions | Function to set the dimentions of the editable popup menu
PopupSetFocus | Function to set focus
PopupSetPosition | Function to set focus
PopupStringCreate | this function uses the create function of control and creates popup strings
PopupStringDestroy | this function uses the destroy function of control and destroys popup strings
PopupStringDraw | this function is to draw the popup strings
PopupStringGetControlHeight | Function to get the lable height of the PopupString
PopupStringHandleAction | function to handle the Popup string actions.
PopupStringSetAttributes | Function to set attributes.
PopupStringSetCallback | function to handle the PopupString actions
PopupStringSetDimensions | Function to set dimension.
PopupStringSetFocus | Function to handle the PopupString actions
PopupStringSetPosition | Function to set position.
PostManagerDisplayInfoBox | Function to display the Information box
PostManagerDisplayMenu | Wrapper function for Display Menu.
PostManagerDisplayMsgBox |
PostManagerDisplayMsgBoxEx | Wrapper function for Display OEM Message box.
PostManagerDisplayPostMessage | This function is the protocol to display messages in the Post screen.
PostManagerDisplayPostMessageEx | This function is the protocol to display messages with attributes in the Post screen.
PostManagerDisplayProgress | Wrapper function for Display OEM Message box.
PostManagerDisplayQuietBootMessage | Function for the quit booting display.
PostManagerDisplayTextBox | Function to display text entry interface
PostManagerGetAttribute | Function to Get color
PostManagerGetCursorPosition | Wrapper function for GetCurPos Writes cursor position into given X and Y locations.
PostManagerGetPostStatus | Function returns current Post status.
PostManagerHandshake | This function is the handshake function to which BDS hands-off.
PostManagerInitProgressBar | Initializes the PostManagerProgressBar
PostManagerSetAtribute | Function to set color
PostManagerSetCursorPosition | Wrapper function for SetCurPos
PostManagerSetProgressBarPosition | Increments the PostManagerProgressBar
PostManagerSwitchToPostScreen | This function is the protocol to switch to Post screen
PrepareOutput | To validate the colorType and bitDepth combination and prepare the Output data
PreservePostMessages | function to take care the postmessages when Screen mode changes Only supported if OldMaxCols <= NewMaxCols
PrintPostMessage | function to Print the Post massages
PrntScrnKeyHandleaction | Function to handle PrintScreenKeyto get screen image as BltBuffer and save as BMP file to a available filesystem
PrntScrnKeyNotification | PrntScrnKeyNotification Function handle PrntScrnKey action
ProcessActionQuestionConfiguration | Function to process Action Control Configuration String. UEFI Action control is a 2.1 control
ProcessBrowserActionRequest | Parameter: EFI_BROWSER_ACTION_REQUEST actionReq Return Value: EFI_STATUS
ProcessPackNotification | Processes the IFR notification queue
ProcessPackNotification | Processes the IFR notification queue
ProcessPackToFile | Prints the HPK data to file
PushExpression | Push an Expression value onto the Stack Parameter: Value - Expression value to push. Return value: EFI_SUCCESS - The value was pushed onto the stack. EFI_OUT_OF_RESOURCES - There is not enough system memory to grow the stack.
PushScope | Push an Operand onto the Stack Parameter: Operand to push. Return value: EFI_SUCCESS - The value was pushed onto the stack. EFI_OUT_OF_RESOURCES - There is not enough system memory to grow the stack.
PushStack | Push an element onto the Boolean Stack Parameter: Stack - On input: old stack; On Output: new stack StackPtr - On input: old stack pointer; On Output: new stack pointer StackPtr - On input: old stack end; On Output: new stack end Data - Data to push. Return value: EFI_SUCCESS - Push stack success.

Data Structure | Description
PAGE_BGCOLOR | Background Color of the main area (Main, Help, and Navigation Frames) in a page.
PAGE_FGCOLOR | Foreground and Border Color of main area in a page (Default EFI_BLUE)
PAGE_LINK_COLOR | Submenu text color (Default PAGE_FGCOLOR)
PAGEBORDER_FULL_H | Vertical height of the page border
PAGEBORDER_FULL_W | Horizontal width of the page border
PAGEBORDER_FULL_X | X-Coordinate position of the Page border. (Default 0)
PAGEBORDER_FULL_Y | Y-Coordinate position of the Page border. (Default 2)
PAGEBORDER_H | Vertical height of the page border.
PAGEBORDER_W | Horizontal width of the page border
PAGEBORDER_X | X-Coordinate position of the Page border. (Default 0)
PAGEBORDER_Y | Y-Coordinate position of the Page border. (Default 2)
PageLink |
POPUP_BGCOLOR | Background Color of Popup Windows, and Message Boxes (Default EFI_BACKGROUND_BLUE)
POPUP_FGCOLOR | Foreground Color of Popup Windows, and Message Boxes (Default EFI_WHITE)
POPUP_MENU_ENTER_SETUP | 1 => Allows to enter setup from BBS popup
PVAR_KEY_TABLE |

Built on 16:20:02 10/01/14


Functions in Alphabetical Order

R

Function | Description
readbuf | Read the next byte from buffer
ReadChunk | To Read all the chunk data
ReadImageDesc | Read the image description and the optional color map.
ReadImageResource | Function to read all the resources of a image.
ReadJPEGImage | Reads the 8x8 matrix data for each of Y_0,Y_1,Y_2,Y_3,Cb and Cr. The final Output will be image data after inverse DCT is applied.
ReadJPEGImage_YUV | Reads the 8x8 matrix data for each of Y_0,Y_1,Y_2,Y_3,Cb and Cr. The final Output will be RGB pixel data.
ReadPlatformLang | Dummy function for PlatformLang function
ReadPlatformLang | Function to return the PlatformLang
ReadScreenDesc | Read the signature, the screen description, and the optional default color map.
RearrangeBBSOrder | Rearranges the bootdata legacy entries with legacydevorder defaults
RearrangeBBSOrderVariable | Function to reorder the BBS order variable
RearrangeBootDriverOrderVariable | Function to rearrange the boot/driver order variables
RefreshBootKeysDetails | Dummy function for RefreshBootKeysDetails function
RefreshBootKeysDetails | Clears the boot key gloabl details
RefreshGroupOnCallBack | Callback function which refreshes Controls of a Group which are set with refresh Id Parameter: EFI_EVENT Event, VOID *Context Return value:
RegFormNotification | Registers the hii pack notification Parameter: VOID Return value: EFI_STATUS
RegFormNotification | Registers the hii pack notification Parameter: VOID Return value: EFI_STATUS
RegisterFormNotification | Notification Registering Function Parameter: EFI_HII_DATABASE_NOTIFY PackageNotifyFn, EFI_HII_DATABASE_NOTIFY_TYPE NotifyType, EFI_HANDLE *NotifyHandle Return value: EFI_STATUS EFI_SUCCESS
RegisterNotification | It will create a notify event and register a notification.
ReGroupOptions | function to regroup the boot options
RemoveDuplicateIFRNotification | Finds duplicate notification on the same handle and remove
RemoveFromQueueByEntry | Removes the notification entry from the queue, and returns the pointer to the next notification node
RemoveNotifFromQueueByHandleType | Removes the all the node with same notification handle and type except the passed the entry from the queue
ResetButtonCreate | Function to create an ResetButton Control.
ResetButtonDraw | Function to draw ResetButton.
ResetButtonHandleAction | Function to handle the ResetButton.
ResetButtonInitialize | Function to Initialize an Action Control.
ResetExpressionStack | Reset stack pointer to begin of the stack. Parameter: None. Return value: None
ResetNavStack | Resets the navigation stack
ResetScopeStack | Reset stack pointer to begin of the stack. Parameter: None. Return value: None.
ResetSys | Function to reset
RestoreGraphicsScreen | Restores the saved Post graphics screen
RestorePostScreen | Function to restore the saved screen
RestoreScreen | function to restore the screen from the saved screen buffer.
RTIfrProcessAddVarListAndPageIDList | Function to add var list page ID list
RTIfrProcessExit | Function to process ifr exit
RTIfrProcessFormIfUpdated | Fuction to process form if updated
RTIfrProcessRunTimeForms | Function to process runtime forms
RTIfrUpdateVariableInfo | Wrapper function to include RTIfrUpdateVariableInfo based on SDL token.

Built on 16:20:02 10/01/14


Functions in Alphabetical Order

S

Function | Description
SaveAddDelBootOptions | function to save the added/deleted boot option
SaveAddDelDriverOptions | Function to save the added/deleted Driver option
SaveAndExit | Function to save and exit
SaveAndReset | Function to save and reset
SaveBBSOrder | Function to save the bbs device order
SaveCleanUpGifDatas | Saves the structures used for preserving the gif images
SaveGraphicsScreen | Saves Post graphics screen
SavePostScreen | Function to save the Post screen
SavePswdString | Dummy fucntion to avoid build error Parameter: CONTROL_INFO * ControlData, CHAR16 *String Return Value: VOID
SavePswdString | fucntion to save the password string. Parameter: CONTROL_INFO * ControlData, CHAR16 *String Return Value: VOID
SaveQuestionValues | Save all the values to the system Parameter: VOID Return Value: EFI_STATUS EFI_SUCCESS
SaveScreen | function to get the backup of the screen.
SaveUserDefaults | Function to save the user specified defaults
SaveUserDefaultsSilently | Function to save the user set defaults Silently
SaveWithoutExit | Function to save without exit
SearchHook | Finds the Firsthookfn and Lasthookfn of HookNum
SearchHuffmanCode | Searches the Huffman code of the DC/AC Luminance/Chrominace values in Huffman code tables and find the appropriate HuffmanCodeValue.
SearchLastHook | Returns the lasthookfn number
SendForm | This is the routine which an external caller uses to direct the browser where to obtain it's information.
SetBootOptionSupportVariable | Function to set the BootOptionSupport variable
SetCallBackControlInfo | Set the variable inforamtion Parameter: EFI_HANDLE VarHandle - Variable handle to process UINT32 VarIndex - Variable index in the gVariables->VariableList Return value:VOID
SetCurPos | Sets the cursor to the position defined by X and Y.
SetDefaultPassword | Function to set defaults password in NVRAM, if any present in SDL
SetDesiredTextMode | function to set the test mode
SetDriverHealthCount | Sets the DriverHealthCount and DriverHlthEnable variables
SetDriverHealthCount | Sets the DriverHealthCount and DriverHlthEnable variables
SetDrvHealthHandleAndCtrlCount | Finds and sets the number of controllers supports the driver health handle
SetDrvHealthHandleAndCtrlCount | Finds and sets the number of controllers supports the driver health handle
SetGetBgrtCoordinates | Sets the BGRT logo coordinates
SetGraphicsResolution | Sets the graphical resolution corresponding to the input parameter
SetListBoxHelpString | Function to set a string in List Box.
SetListBoxString | Function to set a string in List Box.
SetNativeResFromEdid | Finds and sets the resolution from EDID
SetParentFormID | Updated NAV_PAGE_STACK with current page and parent page info
SetPasswordType | function to set the type of password
SetPostScreenScrollArea | Sets the PostScreen Scroll Area.
SetQuestionValue | Set the Value for a Question Parameter: IN UINT32 PgIndex IN UINT32 CtrlIndex IN UINT8 *Value IN UINTN ValueSize OUT UINT16 *ErrStrToken Return Value: EFI_STATUS EFI_SUCCESS EFI_NOT_READY EFI_INVALID_PARAMETER
SetScreenResolution | function to set the screen resolutions.
SetScrollPosition | function to set the position of the Scroll bar
SetSystemAccessValue | function to set the system access Value
SetupDebugKeyHandler | Parameter: Return value:
SetupDebugPrint |
SetupShowDebugScreen | Parameter: Return value:
ShiftTwoLineBuf |
ShowBootOverrideSelectOption | function to Show menu with below option on selecting options under Boot Override 1) Override now and clear the BootNext data 2) Override now but keep the BootNext data 3) Boot to BootNext and clear BootNext data
ShowHelpMessageBox | Function to Display the help message box
ShowInfoBox | fucntiont to display the information box
ShowPostMenu | Function to show menu
ShowPostMsgBox | Function to display the message box
ShowPostMsgBox | Function to show messagebox
ShowPostMsgBoxEx | Function to display the message box
ShowPostMsgBoxEx | Function to show messagebox
ShowPostProgress | Function to display the progress bar
ShowPostProgress | Function to display the progress bar
ShowPostTextBox | Function to display text entry interface
ShowPostTextBox | Function to display text entry interface
SkipEscCode | function to perform the esc key operation
SkipObject | Skip over an extended GIF object.
SlowFlushLines | function to slow flush lines
SpecialActionCallBack | Callback for UEFI Action control. This is used only in UEFI 2.1
SpecialControlsFixup | Fixes control information for special control in the varstore Parameter: None Return value: EFI_STATUS
SpecialFixupDelBootOption | function to fixup the deletion of a boot device option
SpecialFixupDelDriverOption | Function to fixup the deletion of a driver option
SpecialGetValue | function to handle the operation of getting the Ifr Value.
SpecialUpdatePageControls | special fucntion to update the page controls
SpecialUpdatePageControls | Fix the Boot Order, BBS Order and Boot Override controls.
SPrint | SPrint function to process format and place the results in Buffer
StopClickEvent | Function to Stop the Click Event
StopRefreshOpEvent | Stops the refresh event
StrCpy8 | Copies a CHAR8 String from source to destination
StrDup | function to dump and return the string
StrDup16to8 | Duplicates a String from CHAR16 to CHAR8
StrDup8 | Duplicates a String of type CHAR8
StrDup8to16 | Duplicates a String from CHAR8 to CHAR16
StringWrapText | function to create a new text by wrapping the given text.
StringZeroFreeMemory | Function to free the string pointers and zeroing its memory, used for strings Care should be taken String Length identification function is used
StrLen8 | Returns Length of a String of type CHAR8
StrZeroPad | function to pad with zero
StyleAddAdditionalControls | Function to add additinal controls
StyleAddAdditionalControls | Function to add additinal controls
StyleAddExtraPagesData | Function to add extra pages
StyleAddExtraPagesData | Function to add extra pages
StyleBeforeFrame | Function to alter frame styling before frame is drawn
StyleBeforeFrame | Function to alter frame styling before frame is drawn
StyleBootManagerPage | Function to set boot manager page
StyleControlColor | Adds controls to the frame
StyleControlColor | Adds controls to the frame
StyleDrawHelpScrollBar | Function to draw the help frame scrollbar
StyleDrawHelpScrollBar | Function to draw the help frame scrollbar
StyleDrawPageBorder | Function to draw the page border
StyleDrawPageBorder | Function to draw the page border
StyleDrawScrollBar | Function to draw the frame scrollbar
StyleDrawScrollBar | Function to draw the frame scrollbar
StyleExit | Function to do style initialization on exit
StyleExit | Function to do style initialization on exit
StyleFrameAddTitle | Function to add frame title
StyleFrameAddTitle | Function to add frame title
StyleFrameAddTitle | Function to add frame title
StyleFrameAddTitle | Function to add frame title
StyleFrameDrawable | Function to determine if frame is drawable
StyleFrameDrawable | Function to determine if frame is drawable
StyleFrameHandleKey | Function to handle frame action keys
StyleFrameHandleKey | Function to handle frame action keys
StyleFrameHandleMouse | Function to handle frame using mouse
StyleFrameHandleMouse | Function to handle frame using mouse
StyleFrameHandleTimer | Function to handle frame timer action
StyleFrameHandleTimer | Function to handle frame timer action
StyleFrameIndexOf | Function to get frame index
StyleFrameIndexOf | Function to get frame index
StyleFrameIndexOf | Function to get frame index
StyleFrameIndexOf | Function to get frame index
StyleFrameSetControlPositions | Function to set control positioning in a frame
StyleFrameSetControlPositions | Function to set control positioning in a frame
StyleGetClearScreenColor | Function to Get Clear Screen Color
StyleGetClearScreenColor | Function to Get Clear Screen Color
StyleGetDateFormat | Function to get date format
StyleGetFrameInitData | Function to get frame initialization data
StyleGetFrameInitData | Function to get frame initialization data
StyleGetMessageboxColor | Function to get control Messagebox color
StyleGetMessageboxColor | Function to get control Messagebox color
StyleGetNavToken | Function to get navigation token
StyleGetNavToken | Function to get navigation token
StyleGetPageFrames | Function to number of frames
StyleGetPageFrames | Function to number of frames
StyleGetPageFrames | Function to number of frames
StyleGetPageFrames | Function to number of frames
StyleGetPageLinkColor | Function to PageLink (Submenu) color
StyleGetScrollBarColor | Function to get scrollbar color
StyleGetScrollBarColor | Function to get scrollbar color
StyleGetScrollBarDownArrowColor | Function to get scrollbar downarrow color
StyleGetScrollBarDownArrowColor | Function to get scrollbar downarrow color
StyleGetScrollBarUpArrowColor | Function to get scrollbar UpArrow Color
StyleGetScrollBarUpArrowColor | Function to get scrollbar UpArrow Color
StyleGetScrollBehavior | Function to get scroll behavior
StyleGetScrollBehavior | Function to get scroll behavior
StyleGetShadowSupport | Function to get shadow support
StyleGetShadowSupport | Function to get shadow support
StyleGetSpecialColor | Function to get control special color
StyleGetSpecialColor | Function to get control special color
StyleGetStdMaxCols | Function to get max number of rows
StyleGetStdMaxCols | Function to get max number of rows
StyleGetStdMaxRows | Function to max number of columns
StyleGetStdMaxRows | Function to max number of columns
StyleGetTextMode | Function to get text mode
StyleGetTextMode | Function to get text mode
StyleGetWindowColor | Function to get window color
StyleGetWindowColor | Function to get window color
StyleHandleControlOverflow | Function to handle control overflow
StyleHandleControlOverflow | Function to handle control overflow
StyleHelpAreaScrollable | Function to get Help area scroll support
StyleInit | Function to Initialize style
StyleInit | Function to Initialize style
StyleInitializeFrame | Function to Initialize frame
StyleInitializeFrame | Function to Initialize frame
StyleLabelCallback | Function to set label callback
StyleLanguagePage | Function to set Language page
StyleOverRideComponent | Function to override component or control functionality
StyleOverRideComponent | Function to override component or control functionality
StylePageItemFocus | This function is called whenever a user navigates to a new page. OEMs may use this hook to set item focus. The default behavior sets focus to the previously focused page item.
StylePageItemFocus | This function is called whenever a user navigates to a new page. OEMs may use this hook to set item focus. The default behavior sets focus to the previously focused page item.
StyleSelectFirstDisplayPage | Function to set the first display page
StyleSelectFirstDisplayPage | Function to set the first display page
StyleShowDay | Function to show day in date format
StyleSubPageItemFocus | This function is called whenever a user returns (or navigates back) from a submenu page causing a complete page redraw. OEMs may use this hook to set item focus. The default behavior sets focus to the previously focused page item.
StyleSubPageItemFocus | This function is called whenever a user returns (or navigates back) from a submenu page causing a complete page redraw. OEMs may use this hook to set item focus. The default behavior sets focus to the previously focused page item.
StyleUpdateFrameStrings | Function to update frame strings
StyleUpdateFrameStrings | Function to update frame strings
StyleUpdateVersionString | Function to set the version string
StyleUpdateVersionString | Function to set the version string
SubMenuCreate | this function uses the create function of control and create submenu.
SubMenuDestroy | this function uses the destroy function of control and destroys submenu.
SubMenuDraw | function to draw a sub-menu.
SubMenuGetControlHeight | Function to get the label height of the submenu
SubMenuHandleAction | function to handle the submenu actions
SubMenuSetAttributes | Function to set attributes.
SubMenuSetCallback | function to handle the submenu actions
SubMenuSetDimensions | Function to set dimension.
SubMenuSetFocus | Function to handle the submenu actions
SubMenuSetPosition | Function to set position.
SupportPrintScreen | function to support the print screen.
SupportPrintScreenEvent | function to Check the print screen supprot event.
SwapBuffer | Swap bytes in the buffer.

Data Structure | Description
SCROLLBAR_BGCOLOR | Background color of the Scroll bar (Default PAGE_BGCOLOR)
SCROLLBAR_DOWNARROW_BGCOLOR | Background color of the Scroll bar Down-Arrow (Default PAGE_BGCOLOR)
SCROLLBAR_DOWNARROW_FGCOLOR | Foreground Color of the Scroll bar Down-Arrow (Default PAGE_FGCOLOR)
SCROLLBAR_FGCOLOR | Foreground Color of the Scroll bar (Default PAGE_FGCOLOR)
SCROLLBAR_UPARROW_BGCOLOR | Background color of the Scroll bar Up-Arrow (Default PAGE_BGCOLOR)
SCROLLBAR_UPARROW_FGCOLOR | Foreground Color of the Scroll bar Up-Arrow (Default PAGE_FGCOLOR)
SELECTED_MENU_BGCOLOR | Background color of the Selected Menu in the Menu bar frame
SELECTED_MENU_FGCOLOR | Foreground Color of the Selected Menu in the Menu bar frame
SETUP_FORM_BROWSER_SUPPORT | 1 => Installs form browser protocol should turn on SETUP_RUNTIME_IFR_PROCESSING. 0 => Does not install form browser protocol.
SETUP_FORM_BROWSER_SUPPORT | 1 => Installs form browser protocol should turn on SETUP_RUNTIME_IFR_PROCESSING. 0 => Does not install form browser protocol.
SETUP_LINK |
SETUP_OEM_SPECIAL_CONTROL_SUPPORT | Turn on to have OEM Special Control Support.
SETUP_STYLE_EZPORT | Condition to support Ezport Style Sources
SETUP_STYLE_FULL_SCREEN | Condition to support full screen layout
SETUP_USE_GRAPHICS_OUTPUT_PROTOCOL | 1 => Uses Graphics Output protocol. 0 => Uses UgaDraw protocol.
SETUP_USE_GUIDED_SECTION | Enable to have BCP compatibility in Aptio 3.x
STYLE_CONTROL_LEFT_MARGIN | Control column left margin
STYLE_CONTROL_LEFT_PAD | Control left padding
STYLE_CONTROL_RIGHT_AREA_WIDTH | Control column width
STYLE_FULL_MAX_COLS | Maximum columns in full screen mode
STYLE_FULL_MAX_ROWS | Maximum rows in full screen mode
STYLE_HOTKEY_FAILSAFE | Hot Key to load fail safe values
STYLE_LABEL_LEFT_MARGIN | Label column left margin in normal screen mode
STYLE_PAGE_FIRSTITEM_FOCUS | Reset focus to the first item when navigating to a new page. (Default 0 => Set focus to previously selected item)
STYLE_SCROLLBAR_ROLLOVER | Support rollover when the scroll limit has been reached
STYLE_SHADOW_SUPPORT | To enable/disable shadow support
STYLE_SPACEKEY_INCREMENT | To enable space key increment
STYLE_STD_MAX_COLS | Maximum columns in Standard mode
STYLE_STD_MAX_ROWS | Maximum rows in standard mode
STYLE_SUBPAGE_FIRSTITEM_FOCUS | Reset focus to the first item when navigating back from submenu. (Default 0 => Set focus to previously selected item)

Built on 16:20:02 10/01/14


Functions in Alphabetical Order

T

Function | Description
TextCreate | this function uses the create function of control and creates text
TextDestroy | this function uses the destroy function of control and destroys the text
TextDraw | function to draw the text with attributes.
TextGetControlHeight | function to get the text height
TextHandleAction | function to handle the text actions
TextSetAttributes | Function to set text attributes.
TextSetCallback | Function to set callback.
TextSetDimensions | Function to set text dimension.
TextSetFocus | Function to set focus.
TextSetPosition | Function to set position.
TextSetText | function to set the text
TimeCreate | this function uses the create function of control and creates and sets the timer
TimeDestroy | this function uses the destroy function of control and destroys the timer
TimeDraw | function to draw time with attributes
TimeGetControlHeight | Function to set time height.
TimeHandleAction | function to handle the actions of time
TimeInitialize | this function uses the Initialize function of control and initializes the time
TimerCreateTimer | function to create a timer event and to set the timer
TimerStopTimer | function to stop the timer event.
TimeSetAttributes | Function to set time attributes.
TimeSetCallback | Function to set callback.
TimeSetDimensions | Function to set time dimension.
TimeSetFocus | Function to set focus.
TimeSetPosition | Function to set position.
ToLower | Converts the unicode character of the string from uppercase to lowercase.
Transparency_Decode | To store the tRNS data values in PngPalette variables
TSE_SOFTKBD_GetButtonStatus | Function to return the mouse button status if it is over softkbd
TSE_SOFTKBD_GetMouseCoordinates | Function to return the mouse co-ordinates if it is over softkbd
TseBootNowinBootOrderInit | function build the AMI defaults
TseEfiCreateEventReadyToBoot | To avoid including EDK libs.
TseFramePwdCallbackIdePasswordUpdate | function to update the ide password
TSEGetactualScreentop | Function to retrun the actual Screen Top value
TSEGetCoordinates | Function to handle the mouse Destory
TSEGetNVVariable | reads the NV Varaiable from Nram buffer using NVLib.
TSEIsMouseClickedonSoftkbd | Function to handle the mouse Clicked on Softkbd
TSEIsMouseOnSoftkbd | Function to return whether MousePointer is on softkbd or not
TSELiteFixAddBootOptionFileList | Function to fix Add Boot Option file list
TSELiteFixBBSOrder | Fixes the BBS Order Orderlist.
TSELiteFixBootOrder | Fixes the Boot Order OrderList.
TSELiteFixBootOrderRide | Function to fix boot override
TseLiteIsSpecialOptionList | Function that decided to re evaluate the option list/Name from the Vfr. For TSE Special Controls it should return TRUE. for other controls it may return FALSE. For UEFI 2.0 it may return TRUE by default.
TSEMouseDestroy | Function to handle the mouse Destory
TSEMouseFrameHandleAction | Function to hadnle frame using mouse
TSEMouseFreeze | Function to handle the mouse Destory
TSEMouseHelpFrameHandleAction | Function to hadnle help frame using mouse
TSEMouseInit | Function to Initialize the mouse
TSEMouseListBoxHandleAction | Function to hadnle List Box using mouse
TSEMouseListBoxScrollBarMove | Adds scroll bar functionality for frames with many controls
TSEMouseMenuHandleAction | Function to hadnle Menu using mouse
TSEMouseMsgBoxHandleAction | Function to hadnle Message Box using mouse
TSEMouseReadInfo | Function to read the information using mouse
TSEMouseRefresh | Function to handle the mouse Refresh
TSEMouseScrollBarMove | Adds scroll bar functionality for frames with many controls
TSEMouseStart | Function to handle the mouse Startd
TSEMouseStop | Function to handle the mouse stop
TSENumericSoftKbdExit | Function to destroy the numeric softkbd display
TSENumericSoftKbdInit | Function to display the numeric softkbd
TsePasswordEncodeLocal | Function to encode the password string Parameter: CHAR16 *Password, UINTN MaxSize Return value: VOID
TsePopupPwdAuthenticateIDEPwd | Function to authenticate the IDE password
TsePopupPwdUpdateIDEPwd | function to update the IDE password
TSEPrintableKeysSoftKbdExit | function to exit PrintableKeysSoftkbd layout and reset with default keyboard layout
TSEPrintableKeysSoftKbdInit | function to launch PrintableKeysSoftkbd layout
TSEResetPwdKeyboardLayout | function to exit TSEResetKeyboardLayout and reset with default keyboard layout
TSESetPwdKeyboardLayout | function to Initialize TSESetKeyboardLayout
TseUpdateAddDeleteBootVar | Function to update add and delete boot variables
TseUpdateAddDeleteDriverVar | Function to update add and delete driver variables
TseVarBuildAMIDefaults | function build the AMI defaults

Data Structure | Description
TEXT_COLOR | Foreround color of text controls
TianoHII_SUPPORT | Switch to enable Tiano defined HII support in Project
TITLE_BGCOLOR | Background Color of the Title bar frame.
TITLE_FGCOLOR | Foreground Color of the Title bar frame
TITLE_FULL_H | Vertical Height of the Title bar frame
TITLE_FULL_W | Horizontal Width of the Title bar frame.
TITLE_FULL_X | X-Coordinate position of the Title bar frame. (Default 0)
TITLE_FULL_Y | Y-Coordinate position of the Title bar frame. (Default 0)
TITLE_H | Vertical Height of the Title bar frame
TITLE_W | Horizontal Width of the Title bar frame
TITLE_X | X-Coordinate position of the Title bar frame. (Default 0)
TITLE_Y | Y-Coordinate position of the Title bar frame. (Default 0)
TSE_ADVANCED_SUPPORT | Main switch to enable Ezport Style in TSE
TSE_BEST_HORIZONTAL_RESOLUTION | Set TSE standard Horizontal resolution. 800 is Standard horizontal resolution for TSE.
TSE_BEST_VERTICAL_RESOLUTION | Set TSE standard Vertical resolution. 600 is Standard Vertical resolution for TSE.
TSE_MAX_DRIVE_NAME | Set the value to dispaly number of characters for Drive name
TSE_NVRAM_DEFAULTS_SUPPORT | Turn on to use NVRAM module to get the default values.
TSE_SEPERATE_EFI_LEGACY_OPTIONS | Turn on to have EFI options and Legacy options seperate. This will have effect only if BDS also seperates EFI and Legacy options.
TSE_STYLE_EZPORT_SUPPORT | Main switch to enable Ezport Style in TSE
TSE_STYLE_SOURCES_SUPPORT | Don't Edit.
TSE_SUPPORT_VFRCOMPILE_1_88 | Turn on to support vfrcompiler version 1.88 and later
TSE_SUPPORT_VFRCOMPILE_1_88 | Turn on to support vfrcompiler version 1.88 and later
TSE_USE_EDK_LIBRARY | Turn on to Depend on the EDK Libraries, OFF makes use of Aptio Libaray
TseLite_SUPPORT | Main switch to enable TseLite sources support in Project

Built on 16:20:03 10/01/14


Functions in Alphabetical Order

U

Function | Description
Uefi20HiiChangeStringLanguage | function to change the language string
Uefi20HiiGetStringLanguage | function to get the language string
Uefi20HiiInitializeProtocol | function to Initialize the Hii protocol
Uefi21HiiGetStringLanguage | Returns the string for incoming token. If lang is valid then return string for this lang else return string for PlatformLang variable else return english string - default
UefiActionCreate | Function to create an Action Control.
UefiActionDraw | Function to draw an Action Control.
UefiActionHandleAction | Function to handle the Label actions.
UefiActionInitialize | Function to Initialize an Action Control.
UefiAddEndOp | Function to add end op code
UefiAddEndOp | Parameter: VOID *IfrPtr Return value: VOID
UEFICallSetupFormCallBack | Wrapper function for the Implementation of FormBrowser with actions support .This is used only in UEFI 2.1
UefiCreateDynamicControlCondition | Function to create dynamic control condition
UefiCreateDynamicControlCondition | Parameter: CONTROL_INFO *control,UINT16 VarId, UINT16 PrevControlQuestionID,UINT16 Value Return value: VOID
UefiCreateOneOfWithOptionsTemplate | Function to create OneOf option template
UefiCreateOneOfWithOptionsTemplate | Parameter: UINTN OptionCount, CONTROL_INFO *CtrlInfo Return value: VOID*
UefiCreateStringTemplate | Function to create uefi string template Parameter: UINT16 Token Return value: VOID *
UefiCreateStringTemplate | Function to create uefi string template Parameter: UINT16 Token Return value: VOID *
UefiCreateSubTitleTemplate | Function to prepare the template for sub-title
UefiCreateSubTitleTemplate | Parameter: UINT16 Token Return value: VOID *
UefiFormCallbackNVRead | Function to get callback nvread
UefiFormCallbackNVRead | Parameter: CHAR16 *name, EFI_GUID *guid, UINT32 *attributes, UINTN *size, VOID **buffer Return value: EFI_STATUS
UefiFormCallbackNVWrite | Function to get callback nvwrite
UefiFormCallbackNVWrite | Parameter: CHAR16 *name, EFI_GUID *guid, UINT32 attributes, VOID *buffer, UINTN size Return value: EFI_STATUS
UefiGetActionWapper | The Wrapper function to get the actual action for the driver Parameter: UINTN Action Return Value: EFI_BROWSER_ACTION
UefiGetActionWapper | The Wrapper function to get the actual action for the driver Parameter: UINTN Action Return Value: EFI_BROWSER_ACTION
UefiGetBaseValue | Function to get the base value
UefiGetBaseValue | Parameter: VOID *IfrPtr Return value: UINT8
UefiGetControlKey | Helper function in obtaining Control Key
UefiGetControlKey | Parameter: CONTROL_INFO *ControlData Return value: UINT16
UefiGetDateTimeDetails | Function to get the details of data and time
UefiGetDateTimeDetails | Parameter: VOID *IfrPtr,UINT8 Type,UINT16 * Help,UINT16 * Min,UINT16 * Max Return value: VOID
UefiGetEqIDQuestionID | Function to Check EqID question ID
UefiGetEqIDQuestionID | Parameter: VOID *IfrPtr Return value: UINT16
UefiGetFlagsField | to get the Flags field from ifr
UefiGetFlagsField | Parameter: VOID *IfrPtr Return value: UINT8
UefiGetHelpField | To get the specific help field
UefiGetHelpField | Parameter: VOID *IfrPtr Return value: UINT16
UefiGetIfrLength | Function to get the length of Ifr
UefiGetIfrLength | Parameter: VOID *IfrPtr Return value: UINT8
UefiGetKeyField | To get the Key field from ifr
UefiGetKeyField | Parameter: VOID *IfrPtr Return value: UINT16
UefiGetMaxEntries | Function to get max entries
UefiGetMaxEntries | Parameter: VOID *IfrPtr Return value: UINT8
UefiGetMaxValue | Function to get the max value
UefiGetMaxValue | Parameter: VOID *IfrPtr Return value: UINT64
UefiGetMinValue | Function to get the minimum value
UefiGetMinValue | Parameter: VOID *IfrPtr Return value: UINT64
UefiGetOneOfOptions | Function to get OneOf options
UefiGetOneOfOptions | Parameter: VOID *IfrPtr,VOID **Handle,UINT16 **OptionPtrTokens, UINT64 **ValuePtrTokens, UINT16 *ItemCount, UINT16 *Interactive,UINT16 *CallBackKey Return value: EFI_STATUS
UefiGetPromptField | To get the prompt field from ifr
UefiGetPromptField | Parameter: VOID *IfrPtr Return value: UINT16
UefiGetQuestionID | Function to get question ID
UefiGetQuestionID | Parameter: CONTROL_INFO *Control Return value: UINT16
UefiGetQuestionOffset | Function to get question offset
UefiGetQuestionOffset | Parameter: VOID *IfrPtr Return value: UINT16
UefiGetResetButtonDefaultid | In UEFI 2.0 this is Dummy function. Parameter: VOID *IfrPtr Return value: UINT16
UefiGetResetButtonDefaultid | Funtion get the ResetButton Default Id from the Opcode information Parameter: VOID *IfrPtr Return value: UINT16
UefiGetSpecialEqIDIfrPtr | Function to get special eqID Ifr pointer
UefiGetSpecialEqIDValue | Function to get special eqID value
UefiGetSpecialEqIDValue | Parameter: CONTROL_INFO *ControlInfo, GUID_INFO **GuidInfo Return value: UINT16
UefiGetStepValue | Function to get the step value
UefiGetStepValue | Parameter: VOID *IfrPtr Return value: UINT64
UefiGetTextField | Function to get the Text Field.
UefiGetTextField | Parameter: VOID *IfrPtr Return value: UINT16
UefiGetTextTwoField | Function to get the Text Field.
UefiGetTextTwoField | Parameter: VOID *IfrPtr Return value: UINT16
UefiGetTime | Function to get time Parameter: CONTROL_INFO *control, EFI_TIME *Tm Return value: STATUS
UefiGetTime | Function to get time Parameter: CONTROL_INFO *control, EFI_TIME *Tm Return value: STATUS
UefiGetTitleField | To get the Title field from ifr
UefiGetTitleField | Parameter: VOID *IfrPtr Return value: UINT16
UefiGetValidOptionSize | Function to get sizeof option.UEFI2.0 doesn't have EFI_IFR_TYPE support
UefiGetValidOptionType | Assuming all the options in this control has option with same type and length
UefiGetWidth | Function to get width
UefiGetWidth | Parameter: VOID *IfrPtr Return value: UINT16
UefiIsEfiVariable | Function to Check efi variable
UefiIsEfiVariable | Parameter: UINT32 variable, VARIABLE_INFO *varInfo Return value: BOOLEAN
UefiIsInteractive | To get Uefi Interactive
UefiIsInteractive | Parameter: CONTROL_INFO *ControlData Return value: BOOLEAN
UefiIsOneOfControl | Function to Check for OneOf controls
UefiIsOneOfControl | Parameter: VOID *IfrPtr Return value: BOOLEAN
UefiIsProceedWithPageChange | For UEFI 2.0 Just return EFI_SUCCESS; Parameter: EFI_STATUS Return Value: EFI_STATUS
UefiIsProceedWithPageChange | If the FormCallBack returns status is EFI_UNSUPPORTED or EFI_SUCCESS. Change page is allowed. Otherwise changeing of page should not happen For UEFI 2.0 Just return EFI_SUCCESS; Parameter: EFI_STATUS Return Value: EFI_STATUS
UefiLoadPreviousValuesforCurrentform | Loads previous value for the current form
UefiPreControlUpdate | In UEFI 2.0 this is Dummy function. Parameter: CONTROL_INFO * ControlData Return Value: EFI_STATUS
UefiPreControlUpdate | store the Control value before updating and calling the callback. Parameter: CONTROL_INFO * ControlData Return Value: EFI_STATUS
UefiRefershQuestionValueNvRAM | Function Refresh the question Parameter: CONTROL_INFO *control Return value: STATUS
UefiRefershQuestionValueNvRAM | Function to Refresh the questions Parameter: CONTROL_INFO *ControlData Return value: EFI_STATUS
UefiSetEqIDQuestionID | Function to set EqID question ID
UefiSetEqIDQuestionID | Parameter: VOID *IfrPtr, UINT16 Value Return value: VOID
UefiSetEqIDValue | Function to set EqID value
UefiSetEqIDValue | Parameter: VOID *IfrPtr, UINT16 Value Return value: VOID
UefiSetHelpField | To Set the specific help field
UefiSetHelpField | Parameter: VOID *IfrPtr,UINT16 Token Return value: VOID
UefiSetOneOfOption | Function to set OneOf option
UefiSetOneOfOption | Parameter: VOID *IfrPtr, UINT64 Value, UINT32 Size, UINT8 Flag, UINT16 Option Return value: VOID
UefiSetPromptField | Function to set the prompt Field.
UefiSetPromptField | Parameter: VOID *IfrPtr,UINT16 Token Return value: VOID
UefiSetSubTitleField | Function to Set the Sub-Title Field.
UefiSetSubTitleField | Parameter: VOID *IfrPtr,UINT16 Token Return value: VOID
UefiSetTime | Function to set time Parameter: CONTROL_INFO *control, EFI_TIME *Tm Return value: STATUS
UefiSetTime | Function to set time Parameter: CONTROL_INFO *control, EFI_TIME *Tm Return value: STATUS
UefiSetWidth | Function to set width
UefiSetWidth | Parameter: VOID *IfrPtr,UINT8 Width Return value: VOID
UefiSpecialGuidCallback | Function to get special guid callback
UefiSpecialGuidCallback | Parameter: VOID * HiiHandle, UINT16 Key, EFI_GUID *pGUID Return value: VOID
UefiTseLiteGetAmiCallbackIndex | Function to get ami callback index
UefiTseLiteGetAmiCallbackIndex | Parameter: VOID * Ptr Return value: UINT16
UefiTseLiteGetBootOverRideIndex | Function to get boot override index
UefiTseLiteGetBootOverRideIndex | Parameter: VOID *IfrPtr Return value: UINT16
UefiUpdateControlQuestionID | Parameter: VOID *IfrPtr, UINT16 Value Return value: VOID
UefiUpdateControlVarOffset | Function to update control variable offset
UefiUpdateControlVarOffset | Parameter: VOID *IfrPtr, UINT16 Value Return value: VOID
UefiupdateResetButtonDefault | In UEFI 2.0 this is Dummy function.
UefiupdateResetButtonDefault | Function to update defaults depending on the Default Id on Selecting the Reset Button
UefiVarGetNvram | Function to get nvram Parameter: VARIABLE_INFO *VariableInfo, VOID **Buffer, UINTN Offset, UINTN Size
UefiVarGetNvram | Parameter: VARIABLE_INFO *VariableInfo, VOID **Buffer, UINTN Offset, UINTN Size Return value: EFI_STATUS
UefiVarSetNvram | Parameter: VARIABLE_INFO *VariableInfo, VOID *Buffer, UINTN Offset, UINTN Size Return value: EFI_STATUS
UefiVarsetnvramforCurrentform | Save the values for the passed pageID If this function is not called as part of browser action then it is caller responsibility to reset the gProFormOffset and gProcessedForms gProFormOffset = 0; MemSet (gProcessedForms, MAX_FORMS_TO_PROCESS, 0);
UIUpdateCallback | UI callback function for dynamic form updates.
Uncompress | Used to Uncompress the Image data and to convert the RGB format.
UnicodeToConfigString | Convert Unicode string to binary representation Config string, e.g. "ABCD" => "0041004200430044". Config string appears in <ConfigHdr> (i.e. "&NAME=<string>"), or Name/Value pair in <ConfigBody> (i.e. "label=<string>").
UninstallBGRT | UninstallsBGRT table, Called for Legacy Boot
UnInstallFormBrowserProtocol | Uninstalls the Formbrowser Protocol in the given handle if SETUP_FORM_BROWSER_SUPPORT is on.
UnInstallFormBrowserProtocol | UnInstall FormBrowser Protocol Parameter: EFI_HANDLE Handle Return value:VOID
UninstallProtocol | This function uninstalls different protocols exported.
UnRegFormNotification | Unregisters the form notification Parameter: VOID Return value: VOID
UnRegFormNotification | Unregisters the form notification Parameter: VOID Return value: VOID
UnRegisterFormNotification | Notification UnRegistering Function Parameter: EFI_HANDLE *NotifyHandle Return value: EFI_STATUS EFI_SUCCESS
UpdateBootVariables | Update the BootOrder,BBSOrder Cache From the NVRAM.
UpdateBootVariables | Dummy function for UpdateBootVariables
Updatedefaults | Function to update defsaults
UpdateDestiantionQuestion | Dummy function for 2.0
UpdateDestiantionQuestion | Finds the destination question ID for the current destination
UpdateDriverVariables | Update the DriverOrder Cache From the NVRAM.
UpdateDriverVariables | Dummy function for UpdateDriverVariables
UpdateFilePathString | To create the File Path string based on the file selected.
UpdateFinalCondition | To finalize the codition flag
UpdateGoPUgaDraw | function to update the Gop when controls comes to TSE.
UpdategScreenParams | Verifies and corrects the gScreen params with the current uni strings
UpdateIFRRefXControls | Updates the reference link information in for the EFI_IFR_REFX controls
UpdateLegacyDevVariable
UpdateLegacyDevVariable | Update the LegacyDev variable with Device count in each BBS type
UpdateNVDefautls | Updated the Variable buffer with NVRam Defaults buffer.
UpdateOrderlistcount | Function to update the orderlist count.
UpdatePageFocusedItemHelp | function to update the Help in case of First Item focus set.
UpdatePasswordToNonCaseSensitive | function to update the given password to non case sensitive
UpDisplayList | function to display the upside list

Data Structure | Description
UEFI_2_0_SUPPORT | Main switch to enable UEFI 2.0 sources support in Project
UEFI_HII_2_1_SUPPORT | Main switch to enable UEFI 2.1 sources support in Project

Built on 16:20:03 10/01/14


Functions in Alphabetical Order

V

Function | Description
VarBuildDefaults | function to build the default variables
VarGetDefaults | Function to get var defaults
VarGetNvram | function to get the NvRam varible names
VarGetNvramName | function to get the NvRam Variable Name
VarGetNvramQuestionValue | Gets the question value buffer from a specific offset of a variable buffer
VarGetValue | Function to get var value
VarGetVariableInfoId | function to get the ID of the variable information
VarGetVariableInfoIndex | Function to get variable info index
VarLoadVariables | function to load the variables
VarSetNvram | function to set the NvRam varible names
VarSetNvramName | function to Set the NvRam Variable Name
VarSetValue | Function to set variable value
VarUpdateDefaults | Function to update variable defaults
VarUpdateVariable | Function to update variable
VSPrint | VSPrint function to process format and place the results in Buffer. Since a VA_LIST is used this rountine allows the nesting of Vararg routines. Thus this is the main print working routine

Data Structure | Description
VERTICAL_MAIN_DIVIDER | Vertical divider (border) position between the MainFrame window and (helper and Navigation) frame windows.

Built on 16:20:03 10/01/14


Functions in Alphabetical Order

W

Function | Description
Wcscmp | To avoid including EDK libs.
Wcscpy | To avoid including EDK libs.
Wcslen | To avoid including EDK libs.
WriteDataToFile | Writes data to file
WritePackToFile | Writes Hpk data to file
writepixel | Write a pixel at (X,Y) on the screen.

Built on 16:20:03 10/01/14


General Information

Header | Description
Driver_Integration | * This is the case adding a new driver into an Aptio project. If driver source code is available, add the driver source and rebuild the project. * Verify all the protocols used are present in the project * Make sure the dependencies are compatible between driver and project * The new setup page can only appear as top level menu item * In case only binary form is available, next are requirements, * The adding driver must have a unique GUID from the project * If the adding driver uses platform variables, make sure the setup definition in the project and the adding driver is completely identical * If private variables are used, make sure it has a different GUID and variable names are unique * Both the driver’s DXE and HPK files are required to put into the project * Use Setup.ini to indicate the location of driver setup page * It’s impossible the new page to be a submenu of an existing page
HII_Package_files | Aptio TSE performs a Post-processing of the information that will be stored into HII and saves the result into a separate section of the driver in order to allow Post-build configuration. This requires that the HII Package files, created by Intel’s VFRCOMPILE utility, be generated as inputs to the Aptio TSE build. These files are generated based on a command line parameter to the VFRCOMPILE utility. This command line can be specified using the VFRCOMPILE_FLAGS SDL token. This SDL token must be set to "-ibin" in order to generate the HPK files.
How_to_add_a_page | Adding a page to a VFR is quite simple. There are 2 pieces that make up a new page: the reference to the page from an existing page, and the new page definition itself: // inside an existing form goto MY_SETUP_FORM_ID, prompt = STRING_TOKEN(STR_MY_SETUP_PAGE), help = STRING_TOKEN(STR_MY_SETUP_PAGE_HELP); // after all form definitions form formid = MY_SETUP_FORM_ID, title = STRING_TOKEN(STR_MY_SETUP_PAGE); subtitle text = STRING_TOKEN(STR_SOME_TEXT_STRING); // additional controls go here endform;
How_to_display_a_dynamic_value | Dynamic text is fully supported by TSE. Creating and modifying dynamic text needs to follow certain rules. A dynamic text control is simply a TEXT VFR control with the INTERACTIVE flag set to true. In this case, the FORM_CALLBACK.Callback function is called every 100ms to refresh the contents of the displayed control. It is the requirement of the callback routine to update the string in the HII database with the new value to be displayed. The callback interval can be managed in multiple ways. It can be changed in the setup data using a tool such as AMIBCP. It can also be managed programmatically in the callback routine itself. Example: #define CPU1_TEMP_KEY 0x1234 text help = STRING_TOKEN(STR_NULL_STRING), text = STRING_TOKEN(STR_CPU1_TEMP_PROMPT), text = STRING_TOKEN(STR_CPU1_TEMP_VAL), flags = INTERACTIVE, key = CPU1_TEMP_KEY; This definition into the VFR file will automatically cause TSE to create a dynamic text control. It is the responsibility of the callback routine (most likely published by a separate DXE driver) to update the temperature data. Sample pseudo-code for the callback is listed below: CHAR16 gUpdateString[256]; EFI_STATUS Callback( ..., UINT16 key, ... ) { switch ( key ) { case CPU1_TEMP_KEY : UINT16 stringRef = STRING_TOKEN(STR_CPU1_TEMP_VAL); UINTN cpuTemp = GetCPUTemp( CPU1 ); SPrint( gUpdateString, sizeof( gUpdateString ), L"%d", cpuTemp ); // this call to NewString replaces the string in HII HII->NewString( HII, L"eng", handle, &stringRef, gUpdateString ); break; } }
How_to_display_message_in_the_POST_screen | TSE publishes a function called DisplayPostMessage as part of AMI_POST_MANAGER (formerly MRE_HAND_SHAKE) protocol. Other drivers can use this function to display UNICODE strings in Post screen. Prototype for DisplayPostMessage is provided in AMIPostMgr.h typedef EFI_STATUS (EFIAPI *AMI_POST_MANAGER_DISPLAY_MESSAGE) ( CHAR16 *Message typedef struct _AMI_POST_MANAGER_PROTOCOL { AMI_POST_MANAGER_HANDSHAKE Handshake; AMI_POST_MANAGER_DISPLAY_MESSAGE DisplayPostMessage; }AMI_POST_MANAGER_PROTOCOL;
How_to_display_value_which_may_change_from_boot_to_boot | Changing strings can be accomplished through a couple of different means. One, which is used for such facilities as memory sizing and hard drive identification, is to update a string into HII that has been put there as a placeholder. For example, a memory VFR might look like: text help = STRING_TOKEN(STR_NULL_STRING), text = STRING_TOKEN(STR_TOTAL_MEMORY_SIZE_PROMPT), text = STRING_TOKEN(STR_MEMORY_SIZE_VAL), flags = 0, key = 0; In the firmware, there will be code that updates the place holder string STR_MEMORY_SIZE_VAL with the actual string for the size. For example, CHAR16 string[20] ; SPrint( string, 20, L"%dMB", memosrySize ) ; Hii->AddString( Hii, &token, string ) ; This can also be accomplished in concert by code into the firmware and the VFRs themselves. First, a structure should be defined into which the data to be shared is stored. Then, along with a name and GUID, a volatile EFI variable my be defined. This is accomplished by setting the variable WITHOUT the EFI_VARIABLE_NON_VOLATILE flag. // inside a firmware driver Status = gRT->SetVariable( L"MyVariable", &myGuid, EFI_VARIABLE_BOOTSERVICE_ACCESS, &myVariableStruct, sizeof(myVariableStruct) Into the VFR, a varstore must be created (similar to the one above) and used to access this variable.
How_to_gray_out_or_suppress_a_control | The following example shows how to gray out or suppress a control from within the VFR definition file. grayoutif ideqval SYSTEM_ACCESS.Access == SYSTEM_PASSWORD_USER; oneof varid = SetupMap.IdeMode, prompt = STRING_TOKEN(STR_IDE_MODE_PROMPT), help = STRING_TOKEN(STR_IDE_MODE_HELP), option text = STRING_TOKEN(STR_DISABLE), value = 0, flags = RESET_REQUIRED; option text = STRING_TOKEN(STR_ENABLE), value = 1, flags = DEFAULT | RESET_REQUIRED; endoneof; endif;
How_to_integrate_an_EFI_application | Integrating an EFI application into the setup data is very simply done, using AMI’s extensions. There are multiple steps involved in creating a launch, but none involve modifying source code. First, define your variable store within your VFR file. The actual structure of the variable store is not used, so we simply define a basic structure: typedef struct _MY_OEM_PACK { UINT16 Value; } MY_OEM_PACK; varstore MY_OEM_PACK, key = MY_OEM_PACK_KEY_ID, name = application.efi, guid = MY_OEM_PACK_GUID; The important things to keep in mind with the above definitions are that the GUID and the key uniquely identify your application. Next, define VFR entry as follows. It will always be a reference wrapped by a suppress clause: // compare against a non-zero value so the suppress condition will fail. suppressif ideqval MY_OEM_PACK.Value == 1; // OEM_FORM_ID can be either an empty form defined elsewhere in the VFR // or the containing form’s formid value goto OEM_FORM_ID, prompt = STRING_TOKEN(STR_MY_OEM_APPLICATION), help = STRING_TOKEN(STR_MY_APPLICATION_HELP); endif; Last step is to define your behavior into the SETUP.INI file so that TSE will understand the overridden HII construct. [GUIDx] ; where x is the next available GUID number in the file guid = XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX name = unused key = XXXX ; this should be the same key value defined in the varstore flags = 6 ; these are the flags that tell what the action to perform is ; the values can be Ored togeteher to create multiple actions: ; 1 – signifies that the callback is AMI internal ; 2 – the GUID is treated as a filename in FV and launched ; 4 – the name defined in the varstore is treated as an EFI ; executable name and is launched from the filesystem ; Using 4 and 2 together will try FV first, then filesystem
How_to_provide_Default_boot_order | To have this functionality; on every boot in addition to creating / updating "BootOrder" and "LegacyDevOrder" variables based on the addition and removal of boot devices; BDS should also create / update the variables "DefaultBootOrder" and "DefaultLegacyDevOrder". "DefaultBootOrder" and "DefaultLegacyDevOrder" are variables introduced to provide TSE with the default ordering of devices. TSE displays these default orders when the user is loading optimal defaults. Details of default boot order variable VariableName: "DefaultBootOrder" Guid: 45cf35f6-0d6e-4d04-856a-0370a5b16f53 Details of default legacy device order variable VariableName: "DefaultLegacyDeviceOrder" Guid: 3c4ead08-45ae-4315-8d15-a60eaa8caf69 PS: If these variables are not present TSE will load the values of the BootOrder and LeagacyDevOrder variables it entered with as default values
How_To_Switch_to_different_Style | Clone and change the following SDL token settings. Ezport Style TSE_STYLE_EZPORT_BIN_SUPPORT = ON TSE_STYLE_EZPORT_SUPPORT = ON TSE_STYLE_LEGACY_BIN_SUPPORT = OFF TSE_STYLE_LEGACY_SUPPORT = OFF TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = OFF TSE_STYLE_EZPORTPLUS_SUPPORT = OFF Legacy Style TSE_STYLE_EZPORT_BIN_SUPPORT = OFF TSE_STYLE_EZPORT_SUPPORT = OFF TSE_STYLE_LEGACY_BIN_SUPPORT = ON TSE_STYLE_LEGACY_SUPPORT = ON TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = OFF TSE_STYLE_EZPORTPLUS_SUPPORT = OFF EzportPlus Style TSE_STYLE_EZPORT_BIN_SUPPORT = OFF TSE_STYLE_EZPORT_SUPPORT = OFF TSE_STYLE_LEGACY_BIN_SUPPORT = OFF TSE_STYLE_LEGACY_SUPPORT = OFF TSE_STYLE_EZPORTPLUS_BIN_SUPPORT = ON TSE_STYLE_EZPORTPLUS_SUPPORT = ON
Image_formats | The OEM logo image that is used in Aptio TSE is BMP and GIF format. Future versions will support other image formats (like PCX and JPG). There are no color depth restrictions for this image. The image cannot be an RLE encoded bitmap or otherwise compressed bitmap. Compression is referring to image compression as defined by the BMP format, not EFI compression. The image is designed to fit into a specified area of the screen. The dimensions of the image file should be set accordingly. The default image dimensions are listed below, SmLogo: 400x100
Localization | One of the many features of Aptio, is the ability to easily work with multiple languages. Aptio TSE is no exception. Aptio TSE uses the exact same .UNI string management as the Aptio project itself.
Post | Any of the images associated with Aptio can be modified after the firmware has been built using the AMI ChangeLogo tool. The rendering information may be modified together with other information like Optimal and Failsafe values may be customized after the firmware has been built using the AMIBCP tool.
Setup_path_in_MINISETUP | Since Aptio TSE accesses the default setup NVRAM storage directly, it is important that the correct layout of the NVRAM variable is known by TSE. This requires TSE to include the SetupVariable.h header file specific to the current project. This header file will be located in the SAME directory where the setup .VFR files are kept. The SETUP_PATH variable in the MINISETUP.MAK must match the path, relative to the root of the Aptio project. For example, for an Intel D865GCH R6-based Aptio project, this should be set as follows, SETUP_PATH = Platform\IntelDpg\D865GCH\DXE\D865GCHPlatform\Setup
TSE_FAQ | Q: The strings do not show up on the screen. A: There are several possible solutions to this problem. There could be an issue with the VFR creation. TSE expects each formset in the VFR files to have the same GUID but unique CLASS and SUBCLASS identifiers. There could be strings that are not defined into the .UNI file. This is unlikely as this would be caught during the build process. Q: Setup doesn't find any of my pages. A: Make sure that the GUID defined for your formsets matches the GUID defined into the main section of the SETUP.INI file. Q: How do I use multiple variables? A: TSE fully supports multiple variables defined into the VFR files. But, there is a caveat. The default variable (usually defined using the formset GUID and the name "Setup") must also be re-defined. This is a workaround for a faulty VFR compiler. These variables should be defined using the VFR command varstore. See the previous section for examples of how to use the varstore command. Q: How do I use the reference VFR files that are included into the TSE package? A: These VFR files are used in exactly the same way the platform VFR files are used. There are a couple of things that need to be modified into the platform code to install them. The .CIF file that includes the VFR files for the platform should be modified to reflect the new files. The file PLATFORM.C should be modified to install the new HII packs into the HII database. This includes defining new variables for the new VFR binaries, adding these binaries to the function call that installs the HII packs, etc. The VFR files should be copied to the platform setup directory to be included into the build process.

Built on 16:20:23 10/01/14


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2011 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.