American Megatrends, Inc.

Default Secure Boot Variables

Copyright

Release Notes

© American Megatrends, Inc.


Release Notes - NDA Required

Information:

Component Name: Default Secure Boot Variables.

Component Type: ModulePart of Secure Boot eModule

Date: 05-14-2015

Component Description:

This module contains 5 Secure Boot Variables (PK, KEK, db, dbx & dbt) and Aptio 4 Build rules to include each separate Variable file as FFS into Aptio Firmware Volume

Component usage guide

Current module includes 5 Secure Boot Variables in a binary format.

Below is the list of Default Secure Boot variables with the Key certificates and brief description (# - number of certificates inside a variable)

PK (Platform Key)

#1 “DO NOT TRUST - AMI Test PK0”.

Test Platform Key

Note: AMI Test Key must be replaced with OEM defined PK

KEK (Key Exchange Key)

#1 "Microsoft Corporation KEK CA 2011".

The Microsoft KEK certificate: http://www.microsoft.com/pkiops/certs/MicCorKEKCA2011_2011-06-24.crt

db (Good Signature Database)

#1 "Microsoft Windows Production PCA 2011"

http://www.microsoft.com/pkiops/certs/MicWinProPCA2011_2011-10-19.crt.

The Certificate must be present in order for Microsoft Windows 8 to boot.

#2 “Microsoft Corporation UEFI CA 2011”

http://www.microsoft.com/pkiops/certs/MicCorUEFCA2011_2011-06-27.crt

The Certificate allows UEFI drivers and applications from 3’rd parties to run on the system without requiring additional steps for the user.

dbx (Forbidden Signature Database)

#1 SHA256 Certificate containing SHA-256 hash of “0” with dummy Owner GUID- used as dummy placeholder for Forbidden Database - dbx

#13 SHA256 Certificates with the hashes, that have already been revoked (file is available here: http://www.uefi.org/revocationlistfile).

“dbx” is required to be present in all MS Win10 ready out-of-box systems

dbt (Authorized TimeStamp Signature Database)

#1 Microsoft Corporation “Microsoft Time-Stamp PCA” Certificate. Used as a placeholder for dbt database.

Release History:

05/14/2015: replaced dbx with one recommended by MS Win10 to pass Secure Boot logo test

07/25/2013: Add build rules to include “dbt” Variable

03/06/2013:

1. Update PK Key with expiration on 3/06/2017

2. PK and KEK variables don't include PKCS#7 signature in AuthHdr to minimize var's size in FV

3. db and dbx vars are signed with new PK

© American Megatrends Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

Built on 09:21:09 05/14/15


Functions in Alphabetical Order

AMIBIOS Function Reference

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

Built on 09:21:09 05/14/15


AMIBIOS Function Reference

General Information

Built on 09:21:09 05/14/15


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2015 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.