American Megatrends, Inc.

ReleaseNotes

Copyright

Release Notes

© American Megatrends, Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel CPPC
Component Reference Name: Intel CPPC
Component Type: eModule
Release Date: 2012-04-25
Source Control Label: 4.6.5.3_CPPC-RC_055_000
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/CPPC;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_055_004 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel CPPC initialization.
This is a caption
Filename | Description
Cppc.cif | Intel CPPC eModule CIF file.
Cppc.sdl | Intel CPPC eModule SDL file.
ReleaseNotes.chm | Intel CPPC eModule CHM file.

ModulePart Name:CppcDxe
ModulePart Description:Intel CPPC Dxe Component.
Filename | Description
CppcDxe.cif | Intel CPPC Dxe CIF file.
CppcDxe.sdl | Intel CPPC Dxe parameters.
CppcDxe.mak | Intel CPPC Dxe make file.
Cppc.c | Intel CPPC Dxe C code.
Cppc.dxs | Intel CPPC Dxe dependency file.
Cppc.h | Intel CPPC Dxe porting functions and data structures definition.
Cppc.inf | Intel CPPC Dxe inf file.
ModulePart Name:CppcAcpiTables
ModulePart Description:Intel CPPC Acpi Tables Component.
Filename | Description
CppcAcpiTables.cif | Intel CPPC AcpiTables CIF file.
CppcAcpiTables.sdl | Intel CPPC AcpiTables parameters.
CppcAcpiTables.mak | Intel CPPC AcpiTables make file.
Cppc.asl | Intel CPPC AcpiTables asl file.
CppcDebug.asl | Intel CPPC AcpiTables asl file.
CpuPm.asl | Intel CPPC AcpiTables asl file.
Pcct.asl | Intel CPPC AcpiTables asl file.
CppcAcpiTables.inf | Intel CPPC AcpiTables asl file.
ModulePart Name:CppcGuidLib
ModulePart Description:Intel CPPC GuidLib Component.
Filename | Description
CppcGuidLib.cif | Intel CPPC GuidLib CIF file.
CppcGuidLib.sdl | Intel CPPC GuidLib parameters.
CppcGuidLib.mak | Intel CPPC GuidLib make file.
CppcGuidLib.inf | Intel CPPC GuidLib inf file.
CppcAcpiTableStorage.c | Intel CPPC GuidLib GUID definition.
CppcAcpiTableStorage.h | Intel CPPC GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel CPPC Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:

© American Megatrends Inc.


Component Information:
Component Title: Intel CPPC
Component Reference Name: Intel CPPC
Component Type: eModule
Release Date: 2012-05-14
Source Control Label: 4.6.5.3_CPPC-RC_056_001
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/CPPC;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_056_005 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel CPPC initialization.
This is a caption
Filename | Description
Cppc.cif | Intel CPPC eModule CIF file.
Cppc.sdl | Intel CPPC eModule SDL file.
ReleaseNotes.chm | Intel CPPC eModule CHM file.

ModulePart Name:CppcDxe
ModulePart Description:Intel CPPC Dxe Component.
Filename | Description
CppcDxe.cif | Intel CPPC Dxe CIF file.
CppcDxe.sdl | Intel CPPC Dxe parameters.
CppcDxe.mak | Intel CPPC Dxe make file.
Cppc.c | Intel CPPC Dxe C code.
Cppc.dxs | Intel CPPC Dxe dependency file.
Cppc.h | Intel CPPC Dxe porting functions and data structures definition.
Cppc.inf | Intel CPPC Dxe inf file.
ModulePart Name:CppcAcpiTables
ModulePart Description:Intel CPPC Acpi Tables Component.
Filename | Description
CppcAcpiTables.cif | Intel CPPC AcpiTables CIF file.
CppcAcpiTables.sdl | Intel CPPC AcpiTables parameters.
CppcAcpiTables.mak | Intel CPPC AcpiTables make file.
Cppc.asl | Intel CPPC AcpiTables asl file.
CppcDebug.asl | Intel CPPC AcpiTables asl file.
CpuPm.asl | Intel CPPC AcpiTables asl file.
Pcct.asl | Intel CPPC AcpiTables asl file.
CppcAcpiTables.inf | Intel CPPC AcpiTables asl file.
ModulePart Name:CppcGuidLib
ModulePart Description:Intel CPPC GuidLib Component.
Filename | Description
CppcGuidLib.cif | Intel CPPC GuidLib CIF file.
CppcGuidLib.sdl | Intel CPPC GuidLib parameters.
CppcGuidLib.mak | Intel CPPC GuidLib make file.
CppcGuidLib.inf | Intel CPPC GuidLib inf file.
CppcAcpiTableStorage.c | Intel CPPC GuidLib GUID definition.
CppcAcpiTableStorage.h | Intel CPPC GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel CPPC Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_CPPC-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel CPPC
Component Reference Name: Intel CPPC
Component Type: eModule
Release Date: 2012-07-02
Source Control Label: 4.6.5.3_CPPC-RC_060_002
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/CPPC;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_060_007 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel CPPC initialization.
This is a caption
Filename | Description
Cppc.cif | Intel CPPC eModule CIF file.
Cppc.sdl | Intel CPPC eModule SDL file.
ReleaseNotes.chm | Intel CPPC eModule CHM file.

ModulePart Name:CppcDxe
ModulePart Description:Intel CPPC Dxe Component.
Filename | Description
CppcDxe.cif | Intel CPPC Dxe CIF file.
CppcDxe.sdl | Intel CPPC Dxe parameters.
CppcDxe.mak | Intel CPPC Dxe make file.
Cppc.c | Intel CPPC Dxe C code.
Cppc.dxs | Intel CPPC Dxe dependency file.
Cppc.h | Intel CPPC Dxe porting functions and data structures definition.
Cppc.inf | Intel CPPC Dxe inf file.
ModulePart Name:CppcAcpiTables
ModulePart Description:Intel CPPC Acpi Tables Component.
Filename | Description
CppcAcpiTables.cif | Intel CPPC AcpiTables CIF file.
CppcAcpiTables.sdl | Intel CPPC AcpiTables parameters.
CppcAcpiTables.mak | Intel CPPC AcpiTables make file.
Cppc.asl | Intel CPPC AcpiTables asl file.
Pcct.asl | Intel CPPC AcpiTables asl file.
Cpc.asl | Intel CPPC AcpiTables asl file.
CppcAcpiTables.inf | Intel CPPC AcpiTables asl file.
ModulePart Name:CppcGuidLib
ModulePart Description:Intel CPPC GuidLib Component.
Filename | Description
CppcGuidLib.cif | Intel CPPC GuidLib CIF file.
CppcGuidLib.sdl | Intel CPPC GuidLib parameters.
CppcGuidLib.mak | Intel CPPC GuidLib make file.
CppcGuidLib.inf | Intel CPPC GuidLib inf file.
CppcAcpiTableStorage.c | Intel CPPC GuidLib GUID definition.
CppcAcpiTableStorage.h | Intel CPPC GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel CPPC Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_CPPC-RC_056_001
4.6.5.3_CPPC-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel CPPC
Component Reference Name: Intel CPPC
Component Type: eModule
Release Date: 2012-07-27
Source Control Label: 4.6.5.3_CPPC-RC_060_003
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/CPPC;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_060_007 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel CPPC initialization.
This is a caption
Filename | Description
Cppc.cif | Intel CPPC eModule CIF file.
Cppc.sdl | Intel CPPC eModule SDL file.
ReleaseNotes.chm | Intel CPPC eModule CHM file.

ModulePart Name:CppcDxe
ModulePart Description:Intel CPPC Dxe Component.
Filename | Description
CppcDxe.cif | Intel CPPC Dxe CIF file.
CppcDxe.sdl | Intel CPPC Dxe parameters.
CppcDxe.mak | Intel CPPC Dxe make file.
Cppc.c | Intel CPPC Dxe C code.
Cppc.dxs | Intel CPPC Dxe dependency file.
Cppc.h | Intel CPPC Dxe porting functions and data structures definition.
Cppc.inf | Intel CPPC Dxe inf file.
ModulePart Name:CppcAcpiTables
ModulePart Description:Intel CPPC Acpi Tables Component.
Filename | Description
CppcAcpiTables.cif | Intel CPPC AcpiTables CIF file.
CppcAcpiTables.sdl | Intel CPPC AcpiTables parameters.
CppcAcpiTables.mak | Intel CPPC AcpiTables make file.
Cppc.asl | Intel CPPC AcpiTables asl file.
Pcct.asl | Intel CPPC AcpiTables asl file.
Cpc.asl | Intel CPPC AcpiTables asl file.
CppcAcpiTables.inf | Intel CPPC AcpiTables asl file.
ModulePart Name:CppcGuidLib
ModulePart Description:Intel CPPC GuidLib Component.
Filename | Description
CppcGuidLib.cif | Intel CPPC GuidLib CIF file.
CppcGuidLib.sdl | Intel CPPC GuidLib parameters.
CppcGuidLib.mak | Intel CPPC GuidLib make file.
CppcGuidLib.inf | Intel CPPC GuidLib inf file.
CppcAcpiTableStorage.c | Intel CPPC GuidLib GUID definition.
CppcAcpiTableStorage.h | Intel CPPC GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel CPPC Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
[EIP] 95470
[TAG] None
[Category] Bug Fix
[Severity] Normal
[Symptom] Cpc and Pcct table not find in ACPI SSDT table.
[Solution] Update CppcAcpiTables.mak to improve.
[Files] CppcAcpiTables.mak, CppcAcpiTables.sdl, Cppc.cif
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_CPPC-RC_060_002
4.6.5.3_CPPC-RC_056_001
4.6.5.3_CPPC-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel CPPC
Component Reference Name: Intel CPPC
Component Type: eModule
Release Date: 2012-08-14
Source Control Label: 4.6.5.3_CPPC-RC_061_004
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/CPPC;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel CPPC initialization.
This is a caption
Filename | Description
Cppc.cif | Intel CPPC eModule CIF file.
Cppc.sdl | Intel CPPC eModule SDL file.
ReleaseNotes.chm | Intel CPPC eModule CHM file.

ModulePart Name:CppcDxe
ModulePart Description:Intel CPPC Dxe Component.
Filename | Description
CppcDxe.cif | Intel CPPC Dxe CIF file.
CppcDxe.sdl | Intel CPPC Dxe parameters.
CppcDxe.mak | Intel CPPC Dxe make file.
Cppc.c | Intel CPPC Dxe C code.
Cppc.dxs | Intel CPPC Dxe dependency file.
Cppc.h | Intel CPPC Dxe porting functions and data structures definition.
Cppc.inf | Intel CPPC Dxe inf file.
ModulePart Name:CppcAcpiTables
ModulePart Description:Intel CPPC Acpi Tables Component.
Filename | Description
CppcAcpiTables.cif | Intel CPPC AcpiTables CIF file.
CppcAcpiTables.sdl | Intel CPPC AcpiTables parameters.
CppcAcpiTables.mak | Intel CPPC AcpiTables make file.
Cppc.asl | Intel CPPC AcpiTables asl file.
Pcct.asl | Intel CPPC AcpiTables asl file.
Cpc.asl | Intel CPPC AcpiTables asl file.
CppcAcpiTables.inf | Intel CPPC AcpiTables asl file.
ModulePart Name:CppcGuidLib
ModulePart Description:Intel CPPC GuidLib Component.
Filename | Description
CppcGuidLib.cif | Intel CPPC GuidLib CIF file.
CppcGuidLib.sdl | Intel CPPC GuidLib parameters.
CppcGuidLib.mak | Intel CPPC GuidLib make file.
CppcGuidLib.inf | Intel CPPC GuidLib inf file.
CppcAcpiTableStorage.c | Intel CPPC GuidLib GUID definition.
CppcAcpiTableStorage.h | Intel CPPC GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel CPPC Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_CPPC-RC_060_003
4.6.5.3_CPPC-RC_060_002
4.6.5.3_CPPC-RC_056_001
4.6.5.3_CPPC-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel CPPC
Component Reference Name: Intel CPPC
Component Type: eModule
Release Date: 2012-09-26
Source Control Label: 4.6.5.3_CPPC-RC_070_005
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/CPPC;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_070_013 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel CPPC initialization.
This is a caption
Filename | Description
Cppc.cif | Intel CPPC eModule CIF file.
Cppc.sdl | Intel CPPC eModule SDL file.
ReleaseNotes.chm | Intel CPPC eModule CHM file.

ModulePart Name:CppcDxe
ModulePart Description:Intel CPPC Dxe Component.
Filename | Description
CppcDxe.cif | Intel CPPC Dxe CIF file.
CppcDxe.sdl | Intel CPPC Dxe parameters.
CppcDxe.mak | Intel CPPC Dxe make file.
Cppc.c | Intel CPPC Dxe C code.
Cppc.dxs | Intel CPPC Dxe dependency file.
Cppc.h | Intel CPPC Dxe porting functions and data structures definition.
Cppc.inf | Intel CPPC Dxe inf file.
ModulePart Name:CppcAcpiTables
ModulePart Description:Intel CPPC Acpi Tables Component.
Filename | Description
CppcAcpiTables.cif | Intel CPPC AcpiTables CIF file.
CppcAcpiTables.sdl | Intel CPPC AcpiTables parameters.
CppcAcpiTables.mak | Intel CPPC AcpiTables make file.
Cppc.asl | Intel CPPC AcpiTables asl file.
Pcct.asl | Intel CPPC AcpiTables asl file.
Cpc.asl | Intel CPPC AcpiTables asl file.
CppcAcpiTables.inf | Intel CPPC AcpiTables asl file.
ModulePart Name:CppcGuidLib
ModulePart Description:Intel CPPC GuidLib Component.
Filename | Description
CppcGuidLib.cif | Intel CPPC GuidLib CIF file.
CppcGuidLib.sdl | Intel CPPC GuidLib parameters.
CppcGuidLib.mak | Intel CPPC GuidLib make file.
CppcGuidLib.inf | Intel CPPC GuidLib inf file.
CppcAcpiTableStorage.c | Intel CPPC GuidLib GUID definition.
CppcAcpiTableStorage.h | Intel CPPC GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel CPPC Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_CPPC-RC_061_004
4.6.5.3_CPPC-RC_060_003
4.6.5.3_CPPC-RC_060_002
4.6.5.3_CPPC-RC_056_001
4.6.5.3_CPPC-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel CPPC
Component Reference Name: Intel CPPC
Component Type: eModule
Release Date: 2012-10-15
Source Control Label: 4.6.5.3_CPPC-RC_071_006
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/CPPC;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_071_014 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel CPPC initialization.
This is a caption
Filename | Description
Cppc.cif | Intel CPPC eModule CIF file.
Cppc.sdl | Intel CPPC eModule SDL file.
ReleaseNotes.chm | Intel CPPC eModule CHM file.

ModulePart Name:CppcDxe
ModulePart Description:Intel CPPC Dxe Component.
Filename | Description
CppcDxe.cif | Intel CPPC Dxe CIF file.
CppcDxe.sdl | Intel CPPC Dxe parameters.
CppcDxe.mak | Intel CPPC Dxe make file.
Cppc.c | Intel CPPC Dxe C code.
Cppc.dxs | Intel CPPC Dxe dependency file.
Cppc.h | Intel CPPC Dxe porting functions and data structures definition.
Cppc.inf | Intel CPPC Dxe inf file.
ModulePart Name:CppcAcpiTables
ModulePart Description:Intel CPPC Acpi Tables Component.
Filename | Description
CppcAcpiTables.cif | Intel CPPC AcpiTables CIF file.
CppcAcpiTables.sdl | Intel CPPC AcpiTables parameters.
CppcAcpiTables.mak | Intel CPPC AcpiTables make file.
Cppc.asl | Intel CPPC AcpiTables asl file.
Pcct.asl | Intel CPPC AcpiTables asl file.
Cpc.asl | Intel CPPC AcpiTables asl file.
CppcAcpiTables.inf | Intel CPPC AcpiTables asl file.
ModulePart Name:CppcGuidLib
ModulePart Description:Intel CPPC GuidLib Component.
Filename | Description
CppcGuidLib.cif | Intel CPPC GuidLib CIF file.
CppcGuidLib.sdl | Intel CPPC GuidLib parameters.
CppcGuidLib.mak | Intel CPPC GuidLib make file.
CppcGuidLib.inf | Intel CPPC GuidLib inf file.
CppcAcpiTableStorage.c | Intel CPPC GuidLib GUID definition.
CppcAcpiTableStorage.h | Intel CPPC GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel CPPC Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_CPPC-RC_070_005
4.6.5.3_CPPC-RC_061_004
4.6.5.3_CPPC-RC_060_003
4.6.5.3_CPPC-RC_060_002
4.6.5.3_CPPC-RC_056_001
4.6.5.3_CPPC-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel CPPC
Component Reference Name: Intel CPPC
Component Type: eModule
Release Date: 2012-11-20
Source Control Label: 4.6.5.3_CPPC-RC_080_007
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/CPPC;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_080_017 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel CPPC initialization.
This is a caption
Filename | Description
Cppc.cif | Intel CPPC eModule CIF file.
Cppc.sdl | Intel CPPC eModule SDL file.
ReleaseNotes.chm | Intel CPPC eModule CHM file.

ModulePart Name:CppcDxe
ModulePart Description:Intel CPPC Dxe Component.
Filename | Description
CppcDxe.cif | Intel CPPC Dxe CIF file.
CppcDxe.sdl | Intel CPPC Dxe parameters.
CppcDxe.mak | Intel CPPC Dxe make file.
Cppc.c | Intel CPPC Dxe C code.
Cppc.dxs | Intel CPPC Dxe dependency file.
Cppc.h | Intel CPPC Dxe porting functions and data structures definition.
Cppc.inf | Intel CPPC Dxe inf file.
ModulePart Name:CppcAcpiTables
ModulePart Description:Intel CPPC Acpi Tables Component.
Filename | Description
CppcAcpiTables.cif | Intel CPPC AcpiTables CIF file.
CppcAcpiTables.sdl | Intel CPPC AcpiTables parameters.
CppcAcpiTables.mak | Intel CPPC AcpiTables make file.
Cppc.asl | Intel CPPC AcpiTables asl file.
Pcct.asl | Intel CPPC AcpiTables asl file.
Cpc.asl | Intel CPPC AcpiTables asl file.
CppcAcpiTables.inf | Intel CPPC AcpiTables asl file.
ModulePart Name:CppcGuidLib
ModulePart Description:Intel CPPC GuidLib Component.
Filename | Description
CppcGuidLib.cif | Intel CPPC GuidLib CIF file.
CppcGuidLib.sdl | Intel CPPC GuidLib parameters.
CppcGuidLib.mak | Intel CPPC GuidLib make file.
CppcGuidLib.inf | Intel CPPC GuidLib inf file.
CppcAcpiTableStorage.c | Intel CPPC GuidLib GUID definition.
CppcAcpiTableStorage.h | Intel CPPC GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel CPPC Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
[TAG] None
[Category] Improvement
[Description] Create Token for OEM clone
[Files] CppcAcpiTables.sdl CppcAcpiTables.mak
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_CPPC-RC_071_006
4.6.5.3_CPPC-RC_070_005
4.6.5.3_CPPC-RC_061_004
4.6.5.3_CPPC-RC_060_003
4.6.5.3_CPPC-RC_060_002
4.6.5.3_CPPC-RC_056_001
4.6.5.3_CPPC-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel CPPC
Component Reference Name: Intel CPPC
Component Type: eModule
Release Date: 2012-12-18
Source Control Label: 4.6.5.3_CPPC-RC_081_008
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/CPPC;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_081_019 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel CPPC initialization.
This is a caption
Filename | Description
Cppc.cif | Intel CPPC eModule CIF file.
Cppc.sdl | Intel CPPC eModule SDL file.
ReleaseNotes.chm | Intel CPPC eModule CHM file.

ModulePart Name:CppcDxe
ModulePart Description:Intel CPPC Dxe Component.
Filename | Description
CppcDxe.cif | Intel CPPC Dxe CIF file.
CppcDxe.sdl | Intel CPPC Dxe parameters.
CppcDxe.mak | Intel CPPC Dxe make file.
Cppc.c | Intel CPPC Dxe C code.
Cppc.dxs | Intel CPPC Dxe dependency file.
Cppc.h | Intel CPPC Dxe porting functions and data structures definition.
Cppc.inf | Intel CPPC Dxe inf file.
ModulePart Name:CppcAcpiTables
ModulePart Description:Intel CPPC Acpi Tables Component.
Filename | Description
CppcAcpiTables.cif | Intel CPPC AcpiTables CIF file.
CppcAcpiTables.sdl | Intel CPPC AcpiTables parameters.
CppcAcpiTables.mak | Intel CPPC AcpiTables make file.
Cppc.asl | Intel CPPC AcpiTables asl file.
Pcct.asl | Intel CPPC AcpiTables asl file.
Cpc.asl | Intel CPPC AcpiTables asl file.
CppcAcpiTables.inf | Intel CPPC AcpiTables asl file.
ModulePart Name:CppcGuidLib
ModulePart Description:Intel CPPC GuidLib Component.
Filename | Description
CppcGuidLib.cif | Intel CPPC GuidLib CIF file.
CppcGuidLib.sdl | Intel CPPC GuidLib parameters.
CppcGuidLib.mak | Intel CPPC GuidLib make file.
CppcGuidLib.inf | Intel CPPC GuidLib inf file.
CppcAcpiTableStorage.c | Intel CPPC GuidLib GUID definition.
CppcAcpiTableStorage.h | Intel CPPC GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel CPPC Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_CPPC-RC_080_007
4.6.5.3_CPPC-RC_071_006
4.6.5.3_CPPC-RC_070_005
4.6.5.3_CPPC-RC_061_004
4.6.5.3_CPPC-RC_060_003
4.6.5.3_CPPC-RC_060_002
4.6.5.3_CPPC-RC_056_001
4.6.5.3_CPPC-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel CPPC
Component Reference Name: Intel CPPC
Component Type: eModule
Release Date: 2013-01-04
Source Control Label: 4.6.5.3_CPPC-RC_090_009
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/CPPC;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_090_020 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel CPPC initialization.
This is a caption
Filename | Description
Cppc.cif | Intel CPPC eModule CIF file.
Cppc.sdl | Intel CPPC eModule SDL file.
ReleaseNotes.chm | Intel CPPC eModule CHM file.

ModulePart Name:CppcDxe
ModulePart Description:Intel CPPC Dxe Component.
Filename | Description
CppcDxe.cif | Intel CPPC Dxe CIF file.
CppcDxe.sdl | Intel CPPC Dxe parameters.
CppcDxe.mak | Intel CPPC Dxe make file.
Cppc.c | Intel CPPC Dxe C code.
Cppc.dxs | Intel CPPC Dxe dependency file.
Cppc.h | Intel CPPC Dxe porting functions and data structures definition.
Cppc.inf | Intel CPPC Dxe inf file.
ModulePart Name:CppcAcpiTables
ModulePart Description:Intel CPPC Acpi Tables Component.
Filename | Description
CppcAcpiTables.cif | Intel CPPC AcpiTables CIF file.
CppcAcpiTables.sdl | Intel CPPC AcpiTables parameters.
CppcAcpiTables.mak | Intel CPPC AcpiTables make file.
Cppc.asl | Intel CPPC AcpiTables asl file.
Pcct.asl | Intel CPPC AcpiTables asl file.
Cpc.asl | Intel CPPC AcpiTables asl file.
CppcAcpiTables.inf | Intel CPPC AcpiTables asl file.
ModulePart Name:CppcGuidLib
ModulePart Description:Intel CPPC GuidLib Component.
Filename | Description
CppcGuidLib.cif | Intel CPPC GuidLib CIF file.
CppcGuidLib.sdl | Intel CPPC GuidLib parameters.
CppcGuidLib.mak | Intel CPPC GuidLib make file.
CppcGuidLib.inf | Intel CPPC GuidLib inf file.
CppcAcpiTableStorage.c | Intel CPPC GuidLib GUID definition.
CppcAcpiTableStorage.h | Intel CPPC GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel CPPC Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_CPPC-RC_081_008
4.6.5.3_CPPC-RC_080_007
4.6.5.3_CPPC-RC_071_006
4.6.5.3_CPPC-RC_070_005
4.6.5.3_CPPC-RC_061_004
4.6.5.3_CPPC-RC_060_003
4.6.5.3_CPPC-RC_060_002
4.6.5.3_CPPC-RC_056_001
4.6.5.3_CPPC-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel CPPC
Component Reference Name: Intel CPPC
Component Type: eModule
Release Date: 2013-01-28
Source Control Label: 4.6.5.3_CPPC-RC_100_010
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/CPPC;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_100_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel CPPC initialization.
This is a caption
Filename | Description
Cppc.cif | Intel CPPC eModule CIF file.
Cppc.sdl | Intel CPPC eModule SDL file.
ReleaseNotes.chm | Intel CPPC eModule CHM file.

ModulePart Name:CppcDxe
ModulePart Description:Intel CPPC Dxe Component.
Filename | Description
CppcDxe.cif | Intel CPPC Dxe CIF file.
CppcDxe.sdl | Intel CPPC Dxe parameters.
CppcDxe.mak | Intel CPPC Dxe make file.
Cppc.c | Intel CPPC Dxe C code.
Cppc.dxs | Intel CPPC Dxe dependency file.
Cppc.h | Intel CPPC Dxe porting functions and data structures definition.
Cppc.inf | Intel CPPC Dxe inf file.
ModulePart Name:CppcAcpiTables
ModulePart Description:Intel CPPC Acpi Tables Component.
Filename | Description
CppcAcpiTables.cif | Intel CPPC AcpiTables CIF file.
CppcAcpiTables.sdl | Intel CPPC AcpiTables parameters.
CppcAcpiTables.mak | Intel CPPC AcpiTables make file.
Cppc.asl | Intel CPPC AcpiTables asl file.
Pcct.asl | Intel CPPC AcpiTables asl file.
Cpc.asl | Intel CPPC AcpiTables asl file.
CppcAcpiTables.inf | Intel CPPC AcpiTables asl file.
ModulePart Name:CppcGuidLib
ModulePart Description:Intel CPPC GuidLib Component.
Filename | Description
CppcGuidLib.cif | Intel CPPC GuidLib CIF file.
CppcGuidLib.sdl | Intel CPPC GuidLib parameters.
CppcGuidLib.mak | Intel CPPC GuidLib make file.
CppcGuidLib.inf | Intel CPPC GuidLib inf file.
CppcAcpiTableStorage.c | Intel CPPC GuidLib GUID definition.
CppcAcpiTableStorage.h | Intel CPPC GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel CPPC Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_CPPC-RC_090_009
4.6.5.3_CPPC-RC_081_008
4.6.5.3_CPPC-RC_080_007
4.6.5.3_CPPC-RC_071_006
4.6.5.3_CPPC-RC_070_005
4.6.5.3_CPPC-RC_061_004
4.6.5.3_CPPC-RC_060_003
4.6.5.3_CPPC-RC_060_002
4.6.5.3_CPPC-RC_056_001
4.6.5.3_CPPC-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel CPPC
Component Reference Name: Intel CPPC
Component Type: eModule
Release Date: 2013-02-09
Source Control Label: 4.6.5.3_CPPC-RC_110_011
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/CPPC;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_110_022 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel CPPC initialization.
This is a caption
Filename | Description
Cppc.cif | Intel CPPC eModule CIF file.
Cppc.sdl | Intel CPPC eModule SDL file.
ReleaseNotes.chm | Intel CPPC eModule CHM file.

ModulePart Name:CppcDxe
ModulePart Description:Intel CPPC Dxe Component.
Filename | Description
CppcDxe.cif | Intel CPPC Dxe CIF file.
CppcDxe.sdl | Intel CPPC Dxe parameters.
CppcDxe.mak | Intel CPPC Dxe make file.
Cppc.c | Intel CPPC Dxe C code.
Cppc.dxs | Intel CPPC Dxe dependency file.
Cppc.h | Intel CPPC Dxe porting functions and data structures definition.
Cppc.inf | Intel CPPC Dxe inf file.
ModulePart Name:CppcAcpiTables
ModulePart Description:Intel CPPC Acpi Tables Component.
Filename | Description
CppcAcpiTables.cif | Intel CPPC AcpiTables CIF file.
CppcAcpiTables.sdl | Intel CPPC AcpiTables parameters.
CppcAcpiTables.mak | Intel CPPC AcpiTables make file.
Cppc.asl | Intel CPPC AcpiTables asl file.
Pcct.asl | Intel CPPC AcpiTables asl file.
Cpc.asl | Intel CPPC AcpiTables asl file.
CppcAcpiTables.inf | Intel CPPC AcpiTables asl file.
ModulePart Name:CppcGuidLib
ModulePart Description:Intel CPPC GuidLib Component.
Filename | Description
CppcGuidLib.cif | Intel CPPC GuidLib CIF file.
CppcGuidLib.sdl | Intel CPPC GuidLib parameters.
CppcGuidLib.mak | Intel CPPC GuidLib make file.
CppcGuidLib.inf | Intel CPPC GuidLib inf file.
CppcAcpiTableStorage.c | Intel CPPC GuidLib GUID definition.
CppcAcpiTableStorage.h | Intel CPPC GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel CPPC Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_CPPC-RC_100_010
4.6.5.3_CPPC-RC_090_009
4.6.5.3_CPPC-RC_081_008
4.6.5.3_CPPC-RC_080_007
4.6.5.3_CPPC-RC_071_006
4.6.5.3_CPPC-RC_070_005
4.6.5.3_CPPC-RC_061_004
4.6.5.3_CPPC-RC_060_003
4.6.5.3_CPPC-RC_060_002
4.6.5.3_CPPC-RC_056_001
4.6.5.3_CPPC-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel CPPC
Component Reference Name: Intel CPPC
Component Type: eModule
Release Date: 2013-02-23
Source Control Label: 4.6.5.3_CPPC-RC_120_012
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/CPPC;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_120_023 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel CPPC initialization.
This is a caption
Filename | Description
Cppc.cif | Intel CPPC eModule CIF file.
Cppc.sdl | Intel CPPC eModule SDL file.
ReleaseNotes.chm | Intel CPPC eModule CHM file.

ModulePart Name:CppcDxe
ModulePart Description:Intel CPPC Dxe Component.
Filename | Description
CppcDxe.cif | Intel CPPC Dxe CIF file.
CppcDxe.sdl | Intel CPPC Dxe parameters.
CppcDxe.mak | Intel CPPC Dxe make file.
Cppc.c | Intel CPPC Dxe C code.
Cppc.dxs | Intel CPPC Dxe dependency file.
Cppc.h | Intel CPPC Dxe porting functions and data structures definition.
Cppc.inf | Intel CPPC Dxe inf file.
ModulePart Name:CppcAcpiTables
ModulePart Description:Intel CPPC Acpi Tables Component.
Filename | Description
CppcAcpiTables.cif | Intel CPPC AcpiTables CIF file.
CppcAcpiTables.sdl | Intel CPPC AcpiTables parameters.
CppcAcpiTables.mak | Intel CPPC AcpiTables make file.
Cppc.asl | Intel CPPC AcpiTables asl file.
Pcct.asl | Intel CPPC AcpiTables asl file.
Cpc.asl | Intel CPPC AcpiTables asl file.
CppcAcpiTables.inf | Intel CPPC AcpiTables asl file.
ModulePart Name:CppcGuidLib
ModulePart Description:Intel CPPC GuidLib Component.
Filename | Description
CppcGuidLib.cif | Intel CPPC GuidLib CIF file.
CppcGuidLib.sdl | Intel CPPC GuidLib parameters.
CppcGuidLib.mak | Intel CPPC GuidLib make file.
CppcGuidLib.inf | Intel CPPC GuidLib inf file.
CppcAcpiTableStorage.c | Intel CPPC GuidLib GUID definition.
CppcAcpiTableStorage.h | Intel CPPC GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel CPPC Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_CPPC-RC_110_011
4.6.5.3_CPPC-RC_100_010
4.6.5.3_CPPC-RC_090_009
4.6.5.3_CPPC-RC_081_008
4.6.5.3_CPPC-RC_080_007
4.6.5.3_CPPC-RC_071_006
4.6.5.3_CPPC-RC_070_005
4.6.5.3_CPPC-RC_061_004
4.6.5.3_CPPC-RC_060_003
4.6.5.3_CPPC-RC_060_002
4.6.5.3_CPPC-RC_056_001
4.6.5.3_CPPC-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel CPPC
Component Reference Name: Intel CPPC
Component Type: eModule
Release Date: 2013-03-15
Source Control Label: 4.6.5.3_CPPC-RC_130_013
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/CPPC;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_130_025 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel CPPC initialization.
This is a caption
Filename | Description
Cppc.cif | Intel CPPC eModule CIF file.
Cppc.sdl | Intel CPPC eModule SDL file.
ReleaseNotes.chm | Intel CPPC eModule CHM file.

ModulePart Name:CppcDxe
ModulePart Description:Intel CPPC Dxe Component.
Filename | Description
CppcDxe.cif | Intel CPPC Dxe CIF file.
CppcDxe.sdl | Intel CPPC Dxe parameters.
CppcDxe.mak | Intel CPPC Dxe make file.
Cppc.c | Intel CPPC Dxe C code.
Cppc.dxs | Intel CPPC Dxe dependency file.
Cppc.h | Intel CPPC Dxe porting functions and data structures definition.
Cppc.inf | Intel CPPC Dxe inf file.
ModulePart Name:CppcAcpiTables
ModulePart Description:Intel CPPC Acpi Tables Component.
Filename | Description
CppcAcpiTables.cif | Intel CPPC AcpiTables CIF file.
CppcAcpiTables.sdl | Intel CPPC AcpiTables parameters.
CppcAcpiTables.mak | Intel CPPC AcpiTables make file.
Cppc.asl | Intel CPPC AcpiTables asl file.
Pcct.asl | Intel CPPC AcpiTables asl file.
Cpc.asl | Intel CPPC AcpiTables asl file.
CppcAcpiTables.inf | Intel CPPC AcpiTables asl file.
ModulePart Name:CppcGuidLib
ModulePart Description:Intel CPPC GuidLib Component.
Filename | Description
CppcGuidLib.cif | Intel CPPC GuidLib CIF file.
CppcGuidLib.sdl | Intel CPPC GuidLib parameters.
CppcGuidLib.mak | Intel CPPC GuidLib make file.
CppcGuidLib.inf | Intel CPPC GuidLib inf file.
CppcAcpiTableStorage.c | Intel CPPC GuidLib GUID definition.
CppcAcpiTableStorage.h | Intel CPPC GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel CPPC Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_CPPC-RC_120_012
4.6.5.3_CPPC-RC_110_011
4.6.5.3_CPPC-RC_100_010
4.6.5.3_CPPC-RC_090_009
4.6.5.3_CPPC-RC_081_008
4.6.5.3_CPPC-RC_080_007
4.6.5.3_CPPC-RC_071_006
4.6.5.3_CPPC-RC_070_005
4.6.5.3_CPPC-RC_061_004
4.6.5.3_CPPC-RC_060_003
4.6.5.3_CPPC-RC_060_002
4.6.5.3_CPPC-RC_056_001
4.6.5.3_CPPC-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel CPPC
Component Reference Name: Intel CPPC
Component Type: eModule
Release Date: 2013-05-13
Source Control Label: 4.6.5.3_CPPC-RC_150_014
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/CPPC;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_150_028 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel CPPC initialization.
This is a caption
Filename | Description
Cppc.cif | Intel CPPC eModule CIF file.
Cppc.sdl | Intel CPPC eModule SDL file.
ReleaseNotes.chm | Intel CPPC eModule CHM file.

ModulePart Name:CppcDxe
ModulePart Description:Intel CPPC Dxe Component.
Filename | Description
CppcDxe.cif | Intel CPPC Dxe CIF file.
CppcDxe.sdl | Intel CPPC Dxe parameters.
CppcDxe.mak | Intel CPPC Dxe make file.
Cppc.c | Intel CPPC Dxe C code.
Cppc.dxs | Intel CPPC Dxe dependency file.
Cppc.h | Intel CPPC Dxe porting functions and data structures definition.
Cppc.inf | Intel CPPC Dxe inf file.
ModulePart Name:CppcAcpiTables
ModulePart Description:Intel CPPC Acpi Tables Component.
Filename | Description
CppcAcpiTables.cif | Intel CPPC AcpiTables CIF file.
CppcAcpiTables.sdl | Intel CPPC AcpiTables parameters.
CppcAcpiTables.mak | Intel CPPC AcpiTables make file.
Cppc.asl | Intel CPPC AcpiTables asl file.
Pcct.asl | Intel CPPC AcpiTables asl file.
Cpc.asl | Intel CPPC AcpiTables asl file.
CppcAcpiTables.inf | Intel CPPC AcpiTables asl file.
ModulePart Name:CppcGuidLib
ModulePart Description:Intel CPPC GuidLib Component.
Filename | Description
CppcGuidLib.cif | Intel CPPC GuidLib CIF file.
CppcGuidLib.sdl | Intel CPPC GuidLib parameters.
CppcGuidLib.mak | Intel CPPC GuidLib make file.
CppcGuidLib.inf | Intel CPPC GuidLib inf file.
CppcAcpiTableStorage.c | Intel CPPC GuidLib GUID definition.
CppcAcpiTableStorage.h | Intel CPPC GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel CPPC Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_CPPC-RC_130_013
4.6.5.3_CPPC-RC_120_012
4.6.5.3_CPPC-RC_110_011
4.6.5.3_CPPC-RC_100_010
4.6.5.3_CPPC-RC_090_009
4.6.5.3_CPPC-RC_081_008
4.6.5.3_CPPC-RC_080_007
4.6.5.3_CPPC-RC_071_006
4.6.5.3_CPPC-RC_070_005
4.6.5.3_CPPC-RC_061_004
4.6.5.3_CPPC-RC_060_003
4.6.5.3_CPPC-RC_060_002
4.6.5.3_CPPC-RC_056_001
4.6.5.3_CPPC-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel CPPC
Component Reference Name: Intel CPPC
Component Type: eModule
Release Date: 2013-06-02
Source Control Label: 4.6.5.3_CPPC-RC_150_014a
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/CPPC;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_150_028a or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel CPPC initialization.
This is a caption
Filename | Description
Cppc.cif | Intel CPPC eModule CIF file.
Cppc.sdl | Intel CPPC eModule SDL file.
ReleaseNotes.chm | Intel CPPC eModule CHM file.

ModulePart Name:CppcDxe
ModulePart Description:Intel CPPC Dxe Component.
Filename | Description
CppcDxe.cif | Intel CPPC Dxe CIF file.
CppcDxe.sdl | Intel CPPC Dxe parameters.
CppcDxe.mak | Intel CPPC Dxe make file.
Cppc.c | Intel CPPC Dxe C code.
Cppc.dxs | Intel CPPC Dxe dependency file.
Cppc.h | Intel CPPC Dxe porting functions and data structures definition.
Cppc.inf | Intel CPPC Dxe inf file.
ModulePart Name:CppcAcpiTables
ModulePart Description:Intel CPPC Acpi Tables Component.
Filename | Description
CppcAcpiTables.cif | Intel CPPC AcpiTables CIF file.
CppcAcpiTables.sdl | Intel CPPC AcpiTables parameters.
CppcAcpiTables.mak | Intel CPPC AcpiTables make file.
Cppc.asl | Intel CPPC AcpiTables asl file.
Pcct.asl | Intel CPPC AcpiTables asl file.
Cpc.asl | Intel CPPC AcpiTables asl file.
CppcAcpiTables.inf | Intel CPPC AcpiTables asl file.
ModulePart Name:CppcGuidLib
ModulePart Description:Intel CPPC GuidLib Component.
Filename | Description
CppcGuidLib.cif | Intel CPPC GuidLib CIF file.
CppcGuidLib.sdl | Intel CPPC GuidLib parameters.
CppcGuidLib.mak | Intel CPPC GuidLib make file.
CppcGuidLib.inf | Intel CPPC GuidLib inf file.
CppcAcpiTableStorage.c | Intel CPPC GuidLib GUID definition.
CppcAcpiTableStorage.h | Intel CPPC GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: None
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
CppcAcpiTables.mak
[Category] Improvement
[Description] Change IASL compiler path to $(ACPIPLATFORM_ASL_COMPILER) in SharkBay project.
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_CPPC-RC_150_014
4.6.5.3_CPPC-RC_130_013
4.6.5.3_CPPC-RC_120_012
4.6.5.3_CPPC-RC_110_011
4.6.5.3_CPPC-RC_100_010
4.6.5.3_CPPC-RC_090_009
4.6.5.3_CPPC-RC_081_008
4.6.5.3_CPPC-RC_080_007
4.6.5.3_CPPC-RC_071_006
4.6.5.3_CPPC-RC_070_005
4.6.5.3_CPPC-RC_061_004
4.6.5.3_CPPC-RC_060_003
4.6.5.3_CPPC-RC_060_002
4.6.5.3_CPPC-RC_056_001
4.6.5.3_CPPC-RC_055_000

© American Megatrends Inc.


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2012 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.


Component Information:
Component Title: Intel CPPC
Component Reference Name: Intel CPPC
Component Type: eModule
Release Date: 2013-06-21
Source Control Label: 4.6.5.3_CPPC-RC_160_015
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/CPPC;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_150_028a or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel CPPC initialization.
This is a caption
Filename | Description
Cppc.cif | Intel CPPC eModule CIF file.
Cppc.sdl | Intel CPPC eModule SDL file.
ReleaseNotes.chm | Intel CPPC eModule CHM file.

ModulePart Name:CppcDxe
ModulePart Description:Intel CPPC Dxe Component.
Filename | Description
CppcDxe.cif | Intel CPPC Dxe CIF file.
CppcDxe.sdl | Intel CPPC Dxe parameters.
CppcDxe.mak | Intel CPPC Dxe make file.
Cppc.c | Intel CPPC Dxe C code.
Cppc.dxs | Intel CPPC Dxe dependency file.
Cppc.h | Intel CPPC Dxe porting functions and data structures definition.
Cppc.inf | Intel CPPC Dxe inf file.
ModulePart Name:CppcAcpiTables
ModulePart Description:Intel CPPC Acpi Tables Component.
Filename | Description
CppcAcpiTables.cif | Intel CPPC AcpiTables CIF file.
CppcAcpiTables.sdl | Intel CPPC AcpiTables parameters.
CppcAcpiTables.mak | Intel CPPC AcpiTables make file.
Cppc.asl | Intel CPPC AcpiTables asl file.
Pcct.asl | Intel CPPC AcpiTables asl file.
Cpc.asl | Intel CPPC AcpiTables asl file.
CppcAcpiTables.inf | Intel CPPC AcpiTables asl file.
ModulePart Name:CppcGuidLib
ModulePart Description:Intel CPPC GuidLib Component.
Filename | Description
CppcGuidLib.cif | Intel CPPC GuidLib CIF file.
CppcGuidLib.sdl | Intel CPPC GuidLib parameters.
CppcGuidLib.mak | Intel CPPC GuidLib make file.
CppcGuidLib.inf | Intel CPPC GuidLib inf file.
CppcAcpiTableStorage.c | Intel CPPC GuidLib GUID definition.
CppcAcpiTableStorage.h | Intel CPPC GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Shark Bay Client ACPI Reference Code Production Version 1.6.0
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE: None
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_CPPC-RC_150_014a
4.6.5.3_CPPC-RC_150_014
4.6.5.3_CPPC-RC_130_013
4.6.5.3_CPPC-RC_120_012
4.6.5.3_CPPC-RC_110_011
4.6.5.3_CPPC-RC_100_010
4.6.5.3_CPPC-RC_090_009
4.6.5.3_CPPC-RC_081_008
4.6.5.3_CPPC-RC_080_007
4.6.5.3_CPPC-RC_071_006
4.6.5.3_CPPC-RC_070_005
4.6.5.3_CPPC-RC_061_004
4.6.5.3_CPPC-RC_060_003
4.6.5.3_CPPC-RC_060_002
4.6.5.3_CPPC-RC_056_001
4.6.5.3_CPPC-RC_055_000

© American Megatrends Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • CppcAcpiTables.mak
  • CppcDxe.mak
  • CppcGuidLib.mak
Built on 19:06:59 06/21/13


AMIBIOS Function Reference

CppcAcpiTables.mak

Description:
MAke file to build Intel CPPC ACPI ASL components
Built on 19:06:59 06/21/13


AMIBIOS Function Reference

CppcDxe.mak

Description:
Make file to build Intel CPPC components
Built on 19:06:59 06/21/13


AMIBIOS Function Reference

CppcGuidLib.mak

Description:
Make file to build Intel CPPC GuidLib components
Built on 19:06:59 06/21/13


Functions in Alphabetical Order

AMIBIOS Function Reference

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

Built on 19:06:59 06/21/13


AMIBIOS Function Reference

General Information

Built on 19:06:59 06/21/13