American Megatrends, Inc.

ReleaseNotes

Copyright

Release Notes

© American Megatrends, Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2012-04-25
Source Control Label: 4.6.5.3_DPTF-RC_055_000
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_055_004 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
FgenDppmPolicy.asl | Intel DPTF AcpiTables asl file.
FgenParticipant.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2012-05-14
Source Control Label: 4.6.5.3_DPTF-RC_056_001
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_056_005 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
FgenDppmPolicy.asl | Intel DPTF AcpiTables asl file.
FgenParticipant.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2012-07-02
Source Control Label: 4.6.5.3_DPTF-RC_060_002
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_060_007 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2012-08-14
Source Control Label: 4.6.5.3_DPTF-RC_061_003
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_061_010 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
WifiDppmPolicy.asl.asl | Intel DPTF AcpiTables asl file.
WifiParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_Tools_39, Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2012-09-26
Source Control Label: 4.6.5.3_DPTF-RC_070_004
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_070_013 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:NONE
Files changed in the Reference or 3rd Party Code:
NONE
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2012-10-15
Source Control Label: 4.6.5.3_DPTF-RC_071_005
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_071_014 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:B0d4Participant.asl
Files changed in the Reference or 3rd Party Code:
B0d4Participant.asl
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2012-11-06
Source Control Label: 4.6.5.3_DPTF-RC_071_006
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_071_015 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:None
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
Fix BSOD issue when enable DPTF

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
B0d4Participant.asl
Fix BSOD issue when enable DPTF

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_071_005
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2012-11-20
Source Control Label: 4.6.5.3_DPTF-RC_080_007
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_080_017 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:None
Files changed in the Reference or 3rd Party Code:
[TAG] None
[Category] Improvement
[Description] Create Token for OEM clone
[Files] DptfAcpiTables.sdl DptfAcpiTables.mak
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_071_006
4.6.5.3_DPTF-RC_071_005
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2012-12-18
Source Control Label: 4.6.5.3_DPTF-RC_081_008
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_081_019 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:None
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
NONE
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_080_007
4.6.5.3_DPTF-RC_071_006
4.6.5.3_DPTF-RC_071_005
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2013-01-14
Source Control Label: 4.6.5.3_DPTF-RC_090_009
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_090_020 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
TPwrParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:None
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
Power participant
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_081_008
4.6.5.3_DPTF-RC_080_007
4.6.5.3_DPTF-RC_071_006
4.6.5.3_DPTF-RC_071_005
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2013-01-29
Source Control Label: 4.6.5.3_DPTF-RC_100_010
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_100_021 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
TPwrParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
ModulePart Name:DptfAcpiTablesFfrd
ModulePart Description:Intel DPTF Ffrd Acpi Tables Component.
Filename | Description
DptfAcpiTablesFfrd.cif | Intel DPTF Ffrd AcpiTables CIF file.
DptfAcpiTablesFfrd.inf | Intel DPTF Ffrd AcpiTables inf file.
DptfAcpiTablesFfrd.sdl | Intel DPTF Ffrd AcpiTables parameters.
DptfAcpiTablesFfrd.mak | Intel DPTF Ffrd AcpiTables make file.
DptfFfrd.asl | Intel DPTF Ffrd AcpiTables asl file.
Ertm.asl | Intel DPTF Ffrd AcpiTables asl file.
Trt.asl | Intel DPTF Ffrd AcpiTables asl file.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:These files are changed for Dptf Ffrd acpitable support
Dptf.c,Dptf.h,DptfAcpiTableStorage.c,DptfAcpiTableStorage.h
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
Dptf Ffrd Acpitable,add in "DptfAcpiTablesFfrd" module part:
Reference code add this table to support DPTF function on Ffrd platform.
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_090_009
4.6.5.3_DPTF-RC_081_008
4.6.5.3_DPTF-RC_080_007
4.6.5.3_DPTF-RC_071_006
4.6.5.3_DPTF-RC_071_005
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2013-02-01
Source Control Label: 4.6.5.3_DPTF-RC_100_010a
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_100_021a or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
TPwrParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
ModulePart Name:DptfAcpiTablesFfrd
ModulePart Description:Intel DPTF Ffrd Acpi Tables Component.
Filename | Description
DptfAcpiTablesFfrd.cif | Intel DPTF Ffrd AcpiTables CIF file.
DptfAcpiTablesFfrd.inf | Intel DPTF Ffrd AcpiTables inf file.
DptfAcpiTablesFfrd.sdl | Intel DPTF Ffrd AcpiTables parameters.
DptfAcpiTablesFfrd.mak | Intel DPTF Ffrd AcpiTables make file.
DptfFfrd.asl | Intel DPTF Ffrd AcpiTables asl file.
Ertm.asl | Intel DPTF Ffrd AcpiTables asl file.
Trt.asl | Intel DPTF Ffrd AcpiTables asl file.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:
None
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed:EIP112643
To solve the workshop fail item.
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_100_010
4.6.5.3_DPTF-RC_090_009
4.6.5.3_DPTF-RC_081_008
4.6.5.3_DPTF-RC_080_007
4.6.5.3_DPTF-RC_071_006
4.6.5.3_DPTF-RC_071_005
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2013-02-06
Source Control Label: 4.6.5.3_DPTF-RC_100_010b
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_100_021a or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
TPwrParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
ModulePart Name:DptfAcpiTablesFfrd
ModulePart Description:Intel DPTF Ffrd Acpi Tables Component.
Filename | Description
DptfAcpiTablesFfrd.cif | Intel DPTF Ffrd AcpiTables CIF file.
DptfAcpiTablesFfrd.inf | Intel DPTF Ffrd AcpiTables inf file.
DptfAcpiTablesFfrd.sdl | Intel DPTF Ffrd AcpiTables parameters.
DptfAcpiTablesFfrd.mak | Intel DPTF Ffrd AcpiTables make file.
DptfFfrd.asl | Intel DPTF Ffrd AcpiTables asl file.
Ertm.asl | Intel DPTF Ffrd AcpiTables asl file.
Trt.asl | Intel DPTF Ffrd AcpiTables asl file.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:
None
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed:EIP112643
To solve the workshop fail item.
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_100_010a
4.6.5.3_DPTF-RC_100_010
4.6.5.3_DPTF-RC_090_009
4.6.5.3_DPTF-RC_081_008
4.6.5.3_DPTF-RC_080_007
4.6.5.3_DPTF-RC_071_006
4.6.5.3_DPTF-RC_071_005
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2013-02-09
Source Control Label: 4.6.5.3_DPTF-RC_110_011
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_110_022 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
TPwrParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
ModulePart Name:DptfAcpiTablesFfrd
ModulePart Description:Intel DPTF Ffrd Acpi Tables Component.
Filename | Description
DptfAcpiTablesFfrd.cif | Intel DPTF Ffrd AcpiTables CIF file.
DptfAcpiTablesFfrd.inf | Intel DPTF Ffrd AcpiTables inf file.
DptfAcpiTablesFfrd.sdl | Intel DPTF Ffrd AcpiTables parameters.
DptfAcpiTablesFfrd.mak | Intel DPTF Ffrd AcpiTables make file.
DptfFfrd.asl | Intel DPTF Ffrd AcpiTables asl file.
Ertm.asl | Intel DPTF Ffrd AcpiTables asl file.
Trt.asl | Intel DPTF Ffrd AcpiTables asl file.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:
DptfFfrd.asl,Dptf.asl,TPwrParticipant.asl
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed:
None
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_100_010b
4.6.5.3_DPTF-RC_100_010a
4.6.5.3_DPTF-RC_100_010
4.6.5.3_DPTF-RC_090_009
4.6.5.3_DPTF-RC_081_008
4.6.5.3_DPTF-RC_080_007
4.6.5.3_DPTF-RC_071_006
4.6.5.3_DPTF-RC_071_005
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2013-02-23
Source Control Label: 4.6.5.3_DPTF-RC_120_012
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_120_023 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
TPwrParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
ModulePart Name:DptfAcpiTablesFfrd
ModulePart Description:Intel DPTF Ffrd Acpi Tables Component.
Filename | Description
DptfAcpiTablesFfrd.cif | Intel DPTF Ffrd AcpiTables CIF file.
DptfAcpiTablesFfrd.inf | Intel DPTF Ffrd AcpiTables inf file.
DptfAcpiTablesFfrd.sdl | Intel DPTF Ffrd AcpiTables parameters.
DptfAcpiTablesFfrd.mak | Intel DPTF Ffrd AcpiTables make file.
DptfFfrd.asl | Intel DPTF Ffrd AcpiTables asl file.
Ertm.asl | Intel DPTF Ffrd AcpiTables asl file.
Trt.asl | Intel DPTF Ffrd AcpiTables asl file.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:
File path:AcpiTables\Ffrd
Art.asl,DptfFfrd.asl,Ertm.asl,TAmbParticipant.asl,TEfnParticipant.asl,TFN1Participant.asl
TFN2Participant.asl,TInlDppmPolicy.asl,TInlParticipant.asl,TmemParticipant.asl,Trt.asl,TSknParticipant.asl
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed:
None
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_110_011
4.6.5.3_DPTF-RC_100_010b
4.6.5.3_DPTF-RC_100_010a
4.6.5.3_DPTF-RC_100_010
4.6.5.3_DPTF-RC_090_009
4.6.5.3_DPTF-RC_081_008
4.6.5.3_DPTF-RC_080_007
4.6.5.3_DPTF-RC_071_006
4.6.5.3_DPTF-RC_071_005
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2013-03-15
Source Control Label: 4.6.5.3_DPTF-RC_130_013
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_130_025 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
TPwrParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
ModulePart Name:DptfAcpiTablesFfrd
ModulePart Description:Intel DPTF Ffrd Acpi Tables Component.
Filename | Description
DptfAcpiTablesFfrd.cif | Intel DPTF Ffrd AcpiTables CIF file.
DptfAcpiTablesFfrd.inf | Intel DPTF Ffrd AcpiTables inf file.
DptfAcpiTablesFfrd.sdl | Intel DPTF Ffrd AcpiTables parameters.
DptfAcpiTablesFfrd.mak | Intel DPTF Ffrd AcpiTables make file.
DptfFfrd.asl | Intel DPTF Ffrd AcpiTables asl file.
Ertm.asl | Intel DPTF Ffrd AcpiTables asl file.
Trt.asl | Intel DPTF Ffrd AcpiTables asl file.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:None
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed:
None
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_120_012
4.6.5.3_DPTF-RC_110_011
4.6.5.3_DPTF-RC_100_010b
4.6.5.3_DPTF-RC_100_010a
4.6.5.3_DPTF-RC_100_010
4.6.5.3_DPTF-RC_090_009
4.6.5.3_DPTF-RC_081_008
4.6.5.3_DPTF-RC_080_007
4.6.5.3_DPTF-RC_071_006
4.6.5.3_DPTF-RC_071_005
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2013-04-08
Source Control Label: 4.6.5.3_DPTF-RC_140_014
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_140_027 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
TPwrParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
ModulePart Name:DptfAcpiTablesFfrd
ModulePart Description:Intel DPTF Ffrd Acpi Tables Component.
Filename | Description
DptfAcpiTablesFfrd.cif | Intel DPTF Ffrd AcpiTables CIF file.
DptfAcpiTablesFfrd.inf | Intel DPTF Ffrd AcpiTables inf file.
DptfAcpiTablesFfrd.sdl | Intel DPTF Ffrd AcpiTables parameters.
DptfAcpiTablesFfrd.mak | Intel DPTF Ffrd AcpiTables make file.
DptfFfrd.asl | Intel DPTF Ffrd AcpiTables asl file.
Ertm.asl | Intel DPTF Ffrd AcpiTables asl file.
Trt.asl | Intel DPTF Ffrd AcpiTables asl file.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:
Dptf\AcpiTables\B0d4CtdpPolicy.asl,Dptf\AcpiTables\DplyParticipant.asl,Dptf\AcpiTables\Dptf.asl,Dptf\AcpiTables\TPwrParticipant.asl
Dptf\AcpiTables\Ffrd\Art.asl,Dptf\AcpiTables\Ffrd\B0d4DppmPolicy.asl,Dptf\AcpiTables\Ffrd\DptfFfrd.asl,Dptf\AcpiTables\Ffrd\TAmbParticipant.asl
Dptf\AcpiTables\Ffrd\TEfnParticipant.asl,Dptf\AcpiTables\Ffrd\TFN1Participant.asl,Dptf\AcpiTables\Ffrd\TFN2Participant.asl
Dptf\AcpiTables\Ffrd\TInlDppmPolicy.asl,Dptf\AcpiTables\Ffrd\TMemParticipant.asl,Dptf\AcpiTables\Ffrd\Trt.asl,Dptf\AcpiTables\Ffrd\TSknParticipant.asl
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
Description:
Yellow bang observed for Display participant in Device manager
Afected files:
Dptf\AcpiTables\Ffrd\DptfFfrd.asl,Dptf\AcpiTables\Dptf.asl,Dptf\AcpiTables\DplyParticipant.asl

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed:
None
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_130_013
4.6.5.3_DPTF-RC_120_012
4.6.5.3_DPTF-RC_110_011
4.6.5.3_DPTF-RC_100_010b
4.6.5.3_DPTF-RC_100_010a
4.6.5.3_DPTF-RC_100_010
4.6.5.3_DPTF-RC_090_009
4.6.5.3_DPTF-RC_081_008
4.6.5.3_DPTF-RC_080_007
4.6.5.3_DPTF-RC_071_006
4.6.5.3_DPTF-RC_071_005
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2013-05-13
Source Control Label: 4.6.5.3_DPTF-RC_150_015
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_150_028 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
TPwrParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
ModulePart Name:DptfAcpiTablesFfrd
ModulePart Description:Intel DPTF Ffrd Acpi Tables Component.
Filename | Description
DptfAcpiTablesFfrd.cif | Intel DPTF Ffrd AcpiTables CIF file.
DptfAcpiTablesFfrd.inf | Intel DPTF Ffrd AcpiTables inf file.
DptfAcpiTablesFfrd.sdl | Intel DPTF Ffrd AcpiTables parameters.
DptfAcpiTablesFfrd.mak | Intel DPTF Ffrd AcpiTables make file.
DptfFfrd.asl | Intel DPTF Ffrd AcpiTables asl file.
Ertm.asl | Intel DPTF Ffrd AcpiTables asl file.
Trt.asl | Intel DPTF Ffrd AcpiTables asl file.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:
Dptf\AcpiTables\B0d4Participant.asl,Dptf\AcpiTables\Dptf.asl,Dptf\AcpiTables\TPwrParticipant.asl
Dptf\AcpiTables\Ffrd\TMemDppmPolicy.asl
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed:
None
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_140_014
4.6.5.3_DPTF-RC_130_013
4.6.5.3_DPTF-RC_120_012
4.6.5.3_DPTF-RC_110_011
4.6.5.3_DPTF-RC_100_010b
4.6.5.3_DPTF-RC_100_010a
4.6.5.3_DPTF-RC_100_010
4.6.5.3_DPTF-RC_090_009
4.6.5.3_DPTF-RC_081_008
4.6.5.3_DPTF-RC_080_007
4.6.5.3_DPTF-RC_071_006
4.6.5.3_DPTF-RC_071_005
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2013-06-02
Source Control Label: 4.6.5.3_DPTF-RC_150_015a
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_150_028a or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
TPwrParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
ModulePart Name:DptfAcpiTablesFfrd
ModulePart Description:Intel DPTF Ffrd Acpi Tables Component.
Filename | Description
DptfAcpiTablesFfrd.cif | Intel DPTF Ffrd AcpiTables CIF file.
DptfAcpiTablesFfrd.inf | Intel DPTF Ffrd AcpiTables inf file.
DptfAcpiTablesFfrd.sdl | Intel DPTF Ffrd AcpiTables parameters.
DptfAcpiTablesFfrd.mak | Intel DPTF Ffrd AcpiTables make file.
DptfFfrd.asl | Intel DPTF Ffrd AcpiTables asl file.
Ertm.asl | Intel DPTF Ffrd AcpiTables asl file.
Trt.asl | Intel DPTF Ffrd AcpiTables asl file.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Intel DPTF Refcode
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:
None
Files changed in the Reference or 3rd Party Code:
DptfAcpiTables.mak,DptfAcpiTablesFfrd.mak
[Category] Improvement
[Description] Change IASL compiler path to $(ACPIPLATFORM_ASL_COMPILER) in SharkBay project.
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed:
None
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_150_015
4.6.5.3_DPTF-RC_140_014
4.6.5.3_DPTF-RC_130_013
4.6.5.3_DPTF-RC_120_012
4.6.5.3_DPTF-RC_110_011
4.6.5.3_DPTF-RC_100_010b
4.6.5.3_DPTF-RC_100_010a
4.6.5.3_DPTF-RC_100_010
4.6.5.3_DPTF-RC_090_009
4.6.5.3_DPTF-RC_081_008
4.6.5.3_DPTF-RC_080_007
4.6.5.3_DPTF-RC_071_006
4.6.5.3_DPTF-RC_071_005
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2013-06-21
Source Control Label: 4.6.5.3_DPTF-RC_160_016
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_150_028a or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
TPwrParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
WWANDppmPolicy.asl Intel DPTF AcpiTables asl file. WWANParticipant.asl Intel DPTF AcpiTables asl file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
ModulePart Name:DptfAcpiTablesFfrd
ModulePart Description:Intel DPTF Ffrd Acpi Tables Component.
Filename | Description
DptfAcpiTablesFfrd.cif | Intel DPTF Ffrd AcpiTables CIF file.
DptfAcpiTablesFfrd.inf | Intel DPTF Ffrd AcpiTables inf file.
DptfAcpiTablesFfrd.sdl | Intel DPTF Ffrd AcpiTables parameters.
DptfAcpiTablesFfrd.mak | Intel DPTF Ffrd AcpiTables make file.
DptfFfrd.asl | Intel DPTF Ffrd AcpiTables asl file.
Ertm.asl | Intel DPTF Ffrd AcpiTables asl file.
Trt.asl | Intel DPTF Ffrd AcpiTables asl file.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Shark Bay Client ACPI Reference Code Production Version 1.6.0
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:
None
Files changed in the Reference or 3rd Party Code:
None
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed:
None
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_150_015a
4.6.5.3_DPTF-RC_150_015
4.6.5.3_DPTF-RC_140_014
4.6.5.3_DPTF-RC_130_013
4.6.5.3_DPTF-RC_120_012
4.6.5.3_DPTF-RC_110_011
4.6.5.3_DPTF-RC_100_010b
4.6.5.3_DPTF-RC_100_010a
4.6.5.3_DPTF-RC_100_010
4.6.5.3_DPTF-RC_090_009
4.6.5.3_DPTF-RC_081_008
4.6.5.3_DPTF-RC_080_007
4.6.5.3_DPTF-RC_071_006
4.6.5.3_DPTF-RC_071_005
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2013-07-15
Source Control Label: 4.6.5.3_DPTF-RC_161_017
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_150_028a or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
TPwrParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
WWANDppmPolicy.asl Intel DPTF AcpiTables asl file. WWANParticipant.asl Intel DPTF AcpiTables asl file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
ModulePart Name:DptfAcpiTablesFfrd
ModulePart Description:Intel DPTF Ffrd Acpi Tables Component.
Filename | Description
DptfAcpiTablesFfrd.cif | Intel DPTF Ffrd AcpiTables CIF file.
DptfAcpiTablesFfrd.inf | Intel DPTF Ffrd AcpiTables inf file.
DptfAcpiTablesFfrd.sdl | Intel DPTF Ffrd AcpiTables parameters.
DptfAcpiTablesFfrd.mak | Intel DPTF Ffrd AcpiTables make file.
DptfFfrd.asl | Intel DPTF Ffrd AcpiTables asl file.
Ertm.asl | Intel DPTF Ffrd AcpiTables asl file.
Trt.asl | Intel DPTF Ffrd AcpiTables asl file.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40, Dated: 2012-07-03
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Shark Bay Client ACPI Reference Code Production Version 1.6.1
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:
None
Files changed in the Reference or 3rd Party Code:
New features added in this label:
Feature 1:
Description/Solution:
Support P-state Limiting on CPPC Systems (cTDP feature).
Affected files:
\AcpiTables\Dptf\AcpiTables\Ffrd\DptfFfrd.asl
\AcpiTables\Dptf\AcpiTables\B0d4Participant.asl
\AcpiTables\Dptf\AcpiTables\Dptf.asl
\AcpiTables\Dptf\AcpiTables\TcpuParticipant.asl
Feature 2:
Description/Solution:
Remove Throttling Control from PDRT table when system is AC-powered.
Affected files:
\AcpiTables\Dptf\AcpiTables\Ffrd\DptfFfrd.asl
\AcpiTables\Dptf\AcpiTables\Dptf.asl
Feature 3:
Description/Solution:
Add Read and Write methods to support EC low power mode around EC op region accesses.
Affected files:
\AcpiTables\Dptf\AcpiTables\Ffrd\TFN1Participant.asl
\AcpiTables\Dptf\AcpiTables\Ffrd\TFN2Participant.asl
\AcpiTables\Dptf\AcpiTables\Ffrd\TMemParticipant.asl
\AcpiTables\Dptf\AcpiTables\Ffrd\TSknParticipant.asl
\AcpiTables\Dptf\AcpiTables\TPwrParticipant.asl
\AcpiTables\Dptf\AcpiTables\TSknParticipant.asl
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed:
None
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_160_016
4.6.5.3_DPTF-RC_150_015a
4.6.5.3_DPTF-RC_150_015
4.6.5.3_DPTF-RC_140_014
4.6.5.3_DPTF-RC_130_013
4.6.5.3_DPTF-RC_120_012
4.6.5.3_DPTF-RC_110_011
4.6.5.3_DPTF-RC_100_010b
4.6.5.3_DPTF-RC_100_010a
4.6.5.3_DPTF-RC_100_010
4.6.5.3_DPTF-RC_090_009
4.6.5.3_DPTF-RC_081_008
4.6.5.3_DPTF-RC_080_007
4.6.5.3_DPTF-RC_071_006
4.6.5.3_DPTF-RC_071_005
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2013-11-07
Source Control Label: 4.6.5.3_DPTF-RC_170_018
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_150_028a or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
TPwrParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
WWANDppmPolicy.asl Intel DPTF AcpiTables asl file. WWANParticipant.asl Intel DPTF AcpiTables asl file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
ModulePart Name:DptfAcpiTablesFfrd
ModulePart Description:Intel DPTF Ffrd Acpi Tables Component.
Filename | Description
DptfAcpiTablesFfrd.cif | Intel DPTF Ffrd AcpiTables CIF file.
DptfAcpiTablesFfrd.inf | Intel DPTF Ffrd AcpiTables inf file.
DptfAcpiTablesFfrd.sdl | Intel DPTF Ffrd AcpiTables parameters.
DptfAcpiTablesFfrd.mak | Intel DPTF Ffrd AcpiTables make file.
DptfFfrd.asl | Intel DPTF Ffrd AcpiTables asl file.
Ertm.asl | Intel DPTF Ffrd AcpiTables asl file.
Trt.asl | Intel DPTF Ffrd AcpiTables asl file.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2012-03
Visual eBios: RSS.5.73.0244, Dated: 2012-03
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Shark Bay Client ACPI Reference Code Production Version 1.6.1
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:
None
Files changed in the Reference or 3rd Party Code:
New features added in this label:
Feature 1:
Description/Solution:
Enhance P-state Limiting support on CPPC Systems
Affected files:
\AcpiTables\Dptf\AcpiTables\B0d4Participant.asl
\AcpiTables\Dptf\AcpiTables\TcpuParticipant.asl
Affected Platform:
ULT Only
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed:
None
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_161_017
4.6.5.3_DPTF-RC_160_016
4.6.5.3_DPTF-RC_150_015a
4.6.5.3_DPTF-RC_150_015
4.6.5.3_DPTF-RC_140_014
4.6.5.3_DPTF-RC_130_013
4.6.5.3_DPTF-RC_120_012
4.6.5.3_DPTF-RC_110_011
4.6.5.3_DPTF-RC_100_010b
4.6.5.3_DPTF-RC_100_010a
4.6.5.3_DPTF-RC_100_010
4.6.5.3_DPTF-RC_090_009
4.6.5.3_DPTF-RC_081_008
4.6.5.3_DPTF-RC_080_007
4.6.5.3_DPTF-RC_071_006
4.6.5.3_DPTF-RC_071_005
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2012 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.


Component Information:
Component Title: Intel DPTF
Component Reference Name: Dptf
Component Type: eModule
Release Date: 2014-03-14
Source Control Label: 4.6.5.3_DPTF-RC_180_019
Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/DPTF;
Dependencies
Component Dependencies
ONE
Dependent Component Title: Platform
Dependent Component Reference Name: AcpiPlatform
Dependent Source Control Label: 4.6.5.3_PF-ACPI_RC_180_033 or above
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Platform;

File Dependencies
N0NE

Protocol Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
Intel DPTF initialization.
This is a caption
Filename | Description
Dptf.cif | Intel DPTF eModule CIF file.
Dptf.sdl | Intel DPTF eModule SDL file.
ReleaseNotes.chm | Intel DPTF eModule CHM file.

ModulePart Name:DptfDxe
ModulePart Description:Intel DPTF Dxe Component.
Filename | Description
DptfDxe.cif | Intel DPTF Dxe CIF file.
DptfDxe.sdl | Intel DPTF Dxe parameters.
DptfDxe.mak | Intel DPTF Dxe make file.
Dptf.c | Intel DPTF Dxe C code.
Dptf.dxs | Intel DPTF Dxe dependency file.
Dptf.h | Intel DPTF Dxe porting functions and data structures definition.
Dptf.inf | Intel DPTF Dxe inf file.
ModulePart Name:DptfAcpiTables
ModulePart Description:Intel DPTF Acpi Tables Component.
Filename | Description
DptfAcpiTables.cif | Intel DPTF AcpiTables CIF file.
DptfAcpiTables.sdl | Intel DPTF AcpiTables parameters.
DptfAcpiTables.mak | Intel DPTF AcpiTables make file.
Art.asl | Intel DPTF AcpiTables asl file.
B0d4CtdpPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4DppmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4LpmPolicy.asl | Intel DPTF AcpiTables asl file.
B0d4Participant.asl | Intel DPTF AcpiTables asl file.
DplyParticipant.asl | Intel DPTF AcpiTables asl file.
Dppm.asl | Intel DPTF AcpiTables asl file.
Dptf.asl | Intel DPTF AcpiTables asl file.
Ertm.asl | Intel DPTF AcpiTables asl file.
T_VRDppmPolicy.asl | Intel DPTF AcpiTables asl file.
T_VRParticipant.asl | Intel DPTF AcpiTables asl file.
TAmbDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TAmbParticipant.asl | Intel DPTF AcpiTables asl file.
TcpuDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TcpuParticipant.asl | Intel DPTF AcpiTables asl file.
TEfnDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TEfnParticipant.asl | Intel DPTF AcpiTables asl file.
TFN1Participant.asl | Intel DPTF AcpiTables asl file.
TFN2Participant.asl | Intel DPTF AcpiTables asl file.
TMemDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TMemParticipant.asl | Intel DPTF AcpiTables asl file.
TpchDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TpchParticipant.asl | Intel DPTF AcpiTables asl file.
Trt.asl | Intel DPTF AcpiTables asl file.
TSknDppmPolicy.asl | Intel DPTF AcpiTables asl file.
TSknParticipant.asl | Intel DPTF AcpiTables asl file.
TPwrParticipant.asl | Intel DPTF AcpiTables asl file.
DptfAcpiTables.inf | Intel DPTF AcpiTables inf file.
WWANDppmPolicy.asl Intel DPTF AcpiTables asl file. WWANParticipant.asl Intel DPTF AcpiTables asl file.
ModulePart Name:DptfGuidLib
ModulePart Description:Intel DPTF GuidLib Component.
Filename | Description
DptfGuidLib.cif | Intel DPTF GuidLib CIF file.
DptfGuidLib.sdl | Intel DPTF GuidLib parameters.
DptfGuidLib.mak | Intel DPTF GuidLib make file.
DptfGuidLib.inf | Intel DPTF GuidLib inf file.
DptfAcpiTableStorage.c | Intel DPTF GuidLib GUID definition.
DptfAcpiTableStorage.h | Intel DPTF GuidLib GUID definition.
ModulePart Name:DptfAcpiTablesFfrd
ModulePart Description:Intel DPTF Ffrd Acpi Tables Component.
Filename | Description
DptfAcpiTablesFfrd.cif | Intel DPTF Ffrd AcpiTables CIF file.
DptfAcpiTablesFfrd.inf | Intel DPTF Ffrd AcpiTables inf file.
DptfAcpiTablesFfrd.sdl | Intel DPTF Ffrd AcpiTables parameters.
DptfAcpiTablesFfrd.mak | Intel DPTF Ffrd AcpiTables make file.
DptfFfrd.asl | Intel DPTF Ffrd AcpiTables asl file.
Ertm.asl | Intel DPTF Ffrd AcpiTables asl file.
Trt.asl | Intel DPTF Ffrd AcpiTables asl file.
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41, Dated: 2012-03
Visual eBios: RSS.5.73.0244, Dated: 2012-03
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party Code/File in this Release:
ITEM_TITLE: Shark Bay Client ACPI Reference Code Production Version 1.8.0
Reference or 3rd Party Code updated in this Release:
ITEM_TITLE:
None
Files changed in the Reference or 3rd Party Code:
New features added in this label:
None
General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed:
None
Known Limitations and Erratas in this label:
Errata Item(s) with a Description
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
4.6.5.3_DPTF-RC_170_018
4.6.5.3_DPTF-RC_161_017
4.6.5.3_DPTF-RC_160_016
4.6.5.3_DPTF-RC_150_015a
4.6.5.3_DPTF-RC_150_015
4.6.5.3_DPTF-RC_140_014
4.6.5.3_DPTF-RC_130_013
4.6.5.3_DPTF-RC_120_012
4.6.5.3_DPTF-RC_110_011
4.6.5.3_DPTF-RC_100_010b
4.6.5.3_DPTF-RC_100_010a
4.6.5.3_DPTF-RC_100_010
4.6.5.3_DPTF-RC_090_009
4.6.5.3_DPTF-RC_081_008
4.6.5.3_DPTF-RC_080_007
4.6.5.3_DPTF-RC_071_006
4.6.5.3_DPTF-RC_071_005
4.6.5.3_DPTF-RC_070_004
4.6.5.3_DPTF-RC_061_003
4.6.5.3_DPTF-RC_060_002
4.6.5.3_DPTF-RC_056_001
4.6.5.3_DPTF-RC_055_000

© American Megatrends Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • DptfAcpiTables.mak
  • DptfAcpiTablesFfrd.mak
  • DptfDxe.mak
  • DptfGuidLib.mak
Built on 20:55:21 03/14/14


AMIBIOS Function Reference

DptfAcpiTables.mak

Description:
MAke file to build Intel DPTF ACPI ASL components
Built on 20:55:21 03/14/14


AMIBIOS Function Reference

DptfAcpiTablesFfrd.mak

Description:
MAke file to build Aptio ACPI ASL components
Built on 20:55:21 03/14/14


AMIBIOS Function Reference

DptfDxe.mak

Description:
MAke file to build Intel DPTF components
Built on 20:55:21 03/14/14


AMIBIOS Function Reference

DptfGuidLib.mak

Description:
MAke file to build Intel DPTF GuidLib components
Built on 20:55:21 03/14/14


Functions in Alphabetical Order

AMIBIOS Function Reference

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

Built on 20:55:21 03/14/14


AMIBIOS Function Reference

General Information

Built on 20:55:21 03/14/14