American Megatrends, Inc.

Pfat

Copyright

General Information

Release Notes

© American Megatrends, Inc.


Release Notes - NDA Required

Component Information:
Component Title: PfatServices
Component Reference Name: PfatServices
Component Type: eModule
Release Date: 2012-09-25
Source Control Label: 4.6.5.1_INTEL_PFAT_2
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelPfat;

Dependencies
Dependent Component Title: NVRAM SMI
Dependent Component Reference Name: NvramSmi
Dependent Source Control Label: 4.6.5.1_NvramSmi_3
Dependent Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/NvramSmi;
Non-Compiled BIN and LIB File(s) within this Component:

PfatBinary.bin
Company Name: Intel
General Information: Reference PFAT KIT
Component Description:
This component enables Intel Platform Firmware Armoring Support on a Platform
PfatServices
Filename | Description
PfatServices.cif | CIF file for PfatServices
PfatServices.c | Code listing file that initializes PFAT support in DXE
PfatServices.chm | CHM file for PfatServices
PfatServices.h | Header file for PfatServices module
PfatServices.h | Header file for PfatServices module
PfatServices.inf | INF file for PFATServices module
PfatServices.mak | Make file for PfatServices
PfatServices.sdl | SDL file for PfatServices

ModulePart Name: PFatBinary
ModulePart Description: Defines Pfat binary module included in BIOS
Filename | Description
PfatBinary.cif | CIF file for PfatBinary
PfatBinary.mak | Make file for Pfat Binary module part
PfatBinary.sdl | SDL file for Pfat Binary module part
PfatBinary.bin | This is the Intel Pfat Binary provided by Intel for integration into the BIOS. All PFAT access go through this Binary.
ModulePart Name: PfatFlashLib
ModulePart Description: Defines PFAT flash library
Filename | Description
PfatFlashLib.cif | CIF file for PfatFlashLib
PfatFlashLib.c | Provides flash library override when Pfat support is enabled
PfatFlashLib.sdl | SDL file for PfatFlashLib
PfatFlashLib.mak | Make file for PfatFlashLib
ModulePart Name: PfatPubKey
ModulePart Description: Defined the process for creating the final Pfat Update Package
Filename | Description
PfatPubKey.cif | CIF file for PfatPubKey
PfatPubKey.mak | Defines the make process for creating the final Pfat binary as well as Pfat public and private key generation
PfatPubKey.sdl | SDL file for PfatPubKey
Dummy.bin | Dummy helper file for initial generation extraction of pfat public key from private key.
ModulePart Name: PfatUtilsandScripts
ModulePart Description: Contains the tools and binaries used for creating the final PFAT Update Package
Filename | Description
PfatUtilsandScripts.cif | CIF file for PfatUtilsandScripts
.VKeyExp | Exponent binary for PFAT private key
Keygen | Tool for creating PFAT keys
PfatCertHeader.bin | Binary that describes the header file for pfat binaries
PfatCryptoCon.exe | Tool for creating Pfat hashes and signatures.
PfatUtilsandScripts.sdl | SDL file for PfatUtilsandScripts
PPB.exe | Intel Tool for creating the PFAT Update Package.
Psl2Bin.exe | Intel Tool for converting PFAT psl scripts into binaries.
ModulePart Name: PfatCpuPolicyOverride
ModulePart Description: Defines the Pfat policies for the system.
Filename | Description
PfatCpuPolicyOverride.cif | CIF file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.c | Code file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.dxs | Dependency file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.h | Header file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.mak | Make file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.sdl | SDL file for PfatCpuPolicyOverride
ModulePart Name: PfatSetup
ModulePart Description: Defines the Pfat Setup support
Filename | Description
PfatSetup.cif | CIF file for PfatSetup
PfatSetup.sd | Setup Description file for PfatSetup
PfatSetup.uni | UNI file for PfatSetup
PfatSetup.mak | Make file for PfatSetup
PfatSetup.sdl | SDL file for PfatSetup
AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
General Bug Fixes and EIP Addressed in this Label:
NONE

EIP Addressed
NONE
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
Booting to BIOS Setup with PFAT support enabled or disabled
Booting to Windows 8 with PFAT support enabled or disabled
Secure PFAT update using PFAT SFAM Policies and Signed PUPs
Validation Testing:
Release History:

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: PfatServices
Component Reference Name: PfatServices
Component Type: eModule
Release Date: 2012-10-05
Source Control Label: 4.6.5.1_INTEL_PFAT_2_1
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelPfat;

Dependencies
Dependent Component Title: NVRAM SMI
Dependent Component Reference Name: NvramSmi
Dependent Source Control Label: 4.6.5.1_NvramSmi_3
Dependent Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/NvramSmi;
Non-Compiled BIN and LIB File(s) within this Component:

PfatBinary.bin
Company Name: Intel
General Information: Reference PFAT KIT Beta 0.8
Component Description:
This component enables Intel Platform Firmware Armoring Support on a Platform
PfatServices
Filename | Description
PfatServices.cif | CIF file for PfatServices
PfatServices.c | Code listing file that initializes PFAT support in DXE
PfatServices.chm | CHM file for PfatServices
PfatServices.h | Header file for PfatServices module
PfatServices.h | Header file for PfatServices module
PfatServices.inf | INF file for PFATServices module
PfatServices.mak | Make file for PfatServices
PfatServices.sdl | SDL file for PfatServices

ModulePart Name: PFatBinary
ModulePart Description: Defines Pfat binary module included in BIOS
Filename | Description
PfatBinary.cif | CIF file for PfatBinary
PfatBinary.mak | Make file for Pfat Binary module part
PfatBinary.sdl | SDL file for Pfat Binary module part
PfatBinary.bin | This is the Intel Pfat Binary provided by Intel for integration into the BIOS. All PFAT access go through this Binary.
ModulePart Name: PfatFlashLib
ModulePart Description: Defines PFAT flash library
Filename | Description
PfatFlashLib.cif | CIF file for PfatFlashLib
PfatFlashLib.c | Provides flash library override when Pfat support is enabled
PfatFlashLib.sdl | SDL file for PfatFlashLib
PfatFlashLib.mak | Make file for PfatFlashLib
ModulePart Name: PfatPubKey
ModulePart Description: Defined the process for creating the final Pfat Update Package
Filename | Description
PfatPubKey.cif | CIF file for PfatPubKey
PfatPubKey.mak | Defines the make process for creating the final Pfat binary as well as Pfat public and private key generation
PfatPubKey.sdl | SDL file for PfatPubKey
Dummy.bin | Dummy helper file for initial generation extraction of pfat public key from private key.
ModulePart Name: PfatUtilsandScripts
ModulePart Description: Contains the tools and binaries used for creating the final PFAT Update Package
Filename | Description
PfatUtilsandScripts.cif | CIF file for PfatUtilsandScripts
.VKeyExp | Exponent binary for PFAT private key
Keygen | Tool for creating PFAT keys
PfatCertHeader.bin | Binary that describes the header file for pfat binaries
PfatCryptoCon.exe | Tool for creating Pfat hashes and signatures.
PfatUtilsandScripts.sdl | SDL file for PfatUtilsandScripts
PPB.exe | Intel Tool for creating the PFAT Update Package.
Psl2Bin.exe | Intel Tool for converting PFAT psl scripts into binaries.
ModulePart Name: PfatCpuPolicyOverride
ModulePart Description: Defines the Pfat policies for the system.
Filename | Description
PfatCpuPolicyOverride.cif | CIF file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.c | Code file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.dxs | Dependency file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.h | Header file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.mak | Make file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.sdl | SDL file for PfatCpuPolicyOverride
ModulePart Name: PfatSetup
ModulePart Description: Defines the Pfat Setup support
Filename | Description
PfatSetup.cif | CIF file for PfatSetup
PfatSetup.sd | Setup Description file for PfatSetup
PfatSetup.uni | UNI file for PfatSetup
PfatSetup.mak | Make file for PfatSetup
PfatSetup.sdl | SDL file for PfatSetup
AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
General Bug Fixes and EIP Addressed in this Label:
NONE

EIP Addressed
EIP 103265 : Updated PFAT Module to RC version 0.8 Beta
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes
NONE

EIP Addressed
NONE
Known Limitations and Erratas in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
Booting to BIOS Setup with PFAT support enabled or disabled
Booting to Windows 8 with PFAT support enabled or disabled
Secure PFAT update using PFAT SFAM Policies and Signed PUPs
Validation Testing:
Release History:

4.6.5.1_INTEL_PFAT_2

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: PfatServices
Component Reference Name: PfatServices
Component Type: eModule
Release Date: 2012-10-19
Source Control Label: 4.6.5.1_INTEL_PFAT_2_2
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelPfat;

Dependencies
Dependent Component Title: NVRAM SMI
Dependent Component Reference Name: NvramSmi
Dependent Source Control Label: 4.6.5.1_NvramSmi_3
Dependent Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/NvramSmi;
Non-Compiled BIN and LIB File(s) within this Component:

PfatBinary.bin
Company Name: Intel
General Information: Reference PFAT KIT Beta 0.8
Component Description:
This component enables Intel Platform Firmware Armoring Support on a Platform
PfatServices
Filename | Description
PfatServices.cif | CIF file for PfatServices
PfatServices.c | Code listing file that initializes PFAT support in DXE
PfatServices.chm | CHM file for PfatServices
PfatServices.h | Header file for PfatServices module
PfatServices.h | Header file for PfatServices module
PfatServices.inf | INF file for PFATServices module
PfatServices.mak | Make file for PfatServices
PfatServices.sdl | SDL file for PfatServices

ModulePart Name: PFatBinary
ModulePart Description: Defines Pfat binary module included in BIOS
Filename | Description
PfatBinary.cif | CIF file for PfatBinary
PfatBinary.mak | Make file for Pfat Binary module part
PfatBinary.sdl | SDL file for Pfat Binary module part
PfatBinary.bin | This is the Intel Pfat Binary provided by Intel for integration into the BIOS. All PFAT access go through this Binary.
ModulePart Name: PfatFlashLib
ModulePart Description: Defines PFAT flash library
Filename | Description
PfatFlashLib.cif | CIF file for PfatFlashLib
PfatFlashLib.c | Provides flash library override when Pfat support is enabled
PfatFlashLib.sdl | SDL file for PfatFlashLib
PfatFlashLib.mak | Make file for PfatFlashLib
ModulePart Name: PfatPubKey
ModulePart Description: Defined the process for creating the final Pfat Update Package
Filename | Description
PfatPubKey.cif | CIF file for PfatPubKey
PfatPubKey.mak | Defines the make process for creating the final Pfat binary as well as Pfat public and private key generation
PfatPubKey.sdl | SDL file for PfatPubKey
Dummy.bin | Dummy helper file for initial generation extraction of pfat public key from private key.
ModulePart Name: PfatUtilsandScripts
ModulePart Description: Contains the tools and binaries used for creating the final PFAT Update Package
Filename | Description
PfatUtilsandScripts.cif | CIF file for PfatUtilsandScripts
.VKeyExp | Exponent binary for PFAT private key
Keygen | Tool for creating PFAT keys
PfatCertHeader.bin | Binary that describes the header file for pfat binaries
PfatCryptoCon.exe | Tool for creating Pfat hashes and signatures.
PfatUtilsandScripts.sdl | SDL file for PfatUtilsandScripts
PPB.exe | Intel Tool for creating the PFAT Update Package.
Psl2Bin.exe | Intel Tool for converting PFAT psl scripts into binaries.
ModulePart Name: PfatCpuPolicyOverride
ModulePart Description: Defines the Pfat policies for the system.
Filename | Description
PfatCpuPolicyOverride.cif | CIF file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.c | Code file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.dxs | Dependency file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.h | Header file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.mak | Make file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.sdl | SDL file for PfatCpuPolicyOverride
ModulePart Name: PfatSetup
ModulePart Description: Defines the Pfat Setup support
Filename | Description
PfatSetup.cif | CIF file for PfatSetup
PfatSetup.sd | Setup Description file for PfatSetup
PfatSetup.uni | UNI file for PfatSetup
PfatSetup.mak | Make file for PfatSetup
PfatSetup.sdl | SDL file for PfatSetup
AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
General Bug Fixes and EIP Addressed in this Label:
NONE

EIP Addressed
EIP 103945 : The system can't enter UEFI WIN8 OS when PFAT is Disabled and CSM is disabled
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

EIP 103945
PfatFlashLib.c
Known Limitations and Erratas in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
Booting to BIOS Setup with PFAT support enabled or disabled
Booting to Windows 8 with PFAT support enabled or disabled
Secure PFAT update using PFAT SFAM Policies and Signed PUPs
Validation Testing:
Release History:

4.6.5.1_INTEL_PFAT_2
4.6.5.1_INTEL_PFAT_2_1

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: PfatServices
Component Reference Name: PfatServices
Component Type: eModule
Release Date: 2012-11-20
Source Control Label: 4.6.5.1_INTEL_PFAT_2_3
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelPfat;

Dependencies
Dependent Component Title: NVRAM SMI
Dependent Component Reference Name: NvramSmi
Dependent Source Control Label: 4.6.5.1_NvramSmi_3
Dependent Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/NvramSmi;
Non-Compiled BIN and LIB File(s) within this Component:

PfatBinary.bin
Company Name: Intel
General Information: Reference PFAT KIT Beta 0.8
Component Description:
This component enables Intel Platform Firmware Armoring Support on a Platform
PfatServices
Filename | Description
PfatServices.cif | CIF file for PfatServices
PfatServices.c | Code listing file that initializes PFAT support in DXE
PfatServices.chm | CHM file for PfatServices
PfatServices.h | Header file for PfatServices module
PfatServices.h | Header file for PfatServices module
PfatServices.inf | INF file for PFATServices module
PfatServices.mak | Make file for PfatServices
PfatServices.sdl | SDL file for PfatServices

ModulePart Name: PFatBinary
ModulePart Description: Defines Pfat binary module included in BIOS
Filename | Description
PfatBinary.cif | CIF file for PfatBinary
PfatBinary.mak | Make file for Pfat Binary module part
PfatBinary.sdl | SDL file for Pfat Binary module part
PfatBinary.bin | This is the Intel Pfat Binary provided by Intel for integration into the BIOS. All PFAT access go through this Binary.
ModulePart Name: PfatFlashLib
ModulePart Description: Defines PFAT flash library
Filename | Description
PfatFlashLib.cif | CIF file for PfatFlashLib
PfatFlashLib.c | Provides flash library override when Pfat support is enabled
PfatFlashLib.sdl | SDL file for PfatFlashLib
PfatFlashLib.mak | Make file for PfatFlashLib
ModulePart Name: PfatPubKey
ModulePart Description: Defined the process for creating the final Pfat Update Package
Filename | Description
PfatPubKey.cif | CIF file for PfatPubKey
PfatPubKey.mak | Defines the make process for creating the final Pfat binary as well as Pfat public and private key generation
PfatPubKey.sdl | SDL file for PfatPubKey
Dummy.bin | Dummy helper file for initial generation extraction of pfat public key from private key.
ModulePart Name: PfatUtilsandScripts
ModulePart Description: Contains the tools and binaries used for creating the final PFAT Update Package
Filename | Description
PfatUtilsandScripts.cif | CIF file for PfatUtilsandScripts
.VKeyExp | Exponent binary for PFAT private key
BuildAmiPfatHeader.exe | Ami executable for creating AMI specific pfat header to aid in flashing
BuildPSL.bat | Batch file to build PFAT Script for flashing
CutRom.exe | Ami executable to aid in stitching and creating PFAT binaries
dummyfile.bin | file used by pfatcryptoCon for extracting public key from private key
Keygen | Tool for creating PFAT keys
PfatCertHeader.bin | Binary that describes the header file for pfat binaries
PfatCryptoCon.exe | Tool for creating Pfat hashes and signatures.
PfatPubKeysAndBuildPSL.sdl | SDL file for PfatPubKeysAndBuildPSL
PfatPubKeysAndBuildPSL.mak | Make file for PfatPubKeysAndBuildPSL
PPB.exe | Intel Tool for creating the PFAT Update Package.
Psl2Bin.exe | Intel Tool for converting PFAT psl scripts into binaries.
ModulePart Name: PfatCpuPolicyOverride
ModulePart Description: Defines the Pfat policies for the system.
Filename | Description
PfatCpuPolicyOverride.cif | CIF file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.c | Code file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.dxs | Dependency file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.h | Header file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.mak | Make file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.sdl | SDL file for PfatCpuPolicyOverride
Opensslib.lib | Openssl Crypto library
PeiCryptLib.lib | Pei Crypto library
ModulePart Name: PfatSetup
ModulePart Description: Defines the Pfat Setup support
Filename | Description
PfatSetup.cif | CIF file for PfatSetup
PfatSetup.sd | Setup Description file for PfatSetup
PfatSetup.uni | UNI file for PfatSetup
PfatSetup.mak | Make file for PfatSetup
PfatSetup.sdl | SDL file for PfatSetup
AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
Other Tools Requirements
The Intel PFAT Tools such as PSL2Bin.exe and PPB.exe require Microsoft Redistribution Package Installed on the Build platform.
The 32 bit version can be found at: Microsoft Redistribution Package 32 Bit
The 64 bit version can be found at: Microsoft Redistribution Package 64 Bit
General Bug Fixes and EIP Addressed in this Label:

EIP Addressed
EIP 103945 : The system can't enter UEFI WIN8 OS when PFAT is Disabled and CSM is disabled
EIP 105153 : Possible system hang if NVRAM is access during legacy O.S.
EIP 106901 : Assert in debug mode when PFAT is disabled and Debug mode is enabled
EIP 106901 : When PFAT module is support and BIOS lock is Enabled on setup menu,setup NvRam data can't be save
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

EIP 103945:
PfatFlashLib.c

EIP 105153:
PfatFlashLib.c

EIP 106901:
PfatServices.sdl
PfatPubKeysAndBuildPSL.sdl
Known Limitations and Erratas in this label:
NO known limitations
Errata:
System Policies: Default implementation has a setup flag to disable and enable Pfat support. For production systems where PFAT is supported, it is suggested to set Pfat to default enabled and disallow the manipulation of the setup variable
Remaining Issues:
NONE
Unit Testing:
Booting to BIOS Setup with PFAT support enabled or disabled
Booting to Windows 8 with PFAT support enabled or disabled
Secure PFAT update using PFAT SFAM Policies and Signed PUPs
Validation Testing:
Release History:

4.6.5.1_INTEL_PFAT_2
4.6.5.1_INTEL_PFAT_2_1
4.6.5.1_INTEL_PFAT_2_2

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel PFAT Technology
Component Reference Name: Intel PFAT Technology
Component Type: eModule
Release Date: 2012-12-03
Source Control Label: 4.6.5.1_INTEL_PFAT_2_4
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelPfat;

Dependencies
Dependent Component Title: NVRAM SMI
Dependent Component Reference Name: NvramSmi
Dependent Source Control Label: 4.6.5.1_NvramSmi_3
Dependent Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/NvramSmi;
Dependent Component Title: Rom Image
Dependent Component Reference Name: RomImage
Dependent Source Control Label: 4.6.5.3_RomImage_014
Dependent Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/RomImage;
Non-Compiled BIN and LIB File(s) within this Component:

PfatBinary.bin
Company Name: Intel
General Information: Reference PFAT KIT Beta 0.8
Component Description:
This component enables Intel Platform Firmware Armoring Support on a Platform
PfatServices
Filename | Description
PfatServices.cif | CIF file for PfatServices
PfatServices.c | Code listing file that initializes PFAT support in DXE
PfatServices.chm | CHM file for PfatServices
PfatServices.h | Header file for PfatServices module
PfatServices.h | Header file for PfatServices module
PfatServices.inf | INF file for PFATServices module
PfatServices.mak | Make file for PfatServices
PfatServices.sdl | SDL file for PfatServices

ModulePart Name: PFatBinary
ModulePart Description: Defines Pfat binary module included in BIOS
Filename | Description
PfatBinary.cif | CIF file for PfatBinary
PfatBinary.mak | Make file for Pfat Binary module part
PfatBinary.sdl | SDL file for Pfat Binary module part
PfatBinary.bin | This is the Intel Pfat Binary provided by Intel for integration into the BIOS. All PFAT access go through this Binary.
ModulePart Name: PfatFlashLib
ModulePart Description: Defines PFAT flash library
Filename | Description
PfatFlashLib.cif | CIF file for PfatFlashLib
PfatFlashLib.c | Provides flash library override when Pfat support is enabled
PfatFlashLib.sdl | SDL file for PfatFlashLib
PfatFlashLib.mak | Make file for PfatFlashLib
ModulePart Name: PfatPubKey
ModulePart Description: Defined the process for creating the final Pfat Update Package
Filename | Description
PfatPubKey.cif | CIF file for PfatPubKey
PfatPubKey.mak | Defines the make process for creating the final Pfat binary as well as Pfat public and private key generation
PfatPubKey.sdl | SDL file for PfatPubKey
Dummy.bin | Dummy helper file for initial generation extraction of pfat public key from private key.
ModulePart Name: PfatUtilsandScripts
ModulePart Description: Contains the tools and binaries used for creating the final PFAT Update Package
Filename | Description
PfatUtilsandScripts.cif | CIF file for PfatUtilsandScripts
.VKeyExp | Exponent binary for PFAT private key
BuildAmiPfatHeader.exe | Ami executable for creating AMI specific pfat header to aid in flashing
BuildPSL.bat | Batch file to build PFAT Script for flashing
CutRom.exe | Ami executable to aid in stitching and creating PFAT binaries
dummyfile.bin | file used by pfatcryptoCon for extracting public key from private key
Keygen | Tool for creating PFAT keys
PfatCertHeader.bin | Binary that describes the header file for pfat binaries
PfatCryptoCon.exe | Tool for creating Pfat hashes and signatures.
PfatPubKeysAndBuildPSL.sdl | SDL file for PfatPubKeysAndBuildPSL
PfatPubKeysAndBuildPSL.mak | Make file for PfatPubKeysAndBuildPSL
PPB.exe | Intel Tool for creating the PFAT Update Package.
Psl2Bin.exe | Intel Tool for converting PFAT psl scripts into binaries.
ModulePart Name: PfatCpuPolicyOverride
ModulePart Description: Defines the Pfat policies for the system.
Filename | Description
PfatCpuPolicyOverride.cif | CIF file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.c | Code file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.dxs | Dependency file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.h | Header file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.mak | Make file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.sdl | SDL file for PfatCpuPolicyOverride
Opensslib.lib | Openssl Crypto library
PeiCryptLib.lib | Pei Crypto library
ModulePart Name: PfatSetup
ModulePart Description: Defines the Pfat Setup support
Filename | Description
PfatSetup.cif | CIF file for PfatSetup
PfatSetup.sd | Setup Description file for PfatSetup
PfatSetup.uni | UNI file for PfatSetup
PfatSetup.mak | Make file for PfatSetup
PfatSetup.sdl | SDL file for PfatSetup
AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
Other Tools Requirements
The Intel PFAT Tools such as PSL2Bin.exe and PPB.exe require Microsoft Redistribution Package Installed on the Build platform.
The 32 bit version can be found at: Microsoft Redistribution Package 32 Bit
The 64 bit version can be found at: Microsoft Redistribution Package 64 Bit
General Bug Fixes and EIP Addressed in this Label:

EIP Addressed
EIP 107917 : In some build environments, When Sharkbay BIOS build, error occurs in CutRom.exe.
EIP 107344 : AFULNX2 fails
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

EIP 107917:
BuildPSL.bat

EIP 107344:
PfatFlashLib.c
Known Limitations and Erratas in this label:
NO known limitations
Errata:
System Policies: Default implementation has a setup flag to disable and enable Pfat support. For production systems where PFAT is supported, it is suggested to set Pfat to default enabled and disallow the manipulation of the setup variable
Remaining Issues:
NONE
Unit Testing:
Booting to BIOS Setup with PFAT support enabled or disabled
Booting to Windows 8 with PFAT support enabled or disabled
Secure PFAT update using PFAT SFAM Policies and Signed PUPs
Validation Testing:
Release History:

4.6.5.1_INTEL_PFAT_2
4.6.5.1_INTEL_PFAT_2_1
4.6.5.1_INTEL_PFAT_2_2
4.6.5.1_INTEL_PFAT_2_3

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel PFAT Technology
Component Reference Name: Intel PFAT Technology
Component Type: eModule
Release Date: 2012-01-18
Source Control Label: 4.6.5.1_INTEL_PFAT_2_5
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelPfat;

Dependencies
Dependent Component Title: NVRAM SMI
Dependent Component Reference Name: NvramSmi
Dependent Source Control Label: 4.6.5.1_NvramSmi_3
Dependent Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/NvramSmi;
Dependent Component Title: Rom Image
Dependent Component Reference Name: RomImage
Dependent Source Control Label: 4.6.5.3_RomImage_014
Dependent Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/RomImage;
Non-Compiled BIN and LIB File(s) within this Component:

PfatBinary.bin
Company Name: Intel
General Information: Reference PFAT KIT Beta .95
Component Description:
This component enables Intel Platform Firmware Armoring Support on a Platform
PfatServices
Filename | Description
PfatServices.cif | CIF file for PfatServices
PfatServices.c | Code listing file that initializes PFAT support in DXE
PfatServices.chm | CHM file for PfatServices
PfatServices.h | Header file for PfatServices module
PfatServices.h | Header file for PfatServices module
PfatServices.inf | INF file for PFATServices module
PfatServices.mak | Make file for PfatServices
PfatServices.sdl | SDL file for PfatServices

ModulePart Name: PFatBinary
ModulePart Description: Defines Pfat binary module included in BIOS
Filename | Description
PfatBinary.cif | CIF file for PfatBinary
PfatBinary.mak | Make file for Pfat Binary module part
PfatBinary.sdl | SDL file for Pfat Binary module part
PfatBinary.bin | This is the Intel Pfat Binary provided by Intel for integration into the BIOS. All PFAT access go through this Binary.
ModulePart Name: PfatFlashLib
ModulePart Description: Defines PFAT flash library
Filename | Description
PfatFlashLib.cif | CIF file for PfatFlashLib
PfatFlashLib.c | Provides flash library override when Pfat support is enabled
PfatFlashLib.sdl | SDL file for PfatFlashLib
PfatFlashLib.mak | Make file for PfatFlashLib
ModulePart Name: PfatPubKey
ModulePart Description: Defined the process for creating the final Pfat Update Package
Filename | Description
PfatPubKey.cif | CIF file for PfatPubKey
PfatPubKey.mak | Defines the make process for creating the final Pfat binary as well as Pfat public and private key generation
PfatPubKey.sdl | SDL file for PfatPubKey
Dummy.bin | Dummy helper file for initial generation extraction of pfat public key from private key.
ModulePart Name: PfatUtilsandScripts
ModulePart Description: Contains the tools and binaries used for creating the final PFAT Update Package
Filename | Description
PfatUtilsandScripts.cif | CIF file for PfatUtilsandScripts
.VKeyExp | Exponent binary for PFAT private key
BuildAmiPfatHeader.exe | Ami executable for creating AMI specific pfat header to aid in flashing
BuildPSL.bat | Batch file to build PFAT Script for flashing
CutRom.exe | Ami executable to aid in stitching and creating PFAT binaries
dummyfile.bin | file used by pfatcryptoCon for extracting public key from private key
Keygen | Tool for creating PFAT keys
PfatCertHeader.bin | Binary that describes the header file for pfat binaries
PfatCryptoCon.exe | Tool for creating Pfat hashes and signatures.
PfatPubKeysAndBuildPSL.sdl | SDL file for PfatPubKeysAndBuildPSL
PfatPubKeysAndBuildPSL.mak | Make file for PfatPubKeysAndBuildPSL
PPB.exe | Intel Tool for creating the PFAT Update Package.
Psl2Bin.exe | Intel Tool for converting PFAT psl scripts into binaries.
ModulePart Name: PfatCpuPolicyOverride
ModulePart Description: Defines the Pfat policies for the system.
Filename | Description
PfatCpuPolicyOverride.cif | CIF file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.c | Code file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.dxs | Dependency file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.h | Header file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.mak | Make file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.sdl | SDL file for PfatCpuPolicyOverride
Opensslib.lib | Openssl Crypto library
PeiCryptLib.lib | Pei Crypto library
ModulePart Name: PfatSetup
ModulePart Description: Defines the Pfat Setup support
Filename | Description
PfatSetup.cif | CIF file for PfatSetup
PfatSetup.sd | Setup Description file for PfatSetup
PfatSetup.uni | UNI file for PfatSetup
PfatSetup.mak | Make file for PfatSetup
PfatSetup.sdl | SDL file for PfatSetup
AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
Other Tools Requirements
The Intel PFAT Tools such as PSL2Bin.exe and PPB.exe require Microsoft Redistribution Package Installed on the Build platform.
The 32 bit version can be found at: Microsoft Redistribution Package 32 Bit
The 64 bit version can be found at: Microsoft Redistribution Package 64 Bit
General Bug Fixes and EIP Addressed in this Label:

EIP Addressed
EIP 112622 : Update Haswell PFAT Module and Tools to Production Candidate 0.95
EIP 109350 : Building error when the token of BUILD_PEI_FLASH_LIB = 1 for PFAT module
EIP 112480 : CutRom.exe, BuildAmiPfatHeader.exe, BpmKmGen.exe and FITUtil.exe can't work when users didn't install the Microsoft Visual C++ 2010 Redistributable Package
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

EIP 109350:
PfatFlashLib.c
Known Limitations and Erratas in this label:
NO known limitations
Errata:
System Policies: Default implementation has a setup flag to disable and enable Pfat support. For production systems where PFAT is supported, it is suggested to set Pfat to default enabled and disallow the manipulation of the setup variable
Remaining Issues:
NONE
Unit Testing:
Booting to BIOS Setup with PFAT support enabled or disabled
Booting to Windows 8 with PFAT support enabled or disabled
Secure PFAT update using PFAT SFAM Policies and Signed PUPs
Validation Testing:
Release History:

4.6.5.1_INTEL_PFAT_2
4.6.5.1_INTEL_PFAT_2_1
4.6.5.1_INTEL_PFAT_2_2
4.6.5.1_INTEL_PFAT_2_3
4.6.5.1_INTEL_PFAT_2_4

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel PFAT Technology
Component Reference Name: Intel PFAT Technology
Component Type: eModule
Release Date: 2012-01-18
Source Control Label: 4.6.5.1_INTEL_PFAT_2_6
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelPfat;

Dependencies
Dependent Component Title: NVRAM SMI
Dependent Component Reference Name: NvramSmi
Dependent Source Control Label: 4.6.5.1_NvramSmi_3
Dependent Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/NvramSmi;
Dependent Component Title: Rom Image
Dependent Component Reference Name: RomImage
Dependent Source Control Label: 4.6.5.3_RomImage_014
Dependent Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/RomImage;
Dependent Component Title: Intel System Agent
Dependent Component Reference Name:Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_130_027
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:

PfatBinary.bin
Company Name: Intel
General Information: Reference PFAT KIT Beta .95
Component Description:
This component enables Intel Platform Firmware Armoring Support on a Platform
PfatServices
Filename | Description
PfatServices.cif | CIF file for PfatServices
PfatServices.c | Code listing file that initializes PFAT support in DXE
PfatServices.chm | CHM file for PfatServices
PfatServices.h | Header file for PfatServices module
PfatServices.h | Header file for PfatServices module
PfatServices.inf | INF file for PFATServices module
PfatServices.mak | Make file for PfatServices
PfatServices.sdl | SDL file for PfatServices

ModulePart Name: PFatBinary
ModulePart Description: Defines Pfat binary module included in BIOS
Filename | Description
PfatBinary.cif | CIF file for PfatBinary
PfatBinary.mak | Make file for Pfat Binary module part
PfatBinary.sdl | SDL file for Pfat Binary module part
PfatBinary.bin | This is the Intel Pfat Binary provided by Intel for integration into the BIOS. All PFAT access go through this Binary.
ModulePart Name: PfatFlashLib
ModulePart Description: Defines PFAT flash library
Filename | Description
PfatFlashLib.cif | CIF file for PfatFlashLib
PfatFlashLib.c | Provides flash library override when Pfat support is enabled
PfatFlashLib.sdl | SDL file for PfatFlashLib
PfatFlashLib.mak | Make file for PfatFlashLib
ModulePart Name: PfatPubKey
ModulePart Description: Defined the process for creating the final Pfat Update Package
Filename | Description
PfatPubKey.cif | CIF file for PfatPubKey
PfatPubKey.mak | Defines the make process for creating the final Pfat binary as well as Pfat public and private key generation
PfatPubKey.sdl | SDL file for PfatPubKey
Dummy.bin | Dummy helper file for initial generation extraction of pfat public key from private key.
ModulePart Name: PfatUtilsandScripts
ModulePart Description: Contains the tools and binaries used for creating the final PFAT Update Package
Filename | Description
PfatUtilsandScripts.cif | CIF file for PfatUtilsandScripts
.VKeyExp | Exponent binary for PFAT private key
BuildAmiPfatHeader.exe | Ami executable for creating AMI specific pfat header to aid in flashing
BuildPSL.bat | Batch file to build PFAT Script for flashing
CutRom.exe | Ami executable to aid in stitching and creating PFAT binaries
dummyfile.bin | file used by pfatcryptoCon for extracting public key from private key
Keygen | Tool for creating PFAT keys
PfatCertHeader.bin | Binary that describes the header file for pfat binaries
PfatCryptoCon.exe | Tool for creating Pfat hashes and signatures.
PfatPubKeysAndBuildPSL.sdl | SDL file for PfatPubKeysAndBuildPSL
PfatPubKeysAndBuildPSL.mak | Make file for PfatPubKeysAndBuildPSL
PPB.exe | Intel Tool for creating the PFAT Update Package.
Psl2Bin.exe | Intel Tool for converting PFAT psl scripts into binaries.
ModulePart Name: PfatCpuPolicyOverride
ModulePart Description: Defines the Pfat policies for the system.
Filename | Description
PfatCpuPolicyOverride.cif | CIF file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.c | Code file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.dxs | Dependency file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.h | Header file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.mak | Make file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.sdl | SDL file for PfatCpuPolicyOverride
Opensslib.lib | Openssl Crypto library
PeiCryptLib.lib | Pei Crypto library
ModulePart Name: PfatSetup
ModulePart Description: Defines the Pfat Setup support
Filename | Description
PfatSetup.cif | CIF file for PfatSetup
PfatSetup.sd | Setup Description file for PfatSetup
PfatSetup.uni | UNI file for PfatSetup
PfatSetup.mak | Make file for PfatSetup
PfatSetup.sdl | SDL file for PfatSetup
ModulePart Name: PfatRecovery
ModulePart Description: Provides recovery support in Pfat
Filename | Description
PfatRecovery.cif | CIF file for PfatRecovery
PfatRecovery.c | Code listing for PfatRecovery
PfatRecovery.dxs | dependency file for PfatRecovery
PfatRecovery.mak | Make file for PfatRecovery
PfatRecovery.sdl | SDL file for PfatRecovery
PfatRecoveryHook.sdl | support file to hook recovery flow
AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
Other Tools Requirements
The Intel PFAT Tools such as PSL2Bin.exe and PPB.exe may require Microsoft Redistribution Package Installed on the Build platform.
The 32 bit version can be found at: Microsoft Redistribution Package 32 Bit
The 64 bit version can be found at: Microsoft Redistribution Package 64 Bit
General Bug Fixes and EIP Addressed in this Label:

EIP Addressed
EIP 106660: Support flash recovery function for Intel PFAT

EIP Addressed
EIP 114403: PFAT Haswell BIOS Guard SDK Production Version 1.0 Tools check-in
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

EIP 106660:
Added PfatRecovery Sub-component

EIP 114403:
Updated PfatTools PPB.exe and psl2bin.exe
Known Limitations and Erratas in this label:
NO known limitations
Errata:
System Policies: Default implementation has a setup flag to disable and enable Pfat support. For production systems where PFAT is supported, it is suggested to set Pfat to default enabled and disallow the manipulation of the setup variable
Remaining Issues:
NONE
Unit Testing:
Booting to BIOS Setup with PFAT support enabled or disabled
Booting to Windows 8 with PFAT support enabled or disabled
Secure PFAT update using PFAT SFAM Policies and Signed PUPs
Validation Testing:
Release History:

4.6.5.1_INTEL_PFAT_2
4.6.5.1_INTEL_PFAT_2_1
4.6.5.1_INTEL_PFAT_2_2
4.6.5.1_INTEL_PFAT_2_3
4.6.5.1_INTEL_PFAT_2_4
4.6.5.1_INTEL_PFAT_2_5

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel PFAT Technology
Component Reference Name: Intel PFAT Technology
Component Type: eModule
Release Date: 2013-05-29
Source Control Label: 4.6.5.1_INTEL_PFAT_2_8
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelPfat;

Dependencies
Dependent Component Title: NVRAM SMI
Dependent Component Reference Name: NvramSmi
Dependent Source Control Label: 4.6.5.1_NvramSmi_3
Dependent Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/NvramSmi;
Dependent Component Title: Rom Image
Dependent Component Reference Name: RomImage
Dependent Source Control Label: 4.6.5.3_RomImage_014
Dependent Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/RomImage;
Dependent Component Title: Intel System Agent
Dependent Component Reference Name:Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_130_027
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:

PfatBinary.bin
Company Name: Intel
General Information: Reference PFAT KIT Beta .95
Component Description:
This component enables Intel Platform Firmware Armoring Support on a Platform
PfatServices
Filename | Description
PfatServices.cif | CIF file for PfatServices
PfatServices.c | Code listing file that initializes PFAT support in DXE
PfatServices.chm | CHM file for PfatServices
PfatServices.h | Header file for PfatServices module
PfatServices.h | Header file for PfatServices module
PfatServices.inf | INF file for PFATServices module
PfatServices.mak | Make file for PfatServices
PfatServices.sdl | SDL file for PfatServices

ModulePart Name: PFatBinary
ModulePart Description: Defines Pfat binary module included in BIOS
Filename | Description
PfatBinary.cif | CIF file for PfatBinary
PfatBinary.mak | Make file for Pfat Binary module part
PfatBinary.sdl | SDL file for Pfat Binary module part
PfatBinary.bin | This is the Intel Pfat Binary provided by Intel for integration into the BIOS. All PFAT access go through this Binary.
ModulePart Name: PfatFlashLib
ModulePart Description: Defines PFAT flash library
Filename | Description
PfatFlashLib.cif | CIF file for PfatFlashLib
PfatFlashLib.c | Provides flash library override when Pfat support is enabled
PfatFlashLib.sdl | SDL file for PfatFlashLib
PfatFlashLib.mak | Make file for PfatFlashLib
ModulePart Name: PfatPubKey
ModulePart Description: Defined the process for creating the final Pfat Update Package
Filename | Description
PfatPubKey.cif | CIF file for PfatPubKey
PfatPubKey.mak | Defines the make process for creating the final Pfat binary as well as Pfat public and private key generation
PfatPubKey.sdl | SDL file for PfatPubKey
Dummy.bin | Dummy helper file for initial generation extraction of pfat public key from private key.
ModulePart Name: PfatUtilsandScripts
ModulePart Description: Contains the tools and binaries used for creating the final PFAT Update Package
Filename | Description
PfatUtilsandScripts.cif | CIF file for PfatUtilsandScripts
.VKeyExp | Exponent binary for PFAT private key
BuildAmiPfatHeader.exe | Ami executable for creating AMI specific pfat header to aid in flashing
BuildPSL.bat | Batch file to build PFAT Script for flashing
CutRom.exe | Ami executable to aid in stitching and creating PFAT binaries
dummyfile.bin | file used by pfatcryptoCon for extracting public key from private key
Keygen | Tool for creating PFAT keys
PfatCertHeader.bin | Binary that describes the header file for pfat binaries
PfatCryptoCon.exe | Tool for creating Pfat hashes and signatures.
PfatPubKeysAndBuildPSL.sdl | SDL file for PfatPubKeysAndBuildPSL
PfatPubKeysAndBuildPSL.mak | Make file for PfatPubKeysAndBuildPSL
PPB.exe | Intel Tool for creating the PFAT Update Package.
Psl2Bin.exe | Intel Tool for converting PFAT psl scripts into binaries.
ModulePart Name: PfatCpuPolicyOverride
ModulePart Description: Defines the Pfat policies for the system.
Filename | Description
PfatCpuPolicyOverride.cif | CIF file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.c | Code file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.dxs | Dependency file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.h | Header file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.mak | Make file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.sdl | SDL file for PfatCpuPolicyOverride
Opensslib.lib | Openssl Crypto library
PeiCryptLib.lib | Pei Crypto library
ModulePart Name: PfatSetup
ModulePart Description: Defines the Pfat Setup support
Filename | Description
PfatSetup.cif | CIF file for PfatSetup
PfatSetup.sd | Setup Description file for PfatSetup
PfatSetup.uni | UNI file for PfatSetup
PfatSetup.mak | Make file for PfatSetup
PfatSetup.sdl | SDL file for PfatSetup
ModulePart Name: PfatRecovery
ModulePart Description: Provides recovery support in Pfat
Filename | Description
PfatRecovery.cif | CIF file for PfatRecovery
PfatRecovery.c | Code listing for PfatRecovery
PfatRecovery.dxs | dependency file for PfatRecovery
PfatRecovery.mak | Make file for PfatRecovery
PfatRecovery.sdl | SDL file for PfatRecovery
PfatRecoveryHook.sdl | support file to hook recovery flow
AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
Other Tools Requirements
The Intel PFAT Tools such as PSL2Bin.exe and PPB.exe may require Microsoft Redistribution Package Installed on the Build platform.
The 32 bit version can be found at: Microsoft Redistribution Package 32 Bit
The 64 bit version can be found at: Microsoft Redistribution Package 64 Bit
General Bug Fixes and EIP Addressed in this Label:

EIP Addressed
EIP 106660: Support flash recovery function for Intel PFAT

EIP Addressed
EIP 114403: PFAT Haswell BIOS Guard SDK Production Version 1.0 Tools check-in
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

EIP 124189:
When Secure Flash module is removed Pfat fails to build. Secure Flash also fails.
Known Limitations and Erratas in this label:
NO known limitations
Errata:
System Policies: Default implementation has a setup flag to disable and enable Pfat support. For production systems where PFAT is supported, it is suggested to set Pfat to default enabled and disallow the manipulation of the setup variable
Remaining Issues:
NONE
Unit Testing:
Booting to BIOS Setup with PFAT support enabled or disabled
Booting to Windows 8 with PFAT support enabled or disabled
Secure PFAT update using PFAT SFAM Policies and Signed PUPs
Validation Testing:
Release History:

4.6.5.1_INTEL_PFAT_2
4.6.5.1_INTEL_PFAT_2_1
4.6.5.1_INTEL_PFAT_2_2
4.6.5.1_INTEL_PFAT_2_3
4.6.5.1_INTEL_PFAT_2_4
4.6.5.1_INTEL_PFAT_2_5
4.6.5.1_INTEL_PFAT_2_6

© American Megatrends Inc.


The Intel Platform Firmware Armoring Technology (PFAT) helps OEMs accomplish flash protection using a combination of CPU and PCH features. The embedded controller can also be secured using this feature. When PFAT is enabled the SPI flash part on the platform can only be access via special CPU cycles. The BIOS sends SPI cycles through the PFAT binary after Flash lockdown is achieved via the Intel PCH component. The Flash protection policy is defined with the Signed Flash Area Map (SFAM). The SFAM is used by the PFAT module to determine the areas of flash that require signed packages to update. Reference the Intel PFAT BIOS specification for more information about how PFAT secures the SPI Flash.

General Information

Built on 18:10:43 09/25/12


Release Notes - NDA Required

Component Information:
Component Title: Intel PFAT Technology
Component Reference Name: Intel PFAT Technology
Component Type: eModule
Release Date: 2013-07-15
Source Control Label: 4.6.5.1_INTEL_PFAT_3
Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/IntelPfat;

Dependencies
Dependent Component Title: NVRAM SMI
Dependent Component Reference Name: NvramSmi
Dependent Source Control Label: 4.6.5.1_NvramSmi_3
Dependent Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/NvramSmi;
Dependent Component Title: Rom Image
Dependent Component Reference Name: RomImage
Dependent Source Control Label: 4.6.5.3_RomImage_014
Dependent Source Control Location: SS: Database;$/Alaska/SOURCE/Modules/SharkBayRefCodes/RomImage;
Dependent Component Title: Intel System Agent
Dependent Component Reference Name:Intel System Agent
Dependent Source Control Label: 4.6.5.3_Intel_SA-RC_130_027
Dependent Source Control Location: SS: Alaska;$/Alaska/SOURCE/Modules/SharkBayRefCodes/Haswell;
Non-Compiled BIN and LIB File(s) within this Component:

PfatBinary.bin
Company Name: Intel
General Information: Reference PFAT KIT Beta .95
Component Description:
This component enables Intel Platform Firmware Armoring Support on a Platform
PfatServices
Filename | Description
PfatServices.cif | CIF file for PfatServices
PfatServices.c | Code listing file that initializes PFAT support in DXE
PfatServices.chm | CHM file for PfatServices
PfatServices.h | Header file for PfatServices module
PfatServices.h | Header file for PfatServices module
PfatServices.inf | INF file for PFATServices module
PfatServices.mak | Make file for PfatServices
PfatServices.sdl | SDL file for PfatServices

ModulePart Name: PFatBinary
ModulePart Description: Defines Pfat binary module included in BIOS
Filename | Description
PfatBinary.cif | CIF file for PfatBinary
PfatBinary.mak | Make file for Pfat Binary module part
PfatBinary.sdl | SDL file for Pfat Binary module part
PfatBinary.bin | This is the Intel Pfat Binary provided by Intel for integration into the BIOS. All PFAT access go through this Binary.
ModulePart Name: PfatFlashLib
ModulePart Description: Defines PFAT flash library
Filename | Description
PfatFlashLib.cif | CIF file for PfatFlashLib
PfatFlashLib.c | Provides flash library override when Pfat support is enabled
PfatFlashLib.sdl | SDL file for PfatFlashLib
PfatFlashLib.mak | Make file for PfatFlashLib
ModulePart Name: PfatPubKey
ModulePart Description: Defined the process for creating the final Pfat Update Package
Filename | Description
PfatPubKey.cif | CIF file for PfatPubKey
PfatPubKey.mak | Defines the make process for creating the final Pfat binary as well as Pfat public and private key generation
PfatPubKey.sdl | SDL file for PfatPubKey
Dummy.bin | Dummy helper file for initial generation extraction of pfat public key from private key.
ModulePart Name: PfatUtilsandScripts
ModulePart Description: Contains the tools and binaries used for creating the final PFAT Update Package
Filename | Description
PfatUtilsandScripts.cif | CIF file for PfatUtilsandScripts
.VKeyExp | Exponent binary for PFAT private key
BuildAmiPfatHeader.exe | Ami executable for creating AMI specific pfat header to aid in flashing
BuildPSL.bat | Batch file to build PFAT Script for flashing
CutRom.exe | Ami executable to aid in stitching and creating PFAT binaries
dummyfile.bin | file used by pfatcryptoCon for extracting public key from private key
Keygen | Tool for creating PFAT keys
PfatCertHeader.bin | Binary that describes the header file for pfat binaries
PfatCryptoCon.exe | Tool for creating Pfat hashes and signatures.
PfatPubKeysAndBuildPSL.sdl | SDL file for PfatPubKeysAndBuildPSL
PfatPubKeysAndBuildPSL.mak | Make file for PfatPubKeysAndBuildPSL
PPB.exe | Intel Tool for creating the PFAT Update Package.
Psl2Bin.exe | Intel Tool for converting PFAT psl scripts into binaries.
ModulePart Name: PfatCpuPolicyOverride
ModulePart Description: Defines the Pfat policies for the system.
Filename | Description
PfatCpuPolicyOverride.cif | CIF file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.c | Code file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.dxs | Dependency file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.h | Header file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.mak | Make file for PfatCpuPolicyOverride
PfatCpuPolicyOverride.sdl | SDL file for PfatCpuPolicyOverride
Opensslib.lib | Openssl Crypto library
PeiCryptLib.lib | Pei Crypto library
ModulePart Name: PfatSetup
ModulePart Description: Defines the Pfat Setup support
Filename | Description
PfatSetup.cif | CIF file for PfatSetup
PfatSetup.sd | Setup Description file for PfatSetup
PfatSetup.uni | UNI file for PfatSetup
PfatSetup.mak | Make file for PfatSetup
PfatSetup.sdl | SDL file for PfatSetup
ModulePart Name: PfatRecovery
ModulePart Description: Provides recovery support in Pfat
Filename | Description
PfatRecovery.cif | CIF file for PfatRecovery
PfatRecovery.c | Code listing for PfatRecovery
PfatRecovery.dxs | dependency file for PfatRecovery
PfatRecovery.mak | Make file for PfatRecovery
PfatRecovery.sdl | SDL file for PfatRecovery
PfatRecoveryHook.sdl | support file to hook recovery flow
AMI Build Tools:
Tools Label: Alaska_Tools_39, Dated: 2012-01-04
Visual eBios: RSS.5.72.0220, Dated: 2012-01-04
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
Other Tools Requirements
The Intel PFAT Tools such as PSL2Bin.exe and PPB.exe may require Microsoft Redistribution Package Installed on the Build platform.
The 32 bit version can be found at: Microsoft Redistribution Package 32 Bit
The 64 bit version can be found at: Microsoft Redistribution Package 64 Bit
General Bug Fixes and EIP Addressed in this Label:

EIP Addressed
EIP 124189: Secure Flash failure with Pfat

EIP Addressed
EIP 127158: PFAT Haswell BIOS Guard SDK Production Version 1.01 Tools check-in
Files Changed for General Bug Fixes and EIP Addressed in this Label:
General Bug Fixes

EIP 124189:
When Secure Flash module is removed Pfat fails to build. Secure Flash also fails.
Known Limitations and Erratas in this label:
NO known limitations
Errata:
System Policies: Default implementation has a setup flag to disable and enable Pfat support. For production systems where PFAT is supported, it is suggested to set Pfat to default enabled and disallow the manipulation of the setup variable
Remaining Issues:
NONE
Unit Testing:
Booting to BIOS Setup with PFAT support enabled or disabled
Booting to Windows 8 with PFAT support enabled or disabled
Secure PFAT update using PFAT SFAM Policies and Signed PUPs
Validation Testing:
Release History:

4.6.5.1_INTEL_PFAT_2
4.6.5.1_INTEL_PFAT_2_1
4.6.5.1_INTEL_PFAT_2_2
4.6.5.1_INTEL_PFAT_2_3
4.6.5.1_INTEL_PFAT_2_4
4.6.5.1_INTEL_PFAT_2_5
4.6.5.1_INTEL_PFAT_2_6
4.6.5.1_INTEL_PFAT_2_8

© American Megatrends Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • HandlePfatLegacy.mak
  • HandlePfatLegacy.sdl
  • PfatBinary.mak
  • PfatCpuPolicyOverride.mak
  • PfatCpuPolicyOverride.sdl
  • PfatFlashLib.mak
  • PfatFlashLib.sdl
  • PfatPubKeysAndBuildPSL.mak
  • PfatRecovery.mak
  • PfatRecovery.sdl
  • PfatServices.mak
  • PfatSetup.mak
  • PfatSetup.sdl
Built on 20:09:22 07/15/13


HandlePfatLegacy.mak

Description:
Make file for HandlePfatLegacy


HandlePfatLegacy.sdl

Description:
SDL file for HandlePfatLegacy


PfatBinary.mak

Description:
Make file PfatBinary


PfatCpuPolicyOverride.mak

Description:
Make file for PfatCpuPolicyOverride


PfatCpuPolicyOverride.sdl

Description:
SDL file for PfatCpuPolicyOverride


PfatFlashLib.mak

Description:
Make file for PfatFlashLib


PfatFlashLib.sdl

Description:
SDL file for PfatFlashLib


PfatPubKeysAndBuildPSL.mak

Description:
Make for for PfatPubKey


PfatRecovery.mak

Description:
Make file for PfatRecovery module part


PfatRecovery.sdl

Description:
SDL file for PfatSetup


PfatServices.mak

Description:
Make file for PfatServices component


PfatSetup.mak

Description:
Make file for PfatSetup module part


PfatSetup.sdl

Description:
SDL file for PfatSetup


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2011 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.