American Megatrends, Inc.

ReleaseNotes

Copyright

Release Notes

© American Megatrends, Inc.


Release Notes - NDA Required

BIOS Information:
AMI BIOS Core: Aptio 4.6.5.3
Release Date: 2012-02-17
Source Control Label: 4.6.5.3_VEB_1AQQW000
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: 00
Northbridge: Haswell
Southbridge: LynxPoint
Processor: Haswell, Stepping: A1
CPU ID: 306C1, Microcode Version: 004
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version:
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1018
ME F/W Binary: LPT_H_1.5M_PreProduction.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_5.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
Board\Flash\SPI\SpiFlash.cif | Add Intel module part in SPI.
Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Core\EM\CSM\CSM.c | Revise for Intel CPU module.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\EM\ACPI\AcpiCore.c | Update the rev.86 for BGRT lose issue.(EIP#67951)
Core\CORE_PEI\DxeIpl.c | Revise for S3 issue.
ReferenceCode\ME\Library\MeKernel\include\MkhiMsgs.h | Revise for EOP issue.
ReferenceCode\Haswell\PowerManagement\PowerMgmtS3\Smm\PowerMgmtS3.c | Revise for EOP issue.
ReferenceCode\Haswell\PowerManagement\PowerMgmtS3\Smm\PowerMgmtS3.dxs | Revise for EOP issue.
ReferenceCode\Me\Heci\Dxe\Hecidrv.c | Revise for EOP issue.
Include\Protocol\S3SaveState.h | Update to rev2 for Build errors if some GUIDs are added to DXS.
Core\EM\SMM\SmmInit.c | Revise for BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.03.0069
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;

Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On
Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

Chipset Specific Function Support:
Required eModule(s)
None

Token Setting
Token Name Value
Notes: Please describe any notes for supporting this function

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_38 , Dated: 2011-12-20
Visual eBios: RSS 5.72.0219, Dated: 2011-12-20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell Reference code ver. 0.50
NorthBridge – Haswell - SystemAgent Reference code ver. 0.50
SouthBridge – LynxPoint Reference code label ver. 0.50
Haswell ACPI – Reference code ver. 0.50
Manageability Engine (ME) Reference Code ver. 0.50
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
None
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
None
EIP addressed in this label:
None
Files changed for EIP fixes:
None
Known issues and limitations in this label:
None
Remaining Issues:
None
Unit Testing:
None
Validation Testing:
Internal pre-test
Notes:
01. Need to add Haswell CPU Microcode.
Release History:
Labeled '4.6.5.3_VEB_1AQQW000' :2012/02/17
Labeled '(INT)a_4.6.5.3_VEB_1AQQW000' :2012/02/13

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.3
Release Date: 2012-02-24
Source Control Label: 4.6.5.3_VEB_1AQQW001
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: 00
Northbridge: Haswell
Southbridge: LynxPoint
Processor: Haswell, Stepping: A1
CPU ID: 306C1, Microcode Version: 00B
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version:
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1018
ME F/W Binary: LPT_H_1.5M_PreProduction.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_5.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
Board\Flash\SPI\SpiFlash.cif | Add Intel module part in SPI.
Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Core\EM\CSM\CSM.c | Revise for Intel CPU module.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\EM\ACPI\AcpiCore.c | Update the rev.86 for BGRT lose issue.(EIP#67951)
Core\CORE_PEI\DxeIpl.c | Revise for S3 issue.
ReferenceCode\Haswell\PowerManagement\PowerMgmtS3\Smm\PowerMgmtS3.c | Revise for EOP issue.
ReferenceCode\Haswell\PowerManagement\PowerMgmtS3\Smm\PowerMgmtS3.dxs | Revise for EOP issue.
Include\Protocol\S3SaveState.h | Update to rev2 for Build errors if some GUIDs are added to DXS.
Core\EM\SMM\SmmInit.c | Revise for BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
CORE\EM\SMIFlash\SMIFlashLinks.c | Update to rev.18 for OA3.0.
Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
ReferenceCode\ME\SampleCode\PlatformReset\RuntimeDxe\PlatformReset.c | Wait FwInitComplete bit ready to do reset.Fix flash the BIOS first boot problems.
Core\EM\SMBIOS\SMBios.c | Update to rev.121 for a redundant FreePool call.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.03.0069
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;

Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On
Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

Chipset Specific Function Support:
Required eModule(s)
None

Token Setting
Token Name Value
Notes: Please describe any notes for supporting this function

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_38 , Dated: 2011-12-20
Visual eBios: RSS 5.72.0219, Dated: 2011-12-20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell Reference code ver. 0.50
NorthBridge – Haswell - SystemAgent Reference code ver. 0.50
SouthBridge – LynxPoint Reference code label ver. 0.51
Haswell ACPI – Reference code ver. 0.50
Manageability Engine (ME) Reference Code ver. 0.50
Reference or 3rd Party code updated in this Release:
SouthBridge – LynxPoint Reference code label ver. 0.51
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Haswell : 4651_Haswell_01a-RC_050
02. Intel SystemAgent : 4.6.5.3_Intel_SA-RC_050_001
03. Intel PCH : 4.6.5.3_Intel_LPT-RC_051_002
04. ME : 4.6.4.1_Intel_ME_RC_0.5_002
05. Platform : 4.6.5.3_PF-ACPI_RC_050_001
06. Capsule : 4.6.5.3_Capsule_07
07. IdeSMART : 4.6.5.1_HddSmart_007
08. IdeSecurity : 4.6.3_HddSecurity_020
09. IdeAcoustic : 4.6.3_HddAcoustic_003
10. SMBIOS - Board : 4.6.3_SMBIOSBOARD_31
11. SMBIOS - Core Source : 4.6.3_SMBIOSBOARD_31
12. SMIFlash : 4.6.3.6_SMIFLASH_23
13. USB : 4.6.3_USB_08.10.20
14. USBSB : 4.6.4.0_USB_8.10.20_PCH_011
Modules added to this label:
01. Intel EDK : 4.6.5.3_IntelEDK_1117_Patch7_00
02. ROM Image : 4.6.5.3_RomImage_000
Modules removed from last label:
01. Intel EDK : 4.6.4.1_IntelEDK_000a
02. EcPs2Kbd : 4.6.3.3_EcPs2Kbd_04
New features added in this label:
None
General Bug Fixes:
None
EIP addressed in this label:
None
Files changed for EIP fixes:
None
Known issues and limitations in this label:
None
Remaining Issues:
None
Unit Testing:
None
Validation Testing:
Internal pre-test
Notes:
01. Need to add Haswell CPU Microcode.
02. The RomImage module is based on ME9.0.0.1018 FW.
Need add files to .\RomImage\
Fitc.exe of ME9.0_1.5M_9.0.0.1018 renames into FITC_1_5.EXE.
Fitc.exe of ME9.0_5M_9.0.0.1018 renames into FITC_5.EXE.
fitctmpl.xml
newfiletmpl.xml
vsccommn.bin
ME9.0_1.5M_PreProduction.bin
ME9.0_5M_PreProduction.bin
NAHUM6_CLARKSVILLE_DESKTOP_5.bin
NAHUM6_CLARKSVILLE_MOBILE_5.bin
Release History:
Labeled '4.6.5.3_VEB_1AQQW000' :2012/02/17
Labeled '(INT)a_4.6.5.3_VEB_1AQQW000' :2012/02/13


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.3
Release Date: 2012-04-03
Source Control Label: 4.6.5.3_VEB_1AQQW002
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: 00
Northbridge: Haswell
Southbridge: LynxPoint
Processor: Haswell, Stepping: A1
CPU ID: 306C1, Microcode Version: 00B
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version:
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1018
ME F/W Binary: LPT_H_1.5M_PreProduction.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_5.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
Board\Flash\SPI\SpiFlash.cif | Add Intel module part in SPI.
Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Core\EM\CSM\CSM.c | Revise for Intel CPU module.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\EM\ACPI\AcpiCore.c | Update the rev.86 for BGRT lose issue.(EIP#67951)
Core\CORE_PEI\DxeIpl.c | Revise for S3 issue.
ReferenceCode\Haswell\PowerManagement\PowerMgmtS3\Smm\PowerMgmtS3.c | Revise for EOP issue.
ReferenceCode\Haswell\PowerManagement\PowerMgmtS3\Smm\PowerMgmtS3.dxs | Revise for EOP issue.
Include\Protocol\S3SaveState.h | Update to rev2 for Build errors if some GUIDs are added to DXS.
Core\EM\SMM\SmmInit.c | Revise for BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
CORE\EM\SMIFlash\SMIFlashLinks.c | Update to rev.18 for OA3.0.
Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
ReferenceCode\ME\SampleCode\PlatformReset\RuntimeDxe\PlatformReset.c | Wait FwInitComplete bit ready to do reset.Fix flash the BIOS first boot problems.
Core\EM\SMBIOS\SMBios.c | Update to rev.121 for a redundant FreePool call.
Core\EM\CsmOptOut\CsmOptOut.sd | Remove Csm Support item because it is useless.
board\em\csm\csm.sd | Hide the Auto item from Launch CSM.
Core\CORE_DXE\Page.c | Update page.c to version 10 for EIP82751.
Core\CORE_DXE\locate.c | Update locate.c to version 5 for EIP82756.
Core\EM\NVRAM\NVRAMDXE.c | Update to rev.88 for EIP82122.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.03.0069
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;

Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On
Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

Chipset Specific Function Support:
Required eModule(s)
None

Token Setting
Token Name Value
Notes: Please describe any notes for supporting this function

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_38 , Dated: 2011-12-20
Visual eBios: RSS 5.72.0219, Dated: 2011-12-20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell Reference code ver. 0.50
NorthBridge – Haswell - SystemAgent Reference code ver. 0.50
SouthBridge – LynxPoint Reference code label ver. 0.51
Haswell ACPI – Reference code ver. 0.50
Manageability Engine (ME) Reference Code ver. 0.50
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel SystemAgent : 4.6.5.3_Intel_SA-RC_050_003
02. Intel PCH : 4.6.5.3_Intel_LPT-RC_051_003
03. Platform : 4.6.5.3_PF-ACPI_RC_050_002
04. Intel EDK : 4.6.5.3_IntelEDK1117_Patch8_01
05. TCG : 4.6.4.0_TCG_39
06. Intel Nehalem Microcode : 4.6.0_INTEL_MICROCODE_36
07. UefiNetworkStack II : 4.6.4_UEFI_NETWORK_STACK_II_03
08. RomImage : 4.6.5.3_RomImage_001
Modules added to this label:
01. CryptoPkg : 4.6.5.0_CRYPTOAPI_0005
02. OpalSecurity : 4.6.5.2_OpalSecurity_002
03. Secure Flash Pkg : 4.6.5.1_SECMOD_0006
04. CsmOptOut : 4.6.5.3_Csm_OptOut_01
05. RsdpPlus : 4.6.4.0_RsdpPlus_03
06. Secure Boot Pkg : 4.6.5.1_SECUREBOOT_WIN8_010
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
None
EIP addressed in this label:
None
Files changed for EIP fixes:
None
Known issues and limitations in this label:
01. Haswell CPU RefCode do not support "x64_build = 0".
02. Please refer to EIP#85251 for hang on A2 issue.
03. Fedora 16 x64 sleep test failed.
Remaining Issues:
None
Unit Testing:
None
Validation Testing:
Internal pre-test
Notes:
01. Need to add Haswell CPU Microcode.
02. The RomImage module is based on ME9.0.0.1018 FW.
Need add files to .\RomImage\
Fitc.exe of ME9.0_1.5M_9.0.0.1018 renames into FITC_1_5.EXE.
Fitc.exe of ME9.0_5M_9.0.0.1018 renames into FITC_5.EXE.
fitctmpl.xml
newfiletmpl.xml
vsccommn.bin
ME9.0_1.5M_PreProduction.bin
ME9.0_5M_PreProduction.bin
NAHUM6_CLARKSVILLE_DESKTOP_5.bin
NAHUM6_CLARKSVILLE_MOBILE_5.bin
03. hsm_Vbios.bin, hsd_Vbios.bin, IntelGopDriver.efi, vbt.bin, GbE_OR.BIN, SataDriver.efi and SataOrom120.BIN is dummy files.
04. Only use FITc GUI interface to build the image for generic Verify/Test BIOS.
Release History:
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.3
Release Date: 2012-04-17
Source Control Label: 4.6.5.3_VEB_1AQQW003
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: 00
Northbridge: Haswell
Southbridge: LynxPoint
Processor: Haswell, Stepping: A1
CPU ID: 306C1, Microcode Version: 00B
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version:
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1018
ME F/W Binary: LPT_H_1.5M_PreProduction.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_5.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
Board\Flash\SPI\SpiFlash.cif | Add Intel module part in SPI.
Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Core\EM\CSM\CSM.c | Revise for Intel CPU module.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\EM\ACPI\AcpiCore.c | Update the rev.86 for BGRT lose issue.(EIP#67951)
Core\CORE_PEI\DxeIpl.c | Revise for S3 issue.
Include\Protocol\S3SaveState.h | Update to rev2 for Build errors if some GUIDs are added to DXS.
Core\EM\SMM\SmmInit.c | Revise for BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
CORE\EM\SMIFlash\SMIFlashLinks.c | Update to rev.18 for OA3.0.
Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
Core\EM\SMBIOS\SMBios.c | Update to rev.121 for a redundant FreePool call.
Core\EM\CsmOptOut\CsmOptOut.sd | Remove Csm Support item because it is useless.
board\em\csm\csm.sd | Hide the Auto item from Launch CSM.
Core\CORE_DXE\Page.c | Update page.c to version 10 for EIP82751.
Core\CORE_DXE\locate.c | Update locate.c to version 5 for EIP82756.
Core\EM\NVRAM\NVRAMDXE.c | Update to rev.88 for EIP82122.
ReferenceCode\Haswell\CpuInit\Dxe\x64\MemoryOperation.c | Support AMI debugRx Debugger.
Core\EM\NVRAM\NVRAMDXE.c | Support AMI debugRx Debugger.
Core\EM\NVRAM\NVRAMDXE.c | Support AMI debugRx Debugger.
Core\EM\S3\BootScriptSave.c | Correct 'SCRIPT_MEM_POLL' macro for Aptio4.
EDK\Foundation\Library\Dxe\EfiScriptLib\EfiScriptLib.c | Correct 'SCRIPT_MEM_POLL' macro for Aptio4.
EDK\Foundation\Library\Dxe\EfiScriptLib\EfiScriptLib.mak | Correct 'SCRIPT_MEM_POLL' macro for Aptio4.
Chipset\NB\NBCspLib.h | Fixed warm boot system hang.
Chipset\NB\NBPEI.c | Fixed warm boot system hang.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.03.0069
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;

Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On
Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

Chipset Specific Function Support:
Required eModule(s)
None

Token Setting
Token Name Value
Notes: Please describe any notes for supporting this function

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_38 , Dated: 2011-12-20
Visual eBios: RSS 5.72.0219, Dated: 2011-12-20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell Reference code ver. 0.55
NorthBridge – Haswell - SystemAgent Reference code ver. 0.55
SouthBridge – LynxPoint Reference code label ver. 0.55
Haswell ACPI – Reference code ver. 0.55
Manageability Engine (ME) Reference Code ver. 0.55
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Haswell : 4651_Haswell_02a-RC_055.
02. Intel PCH : 4.6.5.3_Intel_LPT-RC_055_004.
03. Intel SystemAgent : 4.6.5.3_Intel_SA-RC_055_004.
04. ME : 4.6.4.1_Intel_ME_RC_0.55_004.
05. Platform : 4.6.5.3_PF-ACPI_RC_055_003.
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
None
EIP addressed in this label:
None
Files changed for EIP fixes:
None
Known issues and limitations in this label:
01. Haswell CPU RefCode do not support "x64_build = 0".
02. Please refer to EIP#85251 for hang on A2 issue.
03. Fedora 16 x64 sleep test failed.
04. PCH_RC_VERSION did not update, LynxPoint RefCode Revision will show 0.5.1.
05. Resume fail from S3.
06. Set XHCI Mode to disable for install Fedora.
07. Sometimes AMIDebugRx Debugger will lost connection when cold boot.
Remaining Issues:
None
Unit Testing:
None
Validation Testing:
Internal pre-test
Notes:
01. Need to add Haswell CPU Microcode.
02. The RomImage module is based on ME9.0.0.1018 FW.
Need add files to .\RomImage\
Fitc.exe of ME9.0_1.5M_9.0.0.1018 renames into FITC_1_5.EXE.
Fitc.exe of ME9.0_5M_9.0.0.1018 renames into FITC_5.EXE.
fitctmpl.xml
newfiletmpl.xml
vsccommn.bin
ME9.0_1.5M_PreProduction.bin
ME9.0_5M_PreProduction.bin
NAHUM6_CLARKSVILLE_DESKTOP_5.bin
NAHUM6_CLARKSVILLE_MOBILE_5.bin
03. hsm_Vbios.bin, hsd_Vbios.bin, IntelGopDriver.efi, vbt.bin, GbE_OR.BIN, SataDriver.efi and SataOrom120.BIN is dummy files.
04. Only use FITc GUI interface to build the image for generic Verify/Test BIOS.
05. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
Release History:
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.3
Release Date: 2012-05-04
Source Control Label: 4.6.5.3_VEB_1AQQW004
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: 00
Northbridge: Haswell
Southbridge: LynxPoint
Processor: Haswell, Stepping: A1
CPU ID: 306C1, Microcode Version: 00D
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2138
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1064
ME F/W Binary: LPT_H_1.5M_PreProduction.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_5.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
Board\Flash\SPI\SpiFlash.cif | Add Intel module part in SPI.
Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Core\EM\CSM\CSM.c | Revise for Intel CPU module.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\EM\ACPI\AcpiCore.c | Update the rev.86 for BGRT lose issue.(EIP#67951)
Core\CORE_PEI\DxeIpl.c | Revise for S3 issue.
Include\Protocol\S3SaveState.h | Update to rev2 for Build errors if some GUIDs are added to DXS.
Core\EM\SMM\SmmInit.c | Revise for BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
CORE\EM\SMIFlash\SMIFlashLinks.c | Update to rev.18 for OA3.0.
Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
Core\EM\SMBIOS\SMBios.c | Update to rev.121 for a redundant FreePool call.
Core\EM\CsmOptOut\CsmOptOut.sd | Remove Csm Support item because it is useless.
board\em\csm\csm.sd | Hide the Auto item from Launch CSM.
Core\CORE_DXE\Page.c | Update page.c to version 10 for EIP82751.
Core\CORE_DXE\locate.c | Update locate.c to version 5 for EIP82756.
Core\EM\NVRAM\NVRAMDXE.c | Update to rev.88 for EIP82122.
ReferenceCode\Haswell\CpuInit\Dxe\x64\MemoryOperation.c | Support AMI debugRx Debugger.
ReferenceCode\Haswell\CpuInit\Dxe\CpuDxe.h | Support AMI debugRx Debugger.
ReferenceCode\Haswell\CpuInit\Dxe\Cpu.c | Support AMI debugRx Debugger. Add temporary workaround for INTEL_390302.
Core\EM\S3\BootScriptSave.c | Correct 'SCRIPT_MEM_POLL' macro for Aptio4.
Core\EM\SMM\SmmDispatcher.c | Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
ReferenceCode\AcpiTables\Dsdt\Gpe.asl | Modify to support Thunderbolt.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.03.0069
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;

Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On
Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

Chipset Specific Function Support:
Required eModule(s)
None

Token Setting
Token Name Value
Notes: Please describe any notes for supporting this function

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell Reference code ver. 0.55
NorthBridge – Haswell - SystemAgent Reference code ver. 0.55
SouthBridge – LynxPoint Reference code label ver. 0.55
Haswell ACPI – Reference code ver. 0.55
Manageability Engine (ME) Reference Code ver. 0.55
Intel Rapid Start Technology – Reference code ver. 0.55
Intel DPTF – Reference code ver. 0.55
Intel CPPC – Reference code ver. 0.55
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Haswell : 4651_Haswell_02b-RC_055.
02. Intel PCH : 4.6.5.3_Intel_LPT-RC_055_006.
03. Intel SystemAgent : 4.6.5.3_Intel_SA-RC_055_005.
04. ME : 4.6.4.1_Intel_ME_RC_0.55_006.
05. Platform : 4.6.5.3_PF-ACPI_RC_055_004.
06. Intel EDK : 4.6.5.3_IntelEDK1117_Patch8_03.
07. Intel Nehalem Microcode module : 4.6.0_INTEL_MICROCODE_38.
08. Rom Image : 4.6.5.3_RomImage_002.
Modules added to this label:
01. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_055_000.
02. Intel DPTF : 4.6.5.3_DPTF-RC_055_000.
03. Intel CPPC : 4.6.5.3_CPPC-RC_055_000.
04. Thunderbolt : 4.6.4.1_TBT_091_001
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
None
EIP addressed in this label:
None
Files changed for EIP fixes:
None
Known issues and limitations in this label:
01. Haswell CPU RefCode do not support "x64_build = 0".
02. Please refer to EIP#85251 for hang on A2 issue.
03. Fedora 16 x64 S3/S4 resume detect USB error message.
04. Sata Driver v12.0.0.1476 not working properly.
05. According to Intel_497869, disable PCH PCIe ports 3 through 8 if resume failed from S3.
06. Set XHCI Mode to disable for install Fedora.
07. Sometimes AMIDebugRx Debugger will lost connection when cold boot.
08. Install UEFI Windows will hang up if enable "DEBUG_MODE", it will assert on Runtime.c, please refer to EIP#89078
09. When connect Memory above 4G, sometimes system will blue screen on 0x0000009C.
Remaining Issues:
None
Unit Testing:
None
Validation Testing:
Internal pre-test
Notes:
01. GbE_OR.BIN is dummy files.
02. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
03. Set BIOS region length to 0x00400000 in FITc for S3.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1064 for Flathead Creek CRB
Rom0x_8MB_Q87.bin: This is ME9.0_5M_9.0.0.1064 for Flathead Creek CRB
Release History:
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

c?American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.3
Release Date: 2012-05-21
Source Control Label: 4.6.5.3_VEB_1AQQW005
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: 00
Northbridge: Haswell
Southbridge: LynxPoint
Processor: Haswell, Stepping: A1
CPU ID: 306C1, Microcode Version: 00D
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2139
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1064
ME F/W Binary: LPT_H_1.5M_PreProduction.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_5.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
Board\Flash\SPI\SpiFlash.cif | Add Intel module part in SPI.
Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Core\EM\CSM\CSM.c | Revise for Intel CPU module.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\EM\ACPI\AcpiCore.c | Update the rev.86 for BGRT lose issue.(EIP#67951)
Core\CORE_PEI\DxeIpl.c | Revise for S3 issue.
Include\Protocol\S3SaveState.h | Update to rev2 for Build errors if some GUIDs are added to DXS.
Core\EM\SMM\SmmInit.c | Revise for BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
CORE\EM\SMIFlash\SMIFlashLinks.c | Update to rev.18 for OA3.0.
Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
Core\EM\SMBIOS\SMBios.c | Update to rev.121 for a redundant FreePool call.
Core\EM\CsmOptOut\CsmOptOut.sd | Remove Csm Support item because it is useless.
board\em\csm\csm.sd | Hide the Auto item from Launch CSM.
Core\CORE_DXE\Page.c | Update page.c to version 10 for EIP82751.
Core\CORE_DXE\locate.c | Update locate.c to version 5 for EIP82756.
Core\EM\NVRAM\NVRAMDXE.c | Update to rev.88 for EIP82122.
Core\EM\S3\BootScriptSave.c | Correct 'SCRIPT_MEM_POLL' macro for Aptio4.
Core\EM\SMM\SmmDispatcher.c | Modify SMM InterruptManage function to execute Non-PI handler after PI handler.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.03.0069
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;

Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On
Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

Chipset Specific Function Support:
Required eModule(s)
None

Token Setting
Token Name Value
Notes: Please describe any notes for supporting this function

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell Reference code ver. 0.56
NorthBridge – Haswell - SystemAgent Reference code ver. 0.56
SouthBridge – LynxPoint Reference code label ver. 0.56
Haswell ACPI – Reference code ver. 0.56
Manageability Engine (ME) Reference Code ver. 0.56
Intel Rapid Start Technology – Reference code ver. 0.56
Intel DPTF – Reference code ver. 0.56
Intel CPPC – Reference code ver. 0.56
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Haswell : 4651_Haswell_03a-RC_056.
02. Intel PCH : 4.6.5.3_Intel_LPT-RC_056_007.
03. Intel SystemAgent : 4.6.5.3_Intel_SA-RC_056_006.
04. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_056_001.
05. ME : 4.6.4.1_Intel_ME_RC_0.55_007.
06. Platform : 4.6.5.3_PF-ACPI_RC_056_005.
07. Intel DPTF : 4.6.5.3_DPTF-RC_056_001.
08. Intel CPPC : 4.6.5.3_CPPC-RC_056_001.
09. Rom Image : 4.6.5.3_RomImage_003.
10. CSP : Intel ICHx SPI - Source : 4.6.3_SPI-Intel-ICHx_10
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
None
EIP addressed in this label:
None
Files changed for EIP fixes:
None
Known issues and limitations in this label:
01. Haswell CPU RefCode do not support "x64_build = 0".
02. Please refer to EIP#85251 for hang on A2 issue.
03. Fedora Core 16 64 bit S3/S4 resume detect USB error message.
04. Sata Driver v12.0.0.1476 not working properly.
05. According to Intel_497869, to disable PCH PCIe port 3 through 8 if resume failed from S3.
06. Fedora Core 16 64 bit installation fail: Resolved by set setup item "xHCI Mode" = "Disabled".
07. Screen might not have any output if from internal GfX.(VBIOS 2139 and GOP v5.0.1.1005)
08. If the setup item "MRC Fast Boot" = "Enabled", to unplug DIMM or change its position will cause system hang at CKP 0x55 in warm boot.
09. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C randomly occur.
10. For fast boot support, to enable the setup item "MRC Fast Boot" is required.
11. USB 3.0 controller has no functional in Windows 8: To set the setup item "xHCI Mode" = "Disabled" for temporary, it should be fixed by windows driver.
Remaining Issues:
None
Unit Testing:
None
Validation Testing:
Please refer to EIP#90296
Notes:
01. GbE_OR.BIN is dummy files.
02. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1064 for Flathead Creek CRB
Rom0x_8MB_Q87.bin: This is ME9.0_5M_9.0.0.1064 for Flathead Creek CRB
Release History:
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.3
Release Date: 2012-06-27
Source Control Label: 4.6.5.3_VEB_1AQQW006
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: 00
Northbridge: Haswell
Southbridge: LynxPoint
Processor: Haswell, Stepping: A1
CPU ID: 306C1, Microcode Version: 00D
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2139
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1064
ME F/W Binary: LPT_H_1.5M_PreProduction.bin; ME9.0_5M_PreProduction.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_5.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
Board\Flash\SPI\SpiFlash.cif | Add Intel module part in SPI.
Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Core\EM\CSM\CSM.c | Revise for Intel CPU module.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\CORE_PEI\DxeIpl.c | Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
CORE\EM\SMIFlash\SMIFlashLinks.c | Update to rev.18 for OA3.0.
Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
Core\EM\SMBIOS\SMBios.c | Update to rev.121 for a redundant FreePool call.
Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
board\em\csm\csm.sd | Remove CsmSupport item because it is useless.
Core\CORE_DXE\Page.c | Update page.c to version 10 for EIP82751.
Core\CORE_DXE\locate.c | Update locate.c to version 5 for EIP82756.
Core\EM\NVRAM\NVRAMDXE.c | Update to rev.92 for Win8 Test.
Core\EM\S3\BootScriptSave.c | Correct 'SCRIPT_MEM_POLL' macro for Aptio4.
Core\EM\SMM\SmmDispatcher.c | Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
Core\EM\ACPI\AcpiCore.c | Update it for EIP88889.
Include\ACPI50.h | Update it for EIP88889.
CORE\EM\ACPI\asllib.asl | Update to rev.8 for EIP87370.
Core\CORE_DXE\BootOptions.c | Update to rev.23 for EIP84716.
Core\EM\NvramSmi\NvramSmi.c | Update to rev.7 for EIP86642.
Core\EM\SecurityPkg\AuthenticatedVariable\AuthVariable.c | Update to rev.43 for Win8 Test.
ReferenceCode\RapidStart\Smm\RapidStartSmm.c | Correct resume fail from S4 of iRST.
Core\CORE_DXE\BDS.c | Update to rev.111 for EIP85611.Update rev.113 and 114 for EIP90941.
Core\CORE_DXE\CORE_DXE.sdl | Update EIP85611
Chipset\SB\AcpiModeEnable.mak | Fix the system may hang at 0xB1 when boot to UEFI Windows 8.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.03.0069
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;

Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On
Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

Chipset Specific Function Support:
Required eModule(s)
None

Token Setting
Token Name Value
Notes: Please describe any notes for supporting this function

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell Reference code ver. 0.56
NorthBridge – Haswell - SystemAgent Reference code ver. 0.56
SouthBridge – LynxPoint Reference code label ver. 0.57
Haswell ACPI – Reference code ver. 0.56
Manageability Engine (ME) Reference Code ver. 0.56
Intel Rapid Start Technology – Reference code ver. 0.56
Intel DPTF – Reference code ver. 0.56
Intel CPPC – Reference code ver. 0.56
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Haswell : 4651_Haswell_03c-RC_056
02. Intel SystemAgent : 4.6.5.3_Intel_SA-RC_056_007
03. Intel PCH : 4.6.5.3_Intel_LPT-RC_057_009
04. ME : 4.6.4.1_Intel_ME_RC_0.55_008
05. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_056_002
06. Platform : 4.6.5.3_PF-ACPI_RC_056_006
07. ACPI : 4.6.4.0_ACPI_45
08. TSE Binary : 4.6.2_TSE_2_15_1226
09. Secure Flash Pkg : 4.6.5.1_SECMOD_009
10. Secure Boot Pkg : 4.6.5.1_SECBOOT_WIN8_011
11. CryptoPkg : 4.6.5.0_CRYPTOAPI_008
12. UefiNetworkStack II : 4.6.4_UEFI_NETWORK_STACK_II_04
13. TCG : 4.6.4.0_TCG_40
14. OemActivation : 4.6.4.0_OA_4.0
15. Post Time Tuning : 4.6.4.0_PTT_10
16. CSP : Intel ICHx SPI - Source : 4.6.3_SPI-Intel-ICHx_11
Modules added to this label:
01. OFBD : 4.6.3.2_OFBD.1.0.2.
02. OFBD : 4.6.5.0_OFBD_SECURE_FLASH_0.0.5.
03. NvramSmi : 4.6.5.1_NvramSmi_2.
04. IntelGigabitLan : 4.6.3.1_INTEL_GIGABIT_LAN_04.
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
None
EIP addressed in this label:
None
Files changed for EIP fixes:
None
Known issues and limitations in this label:
01. Haswell CPU RefCode do not support "x64_build = 0".
02. Please refer to EIP#85251 for hang on A2 issue.
03. Fedora Core 16 64 bit S3/S4 resume detect USB error message.
04. Sata Driver v12.0.0.1476 not working properly.
05. According to Intel_497869, to disable PCH PCIe port 3 through 8 if resume failed from S3.
06. Fedora Core 16 64 bit installation fail: Resolved by set setup item "xHCI Mode" = "Disabled".
07. Screen might not have any output if from internal GfX.(VBIOS 2139 and GOP v5.0.1.1005)
08. If the setup item "MRC Fast Boot" = "Enabled", to unplug DIMM or change its position will cause system hang at CKP 0x55 in warm boot.
09. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C randomly occur.
10. For fast boot support, to enable the setup item "MRC Fast Boot" is required.
11. USB 3.0 controller has no functional in Windows 8: To set the setup item "xHCI Mode" = "Disabled" for temporary, it should be fixed by windows driver.
12. Set SATA mode to RAID and select UEFI Driver, CD-ROM device will disappear with v12.0.0.1476, but v12.0.0.1284 is fine.
Remaining Issues:
None
Unit Testing:
None
Validation Testing:
Please refer to EIP#92806
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Inrel Rapid Start function enabled need to enable MRC FaceBoot setup item.
03. IntelGigabitLan module: 4.6.3.1_INTEL_GIGABIT_LAN_04 doesn't support onboard GbE.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1064 for Flathead Creek CRB
Rom0x_8MB_Q87.bin: This is ME9.0_5M_9.0.0.1064 for Flathead Creek CRB
Release History:
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.3
Release Date: 2012-07-12
Source Control Label: 4.6.5.3_VEB_1AQQW007
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: 00
Northbridge: Haswell
Southbridge: LynxPoint
Processor: Haswell, Stepping: A1
CPU ID: 306C1, Microcode Version: 00D
Memory: 2GB, Frequency: 1333MHz
Video BIOS Version: 2142
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1064
ME F/W Binary: LPT_H_1.5M_PreProduction.bin; ME9.0_5M_PreProduction.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_5.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
Board\Flash\SPI\SpiFlash.cif | Add Intel module part in SPI.
Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Core\EM\CSM\CSM.c | Revise for Intel CPU module.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\CORE_PEI\DxeIpl.c | Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
CORE\EM\SMIFlash\SMIFlashLinks.c | Update to rev.18 for OA3.0.
Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
Core\EM\SMBIOS\SMBios.c | Update to rev.121 for a redundant FreePool call.
Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
board\em\csm\csm.sd | Remove CsmSupport item because it is useless.
Core\CORE_DXE\Page.c | Update page.c to version 10 for EIP82751.
Core\CORE_DXE\locate.c | Update locate.c to version 5 for EIP82756.
Core\EM\NVRAM\NVRAMDXE.c | Update to rev.92 for Win8 Test.
Core\EM\S3\BootScriptSave.c | Correct 'SCRIPT_MEM_POLL' macro for Aptio4.
Core\EM\SMM\SmmDispatcher.c | Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
Core\EM\ACPI\AcpiCore.c | Update it for EIP88889.
Include\ACPI50.h | Update it for EIP88889.
CORE\EM\ACPI\asllib.asl | Update to rev.8 for EIP87370.
Core\CORE_DXE\BootOptions.c | Update to rev.23 for EIP84716.
Core\EM\NvramSmi\NvramSmi.c | Update to rev.7 for EIP86642.
Core\EM\SecurityPkg\AuthenticatedVariable\AuthVariable.c | Update to rev.43 for Win8 Test.
ReferenceCode\RapidStart\Smm\RapidStartSmm.c | Correct resume fail from S4 of iRST.
Core\CORE_DXE\BDS.c | Update to rev.111 for EIP85611.Update rev.113 and 114 for EIP90941.
Core\CORE_DXE\CORE_DXE.sdl | Update EIP85611
Board\EM\ACPI\ACPI.sd | Disabled S1 Sleep state.
Board\EM\ACPI\ACPI.sd | Disabled S1 Sleep state.
Chipset\NB\NBDxe.c | Change the location to max payload configure.
RomImage\XmlFiles\H87_8Mx1.xml | Minor change in Componemt Section.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.03.0069
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;

Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On
Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

Chipset Specific Function Support:
Required eModule(s)
None

Token Setting
Token Name Value
Notes: Please describe any notes for supporting this function

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell Reference code ver. 0.60
NorthBridge – Haswell - SystemAgent Reference code ver. 0.60
SouthBridge – LynxPoint Reference code label ver. 0.60
Haswell ACPI – Reference code ver. 0.60
Manageability Engine (ME) Reference Code ver. 0.60
Intel Rapid Start Technology – Reference code ver. 0.60
Intel DPTF – Reference code ver. 0.60
Intel CPPC – Reference code ver. 0.60
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Haswell : 4651_Haswell_04-RC_060
02. Intel SystemAgent : 4.6.5.3_Intel_SA-RC_060_008
03. Intel PCH : 4.6.5.3_Intel_LPT-RC_060_010
04. ME : 4.6.4.1_Intel_ME_RC_0.60_009
05. Platform : 4.6.5.3_PF-ACPI_RC_060_008
06. DPTF : 4.6.5.3_DPTF-RC_060_002
07. CPPC : 4.6.5.3_CPPC-RC_060_002
08. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_060_003
Modules added to this label:
01. FIT : Label 4651_FIT_001
02. KbcSouthBridge - LynxPoint: 4.6.3-KbcEmulation-LynxPnt-001
Modules removed from last label:
01. KbcSouthBridge - Ibex Peak: 4.6.3-KbcEmulation-IbexPeak-001
New features added in this label:
None
General Bug Fixes:
None
EIP addressed in this label:
None
Files changed for EIP fixes:
None
Known issues and limitations in this label:
01. Haswell CPU RefCode do not support "x64_build = 0".
02. Please refer to EIP#85251 for hang on A2 issue.
03. Fedora Core 16 64 bit S3/S4 resume detect USB error message.
04. Sata Driver v12.0.0.1476 not working properly.
05. According to Intel_497869, to disable PCH PCIe port 3 through 8 if resume failed from S3.
06. Fedora Core 16 64 bit installation fail: Resolved by set setup item "xHCI Mode" = "Disabled".
07. Screen might not have any output if from internal GfX.(VBIOS 2139 and GOP v5.0.1.1005)
08. If the setup item "MRC Fast Boot" = "Enabled", to unplug DIMM or change its position will cause system hang at CKP 0x55 in warm boot.
09. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C randomly occur.
10. For fast boot support, to enable the setup item "MRC Fast Boot" is required.
11. USB 3.0 controller has no functional in Windows 8: To set the setup item "xHCI Mode" = "Disabled" for temporary, it should be fixed by windows driver.
Remaining Issues:
None
Unit Testing:
None
Validation Testing:
Please refer to EIP#94612
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Inrel Rapid Start function enabled need to enable MRC FaceBoot setup item.
03. Change GP I/O base asddress to 0x800, GP I/O Registes Range to 0x400.
03. IntelGigabitLan module: 4.6.3.1_INTEL_GIGABIT_LAN_04 doesn't support onboard GbE.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1064 for Flathead Creek CRB
Rom0x_8MB_Q87.bin: This is ME9.0_5M_9.0.0.1064 for Flathead Creek CRB
Release History:
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.3
Release Date: 2012-08-15
Source Control Label: 4.6.5.3_VEB_1AQQW008
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: 00
Northbridge: Haswell
Southbridge: LynxPoint
Processor: Haswell, Stepping: A1
CPU ID: 306C1, Microcode Version: 013
Memory: 2GB, Frequency: 1333MHz
Video BIOS Version: 2144
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1139
ME F/W Binary: LPT_H_1.5M_PreProduction.bin; ME9.0_5M_PreProduction.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_5.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
Board\Flash\SPI\SpiFlash.cif | Add Intel module part in SPI.
Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Core\EM\CSM\CSM.c | Revise for Intel CPU module.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\CORE_PEI\DxeIpl.c | Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
CORE\EM\SMIFlash\SMIFlashLinks.c | Update to rev.18 for OA3.0.
Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
Core\EM\SMBIOS\SMBios.c | Update to rev.121 for a redundant FreePool call.
Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
board\em\csm\csm.sd | Remove CsmSupport item because it is useless.
Core\CORE_DXE\Page.c | Update page.c to version 10 for EIP82751.
Core\CORE_DXE\locate.c | Update locate.c to version 5 for EIP82756.
Core\EM\NVRAM\NVRAMDXE.c | Update to rev.92 for Win8 Test.
Core\EM\S3\BootScriptSave.c | Correct 'SCRIPT_MEM_POLL' macro for Aptio4.
Core\EM\SMM\SmmDispatcher.c | Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
Core\EM\ACPI\AcpiCore.c | Update it for EIP88889.
Include\ACPI50.h | Update it for EIP88889.
CORE\EM\ACPI\asllib.asl | Update to rev.8 for EIP87370.
Core\CORE_DXE\BootOptions.c | Update to rev.23 for EIP84716.
Core\EM\NvramSmi\NvramSmi.c | Update to rev.7 for EIP86642.
Core\EM\SecurityPkg\AuthenticatedVariable\AuthVariable.c | Update to rev.43 for Win8 Test.
ReferenceCode\RapidStart\Smm\RapidStartSmm.c | Correct resume fail from S4 of iRST.
Core\CORE_DXE\BDS.c | Update to rev.111 for EIP85611.Update rev.113 and 114 for EIP90941.
Core\CORE_DXE\CORE_DXE.sdl | Update EIP85611
Board\EM\ACPI\ACPI.sd | Disabled S1 Sleep state.
Board\EM\ACPI\ACPI.sd | Disabled S1 Sleep state.
Core\EM\Sredir\LegacySredir.c | Update for iAMT IDER/SOL function.
Core\EM\PCI\PciBus.c | Update PciBus.c to Revision 140 for CsmOptOut.
Include\AmiLoadCsmPolicy.h | Update AmiLoadCsmPolicy.h to Revision 2 for CsmOptOut.
CRB\M32306C1_FFFF0013.pdb | Add CPU microcode A-0 (Haswell) M32306C1_FFFF0013.
CRB\M32306C2_FFFF0003.pdb | Add CPU microcode B-0 (Haswell) M32306C2_FFFF0003.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.03.0069
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;

Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On
Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

Chipset Specific Function Support:
Required eModule(s)
None

Token Setting
Token Name Value
Notes: Please describe any notes for supporting this function

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell Reference code ver. 0.60
NorthBridge – Haswell - SystemAgent Reference code ver. 0.60
SouthBridge – LynxPoint Reference code label ver. 0.60
Haswell ACPI – Reference code ver. 0.60
Manageability Engine (ME) Reference Code ver. 0.60
Intel Rapid Start Technology – Reference code ver. 0.60
Intel DPTF – Reference code ver. 0.60
Intel CPPC – Reference code ver. 0.60
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Haswell : 4651_Haswell_04a-RC_060
02. Intel SystemAgent : 4.6.5.3_Intel_SA-RC_060_009
03. Intel PCH : 4.6.5.3_Intel_LPT-RC_060_011
04. CsmOptOut : 4.6.5.4_Csm_OptOut_03
05. ME : 4.6.4.1_Intel_ME_RC_0.60_012
06. Platform : 4.6.5.3_PF-ACPI_RC_060_009
07. CPPC : 4.6.5.3_CPPC-RC_060_003
08. Intel Nehalem Microcode : 4.6.0_INTEL_MICROCODE_41
09. RomImage : 4.6.5.3_RomImage_006
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. Haswell CPU RefCode do not support "x64_build = 0".
02. Please refer to EIP#85251 for hang on 0xA0 or 0xA2 issue.
03. Fedora Core 16 64 bit S3/S4 resume detect USB error message.
04. According to Intel_497869, to disable PCH PCIe port 3 through 8 if resume failed from S3.
05. Fedora Core 16 64 bit installation fail: Resolved by set setup item "xHCI Mode" = "Disabled".
06. Screen might not have any output if from internal GfX.(VBIOS 2144 and GOP v5.0.4.1010)
07. If the setup item "MRC Fast Boot" = "Enabled", to unplug DIMM or change its position will cause system hang at CKP 0x55 in warm boot.
08. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C randomly occur.
09. For fast boot support, to enable the setup item "MRC Fast Boot" is required.
10. Set "Secure Boot Mode = Custom" and "Install default Secure Boot keys" option. The Legacy boot options are still available.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Please refer to EIP#92775
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Inrel Rapid Start function enabled need to enable MRC FaceBoot setup item.
03. Change GP I/O base asddress to 0x800, GP I/O Registes Range to 0x400.
04. IntelGigabitLan module: 4.6.3.1_INTEL_GIGABIT_LAN_04 doesn't support onboard GbE.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1139 for Flathead Creek CRB
Rom0x_8MB_Q87.bin: This is ME9.0_5M_9.0.0.1139 for Flathead Creek CRB
Release History:
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.3
Release Date: 2012-08-21
Source Control Label: 4.6.5.3_VEB_1AQQW009
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: 00
Northbridge: Haswell
Southbridge: LynxPoint
Processor: Haswell, Stepping: A1
CPU ID: 306C1, Microcode Version: 013
Memory: 2GB, Frequency: 1333MHz
Video BIOS Version: 2145
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1139
ME F/W Binary: LPT_H_1.5M_PreProduction.bin; ME9.0_5M_PreProduction.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_5.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
Board\Flash\SPI\SpiFlash.cif | Add Intel module part in SPI.
Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Core\EM\CSM\CSM.c | Revise for Intel CPU module.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\CORE_PEI\DxeIpl.c | Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
Core\EM\SMBIOS\SMBios.c | Update to rev.121 for a redundant FreePool call.
Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
board\em\csm\csm.sd | Remove CsmSupport item because it is useless.
Core\CORE_DXE\Page.c | Update page.c to version 10 for EIP82751.
Core\CORE_DXE\locate.c | Update locate.c to version 5 for EIP82756.
Core\EM\NVRAM\NVRAMDXE.c | Update to rev.92 for Win8 Test.
Core\EM\S3\BootScriptSave.c | Correct 'SCRIPT_MEM_POLL' macro for Aptio4.
Core\EM\SMM\SmmDispatcher.c | Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
Core\EM\ACPI\AcpiCore.c | Update it for EIP88889.
Include\ACPI50.h | Update it for EIP88889.
CORE\EM\ACPI\asllib.asl | Update to rev.8 for EIP87370.
Core\CORE_DXE\BootOptions.c | Update to rev.23 for EIP84716.
Core\EM\NvramSmi\NvramSmi.c | Update to rev.7 for EIP86642.
Core\EM\SecurityPkg\AuthenticatedVariable\AuthVariable.c | Update to rev.43 for Win8 Test.
Core\CORE_DXE\BDS.c | Update to rev.111 for EIP85611.Update rev.113 and 114 for EIP90941.
Core\CORE_DXE\CORE_DXE.sdl | Update EIP85611
Board\EM\ACPI\ACPI.sd | Disabled S1 Sleep state.
Board\EM\ACPI\ACPI.sd | Disabled S1 Sleep state.
Core\EM\Sredir\LegacySredir.c | Update for iAMT IDER/SOL function.
Core\EM\PCI\PciBus.c | Update PciBus.c to Revision 140 for CsmOptOut.
Include\AmiLoadCsmPolicy.h | Update AmiLoadCsmPolicy.h to Revision 2 for CsmOptOut.
CRB\M32306C1_FFFF0013.pdb | Add CPU microcode A-0 (Haswell) M32306C1_FFFF0013.
CRB\M32306C2_FFFF0003.pdb | Add CPU microcode B-0 (Haswell) M32306C2_FFFF0003.
ReferenceCode\Haswell\CpuS3\Pei\CpuS3Peim.c | Fixed S3 resume fail.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.03.0069
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;

Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On
Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

Chipset Specific Function Support:
Required eModule(s)
None

Token Setting
Token Name Value
Notes: Please describe any notes for supporting this function

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_39 , Dated: 2012-04-04
Visual eBios: RSS.5.73.0225, Dated: 2012-03-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell: reference code ver. 0.61
NorthBridge – Haswell - SystemAgent: reference code ver. 0.61
SouthBridge – LynxPoint: reference code label ver. 0.61
Hasewell ACPI – Reference code ver. 0.61
Manageability Engine (ME) reference code ver. 0.61
Intel Rapid Start Technology – Reference code ver. 0.61
Intel DPTF – Reference code ver. 0.61
Intel CPPC – Reference code ver. 0.61
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. CPU : 4651_Haswell_05a-RC_061
02. NB : 4.6.5.3_Intel_SA-RC_061_010
03. SB : 4.6.5.3_Intel_LPT-RC_061_013
04. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_061_004
05. ME : 4.6.4.1_Intel_ME_RC_0.61_013
06. Platform : 4.6.5.3_PF-ACPI_RC_061_010
07. DPTF : 4.6.5.3_DPTF-RC_061_003
08. CPPC : 4.6.5.3_CPPC-RC_061_004
09. TSE : 4.6.2_TSE_2_15_1227
10. USB : 4.6.3_USB_08.10.22
11. SMIFlash : 4.6.3.6_SMIFLASH_25
12. Intel Nehalem Microcode: 4.6.0_INTEL_MICROCODE_42
Modules added to this label:
01. AmiGopPolicy : 4.6.5.3_AmiGopPolicy_000
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. Haswell CPU RefCode do not support "x64_build = 0".
02. Please refer to EIP#85251 for hang on 0xA0 or 0xA2 issue.
03. Fedora Core 16 64 bit S3/S4 resume detect USB error message.
04. According to Intel_497869, to disable PCH PCIe port 3 through 8 if resume failed from S3.
05. Fedora Core 16 64 bit installation fail: Resolved by set setup item "xHCI Mode" = "Disabled".
06. While testing vBIOS 2145 and GOP 5.0.5.1012, there is state that IGFX can't display.
07. If the setup item "MRC Fast Boot" = "Enabled", to unplug DIMM or change its position will cause system hang at CKP 0x55 in warm boot.
08. For fast boot support, to enable the setup item "MRC Fast Boot" is required.
09. Set "Secure Boot Mode = Custom" and "Install default Secure Boot keys" option. The Legacy boot options are still available.
10. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C randomly occur.(Fixed in HSW B0)
11. D-SUB output might not functional if driver is installed on LPT B0 Sku board.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Inrel Rapid Start function enabled need to enable MRC FaceBoot setup item.
03. Change GP I/O base asddress to 0x800, GP I/O Registes Range to 0x400.Change PM(ACPI) base asddress to 0x1800.
04. IntelGigabitLan module: 4.6.3.1_INTEL_GIGABIT_LAN_04 doesn't support onboard GbE.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1139 for Flathead Creek CRB
Rom0x_8MB_Q87.bin: This is ME9.0_5M_9.0.0.1139 for Flathead Creek CRB
Release History:
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.3
Release Date: 2012-09-06
Source Control Label: 4.6.5.3_VEB_1AQQW010
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: 00
Northbridge: Haswell
Southbridge: LynxPoint Stepping: B0
Processor: Haswell, Stepping: B0
CPU ID: 306C2, Microcode Version: 003
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2145
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1179
ME F/W Binary: ME9.0_1.5M_PreProduction.bin; ME9.0_5M_PreProduction.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_11.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
Board\Flash\SPI\SpiFlash.cif | Add Intel module part in SPI.
Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
Core\CORE_DXE\Page.c | Update page.c to version 10 for EIP82751.
Core\CORE_DXE\locate.c | Update locate.c to version 5 for EIP82756.
Core\EM\NVRAM\NVRAMDXE.c 1. Update to rev.92 for Win8 Test.
2. Update to rev.95 for Win8 Test.
Core\EM\S3\BootScriptSave.c | Correct 'SCRIPT_MEM_POLL' macro for Aptio4.
Core\EM\SMM\SmmDispatcher.c | Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
Core\EM\ACPI\AcpiCore.c
Include\ACPI50.h
Core\EM\S3\S3Resume.c
Library\EfiLib.c
Core\CORE_DXE\Image.c
 Update it for EIP88889.
Win8 test - UEFI Firmware Certification Test Failed(FPDT)
CORE\EM\ACPI\asllib.asl | Update to rev.8 for EIP87370.
Core\CORE_DXE\BootOptions.c | Update to rev.25 for EIP92839.
Core\EM\NvramSmi\NvramSmi.c | Update to rev.8 for EIP88363.
Core\CORE_DXE\BDS.c | Update to rev.111 for EIP85611.Update rev.113 and 114 for EIP90941.
Core\CORE_DXE\CORE_DXE.sdl | Update EIP85611
Board\EM\ACPI\ACPI.sd | Disabled S1 Sleep state.
Core\EM\Sredir\LegacySredir.c | Update for iAMT IDER/SOL function.
Core\EM\PCI\PciBus.c | Update to rev.145 for EIP97691.
Include\AmiLoadCsmPolicy.h | Update AmiLoadCsmPolicy.h to Revision 2 for CsmOptOut.
ReferenceCode\Haswell\CpuS3\Pei\CpuS3Peim.c | Fixed S3 resume fail.
Core\CORE_DXE\BdsBoard.c | Update to rev.63 for EIP85762.
Include\BootOptions.h | Update it for EIP85762.
Core\EM\PS2CTL\kbc.h
Core\EM\PS2CTL\ps2kbd.c
 Update it for EIP88437.
Windows 8 feature test - USB KEY boot issue (secure boot)
ReferenceCode\RapidStart\Pei\RapidStartPei.c | Improve iFFS performance.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Include\AmiDxeLib.h
Core\EM\S3\BootScriptSave.c
         Reprogram 'SaveStateMemPoll' functon.
Edk\MiniSetup\BootOnly\MiniSetupLocal.lib
Edk\MiniSetup\BootOnly\MiniSetupLocalx64.lib
         Update to rev.82 for WIN8 test
ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchPm.c
         System might stop at 0x71 during reset long run test.(EIP100194)
ReferenceCode\Chipset\SystemAgent\MemoryInit\Pei\
Source\ReadTraining\MrcReadDqDqs.c 		Update it for Sighting #4391781.
Board\EM\Platform\AcpiPlatform.c
Board\EM\Platform\AcpiPlatform.h
ReferenceCode\RapidStart\Smm\RapidStartSmm.mak
         Update it for iSCT

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.03.0069
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;

Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On
Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

Chipset Specific Function Support:
Required eModule(s)
None

Token Setting
Token Name Value
Notes: Please describe any notes for supporting this function

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated: 2012-07
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell: reference code ver. 0.61
NorthBridge – Haswell - SystemAgent: reference code ver. 0.61
SouthBridge – LynxPoint: reference code label ver. 0.61
Hasewell ACPI – Reference code ver. 0.61
Manageability Engine (ME) reference code ver. 0.61
Intel Rapid Start Technology – Reference code ver. 0.61
Intel DPTF – Reference code ver. 0.61
Intel CPPC – Reference code ver. 0.61
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. CPU : 4651_Haswell_05b-RC_061
02. NB : 4.6.5.3_Intel_SA-RC_061_012
03. SB : 4.6.5.3_Intel_LPT-RC_061_015
04. ME : 4.6.4.1_Intel_ME_RC_0.61_014
05. Platform: 4.6.5.3_PF-ACPI_RC_061_011
06. Secure Flash Pkg : 4.6.5.1_SECMOD_010
07. Secure Boot Pkg : 4.6.5.1_SECBOOT_WIN8_12
08. Post Time Tuning : 4.6.4.0_PTT_11
09. UefiNetworkStack II : 4.6.4_UEFI_NETWORK_STACK_II_05
10. Rom Image : 4.6.5.3_RomImage_008
11. SMBIOS - Board : 4.6.5.1_SMBIOSBOARD_32
12. SMBIOS - Core Source : 4.6.5.1_SMBIOS_32
13. CSM : 4.6.3.1_CSM.7.70_79
Modules added to this label:
NONE
Modules removed from last label:
01. Embedded Controller
New features added in this label:
  1. Enable 60/64 decode for AMT IDER function.
    a. Set "KBC_SUPPORT" = "1".
    b. Set "ISA_IRQ_MASK" = "0xE307".
    c. Enable 60/64 decode range.
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. Haswell CPU RefCode do not support "x64_build = 0".
02. Fedora Core 16 64 bit S3/S4 resume detect USB error message.
03. According to Intel_497869, to disable PCH PCIe port 3 through 8 if resume failed from S3.
04. Fedora Core 16 64 bit installation fail: Resolved by set setup item "xHCI Mode" = "Disabled".
05. While testing vBIOS 2145 and GOP 5.0.5.1012, there is state that IGFX can't display.
06. If the setup item "MRC Fast Boot" = "Enabled", to unplug DIMM or change its position will cause system hang at CKP 0x55 in warm boot.
07. For fast boot support, to enable the setup item "MRC Fast Boot" is required.
08. Set "Secure Boot Mode = Custom" and "Install default Secure Boot keys" option. The Legacy boot options are still available.
09. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C randomly occur with A1(306C1) stepping HSW.
10. D-SUB output might not functional if driver is installed on LPT B0 Sku board.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
03. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
04. IntelGigabitLan module: 4.6.3.1_INTEL_GIGABIT_LAN_04 doesn't support onboard GbE.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1179 for Flathead Creek CRB
Rom0x_8MB_Q87.bin: This is ME9.0_5M_9.0.0.1179 for Flathead Creek CRB
Release History:
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.3
Release Date: 2012-09-18
Source Control Label: 4.6.5.3_VEB_1AQQW011
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: 00
Northbridge: Haswell
Southbridge: LynxPoint Stepping: B0
Processor: Haswell, Stepping: B0
CPU ID: 306C2, Microcode Version: 003
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2145
EC Version: 1.10
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1179
ME F/W Binary: ME9.0_1.5M_PreProduction.bin; ME9.0_5M_PreProduction.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_11.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
Board\Flash\SPI\SpiFlash.cif | Add Intel module part in SPI.
Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
Core\CORE_DXE\Page.c | Update page.c to version 10 for EIP82751.
Core\CORE_DXE\locate.c | Update locate.c to version 5 for EIP82756.
Core\EM\NVRAM\NVRAMDXE.c 1. Update to rev.92 for Win8 Test.
2. Update to rev.95 for Win8 Test.
Core\EM\S3\BootScriptSave.c | Correct 'SCRIPT_MEM_POLL' macro for Aptio4.
Core\EM\SMM\SmmDispatcher.c | Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
Core\EM\ACPI\AcpiCore.c
Include\ACPI50.h
Core\EM\S3\S3Resume.c
Library\EfiLib.c
Core\CORE_DXE\Image.c
 Update it for EIP88889.
Win8 test - UEFI Firmware Certification Test Failed(FPDT)
CORE\EM\ACPI\asllib.asl | Update to rev.8 for EIP87370.
Core\CORE_DXE\BootOptions.c | Update to rev.25 for EIP92839.
Core\EM\NvramSmi\NvramSmi.c | Update to rev.8 for EIP88363.
Core\CORE_DXE\BDS.c | Update to rev.111 for EIP85611.Update rev.113 and 114 for EIP90941.
Core\CORE_DXE\CORE_DXE.sdl | Update EIP85611
Board\EM\ACPI\ACPI.sd | Disabled S1 Sleep state.
Core\EM\Sredir\LegacySredir.c | Update for iAMT IDER/SOL function.
Core\EM\PCI\PciBus.c | Update to rev.145 for EIP97691.
Include\AmiLoadCsmPolicy.h | Update AmiLoadCsmPolicy.h to Revision 2 for CsmOptOut.
ReferenceCode\Haswell\CpuS3\Pei\CpuS3Peim.c | Fixed S3 resume fail.
Core\CORE_DXE\BdsBoard.c | Update to rev.63 for EIP85762.
Include\BootOptions.h | Update it for EIP85762.
Core\EM\PS2CTL\kbc.h
Core\EM\PS2CTL\ps2kbd.c
 Update it for EIP88437.
Windows 8 feature test - USB KEY boot issue (secure boot)
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Include\AmiDxeLib.h
Core\EM\S3\BootScriptSave.c
 Reprogram 'SaveStateMemPoll' functon.
Edk\MiniSetup\BootOnly\MiniSetupLocal.lib
Edk\MiniSetup\BootOnly\MiniSetupLocalx64.lib
 Update to rev.82 for WIN8 test
ReferenceCode\Chipset\LynxPoint\PchInit\Pei\PchInitPeim.c
ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchPm.c
 System might stop at 0x71 during reset long run test.(EIP100194)
ReferenceCode\Chipset\SystemAgent\MemoryInit\Pei\
Source\ReadTraining\MrcReadDqDqs.c 		Update it for Sighting #4391781.
ReferenceCode\RapidStart\Smm\RapidStartSmm.mak | Update it for iSCT
Core\EM\CsmOptOut\CsmOptOut.c
ReferenceCode\Haswell\SampleCode\SecCore\Sec\Ia32\Chipset.inc
ReferenceCode\Haswell\SampleCode\SecCore\Sec\Ia32\IvyBridge.inc
         Update to rev.14 for Thunderbolt support.
Modify for Thunderbolt support.
ReferenceCode\Haswell\PowerManagement\Dxe\PowerMgmtFeatures.c Fixed that system can't boot OS if CPU is not CMP mode.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.03.0069
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;

Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On
Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

Chipset Specific Function Support:
Required eModule(s)
None

Token Setting
Token Name Value
Notes: Please describe any notes for supporting this function

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated: 2012-07
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell: reference code ver. 0.61
NorthBridge – Haswell - SystemAgent: reference code ver. 0.61
SouthBridge – LynxPoint: reference code label ver. 0.61
Hasewell ACPI – Reference code ver. 0.61
Manageability Engine (ME) reference code ver. 0.61
Intel Rapid Start Technology – Reference code ver. 0.61
Intel DPTF – Reference code ver. 0.61
Intel CPPC – Reference code ver. 0.61
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. NB : 4.6.5.3_Intel_SA-RC_061_013
02. SB : 4.6.5.3_Intel_LPT-RC_061_016
03. Platform : 4.6.5.3_PF-ACPI_RC_061_012
04. Thunderbolt : 4.6.5.3_TBT_101_002
05. RomImage : 4.6.5.3_RomImage_009
Modules added to this label:
01. Intel Smart Connect Technology : 4.6.5.3_ISCT_000
02. SwitchableGraphics : 4.6.5.3_SG_000
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. Haswell CPU RefCode do not support "x64_build = 0".
02. Fedora Core 16 64 bit S3/S4 resume detect USB error message.
03. According to Intel_497869, to disable PCH PCIe port 3 through 8 if resume failed from S3.
04. Fedora Core 16 64 bit installation fail: Resolved by set setup item "xHCI Mode" = "Disabled".
05. While testing vBIOS 2145 and GOP 5.0.5.1012, there is state that IGFX can't display.
06. If the setup item "MRC Fast Boot" = "Enabled", to unplug DIMM or change its position will cause system hang at CKP 0x55 in warm boot.
07. For fast boot support, to enable the setup item "MRC Fast Boot" is required.
08. Set "Secure Boot Mode = Custom" and "Install default Secure Boot keys" option. The Legacy boot options are still available.
09. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C randomly occur with A1(306C1) stepping HSW.
10. D-SUB output might not functional if driver is installed on LPT B0 Sku board.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
03. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
04. IntelGigabitLan module: 4.6.3.1_INTEL_GIGABIT_LAN_04 doesn't support onboard GbE.
05. To fix iFFS RTC wake up fail issue by set token "AMI_RAPID_START_WORKAROUND" = "1", it can also improve iFFS resume time.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1179 for Flathead Creek CRB
Rom0x_8MB_Q87.bin: This is ME9.0_5M_9.0.0.1179 for Flathead Creek CRB
Release History:
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.3
Release Date: 2012-10-04
Source Control Label: 4.6.5.3_VEB_1AQQW012
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Fab 2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: B0
Processor: Haswell, Stepping: B0
CPU ID: 306C2, Microcode Version: 003
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2149
EC Version: 1.10
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1179
ME F/W Binary: ME9.0_1.5M_PreProduction.bin; ME9.0_5M_PreProduction.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_11.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
Board\Flash\SPI\SpiFlash.cif | Add Intel module part in SPI.
Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
Core\CORE_DXE\Page.c | Update page.c to version 10 for EIP82751.
Core\CORE_DXE\locate.c | Update locate.c to version 5 for EIP82756.
Core\EM\NVRAM\NVRAMDXE.c 1. Update to rev.92 for Win8 Test.
2. Update to rev.95 for Win8 Test.
Core\EM\S3\BootScriptSave.c | Correct 'SCRIPT_MEM_POLL' macro for Aptio4.
Core\EM\SMM\SmmDispatcher.c | Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
Core\EM\ACPI\AcpiCore.c
Include\ACPI50.h
Core\EM\S3\S3Resume.c
Library\EfiLib.c
Core\CORE_DXE\Image.c
 Update it for EIP88889.
Win8 test - UEFI Firmware Certification Test Failed(FPDT)
CORE\EM\ACPI\asllib.asl | Update to rev.8 for EIP87370.
Core\CORE_DXE\BootOptions.c | Update to rev.25 for EIP92839.
Core\EM\NvramSmi\NvramSmi.c | Update to rev.8 for EIP88363.
Core\CORE_DXE\BDS.c | Update to rev.111 for EIP85611.Update rev.113 and 114 for EIP90941.
Core\CORE_DXE\CORE_DXE.sdl | Update EIP85611
Board\EM\ACPI\ACPI.sd | Disabled S1 Sleep state.
Core\EM\Sredir\LegacySredir.c | Update for iAMT IDER/SOL function.
Core\EM\PCI\PciBus.c | Update to rev.145 for EIP97691.
Include\AmiLoadCsmPolicy.h | Update AmiLoadCsmPolicy.h to Revision 2 for CsmOptOut.
Core\CORE_DXE\BdsBoard.c | Update to rev.63 for EIP85762.
Include\BootOptions.h | Update it for EIP85762.
Core\EM\PS2CTL\kbc.h
Core\EM\PS2CTL\ps2kbd.c
 Update it for EIP88437.
Windows 8 feature test - USB KEY boot issue (secure boot)
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Include\AmiDxeLib.h
Core\EM\S3\BootScriptSave.c
 Reprogram 'SaveStateMemPoll' functon.
EDK\MiniSetup\BootOnly\MiniSetupLocal.lib
EDK\MiniSetup\BootOnly\MiniSetupLocalx64.lib
 Update to rev.82 for WIN8 test
Core\EM\CsmOptOut\CsmOptOut.c
 Update to rev.14 for Thunderbolt support.
Core\em\Ahci\AhciBus.c
Core\eM\Ahci\AInt13.c
Include\Protocol\PAhciBus.h
         Update EIP95440 for UEFI RAID driver support.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.03.0069
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;

Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On
Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

Chipset Specific Function Support:
Required eModule(s)
None

Token Setting
Token Name Value
Notes: Please describe any notes for supporting this function

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated: 2012-07
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell: Reference code ver. 0.70
NorthBridge – Haswell - SystemAgent: Reference code ver. 0.70
SouthBridge – LynxPoint: Reference code ver. 0.70
Hasewell ACPI – Reference code ver. 0.70
Manageability Engine (ME) Reference code ver. 0.70
Intel Rapid Start Technology – Reference code ver. 0.70
Intel DPTF – Reference code ver. 0.70
Intel CPPC – Reference code ver. 0.70
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. CPU : 4651_Haswell_06-RC_070
02. NB : 4.6.5.3_Intel_SA-RC_070_017
03. SB : 4.6.5.3_Intel_LPT-RC_070_018
04. AHCI : 4.6.3_AhciSrc_020
05. CSP : Intel ICHx SPI - Source : 4.6.3_SPI-Intel-ICHx_12
06. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_070_005
07. ME : 4.6.4.1_Intel_ME_RC_0.70_015
08. Platform : 4.6.5.3_PF-ACPI_RC_070_013
09. Intel Smart Connect Technology : 4.6.5.3_ISCT40_050_001
10. SwitchableGraphics : 4.6.5.3_SG_001
Modules added to this label:
01. EcPs2Kbd : 4.6.3.3_EcPs2Kbd_04
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek Fab2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. Please refer to EIP#85251 for hang on 0xA0 or 0xA2 issue.
04. Fedora Core 16/17 x64 Known issues:
a. Fedora Core 16 and 17 x64 S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
05. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
06. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C is occurring on HSW A1(306C1) stepping randomly .
07. D-SUB output might not functional if driver is installed on LPT B0 Sku board.
08. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
09. IntelGigabitLan module: 4.6.3.1_INTEL_GIGABIT_LAN_04 doesn't support onboard GbE.
10. System would hang at CKP 0x78 when SDL token "AMIDEBUG_RX_SUPPORT" = "1" and TPM is enabled.
11. System might hang at Windows 7 x64 BSOD 0x000000F4 after S3 resume.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1179 for Flathead Creek CRB
Rom0x_8MB_Q87.bin: This is ME9.0_5M_9.0.0.1179 for Flathead Creek CRB
Release History:
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.3
Release Date: 2012-10-15
Source Control Label: 4.6.5.3_VEB_1AQQW013
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Fab 2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: B0
Processor: Haswell, Stepping: B0
CPU ID: 306C2, Microcode Version: 003
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2149
EC Version: 1.10
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1179
ME F/W Binary: ME9.0_1.5M_PreProduction.bin; ME9.0_5M_PreProduction.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_11.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
Board\Flash\SPI\SpiFlash.cif | Add Intel module part in SPI.
Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
Core\CORE_DXE\Page.c | Update page.c to version 10 for EIP82751.
Core\CORE_DXE\locate.c | Update locate.c to version 5 for EIP82756.
Core\EM\NVRAM\NVRAMDXE.c 1. Update to rev.92 for Win8 Test.
2. Update to rev.95 for Win8 Test.
Core\EM\S3\BootScriptSave.c | Correct 'SCRIPT_MEM_POLL' macro for Aptio4.
Core\EM\SMM\SmmDispatcher.c | Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
Core\EM\ACPI\AcpiCore.c
Include\ACPI50.h
Core\EM\S3\S3Resume.c
Library\EfiLib.c
Core\CORE_DXE\Image.c
 Update it for EIP88889.
Win8 test - UEFI Firmware Certification Test Failed(FPDT)
CORE\EM\ACPI\asllib.asl | Update to rev.8 for EIP87370.
Core\CORE_DXE\BootOptions.c | Update to rev.25 for EIP92839.
Core\CORE_DXE\BDS.c | Update to rev.111 for EIP85611.Update rev.113 and 114 for EIP90941.
Core\CORE_DXE\CORE_DXE.sdl | Update EIP85611
Board\EM\ACPI\ACPI.sd | Disabled S1 Sleep state.
Core\EM\Sredir\LegacySredir.c | Update for iAMT IDER/SOL function.
Core\EM\PCI\PciBus.c | Update to rev.145 for EIP97691.
Include\AmiLoadCsmPolicy.h | Update AmiLoadCsmPolicy.h to Revision 2 for CsmOptOut.
Core\CORE_DXE\BdsBoard.c | Update to rev.63 for EIP85762.
Include\BootOptions.h | Update it for EIP85762.
Core\EM\PS2CTL\kbc.h
Core\EM\PS2CTL\ps2kbd.c
 Update it for EIP88437.
Windows 8 feature test - USB KEY boot issue (secure boot)
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Include\AmiDxeLib.h
Core\EM\S3\BootScriptSave.c
 Reprogram 'SaveStateMemPoll' functon.
Core\EM\CsmOptOut\CsmOptOut.c
 Update to rev.14 for Thunderbolt support.
Core\em\Ahci\AhciBus.c
Core\eM\Ahci\AInt13.c
Include\Protocol\PAhciBus.h
 Update EIP95440 for UEFI RAID driver support.
Library\Memory.c
 Update for EIP81447
Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi
 Update for Intel GbE i217 (B0:D19:F0) support.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.03.0069
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;

Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On
Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

Chipset Specific Function Support:
Required eModule(s)
None

Token Setting
Token Name Value
Notes: Please describe any notes for supporting this function

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated: 2012-07
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell: Reference code ver. 0.70
NorthBridge – Haswell - SystemAgent: Reference code ver. 0.70
SouthBridge – LynxPoint: Reference code ver. 0.70
Hasewell ACPI – Reference code ver. 0.70
Manageability Engine (ME) Reference code ver. 0.70
Intel Rapid Start Technology – Reference code ver. 0.70
Intel DPTF – Reference code ver. 0.70
Intel CPPC – Reference code ver. 0.70
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. CPU : 4651_Haswell_06b-RC_070
02. NVRAM SMI : 4.6.5.1_NvramSmi_3
03. TSE Biniary : 4.6.2_TSE_2_15_1231
04. Intel Nehalem Microcode : 4.6.0_INTEL_MICROCODE_43
Modules added to this label:
01.EFI OS BootOptionName: 4.6.4.1_EfiOsBootOptionNames_02
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek Fab2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. Please refer to EIP#85251 for hang on 0xA0 or 0xA2 issue.
04. Fedora Core 16/17 x64 Known issues:
a. Fedora Core 16 and 17 x64 S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
05. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
06. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C is occurring on HSW A1(306C1) stepping randomly .
07. D-SUB output might not functional if driver is installed on LPT B0 Sku board.
08. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
09. System would hang at CKP 0x78 when SDL token "AMIDEBUG_RX_SUPPORT" = "1" and TPM is enabled.
10. System might hang at Windows 7 x64 BSOD 0x000000F4 after S3 resume.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1179 for Flathead Creek CRB
Rom0x_8MB_Q87.bin: This is ME9.0_5M_9.0.0.1179 for Flathead Creek CRB
Release History:
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.3
Release Date: 2012-10-22
Source Control Label: 4.6.5.3_VEB_1AQQW014
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Fab 2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: B0
Processor: Haswell, Stepping: B0
CPU ID: 306C2, Microcode Version: 003
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2155
EC Version: 1.10
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1179
ME F/W Binary: ME9.0_1.5M_PreProduction.bin; ME9.0_5M_PreProduction.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_11.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
Board\Flash\SPI\SpiFlash.cif | Add Intel module part in SPI.
Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
Core\CORE_DXE\Page.c | Update page.c to version 10 for EIP82751.
Core\CORE_DXE\locate.c | Update locate.c to version 5 for EIP82756.
Core\EM\NVRAM\NVRAMDXE.c 1. Update to rev.92 for Win8 Test.
2. Update to rev.95 for Win8 Test.
Core\EM\S3\BootScriptSave.c | Correct 'SCRIPT_MEM_POLL' macro for Aptio4.
Core\EM\SMM\SmmDispatcher.c | Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
Core\EM\ACPI\AcpiCore.c
Include\ACPI50.h
Core\EM\S3\S3Resume.c
Library\EfiLib.c
Core\CORE_DXE\Image.c
 Update it for EIP88889.
Win8 test - UEFI Firmware Certification Test Failed(FPDT)
CORE\EM\ACPI\asllib.asl | Update to rev.8 for EIP87370.
Core\CORE_DXE\BootOptions.c | Update to rev.25 for EIP92839.
Core\CORE_DXE\BDS.c | Update to rev.111 for EIP85611.Update rev.113 and 114 for EIP90941.
Core\CORE_DXE\CORE_DXE.sdl | Update EIP85611
Board\EM\ACPI\ACPI.sd | Disabled S1 Sleep state.
Core\EM\Sredir\LegacySredir.c | Update for iAMT IDER/SOL function.
Core\EM\PCI\PciBus.c | Update to rev.145 for EIP97691.
Include\AmiLoadCsmPolicy.h | Update AmiLoadCsmPolicy.h to Revision 2 for CsmOptOut.
Core\CORE_DXE\BdsBoard.c | Update to rev.63 for EIP85762.
Include\BootOptions.h | Update it for EIP85762.
Core\EM\PS2CTL\kbc.h
Core\EM\PS2CTL\ps2kbd.c
 Update it for EIP88437.
Windows 8 feature test - USB KEY boot issue (secure boot)
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Include\AmiDxeLib.h
Core\EM\S3\BootScriptSave.c
 Reprogram 'SaveStateMemPoll' functon.
Core\EM\CsmOptOut\CsmOptOut.c
 Update to rev.14 for Thunderbolt support.
Core\em\Ahci\AhciBus.c
Core\eM\Ahci\AInt13.c
Include\Protocol\PAhciBus.h
 Update EIP95440 for UEFI RAID driver support.
Library\Memory.c
 Update for EIP81447
Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi
 Update for Intel GbE i217 (B0:D19:F0) support.
ReferenceCode\Haswell\CpuInit\Dxe\CpuInitDxeDbgr.c
ReferenceCode\Haswell\CpuInit\Dxe\CpuInitDxeDbgr.h
         Fix the building error issue is occurring if "AMIDEBUG_RX_SUPPORT" = "1".
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c
         Update for Intel PFAT support.
Board\EM\Pfat\PfatCpuPolicyOverride\PfatCpuPolicyOverride.c
 Fixed PFAT function fail on single SPI platform.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.03.0069
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;

Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On
Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

Chipset Specific Function Support:
Required eModule(s)
None

Token Setting
Token Name Value
Notes: Please describe any notes for supporting this function

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated: 2012-07
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell: Reference code ver. 0.71
NorthBridge – Haswell - SystemAgent: Reference code ver. 0.71
SouthBridge – LynxPoint: Reference code ver. 0.71
Hasewell ACPI – Reference code ver. 0.71
Manageability Engine (ME) Reference code ver. 0.71
Intel Rapid Start Technology – Reference code ver. 0.71
Intel DPTF – Reference code ver. 0.71
Intel CPPC – Reference code ver. 0.71
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. CPU : 4651_Haswell_07-RC_071
02. NB : 4.6.5.3_Intel_SA-RC_071_019b
03. SB : 4.6.5.3_Intel_LPT-RC_071_020
04. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_071_006
05. ME : 4.6.4.1_Intel_ME_RC_0.71_016
06. Platform : 4.6.5.3_PF-ACPI_RC_071_014
07. DPTF : 4.6.5.3_DPTF-RC_071_005
08. CPPC : 4.6.5.3_CPPC-RC_071_006
09. Intel Smart Connect Technology : 4.6.5.3_ISCT40_050_002
10. SwitchableGraphics : 4.6.5.3_SG_002
Modules added to this label:
01. PfatServices : 4.6.5.1_INTEL_PFAT_2_2
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek Fab2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. System hangs at CKP 0xA0 or 0xA2 randomly when HSW CPU stepping is A0/A1.
04. Fedora Core 16/17 x64 Known issues:
a. Fedora Core 16 and 17 x64 S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
05. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
06. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C is occurring on HSW A1(306C1) stepping randomly .
07. D-SUB output might not functional if driver is installed on LPT B0 Sku board.
08. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
09. System would hang at CKP 0x78 when SDL token "AMIDEBUG_RX_SUPPORT" = "1" and TPM is enabled.
10. System might hang at Windows 7 x64 BSOD 0x000000F4 after S3 resume.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1179 for Flathead Creek CRB
Rom0x_8MB_Q87.bin: This is ME9.0_5M_9.0.0.1179 for Flathead Creek CRB
Release History:
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2012-11-13
Source Control Label: 4.6.5.4_VEB_1AQQW015
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Fab 2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: B0
Processor: Haswell, Stepping: B0
CPU ID: 306C2, Microcode Version: 003
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2155
EC Version: 1.10
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1179
ME F/W Binary: ME9.0_1.5M_PreProduction.bin; ME9.0_5M_PreProduction.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_11.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD | Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Core\EM\Capsule2_0\Capsule2_0.c | Update it for EIP103898.
Core\CORE_DXE\ConSplitter\ConSplit.c | Update to rev.55 for EIP103887.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\FileSystem\FileFatHandler.c Update it for EIP#104620.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
ACPI_MOD | Board\EM\ACPI\ACPI.sd | Disabled S1 Sleep state.
Core\EM\ACPI\AcpiCore.c | Update for Haswell CPU Refcode.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD Core\em\Ahci\AhciBus.c
Core\eM\Ahci\AInt13.c 		Update EIP95440 for UEFI RAID driver support.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
OA30_MOD Core\EM\OemActivation\OemActivation.c
Core\EM\OemActivation\SmmOemActivation.c 		Update for EIP90324.
OFBDME_MOD | Chipset\eM\ME\MEUD\CSP_MEUD.c | Support SharkBay flash ME.
PFAT_MOD | Board\EM\Pfat\PfatCpuPolicyOverride\PfatCpuPolicyOverride.c | Fixed PFAT function fail on single SPI platform.
PLT_MOD | Board\EM\Platform\AcpiPlatform.c | Fixed the building error.
SMM_MOD Core\EM\SMM\SmmDispatcher.c Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
TCG_MOD Board\EM\TCG\AmiTcgPlatformPeiAfterMem.c
Core\EM\Tcg\xTcgPei.c 		Update for EIP90807.
Core\EM\Tcg\TcgDxe.c | Update to rev. 37 for fix EIP102905: System can't booy when AMI Debug RX and TPM both are enabled.
USB_MOD | core\em\usb\rt\ehci.c | Update it for EIP102781
Core\EM\usb\usbbus.c | Update to rev.73 for EIP#104910.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated: 2012-07
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell: Reference code ver. 0.72
NorthBridge – Haswell - SystemAgent: Reference code ver. 0.72
SouthBridge – LynxPoint: Reference code ver. 0.71
Hasewell ACPI – Reference code ver. 0.71
Manageability Engine (ME) Reference code ver. 0.71
Intel Rapid Start Technology – Reference code ver. 0.71
Intel DPTF – Reference code ver. 0.71
Intel CPPC – Reference code ver. 0.71
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Core : 4.6.5.4
02. Core Sources : 4.6.5.4
03. CSP : Intel ICHx SPI - Source : 4.6.3_SPI-Intel-ICHx_13
04. CPU : 4651_Haswell_08a-RC_072
05. NB : 4.6.5.3_Intel_SA-RC_072_020b
06. SB : 4.6.5.3_Intel_LPT-RC_071_022
07. ACPI : 4.6.4.0_ACPI_46
08. AHCI : 4.6.3_AhciSrc_021
09. CMOS Manager : 4.6.3_CMOSMGR_11_BETA12
10. CryptoPkg : 4.6.5.x_CRYPTOAPI_010
11. EFI OS BootOptionNames : 4.6.4.1_EfiOsBootOptionNames_03
12. Intel DPTF : 4.6.5.3_DPTF-RC_071_006
15. Intel FIT : 4.6.5.1_FIT_005
16. Intel Nehalem Microcode : 4.6.0_INTEL_MICROCODE_44
17. Intel Smart Connect Technology : 4.6.5.3_ISCT40_050_003
18. CsmOptOut : 4.6.5.4_Csm_OptOut_04
19. ME : 4.6.4.1_Intel_ME_RC_0.71_018
20. Platform :4.6.5.3_PF-ACPI_RC_071_016
21. Post Time Tuning : 4.6.4.0_PTT_12
22. PEI Ram Boot : 4.6.3_PEIRamBoot_14
23. Secure Boot Pkg : 4.6.5.1_SECBOOT_WIN8_ 015
24. Secure Flash Pkg : 4.6.5.1_SECMOD_012
25. SMM : 4.6.3_SMM_46
26. Legacy Serial Redirection : 4.5.5_LegacySredir_30
27. Serial Redirection : 4.6.3_Terminal_48
28. Thunderbolt : 4.6.5.3_TBT_103_000
29. TSE Binary : 4.6.2_TSE_2_15_1234
30. UefiNetworkStack II : 4.6.4_UEFI_NETWORK_STACK_II_06
31. USB : 4.6.3_USB_08.10.24
32. SouthBridge - Intel PCH : 4.6.4.0_USB_8.10.22_PCH_013
33. UsbRecovery : 4.6.3_USB_RECOVERY_SRC_25
34. AMI Debug RX : 4.6.2_AMIDebugRx_2.04.0074
35. Board : 4.6.5.4_Board_31
36. CSP Library : 4.6.4.0_CSPLibrary_021
Modules added to this label:
01. Hardware Signature Management : 4.6.5.3_HwSignature_01
02. On Flash Block Description (APTIO) - Intel ME Update : 4.6.3.2_OFBD_ME_UPDATE_006
03. 4.6.3.2_OFBD_ME_UPDATE_006 : CSP : ME 8.0 Firmware Update
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek Fab2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. System hangs at CKP 0xA0 or 0xA2 randomly when HSW CPU stepping is A0/A1.
04. Fedora Core 16/17 x64 Known issues:
a. Fedora Core 16 and 17 x64 S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
05. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
06. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C is occurring on HSW A1(306C1) stepping randomly .
07. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
08. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that “Lost the msvcp100.dll” when PFAT module is exist, please install the Microsoft Visual C++ 2010 x86/x64 Redistributable.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1179 for Flathead Creek CRB
Rom0x_8MB_Q87.bin: This is ME9.0_5M_9.0.0.1179 for Flathead Creek CRB
Release History:
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2012-11-26
Source Control Label: 4.6.5.4_VEB_1AQQW016
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Fab 2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: B0
Processor: Haswell, Stepping: B0
CPU ID: 306C2, Microcode Version: 006
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2155
EC Version: 1.10
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1257
ME F/W Binary: ME9.0_1.5M_PreProduction.bin; ME9.0_5M_PreProduction.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_11.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD | Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\EM\Capsule2_0\Capsule2_0.c | Update it for EIP103898.
Core\CORE_DXE\ConSplitter\ConSplit.c | Update to rev.55 for EIP103887.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\FileSystem\FileFatHandler.c Update it for EIP#104620.
Core\CORE_DXE\GC.c
Core\CORE_DXE\UefiHii\HiiFont.c
Core\CORE_DXE\UefiHii\HiiFontEx.c 		Update for SCT test (EIP105534).
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
ACPI_MOD | Board\EM\ACPI\ACPI.sd | Disabled S1 Sleep state.
Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD Core\em\Ahci\AhciBus.c
Core\eM\Ahci\AInt13.c 		Update EIP95440 for UEFI RAID driver support.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
OA30_MOD Core\EM\OemActivation\OemActivation.c
Core\EM\OemActivation\SmmOemActivation.c 		Update for EIP90324.
OFBDME_MOD | Chipset\eM\ME\MEUD\CSP_MEUD.c | Support SharkBay flash ME.
PFAT_MOD | ReferenceCode\Pfat\PfatFlashLib\PfatFlashLib.c | Fixed executing AFULNX2 and AFUWIN64 causes system hang.
SMM_MOD Core\EM\SMM\SmmDispatcher.c Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
TCG_MOD Board\EM\TCG\AmiTcgPlatformPeiAfterMem.c
Core\EM\Tcg\xTcgPei.c 		Update for EIP90807.
Core\EM\Tcg\TcgDxe.c | Update to rev. 37 for fix EIP102905: System can't booy when AMI Debug RX and TPM both are enabled.
USB_MOD | core\em\usb\rt\ehci.c | Update it for EIP102781
Core\EM\usb\usbbus.c | Update to rev.73 for EIP#104910.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated: 2012-07
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell: Reference code ver. 0.80
NorthBridge – Haswell - SystemAgent: Reference code ver. 0.80
SouthBridge – LynxPoint: Reference code ver. 0.80
Hasewell ACPI – Reference code ver. 0.80
Manageability Engine (ME) Reference code ver. 0.80
Intel Rapid Start Technology – Reference code ver. 0.80
Intel DPTF – Reference code ver. 0.80
Intel CPPC – Reference code ver. 0.80
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. CPU : 4651_Haswell_09a-RC_080
02. NB : 4.6.5.3_Intel_SA-RC_080_021
03. SB : 4.6.5.3_Intel_LPT-RC_080_023b
04. Intel CPPC : 4.6.5.3_CPPC-RC_080_007
05. Intel DPTF : 4.6.5.3_DPTF-RC_080_007
06. Intel PFAT Technology : 4.6.5.1_INTEL_PFAT_2_3
07. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_080_009
08. Intel Smart Connect Technology : 4.6.5.3_ISCT40_050_004
09. ME : 4.6.4.1_Intel_ME_RC_0.80_019
10. Platform : 4.6.5.3_PF-ACPI_RC_080_018
11. SMBIOS - Board : 4.6.5.1_SMBIOSBOARD_33
12. SMBIOS - Core Source : 4.6.5.1_SMBIOS_33
13. SwitchableGraphics : 4.6.5.3_SG_003
14. Rom Image : 4.6.5.3_RomImage_013
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek Fab2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. System hangs at CKP 0xA0 or 0xA2 randomly when HSW CPU stepping is A0/A1.
04. Fedora Core 16/17 x64 Known issues:
a. Fedora Core 16 and 17 x64 S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
05. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
06. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C is occurring on HSW A1(306C1) stepping randomly .
07. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
08. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
09. AMI Debugger source level debugging will stop at CKP 0x9C during cold boot.
10. Update image fail by Intel FPT.efi.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that “Lost the msvcp100.dll” when PFAT module is exist, please install the Microsoft Visual C++ 2010 x86/x64 Redistributable.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1257 for Flathead Creek CRB
Rom0x_8MB_Q87.bin: This is ME9.0_5M_9.0.0.1257 for Flathead Creek CRB
Release History:
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2012-12-24
Source Control Label: 4.6.5.4_VEB_1AQQW017
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Fab 2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: C0
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 001
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2157
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1272
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_11.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD | Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\EM\Capsule2_0\Capsule2_0.c | Update it for EIP103898.
Core\CORE_DXE\ConSplitter\ConSplit.c | Update to rev.55 for EIP103887.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\FileSystem\FileFatHandler.c Update it for EIP#104620.
Core\CORE_DXE\GC.c
Core\CORE_DXE\UefiHii\HiiFont.c
Core\CORE_DXE\UefiHii\HiiFontEx.c 		Update for SCT test (EIP105534).
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
ACPI_MOD
Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD Core\em\Ahci\AhciBus.c
Core\eM\Ahci\AInt13.c 		Update EIP95440 for UEFI RAID driver support.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
OA30_MOD Core\EM\OemActivation\OemActivation.c
Core\EM\OemActivation\SmmOemActivation.c 		Update for EIP90324.
OFBDME_MOD Chipset\eM\ME\MEUD\CSP_MEUD.c
Chipset\eM\ME\MEUD\CSP_MEUD.mak 		Update for OFBD ME update.
1. Change "OFBD_VERSION" to "0x210.
2. Added target to .H in "CSP_MEUD_SUPPORT".
3. Added "LYNX_POINT_CHIP".
SMBIOS_MOD | Core\EM\SMBIOS\SMBios.c | EIP108441: Fix 2 AT test fails: ATP_BIOS_TC005 and ATP_E2E_HR223.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
USB_MOD | core\em\usb\rt\ehci.c | Update it for EIP102781
Core\EM\usb\usbbus.c | Update to rev.73 for EIP#104910.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated: 2012-07
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell: Reference code ver. 0.81
NorthBridge – Haswell - SystemAgent: Reference code ver. 0.81
SouthBridge – LynxPoint: Reference code ver. 0.81
Hasewell ACPI – Reference code ver. 0.81
Manageability Engine (ME) Reference code ver. 0.81
Intel Rapid Start Technology – Reference code ver. 0.81
Intel DPTF – Reference code ver. 0.81
Intel CPPC – Reference code ver. 0.81
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. CPU : 4651_Haswell_10b-RC_081
02. NB : 4.6.5.3_Intel_SA-RC_081_022a
03. SB : 4.6.5.3_Intel_LPT-RC_081_024a
04. AmiGopPolicy : 4.6.5.3_AmiGopPolicy_003
05. Intel CPPC : 4.6.5.3_CPPC-RC_081_008
06. Intel DPTF : 4.6.5.3_DPTF-RC_081_008
07. Intel FIT : 4.6.5.1_FIT_008
08. Intel PFAT Technology : 4.6.5.1_INTEL_PFAT_2_4
09. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_081_012
10. Intel Smart Connect Technology : 4.6.5.3_ISCT40_050_005
11. OFBD Intel ME Update : OFBD_ME_UPDATE_SERVER_BETA3
12. OFBD ME80 : OFBD_ME_UPDATE_SERVER_BETA3
13. Rom Image : 4.6.5.3_RomImage_017
14. RsdpPlus : 4.6.4.0_RsdpPlus_05
15. ME : 4.6.4.1_Intel_ME_RC_0.81_021
16. SwitchableGraphics : 4.6.5.3_SG_005
17. NVRAM SMI : 4.6.5.1_NvramSmi_4
18. Platform : 4.6.5.3_PF-ACPI_RC_081_019
19. CryptoPkg : 4.6.5.x_CRYPTOAPI_013
20. Hardware Signature Management : 4.6.5.3_HwSignature_02
21. Secure Boot Pkg : 4.6.5.1_SECBOOT_WIN8_ 017
22. Secure Flash Pkg : 4.6.5.1_SECMOD_014
23. TCG : 4.6.4.0_TCG_41
24. TSE Binary : 4.6.2_TSE_2_15_1236
25. USBSB : 4.6.4.0_USB_8.10.22_PCH_014
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. System hangs at CKP 0xA0 or 0xA2 randomly when HSW CPU stepping is A0/A1.
04. Fedora Core 16/17 x64 Known issues:
a. Fedora Core 16 and 17 x64 S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
05. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
06. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C is occurring on HSW A1(306C1) stepping randomly .
07. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
08. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
09. Secure flash "capsule" and "recovery" cannot rollback to the previous version.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that “Lost the msvcp100.dll” when PFAT module is exist, please install the Microsoft Visual C++ 2010 x86/x64 Redistributable.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1272 for Flathead Creek CRB FAB2
Rom0x_8MB_Q87.bin: This is ME9.0_5M_9.0.0.1272 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-01-18
Source Control Label: 4.6.5.4_VEB_1AQQW018
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Fab 2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C0
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 004
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2162
GOP Driver Version: 5.0.1020
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1287
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD | Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\EM\Capsule2_0\Capsule2_0.c | Update it for EIP103898.
Core\CORE_DXE\ConSplitter\ConSplit.c | Update to rev.55 for EIP103887.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\FileSystem\FileFatHandler.c Update it for EIP#104620.
Core\CORE_DXE\GC.c
Core\CORE_DXE\UefiHii\HiiFont.c
Core\CORE_DXE\UefiHii\HiiFontEx.c 		Update for SCT test (EIP105534).
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD Core\em\Ahci\AhciBus.c
Core\eM\Ahci\AInt13.c 		Update EIP95440 for UEFI RAID driver support.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.c EIP110657: UEFIBIOSVIDEO:ParseEdidData may ignore Detailed Timings block.
EIP108990: UEFI BIOS Video driver needs to report more available video modes
EIP102919: EDID information parser does not return FALSE if no valid EDID timing is found.
EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
EIP96659: UEFI SCT 2.3.1 Summer Summit version reports that framebuffersize mismatch in query mode of SCT test
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.h | EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
OA30_MOD Core\EM\OemActivation\OemActivation.c
Core\EM\OemActivation\SmmOemActivation.c 		Update for EIP90324.
OFBDME_MOD Chipset\eM\ME\MEUD\CSP_MEUD.c
Chipset\eM\ME\MEUD\CSP_MEUD.mak 		Update for OFBD ME update.
1. Change "OFBD_VERSION" to "0x210.
2. Added target to .H in "CSP_MEUD_SUPPORT".
3. Added "LYNX_POINT_CHIP".
SMBIOS_MOD | Core\EM\SMBIOS\SMBios.c | EIP108441: Fix 2 AT test fails: ATP_BIOS_TC005 and ATP_E2E_HR223.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
USB_MOD | core\em\usb\rt\ehci.c | Update it for EIP102781
core\em\usb\uhcd.c | Change RmhPowerOnDelay = 0 for reduce the boot time.
Core\EM\usb\usbbus.c | Update to rev.73 for EIP#104910.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated: 2012-07
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell: Reference code ver. 0.90
NorthBridge – Haswell - SystemAgent: Reference code ver. 0.90
SouthBridge – LynxPoint: Reference code ver. 0.90
Hasewell ACPI – Reference code ver. 0.90
Manageability Engine (ME) Reference code ver. 0.90
Intel Rapid Start Technology – Reference code ver. 0.90
Intel DPTF – Reference code ver. 0.90
Intel CPPC – Reference code ver. 0.90
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. CPU : 4651_Haswell_11-RC_090
02. NB : 4.6.5.3_Intel_SA-RC_090_023a
03. SB : 4.6.5.3_Intel_LPT-RC_090_025
04. CryptoPkg : 4.6.5.x_CRYPTOAPI_014
05. Intel CPPC : 4.6.5.3_CPPC-RC_090_009
06. Intel DPTF : 4.6.5.3_DPTF-RC_090_009
07. Intel FIT : 4.6.5.1_FIT_011
08. Intel Nehalem Microcode : 4.6.0_INTEL_MICROCODE_45
09. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_090_016
10. Intel Smart Connect Technology : 4.6.5.3_ISCT41_070_008
11. ME : 4.6.4.1_Intel_ME_RC_0.90_023
12. Platform : 4.6.5.3_PF-ACPI_RC_090_020a
13. Secure Boot Pkg : 4.6.5.1_SECBOOT_WIN8_ 018
14. SwitchableGraphics : 4.6.5.3_SG_006
15. Rom Image : 4.6.5.3_RomImage_018
16. USBSB : 4.6.4.0_USB_8.10.22_PCH_017
17. Thunderbolt : 4.6.5.3_TBT_001
18. UefiNetworkStack II : 4.6.4_UEFI_NETWORK_STACK_II_07
Modules added to this label:
01. NTFS Driver : 4.6.5.1_NTFS_Driver_04
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. System hangs at CKP 0xA0 or 0xA2 randomly when HSW CPU stepping is A0/A1.
04. Fedora Core 16/17 x64 Known issues:
a. Fedora Core 16 and 17 x64 S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
05. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
06. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C is occurring on HSW A1(306C1) stepping randomly .
07. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
08. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that “Lost the msvcp100.dll” when PFAT module is exist, please install the Microsoft Visual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1020_FC.BIN" to override "Chipset\NB\GOP\Haswell\vbt.bin".
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1287 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.0.1287 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-01-23
Source Control Label: 4.6.5.4_VEB_1AQQW018a
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Fab 2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C0
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 004
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2162
GOP Driver Version: 5.0.1020
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1287
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD | Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\EM\Capsule2_0\Capsule2_0.c | Update it for EIP103898.
Core\CORE_DXE\ConSplitter\ConSplit.c | Update to rev.55 for EIP103887.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\FileSystem\FileFatHandler.c Update it for EIP#104620.
Core\CORE_DXE\GC.c
Core\CORE_DXE\UefiHii\HiiFont.c
Core\CORE_DXE\UefiHii\HiiFontEx.c 		Update for SCT test (EIP105534).
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD Core\em\Ahci\AhciBus.c
Core\eM\Ahci\AInt13.c 		Update EIP95440 for UEFI RAID driver support.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.c EIP110657: UEFIBIOSVIDEO:ParseEdidData may ignore Detailed Timings block.
EIP108990: UEFI BIOS Video driver needs to report more available video modes
EIP102919: EDID information parser does not return FALSE if no valid EDID timing is found.
EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
EIP96659: UEFI SCT 2.3.1 Summer Summit version reports that framebuffersize mismatch in query mode of SCT test
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.h | EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
OA30_MOD Core\EM\OemActivation\OemActivation.c
Core\EM\OemActivation\SmmOemActivation.c 		Update for EIP90324.
OFBDME_MOD Chipset\eM\ME\MEUD\CSP_MEUD.c
Chipset\eM\ME\MEUD\CSP_MEUD.mak 		Update for OFBD ME update.
1. Change "OFBD_VERSION" to "0x210.
2. Added target to .H in "CSP_MEUD_SUPPORT".
3. Added "LYNX_POINT_CHIP".
SMBIOS_MOD | Core\EM\SMBIOS\SMBios.c | EIP108441: Fix 2 AT test fails: ATP_BIOS_TC005 and ATP_E2E_HR223.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
USB_MOD | core\em\usb\rt\ehci.c | Update it for EIP102781
core\em\usb\uhcd.c | Change RmhPowerOnDelay = 0 for reduce the boot time.
Core\EM\usb\usbbus.c | Update to rev.73 for EIP#104910.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated: 2012-07
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell: Reference code ver. 0.90
NorthBridge – Haswell - SystemAgent: Reference code ver. 0.90
SouthBridge – LynxPoint: Reference code ver. 0.90
Hasewell ACPI – Reference code ver. 0.90
Manageability Engine (ME) Reference code ver. 0.90
Intel Rapid Start Technology – Reference code ver. 0.90
Intel DPTF – Reference code ver. 0.90
Intel CPPC – Reference code ver. 0.90
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel PFAT Technology : 4.6.5.1_INTEL_PFAT_2_5
02. USBSB : 4.6.4.0_USB_8.10.22_PCH_018
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. System hangs at CKP 0xA0 or 0xA2 randomly when HSW CPU stepping is A0/A1.
04. Fedora Core 16/17 x64 Known issues:
a. Fedora Core 16 and 17 x64 S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
05. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
06. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C is occurring on HSW A1(306C1) stepping randomly .
07. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
08. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that “Lost the msvcp100.dll” when PFAT module is exist, please install the Microsoft Visual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1020_FC.BIN" to override "Chipset\NB\GOP\Haswell\vbt.bin".
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1287 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.0.1287 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-02-01
Source Control Label: 4.6.5.4_VEB_1AQQW019
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C0
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 006
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2162
GOP Driver Version: 5.0.1020
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1310
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD | Core\EM\BoardInfo\AmiBoardInfo.mak | Revise for Platform eModule.
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\EM\Capsule2_0\Capsule2_0.c | Update it for EIP103898.
Core\CORE_DXE\ConSplitter\ConSplit.c | Update to rev.55 for EIP103887.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\FileSystem\FileFatHandler.c Update it for EIP#104620.
Core\CORE_DXE\GC.c
Core\CORE_DXE\UefiHii\HiiFont.c
Core\CORE_DXE\UefiHii\HiiFontEx.c 		Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c Update to Rev.14 & 15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD Core\em\Ahci\AhciBus.c
Core\eM\Ahci\AInt13.c 		Update EIP95440 for UEFI RAID driver support.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.c EIP110657: UEFIBIOSVIDEO:ParseEdidData may ignore Detailed Timings block.
EIP108990: UEFI BIOS Video driver needs to report more available video modes
EIP102919: EDID information parser does not return FALSE if no valid EDID timing is found.
EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
EIP96659: UEFI SCT 2.3.1 Summer Summit version reports that framebuffersize mismatch in query mode of SCT test
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.h | EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
OA30_MOD Core\EM\OemActivation\OemActivation.c
Core\EM\OemActivation\SmmOemActivation.c 		Update for EIP90324.
OFBDME_MOD Chipset\eM\ME\MEUD\CSP_MEUD.c
Chipset\eM\ME\MEUD\CSP_MEUD.mak 		Update for OFBD ME update.
1. Change "OFBD_VERSION" to "0x210.
2. Added target to .H in "CSP_MEUD_SUPPORT".
3. Added "LYNX_POINT_CHIP".
SMBIOS_MOD | Core\EM\SMBIOS\SMBios.c | EIP108441: Fix 2 AT test fails: ATP_BIOS_TC005 and ATP_E2E_HR223.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
USB_MOD | core\em\usb\rt\ehci.c | Update it for EIP102781
core\em\usb\uhcd.c | Change RmhPowerOnDelay = 0 for reduce the boot time.
Core\EM\usb\usbbus.c | Update to rev.73 for EIP#104910.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated: 2012-07
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell: Reference code ver. 1.00
NorthBridge – Haswell - SystemAgent: Reference code ver. 1.00
SouthBridge – LynxPoint: Reference code ver. 1.01
Hasewell ACPI – Reference code ver. 1.00
Manageability Engine (ME) Reference code ver. 1.00
Intel Rapid Start Technology – Reference code ver. 1.00
Intel DPTF – Reference code ver. 1.00
Intel CPPC – Reference code ver. 1.00
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. CPU : 4651_Haswell_11-RC_100
02. NB : 4.6.5.3_Intel_SA-RC_100_024
03. SB : 4.6.5.3_Intel_LPT-RC_101_027a
04. Intel CPPC : 4.6.5.3_CPPC-RC_100_010
05. Intel DPTF : 4.6.5.3_DPTF-RC_100_010a
06. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_100_017
07. ME : 4.6.4.1_Intel_ME_RC_1.00_025
08. Platform : 4.6.5.3_PF-ACPI_RC_100_021
09. Thunderbolt : 4.6.5.3_TBT_002
10. Rom Image : 4.6.5.3_RomImage_019
11. Post Time Tuning : 4.6.4.0_PTT_13
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. System hangs at CKP 0xA0 or 0xA2 randomly when HSW CPU stepping is A0/A1.
04. Fedora Core 16/17 x64 Known issues:
a. Fedora Core 16 and 17 x64 S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
05. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
06. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C is occurring on HSW A1(306C1) stepping randomly .
07. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
08. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
09. User cannot enter MEBX after input password in v9.0.0.0022, Intel plan to fix it in v9.0.0.0023.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that “Lost the msvcp100.dll” when PFAT module is exist, please install the Microsoft Visual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1020_FC.BIN" to override "Chipset\NB\GOP\Haswell\vbt.bin".
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1310 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.0.1310 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-02-22
Source Control Label: 4.6.5.4_VEB_1AQQW020
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C0
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 007
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2164
GOP Driver Version: 5.0.1022
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.0.1310
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\EM\Capsule2_0\Capsule2_0.c | Update it for EIP103898.
Core\CORE_DXE\ConSplitter\ConSplit.c | Update to rev.55 for EIP103887.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\FileSystem\FileFatHandler.c Update it for EIP#104620.
Core\CORE_DXE\GC.c
Core\CORE_DXE\UefiHii\HiiFont.c
Core\CORE_DXE\UefiHii\HiiFontEx.c 		Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c Update to Rev.14 & 15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD Core\em\Ahci\AhciBus.c
Core\eM\Ahci\AInt13.c 		Update EIP95440 for UEFI RAID driver support.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.c EIP110657: UEFIBIOSVIDEO:ParseEdidData may ignore Detailed Timings block.
EIP108990: UEFI BIOS Video driver needs to report more available video modes
EIP102919: EDID information parser does not return FALSE if no valid EDID timing is found.
EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
EIP96659: UEFI SCT 2.3.1 Summer Summit version reports that framebuffersize mismatch in query mode of SCT test
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.h | EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
OA30_MOD Core\EM\OemActivation\OemActivation.c
Core\EM\OemActivation\SmmOemActivation.c 		Update for EIP90324.
OFBDME_MOD Chipset\eM\ME\MEUD\CSP_MEUD.c
Chipset\eM\ME\MEUD\CSP_MEUD.mak 		Update for OFBD ME update.
1. Change "OFBD_VERSION" to "0x210.
2. Added target to .H in "CSP_MEUD_SUPPORT".
3. Added "LYNX_POINT_CHIP".
SMBIOS_MOD | Core\EM\SMBIOS\SMBios.c | EIP108441: Fix 2 AT test fails: ATP_BIOS_TC005 and ATP_E2E_HR223.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
USB_MOD | core\em\usb\rt\ehci.c | Update it for EIP102781
core\em\usb\uhcd.c | Change RmhPowerOnDelay = 0 for reduce the boot time.
Core\EM\usb\usbbus.c | Update to rev.73 for EIP#104910.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
SA_MOD ReferenceCode\Chipset\SystemAgent\SaInit\Pei\PciExpressInit.c Fixed that system may stops at CKP 0x55 after resume from S4/S5, fixed it by roll back to SA RC 0.8.1 for CRB only.
Added new token "AMI_SA_PATCH_FOR_CRB" in CRB.SDL.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated: 2012-07
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell: Reference code ver. 1.10
NorthBridge – Haswell - SystemAgent: Reference code ver. 1.10
SouthBridge – LynxPoint: Reference code ver. 1.10
Hasewell ACPI – Reference code ver. 1.10
Manageability Engine (ME) Reference code ver. 1.10
Intel Rapid Start Technology – Reference code ver. 1.10
Intel DPTF – Reference code ver. 1.10
Intel CPPC – Reference code ver. 1.10
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. CPU : 4651_Haswell_12-RC_110
02. NB : 4.6.5.3_Intel_SA-RC_110_025
03. SB : 4.6.5.3_Intel_LPT-RC_110_028b
04. Intel CPPC : 4.6.5.3_CPPC-RC_110_011
05. Intel DPTF : 4.6.5.3_DPTF-RC_110_011
06. Intel FIT : 4.6.5.1_FIT_013
07. Intel Nehalem Microcode : 4.6.0_INTEL_MICROCODE_47
08. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_110_020
09. ME : 4.6.4.1_Intel_ME_RC_1.10_027
10. Platform : 4.6.5.3_PF-ACPI_RC_110_022a
11. PEI Ram Boot : 4.6.3_PEIRamBoot_16
12. Thunderbolt : 4.6.5.3_TBT_003
13. SwitchableGraphics : 4.6.5.3_SG_008
14. Rom Image : 4.6.5.3_RomImage_021
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. System hangs at CKP 0xA0 or 0xA2 randomly when HSW CPU stepping is A0/A1.
04. Fedora Core 16/17 x64 Known issues:
a. Fedora Core 16 and 17 x64 S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
05. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
06. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C is occurring on HSW A1(306C1) stepping randomly .
07. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
08. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that “Lost the msvcp100.dll” when PFAT module is exist, please install the Microsoft Visual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1022_FC.BIN" to override "Chipset\NB\GOP\Haswell\vbt.bin".
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.0.1310 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.0.1310 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-03-04
Source Control Label: 4.6.5.4_VEB_1AQQW021
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C0
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 007
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2164
GOP Driver Version: 5.0.1022
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.1.1333
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\EM\Capsule2_0\Capsule2_0.c | Update it for EIP103898.
Core\CORE_DXE\ConSplitter\ConSplit.c | Update to rev.55 for EIP103887.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\FileSystem\FileFatHandler.c Update it for EIP#104620.
Core\CORE_DXE\GC.c
Core\CORE_DXE\UefiHii\HiiFont.c
Core\CORE_DXE\UefiHii\HiiFontEx.c 		Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c Update to Rev.14 & 15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD Core\em\Ahci\AhciBus.c
Core\eM\Ahci\AInt13.c 		Update EIP95440 for UEFI RAID driver support.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.c EIP110657: UEFIBIOSVIDEO:ParseEdidData may ignore Detailed Timings block.
EIP108990: UEFI BIOS Video driver needs to report more available video modes
EIP102919: EDID information parser does not return FALSE if no valid EDID timing is found.
EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
EIP96659: UEFI SCT 2.3.1 Summer Summit version reports that framebuffersize mismatch in query mode of SCT test
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.h | EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
OA30_MOD Core\EM\OemActivation\OemActivation.c
Core\EM\OemActivation\SmmOemActivation.c 		Update for EIP90324.
OFBDME_MOD Chipset\eM\ME\MEUD\CSP_MEUD.c
Chipset\eM\ME\MEUD\CSP_MEUD.mak 		Update for OFBD ME update.
1. Change "OFBD_VERSION" to "0x210.
2. Added target to .H in "CSP_MEUD_SUPPORT".
3. Added "LYNX_POINT_CHIP".
SMBIOS_MOD | Core\EM\SMBIOS\SMBios.c | EIP108441: Fix 2 AT test fails: ATP_BIOS_TC005 and ATP_E2E_HR223.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
USB_MOD core\em\usb\rt\ehci.c 1. Update it for EIP102781
2. EIP#115461: Fixed system randomly stops at CKP 0xB4 issue.
core\em\usb\uhcd.c | Change RmhPowerOnDelay = 0 for reduce the boot time.
Core\EM\usb\usbbus.c | Update to rev.73 for EIP#104910.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
SA_MOD ReferenceCode\Chipset\SystemAgent\SaInit\Pei\PciExpressInit.c Fixed that system may stops at CKP 0x55 after resume from S4/S5, fixed it by roll back to SA RC 0.8.1 for CRB only.
Added new token "AMI_SA_PATCH_FOR_CRB" in CRB.SDL.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated: 2012-07
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell: Reference code ver. 1.20
NorthBridge – Haswell - SystemAgent: Reference code ver. 1.20
SouthBridge – LynxPoint: Reference code ver. 1.20
Hasewell ACPI – Reference code ver. 1.20
Manageability Engine (ME) Reference code ver. 1.20
Intel Rapid Start Technology – Reference code ver. 1.20
Intel DPTF – Reference code ver. 1.20
Intel CPPC – Reference code ver. 1.20
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. CPU : 4651_Haswell_12-RC_120
02. NB : 4.6.5.3_Intel_SA-RC_110_025
03. SB : 4.6.5.3_Intel_LPT-RC_120_029
04. Intel CPPC : 4.6.5.3_CPPC-RC_120_012
05. Intel DPTF : 4.6.5.3_DPTF-RC_120_012
06. Intel FIT : 4.6.5.1_FIT_014
07. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_120_021
08. ME : 4.6.4.1_Intel_ME_RC_1.20_028
09. Platform : 4.6.5.3_PF-ACPI_RC_120_024
10. Rom Image : 4.6.5.3_RomImage_022
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. System hangs at CKP 0xA0 or 0xA2 randomly when HSW CPU stepping is A0/A1.
04. Fedora Core 16/17 x64 Known issues:
a. Fedora Core 16 and 17 x64 S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
05. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
06. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C is occurring on HSW A1(306C1) stepping randomly .
07. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
08. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that “Lost the msvcp100.dll” when PFAT module is exist, please install the Microsoft Visual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1022_FC.BIN" to override "Chipset\NB\GOP\Haswell\vbt.bin".
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.1.1333 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.10.1333 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-03-21
Source Control Label: 4.6.5.4_VEB_1AQQW022
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C0
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 008
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2164
GOP Driver Version: 5.0.1025
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.1.1333
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\EM\Capsule2_0\Capsule2_0.c | Update it for EIP103898.
Core\CORE_DXE\ConSplitter\ConSplit.c | Update to rev.55 for EIP103887.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\FileSystem\FileFatHandler.c Update it for EIP#104620.
Core\CORE_DXE\GC.c
Core\CORE_DXE\UefiHii\HiiFont.c
Core\CORE_DXE\UefiHii\HiiFontEx.c 		Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c Update to Rev.14 & 15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: UPdate for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD Core\em\Ahci\AhciBus.c
Core\eM\Ahci\AInt13.c 		Update EIP95440 for UEFI RAID driver support.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.c EIP110657: UEFIBIOSVIDEO:ParseEdidData may ignore Detailed Timings block.
EIP108990: UEFI BIOS Video driver needs to report more available video modes
EIP102919: EDID information parser does not return FALSE if no valid EDID timing is found.
EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
EIP96659: UEFI SCT 2.3.1 Summer Summit version reports that framebuffersize mismatch in query mode of SCT test
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.h | EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
OA30_MOD Core\EM\OemActivation\OemActivation.c
Core\EM\OemActivation\SmmOemActivation.c 		Update for EIP90324.
OFBDME_MOD Chipset\eM\ME\MEUD\CSP_MEUD.c
Chipset\eM\ME\MEUD\CSP_MEUD.mak 		Update for OFBD ME update.
1. Change "OFBD_VERSION" to "0x210.
2. Added target to .H in "CSP_MEUD_SUPPORT".
3. Added "LYNX_POINT_CHIP".
SMBIOS_MOD | Core\EM\SMBIOS\SMBios.c | EIP108441: Fix 2 AT test fails: ATP_BIOS_TC005 and ATP_E2E_HR223.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
USB_MOD core\em\usb\rt\ehci.c 1. Update it for EIP102781
2. EIP#115461: Fixed system randomly stops at CKP 0xB4 issue.
core\em\usb\uhcd.c Change RmhPowerOnDelay = 0 for reduce the boot time.
Change EhciPortConnect = 3 for reduce the boot time.
Change EhciPortReset = 20 for reduce the boot time.
Core\EM\usb\usbbus.c | Update to rev.73 for EIP#104910.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
SA_MOD ReferenceCode\Chipset\SystemAgent\SaInit\Pei\PciExpressInit.c Fixed that system may stops at CKP 0x55 after resume from S4/S5, fixed it by roll back to SA RC 0.8.1 for CRB only.
Added new token "AMI_SA_PATCH_FOR_CRB" in CRB.SDL.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated: 2012-07
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell: Reference code ver. 1.30
NorthBridge – Haswell - SystemAgent: Reference code ver. 1.30
SouthBridge – LynxPoint: Reference code ver. 1.30
Hasewell ACPI – Reference code ver. 1.30
Manageability Engine (ME) Reference code ver. 1.30
Intel Rapid Start Technology – Reference code ver. 1.30
Intel DPTF – Reference code ver. 1.30
Intel CPPC – Reference code ver. 1.30
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. CPU : 4651_Haswell_13-RC_130
02. NB : 4.6.5.3_Intel_SA-RC_130_027b
03. SB : 4.6.5.3_Intel_LPT-RC_130_030a
04. Intel CPPC : 4.6.5.3_CPPC-RC_130_013
05. Intel DPTF : 4.6.5.3_DPTF-RC_130_013
06. FIT: 4.6.5.1_FIT_019
07. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_130_023
08. ME : 4.6.4.1_Intel_ME_RC_1.30_030
09. Platform : 4.6.5.3_PF-ACPI_RC_130_025b
10. Rom Image : 4.6.5.3_RomImage_023
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. System hangs at CKP 0xA0 or 0xA2 randomly when HSW CPU stepping is A0/A1.
04. Fedora Core 16/17 x64 Known issues:
a. Fedora Core 16 and 17 x64 S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
05. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
06. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C is occurring on HSW A1(306C1) stepping randomly .
07. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
08. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that “Lost the msvcp100.dll” when PFAT module is exist, please install the Microsoft Visual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1022_FC.BIN" to override "Chipset\NB\GOP\Haswell\vbt.bin".
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.1.1333 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.10.1333 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-03-27
Source Control Label: 4.6.5.4_VEB_1AQQW022a
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C0
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 008
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2164
GOP Driver Version: 5.0.1025
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.2.1345
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\EM\Capsule2_0\Capsule2_0.c | Update it for EIP103898.
Core\CORE_DXE\ConSplitter\ConSplit.c | Update to rev.55 for EIP103887.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\FileSystem\FileFatHandler.c Update it for EIP#104620.
Core\CORE_DXE\GC.c
Core\CORE_DXE\UefiHii\HiiFont.c
Core\CORE_DXE\UefiHii\HiiFontEx.c 		Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c Update to Rev.14 & 15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: UPdate for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD Core\em\Ahci\AhciBus.c
Core\eM\Ahci\AInt13.c 		Update EIP95440 for UEFI RAID driver support.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.c EIP110657: UEFIBIOSVIDEO:ParseEdidData may ignore Detailed Timings block.
EIP108990: UEFI BIOS Video driver needs to report more available video modes
EIP102919: EDID information parser does not return FALSE if no valid EDID timing is found.
EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
EIP96659: UEFI SCT 2.3.1 Summer Summit version reports that framebuffersize mismatch in query mode of SCT test
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.h | EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
OA30_MOD Core\EM\OemActivation\OemActivation.c
Core\EM\OemActivation\SmmOemActivation.c 		Update for EIP90324.
OFBDME_MOD Chipset\eM\ME\MEUD\CSP_MEUD.c
Chipset\eM\ME\MEUD\CSP_MEUD.mak 		Update for OFBD ME update.
1. Change "OFBD_VERSION" to "0x210.
2. Added target to .H in "CSP_MEUD_SUPPORT".
3. Added "LYNX_POINT_CHIP".
SMBIOS_MOD | Core\EM\SMBIOS\SMBios.c | EIP108441: Fix 2 AT test fails: ATP_BIOS_TC005 and ATP_E2E_HR223.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
USB_MOD core\em\usb\rt\ehci.c 1. Update it for EIP102781
2. EIP#115461: Fixed system randomly stops at CKP 0xB4 issue.
core\em\usb\uhcd.c Change RmhPowerOnDelay = 0 for reduce the boot time.
Change EhciPortConnect = 3 for reduce the boot time.
Change EhciPortReset = 20 for reduce the boot time.
Core\EM\usb\usbbus.c | Update to rev.73 for EIP#104910.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
SA_MOD ReferenceCode\Chipset\SystemAgent\SaInit\Pei\PciExpressInit.c Fixed that system may stops at CKP 0x55 after resume from S4/S5, fixed it by roll back to SA RC 0.8.1 for CRB only.
Added new token "AMI_SA_PATCH_FOR_CRB" in CRB.SDL.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated: 2012-07
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
SouthBridge – LynxPoint: Reference code ver. 1.31
Hasewell ACPI – Reference code ver. 1.31
eference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. SB : 4.6.5.3_Intel_LPT-RC_131_031b
02. ME : 4.6.4.1_Intel_ME_RC_1.30_033
03. Platform : 4.6.5.3_PF-ACPI_RC_130_026
04. SG: 4.6.5.3_SG_009
05. Rom Image : 4.6.5.3_RomImage_024
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
Set "USE_RECOVERY_IMAGE_ON_FLASH_UPDATE" token = 0.
Select ROM image to use on BOOT_ON_FLASH_UPDATE path.
We have two images - one already in flash (old) and one in reflash capsule. We can use either one to boot.
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. System hangs at CKP 0xA0 or 0xA2 randomly when HSW CPU stepping is A0/A1.
04. Fedora Core 16/17 x64 Known issues:
a. Fedora Core 16 and 17 x64 S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
05. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
06. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C is occurring on HSW A1(306C1) stepping randomly .
07. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
08. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that “Lost the msvcp100.dll” when PFAT module is exist, please install the Microsoft Visual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1022_FC.BIN" to override "Chipset\NB\GOP\Haswell\vbt.bin".
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.2.1345 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.2.1345 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-04-15
Source Control Label: 4.6.5.4_VEB_1AQQW023
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C0
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 008
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2164
GOP Driver Version: 5.0.1025
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.2.1345
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\EM\Capsule2_0\Capsule2_0.c | Update it for EIP103898.
Core\CORE_DXE\ConSplitter\ConSplit.c | Update to rev.55 for EIP103887.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\FileSystem\FileFatHandler.c Update it for EIP#104620.
Core\CORE_DXE\GC.c
Core\CORE_DXE\UefiHii\HiiFont.c
Core\CORE_DXE\UefiHii\HiiFontEx.c 		Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c Update to Rev.14 & 15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: UPdate for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.h
Core\EM\NVRAM\NVRAMDXE.c
Core\EM\NVRAM\NVRAMRead.c
 Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD Core\em\Ahci\AhciBus.c
Core\eM\Ahci\AInt13.c 		Update EIP95440 for UEFI RAID driver support.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.c EIP110657: UEFIBIOSVIDEO:ParseEdidData may ignore Detailed Timings block.
EIP108990: UEFI BIOS Video driver needs to report more available video modes
EIP102919: EDID information parser does not return FALSE if no valid EDID timing is found.
EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
EIP96659: UEFI SCT 2.3.1 Summer Summit version reports that framebuffersize mismatch in query mode of SCT test
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.h | EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
OA30_MOD Core\EM\OemActivation\OemActivation.c
Core\EM\OemActivation\SmmOemActivation.c 		Update for EIP90324.
OFBDME_MOD Chipset\eM\ME\MEUD\CSP_MEUD.c
Chipset\eM\ME\MEUD\CSP_MEUD.mak 		Update for OFBD ME update.
1. Change "OFBD_VERSION" to "0x210.
2. Added target to .H in "CSP_MEUD_SUPPORT".
3. Added "LYNX_POINT_CHIP".
SMBIOS_MOD | Core\EM\SMBIOS\SMBios.c | EIP108441: Fix 2 AT test fails: ATP_BIOS_TC005 and ATP_E2E_HR223.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
USB_MOD core\em\usb\rt\ehci.c 1. Update it for EIP102781
2. EIP#115461: Fixed system randomly stops at CKP 0xB4 issue.
core\em\usb\uhcd.c | Reduce posttime.
Core\EM\usb\usbbus.c | Update to rev.73 for EIP#104910.
board\em\usb\usbport.c | Reduce posttime.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
SA_MOD ReferenceCode\Chipset\SystemAgent\SaInit\Pei\PciExpressInit.c Fixed that system may stops at CKP 0x55 after resume from S4/S5, fixed it by roll back to SA RC 0.8.1 for CRB only.
Added new token "AMI_SA_PATCH_FOR_CRB" in CRB.SDL.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated: 2012-07
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Reference or 3rd Party code in this Release:
Haswell: Reference code ver. 1.40
NorthBridge – Haswell - SystemAgent: Reference code ver. 1.40
SouthBridge – LynxPoint: Reference code ver. 1.40
Hasewell ACPI – Reference code ver. 1.40
Manageability Engine (ME) Reference code ver. 1.40
Intel Rapid Start Technology – Reference code ver. 1.40
Intel DPTF – Reference code ver. 1.40
eference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. CPU : 4651_Haswell_14-RC_140
02. NB : 4.6.5.3_Intel_SA-RC_140_028a
03. SB : 4.6.5.3_Intel_LPT-RC_140_032
04. Intel DPTF : 4.6.5.3_DPTF-RC_140_014
05. Intel FIT : 4.6.5.1_FIT_020
06. Intel Nehalem Microcode : 4.6.0_INTEL_MICROCODE_48
07. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_140_024
08. ME : 4.6.4.1_Intel_ME_RC_1.40_034
09. Platform : 4.6.5.3_PF-ACPI_RC_140_027
10. Rom Image : 4.6.5.3_RomImage_025
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
Set "USE_RECOVERY_IMAGE_ON_FLASH_UPDATE" token = 0.
Select ROM image to use on BOOT_ON_FLASH_UPDATE path.
We have two images - one already in flash (old) and one in reflash capsule. We can use either one to boot.
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. (Limitation)The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. (Limitation)Haswell CPU RefCode do not support "x64_build = 0".
03. (Limitation)System hangs at CKP 0xA0 or 0xA2 randomly when HSW CPU stepping is A0/A1.
04. (Limitation)Fedora Core 16/17 x64 Known issues:
a. Fedora Core 16 and 17 x64 S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
05. (Limitation)While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
06. (Limitation)If the installed memory size equal or greater than 4GB, BSOD 0x0000009C is occurring on HSW A1(306C1) stepping randomly .
07. (Limitation)D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
08. (Limitation)For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that “Lost the msvcp100.dll” when PFAT module is exist, please install the Microsoft Visual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1022_FC.BIN" to override "Chipset\NB\GOP\Haswell\vbt.bin".
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.2.1345 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.2.1345 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-04-29
Source Control Label: 4.6.5.4_VEB_1AQQW024
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C0
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 008
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2164
GOP Driver Version: 5.0.1025
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.2.1345
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c | Update to rev.55 for EIP103887.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.h | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\NVRAM\NVRAMDXE.c | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAMRead.c | Update for SCT test (EIP116947).
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Core\EM\Recovery\ReFlash\ReFlash.c | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.sdl | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD Core\em\Ahci\AhciBus.c
Core\eM\Ahci\AInt13.c 		Update EIP95440 for UEFI RAID driver support.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.c EIP110657: UEFIBIOSVIDEO:ParseEdidData may ignore Detailed Timings block.
EIP108990: UEFI BIOS Video driver needs to report more available video modes
EIP102919: EDID information parser does not return FALSE if no valid EDID timing is found.
EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
EIP96659: UEFI SCT 2.3.1 Summer Summit version reports that framebuffersize mismatch in query mode of SCT test
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.h | EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
OA30_MOD Core\EM\OemActivation\OemActivation.c
Core\EM\OemActivation\SmmOemActivation.c 		Update for EIP90324.
OFBDME_MOD Chipset\eM\ME\MEUD\CSP_MEUD.c
Chipset\eM\ME\MEUD\CSP_MEUD.mak 		Update for OFBD ME update.
1. Change "OFBD_VERSION" to "0x210.
2. Added target to .H in "CSP_MEUD_SUPPORT".
3. Added "LYNX_POINT_CHIP".
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
USBRecovery_MOD | Core\EM\UsbRecovery\EhciPEI\EhciPei.c | Fixed for EIP106722.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated: 2012-07
Visual eBios: RSS.5.73.0239, Dated: 2012-06-21
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
Haswell: Reference code ver. 1.40
NorthBridge: Haswell - SystemAgent: Reference code ver. 1.40
SouthBridge: LynxPoint: Reference code ver. 1.40
Hasewell ACPI: Reference code ver. 1.40
Manageability Engine (ME): Reference code ver. 1.40
Intel Rapid Start Technology: Reference code ver. 1.40
Intel DPTF: Reference code ver. 1.40
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Flash - Source : 4.6.3_Flash_Combined_2_34
02. CSP : Intel ICHx SPI - Source : 4.6.3_SPI-Intel-ICHx_15
03. CryptoPkg : 4.6.5.x_CRYPTOAPI_015
04. Intel PFAT Technology : 4.6.5.1_INTEL_PFAT_2_6
05. Intel Smart Connect Technology : 4.6.5.3_ISCT41_080_009
06. Post Time Tuning : 4.6.4.0_PTT_15
07. SMBIOS - Board : 4.6.5.1_SMBIOSBOARD_34
08. SMBIOS - Core Source : 4.6.5.1_SMBIOS_34
09. USB : 4.6.3_USB_08.10.27
10. SouthBridge - Intel PCH : 4.6.4.0_USB_8.10.26_PCH_019
11. Thunderbolt : 4.6.5.3_TBT_005
12. PCH : 4.6.5.3_Intel_LPT-RC_140_036
13. System Agent : 4.6.5.3_Intel_SA-RC_140_028c
14. Platform : 4.6.5.3_PF-ACPI_RC_140_027a
15. PEI Ram Boot: 4.6.3_PEIRamBoot_17
16. Intel Rapid Start Technology: 4.6.5.3_iRST-RC_140_026
17. Intel Nehalem Microcode: 4.6.0_INTEL_MICROCODE_50
18. CRB Template Updated
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
01. Windows 8 Firmware Updated support.
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues and limitations in this label:
01. (Limitation)The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. (Limitation)Haswell CPU RefCode do not support "x64_build = 0".
03. (Limitation)System hangs at CKP 0xA0 or 0xA2 randomly when HSW CPU stepping is A0/A1.
04. (Limitation)Fedora Core 16/17 x64 Known issues:
a. Fedora Core 16 and 17 x64 S3resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
05. (Limitation)While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
06. (Limitation)If the installed memory size equal or greater than 4GB, BSOD 0x0000009C is occurring on HSW A1(306C1) stepping randomly .
07. (Limitation)D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
08. (Limitation)For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
09. (Known issue)Fedora 17 x64 can't install complete.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1022_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.2.1345 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.2.1345 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-05-17
Source Control Label: 4.6.5.4_VEB_1AQQW025
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 009
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2164
GOP Driver Version: 5.0.1025
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.3.1347
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c | Update to rev.55 for EIP103887.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.h | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\NVRAM\NVRAMDXE.c | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAMRead.c | Update for SCT test (EIP116947).
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.sdl | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni | Update for EIP122037.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD Core\em\Ahci\AhciBus.c
Core\eM\Ahci\AInt13.c 		Update EIP95440 for UEFI RAID driver support.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.c EIP110657: UEFIBIOSVIDEO:ParseEdidData may ignore Detailed Timings block.
EIP108990: UEFI BIOS Video driver needs to report more available video modes
EIP102919: EDID information parser does not return FALSE if no valid EDID timing is found.
EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
EIP96659: UEFI SCT 2.3.1 Summer Summit version reports that framebuffersize mismatch in query mode of SCT test
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.h | EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
OA30_MOD Core\EM\OemActivation\OemActivation.c
Core\EM\OemActivation\SmmOemActivation.c 		Update for EIP90324.
OFBDME_MOD Chipset\eM\ME\MEUD\CSP_MEUD.c
Chipset\eM\ME\MEUD\CSP_MEUD.mak 		Update for OFBD ME update.
1. Change "OFBD_VERSION" to "0x210.
2. Added target to .H in "CSP_MEUD_SUPPORT".
3. Added "LYNX_POINT_CHIP".
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
USBRecovery_MOD | Core\EM\UsbRecovery\EhciPEI\EhciPei.c | Fixed for EIP106722.
PFAT_MOD | Board\EM\Pfat\PfatPubKeysAndBuildPSL\PfatPubKeysAndBuildPSL.sdl | Update for EIP124189.
PfatRecovery_MOD | Board\EM\Pfat\PfatRecovery\PfatRecovery.sdl | Update for EIP124189.
Board\EM\Pfat\PfatRecovery\PfatRecoveryHook.c | Update for EIP124189.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_40 , Dated:2012-07
Visual eBios: RSS.5.73.0239, Dated:2012-06-21
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.50
NB : Reference code ver. 1.50
SB : Reference code ver. 1.50
Intel CPPC : Reference code ver. 1.50
Intel DPTF : Reference code ver. 1.50
Intel Rapid Start Technology : Reference code ver. 1.50
Platform : Reference code ver. 1.50
Manageability Engine (ME) : Reference code ver. 1.50
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Haswell - 4651_Haswell_15-RC_150
02. Intel PCH : 4.6.5.3_Intel_LPT-RC_150_037
03. Intel System Agent : 4.6.5.3_Intel_SA-RC_150_029a
04. Intel CPPC : 4.6.5.3_CPPC-RC_150_014
05. Intel DPTF : 4.6.5.3_DPTF-RC_150_015
06. Intel FIT : 4.6.5.1_FIT_021
07. Intel Nehalem Microcode : 4.6.0_INTEL_MICROCODE_51
08. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_150_028
09. ME : 4.6.4.1_Intel_ME_RC_1.50_036
10. Platform : 4.6.5.3_PF-ACPI_RC_150_028a
11. Rom Image : 4.6.5.3_RomImage_029
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
1. Updated for EIP122037: FV_DATA area is contained in BlocksToUpdate.(For this issue update Intel FIT to label 21 and modify ReFlash.uni and ReFlashWoker.c.)
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues in this label:
NONE
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. System hangs at CKP 0xA0 or 0xA2 randomly when HSW CPU stepping is A0/A1.
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. If the installed memory size equal or greater than 4GB, BSOD 0x0000009C is occurring on HSW A1(306C1) stepping randomly .
06. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
07. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
08. Fedora Core 16/17/18 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1025_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.3.1347 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.3.1347 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-06-10
Source Control Label: 4.6.5.4_VEB_1AQQW026
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 009
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2170
GOP Driver Version: 5.0.1029
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.10.1372
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Core\EM\PS2CTL\kbc.h | Fixed for EIP118202.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.h | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\NVRAM\NVRAMDXE.c | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAMRead.c | Update for SCT test (EIP116947).
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Core\EM\PS2CTL\ps2kbd.c | Fixed for EIP118202.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.sdl | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni | Update for EIP122037.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c | Fixed for EIP118202.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD | Core\em\Ahci\AhciBus.c | Fixed for EIP118033
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.c EIP110657: UEFIBIOSVIDEO:ParseEdidData may ignore Detailed Timings block.
EIP108990: UEFI BIOS Video driver needs to report more available video modes
EIP102919: EDID information parser does not return FALSE if no valid EDID timing is found.
EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
EIP96659: UEFI SCT 2.3.1 Summer Summit version reports that framebuffersize mismatch in query mode of SCT test
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.h | EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
OA30_MOD Core\EM\OemActivation\OemActivation.c
Core\EM\OemActivation\SmmOemActivation.c 		Update for EIP90324.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
USBRecovery_MOD | Core\EM\UsbRecovery\EhciPEI\EhciPei.c | Fixed for EIP106722.
USB_MOD | core\em\usb\efiusbkb.h | Fixed for EIP118202.
HwSignatureManagement_MOD | Core\EM\HardwareSignature\HardwareChangeDetect.c | Fixed for EIP121317.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.50
NB : Reference code ver. 1.50
SB : Reference code ver. 1.50
Intel CPPC : Reference code ver. 1.50
Intel DPTF : Reference code ver. 1.50
Intel Rapid Start Technology : Reference code ver. 1.50
Platform : Reference code ver. 1.50
Manageability Engine (ME) : Reference code ver. 1.50
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Haswell - 4651_Haswell_15a-RC_150
02. Intel PCH : 4.6.5.3_Intel_LPT-RC_150_038
03. Intel System Agent : 4.6.5.3_Intel_SA-RC_150_029c
04. AHCI : 4.6.3_AhciSrc_022
05. HardwareSignatureManagement : 4.6.5.3_HwSignature_03
06. Intel CPPC : 4.6.5.3_CPPC-RC_150_014a
07. Intel DPTF : 4.6.5.3_DPTF-RC_150_015a
08. Intel Nehalem Microcode : 4.6.0_INTEL_MICROCODE_52
09. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_150_028a
10. Intel Smart Connect Technology : 4.6.5.3_ISCT41_110_012
11. ME : 4.6.4.1_Intel_ME_RC_1.50_037
12. Platform : 4.6.5.3_PF-ACPI_RC_150_028b
13. PEI Ram Boot : 4.6.3_PEIRamBoot_18
14. OFBD - Intel ME Update : 4.6.5.3_iRST-RC_150_028
15. CSP : ME 8.0 Firmware Update : 4.6.3.2_OFBD_ME_UPDATE_008
16. Thunderbolt : 4.6.5.3_TBT_006
17. SouthBridge - Intel PCH : 4.6.4.0_USB_8.10.26_PCH_020
18. Rom Image : 4.6.5.3_RomImage_030
19. Intel FIT : 4.6.5.1_FIT_023
20. Intel PFAT Technology : 4.6.5.1_INTEL_PFAT_2_8
21. SG : 4.6.5.3_SG_010
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues in this label:
NONE
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1029_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.10.1372 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.10.1372 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-06-28
Source Control Label: 4.6.5.4_VEB_1AQQW027
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 009
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2170
GOP Driver Version: 5.0.1032
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.13.1402
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c | Fixed for EIP118202.
Core\CORE_DXE\ConSplitter\ConSplit.h | Fixed for EIP118202.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Core\CORE_DXE\ConSplitter\In.c | Fixed for EIP118202.
Core\EM\PS2CTL\kbc.h | Fixed for EIP118202.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.h | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\NVRAM\NVRAMDXE.c | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAMRead.c | Update for SCT test (EIP116947).
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Core\EM\PS2CTL\ps2kbd.c | Fixed for EIP118202.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni | Update for EIP122037.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c | Fixed for EIP118202.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD | Core\em\Ahci\AhciBus.c | Fixed for EIP118033
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.c EIP110657: UEFIBIOSVIDEO:ParseEdidData may ignore Detailed Timings block.
EIP108990: UEFI BIOS Video driver needs to report more available video modes
EIP102919: EDID information parser does not return FALSE if no valid EDID timing is found.
EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
EIP96659: UEFI SCT 2.3.1 Summer Summit version reports that framebuffersize mismatch in query mode of SCT test
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.h | EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
OA30_MOD Core\EM\OemActivation\OemActivation.c
Core\EM\OemActivation\SmmOemActivation.c 		Update for EIP90324.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
USBRecovery_MOD | Core\EM\UsbRecovery\EhciPEI\EhciPei.c | Fixed for EIP106722.
USB_MOD | core\em\usb\efiusbkb.h | Fixed for EIP118202.
HwSignatureManagement_MOD | Core\EM\HardwareSignature\HardwareChangeDetect.c | Fixed for EIP121317.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.60
NB : Reference code ver. 1.60
SB : Reference code ver. 1.60
Intel CPPC : Reference code ver. 1.60
Intel DPTF : Reference code ver. 1.60
Intel Rapid Start Technology : Reference code ver. 1.60
Platform : Reference code ver. 1.60
Manageability Engine (ME) : Reference code ver. 1.60
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Haswell - 4651_Haswell_16-RC_160
02. Intel PCH : 4.6.5.3_Intel_LPT-RC_160_039
03. Intel System Agent : 4.6.5.3_Intel_SA-RC_160_031b
04. Intel CPPC : 4.6.5.3_CPPC-RC_160_015
05. Intel DPTF : 4.6.5.3_DPTF-RC_160_016
06. Intel Nehalem Microcode : 4.6.0_INTEL_MICROCODE_54
07. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_160_029
08. ME : 4.6.4.1_Intel_ME_RC_1.60_038
09. Platform : 4.6.5.3_PF-ACPI_RC_160_029c
10. Rom Image : 4.6.5.3_RomImage_033
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues in this label:
NONE
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.13.1402 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.13.1402 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-07-19
Source Control Label: 4.6.5.4_VEB_1AQQW028
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 012
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2173
GOP Driver Version: 5.0.1032
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.13.1402
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c | Fixed for EIP118202.
Core\CORE_DXE\ConSplitter\ConSplit.h | Fixed for EIP118202.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Core\CORE_DXE\ConSplitter\In.c | Fixed for EIP118202.
Core\EM\PS2CTL\kbc.h | Fixed for EIP118202.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.h | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\NVRAM\NVRAMDXE.c | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAMRead.c | Update for SCT test (EIP116947).
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Core\EM\PS2CTL\ps2kbd.c | Fixed for EIP118202.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni | Update for EIP122037.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c | Fixed for EIP118202.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD | Core\em\Ahci\AhciBus.c | Fixed for EIP118033
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.c EIP110657: UEFIBIOSVIDEO:ParseEdidData may ignore Detailed Timings block.
EIP108990: UEFI BIOS Video driver needs to report more available video modes
EIP102919: EDID information parser does not return FALSE if no valid EDID timing is found.
EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
EIP96659: UEFI SCT 2.3.1 Summer Summit version reports that framebuffersize mismatch in query mode of SCT test
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.h | EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
OA30_MOD Core\EM\OemActivation\OemActivation.c
Core\EM\OemActivation\SmmOemActivation.c 		Update for EIP90324.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
USBRecovery_MOD | Core\EM\UsbRecovery\EhciPEI\EhciPei.c | Fixed for EIP106722.
USB_MOD | core\em\usb\efiusbkb.h | Fixed for EIP118202.
HwSignatureManagement_MOD | Core\EM\HardwareSignature\HardwareChangeDetect.c | Fixed for EIP121317.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.6.1
NB : Reference code ver. 1.6.1
SB : Reference code ver. 1.6.1
Intel DPTF : Reference code ver. 1.6.1
Intel Rapid Start Technology : Reference code ver. 1.6.1
Platform : Reference code ver. 1.6.1
Manageability Engine (ME) : Reference code ver. 1.6.1
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Haswell - 4651_Haswell_17-RC_161
02. Intel PCH : 4.6.5.3_Intel_LPT-RC_161_040b
03. Intel System Agent : 4.6.5.3_Intel_SA-RC_161_032a
04. Intel DPTF : 4.6.5.3_DPTF-RC_161_017
05. Intel Nehalem Microcode : 4.6.0_INTEL_MICROCODE_56
06. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_161_030
07. ME : 4.6.4.1_Intel_ME_RC_1.61_039
08. Platform : 4.6.5.3_PF-ACPI_RC_161_030b
09. SG : 4.6.5.3_SG_011
10. Rom Image : 4.6.5.3_RomImage_034
11. Intel FIT : 4.6.5.1_FIT_024
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues in this label:
NONE
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.13.1402 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.13.1402 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-08-07
Source Control Label: 4.6.5.4_VEB_1AQQW029
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 012
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2176
GOP Driver Version: 5.0.1033
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.13.1402
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Core\EM\PS2CTL\kbc.h | Fixed for EIP118202.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.h | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\NVRAM\NVRAMDXE.c | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAMRead.c | Update for SCT test (EIP116947).
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Core\EM\PS2CTL\ps2kbd.c | Fixed for EIP118202.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni | Update for EIP122037.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c | Fixed for EIP118202.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD | Core\em\Ahci\AhciBus.c | Fixed for EIP118033
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
Core\EM\CSM\CsmSimpleIn.c | Update it for EIP109384.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.c EIP110657: UEFIBIOSVIDEO:ParseEdidData may ignore Detailed Timings block.
EIP108990: UEFI BIOS Video driver needs to report more available video modes
EIP102919: EDID information parser does not return FALSE if no valid EDID timing is found.
EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
EIP96659: UEFI SCT 2.3.1 Summer Summit version reports that framebuffersize mismatch in query mode of SCT test
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.h | EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
SecureFlash_MOD | Core\EM\SecurityPkg\SecFlashUpd\VerifyFwCapsule.c | Fixed for IGNORE_IMAGE_ROLLBACK issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
USBRecovery_MOD | Core\EM\UsbRecovery\EhciPEI\EhciPei.c | Fixed for EIP106722.
USB_MOD | core\em\usb\efiusbkb.h | Fixed for EIP118202.
HwSignatureManagement_MOD | Core\EM\HardwareSignature\HardwareChangeDetect.c | Fixed for EIP121317.
OFBD_MOD | Core\EM\OFBD\OFBD.c | Fixed for issue when using AFU tool flash bios.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.6.1
NB : Reference code ver. 1.6.1
SB : Reference code ver. 1.6.1
Intel DPTF : Reference code ver. 1.6.1
Intel Rapid Start Technology : Reference code ver. 1.6.1
Platform : Reference code ver. 1.6.1
Manageability Engine (ME) : Reference code ver. 1.6.1
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. SPI ICHx : 4.6.3_SPI-Intel-ICHx_16
02. Intel PCH : 4.6.5.3_Intel_LPT-RC_161_040c
03. Intel System Agent : 4.6.5.3_Intel_SA-RC_161_032b
04. Intel Nehalem Microcode : 4.6.0_INTEL_MICROCODE_58
05. Intel Smart Connect Technology : 4.6.5.3_ISCT41_110_013
06. SMIFlash : 4.6.3.6_SMIFLASH_26
07. OemActivation : 4.6.4.0_OA_4.2
08. Platform : 4.6.5.3_PF-ACPI_RC_161_030c
09. OFBD : 4.6.3.2_OFBD.1.0.4
10. Secure Boot Pkg : 4.6.5.1_SECBOOT_WIN8_020
11. Secure Flash Pkg : 4.6.5.1_SECMOD_015
12. Legacy Serial Redirection : 4.5.5_LegacySredir_36
13. SMBIOS - Board : 4.6.5.1_SMBIOSBOARD_35
14. SMBIOS - Core Source : 4.6.5.1_SMBIOS_35
15. Serial Redirection : 4.6.3_Terminal_52
16. Thunderbolt : 4.6.5.3_TBT_009
17. Rom Image : 4.6.5.3_RomImage_035
18. Intel PFAT Technology : 4.6.5.1_INTEL_PFAT_3
Modules added to this label:
01. RestoreSpecialBootOptions : 4.6.5.4_RSBO_00
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues in this label:
NONE
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already, CRB still use old key in CRB folder for rollback flash. And OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.13.1402 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.13.1402 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-08-23
Source Control Label: 4.6.5.4_VEB_1AQQW030QARelease
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 012
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2176
GOP Driver Version: 5.0.1033
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.13.1402
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Core\EM\PS2CTL\kbc.h | Fixed for EIP118202.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.h | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\NVRAM\NVRAMDXE.c | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAMRead.c | Update for SCT test (EIP116947).
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Core\EM\PS2CTL\ps2kbd.c | Fixed for EIP118202.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni | Update for EIP122037.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c | Fixed for EIP118202.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD | Core\em\Ahci\AhciBus.c | Fixed for EIP118033
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
Core\EM\CSM\CsmSimpleIn.c | Update it for EIP109384.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.c EIP110657: UEFIBIOSVIDEO:ParseEdidData may ignore Detailed Timings block.
EIP108990: UEFI BIOS Video driver needs to report more available video modes
EIP102919: EDID information parser does not return FALSE if no valid EDID timing is found.
EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
EIP96659: UEFI SCT 2.3.1 Summer Summit version reports that framebuffersize mismatch in query mode of SCT test
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.h | EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
SecureFlash_MOD | Core\EM\SecurityPkg\SecFlashUpd\VerifyFwCapsule.c | Fixed for IGNORE_IMAGE_ROLLBACK issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
USBRecovery_MOD | Core\EM\UsbRecovery\EhciPEI\EhciPei.c | Fixed for EIP106722.
USB_MOD | core\em\usb\efiusbkb.h | Fixed for EIP118202.
HwSignatureManagement_MOD | Core\EM\HardwareSignature\HardwareChangeDetect.c | Fixed for EIP121317.
OFBD_MOD | Core\EM\OFBD\OFBD.c | Fixed for issue when using AFU tool flash bios.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.6.1
NB : Reference code ver. 1.6.1
SB : Reference code ver. 1.6.1
Intel DPTF : Reference code ver. 1.6.1
Intel Rapid Start Technology : Reference code ver. 1.6.1
Platform : Reference code ver. 1.6.1
Manageability Engine (ME) : Reference code ver. 1.6.1
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Platform : 4.6.5.3_PF-ACPI_RC_161_030d
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues in this label:
NONE
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already, CRB still use old key in CRB folder for rollback flash. And OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.13.1402 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.13.1402 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-08-29
Source Control Label: 4.6.5.4_VEB_1AQQW031
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 016
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2176
GOP Driver Version: 5.0.1033
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.20.1447
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Core\EM\PS2CTL\kbc.h | Fixed for EIP118202.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.h | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\NVRAM\NVRAMDXE.c | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAMRead.c | Update for SCT test (EIP116947).
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Core\EM\PS2CTL\ps2kbd.c | Fixed for EIP118202.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni | Update for EIP122037.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c | Fixed for EIP118202.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
AHCI_MOD | Core\em\Ahci\AhciBus.c | Fixed for EIP118033
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CSM_MOD | Core\EM\CSM\CSM.c | Update for EIP71033.
Core\EM\CSM\CsmSimpleIn.c | Update it for EIP109384.
include\Protocol\LegacyBiosExt.h | Update it for EIP92416.
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.c EIP110657: UEFIBIOSVIDEO:ParseEdidData may ignore Detailed Timings block.
EIP108990: UEFI BIOS Video driver needs to report more available video modes
EIP102919: EDID information parser does not return FALSE if no valid EDID timing is found.
EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
EIP96659: UEFI SCT 2.3.1 Summer Summit version reports that framebuffersize mismatch in query mode of SCT test
Core\EM\CSM\Thunk\CsmVideo\UefiBiosVideo.h | EIP102886: Enabling 4GB Decoding in PCI settings causes system to hang at checkpoint B2. No longer able to enter TSE.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
SecureFlash_MOD | Core\EM\SecurityPkg\SecFlashUpd\VerifyFwCapsule.c | Fixed for IGNORE_IMAGE_ROLLBACK issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
USBRecovery_MOD | Core\EM\UsbRecovery\EhciPEI\EhciPei.c | Fixed for EIP106722.
USB_MOD | core\em\usb\efiusbkb.h | Fixed for EIP118202.
HwSignatureManagement_MOD | Core\EM\HardwareSignature\HardwareChangeDetect.c | Fixed for EIP121317.
OFBD_MOD | Core\EM\OFBD\OFBD.c | Fixed for issue when using AFU tool flash bios.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.6.2
NB : Reference code ver. 1.6.2
SB : Reference code ver. 1.6.2
Intel Rapid Start Technology : Reference code ver. 1.6.2
Platform : Reference code ver. 1.6.2
Manageability Engine (ME) : Reference code ver. 1.6.2
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Haswell - 4651_Haswell_18-RC_162
02. Intel PCH : 4.6.5.3_Intel_LPT-RC_162_041
03. Intel System Agent : 4.6.5.3_Intel_SA-RC_162_33
04. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_162_031
05. ME : 4.6.4.1_Intel_ME_RC_1.62_043
06. Platform : 4.6.5.3_PF-ACPI_RC_162_031
07. Rom Image : 4.6.5.3_RomImage_038
08. Intel Nehalem Microcode : 4.6.0_INTEL_MICROCODE_59a
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues in this label:
NONE
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.20.1447 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.20.1447 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-09-27
Source Control Label: 4.6.5.4_VEB_1AQQW032
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 016
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2176
GOP Driver Version: 5.0.1033
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.20.1447
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\CORE_DXE\BootOptions.c | Add EIP 134220 solution to fix boot option doesn't change in special test step.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.h | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\NVRAM\NVRAMDXE.c | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAMRead.c | Update for SCT test (EIP116947).
Include\Protocol\PAhciBus.h | Update for ACHI module labeled 24.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Include\Protocol\PIDEBus.h | Update for ACHI module labeled 24.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni | Update for EIP122037.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
HwSignatureManagement_MOD | Core\EM\HardwareSignature\HardwareChangeDetect.c | Fixed for EIP121317.
Terminal_MOD
Core\EM\Terminal\Terminal.sd
Core\EM\Terminal\TerminalSetup.c 		Fix for build error.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.6.2
NB : Reference code ver. 1.6.2
SB : Reference code ver. 1.6.2
Intel Rapid Start Technology : Reference code ver. 1.6.2
Platform : Reference code ver. 1.6.2
Manageability Engine (ME) : Reference code ver. 1.6.2
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel PCH : 4.6.5.3_Intel_LPT-RC_162_042
02. ACPI : 4.6.5.0_ACPI_47
03. AHCI : 4.6.3_AhciSrc_024
04. CryptoPkg : 4.6.5.x_CRYPTOAPI_017
05. EFI OS BootOptionNames : 4.6.4.1_EfiOsBootOptionNames_05
06. OFBD : 4.6.3.2_OFBD.1.0.5
07. Post Time Tuning : 4.6.4.0_PTT_16
08. RsdpPlus : 4.6.4.0_RsdpPlus_07
09. Secure Boot Pkg : 4.6.5.1_SECBOOT_WIN8_022
10. Secure Flash Pkg : 4.6.5.1_SECMOD_016
11. CSM : 4.6.5.3_CSM.7.71_80
12. PS2CTL : 4.6.5_PS2CTL_003
13. Serial Redirection : 4.6.3_Terminal_53
14. StatusCode : 4.6.3_StatusCode_19
15. USB : 4.6.3_USB_08.10.28
16. UsbRecovery : 4.6.3_USB_RECOVERY_SRC_26
17. Intel FIT : 4.6.5.1_FIT_025
18. Rom Image : 4.6.5.3_RomImage_040
19. RestoreSpecialBootOptions : 4.6.5.4_RSBO_01
20. Platform : 4.6.5.3_PF-ACPI_RC_162_031a
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues in this label:
01. CPU Security Configuration(MSR 4E0[0] SMM_FEATURE_CONTROL MSR Lock) will be changed after S3 resume, it will be fixed in next label.
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.20.1447 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.20.1447 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-10-01
Source Control Label: 4.6.5.4_VEB_1AQQW032a
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 016
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2176
GOP Driver Version: 5.0.1033
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.20.1447
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\CORE_DXE\BootOptions.c | Add EIP 134220 solution to fix boot option doesn't change in special test step.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CPU\CpuSpSmi.c Update for EIP137873.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.h | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\NVRAM\NVRAMDXE.c Update for SCT test (EIP116947).
Update to v.102 for EIP103562.
Core\EM\NVRAM\NVRAMRead.c | Update for SCT test (EIP116947).
Include\Protocol\PAhciBus.h | Update for ACHI module labeled 24.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Include\Protocol\PIDEBus.h | Update for ACHI module labeled 24.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
HwSignatureManagement_MOD | Core\EM\HardwareSignature\HardwareChangeDetect.c | Fixed for EIP121317.
Terminal_MOD
Core\EM\Terminal\Terminal.sd
Core\EM\Terminal\TerminalSetup.c 		Fix for build error.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.6.2
NB : Reference code ver. 1.6.2
SB : Reference code ver. 1.6.2
Intel Rapid Start Technology : Reference code ver. 1.6.2
Platform : Reference code ver. 1.6.2
Manageability Engine (ME) : Reference code ver. 1.6.2
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel PCH : 4.6.5.3_Intel_LPT-RC_162_042
02. ACPI : 4.6.5.0_ACPI_47
03. AHCI : 4.6.3_AhciSrc_024
04. CryptoPkg : 4.6.5.x_CRYPTOAPI_017
05. EFI OS BootOptionNames : 4.6.4.1_EfiOsBootOptionNames_05
06. OFBD : 4.6.3.2_OFBD.1.0.5
07. Post Time Tuning : 4.6.4.0_PTT_16
08. RsdpPlus : 4.6.4.0_RsdpPlus_07
09. Secure Boot Pkg : 4.6.5.1_SECBOOT_WIN8_022
10. Secure Flash Pkg : 4.6.5.1_SECMOD_016
11. CSM : 4.6.5.3_CSM.7.71_80
12. PS2CTL : 4.6.5_PS2CTL_003
13. Serial Redirection : 4.6.3_Terminal_53
14. StatusCode : 4.6.3_StatusCode_19
15. USB : 4.6.3_USB_08.10.28
16. UsbRecovery : 4.6.3_USB_RECOVERY_SRC_26
17. Intel FIT : 4.6.5.1_FIT_025
18. Rom Image : 4.6.5.3_RomImage_040
19. RestoreSpecialBootOptions : 4.6.5.4_RSBO_01
20. Platform : 4.6.5.3_PF-ACPI_RC_162_031a
21. OFBD Intel ME Update : 4.6.3.2_OFBD_ME_UPDATE_010
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues in this label:
01. CPU Security Configuration(MSR 4E0[0] SMM_FEATURE_CONTROL MSR Lock) will be changed after S3 resume, it will be fixed in next label.
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.20.1447 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.20.1447 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-10-25
Source Control Label: 4.6.5.4_VEB_1AQQW032b
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 016
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2176
GOP Driver Version: 5.0.1033
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.20.1447
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.h | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\NVRAM\NVRAMDXE.c Update for SCT test (EIP116947).
Update to v.102 for EIP103562.
Core\EM\NVRAM\NVRAMRead.c | Update for SCT test (EIP116947).
Include\Protocol\PAhciBus.h | Update for ACHI module labeled 24.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Include\Protocol\PIDEBus.h | Update for ACHI module labeled 24.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
HwSignatureManagement_MOD | Core\EM\HardwareSignature\HardwareChangeDetect.c | Fixed for EIP121317.
Terminal_MOD
Core\EM\Terminal\Terminal.sd
Core\EM\Terminal\TerminalSetup.c 		Fix for build error.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.6.2
NB : Reference code ver. 1.6.2
SB : Reference code ver. 1.6.2
Intel Rapid Start Technology : Reference code ver. 1.6.2
Platform : Reference code ver. 1.6.2
Manageability Engine (ME) : Reference code ver. 1.6.2
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel PCH : 4.6.5.3_Intel_LPT-RC_162_043
02. Intel System Agent : 4.6.5.3_Intel_SA-RC_162_33a
03. CryptoPkg : 4.6.5.x_CRYPTOAPI_018
04. Intel Haswell : 4651_Haswell_18b-RC_162
05. Intel Nehalem Microcode : 4.6.0_INTEL_MICROCODE_63
06. Intel FIT : 4.6.5.1_FIT_027
07. TCG : 4.6.4_TCG_42
08. Intel Smart Connect Technology : 4.6.5.3_ISCT41_110_014
09. Platform : 4.6.5.3_PF-ACPI_RC_162_031c
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Known issues in this label:

Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.20.1447 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.20.1447 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-11-04
Source Control Label: 4.6.5.4_VEB_1AQQW033
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 016
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2179
GOP Driver Version: 5.0.1035
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.20.1447
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Include\Capsule.h | Fixed for EIP106722.
Core\CORE_DXE\BdsBoard.c
Core\CORE_DXE\BootOptions.c
Core\CORE_DXE\BootOptions.h 		Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Core\EM\Capsule2_0\Capsule2_0.c | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.h | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\NVRAM\NVRAMDXE.c Update for SCT test (EIP116947).
Update to v.102 for EIP103562.
Core\EM\NVRAM\NVRAMRead.c | Update for SCT test (EIP116947).
Include\Protocol\PAhciBus.h | Update for ACHI module labeled 24.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Include\Protocol\PIDEBus.h | Update for ACHI module labeled 24.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
HwSignatureManagement_MOD | Core\EM\HardwareSignature\HardwareChangeDetect.c | Fixed for EIP121317.
Terminal_MOD
Core\EM\Terminal\Terminal.sd
Core\EM\Terminal\TerminalSetup.c 		Fix for build error.
TCG_MOD | Core\EM\TCG\TpmClearOnRollback\TpmClearOnRollbackOfbd.c | Fix after adding 4.6.4_TCG_42, it would cause a building error.
AHCI_MOD | Core\em\Ahci\AhciController.c | Fix spending much time at 0xA2 when booting for EIP139789.
CRB CRB\CRB.sdl 1. Modify token "CRB1_NB_PCI_DEVICES_SSID_TABLE" and token "CRB2_NB_PCI_DEVICES_SSID_TABLE" for EIP140475
2. Modify ELINK "UsbDevicePathTestSkip" to "MatchUefiFloppyDrive" for EIP139412. (Having same boot option in Setup Menu.)
3. Set token "PTT_VER" to 16
4. Set token "SUPPORT_RAID_DRIVER" to 0 as default.
5. Update GOP 5.0.1035.
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.6.2
NB : Reference code ver. 1.6.2
SB : Reference code ver. 1.6.2
Intel Rapid Start Technology : Reference code ver. 1.6.2
Platform : Reference code ver. 1.6.2
Manageability Engine (ME) : Reference code ver. 1.6.2
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel PCH : 4.6.5.3_Intel_LPT-RC_162_043
02. Intel System Agent : 4.6.5.3_Intel_SA-RC_162_33a
03. CryptoPkg : 4.6.5.x_CRYPTOAPI_018
04. Intel Haswell : 4651_Haswell_18b-RC_162
05. Intel Nehalem Microcode : 4.6.0_INTEL_MICROCODE_63
06. Intel FIT : 4.6.5.1_FIT_027
07. TCG : 4.6.4_TCG_42
08. Intel Smart Connect Technology : 4.6.5.3_ISCT41_110_014
09. Platform : 4.6.5.3_PF-ACPI_RC_162_031c
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Post Time:
- Enable the Fast boot item in Setup.
- Disable USB Support item in Setup.
- Disable PS2 Device Supportitem in Setup.
- CSM Disable
- Tested on SBDT FHC CRB FAB2 without any USB device connected.
- Check the Boot time by “regedit” in OS. The value of FWPostTIme: is 1.531 seconds with Intel SSD 520.
Known issues in this label:

Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
EIP141537
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.20.1447 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.20.1447 for Flathead Creek CRB FAB2
Release History:
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-11-14
Source Control Label: 4.6.5.4_VEB_1AQQW034
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version: 017
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2179
GOP Driver Version: 5.0.1035
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.30.1482
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\CORE_DXE\BdsBoard.c
Core\CORE_DXE\BootOptions.c
Core\CORE_DXE\BootOptions.h 		Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.h | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\NVRAM\NVRAMDXE.c Update for SCT test (EIP116947).
Update to v.102 for EIP103562.
Core\EM\NVRAM\NVRAMRead.c | Update for SCT test (EIP116947).
Include\Protocol\PAhciBus.h | Update for ACHI module labeled 24.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Include\Protocol\PIDEBus.h | Update for ACHI module labeled 24.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
HwSignatureManagement_MOD | Core\EM\HardwareSignature\HardwareChangeDetect.c | Fixed for EIP121317.
Terminal_MOD
Core\EM\Terminal\Terminal.sd
Core\EM\Terminal\TerminalSetup.c 		Fix for build error.
TCG_MOD | Core\EM\TCG\TpmClearOnRollback\TpmClearOnRollbackOfbd.c | Fix after adding 4.6.4_TCG_42, it would cause a building error.>
AHCI_MOD | Core\em\Ahci\AhciController.c | Fix spending much time at 0xA2 when booting for EIP139789.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."

AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.7.0
NB : Reference code ver. 1.7.0
SB : Reference code ver. 1.7.0
Intel Rapid Start Technology : Reference code ver. 1.7.0
Platform : Reference code ver. 1.7.0
Manageability Engine (ME) : Reference code ver. 1.7.0
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel PCH : 4.6.5.3_Intel_LPT-RC_170_044a
02. Intel System Agent : 4.6.5.3_Intel_SA-RC_170_34
03. Intel Haswell : 4651_Haswell_19-RC_170
04. ME : 4.6.4.1_Intel_ME_RC_1.70_044
05. Platform : 4.6.5.3_PF-ACPI_RC_170_032a
06. Intel DPTF : 4.6.5.3_DPTF-RC_170_018
07. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_170_032
08. Rom Image : 4.6.5.3_RomImage_041
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● USB Support Disable
● PS2 Device Supportitem Disable
● CSM Disable
- Tested on SBDT FHC CRB FAB2 without any USB device connected.
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 1.530 seconds with Intel SSD 520.
The value of FWPostTIme : is 3.955 seconds with WD5000BPKT.
Known issues in this label:

Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
EIP142595
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.30.1482 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.30.1482 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2013-12-25
Source Control Label: 4.6.5.4_VEB_1AQQW035
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:017
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version:2179
GOP Driver Version:5.0.1035
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.30.1482
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\CORE_DXE\BdsBoard.c
Core\CORE_DXE\BootOptions.c
Core\CORE_DXE\BootOptions.h 		Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.h | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\NVRAM\NVRAMDXE.c Update for SCT test (EIP116947).
Update to v.102 for EIP103562.
Core\EM\NVRAM\NVRAMRead.c | Update for SCT test (EIP116947).
Include\Protocol\PAhciBus.h | Update for ACHI module labeled 24.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Include\Protocol\PIDEBus.h | Update for ACHI module labeled 24.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
IntelGbL_MOD | Board\EN\IntelGigabitLan\IntelGigabitLanx64.efi | Update for Intel GbE i217 (B0:D19:F0) support.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
HwSignatureManagement_MOD | Core\EM\HardwareSignature\HardwareChangeDetect.c | Fixed for EIP121317.
Terminal_MOD
Core\EM\Terminal\Terminal.sd
Core\EM\Terminal\TerminalSetup.c 		Fix for build error.
TCG_MOD | Core\EM\TCG\TpmClearOnRollback\TpmClearOnRollbackOfbd.c | Fix after adding 4.6.4_TCG_42, it would cause a building error.>
AHCI_MOD Core\em\Ahci\AhciController.c
Core\em\Ahci\AhciController.h 		Fix spending much time at 0xA2 when booting for EIP139789.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.7.0
NB : Reference code ver. 1.7.1
SB : Reference code ver. 1.7.0
Intel Rapid Start Technology : Reference code ver. 1.7.0
Platform : Reference code ver. 1.7.0
Manageability Engine (ME) : Reference code ver. 1.7.0
Reference or 3rd Party code updated in this Release:
NB : Reference code ver. 1.7.1
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel System Agent : 4.6.5.3_Intel_SA-RC_171_35
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● USB Support Disable
● PS2 Device Supportitem Disable
● CSM Disable
- Tested on SBDT FHC CRB FAB2 without any USB device connected.
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 2.043 seconds with Intel SSD 520.
The value of FWPostTIme : is 3.630 seconds with WD5000BPKT.
Known issues in this label:

Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
https://eip.ami.com.tw/eip/projects/display.do?id=12076
Validation Testing:
Internal pre-test.
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.30.1482 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.30.1482 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2014-03-21
Source Control Label: 4.6.5.4_VEB_1AQQW036
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:017
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version:2179
GOP Driver Version:5.0.1035
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.30.1482
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\CORE_DXE\BdsBoard.c
Core\CORE_DXE\BootOptions.c
Include\BootOptions.h 		Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.h | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\NVRAM\NVRAMDXE.c Update for SCT test (EIP116947).
Update to v.102 for EIP103562.
Core\EM\NVRAM\NVRAMRead.c | Update for SCT test (EIP116947).
Include\Protocol\PAhciBus.h | Update for ACHI module labeled 24.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Include\Protocol\PIDEBus.h | Update for ACHI module labeled 24.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
Terminal_MOD Core\EM\Terminal\Terminal.sd
Core\EM\Terminal\TerminalSetup.c 		Fix for build error.
TCG_MOD | Core\EM\TCG\TpmClearOnRollback\TpmClearOnRollbackOfbd.c | Fix after adding 4.6.4_TCG_42, it would cause a building error.>
AHCI_MOD Core\em\Ahci\AhciController.c
Core\em\Ahci\AhciController.h 		Fix spending much time at 0xA2 when booting for EIP139789.
Core\em\Ahci\AhciBus.h
Core\em\Ahci\AhciBus.c 		For EIP127356.
IdeSecurity_MOD Core\EM\HddSecurity\Hddpassword\HddPassword.c
Core\EM\HddSecurity\IdeSecurity.c
Core\EM\HddSecurity\IDESMM.c 		For EIP127356.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.8.0
NB : Reference code ver. 1.8.0
SB : Reference code ver. 1.8.0
Intel Rapid Start Technology : Reference code ver. 1.8.0
Platform : Reference code ver. 1.8.0
Manageability Engine (ME) : Reference code ver. 1.8.0
Intel DPTF : Reference code ver. 1.8.0
Reference or 3rd Party code updated in this Release:
CPU : Reference code ver. 1.8.0
NB : Reference code ver. 1.8.0
SB : Reference code ver. 1.8.0
Manageability Engine (ME) : Reference code ver. 1.8.0
Platform : Reference code ver. 1.8.0
Intel Rapid Start Technology : Reference code ver. 1.8.0
Intel DPTF : Reference code ver. 1.8.0
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Haswell : 4651_Haswell_20-RC_180
02. Intel PCH : 4.6.5.3_Intel_LPT-RC_180_047b
03. Intel System Agent : 4.6.5.3_Intel_SA-RC_180_36
04. ME : 4.6.4.1_Intel_ME_RC_1.80_046
05. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_180_033
06. Platform : 4.6.5.3_PF-ACPI_RC_180_033
07. Intel DPTF : 4.6.5.3_DPTF-RC_180_019
08. Intel Nehalem Microcode : 4.6.0_INTEL_MICROCODE_65
09. IntelGigabitLan : 4.6.3.1_INTEL_GIGABIT_LAN_07
10. Hardware Signature Management : 4.6.5.3_HwSignature_04
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● USB Support Disable
● PS2 Device Supportitem Disable
● CSM Disable
- Tested on SBDT FHC CRB FAB2 without any USB device connected.
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 2.043 seconds with Intel SSD 520.
The value of FWPostTIme : is 3.404 seconds with WD5000BPKT.
Known issues in this label:

Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
https://eip.ami.com.tw/eip/projects/display.do?id=12076
Validation Testing:
https://eip.ami.com.tw/eip/issues/display.do?id=159260
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.30.1482 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.30.1482 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW035
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2014-03-21
Source Control Label: 4.6.5.4_VEB_1AQQW036a
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:017
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version:2179
GOP Driver Version:5.0.1036
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.30.1482
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\CORE_DXE\BdsBoard.c
Core\CORE_DXE\BootOptions.c
Include\BootOptions.h 		Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\NVRAM\NVRAM.h | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\NVRAM\NVRAMDXE.c Update for SCT test (EIP116947).
Update to v.102 for EIP103562.
Core\EM\NVRAM\NVRAMRead.c | Update for SCT test (EIP116947).
Include\Protocol\PAhciBus.h | Update for ACHI module labeled 24.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Include\Protocol\PIDEBus.h | Update for ACHI module labeled 24.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
Terminal_MOD Core\EM\Terminal\Terminal.sd
Core\EM\Terminal\TerminalSetup.c 		Fix for build error.
TCG_MOD | Core\EM\TCG\TpmClearOnRollback\TpmClearOnRollbackOfbd.c | Fix after adding 4.6.4_TCG_42, it would cause a building error.>
AHCI_MOD Core\em\Ahci\AhciController.c
Core\em\Ahci\AhciController.h 		Fix spending much time at 0xA2 when booting for EIP139789.
Core\em\Ahci\AhciBus.h
Core\em\Ahci\AhciBus.c 		For EIP127356.
IdeSecurity_MOD Core\EM\HddSecurity\Hddpassword\HddPassword.c
Core\EM\HddSecurity\IdeSecurity.c
Core\EM\HddSecurity\IDESMM.c 		For EIP127356.
Platform_MOD | ReferenceCode\AcpiTables\Dsdt\THERMAL.ASL | For EIP152211.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.8.0
NB : Reference code ver. 1.8.0
SB : Reference code ver. 1.8.0
Intel Rapid Start Technology : Reference code ver. 1.8.0
Platform : Reference code ver. 1.8.0
Manageability Engine (ME) : Reference code ver. 1.8.0
Intel DPTF : Reference code ver. 1.8.0
Reference or 3rd Party code updated in this Release:
CPU : Reference code ver. 1.8.0
NB : Reference code ver. 1.8.0
SB : Reference code ver. 1.8.0
Manageability Engine (ME) : Reference code ver. 1.8.0
Platform : Reference code ver. 1.8.0
Intel Rapid Start Technology : Reference code ver. 1.8.0
Intel DPTF : Reference code ver. 1.8.0
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Haswell : 4651_Haswell_20-RC_180
02. Intel PCH : 4.6.5.3_Intel_LPT-RC_180_047b
03. Intel System Agent : 4.6.5.3_Intel_SA-RC_180_36
04. ME : 4.6.4.1_Intel_ME_RC_1.80_046
05. Intel Rapid Start Technology : 4.6.5.3_iRST-RC_180_033
06. Platform : 4.6.5.3_PF-ACPI_RC_180_033
07. Intel DPTF : 4.6.5.3_DPTF-RC_180_019
08. Intel Nehalem Microcode : 4.6.0_INTEL_MICROCODE_65
09. IntelGigabitLan : 4.6.3.1_INTEL_GIGABIT_LAN_07
10. Hardware Signature Management : 4.6.5.3_HwSignature_04
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● USB Support Disable
● PS2 Device Supportitem Disable
● CSM Disable
- Tested on SBDT FHC CRB FAB2 without any USB device connected.
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 2.043 seconds with Intel SSD 520.
The value of FWPostTIme : is 3.404 seconds with WD5000BPKT.
Known issues in this label:

Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
https://eip.ami.com.tw/eip/projects/display.do?id=12076
Validation Testing:
https://eip.ami.com.tw/eip/issues/display.do?id=159260
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.30.1482 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.30.1482 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW036
4.6.5.4_VEB_1AQQW035
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2014-04-25
Source Control Label: 4.6.5.4_VEB_1AQQW037
Source Control Location: SS: Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:017
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version:2179
GOP Driver Version:5.0.1036
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.30.1482
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\Capsule2_0\Capsule2_0.c Fixed for EIP106722.
Support 2014 BIOS Security Disclosures.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\EM\NVRAM\NVRAM.mak | EIP98678: GetVariable() response slow. Added token to process only SetVariable through SMI.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Core\EM\NVRAM\NVRAMDXE.c Update for SCT test (EIP116947).
Update to v.102 for EIP103562.
Support 2014 BIOS Security Disclosures.
Core\EM\NVRAM\NVRAM.h | Update for SCT test (EIP116947).
Core\EM\NVRAM\NVRAMRead.c | Update for SCT test (EIP116947).
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Include\Protocol\PIDEBus.h | Update for ACHI module labeled 24.
Include\Protocol\PAhciBus.h | Update for ACHI module labeled 24.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Core\CORE_DXE\BdsBoard.c
Core\CORE_DXE\BootOptions.c
Include\BootOptions.h 		Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Library\PeiLib.c | Support 2014 BIOS Security Disclosures.
Library\EfiLib.c | Support 2014 BIOS Security Disclosures.
Core\CORE_DXE\FwVolBlock.c | Support 2014 BIOS Security Disclosures.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
Terminal_MOD Core\EM\Terminal\Terminal.sd
Core\EM\Terminal\TerminalSetup.c 		Fix for build error.
AHCI_MOD Core\em\Ahci\AhciController.c
Core\em\Ahci\AhciController.h 		Fix spending much time at 0xA2 when booting for EIP139789.
Core\em\Ahci\AhciBus.h
Core\em\Ahci\AhciBus.c 		For EIP127356.
IdeSecurity_MOD Core\EM\HddSecurity\Hddpassword\HddPassword.c
Core\EM\HddSecurity\IdeSecurity.c
Core\EM\HddSecurity\IDESMM.c 		For EIP127356.
Platform_MOD | ReferenceCode\AcpiTables\Dsdt\THERMAL.ASL | For EIP152211.
NvramSmi_MOD | Core\EM\NvramSmi\NvramSmi.c | Upadte NvramSmi 05 Handle initialized with NULL.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.8.0
NB : Reference code ver. 1.8.0
SB : Reference code ver. 1.8.0
Intel Rapid Start Technology : Reference code ver. 1.8.0
Platform : Reference code ver. 1.8.0
Manageability Engine (ME) : Reference code ver. 1.8.0
Intel DPTF : Reference code ver. 1.8.0
Reference or 3rd Party code updated in this Release:
CPU : Reference code ver. 1.8.0
NB : Reference code ver. 1.8.0
SB : Reference code ver. 1.8.0
Manageability Engine (ME) : Reference code ver. 1.8.0
Platform : Reference code ver. 1.8.0
Intel Rapid Start Technology : Reference code ver. 1.8.0
Intel DPTF : Reference code ver. 1.8.0
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. NVRAM SMI : 4.6.5.1_NvramSmi_5
02. CryptoPkg : 4.6.5.x_CRYPTOAPI_020
03. ACPI : 4.6.5.0_ACPI_48
04. TCG : 4.6.5.5_TCG_43
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
NONE
Files changed for EIP fixes:
NONE
Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● USB Support Disable
● PS2 Device Supportitem Disable
● CSM Disable
- Tested on SBDT FHC CRB FAB2 without any USB device connected.
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 2.043 seconds with Intel SSD 520.
The value of FWPostTIme : is 3.404 seconds with WD5000BPKT.
Known issues in this label:

Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
https://eip.ami.com.tw/eip/projects/display.do?id=12076
Validation Testing:
https://eip.ami.com.tw/eip/issues/display.do?id=165278
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.30.1482 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.30.1482 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW036a
4.6.5.4_VEB_1AQQW036
4.6.5.4_VEB_1AQQW035
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2014-07-08
Source Control Label: 4.6.5.4_VEB_1AQQW038
Source Control Location: SS:Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:01A
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version:2179
GOP Driver Version:5.0.1036
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.30.1482
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\Capsule2_0\Capsule2_0.c Fixed for EIP106722.
Support 2014 BIOS Security Disclosures.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\BDS.c | Update for SCT test (EIP104956).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Include\Protocol\PIDEBus.h | Update for ACHI module labeled 24.
Include\Protocol\PAhciBus.h | Update for ACHI module labeled 24.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Core\CORE_DXE\BdsBoard.c
Core\CORE_DXE\BootOptions.c
Include\BootOptions.h 		Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Library\PeiLib.c | Support 2014 BIOS Security Disclosures.
Library\EfiLib.c | Support 2014 BIOS Security Disclosures.
Core\CORE_DXE\FwVolBlock.c | Support 2014 BIOS Security Disclosures.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
NvramSmi_MOD | Core\EM\NvramSmi\NvramSmi.c | Upadte NvramSmi 05 Handle initialized with NULL.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.8.0
NB : Reference code ver. 1.8.0
SB : Reference code ver. 1.8.0
Intel Rapid Start Technology : Reference code ver. 1.8.0
Platform : Reference code ver. 1.8.0
Manageability Engine (ME) : Reference code ver. 1.8.0
Intel DPTF : Reference code ver. 1.8.0
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. NVRAM;4.6.5.5_NVRAM_02
02. Intel Haswell;4651_Haswell_20c-RC_180
03. Intel PCH;4.6.5.3_Intel_LPT-RC_180_048a
04. Intel System Agent;4.6.5.3_Intel_SA-RC_180_37
05. AHCI;4.6.3_AhciSrc_026
06. AmiGopPolicy: 4.6.5.3_AmiGopPolicy_006
07. Intel Rapid Start Technology;4.6.5.3_iRST-RC_180_033a
08. Intel Smart Connect Technology;4.6.5.3_ISCT41_110_015
09. CsmOptOut;4.6.5.4_Csm_OptOut_05
10. ME;4.6.4.1_Intel_ME_RC_1.80_047
11. Platform;4.6.5.3_PF-ACPI_RC_180_033b
12. PEI Ram Boot : 4.6.3_PEIRamBoot_20
13. On Flash Block Description (APTIO)- Intel ME Update : 4.6.3.2_OFBD_ME_UPDATE_013
14. Secure Boot Pkg;4.6.5.1_SECBOOT_WIN8_023
15. IdeSecurity : 4.6.3_HddSecurity_026
16. IdeAcoustic : 4.6.3_HddAcoustic_005
17. SMIFlash;4.6.3.6_SMIFLASH_28
18. Sirial Redirection;4.6.3_Terminal_54
19. SwitchableGraphics;4.6.5.3_SG_012
20. TCG : 4.6.5.5_TCG_44
21. Thunderbolt;4.6.5.3_TBT_013
22. TSE Binary : 4.6.2_TSE_2_17_1246
23. UefiNetworkStack II : 4.6.5.4_UefiNetworkStackII_11
24. USB : 4.6.3_USB_08.10.31
25. Intel NehalemMicrocode;4.6.0_INTEL_MICROCODE_67
Modules added to this label:
TseDefaultBootOrder: 4.6.4.1_DefBootOrder_1.3
Modules removed from last label:
NTFS Driver:4.6.5.1_NTFS_Driver_04
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
EIP172950: UEFI Variable Technical Advisory implement.
Modules: list in "Modules update from last label" No.1~24"
Files changed for EIP fixes:
NONE
Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● USB Support Disable
● PS2 Device Supportitem Disable
● CSM Disable
- Tested on SBDT FHC CRB FAB2 without any USB device connected.
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 2.043 seconds with Intel SSD 520.
The value of FWPostTIme : is 3.404 seconds with WD5000BPKT.
Known issues in this label:
01. HDD password prompt screen is distorted(EIP#173965): Update .\EDK\MiniSetup\BootOnly\postmgmtext.c rev.3 to fix. This needs TSE source.
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
https://eip.ami.com.tw/eip/projects/display.do?id=12076
Validation Testing:
https://eip.ami.com.tw/eip/issues/display.do?id=175744
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.30.1482 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.30.1482 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW037
4.6.5.4_VEB_1AQQW036a
4.6.5.4_VEB_1AQQW036
4.6.5.4_VEB_1AQQW035
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2014-07-21
Source Control Label: 4.6.5.4_VEB_1AQQW039
Source Control Location: SS:Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:01A
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version:2179
GOP Driver Version:5.0.1036
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.30.1482
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Core\EM\Capsule2_0\Capsule2_0.c Fixed for EIP106722.
Support 2014 BIOS Security Disclosures.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\BDS.c Update for SCT test (EIP104956).
Update rev.125 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\GC.c | Update for SCT test (EIP105534).
Core\CORE_DXE\GenericSio.c
 Update rev.83 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Include\Protocol\PIDEBus.h | Update for ACHI module labeled 24.
Include\Protocol\PAhciBus.h | Update for ACHI module labeled 24.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Core\CORE_DXE\BdsBoard.c
Include\BootOptions.h 		Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Core\CORE_DXE\BootOptions.c
 Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Update rev.39 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Library\PeiLib.c | Support 2014 BIOS Security Disclosures.
Library\EfiLib.c | Support 2014 BIOS Security Disclosures.
Core\CORE_DXE\FwVolBlock.c | Support 2014 BIOS Security Disclosures.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
AmiGopPolicy_MOD | Board\EM\AmiGopPolicy\AmiGopPolicySetup.c | Change "#else if" to "#elif".
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
NvramSmi_MOD | Core\EM\NvramSmi\NvramSmi.c | Upadte NvramSmi 05 Handle initialized with NULL.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.8.0
NB : Reference code ver. 1.8.0
SB : Reference code ver. 1.8.0
Intel Rapid Start Technology : Reference code ver. 1.8.0
Platform : Reference code ver. 1.8.0
Manageability Engine (ME) : Reference code ver. 1.8.0
Intel DPTF : Reference code ver. 1.8.0
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel PCH;4.6.5.3_Intel_LPT-RC_180_049
02. Intel System Agent;4.6.5.3_Intel_SA-RC_180_37a
03. ACPI;4.6.5.0_ACPI_49
04. Intel Rapid Start Technology;4.6.5.3_iRST-RC_180_033c
05. Intel Smart Connect Technology; 4.6.5.3_ISCT41_110_017
06. Platform;4.6.5.3_PF-ACPI_RC_180_033c
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
EIP172950: Core update for UEFI Variable Technical Advisory implement.
Files: BDS.c, BootOptions.c, GenericSio.c
Files changed for EIP fixes:
NONE
Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● USB Support Disable
● PS2 Device Supportitem Disable
● CSM Disable
- Tested on SBDT FHC CRB FAB2 without any USB device connected.
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 2.043 seconds with Intel SSD 520.
The value of FWPostTIme : is 3.404 seconds with WD5000BPKT.
Known issues in this label:
01. HDD password prompt screen is distorted(EIP#173965): Update .\EDK\MiniSetup\BootOnly\postmgmtext.c rev.3 to fix. This needs TSE source.
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
https://eip.ami.com.tw/eip/projects/display.do?id=12076
Validation Testing:
https://eip.ami.com.tw/eip/issues/display.do?id=178116
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.30.1482 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.30.1482 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW038
4.6.5.4_VEB_1AQQW037
4.6.5.4_VEB_1AQQW036a
4.6.5.4_VEB_1AQQW036
4.6.5.4_VEB_1AQQW035
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2014-11-21
Source Control Label: 4.6.5.4_VEB_1AQQW040
Source Control Location: SS:Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:01C
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version:2179
GOP Driver Version:5.0.1036
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.30.1482
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h
 Fixed for EIP118202.
Core\CORE_DXE\BDS.c Update for SCT test (EIP104956).
Update rev.125 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\BdsBoard.c | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Core\CORE_DXE\BootOptions.c
 Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Update rev.39 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Include\BootOptions.h | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c Fixed for EIP106722.
Support 2014 BIOS Security Disclosures.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Core\EfiFirmwareVolumeHeader.h | Update rev2.
Library\EfiLib.c | Support 2014 BIOS Security Disclosures.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Include\Protocol\FirmwareVolumeBlock.h | Update rev6.
Core\CORE_DXE\FwVolBlock.c
 Support 2014 BIOS Security Disclosures. Update rev5,6,7.
Core\CORE_DXE\GC.c | Update for SCT test(EIP105534).
Core\CORE_DXE\GenericSio.c | Update rev.83 for EIP172950,Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Include\Protocol\PAhciBus.h | Update for ACHI module labeled 24.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Library\PeiLib.c | Support 2014 BIOS Security Disclosures.
Include\Protocol\PIDEBus.h | Update for ACHI module labeled 24.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
NvramSmi_MOD | Core\EM\NvramSmi\NvramSmi.c | Upadte NvramSmi 05 Handle initialized with NULL.
BootScriptHide_MOD | Core\EM\BootScriptHide\BootScriptHideSmm.c | Modify for project.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.8.0
NB : Reference code ver. 1.8.0
SB : Reference code ver. 1.8.0
Intel Rapid Start Technology : Reference code ver. 1.8.0
Platform : Reference code ver. 1.8.0
Manageability Engine (ME) : Reference code ver. 1.8.0
Intel DPTF : Reference code ver. 1.8.0
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel PCH;4.6.5.3_Intel_LPT-RC_180_049.2
02. Intel System Agent;4.6.5.3_Intel_SA-RC_180_37b
03. AmiGopPolicy;4.6.5.3_AmiGopPolicy_006a
04. NehalemMicrocode;4.6.0_INTEL_MICROCODE_69
05. Intel Smart Connect Technology; 4.6.5.3_ISCT41_110_018
06. CSM/Generic;4.6.5.3_CSM.7.76_81
07. ME;4.6.4.1_Intel_ME_RC_1.80_049
Modules added to this label:
01. TCG2;4.6.5.5_TCG2_02
02. BootScriptHide;4.6.5.5_BootScriptHide_01
Modules removed from last label:
01. TCG;4.6.5.5_TCG_44
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
1. EIP191080: Add BootScriptHide Module to project.
Files changed for EIP fixes:
1. EIP191080: Add BootScriptHide Module (new private,BootScriptHideSmm.c),
Update Intel PCH;4.6.5.3_Intel_LPT-RC_180_049.2,
CRB.sdl (Clone Token, "BootScriptHide_SUPPORT" and "PchS3Support_SUPPORT").
Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● USB Support Disable
● PS2 Device Supportitem Disable
● CSM Disable
- Tested on SBDT FHC CRB FAB2 without any USB device connected.
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 1.950 seconds with Intel SSD 520 without TPM.
The value of FWPostTIme : is 3.754 seconds with 2.5" HDD without TPM.
Known issues in this label:
01. HDD password prompt screen is distorted(EIP#173965): Update .\EDK\MiniSetup\BootOnly\postmgmtext.c rev.3 to fix. This needs TSE source.
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
https://eip.ami.com.tw/eip/projects/display.do?id=12076
Validation Testing:
https://eip.ami.com.tw/eip/issues/display.do?id=192981
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.30.1482 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.30.1482 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW039
4.6.5.4_VEB_1AQQW038
4.6.5.4_VEB_1AQQW037
4.6.5.4_VEB_1AQQW036a
4.6.5.4_VEB_1AQQW036
4.6.5.4_VEB_1AQQW035
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2014-12-09
Source Control Label: 4.6.5.4_VEB_1AQQW041
Source Control Location: SS:Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:01C
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version:2179
GOP Driver Version:5.0.1036
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.30.1482
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h
 Fixed for EIP118202.
Core\CORE_DXE\BDS.c Update for SCT test (EIP104956).
Update rev.125 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\BdsBoard.c | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Core\CORE_DXE\BootOptions.c
 Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Update rev.39 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Include\BootOptions.h | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c Fixed for EIP106722.
Support 2014 BIOS Security Disclosures.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Core\EfiFirmwareVolumeHeader.h | Update rev2.
Library\EfiLib.c | Support 2014 BIOS Security Disclosures.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Include\Protocol\FirmwareVolumeBlock.h | Update rev6.
Core\CORE_DXE\FwVolBlock.c
 Support 2014 BIOS Security Disclosures. Update rev5,6,7.
Core\CORE_DXE\GC.c | Update for SCT test(EIP105534).
Core\CORE_DXE\GenericSio.c | Update rev.83 for EIP172950,Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Include\Protocol\PAhciBus.h | Update for ACHI module labeled 24.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Library\PeiLib.c | Support 2014 BIOS Security Disclosures.
Include\Protocol\PIDEBus.h | Update for ACHI module labeled 24.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
NvramSmi_MOD | Core\EM\NvramSmi\NvramSmi.c | Upadte NvramSmi 05 Handle initialized with NULL.
BootScriptHide_MOD | Core\EM\BootScriptHide\BootScriptHideSmm.c | Modify for project.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.9.0
NB : Reference code ver. 1.9.0
SB : Reference code ver. 1.9.0
Intel Rapid Start Technology :Reference code ver. 1.9.0
Platform : Reference code ver. 1.9.0
Manageability Engine (ME) : Reference code ver. 1.9.0
Intel DPTF : Reference code ver. 1.8.0
Reference or 3rd Party code updated in this Release:
CPU : Reference code ver. 1.9.0
NB : Reference code ver. 1.9.0
SB : Reference code ver. 1.9.0
Intel Rapid Start Technology : Reference code ver. 1.9.0
Manageability Engine (ME) : Reference code ver. 1.9.0
Platform : Reference code ver. 1.9.0
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Haswell;4651_Haswell_21-RC_190
02. Intel PCH;4.6.5.3_Intel_LPT-RC_190_050
03. Intel System Agent;4.6.5.3_Intel_SA-RC_190_39
04. Intel Rapid Start Technology;4.6.5.3_iRST-RC_190_034
05. ME; 4.6.4.1_Intel_ME_RC_1.90_050
06. Platform;4.6.5.3_PF-ACPI_RC_190_034
07. NehalemMicrocode;4.6.0_INTEL_MICROCODE_71
Modules added to this label:
AmiBufferValidationLib;AmiBufferValidationLib_01
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
1. EIP194522: Shark Bay Reference Code Production Version 1.9.0 for Desktop platform.
Files changed for EIP fixes:
1. EIP194522: No.1~6 in "Modules update from last label" list.
Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● CSM Disable
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 1.637 seconds with Intel SSD 520 180G without TPM.
The value of FWPostTIme : is 3.953 seconds with WD3200BEVT HDD without TPM.
Known issues in this label:
01. HDD password prompt screen is distorted(EIP#173965): Update .\EDK\MiniSetup\BootOnly\postmgmtext.c rev.3 to fix. This needs TSE source.
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
https://eip.ami.com.tw/eip/projects/display.do?id=12076
Validation Testing:
https://eip.ami.com.tw/eip/issues/display.do?id=194933
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.30.1482 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.30.1482 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW040
4.6.5.4_VEB_1AQQW039
4.6.5.4_VEB_1AQQW038
4.6.5.4_VEB_1AQQW037
4.6.5.4_VEB_1AQQW036a
4.6.5.4_VEB_1AQQW036
4.6.5.4_VEB_1AQQW035
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2015-01-16
Source Control Label: 4.6.5.4_VEB_1AQQW042
Source Control Location: SS:Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:01C
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version:2179
GOP Driver Version:5.0.1036
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.30.1482
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h
 Fixed for EIP118202.
Core\CORE_DXE\BDS.c Update for SCT test (EIP104956).
Update rev.125 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\BdsBoard.c | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Core\CORE_DXE\BootOptions.c
 Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Update rev.39 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Include\BootOptions.h | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c Fixed for EIP106722.
Support 2014 BIOS Security Disclosures.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Core\EfiFirmwareVolumeHeader.h | Update rev2.
Library\EfiLib.c | Support 2014 BIOS Security Disclosures.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Include\Protocol\FirmwareVolumeBlock.h | Update rev6.
Core\CORE_DXE\FwVolBlock.c
 Support 2014 BIOS Security Disclosures. Update rev5,6,7.
Core\CORE_DXE\GC.c | Update for SCT test(EIP105534).
Core\CORE_DXE\GenericSio.c | Update rev.83 for EIP172950,Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Include\Protocol\PAhciBus.h | Update for ACHI module labeled 24.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Library\PeiLib.c | Support 2014 BIOS Security Disclosures.
Include\Protocol\PIDEBus.h | Update for ACHI module labeled 24.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
NvramSmi_MOD | Core\EM\NvramSmi\NvramSmi.c | Upadte NvramSmi 05 Handle initialized with NULL.
BootScriptHide_MOD | Core\EM\BootScriptHide\BootScriptHideSmm.c | Modify for project.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.9.0
NB : Reference code ver. 1.9.0
SB : Reference code ver. 1.9.0
Intel Rapid Start Technology :Reference code ver. 1.9.0
Platform : Reference code ver. 1.9.0
Manageability Engine (ME) : Reference code ver. 1.9.0
Intel DPTF : Reference code ver. 1.8.0
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. KbcEmulation;4.6.3-KbcEmulation-020
02. HddSecurity;4.6.3_HddSecurity_027
03. USB; 4.6.3_USB_08.10.33
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
1. EIP197820: Security review on Use of Non-Locked BARs in SMI handlers for SHB DT.
Files changed for EIP fixes:
1. EIP197820:a, 4.6.3_HddSecurity_027. b, 4.6.3-KbcEmulation-020. c, 4.6.3_USB_08.10.33
Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● CSM Disable
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 1.876 seconds with SSD: Intel SSD 520 without TPM.
The value of FWPostTIme : is 3.478 seconds with HDD: 2.5"WD 120G without TPM.
Known issues in this label:
01. HDD password prompt screen is distorted(EIP#173965): Update .\EDK\MiniSetup\BootOnly\postmgmtext.c rev.3 to fix. This needs TSE source.
02. The options of "DIMM profile" can’t load default(EIP#200606): Update NBSetup.c version26.
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
https://eip.ami.com.tw/eip/projects/display.do?id=12076
Validation Testing:
https://eip.ami.com.tw/eip/issues/display.do?id=199921
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.30.1482 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.30.1482 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW041
4.6.5.4_VEB_1AQQW040
4.6.5.4_VEB_1AQQW039
4.6.5.4_VEB_1AQQW038
4.6.5.4_VEB_1AQQW037
4.6.5.4_VEB_1AQQW036a
4.6.5.4_VEB_1AQQW036
4.6.5.4_VEB_1AQQW035
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2015-02-11
Source Control Label: 4.6.5.4_VEB_1AQQW043
Source Control Location: SS:Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:01D
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version:2179
GOP Driver Version:5.0.1036
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.0
ME Kit Revision: 9.0.30.1482
ME F/W Binary: ME9.0_1.5M_Production.bin; ME9.0_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h
 Fixed for EIP118202.
Core\CORE_DXE\BDS.c Update for SCT test (EIP104956).
Update rev.125 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\BdsBoard.c | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Core\CORE_DXE\BootOptions.c
 Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Update rev.39 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Include\BootOptions.h | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c Fixed for EIP106722.
Support 2014 BIOS Security Disclosures.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Core\EfiFirmwareVolumeHeader.h | Update rev2.
Library\EfiLib.c | Support 2014 BIOS Security Disclosures.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Include\Protocol\FirmwareVolumeBlock.h | Update rev6.
Core\CORE_DXE\FwVolBlock.c
 Support 2014 BIOS Security Disclosures. Update rev5,6,7.
Core\CORE_DXE\GC.c | Update for SCT test(EIP105534).
Core\CORE_DXE\GenericSio.c | Update rev.83 for EIP172950,Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384.
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Include\Protocol\PAhciBus.h Update for AHCI module labeled 24. Update v12 for AhciSrc _027.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Library\PeiLib.c | Support 2014 BIOS Security Disclosures.
Include\Protocol\PIDEBus.h Update for AHCI module labeled 24. Update v31 for AhciSrc _027.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
NvramSmi_MOD | Core\EM\NvramSmi\NvramSmi.c | Upadte NvramSmi 05 Handle initialized with NULL.
BootScriptHide_MOD | Core\EM\BootScriptHide\BootScriptHideSmm.c | Modify for project.
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.9.0
NB : Reference code ver. 1.9.0
SB : Reference code ver. 1.9.0
Intel Rapid Start Technology :Reference code ver. 1.9.0
Platform : Reference code ver. 1.9.0
Manageability Engine (ME) : Reference code ver. 1.9.0
Intel DPTF : Reference code ver. 1.8.0
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Haswell;4651_Haswell_21a-RC_190
02. Intel PCH;4.6.5.3_Intel_LPT-RC_190_050.2
03. Intel System Agent;4.6.5.3_Intel_SA-RC_190_39a
04. AHCI;4.6.3_AhciSrc_027
05. AmiBufferValidationLib;AmiBufferValidationLib_03
06. Intel Nehalem Microcode;4.6.0_INTEL_MICROCODE_72
07. Legacy Serial Redirection;4.5.5_LegacySredir_39
08. Serial Redirection;4.6.3_Terminal_55
09. TSE Binary;4.6.2_TSE_2_17_1247
Modules added to this label:
01. FLASH SMI;4.6.5.5_FlashSmi_00 (This is an essential eModule for this CRB label)
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
01. The options of "DIMM profile" can't load default(EIP#200606): Fixed in Intel System Agent;4.6.5.3_Intel_SA-RC_190_39a.
EIP addressed in this label:
1. EIP200378: Security review on SMM Buffer issue for SHB DT
2. EIP202192: [SharkBay Desktop] SMM_BWP and BIOS_BLE must be enabled for Flash Recovery and Capsule modes
3. EIP202457: Don't load Intel GOP driver when set Video is as Legacy on BIOS setup
Files changed for EIP fixes:
1. EIP200378: a, 4.6.3_AhciSrc_027. b, 4.5.5_LegacySredir_39
2. EIP202192: a, 4.6.5.3_Intel_LPT-RC_190_050.2 (SBDxe.c rev100,SBGeneric.c Rev27).
b, FLASH SMI module,4.6.5.5_FlashSmi_00 ([SS Path] $/Alaska/SOURCE/Modules/FlashSmi)
3. EIP202457: 4.6.5.3_Intel_SA-RC_190_39a (IntelSaGopDriver.mak rev4, IntelGopDriver.dxs (new) )
Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● CSM Disable
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 1.683 seconds with SSD: Intel SSD 520 without TPM.
The value of FWPostTIme : is 3.782 seconds with HDD: 2.5" Seagate 320G without TPM.
Known issues in this label:
01. HDD password prompt screen is distorted from 2nd HDD if system plug more than one.
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
https://eip.ami.com.tw/eip/projects/display.do?id=12076
Validation Testing:
https://eip.ami.com.tw/eip/issues/display.do?id=203584
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.0_1.5M_9.0.30.1482 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.0_5M_9.0.30.1482 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW042
4.6.5.4_VEB_1AQQW041
4.6.5.4_VEB_1AQQW040
4.6.5.4_VEB_1AQQW039
4.6.5.4_VEB_1AQQW038
4.6.5.4_VEB_1AQQW037
4.6.5.4_VEB_1AQQW036a
4.6.5.4_VEB_1AQQW036
4.6.5.4_VEB_1AQQW035
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2015-07-16
Source Control Label: 4.6.5.4_VEB_1AQQW044
Source Control Location: SS:Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:01D
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version:2179
GOP Driver Version:5.0.1036
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.1
ME Kit Revision: 9.1.30.1008
ME F/W Binary: ME9.1_1.5M_Production.bin; ME9.1_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h
 Fixed for EIP118202.
Core\CORE_DXE\BDS.c Update for SCT test (EIP104956).
Update rev.125 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\BdsBoard.c | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Core\CORE_DXE\BootOptions.c
 Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Update rev.39 for EIP172950, Core updates for UEFI Variable Technical Advisory implement. EIP210170.
Include\BootOptions.h | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c Fixed for EIP106722.
Support 2014 BIOS Security Disclosures.
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\EM\AMITSE\commonoem.c
 Update rev66 for EIP201836, Correct WaitForEvent().
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Core\EfiFirmwareVolumeHeader.h | Update rev2.
Library\EfiLib.c | Support 2014 BIOS Security Disclosures.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Include\Protocol\FirmwareVolumeBlock.h | Update rev6.
Core\CORE_DXE\FwVolBlock.c
 Support 2014 BIOS Security Disclosures. Update rev5,6,7.
Core\CORE_DXE\GC.c | Update for SCT test(EIP105534).
Core\CORE_DXE\GenericSio.c | Update rev.83 for EIP172950,Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384. EIP217417
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Include\Protocol\PAhciBus.h Update for AHCI module labeled 24. Update v12 for AhciSrc _027.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Library\PeiLib.c | Support 2014 BIOS Security Disclosures.
Include\Protocol\PIDEBus.h Update for AHCI module labeled 24. Update v31 for AhciSrc _027.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1. Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
NvramSmi_MOD | Core\EM\NvramSmi\NvramSmi.c | Upadte NvramSmi 05 Handle initialized with NULL.
IntelHaswell_MOD | Board\CPU\TxtDxe\AmiTxtInfoHook.c | Correct WaitForEvent()
TCG2_MOD
 Board\EM\TCG2\Common\Setup\TPMPwd.c
 Correct WaitForEvent()
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.9.0
NB : Reference code ver. 1.9.0
SB : Reference code ver. 1.9.1
Intel Rapid Start Technology :Reference code ver. 1.9.0
Platform : Reference code ver. 1.9.0
Manageability Engine (ME) : Reference code ver. 1.9.0
Intel DPTF : Reference code ver. 1.8.0
Reference or 3rd Party code updated in this Release:
SB : Reference code ver. 1.9.1
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Haswell;4651_Haswell_21c-RC_190
02. Intel PCH;4.6.5.3_Intel_LPT-RC_191_051.1
03. Intel System Agent;4.6.5.3_Intel_SA-RC_190_39b
04. Intel Nehalem Microcode; 4.6.0_INTEL_MICROCODE_77
05. On Flash Block Description(APTIO) - Intel ME Update;4.6.3.2_OFBD_ME_UPDATE_015
06. IdeSecurity;4.6.3_HddSecurity_029
07. Secure Boot Pkg;4.6.5.1_SECBOOT_WIN8_025
08. Rom Image;4.6.5.3_RomImage_048
Modules added to this label:
01. Block S3 Variable; BlockS3Var_00
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
1. EIP221317: [SharkBay] S3 Security Technical Advisories
2. EIP214066: [SHB-DT] ME capsule update support.
3. EIP210170: Improved BootOption DevicePath match algorithm.
4. EIP210836: [REF-37724]ARM systems generate exception after 3 invalid password tries in the POST.
5. EIP217417: [SharkBay] usb keyboard hot-plug not work when enter BIOS password windows.
Files changed for EIP fixes:
1. EIP221317: Update SA 4.6.5.3_Intel_SA-RC_190_39b, add module-Block S3 Variable
2. EIP214066: Update module-4.6.3.2_OFBD_ME_UPDATE_015. Related setting please refer Porting Notes #8
3. EIP210170: Bootoptions.c
4. EIP210836: commonoem.c,AmiTxtInfoHook.c,TPMPwd.c
5. EIP217417: In.c
6. EIP N/A: CRB.sdl , Enable tokan "SMM_COMMUNICATE_SUPPORT" for upgrade 4.6.3_HddSecurity_029.
Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● CSM Disable
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 1.762 seconds with SSD: Intel SSD 530 without TPM.
The value of FWPostTIme : is 3.471 seconds with HDD: 2.5" Seagate 500G without TPM.
Known issues in this label:
01. HDD password prompt screen is distorted from 2nd HDD if system plug more than one.
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
Remaining Issues:
NONE
Unit Testing:
https://eip.ami.com.tw/eip/issues/display.do?id=225746
Validation Testing:
https://eip.ami.com.tw/eip/issues/display.do?id=228230
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
08. ME capsule update support:
a. Enable token , "MEFwUpdLcl_SUPPORT" and "MEFWUPDLCL_ON_SHARKBAY_PLATFORM"
b. ME_BIN_FILE = ME image
c. ME_FW_IMAGE_VERSION = "{x, x, x, x}"
d. FWCAPSULE_IMAGE_SIZE = "$(FLASH_SIZE)+$(FWCAPSULE_MAX_HDR_SIZE)+$(FV_MEFWCAP_SIZE)".
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.1_1.5M_9.1.30.1008 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.1_5M_9.1.30.1008 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW043
4.6.5.4_VEB_1AQQW042
4.6.5.4_VEB_1AQQW041
4.6.5.4_VEB_1AQQW040
4.6.5.4_VEB_1AQQW039
4.6.5.4_VEB_1AQQW038
4.6.5.4_VEB_1AQQW037
4.6.5.4_VEB_1AQQW036a
4.6.5.4_VEB_1AQQW036
4.6.5.4_VEB_1AQQW035
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2015-10-21
Source Control Label: 4.6.5.4_VEB_1AQQW045
Source Control Location: SS:Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:01D
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version:2179
GOP Driver Version:5.0.1036
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.1
ME Kit Revision: 9.1.30.1008
ME F/W Binary: ME9.1_1.5M_Production.bin; ME9.1_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h
 Fixed for EIP118202.
Core\CORE_DXE\BDS.c Update for SCT test (EIP104956).
Update rev.125 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\BdsBoard.c | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Core\CORE_DXE\BootOptions.c
 Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Update rev.39 for EIP172950, Core updates for UEFI Variable Technical Advisory implement. EIP210170.
Include\BootOptions.h | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c Fixed for EIP106722.
Support 2014 BIOS Security Disclosures.
Core\EM\Capsule2_0\Capsule2_0Runtime.c
 Update EIP225308
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\EM\AMITSE\commonoem.c | Update rev66 for EIP201836, Correct WaitForEvent().
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Core\EfiFirmwareVolumeHeader.h | Update rev2.
Library\EfiLib.c | Support 2014 BIOS Security Disclosures.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Include\Protocol\FirmwareVolumeBlock.h | Update rev6.
Core\CORE_DXE\FwVolBlock.c
 Support 2014 BIOS Security Disclosures. Update rev5,6,7.
Core\CORE_DXE\GC.c | Update for SCT test(EIP105534).
Core\CORE_DXE\GenericSio.c | Update rev.83 for EIP172950,Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384. EIP217417
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Include\Protocol\PAhciBus.h Update for AHCI module labeled 24. Update v12 for AhciSrc _027.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Library\PeiLib.c | Support 2014 BIOS Security Disclosures.
Include\Protocol\PIDEBus.h Update for AHCI module labeled 24. Update v31 for AhciSrc _027.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
NvramSmi_MOD | Core\EM\NvramSmi\NvramSmi.c | Upadte NvramSmi 05 Handle initialized with NULL.
IntelHaswell_MOD | Board\CPU\TxtDxe\AmiTxtInfoHook.c | Correct WaitForEvent()
TCG2_MOD | Board\EM\TCG2\Common\Setup\TPMPwd.c | Correct WaitForEvent()
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.9.0
NB : Reference code ver. 1.9.0
SB : Reference code ver. 1.9.1
Intel Rapid Start Technology :Reference code ver. 1.9.0
Platform : Reference code ver. 1.9.0
Manageability Engine (ME) : Reference code ver. 1.9.0
Intel DPTF : Reference code ver. 1.8.0
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel PCH;4.6.5.3_Intel_LPT-RC_191_051.2
02. Intel Nehalem Microcode;4.6.0_INTEL_MICROCODE_81
03. ME;4.6.4.1_Intel_ME_RC_1.90_052
04. PEI Ram Boot;4.6.3_PEIRamBoot_022
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
1. EIP239795: Security Vulnerability : (AMT) A vulnerability allows the takeover of the system
Files changed for EIP fixes:
1. EIP239795: Update ME eModule label 4.6.4.1_Intel_ME_RC_1.90_052
Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● CSM Disable
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 1.675 seconds with SSD: Intel SSD 530 without TPM.
The value of FWPostTIme : is 3.298 seconds with HDD: 2.5" Seagate 320G without TPM.
Known issues in this label:
01. HDD password prompt screen is distorted from 2nd HDD if system plug more than one.
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
08. Fedora 22 x64 S4 resume failed.
Remaining Issues:
NONE
Unit Testing:
https://eip.ami.com.tw/eip/projects/display.do?id=12076
Validation Testing:
https://eip.ami.com.tw/eip/issues/display.do?id=240711
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
08. ME capsule update support:
a. Enable token , "MEFwUpdLcl_SUPPORT" and "MEFWUPDLCL_ON_SHARKBAY_PLATFORM"
b. ME_BIN_FILE = ME image
c. ME_FW_IMAGE_VERSION = "{x, x, x, x}"
d. FWCAPSULE_IMAGE_SIZE = "$(FLASH_SIZE)+$(FWCAPSULE_MAX_HDR_SIZE)+$(FV_MEFWCAP_SIZE)".
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.1_1.5M_9.1.30.1008 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.1_5M_9.1.30.1008 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW044
4.6.5.4_VEB_1AQQW043
4.6.5.4_VEB_1AQQW042
4.6.5.4_VEB_1AQQW041
4.6.5.4_VEB_1AQQW040
4.6.5.4_VEB_1AQQW039
4.6.5.4_VEB_1AQQW038
4.6.5.4_VEB_1AQQW037
4.6.5.4_VEB_1AQQW036a
4.6.5.4_VEB_1AQQW036
4.6.5.4_VEB_1AQQW035
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2016-5-5
Source Control Label: 4.6.5.4_VEB_1AQQW046
Source Control Location: SS:Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:020
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2179
GOP Driver Version: 5.0.1036
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.1
ME Kit Revision: 9.1.35.1006
ME F/W Binary: ME9.1_1.5M_Production.bin; ME9.1_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h
 Fixed for EIP118202.
Core\CORE_DXE\BDS.c Update for SCT test (EIP104956).
Update rev.125 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\BdsBoard.c | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Core\CORE_DXE\BootOptions.c
 Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Update rev.39 for EIP172950, Core updates for UEFI Variable Technical Advisory implement. EIP210170.
Include\BootOptions.h | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c Fixed for EIP106722.
Support 2014 BIOS Security Disclosures.
Core\EM\Capsule2_0\Capsule2_0Runtime.c Update EIP225308
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\EM\AMITSE\commonoem.c | Update rev66 for EIP201836, Correct WaitForEvent().
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Core\EfiFirmwareVolumeHeader.h | Update rev2.
Library\EfiLib.c | Support 2014 BIOS Security Disclosures.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Include\Protocol\FirmwareVolumeBlock.h | Update rev6.
Core\CORE_DXE\FwVolBlock.c
 Support 2014 BIOS Security Disclosures. Update rev5,6,7.
Core\CORE_DXE\GC.c | Update for SCT test(EIP105534).
Core\CORE_DXE\GenericSio.c | Update rev.83 for EIP172950,Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384. EIP217417
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Include\Protocol\PAhciBus.h Update for AHCI module labeled 24. Update v12 for AhciSrc _027.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Library\PeiLib.c | Support 2014 BIOS Security Disclosures.
Include\Protocol\PIDEBus.h Update for AHCI module labeled 24. Update v31 for AhciSrc _027.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
NvramSmi_MOD | Core\EM\NvramSmi\NvramSmi.c | Upadte NvramSmi 05 Handle initialized with NULL.
IntelHaswell_MOD | Board\CPU\TxtDxe\AmiTxtInfoHook.c | Correct WaitForEvent()
TCG2_MOD | Board\EM\TCG2\Common\Setup\TPMPwd.c | Correct WaitForEvent()
Chipset_MOD Board\EM\Platform\AcpiPlatform.c
ReferenceCode\Haswell\PowerManagement\Dxe\PowerMgmtInit.c
 Modify for ACPI table.
ReferenceCode\Chipset\SystemAgent\MemoryInit\Pei\MemoryInit.c | Modify InstallEfiMemory ().
Chipset\SB\SBRun.c | Modify VerifyTime().
Chipset\NB\SystemAgentWrap\UpdateMemoryRecord\UpdateMemoryRecord.c Update EIP249553
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.9.0
NB : Reference code ver. 1.9.0
SB : Reference code ver. 1.9.1
Intel Rapid Start Technology :Reference code ver. 1.9.0
Platform : Reference code ver. 1.9.0
Manageability Engine (ME) : Reference code ver. 1.9.0
Intel DPTF : Reference code ver. 1.8.0
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. EfiOsBootOptionNames;4.6.4.1_EfiOsBootOptionNames_13
02. NehalemMicrocode;4.6.0_INTEL_MICROCODE_84
03. OFBD;4.6.3.2_OFBD.1.0.6
04. SecureFlashPkg;4.6.5.1_SECMOD_017
05. SMBIOS-Board;4.6.5.5_SMBIOSBOARD_40
06. SMBIOS-Core Source;4.6.5.5_SMBIOS_40
07. SMIFlash;4.6.3.6_SMIFLASH_31
08. RomImage;4.6.5.3_RomImage_049
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
1. EIP259956: [SharkBay DT] Security Vulnerability(AMISV037) - Potential issues in SMM
2. EIP249553: SMBIOS Type17 memory speed report issue
Files changed for EIP fixes:
1. EIP259956: Update
1. OFBD;4.6.3.2_OFBD.1.0.6 ,
2. SecureFlashPkg;4.6.5.1_SECMOD_017 ,
3. SMIFlash;4.6.3.6_SMIFLASH_31 ,
4. SMBIOS-BOARD;4.6.5.5_SMBIOSBOARD_40 ,
5. SMBIOS-Core Source;4.6.5.5_SMBIOS_40
2. .\CRB\CRB.sdl (EIP #NA)
-Clone Token, "RECOVERY_ROM".
-Clone ME capsule update support Tokens (Refer Porting Notes #08).
3. .\Chipset\NB\SystemAgentWrap\UpdateMemoryRecord\UpdateMemoryRecord.c rev10 (EIP #249553)
4. .\Board\EM\Platform\AcpiPlatform.c (EIP #NA)
5. .\ReferenceCode\Haswell\PowerManagement\Dxe\PowerMgmtInit.c(EIP #NA)
6. .\ReferenceCode\Chipset\SystemAgent\MemoryInit\Pei\MemoryInit.c (EIP #NA)
7. .\Chipset\SB\SBRun.c (EIP #NA)
Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● CSM Disable
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 1.713 seconds with SSD: Intel SSD 535 240G without TPM.
The value of FWPostTIme : is 3.497 seconds with HDD without TPM.
Known issues in this label:
01. HDD password prompt screen is distorted from 2nd HDD if system plug more than one.
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
08. Fedora 22/23 x64 S4 resume failed.
Remaining Issues:
NONE
Unit Testing:
https://eip.ami.com.tw/eip/projects/display.do?id=12076
Validation Testing:
https://eip.ami.com.tw/eip/issues/display.do?id=266418
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
08. ME capsule update support(EIP #214066):
a. Enable token , "MEFwUpdLcl_SUPPORT" and "MEFWUPDLCL_ON_SHARKBAY_PLATFORM"
b. ME_BIN_FILE = ME image
c. ME_FW_IMAGE_VERSION = "{x, x, x, x}"
d. FWCAPSULE_IMAGE_SIZE = "$(FLASH_SIZE)+$(FWCAPSULE_MAX_HDR_SIZE)+$(FV_MEFWCAP_SIZE)".
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.1_1.5M_9.1.35.1006 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.1_5M_9.1.35.1006 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW045
4.6.5.4_VEB_1AQQW044
4.6.5.4_VEB_1AQQW043
4.6.5.4_VEB_1AQQW042
4.6.5.4_VEB_1AQQW041
4.6.5.4_VEB_1AQQW040
4.6.5.4_VEB_1AQQW039
4.6.5.4_VEB_1AQQW038
4.6.5.4_VEB_1AQQW037
4.6.5.4_VEB_1AQQW036a
4.6.5.4_VEB_1AQQW036
4.6.5.4_VEB_1AQQW035
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2016-7-1
Source Control Label: 4.6.5.4_VEB_1AQQW047
Source Control Location: SS:Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:021
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2179
GOP Driver Version: 5.0.1036
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.1
ME Kit Revision: 9.1.35.1006
ME F/W Binary: ME9.1_1.5M_Production.bin; ME9.1_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h
 Fixed for EIP118202.
Core\CORE_DXE\BDS.c Update for SCT test (EIP104956).
Update rev.125 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\BdsBoard.c | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Core\CORE_DXE\BootOptions.c
 Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Update rev.39 for EIP172950, Core updates for UEFI Variable Technical Advisory implement. EIP210170.
Include\BootOptions.h | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c Fixed for EIP106722.
Support 2014 BIOS Security Disclosures.
Core\EM\Capsule2_0\Capsule2_0Runtime.c Update EIP225308
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\EM\AMITSE\commonoem.c | Update rev66 for EIP201836, Correct WaitForEvent().
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Core\EfiFirmwareVolumeHeader.h | Update rev2.
Library\EfiLib.c | Support 2014 BIOS Security Disclosures.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Include\Protocol\FirmwareVolumeBlock.h | Update rev6.
Core\CORE_DXE\FwVolBlock.c
 Support 2014 BIOS Security Disclosures. Update rev5,6,7.
Core\CORE_DXE\GC.c | Update for SCT test(EIP105534).
Core\CORE_DXE\GenericSio.c | Update rev.83 for EIP172950,Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384. EIP217417
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Include\Protocol\PAhciBus.h Update for AHCI module labeled 24. Update v12 for AhciSrc _027.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Library\PeiLib.c | Support 2014 BIOS Security Disclosures.
Include\Protocol\PIDEBus.h Update for AHCI module labeled 24. Update v31 for AhciSrc _027.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1.Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
NvramSmi_MOD | Core\EM\NvramSmi\NvramSmi.c | Upadte NvramSmi 05 Handle initialized with NULL.
IntelHaswell_MOD | Board\CPU\TxtDxe\AmiTxtInfoHook.c | Correct WaitForEvent()
TCG2_MOD | Board\EM\TCG2\Common\Setup\TPMPwd.c | Correct WaitForEvent()
Chipset_MOD Board\EM\Platform\AcpiPlatform.c
ReferenceCode\Haswell\PowerManagement\Dxe\PowerMgmtInit.c
 Modify for ACPI table.
ReferenceCode\Chipset\SystemAgent\MemoryInit\Pei\MemoryInit.c | Modify InstallEfiMemory ().
Chipset\SB\SATA.ASL
 EIP255383
Chipset\SB\SBRun.c | Modify VerifyTime().
Chipset\NB\SystemAgentWrap\UpdateMemoryRecord\UpdateMemoryRecord.c Update EIP249553
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.9.0
NB : Reference code ver. 1.9.0
SB : Reference code ver. 1.9.1
Intel Rapid Start Technology :Reference code ver. 1.9.0
Platform : Reference code ver. 1.9.0
Manageability Engine (ME) : Reference code ver. 1.9.0
Intel DPTF : Reference code ver. 1.8.0
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. BootScriptHide;4.6.5.5_BootScriptHide_02
02. Intel Nehalem Microcode;4.6.0_INTEL_MICROCODE_86
Modules added to this label:
01. NVMe ; 4.6.5.5_NVMe_005
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
1. EIP268811: System may hang sporadically at AE checkpoint on reboot cycle if +USB PCIE card (refer Porting Notes #9)
EIP addressed in this label:
1. EIP272318: [SharkBay DT] Security Vulnerability - ACPI FACS Protection
2. EIP255383: FORCE_HDD_PASSWORD_PROMPT sdl token enabled , s4 doesnt work.
Files changed for EIP fixes:
1. EIP272318: Update 4.6.5.5_BootScriptHide_02
2. EIP255383: SATA.asl
3. EIP268811: SmmDispatcher.c rollback. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated. Token "ENABLE_SEND_SMI_IPI_IN_SMM" default is not exit. (refer Porting Notes #9)

Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● CSM Disable
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 1.633 seconds with SSD: Intel SSD 530 without TPM.
The value of FWPostTIme : is 3.316 seconds with HDD without TPM.
Known issues in this label:
01. HDD password prompt screen is distorted from 2nd HDD if system plug more than one.
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
08. Fedora 22/23 x64 S4 resume failed.
Remaining Issues:
NONE
Unit Testing:
https://eip.ami.com.tw/eip/projects/display.do?id=12076
Validation Testing:
https://eip.ami.com.tw/eip/issues/display.do?id=275821
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
08. ME capsule update support(EIP #214066):
a. Enable token , "MEFwUpdLcl_SUPPORT" and "MEFWUPDLCL_ON_SHARKBAY_PLATFORM"
b. ME_BIN_FILE = ME image (default value = "$(ROM_IMAGE_DIR)\ME\ME9.1_1.5M_Production.BIN")
c. ME_FW_IMAGE_VERSION = "{x, x, x, x}"
d. FWCAPSULE_IMAGE_SIZE = "$(FLASH_SIZE)+$(FWCAPSULE_MAX_HDR_SIZE)+$(FV_MEFWCAP_SIZE)".
09. Token "ENABLE_SEND_SMI_IPI_IN_SMM" default is not exit. In this condition, "GetTime" function sometimes would returns an invalid value.
If add and Enabled this token, there is a side effect that system may hang sporadically at 0xAX check point. (NEW Porting Notes in this label)
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.1_1.5M_9.1.35.1006 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.1_5M_9.1.35.1006 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW046
4.6.5.4_VEB_1AQQW045
4.6.5.4_VEB_1AQQW044
4.6.5.4_VEB_1AQQW043
4.6.5.4_VEB_1AQQW042
4.6.5.4_VEB_1AQQW041
4.6.5.4_VEB_1AQQW040
4.6.5.4_VEB_1AQQW039
4.6.5.4_VEB_1AQQW038
4.6.5.4_VEB_1AQQW037
4.6.5.4_VEB_1AQQW036a
4.6.5.4_VEB_1AQQW036
4.6.5.4_VEB_1AQQW035
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2016-08-22
Source Control Label: 4.6.5.4_VEB_1AQQW048
Source Control Location: SS:Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:021
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2179
GOP Driver Version: 5.0.1036
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.1
ME Kit Revision: 9.1.35.1006
ME F/W Binary: ME9.1_1.5M_Production.bin; ME9.1_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h
 Fixed for EIP118202.
Core\CORE_DXE\BDS.c Update for SCT test (EIP104956).
Update rev.125 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\BdsBoard.c | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Core\CORE_DXE\BootOptions.c
 Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Update rev.39 for EIP172950, Core updates for UEFI Variable Technical Advisory implement. EIP210170.
Include\BootOptions.h | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c Fixed for EIP106722.
Support 2014 BIOS Security Disclosures.
Core\EM\Capsule2_0\Capsule2_0Runtime.c Update EIP225308
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\EM\AMITSE\commonoem.c | Update rev66 for EIP201836, Correct WaitForEvent().
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Core\EfiFirmwareVolumeHeader.h | Update rev2.
Library\EfiLib.c | Support 2014 BIOS Security Disclosures.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Include\Protocol\FirmwareVolumeBlock.h | Update rev6.
Core\CORE_DXE\FwVolBlock.c
 Support 2014 BIOS Security Disclosures. Update rev5,6,7.
Core\CORE_DXE\GC.c | Update for SCT test(EIP105534).
Core\CORE_DXE\GenericSio.c | Update rev.83 for EIP172950,Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384. EIP217417
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Include\Protocol\PAhciBus.h Update for AHCI module labeled 24. Update v12 for AhciSrc _027.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Library\PeiLib.c | Support 2014 BIOS Security Disclosures.
Include\Protocol\PIDEBus.h Update for AHCI module labeled 24. Update v31 for AhciSrc _027.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1.Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
NvramSmi_MOD | Core\EM\NvramSmi\NvramSmi.c | Upadte NvramSmi 05 Handle initialized with NULL.
IntelHaswell_MOD | Board\CPU\TxtDxe\AmiTxtInfoHook.c | Correct WaitForEvent()
TCG2_MOD | Board\EM\TCG2\Common\Setup\TPMPwd.c | Correct WaitForEvent()
Chipset_MOD Board\EM\Platform\AcpiPlatform.c
ReferenceCode\Haswell\PowerManagement\Dxe\PowerMgmtInit.c
 Modify for ACPI table.
ReferenceCode\Chipset\SystemAgent\MemoryInit\Pei\MemoryInit.c | Modify InstallEfiMemory ().
Chipset\SB\SATA.ASL | EIP255383
Chipset\SB\SBRun.c | Modify VerifyTime().
Chipset\NB\SystemAgenWrap\UpdateMemoryRecord\UpdateMemoryRecord.c
 Update EIP249553
Chipset\SB\usb\usbsb.c
 Sync with 4.6.3_USB_08.10.35
Chipset\NB\SystemAgentWrap\UpdateMemoryRecord\UpdateMemoryRecord.c Update EIP249553
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.9.0
NB : Reference code ver. 1.9.0
SB : Reference code ver. 1.9.1
Intel Rapid Start Technology :Reference code ver. 1.9.0
Platform : Reference code ver. 1.9.0
Manageability Engine (ME) : Reference code ver. 1.9.0
Intel DPTF : Reference code ver. 1.8.0
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. USB;4.6.3_USB_08.10.35
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
1. EIP283192: [SharkBay DT] SAx0011 Vulnerability
Files changed for EIP fixes:
1. EIP283192: Update 4.6.3_USB_08.10.35
2. usbsb.c : Sync with 4.6.3_USB_08.10.35 (EIP n/a)

Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● CSM Disable
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 1.715 seconds with SSD: Intel SSD 530 without TPM.
The value of FWPostTIme : is 3.288 seconds with HDD without TPM.
Known issues in this label:
01. HDD password prompt screen is distorted from 2nd HDD if system plug more than one.
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
08. Fedora 22/23/24 x64 S4 resume failed.
Remaining Issues:
NONE
Unit Testing:
https://eip.ami.com.tw/eip/projects/display.do?id=12076
Validation Testing:
https://eip.ami.com.tw/eip/issues/display.do?id=283763
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
08. ME capsule update support(EIP #214066):
a. Enable token , "MEFwUpdLcl_SUPPORT" and "MEFWUPDLCL_ON_SHARKBAY_PLATFORM"
b. ME_BIN_FILE = ME image (default value = "$(ROM_IMAGE_DIR)\ME\ME9.1_1.5M_Production.BIN")
c. ME_FW_IMAGE_VERSION = "{x, x, x, x}"
d. FWCAPSULE_IMAGE_SIZE = "$(FLASH_SIZE)+$(FWCAPSULE_MAX_HDR_SIZE)+$(FV_MEFWCAP_SIZE)".
09. Token "ENABLE_SEND_SMI_IPI_IN_SMM" default is not exit. In this condition, "GetTime" function sometimes would returns an invalid value.
If add and Enabled this token, there is a side effect that system may hang sporadically at 0xAX check point. (Porting Notes add in label47)
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.1_1.5M_9.1.35.1006 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.1_5M_9.1.35.1006 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW047
4.6.5.4_VEB_1AQQW046
4.6.5.4_VEB_1AQQW045
4.6.5.4_VEB_1AQQW044
4.6.5.4_VEB_1AQQW043
4.6.5.4_VEB_1AQQW042
4.6.5.4_VEB_1AQQW041
4.6.5.4_VEB_1AQQW040
4.6.5.4_VEB_1AQQW039
4.6.5.4_VEB_1AQQW038
4.6.5.4_VEB_1AQQW037
4.6.5.4_VEB_1AQQW036a
4.6.5.4_VEB_1AQQW036
4.6.5.4_VEB_1AQQW035
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2017-03-02
Source Control Label: 4.6.5.4_VEB_1AQQW049
Source Control Location: SS:Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:021
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2179
GOP Driver Version: 5.0.1036
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.1
ME Kit Revision: 9.1.35.1006
ME F/W Binary: ME9.1_1.5M_Production.bin; ME9.1_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h
 Fixed for EIP118202.
Core\EM\usb\amiusbhc.c
 EIP320994
Core\CORE_DXE\BDS.c Update for SCT test (EIP104956).
Update rev.125 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\BdsBoard.c | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Core\CORE_DXE\BootOptions.c
 Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Update rev.39 for EIP172950, Core updates for UEFI Variable Technical Advisory implement. EIP210170.
Include\BootOptions.h | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c Fixed for EIP106722.
Support 2014 BIOS Security Disclosures.
Core\EM\Capsule2_0\Capsule2_0Runtime.c Update EIP225308
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\EM\AMITSE\commonoem.c | Update rev66 for EIP201836, Correct WaitForEvent().
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Core\EfiFirmwareVolumeHeader.h | Update rev2.
Library\EfiLib.c | Support 2014 BIOS Security Disclosures.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Include\Protocol\FirmwareVolumeBlock.h | Update rev6.
Core\CORE_DXE\FwVolBlock.c
 Support 2014 BIOS Security Disclosures. Update rev5,6,7.
Core\CORE_DXE\GC.c | Update for SCT test(EIP105534).
Core\CORE_DXE\GenericSio.c | Update rev.83 for EIP172950,Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384. EIP217417
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Include\Protocol\PAhciBus.h Update for AHCI module labeled 24. Update v12 for AhciSrc _027.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Library\PeiLib.c | Support 2014 BIOS Security Disclosures.
Include\Protocol\PIDEBus.h Update for AHCI module labeled 24. Update v31 for AhciSrc _027.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1.Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
NvramSmi_MOD | Core\EM\NvramSmi\NvramSmi.c | Upadte NvramSmi 05 Handle initialized with NULL.
IntelHaswell_MOD | Board\CPU\TxtDxe\AmiTxtInfoHook.c | Correct WaitForEvent()
TCG2_MOD | Board\EM\TCG2\Common\Setup\TPMPwd.c | Correct WaitForEvent()
Chipset_MOD Board\EM\Platform\AcpiPlatform.c
ReferenceCode\Haswell\PowerManagement\Dxe\PowerMgmtInit.c
 Modify for ACPI table.
ReferenceCode\Chipset\SystemAgent\MemoryInit\Pei\MemoryInit.c | Modify InstallEfiMemory ().
Chipset\SB\SATA.ASL | EIP255383
Chipset\SB\SBRun.c | Modify VerifyTime().
Chipset\NB\SystemAgenWrap\UpdateMemoryRecord\UpdateMemoryRecord.c
 Update EIP249553
Chipset\SB\usb\usbsb.c
 Sync with 4.6.5.1_USB_08.10.36
Chipset\NB\SystemAgentWrap\UpdateMemoryRecord\UpdateMemoryRecord.c Update EIP249553
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.9.0
NB : Reference code ver. 1.9.0
SB : Reference code ver. 1.9.1
Intel Rapid Start Technology :Reference code ver. 1.9.0
Platform : Reference code ver. 1.9.0
Manageability Engine (ME) : Reference code ver. 1.9.0
Intel DPTF : Reference code ver. 1.8.0
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. USB;4.6.5.1_USB_08.10.36
02. NVMe;4.6.5.5_NVMe_006
03. Intel Nehalem Microcode;4.6.0_INTEL_MICROCODE_87

Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
1. EIP316345: [SA40011] Security Vulnerability
2. EIP316430: [Haswell Series] Modules Update/Function implementation/Bug fixed on 'SharkBay DT' CRB049 project label
3. EIP320994: Fixed Reconnect XHCI controller fail in shell with USB,4.6.5.1_USB_08.10.36 (XHCI Mode: Enabled)

Files changed for EIP fixes:
1. EIP316345: Usb label: 4.6.5.1_USB_08.10.36, NVMe label: 4.6.5.5_NVMe_006, SdioDriver label: 4.6.3_SdioDriver_015 (SDIODriver is not in this SharkBay-DT project)
2. usbsb.c : Sync with 4.6.5.1_USB_08.10.36 (EIP n/a)
3. EIP320994 :amiusbhc.c

Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● CSM Disable
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 1.705 seconds with SSD: Intel SSD 540S without TPM.
The value of FWPostTIme : is 2.347 seconds with HDD: WD5000LPLX(Black) without TPM.
Known issues in this label:
01. HDD password prompt screen is distorted from 2nd HDD if system plug more than one.
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
08. Fedora 22/23/24 x64 S4 resume failed.
Remaining Issues:
NONE
Unit Testing:
https://eip.ami.com.tw/eip/projects/display.do?id=12076
Validation Testing:
https://eip.ami.com.tw/eip/issues/display.do?id=319420
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
08. ME capsule update support(EIP #214066):
a. Enable token , "MEFwUpdLcl_SUPPORT" and "MEFWUPDLCL_ON_SHARKBAY_PLATFORM"
b. ME_BIN_FILE = ME image (default value = "$(ROM_IMAGE_DIR)\ME\ME9.1_1.5M_Production.BIN")
c. ME_FW_IMAGE_VERSION = "{x, x, x, x}"
d. FWCAPSULE_IMAGE_SIZE = "$(FLASH_SIZE)+$(FWCAPSULE_MAX_HDR_SIZE)+$(FV_MEFWCAP_SIZE)".
09. Token "ENABLE_SEND_SMI_IPI_IN_SMM" default is not exit. In this condition, "GetTime" function sometimes would returns an invalid value.
If add and Enabled this token, there is a side effect that system may hang sporadically at 0xAX check point. (Porting Notes add in label47)
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.1_1.5M_9.1.35.1006 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.1_5M_9.1.35.1006 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW048
4.6.5.4_VEB_1AQQW047
4.6.5.4_VEB_1AQQW046
4.6.5.4_VEB_1AQQW045
4.6.5.4_VEB_1AQQW044
4.6.5.4_VEB_1AQQW043
4.6.5.4_VEB_1AQQW042
4.6.5.4_VEB_1AQQW041
4.6.5.4_VEB_1AQQW040
4.6.5.4_VEB_1AQQW039
4.6.5.4_VEB_1AQQW038
4.6.5.4_VEB_1AQQW037
4.6.5.4_VEB_1AQQW036a
4.6.5.4_VEB_1AQQW036
4.6.5.4_VEB_1AQQW035
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2017-08-09
Source Control Label: 4.6.5.4_VEB_1AQQW050
Source Control Location: SS:Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:022
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2179
GOP Driver Version: 5.0.1036
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.1
ME Kit Revision: 9.1.35.1006(1.5MB), kit#110762 / 9.1.41.3024(5MB), kit#121671
ME F/W Binary: ME9.1_1.5M_Production.bin; ME9.1_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Core\EM\usb\amiusbhc.c | EIP320994
Core\CORE_DXE\BDS.c Update for SCT test (EIP104956).
Update rev.125 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\BdsBoard.c | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Core\CORE_DXE\BootOptions.c
 Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Update rev.39 for EIP172950, Core updates for UEFI Variable Technical Advisory implement. EIP210170.
Include\BootOptions.h | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c Fixed for EIP106722.
Support 2014 BIOS Security Disclosures.
Core\EM\Capsule2_0\Capsule2_0Runtime.c Update EIP225308
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\EM\AMITSE\commonoem.c | Update rev66 for EIP201836, Correct WaitForEvent().
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\EM\CSM\CsmHwInfo.c
 Update EIP184371, Filter the DiskInfo protocols while creating HddInfo
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Core\EfiFirmwareVolumeHeader.h | Update rev2.
Library\EfiLib.c | Support 2014 BIOS Security Disclosures.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Include\Protocol\FirmwareVolumeBlock.h | Update rev6.
Core\EM\Runtime\Flash.c
 EIP344536, SA40037-BIOS update failure vulnerability
Core\CORE_DXE\FwVolBlock.c
 Support 2014 BIOS Security Disclosures. Update rev5,6,7.
Core\CORE_DXE\GC.c | Update for SCT test(EIP105534).
Core\CORE_DXE\GenericSio.c | Update rev.83 for EIP172950,Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384. EIP217417
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Include\Protocol\PAhciBus.h Update for AHCI module labeled 24. Update v12 for AhciSrc _027.
Core\EM\PCI\PciBus.c | EIP107491: PciBus can not detect some pcie card.
Library\PeiLib.c | Support 2014 BIOS Security Disclosures.
Include\Protocol\PIDEBus.h Update for AHCI module labeled 24. Update v31 for AhciSrc _027.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1.Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
NvramSmi_MOD | Core\EM\NvramSmi\NvramSmi.c | Upadte NvramSmi 05 Handle initialized with NULL.
IntelHaswell_MOD | Board\CPU\TxtDxe\AmiTxtInfoHook.c | Correct WaitForEvent()
TCG2_MOD | Board\EM\TCG2\Common\Setup\TPMPwd.c | Correct WaitForEvent()
Chipset_MOD Board\EM\Platform\AcpiPlatform.c
ReferenceCode\Haswell\PowerManagement\Dxe\PowerMgmtInit.c
 Modify for ACPI table.
ReferenceCode\Chipset\SystemAgent\MemoryInit\Pei\MemoryInit.c | Modify InstallEfiMemory ().
Chipset\SB\SATA.ASL | EIP255383
Chipset\SB\SBRun.c | Modify VerifyTime().
ReferenceCode\Chipset\SystemAgent\SmbiosMemory\Dxe\SmbiosMemory.c
 Modify for Smbios type19 MemoryArrayPartitionWidth
Chipset\NB\SystemAgenWrap\UpdateMemoryRecord\UpdateMemoryRecord.c
 Update EIP249553
Chipset\SB\usb\usbsb.c | Sync with 4.6.5.1_USB_08.10.36
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.9.0
NB : Reference code ver. 1.9.0
SB : Reference code ver. 1.9.1
Intel Rapid Start Technology :Reference code ver. 1.9.0
Platform : Reference code ver. 1.9.0
Manageability Engine (ME) : Reference code ver. 1.9.0
Intel DPTF : Reference code ver. 1.8.0
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
01. Intel Nehalem Microcode;4.6.0_INTEL_MICROCODE_88
02. Rom Image;4.6.5.3_RomImage_051

Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
1. EIP344536: SA40037 - BIOS update failure vulnerability
2. EIP344598: [Haswell Series] [SHB_DT] Modules Update/Function implementation/Bug fixed on CRB050 project label
3. EIP184371: Filter the DiskInfo protocols while creating HddInfo
Files changed for EIP fixes:
1. EIP344536: Flash.c
2. EIP344598: Microcode module , RomImage module , SmbiosMemory.c for smbios type19.
3. EIP184371: CsmHwInfo.c
4. EIP n/a : CRB.sdl (Clone Token, "ACPI_INT_MODEL" & "BASE_BOARD_INFO" ; Add Token, "DEFAULT_STRING" ; Modify Token Value, "BASE_BOARD_MANUFACTURER" & "BASE_BOARD_PRODUCT_NAME")

Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● CSM Disable
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 1.680 seconds with SSD: Intel SSD 535 240GB without TPM.
The value of FWPostTIme : is 3.772 seconds with HDD: Seagate 320GB without TPM.
Known issues in this label:
01. HDD password prompt screen is distorted from 2nd HDD if system plug more than one.
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
08. Fedora 22/23/24 x64 S4 resume failed.
Remaining Issues:
NONE
Unit Testing:
EIP344598
Validation Testing:
EIP352733
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
08. ME capsule update support(EIP #214066):
a. Enable token , "MEFwUpdLcl_SUPPORT" and "MEFWUPDLCL_ON_SHARKBAY_PLATFORM"
b. ME_BIN_FILE = ME image (default value = "$(ROM_IMAGE_DIR)\ME\ME9.1_1.5M_Production.BIN")
c. ME_FW_IMAGE_VERSION = "{x, x, x, x}"
d. FWCAPSULE_IMAGE_SIZE = "$(FLASH_SIZE)+$(FWCAPSULE_MAX_HDR_SIZE)+$(FV_MEFWCAP_SIZE)".
09. Token "ENABLE_SEND_SMI_IPI_IN_SMM" default is not exit. In this condition, "GetTime" function sometimes would returns an invalid value.
If add and Enabled this token, there is a side effect that system may hang sporadically at 0xAX check point. (Porting Notes add in label47)
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.1_1.5M_9.1.35.1006 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.1_5M_9.1.41.3024 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW049
4.6.5.4_VEB_1AQQW048
4.6.5.4_VEB_1AQQW047
4.6.5.4_VEB_1AQQW046
4.6.5.4_VEB_1AQQW045
4.6.5.4_VEB_1AQQW044
4.6.5.4_VEB_1AQQW043
4.6.5.4_VEB_1AQQW042
4.6.5.4_VEB_1AQQW041
4.6.5.4_VEB_1AQQW040
4.6.5.4_VEB_1AQQW039
4.6.5.4_VEB_1AQQW038
4.6.5.4_VEB_1AQQW037
4.6.5.4_VEB_1AQQW036a
4.6.5.4_VEB_1AQQW036
4.6.5.4_VEB_1AQQW035
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2016 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.


BIOS Information:
AMI BIOS Core: Aptio 4.6.5.4
Release Date: 2017-11-15
Source Control Label: 4.6.5.4_VEB_1AQQW051
Source Control Location: SS:Alaska;$/Alaska/Projects/Intel/Haswell/LynxPoint_SharkBay-DT_Crb_1AQQW;
Platform Information:
Platform Name: Shark Bay
Platform Revision: Flathead Creek FAB2
Northbridge: Haswell
Southbridge: LynxPoint Stepping: Q87 C2
Processor: Haswell, Stepping: C0
CPU ID: 306C3, Microcode Version:022
Memory: 4GB, Frequency: 1333MHz
Video BIOS Version: 2179
GOP Driver Version: 5.0.1036
EC Version: 1.12
Non-Compiled BIN and LIB File(s) in Flavor:
NONE
ME Information:
ME Kit Name: Intel Management Engine Firmware 9.1
ME Kit Revision: 9.1.35.1006(1.5MB), kit#110762 / 9.1.42.3002(5MB), kit#125075
ME F/W Binary: ME9.1_1.5M_Production.bin; ME9.1_5M_Production.bin
GBE LAN F/W Binary: NAHUM6_CLARKSVILLE_DESKTOP_12.bin
Build Parameters | Setting
Number of Flash Components | 2

VSCC Table
ATMEL AT26DF321
Winbond W25Q64BV

Platform File List:
File Name | Description
SharkBayDT.cif | Platform component information file
ReleaseNotes.chm | This file

Private File List:
File Name | Description
BOARD_MOD | Board\ReportFV2.c | Fix BIOS Crisis Recovery halt on F1/3b very long time if LZMA_SUPPORT = 1(EIP#71398)
Board\Flash\SPI\ICHx\SPIFlash.c
 EIP358409:[SAx0039][Flash_17/16/14/11/10/09/08/7] SPI security update
CORE_MOD Core\EM\BoardInfo\AmiBoardInfo.mak 1. Revise for Platform eModule.
2. Add eLink "SB_OSCM_ASL" support.
3. Add eLink "ASL_PCI0_INI" for Thunderbolt support.(eLink definition located in CRB.SDL)
4. Updated for EIP107638
Include\AmiDxeLib.h | Reprogram 'SaveStateMemPoll' functon.
Include\Protocol\AmiKeycode.h | Fixed for EIP118202.
Core\EM\usb\amiusbhc.c | EIP320994
Core\CORE_DXE\BDS.c Update for SCT test (EIP104956).
Update rev.125 for EIP172950, Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\BdsBoard.c | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Core\CORE_DXE\BootOptions.c
 Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Update rev.39 for EIP172950, Core updates for UEFI Variable Technical Advisory implement. EIP210170.
Include\BootOptions.h | Fix Setup menu erroneously shows multiple instances of the same bootable device for EIP139412.
Include\Capsule.h | Fixed for EIP106722.
Core\EM\Capsule2_0\Capsule2_0.c Fixed for EIP106722.
Support 2014 BIOS Security Disclosures.
Core\EM\Capsule2_0\Capsule2_0Runtime.c Update EIP225308
Core\EM\Recovery\CapsuleRecovery.c | Fixed for EIP106722.
Core\EM\AMITSE\commonoem.c | Update rev66 for EIP201836, Correct WaitForEvent().
Core\CORE_DXE\ConSplitter\ConSplit.c Fixed for EIP118202.
Fixed for EIP109384.
Core\CORE_DXE\ConSplitter\ConSplit.h Fixed for EIP118202.
Fixed for EIP109384.
Core\EM\CSM\CsmHwInfo.c | Update EIP184371, Filter the DiskInfo protocols while creating HddInfo
Core\CORE_PEI\DxeIpl.c 1. Fixed that CPU SMM Base doesn't be relocated when system is from S3 resume.
2. Fixed system hang at CKP 0x4F during S3 resume if HT is disabled.
Include\Protocol\EdidOverride.h | Fix building error when opening OEM_EDID_OVERRIDE_PROTOCOL_SUPPORT.
Core\EfiFirmwareVolumeHeader.h | Update rev2.
Library\EfiLib.c | Support 2014 BIOS Security Disclosures.
Core\EM\Recovery\ReFlash\Esrt.c | Fixed for EIP106722.
Core\EM\FileSystem\FileFatHandler.c | Update it for EIP#104620.
Include\Protocol\FirmwareVolumeBlock.h | Update rev6.
Core\EM\Runtime\Flash.c | EIP344536,SA40037-BIOS update failure vulnerability
Core\CORE_DXE\FwVolBlock.c
 Support 2014 BIOS Security Disclosures. Update rev5,6,7.
Core\CORE_DXE\GC.c | Update for SCT test(EIP105534).
Core\CORE_DXE\GenericSio.c | Update rev.83 for EIP172950,Core updates for UEFI Variable Technical Advisory implement.
Core\CORE_DXE\UefiHii\HiiFont.c | Update for SCT test (EIP105534).
Core\CORE_DXE\UefiHii\HiiFontEx.c Update for SCT test (EIP105534).
Update to Rev.14,15 for:
EIP112874: System displays output in wrong colors.
EIP109050: Memory leal in call to GetGlyph function.
EIP110240: Update for Reboot cycling with USB Flash drive (OVERNIGHT) test.
Update for EIP105534 and EIP126176.
Core\CORE_DXE\UefiHii\HiiPrivate.h | Update for EIP126176.
Core\CORE_DXE\ConSplitter\In.c Fixed for EIP118202.
Fixed for EIP109384. EIP217417
Include\Protocol\MpService.h | EFI_MP_PROC_CONTEXT is copyied from Intel CPU RC.
Include\Protocol\PAhciBus.h Update for AHCI module labeled 24. Update v12 for AhciSrc _027.
Core\EM\PCI\PciBus.c EIP107491: PciBus can not detect some pcie card.
EIP369842:[AMISV081][SA50041][SA40041] PCIBUS: DMA Attack
Library\PeiLib.c | Support 2014 BIOS Security Disclosures.
Include\Protocol\PIDEBus.h Update for AHCI module labeled 24. Update v31 for AhciSrc _027.
Core\EM\Recovery\Recovery.mak | Update for EIP124189.
Core\EM\Recovery\ReFlash\ReFlash.c Fixed for EIP106722.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlash.h | Fixed for EIP106722.
Core\EM\Recovery\ReFlash\ReFlash.uni Update for EIP122037.
Update for EIP137328.
Core\EM\Recovery\ReFlash\ReFlashWorker.c | Fixed for EIP106722/EIP122037.
Core\EM\S3\S3Resume.c | Fix RHEL6.4 S3 resume issue.
Include\SMM.h | Make structure EFI_SMM_CPU_SAVE_STATE is the same with SmmBase.h.
Library\Tokens.c Fixed for EIP118202.
Update for PS2CTL module which labeled 4.6.5_PS2CTL_003.
ACPI_MOD Core\EM\ACPI\AcpiCore.c 1. Update for Haswell CPU Refcode.
2. Update for LPT PCH Refcode.
3. Fixed EIP#106575 and EIP#106731 that FPDT table got incorrect data issue.
4. Apply EIP101547 for fix EIP112970: System cannot enter to Windows if TPM is enabled and active with 5M ME firmware.
5. Update for ACPI module labeled 47.
Core\EM\S3\BootScriptExecuter.c
Core\EM\S3\BootScriptPrivate.h
Core\EM\S3\BootScriptSave.c 		Reprogram 'SaveStateMemPoll' functon.
Update for ACPI module labeled 47.
CmosManager_MOD | Core\EM\CmosManager\CmosBoard.c | Update it to the rev19 for EIP92072.
CsmOptOut_MOD | Core\EM\CsmOptOut\CsmOptOut.sd | Remove some items for compatible issue.
SMM_MOD Core\EM\SMM\SmmDispatcher.c 1.Modify SMM InterruptManage function to execute Non-PI handler after PI handler.
2. Set a #if condition: "ENABLE_SEND_SMI_IPI_IN_SMM" to isolate send SMI IPI in SMM for avoid system stay in an unstable state when numerous SMI# are generated.
Core\EM\SMM\SmmInit.c | Move 'DisableSmmCallbacks' event from BDS_CONNECT_DRIVERS_PROTOCOL_GUID to BDS_ALL_DRIVERS_CONNECTED_PROTOCOL_GUID.
Core\EM\SMM\SmmEntry.asm
Core\EM\SMM\Smst.c 		Update for Intel PFAT support.
NvramSmi_MOD | Core\EM\NvramSmi\NvramSmi.c | Upadte NvramSmi 05 Handle initialized with NULL.
IntelHaswell_MOD | Board\CPU\TxtDxe\AmiTxtInfoHook.c | Correct WaitForEvent()
TCG2_MOD | Board\EM\TCG2\Common\Setup\TPMPwd.c | Correct WaitForEvent()
Chipset_MOD Board\EM\Platform\AcpiPlatform.c
ReferenceCode\Haswell\PowerManagement\Dxe\PowerMgmtInit.c
 Modify for ACPI table.
ReferenceCode\Chipset\SystemAgent\MemoryInit\Pei\MemoryInit.c | Modify InstallEfiMemory ().
ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchInit.c
Chipset\SB\SBDxe.c
 EIP357393:[SAx0039] SPI opcode Security Vulnerability Update
Chipset\SB\SATA.ASL | EIP255383
Chipset\SB\SBRun.c | Modify VerifyTime().
ReferenceCode\Chipset\SystemAgent\SmbiosMemory\Dxe\SmbiosMemory.c | Modify for Smbios type19 MemoryArrayPartitionWidth
Chipset\NB\SystemAgenWrap\UpdateMemoryRecord\UpdateMemoryRecord.c
 Update EIP249553
Chipset\SB\usb\usbsb.c | Sync with 4.6.5.1_USB_08.10.36
AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: [AMI Debug Rx]
eModule Reference Name: [AMIDebugRx]
eModule Source Control Label: 4.6.2_AMIDebugRx_2.04.0074
eModule Source Control Location:SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;
Token Setting
Check Point Mode | Value
AMIDEBUG_RX_SUPPORT | On

Notes: "DEBUG_MODE = 1: Support debug message print out by AMI Debug Rx."
AMI Build Tools:
Tools Label: 4.5.5_TOOLS_41 , Dated:2013-03-19
Visual eBios: RSS 5.73.0244, Dated:2013-03-19
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver.7600.16385.1
Reference or 3rd Party code in this Release:
CPU : Reference code ver. 1.9.0
NB : Reference code ver. 1.9.0
SB : Reference code ver. 1.9.1
Intel Rapid Start Technology :Reference code ver. 1.9.0
Platform : Reference code ver. 1.9.0
Manageability Engine (ME) : Reference code ver. 1.9.0
Intel DPTF : Reference code ver. 1.8.0
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
Please refer to the release notes in each modules.
Modules update from last label:
* Required Fixes are in Red
1. RomImage; 4.6.5.3_RomImage_052
Modules added to this label:
NONE
Modules removed from last label:
NONE
New features added in this label:
NONE
General Bug Fixes:
NONE
EIP addressed in this label:
1. EIP357568: [Aptio4][HSW series][SharkBay-DT] Modules Update/Function implementation/Bug fixed on CRB051 project label
2. EIP357393: [SAx0039] SPI opcode Security Vulnerability Update
3. EIP358409: [SAx0039][Flash_17/16/14/11/10/09/08/7] SPI security update
4. EIP369842: [AMISV081][SA50041][SA40041] PCIBUS: DMA Attack
5. EIP374507: Update ME 9.1.42.3002 firmware only Hot Fix for 5M SKU
Files changed for EIP fixes:
1. EIP357393: Chipset\SB\SBDxe.c , ReferenceCode\Chipset\LynxPoint\PchInit\Dxe\PchInit.c
2. EIP358409: Board\Flash\SPI\ICHx\SPIFlash.c
3. EIP369842: Core\EM\PCI\PciBus.c
4. EIP374507: '4.6.5.3_RomImage_052'

Post Time:
- Environment Setup
[Setup Menu]
● Fast boot Enable
● CSM Disable
- Check the Boot time by “regedit” in OS.
The value of FWPostTIme : is 1.854 seconds with SSD: Intel SSD 530 120GB without TPM.
The value of FWPostTIme : is 3.408 seconds with HDD: Seagate 320GB without TPM.
Known issues in this label:
01. HDD password prompt screen is distorted from 2nd HDD if system plug more than one.
Limitations in this label:
01. The label verify on SharkBay-DT Flathead Creek FAB2 ONLY.
02. Haswell CPU RefCode do not support "x64_build = 0".
03. New RefCode doesn't support HSW CPU stepping A0/A1
04. While testing vBIOS 2149 and GOP 5.0.5.1012, there is state that IGFX can't display.
05. D-SUB output might not functional if IGFX driver is installed on LPT B0 Sku board.
06. For Intel Rapid Start Technology support enabling MRC FastBoot from SETUP is required.
07. Fedora Core 16/17/18/19 x64:
a. S3 resume test failed.
b. Set xHCI Mode to disable for install Fedora Core 16.
c. Fedora 17/18 x64 can't install complete with IGD, if use PEG card is OK.
d. Fedora 19 x64 with IGD, S3/S4 fail.
08. Fedora 22/23/24 x64 S4 resume failed.
Remaining Issues:
NONE
Unit Testing:
EIP357568
Validation Testing:
EIP373853
Porting Notes:
01. Enable XHCI Pre-Boot Driver and XHCI Mode in setup for USB3.0 device boot.
02. Change GPIO base address to 0x1C00, GPIO Registes Range to 0x400.Change PM(ACPI) base address to 0x1800.
03. If users compiled error message that "Lost the msvcp100.dll" when PFAT module is exist, please install the MicrosoftVisual C++ 2010 x86/x64 Redistributable.
04. For support Intel Sharkbay-DT CRB (FHC FAB2) eDP, add "CRB\VBT_5.0.1032_FC.BIN "to override "Chipset\NB\GOP\Haswell\vbt.bin".
05. Unique FW_VERSION_GUID. Create New GUID for FW_VERSION_GUID in CRB.SDL, OEM or customers have to confrim this GUID value is same with previous one.
06. Secure Flash module remove key already. OEM team should use thier own key.
07. Modify ELINK ROMHOLE.ffs's parent to "FV_MAIN_OUTSIDE_NESTED" for BQA change logo test. User should add parameter "/L" after AFU command when use AFU tool flash bios from previous version to 1AQQW029 and later.
08. ME capsule update support(EIP #214066):
a. Enable token , "MEFwUpdLcl_SUPPORT" and "MEFWUPDLCL_ON_SHARKBAY_PLATFORM"
b. ME_BIN_FILE = ME image (default value = "$(ROM_IMAGE_DIR)\ME\ME9.1_1.5M_Production.BIN")
c. ME_FW_IMAGE_VERSION = "{x, x, x, x}"
d. FWCAPSULE_IMAGE_SIZE = "$(FLASH_SIZE)+$(FWCAPSULE_MAX_HDR_SIZE)+$(FV_MEFWCAP_SIZE)".
09. Token "ENABLE_SEND_SMI_IPI_IN_SMM" default is not exit. In this condition, "GetTime" function sometimes would returns an invalid value.
If add and Enabled this token, there is a side effect that system may hang sporadically at 0xAX check point. (Porting Notes add in label47)
The explanation of BIOS image:
Rom_8MB_H87.bin: This is ME9.1_1.5M_9.1.35.1006 for Flathead Creek CRB FAB2
Rom0x_Q87.bin: This is ME9.1_5M_9.1.42.3002 for Flathead Creek CRB FAB2
Release History:
4.6.5.4_VEB_1AQQW050
4.6.5.4_VEB_1AQQW049
4.6.5.4_VEB_1AQQW048
4.6.5.4_VEB_1AQQW047
4.6.5.4_VEB_1AQQW046
4.6.5.4_VEB_1AQQW045
4.6.5.4_VEB_1AQQW044
4.6.5.4_VEB_1AQQW043
4.6.5.4_VEB_1AQQW042
4.6.5.4_VEB_1AQQW041
4.6.5.4_VEB_1AQQW040
4.6.5.4_VEB_1AQQW039
4.6.5.4_VEB_1AQQW038
4.6.5.4_VEB_1AQQW037
4.6.5.4_VEB_1AQQW036a
4.6.5.4_VEB_1AQQW036
4.6.5.4_VEB_1AQQW035
4.6.5.4_VEB_1AQQW034
4.6.5.4_VEB_1AQQW033
4.6.5.3_VEB_1AQQW032b
4.6.5.3_VEB_1AQQW032a
4.6.5.3_VEB_1AQQW032
4.6.5.3_VEB_1AQQW031
4.6.5.3_VEB_1AQQW030QARelease
4.6.5.3_VEB_1AQQW029
4.6.5.3_VEB_1AQQW028
4.6.5.3_VEB_1AQQW027
4.6.5.3_VEB_1AQQW026
4.6.5.3_VEB_1AQQW025
4.6.5.3_VEB_1AQQW024
4.6.5.3_VEB_1AQQW023
4.6.5.3_VEB_1AQQW022a
4.6.5.3_VEB_1AQQW022
4.6.5.3_VEB_1AQQW021
4.6.5.3_VEB_1AQQW020
4.6.5.3_VEB_1AQQW019
4.6.5.3_VEB_1AQQW018a
4.6.5.3_VEB_1AQQW018
4.6.5.3_VEB_1AQQW017
4.6.5.3_VEB_1AQQW016
4.6.5.3_VEB_1AQQW015
4.6.5.3_VEB_1AQQW014
4.6.5.3_VEB_1AQQW013
4.6.5.3_VEB_1AQQW012
4.6.5.3_VEB_1AQQW011
4.6.5.3_VEB_1AQQW010
4.6.5.3_VEB_1AQQW009
4.6.5.3_VEB_1AQQW008
4.6.5.3_VEB_1AQQW007
4.6.5.3_VEB_1AQQW006
4.6.5.3_VEB_1AQQW005
4.6.5.3_VEB_1AQQW004
4.6.5.3_VEB_1AQQW003
4.6.5.3_VEB_1AQQW002
4.6.5.3_VEB_1AQQW001
4.6.5.3_VEB_1AQQW000

© American Megatrends Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.
For a list by segment, see By Segment.

  • CRB.mak
  • CRB.sd
  • CRBAcpi.c
  • CRBDxe.c
  • CRBDxe.DXS
  • CRBLib.c
  • CRBLib.h
  • CRBPei.c
  • CRBPei.DXS
  • CRBSec.ASM
  • CRBSetup.c
  • CRBSmi.c
  • CRBSmi.DXS
  • CRBTse.c
Built on 17:00:07 11/15/17


AMIBIOS Function Reference

CRB.mak

Description:
This make file builds Chipset Reference Board SEC,PEI & DXE
components and link them to respective binary
Built on 17:00:07 11/15/17


AMIBIOS Function Reference

CRB.sd

Description:
Chipset Reference Board setup form
Built on 17:00:07 11/15/17


AMIBIOS Function Reference

CRBAcpi.c

Description:
This file contains 2 eLinks for CRB ACPI Enabled/Disabled
event(s).

The following functions are used in the file: CRBAcpi.c.

Function | Description
CRBAcpiDisabled | This routine will be called when ACPI disabled.
CRBAcpiEnabled | This routine will be called when ACPI enabled.

Built on 17:00:07 11/15/17


CRBAcpiDisabled in the CRBAcpi.c

AMIBIOS Function Reference

Function : CRBAcpiDisabled

File: CRBAcpi.c
Description:
This routine will be called when ACPI disabled.
Input:
DispatchHandle  - Handle to the Dispatcher
DispatchContext - SW SMM dispatcher context
Output:
None
Notes:
Porting if needed.
Built on 17:00:07 11/15/17


CRBAcpiEnabled in the CRBAcpi.c

AMIBIOS Function Reference

Function : CRBAcpiEnabled

File: CRBAcpi.c
Description:
This routine will be called when ACPI enabled.
Input:
DispatchHandle  - Handle to the Dispatcher
DispatchContext - SW SMM dispatcher context
Output:
None
Notes:
Porting if needed.
Built on 17:00:07 11/15/17


AMIBIOS Function Reference

CRBDxe.c

Description:
This file contains code for Chipset Reference Board Template
initialization in the DXE stage

The following functions are used in the file: CRBDxe.c.

Function | Description
CRBDXE_Init | This function is the entry point for CRB DXE driver. This function initializes the CRB in DXE phase.

Built on 17:00:07 11/15/17


CRBDXE_Init in the CRBDxe.c

AMIBIOS Function Reference

Function : CRBDXE_Init

File: CRBDxe.c
Description:
This function is the entry point for CRB DXE driver.
This function initializes the CRB in DXE phase.
Input:
ImageHandle - Image handle
SystemTable - Pointer to the system table
Output:
EFI_SUCCESS
Notes:
This routine is called very early, prior to SBDXE and NBDXE.
Built on 17:00:07 11/15/17


AMIBIOS Function Reference

CRBDxe.DXS

Description:
This file is the dependency file for the CRB DXE driver.
Built on 17:00:07 11/15/17


AMIBIOS Function Reference

CRBLib.c

Description:
This file contains Chipset Reference Board related code that
is needed for both PEI & DXE stage.
To avoid code duplication this file is made as a library and
linked both in PEI & DXE CRB FFS.
Notes:
MAKE SURE NO PEI OR DXE SPECIFIC CODE IS NEEDED
Built on 17:00:07 11/15/17


AMIBIOS Function Reference

CRBLib.h

Description:
Custom Reference Board (or Demo Board) header file.
Defines all the CRB specific equates and structures in
this file.
Built on 17:00:07 11/15/17


AMIBIOS Function Reference

CRBPei.c

Description:
This file contains code for Chipset Reference Board
Template initialization in the PEI stage

The following functions are used in the file: CRBPei.c.

Function | Description
CRBPEI_Init | This function is the entry point for CRB PEIM. It initializes the chipset CRB in PEI phase.
InitCK505ClockGen | This function is to initialiae CK505 clock generator.

Built on 17:00:07 11/15/17


CRBPEI_Init in the CRBPei.c

AMIBIOS Function Reference

Function : CRBPEI_Init

File: CRBPei.c
Description:
This function is the entry point for CRB PEIM.
It initializes the chipset CRB in PEI phase.
Input:
FfsHeader   - Pointer to the FFS file header.
PeiServices - Pointer to the PEI services table.
Output:
EFI_SUCCESS
Notes:
This routine is called very early, prior to SBPEI and NBPEI.
Built on 17:00:07 11/15/17


InitCK505ClockGen in the CRBPei.c

AMIBIOS Function Reference

Function : InitCK505ClockGen

File: CRBPei.c
Description:
This function is to initialiae CK505 clock generator.
Input:
IN EFI_PEI_SERVICES             **PeiServices,
IN EFI_PEI_NOTIFY_DESCRIPTOR    *NotifyDescriptor,
IN VOID                         *NullPpi
Output:
EFI_SUCCESS
Notes:

Built on 17:00:07 11/15/17


AMIBIOS Function Reference

CRBPei.DXS

Description:
This file is the dependency file for the CRB PEIM.
Built on 17:00:07 11/15/17


AMIBIOS Function Reference

CRBSec.ASM

Description:
Program any workaround or initialization needed before
enabling Cache as memory in the SEC stage for CRB.

The following functions are used in the file: CRBSec.ASM.

Function | Description
SECCRB_EarlyInit | This routine initializes CRB for PEI preparation

Built on 17:00:07 11/15/17


SECCRB_EarlyInit in the CRBSec.ASM

AMIBIOS Function Reference

Function : SECCRB_EarlyInit

File: CRBSec.ASM
Segment: STARTUP_SEG
Description:
This routine initializes CRB for PEI preparation
Input:
ESP BIST Info
EBP Reset ID (EDX at reset)
Stack not available
Output:
None
Modified:
All, except EBP and ESP
Notes:
NBSEC & SBSEC initialization is done at this point.
Built on 17:00:07 11/15/17


AMIBIOS Function Reference

CRBSetup.c

Description:
Chipset Reference Board Setup Routines

The following functions are used in the file: CRBSetup.c.

Function | Description
InitCRBStrings | Initializes Demo Board Setup String.

Built on 17:00:07 11/15/17


InitCRBStrings in the CRBSetup.c

AMIBIOS Function Reference

Function : InitCRBStrings

File: CRBSetup.c
Description:
Initializes Demo Board Setup String.
Input:
HiiHandle - Handle to HII database
Class     - Indicates the setup class
Output:
None
Built on 17:00:07 11/15/17


AMIBIOS Function Reference

CRBSmi.c

Description:
This file contains code for all CRB SMI events

The following functions are used in the file: CRBSmi.c.

Function | Description
CRBChildDispatcher | This is an entry for CRB SMM Child Dispatcher Handler.
CRBSmiHandler | This is a template CRB SMI Handler for Porting.
CRBSwSmiHandler | This is a template CRB software SMI Handler for Porting.
CRBSxSmiHandler | This is a template CRB Sx SMI Handler for Porting.
GetCRBSmiContext | This is a template CRB SMI GetContext for Porting.
InitializeCRBSmm | Installs CRB SMM Child Dispatcher Handler.
InSmmFunction | Installs CRB SMM Child Dispatcher Handler.

Built on 17:00:07 11/15/17


CRBChildDispatcher in the CRBSmi.c

AMIBIOS Function Reference

Function : CRBChildDispatcher

File: CRBSmi.c
Description:
This is an entry for CRB SMM Child Dispatcher Handler.
Input:
PI 0.91, 1.0
   SmmImageHandle       - SMI Image Hander
   *CommunicationBuffer - Pointer to optional communication
                          buffer
   *SourceSize          - Pointer to size of communication
                          buffer
PI 1.1, 1.2
   DispatchHandle  - SMI dispatcher handle
   *DispatchContext- Pointer to the dispatched context
   CommBuffer      - Pointer to a collection of data in
                     memory that will be conveyed from a
                     non-SMM environment into an SMM
                     environment
   CommBufferSize  - Pointer to the size of the CommBuffer
Output:
EFI_STATUS
   EFI_HANDLER_SUCCESS
Notes:
Here is the control flow of this function:
1. Read SMI source status registers.
2. If source, call handler.
3. Repeat #2 for all sources registered.
Referrals:
GetCRBSmiContext, CRBSmiHandler
Built on 17:00:07 11/15/17


CRBSmiHandler in the CRBSmi.c

AMIBIOS Function Reference

Function : CRBSmiHandler

File: CRBSmi.c
Description:
This is a template CRB SMI Handler for Porting.
Input:
None
Output:
None
Built on 17:00:07 11/15/17


CRBSwSmiHandler in the CRBSmi.c

AMIBIOS Function Reference

Function : CRBSwSmiHandler

File: CRBSmi.c
Description:
This is a template CRB software SMI Handler for Porting.
Input:
PI 0.91, 1.0
   DispatchHandle   - SMI dispatcher handle
   *DispatchContext - Pointer to the dispatch context
PI 1.1, 1.2
   DispatchHandle  - SMI dispatcher handle
   *DispatchContext- Points to an optional S/W SMI context
   CommBuffer      - Points to the optional communication
                     buffer
   CommBufferSize  - Points to the size of the optional
                     communication buffer
Output:
EFI_STATUS if the new SMM PI is applied.
Built on 17:00:07 11/15/17


CRBSxSmiHandler in the CRBSmi.c

AMIBIOS Function Reference

Function : CRBSxSmiHandler

File: CRBSmi.c
Description:
This is a template CRB Sx SMI Handler for Porting.
Input:
PI 0.91, 1.0
   DispatchHandle   - SMI dispatcher handle
   *DispatchContext - Pointer to the dispatch context
PI 1.1, 1.2
   DispatchHandle  - SMI dispatcher handle
   *DispatchContext- Points to an optional Sx SMI context
   CommBuffer      - Points to the optional communication
                     buffer
   CommBufferSize  - Points to the size of the optional
                     communication buffer
Output:
EFI_STATUS if the new SMM PI is applied.
Built on 17:00:07 11/15/17


GetCRBSmiContext in the CRBSmi.c

AMIBIOS Function Reference

Function : GetCRBSmiContext

File: CRBSmi.c
Description:
This is a template CRB SMI GetContext for Porting.
Input:
None
Output:
None
Notes:
Here is the control flow of this function:
1. Check if CRB Smi source.
2. If yes, return TRUE.
3. If not, return FALSE.
Built on 17:00:07 11/15/17


InitializeCRBSmm in the CRBSmi.c

AMIBIOS Function Reference

Function : InitializeCRBSmm

File: CRBSmi.c
Description:
Installs CRB SMM Child Dispatcher Handler.
Input:
ImageHandle - Image handle
*SystemTable - Pointer to the system table
Output:
EFI_STATUS
   EFI_NOT_FOUND - The SMM Base protocol is not found.
   EFI_SUCCESS   - Installs CRB SMM Child Dispatcher Handler
                   successfully.
Built on 17:00:07 11/15/17


InSmmFunction in the CRBSmi.c

AMIBIOS Function Reference

Function : InSmmFunction

File: CRBSmi.c
Description:
Installs CRB SMM Child Dispatcher Handler.
Input:
ImageHandle - Image handle
*SystemTable - Pointer to the system table
Output:
EFI_STATUS
   EFI_NOT_FOUND - The SMM Base protocol is not found.
   EFI_SUCCESS   - Installs CRB SMM Child Dispatcher Handler
                   successfully.
Built on 17:00:07 11/15/17


AMIBIOS Function Reference

CRBSmi.DXS

Description:
This file is the dependency file for the CRB SMI driver.
Built on 17:00:07 11/15/17


AMIBIOS Function Reference

CRBTse.c

The following functions are used in the file: CRBTse.c.

Function | Description
CheckForChangeinSataMode | Gets the sata mode when exiting and resetting from setup and checks whether sata mode is changed. If changed it issues cold reset. Satamode(Value got before entering setup) is Stored in Satamode_Before_Setup.
GetSetupSataMode | Gets the sata mode before entering Setup and Store in Satamode. Global Variable.
IssueColdReset | Issues cold reset.

Built on 17:00:07 11/15/17


CheckForChangeinSataMode in the CRBTse.c

AMIBIOS Function Reference

Function : CheckForChangeinSataMode

File: CRBTse.c
Description:
Gets the sata mode when exiting and resetting from
setup and checks whether sata mode is changed. If changed it
issues cold reset. Satamode(Value got before entering setup) is
Stored in Satamode_Before_Setup.
Input:
VOID
Output:
VOID
Built on 17:00:07 11/15/17


GetSetupSataMode in the CRBTse.c

AMIBIOS Function Reference

Function : GetSetupSataMode

File: CRBTse.c
Description:
Gets the sata mode before entering Setup and Store in Satamode.
Global Variable.
Input:
VOID
Output:
VOID
Built on 17:00:07 11/15/17


IssueColdReset in the CRBTse.c

AMIBIOS Function Reference

Function : IssueColdReset

File: CRBTse.c
Description:
Issues cold reset.
Input:
VOID
Output:
VOID
Built on 17:00:07 11/15/17


Function by Segment

AMIBIOS Function Reference

By Segment

The following is a list of the segments.
For a list in alphabetical order, see In Alphabetical Order.
For a list by file name, see By File Name.

  • STARTUP_SEG
Built on 17:00:07 11/15/17


AMIBIOS Function Reference

STARTUP_SEG

The following functions are used in the segment: STARTUP_SEG.

Function | Description
SECCRB_EarlyInit | This routine initializes CRB for PEI preparation

Built on 17:00:07 11/15/17


Functions in Alphabetical Order

AMIBIOS Function Reference

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.
For a list by segment, see By Segment.

  • C
  • G
  • I
  • S
Built on 17:00:07 11/15/17


Functions in Alphabetical Order

AMIBIOS Function Reference

C

Function | Description
CheckForChangeinSataMode | Gets the sata mode when exiting and resetting from setup and checks whether sata mode is changed. If changed it issues cold reset. Satamode(Value got before entering setup) is Stored in Satamode_Before_Setup.
CRBAcpiDisabled | This routine will be called when ACPI disabled.
CRBAcpiEnabled | This routine will be called when ACPI enabled.
CRBChildDispatcher | This is an entry for CRB SMM Child Dispatcher Handler.
CRBDXE_Init | This function is the entry point for CRB DXE driver. This function initializes the CRB in DXE phase.
CRBPEI_Init | This function is the entry point for CRB PEIM. It initializes the chipset CRB in PEI phase.
CRBSmiHandler | This is a template CRB SMI Handler for Porting.
CRBSwSmiHandler | This is a template CRB software SMI Handler for Porting.
CRBSxSmiHandler | This is a template CRB Sx SMI Handler for Porting.

Built on 17:00:07 11/15/17


Functions in Alphabetical Order

AMIBIOS Function Reference

G

Function | Description
GetCRBSmiContext | This is a template CRB SMI GetContext for Porting.
GetSetupSataMode | Gets the sata mode before entering Setup and Store in Satamode. Global Variable.

Built on 17:00:07 11/15/17


Functions in Alphabetical Order

AMIBIOS Function Reference

I

Function | Description
InitCK505ClockGen | This function is to initialiae CK505 clock generator.
InitCRBStrings | Initializes Demo Board Setup String.
InitializeCRBSmm | Installs CRB SMM Child Dispatcher Handler.
InSmmFunction | Installs CRB SMM Child Dispatcher Handler.
IssueColdReset | Issues cold reset.

Built on 17:00:07 11/15/17


Functions in Alphabetical Order

AMIBIOS Function Reference

S

Function | Description
SECCRB_EarlyInit | This routine initializes CRB for PEI preparation

Built on 17:00:07 11/15/17


AMIBIOS Function Reference

General Information

Built on 17:00:07 11/15/17