summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIru Cai <mytbk920423@gmail.com>2014-04-07 10:35:38 +0800
committerIru Cai <mytbk920423@gmail.com>2014-04-07 10:47:59 +0800
commit019735dd84eeb35e5415ac67e1f9b08cfba3a61b (patch)
treeea2e8a99b098cd2b5950ade7a2b442ad8b82bef3 /CMakeLists.txt
parent1be5668c144977a254af6e87454b3931dbfd1a07 (diff)
downloadfqterm-019735dd84eeb35e5415ac67e1f9b08cfba3a61b.tar.xz
Update CMake files for git.
A transfer from SVN to git.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6098e8e..dd3213f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,8 +18,9 @@ ENDIF(NOT CMAKE_BUILD_TYPE)
set(CMAKE_COLOR_MAKEFILE ON)
-include(${CMAKE_MODULE_PATH}/VersionControl.cmake)
-vcs_get_revision(MCGSVN_WC_REVISION)
+include(GetGitRevisionDescription)
+git_describe(MCGGIT_WC_REVISION)
+message("Git revision: " ${MCGGIT_WC_REVISION})
find_package(Qt4 COMPONENTS QtCore QtGui QtNetwork QtScript QtXml REQUIRED)
IF(APPLE)