summaryrefslogtreecommitdiff
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authoriroul <iroul@iroul-VirtualBox.(none)>2014-04-04 07:35:14 -0700
committeriroul <iroul@iroul-VirtualBox.(none)>2014-04-04 07:35:14 -0700
commitafd34f2893a06a3aecf17e8e83b1df6ed2ae91a2 (patch)
tree851102abc55d91a1b76e63e9e89f9a7733da95b5 /src/common/CMakeLists.txt
parentc4b028ad53f7b362a864de24828d7cc39ff67b0a (diff)
downloadfqterm-afd34f2893a06a3aecf17e8e83b1df6ed2ae91a2.tar.xz
move to my github.
Diffstat (limited to 'src/common/CMakeLists.txt')
-rw-r--r--src/common/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
new file mode 100644
index 0000000..d3f0c09
--- /dev/null
+++ b/src/common/CMakeLists.txt
@@ -0,0 +1,36 @@
+set(fqterm_common_SRCS
+ common.h
+ common.cpp
+ fqterm.h
+ fqterm_trace.h
+ fqterm_trace.cpp
+ fqterm_config.h
+ fqterm_config.cpp
+ fqterm_sound.h
+ fqterm_sound.cpp
+ fqterm_param.h
+ fqterm_param.cpp
+ fqterm_path.h
+ fqterm_path.cpp
+ fqterm_font.h
+ fqterm_font.cpp
+ fqterm_exif_extractor.h
+ fqterm_exif_extractor.cpp
+ fqterm_filedialog.h
+ fqterm_filedialog.cpp
+ fqterm_shortcuthelper.h
+ fqterm_shortcuthelper.cpp
+)
+
+qt4_automoc(${fqterm_common_SRCS})
+
+include_directories(
+ ${QT_INCLUDE_DIR}
+ ${QT_QTCORE_INCLUDE_DIR}
+ ${QT_QTGUI_INCLUDE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+add_library(fqterm_common
+ ${fqterm_common_SRCS}
+)