summaryrefslogtreecommitdiff
path: root/src/fqterm/CMakeLists.txt
diff options
context:
space:
mode:
authoriroul <iroul@iroul-VirtualBox.(none)>2014-04-04 07:35:14 -0700
committeriroul <iroul@iroul-VirtualBox.(none)>2014-04-04 07:35:14 -0700
commitafd34f2893a06a3aecf17e8e83b1df6ed2ae91a2 (patch)
tree851102abc55d91a1b76e63e9e89f9a7733da95b5 /src/fqterm/CMakeLists.txt
parentc4b028ad53f7b362a864de24828d7cc39ff67b0a (diff)
downloadfqterm-afd34f2893a06a3aecf17e8e83b1df6ed2ae91a2.tar.xz
move to my github.
Diffstat (limited to 'src/fqterm/CMakeLists.txt')
-rw-r--r--src/fqterm/CMakeLists.txt83
1 files changed, 83 insertions, 0 deletions
diff --git a/src/fqterm/CMakeLists.txt b/src/fqterm/CMakeLists.txt
new file mode 100644
index 0000000..a93cdaf
--- /dev/null
+++ b/src/fqterm/CMakeLists.txt
@@ -0,0 +1,83 @@
+set(fqterm_SRCS
+ fqterm_app.h
+ fqterm_autoupdate.h
+ fqterm_frame.h
+ fqterm_screen.h
+ fqterm_window.h
+ fqterm_wndmgr.h
+ fqterm_autoupdate.cpp
+ fqterm_app.cpp
+ fqterm_frame.cpp
+ fqterm_screen.cpp
+ fqterm_window.cpp
+ fqterm_wndmgr.cpp
+ fqterm_python.h
+ fqterm_python.cpp
+ fqterm_scriptengine.h
+ fqterm_scriptengine.cpp
+)
+
+
+IF(WIN32)
+ set(global_shortcut_impl_SRCS 3rdparty/qxtglobalshortcut_win.cpp)
+ELSE(WIN32)
+ IF(APPLE)
+ set(global_shortcut_impl_SRCS 3rdparty/qxtglobalshortcut_mac.cpp)
+ ELSE(APPLE)
+ set(global_shortcut_impl_SRCS 3rdparty/qxtglobalshortcut_x11.cpp)
+ ENDIF(APPLE)
+ENDIF(WIN32)
+
+
+
+set(3rdparty_SRCS
+ 3rdparty/dotnetstyle.cpp
+ 3rdparty/dotnetstyle.h
+ 3rdparty/qxtglobalshortcut.cpp
+ 3rdparty/qxtglobalshortcut.h
+ 3rdparty/qxtglobalshortcut_p.h
+ 3rdparty/qxtglobal.h
+ 3rdparty/uaocodec.h
+ 3rdparty/uaocodec.cpp
+ ${global_shortcut_impl_SRCS}
+)
+
+qt4_automoc(${fqterm_SRCS}
+ ${3rdparty_SRCS}
+)
+
+qt4_create_translation(fqterm_qm_file
+ ${fqterm_SRCS}
+ ${CMAKE_SOURCE_DIR}/res/dict/fqterm_zh_CN.ts
+)
+
+include_directories(
+ ${QT_INCLUDE_DIR}
+ ${QT_QTCORE_INCLUDE_DIR}
+ ${QT_QTGUI_INCLUDE_DIR}
+ ${QT_QTNETWORK_INCLUDE_DIR}
+ ${QT_QTSCRIPT_INCLUDE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/../common
+ ${CMAKE_CURRENT_SOURCE_DIR}/../protocol
+ ${CMAKE_CURRENT_SOURCE_DIR}/../terminal
+ ${CMAKE_CURRENT_SOURCE_DIR}/../utilities
+ ${CMAKE_CURRENT_SOURCE_DIR}/../unite
+ ${CMAKE_CURRENT_SOURCE_DIR}/../ui
+ ${CMAKE_CURRENT_SOURCE_DIR}/3rdparty
+ ${CMAKE_CURRENT_BINARY_DIR}/../ui
+ ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+add_library(fqterm_main
+ ${fqterm_SRCS}
+ ${3rdparty_SRCS}
+)
+
+add_dependencies(fqterm_main
+ fqterm_common
+ fqterm_terminal
+ fqterm_protocol
+ fqterm_ui
+ fqterm_utilities
+ fqterm_unite
+)