summaryrefslogtreecommitdiff
path: root/src/protocol/CMakeLists.txt
diff options
context:
space:
mode:
authorIru Cai <mytbk920423@gmail.com>2016-10-26 14:17:15 +0800
committerIru Cai <mytbk920423@gmail.com>2016-10-28 10:40:16 +0800
commite2247862eab2782e61af505b1a5656831ec6a5f0 (patch)
treee2820e9a1b69b970a010486d39437ac718937173 /src/protocol/CMakeLists.txt
parentd11e98917c2f5800aa52883a56ee10e82288b99e (diff)
downloadfqterm-e2247862eab2782e61af505b1a5656831ec6a5f0.tar.xz
Move ``find_package(OpenSSL)`` to protocol/CMakeLists.txt
Files in ``protocol`` directory need ${OPENSSL_INCLUDE_DIR}, but this include is not done when building in this directory if the find_package statement is in ${SRC_ROOT}/CMakeLists.txt.*.
Diffstat (limited to 'src/protocol/CMakeLists.txt')
-rw-r--r--src/protocol/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/protocol/CMakeLists.txt b/src/protocol/CMakeLists.txt
index c6cf81d..cd7d2f4 100644
--- a/src/protocol/CMakeLists.txt
+++ b/src/protocol/CMakeLists.txt
@@ -1,3 +1,4 @@
+find_package(OpenSSL REQUIRED)
set(CMAKE_AUTOMOC ON)
set(export_SRCS