summaryrefslogtreecommitdiff
path: root/src/ui/CMakeLists.txt
diff options
context:
space:
mode:
authorIru Cai <mytbk920423@gmail.com>2016-04-03 00:29:10 +0800
committerIru Cai <mytbk920423@gmail.com>2016-04-03 10:16:53 +0800
commit3a2cb75c85b8f98ebb0262ec3d5b590dcb9d79a1 (patch)
tree4d9ffee201e903f9ea2137327565d38395e4fd70 /src/ui/CMakeLists.txt
parentb91ee982b8ce1e08aad128a65312501ef5dd8ecd (diff)
downloadfqterm-3a2cb75c85b8f98ebb0262ec3d5b590dcb9d79a1.tar.xz
move imageviewer sources to ui/imageviewer
Diffstat (limited to 'src/ui/CMakeLists.txt')
-rw-r--r--src/ui/CMakeLists.txt16
1 files changed, 1 insertions, 15 deletions
diff --git a/src/ui/CMakeLists.txt b/src/ui/CMakeLists.txt
index e47ee73..f522b03 100644
--- a/src/ui/CMakeLists.txt
+++ b/src/ui/CMakeLists.txt
@@ -1,18 +1,8 @@
set(CMAKE_AUTOMOC ON)
-if(IMAGE_USE_PICFLOW)
- set(IMGVIEW_SRCS
- imageviewer.h
- imageviewer.cpp)
-else(IMAGE_USE_PICFLOW)
- set(IMGVIEW_SRCS
- imageviewer_origin.cpp
- imageviewer_origin.h)
-endif(IMAGE_USE_PICFLOW)
+add_subdirectory(imageviewer)
set(fqterm_ui_SRCS
- fqtermimage.cpp
- ${IMGVIEW_SRCS}
aboutdialog.h
addrdialog.h
articledialog.h
@@ -39,8 +29,6 @@ set(fqterm_ui_SRCS
osdmessage.cpp
overlayWidget.h
overlayWidget.cpp
- pictureflow.h
- pictureflow.cpp
popupMessage.h
popupMessage.cpp
popwidget.h
@@ -55,8 +43,6 @@ set(fqterm_ui_SRCS
shortcutdialog.cpp
statusBar.h
statusBar.cpp
- fqterm_canvas.h
- fqterm_canvas.cpp
sitemanager.h
sitemanager.cpp
iplookup.h