summaryrefslogtreecommitdiff
path: root/src/ui/CMakeLists.txt
diff options
context:
space:
mode:
authorIru Cai <mytbk920423@gmail.com>2015-09-24 22:52:54 +0800
committerIru Cai <mytbk920423@gmail.com>2015-10-02 16:57:55 +0800
commitbd8a86f2ab05998e7ac95b2e3d6a2160ac1fa534 (patch)
treeab5e59e608ca87f08f1fd7b4cf544f166a2c7a54 /src/ui/CMakeLists.txt
parent30a6a3cecf34d904294cff9c9bb4261e57ee4c91 (diff)
downloadfqterm-bd8a86f2ab05998e7ac95b2e3d6a2160ac1fa534.tar.xz
split source code for imageviewer and imageviewer_origin
Diffstat (limited to 'src/ui/CMakeLists.txt')
-rw-r--r--src/ui/CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/ui/CMakeLists.txt b/src/ui/CMakeLists.txt
index bd1a373..8fc7b0b 100644
--- a/src/ui/CMakeLists.txt
+++ b/src/ui/CMakeLists.txt
@@ -1,4 +1,16 @@
+if(IMAGE_USE_PICFLOW)
+ set(IMGVIEW_SRCS
+ imageviewer.h
+ imageviewer.cpp)
+else(IMAGE_USE_PICFLOW)
+ set(IMGVIEW_SRCS
+ imageviewer_origin.cpp
+ imageviewer_origin.h)
+endif(IMAGE_USE_PICFLOW)
+
set(fqterm_ui_SRCS
+ fqtermimage.cpp
+ ${IMGVIEW_SRCS}
aboutdialog.h
addrdialog.h
articledialog.h
@@ -37,8 +49,6 @@ set(fqterm_ui_SRCS
fqterm_time_label.cpp
fqterm_tool_button.h
fqterm_tool_button.cpp
- imageviewer.h
- imageviewer.cpp
shortcutdialog.h
shortcutdialog.cpp
statusBar.h