summaryrefslogtreecommitdiff
path: root/ext/fputils/Makefile.am
diff options
context:
space:
mode:
authorAndreas Sandberg <andreas@sandberg.pp.se>2013-09-30 09:40:26 +0200
committerAndreas Sandberg <andreas@sandberg.pp.se>2013-09-30 09:40:26 +0200
commitd3937f3b373ee9b1af09176d8a7d86eb6fcf790f (patch)
treef12ad785822c855522a762d93f3212c2948da696 /ext/fputils/Makefile.am
parent3af2d8eab0e5b1ba4e936291b01895cc82fb124e (diff)
downloadgem5-d3937f3b373ee9b1af09176d8a7d86eb6fcf790f.tar.xz
ext: Include libfputils
This changeset includes libfputils from revision bbf0d61d75. This library can be used to convert to and from 80-bit floats and query the type of an 80-bit float, which is needed to support the x87 FPU.
Diffstat (limited to 'ext/fputils/Makefile.am')
-rw-r--r--ext/fputils/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/ext/fputils/Makefile.am b/ext/fputils/Makefile.am
new file mode 100644
index 000000000..d635d0e36
--- /dev/null
+++ b/ext/fputils/Makefile.am
@@ -0,0 +1,19 @@
+ACLOCAL_AMFLAGS=-I m4
+
+SUBDIRS=. tests
+
+MOSTLYCLEANFILES=
+
+lib_LTLIBRARIES = libfputils.la
+
+include_HEADERS = include/fputils/fp80.h
+
+libfputils_la_SOURCES = \
+ include/fputils/fp80.h \
+ fpbits.h \
+ fp80.c
+
+
+include $(top_srcdir)/doxygen.am
+
+MOSTLYCLEANFILES += $(DX_CLEANFILES)