summaryrefslogtreecommitdiff
path: root/ext/fputils/Makefile.am
diff options
context:
space:
mode:
authorAndreas Sandberg <Andreas.Sandberg@ARM.com>2014-10-16 05:49:58 -0400
committerAndreas Sandberg <Andreas.Sandberg@ARM.com>2014-10-16 05:49:58 -0400
commite6ad39adac7e77e36a294f63da47ad79ca446e93 (patch)
treef3d182a99cb9febbce10d634673a2bda18dae8a7 /ext/fputils/Makefile.am
parent2d2006ddb3df926d79d0d744af81e8260f5c466c (diff)
downloadgem5-e6ad39adac7e77e36a294f63da47ad79ca446e93.tar.xz
ext: Update fputils to rev 6a47fd8358
This patch updates fputils to the latest revision (6a47fd8358) from the upstream repository (github.com/andysan/fputils). Most notably, this includes changes that export a limited set of 64-bit float manipulation and avoids a warning about unused 64-bit floats in clang.
Diffstat (limited to 'ext/fputils/Makefile.am')
-rw-r--r--ext/fputils/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/ext/fputils/Makefile.am b/ext/fputils/Makefile.am
index d635d0e36..c8aaac410 100644
--- a/ext/fputils/Makefile.am
+++ b/ext/fputils/Makefile.am
@@ -6,11 +6,17 @@ MOSTLYCLEANFILES=
lib_LTLIBRARIES = libfputils.la
-include_HEADERS = include/fputils/fp80.h
+include_HEADERS = \
+ include/fputils/fp80.h \
+ include/fputils/fp64.h \
+ include/fputils/fptypes.h
libfputils_la_SOURCES = \
include/fputils/fp80.h \
+ include/fputils/fp64.h \
+ include/fputils/fptypes.h \
fpbits.h \
+ fp64.c \
fp80.c