summaryrefslogtreecommitdiff
path: root/ext/fputils/configure.in
diff options
context:
space:
mode:
authorAndreas Sandberg <andreas@sandberg.pp.se>2013-09-30 09:40:26 +0200
committerAndreas Sandberg <andreas@sandberg.pp.se>2013-09-30 09:40:26 +0200
commitd3937f3b373ee9b1af09176d8a7d86eb6fcf790f (patch)
treef12ad785822c855522a762d93f3212c2948da696 /ext/fputils/configure.in
parent3af2d8eab0e5b1ba4e936291b01895cc82fb124e (diff)
downloadgem5-d3937f3b373ee9b1af09176d8a7d86eb6fcf790f.tar.xz
ext: Include libfputils
This changeset includes libfputils from revision bbf0d61d75. This library can be used to convert to and from 80-bit floats and query the type of an 80-bit float, which is needed to support the x87 FPU.
Diffstat (limited to 'ext/fputils/configure.in')
-rw-r--r--ext/fputils/configure.in32
1 files changed, 32 insertions, 0 deletions
diff --git a/ext/fputils/configure.in b/ext/fputils/configure.in
new file mode 100644
index 000000000..59a21c18e
--- /dev/null
+++ b/ext/fputils/configure.in
@@ -0,0 +1,32 @@
+AC_INIT(libfputils, 1.0, andreas@sandberg.pp.se)
+
+AC_CONFIG_MACRO_DIR([m4])
+
+AM_INIT_AUTOMAKE([foreign -Wall -Werror])
+
+DX_PDF_FEATURE(OFF)
+DX_PS_FEATURE(OFF)
+DX_MAN_FEATURE(OFF)
+DX_INIT_DOXYGEN([libfputils])
+
+AC_REQUIRE_AUX_FILE([tap-driver.sh])
+
+AC_PROG_CC
+AM_PROG_CC_C_O
+AC_PROG_LIBTOOL
+AC_PROG_AWK
+
+AM_CFLAGS="-Wall -Werror"
+AM_CPPFLAGS="-I\$(abs_top_srcdir)/include"
+
+AC_SUBST(AM_CFLAGS)
+AC_SUBST(AM_CPPFLAGS)
+
+AC_CONFIG_HEADERS([config.h])
+
+AC_CONFIG_FILES([ \
+ Doxyfile \
+ Makefile \
+ tests/Makefile \
+])
+AC_OUTPUT