summaryrefslogtreecommitdiff
path: root/ext/fputils/tests/Makefile.am
diff options
context:
space:
mode:
authorAndreas Sandberg <andreas@sandberg.pp.se>2013-09-30 09:40:26 +0200
committerAndreas Sandberg <andreas@sandberg.pp.se>2013-09-30 09:40:26 +0200
commitd3937f3b373ee9b1af09176d8a7d86eb6fcf790f (patch)
treef12ad785822c855522a762d93f3212c2948da696 /ext/fputils/tests/Makefile.am
parent3af2d8eab0e5b1ba4e936291b01895cc82fb124e (diff)
downloadgem5-d3937f3b373ee9b1af09176d8a7d86eb6fcf790f.tar.xz
ext: Include libfputils
This changeset includes libfputils from revision bbf0d61d75. This library can be used to convert to and from 80-bit floats and query the type of an 80-bit float, which is needed to support the x87 FPU.
Diffstat (limited to 'ext/fputils/tests/Makefile.am')
-rw-r--r--ext/fputils/tests/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/ext/fputils/tests/Makefile.am b/ext/fputils/tests/Makefile.am
new file mode 100644
index 000000000..6faffead2
--- /dev/null
+++ b/ext/fputils/tests/Makefile.am
@@ -0,0 +1,13 @@
+
+TEST_LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+ $(top_srcdir)/tap-driver.sh
+
+LIBS=-lm $(top_builddir)/.libs/libfputils.la libtest.a
+
+FP80_TESTS=fp80_cvtd fp80_cvfd fp80_cvtf
+TESTS=$(FP80_TESTS)
+
+check_LIBRARIES=libtest.a
+check_PROGRAMS=$(FP80_TESTS)
+
+libtest_a_SOURCES=test_helper.c test_helper.h