summaryrefslogtreecommitdiff
path: root/ext/ply/setup.py
diff options
context:
space:
mode:
authorNathan Binkert <nate@binkert.org>2009-08-16 13:39:58 -0700
committerNathan Binkert <nate@binkert.org>2009-08-16 13:39:58 -0700
commite1270f81bdc81f5a575b34c2d2c294bdde3e6f4f (patch)
treeb54af3469a338609faf04e67603c5264e79d59a5 /ext/ply/setup.py
parentbcaf93d182f43bf72d52104bb909324945904120 (diff)
downloadgem5-e1270f81bdc81f5a575b34c2d2c294bdde3e6f4f.tar.xz
ply: update PLY to version 3.2
Diffstat (limited to 'ext/ply/setup.py')
-rw-r--r--ext/ply/setup.py25
1 files changed, 12 insertions, 13 deletions
diff --git a/ext/ply/setup.py b/ext/ply/setup.py
index f743ac78c..606b29cde 100644
--- a/ext/ply/setup.py
+++ b/ext/ply/setup.py
@@ -1,23 +1,22 @@
-from distutils.core import setup
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
setup(name = "ply",
description="Python Lex & Yacc",
long_description = """
-PLY is yet another implementation of lex and yacc for Python. Although several other
-parsing tools are available for Python, there are several reasons why you might
-want to take a look at PLY:
+PLY is yet another implementation of lex and yacc for Python. Some notable
+features include the fact that its implemented entirely in Python and it
+uses LALR(1) parsing which is efficient and well suited for larger grammars.
-It's implemented entirely in Python.
+PLY provides most of the standard lex/yacc features including support for empty
+productions, precedence rules, error recovery, and support for ambiguous grammars.
-It uses LR-parsing which is reasonably efficient and well suited for larger grammars.
-
-PLY provides most of the standard lex/yacc features including support for empty
-productions, precedence rules, error recovery, and support for ambiguous grammars.
-
-PLY is extremely easy to use and provides very extensive error checking.
+PLY is extremely easy to use and provides very extensive error checking.
""",
- license="""Lesser GPL (LGPL)""",
- version = "2.3",
+ license="""BSD""",
+ version = "3.2",
author = "David Beazley",
author_email = "dave@dabeaz.com",
maintainer = "David Beazley",