summaryrefslogtreecommitdiff
path: root/ext/dsent/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ext/dsent/CMakeLists.txt')
-rw-r--r--ext/dsent/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/ext/dsent/CMakeLists.txt b/ext/dsent/CMakeLists.txt
new file mode 100644
index 000000000..555606c86
--- /dev/null
+++ b/ext/dsent/CMakeLists.txt
@@ -0,0 +1,46 @@
+# Copyright (c) 2014 Mark D. Hill and David A. Wood
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met: redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer;
+# redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the distribution;
+# neither the name of the copyright holders nor the names of its
+# contributors may be used to endorse or promote products derived from
+# this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cmake_minimum_required (VERSION 2.6)
+
+project (DSENT)
+# find out all the file that need to be compiled
+file(GLOB_RECURSE SRCS "*.h" "*.cc")
+
+# add the library
+add_library(dsent MODULE ${SRCS})
+
+SET(PYTHON_CONFIG "python-config")
+
+# add the binary tree to the search path for include files
+include_directories("${CMAKE_SOURCE_DIR}" "`${PYTHON_CONFIG} --includes`")
+EXEC_PROGRAM(${PYTHON_CONFIG} ARGS --cflags OUTPUT_VARIABLE PYTHON_CFLAGS)
+EXEC_PROGRAM(${PYTHON_CONFIG} ARGS --ldflags OUTPUT_VARIABLE PYTHON_LFLAGS)
+
+set_target_properties(dsent PROPERTIES
+ PREFIX ""
+ COMPILE_FLAGS "${PYTHON_CFLAGS} -std=c++11"
+ LINK_FLAGS "${PYTHON_LFLAGS}")