summaryrefslogtreecommitdiff
path: root/ext/fputils/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'ext/fputils/configure.in')
-rw-r--r--ext/fputils/configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/ext/fputils/configure.in b/ext/fputils/configure.in
index 59a21c18e..bb2291b6f 100644
--- a/ext/fputils/configure.in
+++ b/ext/fputils/configure.in
@@ -12,10 +12,14 @@ DX_INIT_DOXYGEN([libfputils])
AC_REQUIRE_AUX_FILE([tap-driver.sh])
AC_PROG_CC
-AM_PROG_CC_C_O
+AC_PROG_CC_C99
AC_PROG_LIBTOOL
AC_PROG_AWK
+if test "x$ac_cv_prog_cc_c99" = "xno"; then
+ AC_MSG_ERROR([Could not enable C99 support in compiler.])
+fi
+
AM_CFLAGS="-Wall -Werror"
AM_CPPFLAGS="-I\$(abs_top_srcdir)/include"