summaryrefslogtreecommitdiff
path: root/platform/android/build.gradle
diff options
context:
space:
mode:
authorfredrossperry <fredrossperry@gmail.com>2015-08-21 13:27:08 -0700
committerRobin Watts <robin.watts@artifex.com>2015-09-29 15:41:28 +0100
commitc15f8ca38f526930bd4da7fe610b04cd8fa93bca (patch)
tree5901b434d4ffc29781e5810f26657aa7be79e403 /platform/android/build.gradle
parentfb7206c262a5f9ff0e39e89946846771479ba3ec (diff)
downloadmupdf-c15f8ca38f526930bd4da7fe610b04cd8fa93bca.tar.xz
Support for proofing
- use core.fileFormat to decide whether a proof file is being viewed, - don't show the proofing button except for PDF files. - in a proofing activity, show the page that was being viewed when the proof was requested. - Add extra two arguments to fz_write_gproof_file in the Android build.
Diffstat (limited to 'platform/android/build.gradle')
-rw-r--r--platform/android/build.gradle2
1 files changed, 1 insertions, 1 deletions
diff --git a/platform/android/build.gradle b/platform/android/build.gradle
index 85e0d1dd..2feb577f 100644
--- a/platform/android/build.gradle
+++ b/platform/android/build.gradle
@@ -68,7 +68,7 @@ if (Os.isFamily(Os.FAMILY_WINDOWS)) {
/* This task builds the native part */
task buildNative(type: Exec,description: 'Compile JNI source via NDK') {
println('executing buildNative')
- commandLine ndkBuildPath, '-C', file('.').absolutePath
+ commandLine ndkBuildPath, '-C', file('.').absolutePath, ' SUPPORT_GPROOF=1'
//'NDK_PROJECT_PATH=build','APP_BUILD_SCRIPT=src/main/jni/Android.mk'//force using appropriate Makefile
}